Pastel.Evolution Namespace

[image]

Pastel Evolution SDK
Pastel.Evolution Namespace
Send Feedback

Classes

 | Class | Description
Public class | AccountBase | Provides basic account functionality.
Public class | Address | Represents an address record used by various modules.
Public class | Agent | Represents an agent.
Public class | AgentGroup | Represents an group.
Public class | AgingTerm | Represents customer and supplier aging terms.
Public class | AllocationCollection |
Public class | AllocationEntry |
Public class | Area | Represents a geographical area to which accounts can be linked.
Public class | Bank | Represents a bank record.
Public class | Branch | Represents a bank record.
Public class | BranchedRecordBase |
Public class | BusinessClass | Represents a business classification which can be assigned to accounts.
Public class | BusinessType | Represents a business/industry type which can be assigned to accounts.
Public class | CashbookBatch |
Public class | CashbookBatchDetail |
Public class | CashbookBatchDetailCollection | Represents a collection of cashbook batch detail items, typically owned by a given inventory document record.
Public class | CashbookBatchDetailCollection..::..CashbookBatchDetailCollectionChangedEventArgs |
Public class | CashbookBatchSplitCollection | Represents a collection of cashbook batch detail items, typically owned by a given inventory document record.
Public class | CashbookBatchSplitCollection..::..CashbookBatchDetailCollectionChangedEventArgs |
Public class | ComHelper | Provides various functions for overcoming the limitations of accessing the API via COM. This class gets extended as required.
Public class | Competitor | Represents a Contact Management competitor.
Public class | CompletedContractPostingMethodGLContext |
Public class | Contract | Represents a Contact Management contract.
Public class | CostAllocation | Describes a transaction split allocation used when splitting a transaction's contra entry.
Public class | CostAllocationCollection |
Public class | Country | Represents a country record.
Public class | CreditNote | Represents an Evolution sales credit note.
Public class | Currency | Represents a currency record.
Public class | Customer | Represents a customer account.
Public class | CustomerGroup | Represents a customer group.
Public class | CustomerTransaction | Represents a customer transaction.
Public class | DatabaseContext |
Public class | Defaults | Contains various global static methods and properties related to the basic functionality of the SDK.
Public class | DeliveryAddress |
Public class | DeliveryAddressCode |
Public class | DeliveryAddressCollection | Represents a collection of warehouse context records.
Public class | DeliveryMethod | Represents an order delivery method.
Public class | Department | Represents a business department which can be assigned to accounts.
Public class | Designation | Represents a designation which can be assigned to persons.
Public class | Document | Represents a contact management document.
Public class | DocumentCategory | Represents a contact management document category.
Public class | DrCrAccount | A debtor and creditor account base class.
Public class | DrCrTransaction | A debtor and creditor transaction base class.
Public class | EscalationGroup | Represents a Contact Management escalation group.
Public class | EvolutionDatabaseException |
Public class | EvolutionException | A generic SDK exception class from which other SDK exception types inherit.
Public class | EvolutionNullReferenceException |
Public class | EvolutionVersion |
Public class | ExchangeRate | Represents a hist record.
Public class | ExchangeRateCollection | Represents a collection of warehouse context records.
Public class | FieldCollection |
Public class | FieldCollectionManager |
Public class | GLAccount | Represents a General Ledger account.
Public class | GLBatch | Facilitates batch processing of GL transactions. Mainly used internally and not to be confused with journal batches.
Public class | GLBatch..::..BatchCollectionChangedEventArgs |
Public class | GLTransaction | Represents a general ledger transaction.
Public class | Incident | Represents an Evolution Contact Management incident.
Public class | IncidentCategory | Represents an incident category.
Public class | IncidentLogEntry | Represents an incident log entry.
Public class | IncidentLogNotification | Represents an incident notification. These appear in My Desktop\Notifications.
Public class | IncidentType | Represents an incident type.
Public class | InventoryBin | Represents an inventory bin.
Public class | InventoryGroup | Represents an inventory group.
Public class | InventoryItem | Respresents an inventory item, typically products sold or services rendered.
Public class | InventorySegmentCollection |
Public class | InventorySegmentGroup |
Public class | InventorySegmentType |
Public class | InventorySegmentValue |
Public class | InventoryTransaction | Represents an inventory transaction.
Public class | JobCard | Represents an Evolution job card.
Public class | JobDetail | Represents a job transaction.
Public class | JobDetailCollection |
Public class | JobDetailCollection..::..JobDetailCollectionChangedEventArgs |
Public class | JobPostingMethodGLContext |
Public class | JobPostingMethodGLContextCollection |
Public class | JobTransactionCode | Represents a job costing transaction code.
Public class | JournalBatch |
Public class | JournalBatchDetail |
Public class | JournalBatchDetailCollection | Represents a collection of batch detail items, typically owned by a given inventory document record.
Public class | JournalBatchDetailCollection..::..JournalBatchDetailCollectionChangedEventArgs |
Public class | Lot | Represents a distinct inventory lot.
Public class | LotContext | Represents a distinct inventory lot.
Public class | LotContext..::..LotContextCollection |
Public class | LotStatus | Represents a lot status indicator.
Public class | NatureOfTransaction | Represents an EU Nature of Transaction code.
Public class | Opportunity | Represents a Contact Management sales opportunity.
Public class | OpportunityStage | Represents a Contact Management sales opportunity stage.
Public class | OpportunityState | Represents a Contact Management opportunity status.
Public class | OrderBase | Includes functionality that is common to all inventory documents. Must be inherited.
Public class | OrderDetail | Represents an inventory document detail record.
Public class | OrderDetailCollection | Represents a collection of order detail items, typically owned by a given inventory document record.
Public class | OrderDetailCollection..::..OrderDetailCollectionChangedEventArgs |
Public class | OrderStatus | Represents a user-definable inventory document status.
Public class | PackCode | Represents an inventory item pack code.
Public class | PercentageOfCompletedContractPostingMethodGLContext |
Public class | Person | Represents a person record.
Public class | PostDatedCheque | Represents a post dated transaction.
Public class | PriceList | Represents an inventory price list.
Public class | PrintGroup | Represents a print group, which is a collection of inventory documents enabling batch printing.
Public class | Priority | Represents an incident priority.
Public class | Project | Represents a project.
Public class | Prospect | Represents a Contact Management prospective customer.
Public class | PurchaseOrder | Representation a Purchase Order document.
Public class | PurchasesDocumentBase |
Public class | RecordBase | Embodies a common Evolution record, such as an account.
Public class | ReturnToSupplier | Represents a return to supplier document.
Public class | SalesDocumentBase |
Public class | SalesOrder | An object representation of an Evolution Sales Order.
Public class | SalesOrderQuotation |
Public class | SalesRepresentative | Represents an Evolution sales representative.
Public class | SellingPrice | Represents a collection of inventory selling prices.
Public class | SellingPriceCollection | Represents an inventory selling price collection.
Public class | Serialiser |
Public class | SerialNumber | Represents a distinct serial number.
Public class | SerialNumberCollection | Represents a collection of serial numbers, typically linked to a transaction or inventory document detail record.
Public class | SerialNumberTransaction | Summary description for Transaction.
Public class | SerialNumberTransaction..::..MovementParameters | Represents a set of parameters used by a serial number collection when relocating serial numbers.
Public class | SettlementTerms | Represents settlement terms.
Public class | SplitAllocation | Describes a transaction split allocation used when splitting a transaction's contra entry.
Public class | SplitAllocationCollection |
Public class | SplitAllocationCollection..::..OrderDetailCollectionChangedEventArgs |
Public class | Supplier | Represents a supplier account.
Public class | SupplierGroup | Represents a supplier group.
Public class | SupplierTransaction | Represents a supplier transaction.
Public class | TaxRate | Represents a tax rate.
Public class | TransactionBase | Embodies a common Evolution transaction.
Public class | TransactionBase..::..AllocationEntry | Obsolete.
Public class | TransactionBase..::..GLPostingEventArgs |
Public class | TransactionBase..::..SplitAllocation | Obsolete.
Public class | TransactionCode | Represents an Evolution transaction code. Transaction codes dictate the nature (debit/credit) of a transaction as well as the GL accounts to post to.
Public class | TransactionCodeBase | Embodies common Evolution transaction code functionality.
Public class | TransactionTypePostingMethodGLContextBase |
Public class | TransactionTypePostingMethodGLContextCollection |
Public class | Unit | Represents an inventory unit.
Public class | UnitCategory | Represents an inventory group.
Public class | UnitConversion |
Public class | UnitConversionCollection | Represents a collection of warehouse context records.
Public class | Utils |
Public class | Utils..::..LimitedQueue |
Public class | Warehouse | Represents an inventory warehouse.
Public class | WarehouseContext | Represents an inventory item's context within a give warehouse.
Public class | WarehouseContextCollection | Represents a collection of warehouse context records.
Public class | WarehouseTransfer | Represents a warehouse transfer transaction.
Public class | Worker | Represents a Worker.

Interfaces

 | Interface | Description
Public interface | IBranched |

Delegates

 | Delegate | Description
Public delegate | CashbookBatchDetailCollection..::..CashbookBatchDetailChangedEventHandler |
Public delegate | CashbookBatchSplitCollection..::..CashbookBatchDetailChangedEventHandler |
Public delegate | JobDetailCollection..::..JobDetailChangedEventHandler |
Public delegate | JournalBatchDetailCollection..::..JournalBatchDetailChangedEventHandler |
Public delegate | OrderDetailCollection..::..OrderDetailChangedEventHandler |
Public delegate | SplitAllocationCollection..::..OrderDetailChangedEventHandler |
Public delegate | TransactionBase..::..GLPostingEventHandler |

Enumerations

 | Enumeration | Description
Public enumeration | AccountAgeingMethod | Describes an account's ageing method.
Public enumeration | AgeingDate | Specifies the date to use when ageing transactions on an ageing reports.
Public enumeration | AgingIntervalOption |
Public enumeration | AgingModule |
Public enumeration | AgingTypeOption |
Public enumeration | AutoPaymentMethod | Describes the automatic payment method available to supplier accounts.
Public enumeration | Bank..::..AccountType | Describes a bank account type.
Public enumeration | CashbookBatchDetail..::..Module |
Public enumeration | CashbookBatchDetail..::..SplitLineType |
Public enumeration | CashbookBatchDetailCollection..::..CashbookBatchDetailChangeAction |
Public enumeration | CashbookBatchSplitCollection..::..CashbookBatchDetailChangeAction |
Public enumeration | Contract..::..ContractBillingType |
Public enumeration | DocumentState | Describes an inventory document's state.
Public enumeration | DocumentTotalRoundingStrategy |
Public enumeration | DocumentType | Describes an inventory document's type.
Public enumeration | DrCrTransaction..::..FcCalcElement |
Public enumeration | EvolutionVersion..::..SpecialBuilds |
Public enumeration | FieldCollectionManager..::..FieldType |
Public enumeration | GLAccount..::..AccountType | Defines general ledger account types.
Public enumeration | GLBatch..::..BatchChangeAction |
Public enumeration | Incident..::..IncidentStatus | Describes the status of the incident.
Public enumeration | IncidentLogAction |
Public enumeration | InventoryCostingMethod | Inventory costing method.
Public enumeration | InventoryIntegrationMethod | Inventory costing method.
Public enumeration | InventoryOperation |
Public enumeration | JobCard..::..JobStatus |
Public enumeration | JobDetail..::..TransactionKind |
Public enumeration | JobDetail..::..TransactionSource |
Public enumeration | JobDetailCollection..::..JobDetailChangeAction |
Public enumeration | JobPostingMethod |
Public enumeration | JobStatus |
Public enumeration | JournalBatchDetailCollection..::..JournalBatchDetailChangeAction |
Public enumeration | Module |
Public enumeration | ModuleID | Evolution module ID as it appears in the posting tables. Mainly used internally.
Public enumeration | OrderDetailCollection..::..OrderDetailChangeAction |
Public enumeration | PropertyDirection | Describes whether a Property's Direction is a Value or Percentage.
Public enumeration | PurchaseOrder..::..GrvPhase |
Public enumeration | SerialNumberLocation | Describes an inventory number's location.
Public enumeration | SerialNumberTransaction..::..SerialNumberMovement |
Public enumeration | SplitAllocationCollection..::..OrderDetailChangeAction |
Public enumeration | TaxMode |


AccountAgeingMethod Enumeration

[image]

Pastel Evolution SDK
AccountAgeingMethod Enumeration
See Also Send Feedback
Describes an account's ageing method.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public enum AccountAgeingMethod
Visual Basic
Public Enumeration AccountAgeingMethod

Members

Member name | Value | Description
OpenItem | 0 | Each transaction on the account is allocated and aged individually.
BalanceForward | 1 | Transaction balances on the account are automatically offset by other transactions in the same or previous periods.

See Also

Pastel.Evolution Namespace


AccountBase Class

[image]

Pastel Evolution SDK
AccountBase Class
Members See Also Send Feedback
Provides basic account functionality.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract class AccountBase : BranchedRecordBase
Visual Basic
Public MustInherit Class AccountBase
    Inherits BranchedRecordBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..AccountBase
Pastel.Evolution..::..DrCrAccount
Pastel.Evolution..::..GLAccount
Pastel.Evolution..::..InventoryItem
Pastel.Evolution..::..JobCard
Pastel.Evolution..::..Warehouse
Pastel.Evolution..::..Worker

See Also

AccountBase Members


AccountBase Members

[image] [image]

Pastel Evolution SDK
AccountBase Members
AccountBase Class Constructors Methods Fields Properties See Also Send Feedback

The AccountBase type exposes the following members.

Constructors

 | Name | Description
Protected method | AccountBase | Initializes a new instance of the AccountBase class

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | (Overrides Object..::..ToString()()()().)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | Active | Gets or sets the record's state.
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Code | Gets the internal record ID (0 for new, unsaved records).
Public property | Description | Gets or sets the record's description. The database field corresponding to the code is not necessarily called description.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Inherited from RecordBase.)
Public property | LongID | Gets the internal record ID (0 for new, unsaved records). (Inherited from RecordBase.)
Public property | Module | Each module type is associated with an Evolution module.

See Also

AccountBase Class


AccountBase Constructor

[image]

Pastel Evolution SDK
AccountBase Constructor
AccountBase Class See Also Send Feedback
Initializes a new instance of the AccountBase class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected AccountBase()
Visual Basic
Protected Sub New

See Also

AccountBase Class
AccountBase Members


AccountBase Fields

[image] [image]

Pastel Evolution SDK
AccountBase Fields
AccountBase Class See Also Send Feedback

The AccountBase type exposes the following members.

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

AccountBase Class


AccountBase Methods

[image] [image]

Pastel Evolution SDK
AccountBase Methods
AccountBase Class See Also Send Feedback

The AccountBase type exposes the following members.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | (Overrides Object..::..ToString()()()().)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

AccountBase Class


AccountBase.OnDelete Method

[image]

Pastel Evolution SDK
AccountBase..::..OnDelete Method
AccountBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

See Also

AccountBase Class
AccountBase Members


AccountBase.OnSave Method

[image]

Pastel Evolution SDK
AccountBase..::..OnSave Method
AccountBase Class See Also Send Feedback
Persists the record to the database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

AccountBase Class
AccountBase Members


AccountBase.ToString Method

[image]

Pastel Evolution SDK
AccountBase..::..ToString Method
AccountBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String

See Also

AccountBase Class
AccountBase Members


AccountBase Properties

[image] [image]

Pastel Evolution SDK
AccountBase Properties
AccountBase Class See Also Send Feedback

The AccountBase type exposes the following members.

Properties

 | Name | Description
Public property | Active | Gets or sets the record's state.
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Code | Gets the internal record ID (0 for new, unsaved records).
Public property | Description | Gets or sets the record's description. The database field corresponding to the code is not necessarily called description.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Inherited from RecordBase.)
Public property | LongID | Gets the internal record ID (0 for new, unsaved records). (Inherited from RecordBase.)
Public property | Module | Each module type is associated with an Evolution module.

See Also

AccountBase Class


AccountBase.Active Property

[image]

Pastel Evolution SDK
AccountBase..::..Active Property
AccountBase Class See Also Send Feedback
Gets or sets the record's state.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract bool Active { get; set; }
Visual Basic
Public MustOverride Property Active As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

AccountBase Class
AccountBase Members


AccountBase.Code Property

[image]

Pastel Evolution SDK
AccountBase..::..Code Property
AccountBase Class See Also Send Feedback
Gets the internal record ID (0 for new, unsaved records).
Gets or sets the record's code. The corresponding database field is not necessarily called code.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract string Code { get; set; }
Visual Basic
Public MustOverride Property Code As String
    Get
    Set

Property Value

Type: String

See Also

AccountBase Class
AccountBase Members


AccountBase.Description Property

[image]

Pastel Evolution SDK
AccountBase..::..Description Property
AccountBase Class See Also Send Feedback
Gets or sets the record's description. The database field corresponding to the code is not necessarily called description.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract string Description { get; set; }
Visual Basic
Public MustOverride Property Description As String
    Get
    Set

Property Value

Type: String

See Also

AccountBase Class
AccountBase Members


AccountBase.Module Property

[image]

Pastel Evolution SDK
AccountBase..::..Module Property
AccountBase Class See Also Send Feedback
Each module type is associated with an Evolution module.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract Module Module { get; }
Visual Basic
Public MustOverride ReadOnly Property Module As Module
    Get

Property Value

Type: Module

See Also

AccountBase Class
AccountBase Members


Address Class

[image]

Pastel Evolution SDK
Address Class
Members See Also Send Feedback
Represents an address record used by various modules.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class Address
Visual Basic
Public Class Address

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..Address

See Also

Address Members


Address Members

[image] [image]

Pastel Evolution SDK
Address Members
Address Class Constructors Methods Properties See Also Send Feedback

The Address type exposes the following members.

Constructors

 | Name | Description
Public method | Address()()()() | Creates a new instance of an address record.
Public method | Address(String) | Creates a new instance of an address record from a multi line string.
Public method | Address(String, String, String) | Creates a new instance of an address record.
Public method | Address(String, String, String, String, String, String) | Creates a new instance of an address record.

Methods

 | Name | Description
Public method | Condense | Obtains a condensed version of the current address (stripped of blank lines). Note that any changes made to the returned address will not affect the current address. Also note that the postal address will be out of place if less than 6 lines are populated.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString()()()() | Converts the address into a block-formatted string void of any blank lines in between fields. (Overrides Object..::..ToString()()()().)
Public method | ToString(Boolean) | Converts the address into a block-formatted string.

Properties

 | Name | Description
Public property | Line1 | Gets or sets the first line of the address.
Public property | Line2 | Gets or sets the second line of the address.
Public property | Line3 | Gets or sets the third line of the address.
Public property | Line4 | Gets or sets the fourth line of the address.
Public property | Line5 | Gets or sets the fifth line of the address.
Public property | Line6 | Gets or sets the sixth line of the address.
Public property | PostalCode | Gets or sets the postal code of the address.

See Also

Address Class


Address Constructor

[image] [image]

Pastel Evolution SDK
Address Constructor
Address Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Address()()()() | Creates a new instance of an address record.
Public method | Address(String) | Creates a new instance of an address record from a multi line string.
Public method | Address(String, String, String) | Creates a new instance of an address record.
Public method | Address(String, String, String, String, String, String) | Creates a new instance of an address record.

See Also

Address Class
Address Members


Address Constructor

[image]

Pastel Evolution SDK
Address Constructor
Address Class See Also Send Feedback
Creates a new instance of an address record.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Address()
Visual Basic
Public Sub New

See Also

Address Class
Address Members
Address Overload


Address Constructor (String)

[image]

Pastel Evolution SDK
Address Constructor (String)
Address Class See Also Send Feedback
Creates a new instance of an address record from a multi line string.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Address(
    string address
)
Visual Basic
Public Sub New (
    address As String
)

Parameters

address
Type: System..::..String

See Also

Address Class
Address Members
Address Overload


Address Constructor (String, String, String)

[image]

Pastel Evolution SDK
Address Constructor (String, String, String)
Address Class See Also Send Feedback
Creates a new instance of an address record.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Address(
    string line1,
    string line2,
    string postalCode
)
Visual Basic
Public Sub New (
    line1 As String,
    line2 As String,
    postalCode As String
)

Parameters

line1
Type: System..::..String
line2
Type: System..::..String
postalCode
Type: System..::..String

See Also

Address Class
Address Members
Address Overload


Address Constructor (String, String, String, String, String, String)

[image]

Pastel Evolution SDK
Address Constructor (String, String, String, String, String, String)
Address Class See Also Send Feedback
Creates a new instance of an address record.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Address(
    string line1,
    string line2,
    string line3,
    string line4,
    string line5,
    string postalCode
)
Visual Basic
Public Sub New (
    line1 As String,
    line2 As String,
    line3 As String,
    line4 As String,
    line5 As String,
    postalCode As String
)

Parameters

line1
Type: System..::..String
line2
Type: System..::..String
line3
Type: System..::..String
line4
Type: System..::..String
line5
Type: System..::..String
postalCode
Type: System..::..String

See Also

Address Class
Address Members
Address Overload


Address Methods

[image] [image]

Pastel Evolution SDK
Address Methods
Address Class See Also Send Feedback

The Address type exposes the following members.

Methods

 | Name | Description
Public method | Condense | Obtains a condensed version of the current address (stripped of blank lines). Note that any changes made to the returned address will not affect the current address. Also note that the postal address will be out of place if less than 6 lines are populated.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString()()()() | Converts the address into a block-formatted string void of any blank lines in between fields. (Overrides Object..::..ToString()()()().)
Public method | ToString(Boolean) | Converts the address into a block-formatted string.

See Also

Address Class


Address.Condense Method

[image]

Pastel Evolution SDK
Address..::..Condense Method
Address Class See Also Send Feedback
Obtains a condensed version of the current address (stripped of blank lines). Note that any changes made to the returned address will not affect the current address. Also note that the postal address will be out of place if less than 6 lines are populated.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Address Condense()
Visual Basic
Public Function Condense As Address

Return Value

Type: Address

See Also

Address Class
Address Members


Address.ToString Method

[image] [image]

Pastel Evolution SDK
Address..::..ToString Method
Address Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | Converts the address into a block-formatted string void of any blank lines in between fields. (Overrides Object..::..ToString()()()().)
Public method | ToString(Boolean) | Converts the address into a block-formatted string.

See Also

Address Class
Address Members


Address.ToString Method

[image]

Pastel Evolution SDK
Address..::..ToString Method
Address Class See Also Send Feedback
Converts the address into a block-formatted string void of any blank lines in between fields.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String
The formatted address.

See Also

Address Class
Address Members
ToString Overload


Address.ToString Method (Boolean)

[image]

Pastel Evolution SDK
Address..::..ToString Method (Boolean)
Address Class See Also Send Feedback
Converts the address into a block-formatted string.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string ToString(
    bool compact
)
Visual Basic
Public Function ToString (
    compact As Boolean
) As String

Parameters

compact
Type: System..::..Boolean

Return Value

Type: String
The formatted address.

See Also

Address Class
Address Members
ToString Overload


Address Properties

[image] [image]

Pastel Evolution SDK
Address Properties
Address Class See Also Send Feedback

The Address type exposes the following members.

Properties

 | Name | Description
Public property | Line1 | Gets or sets the first line of the address.
Public property | Line2 | Gets or sets the second line of the address.
Public property | Line3 | Gets or sets the third line of the address.
Public property | Line4 | Gets or sets the fourth line of the address.
Public property | Line5 | Gets or sets the fifth line of the address.
Public property | Line6 | Gets or sets the sixth line of the address.
Public property | PostalCode | Gets or sets the postal code of the address.

See Also

Address Class


Address.Line1 Property

[image]

Pastel Evolution SDK
Address..::..Line1 Property
Address Class See Also Send Feedback
Gets or sets the first line of the address.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Line1 { get; set; }
Visual Basic
Public Property Line1 As String
    Get
    Set

Property Value

Type: String

See Also

Address Class
Address Members


Address.Line2 Property

[image]

Pastel Evolution SDK
Address..::..Line2 Property
Address Class See Also Send Feedback
Gets or sets the second line of the address.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Line2 { get; set; }
Visual Basic
Public Property Line2 As String
    Get
    Set

Property Value

Type: String

See Also

Address Class
Address Members


Address.Line3 Property

[image]

Pastel Evolution SDK
Address..::..Line3 Property
Address Class See Also Send Feedback
Gets or sets the third line of the address.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Line3 { get; set; }
Visual Basic
Public Property Line3 As String
    Get
    Set

Property Value

Type: String

See Also

Address Class
Address Members


Address.Line4 Property

[image]

Pastel Evolution SDK
Address..::..Line4 Property
Address Class See Also Send Feedback
Gets or sets the fourth line of the address.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Line4 { get; set; }
Visual Basic
Public Property Line4 As String
    Get
    Set

Property Value

Type: String

See Also

Address Class
Address Members


Address.Line5 Property

[image]

Pastel Evolution SDK
Address..::..Line5 Property
Address Class See Also Send Feedback
Gets or sets the fifth line of the address.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Line5 { get; set; }
Visual Basic
Public Property Line5 As String
    Get
    Set

Property Value

Type: String

See Also

Address Class
Address Members


Address.Line6 Property

[image]

Pastel Evolution SDK
Address..::..Line6 Property
Address Class See Also Send Feedback
Gets or sets the sixth line of the address.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Line6 { get; set; }
Visual Basic
Public Property Line6 As String
    Get
    Set

Property Value

Type: String

See Also

Address Class
Address Members


Address.PostalCode Property

[image]

Pastel Evolution SDK
Address..::..PostalCode Property
Address Class See Also Send Feedback
Gets or sets the postal code of the address.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string PostalCode { get; set; }
Visual Basic
Public Property PostalCode As String
    Get
    Set

Property Value

Type: String

See Also

Address Class
Address Members


AgeingDate Enumeration

[image]

Pastel Evolution SDK
AgeingDate Enumeration
See Also Send Feedback
Specifies the date to use when ageing transactions on an ageing reports.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public enum AgeingDate
Visual Basic
Public Enumeration AgeingDate

Members

Member name | Value | Description
InvoiceDate | 0 | The actual transaction date is used during age calculation.
StatementDate | 1 | The statement date (typically the last day of the month in which the transaction was processed) is used to determine transaction ages.

Remarks

Examples

E.g. when a transaction is dated 31 January 2000, and a statement is generated for 31 March 2000, it will be aged under 30 Days if the invoice date is used, but 60 Days if statement date (month-end) is used.

See Also

Pastel.Evolution Namespace


Agent Class

[image]

Pastel Evolution SDK
Agent Class
Members See Also Send Feedback
Represents an agent.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class Agent : BranchedRecordBase
Visual Basic
Public Class Agent
    Inherits BranchedRecordBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..Agent

See Also

Agent Members


Agent Members

[image] [image]

Pastel Evolution SDK
Agent Members
Agent Class Constructors Methods Fields Properties See Also Send Feedback

The Agent type exposes the following members.

Constructors

 | Name | Description
Public method | Agent()()()() | Creates a new instance of the Agent class.
Public method | Agent(Int32) | Creates a new instance of the Agent class.
Public method | Agent(String) | Creates a new instance of the Agent class.

Methods

 | Name | Description
 | _ListCurrentBranch |
 | Authenticate | Authenticates the agent in the Evolution database.
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds an agent account ID.
 | FindByName | Attempts to find an agent by its code and returns its ID.
 | Get | Returns an instance of the first record satisfying the criteria specified; otherwise, returns null.
 | GetByName | Returns an instance of the first record with the code specified; otherwise, returns null.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | SetPassword(String) | Sets a new password for the agent.
Public method | SetPassword(String, String) | Sets a new password for the agent, along with a password reminder.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | CanAssignIncidents | Determines whether incidents can be assigned to this agent.
Public property | CanSetOutOfOffice | Determines whether the agent can set itself out of office.
Public property | Comments | Gets or sets comments for this agent.
Public property | Description | Gets or sets the agent's description.
Public property | DisplayName | Gets or sets the agent's display name.
Public property | EmailAddress | Gets or sets the agent's e-mail address.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | IsActive | Gets or sets the agent's display name.
Public property | IsOutOfOffice | Determines whether this agent is out of office.
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | Name | Gets or sets the agent name.

See Also

Agent Class


Agent Constructor

[image] [image]

Pastel Evolution SDK
Agent Constructor
Agent Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Agent()()()() | Creates a new instance of the Agent class.
Public method | Agent(Int32) | Creates a new instance of the Agent class.
Public method | Agent(String) | Creates a new instance of the Agent class.

See Also

Agent Class
Agent Members


Agent Constructor

[image]

Pastel Evolution SDK
Agent Constructor
Agent Class See Also Send Feedback
Creates a new instance of the Agent class.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Agent()
Visual Basic
Public Sub New

See Also

Agent Class
Agent Members
Agent Overload


Agent Constructor (Int32)

[image]

Pastel Evolution SDK
Agent Constructor (Int32)
Agent Class See Also Send Feedback
Creates a new instance of the Agent class.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Agent(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32
The agent ID in the database.

Exceptions

Exception | Condition
Pastel.Evolution..::..EvolutionException | ID does not exist in the database.

See Also

Agent Class
Agent Members
Agent Overload


Agent Constructor (String)

[image]

Pastel Evolution SDK
Agent Constructor (String)
Agent Class See Also Send Feedback
Creates a new instance of the Agent class.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Agent(
    string name
)
Visual Basic
Public Sub New (
    name As String
)

Parameters

name
Type: System..::..String
The agent login name in the database.

Exceptions

Exception | Condition
Pastel.Evolution..::..EvolutionException | Login name does not exist in the database.

See Also

Agent Class
Agent Members
Agent Overload


Agent Fields

[image] [image]

Pastel Evolution SDK
Agent Fields
Agent Class See Also Send Feedback

The Agent type exposes the following members.

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

Agent Class


Agent Methods

[image] [image]

Pastel Evolution SDK
Agent Methods
Agent Class See Also Send Feedback

The Agent type exposes the following members.

Methods

 | Name | Description
 | _ListCurrentBranch |
 | Authenticate | Authenticates the agent in the Evolution database.
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds an agent account ID.
 | FindByName | Attempts to find an agent by its code and returns its ID.
 | Get | Returns an instance of the first record satisfying the criteria specified; otherwise, returns null.
 | GetByName | Returns an instance of the first record with the code specified; otherwise, returns null.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | SetPassword(String) | Sets a new password for the agent.
Public method | SetPassword(String, String) | Sets a new password for the agent, along with a password reminder.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

Agent Class


Agent._ListCurrentBranch Method

[image]

Pastel Evolution SDK
Agent..::.._ListCurrentBranch Method
Agent Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable _ListCurrentBranch(
    string criteria
)
Visual Basic
Public Shared Function _ListCurrentBranch (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String

Return Value

Type: DataTable

See Also

Agent Class
Agent Members


Agent.Authenticate Method

[image]

Pastel Evolution SDK
Agent..::..Authenticate Method
Agent Class See Also Send Feedback
Authenticates the agent in the Evolution database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static bool Authenticate(
    string agentName,
    string password
)
Visual Basic
Public Shared Function Authenticate (
    agentName As String,
    password As String
) As Boolean

Parameters

agentName
Type: System..::..String
Specifies the agent name.
password
Type: System..::..String
Specifies the agent password.

Return Value

Type: Boolean
True if the agent exists in the database, is active, and the password supplied is correct; false otherwise.

See Also

Agent Class
Agent Members


Agent.Find Method

[image]

Pastel Evolution SDK
Agent..::..Find Method
Agent Class See Also Send Feedback
Finds an agent account ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String
The criteria passed to the SQL query.

Return Value

Type: Int32
The ID of the first record found; -1 if not record was found.

See Also

Agent Class
Agent Members


Agent.FindByName Method

[image]

Pastel Evolution SDK
Agent..::..FindByName Method
Agent Class See Also Send Feedback
Attempts to find an agent by its code and returns its ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int FindByName(
    string name
)
Visual Basic
Public Shared Function FindByName (
    name As String
) As Integer

Parameters

name
Type: System..::..String
The name used to lookup the agent.

Return Value

Type: Int32
-1 if no record was found, else the id of the first account matching the criteria supplied.

See Also

Agent Class
Agent Members
Pastel.Evolution Namespace
Agent..::..Find(String)


Agent.Get Method

[image]

Pastel Evolution SDK
Agent..::..Get Method
Agent Class See Also Send Feedback
Returns an instance of the first record satisfying the criteria specified; otherwise, returns null.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static Agent Get(
    string criteria
)
Visual Basic
Public Shared Function Get (
    criteria As String
) As Agent

Parameters

criteria
Type: System..::..String
The criteria passed to the SQL query.

Return Value

Type: Agent
The record found; otherwise null

See Also

Agent Class
Agent Members
Pastel.Evolution Namespace
Agent..::..Find(String)
Agent..::..Agent(String)
Agent..::..GetByName(String)


Agent.GetByName Method

[image]

Pastel Evolution SDK
Agent..::..GetByName Method
Agent Class See Also Send Feedback
Returns an instance of the first record with the code specified; otherwise, returns null.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static Agent GetByName(
    string name
)
Visual Basic
Public Shared Function GetByName (
    name As String
) As Agent

Parameters

name
Type: System..::..String
Specifies the agent name.

Return Value

Type: Agent
The record found; otherwise null

See Also

Agent Class
Agent Members
Pastel.Evolution Namespace
Agent..::..Get(String)
Agent..::..Agent(String)
Agent..::..Find(String)


Agent.List Method

[image]

Pastel Evolution SDK
Agent..::..List Method
Agent Class See Also Send Feedback
Gets a list of database records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria
)
Visual Basic
Public Shared Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.

Return Value

Type: DataTable
Table containing selected records.

See Also

Agent Class
Agent Members


Agent.OnDelete Method

[image]

Pastel Evolution SDK
Agent..::..OnDelete Method
Agent Class See Also Send Feedback
Removes the record from the database, provided it is not referenced by other records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

See Also

Agent Class
Agent Members


Agent.OnSave Method

[image]

Pastel Evolution SDK
Agent..::..OnSave Method
Agent Class See Also Send Feedback
Persists the record to the database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

Agent Class
Agent Members


Agent.SetPassword Method

[image] [image]

Pastel Evolution SDK
Agent..::..SetPassword Method
Agent Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetPassword(String) | Sets a new password for the agent.
Public method | SetPassword(String, String) | Sets a new password for the agent, along with a password reminder.

See Also

Agent Class
Agent Members


Agent.SetPassword Method (String)

[image]

Pastel Evolution SDK
Agent..::..SetPassword Method (String)
Agent Class See Also Send Feedback
Sets a new password for the agent.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void SetPassword(
    string newPwd
)
Visual Basic
Public Sub SetPassword (
    newPwd As String
)

Parameters

newPwd
Type: System..::..String

See Also

Agent Class
Agent Members
SetPassword Overload


Agent.SetPassword Method (String, String)

[image]

Pastel Evolution SDK
Agent..::..SetPassword Method (String, String)
Agent Class See Also Send Feedback
Sets a new password for the agent, along with a password reminder.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void SetPassword(
    string newPwd,
    string reminder
)
Visual Basic
Public Sub SetPassword (
    newPwd As String,
    reminder As String
)

Parameters

newPwd
Type: System..::..String
reminder
Type: System..::..String

See Also

Agent Class
Agent Members
SetPassword Overload


Agent Properties

[image] [image]

Pastel Evolution SDK
Agent Properties
Agent Class See Also Send Feedback

The Agent type exposes the following members.

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | CanAssignIncidents | Determines whether incidents can be assigned to this agent.
Public property | CanSetOutOfOffice | Determines whether the agent can set itself out of office.
Public property | Comments | Gets or sets comments for this agent.
Public property | Description | Gets or sets the agent's description.
Public property | DisplayName | Gets or sets the agent's display name.
Public property | EmailAddress | Gets or sets the agent's e-mail address.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | IsActive | Gets or sets the agent's display name.
Public property | IsOutOfOffice | Determines whether this agent is out of office.
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | Name | Gets or sets the agent name.

See Also

Agent Class


Agent.CanAssignIncidents Property

[image]

Pastel Evolution SDK
Agent..::..CanAssignIncidents Property
Agent Class See Also Send Feedback
Determines whether incidents can be assigned to this agent.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool CanAssignIncidents { get; set; }
Visual Basic
Public Property CanAssignIncidents As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

Agent Class
Agent Members


Agent.CanSetOutOfOffice Property

[image]

Pastel Evolution SDK
Agent..::..CanSetOutOfOffice Property
Agent Class See Also Send Feedback
Determines whether the agent can set itself out of office.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool CanSetOutOfOffice { get; set; }
Visual Basic
Public Property CanSetOutOfOffice As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

Agent Class
Agent Members


Agent.Comments Property

[image]

Pastel Evolution SDK
Agent..::..Comments Property
Agent Class See Also Send Feedback
Gets or sets comments for this agent.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Comments { get; set; }
Visual Basic
Public Property Comments As String
    Get
    Set

Property Value

Type: String

See Also

Agent Class
Agent Members


Agent.Description Property

[image]

Pastel Evolution SDK
Agent..::..Description Property
Agent Class See Also Send Feedback
Gets or sets the agent's description.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set

Property Value

Type: String

See Also

Agent Class
Agent Members


Agent.DisplayName Property

[image]

Pastel Evolution SDK
Agent..::..DisplayName Property
Agent Class See Also Send Feedback
Gets or sets the agent's display name.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string DisplayName { get; set; }
Visual Basic
Public Property DisplayName As String
    Get
    Set

Property Value

Type: String

See Also

Agent Class
Agent Members


Agent.EmailAddress Property

[image]

Pastel Evolution SDK
Agent..::..EmailAddress Property
Agent Class See Also Send Feedback
Gets or sets the agent's e-mail address.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string EmailAddress { get; set; }
Visual Basic
Public Property EmailAddress As String
    Get
    Set

Property Value

Type: String

See Also

Agent Class
Agent Members


Agent.ID Property

[image]

Pastel Evolution SDK
Agent..::..ID Property
Agent Class See Also Send Feedback
Gets the internal record ID (0 for new, unsaved records).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

See Also

Agent Class
Agent Members


Agent.IsActive Property

[image]

Pastel Evolution SDK
Agent..::..IsActive Property
Agent Class See Also Send Feedback
Gets or sets the agent's display name.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool IsActive { get; set; }
Visual Basic
Public Property IsActive As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

Agent Class
Agent Members


Agent.IsOutOfOffice Property

[image]

Pastel Evolution SDK
Agent..::..IsOutOfOffice Property
Agent Class See Also Send Feedback
Determines whether this agent is out of office.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool IsOutOfOffice { get; set; }
Visual Basic
Public Property IsOutOfOffice As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

Agent Class
Agent Members


Agent.LongID Property

[image]

Pastel Evolution SDK
Agent..::..LongID Property
Agent Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

Agent Class
Agent Members


Agent.Name Property

[image]

Pastel Evolution SDK
Agent..::..Name Property
Agent Class See Also Send Feedback
Gets or sets the agent name.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

Property Value

Type: String

See Also

Agent Class
Agent Members


AgentGroup Class

[image]

Pastel Evolution SDK
AgentGroup Class
Members See Also Send Feedback
Represents an group.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class AgentGroup : BranchedRecordBase
Visual Basic
Public Class AgentGroup
    Inherits BranchedRecordBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..AgentGroup

See Also

AgentGroup Members


AgentGroup Members

[image] [image]

Pastel Evolution SDK
AgentGroup Members
AgentGroup Class Constructors Methods Fields Properties See Also Send Feedback

The AgentGroup type exposes the following members.

Constructors

 | Name | Description
Public method | AgentGroup()()()() | Creates a new instance of the agent group class.
Public method | AgentGroup(Int32) | Creates a new instance of the agent group class.
Public method | AgentGroup(String) | Creates a new instance of the agent group class.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds an group account ID.
 | FindByName | Attempts to find an group by its code and returns its ID.
 | Get | Returns an instance of the first record satisfying the criteria specified; otherwise, returns null.
 | GetByName | Returns an instance of the first record with the code specified; otherwise, returns null.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Description | Gets or sets the group's description.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | Name | Gets or sets the group name.

See Also

AgentGroup Class


AgentGroup Constructor

[image] [image]

Pastel Evolution SDK
AgentGroup Constructor
AgentGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AgentGroup()()()() | Creates a new instance of the agent group class.
Public method | AgentGroup(Int32) | Creates a new instance of the agent group class.
Public method | AgentGroup(String) | Creates a new instance of the agent group class.

See Also

AgentGroup Class
AgentGroup Members


AgentGroup Constructor

[image]

Pastel Evolution SDK
AgentGroup Constructor
AgentGroup Class See Also Send Feedback
Creates a new instance of the agent group class.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public AgentGroup()
Visual Basic
Public Sub New

See Also

AgentGroup Class
AgentGroup Members
AgentGroup Overload


AgentGroup Constructor (Int32)

[image]

Pastel Evolution SDK
AgentGroup Constructor (Int32)
AgentGroup Class See Also Send Feedback
Creates a new instance of the agent group class.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public AgentGroup(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32
The group ID in the database.

Exceptions

Exception | Condition
Pastel.Evolution..::..EvolutionException | ID does not exist in the database.

See Also

AgentGroup Class
AgentGroup Members
AgentGroup Overload


AgentGroup Constructor (String)

[image]

Pastel Evolution SDK
AgentGroup Constructor (String)
AgentGroup Class See Also Send Feedback
Creates a new instance of the agent group class.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public AgentGroup(
    string name
)
Visual Basic
Public Sub New (
    name As String
)

Parameters

name
Type: System..::..String
The group login name in the database.

See Also

AgentGroup Class
AgentGroup Members
AgentGroup Overload


AgentGroup Fields

[image] [image]

Pastel Evolution SDK
AgentGroup Fields
AgentGroup Class See Also Send Feedback

The AgentGroup type exposes the following members.

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

AgentGroup Class


AgentGroup Methods

[image] [image]

Pastel Evolution SDK
AgentGroup Methods
AgentGroup Class See Also Send Feedback

The AgentGroup type exposes the following members.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds an group account ID.
 | FindByName | Attempts to find an group by its code and returns its ID.
 | Get | Returns an instance of the first record satisfying the criteria specified; otherwise, returns null.
 | GetByName | Returns an instance of the first record with the code specified; otherwise, returns null.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

AgentGroup Class


AgentGroup.Find Method

[image]

Pastel Evolution SDK
AgentGroup..::..Find Method
AgentGroup Class See Also Send Feedback
Finds an group account ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String
The criteria passed to the SQL query.

Return Value

Type: Int32
The ID of the first record found; -1 if not record was found.

See Also

AgentGroup Class
AgentGroup Members


AgentGroup.FindByName Method

[image]

Pastel Evolution SDK
AgentGroup..::..FindByName Method
AgentGroup Class See Also Send Feedback
Attempts to find an group by its code and returns its ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int FindByName(
    string name
)
Visual Basic
Public Shared Function FindByName (
    name As String
) As Integer

Parameters

name
Type: System..::..String
The name used to lookup the agent group.

Return Value

Type: Int32
-1 if no record was found, else the id of the first account matching the criteria supplied.

See Also

AgentGroup Class
AgentGroup Members
Pastel.Evolution Namespace
AgentGroup..::..Find(String)


AgentGroup.Get Method

[image]

Pastel Evolution SDK
AgentGroup..::..Get Method
AgentGroup Class See Also Send Feedback
Returns an instance of the first record satisfying the criteria specified; otherwise, returns null.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static AgentGroup Get(
    string criteria
)
Visual Basic
Public Shared Function Get (
    criteria As String
) As AgentGroup

Parameters

criteria
Type: System..::..String
The criteria passed to the SQL query.

Return Value

Type: AgentGroup
The record found; otherwise null

See Also

AgentGroup Class
AgentGroup Members
Pastel.Evolution Namespace
AgentGroup..::..Find(String)
AgentGroup..::..AgentGroup(String)
AgentGroup..::..GetByName(String)


AgentGroup.GetByName Method

[image]

Pastel Evolution SDK
AgentGroup..::..GetByName Method
AgentGroup Class See Also Send Feedback
Returns an instance of the first record with the code specified; otherwise, returns null.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static AgentGroup GetByName(
    string name
)
Visual Basic
Public Shared Function GetByName (
    name As String
) As AgentGroup

Parameters

name
Type: System..::..String
Specifies the group name.

Return Value

Type: AgentGroup
The record found; otherwise null

See Also

AgentGroup Class
AgentGroup Members
Pastel.Evolution Namespace
AgentGroup..::..Get(String)
AgentGroup..::..AgentGroup(String)
AgentGroup..::..Find(String)


AgentGroup.List Method

[image]

Pastel Evolution SDK
AgentGroup..::..List Method
AgentGroup Class See Also Send Feedback
Gets a list of database records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria
)
Visual Basic
Public Shared Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.

Return Value

Type: DataTable
Table containing selected records.

See Also

AgentGroup Class
AgentGroup Members


AgentGroup.OnDelete Method

[image]

Pastel Evolution SDK
AgentGroup..::..OnDelete Method
AgentGroup Class See Also Send Feedback
Removes the record from the database, provided it is not referenced by other records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

See Also

AgentGroup Class
AgentGroup Members


AgentGroup.OnSave Method

[image]

Pastel Evolution SDK
AgentGroup..::..OnSave Method
AgentGroup Class See Also Send Feedback
Persists the record to the database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

AgentGroup Class
AgentGroup Members


AgentGroup Properties

[image] [image]

Pastel Evolution SDK
AgentGroup Properties
AgentGroup Class See Also Send Feedback

The AgentGroup type exposes the following members.

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Description | Gets or sets the group's description.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | Name | Gets or sets the group name.

See Also

AgentGroup Class


AgentGroup.Description Property

[image]

Pastel Evolution SDK
AgentGroup..::..Description Property
AgentGroup Class See Also Send Feedback
Gets or sets the group's description.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set

Property Value

Type: String

See Also

AgentGroup Class
AgentGroup Members


AgentGroup.ID Property

[image]

Pastel Evolution SDK
AgentGroup..::..ID Property
AgentGroup Class See Also Send Feedback
Gets the internal record ID (0 for new, unsaved records).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

See Also

AgentGroup Class
AgentGroup Members


AgentGroup.LongID Property

[image]

Pastel Evolution SDK
AgentGroup..::..LongID Property
AgentGroup Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

AgentGroup Class
AgentGroup Members


AgentGroup.Name Property

[image]

Pastel Evolution SDK
AgentGroup..::..Name Property
AgentGroup Class See Also Send Feedback
Gets or sets the group name.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

Property Value

Type: String

See Also

AgentGroup Class
AgentGroup Members


AgingIntervalOption Enumeration

[image]

Pastel Evolution SDK
AgingIntervalOption Enumeration
See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public enum AgingIntervalOption
Visual Basic
Public Enumeration AgingIntervalOption

Members

Member name | Value | Description
ThirtyDays | 0 |
SevenDays | 1 |
Custom | 2 |

See Also

Pastel.Evolution Namespace


AgingModule Enumeration

[image]

Pastel Evolution SDK
AgingModule Enumeration
See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public enum AgingModule
Visual Basic
Public Enumeration AgingModule

Members

Member name | Value | Description
AR | 0 |
AP | 1 |

See Also

Pastel.Evolution Namespace


AgingTerm Class

[image]

Pastel Evolution SDK
AgingTerm Class
Members See Also Send Feedback
Represents customer and supplier aging terms.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class AgingTerm : BranchedRecordBase
Visual Basic
Public Class AgingTerm
    Inherits BranchedRecordBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..AgingTerm

See Also

AgingTerm Members


AgingTerm Members

[image] [image]

Pastel Evolution SDK
AgingTerm Members
AgingTerm Class Constructors Methods Fields Properties See Also Send Feedback

The AgingTerm type exposes the following members.

Constructors

 | Name | Description
Public method | AgingTerm()()()() | Creates a new instance of aging terms.
Public method | AgingTerm(Int32) | Creates a new instance of aging terms.
Public method | AgingTerm(AgingModule, String) | Creates a new instance of aging terms.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find(String) | Finds an aging terms record ID.
 | Find(String, AgingModule) | Finds a record's database ID.
 | FindByCode | Attempts to find aging terms by its code and returns its ID.
 | Get | Returns an instance of the first record satisfying the criteria specified; otherwise, returns null.
 | GetByCode | Returns an instance of the first record with the code specified; otherwise, returns null.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List(String) | Gets a list of database records.
 | List(String, AgingModule) | Executes the List method.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | AgeTypeOption |
Public property | AgingMessage120DaysLine1 |
Public property | AgingMessage120DaysLine2 |
Public property | AgingMessage150DaysLine1 |
Public property | AgingMessage150DaysLine2 |
Public property | AgingMessage180DaysLine1 |
Public property | AgingMessage180DaysLine2 |
Public property | AgingMessage30DaysLine1 |
Public property | AgingMessage30DaysLine2 |
Public property | AgingMessage60DaysLine1 |
Public property | AgingMessage60DaysLine2 |
Public property | AgingMessage90DaysLine1 |
Public property | AgingMessage90DaysLine2 |
Public property | AgingMessageCurrentLine1 |
Public property | AgingMessageCurrentLine2 |
Public property | AutoSetToPeriod |
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Code | Gets or sets the Aging Term code.
Public property | Description | Gets or sets the aging term' description.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | Interval1NumberOfDays |
Public property | Interval2NumberOfDays |
Public property | Interval3NumberOfDays |
Public property | Interval4NumberOfDays |
Public property | Interval5NumberOfDays |
Public property | Interval6NumberOfDays |
Public property | Interval7NumberOfDays |
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | Module |
Public property | StatementCloseDate120Days |
Public property | StatementCloseDate150Days |
Public property | StatementCloseDate180Days |
Public property | StatementCloseDate30Days |
Public property | StatementCloseDate60Days |
Public property | StatementCloseDate90Days |
Public property | StatementCloseDateCurrent |
Public property | TermDescription120Days |
Public property | TermDescription150Days |
Public property | TermDescription180Days |
Public property | TermDescription30Days |
Public property | TermDescription60Days |
Public property | TermDescription90Days |
Public property | TermDescriptionCurrent |
Public property | TermDescriptionOption |
Public property | TermIntervalOption |

See Also

AgingTerm Class


AgingTerm Constructor

[image] [image]

Pastel Evolution SDK
AgingTerm Constructor
AgingTerm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AgingTerm()()()() | Creates a new instance of aging terms.
Public method | AgingTerm(Int32) | Creates a new instance of aging terms.
Public method | AgingTerm(AgingModule, String) | Creates a new instance of aging terms.

See Also

AgingTerm Class
AgingTerm Members


AgingTerm Constructor

[image]

Pastel Evolution SDK
AgingTerm Constructor
AgingTerm Class See Also Send Feedback
Creates a new instance of aging terms.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public AgingTerm()
Visual Basic
Public Sub New

See Also

AgingTerm Class
AgingTerm Members
AgingTerm Overload


AgingTerm Constructor (Int32)

[image]

Pastel Evolution SDK
AgingTerm Constructor (Int32)
AgingTerm Class See Also Send Feedback
Creates a new instance of aging terms.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public AgingTerm(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32
Specifies the id of the existing record.

See Also

AgingTerm Class
AgingTerm Members
AgingTerm Overload


AgingTerm Constructor (AgingModule, String)

[image]

Pastel Evolution SDK
AgingTerm Constructor (AgingModule, String)
AgingTerm Class See Also Send Feedback
Creates a new instance of aging terms.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public AgingTerm(
    AgingModule module,
    string code
)
Visual Basic
Public Sub New (
    module As AgingModule,
    code As String
)

Parameters

module
Type: Pastel.Evolution..::..AgingModule
code
Type: System..::..String
Specifies the code of the existing record.

See Also

AgingTerm Class
AgingTerm Members
AgingTerm Overload


AgingTerm Fields

[image] [image]

Pastel Evolution SDK
AgingTerm Fields
AgingTerm Class See Also Send Feedback

The AgingTerm type exposes the following members.

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

AgingTerm Class


AgingTerm Methods

[image] [image]

Pastel Evolution SDK
AgingTerm Methods
AgingTerm Class See Also Send Feedback

The AgingTerm type exposes the following members.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find(String) | Finds an aging terms record ID.
 | Find(String, AgingModule) | Finds a record's database ID.
 | FindByCode | Attempts to find aging terms by its code and returns its ID.
 | Get | Returns an instance of the first record satisfying the criteria specified; otherwise, returns null.
 | GetByCode | Returns an instance of the first record with the code specified; otherwise, returns null.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List(String) | Gets a list of database records.
 | List(String, AgingModule) | Executes the List method.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

AgingTerm Class


AgingTerm.Find Method

[image] [image]

Pastel Evolution SDK
AgingTerm..::..Find Method
AgingTerm Class See Also Send Feedback

Overload List

Name | Description
Find(String) | Finds an aging terms record ID.
Find(String, AgingModule) | Finds a record's database ID.

See Also

AgingTerm Class
AgingTerm Members


AgingTerm.Find Method (String)

[image]

Pastel Evolution SDK
AgingTerm..::..Find Method (String)
AgingTerm Class See Also Send Feedback
Finds an aging terms record ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String
The criteria passed to the SQL query. Eg. cCode = 'MNTH-STMT' or cDescription like '%Internal%'

Return Value

Type: Int32
The ID of the first record found; -1 if not record was found.

See Also

AgingTerm Class
AgingTerm Members
Find Overload


AgingTerm.Find Method (String, AgingModule)

[image]

Pastel Evolution SDK
AgingTerm..::..Find Method (String, AgingModule)
AgingTerm Class See Also Send Feedback
Finds a record's database ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria,
    AgingModule module
)
Visual Basic
Public Shared Function Find (
    criteria As String,
    module As AgingModule
) As Integer

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.
module
Type: Pastel.Evolution..::..AgingModule
Specifies the module.

Return Value

Type: Int32
The Find.

See Also

AgingTerm Class
AgingTerm Members
Find Overload
Pastel.Evolution Namespace
AgingTerm..::..Find(String)


AgingTerm.FindByCode Method

[image]

Pastel Evolution SDK
AgingTerm..::..FindByCode Method
AgingTerm Class See Also Send Feedback
Attempts to find aging terms by its code and returns its ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int FindByCode(
    AgingModule module,
    string code
)
Visual Basic
Public Shared Function FindByCode (
    module As AgingModule,
    code As String
) As Integer

Parameters

module
Type: Pastel.Evolution..::..AgingModule
code
Type: System..::..String
The code used to lookup the aging terms.

Return Value

Type: Int32
-1 if no record was found, else the id of the first account matching the criteria supplied.

See Also

AgingTerm Class
AgingTerm Members
Pastel.Evolution Namespace
AgingTerm..::..Find(String)


AgingTerm.Get Method

[image]

Pastel Evolution SDK
AgingTerm..::..Get Method
AgingTerm Class See Also Send Feedback
Returns an instance of the first record satisfying the criteria specified; otherwise, returns null.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static AgingTerm Get(
    string criteria
)
Visual Basic
Public Shared Function Get (
    criteria As String
) As AgingTerm

Parameters

criteria
Type: System..::..String
The criteria passed to the SQL query. Eg. cCode = 'MNTH-STMT' or cDescription like '%Internal%'

Return Value

Type: AgingTerm
The record found; otherwise null

See Also

AgingTerm Class
AgingTerm Members
Pastel.Evolution Namespace
AgingTerm..::..Find(String)
[!:AgingTerm(string)]
[!:GetByCode(string)]


AgingTerm.GetByCode Method

[image]

Pastel Evolution SDK
AgingTerm..::..GetByCode Method
AgingTerm Class See Also Send Feedback
Returns an instance of the first record with the code specified; otherwise, returns null.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static AgingTerm GetByCode(
    AgingModule module,
    string code
)
Visual Basic
Public Shared Function GetByCode (
    module As AgingModule,
    code As String
) As AgingTerm

Parameters

module
Type: Pastel.Evolution..::..AgingModule
code
Type: System..::..String
Specifies the code.

Return Value

Type: AgingTerm
The record found; otherwise null

See Also

AgingTerm Class
AgingTerm Members
Pastel.Evolution Namespace
AgingTerm..::..Get(String)
[!:AgingTerm(string)]
AgingTerm..::..Find(String)


AgingTerm.List Method

[image] [image]

Pastel Evolution SDK
AgingTerm..::..List Method
AgingTerm Class See Also Send Feedback

Overload List

Name | Description
List(String) | Gets a list of database records.
List(String, AgingModule) | Executes the List method.

See Also

AgingTerm Class
AgingTerm Members


AgingTerm.List Method (String)

[image]

Pastel Evolution SDK
AgingTerm..::..List Method (String)
AgingTerm Class See Also Send Feedback
Gets a list of database records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria
)
Visual Basic
Public Shared Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.

Return Value

Type: DataTable
Table containing selected records.

See Also

AgingTerm Class
AgingTerm Members
List Overload


AgingTerm.List Method (String, AgingModule)

[image]

Pastel Evolution SDK
AgingTerm..::..List Method (String, AgingModule)
AgingTerm Class See Also Send Feedback
Executes the List method.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria,
    AgingModule module
)
Visual Basic
Public Shared Function List (
    criteria As String,
    module As AgingModule
) As DataTable

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.
module
Type: Pastel.Evolution..::..AgingModule
Specifies the module.

Return Value

Type: DataTable
The List.

See Also

AgingTerm Class
AgingTerm Members
List Overload


AgingTerm.OnDelete Method

[image]

Pastel Evolution SDK
AgingTerm..::..OnDelete Method
AgingTerm Class See Also Send Feedback
Removes the record from the database, provided it is not referenced by other records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

See Also

AgingTerm Class
AgingTerm Members


AgingTerm.OnSave Method

[image]

Pastel Evolution SDK
AgingTerm..::..OnSave Method
AgingTerm Class See Also Send Feedback
Persists the record to the database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

AgingTerm Class
AgingTerm Members


AgingTerm Properties

[image] [image]

Pastel Evolution SDK
AgingTerm Properties
AgingTerm Class See Also Send Feedback

The AgingTerm type exposes the following members.

Properties

 | Name | Description
Public property | AgeTypeOption |
Public property | AgingMessage120DaysLine1 |
Public property | AgingMessage120DaysLine2 |
Public property | AgingMessage150DaysLine1 |
Public property | AgingMessage150DaysLine2 |
Public property | AgingMessage180DaysLine1 |
Public property | AgingMessage180DaysLine2 |
Public property | AgingMessage30DaysLine1 |
Public property | AgingMessage30DaysLine2 |
Public property | AgingMessage60DaysLine1 |
Public property | AgingMessage60DaysLine2 |
Public property | AgingMessage90DaysLine1 |
Public property | AgingMessage90DaysLine2 |
Public property | AgingMessageCurrentLine1 |
Public property | AgingMessageCurrentLine2 |
Public property | AutoSetToPeriod |
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Code | Gets or sets the Aging Term code.
Public property | Description | Gets or sets the aging term' description.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | Interval1NumberOfDays |
Public property | Interval2NumberOfDays |
Public property | Interval3NumberOfDays |
Public property | Interval4NumberOfDays |
Public property | Interval5NumberOfDays |
Public property | Interval6NumberOfDays |
Public property | Interval7NumberOfDays |
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | Module |
Public property | StatementCloseDate120Days |
Public property | StatementCloseDate150Days |
Public property | StatementCloseDate180Days |
Public property | StatementCloseDate30Days |
Public property | StatementCloseDate60Days |
Public property | StatementCloseDate90Days |
Public property | StatementCloseDateCurrent |
Public property | TermDescription120Days |
Public property | TermDescription150Days |
Public property | TermDescription180Days |
Public property | TermDescription30Days |
Public property | TermDescription60Days |
Public property | TermDescription90Days |
Public property | TermDescriptionCurrent |
Public property | TermDescriptionOption |
Public property | TermIntervalOption |

See Also

AgingTerm Class


AgingTerm.AgeTypeOption Property

[image]

Pastel Evolution SDK
AgingTerm..::..AgeTypeOption Property
AgingTerm Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public AgingTypeOption AgeTypeOption { get; set; }
Visual Basic
Public Property AgeTypeOption As AgingTypeOption
    Get
    Set

Property Value

Type: AgingTypeOption

See Also

AgingTerm Class
AgingTerm Members


AgingTerm.AgingMessage120DaysLine1 Property

[image]

Pastel Evolution SDK
AgingTerm..::..AgingMessage120DaysLine1 Property
AgingTerm Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string AgingMessage120DaysLine1 { get; set; }
Visual Basic
Public Property AgingMessage120DaysLine1 As String
    Get
    Set

Property Value

Type: String

See Also

AgingTerm Class
AgingTerm Members


AgingTerm.AgingMessage120DaysLine2 Property

[image]

Pastel Evolution SDK
AgingTerm..::..AgingMessage120DaysLine2 Property
AgingTerm Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string AgingMessage120DaysLine2 { get; set; }
Visual Basic
Public Property AgingMessage120DaysLine2 As String
    Get
    Set

Property Value

Type: String

See Also

AgingTerm Class
AgingTerm Members


AgingTerm.AgingMessage150DaysLine1 Property

[image]

Pastel Evolution SDK
AgingTerm..::..AgingMessage150DaysLine1 Property
AgingTerm Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string AgingMessage150DaysLine1 { get; set; }
Visual Basic
Public Property AgingMessage150DaysLine1 As String
    Get
    Set

Property Value

Type: String

See Also

AgingTerm Class
AgingTerm Members


AgingTerm.AgingMessage150DaysLine2 Property

[image]

Pastel Evolution SDK
AgingTerm..::..AgingMessage150DaysLine2 Property
AgingTerm Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string AgingMessage150DaysLine2 { get; set; }
Visual Basic
Public Property AgingMessage150DaysLine2 As String
    Get
    Set

Property Value

Type: String

See Also

AgingTerm Class
AgingTerm Members


AgingTerm.AgingMessage180DaysLine1 Property

[image]

Pastel Evolution SDK
AgingTerm..::..AgingMessage180DaysLine1 Property
AgingTerm Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string AgingMessage180DaysLine1 { get; set; }
Visual Basic
Public Property AgingMessage180DaysLine1 As String
    Get
    Set

Property Value

Type: String

See Also

AgingTerm Class
AgingTerm Members


AgingTerm.AgingMessage180DaysLine2 Property

[image]

Pastel Evolution SDK
AgingTerm..::..AgingMessage180DaysLine2 Property
AgingTerm Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string AgingMessage180DaysLine2 { get; set; }
Visual Basic
Public Property AgingMessage180DaysLine2 As String
    Get
    Set

Property Value

Type: String

See Also

AgingTerm Class
AgingTerm Members


AgingTerm.AgingMessage30DaysLine1 Property

[image]

Pastel Evolution SDK
AgingTerm..::..AgingMessage30DaysLine1 Property
AgingTerm Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string AgingMessage30DaysLine1 { get; set; }
Visual Basic
Public Property AgingMessage30DaysLine1 As String
    Get
    Set

Property Value

Type: String

See Also

AgingTerm Class
AgingTerm Members


AgingTerm.AgingMessage30DaysLine2 Property

[image]

Pastel Evolution SDK
AgingTerm..::..AgingMessage30DaysLine2 Property
AgingTerm Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string AgingMessage30DaysLine2 { get; set; }
Visual Basic
Public Property AgingMessage30DaysLine2 As String
    Get
    Set

Property Value

Type: String

See Also

AgingTerm Class
AgingTerm Members


AgingTerm.AgingMessage60DaysLine1 Property

[image]

Pastel Evolution SDK
AgingTerm..::..AgingMessage60DaysLine1 Property
AgingTerm Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string AgingMessage60DaysLine1 { get; set; }
Visual Basic
Public Property AgingMessage60DaysLine1 As String
    Get
    Set

Property Value

Type: String

See Also

AgingTerm Class
AgingTerm Members


AgingTerm.AgingMessage60DaysLine2 Property

[image]

Pastel Evolution SDK
AgingTerm..::..AgingMessage60DaysLine2 Property
AgingTerm Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string AgingMessage60DaysLine2 { get; set; }
Visual Basic
Public Property AgingMessage60DaysLine2 As String
    Get
    Set

Property Value

Type: String

See Also

AgingTerm Class
AgingTerm Members


AgingTerm.AgingMessage90DaysLine1 Property

[image]

Pastel Evolution SDK
AgingTerm..::..AgingMessage90DaysLine1 Property
AgingTerm Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string AgingMessage90DaysLine1 { get; set; }
Visual Basic
Public Property AgingMessage90DaysLine1 As String
    Get
    Set

Property Value

Type: String

See Also

AgingTerm Class
AgingTerm Members


AgingTerm.AgingMessage90DaysLine2 Property

[image]

Pastel Evolution SDK
AgingTerm..::..AgingMessage90DaysLine2 Property
AgingTerm Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string AgingMessage90DaysLine2 { get; set; }
Visual Basic
Public Property AgingMessage90DaysLine2 As String
    Get
    Set

Property Value

Type: String

See Also

AgingTerm Class
AgingTerm Members


AgingTerm.AgingMessageCurrentLine1 Property

[image]

Pastel Evolution SDK
AgingTerm..::..AgingMessageCurrentLine1 Property
AgingTerm Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string AgingMessageCurrentLine1 { get; set; }
Visual Basic
Public Property AgingMessageCurrentLine1 As String
    Get
    Set

Property Value

Type: String

See Also

AgingTerm Class
AgingTerm Members


AgingTerm.AgingMessageCurrentLine2 Property

[image]

Pastel Evolution SDK
AgingTerm..::..AgingMessageCurrentLine2 Property
AgingTerm Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string AgingMessageCurrentLine2 { get; set; }
Visual Basic
Public Property AgingMessageCurrentLine2 As String
    Get
    Set

Property Value

Type: String

See Also

AgingTerm Class
AgingTerm Members


AgingTerm.AutoSetToPeriod Property

[image]

Pastel Evolution SDK
AgingTerm..::..AutoSetToPeriod Property
AgingTerm Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool AutoSetToPeriod { get; set; }
Visual Basic
Public Property AutoSetToPeriod As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

AgingTerm Class
AgingTerm Members


AgingTerm.Code Property

[image]

Pastel Evolution SDK
AgingTerm..::..Code Property
AgingTerm Class See Also Send Feedback
Gets or sets the Aging Term code.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Code { get; set; }
Visual Basic
Public Property Code As String
    Get
    Set

Property Value

Type: String

See Also

AgingTerm Class
AgingTerm Members


AgingTerm.Description Property

[image]

Pastel Evolution SDK
AgingTerm..::..Description Property
AgingTerm Class See Also Send Feedback
Gets or sets the aging term' description.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set

Property Value

Type: String

See Also

AgingTerm Class
AgingTerm Members


AgingTerm.ID Property

[image]

Pastel Evolution SDK
AgingTerm..::..ID Property
AgingTerm Class See Also Send Feedback
Gets the internal record ID (0 for new, unsaved records).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

Remarks

Once saved, the ID will reflect the record's internal database identifier.

See Also

AgingTerm Class
AgingTerm Members


AgingTerm.Interval1NumberOfDays Property

[image]

Pastel Evolution SDK
AgingTerm..::..Interval1NumberOfDays Property
AgingTerm Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int Interval1NumberOfDays { get; set; }
Visual Basic
Public Property Interval1NumberOfDays As Integer
    Get
    Set

Property Value

Type: Int32

See Also

AgingTerm Class
AgingTerm Members


AgingTerm.Interval2NumberOfDays Property

[image]

Pastel Evolution SDK
AgingTerm..::..Interval2NumberOfDays Property
AgingTerm Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int Interval2NumberOfDays { get; set; }
Visual Basic
Public Property Interval2NumberOfDays As Integer
    Get
    Set

Property Value

Type: Int32

See Also

AgingTerm Class
AgingTerm Members


AgingTerm.Interval3NumberOfDays Property

[image]

Pastel Evolution SDK
AgingTerm..::..Interval3NumberOfDays Property
AgingTerm Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int Interval3NumberOfDays { get; set; }
Visual Basic
Public Property Interval3NumberOfDays As Integer
    Get
    Set

Property Value

Type: Int32

See Also

AgingTerm Class
AgingTerm Members


AgingTerm.Interval4NumberOfDays Property

[image]

Pastel Evolution SDK
AgingTerm..::..Interval4NumberOfDays Property
AgingTerm Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int Interval4NumberOfDays { get; set; }
Visual Basic
Public Property Interval4NumberOfDays As Integer
    Get
    Set

Property Value

Type: Int32

See Also

AgingTerm Class
AgingTerm Members


AgingTerm.Interval5NumberOfDays Property

[image]

Pastel Evolution SDK
AgingTerm..::..Interval5NumberOfDays Property
AgingTerm Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int Interval5NumberOfDays { get; set; }
Visual Basic
Public Property Interval5NumberOfDays As Integer
    Get
    Set

Property Value

Type: Int32

See Also

AgingTerm Class
AgingTerm Members


AgingTerm.Interval6NumberOfDays Property

[image]

Pastel Evolution SDK
AgingTerm..::..Interval6NumberOfDays Property
AgingTerm Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int Interval6NumberOfDays { get; set; }
Visual Basic
Public Property Interval6NumberOfDays As Integer
    Get
    Set

Property Value

Type: Int32

See Also

AgingTerm Class
AgingTerm Members


AgingTerm.Interval7NumberOfDays Property

[image]

Pastel Evolution SDK
AgingTerm..::..Interval7NumberOfDays Property
AgingTerm Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int Interval7NumberOfDays { get; set; }
Visual Basic
Public Property Interval7NumberOfDays As Integer
    Get
    Set

Property Value

Type: Int32

See Also

AgingTerm Class
AgingTerm Members


AgingTerm.LongID Property

[image]

Pastel Evolution SDK
AgingTerm..::..LongID Property
AgingTerm Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

AgingTerm Class
AgingTerm Members


AgingTerm.Module Property

[image]

Pastel Evolution SDK
AgingTerm..::..Module Property
AgingTerm Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public AgingModule Module { get; set; }
Visual Basic
Public Property Module As AgingModule
    Get
    Set

Property Value

Type: AgingModule

See Also

AgingTerm Class
AgingTerm Members


AgingTerm.StatementCloseDate120Days Property

[image]

Pastel Evolution SDK
AgingTerm..::..StatementCloseDate120Days Property
AgingTerm Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DateTime StatementCloseDate120Days { get; set; }
Visual Basic
Public Property StatementCloseDate120Days As DateTime
    Get
    Set

Property Value

Type: DateTime

See Also

AgingTerm Class
AgingTerm Members


AgingTerm.StatementCloseDate150Days Property

[image]

Pastel Evolution SDK
AgingTerm..::..StatementCloseDate150Days Property
AgingTerm Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DateTime StatementCloseDate150Days { get; set; }
Visual Basic
Public Property StatementCloseDate150Days As DateTime
    Get
    Set

Property Value

Type: DateTime

See Also

AgingTerm Class
AgingTerm Members


AgingTerm.StatementCloseDate180Days Property

[image]

Pastel Evolution SDK
AgingTerm..::..StatementCloseDate180Days Property
AgingTerm Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DateTime StatementCloseDate180Days { get; set; }
Visual Basic
Public Property StatementCloseDate180Days As DateTime
    Get
    Set

Property Value

Type: DateTime

See Also

AgingTerm Class
AgingTerm Members


AgingTerm.StatementCloseDate30Days Property

[image]

Pastel Evolution SDK
AgingTerm..::..StatementCloseDate30Days Property
AgingTerm Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DateTime StatementCloseDate30Days { get; set; }
Visual Basic
Public Property StatementCloseDate30Days As DateTime
    Get
    Set

Property Value

Type: DateTime

See Also

AgingTerm Class
AgingTerm Members


AgingTerm.StatementCloseDate60Days Property

[image]

Pastel Evolution SDK
AgingTerm..::..StatementCloseDate60Days Property
AgingTerm Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DateTime StatementCloseDate60Days { get; set; }
Visual Basic
Public Property StatementCloseDate60Days As DateTime
    Get
    Set

Property Value

Type: DateTime

See Also

AgingTerm Class
AgingTerm Members


AgingTerm.StatementCloseDate90Days Property

[image]

Pastel Evolution SDK
AgingTerm..::..StatementCloseDate90Days Property
AgingTerm Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DateTime StatementCloseDate90Days { get; set; }
Visual Basic
Public Property StatementCloseDate90Days As DateTime
    Get
    Set

Property Value

Type: DateTime

See Also

AgingTerm Class
AgingTerm Members


AgingTerm.StatementCloseDateCurrent Property

[image]

Pastel Evolution SDK
AgingTerm..::..StatementCloseDateCurrent Property
AgingTerm Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DateTime StatementCloseDateCurrent { get; set; }
Visual Basic
Public Property StatementCloseDateCurrent As DateTime
    Get
    Set

Property Value

Type: DateTime

See Also

AgingTerm Class
AgingTerm Members


AgingTerm.TermDescription120Days Property

[image]

Pastel Evolution SDK
AgingTerm..::..TermDescription120Days Property
AgingTerm Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string TermDescription120Days { get; set; }
Visual Basic
Public Property TermDescription120Days As String
    Get
    Set

Property Value

Type: String

See Also

AgingTerm Class
AgingTerm Members


AgingTerm.TermDescription150Days Property

[image]

Pastel Evolution SDK
AgingTerm..::..TermDescription150Days Property
AgingTerm Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string TermDescription150Days { get; set; }
Visual Basic
Public Property TermDescription150Days As String
    Get
    Set

Property Value

Type: String

See Also

AgingTerm Class
AgingTerm Members


AgingTerm.TermDescription180Days Property

[image]

Pastel Evolution SDK
AgingTerm..::..TermDescription180Days Property
AgingTerm Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string TermDescription180Days { get; set; }
Visual Basic
Public Property TermDescription180Days As String
    Get
    Set

Property Value

Type: String

See Also

AgingTerm Class
AgingTerm Members


AgingTerm.TermDescription30Days Property

[image]

Pastel Evolution SDK
AgingTerm..::..TermDescription30Days Property
AgingTerm Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string TermDescription30Days { get; set; }
Visual Basic
Public Property TermDescription30Days As String
    Get
    Set

Property Value

Type: String

See Also

AgingTerm Class
AgingTerm Members


AgingTerm.TermDescription60Days Property

[image]

Pastel Evolution SDK
AgingTerm..::..TermDescription60Days Property
AgingTerm Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string TermDescription60Days { get; set; }
Visual Basic
Public Property TermDescription60Days As String
    Get
    Set

Property Value

Type: String

See Also

AgingTerm Class
AgingTerm Members


AgingTerm.TermDescription90Days Property

[image]

Pastel Evolution SDK
AgingTerm..::..TermDescription90Days Property
AgingTerm Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string TermDescription90Days { get; set; }
Visual Basic
Public Property TermDescription90Days As String
    Get
    Set

Property Value

Type: String

See Also

AgingTerm Class
AgingTerm Members


AgingTerm.TermDescriptionCurrent Property

[image]

Pastel Evolution SDK
AgingTerm..::..TermDescriptionCurrent Property
AgingTerm Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string TermDescriptionCurrent { get; set; }
Visual Basic
Public Property TermDescriptionCurrent As String
    Get
    Set

Property Value

Type: String

See Also

AgingTerm Class
AgingTerm Members


AgingTerm.TermDescriptionOption Property

[image]

Pastel Evolution SDK
AgingTerm..::..TermDescriptionOption Property
AgingTerm Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public AgingIntervalOption TermDescriptionOption { get; set; }
Visual Basic
Public Property TermDescriptionOption As AgingIntervalOption
    Get
    Set

Property Value

Type: AgingIntervalOption

See Also

AgingTerm Class
AgingTerm Members


AgingTerm.TermIntervalOption Property

[image]

Pastel Evolution SDK
AgingTerm..::..TermIntervalOption Property
AgingTerm Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public AgingIntervalOption TermIntervalOption { get; set; }
Visual Basic
Public Property TermIntervalOption As AgingIntervalOption
    Get
    Set

Property Value

Type: AgingIntervalOption

See Also

AgingTerm Class
AgingTerm Members


AgingTypeOption Enumeration

[image]

Pastel Evolution SDK
AgingTypeOption Enumeration
See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public enum AgingTypeOption
Visual Basic
Public Enumeration AgingTypeOption

Members

Member name | Value | Description
DateOfInvoice | 0 |
DateOfStatement | 1 |

See Also

Pastel.Evolution Namespace


AllocationCollection Class

[image]

Pastel Evolution SDK
AllocationCollection Class
Members See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class AllocationCollection : CollectionBase
Visual Basic
Public Class AllocationCollection
    Inherits CollectionBase

Inheritance Hierarchy

System..::..Object
System.Collections..::..CollectionBase
Pastel.Evolution..::..AllocationCollection

See Also

AllocationCollection Members


AllocationCollection Members

[image] [image]

Pastel Evolution SDK
AllocationCollection Members
AllocationCollection Class Methods Properties See Also Send Feedback

The AllocationCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add(AllocationEntry) | Adds a transaction to the allocation collection.
Public method | Add(DrCrTransaction) | Adds a transaction to the allocation collection, allocating the maximum value possible.
Public method | Add(DrCrTransaction, Double) | Adds a transaction to the allocation collection, allocating the value specified.
Public method | Add(DrCrTransaction, Double, DateTime, String, String) | Adds a transaction to the allocation collection, allocating the value specified.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | (Overrides CollectionBase..::..OnClear()()()().)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove(AllocationEntry) |
Public method | Remove(DrCrTransaction) |
Public method | RemoveAt |
Public method | Save | Saves the transaction's allocations back to the database, whilst also updating any referenced transactions.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item |
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | TotalAllocation | Gets the total allocated value of the collection.
Public property | TotalForeignAllocation | Gets the foreign total allocated value of the collection.

See Also

AllocationCollection Class


AllocationCollection Methods

[image] [image]

Pastel Evolution SDK
AllocationCollection Methods
AllocationCollection Class See Also Send Feedback

The AllocationCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add(AllocationEntry) | Adds a transaction to the allocation collection.
Public method | Add(DrCrTransaction) | Adds a transaction to the allocation collection, allocating the maximum value possible.
Public method | Add(DrCrTransaction, Double) | Adds a transaction to the allocation collection, allocating the value specified.
Public method | Add(DrCrTransaction, Double, DateTime, String, String) | Adds a transaction to the allocation collection, allocating the value specified.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | (Overrides CollectionBase..::..OnClear()()()().)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove(AllocationEntry) |
Public method | Remove(DrCrTransaction) |
Public method | RemoveAt |
Public method | Save | Saves the transaction's allocations back to the database, whilst also updating any referenced transactions.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AllocationCollection Class


AllocationCollection.Add Method

[image] [image]

Pastel Evolution SDK
AllocationCollection..::..Add Method
AllocationCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Add(AllocationEntry) | Adds a transaction to the allocation collection.
Public method | Add(DrCrTransaction) | Adds a transaction to the allocation collection, allocating the maximum value possible.
Public method | Add(DrCrTransaction, Double) | Adds a transaction to the allocation collection, allocating the value specified.
Public method | Add(DrCrTransaction, Double, DateTime, String, String) | Adds a transaction to the allocation collection, allocating the value specified.

See Also

AllocationCollection Class
AllocationCollection Members


AllocationCollection.Add Method (AllocationEntry)

[image]

Pastel Evolution SDK
AllocationCollection..::..Add Method (AllocationEntry)
AllocationCollection Class See Also Send Feedback
Adds a transaction to the allocation collection.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public AllocationEntry Add(
    AllocationEntry allocation
)
Visual Basic
Public Function Add (
    allocation As AllocationEntry
) As AllocationEntry

Parameters

allocation
Type: Pastel.Evolution..::..AllocationEntry
The allocation entry to add to the collection.

Return Value

Type: AllocationEntry

See Also

AllocationCollection Class
AllocationCollection Members
Add Overload


AllocationCollection.Add Method (DrCrTransaction)

[image]

Pastel Evolution SDK
AllocationCollection..::..Add Method (DrCrTransaction)
AllocationCollection Class See Also Send Feedback
Adds a transaction to the allocation collection, allocating the maximum value possible.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public AllocationEntry Add(
    DrCrTransaction transaction
)
Visual Basic
Public Function Add (
    transaction As DrCrTransaction
) As AllocationEntry

Parameters

transaction
Type: Pastel.Evolution..::..DrCrTransaction
The transaction to add to the collection.

Return Value

Type: AllocationEntry

Remarks

If the maximum allocable amount is zero, the standard exception will be raised.

See Also

AllocationCollection Class
AllocationCollection Members
Add Overload


AllocationCollection.Add Method (DrCrTransaction, Double)

[image]

Pastel Evolution SDK
AllocationCollection..::..Add Method (DrCrTransaction, Double)
AllocationCollection Class See Also Send Feedback
Adds a transaction to the allocation collection, allocating the value specified.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public AllocationEntry Add(
    DrCrTransaction transaction,
    double amount
)
Visual Basic
Public Function Add (
    transaction As DrCrTransaction,
    amount As Double
) As AllocationEntry

Parameters

transaction
Type: Pastel.Evolution..::..DrCrTransaction
The transaction to add to the collection.
amount
Type: System..::..Double
The allocation value (foreign currency value if foreign currencies are being allocated).

Return Value

Type: AllocationEntry

See Also

AllocationCollection Class
AllocationCollection Members
Add Overload


AllocationCollection.Add Method (DrCrTransaction, Double, DateTime, String, String)

[image]

Pastel Evolution SDK
AllocationCollection..::..Add Method (DrCrTransaction, Double, DateTime, String, String)
AllocationCollection Class See Also Send Feedback
Adds a transaction to the allocation collection, allocating the value specified.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public AllocationEntry Add(
    DrCrTransaction transaction,
    double amount,
    DateTime balancingDate,
    string balancingReference,
    string balancingDescription
)
Visual Basic
Public Function Add (
    transaction As DrCrTransaction,
    amount As Double,
    balancingDate As DateTime,
    balancingReference As String,
    balancingDescription As String
) As AllocationEntry

Parameters

transaction
Type: Pastel.Evolution..::..DrCrTransaction
The transaction to add to the collection.
amount
Type: System..::..Double
The allocation value (foreign currency value if foreign currencies are being allocated).
balancingDate
Type: System..::..DateTime
balancingReference
Type: System..::..String
balancingDescription
Type: System..::..String

Return Value

Type: AllocationEntry

See Also

AllocationCollection Class
AllocationCollection Members
Add Overload


AllocationCollection.OnClear Method

[image]

Pastel Evolution SDK
AllocationCollection..::..OnClear Method
AllocationCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected override void OnClear()
Visual Basic
Protected Overrides Sub OnClear

See Also

AllocationCollection Class
AllocationCollection Members


AllocationCollection.Remove Method

[image] [image]

Pastel Evolution SDK
AllocationCollection..::..Remove Method
AllocationCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Remove(AllocationEntry) |
Public method | Remove(DrCrTransaction) |

See Also

AllocationCollection Class
AllocationCollection Members


AllocationCollection.Remove Method (AllocationEntry)

[image]

Pastel Evolution SDK
AllocationCollection..::..Remove Method (AllocationEntry)
AllocationCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void Remove(
    AllocationEntry allocation
)
Visual Basic
Public Sub Remove (
    allocation As AllocationEntry
)

Parameters

allocation
Type: Pastel.Evolution..::..AllocationEntry

See Also

AllocationCollection Class
AllocationCollection Members
Remove Overload


AllocationCollection.Remove Method (DrCrTransaction)

[image]

Pastel Evolution SDK
AllocationCollection..::..Remove Method (DrCrTransaction)
AllocationCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void Remove(
    DrCrTransaction tran
)
Visual Basic
Public Sub Remove (
    tran As DrCrTransaction
)

Parameters

tran
Type: Pastel.Evolution..::..DrCrTransaction

See Also

AllocationCollection Class
AllocationCollection Members
Remove Overload


AllocationCollection.RemoveAt Method

[image]

Pastel Evolution SDK
AllocationCollection..::..RemoveAt Method
AllocationCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void RemoveAt(
    int index
)
Visual Basic
Public Sub RemoveAt (
    index As Integer
)

Parameters

index
Type: System..::..Int32

See Also

AllocationCollection Class
AllocationCollection Members


AllocationCollection.Save Method

[image]

Pastel Evolution SDK
AllocationCollection..::..Save Method
AllocationCollection Class See Also Send Feedback
Saves the transaction's allocations back to the database, whilst also updating any referenced transactions.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void Save()
Visual Basic
Public Sub Save

See Also

AllocationCollection Class
AllocationCollection Members


AllocationCollection Properties

[image] [image]

Pastel Evolution SDK
AllocationCollection Properties
AllocationCollection Class See Also Send Feedback

The AllocationCollection type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item |
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | TotalAllocation | Gets the total allocated value of the collection.
Public property | TotalForeignAllocation | Gets the foreign total allocated value of the collection.

See Also

AllocationCollection Class


AllocationCollection.Item Property

[image]

Pastel Evolution SDK
AllocationCollection..::..Item Property
AllocationCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public AllocationEntry this[
    int index
] { get; }
Visual Basic
Public ReadOnly Default Property Item (
    index As Integer
) As AllocationEntry
    Get

Parameters

index
Type: System..::..Int32

Property Value

Type: AllocationEntry

See Also

AllocationCollection Class
AllocationCollection Members


AllocationCollection.TotalAllocation Property

[image]

Pastel Evolution SDK
AllocationCollection..::..TotalAllocation Property
AllocationCollection Class See Also Send Feedback
Gets the total allocated value of the collection.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalAllocation { get; }
Visual Basic
Public ReadOnly Property TotalAllocation As Double
    Get

Property Value

Type: Double

See Also

AllocationCollection Class
AllocationCollection Members


AllocationCollection.TotalForeignAllocation Property

[image]

Pastel Evolution SDK
AllocationCollection..::..TotalForeignAllocation Property
AllocationCollection Class See Also Send Feedback
Gets the foreign total allocated value of the collection.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalForeignAllocation { get; }
Visual Basic
Public ReadOnly Property TotalForeignAllocation As Double
    Get

Property Value

Type: Double

See Also

AllocationCollection Class
AllocationCollection Members


AllocationEntry Class

[image]

Pastel Evolution SDK
AllocationEntry Class
Members See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class AllocationEntry
Visual Basic
Public Class AllocationEntry

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..AllocationEntry
Pastel.Evolution..::..TransactionBase..::..AllocationEntry

See Also

AllocationEntry Members


AllocationEntry Members

[image] [image]

Pastel Evolution SDK
AllocationEntry Members
AllocationEntry Class Constructors Methods Properties See Also Send Feedback

The AllocationEntry type exposes the following members.

Constructors

 | Name | Description
Public method | AllocationEntry()()()() | Initializes a new instance of the AllocationEntry class
Public method | AllocationEntry(DrCrTransaction, Double) | Initializes a new instance of the AllocationEntry class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AllowRemove |
Public property | Amount | Gets the allocation value.
Public property | BalancingDescription |
Public property | BalancingReference |
Public property | BalancingTransaction | Represents the balancing transaction linked to this allocation. After saving of allocations, it will exist on whichever transaction it relates to and not necessarily the current allocation collection.
Public property | BalancingTransactionID | Gets the ID of the balancing transaction.
Public property | Date | Gets the allocation date.
Public property | ForeignAmount | Gets the foreign allocation value.
Public property | Transaction | Gets the allocated transaction.
Public property | TransactionID | Gets the ID of the allocated transaction.

See Also

AllocationEntry Class


AllocationEntry Constructor

[image] [image]

Pastel Evolution SDK
AllocationEntry Constructor
AllocationEntry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AllocationEntry()()()() | Initializes a new instance of the AllocationEntry class
Public method | AllocationEntry(DrCrTransaction, Double) | Initializes a new instance of the AllocationEntry class

See Also

AllocationEntry Class
AllocationEntry Members


AllocationEntry Constructor

[image]

Pastel Evolution SDK
AllocationEntry Constructor
AllocationEntry Class See Also Send Feedback
Initializes a new instance of the AllocationEntry class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public AllocationEntry()
Visual Basic
Public Sub New

See Also

AllocationEntry Class
AllocationEntry Members
AllocationEntry Overload


AllocationEntry Constructor (DrCrTransaction, Double)

[image]

Pastel Evolution SDK
AllocationEntry Constructor (DrCrTransaction, Double)
AllocationEntry Class See Also Send Feedback
Initializes a new instance of the AllocationEntry class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public AllocationEntry(
    DrCrTransaction transaction,
    double amount
)
Visual Basic
Public Sub New (
    transaction As DrCrTransaction,
    amount As Double
)

Parameters

transaction
Type: Pastel.Evolution..::..DrCrTransaction
amount
Type: System..::..Double

See Also

AllocationEntry Class
AllocationEntry Members
AllocationEntry Overload


AllocationEntry Methods

[image] [image]

Pastel Evolution SDK
AllocationEntry Methods
AllocationEntry Class See Also Send Feedback

The AllocationEntry type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AllocationEntry Class


AllocationEntry Properties

[image] [image]

Pastel Evolution SDK
AllocationEntry Properties
AllocationEntry Class See Also Send Feedback

The AllocationEntry type exposes the following members.

Properties

 | Name | Description
Public property | AllowRemove |
Public property | Amount | Gets the allocation value.
Public property | BalancingDescription |
Public property | BalancingReference |
Public property | BalancingTransaction | Represents the balancing transaction linked to this allocation. After saving of allocations, it will exist on whichever transaction it relates to and not necessarily the current allocation collection.
Public property | BalancingTransactionID | Gets the ID of the balancing transaction.
Public property | Date | Gets the allocation date.
Public property | ForeignAmount | Gets the foreign allocation value.
Public property | Transaction | Gets the allocated transaction.
Public property | TransactionID | Gets the ID of the allocated transaction.

See Also

AllocationEntry Class


AllocationEntry.AllowRemove Property

[image]

Pastel Evolution SDK
AllocationEntry..::..AllowRemove Property
AllocationEntry Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool AllowRemove { get; internal set; }
Visual Basic
Public Property AllowRemove As Boolean
    Get
    Friend Set

Property Value

Type: Boolean

See Also

AllocationEntry Class
AllocationEntry Members


AllocationEntry.Amount Property

[image]

Pastel Evolution SDK
AllocationEntry..::..Amount Property
AllocationEntry Class See Also Send Feedback
Gets the allocation value.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double Amount { get; internal set; }
Visual Basic
Public Property Amount As Double
    Get
    Friend Set

Property Value

Type: Double

See Also

AllocationEntry Class
AllocationEntry Members


AllocationEntry.BalancingDescription Property

[image]

Pastel Evolution SDK
AllocationEntry..::..BalancingDescription Property
AllocationEntry Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string BalancingDescription { get; set; }
Visual Basic
Public Property BalancingDescription As String
    Get
    Set

Property Value

Type: String

See Also

AllocationEntry Class
AllocationEntry Members


AllocationEntry.BalancingReference Property

[image]

Pastel Evolution SDK
AllocationEntry..::..BalancingReference Property
AllocationEntry Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string BalancingReference { get; set; }
Visual Basic
Public Property BalancingReference As String
    Get
    Set

Property Value

Type: String

See Also

AllocationEntry Class
AllocationEntry Members


AllocationEntry.BalancingTransaction Property

[image]

Pastel Evolution SDK
AllocationEntry..::..BalancingTransaction Property
AllocationEntry Class See Also Send Feedback
Represents the balancing transaction linked to this allocation. After saving of allocations, it will exist on whichever transaction it relates to and not necessarily the current allocation collection.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DrCrTransaction BalancingTransaction { get; internal set; }
Visual Basic
Public Property BalancingTransaction As DrCrTransaction
    Get
    Friend Set

Property Value

Type: DrCrTransaction

See Also

AllocationEntry Class
AllocationEntry Members


AllocationEntry.BalancingTransactionID Property

[image]

Pastel Evolution SDK
AllocationEntry..::..BalancingTransactionID Property
AllocationEntry Class See Also Send Feedback
Gets the ID of the balancing transaction.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public long BalancingTransactionID { get; internal set; }
Visual Basic
Public Property BalancingTransactionID As Long
    Get
    Friend Set

Property Value

Type: Int64

See Also

AllocationEntry Class
AllocationEntry Members


AllocationEntry.Date Property

[image]

Pastel Evolution SDK
AllocationEntry..::..Date Property
AllocationEntry Class See Also Send Feedback
Gets the allocation date.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DateTime Date { get; internal set; }
Visual Basic
Public Property Date As DateTime
    Get
    Friend Set

Property Value

Type: DateTime

See Also

AllocationEntry Class
AllocationEntry Members


AllocationEntry.ForeignAmount Property

[image]

Pastel Evolution SDK
AllocationEntry..::..ForeignAmount Property
AllocationEntry Class See Also Send Feedback
Gets the foreign allocation value.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double ForeignAmount { get; internal set; }
Visual Basic
Public Property ForeignAmount As Double
    Get
    Friend Set

Property Value

Type: Double

See Also

AllocationEntry Class
AllocationEntry Members


AllocationEntry.Transaction Property

[image]

Pastel Evolution SDK
AllocationEntry..::..Transaction Property
AllocationEntry Class See Also Send Feedback
Gets the allocated transaction.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DrCrTransaction Transaction { get; internal set; }
Visual Basic
Public Property Transaction As DrCrTransaction
    Get
    Friend Set

Property Value

Type: DrCrTransaction

See Also

AllocationEntry Class
AllocationEntry Members


AllocationEntry.TransactionID Property

[image]

Pastel Evolution SDK
AllocationEntry..::..TransactionID Property
AllocationEntry Class See Also Send Feedback
Gets the ID of the allocated transaction.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public long TransactionID { get; internal set; }
Visual Basic
Public Property TransactionID As Long
    Get
    Friend Set

Property Value

Type: Int64

See Also

AllocationEntry Class
AllocationEntry Members


Area Class

[image]

Pastel Evolution SDK
Area Class
Members See Also Send Feedback
Represents a geographical area to which accounts can be linked.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class Area : BranchedRecordBase
Visual Basic
Public Class Area
    Inherits BranchedRecordBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..Area

See Also

Area Members


Area Members

[image] [image]

Pastel Evolution SDK
Area Members
Area Class Constructors Methods Fields Properties See Also Send Feedback

The Area type exposes the following members.

Constructors

 | Name | Description
Public method | Area()()()() | Creates a new instance of the Area class.
Public method | Area(Int32) | Creates a new instance of an existing Area record.
Public method | Area(String) | Creates a new instance of the Area class.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds the ID of an existing area.
 | FindByCode |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | List | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Code |
Public property | Description | Gets or sets the area description.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)

See Also

Area Class


Area Constructor

[image] [image]

Pastel Evolution SDK
Area Constructor
Area Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Area()()()() | Creates a new instance of the Area class.
Public method | Area(Int32) | Creates a new instance of an existing Area record.
Public method | Area(String) | Creates a new instance of the Area class.

See Also

Area Class
Area Members


Area Constructor

[image]

Pastel Evolution SDK
Area Constructor
Area Class See Also Send Feedback
Creates a new instance of the Area class.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Area()
Visual Basic
Public Sub New

See Also

Area Class
Area Members
Area Overload


Area Constructor (Int32)

[image]

Pastel Evolution SDK
Area Constructor (Int32)
Area Class See Also Send Feedback
Creates a new instance of an existing Area record.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Area(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32
The ID of the existing Area.

Exceptions

Exception | Condition
Pastel.Evolution..::..EvolutionException | Specified ID does not exist in the database.

See Also

Area Class
Area Members
Area Overload


Area Constructor (String)

[image]

Pastel Evolution SDK
Area Constructor (String)
Area Class See Also Send Feedback
Creates a new instance of the Area class.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Area(
    string code
)
Visual Basic
Public Sub New (
    code As String
)

Parameters

code
Type: System..::..String
Specifies the area code.

See Also

Area Class
Area Members
Area Overload


Area Fields

[image] [image]

Pastel Evolution SDK
Area Fields
Area Class See Also Send Feedback

The Area type exposes the following members.

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

Area Class


Area Methods

[image] [image]

Pastel Evolution SDK
Area Methods
Area Class See Also Send Feedback

The Area type exposes the following members.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds the ID of an existing area.
 | FindByCode |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | List | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

Area Class


Area.Find Method

[image]

Pastel Evolution SDK
Area..::..Find Method
Area Class See Also Send Feedback
Finds the ID of an existing area.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.

Return Value

Type: Int32
The ID of the first record found; -1 if not record was found.

See Also

Area Class
Area Members


Area.FindByCode Method

[image]

Pastel Evolution SDK
Area..::..FindByCode Method
Area Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int FindByCode(
    string code
)
Visual Basic
Public Shared Function FindByCode (
    code As String
) As Integer

Parameters

code
Type: System..::..String

Return Value

Type: Int32

See Also

Area Class
Area Members


Area.List Method

[image]

Pastel Evolution SDK
Area..::..List Method
Area Class See Also Send Feedback
Gets a list of database records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DataTable List(
    string criteria
)
Visual Basic
Public Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.

Return Value

Type: DataTable
Table containing selected records.

See Also

Area Class
Area Members


Area.OnDelete Method

[image]

Pastel Evolution SDK
Area..::..OnDelete Method
Area Class See Also Send Feedback
Removes the record from the database, provided it is not referenced by other records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

Exceptions

Exception | Condition
IntegrityViolationException |

See Also

Area Class
Area Members


Area.OnSave Method

[image]

Pastel Evolution SDK
Area..::..OnSave Method
Area Class See Also Send Feedback
Persists the record to the database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

Area Class
Area Members


Area Properties

[image] [image]

Pastel Evolution SDK
Area Properties
Area Class See Also Send Feedback

The Area type exposes the following members.

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Code |
Public property | Description | Gets or sets the area description.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)

See Also

Area Class


Area.Code Property

[image]

Pastel Evolution SDK
Area..::..Code Property
Area Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Code { get; set; }
Visual Basic
Public Property Code As String
    Get
    Set

Property Value

Type: String

See Also

Area Class
Area Members


Area.Description Property

[image]

Pastel Evolution SDK
Area..::..Description Property
Area Class See Also Send Feedback
Gets or sets the area description.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set

Property Value

Type: String

See Also

Area Class
Area Members


Area.ID Property

[image]

Pastel Evolution SDK
Area..::..ID Property
Area Class See Also Send Feedback
Gets the internal record ID (0 for new, unsaved records).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

See Also

Area Class
Area Members


Area.LongID Property

[image]

Pastel Evolution SDK
Area..::..LongID Property
Area Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

Area Class
Area Members


AutoPaymentMethod Enumeration

[image]

Pastel Evolution SDK
AutoPaymentMethod Enumeration
See Also Send Feedback
Describes the automatic payment method available to supplier accounts.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public enum AutoPaymentMethod
Visual Basic
Public Enumeration AutoPaymentMethod

Members

Member name | Value | Description
EFT | 0 |
Cheque | 1 |

See Also

Pastel.Evolution Namespace


Bank Class

[image]

Pastel Evolution SDK
Bank Class
Members See Also Send Feedback
Represents a bank record.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class Bank : BranchedRecordBase
Visual Basic
Public Class Bank
    Inherits BranchedRecordBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..Bank

See Also

Bank Members


Bank Members

[image] [image]

Pastel Evolution SDK
Bank Members
Bank Class Constructors Methods Fields Properties See Also Send Feedback

The Bank type exposes the following members.

Constructors

 | Name | Description
Public method | Bank()()()() | Creates a new instance of the Bank class.
Public method | Bank(Int32) | Creates a new instance of the Bank class.
Public method | Bank(String) | Creates a new instance of the Bank class.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Returns the id of the first record found matching the criteria. Eg. BankName = 'abc'
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | Active | Gets or sets the bank's state.
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchCode | Gets or sets the branch code.
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | Name | Gets or sets the bank name.

See Also

Bank Class


Bank Constructor

[image] [image]

Pastel Evolution SDK
Bank Constructor
Bank Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Bank()()()() | Creates a new instance of the Bank class.
Public method | Bank(Int32) | Creates a new instance of the Bank class.
Public method | Bank(String) | Creates a new instance of the Bank class.

See Also

Bank Class
Bank Members


Bank Constructor

[image]

Pastel Evolution SDK
Bank Constructor
Bank Class See Also Send Feedback
Creates a new instance of the Bank class.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Bank()
Visual Basic
Public Sub New

See Also

Bank Class
Bank Members
Bank Overload


Bank Constructor (Int32)

[image]

Pastel Evolution SDK
Bank Constructor (Int32)
Bank Class See Also Send Feedback
Creates a new instance of the Bank class.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Bank(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32
Specifies the id.

See Also

Bank Class
Bank Members
Bank Overload


Bank Constructor (String)

[image]

Pastel Evolution SDK
Bank Constructor (String)
Bank Class See Also Send Feedback
Creates a new instance of the Bank class.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Bank(
    string code
)
Visual Basic
Public Sub New (
    code As String
)

Parameters

code
Type: System..::..String
Specifies the code.

See Also

Bank Class
Bank Members
Bank Overload


Bank Fields

[image] [image]

Pastel Evolution SDK
Bank Fields
Bank Class See Also Send Feedback

The Bank type exposes the following members.

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

Bank Class


Bank Methods

[image] [image]

Pastel Evolution SDK
Bank Methods
Bank Class See Also Send Feedback

The Bank type exposes the following members.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Returns the id of the first record found matching the criteria. Eg. BankName = 'abc'
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

Bank Class


Bank.Find Method

[image]

Pastel Evolution SDK
Bank..::..Find Method
Bank Class See Also Send Feedback
Returns the id of the first record found matching the criteria. Eg. BankName = 'abc'

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String

Return Value

Type: Int32
ID of the record found; if not found, -1

See Also

Bank Class
Bank Members


Bank.List Method

[image]

Pastel Evolution SDK
Bank..::..List Method
Bank Class See Also Send Feedback
Gets a list of database records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria
)
Visual Basic
Public Shared Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String
Specifies the criteria in SQL format.

Return Value

Type: DataTable
Table containing selected records.

See Also

Bank Class
Bank Members


Bank.OnDelete Method

[image]

Pastel Evolution SDK
Bank..::..OnDelete Method
Bank Class See Also Send Feedback
Removes the record from the database, provided it is not referenced by other records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

Exceptions

Exception | Condition
IntegrityViolationException |

See Also

Bank Class
Bank Members


Bank.OnSave Method

[image]

Pastel Evolution SDK
Bank..::..OnSave Method
Bank Class See Also Send Feedback
Persists the record to the database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

Bank Class
Bank Members


Bank Properties

[image] [image]

Pastel Evolution SDK
Bank Properties
Bank Class See Also Send Feedback

The Bank type exposes the following members.

Properties

 | Name | Description
Public property | Active | Gets or sets the bank's state.
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchCode | Gets or sets the branch code.
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | Name | Gets or sets the bank name.

See Also

Bank Class


Bank.Active Property

[image]

Pastel Evolution SDK
Bank..::..Active Property
Bank Class See Also Send Feedback
Gets or sets the bank's state.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool Active { get; set; }
Visual Basic
Public Property Active As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

Bank Class
Bank Members


Bank.BranchCode Property

[image]

Pastel Evolution SDK
Bank..::..BranchCode Property
Bank Class See Also Send Feedback
Gets or sets the branch code.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string BranchCode { get; set; }
Visual Basic
Public Property BranchCode As String
    Get
    Set

Property Value

Type: String

See Also

Bank Class
Bank Members


Bank.ID Property

[image]

Pastel Evolution SDK
Bank..::..ID Property
Bank Class See Also Send Feedback
Gets the internal record ID (0 for new, unsaved records).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

See Also

Bank Class
Bank Members


Bank.LongID Property

[image]

Pastel Evolution SDK
Bank..::..LongID Property
Bank Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

Bank Class
Bank Members


Bank.Name Property

[image]

Pastel Evolution SDK
Bank..::..Name Property
Bank Class See Also Send Feedback
Gets or sets the bank name.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

Property Value

Type: String

See Also

Bank Class
Bank Members


Bank.AccountType Enumeration

[image]

Pastel Evolution SDK
Bank..::..AccountType Enumeration
Bank Class See Also Send Feedback
Describes a bank account type.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public enum AccountType
Visual Basic
Public Enumeration AccountType

Members

Member name | Value | Description
None | 0 |
CurrentCheque | 1 |
Savings | 2 |
Transmission | 3 |
Bond | 4 |
SubShareABSA | 5 |
SubShareFNB | 6 |
CreditCard | 7 |
Wesbank | 8 |

See Also

Pastel.Evolution Namespace


Branch Class

[image]

Pastel Evolution SDK
Branch Class
Members See Also Send Feedback
Represents a bank record.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class Branch : RecordBase
Visual Basic
Public Class Branch
    Inherits RecordBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..Branch

See Also

Branch Members


Branch Members

[image] [image]

Pastel Evolution SDK
Branch Members
Branch Class Constructors Methods Fields Properties See Also Send Feedback

The Branch type exposes the following members.

Constructors

 | Name | Description
Public method | Branch()()()() | Initializes a new instance of the Branch class
Public method | Branch(Int32) | Creates a new instance of the Branch class.
Public method | Branch(String) | Initializes a new instance of the Branch class

Methods

 | Name | Description
 | _Select(String) | Experimental Method
 | _Select(String, String, Boolean) |
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Returns the id of the first record found matching specified criteria. Eg. cBranchDescription = 'abc'
 | FindByCode |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List(String) | Returns a System.Data.DataTable object containing the database records from the Client table matching the supplied criteria.
 | List(String, String) | Returns a System.Data.DataTable object containing the database records from the Client table matching the supplied criteria.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

Fields

 | Name | Description
 | GLOBAL_BRANCH_ID |
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | Active | Gets or sets the bank's state.
Public property | Code | Gets or sets the branch code.
Public property | Description | Gets or sets the bank name.
 | Global |
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | IsGlobal |
Public property | LongID | (Overrides RecordBase..::..LongID.)

See Also

Branch Class


Branch Constructor

[image] [image]

Pastel Evolution SDK
Branch Constructor
Branch Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Branch()()()() | Initializes a new instance of the Branch class
Public method | Branch(Int32) | Creates a new instance of the Branch class.
Public method | Branch(String) | Initializes a new instance of the Branch class

See Also

Branch Class
Branch Members


Branch Constructor

[image]

Pastel Evolution SDK
Branch Constructor
Branch Class See Also Send Feedback
Initializes a new instance of the Branch class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Branch()
Visual Basic
Public Sub New

See Also

Branch Class
Branch Members
Branch Overload


Branch Constructor (Int32)

[image]

Pastel Evolution SDK
Branch Constructor (Int32)
Branch Class See Also Send Feedback
Creates a new instance of the Branch class.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Branch(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32
Specifies the id.

See Also

Branch Class
Branch Members
Branch Overload


Branch Constructor (String)

[image]

Pastel Evolution SDK
Branch Constructor (String)
Branch Class See Also Send Feedback
Initializes a new instance of the Branch class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Branch(
    string code
)
Visual Basic
Public Sub New (
    code As String
)

Parameters

code
Type: System..::..String

See Also

Branch Class
Branch Members
Branch Overload


Branch Fields

[image] [image]

Pastel Evolution SDK
Branch Fields
Branch Class See Also Send Feedback

The Branch type exposes the following members.

Fields

 | Name | Description
 | GLOBAL_BRANCH_ID |
Protected field | wrapper | (Inherited from RecordBase.)

See Also

Branch Class


Branch.GLOBAL_BRANCH_ID Field

[image]

Pastel Evolution SDK
Branch..::..GLOBAL_BRANCH_ID Field
Branch Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public const int GLOBAL_BRANCH_ID
Visual Basic
Public Const GLOBAL_BRANCH_ID As Integer

Field Value

Type: Int32

See Also

Branch Class
Branch Members


Branch Methods

[image] [image]

Pastel Evolution SDK
Branch Methods
Branch Class See Also Send Feedback

The Branch type exposes the following members.

Methods

 | Name | Description
 | _Select(String) | Experimental Method
 | _Select(String, String, Boolean) |
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Returns the id of the first record found matching specified criteria. Eg. cBranchDescription = 'abc'
 | FindByCode |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List(String) | Returns a System.Data.DataTable object containing the database records from the Client table matching the supplied criteria.
 | List(String, String) | Returns a System.Data.DataTable object containing the database records from the Client table matching the supplied criteria.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

Branch Class


Branch._Select Method

[image] [image]

Pastel Evolution SDK
Branch..::.._Select Method
Branch Class See Also Send Feedback

Overload List

Name | Description
_Select(String) | Experimental Method
_Select(String, String, Boolean) |

See Also

Branch Class
Branch Members


Branch._Select Method (String)

[image]

Pastel Evolution SDK
Branch..::.._Select Method (String)
Branch Class See Also Send Feedback
Experimental Method

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static Branch[] _Select(
    string criteria
)
Visual Basic
Public Shared Function _Select (
    criteria As String
) As Branch()

Parameters

criteria
Type: System..::..String

Return Value

Type: array< Branch >[]()[][]

See Also

Branch Class
Branch Members
_Select Overload


Branch._Select Method (String, String, Boolean)

[image]

Pastel Evolution SDK
Branch..::.._Select Method (String, String, Boolean)
Branch Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static Branch[] _Select(
    string criteria,
    string sortOrder,
    bool includeGlobal
)
Visual Basic
Public Shared Function _Select (
    criteria As String,
    sortOrder As String,
    includeGlobal As Boolean
) As Branch()

Parameters

criteria
Type: System..::..String
sortOrder
Type: System..::..String
includeGlobal
Type: System..::..Boolean

Return Value

Type: array< Branch >[]()[][]

See Also

Branch Class
Branch Members
_Select Overload


Branch.Find Method

[image]

Pastel Evolution SDK
Branch..::..Find Method
Branch Class See Also Send Feedback
Returns the id of the first record found matching specified criteria. Eg. cBranchDescription = 'abc'

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String

Return Value

Type: Int32
ID of the record found; if not found, -1

See Also

Branch Class
Branch Members


Branch.FindByCode Method

[image]

Pastel Evolution SDK
Branch..::..FindByCode Method
Branch Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int FindByCode(
    string code
)
Visual Basic
Public Shared Function FindByCode (
    code As String
) As Integer

Parameters

code
Type: System..::..String

Return Value

Type: Int32

See Also

Branch Class
Branch Members


Branch.List Method

[image] [image]

Pastel Evolution SDK
Branch..::..List Method
Branch Class See Also Send Feedback

Overload List

Name | Description
List(String) | Returns a System.Data.DataTable object containing the database records from the Client table matching the supplied criteria.
List(String, String) | Returns a System.Data.DataTable object containing the database records from the Client table matching the supplied criteria.

See Also

Branch Class
Branch Members


Branch.List Method (String)

[image]

Pastel Evolution SDK
Branch..::..List Method (String)
Branch Class See Also Send Feedback
Returns a System.Data.DataTable object containing the database records from the Client table matching the supplied criteria.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria
)
Visual Basic
Public Shared Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String
The SQL criteria used to locate the record, e.g. Account like '1___'

Return Value

Type: DataTable
A System.Data.DataTable object containing matching records.

Remarks

The criteria is passed to an SQL query so use the appropriate syntax. Remember to includethe single quotes around string literals and append additional criteria with and.

See Also

Branch Class
Branch Members
List Overload


Branch.List Method (String, String)

[image]

Pastel Evolution SDK
Branch..::..List Method (String, String)
Branch Class See Also Send Feedback
Returns a System.Data.DataTable object containing the database records from the Client table matching the supplied criteria.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria,
    string sortOrder
)
Visual Basic
Public Shared Function List (
    criteria As String,
    sortOrder As String
) As DataTable

Parameters

criteria
Type: System..::..String
The SQL criteria used to locate the record, e.g. Account like '1___'
sortOrder
Type: System..::..String
The SQL order by clause to use, e.g. DCBalance desc, Account

Return Value

Type: DataTable
A System.Data.DataTable object containing matching records.

Remarks

The criteria is passed to an SQL query so use the appropriate syntax. Remember to includethe single quotes around string literals and append additional criteria with and.

See Also

Branch Class
Branch Members
List Overload


Branch.OnDelete Method

[image]

Pastel Evolution SDK
Branch..::..OnDelete Method
Branch Class See Also Send Feedback
Removes the record from the database, provided it is not referenced by other records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

Exceptions

Exception | Condition
IntegrityViolationException |

See Also

Branch Class
Branch Members


Branch.OnSave Method

[image]

Pastel Evolution SDK
Branch..::..OnSave Method
Branch Class See Also Send Feedback
Persists the record to the database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

Branch Class
Branch Members


Branch.ToString Method

[image]

Pastel Evolution SDK
Branch..::..ToString Method
Branch Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String

See Also

Branch Class
Branch Members


Branch Properties

[image] [image]

Pastel Evolution SDK
Branch Properties
Branch Class See Also Send Feedback

The Branch type exposes the following members.

Properties

 | Name | Description
Public property | Active | Gets or sets the bank's state.
Public property | Code | Gets or sets the branch code.
Public property | Description | Gets or sets the bank name.
 | Global |
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | IsGlobal |
Public property | LongID | (Overrides RecordBase..::..LongID.)

See Also

Branch Class


Branch.Active Property

[image]

Pastel Evolution SDK
Branch..::..Active Property
Branch Class See Also Send Feedback
Gets or sets the bank's state.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool Active { get; set; }
Visual Basic
Public Property Active As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

Branch Class
Branch Members


Branch.Code Property

[image]

Pastel Evolution SDK
Branch..::..Code Property
Branch Class See Also Send Feedback
Gets or sets the branch code.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Code { get; set; }
Visual Basic
Public Property Code As String
    Get
    Set

Property Value

Type: String

See Also

Branch Class
Branch Members


Branch.Description Property

[image]

Pastel Evolution SDK
Branch..::..Description Property
Branch Class See Also Send Feedback
Gets or sets the bank name.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set

Property Value

Type: String

See Also

Branch Class
Branch Members


Branch.Global Property

[image]

Pastel Evolution SDK
Branch..::..Global Property
Branch Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static Branch Global { get; internal set; }
Visual Basic
Public Shared Property Global As Branch
    Get
    Friend Set

Property Value

Type: Branch

See Also

Branch Class
Branch Members


Branch.ID Property

[image]

Pastel Evolution SDK
Branch..::..ID Property
Branch Class See Also Send Feedback
Gets the internal record ID (0 for new, unsaved records).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

See Also

Branch Class
Branch Members


Branch.IsGlobal Property

[image]

Pastel Evolution SDK
Branch..::..IsGlobal Property
Branch Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool IsGlobal { get; private set; }
Visual Basic
Public Property IsGlobal As Boolean
    Get
    Private Set

Property Value

Type: Boolean

See Also

Branch Class
Branch Members


Branch.LongID Property

[image]

Pastel Evolution SDK
Branch..::..LongID Property
Branch Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

Branch Class
Branch Members


BranchedRecordBase Class

[image]

Pastel Evolution SDK
BranchedRecordBase Class
Members See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract class BranchedRecordBase : RecordBase,
    IBranched
Visual Basic
Public MustInherit Class BranchedRecordBase
    Inherits RecordBase
    Implements IBranched

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..AccountBase
Pastel.Evolution..::..Agent
Pastel.Evolution..::..AgentGroup
Pastel.Evolution..::..AgingTerm
Pastel.Evolution..::..Area
Pastel.Evolution..::..Bank
Pastel.Evolution..::..BusinessClass
Pastel.Evolution..::..BusinessType
Pastel.Evolution..::..CashbookBatch
Pastel.Evolution..::..CashbookBatchDetail
Pastel.Evolution..::..Competitor
Pastel.Evolution..::..Contract
Pastel.Evolution..::..CostAllocation
Pastel.Evolution..::..Country
Pastel.Evolution..::..Currency
Pastel.Evolution..::..CustomerGroup
Pastel.Evolution..::..DeliveryAddress
Pastel.Evolution..::..DeliveryAddressCode
Pastel.Evolution..::..DeliveryMethod
Pastel.Evolution..::..Department
Pastel.Evolution..::..Designation
Pastel.Evolution..::..Document
Pastel.Evolution..::..DocumentCategory
Pastel.Evolution..::..EscalationGroup
Pastel.Evolution..::..ExchangeRate
Pastel.Evolution..::..IncidentCategory
Pastel.Evolution..::..IncidentType
Pastel.Evolution..::..InventoryBin
Pastel.Evolution..::..InventoryGroup
Pastel.Evolution..::..JournalBatch
Pastel.Evolution..::..JournalBatchDetail
Pastel.Evolution..::..Lot
Pastel.Evolution..::..LotStatus
Pastel.Evolution..::..NatureOfTransaction
Pastel.Evolution..::..Opportunity
Pastel.Evolution..::..OpportunityStage
Pastel.Evolution..::..OpportunityState
Pastel.Evolution..::..OrderBase
Pastel.Evolution..::..OrderDetail
Pastel.Evolution..::..OrderStatus
Pastel.Evolution..::..PackCode
Pastel.Evolution..::..Person
Pastel.Evolution..::..PostDatedCheque
Pastel.Evolution..::..PriceList
Pastel.Evolution..::..PrintGroup
Pastel.Evolution..::..Priority
Pastel.Evolution..::..Project
Pastel.Evolution..::..Prospect
Pastel.Evolution..::..SalesRepresentative
Pastel.Evolution..::..SerialNumber
Pastel.Evolution..::..SettlementTerms
Pastel.Evolution..::..SupplierGroup
Pastel.Evolution..::..TaxRate
Pastel.Evolution..::..TransactionCodeBase
Pastel.Evolution..::..Unit
Pastel.Evolution..::..UnitCategory
Pastel.Evolution..::..UnitConversion
Pastel.Evolution..::..WarehouseContext

See Also

BranchedRecordBase Members


BranchedRecordBase Members

[image] [image]

Pastel Evolution SDK
BranchedRecordBase Members
BranchedRecordBase Class Constructors Methods Fields Properties See Also Send Feedback

The BranchedRecordBase type exposes the following members.

Constructors

 | Name | Description
Protected method | BranchedRecordBase | Initializes a new instance of the BranchedRecordBase class

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | (Inherited from RecordBase.)
Protected method | OnSave | (Inherited from RecordBase.)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation |
Protected method | ValidateSetBranch |

Fields

 | Name | Description
Protected field | branch |
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | Branch |
Public property | BranchID | Gets the record's branch ID.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Inherited from RecordBase.)
Public property | LongID | Gets the internal record ID (0 for new, unsaved records). (Inherited from RecordBase.)

See Also

BranchedRecordBase Class


BranchedRecordBase Constructor

[image]

Pastel Evolution SDK
BranchedRecordBase Constructor
BranchedRecordBase Class See Also Send Feedback
Initializes a new instance of the BranchedRecordBase class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected BranchedRecordBase()
Visual Basic
Protected Sub New

See Also

BranchedRecordBase Class
BranchedRecordBase Members


BranchedRecordBase Fields

[image] [image]

Pastel Evolution SDK
BranchedRecordBase Fields
BranchedRecordBase Class See Also Send Feedback

The BranchedRecordBase type exposes the following members.

Fields

 | Name | Description
Protected field | branch |
Protected field | wrapper | (Inherited from RecordBase.)

See Also

BranchedRecordBase Class


BranchedRecordBase.branch Field

[image]

Pastel Evolution SDK
BranchedRecordBase..::..branch Field
BranchedRecordBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected Branch branch
Visual Basic
Protected branch As Branch

Field Value

Type: Branch

See Also

BranchedRecordBase Class
BranchedRecordBase Members


BranchedRecordBase Methods

[image] [image]

Pastel Evolution SDK
BranchedRecordBase Methods
BranchedRecordBase Class See Also Send Feedback

The BranchedRecordBase type exposes the following members.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | (Inherited from RecordBase.)
Protected method | OnSave | (Inherited from RecordBase.)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation |
Protected method | ValidateSetBranch |

See Also

BranchedRecordBase Class


BranchedRecordBase.ValidateBranchRelation Method

[image]

Pastel Evolution SDK
BranchedRecordBase..::..ValidateBranchRelation Method
BranchedRecordBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected void ValidateBranchRelation(
    BranchedRecordBase category
)
Visual Basic
Protected Sub ValidateBranchRelation (
    category As BranchedRecordBase
)

Parameters

category
Type: Pastel.Evolution..::..BranchedRecordBase

See Also

BranchedRecordBase Class
BranchedRecordBase Members


BranchedRecordBase.ValidateSetBranch Method

[image]

Pastel Evolution SDK
BranchedRecordBase..::..ValidateSetBranch Method
BranchedRecordBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected void ValidateSetBranch(
    Branch value
)
Visual Basic
Protected Sub ValidateSetBranch (
    value As Branch
)

Parameters

value
Type: Pastel.Evolution..::..Branch

See Also

BranchedRecordBase Class
BranchedRecordBase Members


BranchedRecordBase Properties

[image] [image]

Pastel Evolution SDK
BranchedRecordBase Properties
BranchedRecordBase Class See Also Send Feedback

The BranchedRecordBase type exposes the following members.

Properties

 | Name | Description
Public property | Branch |
Public property | BranchID | Gets the record's branch ID.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Inherited from RecordBase.)
Public property | LongID | Gets the internal record ID (0 for new, unsaved records). (Inherited from RecordBase.)

See Also

BranchedRecordBase Class


BranchedRecordBase.Branch Property

[image]

Pastel Evolution SDK
BranchedRecordBase..::..Branch Property
BranchedRecordBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Branch Branch { get; set; }
Visual Basic
Public Property Branch As Branch
    Get
    Set

Property Value

Type: Branch

Implements

IBranched..::..Branch

See Also

BranchedRecordBase Class
BranchedRecordBase Members


BranchedRecordBase.BranchID Property

[image]

Pastel Evolution SDK
BranchedRecordBase..::..BranchID Property
BranchedRecordBase Class See Also Send Feedback
Gets the record's branch ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int BranchID { get; set; }
Visual Basic
Public Property BranchID As Integer
    Get
    Set

Property Value

Type: Int32

Implements

IBranched..::..BranchID

See Also

BranchedRecordBase Class
BranchedRecordBase Members


BusinessClass Class

[image]

Pastel Evolution SDK
BusinessClass Class
Members See Also Send Feedback
Represents a business classification which can be assigned to accounts.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class BusinessClass : BranchedRecordBase
Visual Basic
Public Class BusinessClass
    Inherits BranchedRecordBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..BusinessClass

See Also

BusinessClass Members


BusinessClass Members

[image] [image]

Pastel Evolution SDK
BusinessClass Members
BusinessClass Class Constructors Methods Fields Properties See Also Send Feedback

The BusinessClass type exposes the following members.

Constructors

 | Name | Description
Public method | BusinessClass()()()() | Creates a new instance of a business category.
Public method | BusinessClass(Int32) | Creates a new instance of a business category.
Public method | BusinessClass(String) | Creates a new instance of a business category.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds a record's database ID.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | List | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | Type | Gets or sets the business class' type.

See Also

BusinessClass Class


BusinessClass Constructor

[image] [image]

Pastel Evolution SDK
BusinessClass Constructor
BusinessClass Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BusinessClass()()()() | Creates a new instance of a business category.
Public method | BusinessClass(Int32) | Creates a new instance of a business category.
Public method | BusinessClass(String) | Creates a new instance of a business category.

See Also

BusinessClass Class
BusinessClass Members


BusinessClass Constructor

[image]

Pastel Evolution SDK
BusinessClass Constructor
BusinessClass Class See Also Send Feedback
Creates a new instance of a business category.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public BusinessClass()
Visual Basic
Public Sub New

See Also

BusinessClass Class
BusinessClass Members
BusinessClass Overload


BusinessClass Constructor (Int32)

[image]

Pastel Evolution SDK
BusinessClass Constructor (Int32)
BusinessClass Class See Also Send Feedback
Creates a new instance of a business category.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public BusinessClass(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32
The database ID of the existing record.

See Also

BusinessClass Class
BusinessClass Members
BusinessClass Overload


BusinessClass Constructor (String)

[image]

Pastel Evolution SDK
BusinessClass Constructor (String)
BusinessClass Class See Also Send Feedback
Creates a new instance of a business category.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public BusinessClass(
    string name
)
Visual Basic
Public Sub New (
    name As String
)

Parameters

name
Type: System..::..String
The business category name of the existing record.

See Also

BusinessClass Class
BusinessClass Members
BusinessClass Overload


BusinessClass Fields

[image] [image]

Pastel Evolution SDK
BusinessClass Fields
BusinessClass Class See Also Send Feedback

The BusinessClass type exposes the following members.

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

BusinessClass Class


BusinessClass Methods

[image] [image]

Pastel Evolution SDK
BusinessClass Methods
BusinessClass Class See Also Send Feedback

The BusinessClass type exposes the following members.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds a record's database ID.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | List | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

BusinessClass Class


BusinessClass.Find Method

[image]

Pastel Evolution SDK
BusinessClass..::..Find Method
BusinessClass Class See Also Send Feedback
Finds a record's database ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.

Return Value

Type: Int32
The ID of the first record found; -1 if not record was found.

See Also

BusinessClass Class
BusinessClass Members


BusinessClass.List Method

[image]

Pastel Evolution SDK
BusinessClass..::..List Method
BusinessClass Class See Also Send Feedback
Gets a list of database records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DataTable List(
    string criteria
)
Visual Basic
Public Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String
Specifies the SQL criteria.

Return Value

Type: DataTable
Table containing selected records.

See Also

BusinessClass Class
BusinessClass Members


BusinessClass.OnDelete Method

[image]

Pastel Evolution SDK
BusinessClass..::..OnDelete Method
BusinessClass Class See Also Send Feedback
Removes the record from the database, provided it is not referenced by other records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

Exceptions

Exception | Condition
IntegrityViolationException |

See Also

BusinessClass Class
BusinessClass Members


BusinessClass.OnSave Method

[image]

Pastel Evolution SDK
BusinessClass..::..OnSave Method
BusinessClass Class See Also Send Feedback
Persists the record to the database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

BusinessClass Class
BusinessClass Members


BusinessClass Properties

[image] [image]

Pastel Evolution SDK
BusinessClass Properties
BusinessClass Class See Also Send Feedback

The BusinessClass type exposes the following members.

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | Type | Gets or sets the business class' type.

See Also

BusinessClass Class


BusinessClass.ID Property

[image]

Pastel Evolution SDK
BusinessClass..::..ID Property
BusinessClass Class See Also Send Feedback
Gets the internal record ID (0 for new, unsaved records).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

See Also

BusinessClass Class
BusinessClass Members


BusinessClass.LongID Property

[image]

Pastel Evolution SDK
BusinessClass..::..LongID Property
BusinessClass Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

BusinessClass Class
BusinessClass Members


BusinessClass.Type Property

[image]

Pastel Evolution SDK
BusinessClass..::..Type Property
BusinessClass Class See Also Send Feedback
Gets or sets the business class' type.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Type { get; set; }
Visual Basic
Public Property Type As String
    Get
    Set

Property Value

Type: String

See Also

BusinessClass Class
BusinessClass Members


BusinessType Class

[image]

Pastel Evolution SDK
BusinessType Class
Members See Also Send Feedback
Represents a business/industry type which can be assigned to accounts.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class BusinessType : BranchedRecordBase
Visual Basic
Public Class BusinessType
    Inherits BranchedRecordBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..BusinessType

See Also

BusinessType Members


BusinessType Members

[image] [image]

Pastel Evolution SDK
BusinessType Members
BusinessType Class Constructors Methods Fields Properties See Also Send Feedback

The BusinessType type exposes the following members.

Constructors

 | Name | Description
Public method | BusinessType()()()() | Creates a new instance of a business type.
Public method | BusinessType(Int32) | Creates a new instance of a business type.
Public method | BusinessType(String) | Creates a new instance of a business type.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds a record's database ID.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | List | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | Type | Gets or sets the type description.

See Also

BusinessType Class


BusinessType Constructor

[image] [image]

Pastel Evolution SDK
BusinessType Constructor
BusinessType Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BusinessType()()()() | Creates a new instance of a business type.
Public method | BusinessType(Int32) | Creates a new instance of a business type.
Public method | BusinessType(String) | Creates a new instance of a business type.

See Also

BusinessType Class
BusinessType Members


BusinessType Constructor

[image]

Pastel Evolution SDK
BusinessType Constructor
BusinessType Class See Also Send Feedback
Creates a new instance of a business type.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public BusinessType()
Visual Basic
Public Sub New

See Also

BusinessType Class
BusinessType Members
BusinessType Overload


BusinessType Constructor (Int32)

[image]

Pastel Evolution SDK
BusinessType Constructor (Int32)
BusinessType Class See Also Send Feedback
Creates a new instance of a business type.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public BusinessType(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32
Specifies the id of the existing record.

See Also

BusinessType Class
BusinessType Members
BusinessType Overload


BusinessType Constructor (String)

[image]

Pastel Evolution SDK
BusinessType Constructor (String)
BusinessType Class See Also Send Feedback
Creates a new instance of a business type.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public BusinessType(
    string type
)
Visual Basic
Public Sub New (
    type As String
)

Parameters

type
Type: System..::..String
Specifies the type of the existing record.

See Also

BusinessType Class
BusinessType Members
BusinessType Overload


BusinessType Fields

[image] [image]

Pastel Evolution SDK
BusinessType Fields
BusinessType Class See Also Send Feedback

The BusinessType type exposes the following members.

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

BusinessType Class


BusinessType Methods

[image] [image]

Pastel Evolution SDK
BusinessType Methods
BusinessType Class See Also Send Feedback

The BusinessType type exposes the following members.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds a record's database ID.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | List | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

BusinessType Class


BusinessType.Find Method

[image]

Pastel Evolution SDK
BusinessType..::..Find Method
BusinessType Class See Also Send Feedback
Finds a record's database ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.

Return Value

Type: Int32
The ID of the first record found; -1 if not record was found.

See Also

BusinessType Class
BusinessType Members


BusinessType.List Method

[image]

Pastel Evolution SDK
BusinessType..::..List Method
BusinessType Class See Also Send Feedback
Gets a list of database records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DataTable List(
    string criteria
)
Visual Basic
Public Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.

Return Value

Type: DataTable
Table containing selected records.

See Also

BusinessType Class
BusinessType Members


BusinessType.OnDelete Method

[image]

Pastel Evolution SDK
BusinessType..::..OnDelete Method
BusinessType Class See Also Send Feedback
Removes the record from the database, provided it is not referenced by other records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

Exceptions

Exception | Condition
IntegrityViolationException |

See Also

BusinessType Class
BusinessType Members


BusinessType.OnSave Method

[image]

Pastel Evolution SDK
BusinessType..::..OnSave Method
BusinessType Class See Also Send Feedback
Persists the record to the database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

BusinessType Class
BusinessType Members


BusinessType Properties

[image] [image]

Pastel Evolution SDK
BusinessType Properties
BusinessType Class See Also Send Feedback

The BusinessType type exposes the following members.

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | Type | Gets or sets the type description.

See Also

BusinessType Class


BusinessType.ID Property

[image]

Pastel Evolution SDK
BusinessType..::..ID Property
BusinessType Class See Also Send Feedback
Gets the internal record ID (0 for new, unsaved records).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

See Also

BusinessType Class
BusinessType Members


BusinessType.LongID Property

[image]

Pastel Evolution SDK
BusinessType..::..LongID Property
BusinessType Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

BusinessType Class
BusinessType Members


BusinessType.Type Property

[image]

Pastel Evolution SDK
BusinessType..::..Type Property
BusinessType Class See Also Send Feedback
Gets or sets the type description.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Type { get; set; }
Visual Basic
Public Property Type As String
    Get
    Set

Property Value

Type: String

See Also

BusinessType Class
BusinessType Members


CashbookBatch Class

[image]

Pastel Evolution SDK
CashbookBatch Class
Members See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class CashbookBatch : BranchedRecordBase
Visual Basic
Public Class CashbookBatch
    Inherits BranchedRecordBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..CashbookBatch

See Also

CashbookBatch Members


CashbookBatch Members

[image] [image]

Pastel Evolution SDK
CashbookBatch Members
CashbookBatch Class Constructors Methods Fields Properties See Also Send Feedback

The CashbookBatch type exposes the following members.

Constructors

 | Name | Description
Public method | CashbookBatch()()()() | Creates a new instance of a cashbook batch.
Public method | CashbookBatch(Int32) | Creates a new instance of a general ledger cashbook batch.
Public method | CashbookBatch(String) | Creates a new instance of a general ledger cashbook batch.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find |
 | FindByCode |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List(String) |
 | List(String, String) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | AccountsPayableAccount | Gets or sets the cashbook batch integration accounts payable account.
Public property | AccountsPayableAccountID |
Public property | AccountsReceivableAccount | Gets or sets the cashbook batch integration accounts receivable account.
Public property | AccountsReceivableAccountID |
Public property | AllowAccountsPayablePosting | Gets or sets the cashbook batch to allow accounts payable module posting.
Public property | AllowAccountsReceivablePosting | Gets or sets the cashbook batch to allow accounts receivable module posting.
Public property | AllowGeneralLedgerPosting | Gets or sets the cashbook batch to allow general ledger module posting.
Public property | BankAccount | Gets or sets the cashbook batch integration bank account.
Public property | BankAccountID |
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Code | Gets or sets the cashbook batch number.
Public property | DefaultDescription | Gets or sets the new line default description.
Public property | DefaultReference | Gets or sets the new line default reference.
Public property | Description | Gets or sets the cashbook batch description.
Public property | Detail |
Public property | DoClearAfterPost | Gets or sets the cashbook batch clear after post.
Public property | ID | (Overrides RecordBase..::..ID.)
Public property | IncludeInBankRecon | Gets or sets the cashbook batch to appear in bank reconciliation.
Public property | IsLoading | Will be true while the cashbook is busy loading detail.
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | Owner | Gets or sets the batch owner.
Public property | OwnerID | Gets or sets the Agent ID of the batch owner.
Public property | ProcessedCount | Gets or sets the cashbook batch processed count.
Public property | Reference | Gets or sets the cashbook batch reference.
Public property | RepeatLimit | Gets or sets the cashbook batch repeat limit.
Public property | TaxAccount | Gets or sets the cashbook batch integration tax account.
Public property | TaxAccountID |
Public property | TransactionCode | Gets or sets the cashbook batch transaction code.
Public property | TransactionCodeID |

See Also

CashbookBatch Class


CashbookBatch Constructor

[image] [image]

Pastel Evolution SDK
CashbookBatch Constructor
CashbookBatch Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CashbookBatch()()()() | Creates a new instance of a cashbook batch.
Public method | CashbookBatch(Int32) | Creates a new instance of a general ledger cashbook batch.
Public method | CashbookBatch(String) | Creates a new instance of a general ledger cashbook batch.

See Also

CashbookBatch Class
CashbookBatch Members


CashbookBatch Constructor

[image]

Pastel Evolution SDK
CashbookBatch Constructor
CashbookBatch Class See Also Send Feedback
Creates a new instance of a cashbook batch.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public CashbookBatch()
Visual Basic
Public Sub New

See Also

CashbookBatch Class
CashbookBatch Members
CashbookBatch Overload


CashbookBatch Constructor (Int32)

[image]

Pastel Evolution SDK
CashbookBatch Constructor (Int32)
CashbookBatch Class See Also Send Feedback
Creates a new instance of a general ledger cashbook batch.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public CashbookBatch(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32
Specifies the ID of the existing record.

See Also

CashbookBatch Class
CashbookBatch Members
CashbookBatch Overload


CashbookBatch Constructor (String)

[image]

Pastel Evolution SDK
CashbookBatch Constructor (String)
CashbookBatch Class See Also Send Feedback
Creates a new instance of a general ledger cashbook batch.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public CashbookBatch(
    string code
)
Visual Basic
Public Sub New (
    code As String
)

Parameters

code
Type: System..::..String

See Also

CashbookBatch Class
CashbookBatch Members
CashbookBatch Overload


CashbookBatch Fields

[image] [image]

Pastel Evolution SDK
CashbookBatch Fields
CashbookBatch Class See Also Send Feedback

The CashbookBatch type exposes the following members.

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

CashbookBatch Class


CashbookBatch Methods

[image] [image]

Pastel Evolution SDK
CashbookBatch Methods
CashbookBatch Class See Also Send Feedback

The CashbookBatch type exposes the following members.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find |
 | FindByCode |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List(String) |
 | List(String, String) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

CashbookBatch Class


CashbookBatch.Find Method

[image]

Pastel Evolution SDK
CashbookBatch..::..Find Method
CashbookBatch Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String

Return Value

Type: Int32

See Also

CashbookBatch Class
CashbookBatch Members


CashbookBatch.FindByCode Method

[image]

Pastel Evolution SDK
CashbookBatch..::..FindByCode Method
CashbookBatch Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int FindByCode(
    string code
)
Visual Basic
Public Shared Function FindByCode (
    code As String
) As Integer

Parameters

code
Type: System..::..String

Return Value

Type: Int32

See Also

CashbookBatch Class
CashbookBatch Members


CashbookBatch.List Method

[image] [image]

Pastel Evolution SDK
CashbookBatch..::..List Method
CashbookBatch Class See Also Send Feedback

Overload List

Name | Description
List(String) |
List(String, String) |

See Also

CashbookBatch Class
CashbookBatch Members


CashbookBatch.List Method (String)

[image]

Pastel Evolution SDK
CashbookBatch..::..List Method (String)
CashbookBatch Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria
)
Visual Basic
Public Shared Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String

Return Value

Type: DataTable

See Also

CashbookBatch Class
CashbookBatch Members
List Overload


CashbookBatch.List Method (String, String)

[image]

Pastel Evolution SDK
CashbookBatch..::..List Method (String, String)
CashbookBatch Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria,
    string sortOrder
)
Visual Basic
Public Shared Function List (
    criteria As String,
    sortOrder As String
) As DataTable

Parameters

criteria
Type: System..::..String
sortOrder
Type: System..::..String

Return Value

Type: DataTable

See Also

CashbookBatch Class
CashbookBatch Members
List Overload


CashbookBatch.OnDelete Method

[image]

Pastel Evolution SDK
CashbookBatch..::..OnDelete Method
CashbookBatch Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

See Also

CashbookBatch Class
CashbookBatch Members


CashbookBatch.OnSave Method

[image]

Pastel Evolution SDK
CashbookBatch..::..OnSave Method
CashbookBatch Class See Also Send Feedback
Persists the record to the database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

CashbookBatch Class
CashbookBatch Members


CashbookBatch Properties

[image] [image]

Pastel Evolution SDK
CashbookBatch Properties
CashbookBatch Class See Also Send Feedback

The CashbookBatch type exposes the following members.

Properties

 | Name | Description
Public property | AccountsPayableAccount | Gets or sets the cashbook batch integration accounts payable account.
Public property | AccountsPayableAccountID |
Public property | AccountsReceivableAccount | Gets or sets the cashbook batch integration accounts receivable account.
Public property | AccountsReceivableAccountID |
Public property | AllowAccountsPayablePosting | Gets or sets the cashbook batch to allow accounts payable module posting.
Public property | AllowAccountsReceivablePosting | Gets or sets the cashbook batch to allow accounts receivable module posting.
Public property | AllowGeneralLedgerPosting | Gets or sets the cashbook batch to allow general ledger module posting.
Public property | BankAccount | Gets or sets the cashbook batch integration bank account.
Public property | BankAccountID |
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Code | Gets or sets the cashbook batch number.
Public property | DefaultDescription | Gets or sets the new line default description.
Public property | DefaultReference | Gets or sets the new line default reference.
Public property | Description | Gets or sets the cashbook batch description.
Public property | Detail |
Public property | DoClearAfterPost | Gets or sets the cashbook batch clear after post.
Public property | ID | (Overrides RecordBase..::..ID.)
Public property | IncludeInBankRecon | Gets or sets the cashbook batch to appear in bank reconciliation.
Public property | IsLoading | Will be true while the cashbook is busy loading detail.
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | Owner | Gets or sets the batch owner.
Public property | OwnerID | Gets or sets the Agent ID of the batch owner.
Public property | ProcessedCount | Gets or sets the cashbook batch processed count.
Public property | Reference | Gets or sets the cashbook batch reference.
Public property | RepeatLimit | Gets or sets the cashbook batch repeat limit.
Public property | TaxAccount | Gets or sets the cashbook batch integration tax account.
Public property | TaxAccountID |
Public property | TransactionCode | Gets or sets the cashbook batch transaction code.
Public property | TransactionCodeID |

See Also

CashbookBatch Class


CashbookBatch.AccountsPayableAccount Property

[image]

Pastel Evolution SDK
CashbookBatch..::..AccountsPayableAccount Property
CashbookBatch Class See Also Send Feedback
Gets or sets the cashbook batch integration accounts payable account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLAccount AccountsPayableAccount { get; set; }
Visual Basic
Public Property AccountsPayableAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

See Also

CashbookBatch Class
CashbookBatch Members


CashbookBatch.AccountsPayableAccountID Property

[image]

Pastel Evolution SDK
CashbookBatch..::..AccountsPayableAccountID Property
CashbookBatch Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int AccountsPayableAccountID { get; set; }
Visual Basic
Public Property AccountsPayableAccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CashbookBatch Class
CashbookBatch Members


CashbookBatch.AccountsReceivableAccount Property

[image]

Pastel Evolution SDK
CashbookBatch..::..AccountsReceivableAccount Property
CashbookBatch Class See Also Send Feedback
Gets or sets the cashbook batch integration accounts receivable account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLAccount AccountsReceivableAccount { get; set; }
Visual Basic
Public Property AccountsReceivableAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

See Also

CashbookBatch Class
CashbookBatch Members


CashbookBatch.AccountsReceivableAccountID Property

[image]

Pastel Evolution SDK
CashbookBatch..::..AccountsReceivableAccountID Property
CashbookBatch Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int AccountsReceivableAccountID { get; set; }
Visual Basic
Public Property AccountsReceivableAccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CashbookBatch Class
CashbookBatch Members


CashbookBatch.AllowAccountsPayablePosting Property

[image]

Pastel Evolution SDK
CashbookBatch..::..AllowAccountsPayablePosting Property
CashbookBatch Class See Also Send Feedback
Gets or sets the cashbook batch to allow accounts payable module posting.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool AllowAccountsPayablePosting { get; set; }
Visual Basic
Public Property AllowAccountsPayablePosting As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CashbookBatch Class
CashbookBatch Members


CashbookBatch.AllowAccountsReceivablePosting Property

[image]

Pastel Evolution SDK
CashbookBatch..::..AllowAccountsReceivablePosting Property
CashbookBatch Class See Also Send Feedback
Gets or sets the cashbook batch to allow accounts receivable module posting.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool AllowAccountsReceivablePosting { get; set; }
Visual Basic
Public Property AllowAccountsReceivablePosting As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CashbookBatch Class
CashbookBatch Members


CashbookBatch.AllowGeneralLedgerPosting Property

[image]

Pastel Evolution SDK
CashbookBatch..::..AllowGeneralLedgerPosting Property
CashbookBatch Class See Also Send Feedback
Gets or sets the cashbook batch to allow general ledger module posting.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool AllowGeneralLedgerPosting { get; set; }
Visual Basic
Public Property AllowGeneralLedgerPosting As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CashbookBatch Class
CashbookBatch Members


CashbookBatch.BankAccount Property

[image]

Pastel Evolution SDK
CashbookBatch..::..BankAccount Property
CashbookBatch Class See Also Send Feedback
Gets or sets the cashbook batch integration bank account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLAccount BankAccount { get; set; }
Visual Basic
Public Property BankAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

See Also

CashbookBatch Class
CashbookBatch Members


CashbookBatch.BankAccountID Property

[image]

Pastel Evolution SDK
CashbookBatch..::..BankAccountID Property
CashbookBatch Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int BankAccountID { get; set; }
Visual Basic
Public Property BankAccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CashbookBatch Class
CashbookBatch Members


CashbookBatch.Code Property

[image]

Pastel Evolution SDK
CashbookBatch..::..Code Property
CashbookBatch Class See Also Send Feedback
Gets or sets the cashbook batch number.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Code { get; set; }
Visual Basic
Public Property Code As String
    Get
    Set

Property Value

Type: String

See Also

CashbookBatch Class
CashbookBatch Members


CashbookBatch.DefaultDescription Property

[image]

Pastel Evolution SDK
CashbookBatch..::..DefaultDescription Property
CashbookBatch Class See Also Send Feedback
Gets or sets the new line default description.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string DefaultDescription { get; set; }
Visual Basic
Public Property DefaultDescription As String
    Get
    Set

Property Value

Type: String

See Also

CashbookBatch Class
CashbookBatch Members


CashbookBatch.DefaultReference Property

[image]

Pastel Evolution SDK
CashbookBatch..::..DefaultReference Property
CashbookBatch Class See Also Send Feedback
Gets or sets the new line default reference.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string DefaultReference { get; set; }
Visual Basic
Public Property DefaultReference As String
    Get
    Set

Property Value

Type: String

See Also

CashbookBatch Class
CashbookBatch Members


CashbookBatch.Description Property

[image]

Pastel Evolution SDK
CashbookBatch..::..Description Property
CashbookBatch Class See Also Send Feedback
Gets or sets the cashbook batch description.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set

Property Value

Type: String

See Also

CashbookBatch Class
CashbookBatch Members


CashbookBatch.Detail Property

[image]

Pastel Evolution SDK
CashbookBatch..::..Detail Property
CashbookBatch Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public CashbookBatchDetailCollection Detail { get; }
Visual Basic
Public ReadOnly Property Detail As CashbookBatchDetailCollection
    Get

Property Value

Type: CashbookBatchDetailCollection

See Also

CashbookBatch Class
CashbookBatch Members


CashbookBatch.DoClearAfterPost Property

[image]

Pastel Evolution SDK
CashbookBatch..::..DoClearAfterPost Property
CashbookBatch Class See Also Send Feedback
Gets or sets the cashbook batch clear after post.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool DoClearAfterPost { get; set; }
Visual Basic
Public Property DoClearAfterPost As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CashbookBatch Class
CashbookBatch Members


CashbookBatch.ID Property

[image]

Pastel Evolution SDK
CashbookBatch..::..ID Property
CashbookBatch Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

See Also

CashbookBatch Class
CashbookBatch Members


CashbookBatch.IncludeInBankRecon Property

[image]

Pastel Evolution SDK
CashbookBatch..::..IncludeInBankRecon Property
CashbookBatch Class See Also Send Feedback
Gets or sets the cashbook batch to appear in bank reconciliation.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool IncludeInBankRecon { get; set; }
Visual Basic
Public Property IncludeInBankRecon As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CashbookBatch Class
CashbookBatch Members


CashbookBatch.IsLoading Property

[image]

Pastel Evolution SDK
CashbookBatch..::..IsLoading Property
CashbookBatch Class See Also Send Feedback
Will be true while the cashbook is busy loading detail.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool IsLoading { get; internal set; }
Visual Basic
Public Property IsLoading As Boolean
    Get
    Friend Set

Property Value

Type: Boolean

See Also

CashbookBatch Class
CashbookBatch Members


CashbookBatch.LongID Property

[image]

Pastel Evolution SDK
CashbookBatch..::..LongID Property
CashbookBatch Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

CashbookBatch Class
CashbookBatch Members


CashbookBatch.Owner Property

[image]

Pastel Evolution SDK
CashbookBatch..::..Owner Property
CashbookBatch Class See Also Send Feedback
Gets or sets the batch owner.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Agent Owner { get; set; }
Visual Basic
Public Property Owner As Agent
    Get
    Set

Property Value

Type: Agent

See Also

CashbookBatch Class
CashbookBatch Members


CashbookBatch.OwnerID Property

[image]

Pastel Evolution SDK
CashbookBatch..::..OwnerID Property
CashbookBatch Class See Also Send Feedback
Gets or sets the Agent ID of the batch owner.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int OwnerID { get; set; }
Visual Basic
Public Property OwnerID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CashbookBatch Class
CashbookBatch Members


CashbookBatch.ProcessedCount Property

[image]

Pastel Evolution SDK
CashbookBatch..::..ProcessedCount Property
CashbookBatch Class See Also Send Feedback
Gets or sets the cashbook batch processed count.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int ProcessedCount { get; }
Visual Basic
Public ReadOnly Property ProcessedCount As Integer
    Get

Property Value

Type: Int32

See Also

CashbookBatch Class
CashbookBatch Members


CashbookBatch.Reference Property

[image]

Pastel Evolution SDK
CashbookBatch..::..Reference Property
CashbookBatch Class See Also Send Feedback
Gets or sets the cashbook batch reference.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Reference { get; internal set; }
Visual Basic
Public Property Reference As String
    Get
    Friend Set

Property Value

Type: String

See Also

CashbookBatch Class
CashbookBatch Members


CashbookBatch.RepeatLimit Property

[image]

Pastel Evolution SDK
CashbookBatch..::..RepeatLimit Property
CashbookBatch Class See Also Send Feedback
Gets or sets the cashbook batch repeat limit.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int RepeatLimit { get; set; }
Visual Basic
Public Property RepeatLimit As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CashbookBatch Class
CashbookBatch Members


CashbookBatch.TaxAccount Property

[image]

Pastel Evolution SDK
CashbookBatch..::..TaxAccount Property
CashbookBatch Class See Also Send Feedback
Gets or sets the cashbook batch integration tax account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLAccount TaxAccount { get; set; }
Visual Basic
Public Property TaxAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

See Also

CashbookBatch Class
CashbookBatch Members


CashbookBatch.TaxAccountID Property

[image]

Pastel Evolution SDK
CashbookBatch..::..TaxAccountID Property
CashbookBatch Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int TaxAccountID { get; set; }
Visual Basic
Public Property TaxAccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CashbookBatch Class
CashbookBatch Members


CashbookBatch.TransactionCode Property

[image]

Pastel Evolution SDK
CashbookBatch..::..TransactionCode Property
CashbookBatch Class See Also Send Feedback
Gets or sets the cashbook batch transaction code.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public TransactionCode TransactionCode { get; set; }
Visual Basic
Public Property TransactionCode As TransactionCode
    Get
    Set

Property Value

Type: TransactionCode

See Also

CashbookBatch Class
CashbookBatch Members


CashbookBatch.TransactionCodeID Property

[image]

Pastel Evolution SDK
CashbookBatch..::..TransactionCodeID Property
CashbookBatch Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int TransactionCodeID { get; set; }
Visual Basic
Public Property TransactionCodeID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CashbookBatch Class
CashbookBatch Members


CashbookBatchDetail Class

[image]

Pastel Evolution SDK
CashbookBatchDetail Class
Members See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class CashbookBatchDetail : BranchedRecordBase
Visual Basic
Public Class CashbookBatchDetail
    Inherits BranchedRecordBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..CashbookBatchDetail

See Also

CashbookBatchDetail Members


CashbookBatchDetail Members

[image] [image]

Pastel Evolution SDK
CashbookBatchDetail Members
CashbookBatchDetail Class Constructors Methods Fields Properties See Also Send Feedback

The CashbookBatchDetail type exposes the following members.

Constructors

 | Name | Description
Public method | CashbookBatchDetail()()()() | Creates a new instance of a cashbook batch detail record.
Public method | CashbookBatchDetail(Int32) | Creates a new instance of a journal batch detail record.

Methods

 | Name | Description
Protected method | calcTaxValues |
Public method | Clone |
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find |
Protected method | getExchangeRate |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Protected method | setExchangeRate |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | amount |
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | discAmount |
Protected field | discTax |
Protected field | exchange |
Protected field | fcDiscountQueue |
Protected field | fcQueue |
Protected field | foreignAmount |
Protected field | foreignOriginalTax |
Protected field | originalTax |
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | Account |
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Credit |
Public property | Currency | Gets the record currency.
Public property | Customer | Gets or sets the line's customer. Maps directly to the Account property but null if invalid.
Public property | CustomerID | Gets or sets the customer id.
Public property | Date |
Public property | Debit | Sets the transaction debit amount.
Public property | Description | Gets or sets the record description.
Public property | EffectiveCredit |
Public property | EffectiveDebit |
Public property | ExchangeRate | Gets or sets the applicable exchange rate, expressed as [home currency]/[foreign currency]. Defaults to applicable exchange rate for the transaction date.
Public property | ForeignTax | Gets or sets the foreign tax amount (automatically rounded to 2 decimals and always posted positive).
Public property | GLAccountID | Gets or sets the tax account ID.
Public property | ID | (Overrides RecordBase..::..ID.)
Public property | IsLoading |
Public property | LineModule |
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | PostDated | Gets or sets if the record is post dated
Public property | Project | Gets or sets the Project.
Public property | ProjectID | Gets or sets the Project ID.
Public property | Reconcile | Gets or sets if the record is reconciled or not.
Public property | Reference |
Public property | SalesRepresentative | Gets or sets the record sales representative
Public property | SalesRepresentativeID | Gets or sets the sales representative ID.
Public property | SplitGroup | Gets the record Split Group
Public property | SplitLines |
Public property | SplitType |
Public property | Supplier | Gets or sets the line's supplier. Maps directly to the Account property but null if invalid.
Public property | SupplierID | Gets or sets the supplier id.
Public property | Tax | Gets or sets the transaction tax amount (automatically rounded to 2 decimals and always posted positive).
Public property | TaxAccount | Gets or sets the tax account.
Public property | TaxRateID | Gets or sets the TaxRate ID.
Public property | TaxType | Gets or sets the TaxRate.

See Also

CashbookBatchDetail Class


CashbookBatchDetail Constructor

[image] [image]

Pastel Evolution SDK
CashbookBatchDetail Constructor
CashbookBatchDetail Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CashbookBatchDetail()()()() | Creates a new instance of a cashbook batch detail record.
Public method | CashbookBatchDetail(Int32) | Creates a new instance of a journal batch detail record.

See Also

CashbookBatchDetail Class
CashbookBatchDetail Members


CashbookBatchDetail Constructor

[image]

Pastel Evolution SDK
CashbookBatchDetail Constructor
CashbookBatchDetail Class See Also Send Feedback
Creates a new instance of a cashbook batch detail record.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public CashbookBatchDetail()
Visual Basic
Public Sub New

See Also

CashbookBatchDetail Class
CashbookBatchDetail Members
CashbookBatchDetail Overload


CashbookBatchDetail Constructor (Int32)

[image]

Pastel Evolution SDK
CashbookBatchDetail Constructor (Int32)
CashbookBatchDetail Class See Also Send Feedback
Creates a new instance of a journal batch detail record.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public CashbookBatchDetail(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32
Specifies the id of the existing record.

See Also

CashbookBatchDetail Class
CashbookBatchDetail Members
CashbookBatchDetail Overload


CashbookBatchDetail Fields

[image] [image]

Pastel Evolution SDK
CashbookBatchDetail Fields
CashbookBatchDetail Class See Also Send Feedback

The CashbookBatchDetail type exposes the following members.

Fields

 | Name | Description
Protected field | amount |
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | discAmount |
Protected field | discTax |
Protected field | exchange |
Protected field | fcDiscountQueue |
Protected field | fcQueue |
Protected field | foreignAmount |
Protected field | foreignOriginalTax |
Protected field | originalTax |
Protected field | wrapper | (Inherited from RecordBase.)

See Also

CashbookBatchDetail Class


CashbookBatchDetail.amount Field

[image]

Pastel Evolution SDK
CashbookBatchDetail..::..amount Field
CashbookBatchDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected double amount
Visual Basic
Protected amount As Double

Field Value

Type: Double

See Also

CashbookBatchDetail Class
CashbookBatchDetail Members


CashbookBatchDetail.discAmount Field

[image]

Pastel Evolution SDK
CashbookBatchDetail..::..discAmount Field
CashbookBatchDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected double discAmount
Visual Basic
Protected discAmount As Double

Field Value

Type: Double

See Also

CashbookBatchDetail Class
CashbookBatchDetail Members


CashbookBatchDetail.discTax Field

[image]

Pastel Evolution SDK
CashbookBatchDetail..::..discTax Field
CashbookBatchDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected double discTax
Visual Basic
Protected discTax As Double

Field Value

Type: Double

See Also

CashbookBatchDetail Class
CashbookBatchDetail Members


CashbookBatchDetail.exchange Field

[image]

Pastel Evolution SDK
CashbookBatchDetail..::..exchange Field
CashbookBatchDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected double exchange
Visual Basic
Protected exchange As Double

Field Value

Type: Double

See Also

CashbookBatchDetail Class
CashbookBatchDetail Members


CashbookBatchDetail.fcDiscountQueue Field

[image]

Pastel Evolution SDK
CashbookBatchDetail..::..fcDiscountQueue Field
CashbookBatchDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal Utils..::..LimitedQueue fcDiscountQueue
Visual Basic
Protected Friend fcDiscountQueue As Utils..::..LimitedQueue

Field Value

Type: Utils..::..LimitedQueue

See Also

CashbookBatchDetail Class
CashbookBatchDetail Members


CashbookBatchDetail.fcQueue Field

[image]

Pastel Evolution SDK
CashbookBatchDetail..::..fcQueue Field
CashbookBatchDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal Utils..::..LimitedQueue fcQueue
Visual Basic
Protected Friend fcQueue As Utils..::..LimitedQueue

Field Value

Type: Utils..::..LimitedQueue

See Also

CashbookBatchDetail Class
CashbookBatchDetail Members


CashbookBatchDetail.foreignAmount Field

[image]

Pastel Evolution SDK
CashbookBatchDetail..::..foreignAmount Field
CashbookBatchDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected double foreignAmount
Visual Basic
Protected foreignAmount As Double

Field Value

Type: Double

See Also

CashbookBatchDetail Class
CashbookBatchDetail Members


CashbookBatchDetail.foreignOriginalTax Field

[image]

Pastel Evolution SDK
CashbookBatchDetail..::..foreignOriginalTax Field
CashbookBatchDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected double foreignOriginalTax
Visual Basic
Protected foreignOriginalTax As Double

Field Value

Type: Double

See Also

CashbookBatchDetail Class
CashbookBatchDetail Members


CashbookBatchDetail.originalTax Field

[image]

Pastel Evolution SDK
CashbookBatchDetail..::..originalTax Field
CashbookBatchDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected double originalTax
Visual Basic
Protected originalTax As Double

Field Value

Type: Double

See Also

CashbookBatchDetail Class
CashbookBatchDetail Members


CashbookBatchDetail Methods

[image] [image]

Pastel Evolution SDK
CashbookBatchDetail Methods
CashbookBatchDetail Class See Also Send Feedback

The CashbookBatchDetail type exposes the following members.

Methods

 | Name | Description
Protected method | calcTaxValues |
Public method | Clone |
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find |
Protected method | getExchangeRate |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Protected method | setExchangeRate |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

CashbookBatchDetail Class


CashbookBatchDetail.calcTaxValues Method

[image]

Pastel Evolution SDK
CashbookBatchDetail..::..calcTaxValues Method
CashbookBatchDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected void calcTaxValues()
Visual Basic
Protected Sub calcTaxValues

See Also

CashbookBatchDetail Class
CashbookBatchDetail Members


CashbookBatchDetail.Clone Method

[image]

Pastel Evolution SDK
CashbookBatchDetail..::..Clone Method
CashbookBatchDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public CashbookBatchDetail Clone()
Visual Basic
Public Function Clone As CashbookBatchDetail

Return Value

Type: CashbookBatchDetail

See Also

CashbookBatchDetail Class
CashbookBatchDetail Members


CashbookBatchDetail.Find Method

[image]

Pastel Evolution SDK
CashbookBatchDetail..::..Find Method
CashbookBatchDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String

Return Value

Type: Int32

See Also

CashbookBatchDetail Class
CashbookBatchDetail Members


CashbookBatchDetail.getExchangeRate Method

[image]

Pastel Evolution SDK
CashbookBatchDetail..::..getExchangeRate Method
CashbookBatchDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected double getExchangeRate()
Visual Basic
Protected Function getExchangeRate As Double

Return Value

Type: Double

See Also

CashbookBatchDetail Class
CashbookBatchDetail Members


CashbookBatchDetail.List Method

[image]

Pastel Evolution SDK
CashbookBatchDetail..::..List Method
CashbookBatchDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria
)
Visual Basic
Public Shared Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String

Return Value

Type: DataTable

See Also

CashbookBatchDetail Class
CashbookBatchDetail Members


CashbookBatchDetail.OnDelete Method

[image]

Pastel Evolution SDK
CashbookBatchDetail..::..OnDelete Method
CashbookBatchDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

See Also

CashbookBatchDetail Class
CashbookBatchDetail Members


CashbookBatchDetail.OnSave Method

[image]

Pastel Evolution SDK
CashbookBatchDetail..::..OnSave Method
CashbookBatchDetail Class See Also Send Feedback
Persists the record to the database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

CashbookBatchDetail Class
CashbookBatchDetail Members


CashbookBatchDetail.setExchangeRate Method

[image]

Pastel Evolution SDK
CashbookBatchDetail..::..setExchangeRate Method
CashbookBatchDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected void setExchangeRate(
    double value
)
Visual Basic
Protected Sub setExchangeRate (
    value As Double
)

Parameters

value
Type: System..::..Double

See Also

CashbookBatchDetail Class
CashbookBatchDetail Members


CashbookBatchDetail Properties

[image] [image]

Pastel Evolution SDK
CashbookBatchDetail Properties
CashbookBatchDetail Class See Also Send Feedback

The CashbookBatchDetail type exposes the following members.

Properties

 | Name | Description
Public property | Account |
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Credit |
Public property | Currency | Gets the record currency.
Public property | Customer | Gets or sets the line's customer. Maps directly to the Account property but null if invalid.
Public property | CustomerID | Gets or sets the customer id.
Public property | Date |
Public property | Debit | Sets the transaction debit amount.
Public property | Description | Gets or sets the record description.
Public property | EffectiveCredit |
Public property | EffectiveDebit |
Public property | ExchangeRate | Gets or sets the applicable exchange rate, expressed as [home currency]/[foreign currency]. Defaults to applicable exchange rate for the transaction date.
Public property | ForeignTax | Gets or sets the foreign tax amount (automatically rounded to 2 decimals and always posted positive).
Public property | GLAccountID | Gets or sets the tax account ID.
Public property | ID | (Overrides RecordBase..::..ID.)
Public property | IsLoading |
Public property | LineModule |
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | PostDated | Gets or sets if the record is post dated
Public property | Project | Gets or sets the Project.
Public property | ProjectID | Gets or sets the Project ID.
Public property | Reconcile | Gets or sets if the record is reconciled or not.
Public property | Reference |
Public property | SalesRepresentative | Gets or sets the record sales representative
Public property | SalesRepresentativeID | Gets or sets the sales representative ID.
Public property | SplitGroup | Gets the record Split Group
Public property | SplitLines |
Public property | SplitType |
Public property | Supplier | Gets or sets the line's supplier. Maps directly to the Account property but null if invalid.
Public property | SupplierID | Gets or sets the supplier id.
Public property | Tax | Gets or sets the transaction tax amount (automatically rounded to 2 decimals and always posted positive).
Public property | TaxAccount | Gets or sets the tax account.
Public property | TaxRateID | Gets or sets the TaxRate ID.
Public property | TaxType | Gets or sets the TaxRate.

See Also

CashbookBatchDetail Class


CashbookBatchDetail.Account Property

[image]

Pastel Evolution SDK
CashbookBatchDetail..::..Account Property
CashbookBatchDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public AccountBase Account { get; set; }
Visual Basic
Public Property Account As AccountBase
    Get
    Set

Property Value

Type: AccountBase

See Also

CashbookBatchDetail Class
CashbookBatchDetail Members


CashbookBatchDetail.Credit Property

[image]

Pastel Evolution SDK
CashbookBatchDetail..::..Credit Property
CashbookBatchDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double Credit { get; set; }
Visual Basic
Public Property Credit As Double
    Get
    Set

Property Value

Type: Double

See Also

CashbookBatchDetail Class
CashbookBatchDetail Members


CashbookBatchDetail.Currency Property

[image]

Pastel Evolution SDK
CashbookBatchDetail..::..Currency Property
CashbookBatchDetail Class See Also Send Feedback
Gets the record currency.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Currency Currency { get; }
Visual Basic
Public ReadOnly Property Currency As Currency
    Get

Property Value

Type: Currency

See Also

CashbookBatchDetail Class
CashbookBatchDetail Members


CashbookBatchDetail.Customer Property

[image]

Pastel Evolution SDK
CashbookBatchDetail..::..Customer Property
CashbookBatchDetail Class See Also Send Feedback
Gets or sets the line's customer. Maps directly to the Account property but null if invalid.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Customer Customer { get; set; }
Visual Basic
Public Property Customer As Customer
    Get
    Set

Property Value

Type: Customer

See Also

CashbookBatchDetail Class
CashbookBatchDetail Members


CashbookBatchDetail.CustomerID Property

[image]

Pastel Evolution SDK
CashbookBatchDetail..::..CustomerID Property
CashbookBatchDetail Class See Also Send Feedback
Gets or sets the customer id.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int CustomerID { get; set; }
Visual Basic
Public Property CustomerID As Integer
    Get
    Set

Property Value

Type: Int32

Remarks

See Also

CashbookBatchDetail Class
CashbookBatchDetail Members
Pastel.Evolution Namespace
Pastel.Evolution..::..InventoryItem


CashbookBatchDetail.Date Property

[image]

Pastel Evolution SDK
CashbookBatchDetail..::..Date Property
CashbookBatchDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DateTime Date { get; set; }
Visual Basic
Public Property Date As DateTime
    Get
    Set

Property Value

Type: DateTime

See Also

CashbookBatchDetail Class
CashbookBatchDetail Members


CashbookBatchDetail.Debit Property

[image]

Pastel Evolution SDK
CashbookBatchDetail..::..Debit Property
CashbookBatchDetail Class See Also Send Feedback
Sets the transaction debit amount.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double Debit { get; set; }
Visual Basic
Public Property Debit As Double
    Get
    Set

Property Value

Type: Double

Remarks

Be careful when setting both debit and credit values. When setting debit to a negative value, debit will immediately become 0 and credit will immediately be set to the reverse of the value. If then setting credit to 0, the transaction amount will be cancelled.

See Also

CashbookBatchDetail Class
CashbookBatchDetail Members


CashbookBatchDetail.Description Property

[image]

Pastel Evolution SDK
CashbookBatchDetail..::..Description Property
CashbookBatchDetail Class See Also Send Feedback
Gets or sets the record description.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set

Property Value

Type: String

See Also

CashbookBatchDetail Class
CashbookBatchDetail Members


CashbookBatchDetail.EffectiveCredit Property

[image]

Pastel Evolution SDK
CashbookBatchDetail..::..EffectiveCredit Property
CashbookBatchDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double EffectiveCredit { get; set; }
Visual Basic
Public Property EffectiveCredit As Double
    Get
    Set

Property Value

Type: Double

See Also

CashbookBatchDetail Class
CashbookBatchDetail Members


CashbookBatchDetail.EffectiveDebit Property

[image]

Pastel Evolution SDK
CashbookBatchDetail..::..EffectiveDebit Property
CashbookBatchDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double EffectiveDebit { get; set; }
Visual Basic
Public Property EffectiveDebit As Double
    Get
    Set

Property Value

Type: Double

See Also

CashbookBatchDetail Class
CashbookBatchDetail Members


CashbookBatchDetail.ExchangeRate Property

[image]

Pastel Evolution SDK
CashbookBatchDetail..::..ExchangeRate Property
CashbookBatchDetail Class See Also Send Feedback
Gets or sets the applicable exchange rate, expressed as [home currency]/[foreign currency]. Defaults to applicable exchange rate for the transaction date.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double ExchangeRate { get; set; }
Visual Basic
Public Property ExchangeRate As Double
    Get
    Set

Property Value

Type: Double

See Also

CashbookBatchDetail Class
CashbookBatchDetail Members


CashbookBatchDetail.ForeignTax Property

[image]

Pastel Evolution SDK
CashbookBatchDetail..::..ForeignTax Property
CashbookBatchDetail Class See Also Send Feedback
Gets or sets the foreign tax amount (automatically rounded to 2 decimals and always posted positive).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double ForeignTax { get; set; }
Visual Basic
Public Property ForeignTax As Double
    Get
    Set

Property Value

Type: Double

See Also

CashbookBatchDetail Class
CashbookBatchDetail Members


CashbookBatchDetail.GLAccountID Property

[image]

Pastel Evolution SDK
CashbookBatchDetail..::..GLAccountID Property
CashbookBatchDetail Class See Also Send Feedback
Gets or sets the tax account ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int GLAccountID { get; set; }
Visual Basic
Public Property GLAccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CashbookBatchDetail Class
CashbookBatchDetail Members


CashbookBatchDetail.ID Property

[image]

Pastel Evolution SDK
CashbookBatchDetail..::..ID Property
CashbookBatchDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

See Also

CashbookBatchDetail Class
CashbookBatchDetail Members


CashbookBatchDetail.IsLoading Property

[image]

Pastel Evolution SDK
CashbookBatchDetail..::..IsLoading Property
CashbookBatchDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool IsLoading { get; set; }
Visual Basic
Public Property IsLoading As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CashbookBatchDetail Class
CashbookBatchDetail Members


CashbookBatchDetail.LineModule Property

[image]

Pastel Evolution SDK
CashbookBatchDetail..::..LineModule Property
CashbookBatchDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public CashbookBatchDetail..::..Module LineModule { get; set; }
Visual Basic
Public Property LineModule As CashbookBatchDetail..::..Module
    Get
    Set

Property Value

Type: CashbookBatchDetail..::..Module

See Also

CashbookBatchDetail Class
CashbookBatchDetail Members


CashbookBatchDetail.LongID Property

[image]

Pastel Evolution SDK
CashbookBatchDetail..::..LongID Property
CashbookBatchDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

CashbookBatchDetail Class
CashbookBatchDetail Members


CashbookBatchDetail.PostDated Property

[image]

Pastel Evolution SDK
CashbookBatchDetail..::..PostDated Property
CashbookBatchDetail Class See Also Send Feedback
Gets or sets if the record is post dated

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool PostDated { get; set; }
Visual Basic
Public Property PostDated As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CashbookBatchDetail Class
CashbookBatchDetail Members


CashbookBatchDetail.Project Property

[image]

Pastel Evolution SDK
CashbookBatchDetail..::..Project Property
CashbookBatchDetail Class See Also Send Feedback
Gets or sets the Project.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Project Project { get; set; }
Visual Basic
Public Property Project As Project
    Get
    Set

Property Value

Type: Project

See Also

CashbookBatchDetail Class
CashbookBatchDetail Members


CashbookBatchDetail.ProjectID Property

[image]

Pastel Evolution SDK
CashbookBatchDetail..::..ProjectID Property
CashbookBatchDetail Class See Also Send Feedback
Gets or sets the Project ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int ProjectID { get; set; }
Visual Basic
Public Property ProjectID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CashbookBatchDetail Class
CashbookBatchDetail Members


CashbookBatchDetail.Reconcile Property

[image]

Pastel Evolution SDK
CashbookBatchDetail..::..Reconcile Property
CashbookBatchDetail Class See Also Send Feedback
Gets or sets if the record is reconciled or not.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool Reconcile { get; set; }
Visual Basic
Public Property Reconcile As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CashbookBatchDetail Class
CashbookBatchDetail Members


CashbookBatchDetail.Reference Property

[image]

Pastel Evolution SDK
CashbookBatchDetail..::..Reference Property
CashbookBatchDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Reference { get; set; }
Visual Basic
Public Property Reference As String
    Get
    Set

Property Value

Type: String

See Also

CashbookBatchDetail Class
CashbookBatchDetail Members


CashbookBatchDetail.SalesRepresentative Property

[image]

Pastel Evolution SDK
CashbookBatchDetail..::..SalesRepresentative Property
CashbookBatchDetail Class See Also Send Feedback
Gets or sets the record sales representative

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public SalesRepresentative SalesRepresentative { get; set; }
Visual Basic
Public Property SalesRepresentative As SalesRepresentative
    Get
    Set

Property Value

Type: SalesRepresentative

See Also

CashbookBatchDetail Class
CashbookBatchDetail Members


CashbookBatchDetail.SalesRepresentativeID Property

[image]

Pastel Evolution SDK
CashbookBatchDetail..::..SalesRepresentativeID Property
CashbookBatchDetail Class See Also Send Feedback
Gets or sets the sales representative ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int SalesRepresentativeID { get; set; }
Visual Basic
Public Property SalesRepresentativeID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CashbookBatchDetail Class
CashbookBatchDetail Members


CashbookBatchDetail.SplitGroup Property

[image]

Pastel Evolution SDK
CashbookBatchDetail..::..SplitGroup Property
CashbookBatchDetail Class See Also Send Feedback
Gets the record Split Group

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int SplitGroup { get; internal set; }
Visual Basic
Public Property SplitGroup As Integer
    Get
    Friend Set

Property Value

Type: Int32

See Also

CashbookBatchDetail Class
CashbookBatchDetail Members


CashbookBatchDetail.SplitLines Property

[image]

Pastel Evolution SDK
CashbookBatchDetail..::..SplitLines Property
CashbookBatchDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public CashbookBatchSplitCollection SplitLines { get; }
Visual Basic
Public ReadOnly Property SplitLines As CashbookBatchSplitCollection
    Get

Property Value

Type: CashbookBatchSplitCollection

See Also

CashbookBatchDetail Class
CashbookBatchDetail Members


CashbookBatchDetail.SplitType Property

[image]

Pastel Evolution SDK
CashbookBatchDetail..::..SplitType Property
CashbookBatchDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public CashbookBatchDetail..::..SplitLineType SplitType { get; internal set; }
Visual Basic
Public Property SplitType As CashbookBatchDetail..::..SplitLineType
    Get
    Friend Set

Property Value

Type: CashbookBatchDetail..::..SplitLineType

See Also

CashbookBatchDetail Class
CashbookBatchDetail Members


CashbookBatchDetail.Supplier Property

[image]

Pastel Evolution SDK
CashbookBatchDetail..::..Supplier Property
CashbookBatchDetail Class See Also Send Feedback
Gets or sets the line's supplier. Maps directly to the Account property but null if invalid.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Supplier Supplier { get; set; }
Visual Basic
Public Property Supplier As Supplier
    Get
    Set

Property Value

Type: Supplier

See Also

CashbookBatchDetail Class
CashbookBatchDetail Members


CashbookBatchDetail.SupplierID Property

[image]

Pastel Evolution SDK
CashbookBatchDetail..::..SupplierID Property
CashbookBatchDetail Class See Also Send Feedback
Gets or sets the supplier id.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int SupplierID { get; set; }
Visual Basic
Public Property SupplierID As Integer
    Get
    Set

Property Value

Type: Int32

Remarks

See Also

CashbookBatchDetail Class
CashbookBatchDetail Members
Pastel.Evolution Namespace
Pastel.Evolution..::..InventoryItem


CashbookBatchDetail.Tax Property

[image]

Pastel Evolution SDK
CashbookBatchDetail..::..Tax Property
CashbookBatchDetail Class See Also Send Feedback
Gets or sets the transaction tax amount (automatically rounded to 2 decimals and always posted positive).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double Tax { get; set; }
Visual Basic
Public Property Tax As Double
    Get
    Set

Property Value

Type: Double

See Also

CashbookBatchDetail Class
CashbookBatchDetail Members


CashbookBatchDetail.TaxAccount Property

[image]

Pastel Evolution SDK
CashbookBatchDetail..::..TaxAccount Property
CashbookBatchDetail Class See Also Send Feedback
Gets or sets the tax account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLAccount TaxAccount { get; set; }
Visual Basic
Public Property TaxAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

See Also

CashbookBatchDetail Class
CashbookBatchDetail Members


CashbookBatchDetail.TaxRateID Property

[image]

Pastel Evolution SDK
CashbookBatchDetail..::..TaxRateID Property
CashbookBatchDetail Class See Also Send Feedback
Gets or sets the TaxRate ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int TaxRateID { get; set; }
Visual Basic
Public Property TaxRateID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CashbookBatchDetail Class
CashbookBatchDetail Members


CashbookBatchDetail.TaxType Property

[image]

Pastel Evolution SDK
CashbookBatchDetail..::..TaxType Property
CashbookBatchDetail Class See Also Send Feedback
Gets or sets the TaxRate.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public TaxRate TaxType { get; set; }
Visual Basic
Public Property TaxType As TaxRate
    Get
    Set

Property Value

Type: TaxRate

See Also

CashbookBatchDetail Class
CashbookBatchDetail Members


CashbookBatchDetail.Module Enumeration

[image]

Pastel Evolution SDK
CashbookBatchDetail..::..Module Enumeration
CashbookBatchDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public enum Module
Visual Basic
Public Enumeration Module

Members

Member name | Value | Description
Ledger | 0 |
Receivables | 1 |
Payables | 2 |

See Also

Pastel.Evolution Namespace


CashbookBatchDetail.SplitLineType Enumeration

[image]

Pastel Evolution SDK
CashbookBatchDetail..::..SplitLineType Enumeration
CashbookBatchDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public enum SplitLineType
Visual Basic
Public Enumeration SplitLineType

Members

Member name | Value | Description
NonSplit | 0 |
SplitHeader | 1 |
SplitLines | 2 |

See Also

Pastel.Evolution Namespace


CashbookBatchDetailCollection Class

[image]

Pastel Evolution SDK
CashbookBatchDetailCollection Class
Members See Also Send Feedback
Represents a collection of cashbook batch detail items, typically owned by a given inventory document record.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class CashbookBatchDetailCollection : CollectionBase
Visual Basic
Public Class CashbookBatchDetailCollection
    Inherits CollectionBase

Inheritance Hierarchy

System..::..Object
System.Collections..::..CollectionBase
Pastel.Evolution..::..CashbookBatchDetailCollection

See Also

CashbookBatchDetailCollection Members


CashbookBatchDetailCollection Members

[image] [image]

Pastel Evolution SDK
CashbookBatchDetailCollection Members
CashbookBatchDetailCollection Class Methods Properties Events See Also Send Feedback

The CashbookBatchDetailCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Appends a batch detail object to the batch.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Public method | OnCollectionChanged |
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove | Removes the specified order detail line from the collection
Public method | RemoveAt | Removes a detail record using its zero-based index.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | Gets a batch detail object by its zero-based index.
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

Events

 | Name | Description
Public event | CollectionChanged | Occurs when detail records are added or deleted.

See Also

CashbookBatchDetailCollection Class


CashbookBatchDetailCollection Methods

[image] [image]

Pastel Evolution SDK
CashbookBatchDetailCollection Methods
CashbookBatchDetailCollection Class See Also Send Feedback

The CashbookBatchDetailCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Appends a batch detail object to the batch.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Public method | OnCollectionChanged |
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove | Removes the specified order detail line from the collection
Public method | RemoveAt | Removes a detail record using its zero-based index.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CashbookBatchDetailCollection Class


CashbookBatchDetailCollection.Add Method

[image]

Pastel Evolution SDK
CashbookBatchDetailCollection..::..Add Method
CashbookBatchDetailCollection Class See Also Send Feedback
Appends a batch detail object to the batch.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void Add(
    CashbookBatchDetail detailRecord
)
Visual Basic
Public Sub Add (
    detailRecord As CashbookBatchDetail
)

Parameters

detailRecord
Type: Pastel.Evolution..::..CashbookBatchDetail

Remarks

Take note that upon being added to a document, the detail record will assume the document's sales representative and project.

See Also

CashbookBatchDetailCollection Class
CashbookBatchDetailCollection Members


CashbookBatchDetailCollection.OnCollectionChanged Method

[image]

Pastel Evolution SDK
CashbookBatchDetailCollection..::..OnCollectionChanged Method
CashbookBatchDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void OnCollectionChanged(
    CashbookBatchDetailCollection..::..CashbookBatchDetailCollectionChangedEventArgs e
)
Visual Basic
Public Sub OnCollectionChanged (
    e As CashbookBatchDetailCollection..::..CashbookBatchDetailCollectionChangedEventArgs
)

Parameters

e
Type: Pastel.Evolution..::..CashbookBatchDetailCollection..::..CashbookBatchDetailCollectionChangedEventArgs

See Also

CashbookBatchDetailCollection Class
CashbookBatchDetailCollection Members


CashbookBatchDetailCollection.Remove Method

[image]

Pastel Evolution SDK
CashbookBatchDetailCollection..::..Remove Method
CashbookBatchDetailCollection Class See Also Send Feedback
Removes the specified order detail line from the collection

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void Remove(
    CashbookBatchDetail detailRecord
)
Visual Basic
Public Sub Remove (
    detailRecord As CashbookBatchDetail
)

Parameters

detailRecord
Type: Pastel.Evolution..::..CashbookBatchDetail

See Also

CashbookBatchDetailCollection Class
CashbookBatchDetailCollection Members


CashbookBatchDetailCollection.RemoveAt Method

[image]

Pastel Evolution SDK
CashbookBatchDetailCollection..::..RemoveAt Method
CashbookBatchDetailCollection Class See Also Send Feedback
Removes a detail record using its zero-based index.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void RemoveAt(
    int index
)
Visual Basic
Public Sub RemoveAt (
    index As Integer
)

Parameters

index
Type: System..::..Int32

See Also

CashbookBatchDetailCollection Class
CashbookBatchDetailCollection Members


CashbookBatchDetailCollection Properties

[image] [image]

Pastel Evolution SDK
CashbookBatchDetailCollection Properties
CashbookBatchDetailCollection Class See Also Send Feedback

The CashbookBatchDetailCollection type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | Gets a batch detail object by its zero-based index.
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

CashbookBatchDetailCollection Class


CashbookBatchDetailCollection.Item Property

[image]

Pastel Evolution SDK
CashbookBatchDetailCollection..::..Item Property
CashbookBatchDetailCollection Class See Also Send Feedback
Gets a batch detail object by its zero-based index.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public CashbookBatchDetail this[
    int index
] { get; set; }
Visual Basic
Public Default Property Item (
    index As Integer
) As CashbookBatchDetail
    Get
    Set

Parameters

index
Type: System..::..Int32

Return Value

Type: CashbookBatchDetail

See Also

CashbookBatchDetailCollection Class
CashbookBatchDetailCollection Members


CashbookBatchDetailCollection Events

[image] [image]

Pastel Evolution SDK
CashbookBatchDetailCollection Events
CashbookBatchDetailCollection Class See Also Send Feedback

The CashbookBatchDetailCollection type exposes the following members.

Events

 | Name | Description
Public event | CollectionChanged | Occurs when detail records are added or deleted.

See Also

CashbookBatchDetailCollection Class


CashbookBatchDetailCollection.CollectionChanged Event

[image]

Pastel Evolution SDK
CashbookBatchDetailCollection..::..CollectionChanged Event
CashbookBatchDetailCollection Class See Also Send Feedback
Occurs when detail records are added or deleted.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public event CashbookBatchDetailCollection..::..CashbookBatchDetailChangedEventHandler CollectionChanged
Visual Basic
Public Event CollectionChanged As CashbookBatchDetailCollection..::..CashbookBatchDetailChangedEventHandler

Value

Type: Pastel.Evolution..::..CashbookBatchDetailCollection..::..CashbookBatchDetailChangedEventHandler

See Also

CashbookBatchDetailCollection Class
CashbookBatchDetailCollection Members


CashbookBatchDetailCollection.CashbookBatchDetailChangeAction Enumeration

[image]

Pastel Evolution SDK
CashbookBatchDetailCollection..::..CashbookBatchDetailChangeAction Enumeration
CashbookBatchDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public enum CashbookBatchDetailChangeAction
Visual Basic
Public Enumeration CashbookBatchDetailChangeAction

Members

Member name | Value | Description
Added | 0 |
Deleted | 1 |

See Also

Pastel.Evolution Namespace


CashbookBatchDetailCollection.CashbookBatchDetailChangedEventHandler Delegate

[image]

Pastel Evolution SDK
CashbookBatchDetailCollection..::..CashbookBatchDetailChangedEventHandler Delegate
CashbookBatchDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public delegate void CashbookBatchDetailChangedEventHandler(
    Object sender,
    CashbookBatchDetailCollection..::..CashbookBatchDetailCollectionChangedEventArgs e
)
Visual Basic
Public Delegate Sub CashbookBatchDetailChangedEventHandler (
    sender As Object,
    e As CashbookBatchDetailCollection..::..CashbookBatchDetailCollectionChangedEventArgs
)

Parameters

sender
Type: System..::..Object
e
Type: Pastel.Evolution..::..CashbookBatchDetailCollection..::..CashbookBatchDetailCollectionChangedEventArgs

See Also

Pastel.Evolution Namespace


CashbookBatchDetailCollection.CashbookBatchDetailCollectionChangedEventArgs Class

[image]

Pastel Evolution SDK
CashbookBatchDetailCollection..::..CashbookBatchDetailCollectionChangedEventArgs Class
CashbookBatchDetailCollection Class Members See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class CashbookBatchDetailCollectionChangedEventArgs : EventArgs
Visual Basic
Public Class CashbookBatchDetailCollectionChangedEventArgs
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Pastel.Evolution..::..CashbookBatchDetailCollection..::..CashbookBatchDetailCollectionChangedEventArgs

See Also

CashbookBatchDetailCollection..::..CashbookBatchDetailCollectionChangedEventArgs Members


CashbookBatchDetailCollection.CashbookBatchDetailCollectionChangedEventArgs Members

[image] [image]

Pastel Evolution SDK
CashbookBatchDetailCollection..::..CashbookBatchDetailCollectionChangedEventArgs Members
CashbookBatchDetailCollection..::..CashbookBatchDetailCollectionChangedEventArgs Class Constructors Methods Fields See Also Send Feedback

The CashbookBatchDetailCollection..::..CashbookBatchDetailCollectionChangedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | CashbookBatchDetailCollection..::..CashbookBatchDetailCollectionChangedEventArgs | Initializes a new instance of the CashbookBatchDetailCollection..::..CashbookBatchDetailCollectionChangedEventArgs class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | Action |
Public field | DetailRecord |

See Also

CashbookBatchDetailCollection..::..CashbookBatchDetailCollectionChangedEventArgs Class


CashbookBatchDetailCollection.CashbookBatchDetailCollectionChangedEventArgs Constructor

[image]

Pastel Evolution SDK
CashbookBatchDetailCollection..::..CashbookBatchDetailCollectionChangedEventArgs Constructor
CashbookBatchDetailCollection..::..CashbookBatchDetailCollectionChangedEventArgs Class See Also Send Feedback
Initializes a new instance of the CashbookBatchDetailCollection..::..CashbookBatchDetailCollectionChangedEventArgs class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public CashbookBatchDetailCollectionChangedEventArgs(
    CashbookBatchDetail detailRecord,
    CashbookBatchDetailCollection..::..CashbookBatchDetailChangeAction action
)
Visual Basic
Public Sub New (
    detailRecord As CashbookBatchDetail,
    action As CashbookBatchDetailCollection..::..CashbookBatchDetailChangeAction
)

Parameters

detailRecord
Type: Pastel.Evolution..::..CashbookBatchDetail
action
Type: Pastel.Evolution..::..CashbookBatchDetailCollection..::..CashbookBatchDetailChangeAction

See Also

CashbookBatchDetailCollection..::..CashbookBatchDetailCollectionChangedEventArgs Class
CashbookBatchDetailCollection..::..CashbookBatchDetailCollectionChangedEventArgs Members


CashbookBatchDetailCollection.CashbookBatchDetailCollectionChangedEventArgs Fields

[image] [image]

Pastel Evolution SDK
CashbookBatchDetailCollection..::..CashbookBatchDetailCollectionChangedEventArgs Fields
CashbookBatchDetailCollection..::..CashbookBatchDetailCollectionChangedEventArgs Class See Also Send Feedback

The CashbookBatchDetailCollection..::..CashbookBatchDetailCollectionChangedEventArgs type exposes the following members.

Fields

 | Name | Description
Public field | Action |
Public field | DetailRecord |

See Also

CashbookBatchDetailCollection..::..CashbookBatchDetailCollectionChangedEventArgs Class


CashbookBatchDetailCollection.CashbookBatchDetailCollectionChangedEventArgs.Action Field

[image]

Pastel Evolution SDK
CashbookBatchDetailCollection..::..CashbookBatchDetailCollectionChangedEventArgs..::..Action Field
CashbookBatchDetailCollection..::..CashbookBatchDetailCollectionChangedEventArgs Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public CashbookBatchDetailCollection..::..CashbookBatchDetailChangeAction Action
Visual Basic
Public Action As CashbookBatchDetailCollection..::..CashbookBatchDetailChangeAction

Field Value

Type: CashbookBatchDetailCollection..::..CashbookBatchDetailChangeAction

See Also

CashbookBatchDetailCollection..::..CashbookBatchDetailCollectionChangedEventArgs Class
CashbookBatchDetailCollection..::..CashbookBatchDetailCollectionChangedEventArgs Members


CashbookBatchDetailCollection.CashbookBatchDetailCollectionChangedEventArgs.DetailRecord Field

[image]

Pastel Evolution SDK
CashbookBatchDetailCollection..::..CashbookBatchDetailCollectionChangedEventArgs..::..DetailRecord Field
CashbookBatchDetailCollection..::..CashbookBatchDetailCollectionChangedEventArgs Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public CashbookBatchDetail DetailRecord
Visual Basic
Public DetailRecord As CashbookBatchDetail

Field Value

Type: CashbookBatchDetail

See Also

CashbookBatchDetailCollection..::..CashbookBatchDetailCollectionChangedEventArgs Class
CashbookBatchDetailCollection..::..CashbookBatchDetailCollectionChangedEventArgs Members


CashbookBatchDetailCollection.CashbookBatchDetailCollectionChangedEventArgs Methods

[image] [image]

Pastel Evolution SDK
CashbookBatchDetailCollection..::..CashbookBatchDetailCollectionChangedEventArgs Methods
CashbookBatchDetailCollection..::..CashbookBatchDetailCollectionChangedEventArgs Class See Also Send Feedback

The CashbookBatchDetailCollection..::..CashbookBatchDetailCollectionChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CashbookBatchDetailCollection..::..CashbookBatchDetailCollectionChangedEventArgs Class


CashbookBatchSplitCollection Class

[image]

Pastel Evolution SDK
CashbookBatchSplitCollection Class
Members See Also Send Feedback
Represents a collection of cashbook batch detail items, typically owned by a given inventory document record.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class CashbookBatchSplitCollection : CollectionBase
Visual Basic
Public Class CashbookBatchSplitCollection
    Inherits CollectionBase

Inheritance Hierarchy

System..::..Object
System.Collections..::..CollectionBase
Pastel.Evolution..::..CashbookBatchSplitCollection

See Also

CashbookBatchSplitCollection Members


CashbookBatchSplitCollection Members

[image] [image]

Pastel Evolution SDK
CashbookBatchSplitCollection Members
CashbookBatchSplitCollection Class Methods Properties Events See Also Send Feedback

The CashbookBatchSplitCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Appends a batch detail object to the batch.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Public method | OnCollectionChanged |
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove | Removes the specified order detail line from the collection
Public method | RemoveAt | Removes a detail record using its zero-based index.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | Gets a batch detail object by its zero-based index.
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

Events

 | Name | Description
Public event | CollectionChanged | Occurs when detail records are added or deleted.

See Also

CashbookBatchSplitCollection Class


CashbookBatchSplitCollection Methods

[image] [image]

Pastel Evolution SDK
CashbookBatchSplitCollection Methods
CashbookBatchSplitCollection Class See Also Send Feedback

The CashbookBatchSplitCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Appends a batch detail object to the batch.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Public method | OnCollectionChanged |
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove | Removes the specified order detail line from the collection
Public method | RemoveAt | Removes a detail record using its zero-based index.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CashbookBatchSplitCollection Class


CashbookBatchSplitCollection.Add Method

[image]

Pastel Evolution SDK
CashbookBatchSplitCollection..::..Add Method
CashbookBatchSplitCollection Class See Also Send Feedback
Appends a batch detail object to the batch.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void Add(
    CashbookBatchDetail detailRecord
)
Visual Basic
Public Sub Add (
    detailRecord As CashbookBatchDetail
)

Parameters

detailRecord
Type: Pastel.Evolution..::..CashbookBatchDetail

Remarks

Take note that upon being added to a document, the detail record will assume the document's sales representative and project.

See Also

CashbookBatchSplitCollection Class
CashbookBatchSplitCollection Members


CashbookBatchSplitCollection.OnCollectionChanged Method

[image]

Pastel Evolution SDK
CashbookBatchSplitCollection..::..OnCollectionChanged Method
CashbookBatchSplitCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void OnCollectionChanged(
    CashbookBatchSplitCollection..::..CashbookBatchDetailCollectionChangedEventArgs e
)
Visual Basic
Public Sub OnCollectionChanged (
    e As CashbookBatchSplitCollection..::..CashbookBatchDetailCollectionChangedEventArgs
)

Parameters

e
Type: Pastel.Evolution..::..CashbookBatchSplitCollection..::..CashbookBatchDetailCollectionChangedEventArgs

See Also

CashbookBatchSplitCollection Class
CashbookBatchSplitCollection Members


CashbookBatchSplitCollection.Remove Method

[image]

Pastel Evolution SDK
CashbookBatchSplitCollection..::..Remove Method
CashbookBatchSplitCollection Class See Also Send Feedback
Removes the specified order detail line from the collection

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void Remove(
    CashbookBatchDetail detailRecord
)
Visual Basic
Public Sub Remove (
    detailRecord As CashbookBatchDetail
)

Parameters

detailRecord
Type: Pastel.Evolution..::..CashbookBatchDetail

See Also

CashbookBatchSplitCollection Class
CashbookBatchSplitCollection Members


CashbookBatchSplitCollection.RemoveAt Method

[image]

Pastel Evolution SDK
CashbookBatchSplitCollection..::..RemoveAt Method
CashbookBatchSplitCollection Class See Also Send Feedback
Removes a detail record using its zero-based index.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void RemoveAt(
    int index
)
Visual Basic
Public Sub RemoveAt (
    index As Integer
)

Parameters

index
Type: System..::..Int32

See Also

CashbookBatchSplitCollection Class
CashbookBatchSplitCollection Members


CashbookBatchSplitCollection Properties

[image] [image]

Pastel Evolution SDK
CashbookBatchSplitCollection Properties
CashbookBatchSplitCollection Class See Also Send Feedback

The CashbookBatchSplitCollection type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | Gets a batch detail object by its zero-based index.
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

CashbookBatchSplitCollection Class


CashbookBatchSplitCollection.Item Property

[image]

Pastel Evolution SDK
CashbookBatchSplitCollection..::..Item Property
CashbookBatchSplitCollection Class See Also Send Feedback
Gets a batch detail object by its zero-based index.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public CashbookBatchDetail this[
    int index
] { get; set; }
Visual Basic
Public Default Property Item (
    index As Integer
) As CashbookBatchDetail
    Get
    Set

Parameters

index
Type: System..::..Int32

Return Value

Type: CashbookBatchDetail

See Also

CashbookBatchSplitCollection Class
CashbookBatchSplitCollection Members


CashbookBatchSplitCollection Events

[image] [image]

Pastel Evolution SDK
CashbookBatchSplitCollection Events
CashbookBatchSplitCollection Class See Also Send Feedback

The CashbookBatchSplitCollection type exposes the following members.

Events

 | Name | Description
Public event | CollectionChanged | Occurs when detail records are added or deleted.

See Also

CashbookBatchSplitCollection Class


CashbookBatchSplitCollection.CollectionChanged Event

[image]

Pastel Evolution SDK
CashbookBatchSplitCollection..::..CollectionChanged Event
CashbookBatchSplitCollection Class See Also Send Feedback
Occurs when detail records are added or deleted.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public event CashbookBatchSplitCollection..::..CashbookBatchDetailChangedEventHandler CollectionChanged
Visual Basic
Public Event CollectionChanged As CashbookBatchSplitCollection..::..CashbookBatchDetailChangedEventHandler

Value

Type: Pastel.Evolution..::..CashbookBatchSplitCollection..::..CashbookBatchDetailChangedEventHandler

See Also

CashbookBatchSplitCollection Class
CashbookBatchSplitCollection Members


CashbookBatchSplitCollection.CashbookBatchDetailChangeAction Enumeration

[image]

Pastel Evolution SDK
CashbookBatchSplitCollection..::..CashbookBatchDetailChangeAction Enumeration
CashbookBatchSplitCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public enum CashbookBatchDetailChangeAction
Visual Basic
Public Enumeration CashbookBatchDetailChangeAction

Members

Member name | Value | Description
Added | 0 |
Deleted | 1 |

See Also

Pastel.Evolution Namespace


CashbookBatchSplitCollection.CashbookBatchDetailChangedEventHandler Delegate

[image]

Pastel Evolution SDK
CashbookBatchSplitCollection..::..CashbookBatchDetailChangedEventHandler Delegate
CashbookBatchSplitCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public delegate void CashbookBatchDetailChangedEventHandler(
    Object sender,
    CashbookBatchSplitCollection..::..CashbookBatchDetailCollectionChangedEventArgs e
)
Visual Basic
Public Delegate Sub CashbookBatchDetailChangedEventHandler (
    sender As Object,
    e As CashbookBatchSplitCollection..::..CashbookBatchDetailCollectionChangedEventArgs
)

Parameters

sender
Type: System..::..Object
e
Type: Pastel.Evolution..::..CashbookBatchSplitCollection..::..CashbookBatchDetailCollectionChangedEventArgs

See Also

Pastel.Evolution Namespace


CashbookBatchSplitCollection.CashbookBatchDetailCollectionChangedEventArgs Class

[image]

Pastel Evolution SDK
CashbookBatchSplitCollection..::..CashbookBatchDetailCollectionChangedEventArgs Class
CashbookBatchSplitCollection Class Members See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class CashbookBatchDetailCollectionChangedEventArgs : EventArgs
Visual Basic
Public Class CashbookBatchDetailCollectionChangedEventArgs
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Pastel.Evolution..::..CashbookBatchSplitCollection..::..CashbookBatchDetailCollectionChangedEventArgs

See Also

CashbookBatchSplitCollection..::..CashbookBatchDetailCollectionChangedEventArgs Members


CashbookBatchSplitCollection.CashbookBatchDetailCollectionChangedEventArgs Members

[image] [image]

Pastel Evolution SDK
CashbookBatchSplitCollection..::..CashbookBatchDetailCollectionChangedEventArgs Members
CashbookBatchSplitCollection..::..CashbookBatchDetailCollectionChangedEventArgs Class Constructors Methods Fields See Also Send Feedback

The CashbookBatchSplitCollection..::..CashbookBatchDetailCollectionChangedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | CashbookBatchSplitCollection..::..CashbookBatchDetailCollectionChangedEventArgs | Initializes a new instance of the CashbookBatchSplitCollection..::..CashbookBatchDetailCollectionChangedEventArgs class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | Action |
Public field | DetailRecord |

See Also

CashbookBatchSplitCollection..::..CashbookBatchDetailCollectionChangedEventArgs Class


CashbookBatchSplitCollection.CashbookBatchDetailCollectionChangedEventArgs Constructor

[image]

Pastel Evolution SDK
CashbookBatchSplitCollection..::..CashbookBatchDetailCollectionChangedEventArgs Constructor
CashbookBatchSplitCollection..::..CashbookBatchDetailCollectionChangedEventArgs Class See Also Send Feedback
Initializes a new instance of the CashbookBatchSplitCollection..::..CashbookBatchDetailCollectionChangedEventArgs class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public CashbookBatchDetailCollectionChangedEventArgs(
    CashbookBatchDetail detailRecord,
    CashbookBatchSplitCollection..::..CashbookBatchDetailChangeAction action
)
Visual Basic
Public Sub New (
    detailRecord As CashbookBatchDetail,
    action As CashbookBatchSplitCollection..::..CashbookBatchDetailChangeAction
)

Parameters

detailRecord
Type: Pastel.Evolution..::..CashbookBatchDetail
action
Type: Pastel.Evolution..::..CashbookBatchSplitCollection..::..CashbookBatchDetailChangeAction

See Also

CashbookBatchSplitCollection..::..CashbookBatchDetailCollectionChangedEventArgs Class
CashbookBatchSplitCollection..::..CashbookBatchDetailCollectionChangedEventArgs Members


CashbookBatchSplitCollection.CashbookBatchDetailCollectionChangedEventArgs Fields

[image] [image]

Pastel Evolution SDK
CashbookBatchSplitCollection..::..CashbookBatchDetailCollectionChangedEventArgs Fields
CashbookBatchSplitCollection..::..CashbookBatchDetailCollectionChangedEventArgs Class See Also Send Feedback

The CashbookBatchSplitCollection..::..CashbookBatchDetailCollectionChangedEventArgs type exposes the following members.

Fields

 | Name | Description
Public field | Action |
Public field | DetailRecord |

See Also

CashbookBatchSplitCollection..::..CashbookBatchDetailCollectionChangedEventArgs Class


CashbookBatchSplitCollection.CashbookBatchDetailCollectionChangedEventArgs.Action Field

[image]

Pastel Evolution SDK
CashbookBatchSplitCollection..::..CashbookBatchDetailCollectionChangedEventArgs..::..Action Field
CashbookBatchSplitCollection..::..CashbookBatchDetailCollectionChangedEventArgs Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public CashbookBatchSplitCollection..::..CashbookBatchDetailChangeAction Action
Visual Basic
Public Action As CashbookBatchSplitCollection..::..CashbookBatchDetailChangeAction

Field Value

Type: CashbookBatchSplitCollection..::..CashbookBatchDetailChangeAction

See Also

CashbookBatchSplitCollection..::..CashbookBatchDetailCollectionChangedEventArgs Class
CashbookBatchSplitCollection..::..CashbookBatchDetailCollectionChangedEventArgs Members


CashbookBatchSplitCollection.CashbookBatchDetailCollectionChangedEventArgs.DetailRecord Field

[image]

Pastel Evolution SDK
CashbookBatchSplitCollection..::..CashbookBatchDetailCollectionChangedEventArgs..::..DetailRecord Field
CashbookBatchSplitCollection..::..CashbookBatchDetailCollectionChangedEventArgs Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public CashbookBatchDetail DetailRecord
Visual Basic
Public DetailRecord As CashbookBatchDetail

Field Value

Type: CashbookBatchDetail

See Also

CashbookBatchSplitCollection..::..CashbookBatchDetailCollectionChangedEventArgs Class
CashbookBatchSplitCollection..::..CashbookBatchDetailCollectionChangedEventArgs Members


CashbookBatchSplitCollection.CashbookBatchDetailCollectionChangedEventArgs Methods

[image] [image]

Pastel Evolution SDK
CashbookBatchSplitCollection..::..CashbookBatchDetailCollectionChangedEventArgs Methods
CashbookBatchSplitCollection..::..CashbookBatchDetailCollectionChangedEventArgs Class See Also Send Feedback

The CashbookBatchSplitCollection..::..CashbookBatchDetailCollectionChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CashbookBatchSplitCollection..::..CashbookBatchDetailCollectionChangedEventArgs Class


ComHelper Class

[image]

Pastel Evolution SDK
ComHelper Class
Members See Also Send Feedback
Provides various functions for overcoming the limitations of accessing the API via COM. This class gets extended as required.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class ComHelper
Visual Basic
Public Class ComHelper

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..ComHelper

See Also

ComHelper Members


ComHelper Members

[image] [image]

Pastel Evolution SDK
ComHelper Members
ComHelper Class Constructors Methods Properties See Also Send Feedback

The ComHelper type exposes the following members.

Constructors

 | Name | Description
Public method | ComHelper | Initializes a new instance of the ComHelper class

Methods

 | Name | Description
Public method | Address |
Public method | AuthenticateAgent |
Public method | BeginTran |
Public method | CommitTran |
Public method | CompleteDocumentWithCustomReference |
Public method | CreateCommonDBConnection |
Public method | CreateConnection |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindAgent |
Public method | FindAgentByNAme |
Public method | FindAPAccount |
Public method | FindAPAccountByCode |
Public method | FindARAccount |
Public method | FindARAccountByCode |
Public method | FindGLAccount |
Public method | FindGLAccountByCode |
Public method | FindIncident |
Public method | FindIncidentCategory |
Public method | FindIncidentCategoryByDescription |
Public method | FindInventoryDocument |
Public method | FindJobCard |
Public method | FindJobCardByCode |
Public method | FindPriority |
Public method | FindProject |
Public method | FindProjectByCode |
Public method | FindSalesRepresentative |
Public method | FindSalesRepresentativeByCode |
Public method | FindStockItem |
Public method | FindStockItemByCode |
Public method | FindUnit |
Public method | FindUnitCategory |
Public method | GetAgentByName |
Public method | GetAPAccount |
Public method | GetAPTransaction |
Public method | GetAPTransactionsAsXml |
Public method | GetARAccount |
Public method | GetARTransaction |
Public method | GetARTransactionsAsXml |
Public method | GetGLAccount |
Public method | GetGLTransaction |
Public method | GetGLTransactionsAsXml |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIncidentByCode |
Public method | GetIncidentCategoryByDescription |
Public method | GetIncidentTypeByDescription |
Public method | GetJobCard |
Public method | GetJobTransactionCode |
Public method | GetLotByCode |
Public method | GetPriorityByDescription |
Public method | GetProjectByCode |
Public method | GetPurchaseOrder |
Public method | GetSalesOrder |
Public method | GetSalesRepresentative |
Public method | GetStockItem |
Public method | GetSupplierInvoice |
Public method | GetTaxRate |
Public method | GetTransactionCode |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUnitByCode |
Public method | GetUnitByID |
Public method | GetUnitCategoryByCode |
Public method | GetUnitCategoryByID |
Public method | GetWarehouseByCode |
Public method | GetWarehouseByID |
Public method | GetWarehouseContextByCode |
Public method | GetWarehouseContextByID |
Public method | GetWarehouseContextByWarehouse |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProcessDocumentWithCustomReference |
Public method | ProcessStockWithCustomReference |
Public method | RollbackTran |
Public method | SetBranchContext |
Public method | SetCurrentAgent |
Public method | SetLicense |
Public method | SetUserFieldValue |
Public method | StartNewBatch |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyVersion |
Public property | CompatibleEvolutionDatabaseVersion |
Public property | CurrentEvolutionDatabaseVersion |
Public property | RegistrationExpiryDate |
Public property | RmsUsers | Obsolete.

See Also

ComHelper Class


ComHelper Constructor

[image]

Pastel Evolution SDK
ComHelper Constructor
ComHelper Class See Also Send Feedback
Initializes a new instance of the ComHelper class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public ComHelper()
Visual Basic
Public Sub New

See Also

ComHelper Class
ComHelper Members


ComHelper Methods

[image] [image]

Pastel Evolution SDK
ComHelper Methods
ComHelper Class See Also Send Feedback

The ComHelper type exposes the following members.

Methods

 | Name | Description
Public method | Address |
Public method | AuthenticateAgent |
Public method | BeginTran |
Public method | CommitTran |
Public method | CompleteDocumentWithCustomReference |
Public method | CreateCommonDBConnection |
Public method | CreateConnection |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindAgent |
Public method | FindAgentByNAme |
Public method | FindAPAccount |
Public method | FindAPAccountByCode |
Public method | FindARAccount |
Public method | FindARAccountByCode |
Public method | FindGLAccount |
Public method | FindGLAccountByCode |
Public method | FindIncident |
Public method | FindIncidentCategory |
Public method | FindIncidentCategoryByDescription |
Public method | FindInventoryDocument |
Public method | FindJobCard |
Public method | FindJobCardByCode |
Public method | FindPriority |
Public method | FindProject |
Public method | FindProjectByCode |
Public method | FindSalesRepresentative |
Public method | FindSalesRepresentativeByCode |
Public method | FindStockItem |
Public method | FindStockItemByCode |
Public method | FindUnit |
Public method | FindUnitCategory |
Public method | GetAgentByName |
Public method | GetAPAccount |
Public method | GetAPTransaction |
Public method | GetAPTransactionsAsXml |
Public method | GetARAccount |
Public method | GetARTransaction |
Public method | GetARTransactionsAsXml |
Public method | GetGLAccount |
Public method | GetGLTransaction |
Public method | GetGLTransactionsAsXml |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIncidentByCode |
Public method | GetIncidentCategoryByDescription |
Public method | GetIncidentTypeByDescription |
Public method | GetJobCard |
Public method | GetJobTransactionCode |
Public method | GetLotByCode |
Public method | GetPriorityByDescription |
Public method | GetProjectByCode |
Public method | GetPurchaseOrder |
Public method | GetSalesOrder |
Public method | GetSalesRepresentative |
Public method | GetStockItem |
Public method | GetSupplierInvoice |
Public method | GetTaxRate |
Public method | GetTransactionCode |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUnitByCode |
Public method | GetUnitByID |
Public method | GetUnitCategoryByCode |
Public method | GetUnitCategoryByID |
Public method | GetWarehouseByCode |
Public method | GetWarehouseByID |
Public method | GetWarehouseContextByCode |
Public method | GetWarehouseContextByID |
Public method | GetWarehouseContextByWarehouse |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProcessDocumentWithCustomReference |
Public method | ProcessStockWithCustomReference |
Public method | RollbackTran |
Public method | SetBranchContext |
Public method | SetCurrentAgent |
Public method | SetLicense |
Public method | SetUserFieldValue |
Public method | StartNewBatch |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ComHelper Class


ComHelper.Address Method

[image]

Pastel Evolution SDK
ComHelper..::..Address Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Address Address(
    string line1,
    string line2,
    string line3,
    string line4,
    string line5,
    string postalCode
)
Visual Basic
Public Function Address (
    line1 As String,
    line2 As String,
    line3 As String,
    line4 As String,
    line5 As String,
    postalCode As String
) As Address

Parameters

line1
Type: System..::..String
line2
Type: System..::..String
line3
Type: System..::..String
line4
Type: System..::..String
line5
Type: System..::..String
postalCode
Type: System..::..String

Return Value

Type: Address

See Also

ComHelper Class
ComHelper Members


ComHelper.AuthenticateAgent Method

[image]

Pastel Evolution SDK
ComHelper..::..AuthenticateAgent Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool AuthenticateAgent(
    string agentName,
    string password
)
Visual Basic
Public Function AuthenticateAgent (
    agentName As String,
    password As String
) As Boolean

Parameters

agentName
Type: System..::..String
password
Type: System..::..String

Return Value

Type: Boolean

See Also

ComHelper Class
ComHelper Members


ComHelper.BeginTran Method

[image]

Pastel Evolution SDK
ComHelper..::..BeginTran Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void BeginTran()
Visual Basic
Public Sub BeginTran

See Also

ComHelper Class
ComHelper Members


ComHelper.CommitTran Method

[image]

Pastel Evolution SDK
ComHelper..::..CommitTran Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void CommitTran()
Visual Basic
Public Sub CommitTran

See Also

ComHelper Class
ComHelper Members


ComHelper.CompleteDocumentWithCustomReference Method

[image]

Pastel Evolution SDK
ComHelper..::..CompleteDocumentWithCustomReference Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string CompleteDocumentWithCustomReference(
    OrderBase document,
    string reference
)
Visual Basic
Public Function CompleteDocumentWithCustomReference (
    document As OrderBase,
    reference As String
) As String

Parameters

document
Type: Pastel.Evolution..::..OrderBase
reference
Type: System..::..String

Return Value

Type: String

See Also

ComHelper Class
ComHelper Members


ComHelper.CreateCommonDBConnection Method

[image]

Pastel Evolution SDK
ComHelper..::..CreateCommonDBConnection Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void CreateCommonDBConnection(
    string connectionString
)
Visual Basic
Public Sub CreateCommonDBConnection (
    connectionString As String
)

Parameters

connectionString
Type: System..::..String

See Also

ComHelper Class
ComHelper Members


ComHelper.CreateConnection Method

[image]

Pastel Evolution SDK
ComHelper..::..CreateConnection Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void CreateConnection(
    string connectionString
)
Visual Basic
Public Sub CreateConnection (
    connectionString As String
)

Parameters

connectionString
Type: System..::..String

See Also

ComHelper Class
ComHelper Members


ComHelper.FindAgent Method

[image]

Pastel Evolution SDK
ComHelper..::..FindAgent Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int FindAgent(
    string criteria
)
Visual Basic
Public Function FindAgent (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String

Return Value

Type: Int32

See Also

ComHelper Class
ComHelper Members


ComHelper.FindAgentByNAme Method

[image]

Pastel Evolution SDK
ComHelper..::..FindAgentByNAme Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int FindAgentByNAme(
    string name
)
Visual Basic
Public Function FindAgentByNAme (
    name As String
) As Integer

Parameters

name
Type: System..::..String

Return Value

Type: Int32

See Also

ComHelper Class
ComHelper Members


ComHelper.FindAPAccount Method

[image]

Pastel Evolution SDK
ComHelper..::..FindAPAccount Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int FindAPAccount(
    string criteria
)
Visual Basic
Public Function FindAPAccount (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String

Return Value

Type: Int32

See Also

ComHelper Class
ComHelper Members


ComHelper.FindAPAccountByCode Method

[image]

Pastel Evolution SDK
ComHelper..::..FindAPAccountByCode Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int FindAPAccountByCode(
    string code
)
Visual Basic
Public Function FindAPAccountByCode (
    code As String
) As Integer

Parameters

code
Type: System..::..String

Return Value

Type: Int32

See Also

ComHelper Class
ComHelper Members


ComHelper.FindARAccount Method

[image]

Pastel Evolution SDK
ComHelper..::..FindARAccount Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int FindARAccount(
    string criteria
)
Visual Basic
Public Function FindARAccount (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String

Return Value

Type: Int32

See Also

ComHelper Class
ComHelper Members


ComHelper.FindARAccountByCode Method

[image]

Pastel Evolution SDK
ComHelper..::..FindARAccountByCode Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int FindARAccountByCode(
    string code
)
Visual Basic
Public Function FindARAccountByCode (
    code As String
) As Integer

Parameters

code
Type: System..::..String

Return Value

Type: Int32

See Also

ComHelper Class
ComHelper Members


ComHelper.FindGLAccount Method

[image]

Pastel Evolution SDK
ComHelper..::..FindGLAccount Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int FindGLAccount(
    string criteria
)
Visual Basic
Public Function FindGLAccount (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String

Return Value

Type: Int32

See Also

ComHelper Class
ComHelper Members


ComHelper.FindGLAccountByCode Method

[image]

Pastel Evolution SDK
ComHelper..::..FindGLAccountByCode Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int FindGLAccountByCode(
    string code
)
Visual Basic
Public Function FindGLAccountByCode (
    code As String
) As Integer

Parameters

code
Type: System..::..String

Return Value

Type: Int32

See Also

ComHelper Class
ComHelper Members


ComHelper.FindIncident Method

[image]

Pastel Evolution SDK
ComHelper..::..FindIncident Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int FindIncident(
    string criteria
)
Visual Basic
Public Function FindIncident (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String

Return Value

Type: Int32

See Also

ComHelper Class
ComHelper Members


ComHelper.FindIncidentCategory Method

[image]

Pastel Evolution SDK
ComHelper..::..FindIncidentCategory Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int FindIncidentCategory(
    string criteria
)
Visual Basic
Public Function FindIncidentCategory (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String

Return Value

Type: Int32

See Also

ComHelper Class
ComHelper Members


ComHelper.FindIncidentCategoryByDescription Method

[image]

Pastel Evolution SDK
ComHelper..::..FindIncidentCategoryByDescription Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int FindIncidentCategoryByDescription(
    string description
)
Visual Basic
Public Function FindIncidentCategoryByDescription (
    description As String
) As Integer

Parameters

description
Type: System..::..String

Return Value

Type: Int32

See Also

ComHelper Class
ComHelper Members


ComHelper.FindInventoryDocument Method

[image]

Pastel Evolution SDK
ComHelper..::..FindInventoryDocument Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int FindInventoryDocument(
    DocumentType docType,
    string criteria
)
Visual Basic
Public Function FindInventoryDocument (
    docType As DocumentType,
    criteria As String
) As Integer

Parameters

docType
Type: Pastel.Evolution..::..DocumentType
criteria
Type: System..::..String

Return Value

Type: Int32

See Also

ComHelper Class
ComHelper Members


ComHelper.FindJobCard Method

[image]

Pastel Evolution SDK
ComHelper..::..FindJobCard Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int FindJobCard(
    string criteria
)
Visual Basic
Public Function FindJobCard (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String

Return Value

Type: Int32

See Also

ComHelper Class
ComHelper Members


ComHelper.FindJobCardByCode Method

[image]

Pastel Evolution SDK
ComHelper..::..FindJobCardByCode Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int FindJobCardByCode(
    string code
)
Visual Basic
Public Function FindJobCardByCode (
    code As String
) As Integer

Parameters

code
Type: System..::..String

Return Value

Type: Int32

See Also

ComHelper Class
ComHelper Members


ComHelper.FindPriority Method

[image]

Pastel Evolution SDK
ComHelper..::..FindPriority Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int FindPriority(
    string criteria
)
Visual Basic
Public Function FindPriority (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String

Return Value

Type: Int32

See Also

ComHelper Class
ComHelper Members


ComHelper.FindProject Method

[image]

Pastel Evolution SDK
ComHelper..::..FindProject Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int FindProject(
    string criteria
)
Visual Basic
Public Function FindProject (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String

Return Value

Type: Int32

See Also

ComHelper Class
ComHelper Members


ComHelper.FindProjectByCode Method

[image]

Pastel Evolution SDK
ComHelper..::..FindProjectByCode Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int FindProjectByCode(
    string code
)
Visual Basic
Public Function FindProjectByCode (
    code As String
) As Integer

Parameters

code
Type: System..::..String

Return Value

Type: Int32

See Also

ComHelper Class
ComHelper Members


ComHelper.FindSalesRepresentative Method

[image]

Pastel Evolution SDK
ComHelper..::..FindSalesRepresentative Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int FindSalesRepresentative(
    string criteria
)
Visual Basic
Public Function FindSalesRepresentative (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String

Return Value

Type: Int32

See Also

ComHelper Class
ComHelper Members


ComHelper.FindSalesRepresentativeByCode Method

[image]

Pastel Evolution SDK
ComHelper..::..FindSalesRepresentativeByCode Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int FindSalesRepresentativeByCode(
    string code
)
Visual Basic
Public Function FindSalesRepresentativeByCode (
    code As String
) As Integer

Parameters

code
Type: System..::..String

Return Value

Type: Int32

See Also

ComHelper Class
ComHelper Members


ComHelper.FindStockItem Method

[image]

Pastel Evolution SDK
ComHelper..::..FindStockItem Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int FindStockItem(
    string criteria
)
Visual Basic
Public Function FindStockItem (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String

Return Value

Type: Int32

See Also

ComHelper Class
ComHelper Members


ComHelper.FindStockItemByCode Method

[image]

Pastel Evolution SDK
ComHelper..::..FindStockItemByCode Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int FindStockItemByCode(
    string code
)
Visual Basic
Public Function FindStockItemByCode (
    code As String
) As Integer

Parameters

code
Type: System..::..String

Return Value

Type: Int32

See Also

ComHelper Class
ComHelper Members


ComHelper.FindUnit Method

[image]

Pastel Evolution SDK
ComHelper..::..FindUnit Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int FindUnit(
    string criteria
)
Visual Basic
Public Function FindUnit (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String

Return Value

Type: Int32

See Also

ComHelper Class
ComHelper Members


ComHelper.FindUnitCategory Method

[image]

Pastel Evolution SDK
ComHelper..::..FindUnitCategory Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int FindUnitCategory(
    string criteria
)
Visual Basic
Public Function FindUnitCategory (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String

Return Value

Type: Int32

See Also

ComHelper Class
ComHelper Members


ComHelper.GetAgentByName Method

[image]

Pastel Evolution SDK
ComHelper..::..GetAgentByName Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Agent GetAgentByName(
    string name
)
Visual Basic
Public Function GetAgentByName (
    name As String
) As Agent

Parameters

name
Type: System..::..String

Return Value

Type: Agent

See Also

ComHelper Class
ComHelper Members


ComHelper.GetAPAccount Method

[image]

Pastel Evolution SDK
ComHelper..::..GetAPAccount Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Supplier GetAPAccount(
    string code
)
Visual Basic
Public Function GetAPAccount (
    code As String
) As Supplier

Parameters

code
Type: System..::..String

Return Value

Type: Supplier

See Also

ComHelper Class
ComHelper Members


ComHelper.GetAPTransaction Method

[image]

Pastel Evolution SDK
ComHelper..::..GetAPTransaction Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public SupplierTransaction GetAPTransaction(
    int id
)
Visual Basic
Public Function GetAPTransaction (
    id As Integer
) As SupplierTransaction

Parameters

id
Type: System..::..Int32

Return Value

Type: SupplierTransaction

See Also

ComHelper Class
ComHelper Members


ComHelper.GetAPTransactionsAsXml Method

[image]

Pastel Evolution SDK
ComHelper..::..GetAPTransactionsAsXml Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string GetAPTransactionsAsXml(
    Supplier account,
    string criteria
)
Visual Basic
Public Function GetAPTransactionsAsXml (
    account As Supplier,
    criteria As String
) As String

Parameters

account
Type: Pastel.Evolution..::..Supplier
criteria
Type: System..::..String

Return Value

Type: String

See Also

ComHelper Class
ComHelper Members


ComHelper.GetARAccount Method

[image]

Pastel Evolution SDK
ComHelper..::..GetARAccount Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Customer GetARAccount(
    string code
)
Visual Basic
Public Function GetARAccount (
    code As String
) As Customer

Parameters

code
Type: System..::..String

Return Value

Type: Customer

See Also

ComHelper Class
ComHelper Members


ComHelper.GetARTransaction Method

[image]

Pastel Evolution SDK
ComHelper..::..GetARTransaction Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public CustomerTransaction GetARTransaction(
    int id
)
Visual Basic
Public Function GetARTransaction (
    id As Integer
) As CustomerTransaction

Parameters

id
Type: System..::..Int32

Return Value

Type: CustomerTransaction

See Also

ComHelper Class
ComHelper Members


ComHelper.GetARTransactionsAsXml Method

[image]

Pastel Evolution SDK
ComHelper..::..GetARTransactionsAsXml Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string GetARTransactionsAsXml(
    Customer account,
    string criteria
)
Visual Basic
Public Function GetARTransactionsAsXml (
    account As Customer,
    criteria As String
) As String

Parameters

account
Type: Pastel.Evolution..::..Customer
criteria
Type: System..::..String

Return Value

Type: String

See Also

ComHelper Class
ComHelper Members


ComHelper.GetGLAccount Method

[image]

Pastel Evolution SDK
ComHelper..::..GetGLAccount Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLAccount GetGLAccount(
    string code
)
Visual Basic
Public Function GetGLAccount (
    code As String
) As GLAccount

Parameters

code
Type: System..::..String

Return Value

Type: GLAccount

See Also

ComHelper Class
ComHelper Members


ComHelper.GetGLTransaction Method

[image]

Pastel Evolution SDK
ComHelper..::..GetGLTransaction Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLTransaction GetGLTransaction(
    int id
)
Visual Basic
Public Function GetGLTransaction (
    id As Integer
) As GLTransaction

Parameters

id
Type: System..::..Int32

Return Value

Type: GLTransaction

See Also

ComHelper Class
ComHelper Members


ComHelper.GetGLTransactionsAsXml Method

[image]

Pastel Evolution SDK
ComHelper..::..GetGLTransactionsAsXml Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string GetGLTransactionsAsXml(
    GLAccount account,
    string criteria
)
Visual Basic
Public Function GetGLTransactionsAsXml (
    account As GLAccount,
    criteria As String
) As String

Parameters

account
Type: Pastel.Evolution..::..GLAccount
criteria
Type: System..::..String

Return Value

Type: String

See Also

ComHelper Class
ComHelper Members


ComHelper.GetIncidentByCode Method

[image]

Pastel Evolution SDK
ComHelper..::..GetIncidentByCode Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Incident GetIncidentByCode(
    string reference
)
Visual Basic
Public Function GetIncidentByCode (
    reference As String
) As Incident

Parameters

reference
Type: System..::..String

Return Value

Type: Incident

See Also

ComHelper Class
ComHelper Members


ComHelper.GetIncidentCategoryByDescription Method

[image]

Pastel Evolution SDK
ComHelper..::..GetIncidentCategoryByDescription Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public IncidentCategory GetIncidentCategoryByDescription(
    string description
)
Visual Basic
Public Function GetIncidentCategoryByDescription (
    description As String
) As IncidentCategory

Parameters

description
Type: System..::..String

Return Value

Type: IncidentCategory

See Also

ComHelper Class
ComHelper Members


ComHelper.GetIncidentTypeByDescription Method

[image]

Pastel Evolution SDK
ComHelper..::..GetIncidentTypeByDescription Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public IncidentType GetIncidentTypeByDescription(
    string description
)
Visual Basic
Public Function GetIncidentTypeByDescription (
    description As String
) As IncidentType

Parameters

description
Type: System..::..String

Return Value

Type: IncidentType

See Also

ComHelper Class
ComHelper Members


ComHelper.GetJobCard Method

[image]

Pastel Evolution SDK
ComHelper..::..GetJobCard Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public JobCard GetJobCard(
    string code
)
Visual Basic
Public Function GetJobCard (
    code As String
) As JobCard

Parameters

code
Type: System..::..String

Return Value

Type: JobCard

See Also

ComHelper Class
ComHelper Members


ComHelper.GetJobTransactionCode Method

[image]

Pastel Evolution SDK
ComHelper..::..GetJobTransactionCode Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public JobTransactionCode GetJobTransactionCode(
    JobDetail..::..TransactionSource tranSource,
    string code
)
Visual Basic
Public Function GetJobTransactionCode (
    tranSource As JobDetail..::..TransactionSource,
    code As String
) As JobTransactionCode

Parameters

tranSource
Type: Pastel.Evolution..::..JobDetail..::..TransactionSource
code
Type: System..::..String

Return Value

Type: JobTransactionCode

See Also

ComHelper Class
ComHelper Members


ComHelper.GetLotByCode Method

[image]

Pastel Evolution SDK
ComHelper..::..GetLotByCode Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Lot GetLotByCode(
    InventoryItem inventoryItem,
    string code
)
Visual Basic
Public Function GetLotByCode (
    inventoryItem As InventoryItem,
    code As String
) As Lot

Parameters

inventoryItem
Type: Pastel.Evolution..::..InventoryItem
code
Type: System..::..String

Return Value

Type: Lot

See Also

ComHelper Class
ComHelper Members


ComHelper.GetPriorityByDescription Method

[image]

Pastel Evolution SDK
ComHelper..::..GetPriorityByDescription Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Priority GetPriorityByDescription(
    string description
)
Visual Basic
Public Function GetPriorityByDescription (
    description As String
) As Priority

Parameters

description
Type: System..::..String

Return Value

Type: Priority

See Also

ComHelper Class
ComHelper Members


ComHelper.GetProjectByCode Method

[image]

Pastel Evolution SDK
ComHelper..::..GetProjectByCode Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Project GetProjectByCode(
    string code
)
Visual Basic
Public Function GetProjectByCode (
    code As String
) As Project

Parameters

code
Type: System..::..String

Return Value

Type: Project

See Also

ComHelper Class
ComHelper Members


ComHelper.GetPurchaseOrder Method

[image]

Pastel Evolution SDK
ComHelper..::..GetPurchaseOrder Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public PurchaseOrder GetPurchaseOrder(
    string orderNumber
)
Visual Basic
Public Function GetPurchaseOrder (
    orderNumber As String
) As PurchaseOrder

Parameters

orderNumber
Type: System..::..String

Return Value

Type: PurchaseOrder

See Also

ComHelper Class
ComHelper Members


ComHelper.GetSalesOrder Method

[image]

Pastel Evolution SDK
ComHelper..::..GetSalesOrder Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public SalesOrder GetSalesOrder(
    string orderNumber
)
Visual Basic
Public Function GetSalesOrder (
    orderNumber As String
) As SalesOrder

Parameters

orderNumber
Type: System..::..String

Return Value

Type: SalesOrder

See Also

ComHelper Class
ComHelper Members


ComHelper.GetSalesRepresentative Method

[image]

Pastel Evolution SDK
ComHelper..::..GetSalesRepresentative Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public SalesRepresentative GetSalesRepresentative(
    string code
)
Visual Basic
Public Function GetSalesRepresentative (
    code As String
) As SalesRepresentative

Parameters

code
Type: System..::..String

Return Value

Type: SalesRepresentative

See Also

ComHelper Class
ComHelper Members


ComHelper.GetStockItem Method

[image]

Pastel Evolution SDK
ComHelper..::..GetStockItem Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public InventoryItem GetStockItem(
    string code
)
Visual Basic
Public Function GetStockItem (
    code As String
) As InventoryItem

Parameters

code
Type: System..::..String

Return Value

Type: InventoryItem

See Also

ComHelper Class
ComHelper Members


ComHelper.GetSupplierInvoice Method

[image]

Pastel Evolution SDK
ComHelper..::..GetSupplierInvoice Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public PurchaseOrder GetSupplierInvoice(
    string orderNumber,
    string grvNumber
)
Visual Basic
Public Function GetSupplierInvoice (
    orderNumber As String,
    grvNumber As String
) As PurchaseOrder

Parameters

orderNumber
Type: System..::..String
grvNumber
Type: System..::..String

Return Value

Type: PurchaseOrder

See Also

ComHelper Class
ComHelper Members


ComHelper.GetTaxRate Method

[image]

Pastel Evolution SDK
ComHelper..::..GetTaxRate Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public TaxRate GetTaxRate(
    string code
)
Visual Basic
Public Function GetTaxRate (
    code As String
) As TaxRate

Parameters

code
Type: System..::..String

Return Value

Type: TaxRate

See Also

ComHelper Class
ComHelper Members


ComHelper.GetTransactionCode Method

[image]

Pastel Evolution SDK
ComHelper..::..GetTransactionCode Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public TransactionCodeBase GetTransactionCode(
    Module module,
    string code
)
Visual Basic
Public Function GetTransactionCode (
    module As Module,
    code As String
) As TransactionCodeBase

Parameters

module
Type: Pastel.Evolution..::..Module
code
Type: System..::..String

Return Value

Type: TransactionCodeBase

See Also

ComHelper Class
ComHelper Members


ComHelper.GetUnitByCode Method

[image]

Pastel Evolution SDK
ComHelper..::..GetUnitByCode Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Unit GetUnitByCode(
    string code
)
Visual Basic
Public Function GetUnitByCode (
    code As String
) As Unit

Parameters

code
Type: System..::..String

Return Value

Type: Unit

See Also

ComHelper Class
ComHelper Members


ComHelper.GetUnitByID Method

[image]

Pastel Evolution SDK
ComHelper..::..GetUnitByID Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Unit GetUnitByID(
    int id
)
Visual Basic
Public Function GetUnitByID (
    id As Integer
) As Unit

Parameters

id
Type: System..::..Int32

Return Value

Type: Unit

See Also

ComHelper Class
ComHelper Members


ComHelper.GetUnitCategoryByCode Method

[image]

Pastel Evolution SDK
ComHelper..::..GetUnitCategoryByCode Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public UnitCategory GetUnitCategoryByCode(
    string code
)
Visual Basic
Public Function GetUnitCategoryByCode (
    code As String
) As UnitCategory

Parameters

code
Type: System..::..String

Return Value

Type: UnitCategory

See Also

ComHelper Class
ComHelper Members


ComHelper.GetUnitCategoryByID Method

[image]

Pastel Evolution SDK
ComHelper..::..GetUnitCategoryByID Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public UnitCategory GetUnitCategoryByID(
    int id
)
Visual Basic
Public Function GetUnitCategoryByID (
    id As Integer
) As UnitCategory

Parameters

id
Type: System..::..Int32

Return Value

Type: UnitCategory

See Also

ComHelper Class
ComHelper Members


ComHelper.GetWarehouseByCode Method

[image]

Pastel Evolution SDK
ComHelper..::..GetWarehouseByCode Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Warehouse GetWarehouseByCode(
    string code
)
Visual Basic
Public Function GetWarehouseByCode (
    code As String
) As Warehouse

Parameters

code
Type: System..::..String

Return Value

Type: Warehouse

See Also

ComHelper Class
ComHelper Members


ComHelper.GetWarehouseByID Method

[image]

Pastel Evolution SDK
ComHelper..::..GetWarehouseByID Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Warehouse GetWarehouseByID(
    int id
)
Visual Basic
Public Function GetWarehouseByID (
    id As Integer
) As Warehouse

Parameters

id
Type: System..::..Int32

Return Value

Type: Warehouse

See Also

ComHelper Class
ComHelper Members


ComHelper.GetWarehouseContextByCode Method

[image]

Pastel Evolution SDK
ComHelper..::..GetWarehouseContextByCode Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public WarehouseContext GetWarehouseContextByCode(
    InventoryItem item,
    string code
)
Visual Basic
Public Function GetWarehouseContextByCode (
    item As InventoryItem,
    code As String
) As WarehouseContext

Parameters

item
Type: Pastel.Evolution..::..InventoryItem
code
Type: System..::..String

Return Value

Type: WarehouseContext

See Also

ComHelper Class
ComHelper Members


ComHelper.GetWarehouseContextByID Method

[image]

Pastel Evolution SDK
ComHelper..::..GetWarehouseContextByID Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public WarehouseContext GetWarehouseContextByID(
    InventoryItem item,
    int id
)
Visual Basic
Public Function GetWarehouseContextByID (
    item As InventoryItem,
    id As Integer
) As WarehouseContext

Parameters

item
Type: Pastel.Evolution..::..InventoryItem
id
Type: System..::..Int32

Return Value

Type: WarehouseContext

See Also

ComHelper Class
ComHelper Members


ComHelper.GetWarehouseContextByWarehouse Method

[image]

Pastel Evolution SDK
ComHelper..::..GetWarehouseContextByWarehouse Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public WarehouseContext GetWarehouseContextByWarehouse(
    InventoryItem item,
    Warehouse whse
)
Visual Basic
Public Function GetWarehouseContextByWarehouse (
    item As InventoryItem,
    whse As Warehouse
) As WarehouseContext

Parameters

item
Type: Pastel.Evolution..::..InventoryItem
whse
Type: Pastel.Evolution..::..Warehouse

Return Value

Type: WarehouseContext

See Also

ComHelper Class
ComHelper Members


ComHelper.ProcessDocumentWithCustomReference Method

[image]

Pastel Evolution SDK
ComHelper..::..ProcessDocumentWithCustomReference Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string ProcessDocumentWithCustomReference(
    OrderBase document,
    string reference
)
Visual Basic
Public Function ProcessDocumentWithCustomReference (
    document As OrderBase,
    reference As String
) As String

Parameters

document
Type: Pastel.Evolution..::..OrderBase
reference
Type: System..::..String

Return Value

Type: String

See Also

ComHelper Class
ComHelper Members


ComHelper.ProcessStockWithCustomReference Method

[image]

Pastel Evolution SDK
ComHelper..::..ProcessStockWithCustomReference Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string ProcessStockWithCustomReference(
    PurchaseOrder purchaseOrder,
    string reference
)
Visual Basic
Public Function ProcessStockWithCustomReference (
    purchaseOrder As PurchaseOrder,
    reference As String
) As String

Parameters

purchaseOrder
Type: Pastel.Evolution..::..PurchaseOrder
reference
Type: System..::..String

Return Value

Type: String

See Also

ComHelper Class
ComHelper Members


ComHelper.RollbackTran Method

[image]

Pastel Evolution SDK
ComHelper..::..RollbackTran Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void RollbackTran()
Visual Basic
Public Sub RollbackTran

See Also

ComHelper Class
ComHelper Members


ComHelper.SetBranchContext Method

[image]

Pastel Evolution SDK
ComHelper..::..SetBranchContext Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void SetBranchContext(
    int branchID
)
Visual Basic
Public Sub SetBranchContext (
    branchID As Integer
)

Parameters

branchID
Type: System..::..Int32

See Also

ComHelper Class
ComHelper Members


ComHelper.SetCurrentAgent Method

[image]

Pastel Evolution SDK
ComHelper..::..SetCurrentAgent Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void SetCurrentAgent(
    int agentID
)
Visual Basic
Public Sub SetCurrentAgent (
    agentID As Integer
)

Parameters

agentID
Type: System..::..Int32

See Also

ComHelper Class
ComHelper Members


ComHelper.SetLicense Method

[image]

Pastel Evolution SDK
ComHelper..::..SetLicense Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void SetLicense(
    string serialNumber,
    string authKey
)
Visual Basic
Public Sub SetLicense (
    serialNumber As String,
    authKey As String
)

Parameters

serialNumber
Type: System..::..String
authKey
Type: System..::..String

See Also

ComHelper Class
ComHelper Members


ComHelper.SetUserFieldValue Method

[image]

Pastel Evolution SDK
ComHelper..::..SetUserFieldValue Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void SetUserFieldValue(
    Object fields,
    string key,
    Object value
)
Visual Basic
Public Sub SetUserFieldValue (
    fields As Object,
    key As String,
    value As Object
)

Parameters

fields
Type: System..::..Object
key
Type: System..::..String
value
Type: System..::..Object

See Also

ComHelper Class
ComHelper Members


ComHelper.StartNewBatch Method

[image]

Pastel Evolution SDK
ComHelper..::..StartNewBatch Method
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void StartNewBatch()
Visual Basic
Public Sub StartNewBatch

See Also

ComHelper Class
ComHelper Members


ComHelper Properties

[image] [image]

Pastel Evolution SDK
ComHelper Properties
ComHelper Class See Also Send Feedback

The ComHelper type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyVersion |
Public property | CompatibleEvolutionDatabaseVersion |
Public property | CurrentEvolutionDatabaseVersion |
Public property | RegistrationExpiryDate |
Public property | RmsUsers | Obsolete.

See Also

ComHelper Class


ComHelper.AssemblyVersion Property

[image]

Pastel Evolution SDK
ComHelper..::..AssemblyVersion Property
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string AssemblyVersion { get; }
Visual Basic
Public ReadOnly Property AssemblyVersion As String
    Get

Property Value

Type: String

See Also

ComHelper Class
ComHelper Members


ComHelper.CompatibleEvolutionDatabaseVersion Property

[image]

Pastel Evolution SDK
ComHelper..::..CompatibleEvolutionDatabaseVersion Property
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string CompatibleEvolutionDatabaseVersion { get; }
Visual Basic
Public ReadOnly Property CompatibleEvolutionDatabaseVersion As String
    Get

Property Value

Type: String

See Also

ComHelper Class
ComHelper Members


ComHelper.CurrentEvolutionDatabaseVersion Property

[image]

Pastel Evolution SDK
ComHelper..::..CurrentEvolutionDatabaseVersion Property
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string CurrentEvolutionDatabaseVersion { get; }
Visual Basic
Public ReadOnly Property CurrentEvolutionDatabaseVersion As String
    Get

Property Value

Type: String

See Also

ComHelper Class
ComHelper Members


ComHelper.RegistrationExpiryDate Property

[image]

Pastel Evolution SDK
ComHelper..::..RegistrationExpiryDate Property
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DateTime RegistrationExpiryDate { get; }
Visual Basic
Public ReadOnly Property RegistrationExpiryDate As DateTime
    Get

Property Value

Type: DateTime

See Also

ComHelper Class
ComHelper Members


ComHelper.RmsUsers Property

[image]

Pastel Evolution SDK
ComHelper..::..RmsUsers Property
ComHelper Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
[ObsoleteAttribute("No longer registered")]
public int RmsUsers { get; }
Visual Basic
<ObsoleteAttribute("No longer registered")>
Public ReadOnly Property RmsUsers As Integer
    Get

Property Value

Type: Int32

See Also

ComHelper Class
ComHelper Members


Competitor Class

[image]

Pastel Evolution SDK
Competitor Class
Members See Also Send Feedback
Represents a Contact Management competitor.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class Competitor : BranchedRecordBase
Visual Basic
Public Class Competitor
    Inherits BranchedRecordBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..Competitor

See Also

Competitor Members


Competitor Members

[image] [image]

Pastel Evolution SDK
Competitor Members
Competitor Class Constructors Methods Fields Properties See Also Send Feedback

The Competitor type exposes the following members.

Constructors

 | Name | Description
Public method | Competitor()()()() | Creates a new instance of an opportunity.
Public method | Competitor(Int32) | Creates a new instance of a prospect.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Description |
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | Name |

See Also

Competitor Class


Competitor Constructor

[image] [image]

Pastel Evolution SDK
Competitor Constructor
Competitor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Competitor()()()() | Creates a new instance of an opportunity.
Public method | Competitor(Int32) | Creates a new instance of a prospect.

See Also

Competitor Class
Competitor Members


Competitor Constructor

[image]

Pastel Evolution SDK
Competitor Constructor
Competitor Class See Also Send Feedback
Creates a new instance of an opportunity.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Competitor()
Visual Basic
Public Sub New

See Also

Competitor Class
Competitor Members
Competitor Overload


Competitor Constructor (Int32)

[image]

Pastel Evolution SDK
Competitor Constructor (Int32)
Competitor Class See Also Send Feedback
Creates a new instance of a prospect.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Competitor(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32
Specifies the id of the existing record.

See Also

Competitor Class
Competitor Members
Competitor Overload


Competitor Fields

[image] [image]

Pastel Evolution SDK
Competitor Fields
Competitor Class See Also Send Feedback

The Competitor type exposes the following members.

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

Competitor Class


Competitor Methods

[image] [image]

Pastel Evolution SDK
Competitor Methods
Competitor Class See Also Send Feedback

The Competitor type exposes the following members.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

Competitor Class


Competitor.Find Method

[image]

Pastel Evolution SDK
Competitor..::..Find Method
Competitor Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String

Return Value

Type: Int32

See Also

Competitor Class
Competitor Members


Competitor.List Method

[image]

Pastel Evolution SDK
Competitor..::..List Method
Competitor Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria
)
Visual Basic
Public Shared Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String

Return Value

Type: DataTable

See Also

Competitor Class
Competitor Members


Competitor.OnDelete Method

[image]

Pastel Evolution SDK
Competitor..::..OnDelete Method
Competitor Class See Also Send Feedback
Removes the record from the database, provided it is not referenced by other records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

Exceptions

Exception | Condition
IntegrityViolationException |

See Also

Competitor Class
Competitor Members


Competitor.OnSave Method

[image]

Pastel Evolution SDK
Competitor..::..OnSave Method
Competitor Class See Also Send Feedback
Persists the record to the database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

Competitor Class
Competitor Members


Competitor Properties

[image] [image]

Pastel Evolution SDK
Competitor Properties
Competitor Class See Also Send Feedback

The Competitor type exposes the following members.

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Description |
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | Name |

See Also

Competitor Class


Competitor.Description Property

[image]

Pastel Evolution SDK
Competitor..::..Description Property
Competitor Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set

Property Value

Type: String

See Also

Competitor Class
Competitor Members


Competitor.ID Property

[image]

Pastel Evolution SDK
Competitor..::..ID Property
Competitor Class See Also Send Feedback
Gets the internal record ID (0 for new, unsaved records).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

See Also

Competitor Class
Competitor Members


Competitor.LongID Property

[image]

Pastel Evolution SDK
Competitor..::..LongID Property
Competitor Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

Competitor Class
Competitor Members


Competitor.Name Property

[image]

Pastel Evolution SDK
Competitor..::..Name Property
Competitor Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

Property Value

Type: String

See Also

Competitor Class
Competitor Members


CompletedContractPostingMethodGLContext Class

[image]

Pastel Evolution SDK
CompletedContractPostingMethodGLContext Class
Members See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class CompletedContractPostingMethodGLContext : TransactionTypePostingMethodGLContextBase
Visual Basic
Public Class CompletedContractPostingMethodGLContext
    Inherits TransactionTypePostingMethodGLContextBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..TransactionTypePostingMethodGLContextBase
Pastel.Evolution..::..CompletedContractPostingMethodGLContext

See Also

CompletedContractPostingMethodGLContext Members


CompletedContractPostingMethodGLContext Members

[image] [image]

Pastel Evolution SDK
CompletedContractPostingMethodGLContext Members
CompletedContractPostingMethodGLContext Class Methods Properties See Also Send Feedback

The CompletedContractPostingMethodGLContext type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | COSAccount | Gets or sets the Transaction Code's COS GL Account. (Overrides TransactionTypePostingMethodGLContextBase..::..COSAccount.)
Public property | COSAccountID | (Overrides TransactionTypePostingMethodGLContextBase..::..COSAccountID.)
Public property | CustomerControlAccount | Gets or sets the Transaction Code's Customer Control GL Account. (Overrides TransactionTypePostingMethodGLContextBase..::..CustomerControlAccount.)
Public property | CustomerControlAccountID | (Overrides TransactionTypePostingMethodGLContextBase..::..CustomerControlAccountID.)
Public property | RecoveryAccount | Gets or sets the Transaction Code's Recovery GL Account. (Overrides TransactionTypePostingMethodGLContextBase..::..RecoveryAccount.)
Public property | RecoveryAccountID | (Overrides TransactionTypePostingMethodGLContextBase..::..RecoveryAccountID.)
Public property | SalesAccount | Gets or sets the Transaction Code's Sales GL Account. (Overrides TransactionTypePostingMethodGLContextBase..::..SalesAccount.)
Public property | SalesAccountID | (Overrides TransactionTypePostingMethodGLContextBase..::..SalesAccountID.)
Public property | StockAccount | Gets or sets the Transaction Code's Stock GL Account. (Overrides TransactionTypePostingMethodGLContextBase..::..StockAccount.)
Public property | StockAccountID | (Overrides TransactionTypePostingMethodGLContextBase..::..StockAccountID.)
Public property | SupplierControlAccount | Gets or sets the Transaction Code's Supplier Control GL Account. (Overrides TransactionTypePostingMethodGLContextBase..::..SupplierControlAccount.)
Public property | SupplierControlAccountID | (Overrides TransactionTypePostingMethodGLContextBase..::..SupplierControlAccountID.)
Public property | TaxAccount | Gets or sets the Transaction Code's Tax GL Account. (Overrides TransactionTypePostingMethodGLContextBase..::..TaxAccount.)
Public property | TaxAccountID | (Overrides TransactionTypePostingMethodGLContextBase..::..TaxAccountID.)
Public property | WIPAccount | Gets or sets the Transaction Code's WIP GL Account. (Overrides TransactionTypePostingMethodGLContextBase..::..WIPAccount.)
Public property | WIPAccountID | (Overrides TransactionTypePostingMethodGLContextBase..::..WIPAccountID.)

See Also

CompletedContractPostingMethodGLContext Class


CompletedContractPostingMethodGLContext Methods

[image] [image]

Pastel Evolution SDK
CompletedContractPostingMethodGLContext Methods
CompletedContractPostingMethodGLContext Class See Also Send Feedback

The CompletedContractPostingMethodGLContext type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CompletedContractPostingMethodGLContext Class


CompletedContractPostingMethodGLContext Properties

[image] [image]

Pastel Evolution SDK
CompletedContractPostingMethodGLContext Properties
CompletedContractPostingMethodGLContext Class See Also Send Feedback

The CompletedContractPostingMethodGLContext type exposes the following members.

Properties

 | Name | Description
Public property | COSAccount | Gets or sets the Transaction Code's COS GL Account. (Overrides TransactionTypePostingMethodGLContextBase..::..COSAccount.)
Public property | COSAccountID | (Overrides TransactionTypePostingMethodGLContextBase..::..COSAccountID.)
Public property | CustomerControlAccount | Gets or sets the Transaction Code's Customer Control GL Account. (Overrides TransactionTypePostingMethodGLContextBase..::..CustomerControlAccount.)
Public property | CustomerControlAccountID | (Overrides TransactionTypePostingMethodGLContextBase..::..CustomerControlAccountID.)
Public property | RecoveryAccount | Gets or sets the Transaction Code's Recovery GL Account. (Overrides TransactionTypePostingMethodGLContextBase..::..RecoveryAccount.)
Public property | RecoveryAccountID | (Overrides TransactionTypePostingMethodGLContextBase..::..RecoveryAccountID.)
Public property | SalesAccount | Gets or sets the Transaction Code's Sales GL Account. (Overrides TransactionTypePostingMethodGLContextBase..::..SalesAccount.)
Public property | SalesAccountID | (Overrides TransactionTypePostingMethodGLContextBase..::..SalesAccountID.)
Public property | StockAccount | Gets or sets the Transaction Code's Stock GL Account. (Overrides TransactionTypePostingMethodGLContextBase..::..StockAccount.)
Public property | StockAccountID | (Overrides TransactionTypePostingMethodGLContextBase..::..StockAccountID.)
Public property | SupplierControlAccount | Gets or sets the Transaction Code's Supplier Control GL Account. (Overrides TransactionTypePostingMethodGLContextBase..::..SupplierControlAccount.)
Public property | SupplierControlAccountID | (Overrides TransactionTypePostingMethodGLContextBase..::..SupplierControlAccountID.)
Public property | TaxAccount | Gets or sets the Transaction Code's Tax GL Account. (Overrides TransactionTypePostingMethodGLContextBase..::..TaxAccount.)
Public property | TaxAccountID | (Overrides TransactionTypePostingMethodGLContextBase..::..TaxAccountID.)
Public property | WIPAccount | Gets or sets the Transaction Code's WIP GL Account. (Overrides TransactionTypePostingMethodGLContextBase..::..WIPAccount.)
Public property | WIPAccountID | (Overrides TransactionTypePostingMethodGLContextBase..::..WIPAccountID.)

See Also

CompletedContractPostingMethodGLContext Class


CompletedContractPostingMethodGLContext.COSAccount Property

[image]

Pastel Evolution SDK
CompletedContractPostingMethodGLContext..::..COSAccount Property
CompletedContractPostingMethodGLContext Class See Also Send Feedback
Gets or sets the Transaction Code's COS GL Account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override GLAccount COSAccount { get; set; }
Visual Basic
Public Overrides Property COSAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

See Also

CompletedContractPostingMethodGLContext Class
CompletedContractPostingMethodGLContext Members


CompletedContractPostingMethodGLContext.COSAccountID Property

[image]

Pastel Evolution SDK
CompletedContractPostingMethodGLContext..::..COSAccountID Property
CompletedContractPostingMethodGLContext Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int COSAccountID { get; set; }
Visual Basic
Public Overrides Property COSAccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CompletedContractPostingMethodGLContext Class
CompletedContractPostingMethodGLContext Members


CompletedContractPostingMethodGLContext.CustomerControlAccount Property

[image]

Pastel Evolution SDK
CompletedContractPostingMethodGLContext..::..CustomerControlAccount Property
CompletedContractPostingMethodGLContext Class See Also Send Feedback
Gets or sets the Transaction Code's Customer Control GL Account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override GLAccount CustomerControlAccount { get; set; }
Visual Basic
Public Overrides Property CustomerControlAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

See Also

CompletedContractPostingMethodGLContext Class
CompletedContractPostingMethodGLContext Members


CompletedContractPostingMethodGLContext.CustomerControlAccountID Property

[image]

Pastel Evolution SDK
CompletedContractPostingMethodGLContext..::..CustomerControlAccountID Property
CompletedContractPostingMethodGLContext Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int CustomerControlAccountID { get; set; }
Visual Basic
Public Overrides Property CustomerControlAccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CompletedContractPostingMethodGLContext Class
CompletedContractPostingMethodGLContext Members


CompletedContractPostingMethodGLContext.RecoveryAccount Property

[image]

Pastel Evolution SDK
CompletedContractPostingMethodGLContext..::..RecoveryAccount Property
CompletedContractPostingMethodGLContext Class See Also Send Feedback
Gets or sets the Transaction Code's Recovery GL Account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override GLAccount RecoveryAccount { get; set; }
Visual Basic
Public Overrides Property RecoveryAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

See Also

CompletedContractPostingMethodGLContext Class
CompletedContractPostingMethodGLContext Members


CompletedContractPostingMethodGLContext.RecoveryAccountID Property

[image]

Pastel Evolution SDK
CompletedContractPostingMethodGLContext..::..RecoveryAccountID Property
CompletedContractPostingMethodGLContext Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int RecoveryAccountID { get; set; }
Visual Basic
Public Overrides Property RecoveryAccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CompletedContractPostingMethodGLContext Class
CompletedContractPostingMethodGLContext Members


CompletedContractPostingMethodGLContext.SalesAccount Property

[image]

Pastel Evolution SDK
CompletedContractPostingMethodGLContext..::..SalesAccount Property
CompletedContractPostingMethodGLContext Class See Also Send Feedback
Gets or sets the Transaction Code's Sales GL Account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override GLAccount SalesAccount { get; set; }
Visual Basic
Public Overrides Property SalesAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

See Also

CompletedContractPostingMethodGLContext Class
CompletedContractPostingMethodGLContext Members


CompletedContractPostingMethodGLContext.SalesAccountID Property

[image]

Pastel Evolution SDK
CompletedContractPostingMethodGLContext..::..SalesAccountID Property
CompletedContractPostingMethodGLContext Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int SalesAccountID { get; set; }
Visual Basic
Public Overrides Property SalesAccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CompletedContractPostingMethodGLContext Class
CompletedContractPostingMethodGLContext Members


CompletedContractPostingMethodGLContext.StockAccount Property

[image]

Pastel Evolution SDK
CompletedContractPostingMethodGLContext..::..StockAccount Property
CompletedContractPostingMethodGLContext Class See Also Send Feedback
Gets or sets the Transaction Code's Stock GL Account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override GLAccount StockAccount { get; set; }
Visual Basic
Public Overrides Property StockAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

See Also

CompletedContractPostingMethodGLContext Class
CompletedContractPostingMethodGLContext Members


CompletedContractPostingMethodGLContext.StockAccountID Property

[image]

Pastel Evolution SDK
CompletedContractPostingMethodGLContext..::..StockAccountID Property
CompletedContractPostingMethodGLContext Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int StockAccountID { get; set; }
Visual Basic
Public Overrides Property StockAccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CompletedContractPostingMethodGLContext Class
CompletedContractPostingMethodGLContext Members


CompletedContractPostingMethodGLContext.SupplierControlAccount Property

[image]

Pastel Evolution SDK
CompletedContractPostingMethodGLContext..::..SupplierControlAccount Property
CompletedContractPostingMethodGLContext Class See Also Send Feedback
Gets or sets the Transaction Code's Supplier Control GL Account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override GLAccount SupplierControlAccount { get; set; }
Visual Basic
Public Overrides Property SupplierControlAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

See Also

CompletedContractPostingMethodGLContext Class
CompletedContractPostingMethodGLContext Members


CompletedContractPostingMethodGLContext.SupplierControlAccountID Property

[image]

Pastel Evolution SDK
CompletedContractPostingMethodGLContext..::..SupplierControlAccountID Property
CompletedContractPostingMethodGLContext Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int SupplierControlAccountID { get; set; }
Visual Basic
Public Overrides Property SupplierControlAccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CompletedContractPostingMethodGLContext Class
CompletedContractPostingMethodGLContext Members


CompletedContractPostingMethodGLContext.TaxAccount Property

[image]

Pastel Evolution SDK
CompletedContractPostingMethodGLContext..::..TaxAccount Property
CompletedContractPostingMethodGLContext Class See Also Send Feedback
Gets or sets the Transaction Code's Tax GL Account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override GLAccount TaxAccount { get; set; }
Visual Basic
Public Overrides Property TaxAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

See Also

CompletedContractPostingMethodGLContext Class
CompletedContractPostingMethodGLContext Members


CompletedContractPostingMethodGLContext.TaxAccountID Property

[image]

Pastel Evolution SDK
CompletedContractPostingMethodGLContext..::..TaxAccountID Property
CompletedContractPostingMethodGLContext Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int TaxAccountID { get; set; }
Visual Basic
Public Overrides Property TaxAccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CompletedContractPostingMethodGLContext Class
CompletedContractPostingMethodGLContext Members


CompletedContractPostingMethodGLContext.WIPAccount Property

[image]

Pastel Evolution SDK
CompletedContractPostingMethodGLContext..::..WIPAccount Property
CompletedContractPostingMethodGLContext Class See Also Send Feedback
Gets or sets the Transaction Code's WIP GL Account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override GLAccount WIPAccount { get; set; }
Visual Basic
Public Overrides Property WIPAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

See Also

CompletedContractPostingMethodGLContext Class
CompletedContractPostingMethodGLContext Members


CompletedContractPostingMethodGLContext.WIPAccountID Property

[image]

Pastel Evolution SDK
CompletedContractPostingMethodGLContext..::..WIPAccountID Property
CompletedContractPostingMethodGLContext Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int WIPAccountID { get; set; }
Visual Basic
Public Overrides Property WIPAccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CompletedContractPostingMethodGLContext Class
CompletedContractPostingMethodGLContext Members


Contract Class

[image]

Pastel Evolution SDK
Contract Class
Members See Also Send Feedback
Represents a Contact Management contract.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class Contract : BranchedRecordBase
Visual Basic
Public Class Contract
    Inherits BranchedRecordBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..Contract

See Also

Contract Members


Contract Members

[image] [image]

Pastel Evolution SDK
Contract Members
Contract Class Constructors Methods Fields Properties See Also Send Feedback

The Contract type exposes the following members.

Constructors

 | Name | Description
Public method | Contract()()()() | Creates a new instance of a contract.
Public method | Contract(Int32) | Creates a new instance of a contract.

Methods

 | Name | Description
 | _ListCurrentBranch(Int32) |
 | _ListCurrentBranch(String) |
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find |
 | FindByCode |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List(Int32) |
 | List(String) |
 | List(Customer) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | Account | Gets or sets the customer on the contract.
Public property | AllowIncidentTypeOverride |
Public property | BillingType | Gets or sets the contract billing type.
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | ContractNo | Gets or sets the contract number.
Public property | Cost | Gets or sets the contract cost.
Public property | EndDate | Gets or sets the contract end date.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | IncidentType | Gets or sets the incident type.
Public property | IncidentTypeID | Gets or sets the incident's incident type id.
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | Name | Gets or sets the contract name.
Public property | Reference | Gets or sets the contract reference.
Public property | StartDate | Gets or sets the contract start date.
Public property | Units | Gets or sets the contract units, the unit can be minutes or incidents per pack.

See Also

Contract Class


Contract Constructor

[image] [image]

Pastel Evolution SDK
Contract Constructor
Contract Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Contract()()()() | Creates a new instance of a contract.
Public method | Contract(Int32) | Creates a new instance of a contract.

See Also

Contract Class
Contract Members


Contract Constructor

[image]

Pastel Evolution SDK
Contract Constructor
Contract Class See Also Send Feedback
Creates a new instance of a contract.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Contract()
Visual Basic
Public Sub New

See Also

Contract Class
Contract Members
Contract Overload


Contract Constructor (Int32)

[image]

Pastel Evolution SDK
Contract Constructor (Int32)
Contract Class See Also Send Feedback
Creates a new instance of a contract.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Contract(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32
Specifies the id of the existing record.

See Also

Contract Class
Contract Members
Contract Overload


Contract Fields

[image] [image]

Pastel Evolution SDK
Contract Fields
Contract Class See Also Send Feedback

The Contract type exposes the following members.

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

Contract Class


Contract Methods

[image] [image]

Pastel Evolution SDK
Contract Methods
Contract Class See Also Send Feedback

The Contract type exposes the following members.

Methods

 | Name | Description
 | _ListCurrentBranch(Int32) |
 | _ListCurrentBranch(String) |
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find |
 | FindByCode |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List(Int32) |
 | List(String) |
 | List(Customer) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

Contract Class


Contract._ListCurrentBranch Method

[image] [image]

Pastel Evolution SDK
Contract..::.._ListCurrentBranch Method
Contract Class See Also Send Feedback

Overload List

Name | Description
_ListCurrentBranch(Int32) |
_ListCurrentBranch(String) |

See Also

Contract Class
Contract Members


Contract._ListCurrentBranch Method (Int32)

[image]

Pastel Evolution SDK
Contract..::.._ListCurrentBranch Method (Int32)
Contract Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable _ListCurrentBranch(
    int accountID
)
Visual Basic
Public Shared Function _ListCurrentBranch (
    accountID As Integer
) As DataTable

Parameters

accountID
Type: System..::..Int32

Return Value

Type: DataTable

See Also

Contract Class
Contract Members
_ListCurrentBranch Overload


Contract._ListCurrentBranch Method (String)

[image]

Pastel Evolution SDK
Contract..::.._ListCurrentBranch Method (String)
Contract Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable _ListCurrentBranch(
    string criteria
)
Visual Basic
Public Shared Function _ListCurrentBranch (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String

Return Value

Type: DataTable

See Also

Contract Class
Contract Members
_ListCurrentBranch Overload


Contract.Find Method

[image]

Pastel Evolution SDK
Contract..::..Find Method
Contract Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String

Return Value

Type: Int32

See Also

Contract Class
Contract Members


Contract.FindByCode Method

[image]

Pastel Evolution SDK
Contract..::..FindByCode Method
Contract Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int FindByCode(
    string reference
)
Visual Basic
Public Shared Function FindByCode (
    reference As String
) As Integer

Parameters

reference
Type: System..::..String

Return Value

Type: Int32

See Also

Contract Class
Contract Members


Contract.List Method

[image] [image]

Pastel Evolution SDK
Contract..::..List Method
Contract Class See Also Send Feedback

Overload List

Name | Description
List(Int32) |
List(String) |
List(Customer) |

See Also

Contract Class
Contract Members


Contract.List Method (Int32)

[image]

Pastel Evolution SDK
Contract..::..List Method (Int32)
Contract Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    int accountID
)
Visual Basic
Public Shared Function List (
    accountID As Integer
) As DataTable

Parameters

accountID
Type: System..::..Int32

Return Value

Type: DataTable

See Also

Contract Class
Contract Members
List Overload


Contract.List Method (String)

[image]

Pastel Evolution SDK
Contract..::..List Method (String)
Contract Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria
)
Visual Basic
Public Shared Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String

Return Value

Type: DataTable

See Also

Contract Class
Contract Members
List Overload


Contract.List Method (Customer)

[image]

Pastel Evolution SDK
Contract..::..List Method (Customer)
Contract Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    Customer account
)
Visual Basic
Public Shared Function List (
    account As Customer
) As DataTable

Parameters

account
Type: Pastel.Evolution..::..Customer

Return Value

Type: DataTable

See Also

Contract Class
Contract Members
List Overload


Contract.OnDelete Method

[image]

Pastel Evolution SDK
Contract..::..OnDelete Method
Contract Class See Also Send Feedback
Removes the record from the database, provided it is not referenced by other records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

Exceptions

Exception | Condition
IntegrityViolationException |

See Also

Contract Class
Contract Members


Contract.OnSave Method

[image]

Pastel Evolution SDK
Contract..::..OnSave Method
Contract Class See Also Send Feedback
Persists the record to the database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

Contract Class
Contract Members


Contract Properties

[image] [image]

Pastel Evolution SDK
Contract Properties
Contract Class See Also Send Feedback

The Contract type exposes the following members.

Properties

 | Name | Description
Public property | Account | Gets or sets the customer on the contract.
Public property | AllowIncidentTypeOverride |
Public property | BillingType | Gets or sets the contract billing type.
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | ContractNo | Gets or sets the contract number.
Public property | Cost | Gets or sets the contract cost.
Public property | EndDate | Gets or sets the contract end date.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | IncidentType | Gets or sets the incident type.
Public property | IncidentTypeID | Gets or sets the incident's incident type id.
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | Name | Gets or sets the contract name.
Public property | Reference | Gets or sets the contract reference.
Public property | StartDate | Gets or sets the contract start date.
Public property | Units | Gets or sets the contract units, the unit can be minutes or incidents per pack.

See Also

Contract Class


Contract.Account Property

[image]

Pastel Evolution SDK
Contract..::..Account Property
Contract Class See Also Send Feedback
Gets or sets the customer on the contract.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Customer Account { get; set; }
Visual Basic
Public Property Account As Customer
    Get
    Set

Property Value

Type: Customer

See Also

Contract Class
Contract Members


Contract.AllowIncidentTypeOverride Property

[image]

Pastel Evolution SDK
Contract..::..AllowIncidentTypeOverride Property
Contract Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool AllowIncidentTypeOverride { get; set; }
Visual Basic
Public Property AllowIncidentTypeOverride As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

Contract Class
Contract Members


Contract.BillingType Property

[image]

Pastel Evolution SDK
Contract..::..BillingType Property
Contract Class See Also Send Feedback
Gets or sets the contract billing type.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Contract..::..ContractBillingType BillingType { get; set; }
Visual Basic
Public Property BillingType As Contract..::..ContractBillingType
    Get
    Set

Property Value

Type: Contract..::..ContractBillingType

See Also

Contract Class
Contract Members


Contract.ContractNo Property

[image]

Pastel Evolution SDK
Contract..::..ContractNo Property
Contract Class See Also Send Feedback
Gets or sets the contract number.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string ContractNo { get; set; }
Visual Basic
Public Property ContractNo As String
    Get
    Set

Property Value

Type: String

See Also

Contract Class
Contract Members


Contract.Cost Property

[image]

Pastel Evolution SDK
Contract..::..Cost Property
Contract Class See Also Send Feedback
Gets or sets the contract cost.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double Cost { get; set; }
Visual Basic
Public Property Cost As Double
    Get
    Set

Property Value

Type: Double

See Also

Contract Class
Contract Members


Contract.EndDate Property

[image]

Pastel Evolution SDK
Contract..::..EndDate Property
Contract Class See Also Send Feedback
Gets or sets the contract end date.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DateTime EndDate { get; set; }
Visual Basic
Public Property EndDate As DateTime
    Get
    Set

Property Value

Type: DateTime

See Also

Contract Class
Contract Members


Contract.ID Property

[image]

Pastel Evolution SDK
Contract..::..ID Property
Contract Class See Also Send Feedback
Gets the internal record ID (0 for new, unsaved records).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

See Also

Contract Class
Contract Members


Contract.IncidentType Property

[image]

Pastel Evolution SDK
Contract..::..IncidentType Property
Contract Class See Also Send Feedback
Gets or sets the incident type.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public IncidentType IncidentType { get; set; }
Visual Basic
Public Property IncidentType As IncidentType
    Get
    Set

Property Value

Type: IncidentType

See Also

Contract Class
Contract Members


Contract.IncidentTypeID Property

[image]

Pastel Evolution SDK
Contract..::..IncidentTypeID Property
Contract Class See Also Send Feedback
Gets or sets the incident's incident type id.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int IncidentTypeID { get; set; }
Visual Basic
Public Property IncidentTypeID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

Contract Class
Contract Members


Contract.LongID Property

[image]

Pastel Evolution SDK
Contract..::..LongID Property
Contract Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

Contract Class
Contract Members


Contract.Name Property

[image]

Pastel Evolution SDK
Contract..::..Name Property
Contract Class See Also Send Feedback
Gets or sets the contract name.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

Property Value

Type: String

See Also

Contract Class
Contract Members


Contract.Reference Property

[image]

Pastel Evolution SDK
Contract..::..Reference Property
Contract Class See Also Send Feedback
Gets or sets the contract reference.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Reference { get; set; }
Visual Basic
Public Property Reference As String
    Get
    Set

Property Value

Type: String

See Also

Contract Class
Contract Members


Contract.StartDate Property

[image]

Pastel Evolution SDK
Contract..::..StartDate Property
Contract Class See Also Send Feedback
Gets or sets the contract start date.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DateTime StartDate { get; set; }
Visual Basic
Public Property StartDate As DateTime
    Get
    Set

Property Value

Type: DateTime

See Also

Contract Class
Contract Members


Contract.Units Property

[image]

Pastel Evolution SDK
Contract..::..Units Property
Contract Class See Also Send Feedback
Gets or sets the contract units, the unit can be minutes or incidents per pack.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int Units { get; set; }
Visual Basic
Public Property Units As Integer
    Get
    Set

Property Value

Type: Int32

See Also

Contract Class
Contract Members


Contract.ContractBillingType Enumeration

[image]

Pastel Evolution SDK
Contract..::..ContractBillingType Enumeration
Contract Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public enum ContractBillingType
Visual Basic
Public Enumeration ContractBillingType

Members

Member name | Value | Description
Standard | 1 |
Incident | 2 |
Time | 3 |
Pack | 4 |

See Also

Pastel.Evolution Namespace


CostAllocation Class

[image]

Pastel Evolution SDK
CostAllocation Class
Members See Also Send Feedback
Describes a transaction split allocation used when splitting a transaction's contra entry.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class CostAllocation : BranchedRecordBase
Visual Basic
Public Class CostAllocation
    Inherits BranchedRecordBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..CostAllocation

See Also

CostAllocation Members


CostAllocation Members

[image] [image]

Pastel Evolution SDK
CostAllocation Members
CostAllocation Class Constructors Methods Fields Properties See Also Send Feedback

The CostAllocation type exposes the following members.

Constructors

 | Name | Description
Public method | CostAllocation()()()() | Initializes a new instance of the CostAllocation class
Public method | CostAllocation(Int32) | Initializes a new instance of the CostAllocation class

Methods

 | Name | Description
 | _Select(String) | Experimental Method
 | _Select(String, String) | Experimental Method
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List(String) |
 | List(String, String) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | Amount | Gets or sets the transaction value.
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Currency |
Public property | CurrencyID |
Public property | Description |
Public property | ExchangeRate |
Public property | ForeignAmount | Gets or sets the foreign transaction value.
Public property | ID | (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | Reference |
Public property | Supplier |
Public property | SupplierID |
Public property | Tax | Gets or sets the transaction tax value.
Public property | TaxRate |
Public property | TaxRateID |

See Also

CostAllocation Class


CostAllocation Constructor

[image] [image]

Pastel Evolution SDK
CostAllocation Constructor
CostAllocation Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CostAllocation()()()() | Initializes a new instance of the CostAllocation class
Public method | CostAllocation(Int32) | Initializes a new instance of the CostAllocation class

See Also

CostAllocation Class
CostAllocation Members


CostAllocation Constructor

[image]

Pastel Evolution SDK
CostAllocation Constructor
CostAllocation Class See Also Send Feedback
Initializes a new instance of the CostAllocation class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public CostAllocation()
Visual Basic
Public Sub New

See Also

CostAllocation Class
CostAllocation Members
CostAllocation Overload


CostAllocation Constructor (Int32)

[image]

Pastel Evolution SDK
CostAllocation Constructor (Int32)
CostAllocation Class See Also Send Feedback
Initializes a new instance of the CostAllocation class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public CostAllocation(
    int ID
)
Visual Basic
Public Sub New (
    ID As Integer
)

Parameters

ID
Type: System..::..Int32

See Also

CostAllocation Class
CostAllocation Members
CostAllocation Overload


CostAllocation Fields

[image] [image]

Pastel Evolution SDK
CostAllocation Fields
CostAllocation Class See Also Send Feedback

The CostAllocation type exposes the following members.

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

CostAllocation Class


CostAllocation Methods

[image] [image]

Pastel Evolution SDK
CostAllocation Methods
CostAllocation Class See Also Send Feedback

The CostAllocation type exposes the following members.

Methods

 | Name | Description
 | _Select(String) | Experimental Method
 | _Select(String, String) | Experimental Method
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List(String) |
 | List(String, String) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

CostAllocation Class


CostAllocation._Select Method

[image] [image]

Pastel Evolution SDK
CostAllocation..::.._Select Method
CostAllocation Class See Also Send Feedback

Overload List

Name | Description
_Select(String) | Experimental Method
_Select(String, String) | Experimental Method

See Also

CostAllocation Class
CostAllocation Members


CostAllocation._Select Method (String)

[image]

Pastel Evolution SDK
CostAllocation..::.._Select Method (String)
CostAllocation Class See Also Send Feedback
Experimental Method

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static CostAllocation[] _Select(
    string criteria
)
Visual Basic
Public Shared Function _Select (
    criteria As String
) As CostAllocation()

Parameters

criteria
Type: System..::..String

Return Value

Type: array< CostAllocation >[]()[][]

See Also

CostAllocation Class
CostAllocation Members
_Select Overload


CostAllocation._Select Method (String, String)

[image]

Pastel Evolution SDK
CostAllocation..::.._Select Method (String, String)
CostAllocation Class See Also Send Feedback
Experimental Method

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static CostAllocation[] _Select(
    string criteria,
    string sortOrder
)
Visual Basic
Public Shared Function _Select (
    criteria As String,
    sortOrder As String
) As CostAllocation()

Parameters

criteria
Type: System..::..String
sortOrder
Type: System..::..String

Return Value

Type: array< CostAllocation >[]()[][]

See Also

CostAllocation Class
CostAllocation Members
_Select Overload


CostAllocation.List Method

[image] [image]

Pastel Evolution SDK
CostAllocation..::..List Method
CostAllocation Class See Also Send Feedback

Overload List

Name | Description
List(String) |
List(String, String) |

See Also

CostAllocation Class
CostAllocation Members


CostAllocation.List Method (String)

[image]

Pastel Evolution SDK
CostAllocation..::..List Method (String)
CostAllocation Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria
)
Visual Basic
Public Shared Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String

Return Value

Type: DataTable

See Also

CostAllocation Class
CostAllocation Members
List Overload


CostAllocation.List Method (String, String)

[image]

Pastel Evolution SDK
CostAllocation..::..List Method (String, String)
CostAllocation Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria,
    string sortOrder
)
Visual Basic
Public Shared Function List (
    criteria As String,
    sortOrder As String
) As DataTable

Parameters

criteria
Type: System..::..String
sortOrder
Type: System..::..String

Return Value

Type: DataTable

See Also

CostAllocation Class
CostAllocation Members
List Overload


CostAllocation.OnDelete Method

[image]

Pastel Evolution SDK
CostAllocation..::..OnDelete Method
CostAllocation Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

See Also

CostAllocation Class
CostAllocation Members


CostAllocation.OnSave Method

[image]

Pastel Evolution SDK
CostAllocation..::..OnSave Method
CostAllocation Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

CostAllocation Class
CostAllocation Members


CostAllocation Properties

[image] [image]

Pastel Evolution SDK
CostAllocation Properties
CostAllocation Class See Also Send Feedback

The CostAllocation type exposes the following members.

Properties

 | Name | Description
Public property | Amount | Gets or sets the transaction value.
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Currency |
Public property | CurrencyID |
Public property | Description |
Public property | ExchangeRate |
Public property | ForeignAmount | Gets or sets the foreign transaction value.
Public property | ID | (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | Reference |
Public property | Supplier |
Public property | SupplierID |
Public property | Tax | Gets or sets the transaction tax value.
Public property | TaxRate |
Public property | TaxRateID |

See Also

CostAllocation Class


CostAllocation.Amount Property

[image]

Pastel Evolution SDK
CostAllocation..::..Amount Property
CostAllocation Class See Also Send Feedback
Gets or sets the transaction value.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double Amount { get; set; }
Visual Basic
Public Property Amount As Double
    Get
    Set

Property Value

Type: Double

See Also

CostAllocation Class
CostAllocation Members


CostAllocation.Currency Property

[image]

Pastel Evolution SDK
CostAllocation..::..Currency Property
CostAllocation Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Currency Currency { get; set; }
Visual Basic
Public Property Currency As Currency
    Get
    Set

Property Value

Type: Currency

See Also

CostAllocation Class
CostAllocation Members


CostAllocation.CurrencyID Property

[image]

Pastel Evolution SDK
CostAllocation..::..CurrencyID Property
CostAllocation Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int CurrencyID { get; set; }
Visual Basic
Public Property CurrencyID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CostAllocation Class
CostAllocation Members


CostAllocation.Description Property

[image]

Pastel Evolution SDK
CostAllocation..::..Description Property
CostAllocation Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set

Property Value

Type: String

See Also

CostAllocation Class
CostAllocation Members


CostAllocation.ExchangeRate Property

[image]

Pastel Evolution SDK
CostAllocation..::..ExchangeRate Property
CostAllocation Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double ExchangeRate { get; set; }
Visual Basic
Public Property ExchangeRate As Double
    Get
    Set

Property Value

Type: Double

See Also

CostAllocation Class
CostAllocation Members


CostAllocation.ForeignAmount Property

[image]

Pastel Evolution SDK
CostAllocation..::..ForeignAmount Property
CostAllocation Class See Also Send Feedback
Gets or sets the foreign transaction value.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double ForeignAmount { get; set; }
Visual Basic
Public Property ForeignAmount As Double
    Get
    Set

Property Value

Type: Double

See Also

CostAllocation Class
CostAllocation Members


CostAllocation.ID Property

[image]

Pastel Evolution SDK
CostAllocation..::..ID Property
CostAllocation Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

See Also

CostAllocation Class
CostAllocation Members


CostAllocation.LongID Property

[image]

Pastel Evolution SDK
CostAllocation..::..LongID Property
CostAllocation Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

CostAllocation Class
CostAllocation Members


CostAllocation.Reference Property

[image]

Pastel Evolution SDK
CostAllocation..::..Reference Property
CostAllocation Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Reference { get; set; }
Visual Basic
Public Property Reference As String
    Get
    Set

Property Value

Type: String

See Also

CostAllocation Class
CostAllocation Members


CostAllocation.Supplier Property

[image]

Pastel Evolution SDK
CostAllocation..::..Supplier Property
CostAllocation Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Supplier Supplier { get; set; }
Visual Basic
Public Property Supplier As Supplier
    Get
    Set

Property Value

Type: Supplier

See Also

CostAllocation Class
CostAllocation Members


CostAllocation.SupplierID Property

[image]

Pastel Evolution SDK
CostAllocation..::..SupplierID Property
CostAllocation Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int SupplierID { get; set; }
Visual Basic
Public Property SupplierID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CostAllocation Class
CostAllocation Members


CostAllocation.Tax Property

[image]

Pastel Evolution SDK
CostAllocation..::..Tax Property
CostAllocation Class See Also Send Feedback
Gets or sets the transaction tax value.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double Tax { get; set; }
Visual Basic
Public Property Tax As Double
    Get
    Set

Property Value

Type: Double

See Also

CostAllocation Class
CostAllocation Members


CostAllocation.TaxRate Property

[image]

Pastel Evolution SDK
CostAllocation..::..TaxRate Property
CostAllocation Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public TaxRate TaxRate { get; set; }
Visual Basic
Public Property TaxRate As TaxRate
    Get
    Set

Property Value

Type: TaxRate

See Also

CostAllocation Class
CostAllocation Members


CostAllocation.TaxRateID Property

[image]

Pastel Evolution SDK
CostAllocation..::..TaxRateID Property
CostAllocation Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int TaxRateID { get; set; }
Visual Basic
Public Property TaxRateID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CostAllocation Class
CostAllocation Members


CostAllocationCollection Class

[image]

Pastel Evolution SDK
CostAllocationCollection Class
Members See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class CostAllocationCollection : CollectionBase
Visual Basic
Public Class CostAllocationCollection
    Inherits CollectionBase

Inheritance Hierarchy

System..::..Object
System.Collections..::..CollectionBase
Pastel.Evolution..::..CostAllocationCollection

See Also

CostAllocationCollection Members


CostAllocationCollection Members

[image] [image]

Pastel Evolution SDK
CostAllocationCollection Members
CostAllocationCollection Class Constructors Methods Properties See Also Send Feedback

The CostAllocationCollection type exposes the following members.

Constructors

 | Name | Description
Public method | CostAllocationCollection | Initializes a new instance of the CostAllocationCollection class

Methods

 | Name | Description
Public method | _Distribute | Distributes the sum of additional costs between detail records based on values selected for processing (ToProcess).
Public method | Add(CostAllocation) |
Public method | Add(Supplier, Double, String, String) |
Public method | Add(Supplier, Double, Double, TaxRate, String, String) |
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | (Overrides CollectionBase..::..OnClear()()()().)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove |
Public method | RemoveAt |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item |
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | ReadOnly |
Public property | TotalAmount |

See Also

CostAllocationCollection Class


CostAllocationCollection Constructor

[image]

Pastel Evolution SDK
CostAllocationCollection Constructor
CostAllocationCollection Class See Also Send Feedback
Initializes a new instance of the CostAllocationCollection class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public CostAllocationCollection(
    PurchasesDocumentBase document
)
Visual Basic
Public Sub New (
    document As PurchasesDocumentBase
)

Parameters

document
Type: Pastel.Evolution..::..PurchasesDocumentBase

See Also

CostAllocationCollection Class
CostAllocationCollection Members


CostAllocationCollection Methods

[image] [image]

Pastel Evolution SDK
CostAllocationCollection Methods
CostAllocationCollection Class See Also Send Feedback

The CostAllocationCollection type exposes the following members.

Methods

 | Name | Description
Public method | _Distribute | Distributes the sum of additional costs between detail records based on values selected for processing (ToProcess).
Public method | Add(CostAllocation) |
Public method | Add(Supplier, Double, String, String) |
Public method | Add(Supplier, Double, Double, TaxRate, String, String) |
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | (Overrides CollectionBase..::..OnClear()()()().)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove |
Public method | RemoveAt |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CostAllocationCollection Class


CostAllocationCollection._Distribute Method

[image]

Pastel Evolution SDK
CostAllocationCollection..::.._Distribute Method
CostAllocationCollection Class See Also Send Feedback
Distributes the sum of additional costs between detail records based on values selected for processing (ToProcess).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void _Distribute()
Visual Basic
Public Sub _Distribute

Remarks

Only positive, non-zero lines are used in the calculation.

See Also

CostAllocationCollection Class
CostAllocationCollection Members


CostAllocationCollection.Add Method

[image] [image]

Pastel Evolution SDK
CostAllocationCollection..::..Add Method
CostAllocationCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Add(CostAllocation) |
Public method | Add(Supplier, Double, String, String) |
Public method | Add(Supplier, Double, Double, TaxRate, String, String) |

See Also

CostAllocationCollection Class
CostAllocationCollection Members


CostAllocationCollection.Add Method (CostAllocation)

[image]

Pastel Evolution SDK
CostAllocationCollection..::..Add Method (CostAllocation)
CostAllocationCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void Add(
    CostAllocation costEntry
)
Visual Basic
Public Sub Add (
    costEntry As CostAllocation
)

Parameters

costEntry
Type: Pastel.Evolution..::..CostAllocation

See Also

CostAllocationCollection Class
CostAllocationCollection Members
Add Overload


CostAllocationCollection.Add Method (Supplier, Double, String, String)

[image]

Pastel Evolution SDK
CostAllocationCollection..::..Add Method (Supplier, Double, String, String)
CostAllocationCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public CostAllocation Add(
    Supplier supplier,
    double amount,
    string reference,
    string description
)
Visual Basic
Public Function Add (
    supplier As Supplier,
    amount As Double,
    reference As String,
    description As String
) As CostAllocation

Parameters

supplier
Type: Pastel.Evolution..::..Supplier
amount
Type: System..::..Double
reference
Type: System..::..String
description
Type: System..::..String

Return Value

Type: CostAllocation

See Also

CostAllocationCollection Class
CostAllocationCollection Members
Add Overload


CostAllocationCollection.Add Method (Supplier, Double, Double, TaxRate, String, String)

[image]

Pastel Evolution SDK
CostAllocationCollection..::..Add Method (Supplier, Double, Double, TaxRate, String, String)
CostAllocationCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public CostAllocation Add(
    Supplier supplier,
    double amount,
    double tax,
    TaxRate taxRate,
    string reference,
    string description
)
Visual Basic
Public Function Add (
    supplier As Supplier,
    amount As Double,
    tax As Double,
    taxRate As TaxRate,
    reference As String,
    description As String
) As CostAllocation

Parameters

supplier
Type: Pastel.Evolution..::..Supplier
amount
Type: System..::..Double
tax
Type: System..::..Double
taxRate
Type: Pastel.Evolution..::..TaxRate
reference
Type: System..::..String
description
Type: System..::..String

Return Value

Type: CostAllocation

See Also

CostAllocationCollection Class
CostAllocationCollection Members
Add Overload


CostAllocationCollection.OnClear Method

[image]

Pastel Evolution SDK
CostAllocationCollection..::..OnClear Method
CostAllocationCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected override void OnClear()
Visual Basic
Protected Overrides Sub OnClear

See Also

CostAllocationCollection Class
CostAllocationCollection Members


CostAllocationCollection.Remove Method

[image]

Pastel Evolution SDK
CostAllocationCollection..::..Remove Method
CostAllocationCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void Remove(
    CostAllocation costEntry
)
Visual Basic
Public Sub Remove (
    costEntry As CostAllocation
)

Parameters

costEntry
Type: Pastel.Evolution..::..CostAllocation

See Also

CostAllocationCollection Class
CostAllocationCollection Members


CostAllocationCollection.RemoveAt Method

[image]

Pastel Evolution SDK
CostAllocationCollection..::..RemoveAt Method
CostAllocationCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void RemoveAt(
    int index
)
Visual Basic
Public Sub RemoveAt (
    index As Integer
)

Parameters

index
Type: System..::..Int32

See Also

CostAllocationCollection Class
CostAllocationCollection Members


CostAllocationCollection Properties

[image] [image]

Pastel Evolution SDK
CostAllocationCollection Properties
CostAllocationCollection Class See Also Send Feedback

The CostAllocationCollection type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item |
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | ReadOnly |
Public property | TotalAmount |

See Also

CostAllocationCollection Class


CostAllocationCollection.Item Property

[image]

Pastel Evolution SDK
CostAllocationCollection..::..Item Property
CostAllocationCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public CostAllocation this[
    int index
] { get; }
Visual Basic
Public ReadOnly Default Property Item (
    index As Integer
) As CostAllocation
    Get

Parameters

index
Type: System..::..Int32

Property Value

Type: CostAllocation

See Also

CostAllocationCollection Class
CostAllocationCollection Members


CostAllocationCollection.ReadOnly Property

[image]

Pastel Evolution SDK
CostAllocationCollection..::..ReadOnly Property
CostAllocationCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool ReadOnly { get; internal set; }
Visual Basic
Public Property ReadOnly As Boolean
    Get
    Friend Set

Property Value

Type: Boolean

See Also

CostAllocationCollection Class
CostAllocationCollection Members


CostAllocationCollection.TotalAmount Property

[image]

Pastel Evolution SDK
CostAllocationCollection..::..TotalAmount Property
CostAllocationCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalAmount { get; }
Visual Basic
Public ReadOnly Property TotalAmount As Double
    Get

Property Value

Type: Double

See Also

CostAllocationCollection Class
CostAllocationCollection Members


Country Class

[image]

Pastel Evolution SDK
Country Class
Members See Also Send Feedback
Represents a country record.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class Country : BranchedRecordBase
Visual Basic
Public Class Country
    Inherits BranchedRecordBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..Country

See Also

Country Members


Country Members

[image] [image]

Pastel Evolution SDK
Country Members
Country Class Constructors Methods Fields Properties See Also Send Feedback

The Country type exposes the following members.

Constructors

 | Name | Description
Public method | Country()()()() | Creates a new instance of a country.
Public method | Country(Int32) | Creates a new instance of a country.
Public method | Country(String) | Creates a new instance of a country.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds a record's database ID.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | List | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | Name | Gets or sets the country's name.

See Also

Country Class


Country Constructor

[image] [image]

Pastel Evolution SDK
Country Constructor
Country Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Country()()()() | Creates a new instance of a country.
Public method | Country(Int32) | Creates a new instance of a country.
Public method | Country(String) | Creates a new instance of a country.

See Also

Country Class
Country Members


Country Constructor

[image]

Pastel Evolution SDK
Country Constructor
Country Class See Also Send Feedback
Creates a new instance of a country.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Country()
Visual Basic
Public Sub New

See Also

Country Class
Country Members
Country Overload


Country Constructor (Int32)

[image]

Pastel Evolution SDK
Country Constructor (Int32)
Country Class See Also Send Feedback
Creates a new instance of a country.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Country(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32
Specifies the id of the existing record.

See Also

Country Class
Country Members
Country Overload


Country Constructor (String)

[image]

Pastel Evolution SDK
Country Constructor (String)
Country Class See Also Send Feedback
Creates a new instance of a country.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Country(
    string name
)
Visual Basic
Public Sub New (
    name As String
)

Parameters

name
Type: System..::..String
Specifies the name of the existing record.

See Also

Country Class
Country Members
Country Overload


Country Fields

[image] [image]

Pastel Evolution SDK
Country Fields
Country Class See Also Send Feedback

The Country type exposes the following members.

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

Country Class


Country Methods

[image] [image]

Pastel Evolution SDK
Country Methods
Country Class See Also Send Feedback

The Country type exposes the following members.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds a record's database ID.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | List | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

Country Class


Country.Find Method

[image]

Pastel Evolution SDK
Country..::..Find Method
Country Class See Also Send Feedback
Finds a record's database ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.

Return Value

Type: Int32
The ID of the first record found; -1 if not record was found.

See Also

Country Class
Country Members


Country.List Method

[image]

Pastel Evolution SDK
Country..::..List Method
Country Class See Also Send Feedback
Gets a list of database records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DataTable List(
    string criteria
)
Visual Basic
Public Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.

Return Value

Type: DataTable
Table containing selected records.

See Also

Country Class
Country Members


Country.OnDelete Method

[image]

Pastel Evolution SDK
Country..::..OnDelete Method
Country Class See Also Send Feedback
Removes the record from the database, provided it is not referenced by other records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

Exceptions

Exception | Condition
IntegrityViolationException |

See Also

Country Class
Country Members


Country.OnSave Method

[image]

Pastel Evolution SDK
Country..::..OnSave Method
Country Class See Also Send Feedback
Persists the record to the database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

Country Class
Country Members


Country Properties

[image] [image]

Pastel Evolution SDK
Country Properties
Country Class See Also Send Feedback

The Country type exposes the following members.

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | Name | Gets or sets the country's name.

See Also

Country Class


Country.ID Property

[image]

Pastel Evolution SDK
Country..::..ID Property
Country Class See Also Send Feedback
Gets the internal record ID (0 for new, unsaved records).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

See Also

Country Class
Country Members


Country.LongID Property

[image]

Pastel Evolution SDK
Country..::..LongID Property
Country Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

Country Class
Country Members


Country.Name Property

[image]

Pastel Evolution SDK
Country..::..Name Property
Country Class See Also Send Feedback
Gets or sets the country's name.
Gets or sets the country name.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

Property Value

Type: String

See Also

Country Class
Country Members


CreditNote Class

[image]

Pastel Evolution SDK
CreditNote Class
Members See Also Send Feedback
Represents an Evolution sales credit note.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class CreditNote : SalesDocumentBase
Visual Basic
Public Class CreditNote
    Inherits SalesDocumentBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..OrderBase
Pastel.Evolution..::..SalesDocumentBase
Pastel.Evolution..::..CreditNote

See Also

CreditNote Members


CreditNote Members

[image] [image]

Pastel Evolution SDK
CreditNote Members
CreditNote Class Constructors Methods Fields Properties See Also Send Feedback

The CreditNote type exposes the following members.

Constructors

 | Name | Description
Public method | CreditNote()()()() | Creates a new instance of a credit note.
Public method | CreditNote(Int32) | Creates a new instance of a credit note.

Methods

 | Name | Description
Public method | _SetFullQtyToProcess | (Inherited from OrderBase.)
Protected method | BeforePostGLBatch | (Overrides OrderBase..::..BeforePostGLBatch(OrderBase, CancelEventArgs).)
Protected method | BeforePostInventory | (Overrides OrderBase..::..BeforePostInventory(OrderBase, CancelEventArgs).)
Protected method | BeforePostLedger | (Overrides OrderBase..::..BeforePostLedger(OrderBase, CancelEventArgs).)
Protected method | BeforeSave | (Inherited from OrderBase.)
Public method | CalcRounding | (Inherited from SalesDocumentBase.)
Protected method | cascadeForeignValues | (Inherited from OrderBase.)
Protected method | cascadeProject | (Inherited from OrderBase.)
Protected method | cascadeRepresentative | (Inherited from SalesDocumentBase.)
Protected method | cascadeTaxRate | (Inherited from OrderBase.)
Public method | Complete()()()() | Processes (invoices) all outstanding quantities on the order. The entire invoice fails if one or more detail lines do not have sufficient stock available. The CompleteMax method (SalesOrder only) is a variation on this method and attempts to confirm as much of the ordered stock as is available. (Inherited from OrderBase.)
Public method | Complete(String) | Process (invoice) all outstanding quantities on the order. The entire invoice fails if one or more detail lines do not have sufficient stock available. The method is a variation on this method and attempts to confirm as much of the ordered stock as is available. (Inherited from OrderBase.)
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Protected method | Detach | (Inherited from OrderBase.)
Protected method | detailRemainsOutstanding | (Inherited from OrderBase.)
Protected method | detailToProcess | (Inherited from OrderBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds and returns the id of the first document matching the supplied criteria. E.g. InvNumber = 'CRN0001'
Protected method | fullQtySelected | (Inherited from OrderBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | glCreditPosting | (Overrides OrderBase..::..glCreditPosting(TransactionBase, TransactionBase..::..GLPostingEventArgs).)
Protected method | glDebitPosting | (Overrides OrderBase..::..glDebitPosting(TransactionBase, TransactionBase..::..GLPostingEventArgs).)
Protected method | initialise | (Overrides OrderBase..::..initialise()()()().)
 | List | Lists unprocessed documents for the supplied criteria.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Not supported. Use the delete facility from inside Evolution. (Inherited from OrderBase.)
Protected method | OnSave | (Inherited from OrderBase.)
Public method | Process()()()() | Posts the document to the various accounts and ledgers applicable. (Inherited from OrderBase.)
Public method | Process(String) | Posts the document to the various accounts and ledgers applicable. (Inherited from OrderBase.)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | account | (Inherited from OrderBase.)
Protected field | archID | (Inherited from OrderBase.)
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | currency | (Inherited from OrderBase.)
Protected field | dcTran | (Inherited from OrderBase.)
Protected field | deliverTo | (Inherited from OrderBase.)
Protected field | deliveryMethod | (Inherited from OrderBase.)
Protected field | detail | (Inherited from OrderBase.)
Protected field | glBatch | (Inherited from OrderBase.)
Protected field | invoiceTo | (Inherited from OrderBase.)
Protected field | orderPriority | (Inherited from OrderBase.)
Protected field | orderStatus | (Inherited from OrderBase.)
Protected field | originalDocument | (Inherited from OrderBase.)
Protected field | processingAdditionalCosts | (Inherited from OrderBase.)
Protected field | processLedger | Should the document process to AR or AP ledger? (Inherited from OrderBase.)
Protected field | processStock | (Inherited from OrderBase.)
Protected field | project | (Inherited from OrderBase.)
Protected field | prospect | (Inherited from OrderBase.)
Protected field | salesOpp | (Inherited from SalesDocumentBase.)
Protected field | salesRep | (Inherited from SalesDocumentBase.)
Protected field | settlementTerms | (Inherited from OrderBase.)
Protected field | taxType | (Inherited from OrderBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | Account | Gets or sets the AR or AP account associated with the order. (Inherited from OrderBase.)
Public property | AccountID | Gets or sets the ID of the AR or AP account associated with the order. (Inherited from OrderBase.)
Public property | AllowInvoiceRounding | (Inherited from OrderBase.)
Public property | ApplyTaxPerLine | Gets or sets whether tax per line should be applied. (Inherited from OrderBase.)
Public property | Audit | Gets the audit number of the last transaction processed by this document. This value defaults to 0, and will not be available on recalled documents. (Inherited from OrderBase.)
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Currency | Gets or sets the currency. (Inherited from OrderBase.)
Public property | CurrencyID | Gets or sets the document's currency ID. (Inherited from OrderBase.)
Public property | Customer | Gets or sets the document's customer account (maps directly to Account). (Inherited from SalesDocumentBase.)
Public property | DeliverTo | Gets or sets the delivery address. (Inherited from OrderBase.)
Public property | DeliveryDate | Gets or sets the delivery date. (Inherited from OrderBase.)
Public property | DeliveryMethod | Gets or sets the delivery method. (Inherited from OrderBase.)
Public property | DeliveryMethodID | Gets or sets the delivery method ID. (Inherited from OrderBase.)
Public property | Description | Gets or sets the document description. This will also be the description on any transactions posted. (Inherited from OrderBase.)
Public property | Detail | Gets the order detail collection representing the body of the document. (Inherited from OrderBase.)
Public property | Discount | Gets or sets the document discount amount (applicable to tax excl. total), (Inherited from OrderBase.)
Public property | DiscountForeign | Gets or sets the document foreign discount amount (applicable to tax excl. total), (Inherited from OrderBase.)
Public property | DiscountLastProcessed | Gets the document discount amount last processed. (Inherited from OrderBase.)
Public property | DiscountPercent | Gets or sets the document discount percentage. (Inherited from OrderBase.)
Public property | DiscountToProcess | Gets the document discount amount about to be processed (applicable to tax excl. total). (Inherited from OrderBase.)
Public property | DueDate | Gets or sets the due date. (Inherited from OrderBase.)
Public property | ExchangeRate | Gets or sets the exchange rate. (Inherited from OrderBase.)
Public property | ExternalOrderNo | Gets or sets the external order number. (Inherited from OrderBase.)
Protected property | grossLastProcessTotal | (Inherited from OrderBase.)
Protected property | grossLastProcessTotalForeign | (Inherited from OrderBase.)
Protected property | grossOutstTotal | (Inherited from OrderBase.)
Protected property | grossOutstTotalForeign | (Inherited from OrderBase.)
Protected property | grossToProcessTotal | (Inherited from OrderBase.)
Protected property | grossToProcessTotalForeign | (Inherited from OrderBase.)
Protected property | grossTotal | (Inherited from OrderBase.)
Protected property | grossTotalForeign | (Inherited from OrderBase.)
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Inherited from OrderBase.)
Public property | InvoiceDate | Gets or sets the invoice date. (Inherited from OrderBase.)
Public property | InvoiceNumber | Gets or sets the credit note's invoice number.
Public property | InvoiceTo | Gets or sets the invoice address. (Inherited from OrderBase.)
Public property | IsLoading | Will be true while the order is busy loading detail. (Inherited from OrderBase.)
Public property | IsPartialProcessingAllowed | (Overrides OrderBase..::..IsPartialProcessingAllowed.)
Public property | IsProcessing | Will be true while the order is busy processing transactions. (Inherited from OrderBase.)
Public property | LedgerTransaction | Gets the last ledger transaction (AR/AP Transaction) posted. (Inherited from OrderBase.)
Protected property | lineAdditionalCostTotal | (Inherited from OrderBase.)
Public property | LongID | (Inherited from OrderBase.)
Public property | MessageLine1 | Gets or sets the 1st message line. (Inherited from OrderBase.)
Public property | MessageLine2 | Gets or sets the 2nd message line. (Inherited from OrderBase.)
Public property | MessageLine3 | Gets or sets the 3rd message line. (Inherited from OrderBase.)
Protected property | nettLastProcessTotal | (Inherited from OrderBase.)
Protected property | nettLastProcessTotalForeign | (Inherited from OrderBase.)
Protected property | nettOutstTotal | (Inherited from OrderBase.)
Protected property | nettOutstTotalForeign | (Inherited from OrderBase.)
Protected property | nettToProcessTotal | (Inherited from OrderBase.)
Protected property | nettToProcessTotalForeign | (Inherited from OrderBase.)
Public property | OrderDate | Gets or sets the order date. (Inherited from OrderBase.)
Public property | OrderNo | Gets or sets the order number. (Inherited from OrderBase.)
Public property | OrderPriority | Gets or sets the order priority. (Inherited from OrderBase.)
Public property | OrderPriorityID | Gets or sets the order priority ID. (Inherited from OrderBase.)
Public property | OrderStatus | Gets or sets the document's order status. (Inherited from OrderBase.)
Public property | OrderStatusID | Gets or sets the order status ID. (Inherited from OrderBase.)
Public property | OriginalDocument | (Overrides OrderBase..::..OriginalDocument.)
Public property | PrintCount | Gets or sets the print count. (Inherited from OrderBase.)
Public property | Project | Gets or sets the project. (Inherited from OrderBase.)
Public property | ProjectID | Gets or sets the project ID. (Inherited from OrderBase.)
Public property | Prospect | (Inherited from OrderBase.)
Public property | ProspectID | (Inherited from OrderBase.)
Public property | RawFieldData | Obsolete. (Inherited from OrderBase.)
Public property | Reference | Gets or sets the document reference (InvNumber). (Inherited from OrderBase.)
Public property | Reference2 | Gets the 2nd document reference. (Inherited from OrderBase.)
Public property | Representative | Gets or sets the document sales representative. (Inherited from SalesDocumentBase.)
Public property | RepresentativeID | Gets or sets the sales representative ID. (Inherited from SalesDocumentBase.)
Public property | SalesOpportunity | (Inherited from SalesDocumentBase.)
Public property | SettlementTerms | (Inherited from OrderBase.)
Public property | SettlementTermsID | (Inherited from OrderBase.)
Public property | State | Gets the document state. (Inherited from OrderBase.)
Protected property | taxLastProcessTotal | (Inherited from OrderBase.)
Protected property | taxLastProcessTotalForeign | (Inherited from OrderBase.)
Public property | TaxMode | Gets or sets the tax mode. (Inherited from OrderBase.)
Public property | TaxNumber | Gets or sets the cash account's tax number. (Inherited from OrderBase.)
Protected property | taxOutstTotal | (Inherited from OrderBase.)
Protected property | taxOutstTotalForeign | (Inherited from OrderBase.)
Protected property | taxToProcessTotal | (Inherited from OrderBase.)
Protected property | taxToProcessTotalForeign | (Inherited from OrderBase.)
Protected property | taxTotal | (Inherited from OrderBase.)
Protected property | taxTotalForeign | (Inherited from OrderBase.)
Public property | TaxType | (Inherited from OrderBase.)
Public property | TotalDiscountAdjusted | Gets the total discount adjusted amount. (Inherited from OrderBase.)
Public property | TotalDiscountAdjustedForeign | Gets the total discount adjusted foreign amount. (Inherited from OrderBase.)
Public property | TotalExcl | Gets the total excl amount. (Inherited from OrderBase.)
Public property | TotalExclForeign | Gets the total excl amount. (Inherited from OrderBase.)
Public property | TotalIncl | Gets the total incl amount. (Inherited from OrderBase.)
Public property | TotalInclForeign | Gets the total incl amount. (Inherited from OrderBase.)
Public property | TotalInclForeignBeforeInvoiceRounding | Gets the total incl amount before Invoice Rounding. (Inherited from OrderBase.)
Public property | TotalLastProcessExcl | Gets the total last process excl. (Inherited from OrderBase.)
Public property | TotalLastProcessExclForeign | Gets the total last process excl. (Inherited from OrderBase.)
Public property | TotalLastProcessIncl | Gets the total last process incl. (Inherited from OrderBase.)
Public property | TotalLastProcessInclForeign | Gets the total last process incl. (Inherited from OrderBase.)
Public property | TotalLastProcessTax | Gets the total last process tax. (Inherited from OrderBase.)
Public property | TotalLastProcessTaxForeign | Gets the total last process tax. (Inherited from OrderBase.)
Public property | TotalOutstandingExcl | Gets the total outstanding excl. (Inherited from OrderBase.)
Public property | TotalOutstandingExclForeign | Gets the total outstanding excl. (Inherited from OrderBase.)
Public property | TotalOutstandingIncl | Gets the total outstanding incl. (Inherited from OrderBase.)
Public property | TotalOutstandingInclForeign | Gets the total outstanding incl. (Inherited from OrderBase.)
Public property | TotalOutstandingTax | Gets the total outstanding tax. (Inherited from OrderBase.)
Public property | TotalOutstandingTaxForeign | Gets the total outstanding tax. (Inherited from OrderBase.)
Public property | TotalTax | Gets the total tax amount. (Inherited from OrderBase.)
Public property | TotalTaxForeign | Gets the total tax amount. (Inherited from OrderBase.)
Public property | TotalToProcessExcl | Gets the total amount to process excl. (Inherited from OrderBase.)
Public property | TotalToProcessExclForeign | Gets the total amount to process excl. (Inherited from OrderBase.)
Public property | TotalToProcessIncl | Gets the total to process incl. (Inherited from OrderBase.)
Public property | TotalToProcessInclForeign | Gets the total to process incl. (Inherited from OrderBase.)
Public property | TotalToProcessTax | Gets the total to process tax. (Inherited from OrderBase.)
Public property | TotalToProcessTaxForeign | Gets the total to process tax. (Inherited from OrderBase.)
Public property | Type | Gets the order's document type. (Inherited from OrderBase.)
Public property | UserFields | Gets access to the collection of user-defined fields on the record. Note that the field name is case-sensitive. (Inherited from OrderBase.)
Public property | Version | Gets the current version of the order, incremented on every save. (Inherited from OrderBase.)

See Also

CreditNote Class


CreditNote Constructor

[image] [image]

Pastel Evolution SDK
CreditNote Constructor
CreditNote Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreditNote()()()() | Creates a new instance of a credit note.
Public method | CreditNote(Int32) | Creates a new instance of a credit note.

See Also

CreditNote Class
CreditNote Members


CreditNote Constructor

[image]

Pastel Evolution SDK
CreditNote Constructor
CreditNote Class See Also Send Feedback
Creates a new instance of a credit note.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public CreditNote()
Visual Basic
Public Sub New

See Also

CreditNote Class
CreditNote Members
CreditNote Overload


CreditNote Constructor (Int32)

[image]

Pastel Evolution SDK
CreditNote Constructor (Int32)
CreditNote Class See Also Send Feedback
Creates a new instance of a credit note.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public CreditNote(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32
Specifies the id of the existing record.

See Also

CreditNote Class
CreditNote Members
CreditNote Overload


CreditNote Fields

[image] [image]

Pastel Evolution SDK
CreditNote Fields
CreditNote Class See Also Send Feedback

The CreditNote type exposes the following members.

Fields

 | Name | Description
Protected field | account | (Inherited from OrderBase.)
Protected field | archID | (Inherited from OrderBase.)
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | currency | (Inherited from OrderBase.)
Protected field | dcTran | (Inherited from OrderBase.)
Protected field | deliverTo | (Inherited from OrderBase.)
Protected field | deliveryMethod | (Inherited from OrderBase.)
Protected field | detail | (Inherited from OrderBase.)
Protected field | glBatch | (Inherited from OrderBase.)
Protected field | invoiceTo | (Inherited from OrderBase.)
Protected field | orderPriority | (Inherited from OrderBase.)
Protected field | orderStatus | (Inherited from OrderBase.)
Protected field | originalDocument | (Inherited from OrderBase.)
Protected field | processingAdditionalCosts | (Inherited from OrderBase.)
Protected field | processLedger | Should the document process to AR or AP ledger? (Inherited from OrderBase.)
Protected field | processStock | (Inherited from OrderBase.)
Protected field | project | (Inherited from OrderBase.)
Protected field | prospect | (Inherited from OrderBase.)
Protected field | salesOpp | (Inherited from SalesDocumentBase.)
Protected field | salesRep | (Inherited from SalesDocumentBase.)
Protected field | settlementTerms | (Inherited from OrderBase.)
Protected field | taxType | (Inherited from OrderBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

CreditNote Class


CreditNote Methods

[image] [image]

Pastel Evolution SDK
CreditNote Methods
CreditNote Class See Also Send Feedback

The CreditNote type exposes the following members.

Methods

 | Name | Description
Public method | _SetFullQtyToProcess | (Inherited from OrderBase.)
Protected method | BeforePostGLBatch | (Overrides OrderBase..::..BeforePostGLBatch(OrderBase, CancelEventArgs).)
Protected method | BeforePostInventory | (Overrides OrderBase..::..BeforePostInventory(OrderBase, CancelEventArgs).)
Protected method | BeforePostLedger | (Overrides OrderBase..::..BeforePostLedger(OrderBase, CancelEventArgs).)
Protected method | BeforeSave | (Inherited from OrderBase.)
Public method | CalcRounding | (Inherited from SalesDocumentBase.)
Protected method | cascadeForeignValues | (Inherited from OrderBase.)
Protected method | cascadeProject | (Inherited from OrderBase.)
Protected method | cascadeRepresentative | (Inherited from SalesDocumentBase.)
Protected method | cascadeTaxRate | (Inherited from OrderBase.)
Public method | Complete()()()() | Processes (invoices) all outstanding quantities on the order. The entire invoice fails if one or more detail lines do not have sufficient stock available. The CompleteMax method (SalesOrder only) is a variation on this method and attempts to confirm as much of the ordered stock as is available. (Inherited from OrderBase.)
Public method | Complete(String) | Process (invoice) all outstanding quantities on the order. The entire invoice fails if one or more detail lines do not have sufficient stock available. The method is a variation on this method and attempts to confirm as much of the ordered stock as is available. (Inherited from OrderBase.)
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Protected method | Detach | (Inherited from OrderBase.)
Protected method | detailRemainsOutstanding | (Inherited from OrderBase.)
Protected method | detailToProcess | (Inherited from OrderBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds and returns the id of the first document matching the supplied criteria. E.g. InvNumber = 'CRN0001'
Protected method | fullQtySelected | (Inherited from OrderBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | glCreditPosting | (Overrides OrderBase..::..glCreditPosting(TransactionBase, TransactionBase..::..GLPostingEventArgs).)
Protected method | glDebitPosting | (Overrides OrderBase..::..glDebitPosting(TransactionBase, TransactionBase..::..GLPostingEventArgs).)
Protected method | initialise | (Overrides OrderBase..::..initialise()()()().)
 | List | Lists unprocessed documents for the supplied criteria.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Not supported. Use the delete facility from inside Evolution. (Inherited from OrderBase.)
Protected method | OnSave | (Inherited from OrderBase.)
Public method | Process()()()() | Posts the document to the various accounts and ledgers applicable. (Inherited from OrderBase.)
Public method | Process(String) | Posts the document to the various accounts and ledgers applicable. (Inherited from OrderBase.)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

CreditNote Class


CreditNote.BeforePostGLBatch Method

[image]

Pastel Evolution SDK
CreditNote..::..BeforePostGLBatch Method
CreditNote Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected override void BeforePostGLBatch(
    OrderBase orderBase,
    CancelEventArgs e
)
Visual Basic
Protected Overrides Sub BeforePostGLBatch (
    orderBase As OrderBase,
    e As CancelEventArgs
)

Parameters

orderBase
Type: Pastel.Evolution..::..OrderBase
e
Type: System.ComponentModel..::..CancelEventArgs

See Also

CreditNote Class
CreditNote Members


CreditNote.BeforePostInventory Method

[image]

Pastel Evolution SDK
CreditNote..::..BeforePostInventory Method
CreditNote Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected override void BeforePostInventory(
    OrderBase orderBase,
    CancelEventArgs e
)
Visual Basic
Protected Overrides Sub BeforePostInventory (
    orderBase As OrderBase,
    e As CancelEventArgs
)

Parameters

orderBase
Type: Pastel.Evolution..::..OrderBase
e
Type: System.ComponentModel..::..CancelEventArgs

See Also

CreditNote Class
CreditNote Members


CreditNote.BeforePostLedger Method

[image]

Pastel Evolution SDK
CreditNote..::..BeforePostLedger Method
CreditNote Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected override void BeforePostLedger(
    OrderBase orderBase,
    CancelEventArgs e
)
Visual Basic
Protected Overrides Sub BeforePostLedger (
    orderBase As OrderBase,
    e As CancelEventArgs
)

Parameters

orderBase
Type: Pastel.Evolution..::..OrderBase
e
Type: System.ComponentModel..::..CancelEventArgs

See Also

CreditNote Class
CreditNote Members


CreditNote.Find Method

[image]

Pastel Evolution SDK
CreditNote..::..Find Method
CreditNote Class See Also Send Feedback
Finds and returns the id of the first document matching the supplied criteria. E.g. InvNumber = 'CRN0001'

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.

Return Value

Type: Int32
The ID of the first record found; -1 if not record was found.

See Also

CreditNote Class
CreditNote Members


CreditNote.glCreditPosting Method

[image]

Pastel Evolution SDK
CreditNote..::..glCreditPosting Method
CreditNote Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected override void glCreditPosting(
    TransactionBase sender,
    TransactionBase..::..GLPostingEventArgs e
)
Visual Basic
Protected Overrides Sub glCreditPosting (
    sender As TransactionBase,
    e As TransactionBase..::..GLPostingEventArgs
)

Parameters

sender
Type: Pastel.Evolution..::..TransactionBase
e
Type: Pastel.Evolution..::..TransactionBase..::..GLPostingEventArgs

See Also

CreditNote Class
CreditNote Members


CreditNote.glDebitPosting Method

[image]

Pastel Evolution SDK
CreditNote..::..glDebitPosting Method
CreditNote Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected override void glDebitPosting(
    TransactionBase sender,
    TransactionBase..::..GLPostingEventArgs e
)
Visual Basic
Protected Overrides Sub glDebitPosting (
    sender As TransactionBase,
    e As TransactionBase..::..GLPostingEventArgs
)

Parameters

sender
Type: Pastel.Evolution..::..TransactionBase
e
Type: Pastel.Evolution..::..TransactionBase..::..GLPostingEventArgs

See Also

CreditNote Class
CreditNote Members


CreditNote.initialise Method

[image]

Pastel Evolution SDK
CreditNote..::..initialise Method
CreditNote Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void initialise()
Visual Basic
Protected Friend Overrides Sub initialise

See Also

CreditNote Class
CreditNote Members


CreditNote.List Method

[image]

Pastel Evolution SDK
CreditNote..::..List Method
CreditNote Class See Also Send Feedback
Lists unprocessed documents for the supplied criteria.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria
)
Visual Basic
Public Shared Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String
E.g. Customer.Account = 'CASH001' and (OrderNum = 'SO209302')

Return Value

Type: DataTable

Remarks

Pseudo-tables: Core, Customer

See Also

CreditNote Class
CreditNote Members


CreditNote Properties

[image] [image]

Pastel Evolution SDK
CreditNote Properties
CreditNote Class See Also Send Feedback

The CreditNote type exposes the following members.

Properties

 | Name | Description
Public property | Account | Gets or sets the AR or AP account associated with the order. (Inherited from OrderBase.)
Public property | AccountID | Gets or sets the ID of the AR or AP account associated with the order. (Inherited from OrderBase.)
Public property | AllowInvoiceRounding | (Inherited from OrderBase.)
Public property | ApplyTaxPerLine | Gets or sets whether tax per line should be applied. (Inherited from OrderBase.)
Public property | Audit | Gets the audit number of the last transaction processed by this document. This value defaults to 0, and will not be available on recalled documents. (Inherited from OrderBase.)
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Currency | Gets or sets the currency. (Inherited from OrderBase.)
Public property | CurrencyID | Gets or sets the document's currency ID. (Inherited from OrderBase.)
Public property | Customer | Gets or sets the document's customer account (maps directly to Account). (Inherited from SalesDocumentBase.)
Public property | DeliverTo | Gets or sets the delivery address. (Inherited from OrderBase.)
Public property | DeliveryDate | Gets or sets the delivery date. (Inherited from OrderBase.)
Public property | DeliveryMethod | Gets or sets the delivery method. (Inherited from OrderBase.)
Public property | DeliveryMethodID | Gets or sets the delivery method ID. (Inherited from OrderBase.)
Public property | Description | Gets or sets the document description. This will also be the description on any transactions posted. (Inherited from OrderBase.)
Public property | Detail | Gets the order detail collection representing the body of the document. (Inherited from OrderBase.)
Public property | Discount | Gets or sets the document discount amount (applicable to tax excl. total), (Inherited from OrderBase.)
Public property | DiscountForeign | Gets or sets the document foreign discount amount (applicable to tax excl. total), (Inherited from OrderBase.)
Public property | DiscountLastProcessed | Gets the document discount amount last processed. (Inherited from OrderBase.)
Public property | DiscountPercent | Gets or sets the document discount percentage. (Inherited from OrderBase.)
Public property | DiscountToProcess | Gets the document discount amount about to be processed (applicable to tax excl. total). (Inherited from OrderBase.)
Public property | DueDate | Gets or sets the due date. (Inherited from OrderBase.)
Public property | ExchangeRate | Gets or sets the exchange rate. (Inherited from OrderBase.)
Public property | ExternalOrderNo | Gets or sets the external order number. (Inherited from OrderBase.)
Protected property | grossLastProcessTotal | (Inherited from OrderBase.)
Protected property | grossLastProcessTotalForeign | (Inherited from OrderBase.)
Protected property | grossOutstTotal | (Inherited from OrderBase.)
Protected property | grossOutstTotalForeign | (Inherited from OrderBase.)
Protected property | grossToProcessTotal | (Inherited from OrderBase.)
Protected property | grossToProcessTotalForeign | (Inherited from OrderBase.)
Protected property | grossTotal | (Inherited from OrderBase.)
Protected property | grossTotalForeign | (Inherited from OrderBase.)
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Inherited from OrderBase.)
Public property | InvoiceDate | Gets or sets the invoice date. (Inherited from OrderBase.)
Public property | InvoiceNumber | Gets or sets the credit note's invoice number.
Public property | InvoiceTo | Gets or sets the invoice address. (Inherited from OrderBase.)
Public property | IsLoading | Will be true while the order is busy loading detail. (Inherited from OrderBase.)
Public property | IsPartialProcessingAllowed | (Overrides OrderBase..::..IsPartialProcessingAllowed.)
Public property | IsProcessing | Will be true while the order is busy processing transactions. (Inherited from OrderBase.)
Public property | LedgerTransaction | Gets the last ledger transaction (AR/AP Transaction) posted. (Inherited from OrderBase.)
Protected property | lineAdditionalCostTotal | (Inherited from OrderBase.)
Public property | LongID | (Inherited from OrderBase.)
Public property | MessageLine1 | Gets or sets the 1st message line. (Inherited from OrderBase.)
Public property | MessageLine2 | Gets or sets the 2nd message line. (Inherited from OrderBase.)
Public property | MessageLine3 | Gets or sets the 3rd message line. (Inherited from OrderBase.)
Protected property | nettLastProcessTotal | (Inherited from OrderBase.)
Protected property | nettLastProcessTotalForeign | (Inherited from OrderBase.)
Protected property | nettOutstTotal | (Inherited from OrderBase.)
Protected property | nettOutstTotalForeign | (Inherited from OrderBase.)
Protected property | nettToProcessTotal | (Inherited from OrderBase.)
Protected property | nettToProcessTotalForeign | (Inherited from OrderBase.)
Public property | OrderDate | Gets or sets the order date. (Inherited from OrderBase.)
Public property | OrderNo | Gets or sets the order number. (Inherited from OrderBase.)
Public property | OrderPriority | Gets or sets the order priority. (Inherited from OrderBase.)
Public property | OrderPriorityID | Gets or sets the order priority ID. (Inherited from OrderBase.)
Public property | OrderStatus | Gets or sets the document's order status. (Inherited from OrderBase.)
Public property | OrderStatusID | Gets or sets the order status ID. (Inherited from OrderBase.)
Public property | OriginalDocument | (Overrides OrderBase..::..OriginalDocument.)
Public property | PrintCount | Gets or sets the print count. (Inherited from OrderBase.)
Public property | Project | Gets or sets the project. (Inherited from OrderBase.)
Public property | ProjectID | Gets or sets the project ID. (Inherited from OrderBase.)
Public property | Prospect | (Inherited from OrderBase.)
Public property | ProspectID | (Inherited from OrderBase.)
Public property | RawFieldData | Obsolete. (Inherited from OrderBase.)
Public property | Reference | Gets or sets the document reference (InvNumber). (Inherited from OrderBase.)
Public property | Reference2 | Gets the 2nd document reference. (Inherited from OrderBase.)
Public property | Representative | Gets or sets the document sales representative. (Inherited from SalesDocumentBase.)
Public property | RepresentativeID | Gets or sets the sales representative ID. (Inherited from SalesDocumentBase.)
Public property | SalesOpportunity | (Inherited from SalesDocumentBase.)
Public property | SettlementTerms | (Inherited from OrderBase.)
Public property | SettlementTermsID | (Inherited from OrderBase.)
Public property | State | Gets the document state. (Inherited from OrderBase.)
Protected property | taxLastProcessTotal | (Inherited from OrderBase.)
Protected property | taxLastProcessTotalForeign | (Inherited from OrderBase.)
Public property | TaxMode | Gets or sets the tax mode. (Inherited from OrderBase.)
Public property | TaxNumber | Gets or sets the cash account's tax number. (Inherited from OrderBase.)
Protected property | taxOutstTotal | (Inherited from OrderBase.)
Protected property | taxOutstTotalForeign | (Inherited from OrderBase.)
Protected property | taxToProcessTotal | (Inherited from OrderBase.)
Protected property | taxToProcessTotalForeign | (Inherited from OrderBase.)
Protected property | taxTotal | (Inherited from OrderBase.)
Protected property | taxTotalForeign | (Inherited from OrderBase.)
Public property | TaxType | (Inherited from OrderBase.)
Public property | TotalDiscountAdjusted | Gets the total discount adjusted amount. (Inherited from OrderBase.)
Public property | TotalDiscountAdjustedForeign | Gets the total discount adjusted foreign amount. (Inherited from OrderBase.)
Public property | TotalExcl | Gets the total excl amount. (Inherited from OrderBase.)
Public property | TotalExclForeign | Gets the total excl amount. (Inherited from OrderBase.)
Public property | TotalIncl | Gets the total incl amount. (Inherited from OrderBase.)
Public property | TotalInclForeign | Gets the total incl amount. (Inherited from OrderBase.)
Public property | TotalInclForeignBeforeInvoiceRounding | Gets the total incl amount before Invoice Rounding. (Inherited from OrderBase.)
Public property | TotalLastProcessExcl | Gets the total last process excl. (Inherited from OrderBase.)
Public property | TotalLastProcessExclForeign | Gets the total last process excl. (Inherited from OrderBase.)
Public property | TotalLastProcessIncl | Gets the total last process incl. (Inherited from OrderBase.)
Public property | TotalLastProcessInclForeign | Gets the total last process incl. (Inherited from OrderBase.)
Public property | TotalLastProcessTax | Gets the total last process tax. (Inherited from OrderBase.)
Public property | TotalLastProcessTaxForeign | Gets the total last process tax. (Inherited from OrderBase.)
Public property | TotalOutstandingExcl | Gets the total outstanding excl. (Inherited from OrderBase.)
Public property | TotalOutstandingExclForeign | Gets the total outstanding excl. (Inherited from OrderBase.)
Public property | TotalOutstandingIncl | Gets the total outstanding incl. (Inherited from OrderBase.)
Public property | TotalOutstandingInclForeign | Gets the total outstanding incl. (Inherited from OrderBase.)
Public property | TotalOutstandingTax | Gets the total outstanding tax. (Inherited from OrderBase.)
Public property | TotalOutstandingTaxForeign | Gets the total outstanding tax. (Inherited from OrderBase.)
Public property | TotalTax | Gets the total tax amount. (Inherited from OrderBase.)
Public property | TotalTaxForeign | Gets the total tax amount. (Inherited from OrderBase.)
Public property | TotalToProcessExcl | Gets the total amount to process excl. (Inherited from OrderBase.)
Public property | TotalToProcessExclForeign | Gets the total amount to process excl. (Inherited from OrderBase.)
Public property | TotalToProcessIncl | Gets the total to process incl. (Inherited from OrderBase.)
Public property | TotalToProcessInclForeign | Gets the total to process incl. (Inherited from OrderBase.)
Public property | TotalToProcessTax | Gets the total to process tax. (Inherited from OrderBase.)
Public property | TotalToProcessTaxForeign | Gets the total to process tax. (Inherited from OrderBase.)
Public property | Type | Gets the order's document type. (Inherited from OrderBase.)
Public property | UserFields | Gets access to the collection of user-defined fields on the record. Note that the field name is case-sensitive. (Inherited from OrderBase.)
Public property | Version | Gets the current version of the order, incremented on every save. (Inherited from OrderBase.)

See Also

CreditNote Class


CreditNote.InvoiceNumber Property

[image]

Pastel Evolution SDK
CreditNote..::..InvoiceNumber Property
CreditNote Class See Also Send Feedback
Gets or sets the credit note's invoice number.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string InvoiceNumber { get; set; }
Visual Basic
Public Property InvoiceNumber As String
    Get
    Set

Property Value

Type: String

Remarks

The invoice number refers back to an original sale.

See Also

CreditNote Class
CreditNote Members


CreditNote.IsPartialProcessingAllowed Property

[image]

Pastel Evolution SDK
CreditNote..::..IsPartialProcessingAllowed Property
CreditNote Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override bool IsPartialProcessingAllowed { get; }
Visual Basic
Public Overrides ReadOnly Property IsPartialProcessingAllowed As Boolean
    Get

Property Value

Type: Boolean

See Also

CreditNote Class
CreditNote Members


CreditNote.OriginalDocument Property

[image]

Pastel Evolution SDK
CreditNote..::..OriginalDocument Property
CreditNote Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override OrderBase OriginalDocument { get; }
Visual Basic
Public Overrides ReadOnly Property OriginalDocument As OrderBase
    Get

Property Value

Type: OrderBase

See Also

CreditNote Class
CreditNote Members


Currency Class

[image]

Pastel Evolution SDK
Currency Class
Members See Also Send Feedback
Represents a currency record.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class Currency : BranchedRecordBase
Visual Basic
Public Class Currency
    Inherits BranchedRecordBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..Currency

See Also

Currency Members


Currency Members

[image] [image]

Pastel Evolution SDK
Currency Members
Currency Class Constructors Methods Fields Properties See Also Send Feedback

The Currency type exposes the following members.

Constructors

 | Name | Description
Public method | Currency()()()() | Creates a new instance of a currency.
Public method | Currency(Int32) | Creates a new instance of a currency.
Public method | Currency(String) | Creates a new instance of a currency.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds a record's database ID.
 | FindByCode |
 | GetByCode |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | List | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | (Overrides Object..::..ToString()()()().)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Code | Gets or sets the currency's code.
Public property | Description | Gets or sets the currency's description.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | Options | Gets or sets the currency's options.
Public property | PromptAgentID | Gets or sets the currency's prompt agent id (the Id of the agent that gets prompted for setting the currency rate).
Public property | Rates | Gets a collection of exchange rates, accessible by date. Exchange rates are global, and not branch-specific.
Public property | Symbol | Gets or sets the currency's symbol.

See Also

Currency Class


Currency Constructor

[image] [image]

Pastel Evolution SDK
Currency Constructor
Currency Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Currency()()()() | Creates a new instance of a currency.
Public method | Currency(Int32) | Creates a new instance of a currency.
Public method | Currency(String) | Creates a new instance of a currency.

See Also

Currency Class
Currency Members


Currency Constructor

[image]

Pastel Evolution SDK
Currency Constructor
Currency Class See Also Send Feedback
Creates a new instance of a currency.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Currency()
Visual Basic
Public Sub New

See Also

Currency Class
Currency Members
Currency Overload


Currency Constructor (Int32)

[image]

Pastel Evolution SDK
Currency Constructor (Int32)
Currency Class See Also Send Feedback
Creates a new instance of a currency.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Currency(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32
Specifies the id of the existing record.

See Also

Currency Class
Currency Members
Currency Overload


Currency Constructor (String)

[image]

Pastel Evolution SDK
Currency Constructor (String)
Currency Class See Also Send Feedback
Creates a new instance of a currency.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Currency(
    string code
)
Visual Basic
Public Sub New (
    code As String
)

Parameters

code
Type: System..::..String
Specifies the code of the existing record.

See Also

Currency Class
Currency Members
Currency Overload


Currency Fields

[image] [image]

Pastel Evolution SDK
Currency Fields
Currency Class See Also Send Feedback

The Currency type exposes the following members.

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

Currency Class


Currency Methods

[image] [image]

Pastel Evolution SDK
Currency Methods
Currency Class See Also Send Feedback

The Currency type exposes the following members.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds a record's database ID.
 | FindByCode |
 | GetByCode |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | List | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | (Overrides Object..::..ToString()()()().)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

Currency Class


Currency.Find Method

[image]

Pastel Evolution SDK
Currency..::..Find Method
Currency Class See Also Send Feedback
Finds a record's database ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.

Return Value

Type: Int32
The ID of the first record found; -1 if not record was found.

See Also

Currency Class
Currency Members


Currency.FindByCode Method

[image]

Pastel Evolution SDK
Currency..::..FindByCode Method
Currency Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int FindByCode(
    string code
)
Visual Basic
Public Shared Function FindByCode (
    code As String
) As Integer

Parameters

code
Type: System..::..String

Return Value

Type: Int32

See Also

Currency Class
Currency Members


Currency.GetByCode Method

[image]

Pastel Evolution SDK
Currency..::..GetByCode Method
Currency Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static Currency GetByCode(
    string code
)
Visual Basic
Public Shared Function GetByCode (
    code As String
) As Currency

Parameters

code
Type: System..::..String

Return Value

Type: Currency

See Also

Currency Class
Currency Members


Currency.List Method

[image]

Pastel Evolution SDK
Currency..::..List Method
Currency Class See Also Send Feedback
Gets a list of database records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DataTable List(
    string criteria
)
Visual Basic
Public Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.

Return Value

Type: DataTable
Table containing selected records.

See Also

Currency Class
Currency Members


Currency.OnDelete Method

[image]

Pastel Evolution SDK
Currency..::..OnDelete Method
Currency Class See Also Send Feedback
Removes the record from the database, provided it is not referenced by other records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

Exceptions

Exception | Condition
IntegrityViolationException |

See Also

Currency Class
Currency Members


Currency.OnSave Method

[image]

Pastel Evolution SDK
Currency..::..OnSave Method
Currency Class See Also Send Feedback
Persists the record to the database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

Currency Class
Currency Members


Currency.ToString Method

[image]

Pastel Evolution SDK
Currency..::..ToString Method
Currency Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String

See Also

Currency Class
Currency Members


Currency Properties

[image] [image]

Pastel Evolution SDK
Currency Properties
Currency Class See Also Send Feedback

The Currency type exposes the following members.

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Code | Gets or sets the currency's code.
Public property | Description | Gets or sets the currency's description.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | Options | Gets or sets the currency's options.
Public property | PromptAgentID | Gets or sets the currency's prompt agent id (the Id of the agent that gets prompted for setting the currency rate).
Public property | Rates | Gets a collection of exchange rates, accessible by date. Exchange rates are global, and not branch-specific.
Public property | Symbol | Gets or sets the currency's symbol.

See Also

Currency Class


Currency.Code Property

[image]

Pastel Evolution SDK
Currency..::..Code Property
Currency Class See Also Send Feedback
Gets or sets the currency's code.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Code { get; set; }
Visual Basic
Public Property Code As String
    Get
    Set

Property Value

Type: String

See Also

Currency Class
Currency Members


Currency.Description Property

[image]

Pastel Evolution SDK
Currency..::..Description Property
Currency Class See Also Send Feedback
Gets or sets the currency's description.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set

Property Value

Type: String

See Also

Currency Class
Currency Members


Currency.ID Property

[image]

Pastel Evolution SDK
Currency..::..ID Property
Currency Class See Also Send Feedback
Gets the internal record ID (0 for new, unsaved records).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

See Also

Currency Class
Currency Members


Currency.LongID Property

[image]

Pastel Evolution SDK
Currency..::..LongID Property
Currency Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

Currency Class
Currency Members


Currency.Options Property

[image]

Pastel Evolution SDK
Currency..::..Options Property
Currency Class See Also Send Feedback
Gets or sets the currency's options.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int Options { get; set; }
Visual Basic
Public Property Options As Integer
    Get
    Set

Property Value

Type: Int32

See Also

Currency Class
Currency Members


Currency.PromptAgentID Property

[image]

Pastel Evolution SDK
Currency..::..PromptAgentID Property
Currency Class See Also Send Feedback
Gets or sets the currency's prompt agent id (the Id of the agent that gets prompted for setting the currency rate).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int PromptAgentID { get; set; }
Visual Basic
Public Property PromptAgentID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

Currency Class
Currency Members


Currency.Rates Property

[image]

Pastel Evolution SDK
Currency..::..Rates Property
Currency Class See Also Send Feedback
Gets a collection of exchange rates, accessible by date. Exchange rates are global, and not branch-specific.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public ExchangeRateCollection Rates { get; }
Visual Basic
Public ReadOnly Property Rates As ExchangeRateCollection
    Get

Property Value

Type: ExchangeRateCollection

See Also

Currency Class
Currency Members


Currency.Symbol Property

[image]

Pastel Evolution SDK
Currency..::..Symbol Property
Currency Class See Also Send Feedback
Gets or sets the currency's symbol.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Symbol { get; set; }
Visual Basic
Public Property Symbol As String
    Get
    Set

Property Value

Type: String

See Also

Currency Class
Currency Members


Customer Class

[image]

Pastel Evolution SDK
Customer Class
Members See Also Send Feedback
Represents a customer account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class Customer : DrCrAccount
Visual Basic
Public Class Customer
    Inherits DrCrAccount

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..AccountBase
Pastel.Evolution..::..DrCrAccount
Pastel.Evolution..::..Customer

See Also

Customer Members


Customer Members

[image] [image]

Pastel Evolution SDK
Customer Members
Customer Class Constructors Methods Fields Properties See Also Send Feedback

The Customer type exposes the following members.

Constructors

 | Name | Description
Public method | Customer()()()() | Creates a new instance of a customer account.
Public method | Customer(Int32) | Creates a new instance of a customer account.
Public method | Customer(String) | Creates a new instance of a customer account.

Methods

 | Name | Description
Public method | _GenerateAccountCode |
 | _ListCurrentBranch |
Public method | _Refresh | Experimental method.
 | _Select(String) | Experimental Method
 | _Select(String, String) |
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds a customer account ID.
 | FindByCode | Attempts to find an AR account by its account code and returns its ID.
 | Get | Returns the [first] customer object matching the criteria specified; otherwise, returns null.
 | GetByCode | Returns a customer object corresponding to the code specified; otherwise, returns null.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List(String) | Returns a System.Data.DataTable object containing the database records from the Client table matching the supplied criteria.
 | List(String, String) | Returns a System.Data.DataTable object containing the database records from the Client table matching the supplied criteria.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides AccountBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides AccountBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | (Inherited from AccountBase.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | AccountBalance | Gets the current balance on the account. (Overrides DrCrAccount..::..AccountBalance.)
Public property | AccountDescription | Gets or sets an additional description on the account.
Public property | AccountTerms | Gets or sets the account terms. (temporary property)
Public property | Active | Gets or sets the account's operational state. (Overrides AccountBase..::..Active.)
Public property | Addressee | Gets or sets the account's addressee.
Public property | AgeingMethod |
Public property | AgentID | Gets or sets the ID of the agent associated withthe account.
Public property | AgingTerm | Gets or sets the customer aging terms associated with the account.
Public property | AgingTermID | Gets or sets ID of the customer aging terms associated with the account.
Public property | Area | Gets or sets the account's area.
Public property | AreaID | Gets or sets the ID of the Area record associated with the account.
Public property | AutomaticDiscount | Gets or sets the discount percentage (valid values: 0-100) automatically appliedto inventory documents.
Public property | Bank | Gets or sets the bank associated with the account.
Public property | BankAccountNo | Gets or sets the account's bank account number.
Public property | BankAccountType | Gets or sets the account's bank account type.
Public property | BankBranchCode | Gets or sets the account's bank branch code.
Public property | BankID | Gets or sets the ID of the bank record associated with the account.
Public property | BankReferenceNo | Gets or sets the reference number to use in bank transaction exports etc.
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | BusinessClass | Gets or sets the account's business class.
Public property | BusinessClassID | Gets or sets the account's business class ID.
Public property | BusinessType | Gets or sets the account's business type.
Public property | BusinessTypeID | Gets or sets the account's business type ID.
Public property | CellPhone | Gets or sets the mobile number associated with the account.
Public property | ChargeTax | Gets or sets whether or not to charge the account VAT. (Overrides DrCrAccount..::..ChargeTax.)
Public property | CheckTerms | Gets or sets whether or not to check the terms on the account before posting debit transactions.
Public property | Code | Gets or sets the account's code. (Overrides AccountBase..::..Code.)
Public property | ContactPerson | Gets or sets the account's contact person.
Public property | Country | Gets or sets the account's country.Gets or sets the country record associated with the account.
Public property | CountryID | Gets or sets the ID of the country associated with the account.
Public property | CreditLimit | Gets or sets the account's credit limit.
Public property | Currency | Gets or sets the account's currency. A null value indicates home currency. (Overrides DrCrAccount..::..Currency.)
Public property | CurrencyID | Gets or sets the account's currency id. 0 indicates local currency. (Overrides DrCrAccount..::..CurrencyID.)
Public property | DefaultDeliveryAddress | Gets the account's default delivery address. A new address is created on the fly if one does not exist.
Public property | DefaultIncidentTypeID | Gets or sets the account's default incident type ID.
Public property | DefaultPriceList |
Public property | DefaultPriceListID |
Public property | DefaultSettlementTerms | (Overrides DrCrAccount..::..DefaultSettlementTerms.)
Public property | DefaultTaxRate | Gets or sets the account's default tax rate.
Public property | DefaultTaxRateID | Gets or sets the account's default tax rate id.
Public property | DeliverTo | Gets or sets the account's addressee.
Public property | DeliveryAddresses |
Public property | Description | Gets or sets the account's name. (Overrides AccountBase..::..Description.)
Public property | ElectronicDocumentAcceptance | Gets or sets whether or not the customer accepts electronic invoices as originals.
Public property | EmailAddress | Gets or sets the email address associated with the account.
Public property | EmailSourceDocument | Gets or sets whether or not the customer's source documents should be emailed.
Public property | EmailStatement | Gets or sets whether or not the customer account's statement should be emailed.
Public property | Fax | Gets or sets the account's fax number.
Public property | ForeignAccountBalance | Gets the current balance on the account in its foreign currency. (Overrides DrCrAccount..::..ForeignAccountBalance.)
Public property | Group | Gets or sets the customer group associated with the account.
Public property | GroupID | Gets or sets ID of the customer group associated with the account.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | IDNumber |
Public property | Initials | Gets or sets the account's initials if the account represents a person.
Public property | InterestRate | Gets or sets the account's interest rate as used by the interest charging utilityin Evolution (valid values: 0-100).
Public property | IsCashDebtor | Gets or sets whether the account is a cash debtor.
Public property | IsForeignCurrencyAccount | Gets or sets whether the account transacts in a foreign currency. (Overrides DrCrAccount..::..IsForeignCurrencyAccount.)
Public property | IsOnHold | Gets or sets whether or not the account is on hold.
Public property | Item | Gets an account object possessing the given code.
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | MainAccount | Gets or sets the account's main account.
Public property | MainAccountID | Gets the main account's ID (0 if none)
Public property | Module | Gets the Evolution module this record belongs to, Used in internal validation. (Overrides AccountBase..::..Module.)
Public property | PhysicalAddress | Gets or sets the account's physical address.
Public property | PostalAddress | Gets or sets the account's physical address.
Public property | PrintSourceDocument | Gets or sets whether or not the customer's source documents should be printed.
Public property | PrintStatement | Gets or sets whether or not the customer account requires a physical statement.
Public property | PromptTaxNumber | Gets or sets whether or not a prompt should be raised when selling to this account when it does not have a TaxNumber specified.
Public property | RawFieldData | Obsolete.
Public property | Registration | Gets or sets the account's registration (company, CC, etc.) number.
Public property | SalesRepID | Gets or sets the sales representative ID.
Public property | SettlementDiscount | Gets or sets the settlement discount percentage applied when receiving payments through the Evolution front-end (valid values: 0-100).
Public property | StatementZipPassword | Gets or sets the password to the zip file when emailing and zipping a statement. Passed as clear text but encrypted in the database.
Public property | TaxNumber | Gets or sets the account's VAT number.
Public property | Telephone | Gets or sets the account's primary telephone number.
Public property | Telephone2 | Gets or sets the account's secondary telephone number.
Public property | Timestamp | Gets the date/time on which the account was last modified.
Public property | Title | Gets or sets the account's title (Mr., Mrs. etc.) if the account represents a person.
Public property | UseEmail | Gets or sets whether or not to use the account's e-mail address.
Public property | UserFields |
Public property | Webpage | Gets or sets the web address associated with the account.

See Also

Customer Class


Customer Constructor

[image] [image]

Pastel Evolution SDK
Customer Constructor
Customer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Customer()()()() | Creates a new instance of a customer account.
Public method | Customer(Int32) | Creates a new instance of a customer account.
Public method | Customer(String) | Creates a new instance of a customer account.

See Also

Customer Class
Customer Members


Customer Constructor

[image]

Pastel Evolution SDK
Customer Constructor
Customer Class See Also Send Feedback
Creates a new instance of a customer account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Customer()
Visual Basic
Public Sub New

See Also

Customer Class
Customer Members
Customer Overload


Customer Constructor (Int32)

[image]

Pastel Evolution SDK
Customer Constructor (Int32)
Customer Class See Also Send Feedback
Creates a new instance of a customer account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Customer(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32
Specifies the id of the existing record.

See Also

Customer Class
Customer Members
Customer Overload


Customer Constructor (String)

[image]

Pastel Evolution SDK
Customer Constructor (String)
Customer Class See Also Send Feedback
Creates a new instance of a customer account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Customer(
    string code
)
Visual Basic
Public Sub New (
    code As String
)

Parameters

code
Type: System..::..String
Specifies the code of the existing record.

See Also

Customer Class
Customer Members
Customer Overload


Customer Fields

[image] [image]

Pastel Evolution SDK
Customer Fields
Customer Class See Also Send Feedback

The Customer type exposes the following members.

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

Customer Class


Customer Methods

[image] [image]

Pastel Evolution SDK
Customer Methods
Customer Class See Also Send Feedback

The Customer type exposes the following members.

Methods

 | Name | Description
Public method | _GenerateAccountCode |
 | _ListCurrentBranch |
Public method | _Refresh | Experimental method.
 | _Select(String) | Experimental Method
 | _Select(String, String) |
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds a customer account ID.
 | FindByCode | Attempts to find an AR account by its account code and returns its ID.
 | Get | Returns the [first] customer object matching the criteria specified; otherwise, returns null.
 | GetByCode | Returns a customer object corresponding to the code specified; otherwise, returns null.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List(String) | Returns a System.Data.DataTable object containing the database records from the Client table matching the supplied criteria.
 | List(String, String) | Returns a System.Data.DataTable object containing the database records from the Client table matching the supplied criteria.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides AccountBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides AccountBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | (Inherited from AccountBase.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

Customer Class


Customer._GenerateAccountCode Method

[image]

Pastel Evolution SDK
Customer..::.._GenerateAccountCode Method
Customer Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string _GenerateAccountCode(
    string seed
)
Visual Basic
Public Function _GenerateAccountCode (
    seed As String
) As String

Parameters

seed
Type: System..::..String

Return Value

Type: String

See Also

Customer Class
Customer Members


Customer._ListCurrentBranch Method

[image]

Pastel Evolution SDK
Customer..::.._ListCurrentBranch Method
Customer Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable _ListCurrentBranch(
    string criteria
)
Visual Basic
Public Shared Function _ListCurrentBranch (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String

Return Value

Type: DataTable

See Also

Customer Class
Customer Members


Customer._Refresh Method

[image]

Pastel Evolution SDK
Customer..::.._Refresh Method
Customer Class See Also Send Feedback
Experimental method.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void _Refresh()
Visual Basic
Public Sub _Refresh

See Also

Customer Class
Customer Members


Customer._Select Method

[image] [image]

Pastel Evolution SDK
Customer..::.._Select Method
Customer Class See Also Send Feedback

Overload List

Name | Description
_Select(String) | Experimental Method
_Select(String, String) |

See Also

Customer Class
Customer Members


Customer._Select Method (String)

[image]

Pastel Evolution SDK
Customer..::.._Select Method (String)
Customer Class See Also Send Feedback
Experimental Method

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static Customer[] _Select(
    string criteria
)
Visual Basic
Public Shared Function _Select (
    criteria As String
) As Customer()

Parameters

criteria
Type: System..::..String

Return Value

Type: array< Customer >[]()[][]

See Also

Customer Class
Customer Members
_Select Overload


Customer._Select Method (String, String)

[image]

Pastel Evolution SDK
Customer..::.._Select Method (String, String)
Customer Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static Customer[] _Select(
    string criteria,
    string sortOrder
)
Visual Basic
Public Shared Function _Select (
    criteria As String,
    sortOrder As String
) As Customer()

Parameters

criteria
Type: System..::..String
sortOrder
Type: System..::..String

Return Value

Type: array< Customer >[]()[][]

See Also

Customer Class
Customer Members
_Select Overload


Customer.Find Method

[image]

Pastel Evolution SDK
Customer..::..Find Method
Customer Class See Also Send Feedback
Finds a customer account ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String
The criteria passed to the SQL query. Eg. Account = 'CASH001' or Name like '%CASH%'

Return Value

Type: Int32

See Also

Customer Class
Customer Members


Customer.FindByCode Method

[image]

Pastel Evolution SDK
Customer..::..FindByCode Method
Customer Class See Also Send Feedback
Attempts to find an AR account by its account code and returns its ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int FindByCode(
    string code
)
Visual Basic
Public Shared Function FindByCode (
    code As String
) As Integer

Parameters

code
Type: System..::..String
The account code used to lookup the account.

Return Value

Type: Int32
-1 if no record was found, else the id of the first account matching the criteria supplied.

See Also

Customer Class
Customer Members
Pastel.Evolution Namespace
Customer..::..Find(String)


Customer.Get Method

[image]

Pastel Evolution SDK
Customer..::..Get Method
Customer Class See Also Send Feedback
Returns the [first] customer object matching the criteria specified; otherwise, returns null.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static Customer Get(
    string criteria
)
Visual Basic
Public Shared Function Get (
    criteria As String
) As Customer

Parameters

criteria
Type: System..::..String
Eg. Account = 'CASH001' or Name like '%CASH%'

Return Value

Type: Customer

See Also

Customer Class
Customer Members
Pastel.Evolution Namespace
Customer..::..Find(String)


Customer.GetByCode Method

[image]

Pastel Evolution SDK
Customer..::..GetByCode Method
Customer Class See Also Send Feedback
Returns a customer object corresponding to the code specified; otherwise, returns null.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static Customer GetByCode(
    string code
)
Visual Basic
Public Shared Function GetByCode (
    code As String
) As Customer

Parameters

code
Type: System..::..String

Return Value

Type: Customer

See Also

Customer Class
Customer Members


Customer.List Method

[image] [image]

Pastel Evolution SDK
Customer..::..List Method
Customer Class See Also Send Feedback

Overload List

Name | Description
List(String) | Returns a System.Data.DataTable object containing the database records from the Client table matching the supplied criteria.
List(String, String) | Returns a System.Data.DataTable object containing the database records from the Client table matching the supplied criteria.

See Also

Customer Class
Customer Members


Customer.List Method (String)

[image]

Pastel Evolution SDK
Customer..::..List Method (String)
Customer Class See Also Send Feedback
Returns a System.Data.DataTable object containing the database records from the Client table matching the supplied criteria.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria
)
Visual Basic
Public Shared Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String
The SQL criteria used to locate the record, e.g. Account like '1___'

Return Value

Type: DataTable
A System.Data.DataTable object containing matching records.

Remarks

The criteria is passed to an SQL query so use the appropriate syntax. Remember to includethe single quotes around string literals and append additional criteria with and.

See Also

Customer Class
Customer Members
List Overload


Customer.List Method (String, String)

[image]

Pastel Evolution SDK
Customer..::..List Method (String, String)
Customer Class See Also Send Feedback
Returns a System.Data.DataTable object containing the database records from the Client table matching the supplied criteria.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria,
    string sortOrder
)
Visual Basic
Public Shared Function List (
    criteria As String,
    sortOrder As String
) As DataTable

Parameters

criteria
Type: System..::..String
The SQL criteria used to locate the record, e.g. Account like '1___'
sortOrder
Type: System..::..String
The SQL order by clause to use, e.g. DCBalance desc, Account

Return Value

Type: DataTable
A System.Data.DataTable object containing matching records.

Remarks

The criteria is passed to an SQL query so use the appropriate syntax. Remember to includethe single quotes around string literals and append additional criteria with and.

See Also

Customer Class
Customer Members
List Overload


Customer.OnDelete Method

[image]

Pastel Evolution SDK
Customer..::..OnDelete Method
Customer Class See Also Send Feedback
Removes the record from the database, provided it is not referenced by other records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

Exceptions

Exception | Condition
IntegrityViolationException |

See Also

Customer Class
Customer Members


Customer.OnSave Method

[image]

Pastel Evolution SDK
Customer..::..OnSave Method
Customer Class See Also Send Feedback
Persists the record to the database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

Customer Class
Customer Members


Customer Properties

[image] [image]

Pastel Evolution SDK
Customer Properties
Customer Class See Also Send Feedback

The Customer type exposes the following members.

Properties

 | Name | Description
Public property | AccountBalance | Gets the current balance on the account. (Overrides DrCrAccount..::..AccountBalance.)
Public property | AccountDescription | Gets or sets an additional description on the account.
Public property | AccountTerms | Gets or sets the account terms. (temporary property)
Public property | Active | Gets or sets the account's operational state. (Overrides AccountBase..::..Active.)
Public property | Addressee | Gets or sets the account's addressee.
Public property | AgeingMethod |
Public property | AgentID | Gets or sets the ID of the agent associated withthe account.
Public property | AgingTerm | Gets or sets the customer aging terms associated with the account.
Public property | AgingTermID | Gets or sets ID of the customer aging terms associated with the account.
Public property | Area | Gets or sets the account's area.
Public property | AreaID | Gets or sets the ID of the Area record associated with the account.
Public property | AutomaticDiscount | Gets or sets the discount percentage (valid values: 0-100) automatically appliedto inventory documents.
Public property | Bank | Gets or sets the bank associated with the account.
Public property | BankAccountNo | Gets or sets the account's bank account number.
Public property | BankAccountType | Gets or sets the account's bank account type.
Public property | BankBranchCode | Gets or sets the account's bank branch code.
Public property | BankID | Gets or sets the ID of the bank record associated with the account.
Public property | BankReferenceNo | Gets or sets the reference number to use in bank transaction exports etc.
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | BusinessClass | Gets or sets the account's business class.
Public property | BusinessClassID | Gets or sets the account's business class ID.
Public property | BusinessType | Gets or sets the account's business type.
Public property | BusinessTypeID | Gets or sets the account's business type ID.
Public property | CellPhone | Gets or sets the mobile number associated with the account.
Public property | ChargeTax | Gets or sets whether or not to charge the account VAT. (Overrides DrCrAccount..::..ChargeTax.)
Public property | CheckTerms | Gets or sets whether or not to check the terms on the account before posting debit transactions.
Public property | Code | Gets or sets the account's code. (Overrides AccountBase..::..Code.)
Public property | ContactPerson | Gets or sets the account's contact person.
Public property | Country | Gets or sets the account's country.Gets or sets the country record associated with the account.
Public property | CountryID | Gets or sets the ID of the country associated with the account.
Public property | CreditLimit | Gets or sets the account's credit limit.
Public property | Currency | Gets or sets the account's currency. A null value indicates home currency. (Overrides DrCrAccount..::..Currency.)
Public property | CurrencyID | Gets or sets the account's currency id. 0 indicates local currency. (Overrides DrCrAccount..::..CurrencyID.)
Public property | DefaultDeliveryAddress | Gets the account's default delivery address. A new address is created on the fly if one does not exist.
Public property | DefaultIncidentTypeID | Gets or sets the account's default incident type ID.
Public property | DefaultPriceList |
Public property | DefaultPriceListID |
Public property | DefaultSettlementTerms | (Overrides DrCrAccount..::..DefaultSettlementTerms.)
Public property | DefaultTaxRate | Gets or sets the account's default tax rate.
Public property | DefaultTaxRateID | Gets or sets the account's default tax rate id.
Public property | DeliverTo | Gets or sets the account's addressee.
Public property | DeliveryAddresses |
Public property | Description | Gets or sets the account's name. (Overrides AccountBase..::..Description.)
Public property | ElectronicDocumentAcceptance | Gets or sets whether or not the customer accepts electronic invoices as originals.
Public property | EmailAddress | Gets or sets the email address associated with the account.
Public property | EmailSourceDocument | Gets or sets whether or not the customer's source documents should be emailed.
Public property | EmailStatement | Gets or sets whether or not the customer account's statement should be emailed.
Public property | Fax | Gets or sets the account's fax number.
Public property | ForeignAccountBalance | Gets the current balance on the account in its foreign currency. (Overrides DrCrAccount..::..ForeignAccountBalance.)
Public property | Group | Gets or sets the customer group associated with the account.
Public property | GroupID | Gets or sets ID of the customer group associated with the account.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | IDNumber |
Public property | Initials | Gets or sets the account's initials if the account represents a person.
Public property | InterestRate | Gets or sets the account's interest rate as used by the interest charging utilityin Evolution (valid values: 0-100).
Public property | IsCashDebtor | Gets or sets whether the account is a cash debtor.
Public property | IsForeignCurrencyAccount | Gets or sets whether the account transacts in a foreign currency. (Overrides DrCrAccount..::..IsForeignCurrencyAccount.)
Public property | IsOnHold | Gets or sets whether or not the account is on hold.
Public property | Item | Gets an account object possessing the given code.
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | MainAccount | Gets or sets the account's main account.
Public property | MainAccountID | Gets the main account's ID (0 if none)
Public property | Module | Gets the Evolution module this record belongs to, Used in internal validation. (Overrides AccountBase..::..Module.)
Public property | PhysicalAddress | Gets or sets the account's physical address.
Public property | PostalAddress | Gets or sets the account's physical address.
Public property | PrintSourceDocument | Gets or sets whether or not the customer's source documents should be printed.
Public property | PrintStatement | Gets or sets whether or not the customer account requires a physical statement.
Public property | PromptTaxNumber | Gets or sets whether or not a prompt should be raised when selling to this account when it does not have a TaxNumber specified.
Public property | RawFieldData | Obsolete.
Public property | Registration | Gets or sets the account's registration (company, CC, etc.) number.
Public property | SalesRepID | Gets or sets the sales representative ID.
Public property | SettlementDiscount | Gets or sets the settlement discount percentage applied when receiving payments through the Evolution front-end (valid values: 0-100).
Public property | StatementZipPassword | Gets or sets the password to the zip file when emailing and zipping a statement. Passed as clear text but encrypted in the database.
Public property | TaxNumber | Gets or sets the account's VAT number.
Public property | Telephone | Gets or sets the account's primary telephone number.
Public property | Telephone2 | Gets or sets the account's secondary telephone number.
Public property | Timestamp | Gets the date/time on which the account was last modified.
Public property | Title | Gets or sets the account's title (Mr., Mrs. etc.) if the account represents a person.
Public property | UseEmail | Gets or sets whether or not to use the account's e-mail address.
Public property | UserFields |
Public property | Webpage | Gets or sets the web address associated with the account.

See Also

Customer Class


Customer.AccountBalance Property

[image]

Pastel Evolution SDK
Customer..::..AccountBalance Property
Customer Class See Also Send Feedback
Gets the current balance on the account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override double AccountBalance { get; }
Visual Basic
Public Overrides ReadOnly Property AccountBalance As Double
    Get

Property Value

Type: Double

See Also

Customer Class
Customer Members


Customer.AccountDescription Property

[image]

Pastel Evolution SDK
Customer..::..AccountDescription Property
Customer Class See Also Send Feedback
Gets or sets an additional description on the account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string AccountDescription { get; set; }
Visual Basic
Public Property AccountDescription As String
    Get
    Set

Property Value

Type: String

See Also

Customer Class
Customer Members
Pastel.Evolution Namespace
Customer..::..Description


Customer.AccountTerms Property

[image]

Pastel Evolution SDK
Customer..::..AccountTerms Property
Customer Class See Also Send Feedback
Gets or sets the account terms. (temporary property)

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int AccountTerms { get; set; }
Visual Basic
Public Property AccountTerms As Integer
    Get
    Set

Property Value

Type: Int32

See Also

Customer Class
Customer Members


Customer.Active Property

[image]

Pastel Evolution SDK
Customer..::..Active Property
Customer Class See Also Send Feedback
Gets or sets the account's operational state.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override bool Active { get; set; }
Visual Basic
Public Overrides Property Active As Boolean
    Get
    Set

Property Value

Type: Boolean

Remarks

Inactive records cannot be used when posting transactions.

See Also

Customer Class
Customer Members


Customer.Addressee Property

[image]

Pastel Evolution SDK
Customer..::..Addressee Property
Customer Class See Also Send Feedback
Gets or sets the account's addressee.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Addressee { get; set; }
Visual Basic
Public Property Addressee As String
    Get
    Set

Property Value

Type: String

Remarks

This would generally be the same as the account description,except where the company name will not be useful in locating the recipientwhen shipping letters/statements.

See Also

Customer Class
Customer Members
Pastel.Evolution Namespace
Customer..::..DeliverTo


Customer.AgeingMethod Property

[image]

Pastel Evolution SDK
Customer..::..AgeingMethod Property
Customer Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public AccountAgeingMethod AgeingMethod { get; set; }
Visual Basic
Public Property AgeingMethod As AccountAgeingMethod
    Get
    Set

Property Value

Type: AccountAgeingMethod

See Also

Customer Class
Customer Members


Customer.AgentID Property

[image]

Pastel Evolution SDK
Customer..::..AgentID Property
Customer Class See Also Send Feedback
Gets or sets the ID of the agent associated withthe account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int AgentID { get; set; }
Visual Basic
Public Property AgentID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

Customer Class
Customer Members


Customer.AgingTerm Property

[image]

Pastel Evolution SDK
Customer..::..AgingTerm Property
Customer Class See Also Send Feedback
Gets or sets the customer aging terms associated with the account.
Gets or sets the customer aging terms associated with the account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public AgingTerm AgingTerm { get; set; }
Visual Basic
Public Property AgingTerm As AgingTerm
    Get
    Set

Property Value

Type: AgingTerm

See Also

Customer Class
Customer Members


Customer.AgingTermID Property

[image]

Pastel Evolution SDK
Customer..::..AgingTermID Property
Customer Class See Also Send Feedback
Gets or sets ID of the customer aging terms associated with the account.
Gets or sets ID of the customer aging terms associated with the account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int AgingTermID { get; set; }
Visual Basic
Public Property AgingTermID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

Customer Class
Customer Members


Customer.Area Property

[image]

Pastel Evolution SDK
Customer..::..Area Property
Customer Class See Also Send Feedback
Gets or sets the account's area.
Gets or sets the Area record associated with the account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Area Area { get; set; }
Visual Basic
Public Property Area As Area
    Get
    Set

Property Value

Type: Area

See Also

Customer Class
Customer Members


Customer.AreaID Property

[image]

Pastel Evolution SDK
Customer..::..AreaID Property
Customer Class See Also Send Feedback
Gets or sets the ID of the Area record associated with the account.
Gets or sets the ID of the Area record associated with the account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int AreaID { get; set; }
Visual Basic
Public Property AreaID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

Customer Class
Customer Members


Customer.AutomaticDiscount Property

[image]

Pastel Evolution SDK
Customer..::..AutomaticDiscount Property
Customer Class See Also Send Feedback
Gets or sets the discount percentage (valid values: 0-100) automatically appliedto inventory documents.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double AutomaticDiscount { get; set; }
Visual Basic
Public Property AutomaticDiscount As Double
    Get
    Set

Property Value

Type: Double

See Also

Customer Class
Customer Members


Customer.Bank Property

[image]

Pastel Evolution SDK
Customer..::..Bank Property
Customer Class See Also Send Feedback
Gets or sets the bank associated with the account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Bank Bank { get; set; }
Visual Basic
Public Property Bank As Bank
    Get
    Set

Property Value

Type: Bank

See Also

Customer Class
Customer Members


Customer.BankAccountNo Property

[image]

Pastel Evolution SDK
Customer..::..BankAccountNo Property
Customer Class See Also Send Feedback
Gets or sets the account's bank account number.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string BankAccountNo { get; set; }
Visual Basic
Public Property BankAccountNo As String
    Get
    Set

Property Value

Type: String

See Also

Customer Class
Customer Members


Customer.BankAccountType Property

[image]

Pastel Evolution SDK
Customer..::..BankAccountType Property
Customer Class See Also Send Feedback
Gets or sets the account's bank account type.
Gets or sets the account's bank account type.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Bank..::..AccountType BankAccountType { get; set; }
Visual Basic
Public Property BankAccountType As Bank..::..AccountType
    Get
    Set

Property Value

Type: Bank..::..AccountType

See Also

Customer Class
Customer Members


Customer.BankBranchCode Property

[image]

Pastel Evolution SDK
Customer..::..BankBranchCode Property
Customer Class See Also Send Feedback
Gets or sets the account's bank branch code.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string BankBranchCode { get; set; }
Visual Basic
Public Property BankBranchCode As String
    Get
    Set

Property Value

Type: String

See Also

Customer Class
Customer Members


Customer.BankID Property

[image]

Pastel Evolution SDK
Customer..::..BankID Property
Customer Class See Also Send Feedback
Gets or sets the ID of the bank record associated with the account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int BankID { get; set; }
Visual Basic
Public Property BankID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

Customer Class
Customer Members


Customer.BankReferenceNo Property

[image]

Pastel Evolution SDK
Customer..::..BankReferenceNo Property
Customer Class See Also Send Feedback
Gets or sets the reference number to use in bank transaction exports etc.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string BankReferenceNo { get; set; }
Visual Basic
Public Property BankReferenceNo As String
    Get
    Set

Property Value

Type: String

See Also

Customer Class
Customer Members


Customer.BusinessClass Property

[image]

Pastel Evolution SDK
Customer..::..BusinessClass Property
Customer Class See Also Send Feedback
Gets or sets the account's business class.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public BusinessClass BusinessClass { get; set; }
Visual Basic
Public Property BusinessClass As BusinessClass
    Get
    Set

Property Value

Type: BusinessClass

See Also

Customer Class
Customer Members


Customer.BusinessClassID Property

[image]

Pastel Evolution SDK
Customer..::..BusinessClassID Property
Customer Class See Also Send Feedback
Gets or sets the account's business class ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int BusinessClassID { get; set; }
Visual Basic
Public Property BusinessClassID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

Customer Class
Customer Members


Customer.BusinessType Property

[image]

Pastel Evolution SDK
Customer..::..BusinessType Property
Customer Class See Also Send Feedback
Gets or sets the account's business type.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public BusinessType BusinessType { get; set; }
Visual Basic
Public Property BusinessType As BusinessType
    Get
    Set

Property Value

Type: BusinessType

See Also

Customer Class
Customer Members


Customer.BusinessTypeID Property

[image]

Pastel Evolution SDK
Customer..::..BusinessTypeID Property
Customer Class See Also Send Feedback
Gets or sets the account's business type ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int BusinessTypeID { get; set; }
Visual Basic
Public Property BusinessTypeID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

Customer Class
Customer Members


Customer.CellPhone Property

[image]

Pastel Evolution SDK
Customer..::..CellPhone Property
Customer Class See Also Send Feedback
Gets or sets the mobile number associated with the account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string CellPhone { get; set; }
Visual Basic
Public Property CellPhone As String
    Get
    Set

Property Value

Type: String

See Also

Customer Class
Customer Members


Customer.ChargeTax Property

[image]

Pastel Evolution SDK
Customer..::..ChargeTax Property
Customer Class See Also Send Feedback
Gets or sets whether or not to charge the account VAT.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override bool ChargeTax { get; set; }
Visual Basic
Public Overrides Property ChargeTax As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

Customer Class
Customer Members


Customer.CheckTerms Property

[image]

Pastel Evolution SDK
Customer..::..CheckTerms Property
Customer Class See Also Send Feedback
Gets or sets whether or not to check the terms on the account before posting debit transactions.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool CheckTerms { get; set; }
Visual Basic
Public Property CheckTerms As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

Customer Class
Customer Members


Customer.Code Property

[image]

Pastel Evolution SDK
Customer..::..Code Property
Customer Class See Also Send Feedback
Gets or sets the account's code.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override string Code { get; set; }
Visual Basic
Public Overrides Property Code As String
    Get
    Set

Property Value

Type: String

Remarks

This field maps to the Account database field. This is a mandatory field.

See Also

Customer Class
Customer Members


Customer.ContactPerson Property

[image]

Pastel Evolution SDK
Customer..::..ContactPerson Property
Customer Class See Also Send Feedback
Gets or sets the account's contact person.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string ContactPerson { get; set; }
Visual Basic
Public Property ContactPerson As String
    Get
    Set

Property Value

Type: String

See Also

Customer Class
Customer Members


Customer.Country Property

[image]

Pastel Evolution SDK
Customer..::..Country Property
Customer Class See Also Send Feedback
Gets or sets the account's country.Gets or sets the country record associated with the account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Country Country { get; set; }
Visual Basic
Public Property Country As Country
    Get
    Set

Property Value

Type: Country

See Also

Customer Class
Customer Members


Customer.CountryID Property

[image]

Pastel Evolution SDK
Customer..::..CountryID Property
Customer Class See Also Send Feedback
Gets or sets the ID of the country associated with the account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int CountryID { get; set; }
Visual Basic
Public Property CountryID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

Customer Class
Customer Members


Customer.CreditLimit Property

[image]

Pastel Evolution SDK
Customer..::..CreditLimit Property
Customer Class See Also Send Feedback
Gets or sets the account's credit limit.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double CreditLimit { get; set; }
Visual Basic
Public Property CreditLimit As Double
    Get
    Set

Property Value

Type: Double

Remarks

Generally, once an account reaches its credit limit, nofurther sales are allowed. This is not enforced by the SDK and needs tobe checked by calling application if required.

See Also

Customer Class
Customer Members


Customer.Currency Property

[image]

Pastel Evolution SDK
Customer..::..Currency Property
Customer Class See Also Send Feedback
Gets or sets the account's currency. A null value indicates home currency.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override Currency Currency { get; set; }
Visual Basic
Public Overrides Property Currency As Currency
    Get
    Set

Property Value

Type: Currency

See Also

Customer Class
Customer Members


Customer.CurrencyID Property

[image]

Pastel Evolution SDK
Customer..::..CurrencyID Property
Customer Class See Also Send Feedback
Gets or sets the account's currency id. 0 indicates local currency.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int CurrencyID { get; set; }
Visual Basic
Public Overrides Property CurrencyID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

Customer Class
Customer Members


Customer.DefaultDeliveryAddress Property

[image]

Pastel Evolution SDK
Customer..::..DefaultDeliveryAddress Property
Customer Class See Also Send Feedback
Gets the account's default delivery address. A new address is created on the fly if one does not exist.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Address DefaultDeliveryAddress { get; }
Visual Basic
Public ReadOnly Property DefaultDeliveryAddress As Address
    Get

Property Value

Type: Address

See Also

Customer Class
Customer Members


Customer.DefaultIncidentTypeID Property

[image]

Pastel Evolution SDK
Customer..::..DefaultIncidentTypeID Property
Customer Class See Also Send Feedback
Gets or sets the account's default incident type ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int DefaultIncidentTypeID { get; set; }
Visual Basic
Public Property DefaultIncidentTypeID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

Customer Class
Customer Members


Customer.DefaultPriceList Property

[image]

Pastel Evolution SDK
Customer..::..DefaultPriceList Property
Customer Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public PriceList DefaultPriceList { get; set; }
Visual Basic
Public Property DefaultPriceList As PriceList
    Get
    Set

Property Value

Type: PriceList

See Also

Customer Class
Customer Members


Customer.DefaultPriceListID Property

[image]

Pastel Evolution SDK
Customer..::..DefaultPriceListID Property
Customer Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int DefaultPriceListID { get; set; }
Visual Basic
Public Property DefaultPriceListID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

Customer Class
Customer Members


Customer.DefaultSettlementTerms Property

[image]

Pastel Evolution SDK
Customer..::..DefaultSettlementTerms Property
Customer Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override SettlementTerms DefaultSettlementTerms { get; set; }
Visual Basic
Public Overrides Property DefaultSettlementTerms As SettlementTerms
    Get
    Set

Property Value

Type: SettlementTerms

See Also

Customer Class
Customer Members


Customer.DefaultTaxRate Property

[image]

Pastel Evolution SDK
Customer..::..DefaultTaxRate Property
Customer Class See Also Send Feedback
Gets or sets the account's default tax rate.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public TaxRate DefaultTaxRate { get; set; }
Visual Basic
Public Property DefaultTaxRate As TaxRate
    Get
    Set

Property Value

Type: TaxRate

See Also

Customer Class
Customer Members


Customer.DefaultTaxRateID Property

[image]

Pastel Evolution SDK
Customer..::..DefaultTaxRateID Property
Customer Class See Also Send Feedback
Gets or sets the account's default tax rate id.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int DefaultTaxRateID { get; set; }
Visual Basic
Public Property DefaultTaxRateID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

Customer Class
Customer Members


Customer.DeliverTo Property

[image]

Pastel Evolution SDK
Customer..::..DeliverTo Property
Customer Class See Also Send Feedback
Gets or sets the account's addressee.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string DeliverTo { get; set; }
Visual Basic
Public Property DeliverTo As String
    Get
    Set

Property Value

Type: String

Remarks

This would generally be the same as the account description,except where the company name will not be useful in locating the recipientwhen shipping goods.

See Also

Customer Class
Customer Members
Pastel.Evolution Namespace
Customer..::..Addressee


Customer.DeliveryAddresses Property

[image]

Pastel Evolution SDK
Customer..::..DeliveryAddresses Property
Customer Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DeliveryAddressCollection DeliveryAddresses { get; }
Visual Basic
Public ReadOnly Property DeliveryAddresses As DeliveryAddressCollection
    Get

Property Value

Type: DeliveryAddressCollection

See Also

Customer Class
Customer Members


Customer.Description Property

[image]

Pastel Evolution SDK
Customer..::..Description Property
Customer Class See Also Send Feedback
Gets or sets the account's name.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override string Description { get; set; }
Visual Basic
Public Overrides Property Description As String
    Get
    Set

Property Value

Type: String

See Also

Customer Class
Customer Members


Customer.ElectronicDocumentAcceptance Property

[image]

Pastel Evolution SDK
Customer..::..ElectronicDocumentAcceptance Property
Customer Class See Also Send Feedback
Gets or sets whether or not the customer accepts electronic invoices as originals.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool ElectronicDocumentAcceptance { get; set; }
Visual Basic
Public Property ElectronicDocumentAcceptance As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

Customer Class
Customer Members


Customer.EmailAddress Property

[image]

Pastel Evolution SDK
Customer..::..EmailAddress Property
Customer Class See Also Send Feedback
Gets or sets the email address associated with the account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string EmailAddress { get; set; }
Visual Basic
Public Property EmailAddress As String
    Get
    Set

Property Value

Type: String

See Also

Customer Class
Customer Members


Customer.EmailSourceDocument Property

[image]

Pastel Evolution SDK
Customer..::..EmailSourceDocument Property
Customer Class See Also Send Feedback
Gets or sets whether or not the customer's source documents should be emailed.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool EmailSourceDocument { get; set; }
Visual Basic
Public Property EmailSourceDocument As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

Customer Class
Customer Members


Customer.EmailStatement Property

[image]

Pastel Evolution SDK
Customer..::..EmailStatement Property
Customer Class See Also Send Feedback
Gets or sets whether or not the customer account's statement should be emailed.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool EmailStatement { get; set; }
Visual Basic
Public Property EmailStatement As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

Customer Class
Customer Members


Customer.Fax Property

[image]

Pastel Evolution SDK
Customer..::..Fax Property
Customer Class See Also Send Feedback
Gets or sets the account's fax number.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Fax { get; set; }
Visual Basic
Public Property Fax As String
    Get
    Set

Property Value

Type: String

See Also

Customer Class
Customer Members


Customer.ForeignAccountBalance Property

[image]

Pastel Evolution SDK
Customer..::..ForeignAccountBalance Property
Customer Class See Also Send Feedback
Gets the current balance on the account in its foreign currency.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override double ForeignAccountBalance { get; }
Visual Basic
Public Overrides ReadOnly Property ForeignAccountBalance As Double
    Get

Property Value

Type: Double

Remarks

For local accounts, this balance is the same as the AccountBalance.

See Also

Customer Class
Customer Members
Pastel.Evolution Namespace
Customer..::..Currency
Customer..::..IsForeignCurrencyAccount


Customer.Group Property

[image]

Pastel Evolution SDK
Customer..::..Group Property
Customer Class See Also Send Feedback
Gets or sets the customer group associated with the account.
Gets or sets the customer group associated with the account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public CustomerGroup Group { get; set; }
Visual Basic
Public Property Group As CustomerGroup
    Get
    Set

Property Value

Type: CustomerGroup

See Also

Customer Class
Customer Members


Customer.GroupID Property

[image]

Pastel Evolution SDK
Customer..::..GroupID Property
Customer Class See Also Send Feedback
Gets or sets ID of the customer group associated with the account.
Gets or sets ID of the customer group associated with the account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int GroupID { get; set; }
Visual Basic
Public Property GroupID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

Customer Class
Customer Members


Customer.ID Property

[image]

Pastel Evolution SDK
Customer..::..ID Property
Customer Class See Also Send Feedback
Gets the internal record ID (0 for new, unsaved records).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

Remarks

Once saved, the ID will reflect the record's internal database identifier.

See Also

Customer Class
Customer Members


Customer.IDNumber Property

[image]

Pastel Evolution SDK
Customer..::..IDNumber Property
Customer Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string IDNumber { get; set; }
Visual Basic
Public Property IDNumber As String
    Get
    Set

Property Value

Type: String

See Also

Customer Class
Customer Members


Customer.Initials Property

[image]

Pastel Evolution SDK
Customer..::..Initials Property
Customer Class See Also Send Feedback
Gets or sets the account's initials if the account represents a person.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Initials { get; set; }
Visual Basic
Public Property Initials As String
    Get
    Set

Property Value

Type: String

See Also

Customer Class
Customer Members


Customer.InterestRate Property

[image]

Pastel Evolution SDK
Customer..::..InterestRate Property
Customer Class See Also Send Feedback
Gets or sets the account's interest rate as used by the interest charging utilityin Evolution (valid values: 0-100).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double InterestRate { get; set; }
Visual Basic
Public Property InterestRate As Double
    Get
    Set

Property Value

Type: Double

See Also

Customer Class
Customer Members


Customer.IsCashDebtor Property

[image]

Pastel Evolution SDK
Customer..::..IsCashDebtor Property
Customer Class See Also Send Feedback
Gets or sets whether the account is a cash debtor.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool IsCashDebtor { get; set; }
Visual Basic
Public Property IsCashDebtor As Boolean
    Get
    Set

Property Value

Type: Boolean

Remarks

Cash debtors are handled slightly differently to other accounts by Evolution.

See Also

Customer Class
Customer Members


Customer.IsForeignCurrencyAccount Property

[image]

Pastel Evolution SDK
Customer..::..IsForeignCurrencyAccount Property
Customer Class See Also Send Feedback
Gets or sets whether the account transacts in a foreign currency.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override bool IsForeignCurrencyAccount { get; }
Visual Basic
Public Overrides ReadOnly Property IsForeignCurrencyAccount As Boolean
    Get

Property Value

Type: Boolean

Remarks

False for home-currency accounts, true for other currencies.

See Also

Customer Class
Customer Members


Customer.IsOnHold Property

[image]

Pastel Evolution SDK
Customer..::..IsOnHold Property
Customer Class See Also Send Feedback
Gets or sets whether or not the account is on hold.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool IsOnHold { get; set; }
Visual Basic
Public Property IsOnHold As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

Customer Class
Customer Members


Customer.Item Property

[image]

Pastel Evolution SDK
Customer..::..Item Property
Customer Class See Also Send Feedback
Gets an account object possessing the given code.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Customer this[
    string code
] { get; }
Visual Basic
Public ReadOnly Default Property Item (
    code As String
) As Customer
    Get

Parameters

code
Type: System..::..String

Return Value

Type: Customer
The account matching the supplied code.

Exceptions

Exception | Condition
RecordNotExistsException |

See Also

Customer Class
Customer Members


Customer.LongID Property

[image]

Pastel Evolution SDK
Customer..::..LongID Property
Customer Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

Customer Class
Customer Members


Customer.MainAccount Property

[image]

Pastel Evolution SDK
Customer..::..MainAccount Property
Customer Class See Also Send Feedback
Gets or sets the account's main account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Customer MainAccount { get; set; }
Visual Basic
Public Property MainAccount As Customer
    Get
    Set

Property Value

Type: Customer

Remarks

The main account relates to the customer account consolidationmodule which the transactions from one or more debtor accounts under a single main account

See Also

Customer Class
Customer Members


Customer.MainAccountID Property

[image]

Pastel Evolution SDK
Customer..::..MainAccountID Property
Customer Class See Also Send Feedback
Gets the main account's ID (0 if none)

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int MainAccountID { get; }
Visual Basic
Public ReadOnly Property MainAccountID As Integer
    Get

Property Value

Type: Int32

See Also

Customer Class
Customer Members


Customer.Module Property

[image]

Pastel Evolution SDK
Customer..::..Module Property
Customer Class See Also Send Feedback
Gets the Evolution module this record belongs to, Used in internal validation.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override Module Module { get; }
Visual Basic
Public Overrides ReadOnly Property Module As Module
    Get

Property Value

Type: Module

See Also

Customer Class
Customer Members


Customer.PhysicalAddress Property

[image]

Pastel Evolution SDK
Customer..::..PhysicalAddress Property
Customer Class See Also Send Feedback
Gets or sets the account's physical address.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Address PhysicalAddress { get; set; }
Visual Basic
Public Property PhysicalAddress As Address
    Get
    Set

Property Value

Type: Address

See Also

Customer Class
Customer Members


Customer.PostalAddress Property

[image]

Pastel Evolution SDK
Customer..::..PostalAddress Property
Customer Class See Also Send Feedback
Gets or sets the account's physical address.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Address PostalAddress { get; set; }
Visual Basic
Public Property PostalAddress As Address
    Get
    Set

Property Value

Type: Address

See Also

Customer Class
Customer Members


Customer.PrintSourceDocument Property

[image]

Pastel Evolution SDK
Customer..::..PrintSourceDocument Property
Customer Class See Also Send Feedback
Gets or sets whether or not the customer's source documents should be printed.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool PrintSourceDocument { get; set; }
Visual Basic
Public Property PrintSourceDocument As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

Customer Class
Customer Members


Customer.PrintStatement Property

[image]

Pastel Evolution SDK
Customer..::..PrintStatement Property
Customer Class See Also Send Feedback
Gets or sets whether or not the customer account requires a physical statement.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool PrintStatement { get; set; }
Visual Basic
Public Property PrintStatement As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

Customer Class
Customer Members


Customer.PromptTaxNumber Property

[image]

Pastel Evolution SDK
Customer..::..PromptTaxNumber Property
Customer Class See Also Send Feedback
Gets or sets whether or not a prompt should be raised when selling to this account when it does not have a TaxNumber specified.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool PromptTaxNumber { get; set; }
Visual Basic
Public Property PromptTaxNumber As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

Customer Class
Customer Members


Customer.RawFieldData Property

[image]

Pastel Evolution SDK
Customer..::..RawFieldData Property
Customer Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
[ObsoleteAttribute("Use UserFields instead.")]
public FieldCollection RawFieldData { get; }
Visual Basic
<ObsoleteAttribute("Use UserFields instead.")>
Public ReadOnly Property RawFieldData As FieldCollection
    Get

Property Value

Type: FieldCollection

See Also

Customer Class
Customer Members


Customer.Registration Property

[image]

Pastel Evolution SDK
Customer..::..Registration Property
Customer Class See Also Send Feedback
Gets or sets the account's registration (company, CC, etc.) number.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Registration { get; set; }
Visual Basic
Public Property Registration As String
    Get
    Set

Property Value

Type: String

See Also

Customer Class
Customer Members


Customer.SalesRepID Property

[image]

Pastel Evolution SDK
Customer..::..SalesRepID Property
Customer Class See Also Send Feedback
Gets or sets the sales representative ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int SalesRepID { get; set; }
Visual Basic
Public Property SalesRepID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

Customer Class
Customer Members


Customer.SettlementDiscount Property

[image]

Pastel Evolution SDK
Customer..::..SettlementDiscount Property
Customer Class See Also Send Feedback
Gets or sets the settlement discount percentage applied when receiving payments through the Evolution front-end (valid values: 0-100).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double SettlementDiscount { get; set; }
Visual Basic
Public Property SettlementDiscount As Double
    Get
    Set

Property Value

Type: Double

See Also

Customer Class
Customer Members


Customer.StatementZipPassword Property

[image]

Pastel Evolution SDK
Customer..::..StatementZipPassword Property
Customer Class See Also Send Feedback
Gets or sets the password to the zip file when emailing and zipping a statement. Passed as clear text but encrypted in the database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string StatementZipPassword { get; set; }
Visual Basic
Public Property StatementZipPassword As String
    Get
    Set

Property Value

Type: String

See Also

Customer Class
Customer Members


Customer.TaxNumber Property

[image]

Pastel Evolution SDK
Customer..::..TaxNumber Property
Customer Class See Also Send Feedback
Gets or sets the account's VAT number.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string TaxNumber { get; set; }
Visual Basic
Public Property TaxNumber As String
    Get
    Set

Property Value

Type: String

See Also

Customer Class
Customer Members


Customer.Telephone Property

[image]

Pastel Evolution SDK
Customer..::..Telephone Property
Customer Class See Also Send Feedback
Gets or sets the account's primary telephone number.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Telephone { get; set; }
Visual Basic
Public Property Telephone As String
    Get
    Set

Property Value

Type: String

See Also

Customer Class
Customer Members


Customer.Telephone2 Property

[image]

Pastel Evolution SDK
Customer..::..Telephone2 Property
Customer Class See Also Send Feedback
Gets or sets the account's secondary telephone number.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Telephone2 { get; set; }
Visual Basic
Public Property Telephone2 As String
    Get
    Set

Property Value

Type: String

See Also

Customer Class
Customer Members


Customer.Timestamp Property

[image]

Pastel Evolution SDK
Customer..::..Timestamp Property
Customer Class See Also Send Feedback
Gets the date/time on which the account was last modified.
Gets the date/time on which the account was last modified.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DateTime Timestamp { get; }
Visual Basic
Public ReadOnly Property Timestamp As DateTime
    Get

Property Value

Type: DateTime

See Also

Customer Class
Customer Members


Customer.Title Property

[image]

Pastel Evolution SDK
Customer..::..Title Property
Customer Class See Also Send Feedback
Gets or sets the account's title (Mr., Mrs. etc.) if the account represents a person.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Title { get; set; }
Visual Basic
Public Property Title As String
    Get
    Set

Property Value

Type: String

See Also

Customer Class
Customer Members


Customer.UseEmail Property

[image]

Pastel Evolution SDK
Customer..::..UseEmail Property
Customer Class See Also Send Feedback
Gets or sets whether or not to use the account's e-mail address.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool UseEmail { get; set; }
Visual Basic
Public Property UseEmail As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

Customer Class
Customer Members


Customer.UserFields Property

[image]

Pastel Evolution SDK
Customer..::..UserFields Property
Customer Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public FieldCollection UserFields { get; }
Visual Basic
Public ReadOnly Property UserFields As FieldCollection
    Get

Property Value

Type: FieldCollection

See Also

Customer Class
Customer Members


Customer.Webpage Property

[image]

Pastel Evolution SDK
Customer..::..Webpage Property
Customer Class See Also Send Feedback
Gets or sets the web address associated with the account.
Gets or sets the web address associated with the account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Webpage { get; set; }
Visual Basic
Public Property Webpage As String
    Get
    Set

Property Value

Type: String

See Also

Customer Class
Customer Members


CustomerGroup Class

[image]

Pastel Evolution SDK
CustomerGroup Class
Members See Also Send Feedback
Represents a customer group.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class CustomerGroup : BranchedRecordBase
Visual Basic
Public Class CustomerGroup
    Inherits BranchedRecordBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..CustomerGroup

See Also

CustomerGroup Members


CustomerGroup Members

[image] [image]

Pastel Evolution SDK
CustomerGroup Members
CustomerGroup Class Constructors Methods Fields Properties See Also Send Feedback

The CustomerGroup type exposes the following members.

Constructors

 | Name | Description
Public method | CustomerGroup()()()() | Creates a new instance of a group.
Public method | CustomerGroup(Int32) | Creates a new instance of a group.
Public method | CustomerGroup(String) | Creates a new instance of a group.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Returns the id of the first record found matching the criteria. Eg. code = 'abc'
 | FindByCode | Attempts to find an AR group by its code and returns its ID.
 | Get | Returns the [first] group object with the account code specified; otherwise, returns null.
 | GetByCode | Returns a group object corresponding to the code specified; otherwise, returns null.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | List | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Code | Gets or sets the group's code.
Public property | ControlAccount | Gets or sets the group's override GL account.
Public property | ControlAccountID | Gets or sets the group's control account id.
Public property | Description | Gets or sets the group description.
Public property | DiscountMatrixRow | Gets or sets the group's discount matrix row.
Public property | ForeignLossAccountID | Gets or sets the group's foreign loss account id.
Public property | ForeignProfitAccountID | Gets or sets the group's foreign profit account id.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | TaxControlAccount | Gets or sets the group's override tax GL control account.
Public property | TaxControlAccountID | Gets or sets the group's tax control account id.
Public property | TimeStamp | Gets or sets the group's modification timestamp.

See Also

CustomerGroup Class


CustomerGroup Constructor

[image] [image]

Pastel Evolution SDK
CustomerGroup Constructor
CustomerGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CustomerGroup()()()() | Creates a new instance of a group.
Public method | CustomerGroup(Int32) | Creates a new instance of a group.
Public method | CustomerGroup(String) | Creates a new instance of a group.

See Also

CustomerGroup Class
CustomerGroup Members


CustomerGroup Constructor

[image]

Pastel Evolution SDK
CustomerGroup Constructor
CustomerGroup Class See Also Send Feedback
Creates a new instance of a group.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public CustomerGroup()
Visual Basic
Public Sub New

See Also

CustomerGroup Class
CustomerGroup Members
CustomerGroup Overload


CustomerGroup Constructor (Int32)

[image]

Pastel Evolution SDK
CustomerGroup Constructor (Int32)
CustomerGroup Class See Also Send Feedback
Creates a new instance of a group.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public CustomerGroup(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32
Specifies the id of the existing record.

See Also

CustomerGroup Class
CustomerGroup Members
CustomerGroup Overload


CustomerGroup Constructor (String)

[image]

Pastel Evolution SDK
CustomerGroup Constructor (String)
CustomerGroup Class See Also Send Feedback
Creates a new instance of a group.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public CustomerGroup(
    string code
)
Visual Basic
Public Sub New (
    code As String
)

Parameters

code
Type: System..::..String
Specifies the code of the existing record.

See Also

CustomerGroup Class
CustomerGroup Members
CustomerGroup Overload


CustomerGroup Fields

[image] [image]

Pastel Evolution SDK
CustomerGroup Fields
CustomerGroup Class See Also Send Feedback

The CustomerGroup type exposes the following members.

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

CustomerGroup Class


CustomerGroup Methods

[image] [image]

Pastel Evolution SDK
CustomerGroup Methods
CustomerGroup Class See Also Send Feedback

The CustomerGroup type exposes the following members.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Returns the id of the first record found matching the criteria. Eg. code = 'abc'
 | FindByCode | Attempts to find an AR group by its code and returns its ID.
 | Get | Returns the [first] group object with the account code specified; otherwise, returns null.
 | GetByCode | Returns a group object corresponding to the code specified; otherwise, returns null.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | List | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

CustomerGroup Class


CustomerGroup.Find Method

[image]

Pastel Evolution SDK
CustomerGroup..::..Find Method
CustomerGroup Class See Also Send Feedback
Returns the id of the first record found matching the criteria. Eg. code = 'abc'

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.

Return Value

Type: Int32
ID of the record found; if not found, -1

See Also

CustomerGroup Class
CustomerGroup Members


CustomerGroup.FindByCode Method

[image]

Pastel Evolution SDK
CustomerGroup..::..FindByCode Method
CustomerGroup Class See Also Send Feedback
Attempts to find an AR group by its code and returns its ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int FindByCode(
    string code
)
Visual Basic
Public Shared Function FindByCode (
    code As String
) As Integer

Parameters

code
Type: System..::..String
The account code used to lookup the account.

Return Value

Type: Int32
-1 if no record was found, else the id of the first account matching the criteria supplied.

See Also

CustomerGroup Class
CustomerGroup Members
Pastel.Evolution Namespace
CustomerGroup..::..Find(String)


CustomerGroup.Get Method

[image]

Pastel Evolution SDK
CustomerGroup..::..Get Method
CustomerGroup Class See Also Send Feedback
Returns the [first] group object with the account code specified; otherwise, returns null.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static CustomerGroup Get(
    string criteria
)
Visual Basic
Public Shared Function Get (
    criteria As String
) As CustomerGroup

Parameters

criteria
Type: System..::..String
Eg. Code like '1_B%'

Return Value

Type: CustomerGroup

See Also

CustomerGroup Class
CustomerGroup Members
Pastel.Evolution Namespace
CustomerGroup..::..Find(String)


CustomerGroup.GetByCode Method

[image]

Pastel Evolution SDK
CustomerGroup..::..GetByCode Method
CustomerGroup Class See Also Send Feedback
Returns a group object corresponding to the code specified; otherwise, returns null.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static CustomerGroup GetByCode(
    string code
)
Visual Basic
Public Shared Function GetByCode (
    code As String
) As CustomerGroup

Parameters

code
Type: System..::..String

Return Value

Type: CustomerGroup

See Also

CustomerGroup Class
CustomerGroup Members


CustomerGroup.List Method

[image]

Pastel Evolution SDK
CustomerGroup..::..List Method
CustomerGroup Class See Also Send Feedback
Gets a list of database records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DataTable List(
    string criteria
)
Visual Basic
Public Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.

Return Value

Type: DataTable
Table containing selected records.

See Also

CustomerGroup Class
CustomerGroup Members


CustomerGroup.OnDelete Method

[image]

Pastel Evolution SDK
CustomerGroup..::..OnDelete Method
CustomerGroup Class See Also Send Feedback
Removes the record from the database, provided it is not referenced by other records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

Exceptions

Exception | Condition
IntegrityViolationException |

See Also

CustomerGroup Class
CustomerGroup Members


CustomerGroup.OnSave Method

[image]

Pastel Evolution SDK
CustomerGroup..::..OnSave Method
CustomerGroup Class See Also Send Feedback
Persists the record to the database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

CustomerGroup Class
CustomerGroup Members


CustomerGroup Properties

[image] [image]

Pastel Evolution SDK
CustomerGroup Properties
CustomerGroup Class See Also Send Feedback

The CustomerGroup type exposes the following members.

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Code | Gets or sets the group's code.
Public property | ControlAccount | Gets or sets the group's override GL account.
Public property | ControlAccountID | Gets or sets the group's control account id.
Public property | Description | Gets or sets the group description.
Public property | DiscountMatrixRow | Gets or sets the group's discount matrix row.
Public property | ForeignLossAccountID | Gets or sets the group's foreign loss account id.
Public property | ForeignProfitAccountID | Gets or sets the group's foreign profit account id.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | TaxControlAccount | Gets or sets the group's override tax GL control account.
Public property | TaxControlAccountID | Gets or sets the group's tax control account id.
Public property | TimeStamp | Gets or sets the group's modification timestamp.

See Also

CustomerGroup Class


CustomerGroup.Code Property

[image]

Pastel Evolution SDK
CustomerGroup..::..Code Property
CustomerGroup Class See Also Send Feedback
Gets or sets the group's code.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Code { get; set; }
Visual Basic
Public Property Code As String
    Get
    Set

Property Value

Type: String

See Also

CustomerGroup Class
CustomerGroup Members


CustomerGroup.ControlAccount Property

[image]

Pastel Evolution SDK
CustomerGroup..::..ControlAccount Property
CustomerGroup Class See Also Send Feedback
Gets or sets the group's override GL account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLAccount ControlAccount { get; set; }
Visual Basic
Public Property ControlAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

See Also

CustomerGroup Class
CustomerGroup Members


CustomerGroup.ControlAccountID Property

[image]

Pastel Evolution SDK
CustomerGroup..::..ControlAccountID Property
CustomerGroup Class See Also Send Feedback
Gets or sets the group's control account id.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int ControlAccountID { get; set; }
Visual Basic
Public Property ControlAccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CustomerGroup Class
CustomerGroup Members


CustomerGroup.Description Property

[image]

Pastel Evolution SDK
CustomerGroup..::..Description Property
CustomerGroup Class See Also Send Feedback
Gets or sets the group description.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set

Property Value

Type: String

See Also

CustomerGroup Class
CustomerGroup Members


CustomerGroup.DiscountMatrixRow Property

[image]

Pastel Evolution SDK
CustomerGroup..::..DiscountMatrixRow Property
CustomerGroup Class See Also Send Feedback
Gets or sets the group's discount matrix row.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int DiscountMatrixRow { get; set; }
Visual Basic
Public Property DiscountMatrixRow As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CustomerGroup Class
CustomerGroup Members


CustomerGroup.ForeignLossAccountID Property

[image]

Pastel Evolution SDK
CustomerGroup..::..ForeignLossAccountID Property
CustomerGroup Class See Also Send Feedback
Gets or sets the group's foreign loss account id.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int ForeignLossAccountID { get; set; }
Visual Basic
Public Property ForeignLossAccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CustomerGroup Class
CustomerGroup Members


CustomerGroup.ForeignProfitAccountID Property

[image]

Pastel Evolution SDK
CustomerGroup..::..ForeignProfitAccountID Property
CustomerGroup Class See Also Send Feedback
Gets or sets the group's foreign profit account id.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int ForeignProfitAccountID { get; set; }
Visual Basic
Public Property ForeignProfitAccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CustomerGroup Class
CustomerGroup Members


CustomerGroup.ID Property

[image]

Pastel Evolution SDK
CustomerGroup..::..ID Property
CustomerGroup Class See Also Send Feedback
Gets the internal record ID (0 for new, unsaved records).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

See Also

CustomerGroup Class
CustomerGroup Members


CustomerGroup.LongID Property

[image]

Pastel Evolution SDK
CustomerGroup..::..LongID Property
CustomerGroup Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

CustomerGroup Class
CustomerGroup Members


CustomerGroup.TaxControlAccount Property

[image]

Pastel Evolution SDK
CustomerGroup..::..TaxControlAccount Property
CustomerGroup Class See Also Send Feedback
Gets or sets the group's override tax GL control account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLAccount TaxControlAccount { get; set; }
Visual Basic
Public Property TaxControlAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

See Also

CustomerGroup Class
CustomerGroup Members


CustomerGroup.TaxControlAccountID Property

[image]

Pastel Evolution SDK
CustomerGroup..::..TaxControlAccountID Property
CustomerGroup Class See Also Send Feedback
Gets or sets the group's tax control account id.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int TaxControlAccountID { get; set; }
Visual Basic
Public Property TaxControlAccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CustomerGroup Class
CustomerGroup Members


CustomerGroup.TimeStamp Property

[image]

Pastel Evolution SDK
CustomerGroup..::..TimeStamp Property
CustomerGroup Class See Also Send Feedback
Gets or sets the group's modification timestamp.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DateTime TimeStamp { get; set; }
Visual Basic
Public Property TimeStamp As DateTime
    Get
    Set

Property Value

Type: DateTime

See Also

CustomerGroup Class
CustomerGroup Members


CustomerTransaction Class

[image]

Pastel Evolution SDK
CustomerTransaction Class
Members See Also Send Feedback
Represents a customer transaction.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class CustomerTransaction : DrCrTransaction
Visual Basic
Public Class CustomerTransaction
    Inherits DrCrTransaction

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..TransactionBase
Pastel.Evolution..::..DrCrTransaction
Pastel.Evolution..::..CustomerTransaction

See Also

CustomerTransaction Members


CustomerTransaction Members

[image] [image]

Pastel Evolution SDK
CustomerTransaction Members
CustomerTransaction Class Constructors Methods Fields Properties Events See Also Send Feedback

The CustomerTransaction type exposes the following members.

Constructors

 | Name | Description
Public method | CustomerTransaction()()()() | Creates a new instance of a transaction.
Public method | CustomerTransaction(Int64) | Creates a new instance of a transaction.

Methods

 | Name | Description
Protected method | calcAmounts | (Inherited from DrCrTransaction.)
Protected method | calcTaxValues |
Public method | CalculateTax | Calculates the tax amount on the transaction.
Public method | Clone | (Overrides DrCrTransaction..::..Clone()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find(String) | Finds a transaction ID.
 | Find(AccountBase, String) | Finds a transaction ID.
Protected method | getExchangeRate | (Overrides DrCrTransaction..::..getExchangeRate()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List(String) | Returns a System.Data.DataTable object containing the database records from the PostAR table matching the supplied criteria.
 | List(AccountBase, String) | Returns a System.Data.DataTable object containing the database records from the PostAR/PostAP table matching the supplied criteria and limited to the specified account.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAllowBlockedPosting | (Overrides TransactionBase..::..OnAllowBlockedPosting()()()().)
Protected method | OnOverrideControlAccount | (Overrides DrCrTransaction..::..OnOverrideControlAccount(GLTransaction).)
Protected method | OnOverrideTaxControlAccount | (Overrides DrCrTransaction..::..OnOverrideTaxControlAccount(TransactionCode, GLTransaction).)
Protected method | OnPost | (Overrides TransactionBase..::..OnPost()()()().)
Protected method | onPostingGLCredit | (Inherited from TransactionBase.)
Protected method | onPostingGLDebit | (Inherited from TransactionBase.)
Protected method | onPostingGLVat | (Inherited from TransactionBase.)
Public method | Post | Posts the transaction to appropriate ledgers. (Inherited from TransactionBase.)
Protected method | RejectTransactionBranchAssignment | (Inherited from TransactionBase.)
Protected method | setExchangeRate | (Overrides DrCrTransaction..::..setExchangeRate(Double).)
Public method | ToString | (Inherited from DrCrTransaction.)
Public method | Validate | (Overrides DrCrTransaction..::..Validate()()()().)

Fields

 | Name | Description
Protected field | allocations | (Inherited from DrCrTransaction.)
Protected field | amount | (Inherited from DrCrTransaction.)
Protected field | branch | (Inherited from DrCrTransaction.)
Protected field | currency | (Inherited from DrCrTransaction.)
Protected field | fcQueue | (Inherited from DrCrTransaction.)
Protected field | foreignAmount | (Inherited from DrCrTransaction.)
Protected field | foreignOriginalTax | (Inherited from TransactionBase.)
Protected field | foreignTax | (Inherited from DrCrTransaction.)
Protected field | glCredit | (Inherited from DrCrTransaction.)
Protected field | glDebit | (Inherited from DrCrTransaction.)
Protected field | glForeignCredit | (Inherited from DrCrTransaction.)
Protected field | glForeignDebit | (Inherited from DrCrTransaction.)
Protected field | isDebitTrans | (Inherited from TransactionBase.)
Protected field | originalTax | (Inherited from TransactionBase.)
Protected field | project | (Inherited from DrCrTransaction.)
Protected field | readOnly | (Inherited from TransactionBase.)
Protected field | settlementTerms | (Inherited from DrCrTransaction.)
Protected field | splitAllocations | (Inherited from DrCrTransaction.)
Protected field | tax | (Inherited from DrCrTransaction.)
Protected field | taxType | (Inherited from DrCrTransaction.)
Protected field | tranCode | (Inherited from DrCrTransaction.)

Properties

 | Name | Description
Public property | Account | Gets or sets the Account to which the transaction gets posted. This is amandatory field. (Overrides TransactionBase..::..Account.)
Public property | AccountID | Gets or sets the ID of the Account to which the transaction gets posted. (Overrides TransactionBase..::..AccountID.)
Public property | Allocations | Gets the transaction's allocation collection. (Overrides DrCrTransaction..::..Allocations.)
Public property | Amount | Gets or sets the (gross) transaction value. Negative values are allowed and will result in inverted debits and credits. (Overrides DrCrTransaction..::..Amount.)
Public property | Audit | Gets the transaction's audit number. (Overrides TransactionBase..::..Audit.)
Public property | Branch | (Overrides DrCrTransaction..::..Branch.)
Public property | BranchID | (Overrides DrCrTransaction..::..BranchID.)
Public property | Credit | Gets the transaction's credit value, the value of which is determined by the Amount and TransactionCode properties. (Overrides TransactionBase..::..Credit.)
Public property | Currency | Gets the foreign currency in use on this transaction, determined by the specified account. A null value indicates local currency. (Overrides DrCrTransaction..::..Currency.)
Public property | CurrencyID | (Overrides DrCrTransaction..::..CurrencyID.)
Public property | Customer | Gets or sets the transaction's customer account (maps directly to Account).
Public property | Date | Gets or sets the date on which the transaction takes place. This often differs from the actual posting date but defaults to the current date. (Overrides TransactionBase..::..Date.)
Public property | Debit | Gets the transaction's debit value, the value of which is determined by the Amount and TransactionCode properties. (Overrides TransactionBase..::..Debit.)
Public property | Description | Gets or sets the transaction description that - togeter with the Reference - appears on the account's statement by default. This is a mandatory field. (Overrides TransactionBase..::..Description.)
Public property | ExchangeRate | Gets or sets the applicable exchange rate, expressed as [home currency]/[foreign currency]. Defaults to applicable exchange rate for the transaction date. (Inherited from DrCrTransaction.)
Public property | ExtOrderNo | Gets or sets the transaction's external order number. (Overrides TransactionBase..::..ExtOrderNo.)
Public property | ForeignAmount | Gets or sets the foreign transaction value. (Overrides DrCrTransaction..::..ForeignAmount.)
Public property | ForeignCredit | Gets the transaction's foreign credit value, which is determined by the ForeignAmount and TransactionCode properties. (Overrides DrCrTransaction..::..ForeignCredit.)
Public property | ForeignDebit | Gets the transaction's foreign debit value, which is determined by the ForeignAmount and TransactionCode properties. (Overrides DrCrTransaction..::..ForeignDebit.)
Public property | ForeignOutstanding | Gets the transaction's foreign outstanding amount. (Overrides DrCrTransaction..::..ForeignOutstanding.)
Public property | ForeignTax | Gets or sets the transaction foreign tax amount (automatically rounded to 2 decimals). Note that setting this will switch the entry mode to foreign and recalculate the Amount property. (Overrides DrCrTransaction..::..ForeignTax.)
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides TransactionBase..::..ID.)
Public property | IsDebit | Indicates whether the transaction is a debit (true) or credit(false) (Inherited from DrCrTransaction.)
Public property | IsDebitPositive | (Overrides DrCrTransaction..::..IsDebitPositive.)
Public property | MaxForeignOutstanding | Gets the maximum possible foreign outstanding value for the given transaction, based on the ForeignDebit or ForeignCredit value. (Inherited from DrCrTransaction.)
Public property | MaxOutstanding | Gets the maximum possible outstanding value for the given transaction, based on the Debit or Credit value. (Inherited from DrCrTransaction.)
Public property | ModID | Gets or sets the transaction's evolution module id. (Overrides TransactionBase..::..ModID.)
Public property | Module | Gets the Evolution module this record belongs to, used in internal validation. (Overrides TransactionBase..::..Module.)
Public property | OrderNo | Gets or sets the transaction order number. (Overrides TransactionBase..::..OrderNo.)
Public property | Outstanding | Gets the transaction's outstanding amount. (Overrides DrCrTransaction..::..Outstanding.)
Public property | PostDated | Gets or sets whether the transaction is a Post Dated Transaction.
Public property | Project | Gets or sets the Project record associated with this transaction. When using Project Tracking, this field must be specified wherever applicable. (Overrides TransactionBase..::..Project.)
Public property | ProjectID | Gets or sets the ID of the Project record associated with this transaction. When using Project Tracking, this field must be specified wherever applicable. (Overrides TransactionBase..::..ProjectID.)
Public property | Reference | Gets or sets the transaction reference that - together with the Description - appears on the customer statement by default. This is a mandatory field. (Overrides TransactionBase..::..Reference.)
Public property | Reference2 | Gets or sets an additional transaction reference. (Overrides TransactionBase..::..Reference2.)
Public property | SalesRep | Gets or sets the Sales Rep.
Public property | SalesRepID |
Public property | SettlementTerms | (Overrides DrCrTransaction..::..SettlementTerms.)
Public property | SettlementTermsID | (Overrides DrCrTransaction..::..SettlementTermsID.)
Public property | SplitAllocations | Gets the transaction's split allocation collection, used to split the contra account posting to various GL accounts. (Overrides DrCrTransaction..::..SplitAllocations.)
Public property | Tax | Gets or sets the transaction tax amount (automatically rounded to 2 decimals). (Overrides TransactionBase..::..Tax.)
Public property | TaxRate | Gets or sets the TaxRate record associated with this transaction. If a tax type is specified, a tax amount is automatically calculated, but can be overridden. (Overrides TransactionBase..::..TaxRate.)
Public property | TaxRateID | Gets or sets the transaction's tax type id. (Overrides TransactionBase..::..TaxRateID.)
Public property | TillID |
Public property | TransactionCode | Gets or sets the TransactionCode record associated with this transaction, as maintained in Accounts Receivable > Maintenance > Transaction Types. Transaction codes/types govern General Ledger integration. This is a mandatory field. (Overrides TransactionBase..::..TransactionCode.)
Public property | TransactionCodeID | Gets or sets the ID of the TransactionCode record associated with this transaction, which governs General Ledger integration. (Overrides TransactionBase..::..TransactionCodeID.)

Events

 | Name | Description
Public event | GLCreditPosting | (Inherited from TransactionBase.)
Public event | GLDebitPosting | (Inherited from TransactionBase.)
Public event | GLVatPosting | (Inherited from TransactionBase.)

See Also

CustomerTransaction Class


CustomerTransaction Constructor

[image] [image]

Pastel Evolution SDK
CustomerTransaction Constructor
CustomerTransaction Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CustomerTransaction()()()() | Creates a new instance of a transaction.
Public method | CustomerTransaction(Int64) | Creates a new instance of a transaction.

See Also

CustomerTransaction Class
CustomerTransaction Members


CustomerTransaction Constructor

[image]

Pastel Evolution SDK
CustomerTransaction Constructor
CustomerTransaction Class See Also Send Feedback
Creates a new instance of a transaction.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public CustomerTransaction()
Visual Basic
Public Sub New

See Also

CustomerTransaction Class
CustomerTransaction Members
CustomerTransaction Overload


CustomerTransaction Constructor (Int64)

[image]

Pastel Evolution SDK
CustomerTransaction Constructor (Int64)
CustomerTransaction Class See Also Send Feedback
Creates a new instance of a transaction.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public CustomerTransaction(
    long id
)
Visual Basic
Public Sub New (
    id As Long
)

Parameters

id
Type: System..::..Int64
Specifies the id of the existing record.

See Also

CustomerTransaction Class
CustomerTransaction Members
CustomerTransaction Overload


CustomerTransaction Fields

[image] [image]

Pastel Evolution SDK
CustomerTransaction Fields
CustomerTransaction Class See Also Send Feedback

The CustomerTransaction type exposes the following members.

Fields

 | Name | Description
Protected field | allocations | (Inherited from DrCrTransaction.)
Protected field | amount | (Inherited from DrCrTransaction.)
Protected field | branch | (Inherited from DrCrTransaction.)
Protected field | currency | (Inherited from DrCrTransaction.)
Protected field | fcQueue | (Inherited from DrCrTransaction.)
Protected field | foreignAmount | (Inherited from DrCrTransaction.)
Protected field | foreignOriginalTax | (Inherited from TransactionBase.)
Protected field | foreignTax | (Inherited from DrCrTransaction.)
Protected field | glCredit | (Inherited from DrCrTransaction.)
Protected field | glDebit | (Inherited from DrCrTransaction.)
Protected field | glForeignCredit | (Inherited from DrCrTransaction.)
Protected field | glForeignDebit | (Inherited from DrCrTransaction.)
Protected field | isDebitTrans | (Inherited from TransactionBase.)
Protected field | originalTax | (Inherited from TransactionBase.)
Protected field | project | (Inherited from DrCrTransaction.)
Protected field | readOnly | (Inherited from TransactionBase.)
Protected field | settlementTerms | (Inherited from DrCrTransaction.)
Protected field | splitAllocations | (Inherited from DrCrTransaction.)
Protected field | tax | (Inherited from DrCrTransaction.)
Protected field | taxType | (Inherited from DrCrTransaction.)
Protected field | tranCode | (Inherited from DrCrTransaction.)

See Also

CustomerTransaction Class


CustomerTransaction Methods

[image] [image]

Pastel Evolution SDK
CustomerTransaction Methods
CustomerTransaction Class See Also Send Feedback

The CustomerTransaction type exposes the following members.

Methods

 | Name | Description
Protected method | calcAmounts | (Inherited from DrCrTransaction.)
Protected method | calcTaxValues |
Public method | CalculateTax | Calculates the tax amount on the transaction.
Public method | Clone | (Overrides DrCrTransaction..::..Clone()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find(String) | Finds a transaction ID.
 | Find(AccountBase, String) | Finds a transaction ID.
Protected method | getExchangeRate | (Overrides DrCrTransaction..::..getExchangeRate()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List(String) | Returns a System.Data.DataTable object containing the database records from the PostAR table matching the supplied criteria.
 | List(AccountBase, String) | Returns a System.Data.DataTable object containing the database records from the PostAR/PostAP table matching the supplied criteria and limited to the specified account.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAllowBlockedPosting | (Overrides TransactionBase..::..OnAllowBlockedPosting()()()().)
Protected method | OnOverrideControlAccount | (Overrides DrCrTransaction..::..OnOverrideControlAccount(GLTransaction).)
Protected method | OnOverrideTaxControlAccount | (Overrides DrCrTransaction..::..OnOverrideTaxControlAccount(TransactionCode, GLTransaction).)
Protected method | OnPost | (Overrides TransactionBase..::..OnPost()()()().)
Protected method | onPostingGLCredit | (Inherited from TransactionBase.)
Protected method | onPostingGLDebit | (Inherited from TransactionBase.)
Protected method | onPostingGLVat | (Inherited from TransactionBase.)
Public method | Post | Posts the transaction to appropriate ledgers. (Inherited from TransactionBase.)
Protected method | RejectTransactionBranchAssignment | (Inherited from TransactionBase.)
Protected method | setExchangeRate | (Overrides DrCrTransaction..::..setExchangeRate(Double).)
Public method | ToString | (Inherited from DrCrTransaction.)
Public method | Validate | (Overrides DrCrTransaction..::..Validate()()()().)

See Also

CustomerTransaction Class


CustomerTransaction.calcTaxValues Method

[image]

Pastel Evolution SDK
CustomerTransaction..::..calcTaxValues Method
CustomerTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected void calcTaxValues()
Visual Basic
Protected Sub calcTaxValues

See Also

CustomerTransaction Class
CustomerTransaction Members


CustomerTransaction.CalculateTax Method

[image]

Pastel Evolution SDK
CustomerTransaction..::..CalculateTax Method
CustomerTransaction Class See Also Send Feedback
Calculates the tax amount on the transaction.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void CalculateTax()
Visual Basic
Public Sub CalculateTax

See Also

CustomerTransaction Class
CustomerTransaction Members


CustomerTransaction.Clone Method

[image]

Pastel Evolution SDK
CustomerTransaction..::..Clone Method
CustomerTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override Object Clone()
Visual Basic
Public Overrides Function Clone As Object

Return Value

Type: Object

Implements

ICloneable..::..Clone()()()()

See Also

CustomerTransaction Class
CustomerTransaction Members


CustomerTransaction.Find Method

[image] [image]

Pastel Evolution SDK
CustomerTransaction..::..Find Method
CustomerTransaction Class See Also Send Feedback

Overload List

Name | Description
Find(String) | Finds a transaction ID.
Find(AccountBase, String) | Finds a transaction ID.

See Also

CustomerTransaction Class
CustomerTransaction Members


CustomerTransaction.Find Method (String)

[image]

Pastel Evolution SDK
CustomerTransaction..::..Find Method (String)
CustomerTransaction Class See Also Send Feedback
Finds a transaction ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static long Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Long

Parameters

criteria
Type: System..::..String
The criteria passed to the SQL query. Eg. Reference = 'INV001' or Description like '%Invoice%'

Return Value

Type: Int64

See Also

CustomerTransaction Class
CustomerTransaction Members
Find Overload


CustomerTransaction.Find Method (AccountBase, String)

[image]

Pastel Evolution SDK
CustomerTransaction..::..Find Method (AccountBase, String)
CustomerTransaction Class See Also Send Feedback
Finds a transaction ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static long Find(
    AccountBase account,
    string criteria
)
Visual Basic
Public Shared Function Find (
    account As AccountBase,
    criteria As String
) As Long

Parameters

account
Type: Pastel.Evolution..::..AccountBase
The customer account by which to filter the transaction list.
criteria
Type: System..::..String
The criteria passed to the SQL query. Eg. Reference = 'INV001' or Description like '%Invoice%'

Return Value

Type: Int64

See Also

CustomerTransaction Class
CustomerTransaction Members
Find Overload


CustomerTransaction.getExchangeRate Method

[image]

Pastel Evolution SDK
CustomerTransaction..::..getExchangeRate Method
CustomerTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected override double getExchangeRate()
Visual Basic
Protected Overrides Function getExchangeRate As Double

Return Value

Type: Double

See Also

CustomerTransaction Class
CustomerTransaction Members


CustomerTransaction.List Method

[image] [image]

Pastel Evolution SDK
CustomerTransaction..::..List Method
CustomerTransaction Class See Also Send Feedback

Overload List

Name | Description
List(String) | Returns a System.Data.DataTable object containing the database records from the PostAR table matching the supplied criteria.
List(AccountBase, String) | Returns a System.Data.DataTable object containing the database records from the PostAR/PostAP table matching the supplied criteria and limited to the specified account.

See Also

CustomerTransaction Class
CustomerTransaction Members


CustomerTransaction.List Method (String)

[image]

Pastel Evolution SDK
CustomerTransaction..::..List Method (String)
CustomerTransaction Class See Also Send Feedback
Returns a System.Data.DataTable object containing the database records from the PostAR table matching the supplied criteria.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria
)
Visual Basic
Public Shared Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String
The SQL criteria used to locate the record, e.g. Reference like '1___'

Return Value

Type: DataTable
A System.Data.DataTable object containing matching records.

Remarks

The criteria is passed to an SQL query so use the appropriate syntax. Remember to include the single quotes around string literals and append additional criteria with and.

See Also

CustomerTransaction Class
CustomerTransaction Members
List Overload


CustomerTransaction.List Method (AccountBase, String)

[image]

Pastel Evolution SDK
CustomerTransaction..::..List Method (AccountBase, String)
CustomerTransaction Class See Also Send Feedback
Returns a System.Data.DataTable object containing the database records from the PostAR/PostAP table matching the supplied criteria and limited to the specified account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    AccountBase account,
    string criteria
)
Visual Basic
Public Shared Function List (
    account As AccountBase,
    criteria As String
) As DataTable

Parameters

account
Type: Pastel.Evolution..::..AccountBase
The customer account to which to limit the transaction listing.
criteria
Type: System..::..String
The SQL criteria used to locate the record, e.g. Reference like '1___'

Return Value

Type: DataTable
A System.Data.DataTable object containing matching records.

Remarks

The criteria is passed to an SQL query so use the appropriate syntax. Remember to include the single quotes around string literals and append additional criteria with and.

See Also

CustomerTransaction Class
CustomerTransaction Members
List Overload


CustomerTransaction.OnAllowBlockedPosting Method

[image]

Pastel Evolution SDK
CustomerTransaction..::..OnAllowBlockedPosting Method
CustomerTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override bool OnAllowBlockedPosting()
Visual Basic
Protected Friend Overrides Function OnAllowBlockedPosting As Boolean

Return Value

Type: Boolean

See Also

CustomerTransaction Class
CustomerTransaction Members


CustomerTransaction.OnOverrideControlAccount Method

[image]

Pastel Evolution SDK
CustomerTransaction..::..OnOverrideControlAccount Method
CustomerTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnOverrideControlAccount(
    GLTransaction glTran
)
Visual Basic
Protected Friend Overrides Sub OnOverrideControlAccount (
    glTran As GLTransaction
)

Parameters

glTran
Type: Pastel.Evolution..::..GLTransaction

See Also

CustomerTransaction Class
CustomerTransaction Members


CustomerTransaction.OnOverrideTaxControlAccount Method

[image]

Pastel Evolution SDK
CustomerTransaction..::..OnOverrideTaxControlAccount Method
CustomerTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnOverrideTaxControlAccount(
    TransactionCode tranCode,
    GLTransaction glTran
)
Visual Basic
Protected Friend Overrides Sub OnOverrideTaxControlAccount (
    tranCode As TransactionCode,
    glTran As GLTransaction
)

Parameters

tranCode
Type: Pastel.Evolution..::..TransactionCode
glTran
Type: Pastel.Evolution..::..GLTransaction

See Also

CustomerTransaction Class
CustomerTransaction Members


CustomerTransaction.OnPost Method

[image]

Pastel Evolution SDK
CustomerTransaction..::..OnPost Method
CustomerTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected override bool OnPost()
Visual Basic
Protected Overrides Function OnPost As Boolean

Return Value

Type: Boolean

See Also

CustomerTransaction Class
CustomerTransaction Members


CustomerTransaction.setExchangeRate Method

[image]

Pastel Evolution SDK
CustomerTransaction..::..setExchangeRate Method
CustomerTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected override void setExchangeRate(
    double value
)
Visual Basic
Protected Overrides Sub setExchangeRate (
    value As Double
)

Parameters

value
Type: System..::..Double

See Also

CustomerTransaction Class
CustomerTransaction Members


CustomerTransaction.Validate Method

[image]

Pastel Evolution SDK
CustomerTransaction..::..Validate Method
CustomerTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override bool Validate()
Visual Basic
Public Overrides Function Validate As Boolean

Return Value

Type: Boolean

See Also

CustomerTransaction Class
CustomerTransaction Members


CustomerTransaction Properties

[image] [image]

Pastel Evolution SDK
CustomerTransaction Properties
CustomerTransaction Class See Also Send Feedback

The CustomerTransaction type exposes the following members.

Properties

 | Name | Description
Public property | Account | Gets or sets the Account to which the transaction gets posted. This is amandatory field. (Overrides TransactionBase..::..Account.)
Public property | AccountID | Gets or sets the ID of the Account to which the transaction gets posted. (Overrides TransactionBase..::..AccountID.)
Public property | Allocations | Gets the transaction's allocation collection. (Overrides DrCrTransaction..::..Allocations.)
Public property | Amount | Gets or sets the (gross) transaction value. Negative values are allowed and will result in inverted debits and credits. (Overrides DrCrTransaction..::..Amount.)
Public property | Audit | Gets the transaction's audit number. (Overrides TransactionBase..::..Audit.)
Public property | Branch | (Overrides DrCrTransaction..::..Branch.)
Public property | BranchID | (Overrides DrCrTransaction..::..BranchID.)
Public property | Credit | Gets the transaction's credit value, the value of which is determined by the Amount and TransactionCode properties. (Overrides TransactionBase..::..Credit.)
Public property | Currency | Gets the foreign currency in use on this transaction, determined by the specified account. A null value indicates local currency. (Overrides DrCrTransaction..::..Currency.)
Public property | CurrencyID | (Overrides DrCrTransaction..::..CurrencyID.)
Public property | Customer | Gets or sets the transaction's customer account (maps directly to Account).
Public property | Date | Gets or sets the date on which the transaction takes place. This often differs from the actual posting date but defaults to the current date. (Overrides TransactionBase..::..Date.)
Public property | Debit | Gets the transaction's debit value, the value of which is determined by the Amount and TransactionCode properties. (Overrides TransactionBase..::..Debit.)
Public property | Description | Gets or sets the transaction description that - togeter with the Reference - appears on the account's statement by default. This is a mandatory field. (Overrides TransactionBase..::..Description.)
Public property | ExchangeRate | Gets or sets the applicable exchange rate, expressed as [home currency]/[foreign currency]. Defaults to applicable exchange rate for the transaction date. (Inherited from DrCrTransaction.)
Public property | ExtOrderNo | Gets or sets the transaction's external order number. (Overrides TransactionBase..::..ExtOrderNo.)
Public property | ForeignAmount | Gets or sets the foreign transaction value. (Overrides DrCrTransaction..::..ForeignAmount.)
Public property | ForeignCredit | Gets the transaction's foreign credit value, which is determined by the ForeignAmount and TransactionCode properties. (Overrides DrCrTransaction..::..ForeignCredit.)
Public property | ForeignDebit | Gets the transaction's foreign debit value, which is determined by the ForeignAmount and TransactionCode properties. (Overrides DrCrTransaction..::..ForeignDebit.)
Public property | ForeignOutstanding | Gets the transaction's foreign outstanding amount. (Overrides DrCrTransaction..::..ForeignOutstanding.)
Public property | ForeignTax | Gets or sets the transaction foreign tax amount (automatically rounded to 2 decimals). Note that setting this will switch the entry mode to foreign and recalculate the Amount property. (Overrides DrCrTransaction..::..ForeignTax.)
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides TransactionBase..::..ID.)
Public property | IsDebit | Indicates whether the transaction is a debit (true) or credit(false) (Inherited from DrCrTransaction.)
Public property | IsDebitPositive | (Overrides DrCrTransaction..::..IsDebitPositive.)
Public property | MaxForeignOutstanding | Gets the maximum possible foreign outstanding value for the given transaction, based on the ForeignDebit or ForeignCredit value. (Inherited from DrCrTransaction.)
Public property | MaxOutstanding | Gets the maximum possible outstanding value for the given transaction, based on the Debit or Credit value. (Inherited from DrCrTransaction.)
Public property | ModID | Gets or sets the transaction's evolution module id. (Overrides TransactionBase..::..ModID.)
Public property | Module | Gets the Evolution module this record belongs to, used in internal validation. (Overrides TransactionBase..::..Module.)
Public property | OrderNo | Gets or sets the transaction order number. (Overrides TransactionBase..::..OrderNo.)
Public property | Outstanding | Gets the transaction's outstanding amount. (Overrides DrCrTransaction..::..Outstanding.)
Public property | PostDated | Gets or sets whether the transaction is a Post Dated Transaction.
Public property | Project | Gets or sets the Project record associated with this transaction. When using Project Tracking, this field must be specified wherever applicable. (Overrides TransactionBase..::..Project.)
Public property | ProjectID | Gets or sets the ID of the Project record associated with this transaction. When using Project Tracking, this field must be specified wherever applicable. (Overrides TransactionBase..::..ProjectID.)
Public property | Reference | Gets or sets the transaction reference that - together with the Description - appears on the customer statement by default. This is a mandatory field. (Overrides TransactionBase..::..Reference.)
Public property | Reference2 | Gets or sets an additional transaction reference. (Overrides TransactionBase..::..Reference2.)
Public property | SalesRep | Gets or sets the Sales Rep.
Public property | SalesRepID |
Public property | SettlementTerms | (Overrides DrCrTransaction..::..SettlementTerms.)
Public property | SettlementTermsID | (Overrides DrCrTransaction..::..SettlementTermsID.)
Public property | SplitAllocations | Gets the transaction's split allocation collection, used to split the contra account posting to various GL accounts. (Overrides DrCrTransaction..::..SplitAllocations.)
Public property | Tax | Gets or sets the transaction tax amount (automatically rounded to 2 decimals). (Overrides TransactionBase..::..Tax.)
Public property | TaxRate | Gets or sets the TaxRate record associated with this transaction. If a tax type is specified, a tax amount is automatically calculated, but can be overridden. (Overrides TransactionBase..::..TaxRate.)
Public property | TaxRateID | Gets or sets the transaction's tax type id. (Overrides TransactionBase..::..TaxRateID.)
Public property | TillID |
Public property | TransactionCode | Gets or sets the TransactionCode record associated with this transaction, as maintained in Accounts Receivable > Maintenance > Transaction Types. Transaction codes/types govern General Ledger integration. This is a mandatory field. (Overrides TransactionBase..::..TransactionCode.)
Public property | TransactionCodeID | Gets or sets the ID of the TransactionCode record associated with this transaction, which governs General Ledger integration. (Overrides TransactionBase..::..TransactionCodeID.)

See Also

CustomerTransaction Class


CustomerTransaction.Account Property

[image]

Pastel Evolution SDK
CustomerTransaction..::..Account Property
CustomerTransaction Class See Also Send Feedback
Gets or sets the Account to which the transaction gets posted. This is amandatory field.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override AccountBase Account { get; set; }
Visual Basic
Public Overrides Property Account As AccountBase
    Get
    Set

Property Value

Type: AccountBase

See Also

CustomerTransaction Class
CustomerTransaction Members
Pastel.Evolution Namespace
CustomerTransaction..::..Customer


CustomerTransaction.AccountID Property

[image]

Pastel Evolution SDK
CustomerTransaction..::..AccountID Property
CustomerTransaction Class See Also Send Feedback
Gets or sets the ID of the Account to which the transaction gets posted.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int AccountID { get; set; }
Visual Basic
Public Overrides Property AccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CustomerTransaction Class
CustomerTransaction Members
Pastel.Evolution Namespace
CustomerTransaction..::..Account


CustomerTransaction.Allocations Property

[image]

Pastel Evolution SDK
CustomerTransaction..::..Allocations Property
CustomerTransaction Class See Also Send Feedback
Gets the transaction's allocation collection.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override AllocationCollection Allocations { get; }
Visual Basic
Public Overrides ReadOnly Property Allocations As AllocationCollection
    Get

Property Value

Type: AllocationCollection

Remarks

Allocations are used to link debit transactions to credit transactions.

Examples

Copy image Copy
CustomerTransaction inv = new CustomerTransaction();
inv.Account = new Customer("CASH");
inv.TransactionCode = new TransactionCode("IN", Module.AR);
inv.Amount = 1500;
inv.Reference = "Invoice, pay up";
inv.Post();

CustomerTransaction pm = new CustomerTransaction();
pm.Account = new Customer("CASH");
pm.TransactionCode = new TransactionCode("PM", Module.AR);
pm.Amount = 1500;
pm.Reference = "Payment, thank you!";
pm.Post();

inv.Allocations.Add(pm, 1350);
inv.Allocations.Save();

See Also

CustomerTransaction Class
CustomerTransaction Members


CustomerTransaction.Amount Property

[image]

Pastel Evolution SDK
CustomerTransaction..::..Amount Property
CustomerTransaction Class See Also Send Feedback
Gets or sets the (gross) transaction value. Negative values are allowed and will result in inverted debits and credits.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override double Amount { get; set; }
Visual Basic
Public Overrides Property Amount As Double
    Get
    Set

Property Value

Type: Double

See Also

CustomerTransaction Class
CustomerTransaction Members


CustomerTransaction.Audit Property

[image]

Pastel Evolution SDK
CustomerTransaction..::..Audit Property
CustomerTransaction Class See Also Send Feedback
Gets the transaction's audit number.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override string Audit { get; }
Visual Basic
Public Overrides ReadOnly Property Audit As String
    Get

Property Value

Type: String

Remarks

The audit number is 0 when unposted. After posting, it will reflect the transaction's posted audit number.

See Also

CustomerTransaction Class
CustomerTransaction Members


CustomerTransaction.Branch Property

[image]

Pastel Evolution SDK
CustomerTransaction..::..Branch Property
CustomerTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override Branch Branch { get; set; }
Visual Basic
Public Overrides Property Branch As Branch
    Get
    Set

Property Value

Type: Branch

Implements

IBranched..::..Branch

See Also

CustomerTransaction Class
CustomerTransaction Members


CustomerTransaction.BranchID Property

[image]

Pastel Evolution SDK
CustomerTransaction..::..BranchID Property
CustomerTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int BranchID { get; internal set; }
Visual Basic
Public Overrides Property BranchID As Integer
    Get
    Friend Set

Property Value

Type: Int32

Implements

IBranched..::..BranchID

See Also

CustomerTransaction Class
CustomerTransaction Members


CustomerTransaction.Credit Property

[image]

Pastel Evolution SDK
CustomerTransaction..::..Credit Property
CustomerTransaction Class See Also Send Feedback
Gets the transaction's credit value, the value of which is determined by the Amount and TransactionCode properties.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override double Credit { get; set; }
Visual Basic
Public Overrides Property Credit As Double
    Get
    Set

Property Value

Type: Double

See Also

CustomerTransaction Class
CustomerTransaction Members


CustomerTransaction.Currency Property

[image]

Pastel Evolution SDK
CustomerTransaction..::..Currency Property
CustomerTransaction Class See Also Send Feedback
Gets the foreign currency in use on this transaction, determined by the specified account. A null value indicates local currency.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override Currency Currency { get; internal set; }
Visual Basic
Public Overrides Property Currency As Currency
    Get
    Friend Set

Property Value

Type: Currency

See Also

CustomerTransaction Class
CustomerTransaction Members


CustomerTransaction.CurrencyID Property

[image]

Pastel Evolution SDK
CustomerTransaction..::..CurrencyID Property
CustomerTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int CurrencyID { get; internal set; }
Visual Basic
Public Overrides Property CurrencyID As Integer
    Get
    Friend Set

Property Value

Type: Int32

See Also

CustomerTransaction Class
CustomerTransaction Members


CustomerTransaction.Customer Property

[image]

Pastel Evolution SDK
CustomerTransaction..::..Customer Property
CustomerTransaction Class See Also Send Feedback
Gets or sets the transaction's customer account (maps directly to Account).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Customer Customer { get; set; }
Visual Basic
Public Property Customer As Customer
    Get
    Set

Property Value

Type: Customer

See Also

CustomerTransaction Class
CustomerTransaction Members


CustomerTransaction.Date Property

[image]

Pastel Evolution SDK
CustomerTransaction..::..Date Property
CustomerTransaction Class See Also Send Feedback
Gets or sets the date on which the transaction takes place. This often differs from the actual posting date but defaults to the current date.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override DateTime Date { get; set; }
Visual Basic
Public Overrides Property Date As DateTime
    Get
    Set

Property Value

Type: DateTime

See Also

CustomerTransaction Class
CustomerTransaction Members


CustomerTransaction.Debit Property

[image]

Pastel Evolution SDK
CustomerTransaction..::..Debit Property
CustomerTransaction Class See Also Send Feedback
Gets the transaction's debit value, the value of which is determined by the Amount and TransactionCode properties.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override double Debit { get; set; }
Visual Basic
Public Overrides Property Debit As Double
    Get
    Set

Property Value

Type: Double

See Also

CustomerTransaction Class
CustomerTransaction Members


CustomerTransaction.Description Property

[image]

Pastel Evolution SDK
CustomerTransaction..::..Description Property
CustomerTransaction Class See Also Send Feedback
Gets or sets the transaction description that - togeter with the Reference - appears on the account's statement by default. This is a mandatory field.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override string Description { get; set; }
Visual Basic
Public Overrides Property Description As String
    Get
    Set

Property Value

Type: String

Remarks

The Reference is usually a sequencial code whereas the description is more general, e.g. a transaction might have the reference "PMB128901" and the description "Payment - Thank You".

See Also

CustomerTransaction Class
CustomerTransaction Members


CustomerTransaction.ExtOrderNo Property

[image]

Pastel Evolution SDK
CustomerTransaction..::..ExtOrderNo Property
CustomerTransaction Class See Also Send Feedback
Gets or sets the transaction's external order number.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override string ExtOrderNo { get; set; }
Visual Basic
Public Overrides Property ExtOrderNo As String
    Get
    Set

Property Value

Type: String

See Also

CustomerTransaction Class
CustomerTransaction Members


CustomerTransaction.ForeignAmount Property

[image]

Pastel Evolution SDK
CustomerTransaction..::..ForeignAmount Property
CustomerTransaction Class See Also Send Feedback
Gets or sets the foreign transaction value.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override double ForeignAmount { get; set; }
Visual Basic
Public Overrides Property ForeignAmount As Double
    Get
    Set

Property Value

Type: Double

See Also

CustomerTransaction Class
CustomerTransaction Members


CustomerTransaction.ForeignCredit Property

[image]

Pastel Evolution SDK
CustomerTransaction..::..ForeignCredit Property
CustomerTransaction Class See Also Send Feedback
Gets the transaction's foreign credit value, which is determined by the ForeignAmount and TransactionCode properties.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override double ForeignCredit { get; }
Visual Basic
Public Overrides ReadOnly Property ForeignCredit As Double
    Get

Property Value

Type: Double

See Also

CustomerTransaction Class
CustomerTransaction Members


CustomerTransaction.ForeignDebit Property

[image]

Pastel Evolution SDK
CustomerTransaction..::..ForeignDebit Property
CustomerTransaction Class See Also Send Feedback
Gets the transaction's foreign debit value, which is determined by the ForeignAmount and TransactionCode properties.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override double ForeignDebit { get; }
Visual Basic
Public Overrides ReadOnly Property ForeignDebit As Double
    Get

Property Value

Type: Double

See Also

CustomerTransaction Class
CustomerTransaction Members


CustomerTransaction.ForeignOutstanding Property

[image]

Pastel Evolution SDK
CustomerTransaction..::..ForeignOutstanding Property
CustomerTransaction Class See Also Send Feedback
Gets the transaction's foreign outstanding amount.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override double ForeignOutstanding { get; internal set; }
Visual Basic
Public Overrides Property ForeignOutstanding As Double
    Get
    Friend Set

Property Value

Type: Double

See Also

CustomerTransaction Class
CustomerTransaction Members


CustomerTransaction.ForeignTax Property

[image]

Pastel Evolution SDK
CustomerTransaction..::..ForeignTax Property
CustomerTransaction Class See Also Send Feedback
Gets or sets the transaction foreign tax amount (automatically rounded to 2 decimals). Note that setting this will switch the entry mode to foreign and recalculate the Amount property.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override double ForeignTax { get; set; }
Visual Basic
Public Overrides Property ForeignTax As Double
    Get
    Set

Property Value

Type: Double

See Also

CustomerTransaction Class
CustomerTransaction Members


CustomerTransaction.ID Property

[image]

Pastel Evolution SDK
CustomerTransaction..::..ID Property
CustomerTransaction Class See Also Send Feedback
Gets the internal record ID (0 for new, unsaved records).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Long
    Get

Property Value

Type: Int64

See Also

CustomerTransaction Class
CustomerTransaction Members


CustomerTransaction.IsDebitPositive Property

[image]

Pastel Evolution SDK
CustomerTransaction..::..IsDebitPositive Property
CustomerTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override bool IsDebitPositive { get; }
Visual Basic
Public Overrides ReadOnly Property IsDebitPositive As Boolean
    Get

Property Value

Type: Boolean

See Also

CustomerTransaction Class
CustomerTransaction Members


CustomerTransaction.ModID Property

[image]

Pastel Evolution SDK
CustomerTransaction..::..ModID Property
CustomerTransaction Class See Also Send Feedback
Gets or sets the transaction's evolution module id.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override ModuleID ModID { get; set; }
Visual Basic
Public Overrides Property ModID As ModuleID
    Get
    Set

Property Value

Type: ModuleID

See Also

CustomerTransaction Class
CustomerTransaction Members


CustomerTransaction.Module Property

[image]

Pastel Evolution SDK
CustomerTransaction..::..Module Property
CustomerTransaction Class See Also Send Feedback
Gets the Evolution module this record belongs to, used in internal validation.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override Module Module { get; }
Visual Basic
Public Overrides ReadOnly Property Module As Module
    Get

Property Value

Type: Module

See Also

CustomerTransaction Class
CustomerTransaction Members


CustomerTransaction.OrderNo Property

[image]

Pastel Evolution SDK
CustomerTransaction..::..OrderNo Property
CustomerTransaction Class See Also Send Feedback
Gets or sets the transaction order number.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override string OrderNo { get; set; }
Visual Basic
Public Overrides Property OrderNo As String
    Get
    Set

Property Value

Type: String

See Also

CustomerTransaction Class
CustomerTransaction Members


CustomerTransaction.Outstanding Property

[image]

Pastel Evolution SDK
CustomerTransaction..::..Outstanding Property
CustomerTransaction Class See Also Send Feedback
Gets the transaction's outstanding amount.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override double Outstanding { get; internal set; }
Visual Basic
Public Overrides Property Outstanding As Double
    Get
    Friend Set

Property Value

Type: Double

See Also

CustomerTransaction Class
CustomerTransaction Members


CustomerTransaction.PostDated Property

[image]

Pastel Evolution SDK
CustomerTransaction..::..PostDated Property
CustomerTransaction Class See Also Send Feedback
Gets or sets whether the transaction is a Post Dated Transaction.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool PostDated { get; set; }
Visual Basic
Public Property PostDated As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CustomerTransaction Class
CustomerTransaction Members


CustomerTransaction.Project Property

[image]

Pastel Evolution SDK
CustomerTransaction..::..Project Property
CustomerTransaction Class See Also Send Feedback
Gets or sets the Project record associated with this transaction. When using Project Tracking, this field must be specified wherever applicable.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override Project Project { get; set; }
Visual Basic
Public Overrides Property Project As Project
    Get
    Set

Property Value

Type: Project

See Also

CustomerTransaction Class
CustomerTransaction Members


CustomerTransaction.ProjectID Property

[image]

Pastel Evolution SDK
CustomerTransaction..::..ProjectID Property
CustomerTransaction Class See Also Send Feedback
Gets or sets the ID of the Project record associated with this transaction. When using Project Tracking, this field must be specified wherever applicable.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ProjectID { get; set; }
Visual Basic
Public Overrides Property ProjectID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CustomerTransaction Class
CustomerTransaction Members


CustomerTransaction.Reference Property

[image]

Pastel Evolution SDK
CustomerTransaction..::..Reference Property
CustomerTransaction Class See Also Send Feedback
Gets or sets the transaction reference that - together with the Description - appears on the customer statement by default. This is a mandatory field.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override string Reference { get; set; }
Visual Basic
Public Overrides Property Reference As String
    Get
    Set

Property Value

Type: String

Remarks

The Reference is usually quite "cryptic" (numbered sequenceetc.) whereas the description is more friendly, e.g. a transaction might have thereference "PMB128901" and the description "Payment - Thank You".

See Also

CustomerTransaction Class
CustomerTransaction Members


CustomerTransaction.Reference2 Property

[image]

Pastel Evolution SDK
CustomerTransaction..::..Reference2 Property
CustomerTransaction Class See Also Send Feedback
Gets or sets an additional transaction reference.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override string Reference2 { get; set; }
Visual Basic
Public Overrides Property Reference2 As String
    Get
    Set

Property Value

Type: String

See Also

CustomerTransaction Class
CustomerTransaction Members


CustomerTransaction.SalesRep Property

[image]

Pastel Evolution SDK
CustomerTransaction..::..SalesRep Property
CustomerTransaction Class See Also Send Feedback
Gets or sets the Sales Rep.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public SalesRepresentative SalesRep { get; set; }
Visual Basic
Public Property SalesRep As SalesRepresentative
    Get
    Set

Property Value

Type: SalesRepresentative

See Also

CustomerTransaction Class
CustomerTransaction Members


CustomerTransaction.SalesRepID Property

[image]

Pastel Evolution SDK
CustomerTransaction..::..SalesRepID Property
CustomerTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int SalesRepID { get; set; }
Visual Basic
Public Property SalesRepID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CustomerTransaction Class
CustomerTransaction Members


CustomerTransaction.SettlementTerms Property

[image]

Pastel Evolution SDK
CustomerTransaction..::..SettlementTerms Property
CustomerTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override SettlementTerms SettlementTerms { get; set; }
Visual Basic
Public Overrides Property SettlementTerms As SettlementTerms
    Get
    Set

Property Value

Type: SettlementTerms

See Also

CustomerTransaction Class
CustomerTransaction Members


CustomerTransaction.SettlementTermsID Property

[image]

Pastel Evolution SDK
CustomerTransaction..::..SettlementTermsID Property
CustomerTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int SettlementTermsID { get; set; }
Visual Basic
Public Overrides Property SettlementTermsID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CustomerTransaction Class
CustomerTransaction Members


CustomerTransaction.SplitAllocations Property

[image]

Pastel Evolution SDK
CustomerTransaction..::..SplitAllocations Property
CustomerTransaction Class See Also Send Feedback
Gets the transaction's split allocation collection, used to split the contra account posting to various GL accounts.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override SplitAllocationCollection SplitAllocations { get; }
Visual Basic
Public Overrides ReadOnly Property SplitAllocations As SplitAllocationCollection
    Get

Property Value

Type: SplitAllocationCollection

See Also

CustomerTransaction Class
CustomerTransaction Members


CustomerTransaction.Tax Property

[image]

Pastel Evolution SDK
CustomerTransaction..::..Tax Property
CustomerTransaction Class See Also Send Feedback
Gets or sets the transaction tax amount (automatically rounded to 2 decimals).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override double Tax { get; set; }
Visual Basic
Public Overrides Property Tax As Double
    Get
    Set

Property Value

Type: Double

See Also

CustomerTransaction Class
CustomerTransaction Members


CustomerTransaction.TaxRate Property

[image]

Pastel Evolution SDK
CustomerTransaction..::..TaxRate Property
CustomerTransaction Class See Also Send Feedback
Gets or sets the TaxRate record associated with this transaction. If a tax type is specified, a tax amount is automatically calculated, but can be overridden.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override TaxRate TaxRate { get; set; }
Visual Basic
Public Overrides Property TaxRate As TaxRate
    Get
    Set

Property Value

Type: TaxRate

See Also

CustomerTransaction Class
CustomerTransaction Members


CustomerTransaction.TaxRateID Property

[image]

Pastel Evolution SDK
CustomerTransaction..::..TaxRateID Property
CustomerTransaction Class See Also Send Feedback
Gets or sets the transaction's tax type id.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int TaxRateID { get; set; }
Visual Basic
Public Overrides Property TaxRateID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CustomerTransaction Class
CustomerTransaction Members
Pastel.Evolution Namespace
CustomerTransaction..::..TaxRate


CustomerTransaction.TillID Property

[image]

Pastel Evolution SDK
CustomerTransaction..::..TillID Property
CustomerTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int TillID { get; set; }
Visual Basic
Public Property TillID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CustomerTransaction Class
CustomerTransaction Members


CustomerTransaction.TransactionCode Property

[image]

Pastel Evolution SDK
CustomerTransaction..::..TransactionCode Property
CustomerTransaction Class See Also Send Feedback
Gets or sets the TransactionCode record associated with this transaction, as maintained in Accounts Receivable > Maintenance > Transaction Types. Transaction codes/types govern General Ledger integration. This is a mandatory field.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override TransactionCodeBase TransactionCode { get; set; }
Visual Basic
Public Overrides Property TransactionCode As TransactionCodeBase
    Get
    Set

Property Value

Type: TransactionCodeBase

See Also

CustomerTransaction Class
CustomerTransaction Members


CustomerTransaction.TransactionCodeID Property

[image]

Pastel Evolution SDK
CustomerTransaction..::..TransactionCodeID Property
CustomerTransaction Class See Also Send Feedback
Gets or sets the ID of the TransactionCode record associated with this transaction, which governs General Ledger integration.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int TransactionCodeID { get; set; }
Visual Basic
Public Overrides Property TransactionCodeID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CustomerTransaction Class
CustomerTransaction Members
Pastel.Evolution Namespace
CustomerTransaction..::..TransactionCode


CustomerTransaction Events

[image] [image]

Pastel Evolution SDK
CustomerTransaction Events
CustomerTransaction Class See Also Send Feedback

The CustomerTransaction type exposes the following members.

Events

 | Name | Description
Public event | GLCreditPosting | (Inherited from TransactionBase.)
Public event | GLDebitPosting | (Inherited from TransactionBase.)
Public event | GLVatPosting | (Inherited from TransactionBase.)

See Also

CustomerTransaction Class


DatabaseContext Class

[image]

Pastel Evolution SDK
DatabaseContext Class
Members See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static class DatabaseContext
Visual Basic
Public NotInheritable Class DatabaseContext

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..DatabaseContext

See Also

DatabaseContext Members


DatabaseContext Members

[image] [image]

Pastel Evolution SDK
DatabaseContext Members
DatabaseContext Class Methods Properties See Also Send Feedback

The DatabaseContext type exposes the following members.

Methods

Name | Description
BeginTran | Starts a global database transaction.
CommitTran | Quietly commits the global transaction regardless of whether it is actually pending.
CreateCommonDBConnection()()()() | Creates a connection to the database named 'EvolutionCommon', on the local server, using trusted authentication.
CreateCommonDBConnection(String) | Creates a connection to the Evolution common database.
CreateCommonDBConnection(String, String, String, String, Boolean) | Creates a connection to the Evolution common database.
CreateConnection(String) | Creates a connection to a Pastel Evolution database. Use this method if you have a connection string available; otherwise use one of the overloaded methods.
CreateConnection(String, String) | Creates a connection to the Evolution accounting database using trusted authentication.
CreateConnection(String, String, String, String, Boolean) | Creates a connection to the Evolution accounting database.
ExecuteCommandDataTable(SqlCommand) |
ExecuteCommandDataTable(String) |
ExecuteCommandDataTable(SqlConnection, SqlTransaction, SqlCommand) |
ExecuteCommandDataTable(SqlConnection, SqlTransaction, String) |
ExecuteCommandNonQuery(SqlCommand) |
ExecuteCommandNonQuery(String) |
ExecuteCommandNonQuery(SqlConnection, SqlTransaction, SqlCommand) |
ExecuteCommandNonQuery(SqlConnection, SqlTransaction, String) |
ExecuteCommandScalar(SqlCommand) | Executes a command and returns the 1st value from 1st value. Will convert a return value of DBNull to null.
ExecuteCommandScalar(String) |
ExecuteCommandScalar(SqlConnection, SqlTransaction, SqlCommand) | Executes the query, and returns the first column of the first row in the result set returned by the query. Additional columns or rows are ignored.
ExecuteCommandScalar(SqlConnection, SqlTransaction, String) |
ExecuteCommandSingleRow(SqlCommand) |
ExecuteCommandSingleRow(String) |
ExecuteCommandSingleRow(SqlConnection, SqlTransaction, SqlCommand) |
ExecuteCommandSingleRow(SqlConnection, SqlTransaction, String) |
GetProductVersion |
Initialise(String, String, String, String) | Initialises the database connections required by the SDK.
Initialise(String, String, String, String, String, String) | Initialises the database connections required by the SDK. This version of the method assumes the common database is called 'EvolutionCommon', is on the same server as the accounting database, and is able to uses the same login credentials.
Initialise(String, String, String, String, String, String, String) | Initialises the database connections required by the SDK. This version of the method assumes the common database is on the same server as the accounting database, and is able to uses the same login credentials.
IsModuleActive |
RollbackTran | Quietly aborts the global transaction regardless of whether it is actually open.
SetBranchContext |
SetLicense |

Properties

Name | Description
_ContextBranch |
CommonDBConnection |
CommonDBVersion |
CompanyBranch |
CompanyID |
CompanyName |
CompatibleDatabaseVersion |
CurrentAgent |
CurrentDatabaseVersion |
DBConnection | The SqlConnection object used by all database calls in the API. Transaction scope is managed automatically using the BeginTran, CommitTran and RollBackTran methods
DBTransaction | The SQL transaction in progress (if any).
DefaultCommandTimeout |
ExpiryDate |
IsBranchOffline |
IsCommonConnectionOpen |
IsConnectionOpen |
IsTransactionPending |
RegisteredUsers |

See Also

DatabaseContext Class


DatabaseContext Methods

[image] [image]

Pastel Evolution SDK
DatabaseContext Methods
DatabaseContext Class See Also Send Feedback

The DatabaseContext type exposes the following members.

Methods

Name | Description
BeginTran | Starts a global database transaction.
CommitTran | Quietly commits the global transaction regardless of whether it is actually pending.
CreateCommonDBConnection()()()() | Creates a connection to the database named 'EvolutionCommon', on the local server, using trusted authentication.
CreateCommonDBConnection(String) | Creates a connection to the Evolution common database.
CreateCommonDBConnection(String, String, String, String, Boolean) | Creates a connection to the Evolution common database.
CreateConnection(String) | Creates a connection to a Pastel Evolution database. Use this method if you have a connection string available; otherwise use one of the overloaded methods.
CreateConnection(String, String) | Creates a connection to the Evolution accounting database using trusted authentication.
CreateConnection(String, String, String, String, Boolean) | Creates a connection to the Evolution accounting database.
ExecuteCommandDataTable(SqlCommand) |
ExecuteCommandDataTable(String) |
ExecuteCommandDataTable(SqlConnection, SqlTransaction, SqlCommand) |
ExecuteCommandDataTable(SqlConnection, SqlTransaction, String) |
ExecuteCommandNonQuery(SqlCommand) |
ExecuteCommandNonQuery(String) |
ExecuteCommandNonQuery(SqlConnection, SqlTransaction, SqlCommand) |
ExecuteCommandNonQuery(SqlConnection, SqlTransaction, String) |
ExecuteCommandScalar(SqlCommand) | Executes a command and returns the 1st value from 1st value. Will convert a return value of DBNull to null.
ExecuteCommandScalar(String) |
ExecuteCommandScalar(SqlConnection, SqlTransaction, SqlCommand) | Executes the query, and returns the first column of the first row in the result set returned by the query. Additional columns or rows are ignored.
ExecuteCommandScalar(SqlConnection, SqlTransaction, String) |
ExecuteCommandSingleRow(SqlCommand) |
ExecuteCommandSingleRow(String) |
ExecuteCommandSingleRow(SqlConnection, SqlTransaction, SqlCommand) |
ExecuteCommandSingleRow(SqlConnection, SqlTransaction, String) |
GetProductVersion |
Initialise(String, String, String, String) | Initialises the database connections required by the SDK.
Initialise(String, String, String, String, String, String) | Initialises the database connections required by the SDK. This version of the method assumes the common database is called 'EvolutionCommon', is on the same server as the accounting database, and is able to uses the same login credentials.
Initialise(String, String, String, String, String, String, String) | Initialises the database connections required by the SDK. This version of the method assumes the common database is on the same server as the accounting database, and is able to uses the same login credentials.
IsModuleActive |
RollbackTran | Quietly aborts the global transaction regardless of whether it is actually open.
SetBranchContext |
SetLicense |

See Also

DatabaseContext Class


DatabaseContext.BeginTran Method

[image]

Pastel Evolution SDK
DatabaseContext..::..BeginTran Method
DatabaseContext Class See Also Send Feedback
Starts a global database transaction.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static bool BeginTran()
Visual Basic
Public Shared Function BeginTran As Boolean

Return Value

Type: Boolean
True if a transaction was actually started; false if a transaction was already pending.

Remarks

Certain operations will implicitly begin and end a transaction if a transaction is not already pending. If deciding to manage the transaction yourself, be sure to include this in a try-catch block calling RollbackTran or CommitTran methods accordingly. Also be aware that most client tools have their transaction isolation level set to "read commited" by default, so while this transaction is in progress, other data requests for data will be delayed.

See Also

DatabaseContext Class
DatabaseContext Members


DatabaseContext.CommitTran Method

[image]

Pastel Evolution SDK
DatabaseContext..::..CommitTran Method
DatabaseContext Class See Also Send Feedback
Quietly commits the global transaction regardless of whether it is actually pending.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static bool CommitTran()
Visual Basic
Public Shared Function CommitTran As Boolean

Return Value

Type: Boolean
True if a transaction was actually pending; false otherwise.

See Also

DatabaseContext Class
DatabaseContext Members


DatabaseContext.CreateCommonDBConnection Method

[image] [image]

Pastel Evolution SDK
DatabaseContext..::..CreateCommonDBConnection Method
DatabaseContext Class See Also Send Feedback

Overload List

Name | Description
CreateCommonDBConnection()()()() | Creates a connection to the database named 'EvolutionCommon', on the local server, using trusted authentication.
CreateCommonDBConnection(String) | Creates a connection to the Evolution common database.
CreateCommonDBConnection(String, String, String, String, Boolean) | Creates a connection to the Evolution common database.

See Also

DatabaseContext Class
DatabaseContext Members


DatabaseContext.CreateCommonDBConnection Method

[image]

Pastel Evolution SDK
DatabaseContext..::..CreateCommonDBConnection Method
DatabaseContext Class See Also Send Feedback
Creates a connection to the database named 'EvolutionCommon', on the local server, using trusted authentication.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static void CreateCommonDBConnection()
Visual Basic
Public Shared Sub CreateCommonDBConnection

See Also

DatabaseContext Class
DatabaseContext Members
CreateCommonDBConnection Overload


DatabaseContext.CreateCommonDBConnection Method (String)

[image]

Pastel Evolution SDK
DatabaseContext..::..CreateCommonDBConnection Method (String)
DatabaseContext Class See Also Send Feedback
Creates a connection to the Evolution common database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static void CreateCommonDBConnection(
    string connectionString
)
Visual Basic
Public Shared Sub CreateCommonDBConnection (
    connectionString As String
)

Parameters

connectionString
Type: System..::..String
The connection string used by SqlConnection.

See Also

DatabaseContext Class
DatabaseContext Members
CreateCommonDBConnection Overload
Pastel.Evolution Namespace
DatabaseContext..::..CreateConnection(String, String, String, String, Boolean)


DatabaseContext.CreateCommonDBConnection Method (String, String, String, String, Boolean)

[image]

Pastel Evolution SDK
DatabaseContext..::..CreateCommonDBConnection Method (String, String, String, String, Boolean)
DatabaseContext Class See Also Send Feedback
Creates a connection to the Evolution common database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static void CreateCommonDBConnection(
    string server,
    string database,
    string login,
    string password,
    bool trustedAuth
)
Visual Basic
Public Shared Sub CreateCommonDBConnection (
    server As String,
    database As String,
    login As String,
    password As String,
    trustedAuth As Boolean
)

Parameters

server
Type: System..::..String
The SQL server name, alias or IP address.
database
Type: System..::..String
The SQL database name.
login
Type: System..::..String
The SQL Server login name (if not using trusted authentication).
password
Type: System..::..String
The SQL Server login's password (if not using trusted authentication).
trustedAuth
Type: System..::..Boolean
Whether or not to use trusted authentication.

See Also

DatabaseContext Class
DatabaseContext Members
CreateCommonDBConnection Overload
Pastel.Evolution Namespace
DatabaseContext..::..CreateConnection(String)


DatabaseContext.CreateConnection Method

[image] [image]

Pastel Evolution SDK
DatabaseContext..::..CreateConnection Method
DatabaseContext Class See Also Send Feedback

Overload List

Name | Description
CreateConnection(String) | Creates a connection to a Pastel Evolution database. Use this method if you have a connection string available; otherwise use one of the overloaded methods.
CreateConnection(String, String) | Creates a connection to the Evolution accounting database using trusted authentication.
CreateConnection(String, String, String, String, Boolean) | Creates a connection to the Evolution accounting database.

See Also

DatabaseContext Class
DatabaseContext Members


DatabaseContext.CreateConnection Method (String)

[image]

Pastel Evolution SDK
DatabaseContext..::..CreateConnection Method (String)
DatabaseContext Class See Also Send Feedback
Creates a connection to a Pastel Evolution database. Use this method if you have a connection string available; otherwise use one of the overloaded methods.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static void CreateConnection(
    string connectionString
)
Visual Basic
Public Shared Sub CreateConnection (
    connectionString As String
)

Parameters

connectionString
Type: System..::..String
The connection string used by SqlConnection.

See Also

DatabaseContext Class
DatabaseContext Members
CreateConnection Overload
Pastel.Evolution Namespace
DatabaseContext..::..CreateConnection(String, String, String, String, Boolean)


DatabaseContext.CreateConnection Method (String, String)

[image]

Pastel Evolution SDK
DatabaseContext..::..CreateConnection Method (String, String)
DatabaseContext Class See Also Send Feedback
Creates a connection to the Evolution accounting database using trusted authentication.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static void CreateConnection(
    string server,
    string database
)
Visual Basic
Public Shared Sub CreateConnection (
    server As String,
    database As String
)

Parameters

server
Type: System..::..String
The SQL server name, alias or IP address.
database
Type: System..::..String
The SQL database name.

See Also

DatabaseContext Class
DatabaseContext Members
CreateConnection Overload
Pastel.Evolution Namespace
DatabaseContext..::..CreateConnection(String)


DatabaseContext.CreateConnection Method (String, String, String, String, Boolean)

[image]

Pastel Evolution SDK
DatabaseContext..::..CreateConnection Method (String, String, String, String, Boolean)
DatabaseContext Class See Also Send Feedback
Creates a connection to the Evolution accounting database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static void CreateConnection(
    string server,
    string database,
    string login,
    string password,
    bool trustedAuth
)
Visual Basic
Public Shared Sub CreateConnection (
    server As String,
    database As String,
    login As String,
    password As String,
    trustedAuth As Boolean
)

Parameters

server
Type: System..::..String
The SQL server name, alias or IP address.
database
Type: System..::..String
The SQL database name.
login
Type: System..::..String
The SQL Server login name (if not using trusted authentication).
password
Type: System..::..String
The SQL Server login's password (if not using trusted authentication).
trustedAuth
Type: System..::..Boolean
Whether or not to use trusted authentication.

See Also

DatabaseContext Class
DatabaseContext Members
CreateConnection Overload
Pastel.Evolution Namespace
DatabaseContext..::..CreateConnection(String)


DatabaseContext.ExecuteCommandDataTable Method

[image] [image]

Pastel Evolution SDK
DatabaseContext..::..ExecuteCommandDataTable Method
DatabaseContext Class See Also Send Feedback

Overload List

Name | Description
ExecuteCommandDataTable(SqlCommand) |
ExecuteCommandDataTable(String) |
ExecuteCommandDataTable(SqlConnection, SqlTransaction, SqlCommand) |
ExecuteCommandDataTable(SqlConnection, SqlTransaction, String) |

See Also

DatabaseContext Class
DatabaseContext Members


DatabaseContext.ExecuteCommandDataTable Method (SqlCommand)

[image]

Pastel Evolution SDK
DatabaseContext..::..ExecuteCommandDataTable Method (SqlCommand)
DatabaseContext Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable ExecuteCommandDataTable(
    SqlCommand cmd
)
Visual Basic
Public Shared Function ExecuteCommandDataTable (
    cmd As SqlCommand
) As DataTable

Parameters

cmd
Type: System.Data.SqlClient..::..SqlCommand

Return Value

Type: DataTable

See Also

DatabaseContext Class
DatabaseContext Members
ExecuteCommandDataTable Overload


DatabaseContext.ExecuteCommandDataTable Method (String)

[image]

Pastel Evolution SDK
DatabaseContext..::..ExecuteCommandDataTable Method (String)
DatabaseContext Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable ExecuteCommandDataTable(
    string sql
)
Visual Basic
Public Shared Function ExecuteCommandDataTable (
    sql As String
) As DataTable

Parameters

sql
Type: System..::..String

Return Value

Type: DataTable

See Also

DatabaseContext Class
DatabaseContext Members
ExecuteCommandDataTable Overload


DatabaseContext.ExecuteCommandDataTable Method (SqlConnection, SqlTransaction, SqlCommand)

[image]

Pastel Evolution SDK
DatabaseContext..::..ExecuteCommandDataTable Method (SqlConnection, SqlTransaction, SqlCommand)
DatabaseContext Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable ExecuteCommandDataTable(
    SqlConnection connection,
    SqlTransaction transaction,
    SqlCommand cmd
)
Visual Basic
Public Shared Function ExecuteCommandDataTable (
    connection As SqlConnection,
    transaction As SqlTransaction,
    cmd As SqlCommand
) As DataTable

Parameters

connection
Type: System.Data.SqlClient..::..SqlConnection
transaction
Type: System.Data.SqlClient..::..SqlTransaction
cmd
Type: System.Data.SqlClient..::..SqlCommand

Return Value

Type: DataTable

See Also

DatabaseContext Class
DatabaseContext Members
ExecuteCommandDataTable Overload


DatabaseContext.ExecuteCommandDataTable Method (SqlConnection, SqlTransaction, String)

[image]

Pastel Evolution SDK
DatabaseContext..::..ExecuteCommandDataTable Method (SqlConnection, SqlTransaction, String)
DatabaseContext Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable ExecuteCommandDataTable(
    SqlConnection connection,
    SqlTransaction transaction,
    string sql
)
Visual Basic
Public Shared Function ExecuteCommandDataTable (
    connection As SqlConnection,
    transaction As SqlTransaction,
    sql As String
) As DataTable

Parameters

connection
Type: System.Data.SqlClient..::..SqlConnection
transaction
Type: System.Data.SqlClient..::..SqlTransaction
sql
Type: System..::..String

Return Value

Type: DataTable

See Also

DatabaseContext Class
DatabaseContext Members
ExecuteCommandDataTable Overload


DatabaseContext.ExecuteCommandNonQuery Method

[image] [image]

Pastel Evolution SDK
DatabaseContext..::..ExecuteCommandNonQuery Method
DatabaseContext Class See Also Send Feedback

Overload List

Name | Description
ExecuteCommandNonQuery(SqlCommand) |
ExecuteCommandNonQuery(String) |
ExecuteCommandNonQuery(SqlConnection, SqlTransaction, SqlCommand) |
ExecuteCommandNonQuery(SqlConnection, SqlTransaction, String) |

See Also

DatabaseContext Class
DatabaseContext Members


DatabaseContext.ExecuteCommandNonQuery Method (SqlCommand)

[image]

Pastel Evolution SDK
DatabaseContext..::..ExecuteCommandNonQuery Method (SqlCommand)
DatabaseContext Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int ExecuteCommandNonQuery(
    SqlCommand cmd
)
Visual Basic
Public Shared Function ExecuteCommandNonQuery (
    cmd As SqlCommand
) As Integer

Parameters

cmd
Type: System.Data.SqlClient..::..SqlCommand

Return Value

Type: Int32

See Also

DatabaseContext Class
DatabaseContext Members
ExecuteCommandNonQuery Overload


DatabaseContext.ExecuteCommandNonQuery Method (String)

[image]

Pastel Evolution SDK
DatabaseContext..::..ExecuteCommandNonQuery Method (String)
DatabaseContext Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static Object ExecuteCommandNonQuery(
    string sql
)
Visual Basic
Public Shared Function ExecuteCommandNonQuery (
    sql As String
) As Object

Parameters

sql
Type: System..::..String

Return Value

Type: Object

See Also

DatabaseContext Class
DatabaseContext Members
ExecuteCommandNonQuery Overload


DatabaseContext.ExecuteCommandNonQuery Method (SqlConnection, SqlTransaction, SqlCommand)

[image]

Pastel Evolution SDK
DatabaseContext..::..ExecuteCommandNonQuery Method (SqlConnection, SqlTransaction, SqlCommand)
DatabaseContext Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int ExecuteCommandNonQuery(
    SqlConnection connection,
    SqlTransaction transaction,
    SqlCommand cmd
)
Visual Basic
Public Shared Function ExecuteCommandNonQuery (
    connection As SqlConnection,
    transaction As SqlTransaction,
    cmd As SqlCommand
) As Integer

Parameters

connection
Type: System.Data.SqlClient..::..SqlConnection
transaction
Type: System.Data.SqlClient..::..SqlTransaction
cmd
Type: System.Data.SqlClient..::..SqlCommand

Return Value

Type: Int32

See Also

DatabaseContext Class
DatabaseContext Members
ExecuteCommandNonQuery Overload


DatabaseContext.ExecuteCommandNonQuery Method (SqlConnection, SqlTransaction, String)

[image]

Pastel Evolution SDK
DatabaseContext..::..ExecuteCommandNonQuery Method (SqlConnection, SqlTransaction, String)
DatabaseContext Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int ExecuteCommandNonQuery(
    SqlConnection connection,
    SqlTransaction transaction,
    string sql
)
Visual Basic
Public Shared Function ExecuteCommandNonQuery (
    connection As SqlConnection,
    transaction As SqlTransaction,
    sql As String
) As Integer

Parameters

connection
Type: System.Data.SqlClient..::..SqlConnection
transaction
Type: System.Data.SqlClient..::..SqlTransaction
sql
Type: System..::..String

Return Value

Type: Int32

See Also

DatabaseContext Class
DatabaseContext Members
ExecuteCommandNonQuery Overload


DatabaseContext.ExecuteCommandScalar Method

[image] [image]

Pastel Evolution SDK
DatabaseContext..::..ExecuteCommandScalar Method
DatabaseContext Class See Also Send Feedback

Overload List

Name | Description
ExecuteCommandScalar(SqlCommand) | Executes a command and returns the 1st value from 1st value. Will convert a return value of DBNull to null.
ExecuteCommandScalar(String) |
ExecuteCommandScalar(SqlConnection, SqlTransaction, SqlCommand) | Executes the query, and returns the first column of the first row in the result set returned by the query. Additional columns or rows are ignored.
ExecuteCommandScalar(SqlConnection, SqlTransaction, String) |

See Also

DatabaseContext Class
DatabaseContext Members


DatabaseContext.ExecuteCommandScalar Method (SqlCommand)

[image]

Pastel Evolution SDK
DatabaseContext..::..ExecuteCommandScalar Method (SqlCommand)
DatabaseContext Class See Also Send Feedback
Executes a command and returns the 1st value from 1st value. Will convert a return value of DBNull to null.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static Object ExecuteCommandScalar(
    SqlCommand cmd
)
Visual Basic
Public Shared Function ExecuteCommandScalar (
    cmd As SqlCommand
) As Object

Parameters

cmd
Type: System.Data.SqlClient..::..SqlCommand

Return Value

Type: Object

See Also

DatabaseContext Class
DatabaseContext Members
ExecuteCommandScalar Overload


DatabaseContext.ExecuteCommandScalar Method (String)

[image]

Pastel Evolution SDK
DatabaseContext..::..ExecuteCommandScalar Method (String)
DatabaseContext Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static Object ExecuteCommandScalar(
    string sql
)
Visual Basic
Public Shared Function ExecuteCommandScalar (
    sql As String
) As Object

Parameters

sql
Type: System..::..String

Return Value

Type: Object

See Also

DatabaseContext Class
DatabaseContext Members
ExecuteCommandScalar Overload


DatabaseContext.ExecuteCommandScalar Method (SqlConnection, SqlTransaction, SqlCommand)

[image]

Pastel Evolution SDK
DatabaseContext..::..ExecuteCommandScalar Method (SqlConnection, SqlTransaction, SqlCommand)
DatabaseContext Class See Also Send Feedback
Executes the query, and returns the first column of the first row in the result set returned by the query. Additional columns or rows are ignored.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static Object ExecuteCommandScalar(
    SqlConnection connection,
    SqlTransaction transaction,
    SqlCommand cmd
)
Visual Basic
Public Shared Function ExecuteCommandScalar (
    connection As SqlConnection,
    transaction As SqlTransaction,
    cmd As SqlCommand
) As Object

Parameters

connection
Type: System.Data.SqlClient..::..SqlConnection
transaction
Type: System.Data.SqlClient..::..SqlTransaction
cmd
Type: System.Data.SqlClient..::..SqlCommand

Return Value

Type: Object
The first column of the first row in the result set, or a null reference if the result set is empty. This function will return a null reference instead of a DBNull value.

See Also

DatabaseContext Class
DatabaseContext Members
ExecuteCommandScalar Overload


DatabaseContext.ExecuteCommandScalar Method (SqlConnection, SqlTransaction, String)

[image]

Pastel Evolution SDK
DatabaseContext..::..ExecuteCommandScalar Method (SqlConnection, SqlTransaction, String)
DatabaseContext Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static Object ExecuteCommandScalar(
    SqlConnection connection,
    SqlTransaction transaction,
    string sql
)
Visual Basic
Public Shared Function ExecuteCommandScalar (
    connection As SqlConnection,
    transaction As SqlTransaction,
    sql As String
) As Object

Parameters

connection
Type: System.Data.SqlClient..::..SqlConnection
transaction
Type: System.Data.SqlClient..::..SqlTransaction
sql
Type: System..::..String

Return Value

Type: Object

See Also

DatabaseContext Class
DatabaseContext Members
ExecuteCommandScalar Overload


DatabaseContext.ExecuteCommandSingleRow Method

[image] [image]

Pastel Evolution SDK
DatabaseContext..::..ExecuteCommandSingleRow Method
DatabaseContext Class See Also Send Feedback

Overload List

Name | Description
ExecuteCommandSingleRow(SqlCommand) |
ExecuteCommandSingleRow(String) |
ExecuteCommandSingleRow(SqlConnection, SqlTransaction, SqlCommand) |
ExecuteCommandSingleRow(SqlConnection, SqlTransaction, String) |

See Also

DatabaseContext Class
DatabaseContext Members


DatabaseContext.ExecuteCommandSingleRow Method (SqlCommand)

[image]

Pastel Evolution SDK
DatabaseContext..::..ExecuteCommandSingleRow Method (SqlCommand)
DatabaseContext Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataRow ExecuteCommandSingleRow(
    SqlCommand cmd
)
Visual Basic
Public Shared Function ExecuteCommandSingleRow (
    cmd As SqlCommand
) As DataRow

Parameters

cmd
Type: System.Data.SqlClient..::..SqlCommand

Return Value

Type: DataRow

See Also

DatabaseContext Class
DatabaseContext Members
ExecuteCommandSingleRow Overload


DatabaseContext.ExecuteCommandSingleRow Method (String)

[image]

Pastel Evolution SDK
DatabaseContext..::..ExecuteCommandSingleRow Method (String)
DatabaseContext Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataRow ExecuteCommandSingleRow(
    string cmd
)
Visual Basic
Public Shared Function ExecuteCommandSingleRow (
    cmd As String
) As DataRow

Parameters

cmd
Type: System..::..String

Return Value

Type: DataRow

See Also

DatabaseContext Class
DatabaseContext Members
ExecuteCommandSingleRow Overload


DatabaseContext.ExecuteCommandSingleRow Method (SqlConnection, SqlTransaction, SqlCommand)

[image]

Pastel Evolution SDK
DatabaseContext..::..ExecuteCommandSingleRow Method (SqlConnection, SqlTransaction, SqlCommand)
DatabaseContext Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataRow ExecuteCommandSingleRow(
    SqlConnection connection,
    SqlTransaction transaction,
    SqlCommand cmd
)
Visual Basic
Public Shared Function ExecuteCommandSingleRow (
    connection As SqlConnection,
    transaction As SqlTransaction,
    cmd As SqlCommand
) As DataRow

Parameters

connection
Type: System.Data.SqlClient..::..SqlConnection
transaction
Type: System.Data.SqlClient..::..SqlTransaction
cmd
Type: System.Data.SqlClient..::..SqlCommand

Return Value

Type: DataRow

See Also

DatabaseContext Class
DatabaseContext Members
ExecuteCommandSingleRow Overload


DatabaseContext.ExecuteCommandSingleRow Method (SqlConnection, SqlTransaction, String)

[image]

Pastel Evolution SDK
DatabaseContext..::..ExecuteCommandSingleRow Method (SqlConnection, SqlTransaction, String)
DatabaseContext Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataRow ExecuteCommandSingleRow(
    SqlConnection connection,
    SqlTransaction transaction,
    string sql
)
Visual Basic
Public Shared Function ExecuteCommandSingleRow (
    connection As SqlConnection,
    transaction As SqlTransaction,
    sql As String
) As DataRow

Parameters

connection
Type: System.Data.SqlClient..::..SqlConnection
transaction
Type: System.Data.SqlClient..::..SqlTransaction
sql
Type: System..::..String

Return Value

Type: DataRow

See Also

DatabaseContext Class
DatabaseContext Members
ExecuteCommandSingleRow Overload


DatabaseContext.GetProductVersion Method

[image]

Pastel Evolution SDK
DatabaseContext..::..GetProductVersion Method
DatabaseContext Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static EvolutionVersion GetProductVersion(
    SqlConnection connection
)
Visual Basic
Public Shared Function GetProductVersion (
    connection As SqlConnection
) As EvolutionVersion

Parameters

connection
Type: System.Data.SqlClient..::..SqlConnection

Return Value

Type: EvolutionVersion

See Also

DatabaseContext Class
DatabaseContext Members


DatabaseContext.Initialise Method

[image] [image]

Pastel Evolution SDK
DatabaseContext..::..Initialise Method
DatabaseContext Class See Also Send Feedback

Overload List

Name | Description
Initialise(String, String, String, String) | Initialises the database connections required by the SDK.
Initialise(String, String, String, String, String, String) | Initialises the database connections required by the SDK. This version of the method assumes the common database is called 'EvolutionCommon', is on the same server as the accounting database, and is able to uses the same login credentials.
Initialise(String, String, String, String, String, String, String) | Initialises the database connections required by the SDK. This version of the method assumes the common database is on the same server as the accounting database, and is able to uses the same login credentials.

See Also

DatabaseContext Class
DatabaseContext Members


DatabaseContext.Initialise Method (String, String, String, String)

[image]

Pastel Evolution SDK
DatabaseContext..::..Initialise Method (String, String, String, String)
DatabaseContext Class See Also Send Feedback
Initialises the database connections required by the SDK.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static void Initialise(
    string connectionString,
    string commonConnectionString,
    string serialNumber,
    string authKey
)
Visual Basic
Public Shared Sub Initialise (
    connectionString As String,
    commonConnectionString As String,
    serialNumber As String,
    authKey As String
)

Parameters

connectionString
Type: System..::..String
Connection string to use when connecting to the Evolution accounting database.
commonConnectionString
Type: System..::..String
Connection string to use when connecting to the common Evolution database.
serialNumber
Type: System..::..String
Your SDK serial number.
authKey
Type: System..::..String
Your SDK authorisation key.

See Also

DatabaseContext Class
DatabaseContext Members
Initialise Overload


DatabaseContext.Initialise Method (String, String, String, String, String, String)

[image]

Pastel Evolution SDK
DatabaseContext..::..Initialise Method (String, String, String, String, String, String)
DatabaseContext Class See Also Send Feedback
Initialises the database connections required by the SDK. This version of the method assumes the common database is called 'EvolutionCommon', is on the same server as the accounting database, and is able to uses the same login credentials.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static void Initialise(
    string database,
    string server,
    string user,
    string password,
    string serialNumber,
    string authKey
)
Visual Basic
Public Shared Sub Initialise (
    database As String,
    server As String,
    user As String,
    password As String,
    serialNumber As String,
    authKey As String
)

Parameters

database
Type: System..::..String
The Evolution accounting database.
server
Type: System..::..String
The SQL database server name or IP address.
user
Type: System..::..String
The SQL login.
password
Type: System..::..String
The SQL password.
serialNumber
Type: System..::..String
Your SDK serial number.
authKey
Type: System..::..String
Your SDK authorisation key.

See Also

DatabaseContext Class
DatabaseContext Members
Initialise Overload


DatabaseContext.Initialise Method (String, String, String, String, String, String, String)

[image]

Pastel Evolution SDK
DatabaseContext..::..Initialise Method (String, String, String, String, String, String, String)
DatabaseContext Class See Also Send Feedback
Initialises the database connections required by the SDK. This version of the method assumes the common database is on the same server as the accounting database, and is able to uses the same login credentials.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static void Initialise(
    string database,
    string commonDatabase,
    string server,
    string user,
    string password,
    string serialNumber,
    string authKey
)
Visual Basic
Public Shared Sub Initialise (
    database As String,
    commonDatabase As String,
    server As String,
    user As String,
    password As String,
    serialNumber As String,
    authKey As String
)

Parameters

database
Type: System..::..String
The Evolution accounting database.
commonDatabase
Type: System..::..String
The Evolution common database.
server
Type: System..::..String
The SQL database server name or IP address.
user
Type: System..::..String
The SQL login.
password
Type: System..::..String
The SQL password.
serialNumber
Type: System..::..String
Your SDK serial number.
authKey
Type: System..::..String
Your SDK authorisation key.

See Also

DatabaseContext Class
DatabaseContext Members
Initialise Overload


DatabaseContext.IsModuleActive Method

[image]

Pastel Evolution SDK
DatabaseContext..::..IsModuleActive Method
DatabaseContext Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static bool IsModuleActive(
    ModuleRegistration..::..Module module
)
Visual Basic
Public Shared Function IsModuleActive (
    module As ModuleRegistration..::..Module
) As Boolean

Parameters

module
Type: Pastel.Evolution.Internal..::..ModuleRegistration..::..Module

Return Value

Type: Boolean

See Also

DatabaseContext Class
DatabaseContext Members


DatabaseContext.RollbackTran Method

[image]

Pastel Evolution SDK
DatabaseContext..::..RollbackTran Method
DatabaseContext Class See Also Send Feedback
Quietly aborts the global transaction regardless of whether it is actually open.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static bool RollbackTran()
Visual Basic
Public Shared Function RollbackTran As Boolean

Return Value

Type: Boolean
True if a transaction was actually pending; false otherwise.

See Also

DatabaseContext Class
DatabaseContext Members


DatabaseContext.SetBranchContext Method

[image]

Pastel Evolution SDK
DatabaseContext..::..SetBranchContext Method
DatabaseContext Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static void SetBranchContext(
    int branchID
)
Visual Basic
Public Shared Sub SetBranchContext (
    branchID As Integer
)

Parameters

branchID
Type: System..::..Int32

See Also

DatabaseContext Class
DatabaseContext Members


DatabaseContext.SetLicense Method

[image]

Pastel Evolution SDK
DatabaseContext..::..SetLicense Method
DatabaseContext Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static void SetLicense(
    string serialNumber,
    string authKey
)
Visual Basic
Public Shared Sub SetLicense (
    serialNumber As String,
    authKey As String
)

Parameters

serialNumber
Type: System..::..String
authKey
Type: System..::..String

See Also

DatabaseContext Class
DatabaseContext Members


DatabaseContext Properties

[image] [image]

Pastel Evolution SDK
DatabaseContext Properties
DatabaseContext Class See Also Send Feedback

The DatabaseContext type exposes the following members.

Properties

Name | Description
_ContextBranch |
CommonDBConnection |
CommonDBVersion |
CompanyBranch |
CompanyID |
CompanyName |
CompatibleDatabaseVersion |
CurrentAgent |
CurrentDatabaseVersion |
DBConnection | The SqlConnection object used by all database calls in the API. Transaction scope is managed automatically using the BeginTran, CommitTran and RollBackTran methods
DBTransaction | The SQL transaction in progress (if any).
DefaultCommandTimeout |
ExpiryDate |
IsBranchOffline |
IsCommonConnectionOpen |
IsConnectionOpen |
IsTransactionPending |
RegisteredUsers |

See Also

DatabaseContext Class


DatabaseContext._ContextBranch Property

[image]

Pastel Evolution SDK
DatabaseContext..::.._ContextBranch Property
DatabaseContext Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static Branch _ContextBranch { get; internal set; }
Visual Basic
Public Shared Property _ContextBranch As Branch
    Get
    Friend Set

Property Value

Type: Branch

See Also

DatabaseContext Class
DatabaseContext Members


DatabaseContext.CommonDBConnection Property

[image]

Pastel Evolution SDK
DatabaseContext..::..CommonDBConnection Property
DatabaseContext Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static SqlConnection CommonDBConnection { get; }
Visual Basic
Public Shared ReadOnly Property CommonDBConnection As SqlConnection
    Get

Property Value

Type: SqlConnection

See Also

DatabaseContext Class
DatabaseContext Members


DatabaseContext.CommonDBVersion Property

[image]

Pastel Evolution SDK
DatabaseContext..::..CommonDBVersion Property
DatabaseContext Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int CommonDBVersion { get; internal set; }
Visual Basic
Public Shared Property CommonDBVersion As Integer
    Get
    Friend Set

Property Value

Type: Int32

See Also

DatabaseContext Class
DatabaseContext Members


DatabaseContext.CompanyBranch Property

[image]

Pastel Evolution SDK
DatabaseContext..::..CompanyBranch Property
DatabaseContext Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static Branch CompanyBranch { get; private set; }
Visual Basic
Public Shared Property CompanyBranch As Branch
    Get
    Private Set

Property Value

Type: Branch

See Also

DatabaseContext Class
DatabaseContext Members


DatabaseContext.CompanyID Property

[image]

Pastel Evolution SDK
DatabaseContext..::..CompanyID Property
DatabaseContext Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static string CompanyID { get; internal set; }
Visual Basic
Public Shared Property CompanyID As String
    Get
    Friend Set

Property Value

Type: String

See Also

DatabaseContext Class
DatabaseContext Members


DatabaseContext.CompanyName Property

[image]

Pastel Evolution SDK
DatabaseContext..::..CompanyName Property
DatabaseContext Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static string CompanyName { get; }
Visual Basic
Public Shared ReadOnly Property CompanyName As String
    Get

Property Value

Type: String

See Also

DatabaseContext Class
DatabaseContext Members


DatabaseContext.CompatibleDatabaseVersion Property

[image]

Pastel Evolution SDK
DatabaseContext..::..CompatibleDatabaseVersion Property
DatabaseContext Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static string CompatibleDatabaseVersion { get; }
Visual Basic
Public Shared ReadOnly Property CompatibleDatabaseVersion As String
    Get

Property Value

Type: String

See Also

DatabaseContext Class
DatabaseContext Members


DatabaseContext.CurrentAgent Property

[image]

Pastel Evolution SDK
DatabaseContext..::..CurrentAgent Property
DatabaseContext Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static Agent CurrentAgent { get; set; }
Visual Basic
Public Shared Property CurrentAgent As Agent
    Get
    Set

Property Value

Type: Agent

See Also

DatabaseContext Class
DatabaseContext Members


DatabaseContext.CurrentDatabaseVersion Property

[image]

Pastel Evolution SDK
DatabaseContext..::..CurrentDatabaseVersion Property
DatabaseContext Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static string CurrentDatabaseVersion { get; internal set; }
Visual Basic
Public Shared Property CurrentDatabaseVersion As String
    Get
    Friend Set

Property Value

Type: String

See Also

DatabaseContext Class
DatabaseContext Members


DatabaseContext.DBConnection Property

[image]

Pastel Evolution SDK
DatabaseContext..::..DBConnection Property
DatabaseContext Class See Also Send Feedback
The SqlConnection object used by all database calls in the API. Transaction scope is managed automatically using the BeginTran, CommitTran and RollBackTran methods

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static SqlConnection DBConnection { get; }
Visual Basic
Public Shared ReadOnly Property DBConnection As SqlConnection
    Get

Property Value

Type: SqlConnection

See Also

DatabaseContext Class
DatabaseContext Members


DatabaseContext.DBTransaction Property

[image]

Pastel Evolution SDK
DatabaseContext..::..DBTransaction Property
DatabaseContext Class See Also Send Feedback
The SQL transaction in progress (if any).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static SqlTransaction DBTransaction { get; }
Visual Basic
Public Shared ReadOnly Property DBTransaction As SqlTransaction
    Get

Property Value

Type: SqlTransaction

See Also

DatabaseContext Class
DatabaseContext Members


DatabaseContext.DefaultCommandTimeout Property

[image]

Pastel Evolution SDK
DatabaseContext..::..DefaultCommandTimeout Property
DatabaseContext Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int DefaultCommandTimeout { get; set; }
Visual Basic
Public Shared Property DefaultCommandTimeout As Integer
    Get
    Set

Property Value

Type: Int32

See Also

DatabaseContext Class
DatabaseContext Members


DatabaseContext.ExpiryDate Property

[image]

Pastel Evolution SDK
DatabaseContext..::..ExpiryDate Property
DatabaseContext Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DateTime ExpiryDate { get; }
Visual Basic
Public Shared ReadOnly Property ExpiryDate As DateTime
    Get

Property Value

Type: DateTime

See Also

DatabaseContext Class
DatabaseContext Members


DatabaseContext.IsBranchOffline Property

[image]

Pastel Evolution SDK
DatabaseContext..::..IsBranchOffline Property
DatabaseContext Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static bool IsBranchOffline { get; private set; }
Visual Basic
Public Shared Property IsBranchOffline As Boolean
    Get
    Private Set

Property Value

Type: Boolean

See Also

DatabaseContext Class
DatabaseContext Members


DatabaseContext.IsCommonConnectionOpen Property

[image]

Pastel Evolution SDK
DatabaseContext..::..IsCommonConnectionOpen Property
DatabaseContext Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static bool IsCommonConnectionOpen { get; }
Visual Basic
Public Shared ReadOnly Property IsCommonConnectionOpen As Boolean
    Get

Property Value

Type: Boolean

See Also

DatabaseContext Class
DatabaseContext Members


DatabaseContext.IsConnectionOpen Property

[image]

Pastel Evolution SDK
DatabaseContext..::..IsConnectionOpen Property
DatabaseContext Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static bool IsConnectionOpen { get; }
Visual Basic
Public Shared ReadOnly Property IsConnectionOpen As Boolean
    Get

Property Value

Type: Boolean

See Also

DatabaseContext Class
DatabaseContext Members


DatabaseContext.IsTransactionPending Property

[image]

Pastel Evolution SDK
DatabaseContext..::..IsTransactionPending Property
DatabaseContext Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static bool IsTransactionPending { get; }
Visual Basic
Public Shared ReadOnly Property IsTransactionPending As Boolean
    Get

Property Value

Type: Boolean

See Also

DatabaseContext Class
DatabaseContext Members


DatabaseContext.RegisteredUsers Property

[image]

Pastel Evolution SDK
DatabaseContext..::..RegisteredUsers Property
DatabaseContext Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int RegisteredUsers { get; }
Visual Basic
Public Shared ReadOnly Property RegisteredUsers As Integer
    Get

Property Value

Type: Int32

See Also

DatabaseContext Class
DatabaseContext Members


Defaults Class

[image]

Pastel Evolution SDK
Defaults Class
Members See Also Send Feedback
Contains various global static methods and properties related to the basic functionality of the SDK.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class Defaults
Visual Basic
Public Class Defaults

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..Defaults

See Also

Defaults Members


Defaults Members

[image] [image]

Pastel Evolution SDK
Defaults Members
Defaults Class Constructors Methods Fields Properties See Also Send Feedback

The Defaults type exposes the following members.

Constructors

 | Name | Description
Public method | Defaults | Initializes a new instance of the Defaults class

Methods

 | Name | Description
 | _GenerateAccountCode |
 | AddCommandToStream |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetGLPeriod | Gets the period for the transaction date specified.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetModulesRegistered |
 | GetNextIncidentReference | Permanently reserves an incident reference
 | GetNextInvDocNo | Reserves and returns the next available sales order number. If automatic numbering is not used, an empty string is returned.
 | GetNextJobNumber | Permanently reserves an incident reference
 | GetNextOpportunityReference | Permanently reserves an incident reference
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReloadModuleDefaults |
 | StartNewBatch | Forces an audit number increment within the same transaction batch. NOTE: When committing a transaction using Defaults.CommitTran, the audit number will automatically be incremented, so use this function ONLY when you need have different audit numbers in the same transaction scope
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
USERNAME | The internal user name assigned to posted transactions.

Properties

Name | Description
AccountsPayable |
AccountsReceivable |
AssemblyPath |
AssemblyVersion |
Audit | Reserves and returns the next audit number "on the fly".
ContactManagement |
CostVarianceAccountID |
CreditorZeroTaxRate |
DebtorsZeroTaxRate |
DefaultPriceList |
DocumentStoragePath | Obsolete.
GeneralLedger |
Inventory |
InventoryCostingMethod | The inventory costing method configured in Evolution's inventory defaults.
InventoryIntegrationMethod | The inventory integration method configured in Evolution's inventory defaults.
JobCosting |
NullDate |
OutputSqlToStream |
PurchasesCostVarianceAccountID |
PurchasesCreditNoteTransactionCode | The return to supplier transaction code as configured in Evolution's inventory defaults.
PurchasesGrvTransactionCode | The goods received note transaction code as configured in Evolution's inventory defaults.
PurchasesInvoiceTransactionCode | The goods received note transaction code as configured in Evolution's inventory defaults.
RegisteredUsers |
RegistrationExpiryDate |
SalesCreditNoteTransactionCode | The credit note transaction code as configured in Evolution's inventory defaults.
SalesInvoiceTransactionCode | The invoice transaction code as configured in Evolution's inventory defaults.
SqlOutputStream |
WarehouseTransferTransactionCode | The warehouse transfer transaction code as configured in Evolution's inventory defaults.

See Also

Defaults Class


Defaults Constructor

[image]

Pastel Evolution SDK
Defaults Constructor
Defaults Class See Also Send Feedback
Initializes a new instance of the Defaults class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Defaults()
Visual Basic
Public Sub New

See Also

Defaults Class
Defaults Members


Defaults Fields

[image] [image]

Pastel Evolution SDK
Defaults Fields
Defaults Class See Also Send Feedback

The Defaults type exposes the following members.

Fields

Name | Description
USERNAME | The internal user name assigned to posted transactions.

See Also

Defaults Class


Defaults.USERNAME Field

[image]

Pastel Evolution SDK
Defaults..::..USERNAME Field
Defaults Class See Also Send Feedback
The internal user name assigned to posted transactions.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public const string USERNAME
Visual Basic
Public Const USERNAME As String

Field Value

Type: String

See Also

Defaults Class
Defaults Members


Defaults Methods

[image] [image]

Pastel Evolution SDK
Defaults Methods
Defaults Class See Also Send Feedback

The Defaults type exposes the following members.

Methods

 | Name | Description
 | _GenerateAccountCode |
 | AddCommandToStream |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetGLPeriod | Gets the period for the transaction date specified.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetModulesRegistered |
 | GetNextIncidentReference | Permanently reserves an incident reference
 | GetNextInvDocNo | Reserves and returns the next available sales order number. If automatic numbering is not used, an empty string is returned.
 | GetNextJobNumber | Permanently reserves an incident reference
 | GetNextOpportunityReference | Permanently reserves an incident reference
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReloadModuleDefaults |
 | StartNewBatch | Forces an audit number increment within the same transaction batch. NOTE: When committing a transaction using Defaults.CommitTran, the audit number will automatically be incremented, so use this function ONLY when you need have different audit numbers in the same transaction scope
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Defaults Class


Defaults._GenerateAccountCode Method

[image]

Pastel Evolution SDK
Defaults..::.._GenerateAccountCode Method
Defaults Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static string _GenerateAccountCode(
    string table,
    string field,
    int prefixLength,
    int padLength,
    string criteria,
    bool capitalise
)
Visual Basic
Public Shared Function _GenerateAccountCode (
    table As String,
    field As String,
    prefixLength As Integer,
    padLength As Integer,
    criteria As String,
    capitalise As Boolean
) As String

Parameters

table
Type: System..::..String
field
Type: System..::..String
prefixLength
Type: System..::..Int32
padLength
Type: System..::..Int32
criteria
Type: System..::..String
capitalise
Type: System..::..Boolean

Return Value

Type: String

See Also

Defaults Class
Defaults Members


Defaults.AddCommandToStream Method

[image]

Pastel Evolution SDK
Defaults..::..AddCommandToStream Method
Defaults Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static void AddCommandToStream(
    SqlCommand cmd
)
Visual Basic
Public Shared Sub AddCommandToStream (
    cmd As SqlCommand
)

Parameters

cmd
Type: System.Data.SqlClient..::..SqlCommand

See Also

Defaults Class
Defaults Members


Defaults.GetGLPeriod Method

[image]

Pastel Evolution SDK
Defaults..::..GetGLPeriod Method
Defaults Class See Also Send Feedback
Gets the period for the transaction date specified.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int GetGLPeriod(
    DateTime tranDate,
    bool errorIfBlocked
)
Visual Basic
Public Shared Function GetGLPeriod (
    tranDate As DateTime,
    errorIfBlocked As Boolean
) As Integer

Parameters

tranDate
Type: System..::..DateTime
The date for which the corresponding period is to be located.
errorIfBlocked
Type: System..::..Boolean
Whether or not an exception needs to be thrown if the applicable period is blocked.

Return Value

Type: Int32
GL Period ID: 1-12 for 1st year periods, 2-24 for 2nd, etc.

See Also

Defaults Class
Defaults Members


Defaults.GetModulesRegistered Method

[image]

Pastel Evolution SDK
Defaults..::..GetModulesRegistered Method
Defaults Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static string GetModulesRegistered()
Visual Basic
Public Shared Function GetModulesRegistered As String

Return Value

Type: String

See Also

Defaults Class
Defaults Members


Defaults.GetNextIncidentReference Method

[image]

Pastel Evolution SDK
Defaults..::..GetNextIncidentReference Method
Defaults Class See Also Send Feedback
Permanently reserves an incident reference

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static string GetNextIncidentReference()
Visual Basic
Public Shared Function GetNextIncidentReference As String

Return Value

Type: String

See Also

Defaults Class
Defaults Members


Defaults.GetNextInvDocNo Method

[image]

Pastel Evolution SDK
Defaults..::..GetNextInvDocNo Method
Defaults Class See Also Send Feedback
Reserves and returns the next available sales order number. If automatic numbering is not used, an empty string is returned.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static string GetNextInvDocNo(
    DocumentType docType,
    DocumentState docState
)
Visual Basic
Public Shared Function GetNextInvDocNo (
    docType As DocumentType,
    docState As DocumentState
) As String

Parameters

docType
Type: Pastel.Evolution..::..DocumentType
docState
Type: Pastel.Evolution..::..DocumentState

Return Value

Type: String

See Also

Defaults Class
Defaults Members


Defaults.GetNextJobNumber Method

[image]

Pastel Evolution SDK
Defaults..::..GetNextJobNumber Method
Defaults Class See Also Send Feedback
Permanently reserves an incident reference

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static string GetNextJobNumber()
Visual Basic
Public Shared Function GetNextJobNumber As String

Return Value

Type: String

See Also

Defaults Class
Defaults Members


Defaults.GetNextOpportunityReference Method

[image]

Pastel Evolution SDK
Defaults..::..GetNextOpportunityReference Method
Defaults Class See Also Send Feedback
Permanently reserves an incident reference

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static string GetNextOpportunityReference()
Visual Basic
Public Shared Function GetNextOpportunityReference As String

Return Value

Type: String

See Also

Defaults Class
Defaults Members


Defaults.ReloadModuleDefaults Method

[image]

Pastel Evolution SDK
Defaults..::..ReloadModuleDefaults Method
Defaults Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static void ReloadModuleDefaults()
Visual Basic
Public Shared Sub ReloadModuleDefaults

See Also

Defaults Class
Defaults Members


Defaults.StartNewBatch Method

[image]

Pastel Evolution SDK
Defaults..::..StartNewBatch Method
Defaults Class See Also Send Feedback
Forces an audit number increment within the same transaction batch. NOTE: When committing a transaction using Defaults.CommitTran, the audit number will automatically be incremented, so use this function ONLY when you need have different audit numbers in the same transaction scope

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static void StartNewBatch()
Visual Basic
Public Shared Sub StartNewBatch

See Also

Defaults Class
Defaults Members


Defaults Properties

[image] [image]

Pastel Evolution SDK
Defaults Properties
Defaults Class See Also Send Feedback

The Defaults type exposes the following members.

Properties

Name | Description
AccountsPayable |
AccountsReceivable |
AssemblyPath |
AssemblyVersion |
Audit | Reserves and returns the next audit number "on the fly".
ContactManagement |
CostVarianceAccountID |
CreditorZeroTaxRate |
DebtorsZeroTaxRate |
DefaultPriceList |
DocumentStoragePath | Obsolete.
GeneralLedger |
Inventory |
InventoryCostingMethod | The inventory costing method configured in Evolution's inventory defaults.
InventoryIntegrationMethod | The inventory integration method configured in Evolution's inventory defaults.
JobCosting |
NullDate |
OutputSqlToStream |
PurchasesCostVarianceAccountID |
PurchasesCreditNoteTransactionCode | The return to supplier transaction code as configured in Evolution's inventory defaults.
PurchasesGrvTransactionCode | The goods received note transaction code as configured in Evolution's inventory defaults.
PurchasesInvoiceTransactionCode | The goods received note transaction code as configured in Evolution's inventory defaults.
RegisteredUsers |
RegistrationExpiryDate |
SalesCreditNoteTransactionCode | The credit note transaction code as configured in Evolution's inventory defaults.
SalesInvoiceTransactionCode | The invoice transaction code as configured in Evolution's inventory defaults.
SqlOutputStream |
WarehouseTransferTransactionCode | The warehouse transfer transaction code as configured in Evolution's inventory defaults.

See Also

Defaults Class


Defaults.AccountsPayable Property

[image]

Pastel Evolution SDK
Defaults..::..AccountsPayable Property
Defaults Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static APDefaults AccountsPayable { get; }
Visual Basic
Public Shared ReadOnly Property AccountsPayable As APDefaults
    Get

Property Value

Type: APDefaults

See Also

Defaults Class
Defaults Members


Defaults.AccountsReceivable Property

[image]

Pastel Evolution SDK
Defaults..::..AccountsReceivable Property
Defaults Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static ARDefaults AccountsReceivable { get; }
Visual Basic
Public Shared ReadOnly Property AccountsReceivable As ARDefaults
    Get

Property Value

Type: ARDefaults

See Also

Defaults Class
Defaults Members


Defaults.AssemblyPath Property

[image]

Pastel Evolution SDK
Defaults..::..AssemblyPath Property
Defaults Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static string AssemblyPath { get; internal set; }
Visual Basic
Public Shared Property AssemblyPath As String
    Get
    Friend Set

Property Value

Type: String

See Also

Defaults Class
Defaults Members


Defaults.AssemblyVersion Property

[image]

Pastel Evolution SDK
Defaults..::..AssemblyVersion Property
Defaults Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static string AssemblyVersion { get; internal set; }
Visual Basic
Public Shared Property AssemblyVersion As String
    Get
    Friend Set

Property Value

Type: String

See Also

Defaults Class
Defaults Members


Defaults.Audit Property

[image]

Pastel Evolution SDK
Defaults..::..Audit Property
Defaults Class See Also Send Feedback
Reserves and returns the next audit number "on the fly".

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static string Audit { get; }
Visual Basic
Public Shared ReadOnly Property Audit As String
    Get

Property Value

Type: String

See Also

Defaults Class
Defaults Members


Defaults.ContactManagement Property

[image]

Pastel Evolution SDK
Defaults..::..ContactManagement Property
Defaults Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static ContactManagementDefaults ContactManagement { get; }
Visual Basic
Public Shared ReadOnly Property ContactManagement As ContactManagementDefaults
    Get

Property Value

Type: ContactManagementDefaults

See Also

Defaults Class
Defaults Members


Defaults.CostVarianceAccountID Property

[image]

Pastel Evolution SDK
Defaults..::..CostVarianceAccountID Property
Defaults Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int CostVarianceAccountID { get; }
Visual Basic
Public Shared ReadOnly Property CostVarianceAccountID As Integer
    Get

Property Value

Type: Int32

See Also

Defaults Class
Defaults Members


Defaults.CreditorZeroTaxRate Property

[image]

Pastel Evolution SDK
Defaults..::..CreditorZeroTaxRate Property
Defaults Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static TaxRate CreditorZeroTaxRate { get; }
Visual Basic
Public Shared ReadOnly Property CreditorZeroTaxRate As TaxRate
    Get

Property Value

Type: TaxRate

See Also

Defaults Class
Defaults Members


Defaults.DebtorsZeroTaxRate Property

[image]

Pastel Evolution SDK
Defaults..::..DebtorsZeroTaxRate Property
Defaults Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static TaxRate DebtorsZeroTaxRate { get; }
Visual Basic
Public Shared ReadOnly Property DebtorsZeroTaxRate As TaxRate
    Get

Property Value

Type: TaxRate

See Also

Defaults Class
Defaults Members


Defaults.DefaultPriceList Property

[image]

Pastel Evolution SDK
Defaults..::..DefaultPriceList Property
Defaults Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static PriceList DefaultPriceList { get; }
Visual Basic
Public Shared ReadOnly Property DefaultPriceList As PriceList
    Get

Property Value

Type: PriceList

See Also

Defaults Class
Defaults Members


Defaults.DocumentStoragePath Property

[image]

Pastel Evolution SDK
Defaults..::..DocumentStoragePath Property
Defaults Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
[ObsoleteAttribute("Deprecated. Use Defaults.ContactManagement.DocumentStoragePath instead.")]
public static string DocumentStoragePath { get; }
Visual Basic
<ObsoleteAttribute("Deprecated. Use Defaults.ContactManagement.DocumentStoragePath instead.")>
Public Shared ReadOnly Property DocumentStoragePath As String
    Get

Property Value

Type: String

See Also

Defaults Class
Defaults Members


Defaults.GeneralLedger Property

[image]

Pastel Evolution SDK
Defaults..::..GeneralLedger Property
Defaults Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static GLDefaults GeneralLedger { get; }
Visual Basic
Public Shared ReadOnly Property GeneralLedger As GLDefaults
    Get

Property Value

Type: GLDefaults

See Also

Defaults Class
Defaults Members


Defaults.Inventory Property

[image]

Pastel Evolution SDK
Defaults..::..Inventory Property
Defaults Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static InventoryDefaults Inventory { get; }
Visual Basic
Public Shared ReadOnly Property Inventory As InventoryDefaults
    Get

Property Value

Type: InventoryDefaults

See Also

Defaults Class
Defaults Members


Defaults.InventoryCostingMethod Property

[image]

Pastel Evolution SDK
Defaults..::..InventoryCostingMethod Property
Defaults Class See Also Send Feedback
The inventory costing method configured in Evolution's inventory defaults.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static InventoryCostingMethod InventoryCostingMethod { get; }
Visual Basic
Public Shared ReadOnly Property InventoryCostingMethod As InventoryCostingMethod
    Get

Property Value

Type: InventoryCostingMethod

See Also

Defaults Class
Defaults Members


Defaults.InventoryIntegrationMethod Property

[image]

Pastel Evolution SDK
Defaults..::..InventoryIntegrationMethod Property
Defaults Class See Also Send Feedback
The inventory integration method configured in Evolution's inventory defaults.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static InventoryIntegrationMethod InventoryIntegrationMethod { get; }
Visual Basic
Public Shared ReadOnly Property InventoryIntegrationMethod As InventoryIntegrationMethod
    Get

Property Value

Type: InventoryIntegrationMethod

See Also

Defaults Class
Defaults Members


Defaults.JobCosting Property

[image]

Pastel Evolution SDK
Defaults..::..JobCosting Property
Defaults Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static JobDefaults JobCosting { get; }
Visual Basic
Public Shared ReadOnly Property JobCosting As JobDefaults
    Get

Property Value

Type: JobDefaults

See Also

Defaults Class
Defaults Members


Defaults.NullDate Property

[image]

Pastel Evolution SDK
Defaults..::..NullDate Property
Defaults Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DateTime NullDate { get; }
Visual Basic
Public Shared ReadOnly Property NullDate As DateTime
    Get

Property Value

Type: DateTime

See Also

Defaults Class
Defaults Members


Defaults.OutputSqlToStream Property

[image]

Pastel Evolution SDK
Defaults..::..OutputSqlToStream Property
Defaults Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static bool OutputSqlToStream { get; set; }
Visual Basic
Public Shared Property OutputSqlToStream As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

Defaults Class
Defaults Members


Defaults.PurchasesCostVarianceAccountID Property

[image]

Pastel Evolution SDK
Defaults..::..PurchasesCostVarianceAccountID Property
Defaults Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int PurchasesCostVarianceAccountID { get; }
Visual Basic
Public Shared ReadOnly Property PurchasesCostVarianceAccountID As Integer
    Get

Property Value

Type: Int32

See Also

Defaults Class
Defaults Members


Defaults.PurchasesCreditNoteTransactionCode Property

[image]

Pastel Evolution SDK
Defaults..::..PurchasesCreditNoteTransactionCode Property
Defaults Class See Also Send Feedback
The return to supplier transaction code as configured in Evolution's inventory defaults.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static TransactionCode PurchasesCreditNoteTransactionCode { get; }
Visual Basic
Public Shared ReadOnly Property PurchasesCreditNoteTransactionCode As TransactionCode
    Get

Property Value

Type: TransactionCode

See Also

Defaults Class
Defaults Members


Defaults.PurchasesGrvTransactionCode Property

[image]

Pastel Evolution SDK
Defaults..::..PurchasesGrvTransactionCode Property
Defaults Class See Also Send Feedback
The goods received note transaction code as configured in Evolution's inventory defaults.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static TransactionCode PurchasesGrvTransactionCode { get; }
Visual Basic
Public Shared ReadOnly Property PurchasesGrvTransactionCode As TransactionCode
    Get

Property Value

Type: TransactionCode

See Also

Defaults Class
Defaults Members


Defaults.PurchasesInvoiceTransactionCode Property

[image]

Pastel Evolution SDK
Defaults..::..PurchasesInvoiceTransactionCode Property
Defaults Class See Also Send Feedback
The goods received note transaction code as configured in Evolution's inventory defaults.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static TransactionCode PurchasesInvoiceTransactionCode { get; }
Visual Basic
Public Shared ReadOnly Property PurchasesInvoiceTransactionCode As TransactionCode
    Get

Property Value

Type: TransactionCode

See Also

Defaults Class
Defaults Members


Defaults.RegisteredUsers Property

[image]

Pastel Evolution SDK
Defaults..::..RegisteredUsers Property
Defaults Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int RegisteredUsers { get; }
Visual Basic
Public Shared ReadOnly Property RegisteredUsers As Integer
    Get

Property Value

Type: Int32

See Also

Defaults Class
Defaults Members


Defaults.RegistrationExpiryDate Property

[image]

Pastel Evolution SDK
Defaults..::..RegistrationExpiryDate Property
Defaults Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DateTime RegistrationExpiryDate { get; }
Visual Basic
Public Shared ReadOnly Property RegistrationExpiryDate As DateTime
    Get

Property Value

Type: DateTime

See Also

Defaults Class
Defaults Members


Defaults.SalesCreditNoteTransactionCode Property

[image]

Pastel Evolution SDK
Defaults..::..SalesCreditNoteTransactionCode Property
Defaults Class See Also Send Feedback
The credit note transaction code as configured in Evolution's inventory defaults.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static TransactionCode SalesCreditNoteTransactionCode { get; }
Visual Basic
Public Shared ReadOnly Property SalesCreditNoteTransactionCode As TransactionCode
    Get

Property Value

Type: TransactionCode

See Also

Defaults Class
Defaults Members


Defaults.SalesInvoiceTransactionCode Property

[image]

Pastel Evolution SDK
Defaults..::..SalesInvoiceTransactionCode Property
Defaults Class See Also Send Feedback
The invoice transaction code as configured in Evolution's inventory defaults.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static TransactionCode SalesInvoiceTransactionCode { get; }
Visual Basic
Public Shared ReadOnly Property SalesInvoiceTransactionCode As TransactionCode
    Get

Property Value

Type: TransactionCode

See Also

Defaults Class
Defaults Members


Defaults.SqlOutputStream Property

[image]

Pastel Evolution SDK
Defaults..::..SqlOutputStream Property
Defaults Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static MemoryStream SqlOutputStream { get; set; }
Visual Basic
Public Shared Property SqlOutputStream As MemoryStream
    Get
    Set

Property Value

Type: MemoryStream

See Also

Defaults Class
Defaults Members


Defaults.WarehouseTransferTransactionCode Property

[image]

Pastel Evolution SDK
Defaults..::..WarehouseTransferTransactionCode Property
Defaults Class See Also Send Feedback
The warehouse transfer transaction code as configured in Evolution's inventory defaults.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static TransactionCode WarehouseTransferTransactionCode { get; }
Visual Basic
Public Shared ReadOnly Property WarehouseTransferTransactionCode As TransactionCode
    Get

Property Value

Type: TransactionCode

See Also

Defaults Class
Defaults Members


DeliveryAddress Class

[image]

Pastel Evolution SDK
DeliveryAddress Class
Members See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class DeliveryAddress : BranchedRecordBase
Visual Basic
Public Class DeliveryAddress
    Inherits BranchedRecordBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..DeliveryAddress

See Also

DeliveryAddress Members


DeliveryAddress Members

[image] [image]

Pastel Evolution SDK
DeliveryAddress Members
DeliveryAddress Class Constructors Methods Fields Properties See Also Send Feedback

The DeliveryAddress type exposes the following members.

Constructors

 | Name | Description
Public method | DeliveryAddress()()()() | Creates a new instance of a delivery address.
Public method | DeliveryAddress(Int32) | Creates a new instance of a delivery address.

Methods

 | Name | Description
 | _Select(String) | Experimental Method
 | _Select(String, String) | Experimental Method
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List(String) |
 | List(String, String) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | Account |
Public property | AccountID |
Public property | Address | Gets or sets the delivery address record's actual address.
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | CellPhone |
Public property | Code | Gets or sets the delivery address code.
Public property | CodeID |
Public property | Description |
Public property | EmailAddress |
Public property | Fax |
Public property | ID | (Overrides RecordBase..::..ID.)
Public property | IsDefault |
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | Telephone1 |
Public property | Telephone2 |

See Also

DeliveryAddress Class


DeliveryAddress Constructor

[image] [image]

Pastel Evolution SDK
DeliveryAddress Constructor
DeliveryAddress Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DeliveryAddress()()()() | Creates a new instance of a delivery address.
Public method | DeliveryAddress(Int32) | Creates a new instance of a delivery address.

See Also

DeliveryAddress Class
DeliveryAddress Members


DeliveryAddress Constructor

[image]

Pastel Evolution SDK
DeliveryAddress Constructor
DeliveryAddress Class See Also Send Feedback
Creates a new instance of a delivery address.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DeliveryAddress()
Visual Basic
Public Sub New

See Also

DeliveryAddress Class
DeliveryAddress Members
DeliveryAddress Overload


DeliveryAddress Constructor (Int32)

[image]

Pastel Evolution SDK
DeliveryAddress Constructor (Int32)
DeliveryAddress Class See Also Send Feedback
Creates a new instance of a delivery address.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DeliveryAddress(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32
Specifies the id of the existing record.

See Also

DeliveryAddress Class
DeliveryAddress Members
DeliveryAddress Overload


DeliveryAddress Fields

[image] [image]

Pastel Evolution SDK
DeliveryAddress Fields
DeliveryAddress Class See Also Send Feedback

The DeliveryAddress type exposes the following members.

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

DeliveryAddress Class


DeliveryAddress Methods

[image] [image]

Pastel Evolution SDK
DeliveryAddress Methods
DeliveryAddress Class See Also Send Feedback

The DeliveryAddress type exposes the following members.

Methods

 | Name | Description
 | _Select(String) | Experimental Method
 | _Select(String, String) | Experimental Method
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List(String) |
 | List(String, String) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

DeliveryAddress Class


DeliveryAddress._Select Method

[image] [image]

Pastel Evolution SDK
DeliveryAddress..::.._Select Method
DeliveryAddress Class See Also Send Feedback

Overload List

Name | Description
_Select(String) | Experimental Method
_Select(String, String) | Experimental Method

See Also

DeliveryAddress Class
DeliveryAddress Members


DeliveryAddress._Select Method (String)

[image]

Pastel Evolution SDK
DeliveryAddress..::.._Select Method (String)
DeliveryAddress Class See Also Send Feedback
Experimental Method

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DeliveryAddress[] _Select(
    string criteria
)
Visual Basic
Public Shared Function _Select (
    criteria As String
) As DeliveryAddress()

Parameters

criteria
Type: System..::..String

Return Value

Type: array< DeliveryAddress >[]()[][]

See Also

DeliveryAddress Class
DeliveryAddress Members
_Select Overload


DeliveryAddress._Select Method (String, String)

[image]

Pastel Evolution SDK
DeliveryAddress..::.._Select Method (String, String)
DeliveryAddress Class See Also Send Feedback
Experimental Method

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DeliveryAddress[] _Select(
    string criteria,
    string sortOrder
)
Visual Basic
Public Shared Function _Select (
    criteria As String,
    sortOrder As String
) As DeliveryAddress()

Parameters

criteria
Type: System..::..String
sortOrder
Type: System..::..String

Return Value

Type: array< DeliveryAddress >[]()[][]

See Also

DeliveryAddress Class
DeliveryAddress Members
_Select Overload


DeliveryAddress.Find Method

[image]

Pastel Evolution SDK
DeliveryAddress..::..Find Method
DeliveryAddress Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String

Return Value

Type: Int32

See Also

DeliveryAddress Class
DeliveryAddress Members


DeliveryAddress.List Method

[image] [image]

Pastel Evolution SDK
DeliveryAddress..::..List Method
DeliveryAddress Class See Also Send Feedback

Overload List

Name | Description
List(String) |
List(String, String) |

See Also

DeliveryAddress Class
DeliveryAddress Members


DeliveryAddress.List Method (String)

[image]

Pastel Evolution SDK
DeliveryAddress..::..List Method (String)
DeliveryAddress Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria
)
Visual Basic
Public Shared Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String

Return Value

Type: DataTable

See Also

DeliveryAddress Class
DeliveryAddress Members
List Overload


DeliveryAddress.List Method (String, String)

[image]

Pastel Evolution SDK
DeliveryAddress..::..List Method (String, String)
DeliveryAddress Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria,
    string sortOrder
)
Visual Basic
Public Shared Function List (
    criteria As String,
    sortOrder As String
) As DataTable

Parameters

criteria
Type: System..::..String
sortOrder
Type: System..::..String

Return Value

Type: DataTable

See Also

DeliveryAddress Class
DeliveryAddress Members
List Overload


DeliveryAddress.OnDelete Method

[image]

Pastel Evolution SDK
DeliveryAddress..::..OnDelete Method
DeliveryAddress Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

See Also

DeliveryAddress Class
DeliveryAddress Members


DeliveryAddress.OnSave Method

[image]

Pastel Evolution SDK
DeliveryAddress..::..OnSave Method
DeliveryAddress Class See Also Send Feedback
Persists the record to the database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

DeliveryAddress Class
DeliveryAddress Members


DeliveryAddress Properties

[image] [image]

Pastel Evolution SDK
DeliveryAddress Properties
DeliveryAddress Class See Also Send Feedback

The DeliveryAddress type exposes the following members.

Properties

 | Name | Description
Public property | Account |
Public property | AccountID |
Public property | Address | Gets or sets the delivery address record's actual address.
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | CellPhone |
Public property | Code | Gets or sets the delivery address code.
Public property | CodeID |
Public property | Description |
Public property | EmailAddress |
Public property | Fax |
Public property | ID | (Overrides RecordBase..::..ID.)
Public property | IsDefault |
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | Telephone1 |
Public property | Telephone2 |

See Also

DeliveryAddress Class


DeliveryAddress.Account Property

[image]

Pastel Evolution SDK
DeliveryAddress..::..Account Property
DeliveryAddress Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DrCrAccount Account { get; internal set; }
Visual Basic
Public Property Account As DrCrAccount
    Get
    Friend Set

Property Value

Type: DrCrAccount

See Also

DeliveryAddress Class
DeliveryAddress Members


DeliveryAddress.AccountID Property

[image]

Pastel Evolution SDK
DeliveryAddress..::..AccountID Property
DeliveryAddress Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int AccountID { get; }
Visual Basic
Public ReadOnly Property AccountID As Integer
    Get

Property Value

Type: Int32

See Also

DeliveryAddress Class
DeliveryAddress Members


DeliveryAddress.Address Property

[image]

Pastel Evolution SDK
DeliveryAddress..::..Address Property
DeliveryAddress Class See Also Send Feedback
Gets or sets the delivery address record's actual address.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Address Address { get; set; }
Visual Basic
Public Property Address As Address
    Get
    Set

Property Value

Type: Address

See Also

DeliveryAddress Class
DeliveryAddress Members


DeliveryAddress.CellPhone Property

[image]

Pastel Evolution SDK
DeliveryAddress..::..CellPhone Property
DeliveryAddress Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string CellPhone { get; set; }
Visual Basic
Public Property CellPhone As String
    Get
    Set

Property Value

Type: String

See Also

DeliveryAddress Class
DeliveryAddress Members


DeliveryAddress.Code Property

[image]

Pastel Evolution SDK
DeliveryAddress..::..Code Property
DeliveryAddress Class See Also Send Feedback
Gets or sets the delivery address code.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DeliveryAddressCode Code { get; set; }
Visual Basic
Public Property Code As DeliveryAddressCode
    Get
    Set

Property Value

Type: DeliveryAddressCode

See Also

DeliveryAddress Class
DeliveryAddress Members


DeliveryAddress.CodeID Property

[image]

Pastel Evolution SDK
DeliveryAddress..::..CodeID Property
DeliveryAddress Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int CodeID { get; }
Visual Basic
Public ReadOnly Property CodeID As Integer
    Get

Property Value

Type: Int32

See Also

DeliveryAddress Class
DeliveryAddress Members


DeliveryAddress.Description Property

[image]

Pastel Evolution SDK
DeliveryAddress..::..Description Property
DeliveryAddress Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set

Property Value

Type: String

See Also

DeliveryAddress Class
DeliveryAddress Members


DeliveryAddress.EmailAddress Property

[image]

Pastel Evolution SDK
DeliveryAddress..::..EmailAddress Property
DeliveryAddress Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string EmailAddress { get; set; }
Visual Basic
Public Property EmailAddress As String
    Get
    Set

Property Value

Type: String

See Also

DeliveryAddress Class
DeliveryAddress Members


DeliveryAddress.Fax Property

[image]

Pastel Evolution SDK
DeliveryAddress..::..Fax Property
DeliveryAddress Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Fax { get; set; }
Visual Basic
Public Property Fax As String
    Get
    Set

Property Value

Type: String

See Also

DeliveryAddress Class
DeliveryAddress Members


DeliveryAddress.ID Property

[image]

Pastel Evolution SDK
DeliveryAddress..::..ID Property
DeliveryAddress Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

See Also

DeliveryAddress Class
DeliveryAddress Members


DeliveryAddress.IsDefault Property

[image]

Pastel Evolution SDK
DeliveryAddress..::..IsDefault Property
DeliveryAddress Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool IsDefault { get; internal set; }
Visual Basic
Public Property IsDefault As Boolean
    Get
    Friend Set

Property Value

Type: Boolean

See Also

DeliveryAddress Class
DeliveryAddress Members


DeliveryAddress.LongID Property

[image]

Pastel Evolution SDK
DeliveryAddress..::..LongID Property
DeliveryAddress Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

DeliveryAddress Class
DeliveryAddress Members


DeliveryAddress.Telephone1 Property

[image]

Pastel Evolution SDK
DeliveryAddress..::..Telephone1 Property
DeliveryAddress Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Telephone1 { get; set; }
Visual Basic
Public Property Telephone1 As String
    Get
    Set

Property Value

Type: String

See Also

DeliveryAddress Class
DeliveryAddress Members


DeliveryAddress.Telephone2 Property

[image]

Pastel Evolution SDK
DeliveryAddress..::..Telephone2 Property
DeliveryAddress Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Telephone2 { get; set; }
Visual Basic
Public Property Telephone2 As String
    Get
    Set

Property Value

Type: String

See Also

DeliveryAddress Class
DeliveryAddress Members


DeliveryAddressCode Class

[image]

Pastel Evolution SDK
DeliveryAddressCode Class
Members See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class DeliveryAddressCode : BranchedRecordBase
Visual Basic
Public Class DeliveryAddressCode
    Inherits BranchedRecordBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..DeliveryAddressCode

See Also

DeliveryAddressCode Members


DeliveryAddressCode Members

[image] [image]

Pastel Evolution SDK
DeliveryAddressCode Members
DeliveryAddressCode Class Constructors Methods Fields Properties See Also Send Feedback

The DeliveryAddressCode type exposes the following members.

Constructors

 | Name | Description
Public method | DeliveryAddressCode()()()() | Creates a new instance of a delivery address code.
Public method | DeliveryAddressCode(Int32) | Creates a new instance of a delivery address code.
Public method | DeliveryAddressCode(String) | Creates a new instance of a delivery address code.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find |
 | FindByCode |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Code |
Public property | Description |
Public property | ID | (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)

See Also

DeliveryAddressCode Class


DeliveryAddressCode Constructor

[image] [image]

Pastel Evolution SDK
DeliveryAddressCode Constructor
DeliveryAddressCode Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DeliveryAddressCode()()()() | Creates a new instance of a delivery address code.
Public method | DeliveryAddressCode(Int32) | Creates a new instance of a delivery address code.
Public method | DeliveryAddressCode(String) | Creates a new instance of a delivery address code.

See Also

DeliveryAddressCode Class
DeliveryAddressCode Members


DeliveryAddressCode Constructor

[image]

Pastel Evolution SDK
DeliveryAddressCode Constructor
DeliveryAddressCode Class See Also Send Feedback
Creates a new instance of a delivery address code.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DeliveryAddressCode()
Visual Basic
Public Sub New

See Also

DeliveryAddressCode Class
DeliveryAddressCode Members
DeliveryAddressCode Overload


DeliveryAddressCode Constructor (Int32)

[image]

Pastel Evolution SDK
DeliveryAddressCode Constructor (Int32)
DeliveryAddressCode Class See Also Send Feedback
Creates a new instance of a delivery address code.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DeliveryAddressCode(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32
Specifies the id of the existing record.

See Also

DeliveryAddressCode Class
DeliveryAddressCode Members
DeliveryAddressCode Overload


DeliveryAddressCode Constructor (String)

[image]

Pastel Evolution SDK
DeliveryAddressCode Constructor (String)
DeliveryAddressCode Class See Also Send Feedback
Creates a new instance of a delivery address code.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DeliveryAddressCode(
    string code
)
Visual Basic
Public Sub New (
    code As String
)

Parameters

code
Type: System..::..String
Specifies the code.

See Also

DeliveryAddressCode Class
DeliveryAddressCode Members
DeliveryAddressCode Overload


DeliveryAddressCode Fields

[image] [image]

Pastel Evolution SDK
DeliveryAddressCode Fields
DeliveryAddressCode Class See Also Send Feedback

The DeliveryAddressCode type exposes the following members.

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

DeliveryAddressCode Class


DeliveryAddressCode Methods

[image] [image]

Pastel Evolution SDK
DeliveryAddressCode Methods
DeliveryAddressCode Class See Also Send Feedback

The DeliveryAddressCode type exposes the following members.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find |
 | FindByCode |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

DeliveryAddressCode Class


DeliveryAddressCode.Find Method

[image]

Pastel Evolution SDK
DeliveryAddressCode..::..Find Method
DeliveryAddressCode Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String

Return Value

Type: Int32

See Also

DeliveryAddressCode Class
DeliveryAddressCode Members


DeliveryAddressCode.FindByCode Method

[image]

Pastel Evolution SDK
DeliveryAddressCode..::..FindByCode Method
DeliveryAddressCode Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int FindByCode(
    string code
)
Visual Basic
Public Shared Function FindByCode (
    code As String
) As Integer

Parameters

code
Type: System..::..String

Return Value

Type: Int32

See Also

DeliveryAddressCode Class
DeliveryAddressCode Members


DeliveryAddressCode.List Method

[image]

Pastel Evolution SDK
DeliveryAddressCode..::..List Method
DeliveryAddressCode Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria
)
Visual Basic
Public Shared Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String

Return Value

Type: DataTable

See Also

DeliveryAddressCode Class
DeliveryAddressCode Members


DeliveryAddressCode.OnDelete Method

[image]

Pastel Evolution SDK
DeliveryAddressCode..::..OnDelete Method
DeliveryAddressCode Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

See Also

DeliveryAddressCode Class
DeliveryAddressCode Members


DeliveryAddressCode.OnSave Method

[image]

Pastel Evolution SDK
DeliveryAddressCode..::..OnSave Method
DeliveryAddressCode Class See Also Send Feedback
Persists the record to the database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

DeliveryAddressCode Class
DeliveryAddressCode Members


DeliveryAddressCode Properties

[image] [image]

Pastel Evolution SDK
DeliveryAddressCode Properties
DeliveryAddressCode Class See Also Send Feedback

The DeliveryAddressCode type exposes the following members.

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Code |
Public property | Description |
Public property | ID | (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)

See Also

DeliveryAddressCode Class


DeliveryAddressCode.Code Property

[image]

Pastel Evolution SDK
DeliveryAddressCode..::..Code Property
DeliveryAddressCode Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Code { get; set; }
Visual Basic
Public Property Code As String
    Get
    Set

Property Value

Type: String

See Also

DeliveryAddressCode Class
DeliveryAddressCode Members


DeliveryAddressCode.Description Property

[image]

Pastel Evolution SDK
DeliveryAddressCode..::..Description Property
DeliveryAddressCode Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set

Property Value

Type: String

See Also

DeliveryAddressCode Class
DeliveryAddressCode Members


DeliveryAddressCode.ID Property

[image]

Pastel Evolution SDK
DeliveryAddressCode..::..ID Property
DeliveryAddressCode Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

See Also

DeliveryAddressCode Class
DeliveryAddressCode Members


DeliveryAddressCode.LongID Property

[image]

Pastel Evolution SDK
DeliveryAddressCode..::..LongID Property
DeliveryAddressCode Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

DeliveryAddressCode Class
DeliveryAddressCode Members


DeliveryAddressCollection Class

[image]

Pastel Evolution SDK
DeliveryAddressCollection Class
Members See Also Send Feedback
Represents a collection of warehouse context records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class DeliveryAddressCollection : CollectionBase
Visual Basic
Public Class DeliveryAddressCollection
    Inherits CollectionBase

Inheritance Hierarchy

System..::..Object
System.Collections..::..CollectionBase
Pastel.Evolution..::..DeliveryAddressCollection

See Also

DeliveryAddressCollection Members
Pastel.Evolution Namespace
Pastel.Evolution..::..DeliveryAddress


DeliveryAddressCollection Members

[image] [image]

Pastel Evolution SDK
DeliveryAddressCollection Members
DeliveryAddressCollection Class Methods Properties See Also Send Feedback

The DeliveryAddressCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add(DeliveryAddress) |
Public method | Add(String, Address) |
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDefault |
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | SetDefault | Sets the new default delivery address for an account. Remember to call Save() when done.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item[([( Int32])]) | Gets a delivery address by index.
Public property | Item[([( String])]) | Gets the delivery address object relating to the current account and the address code specified.
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

DeliveryAddressCollection Class


DeliveryAddressCollection Methods

[image] [image]

Pastel Evolution SDK
DeliveryAddressCollection Methods
DeliveryAddressCollection Class See Also Send Feedback

The DeliveryAddressCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add(DeliveryAddress) |
Public method | Add(String, Address) |
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDefault |
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | SetDefault | Sets the new default delivery address for an account. Remember to call Save() when done.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DeliveryAddressCollection Class


DeliveryAddressCollection.Add Method

[image] [image]

Pastel Evolution SDK
DeliveryAddressCollection..::..Add Method
DeliveryAddressCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Add(DeliveryAddress) |
Public method | Add(String, Address) |

See Also

DeliveryAddressCollection Class
DeliveryAddressCollection Members


DeliveryAddressCollection.Add Method (DeliveryAddress)

[image]

Pastel Evolution SDK
DeliveryAddressCollection..::..Add Method (DeliveryAddress)
DeliveryAddressCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void Add(
    DeliveryAddress data
)
Visual Basic
Public Sub Add (
    data As DeliveryAddress
)

Parameters

data
Type: Pastel.Evolution..::..DeliveryAddress

See Also

DeliveryAddressCollection Class
DeliveryAddressCollection Members
Add Overload


DeliveryAddressCollection.Add Method (String, Address)

[image]

Pastel Evolution SDK
DeliveryAddressCollection..::..Add Method (String, Address)
DeliveryAddressCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void Add(
    string code,
    Address address
)
Visual Basic
Public Sub Add (
    code As String,
    address As Address
)

Parameters

code
Type: System..::..String
address
Type: Pastel.Evolution..::..Address

See Also

DeliveryAddressCollection Class
DeliveryAddressCollection Members
Add Overload


DeliveryAddressCollection.GetDefault Method

[image]

Pastel Evolution SDK
DeliveryAddressCollection..::..GetDefault Method
DeliveryAddressCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Address GetDefault()
Visual Basic
Public Function GetDefault As Address

Return Value

Type: Address

See Also

DeliveryAddressCollection Class
DeliveryAddressCollection Members


DeliveryAddressCollection.SetDefault Method

[image]

Pastel Evolution SDK
DeliveryAddressCollection..::..SetDefault Method
DeliveryAddressCollection Class See Also Send Feedback
Sets the new default delivery address for an account. Remember to call Save() when done.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void SetDefault(
    DeliveryAddress newDefaultAddress
)
Visual Basic
Public Sub SetDefault (
    newDefaultAddress As DeliveryAddress
)

Parameters

newDefaultAddress
Type: Pastel.Evolution..::..DeliveryAddress

See Also

DeliveryAddressCollection Class
DeliveryAddressCollection Members


DeliveryAddressCollection Properties

[image] [image]

Pastel Evolution SDK
DeliveryAddressCollection Properties
DeliveryAddressCollection Class See Also Send Feedback

The DeliveryAddressCollection type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item[([( Int32])]) | Gets a delivery address by index.
Public property | Item[([( String])]) | Gets the delivery address object relating to the current account and the address code specified.
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

DeliveryAddressCollection Class


DeliveryAddressCollection.Item Property

[image] [image]

Pastel Evolution SDK
DeliveryAddressCollection..::..Item Property
DeliveryAddressCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public property | Item[([( Int32])]) | Gets a delivery address by index.
Public property | Item[([( String])]) | Gets the delivery address object relating to the current account and the address code specified.

See Also

DeliveryAddressCollection Class
DeliveryAddressCollection Members


DeliveryAddressCollection.Item Property (Int32)

[image]

Pastel Evolution SDK
DeliveryAddressCollection..::..Item Property (Int32)
DeliveryAddressCollection Class See Also Send Feedback
Gets a delivery address by index.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DeliveryAddress this[
    int index
] { get; }
Visual Basic
Public ReadOnly Default Property Item (
    index As Integer
) As DeliveryAddress
    Get

Parameters

index
Type: System..::..Int32

Return Value

Type: DeliveryAddress

See Also

DeliveryAddressCollection Class
DeliveryAddressCollection Members
Item Overload


DeliveryAddressCollection.Item Property (String)

[image]

Pastel Evolution SDK
DeliveryAddressCollection..::..Item Property (String)
DeliveryAddressCollection Class See Also Send Feedback
Gets the delivery address object relating to the current account and the address code specified.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DeliveryAddress this[
    string code
] { get; }
Visual Basic
Public ReadOnly Default Property Item (
    code As String
) As DeliveryAddress
    Get

Parameters

code
Type: System..::..String
The delivery address code to return.

Return Value

Type: DeliveryAddress

See Also

DeliveryAddressCollection Class
DeliveryAddressCollection Members
Item Overload


DeliveryMethod Class

[image]

Pastel Evolution SDK
DeliveryMethod Class
Members See Also Send Feedback
Represents an order delivery method.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class DeliveryMethod : BranchedRecordBase
Visual Basic
Public Class DeliveryMethod
    Inherits BranchedRecordBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..DeliveryMethod

See Also

DeliveryMethod Members


DeliveryMethod Members

[image] [image]

Pastel Evolution SDK
DeliveryMethod Members
DeliveryMethod Class Constructors Methods Fields Properties See Also Send Feedback

The DeliveryMethod type exposes the following members.

Constructors

 | Name | Description
Public method | DeliveryMethod()()()() | Creates a new instance of a delivery method.
Public method | DeliveryMethod(Int32) | Creates a new instance of a delivery method.
Public method | DeliveryMethod(String) | Creates a new instance of a delivery method.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds a record's database ID.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | List | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Comment | Gets or sets the delivery method's comment.
Public property | Description | Gets or sets the delivery method's description.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)

See Also

DeliveryMethod Class


DeliveryMethod Constructor

[image] [image]

Pastel Evolution SDK
DeliveryMethod Constructor
DeliveryMethod Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DeliveryMethod()()()() | Creates a new instance of a delivery method.
Public method | DeliveryMethod(Int32) | Creates a new instance of a delivery method.
Public method | DeliveryMethod(String) | Creates a new instance of a delivery method.

See Also

DeliveryMethod Class
DeliveryMethod Members


DeliveryMethod Constructor

[image]

Pastel Evolution SDK
DeliveryMethod Constructor
DeliveryMethod Class See Also Send Feedback
Creates a new instance of a delivery method.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DeliveryMethod()
Visual Basic
Public Sub New

See Also

DeliveryMethod Class
DeliveryMethod Members
DeliveryMethod Overload


DeliveryMethod Constructor (Int32)

[image]

Pastel Evolution SDK
DeliveryMethod Constructor (Int32)
DeliveryMethod Class See Also Send Feedback
Creates a new instance of a delivery method.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DeliveryMethod(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32
Specifies the id of the existing record.

See Also

DeliveryMethod Class
DeliveryMethod Members
DeliveryMethod Overload


DeliveryMethod Constructor (String)

[image]

Pastel Evolution SDK
DeliveryMethod Constructor (String)
DeliveryMethod Class See Also Send Feedback
Creates a new instance of a delivery method.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DeliveryMethod(
    string description
)
Visual Basic
Public Sub New (
    description As String
)

Parameters

description
Type: System..::..String
Specifies the description of the existing record.

See Also

DeliveryMethod Class
DeliveryMethod Members
DeliveryMethod Overload


DeliveryMethod Fields

[image] [image]

Pastel Evolution SDK
DeliveryMethod Fields
DeliveryMethod Class See Also Send Feedback

The DeliveryMethod type exposes the following members.

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

DeliveryMethod Class


DeliveryMethod Methods

[image] [image]

Pastel Evolution SDK
DeliveryMethod Methods
DeliveryMethod Class See Also Send Feedback

The DeliveryMethod type exposes the following members.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds a record's database ID.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | List | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

DeliveryMethod Class


DeliveryMethod.Find Method

[image]

Pastel Evolution SDK
DeliveryMethod..::..Find Method
DeliveryMethod Class See Also Send Feedback
Finds a record's database ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.

Return Value

Type: Int32
The ID of the first record found; -1 if not record was found.

See Also

DeliveryMethod Class
DeliveryMethod Members


DeliveryMethod.List Method

[image]

Pastel Evolution SDK
DeliveryMethod..::..List Method
DeliveryMethod Class See Also Send Feedback
Gets a list of database records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DataTable List(
    string criteria
)
Visual Basic
Public Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.

Return Value

Type: DataTable
Table containing selected records.

See Also

DeliveryMethod Class
DeliveryMethod Members


DeliveryMethod.OnDelete Method

[image]

Pastel Evolution SDK
DeliveryMethod..::..OnDelete Method
DeliveryMethod Class See Also Send Feedback
Removes the record from the database, provided it is not referenced by other records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

Exceptions

Exception | Condition
IntegrityViolationException |

See Also

DeliveryMethod Class
DeliveryMethod Members


DeliveryMethod.OnSave Method

[image]

Pastel Evolution SDK
DeliveryMethod..::..OnSave Method
DeliveryMethod Class See Also Send Feedback
Persists the record to the database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

DeliveryMethod Class
DeliveryMethod Members


DeliveryMethod Properties

[image] [image]

Pastel Evolution SDK
DeliveryMethod Properties
DeliveryMethod Class See Also Send Feedback

The DeliveryMethod type exposes the following members.

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Comment | Gets or sets the delivery method's comment.
Public property | Description | Gets or sets the delivery method's description.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)

See Also

DeliveryMethod Class


DeliveryMethod.Comment Property

[image]

Pastel Evolution SDK
DeliveryMethod..::..Comment Property
DeliveryMethod Class See Also Send Feedback
Gets or sets the delivery method's comment.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Comment { get; set; }
Visual Basic
Public Property Comment As String
    Get
    Set

Property Value

Type: String

See Also

DeliveryMethod Class
DeliveryMethod Members


DeliveryMethod.Description Property

[image]

Pastel Evolution SDK
DeliveryMethod..::..Description Property
DeliveryMethod Class See Also Send Feedback
Gets or sets the delivery method's description.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set

Property Value

Type: String

See Also

DeliveryMethod Class
DeliveryMethod Members


DeliveryMethod.ID Property

[image]

Pastel Evolution SDK
DeliveryMethod..::..ID Property
DeliveryMethod Class See Also Send Feedback
Gets the internal record ID (0 for new, unsaved records).
Gets the internal record ID (0 for new, unsaved records).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

Remarks

Once saved, the ID will reflect the record's internal database identifier.

See Also

DeliveryMethod Class
DeliveryMethod Members


DeliveryMethod.LongID Property

[image]

Pastel Evolution SDK
DeliveryMethod..::..LongID Property
DeliveryMethod Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

DeliveryMethod Class
DeliveryMethod Members


Department Class

[image]

Pastel Evolution SDK
Department Class
Members See Also Send Feedback
Represents a business department which can be assigned to accounts.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class Department : BranchedRecordBase
Visual Basic
Public Class Department
    Inherits BranchedRecordBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..Department

See Also

Department Members


Department Members

[image] [image]

Pastel Evolution SDK
Department Members
Department Class Constructors Methods Fields Properties See Also Send Feedback

The Department type exposes the following members.

Constructors

 | Name | Description
Public method | Department()()()() | Creates a new instance of a department.
Public method | Department(Int32) | Creates a new instance of a department.
Public method | Department(String) | Creates a new instance of a department.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds a record's database ID.
 | FindByDescription |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | List | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Description | Gets or sets the department description.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)

See Also

Department Class


Department Constructor

[image] [image]

Pastel Evolution SDK
Department Constructor
Department Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Department()()()() | Creates a new instance of a department.
Public method | Department(Int32) | Creates a new instance of a department.
Public method | Department(String) | Creates a new instance of a department.

See Also

Department Class
Department Members


Department Constructor

[image]

Pastel Evolution SDK
Department Constructor
Department Class See Also Send Feedback
Creates a new instance of a department.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Department()
Visual Basic
Public Sub New

See Also

Department Class
Department Members
Department Overload


Department Constructor (Int32)

[image]

Pastel Evolution SDK
Department Constructor (Int32)
Department Class See Also Send Feedback
Creates a new instance of a department.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Department(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32
The database ID of the existing record.

See Also

Department Class
Department Members
Department Overload


Department Constructor (String)

[image]

Pastel Evolution SDK
Department Constructor (String)
Department Class See Also Send Feedback
Creates a new instance of a department.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Department(
    string description
)
Visual Basic
Public Sub New (
    description As String
)

Parameters

description
Type: System..::..String
The department name of the existing record.

See Also

Department Class
Department Members
Department Overload


Department Fields

[image] [image]

Pastel Evolution SDK
Department Fields
Department Class See Also Send Feedback

The Department type exposes the following members.

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

Department Class


Department Methods

[image] [image]

Pastel Evolution SDK
Department Methods
Department Class See Also Send Feedback

The Department type exposes the following members.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds a record's database ID.
 | FindByDescription |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | List | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

Department Class


Department.Find Method

[image]

Pastel Evolution SDK
Department..::..Find Method
Department Class See Also Send Feedback
Finds a record's database ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.

Return Value

Type: Int32
The ID of the first record found; -1 if not record was found.

See Also

Department Class
Department Members


Department.FindByDescription Method

[image]

Pastel Evolution SDK
Department..::..FindByDescription Method
Department Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int FindByDescription(
    string description
)
Visual Basic
Public Shared Function FindByDescription (
    description As String
) As Integer

Parameters

description
Type: System..::..String

Return Value

Type: Int32

See Also

Department Class
Department Members


Department.List Method

[image]

Pastel Evolution SDK
Department..::..List Method
Department Class See Also Send Feedback
Gets a list of database records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DataTable List(
    string criteria
)
Visual Basic
Public Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String
Specifies the SQL criteria.

Return Value

Type: DataTable
Table containing selected records.

See Also

Department Class
Department Members


Department.OnDelete Method

[image]

Pastel Evolution SDK
Department..::..OnDelete Method
Department Class See Also Send Feedback
Removes the record from the database, provided it is not referenced by other records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

Exceptions

Exception | Condition
IntegrityViolationException |

See Also

Department Class
Department Members


Department.OnSave Method

[image]

Pastel Evolution SDK
Department..::..OnSave Method
Department Class See Also Send Feedback
Persists the record to the database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

Department Class
Department Members


Department Properties

[image] [image]

Pastel Evolution SDK
Department Properties
Department Class See Also Send Feedback

The Department type exposes the following members.

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Description | Gets or sets the department description.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)

See Also

Department Class


Department.Description Property

[image]

Pastel Evolution SDK
Department..::..Description Property
Department Class See Also Send Feedback
Gets or sets the department description.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set

Property Value

Type: String

See Also

Department Class
Department Members


Department.ID Property

[image]

Pastel Evolution SDK
Department..::..ID Property
Department Class See Also Send Feedback
Gets the internal record ID (0 for new, unsaved records).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

See Also

Department Class
Department Members


Department.LongID Property

[image]

Pastel Evolution SDK
Department..::..LongID Property
Department Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

Department Class
Department Members


Designation Class

[image]

Pastel Evolution SDK
Designation Class
Members See Also Send Feedback
Represents a designation which can be assigned to persons.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class Designation : BranchedRecordBase
Visual Basic
Public Class Designation
    Inherits BranchedRecordBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..Designation

See Also

Designation Members


Designation Members

[image] [image]

Pastel Evolution SDK
Designation Members
Designation Class Constructors Methods Fields Properties See Also Send Feedback

The Designation type exposes the following members.

Constructors

 | Name | Description
Public method | Designation()()()() | Creates a new instance of a designation.
Public method | Designation(Int32) | Creates a new instance of a designation.
Public method | Designation(String) | Creates a new instance of a designation.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds a record's database ID.
 | FindByDescription |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | List | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Description | Gets or sets the designation description.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)

See Also

Designation Class


Designation Constructor

[image] [image]

Pastel Evolution SDK
Designation Constructor
Designation Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Designation()()()() | Creates a new instance of a designation.
Public method | Designation(Int32) | Creates a new instance of a designation.
Public method | Designation(String) | Creates a new instance of a designation.

See Also

Designation Class
Designation Members


Designation Constructor

[image]

Pastel Evolution SDK
Designation Constructor
Designation Class See Also Send Feedback
Creates a new instance of a designation.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Designation()
Visual Basic
Public Sub New

See Also

Designation Class
Designation Members
Designation Overload


Designation Constructor (Int32)

[image]

Pastel Evolution SDK
Designation Constructor (Int32)
Designation Class See Also Send Feedback
Creates a new instance of a designation.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Designation(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32
The database ID of the existing record.

See Also

Designation Class
Designation Members
Designation Overload


Designation Constructor (String)

[image]

Pastel Evolution SDK
Designation Constructor (String)
Designation Class See Also Send Feedback
Creates a new instance of a designation.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Designation(
    string description
)
Visual Basic
Public Sub New (
    description As String
)

Parameters

description
Type: System..::..String
The designation name of the existing record.

See Also

Designation Class
Designation Members
Designation Overload


Designation Fields

[image] [image]

Pastel Evolution SDK
Designation Fields
Designation Class See Also Send Feedback

The Designation type exposes the following members.

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

Designation Class


Designation Methods

[image] [image]

Pastel Evolution SDK
Designation Methods
Designation Class See Also Send Feedback

The Designation type exposes the following members.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds a record's database ID.
 | FindByDescription |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | List | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

Designation Class


Designation.Find Method

[image]

Pastel Evolution SDK
Designation..::..Find Method
Designation Class See Also Send Feedback
Finds a record's database ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.

Return Value

Type: Int32
The ID of the first record found; -1 if not record was found.

See Also

Designation Class
Designation Members


Designation.FindByDescription Method

[image]

Pastel Evolution SDK
Designation..::..FindByDescription Method
Designation Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int FindByDescription(
    string description
)
Visual Basic
Public Shared Function FindByDescription (
    description As String
) As Integer

Parameters

description
Type: System..::..String

Return Value

Type: Int32

See Also

Designation Class
Designation Members


Designation.List Method

[image]

Pastel Evolution SDK
Designation..::..List Method
Designation Class See Also Send Feedback
Gets a list of database records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DataTable List(
    string criteria
)
Visual Basic
Public Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String
Specifies the SQL criteria.

Return Value

Type: DataTable
Table containing selected records.

See Also

Designation Class
Designation Members


Designation.OnDelete Method

[image]

Pastel Evolution SDK
Designation..::..OnDelete Method
Designation Class See Also Send Feedback
Removes the record from the database, provided it is not referenced by other records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

Exceptions

Exception | Condition
IntegrityViolationException |

See Also

Designation Class
Designation Members


Designation.OnSave Method

[image]

Pastel Evolution SDK
Designation..::..OnSave Method
Designation Class See Also Send Feedback
Persists the record to the database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

Designation Class
Designation Members


Designation Properties

[image] [image]

Pastel Evolution SDK
Designation Properties
Designation Class See Also Send Feedback

The Designation type exposes the following members.

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Description | Gets or sets the designation description.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)

See Also

Designation Class


Designation.Description Property

[image]

Pastel Evolution SDK
Designation..::..Description Property
Designation Class See Also Send Feedback
Gets or sets the designation description.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set

Property Value

Type: String

See Also

Designation Class
Designation Members


Designation.ID Property

[image]

Pastel Evolution SDK
Designation..::..ID Property
Designation Class See Also Send Feedback
Gets the internal record ID (0 for new, unsaved records).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

See Also

Designation Class
Designation Members


Designation.LongID Property

[image]

Pastel Evolution SDK
Designation..::..LongID Property
Designation Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

Designation Class
Designation Members


Document Class

[image]

Pastel Evolution SDK
Document Class
Members See Also Send Feedback
Represents a contact management document.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class Document : BranchedRecordBase
Visual Basic
Public Class Document
    Inherits BranchedRecordBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..Document

See Also

Document Members


Document Members

[image] [image]

Pastel Evolution SDK
Document Members
Document Class Constructors Methods Fields Properties See Also Send Feedback

The Document type exposes the following members.

Constructors

 | Name | Description
Public method | Document()()()() | Initializes a new instance of the Document class
Public method | Document(Int32) | Initializes a new instance of the Document class
Public method | Document(String) | Initializes a new instance of the Document class

Methods

 | Name | Description
Public method | _CreateLink(Incident) | Temporary Method
Public method | _CreateLink(Opportunity) | Temporary Method
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find |
 | FindByDescription |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List | Returns a System.Data.DataTable object containing the database records from the _rtblDocStore table matching the supplied criteria.
Public method | Load |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save()()()() | Persists the record to the database. (Inherited from RecordBase.)
Public method | Save(String) | Saves the document to the database after copying the physical file from the specified path and storing it in the central storage directory.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Category |
Public property | CategoryID |
Public property | Description |
Public property | Icon |
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | IsActive |
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | Name |
Public property | Path | Gets the document's physical path. An empty string is returned if no file location is set.
Public property | PhysicalName |

See Also

Document Class


Document Constructor

[image] [image]

Pastel Evolution SDK
Document Constructor
Document Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Document()()()() | Initializes a new instance of the Document class
Public method | Document(Int32) | Initializes a new instance of the Document class
Public method | Document(String) | Initializes a new instance of the Document class

See Also

Document Class
Document Members


Document Constructor

[image]

Pastel Evolution SDK
Document Constructor
Document Class See Also Send Feedback
Initializes a new instance of the Document class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Document()
Visual Basic
Public Sub New

See Also

Document Class
Document Members
Document Overload


Document Constructor (Int32)

[image]

Pastel Evolution SDK
Document Constructor (Int32)
Document Class See Also Send Feedback
Initializes a new instance of the Document class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Document(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32

See Also

Document Class
Document Members
Document Overload


Document Constructor (String)

[image]

Pastel Evolution SDK
Document Constructor (String)
Document Class See Also Send Feedback
Initializes a new instance of the Document class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Document(
    string description
)
Visual Basic
Public Sub New (
    description As String
)

Parameters

description
Type: System..::..String

See Also

Document Class
Document Members
Document Overload


Document Fields

[image] [image]

Pastel Evolution SDK
Document Fields
Document Class See Also Send Feedback

The Document type exposes the following members.

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

Document Class


Document Methods

[image] [image]

Pastel Evolution SDK
Document Methods
Document Class See Also Send Feedback

The Document type exposes the following members.

Methods

 | Name | Description
Public method | _CreateLink(Incident) | Temporary Method
Public method | _CreateLink(Opportunity) | Temporary Method
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find |
 | FindByDescription |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List | Returns a System.Data.DataTable object containing the database records from the _rtblDocStore table matching the supplied criteria.
Public method | Load |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save()()()() | Persists the record to the database. (Inherited from RecordBase.)
Public method | Save(String) | Saves the document to the database after copying the physical file from the specified path and storing it in the central storage directory.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

Document Class


Document._CreateLink Method

[image] [image]

Pastel Evolution SDK
Document..::.._CreateLink Method
Document Class See Also Send Feedback

Overload List

 | Name | Description
Public method | _CreateLink(Incident) | Temporary Method
Public method | _CreateLink(Opportunity) | Temporary Method

See Also

Document Class
Document Members


Document._CreateLink Method (Incident)

[image]

Pastel Evolution SDK
Document..::.._CreateLink Method (Incident)
Document Class See Also Send Feedback
Temporary Method

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void _CreateLink(
    Incident record
)
Visual Basic
Public Sub _CreateLink (
    record As Incident
)

Parameters

record
Type: Pastel.Evolution..::..Incident

See Also

Document Class
Document Members
_CreateLink Overload


Document._CreateLink Method (Opportunity)

[image]

Pastel Evolution SDK
Document..::.._CreateLink Method (Opportunity)
Document Class See Also Send Feedback
Temporary Method

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void _CreateLink(
    Opportunity record
)
Visual Basic
Public Sub _CreateLink (
    record As Opportunity
)

Parameters

record
Type: Pastel.Evolution..::..Opportunity

See Also

Document Class
Document Members
_CreateLink Overload


Document.Find Method

[image]

Pastel Evolution SDK
Document..::..Find Method
Document Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String

Return Value

Type: Int32

See Also

Document Class
Document Members


Document.FindByDescription Method

[image]

Pastel Evolution SDK
Document..::..FindByDescription Method
Document Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int FindByDescription(
    string description
)
Visual Basic
Public Shared Function FindByDescription (
    description As String
) As Integer

Parameters

description
Type: System..::..String

Return Value

Type: Int32

See Also

Document Class
Document Members


Document.List Method

[image]

Pastel Evolution SDK
Document..::..List Method
Document Class See Also Send Feedback
Returns a System.Data.DataTable object containing the database records from the _rtblDocStore table matching the supplied criteria.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria
)
Visual Basic
Public Shared Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String
The SQL criteria used to locate the record, e.g. cDocName like '1___'

Return Value

Type: DataTable
A System.Data.DataTable object containing matching records.

Remarks

The criteria is passed to an SQL query so use the appropriate syntax. Remember to include the single quotes around string literals and append additional criteria with and.

See Also

Document Class
Document Members


Document.Load Method

[image]

Pastel Evolution SDK
Document..::..Load Method
Document Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void Load(
    string location
)
Visual Basic
Public Sub Load (
    location As String
)

Parameters

location
Type: System..::..String

See Also

Document Class
Document Members


Document.OnDelete Method

[image]

Pastel Evolution SDK
Document..::..OnDelete Method
Document Class See Also Send Feedback
Removes the record from the database, provided it is not referenced by other records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

Exceptions

Exception | Condition
IntegrityViolationException |

See Also

Document Class
Document Members


Document.OnSave Method

[image]

Pastel Evolution SDK
Document..::..OnSave Method
Document Class See Also Send Feedback
Persists the record to the database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

Document Class
Document Members


Document.Save Method

[image] [image]

Pastel Evolution SDK
Document..::..Save Method
Document Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Save()()()() | Persists the record to the database. (Inherited from RecordBase.)
Public method | Save(String) | Saves the document to the database after copying the physical file from the specified path and storing it in the central storage directory.

See Also

Document Class
Document Members


Document.Save Method (String)

[image]

Pastel Evolution SDK
Document..::..Save Method (String)
Document Class See Also Send Feedback
Saves the document to the database after copying the physical file from the specified path and storing it in the central storage directory.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void Save(
    string path
)
Visual Basic
Public Sub Save (
    path As String
)

Parameters

path
Type: System..::..String
The full path to the file that needs to be copied.

See Also

Document Class
Document Members
Save Overload


Document Properties

[image] [image]

Pastel Evolution SDK
Document Properties
Document Class See Also Send Feedback

The Document type exposes the following members.

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Category |
Public property | CategoryID |
Public property | Description |
Public property | Icon |
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | IsActive |
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | Name |
Public property | Path | Gets the document's physical path. An empty string is returned if no file location is set.
Public property | PhysicalName |

See Also

Document Class


Document.Category Property

[image]

Pastel Evolution SDK
Document..::..Category Property
Document Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DocumentCategory Category { get; set; }
Visual Basic
Public Property Category As DocumentCategory
    Get
    Set

Property Value

Type: DocumentCategory

See Also

Document Class
Document Members


Document.CategoryID Property

[image]

Pastel Evolution SDK
Document..::..CategoryID Property
Document Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int CategoryID { get; set; }
Visual Basic
Public Property CategoryID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

Document Class
Document Members


Document.Description Property

[image]

Pastel Evolution SDK
Document..::..Description Property
Document Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set

Property Value

Type: String

See Also

Document Class
Document Members


Document.Icon Property

[image]

Pastel Evolution SDK
Document..::..Icon Property
Document Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Icon Icon { get; set; }
Visual Basic
Public Property Icon As Icon
    Get
    Set

Property Value

Type: Icon

See Also

Document Class
Document Members


Document.ID Property

[image]

Pastel Evolution SDK
Document..::..ID Property
Document Class See Also Send Feedback
Gets the internal record ID (0 for new, unsaved records).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

See Also

Document Class
Document Members


Document.IsActive Property

[image]

Pastel Evolution SDK
Document..::..IsActive Property
Document Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool IsActive { get; set; }
Visual Basic
Public Property IsActive As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

Document Class
Document Members


Document.LongID Property

[image]

Pastel Evolution SDK
Document..::..LongID Property
Document Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

Document Class
Document Members


Document.Name Property

[image]

Pastel Evolution SDK
Document..::..Name Property
Document Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

Property Value

Type: String

See Also

Document Class
Document Members


Document.Path Property

[image]

Pastel Evolution SDK
Document..::..Path Property
Document Class See Also Send Feedback
Gets the document's physical path. An empty string is returned if no file location is set.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Path { get; }
Visual Basic
Public ReadOnly Property Path As String
    Get

Property Value

Type: String

See Also

Document Class
Document Members


Document.PhysicalName Property

[image]

Pastel Evolution SDK
Document..::..PhysicalName Property
Document Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string PhysicalName { get; internal set; }
Visual Basic
Public Property PhysicalName As String
    Get
    Friend Set

Property Value

Type: String

See Also

Document Class
Document Members


DocumentCategory Class

[image]

Pastel Evolution SDK
DocumentCategory Class
Members See Also Send Feedback
Represents a contact management document category.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class DocumentCategory : BranchedRecordBase
Visual Basic
Public Class DocumentCategory
    Inherits BranchedRecordBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..DocumentCategory

See Also

DocumentCategory Members


DocumentCategory Members

[image] [image]

Pastel Evolution SDK
DocumentCategory Members
DocumentCategory Class Constructors Methods Fields Properties See Also Send Feedback

The DocumentCategory type exposes the following members.

Constructors

 | Name | Description
Public method | DocumentCategory()()()() | Initializes a new instance of the DocumentCategory class
Public method | DocumentCategory(Int32) | Initializes a new instance of the DocumentCategory class
Public method | DocumentCategory(String) | Initializes a new instance of the DocumentCategory class

Methods

 | Name | Description
 | _ListCurrentBranch |
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find |
 | FindByDescription |
 | GetByDescription |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List | Returns a System.Data.DataTable object containing the database records from the _rtblDocStore table matching the supplied criteria.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Description |
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)

See Also

DocumentCategory Class


DocumentCategory Constructor

[image] [image]

Pastel Evolution SDK
DocumentCategory Constructor
DocumentCategory Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DocumentCategory()()()() | Initializes a new instance of the DocumentCategory class
Public method | DocumentCategory(Int32) | Initializes a new instance of the DocumentCategory class
Public method | DocumentCategory(String) | Initializes a new instance of the DocumentCategory class

See Also

DocumentCategory Class
DocumentCategory Members


DocumentCategory Constructor

[image]

Pastel Evolution SDK
DocumentCategory Constructor
DocumentCategory Class See Also Send Feedback
Initializes a new instance of the DocumentCategory class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DocumentCategory()
Visual Basic
Public Sub New

See Also

DocumentCategory Class
DocumentCategory Members
DocumentCategory Overload


DocumentCategory Constructor (Int32)

[image]

Pastel Evolution SDK
DocumentCategory Constructor (Int32)
DocumentCategory Class See Also Send Feedback
Initializes a new instance of the DocumentCategory class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DocumentCategory(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32

See Also

DocumentCategory Class
DocumentCategory Members
DocumentCategory Overload


DocumentCategory Constructor (String)

[image]

Pastel Evolution SDK
DocumentCategory Constructor (String)
DocumentCategory Class See Also Send Feedback
Initializes a new instance of the DocumentCategory class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DocumentCategory(
    string description
)
Visual Basic
Public Sub New (
    description As String
)

Parameters

description
Type: System..::..String

See Also

DocumentCategory Class
DocumentCategory Members
DocumentCategory Overload


DocumentCategory Fields

[image] [image]

Pastel Evolution SDK
DocumentCategory Fields
DocumentCategory Class See Also Send Feedback

The DocumentCategory type exposes the following members.

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

DocumentCategory Class


DocumentCategory Methods

[image] [image]

Pastel Evolution SDK
DocumentCategory Methods
DocumentCategory Class See Also Send Feedback

The DocumentCategory type exposes the following members.

Methods

 | Name | Description
 | _ListCurrentBranch |
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find |
 | FindByDescription |
 | GetByDescription |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List | Returns a System.Data.DataTable object containing the database records from the _rtblDocStore table matching the supplied criteria.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

DocumentCategory Class


DocumentCategory._ListCurrentBranch Method

[image]

Pastel Evolution SDK
DocumentCategory..::.._ListCurrentBranch Method
DocumentCategory Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable _ListCurrentBranch(
    string criteria
)
Visual Basic
Public Shared Function _ListCurrentBranch (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String

Return Value

Type: DataTable

See Also

DocumentCategory Class
DocumentCategory Members


DocumentCategory.Find Method

[image]

Pastel Evolution SDK
DocumentCategory..::..Find Method
DocumentCategory Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String

Return Value

Type: Int32

See Also

DocumentCategory Class
DocumentCategory Members


DocumentCategory.FindByDescription Method

[image]

Pastel Evolution SDK
DocumentCategory..::..FindByDescription Method
DocumentCategory Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int FindByDescription(
    string description
)
Visual Basic
Public Shared Function FindByDescription (
    description As String
) As Integer

Parameters

description
Type: System..::..String

Return Value

Type: Int32

See Also

DocumentCategory Class
DocumentCategory Members


DocumentCategory.GetByDescription Method

[image]

Pastel Evolution SDK
DocumentCategory..::..GetByDescription Method
DocumentCategory Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DocumentCategory GetByDescription(
    string description
)
Visual Basic
Public Shared Function GetByDescription (
    description As String
) As DocumentCategory

Parameters

description
Type: System..::..String

Return Value

Type: DocumentCategory

See Also

DocumentCategory Class
DocumentCategory Members


DocumentCategory.List Method

[image]

Pastel Evolution SDK
DocumentCategory..::..List Method
DocumentCategory Class See Also Send Feedback
Returns a System.Data.DataTable object containing the database records from the _rtblDocStore table matching the supplied criteria.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria
)
Visual Basic
Public Shared Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String
The SQL criteria used to locate the record, e.g. cDocName like '1___'

Return Value

Type: DataTable
A System.Data.DataTable object containing matching records.

Remarks

The criteria is passed to an SQL query so use the appropriate syntax. Remember to include the single quotes around string literals and append additional criteria with and.

See Also

DocumentCategory Class
DocumentCategory Members


DocumentCategory.OnDelete Method

[image]

Pastel Evolution SDK
DocumentCategory..::..OnDelete Method
DocumentCategory Class See Also Send Feedback
Removes the record from the database, provided it is not referenced by other records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

Exceptions

Exception | Condition
IntegrityViolationException |

See Also

DocumentCategory Class
DocumentCategory Members


DocumentCategory.OnSave Method

[image]

Pastel Evolution SDK
DocumentCategory..::..OnSave Method
DocumentCategory Class See Also Send Feedback
Persists the record to the database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

DocumentCategory Class
DocumentCategory Members


DocumentCategory Properties

[image] [image]

Pastel Evolution SDK
DocumentCategory Properties
DocumentCategory Class See Also Send Feedback

The DocumentCategory type exposes the following members.

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Description |
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)

See Also

DocumentCategory Class


DocumentCategory.Description Property

[image]

Pastel Evolution SDK
DocumentCategory..::..Description Property
DocumentCategory Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set

Property Value

Type: String

See Also

DocumentCategory Class
DocumentCategory Members


DocumentCategory.ID Property

[image]

Pastel Evolution SDK
DocumentCategory..::..ID Property
DocumentCategory Class See Also Send Feedback
Gets the internal record ID (0 for new, unsaved records).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

See Also

DocumentCategory Class
DocumentCategory Members


DocumentCategory.LongID Property

[image]

Pastel Evolution SDK
DocumentCategory..::..LongID Property
DocumentCategory Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

DocumentCategory Class
DocumentCategory Members


DocumentState Enumeration

[image]

Pastel Evolution SDK
DocumentState Enumeration
See Also Send Feedback
Describes an inventory document's state.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public enum DocumentState
Visual Basic
Public Enumeration DocumentState

Members

Member name | Value | Description
Unprocessed | 1 |
Quote | 2 |
PartiallyProcessed | 3 |
Archived | 4 |

See Also

Pastel.Evolution Namespace


DocumentTotalRoundingStrategy Enumeration

[image]

Pastel Evolution SDK
DocumentTotalRoundingStrategy Enumeration
See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public enum DocumentTotalRoundingStrategy
Visual Basic
Public Enumeration DocumentTotalRoundingStrategy

Members

Member name | Value | Description
Up | 0 |
Down | 1 |
Nearest | 2 |

See Also

Pastel.Evolution Namespace


DocumentType Enumeration

[image]

Pastel Evolution SDK
DocumentType Enumeration
See Also Send Feedback
Describes an inventory document's type.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public enum DocumentType
Visual Basic
Public Enumeration DocumentType

Members

Member name | Value | Description
Invoice | 0 |
CreditNote | 1 |
GoodsReceivedVoucher | 2 |
ReturnToSupplier | 3 |
SalesOrder | 4 |
PurchaseOrder | 5 |
DeliveryNote | 100 |

See Also

Pastel.Evolution Namespace


DrCrAccount Class

[image]

Pastel Evolution SDK
DrCrAccount Class
Members See Also Send Feedback
A debtor and creditor account base class.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract class DrCrAccount : AccountBase
Visual Basic
Public MustInherit Class DrCrAccount
    Inherits AccountBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..AccountBase
Pastel.Evolution..::..DrCrAccount
Pastel.Evolution..::..Customer
Pastel.Evolution..::..Supplier

See Also

DrCrAccount Members


DrCrAccount Members

[image] [image]

Pastel Evolution SDK
DrCrAccount Members
DrCrAccount Class Constructors Methods Fields Properties See Also Send Feedback

The DrCrAccount type exposes the following members.

Constructors

 | Name | Description
Protected method | DrCrAccount | Initializes a new instance of the DrCrAccount class

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | (Inherited from AccountBase.)
Protected method | OnSave | Persists the record to the database. (Inherited from AccountBase.)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | (Inherited from AccountBase.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | AccountBalance | Gets the account's current balance.
Public property | Active | Gets or sets the record's state. (Inherited from AccountBase.)
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | ChargeTax | Gets or sets whether or not to charge the account VAT.
Public property | Code | Gets the internal record ID (0 for new, unsaved records). (Inherited from AccountBase.)
Public property | Currency |
Public property | CurrencyID |
Public property | DefaultSettlementTerms |
Public property | Description | Gets or sets the record's description. The database field corresponding to the code is not necessarily called description. (Inherited from AccountBase.)
Public property | ForeignAccountBalance |
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Inherited from RecordBase.)
Public property | IsForeignCurrencyAccount |
Public property | LongID | Gets the internal record ID (0 for new, unsaved records). (Inherited from RecordBase.)
Public property | Module | Each module type is associated with an Evolution module. (Inherited from AccountBase.)

See Also

DrCrAccount Class


DrCrAccount Constructor

[image]

Pastel Evolution SDK
DrCrAccount Constructor
DrCrAccount Class See Also Send Feedback
Initializes a new instance of the DrCrAccount class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected DrCrAccount()
Visual Basic
Protected Sub New

See Also

DrCrAccount Class
DrCrAccount Members


DrCrAccount Fields

[image] [image]

Pastel Evolution SDK
DrCrAccount Fields
DrCrAccount Class See Also Send Feedback

The DrCrAccount type exposes the following members.

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

DrCrAccount Class


DrCrAccount Methods

[image] [image]

Pastel Evolution SDK
DrCrAccount Methods
DrCrAccount Class See Also Send Feedback

The DrCrAccount type exposes the following members.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | (Inherited from AccountBase.)
Protected method | OnSave | Persists the record to the database. (Inherited from AccountBase.)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | (Inherited from AccountBase.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

DrCrAccount Class


DrCrAccount Properties

[image] [image]

Pastel Evolution SDK
DrCrAccount Properties
DrCrAccount Class See Also Send Feedback

The DrCrAccount type exposes the following members.

Properties

 | Name | Description
Public property | AccountBalance | Gets the account's current balance.
Public property | Active | Gets or sets the record's state. (Inherited from AccountBase.)
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | ChargeTax | Gets or sets whether or not to charge the account VAT.
Public property | Code | Gets the internal record ID (0 for new, unsaved records). (Inherited from AccountBase.)
Public property | Currency |
Public property | CurrencyID |
Public property | DefaultSettlementTerms |
Public property | Description | Gets or sets the record's description. The database field corresponding to the code is not necessarily called description. (Inherited from AccountBase.)
Public property | ForeignAccountBalance |
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Inherited from RecordBase.)
Public property | IsForeignCurrencyAccount |
Public property | LongID | Gets the internal record ID (0 for new, unsaved records). (Inherited from RecordBase.)
Public property | Module | Each module type is associated with an Evolution module. (Inherited from AccountBase.)

See Also

DrCrAccount Class


DrCrAccount.AccountBalance Property

[image]

Pastel Evolution SDK
DrCrAccount..::..AccountBalance Property
DrCrAccount Class See Also Send Feedback
Gets the account's current balance.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract double AccountBalance { get; }
Visual Basic
Public MustOverride ReadOnly Property AccountBalance As Double
    Get

Property Value

Type: Double

See Also

DrCrAccount Class
DrCrAccount Members


DrCrAccount.ChargeTax Property

[image]

Pastel Evolution SDK
DrCrAccount..::..ChargeTax Property
DrCrAccount Class See Also Send Feedback
Gets or sets whether or not to charge the account VAT.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract bool ChargeTax { get; set; }
Visual Basic
Public MustOverride Property ChargeTax As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

DrCrAccount Class
DrCrAccount Members


DrCrAccount.Currency Property

[image]

Pastel Evolution SDK
DrCrAccount..::..Currency Property
DrCrAccount Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract Currency Currency { get; set; }
Visual Basic
Public MustOverride Property Currency As Currency
    Get
    Set

Property Value

Type: Currency

See Also

DrCrAccount Class
DrCrAccount Members


DrCrAccount.CurrencyID Property

[image]

Pastel Evolution SDK
DrCrAccount..::..CurrencyID Property
DrCrAccount Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract int CurrencyID { get; set; }
Visual Basic
Public MustOverride Property CurrencyID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

DrCrAccount Class
DrCrAccount Members


DrCrAccount.DefaultSettlementTerms Property

[image]

Pastel Evolution SDK
DrCrAccount..::..DefaultSettlementTerms Property
DrCrAccount Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract SettlementTerms DefaultSettlementTerms { get; set; }
Visual Basic
Public MustOverride Property DefaultSettlementTerms As SettlementTerms
    Get
    Set

Property Value

Type: SettlementTerms

See Also

DrCrAccount Class
DrCrAccount Members


DrCrAccount.ForeignAccountBalance Property

[image]

Pastel Evolution SDK
DrCrAccount..::..ForeignAccountBalance Property
DrCrAccount Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract double ForeignAccountBalance { get; }
Visual Basic
Public MustOverride ReadOnly Property ForeignAccountBalance As Double
    Get

Property Value

Type: Double

See Also

DrCrAccount Class
DrCrAccount Members


DrCrAccount.IsForeignCurrencyAccount Property

[image]

Pastel Evolution SDK
DrCrAccount..::..IsForeignCurrencyAccount Property
DrCrAccount Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract bool IsForeignCurrencyAccount { get; }
Visual Basic
Public MustOverride ReadOnly Property IsForeignCurrencyAccount As Boolean
    Get

Property Value

Type: Boolean

See Also

DrCrAccount Class
DrCrAccount Members


DrCrTransaction Class

[image]

Pastel Evolution SDK
DrCrTransaction Class
Members See Also Send Feedback
A debtor and creditor transaction base class.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract class DrCrTransaction : TransactionBase,
    ICloneable
Visual Basic
Public MustInherit Class DrCrTransaction
    Inherits TransactionBase
    Implements ICloneable

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..TransactionBase
Pastel.Evolution..::..DrCrTransaction
Pastel.Evolution..::..CustomerTransaction
Pastel.Evolution..::..SupplierTransaction

See Also

DrCrTransaction Members


DrCrTransaction Members

[image] [image]

Pastel Evolution SDK
DrCrTransaction Members
DrCrTransaction Class Constructors Methods Fields Properties Events See Also Send Feedback

The DrCrTransaction type exposes the following members.

Constructors

 | Name | Description
Protected method | DrCrTransaction | Initializes a new instance of the DrCrTransaction class

Methods

 | Name | Description
Protected method | calcAmounts |
Public method | Clone |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getExchangeRate |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAllowBlockedPosting | (Inherited from TransactionBase.)
Protected method | OnOverrideControlAccount |
Protected method | OnOverrideTaxControlAccount |
Protected method | OnPost | (Inherited from TransactionBase.)
Protected method | onPostingGLCredit | (Inherited from TransactionBase.)
Protected method | onPostingGLDebit | (Inherited from TransactionBase.)
Protected method | onPostingGLVat | (Inherited from TransactionBase.)
Public method | Post | Posts the transaction to appropriate ledgers. (Inherited from TransactionBase.)
Protected method | RejectTransactionBranchAssignment | (Inherited from TransactionBase.)
Protected method | setExchangeRate |
Public method | ToString | (Overrides Object..::..ToString()()()().)
Public method | Validate | (Overrides TransactionBase..::..Validate()()()().)

Fields

 | Name | Description
Protected field | allocations |
Protected field | amount |
Protected field | branch |
Protected field | currency |
Protected field | fcQueue |
Protected field | foreignAmount |
Protected field | foreignOriginalTax | (Inherited from TransactionBase.)
Protected field | foreignTax |
Protected field | glCredit |
Protected field | glDebit |
Protected field | glForeignCredit |
Protected field | glForeignDebit |
Protected field | isDebitTrans | (Inherited from TransactionBase.)
Protected field | originalTax | (Inherited from TransactionBase.)
Protected field | project |
Protected field | readOnly | (Inherited from TransactionBase.)
Protected field | settlementTerms |
Protected field | splitAllocations |
Protected field | tax |
Protected field | taxType |
Protected field | tranCode |

Properties

 | Name | Description
Public property | Account | Gets or sets the transaction's account. (Inherited from TransactionBase.)
Public property | AccountID | Gets or sets the transaction's account id. (Inherited from TransactionBase.)
Public property | Allocations |
Public property | Amount | Gets or sets the transaction amount.
Public property | Audit | Gets the transaction's audit number. (Inherited from TransactionBase.)
Public property | Branch | (Overrides TransactionBase..::..Branch.)
Public property | BranchID | (Overrides TransactionBase..::..BranchID.)
Public property | Credit | Gets or sets the transaction's credit value. (Inherited from TransactionBase.)
Public property | Currency | Gets the foreign currency in use on this transaction, determined by the specified account. A null value indicates local currency.
Public property | CurrencyID |
Public property | Date | Gets or sets the transaction date. (Inherited from TransactionBase.)
Public property | Debit | Gets or sets the transaction's debit value. (Inherited from TransactionBase.)
Public property | Description | Gets or sets the transaction description. (Inherited from TransactionBase.)
Public property | ExchangeRate | Gets or sets the applicable exchange rate, expressed as [home currency]/[foreign currency]. Defaults to applicable exchange rate for the transaction date.
Public property | ExtOrderNo | Gets or sets the transaction's external order number. (Inherited from TransactionBase.)
Public property | ForeignAmount | Gets or sets the transaction foreign amount.
Public property | ForeignCredit |
Public property | ForeignDebit |
Public property | ForeignOutstanding | Gets the transaction's foreign outstanding amount.
Public property | ForeignTax |
Public property | ID | Gets the transaction id. (Inherited from TransactionBase.)
Public property | IsDebit | Indicates whether the transaction is a debit (true) or credit(false)
Public property | IsDebitPositive | Determines whether the derived transaction is by default nature a debit, i.e. a positive amount is a debit.
Public property | MaxForeignOutstanding | Gets the maximum possible foreign outstanding value for the given transaction, based on the ForeignDebit or ForeignCredit value.
Public property | MaxOutstanding | Gets the maximum possible outstanding value for the given transaction, based on the Debit or Credit value.
Public property | ModID | Gets or sets the transaction's Evolution module ID. (Inherited from TransactionBase.)
Public property | Module | Gets the transaction's Evolution module. (Inherited from TransactionBase.)
Public property | OrderNo | Gets or sets the transaction's order number. (Inherited from TransactionBase.)
Public property | Outstanding | Gets the transaction's outstanding amount.
Public property | Project | Sets the transaction's project. (Inherited from TransactionBase.)
Public property | ProjectID | Gets or sets the transaction's project id. (Inherited from TransactionBase.)
Public property | Reference | Gets or sets the transaction reference. (Inherited from TransactionBase.)
Public property | Reference2 | Gets or sets the 2nd transaction reference. (Inherited from TransactionBase.)
Public property | SettlementTerms |
Public property | SettlementTermsID |
Public property | SplitAllocations | Gets the transaction's split allocation collection.
Public property | Tax | Gets or sets the transaction tax amount. (Inherited from TransactionBase.)
Public property | TaxRate | Gets or sets the transaction's tax type. (Inherited from TransactionBase.)
Public property | TaxRateID | Gets or sets the transaction's tax type id. (Inherited from TransactionBase.)
Public property | TransactionCode | Gets or sets the transaction's transaction code. (Inherited from TransactionBase.)
Public property | TransactionCodeID | Gets or sets the transaction code id. (Inherited from TransactionBase.)

Events

 | Name | Description
Public event | GLCreditPosting | (Inherited from TransactionBase.)
Public event | GLDebitPosting | (Inherited from TransactionBase.)
Public event | GLVatPosting | (Inherited from TransactionBase.)

See Also

DrCrTransaction Class


DrCrTransaction Constructor

[image]

Pastel Evolution SDK
DrCrTransaction Constructor
DrCrTransaction Class See Also Send Feedback
Initializes a new instance of the DrCrTransaction class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected DrCrTransaction()
Visual Basic
Protected Sub New

See Also

DrCrTransaction Class
DrCrTransaction Members


DrCrTransaction Fields

[image] [image]

Pastel Evolution SDK
DrCrTransaction Fields
DrCrTransaction Class See Also Send Feedback

The DrCrTransaction type exposes the following members.

Fields

 | Name | Description
Protected field | allocations |
Protected field | amount |
Protected field | branch |
Protected field | currency |
Protected field | fcQueue |
Protected field | foreignAmount |
Protected field | foreignOriginalTax | (Inherited from TransactionBase.)
Protected field | foreignTax |
Protected field | glCredit |
Protected field | glDebit |
Protected field | glForeignCredit |
Protected field | glForeignDebit |
Protected field | isDebitTrans | (Inherited from TransactionBase.)
Protected field | originalTax | (Inherited from TransactionBase.)
Protected field | project |
Protected field | readOnly | (Inherited from TransactionBase.)
Protected field | settlementTerms |
Protected field | splitAllocations |
Protected field | tax |
Protected field | taxType |
Protected field | tranCode |

See Also

DrCrTransaction Class


DrCrTransaction.allocations Field

[image]

Pastel Evolution SDK
DrCrTransaction..::..allocations Field
DrCrTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal AllocationCollection allocations
Visual Basic
Protected Friend allocations As AllocationCollection

Field Value

Type: AllocationCollection

See Also

DrCrTransaction Class
DrCrTransaction Members


DrCrTransaction.amount Field

[image]

Pastel Evolution SDK
DrCrTransaction..::..amount Field
DrCrTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected double amount
Visual Basic
Protected amount As Double

Field Value

Type: Double

See Also

DrCrTransaction Class
DrCrTransaction Members


DrCrTransaction.branch Field

[image]

Pastel Evolution SDK
DrCrTransaction..::..branch Field
DrCrTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected Branch branch
Visual Basic
Protected branch As Branch

Field Value

Type: Branch

See Also

DrCrTransaction Class
DrCrTransaction Members


DrCrTransaction.currency Field

[image]

Pastel Evolution SDK
DrCrTransaction..::..currency Field
DrCrTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected Currency currency
Visual Basic
Protected currency As Currency

Field Value

Type: Currency

See Also

DrCrTransaction Class
DrCrTransaction Members


DrCrTransaction.fcQueue Field

[image]

Pastel Evolution SDK
DrCrTransaction..::..fcQueue Field
DrCrTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal Utils..::..LimitedQueue fcQueue
Visual Basic
Protected Friend fcQueue As Utils..::..LimitedQueue

Field Value

Type: Utils..::..LimitedQueue

See Also

DrCrTransaction Class
DrCrTransaction Members


DrCrTransaction.foreignAmount Field

[image]

Pastel Evolution SDK
DrCrTransaction..::..foreignAmount Field
DrCrTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected double foreignAmount
Visual Basic
Protected foreignAmount As Double

Field Value

Type: Double

See Also

DrCrTransaction Class
DrCrTransaction Members


DrCrTransaction.foreignTax Field

[image]

Pastel Evolution SDK
DrCrTransaction..::..foreignTax Field
DrCrTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected double foreignTax
Visual Basic
Protected foreignTax As Double

Field Value

Type: Double

See Also

DrCrTransaction Class
DrCrTransaction Members


DrCrTransaction.glCredit Field

[image]

Pastel Evolution SDK
DrCrTransaction..::..glCredit Field
DrCrTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected double glCredit
Visual Basic
Protected glCredit As Double

Field Value

Type: Double

See Also

DrCrTransaction Class
DrCrTransaction Members


DrCrTransaction.glDebit Field

[image]

Pastel Evolution SDK
DrCrTransaction..::..glDebit Field
DrCrTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected double glDebit
Visual Basic
Protected glDebit As Double

Field Value

Type: Double

See Also

DrCrTransaction Class
DrCrTransaction Members


DrCrTransaction.glForeignCredit Field

[image]

Pastel Evolution SDK
DrCrTransaction..::..glForeignCredit Field
DrCrTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected double glForeignCredit
Visual Basic
Protected glForeignCredit As Double

Field Value

Type: Double

See Also

DrCrTransaction Class
DrCrTransaction Members


DrCrTransaction.glForeignDebit Field

[image]

Pastel Evolution SDK
DrCrTransaction..::..glForeignDebit Field
DrCrTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected double glForeignDebit
Visual Basic
Protected glForeignDebit As Double

Field Value

Type: Double

See Also

DrCrTransaction Class
DrCrTransaction Members


DrCrTransaction.project Field

[image]

Pastel Evolution SDK
DrCrTransaction..::..project Field
DrCrTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal Project project
Visual Basic
Protected Friend project As Project

Field Value

Type: Project

See Also

DrCrTransaction Class
DrCrTransaction Members


DrCrTransaction.settlementTerms Field

[image]

Pastel Evolution SDK
DrCrTransaction..::..settlementTerms Field
DrCrTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal SettlementTerms settlementTerms
Visual Basic
Protected Friend settlementTerms As SettlementTerms

Field Value

Type: SettlementTerms

See Also

DrCrTransaction Class
DrCrTransaction Members


DrCrTransaction.splitAllocations Field

[image]

Pastel Evolution SDK
DrCrTransaction..::..splitAllocations Field
DrCrTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal SplitAllocationCollection splitAllocations
Visual Basic
Protected Friend splitAllocations As SplitAllocationCollection

Field Value

Type: SplitAllocationCollection

See Also

DrCrTransaction Class
DrCrTransaction Members


DrCrTransaction.tax Field

[image]

Pastel Evolution SDK
DrCrTransaction..::..tax Field
DrCrTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected double tax
Visual Basic
Protected tax As Double

Field Value

Type: Double

See Also

DrCrTransaction Class
DrCrTransaction Members


DrCrTransaction.taxType Field

[image]

Pastel Evolution SDK
DrCrTransaction..::..taxType Field
DrCrTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal TaxRate taxType
Visual Basic
Protected Friend taxType As TaxRate

Field Value

Type: TaxRate

See Also

DrCrTransaction Class
DrCrTransaction Members


DrCrTransaction.tranCode Field

[image]

Pastel Evolution SDK
DrCrTransaction..::..tranCode Field
DrCrTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal TransactionCodeBase tranCode
Visual Basic
Protected Friend tranCode As TransactionCodeBase

Field Value

Type: TransactionCodeBase

See Also

DrCrTransaction Class
DrCrTransaction Members


DrCrTransaction Methods

[image] [image]

Pastel Evolution SDK
DrCrTransaction Methods
DrCrTransaction Class See Also Send Feedback

The DrCrTransaction type exposes the following members.

Methods

 | Name | Description
Protected method | calcAmounts |
Public method | Clone |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getExchangeRate |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAllowBlockedPosting | (Inherited from TransactionBase.)
Protected method | OnOverrideControlAccount |
Protected method | OnOverrideTaxControlAccount |
Protected method | OnPost | (Inherited from TransactionBase.)
Protected method | onPostingGLCredit | (Inherited from TransactionBase.)
Protected method | onPostingGLDebit | (Inherited from TransactionBase.)
Protected method | onPostingGLVat | (Inherited from TransactionBase.)
Public method | Post | Posts the transaction to appropriate ledgers. (Inherited from TransactionBase.)
Protected method | RejectTransactionBranchAssignment | (Inherited from TransactionBase.)
Protected method | setExchangeRate |
Public method | ToString | (Overrides Object..::..ToString()()()().)
Public method | Validate | (Overrides TransactionBase..::..Validate()()()().)

See Also

DrCrTransaction Class


DrCrTransaction.calcAmounts Method

[image]

Pastel Evolution SDK
DrCrTransaction..::..calcAmounts Method
DrCrTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected void calcAmounts()
Visual Basic
Protected Sub calcAmounts

See Also

DrCrTransaction Class
DrCrTransaction Members


DrCrTransaction.Clone Method

[image]

Pastel Evolution SDK
DrCrTransaction..::..Clone Method
DrCrTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract Object Clone()
Visual Basic
Public MustOverride Function Clone As Object

Return Value

Type: Object

Implements

ICloneable..::..Clone()()()()

See Also

DrCrTransaction Class
DrCrTransaction Members


DrCrTransaction.getExchangeRate Method

[image]

Pastel Evolution SDK
DrCrTransaction..::..getExchangeRate Method
DrCrTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected abstract double getExchangeRate()
Visual Basic
Protected MustOverride Function getExchangeRate As Double

Return Value

Type: Double

See Also

DrCrTransaction Class
DrCrTransaction Members


DrCrTransaction.OnOverrideControlAccount Method

[image]

Pastel Evolution SDK
DrCrTransaction..::..OnOverrideControlAccount Method
DrCrTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal abstract void OnOverrideControlAccount(
    GLTransaction glTran
)
Visual Basic
Protected Friend MustOverride Sub OnOverrideControlAccount (
    glTran As GLTransaction
)

Parameters

glTran
Type: Pastel.Evolution..::..GLTransaction

See Also

DrCrTransaction Class
DrCrTransaction Members


DrCrTransaction.OnOverrideTaxControlAccount Method

[image]

Pastel Evolution SDK
DrCrTransaction..::..OnOverrideTaxControlAccount Method
DrCrTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal abstract void OnOverrideTaxControlAccount(
    TransactionCode tranCode,
    GLTransaction glTran
)
Visual Basic
Protected Friend MustOverride Sub OnOverrideTaxControlAccount (
    tranCode As TransactionCode,
    glTran As GLTransaction
)

Parameters

tranCode
Type: Pastel.Evolution..::..TransactionCode
glTran
Type: Pastel.Evolution..::..GLTransaction

See Also

DrCrTransaction Class
DrCrTransaction Members


DrCrTransaction.setExchangeRate Method

[image]

Pastel Evolution SDK
DrCrTransaction..::..setExchangeRate Method
DrCrTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected abstract void setExchangeRate(
    double value
)
Visual Basic
Protected MustOverride Sub setExchangeRate (
    value As Double
)

Parameters

value
Type: System..::..Double

See Also

DrCrTransaction Class
DrCrTransaction Members


DrCrTransaction.ToString Method

[image]

Pastel Evolution SDK
DrCrTransaction..::..ToString Method
DrCrTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String

See Also

DrCrTransaction Class
DrCrTransaction Members


DrCrTransaction.Validate Method

[image]

Pastel Evolution SDK
DrCrTransaction..::..Validate Method
DrCrTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override bool Validate()
Visual Basic
Public Overrides Function Validate As Boolean

Return Value

Type: Boolean

See Also

DrCrTransaction Class
DrCrTransaction Members


DrCrTransaction Properties

[image] [image]

Pastel Evolution SDK
DrCrTransaction Properties
DrCrTransaction Class See Also Send Feedback

The DrCrTransaction type exposes the following members.

Properties

 | Name | Description
Public property | Account | Gets or sets the transaction's account. (Inherited from TransactionBase.)
Public property | AccountID | Gets or sets the transaction's account id. (Inherited from TransactionBase.)
Public property | Allocations |
Public property | Amount | Gets or sets the transaction amount.
Public property | Audit | Gets the transaction's audit number. (Inherited from TransactionBase.)
Public property | Branch | (Overrides TransactionBase..::..Branch.)
Public property | BranchID | (Overrides TransactionBase..::..BranchID.)
Public property | Credit | Gets or sets the transaction's credit value. (Inherited from TransactionBase.)
Public property | Currency | Gets the foreign currency in use on this transaction, determined by the specified account. A null value indicates local currency.
Public property | CurrencyID |
Public property | Date | Gets or sets the transaction date. (Inherited from TransactionBase.)
Public property | Debit | Gets or sets the transaction's debit value. (Inherited from TransactionBase.)
Public property | Description | Gets or sets the transaction description. (Inherited from TransactionBase.)
Public property | ExchangeRate | Gets or sets the applicable exchange rate, expressed as [home currency]/[foreign currency]. Defaults to applicable exchange rate for the transaction date.
Public property | ExtOrderNo | Gets or sets the transaction's external order number. (Inherited from TransactionBase.)
Public property | ForeignAmount | Gets or sets the transaction foreign amount.
Public property | ForeignCredit |
Public property | ForeignDebit |
Public property | ForeignOutstanding | Gets the transaction's foreign outstanding amount.
Public property | ForeignTax |
Public property | ID | Gets the transaction id. (Inherited from TransactionBase.)
Public property | IsDebit | Indicates whether the transaction is a debit (true) or credit(false)
Public property | IsDebitPositive | Determines whether the derived transaction is by default nature a debit, i.e. a positive amount is a debit.
Public property | MaxForeignOutstanding | Gets the maximum possible foreign outstanding value for the given transaction, based on the ForeignDebit or ForeignCredit value.
Public property | MaxOutstanding | Gets the maximum possible outstanding value for the given transaction, based on the Debit or Credit value.
Public property | ModID | Gets or sets the transaction's Evolution module ID. (Inherited from TransactionBase.)
Public property | Module | Gets the transaction's Evolution module. (Inherited from TransactionBase.)
Public property | OrderNo | Gets or sets the transaction's order number. (Inherited from TransactionBase.)
Public property | Outstanding | Gets the transaction's outstanding amount.
Public property | Project | Sets the transaction's project. (Inherited from TransactionBase.)
Public property | ProjectID | Gets or sets the transaction's project id. (Inherited from TransactionBase.)
Public property | Reference | Gets or sets the transaction reference. (Inherited from TransactionBase.)
Public property | Reference2 | Gets or sets the 2nd transaction reference. (Inherited from TransactionBase.)
Public property | SettlementTerms |
Public property | SettlementTermsID |
Public property | SplitAllocations | Gets the transaction's split allocation collection.
Public property | Tax | Gets or sets the transaction tax amount. (Inherited from TransactionBase.)
Public property | TaxRate | Gets or sets the transaction's tax type. (Inherited from TransactionBase.)
Public property | TaxRateID | Gets or sets the transaction's tax type id. (Inherited from TransactionBase.)
Public property | TransactionCode | Gets or sets the transaction's transaction code. (Inherited from TransactionBase.)
Public property | TransactionCodeID | Gets or sets the transaction code id. (Inherited from TransactionBase.)

See Also

DrCrTransaction Class


DrCrTransaction.Allocations Property

[image]

Pastel Evolution SDK
DrCrTransaction..::..Allocations Property
DrCrTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract AllocationCollection Allocations { get; }
Visual Basic
Public MustOverride ReadOnly Property Allocations As AllocationCollection
    Get

Property Value

Type: AllocationCollection

See Also

DrCrTransaction Class
DrCrTransaction Members


DrCrTransaction.Amount Property

[image]

Pastel Evolution SDK
DrCrTransaction..::..Amount Property
DrCrTransaction Class See Also Send Feedback
Gets or sets the transaction amount.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract double Amount { get; set; }
Visual Basic
Public MustOverride Property Amount As Double
    Get
    Set

Property Value

Type: Double

See Also

DrCrTransaction Class
DrCrTransaction Members


DrCrTransaction.Branch Property

[image]

Pastel Evolution SDK
DrCrTransaction..::..Branch Property
DrCrTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract Branch Branch { get; }
Visual Basic
Public MustOverride ReadOnly Property Branch As Branch
    Get

Property Value

Type: Branch

Implements

IBranched..::..Branch

See Also

DrCrTransaction Class
DrCrTransaction Members


DrCrTransaction.BranchID Property

[image]

Pastel Evolution SDK
DrCrTransaction..::..BranchID Property
DrCrTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract int BranchID { get; }
Visual Basic
Public MustOverride ReadOnly Property BranchID As Integer
    Get

Property Value

Type: Int32

Implements

IBranched..::..BranchID

See Also

DrCrTransaction Class
DrCrTransaction Members


DrCrTransaction.Currency Property

[image]

Pastel Evolution SDK
DrCrTransaction..::..Currency Property
DrCrTransaction Class See Also Send Feedback
Gets the foreign currency in use on this transaction, determined by the specified account. A null value indicates local currency.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract Currency Currency { get; internal set; }
Visual Basic
Public MustOverride Property Currency As Currency
    Get
    Friend Set

Property Value

Type: Currency

See Also

DrCrTransaction Class
DrCrTransaction Members


DrCrTransaction.CurrencyID Property

[image]

Pastel Evolution SDK
DrCrTransaction..::..CurrencyID Property
DrCrTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract int CurrencyID { get; internal set; }
Visual Basic
Public MustOverride Property CurrencyID As Integer
    Get
    Friend Set

Property Value

Type: Int32

See Also

DrCrTransaction Class
DrCrTransaction Members


DrCrTransaction.ExchangeRate Property

[image]

Pastel Evolution SDK
DrCrTransaction..::..ExchangeRate Property
DrCrTransaction Class See Also Send Feedback
Gets or sets the applicable exchange rate, expressed as [home currency]/[foreign currency]. Defaults to applicable exchange rate for the transaction date.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double ExchangeRate { get; set; }
Visual Basic
Public Property ExchangeRate As Double
    Get
    Set

Property Value

Type: Double

See Also

DrCrTransaction Class
DrCrTransaction Members


DrCrTransaction.ForeignAmount Property

[image]

Pastel Evolution SDK
DrCrTransaction..::..ForeignAmount Property
DrCrTransaction Class See Also Send Feedback
Gets or sets the transaction foreign amount.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract double ForeignAmount { get; set; }
Visual Basic
Public MustOverride Property ForeignAmount As Double
    Get
    Set

Property Value

Type: Double

See Also

DrCrTransaction Class
DrCrTransaction Members


DrCrTransaction.ForeignCredit Property

[image]

Pastel Evolution SDK
DrCrTransaction..::..ForeignCredit Property
DrCrTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract double ForeignCredit { get; }
Visual Basic
Public MustOverride ReadOnly Property ForeignCredit As Double
    Get

Property Value

Type: Double

See Also

DrCrTransaction Class
DrCrTransaction Members


DrCrTransaction.ForeignDebit Property

[image]

Pastel Evolution SDK
DrCrTransaction..::..ForeignDebit Property
DrCrTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract double ForeignDebit { get; }
Visual Basic
Public MustOverride ReadOnly Property ForeignDebit As Double
    Get

Property Value

Type: Double

See Also

DrCrTransaction Class
DrCrTransaction Members


DrCrTransaction.ForeignOutstanding Property

[image]

Pastel Evolution SDK
DrCrTransaction..::..ForeignOutstanding Property
DrCrTransaction Class See Also Send Feedback
Gets the transaction's foreign outstanding amount.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract double ForeignOutstanding { get; internal set; }
Visual Basic
Public MustOverride Property ForeignOutstanding As Double
    Get
    Friend Set

Property Value

Type: Double

See Also

DrCrTransaction Class
DrCrTransaction Members


DrCrTransaction.ForeignTax Property

[image]

Pastel Evolution SDK
DrCrTransaction..::..ForeignTax Property
DrCrTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract double ForeignTax { get; set; }
Visual Basic
Public MustOverride Property ForeignTax As Double
    Get
    Set

Property Value

Type: Double

See Also

DrCrTransaction Class
DrCrTransaction Members


DrCrTransaction.IsDebit Property

[image]

Pastel Evolution SDK
DrCrTransaction..::..IsDebit Property
DrCrTransaction Class See Also Send Feedback
Indicates whether the transaction is a debit (true) or credit(false)

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool IsDebit { get; internal set; }
Visual Basic
Public Property IsDebit As Boolean
    Get
    Friend Set

Property Value

Type: Boolean

See Also

DrCrTransaction Class
DrCrTransaction Members


DrCrTransaction.IsDebitPositive Property

[image]

Pastel Evolution SDK
DrCrTransaction..::..IsDebitPositive Property
DrCrTransaction Class See Also Send Feedback
Determines whether the derived transaction is by default nature a debit, i.e. a positive amount is a debit.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract bool IsDebitPositive { get; }
Visual Basic
Public MustOverride ReadOnly Property IsDebitPositive As Boolean
    Get

Property Value

Type: Boolean

See Also

DrCrTransaction Class
DrCrTransaction Members


DrCrTransaction.MaxForeignOutstanding Property

[image]

Pastel Evolution SDK
DrCrTransaction..::..MaxForeignOutstanding Property
DrCrTransaction Class See Also Send Feedback
Gets the maximum possible foreign outstanding value for the given transaction, based on the ForeignDebit or ForeignCredit value.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double MaxForeignOutstanding { get; }
Visual Basic
Public ReadOnly Property MaxForeignOutstanding As Double
    Get

Property Value

Type: Double

See Also

DrCrTransaction Class
DrCrTransaction Members


DrCrTransaction.MaxOutstanding Property

[image]

Pastel Evolution SDK
DrCrTransaction..::..MaxOutstanding Property
DrCrTransaction Class See Also Send Feedback
Gets the maximum possible outstanding value for the given transaction, based on the Debit or Credit value.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double MaxOutstanding { get; }
Visual Basic
Public ReadOnly Property MaxOutstanding As Double
    Get

Property Value

Type: Double

See Also

DrCrTransaction Class
DrCrTransaction Members


DrCrTransaction.Outstanding Property

[image]

Pastel Evolution SDK
DrCrTransaction..::..Outstanding Property
DrCrTransaction Class See Also Send Feedback
Gets the transaction's outstanding amount.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract double Outstanding { get; internal set; }
Visual Basic
Public MustOverride Property Outstanding As Double
    Get
    Friend Set

Property Value

Type: Double

See Also

DrCrTransaction Class
DrCrTransaction Members


DrCrTransaction.SettlementTerms Property

[image]

Pastel Evolution SDK
DrCrTransaction..::..SettlementTerms Property
DrCrTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract SettlementTerms SettlementTerms { get; set; }
Visual Basic
Public MustOverride Property SettlementTerms As SettlementTerms
    Get
    Set

Property Value

Type: SettlementTerms

See Also

DrCrTransaction Class
DrCrTransaction Members


DrCrTransaction.SettlementTermsID Property

[image]

Pastel Evolution SDK
DrCrTransaction..::..SettlementTermsID Property
DrCrTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract int SettlementTermsID { get; set; }
Visual Basic
Public MustOverride Property SettlementTermsID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

DrCrTransaction Class
DrCrTransaction Members


DrCrTransaction.SplitAllocations Property

[image]

Pastel Evolution SDK
DrCrTransaction..::..SplitAllocations Property
DrCrTransaction Class See Also Send Feedback
Gets the transaction's split allocation collection.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract SplitAllocationCollection SplitAllocations { get; }
Visual Basic
Public MustOverride ReadOnly Property SplitAllocations As SplitAllocationCollection
    Get

Property Value

Type: SplitAllocationCollection

See Also

DrCrTransaction Class
DrCrTransaction Members


DrCrTransaction Events

[image] [image]

Pastel Evolution SDK
DrCrTransaction Events
DrCrTransaction Class See Also Send Feedback

The DrCrTransaction type exposes the following members.

Events

 | Name | Description
Public event | GLCreditPosting | (Inherited from TransactionBase.)
Public event | GLDebitPosting | (Inherited from TransactionBase.)
Public event | GLVatPosting | (Inherited from TransactionBase.)

See Also

DrCrTransaction Class


DrCrTransaction.FcCalcElement Enumeration

[image]

Pastel Evolution SDK
DrCrTransaction..::..FcCalcElement Enumeration
DrCrTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public enum FcCalcElement
Visual Basic
Public Enumeration FcCalcElement

Members

Member name | Value | Description
Amount | 0 |
ForeignAmount | 1 |
ExchangeRate | 2 |

See Also

Pastel.Evolution Namespace


EscalationGroup Class

[image]

Pastel Evolution SDK
EscalationGroup Class
Members See Also Send Feedback
Represents a Contact Management escalation group.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class EscalationGroup : BranchedRecordBase
Visual Basic
Public Class EscalationGroup
    Inherits BranchedRecordBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..EscalationGroup

See Also

EscalationGroup Members


EscalationGroup Members

[image] [image]

Pastel Evolution SDK
EscalationGroup Members
EscalationGroup Class Constructors Methods Fields Properties See Also Send Feedback

The EscalationGroup type exposes the following members.

Constructors

 | Name | Description
Public method | EscalationGroup()()()() | Creates a new instance of an escalation group.
Public method | EscalationGroup(Int32) | Creates a new instance of an escalation group.

Methods

 | Name | Description
 | _ListCurrentBranch |
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find |
 | FindByDescription |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Description |
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)

See Also

EscalationGroup Class


EscalationGroup Constructor

[image] [image]

Pastel Evolution SDK
EscalationGroup Constructor
EscalationGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EscalationGroup()()()() | Creates a new instance of an escalation group.
Public method | EscalationGroup(Int32) | Creates a new instance of an escalation group.

See Also

EscalationGroup Class
EscalationGroup Members


EscalationGroup Constructor

[image]

Pastel Evolution SDK
EscalationGroup Constructor
EscalationGroup Class See Also Send Feedback
Creates a new instance of an escalation group.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public EscalationGroup()
Visual Basic
Public Sub New

See Also

EscalationGroup Class
EscalationGroup Members
EscalationGroup Overload


EscalationGroup Constructor (Int32)

[image]

Pastel Evolution SDK
EscalationGroup Constructor (Int32)
EscalationGroup Class See Also Send Feedback
Creates a new instance of an escalation group.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public EscalationGroup(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32
Specifies the id of the existing record.

See Also

EscalationGroup Class
EscalationGroup Members
EscalationGroup Overload


EscalationGroup Fields

[image] [image]

Pastel Evolution SDK
EscalationGroup Fields
EscalationGroup Class See Also Send Feedback

The EscalationGroup type exposes the following members.

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

EscalationGroup Class


EscalationGroup Methods

[image] [image]

Pastel Evolution SDK
EscalationGroup Methods
EscalationGroup Class See Also Send Feedback

The EscalationGroup type exposes the following members.

Methods

 | Name | Description
 | _ListCurrentBranch |
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find |
 | FindByDescription |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

EscalationGroup Class


EscalationGroup._ListCurrentBranch Method

[image]

Pastel Evolution SDK
EscalationGroup..::.._ListCurrentBranch Method
EscalationGroup Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable _ListCurrentBranch(
    string criteria
)
Visual Basic
Public Shared Function _ListCurrentBranch (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String

Return Value

Type: DataTable

See Also

EscalationGroup Class
EscalationGroup Members


EscalationGroup.Find Method

[image]

Pastel Evolution SDK
EscalationGroup..::..Find Method
EscalationGroup Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String

Return Value

Type: Int32

See Also

EscalationGroup Class
EscalationGroup Members


EscalationGroup.FindByDescription Method

[image]

Pastel Evolution SDK
EscalationGroup..::..FindByDescription Method
EscalationGroup Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int FindByDescription(
    string description
)
Visual Basic
Public Shared Function FindByDescription (
    description As String
) As Integer

Parameters

description
Type: System..::..String

Return Value

Type: Int32

See Also

EscalationGroup Class
EscalationGroup Members


EscalationGroup.List Method

[image]

Pastel Evolution SDK
EscalationGroup..::..List Method
EscalationGroup Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria
)
Visual Basic
Public Shared Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String

Return Value

Type: DataTable

See Also

EscalationGroup Class
EscalationGroup Members


EscalationGroup.OnDelete Method

[image]

Pastel Evolution SDK
EscalationGroup..::..OnDelete Method
EscalationGroup Class See Also Send Feedback
Removes the record from the database, provided it is not referenced by other records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

Exceptions

Exception | Condition
IntegrityViolationException |

See Also

EscalationGroup Class
EscalationGroup Members


EscalationGroup.OnSave Method

[image]

Pastel Evolution SDK
EscalationGroup..::..OnSave Method
EscalationGroup Class See Also Send Feedback
Persists the record to the database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

EscalationGroup Class
EscalationGroup Members


EscalationGroup Properties

[image] [image]

Pastel Evolution SDK
EscalationGroup Properties
EscalationGroup Class See Also Send Feedback

The EscalationGroup type exposes the following members.

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Description |
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)

See Also

EscalationGroup Class


EscalationGroup.Description Property

[image]

Pastel Evolution SDK
EscalationGroup..::..Description Property
EscalationGroup Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set

Property Value

Type: String

See Also

EscalationGroup Class
EscalationGroup Members


EscalationGroup.ID Property

[image]

Pastel Evolution SDK
EscalationGroup..::..ID Property
EscalationGroup Class See Also Send Feedback
Gets the internal record ID (0 for new, unsaved records).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

See Also

EscalationGroup Class
EscalationGroup Members


EscalationGroup.LongID Property

[image]

Pastel Evolution SDK
EscalationGroup..::..LongID Property
EscalationGroup Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

EscalationGroup Class
EscalationGroup Members


EvolutionDatabaseException Class

[image]

Pastel Evolution SDK
EvolutionDatabaseException Class
Members See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class EvolutionDatabaseException : EvolutionException
Visual Basic
Public Class EvolutionDatabaseException
    Inherits EvolutionException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Pastel.Evolution..::..EvolutionException
Pastel.Evolution..::..EvolutionDatabaseException

See Also

EvolutionDatabaseException Members


EvolutionDatabaseException Members

[image] [image]

Pastel Evolution SDK
EvolutionDatabaseException Members
EvolutionDatabaseException Class Constructors Methods Properties See Also Send Feedback

The EvolutionDatabaseException type exposes the following members.

Constructors

 | Name | Description
Public method | EvolutionDatabaseException(String) | Initializes a new instance of the EvolutionDatabaseException class
Public method | EvolutionDatabaseException(String, Object) | Initializes a new instance of the EvolutionDatabaseException class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

EvolutionDatabaseException Class


EvolutionDatabaseException Constructor

[image] [image]

Pastel Evolution SDK
EvolutionDatabaseException Constructor
EvolutionDatabaseException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EvolutionDatabaseException(String) | Initializes a new instance of the EvolutionDatabaseException class
Public method | EvolutionDatabaseException(String, Object) | Initializes a new instance of the EvolutionDatabaseException class

See Also

EvolutionDatabaseException Class
EvolutionDatabaseException Members


EvolutionDatabaseException Constructor (String)

[image]

Pastel Evolution SDK
EvolutionDatabaseException Constructor (String)
EvolutionDatabaseException Class See Also Send Feedback
Initializes a new instance of the EvolutionDatabaseException class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public EvolutionDatabaseException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)

Parameters

message
Type: System..::..String

See Also

EvolutionDatabaseException Class
EvolutionDatabaseException Members
EvolutionDatabaseException Overload


EvolutionDatabaseException Constructor (String, Object)

[image]

Pastel Evolution SDK
EvolutionDatabaseException Constructor (String, Object)
EvolutionDatabaseException Class See Also Send Feedback
Initializes a new instance of the EvolutionDatabaseException class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public EvolutionDatabaseException(
    string message,
    Object arg0
)
Visual Basic
Public Sub New (
    message As String,
    arg0 As Object
)

Parameters

message
Type: System..::..String
arg0
Type: System..::..Object

See Also

EvolutionDatabaseException Class
EvolutionDatabaseException Members
EvolutionDatabaseException Overload


EvolutionDatabaseException Methods

[image] [image]

Pastel Evolution SDK
EvolutionDatabaseException Methods
EvolutionDatabaseException Class See Also Send Feedback

The EvolutionDatabaseException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

EvolutionDatabaseException Class


EvolutionDatabaseException Properties

[image] [image]

Pastel Evolution SDK
EvolutionDatabaseException Properties
EvolutionDatabaseException Class See Also Send Feedback

The EvolutionDatabaseException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

EvolutionDatabaseException Class


EvolutionException Class

[image]

Pastel Evolution SDK
EvolutionException Class
Members See Also Send Feedback
A generic SDK exception class from which other SDK exception types inherit.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class EvolutionException : Exception
Visual Basic
Public Class EvolutionException
    Inherits Exception

Inheritance Hierarchy

System..::..Object
System..::..Exception
Pastel.Evolution..::..EvolutionException
Pastel.Evolution..::..EvolutionDatabaseException
Pastel.Evolution..::..EvolutionNullReferenceException

See Also

EvolutionException Members


EvolutionException Members

[image] [image]

Pastel Evolution SDK
EvolutionException Members
EvolutionException Class Constructors Methods Properties See Also Send Feedback

The EvolutionException type exposes the following members.

Constructors

 | Name | Description
Public method | EvolutionException(String) | Initializes a new instance of the EvolutionException class
Public method | EvolutionException(String, EvolutionException) | Initializes a new instance of the EvolutionException class
Public method | EvolutionException(String, Object) | Initializes a new instance of the EvolutionException class
Public method | EvolutionException(String, array<Object>[]()[][]) | Initializes a new instance of the EvolutionException class
Public method | EvolutionException(String, Object, Object) | Initializes a new instance of the EvolutionException class
Public method | EvolutionException(String, Object, Object, Object) | Initializes a new instance of the EvolutionException class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

EvolutionException Class


EvolutionException Constructor

[image] [image]

Pastel Evolution SDK
EvolutionException Constructor
EvolutionException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EvolutionException(String) | Initializes a new instance of the EvolutionException class
Public method | EvolutionException(String, EvolutionException) | Initializes a new instance of the EvolutionException class
Public method | EvolutionException(String, Object) | Initializes a new instance of the EvolutionException class
Public method | EvolutionException(String, array<Object>[]()[][]) | Initializes a new instance of the EvolutionException class
Public method | EvolutionException(String, Object, Object) | Initializes a new instance of the EvolutionException class
Public method | EvolutionException(String, Object, Object, Object) | Initializes a new instance of the EvolutionException class

See Also

EvolutionException Class
EvolutionException Members


EvolutionException Constructor (String)

[image]

Pastel Evolution SDK
EvolutionException Constructor (String)
EvolutionException Class See Also Send Feedback
Initializes a new instance of the EvolutionException class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public EvolutionException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)

Parameters

message
Type: System..::..String

See Also

EvolutionException Class
EvolutionException Members
EvolutionException Overload


EvolutionException Constructor (String, EvolutionException)

[image]

Pastel Evolution SDK
EvolutionException Constructor (String, EvolutionException)
EvolutionException Class See Also Send Feedback
Initializes a new instance of the EvolutionException class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public EvolutionException(
    string message,
    EvolutionException innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As EvolutionException
)

Parameters

message
Type: System..::..String
innerException
Type: Pastel.Evolution..::..EvolutionException

See Also

EvolutionException Class
EvolutionException Members
EvolutionException Overload


EvolutionException Constructor (String, Object)

[image]

Pastel Evolution SDK
EvolutionException Constructor (String, Object)
EvolutionException Class See Also Send Feedback
Initializes a new instance of the EvolutionException class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public EvolutionException(
    string message,
    Object arg0
)
Visual Basic
Public Sub New (
    message As String,
    arg0 As Object
)

Parameters

message
Type: System..::..String
arg0
Type: System..::..Object

See Also

EvolutionException Class
EvolutionException Members
EvolutionException Overload


EvolutionException Constructor (String, Object[])

[image]

Pastel Evolution SDK
EvolutionException Constructor (String, array<Object>[]()[][])
EvolutionException Class See Also Send Feedback
Initializes a new instance of the EvolutionException class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public EvolutionException(
    string message,
    params Object[] args
)
Visual Basic
Public Sub New (
    message As String,
    ParamArray args As Object()
)

Parameters

message
Type: System..::..String
args
Type: array< System..::..Object >[]()[][]

See Also

EvolutionException Class
EvolutionException Members
EvolutionException Overload


EvolutionException Constructor (String, Object, Object)

[image]

Pastel Evolution SDK
EvolutionException Constructor (String, Object, Object)
EvolutionException Class See Also Send Feedback
Initializes a new instance of the EvolutionException class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public EvolutionException(
    string message,
    Object arg0,
    Object arg1
)
Visual Basic
Public Sub New (
    message As String,
    arg0 As Object,
    arg1 As Object
)

Parameters

message
Type: System..::..String
arg0
Type: System..::..Object
arg1
Type: System..::..Object

See Also

EvolutionException Class
EvolutionException Members
EvolutionException Overload


EvolutionException Constructor (String, Object, Object, Object)

[image]

Pastel Evolution SDK
EvolutionException Constructor (String, Object, Object, Object)
EvolutionException Class See Also Send Feedback
Initializes a new instance of the EvolutionException class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public EvolutionException(
    string message,
    Object arg0,
    Object arg1,
    Object arg2
)
Visual Basic
Public Sub New (
    message As String,
    arg0 As Object,
    arg1 As Object,
    arg2 As Object
)

Parameters

message
Type: System..::..String
arg0
Type: System..::..Object
arg1
Type: System..::..Object
arg2
Type: System..::..Object

See Also

EvolutionException Class
EvolutionException Members
EvolutionException Overload


EvolutionException Methods

[image] [image]

Pastel Evolution SDK
EvolutionException Methods
EvolutionException Class See Also Send Feedback

The EvolutionException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

EvolutionException Class


EvolutionException Properties

[image] [image]

Pastel Evolution SDK
EvolutionException Properties
EvolutionException Class See Also Send Feedback

The EvolutionException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

EvolutionException Class


EvolutionNullReferenceException Class

[image]

Pastel Evolution SDK
EvolutionNullReferenceException Class
Members See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class EvolutionNullReferenceException : EvolutionException
Visual Basic
Public Class EvolutionNullReferenceException
    Inherits EvolutionException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Pastel.Evolution..::..EvolutionException
Pastel.Evolution..::..EvolutionNullReferenceException

See Also

EvolutionNullReferenceException Members


EvolutionNullReferenceException Members

[image] [image]

Pastel Evolution SDK
EvolutionNullReferenceException Members
EvolutionNullReferenceException Class Constructors Methods Properties See Also Send Feedback

The EvolutionNullReferenceException type exposes the following members.

Constructors

 | Name | Description
Public method | EvolutionNullReferenceException | Initializes a new instance of the EvolutionNullReferenceException class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

EvolutionNullReferenceException Class


EvolutionNullReferenceException Constructor

[image]

Pastel Evolution SDK
EvolutionNullReferenceException Constructor
EvolutionNullReferenceException Class See Also Send Feedback
Initializes a new instance of the EvolutionNullReferenceException class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public EvolutionNullReferenceException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)

Parameters

message
Type: System..::..String

See Also

EvolutionNullReferenceException Class
EvolutionNullReferenceException Members


EvolutionNullReferenceException Methods

[image] [image]

Pastel Evolution SDK
EvolutionNullReferenceException Methods
EvolutionNullReferenceException Class See Also Send Feedback

The EvolutionNullReferenceException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

EvolutionNullReferenceException Class


EvolutionNullReferenceException Properties

[image] [image]

Pastel Evolution SDK
EvolutionNullReferenceException Properties
EvolutionNullReferenceException Class See Also Send Feedback

The EvolutionNullReferenceException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

EvolutionNullReferenceException Class


EvolutionVersion Class

[image]

Pastel Evolution SDK
EvolutionVersion Class
Members See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class EvolutionVersion
Visual Basic
Public Class EvolutionVersion

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..EvolutionVersion

See Also

EvolutionVersion Members


EvolutionVersion Members

[image] [image]

Pastel Evolution SDK
EvolutionVersion Members
EvolutionVersion Class Constructors Methods Operators Properties See Also Send Feedback

The EvolutionVersion type exposes the following members.

Constructors

 | Name | Description
Public method | EvolutionVersion | Initializes a new instance of the EvolutionVersion class

Methods

 | Name | Description
Public method | Equals | (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

Operators

Name | Description
GreaterThan |
LessThan |

Properties

 | Name | Description
Public property | Build |
Public property | Major |
Public property | Minor |
Public property | Special |

See Also

EvolutionVersion Class


EvolutionVersion Constructor

[image]

Pastel Evolution SDK
EvolutionVersion Constructor
EvolutionVersion Class See Also Send Feedback
Initializes a new instance of the EvolutionVersion class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public EvolutionVersion(
    string version
)
Visual Basic
Public Sub New (
    version As String
)

Parameters

version
Type: System..::..String

See Also

EvolutionVersion Class
EvolutionVersion Members


EvolutionVersion Methods

[image] [image]

Pastel Evolution SDK
EvolutionVersion Methods
EvolutionVersion Class See Also Send Feedback

The EvolutionVersion type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

EvolutionVersion Class


EvolutionVersion.Equals Method

[image]

Pastel Evolution SDK
EvolutionVersion..::..Equals Method
EvolutionVersion Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: System..::..Object

Return Value

Type: Boolean

See Also

EvolutionVersion Class
EvolutionVersion Members


EvolutionVersion.GetHashCode Method

[image]

Pastel Evolution SDK
EvolutionVersion..::..GetHashCode Method
EvolutionVersion Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32

See Also

EvolutionVersion Class
EvolutionVersion Members


EvolutionVersion.ToString Method

[image]

Pastel Evolution SDK
EvolutionVersion..::..ToString Method
EvolutionVersion Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String

See Also

EvolutionVersion Class
EvolutionVersion Members


EvolutionVersion Operators

[image] [image]

Pastel Evolution SDK
EvolutionVersion Operators
EvolutionVersion Class See Also Send Feedback

The EvolutionVersion type exposes the following members.

Operators

Name | Description
GreaterThan |
LessThan |

See Also

EvolutionVersion Class


EvolutionVersion.GreaterThan Operator

[image]

Pastel Evolution SDK
EvolutionVersion..::..GreaterThan Operator
EvolutionVersion Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static bool operator >(
    EvolutionVersion verA,
    EvolutionVersion verB
)
Visual Basic
Public Shared Operator > (
    verA As EvolutionVersion,
    verB As EvolutionVersion
) As Boolean

Parameters

verA
Type: Pastel.Evolution..::..EvolutionVersion
verB
Type: Pastel.Evolution..::..EvolutionVersion

Return Value

Type: Boolean

See Also

EvolutionVersion Class
EvolutionVersion Members


EvolutionVersion.LessThan Operator

[image]

Pastel Evolution SDK
EvolutionVersion..::..LessThan Operator
EvolutionVersion Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static bool operator <(
    EvolutionVersion verA,
    EvolutionVersion verB
)
Visual Basic
Public Shared Operator < (
    verA As EvolutionVersion,
    verB As EvolutionVersion
) As Boolean

Parameters

verA
Type: Pastel.Evolution..::..EvolutionVersion
verB
Type: Pastel.Evolution..::..EvolutionVersion

Return Value

Type: Boolean

See Also

EvolutionVersion Class
EvolutionVersion Members


EvolutionVersion Properties

[image] [image]

Pastel Evolution SDK
EvolutionVersion Properties
EvolutionVersion Class See Also Send Feedback

The EvolutionVersion type exposes the following members.

Properties

 | Name | Description
Public property | Build |
Public property | Major |
Public property | Minor |
Public property | Special |

See Also

EvolutionVersion Class


EvolutionVersion.Build Property

[image]

Pastel Evolution SDK
EvolutionVersion..::..Build Property
EvolutionVersion Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int Build { get; internal set; }
Visual Basic
Public Property Build As Integer
    Get
    Friend Set

Property Value

Type: Int32

See Also

EvolutionVersion Class
EvolutionVersion Members


EvolutionVersion.Major Property

[image]

Pastel Evolution SDK
EvolutionVersion..::..Major Property
EvolutionVersion Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int Major { get; internal set; }
Visual Basic
Public Property Major As Integer
    Get
    Friend Set

Property Value

Type: Int32

See Also

EvolutionVersion Class
EvolutionVersion Members


EvolutionVersion.Minor Property

[image]

Pastel Evolution SDK
EvolutionVersion..::..Minor Property
EvolutionVersion Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int Minor { get; internal set; }
Visual Basic
Public Property Minor As Integer
    Get
    Friend Set

Property Value

Type: Int32

See Also

EvolutionVersion Class
EvolutionVersion Members


EvolutionVersion.Special Property

[image]

Pastel Evolution SDK
EvolutionVersion..::..Special Property
EvolutionVersion Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public EvolutionVersion..::..SpecialBuilds Special { get; internal set; }
Visual Basic
Public Property Special As EvolutionVersion..::..SpecialBuilds
    Get
    Friend Set

Property Value

Type: EvolutionVersion..::..SpecialBuilds

See Also

EvolutionVersion Class
EvolutionVersion Members


EvolutionVersion.SpecialBuilds Enumeration

[image]

Pastel Evolution SDK
EvolutionVersion..::..SpecialBuilds Enumeration
EvolutionVersion Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public enum SpecialBuilds
Visual Basic
Public Enumeration SpecialBuilds

Members

Member name | Value | Description
None | -1 |
Beta | 0 |
Internal | 1 |

See Also

Pastel.Evolution Namespace


ExchangeRate Class

[image]

Pastel Evolution SDK
ExchangeRate Class
Members See Also Send Feedback
Represents a hist record.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class ExchangeRate : BranchedRecordBase
Visual Basic
Public Class ExchangeRate
    Inherits BranchedRecordBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..ExchangeRate

See Also

ExchangeRate Members


ExchangeRate Members

[image] [image]

Pastel Evolution SDK
ExchangeRate Members
ExchangeRate Class Constructors Methods Fields Properties See Also Send Feedback

The ExchangeRate type exposes the following members.

Constructors

 | Name | Description
Public method | ExchangeRate()()()() | Creates a new instance of an exchange rate.
Public method | ExchangeRate(Int32) | Creates a new instance of an exchange rate.
Public method | ExchangeRate(Int32, DateTime) | Creates a new instance of an exchange rate.
Public method | ExchangeRate(Int32, Double, DateTime) | Creates a new instance of an exchange rate.

Methods

 | Name | Description
 | _Select(Int32) |
 | _Select(Currency) |
 | _Select(String, String) |
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find(String) | Finds a record's database ID.
 | Find(Int32, DateTime) | Finds a record's database ID.
 | FindLatest(Int32, DateTime) |
 | FindLatest(Int32, DateTime, Boolean) |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List(String) |
 | List(String, String) | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | (Overrides Object..::..ToString()()()().)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | BuyingRate | Gets or sets the buying rate, expressed as [home currency]/[foreign currency]. Defaults to 1.
Public property | Currency | Gets or sets the foreign currency associated with this exchange rate.
Public property | CurrencyID | Gets or sets the ID of the foreign currency associated with this exchange rate.
Public property | Date | Gets or sets the date for which the rate applies.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | Rate | Sets both the buying and selling rates.
Public property | SellingRate | Gets or sets the selling rate, expressed as [home currency]/[foreign currency]. Defaults to 1.

See Also

ExchangeRate Class


ExchangeRate Constructor

[image] [image]

Pastel Evolution SDK
ExchangeRate Constructor
ExchangeRate Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ExchangeRate()()()() | Creates a new instance of an exchange rate.
Public method | ExchangeRate(Int32) | Creates a new instance of an exchange rate.
Public method | ExchangeRate(Int32, DateTime) | Creates a new instance of an exchange rate.
Public method | ExchangeRate(Int32, Double, DateTime) | Creates a new instance of an exchange rate.

See Also

ExchangeRate Class
ExchangeRate Members


ExchangeRate Constructor

[image]

Pastel Evolution SDK
ExchangeRate Constructor
ExchangeRate Class See Also Send Feedback
Creates a new instance of an exchange rate.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public ExchangeRate()
Visual Basic
Public Sub New

See Also

ExchangeRate Class
ExchangeRate Members
ExchangeRate Overload


ExchangeRate Constructor (Int32)

[image]

Pastel Evolution SDK
ExchangeRate Constructor (Int32)
ExchangeRate Class See Also Send Feedback
Creates a new instance of an exchange rate.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public ExchangeRate(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32
Specifies the id of the existing record.

See Also

ExchangeRate Class
ExchangeRate Members
ExchangeRate Overload


ExchangeRate Constructor (Int32, DateTime)

[image]

Pastel Evolution SDK
ExchangeRate Constructor (Int32, DateTime)
ExchangeRate Class See Also Send Feedback
Creates a new instance of an exchange rate.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public ExchangeRate(
    int currencyID,
    DateTime date
)
Visual Basic
Public Sub New (
    currencyID As Integer,
    date As DateTime
)

Parameters

currencyID
Type: System..::..Int32
date
Type: System..::..DateTime

See Also

ExchangeRate Class
ExchangeRate Members
ExchangeRate Overload


ExchangeRate Constructor (Int32, Double, DateTime)

[image]

Pastel Evolution SDK
ExchangeRate Constructor (Int32, Double, DateTime)
ExchangeRate Class See Also Send Feedback
Creates a new instance of an exchange rate.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public ExchangeRate(
    int currencyID,
    double rate,
    DateTime date
)
Visual Basic
Public Sub New (
    currencyID As Integer,
    rate As Double,
    date As DateTime
)

Parameters

currencyID
Type: System..::..Int32
rate
Type: System..::..Double
date
Type: System..::..DateTime

See Also

ExchangeRate Class
ExchangeRate Members
ExchangeRate Overload


ExchangeRate Fields

[image] [image]

Pastel Evolution SDK
ExchangeRate Fields
ExchangeRate Class See Also Send Feedback

The ExchangeRate type exposes the following members.

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

ExchangeRate Class


ExchangeRate Methods

[image] [image]

Pastel Evolution SDK
ExchangeRate Methods
ExchangeRate Class See Also Send Feedback

The ExchangeRate type exposes the following members.

Methods

 | Name | Description
 | _Select(Int32) |
 | _Select(Currency) |
 | _Select(String, String) |
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find(String) | Finds a record's database ID.
 | Find(Int32, DateTime) | Finds a record's database ID.
 | FindLatest(Int32, DateTime) |
 | FindLatest(Int32, DateTime, Boolean) |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List(String) |
 | List(String, String) | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | (Overrides Object..::..ToString()()()().)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

ExchangeRate Class


ExchangeRate._Select Method

[image] [image]

Pastel Evolution SDK
ExchangeRate..::.._Select Method
ExchangeRate Class See Also Send Feedback

Overload List

Name | Description
_Select(Int32) |
_Select(Currency) |
_Select(String, String) |

See Also

ExchangeRate Class
ExchangeRate Members


ExchangeRate._Select Method (Int32)

[image]

Pastel Evolution SDK
ExchangeRate..::.._Select Method (Int32)
ExchangeRate Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static ExchangeRate[] _Select(
    int currencyID
)
Visual Basic
Public Shared Function _Select (
    currencyID As Integer
) As ExchangeRate()

Parameters

currencyID
Type: System..::..Int32

Return Value

Type: array< ExchangeRate >[]()[][]

See Also

ExchangeRate Class
ExchangeRate Members
_Select Overload


ExchangeRate._Select Method (Currency)

[image]

Pastel Evolution SDK
ExchangeRate..::.._Select Method (Currency)
ExchangeRate Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static ExchangeRate[] _Select(
    Currency owner
)
Visual Basic
Public Shared Function _Select (
    owner As Currency
) As ExchangeRate()

Parameters

owner
Type: Pastel.Evolution..::..Currency

Return Value

Type: array< ExchangeRate >[]()[][]

See Also

ExchangeRate Class
ExchangeRate Members
_Select Overload


ExchangeRate._Select Method (String, String)

[image]

Pastel Evolution SDK
ExchangeRate..::.._Select Method (String, String)
ExchangeRate Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static ExchangeRate[] _Select(
    string criteria,
    string sortOrder
)
Visual Basic
Public Shared Function _Select (
    criteria As String,
    sortOrder As String
) As ExchangeRate()

Parameters

criteria
Type: System..::..String
sortOrder
Type: System..::..String

Return Value

Type: array< ExchangeRate >[]()[][]

See Also

ExchangeRate Class
ExchangeRate Members
_Select Overload


ExchangeRate.Find Method

[image] [image]

Pastel Evolution SDK
ExchangeRate..::..Find Method
ExchangeRate Class See Also Send Feedback

Overload List

Name | Description
Find(String) | Finds a record's database ID.
Find(Int32, DateTime) | Finds a record's database ID.

See Also

ExchangeRate Class
ExchangeRate Members


ExchangeRate.Find Method (String)

[image]

Pastel Evolution SDK
ExchangeRate..::..Find Method (String)
ExchangeRate Class See Also Send Feedback
Finds a record's database ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.

Return Value

Type: Int32
The ID of the first record found; -1 if not record was found.

See Also

ExchangeRate Class
ExchangeRate Members
Find Overload


ExchangeRate.Find Method (Int32, DateTime)

[image]

Pastel Evolution SDK
ExchangeRate..::..Find Method (Int32, DateTime)
ExchangeRate Class See Also Send Feedback
Finds a record's database ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    int currencyID,
    DateTime date
)
Visual Basic
Public Shared Function Find (
    currencyID As Integer,
    date As DateTime
) As Integer

Parameters

currencyID
Type: System..::..Int32
date
Type: System..::..DateTime

Return Value

Type: Int32
The ID of the first record found; -1 if not record was found.

See Also

ExchangeRate Class
ExchangeRate Members
Find Overload


ExchangeRate.FindLatest Method

[image] [image]

Pastel Evolution SDK
ExchangeRate..::..FindLatest Method
ExchangeRate Class See Also Send Feedback

Overload List

Name | Description
FindLatest(Int32, DateTime) |
FindLatest(Int32, DateTime, Boolean) |

See Also

ExchangeRate Class
ExchangeRate Members


ExchangeRate.FindLatest Method (Int32, DateTime)

[image]

Pastel Evolution SDK
ExchangeRate..::..FindLatest Method (Int32, DateTime)
ExchangeRate Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int FindLatest(
    int currencyID,
    DateTime date
)
Visual Basic
Public Shared Function FindLatest (
    currencyID As Integer,
    date As DateTime
) As Integer

Parameters

currencyID
Type: System..::..Int32
date
Type: System..::..DateTime

Return Value

Type: Int32

See Also

ExchangeRate Class
ExchangeRate Members
FindLatest Overload


ExchangeRate.FindLatest Method (Int32, DateTime, Boolean)

[image]

Pastel Evolution SDK
ExchangeRate..::..FindLatest Method (Int32, DateTime, Boolean)
ExchangeRate Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int FindLatest(
    int currencyID,
    DateTime date,
    bool exact
)
Visual Basic
Public Shared Function FindLatest (
    currencyID As Integer,
    date As DateTime,
    exact As Boolean
) As Integer

Parameters

currencyID
Type: System..::..Int32
date
Type: System..::..DateTime
exact
Type: System..::..Boolean

Return Value

Type: Int32

See Also

ExchangeRate Class
ExchangeRate Members
FindLatest Overload


ExchangeRate.List Method

[image] [image]

Pastel Evolution SDK
ExchangeRate..::..List Method
ExchangeRate Class See Also Send Feedback

Overload List

Name | Description
List(String) |
List(String, String) | Gets a list of database records.

See Also

ExchangeRate Class
ExchangeRate Members


ExchangeRate.List Method (String)

[image]

Pastel Evolution SDK
ExchangeRate..::..List Method (String)
ExchangeRate Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria
)
Visual Basic
Public Shared Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String

Return Value

Type: DataTable

See Also

ExchangeRate Class
ExchangeRate Members
List Overload


ExchangeRate.List Method (String, String)

[image]

Pastel Evolution SDK
ExchangeRate..::..List Method (String, String)
ExchangeRate Class See Also Send Feedback
Gets a list of database records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria,
    string sortOrder
)
Visual Basic
Public Shared Function List (
    criteria As String,
    sortOrder As String
) As DataTable

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.
sortOrder
Type: System..::..String
The SQL order by clause to use, e.g. dRateDate desc

Return Value

Type: DataTable
Table containing selected records.

See Also

ExchangeRate Class
ExchangeRate Members
List Overload


ExchangeRate.OnDelete Method

[image]

Pastel Evolution SDK
ExchangeRate..::..OnDelete Method
ExchangeRate Class See Also Send Feedback
Removes the record from the database, provided it is not referenced by other records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

Exceptions

Exception | Condition
IntegrityViolationException |

See Also

ExchangeRate Class
ExchangeRate Members


ExchangeRate.OnSave Method

[image]

Pastel Evolution SDK
ExchangeRate..::..OnSave Method
ExchangeRate Class See Also Send Feedback
Persists the record to the database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

ExchangeRate Class
ExchangeRate Members


ExchangeRate.ToString Method

[image]

Pastel Evolution SDK
ExchangeRate..::..ToString Method
ExchangeRate Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String

See Also

ExchangeRate Class
ExchangeRate Members


ExchangeRate Properties

[image] [image]

Pastel Evolution SDK
ExchangeRate Properties
ExchangeRate Class See Also Send Feedback

The ExchangeRate type exposes the following members.

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | BuyingRate | Gets or sets the buying rate, expressed as [home currency]/[foreign currency]. Defaults to 1.
Public property | Currency | Gets or sets the foreign currency associated with this exchange rate.
Public property | CurrencyID | Gets or sets the ID of the foreign currency associated with this exchange rate.
Public property | Date | Gets or sets the date for which the rate applies.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | Rate | Sets both the buying and selling rates.
Public property | SellingRate | Gets or sets the selling rate, expressed as [home currency]/[foreign currency]. Defaults to 1.

See Also

ExchangeRate Class


ExchangeRate.BuyingRate Property

[image]

Pastel Evolution SDK
ExchangeRate..::..BuyingRate Property
ExchangeRate Class See Also Send Feedback
Gets or sets the buying rate, expressed as [home currency]/[foreign currency]. Defaults to 1.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double BuyingRate { get; set; }
Visual Basic
Public Property BuyingRate As Double
    Get
    Set

Property Value

Type: Double

See Also

ExchangeRate Class
ExchangeRate Members


ExchangeRate.Currency Property

[image]

Pastel Evolution SDK
ExchangeRate..::..Currency Property
ExchangeRate Class See Also Send Feedback
Gets or sets the foreign currency associated with this exchange rate.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Currency Currency { get; set; }
Visual Basic
Public Property Currency As Currency
    Get
    Set

Property Value

Type: Currency

See Also

ExchangeRate Class
ExchangeRate Members


ExchangeRate.CurrencyID Property

[image]

Pastel Evolution SDK
ExchangeRate..::..CurrencyID Property
ExchangeRate Class See Also Send Feedback
Gets or sets the ID of the foreign currency associated with this exchange rate.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int CurrencyID { get; set; }
Visual Basic
Public Property CurrencyID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

ExchangeRate Class
ExchangeRate Members


ExchangeRate.Date Property

[image]

Pastel Evolution SDK
ExchangeRate..::..Date Property
ExchangeRate Class See Also Send Feedback
Gets or sets the date for which the rate applies.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DateTime Date { get; set; }
Visual Basic
Public Property Date As DateTime
    Get
    Set

Property Value

Type: DateTime

See Also

ExchangeRate Class
ExchangeRate Members


ExchangeRate.ID Property

[image]

Pastel Evolution SDK
ExchangeRate..::..ID Property
ExchangeRate Class See Also Send Feedback
Gets the internal record ID (0 for new, unsaved records).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

See Also

ExchangeRate Class
ExchangeRate Members


ExchangeRate.LongID Property

[image]

Pastel Evolution SDK
ExchangeRate..::..LongID Property
ExchangeRate Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

ExchangeRate Class
ExchangeRate Members


ExchangeRate.Rate Property

[image]

Pastel Evolution SDK
ExchangeRate..::..Rate Property
ExchangeRate Class See Also Send Feedback
Sets both the buying and selling rates.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double Rate { set; }
Visual Basic
Public WriteOnly Property Rate As Double
    Set

Property Value

Type: Double

See Also

ExchangeRate Class
ExchangeRate Members


ExchangeRate.SellingRate Property

[image]

Pastel Evolution SDK
ExchangeRate..::..SellingRate Property
ExchangeRate Class See Also Send Feedback
Gets or sets the selling rate, expressed as [home currency]/[foreign currency]. Defaults to 1.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double SellingRate { get; set; }
Visual Basic
Public Property SellingRate As Double
    Get
    Set

Property Value

Type: Double

See Also

ExchangeRate Class
ExchangeRate Members


ExchangeRateCollection Class

[image]

Pastel Evolution SDK
ExchangeRateCollection Class
Members See Also Send Feedback
Represents a collection of warehouse context records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class ExchangeRateCollection
Visual Basic
Public Class ExchangeRateCollection

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..ExchangeRateCollection

See Also

ExchangeRateCollection Members
Pastel.Evolution Namespace
Pastel.Evolution..::..DeliveryAddress


ExchangeRateCollection Members

[image] [image]

Pastel Evolution SDK
ExchangeRateCollection Members
ExchangeRateCollection Class Methods Properties See Also Send Feedback

The ExchangeRateCollection type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of exchange rate items currently loaded into the collection.
Public property | Item | Gets the exchange rate for the date specified.

See Also

ExchangeRateCollection Class


ExchangeRateCollection Methods

[image] [image]

Pastel Evolution SDK
ExchangeRateCollection Methods
ExchangeRateCollection Class See Also Send Feedback

The ExchangeRateCollection type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExchangeRateCollection Class


ExchangeRateCollection.Save Method

[image]

Pastel Evolution SDK
ExchangeRateCollection..::..Save Method
ExchangeRateCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void Save()
Visual Basic
Public Sub Save

See Also

ExchangeRateCollection Class
ExchangeRateCollection Members


ExchangeRateCollection Properties

[image] [image]

Pastel Evolution SDK
ExchangeRateCollection Properties
ExchangeRateCollection Class See Also Send Feedback

The ExchangeRateCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of exchange rate items currently loaded into the collection.
Public property | Item | Gets the exchange rate for the date specified.

See Also

ExchangeRateCollection Class


ExchangeRateCollection.Count Property

[image]

Pastel Evolution SDK
ExchangeRateCollection..::..Count Property
ExchangeRateCollection Class See Also Send Feedback
Gets the number of exchange rate items currently loaded into the collection.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

See Also

ExchangeRateCollection Class
ExchangeRateCollection Members


ExchangeRateCollection.Item Property

[image]

Pastel Evolution SDK
ExchangeRateCollection..::..Item Property
ExchangeRateCollection Class See Also Send Feedback
Gets the exchange rate for the date specified.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public ExchangeRate this[
    DateTime date
] { get; }
Visual Basic
Public ReadOnly Default Property Item (
    date As DateTime
) As ExchangeRate
    Get

Parameters

date
Type: System..::..DateTime

Return Value

Type: ExchangeRate

See Also

ExchangeRateCollection Class
ExchangeRateCollection Members


FieldCollection Class

[image]

Pastel Evolution SDK
FieldCollection Class
Members See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class FieldCollection : ICollection,
    IEnumerable, ICloneable
Visual Basic
Public Class FieldCollection
    Implements ICollection, IEnumerable, ICloneable

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..FieldCollection

See Also

FieldCollection Members


FieldCollection Members

[image] [image]

Pastel Evolution SDK
FieldCollection Members
FieldCollection Class Methods Properties See Also Send Feedback

The FieldCollection type exposes the following members.

Methods

 | Name | Description
Public method | Clone |
Public method | CopyTo |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count |
Public property | FieldNames |
Public property | IsLocked |
Public property | IsSynchronized |
Public property | Item |
Public property | SyncRoot |

See Also

FieldCollection Class


FieldCollection Methods

[image] [image]

Pastel Evolution SDK
FieldCollection Methods
FieldCollection Class See Also Send Feedback

The FieldCollection type exposes the following members.

Methods

 | Name | Description
Public method | Clone |
Public method | CopyTo |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldCollection Class


FieldCollection.Clone Method

[image]

Pastel Evolution SDK
FieldCollection..::..Clone Method
FieldCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Object Clone()
Visual Basic
Public Function Clone As Object

Return Value

Type: Object

Implements

ICloneable..::..Clone()()()()

See Also

FieldCollection Class
FieldCollection Members


FieldCollection.CopyTo Method

[image]

Pastel Evolution SDK
FieldCollection..::..CopyTo Method
FieldCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void CopyTo(
    Array array,
    int index
)
Visual Basic
Public Sub CopyTo (
    array As Array,
    index As Integer
)

Parameters

array
Type: System..::..Array
index
Type: System..::..Int32

Implements

ICollection..::..CopyTo(Array, Int32)

See Also

FieldCollection Class
FieldCollection Members


FieldCollection.GetEnumerator Method

[image]

Pastel Evolution SDK
FieldCollection..::..GetEnumerator Method
FieldCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public IEnumerator GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

FieldCollection Class
FieldCollection Members


FieldCollection Properties

[image] [image]

Pastel Evolution SDK
FieldCollection Properties
FieldCollection Class See Also Send Feedback

The FieldCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count |
Public property | FieldNames |
Public property | IsLocked |
Public property | IsSynchronized |
Public property | Item |
Public property | SyncRoot |

See Also

FieldCollection Class


FieldCollection.Count Property

[image]

Pastel Evolution SDK
FieldCollection..::..Count Property
FieldCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Implements

ICollection..::..Count

See Also

FieldCollection Class
FieldCollection Members


FieldCollection.FieldNames Property

[image]

Pastel Evolution SDK
FieldCollection..::..FieldNames Property
FieldCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public List<string> FieldNames { get; }
Visual Basic
Public ReadOnly Property FieldNames As List(Of String)
    Get

Property Value

Type: List <(Of <(<' String >)>)>

See Also

FieldCollection Class
FieldCollection Members


FieldCollection.IsLocked Property

[image]

Pastel Evolution SDK
FieldCollection..::..IsLocked Property
FieldCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool IsLocked { get; internal set; }
Visual Basic
Public Property IsLocked As Boolean
    Get
    Friend Set

Property Value

Type: Boolean

See Also

FieldCollection Class
FieldCollection Members


FieldCollection.IsSynchronized Property

[image]

Pastel Evolution SDK
FieldCollection..::..IsSynchronized Property
FieldCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool IsSynchronized { get; }
Visual Basic
Public ReadOnly Property IsSynchronized As Boolean
    Get

Property Value

Type: Boolean

Implements

ICollection..::..IsSynchronized

See Also

FieldCollection Class
FieldCollection Members


FieldCollection.Item Property

[image]

Pastel Evolution SDK
FieldCollection..::..Item Property
FieldCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Object this[
    string fieldName
] { get; set; }
Visual Basic
Public Default Property Item (
    fieldName As String
) As Object
    Get
    Set

Parameters

fieldName
Type: System..::..String

Property Value

Type: Object

See Also

FieldCollection Class
FieldCollection Members


FieldCollection.SyncRoot Property

[image]

Pastel Evolution SDK
FieldCollection..::..SyncRoot Property
FieldCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Object SyncRoot { get; }
Visual Basic
Public ReadOnly Property SyncRoot As Object
    Get

Property Value

Type: Object

Implements

ICollection..::..SyncRoot

See Also

FieldCollection Class
FieldCollection Members


FieldCollectionManager Class

[image]

Pastel Evolution SDK
FieldCollectionManager Class
Members See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class FieldCollectionManager : ICloneable
Visual Basic
Public Class FieldCollectionManager
    Implements ICloneable

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..FieldCollectionManager

See Also

FieldCollectionManager Members


FieldCollectionManager Members

[image] [image]

Pastel Evolution SDK
FieldCollectionManager Members
FieldCollectionManager Class Methods Properties See Also Send Feedback

The FieldCollectionManager type exposes the following members.

Methods

 | Name | Description
Public method | Clone |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFieldNames |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DefaultFields |
Public property | IsLocked |
Public property | Item |
Public property | ModifiedFields |
Public property | RawFields |
Public property | ReadOnlyFields |
Public property | UserFields |
Public property | WritableFields |

See Also

FieldCollectionManager Class


FieldCollectionManager Methods

[image] [image]

Pastel Evolution SDK
FieldCollectionManager Methods
FieldCollectionManager Class See Also Send Feedback

The FieldCollectionManager type exposes the following members.

Methods

 | Name | Description
Public method | Clone |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFieldNames |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldCollectionManager Class


FieldCollectionManager.Clone Method

[image]

Pastel Evolution SDK
FieldCollectionManager..::..Clone Method
FieldCollectionManager Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Object Clone()
Visual Basic
Public Function Clone As Object

Return Value

Type: Object

Implements

ICloneable..::..Clone()()()()

See Also

FieldCollectionManager Class
FieldCollectionManager Members


FieldCollectionManager.GetFieldNames Method

[image]

Pastel Evolution SDK
FieldCollectionManager..::..GetFieldNames Method
FieldCollectionManager Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public List<string> GetFieldNames(
    FieldCollectionManager..::..FieldType type
)
Visual Basic
Public Function GetFieldNames (
    type As FieldCollectionManager..::..FieldType
) As List(Of String)

Parameters

type
Type: Pastel.Evolution..::..FieldCollectionManager..::..FieldType

Return Value

Type: List <(Of <(<' String >)>)>

See Also

FieldCollectionManager Class
FieldCollectionManager Members


FieldCollectionManager Properties

[image] [image]

Pastel Evolution SDK
FieldCollectionManager Properties
FieldCollectionManager Class See Also Send Feedback

The FieldCollectionManager type exposes the following members.

Properties

 | Name | Description
Public property | DefaultFields |
Public property | IsLocked |
Public property | Item |
Public property | ModifiedFields |
Public property | RawFields |
Public property | ReadOnlyFields |
Public property | UserFields |
Public property | WritableFields |

See Also

FieldCollectionManager Class


FieldCollectionManager.DefaultFields Property

[image]

Pastel Evolution SDK
FieldCollectionManager..::..DefaultFields Property
FieldCollectionManager Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public FieldCollection DefaultFields { get; }
Visual Basic
Public ReadOnly Property DefaultFields As FieldCollection
    Get

Property Value

Type: FieldCollection

See Also

FieldCollectionManager Class
FieldCollectionManager Members


FieldCollectionManager.IsLocked Property

[image]

Pastel Evolution SDK
FieldCollectionManager..::..IsLocked Property
FieldCollectionManager Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool IsLocked { get; set; }
Visual Basic
Public Property IsLocked As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

FieldCollectionManager Class
FieldCollectionManager Members


FieldCollectionManager.Item Property

[image]

Pastel Evolution SDK
FieldCollectionManager..::..Item Property
FieldCollectionManager Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Object this[
    string fieldName,
    FieldCollectionManager..::..FieldType fieldType
] { get; set; }
Visual Basic
Public Default Property Item (
    fieldName As String,
    fieldType As FieldCollectionManager..::..FieldType
) As Object
    Get
    Set

Parameters

fieldName
Type: System..::..String
fieldType
Type: Pastel.Evolution..::..FieldCollectionManager..::..FieldType

Property Value

Type: Object

See Also

FieldCollectionManager Class
FieldCollectionManager Members


FieldCollectionManager.ModifiedFields Property

[image]

Pastel Evolution SDK
FieldCollectionManager..::..ModifiedFields Property
FieldCollectionManager Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public FieldCollection ModifiedFields { get; }
Visual Basic
Public ReadOnly Property ModifiedFields As FieldCollection
    Get

Property Value

Type: FieldCollection

See Also

FieldCollectionManager Class
FieldCollectionManager Members


FieldCollectionManager.RawFields Property

[image]

Pastel Evolution SDK
FieldCollectionManager..::..RawFields Property
FieldCollectionManager Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public FieldCollection RawFields { get; }
Visual Basic
Public ReadOnly Property RawFields As FieldCollection
    Get

Property Value

Type: FieldCollection

See Also

FieldCollectionManager Class
FieldCollectionManager Members


FieldCollectionManager.ReadOnlyFields Property

[image]

Pastel Evolution SDK
FieldCollectionManager..::..ReadOnlyFields Property
FieldCollectionManager Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public FieldCollection ReadOnlyFields { get; }
Visual Basic
Public ReadOnly Property ReadOnlyFields As FieldCollection
    Get

Property Value

Type: FieldCollection

See Also

FieldCollectionManager Class
FieldCollectionManager Members


FieldCollectionManager.UserFields Property

[image]

Pastel Evolution SDK
FieldCollectionManager..::..UserFields Property
FieldCollectionManager Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public FieldCollection UserFields { get; }
Visual Basic
Public ReadOnly Property UserFields As FieldCollection
    Get

Property Value

Type: FieldCollection

See Also

FieldCollectionManager Class
FieldCollectionManager Members


FieldCollectionManager.WritableFields Property

[image]

Pastel Evolution SDK
FieldCollectionManager..::..WritableFields Property
FieldCollectionManager Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public FieldCollection WritableFields { get; }
Visual Basic
Public ReadOnly Property WritableFields As FieldCollection
    Get

Property Value

Type: FieldCollection

See Also

FieldCollectionManager Class
FieldCollectionManager Members


FieldCollectionManager.FieldType Enumeration

[image]

Pastel Evolution SDK
FieldCollectionManager..::..FieldType Enumeration
FieldCollectionManager Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public enum FieldType
Visual Basic
Public Enumeration FieldType

Members

Member name | Value | Description
Default | 0 | All fields; flagged dirty when modifying.
Modified | 1 | All dirty fields.
ReadOnly | 2 | Read-only (key) fields.
Writable | 3 | All fields except those marked as read-only. Default - read-only = writable
User | 4 | All fields not defined by the template. They are all considered writable!
Raw | 5 | Exactly the same as Default, but not flagged dirty when setting. Used for internal loading

See Also

Pastel.Evolution Namespace


GLAccount Class

[image]

Pastel Evolution SDK
GLAccount Class
Members See Also Send Feedback
Represents a General Ledger account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class GLAccount : AccountBase
Visual Basic
Public Class GLAccount
    Inherits AccountBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..AccountBase
Pastel.Evolution..::..GLAccount

See Also

GLAccount Members


GLAccount Members

[image] [image]

Pastel Evolution SDK
GLAccount Members
GLAccount Class Constructors Methods Fields Properties See Also Send Feedback

The GLAccount type exposes the following members.

Constructors

 | Name | Description
Public method | GLAccount()()()() | Initializes a new instance of the Account class.
Public method | GLAccount(Int32) | Initializes a new instance of the Account class from an existing record in the database.
Public method | GLAccount(String) | Initializes a new instance of the Account class from an existing record in the database.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Attempts to find a GL account and returns its ID.
 | FindByCode | Attempts to find a GL account by its account code and returns its ID.
 | Get | Attempts to find and return a GL account object using the criteria supplied.
 | GetByCode | Attempts to find and return a GL account object by its account code.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List | Returns a System.Data.DataTable object containing the database records from the Accounts table matching the supplied criteria.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides AccountBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides AccountBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Gets the record's string representation. (Overrides AccountBase..::..ToString()()()().)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | Active | Gets or sets the account's operational state. Inactive records cannot be used when posting transactions. (Overrides AccountBase..::..Active.)
Public property | AllowJournals |
Public property | AllowOnPurchasesDocuments | Gets or sets whether this GLAccount can be used for Inventory Purchase transactions. Only GLAcounts that allow Purchases transactions can be used on Purchase Orders and Return To Suppliers.
Public property | AllowOnSalesDocuments | Gets or sets whether this GLAccount can be used for Inventory Sales transactions. Only GLAcounts that allow Sales transactions can be used on Sales Orders and Credit Notes.
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Code | Gets or sets the account's full code. This field maps to the Master_Sub_Account database field. (Overrides AccountBase..::..Code.)
Public property | DefaultCreditNoteTaxType | Gets or sets the GL Account's CRN Tax Type.
Public property | DefaultCreditNoteTaxTypeID | Gets or sets the GL Account's CRN Tax Type id.
Public property | DefaultGoodsReceivedTaxType | Gets or sets the GL Account's GRV Tax Type.
Public property | DefaultGoodsReceivedTaxTypeID | Gets or sets the GL Account's GRV Tax Type id.
Public property | DefaultInvoicingTaxType | Gets or sets the GL Account's INV Tax Type.
Public property | DefaultInvoicingTaxTypeID | Gets or sets the GL Account's INV Tax Type id.
Public property | DefaultReturnToSupplierTaxType | Gets or sets the GL Account's RTS Tax Type.
Public property | DefaultReturnToSupplierTaxTypeID | Gets or sets the GL Account's RTS Tax Type id.
Public property | Description | Gets or sets the record description. (Overrides AccountBase..::..Description.)
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | Module | Indicates the Evolution module this account type belongs to. (Overrides AccountBase..::..Module.)
Public property | SubAccountOfGLAccount |
Public property | SubAccountOfGLAccountID |
Public property | Type | Gets or sets the account's type (financial category).

See Also

GLAccount Class


GLAccount Constructor

[image] [image]

Pastel Evolution SDK
GLAccount Constructor
GLAccount Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GLAccount()()()() | Initializes a new instance of the Account class.
Public method | GLAccount(Int32) | Initializes a new instance of the Account class from an existing record in the database.
Public method | GLAccount(String) | Initializes a new instance of the Account class from an existing record in the database.

See Also

GLAccount Class
GLAccount Members


GLAccount Constructor

[image]

Pastel Evolution SDK
GLAccount Constructor
GLAccount Class See Also Send Feedback
Initializes a new instance of the Account class.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLAccount()
Visual Basic
Public Sub New

See Also

GLAccount Class
GLAccount Members
GLAccount Overload


GLAccount Constructor (Int32)

[image]

Pastel Evolution SDK
GLAccount Constructor (Int32)
GLAccount Class See Also Send Feedback
Initializes a new instance of the Account class from an existing record in the database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLAccount(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32
The ID used to retrieve the record.

Exceptions

Exception | Condition
RecordNotExistsException | No account exists with the specified ID.

See Also

GLAccount Class
GLAccount Members
GLAccount Overload


GLAccount Constructor (String)

[image]

Pastel Evolution SDK
GLAccount Constructor (String)
GLAccount Class See Also Send Feedback
Initializes a new instance of the Account class from an existing record in the database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLAccount(
    string code
)
Visual Basic
Public Sub New (
    code As String
)

Parameters

code
Type: System..::..String
The account code used to retrieve the record.

Exceptions

Exception | Condition
RecordNotExistsException | No account exists with the specified code.

See Also

GLAccount Class
GLAccount Members
GLAccount Overload


GLAccount Fields

[image] [image]

Pastel Evolution SDK
GLAccount Fields
GLAccount Class See Also Send Feedback

The GLAccount type exposes the following members.

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

GLAccount Class


GLAccount Methods

[image] [image]

Pastel Evolution SDK
GLAccount Methods
GLAccount Class See Also Send Feedback

The GLAccount type exposes the following members.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Attempts to find a GL account and returns its ID.
 | FindByCode | Attempts to find a GL account by its account code and returns its ID.
 | Get | Attempts to find and return a GL account object using the criteria supplied.
 | GetByCode | Attempts to find and return a GL account object by its account code.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List | Returns a System.Data.DataTable object containing the database records from the Accounts table matching the supplied criteria.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides AccountBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides AccountBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Gets the record's string representation. (Overrides AccountBase..::..ToString()()()().)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

GLAccount Class


GLAccount.Find Method

[image]

Pastel Evolution SDK
GLAccount..::..Find Method
GLAccount Class See Also Send Feedback
Attempts to find a GL account and returns its ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String
The SQL criteria used to locate the record, e.g. Account = '1000'

Return Value

Type: Int32
-1 if no record was found, else the id of the first account matching the criteria supplied.

Remarks

The criteria is passed to a SQL query so use the appropriate syntax. Remember to includethe single quotes around string literals and append additional criteria with and.

See Also

GLAccount Class
GLAccount Members


GLAccount.FindByCode Method

[image]

Pastel Evolution SDK
GLAccount..::..FindByCode Method
GLAccount Class See Also Send Feedback
Attempts to find a GL account by its account code and returns its ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int FindByCode(
    string code
)
Visual Basic
Public Shared Function FindByCode (
    code As String
) As Integer

Parameters

code
Type: System..::..String
The account code used to lookup the account.

Return Value

Type: Int32
-1 if no record was found, else the id of the first account matching the criteria supplied.

See Also

GLAccount Class
GLAccount Members


GLAccount.Get Method

[image]

Pastel Evolution SDK
GLAccount..::..Get Method
GLAccount Class See Also Send Feedback
Attempts to find and return a GL account object using the criteria supplied.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static GLAccount Get(
    string criteria
)
Visual Basic
Public Shared Function Get (
    criteria As String
) As GLAccount

Parameters

criteria
Type: System..::..String
The SQL criteria used to locate the record, e.g. Account = '1000'

Return Value

Type: GLAccount
The GL account object located or null if no account was found.

See Also

GLAccount Class
GLAccount Members


GLAccount.GetByCode Method

[image]

Pastel Evolution SDK
GLAccount..::..GetByCode Method
GLAccount Class See Also Send Feedback
Attempts to find and return a GL account object by its account code.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static GLAccount GetByCode(
    string code
)
Visual Basic
Public Shared Function GetByCode (
    code As String
) As GLAccount

Parameters

code
Type: System..::..String
The account code used to lookup the account.

Return Value

Type: GLAccount
The GL account object located or null if no account was found.

See Also

GLAccount Class
GLAccount Members


GLAccount.List Method

[image]

Pastel Evolution SDK
GLAccount..::..List Method
GLAccount Class See Also Send Feedback
Returns a System.Data.DataTable object containing the database records from the Accounts table matching the supplied criteria.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria
)
Visual Basic
Public Shared Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String
The SQL criteria used to locate the record, e.g. Account like '1___'

Return Value

Type: DataTable
A System.Data.DataTable object containing matching records.

Remarks

The criteria is passed to an SQL query so use the appropriate syntax. Remember to includethe single quotes around string literals and append additional criteria with and.

See Also

GLAccount Class
GLAccount Members


GLAccount.OnDelete Method

[image]

Pastel Evolution SDK
GLAccount..::..OnDelete Method
GLAccount Class See Also Send Feedback
Removes the record from the database, provided it is not referenced by other records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

Exceptions

Exception | Condition
IntegrityViolationException |

See Also

GLAccount Class
GLAccount Members


GLAccount.OnSave Method

[image]

Pastel Evolution SDK
GLAccount..::..OnSave Method
GLAccount Class See Also Send Feedback
Persists the record to the database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

GLAccount Class
GLAccount Members


GLAccount.ToString Method

[image]

Pastel Evolution SDK
GLAccount..::..ToString Method
GLAccount Class See Also Send Feedback
Gets the record's string representation.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String
The object's string representation.

Remarks

Useful while debugging.

See Also

GLAccount Class
GLAccount Members


GLAccount Properties

[image] [image]

Pastel Evolution SDK
GLAccount Properties
GLAccount Class See Also Send Feedback

The GLAccount type exposes the following members.

Properties

 | Name | Description
Public property | Active | Gets or sets the account's operational state. Inactive records cannot be used when posting transactions. (Overrides AccountBase..::..Active.)
Public property | AllowJournals |
Public property | AllowOnPurchasesDocuments | Gets or sets whether this GLAccount can be used for Inventory Purchase transactions. Only GLAcounts that allow Purchases transactions can be used on Purchase Orders and Return To Suppliers.
Public property | AllowOnSalesDocuments | Gets or sets whether this GLAccount can be used for Inventory Sales transactions. Only GLAcounts that allow Sales transactions can be used on Sales Orders and Credit Notes.
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Code | Gets or sets the account's full code. This field maps to the Master_Sub_Account database field. (Overrides AccountBase..::..Code.)
Public property | DefaultCreditNoteTaxType | Gets or sets the GL Account's CRN Tax Type.
Public property | DefaultCreditNoteTaxTypeID | Gets or sets the GL Account's CRN Tax Type id.
Public property | DefaultGoodsReceivedTaxType | Gets or sets the GL Account's GRV Tax Type.
Public property | DefaultGoodsReceivedTaxTypeID | Gets or sets the GL Account's GRV Tax Type id.
Public property | DefaultInvoicingTaxType | Gets or sets the GL Account's INV Tax Type.
Public property | DefaultInvoicingTaxTypeID | Gets or sets the GL Account's INV Tax Type id.
Public property | DefaultReturnToSupplierTaxType | Gets or sets the GL Account's RTS Tax Type.
Public property | DefaultReturnToSupplierTaxTypeID | Gets or sets the GL Account's RTS Tax Type id.
Public property | Description | Gets or sets the record description. (Overrides AccountBase..::..Description.)
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | Module | Indicates the Evolution module this account type belongs to. (Overrides AccountBase..::..Module.)
Public property | SubAccountOfGLAccount |
Public property | SubAccountOfGLAccountID |
Public property | Type | Gets or sets the account's type (financial category).

See Also

GLAccount Class


GLAccount.Active Property

[image]

Pastel Evolution SDK
GLAccount..::..Active Property
GLAccount Class See Also Send Feedback
Gets or sets the account's operational state. Inactive records cannot be used when posting transactions.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override bool Active { get; set; }
Visual Basic
Public Overrides Property Active As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

GLAccount Class
GLAccount Members


GLAccount.AllowJournals Property

[image]

Pastel Evolution SDK
GLAccount..::..AllowJournals Property
GLAccount Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool AllowJournals { get; set; }
Visual Basic
Public Property AllowJournals As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

GLAccount Class
GLAccount Members


GLAccount.AllowOnPurchasesDocuments Property

[image]

Pastel Evolution SDK
GLAccount..::..AllowOnPurchasesDocuments Property
GLAccount Class See Also Send Feedback
Gets or sets whether this GLAccount can be used for Inventory Purchase transactions. Only GLAcounts that allow Purchases transactions can be used on Purchase Orders and Return To Suppliers.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool AllowOnPurchasesDocuments { get; set; }
Visual Basic
Public Property AllowOnPurchasesDocuments As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

GLAccount Class
GLAccount Members


GLAccount.AllowOnSalesDocuments Property

[image]

Pastel Evolution SDK
GLAccount..::..AllowOnSalesDocuments Property
GLAccount Class See Also Send Feedback
Gets or sets whether this GLAccount can be used for Inventory Sales transactions. Only GLAcounts that allow Sales transactions can be used on Sales Orders and Credit Notes.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool AllowOnSalesDocuments { get; set; }
Visual Basic
Public Property AllowOnSalesDocuments As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

GLAccount Class
GLAccount Members


GLAccount.Code Property

[image]

Pastel Evolution SDK
GLAccount..::..Code Property
GLAccount Class See Also Send Feedback
Gets or sets the account's full code. This field maps to the Master_Sub_Account database field.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override string Code { get; set; }
Visual Basic
Public Overrides Property Code As String
    Get
    Set

Property Value

Type: String

See Also

GLAccount Class
GLAccount Members


GLAccount.DefaultCreditNoteTaxType Property

[image]

Pastel Evolution SDK
GLAccount..::..DefaultCreditNoteTaxType Property
GLAccount Class See Also Send Feedback
Gets or sets the GL Account's CRN Tax Type.
Gets or sets the CRN Tax Type.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public TaxRate DefaultCreditNoteTaxType { get; set; }
Visual Basic
Public Property DefaultCreditNoteTaxType As TaxRate
    Get
    Set

Property Value

Type: TaxRate

See Also

GLAccount Class
GLAccount Members


GLAccount.DefaultCreditNoteTaxTypeID Property

[image]

Pastel Evolution SDK
GLAccount..::..DefaultCreditNoteTaxTypeID Property
GLAccount Class See Also Send Feedback
Gets or sets the GL Account's CRN Tax Type id.
Gets or sets the CRN Tax Type id.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int DefaultCreditNoteTaxTypeID { get; set; }
Visual Basic
Public Property DefaultCreditNoteTaxTypeID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

GLAccount Class
GLAccount Members


GLAccount.DefaultGoodsReceivedTaxType Property

[image]

Pastel Evolution SDK
GLAccount..::..DefaultGoodsReceivedTaxType Property
GLAccount Class See Also Send Feedback
Gets or sets the GL Account's GRV Tax Type.
Gets or sets the GRV Tax Type.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public TaxRate DefaultGoodsReceivedTaxType { get; set; }
Visual Basic
Public Property DefaultGoodsReceivedTaxType As TaxRate
    Get
    Set

Property Value

Type: TaxRate

See Also

GLAccount Class
GLAccount Members


GLAccount.DefaultGoodsReceivedTaxTypeID Property

[image]

Pastel Evolution SDK
GLAccount..::..DefaultGoodsReceivedTaxTypeID Property
GLAccount Class See Also Send Feedback
Gets or sets the GL Account's GRV Tax Type id.
Gets or sets the GRV Tax Type id.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int DefaultGoodsReceivedTaxTypeID { get; set; }
Visual Basic
Public Property DefaultGoodsReceivedTaxTypeID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

GLAccount Class
GLAccount Members


GLAccount.DefaultInvoicingTaxType Property

[image]

Pastel Evolution SDK
GLAccount..::..DefaultInvoicingTaxType Property
GLAccount Class See Also Send Feedback
Gets or sets the GL Account's INV Tax Type.
Gets or sets the INV Tax Type.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public TaxRate DefaultInvoicingTaxType { get; set; }
Visual Basic
Public Property DefaultInvoicingTaxType As TaxRate
    Get
    Set

Property Value

Type: TaxRate

See Also

GLAccount Class
GLAccount Members


GLAccount.DefaultInvoicingTaxTypeID Property

[image]

Pastel Evolution SDK
GLAccount..::..DefaultInvoicingTaxTypeID Property
GLAccount Class See Also Send Feedback
Gets or sets the GL Account's INV Tax Type id.
Gets or sets the INV Tax Type id.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int DefaultInvoicingTaxTypeID { get; set; }
Visual Basic
Public Property DefaultInvoicingTaxTypeID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

GLAccount Class
GLAccount Members


GLAccount.DefaultReturnToSupplierTaxType Property

[image]

Pastel Evolution SDK
GLAccount..::..DefaultReturnToSupplierTaxType Property
GLAccount Class See Also Send Feedback
Gets or sets the GL Account's RTS Tax Type.
Gets or sets the RTS Tax Type.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public TaxRate DefaultReturnToSupplierTaxType { get; set; }
Visual Basic
Public Property DefaultReturnToSupplierTaxType As TaxRate
    Get
    Set

Property Value

Type: TaxRate

See Also

GLAccount Class
GLAccount Members


GLAccount.DefaultReturnToSupplierTaxTypeID Property

[image]

Pastel Evolution SDK
GLAccount..::..DefaultReturnToSupplierTaxTypeID Property
GLAccount Class See Also Send Feedback
Gets or sets the GL Account's RTS Tax Type id.
Gets or sets the RTS Tax Type id.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int DefaultReturnToSupplierTaxTypeID { get; set; }
Visual Basic
Public Property DefaultReturnToSupplierTaxTypeID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

GLAccount Class
GLAccount Members


GLAccount.Description Property

[image]

Pastel Evolution SDK
GLAccount..::..Description Property
GLAccount Class See Also Send Feedback
Gets or sets the record description.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override string Description { get; set; }
Visual Basic
Public Overrides Property Description As String
    Get
    Set

Property Value

Type: String

See Also

GLAccount Class
GLAccount Members


GLAccount.ID Property

[image]

Pastel Evolution SDK
GLAccount..::..ID Property
GLAccount Class See Also Send Feedback
Gets the internal record ID (0 for new, unsaved records).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

See Also

GLAccount Class
GLAccount Members


GLAccount.LongID Property

[image]

Pastel Evolution SDK
GLAccount..::..LongID Property
GLAccount Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

GLAccount Class
GLAccount Members


GLAccount.Module Property

[image]

Pastel Evolution SDK
GLAccount..::..Module Property
GLAccount Class See Also Send Feedback
Indicates the Evolution module this account type belongs to.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override Module Module { get; }
Visual Basic
Public Overrides ReadOnly Property Module As Module
    Get

Property Value

Type: Module

See Also

GLAccount Class
GLAccount Members


GLAccount.SubAccountOfGLAccount Property

[image]

Pastel Evolution SDK
GLAccount..::..SubAccountOfGLAccount Property
GLAccount Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLAccount SubAccountOfGLAccount { get; set; }
Visual Basic
Public Property SubAccountOfGLAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

See Also

GLAccount Class
GLAccount Members


GLAccount.SubAccountOfGLAccountID Property

[image]

Pastel Evolution SDK
GLAccount..::..SubAccountOfGLAccountID Property
GLAccount Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int SubAccountOfGLAccountID { get; set; }
Visual Basic
Public Property SubAccountOfGLAccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

GLAccount Class
GLAccount Members


GLAccount.Type Property

[image]

Pastel Evolution SDK
GLAccount..::..Type Property
GLAccount Class See Also Send Feedback
Gets or sets the account's type (financial category).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLAccount..::..AccountType Type { get; set; }
Visual Basic
Public Property Type As GLAccount..::..AccountType
    Get
    Set

Property Value

Type: GLAccount..::..AccountType

See Also

GLAccount Class
GLAccount Members


GLAccount.AccountType Enumeration

[image]

Pastel Evolution SDK
GLAccount..::..AccountType Enumeration
GLAccount Class See Also Send Feedback
Defines general ledger account types.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public enum AccountType
Visual Basic
Public Enumeration AccountType

Members

Member name | Value | Description
Invalid | 0 |
Bank | 1 |
Expense | 2 |
CurrentAsset | 3 |
Income | 4 |
CurrentLiability | 5 |
LongTermLiability | 6 |
Capital | 7 |
FixedAsset | 8 |
TradingIncome | 9 |
TradingExpense | 10 |
AccumulatedProfit | 11 |
TaxExpense | 12 |
UnallocatedIS | 13 |
DividendsPaid | 14 |
DividendsRec | 15 |
ProfLossOnNonCurrAssetSale | 16 |
InterestPaid | 17 |
ProfLossOnExchange | 18 |
UnallocatedBS | 19 |
ShareHoldersLoan | 20 |
OtherLongTermLiabilities | 21 |
Investments | 22 |
OthFixedAssets | 23 |
Inventory | 24 |
AccountsReceivable | 25 |
AccountsPayable | 26 |
Taxation | 27 |
DeferredTax | 28 |
NonDistribReserves | 29 |
NonCurrentAsset | 30 |
IntangibleAsset | 31 |

See Also

Pastel.Evolution Namespace
Pastel.Evolution..::..GLAccount


GLBatch Class

[image]

Pastel Evolution SDK
GLBatch Class
Members See Also Send Feedback
Facilitates batch processing of GL transactions. Mainly used internally and not to be confused with journal batches.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class GLBatch : CollectionBase
Visual Basic
Public Class GLBatch
    Inherits CollectionBase

Inheritance Hierarchy

System..::..Object
System.Collections..::..CollectionBase
Pastel.Evolution..::..GLBatch

See Also

GLBatch Members


GLBatch Members

[image] [image]

Pastel Evolution SDK
GLBatch Members
GLBatch Class Constructors Methods Properties See Also Send Feedback

The GLBatch type exposes the following members.

Constructors

 | Name | Description
Public method | GLBatch | Initializes a new instance of the GLBatch class

Methods

 | Name | Description
Public method | Add(GLTransaction) | Adds a GL transaction to the batch without attempting consolidation.
Public method | Add(GLTransaction, Boolean, Boolean) | Adds a GL transaction to the batch, optionally consolidating.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Public method | OnCollectionChanged |
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Public method | OnPost |
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Post | Processes each transaction in the batch. Note: All transactions will assume the global audit number when posting.
Public method | Remove | Removes a transaction from the batch.
Public method | RemoveAt | Removes a transaction from a specific location in the batch.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item |
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | TotalCredit | Gets the batch's total credit value.
Public property | TotalDebit | Gets the batch's total debit value.
Public property | TotalForeignCredit | Gets the batch's total foreign credit value.
Public property | TotalForeignDebit | Gets the batch's total foreign debit value.

See Also

GLBatch Class


GLBatch Constructor

[image]

Pastel Evolution SDK
GLBatch Constructor
GLBatch Class See Also Send Feedback
Initializes a new instance of the GLBatch class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLBatch()
Visual Basic
Public Sub New

See Also

GLBatch Class
GLBatch Members


GLBatch Methods

[image] [image]

Pastel Evolution SDK
GLBatch Methods
GLBatch Class See Also Send Feedback

The GLBatch type exposes the following members.

Methods

 | Name | Description
Public method | Add(GLTransaction) | Adds a GL transaction to the batch without attempting consolidation.
Public method | Add(GLTransaction, Boolean, Boolean) | Adds a GL transaction to the batch, optionally consolidating.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Public method | OnCollectionChanged |
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Public method | OnPost |
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Post | Processes each transaction in the batch. Note: All transactions will assume the global audit number when posting.
Public method | Remove | Removes a transaction from the batch.
Public method | RemoveAt | Removes a transaction from a specific location in the batch.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GLBatch Class


GLBatch.Add Method

[image] [image]

Pastel Evolution SDK
GLBatch..::..Add Method
GLBatch Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Add(GLTransaction) | Adds a GL transaction to the batch without attempting consolidation.
Public method | Add(GLTransaction, Boolean, Boolean) | Adds a GL transaction to the batch, optionally consolidating.

See Also

GLBatch Class
GLBatch Members


GLBatch.Add Method (GLTransaction)

[image]

Pastel Evolution SDK
GLBatch..::..Add Method (GLTransaction)
GLBatch Class See Also Send Feedback
Adds a GL transaction to the batch without attempting consolidation.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void Add(
    GLTransaction transaction
)
Visual Basic
Public Sub Add (
    transaction As GLTransaction
)

Parameters

transaction
Type: Pastel.Evolution..::..GLTransaction

See Also

GLBatch Class
GLBatch Members
Add Overload


GLBatch.Add Method (GLTransaction, Boolean, Boolean)

[image]

Pastel Evolution SDK
GLBatch..::..Add Method (GLTransaction, Boolean, Boolean)
GLBatch Class See Also Send Feedback
Adds a GL transaction to the batch, optionally consolidating.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void Add(
    GLTransaction transaction,
    bool consolidate,
    bool strict
)
Visual Basic
Public Sub Add (
    transaction As GLTransaction,
    consolidate As Boolean,
    strict As Boolean
)

Parameters

transaction
Type: Pastel.Evolution..::..GLTransaction
Specifies the transaction.
consolidate
Type: System..::..Boolean
Specifies whether or not to consolidate.
strict
Type: System..::..Boolean
Specifies whether or not to consolidate according to stricter criteria, i.e. reference and description values also have to match.

Remarks

This overloaded method provides the ability to consolidate the transaction with another transaction in the batch, matching on account, module id, tax type, date, and transaction code. If the strict option is used,reference, and description are matched as well. Note: debits and credits are always consolidated separately.

See Also

GLBatch Class
GLBatch Members
Add Overload


GLBatch.OnCollectionChanged Method

[image]

Pastel Evolution SDK
GLBatch..::..OnCollectionChanged Method
GLBatch Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void OnCollectionChanged(
    GLBatch..::..BatchCollectionChangedEventArgs e
)
Visual Basic
Public Sub OnCollectionChanged (
    e As GLBatch..::..BatchCollectionChangedEventArgs
)

Parameters

e
Type: Pastel.Evolution..::..GLBatch..::..BatchCollectionChangedEventArgs

See Also

GLBatch Class
GLBatch Members


GLBatch.OnPost Method

[image]

Pastel Evolution SDK
GLBatch..::..OnPost Method
GLBatch Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool OnPost()
Visual Basic
Public Function OnPost As Boolean

Return Value

Type: Boolean

See Also

GLBatch Class
GLBatch Members


GLBatch.Post Method

[image]

Pastel Evolution SDK
GLBatch..::..Post Method
GLBatch Class See Also Send Feedback
Processes each transaction in the batch. Note: All transactions will assume the global audit number when posting.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool Post()
Visual Basic
Public Function Post As Boolean

Return Value

Type: Boolean

See Also

GLBatch Class
GLBatch Members


GLBatch.Remove Method

[image]

Pastel Evolution SDK
GLBatch..::..Remove Method
GLBatch Class See Also Send Feedback
Removes a transaction from the batch.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void Remove(
    GLTransaction transaction
)
Visual Basic
Public Sub Remove (
    transaction As GLTransaction
)

Parameters

transaction
Type: Pastel.Evolution..::..GLTransaction
Specifies the transaction.

See Also

GLBatch Class
GLBatch Members


GLBatch.RemoveAt Method

[image]

Pastel Evolution SDK
GLBatch..::..RemoveAt Method
GLBatch Class See Also Send Feedback
Removes a transaction from a specific location in the batch.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void RemoveAt(
    int index
)
Visual Basic
Public Sub RemoveAt (
    index As Integer
)

Parameters

index
Type: System..::..Int32
Specifies the index at which to remove the record.

See Also

GLBatch Class
GLBatch Members


GLBatch Properties

[image] [image]

Pastel Evolution SDK
GLBatch Properties
GLBatch Class See Also Send Feedback

The GLBatch type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item |
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | TotalCredit | Gets the batch's total credit value.
Public property | TotalDebit | Gets the batch's total debit value.
Public property | TotalForeignCredit | Gets the batch's total foreign credit value.
Public property | TotalForeignDebit | Gets the batch's total foreign debit value.

See Also

GLBatch Class


GLBatch.Item Property

[image]

Pastel Evolution SDK
GLBatch..::..Item Property
GLBatch Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLTransaction this[
    int index
] { get; set; }
Visual Basic
Public Default Property Item (
    index As Integer
) As GLTransaction
    Get
    Set

Parameters

index
Type: System..::..Int32

Property Value

Type: GLTransaction

See Also

GLBatch Class
GLBatch Members


GLBatch.TotalCredit Property

[image]

Pastel Evolution SDK
GLBatch..::..TotalCredit Property
GLBatch Class See Also Send Feedback
Gets the batch's total credit value.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalCredit { get; }
Visual Basic
Public ReadOnly Property TotalCredit As Double
    Get

Property Value

Type: Double

See Also

GLBatch Class
GLBatch Members


GLBatch.TotalDebit Property

[image]

Pastel Evolution SDK
GLBatch..::..TotalDebit Property
GLBatch Class See Also Send Feedback
Gets the batch's total debit value.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalDebit { get; }
Visual Basic
Public ReadOnly Property TotalDebit As Double
    Get

Property Value

Type: Double

See Also

GLBatch Class
GLBatch Members


GLBatch.TotalForeignCredit Property

[image]

Pastel Evolution SDK
GLBatch..::..TotalForeignCredit Property
GLBatch Class See Also Send Feedback
Gets the batch's total foreign credit value.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalForeignCredit { get; }
Visual Basic
Public ReadOnly Property TotalForeignCredit As Double
    Get

Property Value

Type: Double

See Also

GLBatch Class
GLBatch Members


GLBatch.TotalForeignDebit Property

[image]

Pastel Evolution SDK
GLBatch..::..TotalForeignDebit Property
GLBatch Class See Also Send Feedback
Gets the batch's total foreign debit value.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalForeignDebit { get; }
Visual Basic
Public ReadOnly Property TotalForeignDebit As Double
    Get

Property Value

Type: Double

See Also

GLBatch Class
GLBatch Members


GLBatch.BatchChangeAction Enumeration

[image]

Pastel Evolution SDK
GLBatch..::..BatchChangeAction Enumeration
GLBatch Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public enum BatchChangeAction
Visual Basic
Public Enumeration BatchChangeAction

Members

Member name | Value | Description
Added | 0 |
Deleted | 1 |
Consolidated | 2 |

See Also

Pastel.Evolution Namespace


GLBatch.BatchCollectionChangedEventArgs Class

[image]

Pastel Evolution SDK
GLBatch..::..BatchCollectionChangedEventArgs Class
GLBatch Class Members See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class BatchCollectionChangedEventArgs : EventArgs
Visual Basic
Public Class BatchCollectionChangedEventArgs
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Pastel.Evolution..::..GLBatch..::..BatchCollectionChangedEventArgs

See Also

GLBatch..::..BatchCollectionChangedEventArgs Members


GLBatch.BatchCollectionChangedEventArgs Members

[image] [image]

Pastel Evolution SDK
GLBatch..::..BatchCollectionChangedEventArgs Members
GLBatch..::..BatchCollectionChangedEventArgs Class Constructors Methods Fields See Also Send Feedback

The GLBatch..::..BatchCollectionChangedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | GLBatch..::..BatchCollectionChangedEventArgs | Initializes a new instance of the GLBatch..::..BatchCollectionChangedEventArgs class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | Action |
Public field | Transaction |

See Also

GLBatch..::..BatchCollectionChangedEventArgs Class


GLBatch.BatchCollectionChangedEventArgs Constructor

[image]

Pastel Evolution SDK
GLBatch..::..BatchCollectionChangedEventArgs Constructor
GLBatch..::..BatchCollectionChangedEventArgs Class See Also Send Feedback
Initializes a new instance of the GLBatch..::..BatchCollectionChangedEventArgs class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public BatchCollectionChangedEventArgs(
    GLTransaction transaction,
    GLBatch..::..BatchChangeAction action
)
Visual Basic
Public Sub New (
    transaction As GLTransaction,
    action As GLBatch..::..BatchChangeAction
)

Parameters

transaction
Type: Pastel.Evolution..::..GLTransaction
action
Type: Pastel.Evolution..::..GLBatch..::..BatchChangeAction

See Also

GLBatch..::..BatchCollectionChangedEventArgs Class
GLBatch..::..BatchCollectionChangedEventArgs Members


GLBatch.BatchCollectionChangedEventArgs Fields

[image] [image]

Pastel Evolution SDK
GLBatch..::..BatchCollectionChangedEventArgs Fields
GLBatch..::..BatchCollectionChangedEventArgs Class See Also Send Feedback

The GLBatch..::..BatchCollectionChangedEventArgs type exposes the following members.

Fields

 | Name | Description
Public field | Action |
Public field | Transaction |

See Also

GLBatch..::..BatchCollectionChangedEventArgs Class


GLBatch.BatchCollectionChangedEventArgs.Action Field

[image]

Pastel Evolution SDK
GLBatch..::..BatchCollectionChangedEventArgs..::..Action Field
GLBatch..::..BatchCollectionChangedEventArgs Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLBatch..::..BatchChangeAction Action
Visual Basic
Public Action As GLBatch..::..BatchChangeAction

Field Value

Type: GLBatch..::..BatchChangeAction

See Also

GLBatch..::..BatchCollectionChangedEventArgs Class
GLBatch..::..BatchCollectionChangedEventArgs Members


GLBatch.BatchCollectionChangedEventArgs.Transaction Field

[image]

Pastel Evolution SDK
GLBatch..::..BatchCollectionChangedEventArgs..::..Transaction Field
GLBatch..::..BatchCollectionChangedEventArgs Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLTransaction Transaction
Visual Basic
Public Transaction As GLTransaction

Field Value

Type: GLTransaction

See Also

GLBatch..::..BatchCollectionChangedEventArgs Class
GLBatch..::..BatchCollectionChangedEventArgs Members


GLBatch.BatchCollectionChangedEventArgs Methods

[image] [image]

Pastel Evolution SDK
GLBatch..::..BatchCollectionChangedEventArgs Methods
GLBatch..::..BatchCollectionChangedEventArgs Class See Also Send Feedback

The GLBatch..::..BatchCollectionChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GLBatch..::..BatchCollectionChangedEventArgs Class


GLTransaction Class

[image]

Pastel Evolution SDK
GLTransaction Class
Members See Also Send Feedback
Represents a general ledger transaction.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class GLTransaction : TransactionBase,
    ICloneable
Visual Basic
Public Class GLTransaction
    Inherits TransactionBase
    Implements ICloneable

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..TransactionBase
Pastel.Evolution..::..GLTransaction

See Also

GLTransaction Members


GLTransaction Members

[image] [image]

Pastel Evolution SDK
GLTransaction Members
GLTransaction Class Constructors Methods Fields Properties Events See Also Send Feedback

The GLTransaction type exposes the following members.

Constructors

 | Name | Description
Public method | GLTransaction()()()() | Initializes a new instance of the GLTransaction class
Public method | GLTransaction(Int64) | Initializes a new instance of the GLTransaction class

Methods

 | Name | Description
Public method | Clone |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds a transaction ID.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List | Returns a System.Data.DataTable object containing the database records from the PostGL table matching the supplied criteria.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAllowBlockedPosting | (Overrides TransactionBase..::..OnAllowBlockedPosting()()()().)
Protected method | OnPost | (Overrides TransactionBase..::..OnPost()()()().)
Protected method | onPostingGLCredit | (Inherited from TransactionBase.)
Protected method | onPostingGLDebit | (Inherited from TransactionBase.)
Protected method | onPostingGLVat | (Inherited from TransactionBase.)
Public method | Post | Posts the transaction to appropriate ledgers. (Inherited from TransactionBase.)
Protected method | RejectTransactionBranchAssignment | (Inherited from TransactionBase.)
Public method | ToString | (Overrides Object..::..ToString()()()().)
Public method | Validate | (Overrides TransactionBase..::..Validate()()()().)

Fields

 | Name | Description
Protected field | foreignOriginalTax | (Inherited from TransactionBase.)
Protected field | isDebitTrans | (Inherited from TransactionBase.)
Protected field | originalTax | (Inherited from TransactionBase.)
Protected field | readOnly | (Inherited from TransactionBase.)

Properties

 | Name | Description
Public property | Account | (Overrides TransactionBase..::..Account.)
Public property | AccountID | (Overrides TransactionBase..::..AccountID.)
Public property | Audit | (Overrides TransactionBase..::..Audit.)
Public property | Branch | (Overrides TransactionBase..::..Branch.)
Public property | BranchID | (Overrides TransactionBase..::..BranchID.)
Public property | Credit | (Overrides TransactionBase..::..Credit.)
Public property | Currency | Gets or sets the account's currency. null indicates home currency.
Public property | CurrencyID | Gets or sets the account's currency id. 0 indicates local currency.
Public property | Date | Sets the transaction date, which in turn selects the period automatically (Overrides TransactionBase..::..Date.)
Public property | Debit | Sets the transaction debit amount. (Overrides TransactionBase..::..Debit.)
Public property | Description | Gets or sets the record description. (Overrides TransactionBase..::..Description.)
Public property | EffectiveCredit |
Public property | EffectiveDebit |
Public property | EffectiveForeignCredit |
Public property | EffectiveForeignDebit |
Public property | ExchangeRate |
Public property | ExtOrderNo | (Overrides TransactionBase..::..ExtOrderNo.)
Public property | ForeignCredit |
Public property | ForeignDebit |
Public property | ForeignTax | Gets or sets the foreign transaction tax amount (automatically rounded to 2 decimals and always posted positive).
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides TransactionBase..::..ID.)
Public property | iInvLineID |
Public property | IsReconciled |
Public property | IsSTGLDocLine |
Public property | JobCard |
Public property | JobCardID |
Public property | ModID | (Overrides TransactionBase..::..ModID.)
Public property | Module | (Overrides TransactionBase..::..Module.)
Public property | OrderNo | (Overrides TransactionBase..::..OrderNo.)
Public property | Project | Gets or sets the Project record associated with this transaction. When using Project Tracking, this field must be specified whereverapplicable. (Overrides TransactionBase..::..Project.)
Public property | ProjectID | (Overrides TransactionBase..::..ProjectID.)
Public property | Reference | (Overrides TransactionBase..::..Reference.)
Public property | Reference2 | (Overrides TransactionBase..::..Reference2.)
Public property | Tax | Gets or sets the transaction tax amount (automatically rounded to 2 decimals and always posted positive). (Overrides TransactionBase..::..Tax.)
Public property | TaxAccount | Gets or sets the Tax Account.
Public property | TaxAccountID | Gets or sets the Tax Account ID.
Public property | TaxRate | (Overrides TransactionBase..::..TaxRate.)
Public property | TaxRateID | (Overrides TransactionBase..::..TaxRateID.)
Public property | TransactionCode | (Overrides TransactionBase..::..TransactionCode.)
Public property | TransactionCodeID | (Overrides TransactionBase..::..TransactionCodeID.)

Events

 | Name | Description
Public event | GLCreditPosting | (Inherited from TransactionBase.)
Public event | GLDebitPosting | (Inherited from TransactionBase.)
Public event | GLVatPosting | (Inherited from TransactionBase.)

See Also

GLTransaction Class


GLTransaction Constructor

[image] [image]

Pastel Evolution SDK
GLTransaction Constructor
GLTransaction Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GLTransaction()()()() | Initializes a new instance of the GLTransaction class
Public method | GLTransaction(Int64) | Initializes a new instance of the GLTransaction class

See Also

GLTransaction Class
GLTransaction Members


GLTransaction Constructor

[image]

Pastel Evolution SDK
GLTransaction Constructor
GLTransaction Class See Also Send Feedback
Initializes a new instance of the GLTransaction class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLTransaction()
Visual Basic
Public Sub New

See Also

GLTransaction Class
GLTransaction Members
GLTransaction Overload


GLTransaction Constructor (Int64)

[image]

Pastel Evolution SDK
GLTransaction Constructor (Int64)
GLTransaction Class See Also Send Feedback
Initializes a new instance of the GLTransaction class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLTransaction(
    long id
)
Visual Basic
Public Sub New (
    id As Long
)

Parameters

id
Type: System..::..Int64

See Also

GLTransaction Class
GLTransaction Members
GLTransaction Overload


GLTransaction Fields

[image] [image]

Pastel Evolution SDK
GLTransaction Fields
GLTransaction Class See Also Send Feedback

The GLTransaction type exposes the following members.

Fields

 | Name | Description
Protected field | foreignOriginalTax | (Inherited from TransactionBase.)
Protected field | isDebitTrans | (Inherited from TransactionBase.)
Protected field | originalTax | (Inherited from TransactionBase.)
Protected field | readOnly | (Inherited from TransactionBase.)

See Also

GLTransaction Class


GLTransaction Methods

[image] [image]

Pastel Evolution SDK
GLTransaction Methods
GLTransaction Class See Also Send Feedback

The GLTransaction type exposes the following members.

Methods

 | Name | Description
Public method | Clone |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds a transaction ID.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List | Returns a System.Data.DataTable object containing the database records from the PostGL table matching the supplied criteria.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAllowBlockedPosting | (Overrides TransactionBase..::..OnAllowBlockedPosting()()()().)
Protected method | OnPost | (Overrides TransactionBase..::..OnPost()()()().)
Protected method | onPostingGLCredit | (Inherited from TransactionBase.)
Protected method | onPostingGLDebit | (Inherited from TransactionBase.)
Protected method | onPostingGLVat | (Inherited from TransactionBase.)
Public method | Post | Posts the transaction to appropriate ledgers. (Inherited from TransactionBase.)
Protected method | RejectTransactionBranchAssignment | (Inherited from TransactionBase.)
Public method | ToString | (Overrides Object..::..ToString()()()().)
Public method | Validate | (Overrides TransactionBase..::..Validate()()()().)

See Also

GLTransaction Class


GLTransaction.Clone Method

[image]

Pastel Evolution SDK
GLTransaction..::..Clone Method
GLTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Object Clone()
Visual Basic
Public Function Clone As Object

Return Value

Type: Object

Implements

ICloneable..::..Clone()()()()

See Also

GLTransaction Class
GLTransaction Members


GLTransaction.Find Method

[image]

Pastel Evolution SDK
GLTransaction..::..Find Method
GLTransaction Class See Also Send Feedback
Finds a transaction ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static long Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Long

Parameters

criteria
Type: System..::..String
The criteria passed to the SQL query. Eg. Reference = 'INV001' or Description like '%Invoice%'

Return Value

Type: Int64

See Also

GLTransaction Class
GLTransaction Members


GLTransaction.List Method

[image]

Pastel Evolution SDK
GLTransaction..::..List Method
GLTransaction Class See Also Send Feedback
Returns a System.Data.DataTable object containing the database records from the PostGL table matching the supplied criteria.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria
)
Visual Basic
Public Shared Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String
The SQL criteria used to locate the record, e.g. Reference like '1___' and Audit_No = 10.0005

Return Value

Type: DataTable
A System.Data.DataTable object containing matching records.

Remarks

The criteria is passed to an SQL query so use the appropriate syntax. Remember to include the single quotes around string literals and append additional criteria with and.

See Also

GLTransaction Class
GLTransaction Members


GLTransaction.OnAllowBlockedPosting Method

[image]

Pastel Evolution SDK
GLTransaction..::..OnAllowBlockedPosting Method
GLTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override bool OnAllowBlockedPosting()
Visual Basic
Protected Friend Overrides Function OnAllowBlockedPosting As Boolean

Return Value

Type: Boolean

See Also

GLTransaction Class
GLTransaction Members


GLTransaction.OnPost Method

[image]

Pastel Evolution SDK
GLTransaction..::..OnPost Method
GLTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected override bool OnPost()
Visual Basic
Protected Overrides Function OnPost As Boolean

Return Value

Type: Boolean

See Also

GLTransaction Class
GLTransaction Members


GLTransaction.ToString Method

[image]

Pastel Evolution SDK
GLTransaction..::..ToString Method
GLTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String

See Also

GLTransaction Class
GLTransaction Members


GLTransaction.Validate Method

[image]

Pastel Evolution SDK
GLTransaction..::..Validate Method
GLTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override bool Validate()
Visual Basic
Public Overrides Function Validate As Boolean

Return Value

Type: Boolean

See Also

GLTransaction Class
GLTransaction Members


GLTransaction Properties

[image] [image]

Pastel Evolution SDK
GLTransaction Properties
GLTransaction Class See Also Send Feedback

The GLTransaction type exposes the following members.

Properties

 | Name | Description
Public property | Account | (Overrides TransactionBase..::..Account.)
Public property | AccountID | (Overrides TransactionBase..::..AccountID.)
Public property | Audit | (Overrides TransactionBase..::..Audit.)
Public property | Branch | (Overrides TransactionBase..::..Branch.)
Public property | BranchID | (Overrides TransactionBase..::..BranchID.)
Public property | Credit | (Overrides TransactionBase..::..Credit.)
Public property | Currency | Gets or sets the account's currency. null indicates home currency.
Public property | CurrencyID | Gets or sets the account's currency id. 0 indicates local currency.
Public property | Date | Sets the transaction date, which in turn selects the period automatically (Overrides TransactionBase..::..Date.)
Public property | Debit | Sets the transaction debit amount. (Overrides TransactionBase..::..Debit.)
Public property | Description | Gets or sets the record description. (Overrides TransactionBase..::..Description.)
Public property | EffectiveCredit |
Public property | EffectiveDebit |
Public property | EffectiveForeignCredit |
Public property | EffectiveForeignDebit |
Public property | ExchangeRate |
Public property | ExtOrderNo | (Overrides TransactionBase..::..ExtOrderNo.)
Public property | ForeignCredit |
Public property | ForeignDebit |
Public property | ForeignTax | Gets or sets the foreign transaction tax amount (automatically rounded to 2 decimals and always posted positive).
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides TransactionBase..::..ID.)
Public property | iInvLineID |
Public property | IsReconciled |
Public property | IsSTGLDocLine |
Public property | JobCard |
Public property | JobCardID |
Public property | ModID | (Overrides TransactionBase..::..ModID.)
Public property | Module | (Overrides TransactionBase..::..Module.)
Public property | OrderNo | (Overrides TransactionBase..::..OrderNo.)
Public property | Project | Gets or sets the Project record associated with this transaction. When using Project Tracking, this field must be specified whereverapplicable. (Overrides TransactionBase..::..Project.)
Public property | ProjectID | (Overrides TransactionBase..::..ProjectID.)
Public property | Reference | (Overrides TransactionBase..::..Reference.)
Public property | Reference2 | (Overrides TransactionBase..::..Reference2.)
Public property | Tax | Gets or sets the transaction tax amount (automatically rounded to 2 decimals and always posted positive). (Overrides TransactionBase..::..Tax.)
Public property | TaxAccount | Gets or sets the Tax Account.
Public property | TaxAccountID | Gets or sets the Tax Account ID.
Public property | TaxRate | (Overrides TransactionBase..::..TaxRate.)
Public property | TaxRateID | (Overrides TransactionBase..::..TaxRateID.)
Public property | TransactionCode | (Overrides TransactionBase..::..TransactionCode.)
Public property | TransactionCodeID | (Overrides TransactionBase..::..TransactionCodeID.)

See Also

GLTransaction Class


GLTransaction.Account Property

[image]

Pastel Evolution SDK
GLTransaction..::..Account Property
GLTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override AccountBase Account { get; set; }
Visual Basic
Public Overrides Property Account As AccountBase
    Get
    Set

Property Value

Type: AccountBase

See Also

GLTransaction Class
GLTransaction Members


GLTransaction.AccountID Property

[image]

Pastel Evolution SDK
GLTransaction..::..AccountID Property
GLTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int AccountID { get; set; }
Visual Basic
Public Overrides Property AccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

GLTransaction Class
GLTransaction Members


GLTransaction.Audit Property

[image]

Pastel Evolution SDK
GLTransaction..::..Audit Property
GLTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override string Audit { get; }
Visual Basic
Public Overrides ReadOnly Property Audit As String
    Get

Property Value

Type: String

See Also

GLTransaction Class
GLTransaction Members


GLTransaction.Branch Property

[image]

Pastel Evolution SDK
GLTransaction..::..Branch Property
GLTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override Branch Branch { get; set; }
Visual Basic
Public Overrides Property Branch As Branch
    Get
    Set

Property Value

Type: Branch

Implements

IBranched..::..Branch

See Also

GLTransaction Class
GLTransaction Members


GLTransaction.BranchID Property

[image]

Pastel Evolution SDK
GLTransaction..::..BranchID Property
GLTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int BranchID { get; internal set; }
Visual Basic
Public Overrides Property BranchID As Integer
    Get
    Friend Set

Property Value

Type: Int32

Implements

IBranched..::..BranchID

See Also

GLTransaction Class
GLTransaction Members


GLTransaction.Credit Property

[image]

Pastel Evolution SDK
GLTransaction..::..Credit Property
GLTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override double Credit { get; set; }
Visual Basic
Public Overrides Property Credit As Double
    Get
    Set

Property Value

Type: Double

See Also

GLTransaction Class
GLTransaction Members


GLTransaction.Currency Property

[image]

Pastel Evolution SDK
GLTransaction..::..Currency Property
GLTransaction Class See Also Send Feedback
Gets or sets the account's currency. null indicates home currency.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Currency Currency { get; set; }
Visual Basic
Public Property Currency As Currency
    Get
    Set

Property Value

Type: Currency

See Also

GLTransaction Class
GLTransaction Members


GLTransaction.CurrencyID Property

[image]

Pastel Evolution SDK
GLTransaction..::..CurrencyID Property
GLTransaction Class See Also Send Feedback
Gets or sets the account's currency id. 0 indicates local currency.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int CurrencyID { get; set; }
Visual Basic
Public Property CurrencyID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

GLTransaction Class
GLTransaction Members


GLTransaction.Date Property

[image]

Pastel Evolution SDK
GLTransaction..::..Date Property
GLTransaction Class See Also Send Feedback
Sets the transaction date, which in turn selects the period automatically

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override DateTime Date { get; set; }
Visual Basic
Public Overrides Property Date As DateTime
    Get
    Set

Property Value

Type: DateTime

See Also

GLTransaction Class
GLTransaction Members


GLTransaction.Debit Property

[image]

Pastel Evolution SDK
GLTransaction..::..Debit Property
GLTransaction Class See Also Send Feedback
Sets the transaction debit amount.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override double Debit { get; set; }
Visual Basic
Public Overrides Property Debit As Double
    Get
    Set

Property Value

Type: Double

Remarks

Be careful when setting both debit and credit values. When setting debit to a negative value, debit will immediately become 0 and credit will immediately be set to the reverse of the value. If then setting credit to 0, the transaction amount will be cancelled.

See Also

GLTransaction Class
GLTransaction Members


GLTransaction.Description Property

[image]

Pastel Evolution SDK
GLTransaction..::..Description Property
GLTransaction Class See Also Send Feedback
Gets or sets the record description.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override string Description { get; set; }
Visual Basic
Public Overrides Property Description As String
    Get
    Set

Property Value

Type: String

See Also

GLTransaction Class
GLTransaction Members


GLTransaction.EffectiveCredit Property

[image]

Pastel Evolution SDK
GLTransaction..::..EffectiveCredit Property
GLTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double EffectiveCredit { get; set; }
Visual Basic
Public Property EffectiveCredit As Double
    Get
    Set

Property Value

Type: Double

See Also

GLTransaction Class
GLTransaction Members


GLTransaction.EffectiveDebit Property

[image]

Pastel Evolution SDK
GLTransaction..::..EffectiveDebit Property
GLTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double EffectiveDebit { get; set; }
Visual Basic
Public Property EffectiveDebit As Double
    Get
    Set

Property Value

Type: Double

See Also

GLTransaction Class
GLTransaction Members


GLTransaction.EffectiveForeignCredit Property

[image]

Pastel Evolution SDK
GLTransaction..::..EffectiveForeignCredit Property
GLTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double EffectiveForeignCredit { get; set; }
Visual Basic
Public Property EffectiveForeignCredit As Double
    Get
    Set

Property Value

Type: Double

See Also

GLTransaction Class
GLTransaction Members


GLTransaction.EffectiveForeignDebit Property

[image]

Pastel Evolution SDK
GLTransaction..::..EffectiveForeignDebit Property
GLTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double EffectiveForeignDebit { get; set; }
Visual Basic
Public Property EffectiveForeignDebit As Double
    Get
    Set

Property Value

Type: Double

See Also

GLTransaction Class
GLTransaction Members


GLTransaction.ExchangeRate Property

[image]

Pastel Evolution SDK
GLTransaction..::..ExchangeRate Property
GLTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double ExchangeRate { get; set; }
Visual Basic
Public Property ExchangeRate As Double
    Get
    Set

Property Value

Type: Double

See Also

GLTransaction Class
GLTransaction Members


GLTransaction.ExtOrderNo Property

[image]

Pastel Evolution SDK
GLTransaction..::..ExtOrderNo Property
GLTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override string ExtOrderNo { get; set; }
Visual Basic
Public Overrides Property ExtOrderNo As String
    Get
    Set

Property Value

Type: String

See Also

GLTransaction Class
GLTransaction Members


GLTransaction.ForeignCredit Property

[image]

Pastel Evolution SDK
GLTransaction..::..ForeignCredit Property
GLTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double ForeignCredit { get; set; }
Visual Basic
Public Property ForeignCredit As Double
    Get
    Set

Property Value

Type: Double

See Also

GLTransaction Class
GLTransaction Members


GLTransaction.ForeignDebit Property

[image]

Pastel Evolution SDK
GLTransaction..::..ForeignDebit Property
GLTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double ForeignDebit { get; set; }
Visual Basic
Public Property ForeignDebit As Double
    Get
    Set

Property Value

Type: Double

See Also

GLTransaction Class
GLTransaction Members


GLTransaction.ForeignTax Property

[image]

Pastel Evolution SDK
GLTransaction..::..ForeignTax Property
GLTransaction Class See Also Send Feedback
Gets or sets the foreign transaction tax amount (automatically rounded to 2 decimals and always posted positive).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double ForeignTax { get; set; }
Visual Basic
Public Property ForeignTax As Double
    Get
    Set

Property Value

Type: Double

See Also

GLTransaction Class
GLTransaction Members


GLTransaction.ID Property

[image]

Pastel Evolution SDK
GLTransaction..::..ID Property
GLTransaction Class See Also Send Feedback
Gets the internal record ID (0 for new, unsaved records).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Long
    Get

Property Value

Type: Int64

See Also

GLTransaction Class
GLTransaction Members


GLTransaction.iInvLineID Property

[image]

Pastel Evolution SDK
GLTransaction..::..iInvLineID Property
GLTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int iInvLineID { get; set; }
Visual Basic
Public Property iInvLineID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

GLTransaction Class
GLTransaction Members


GLTransaction.IsReconciled Property

[image]

Pastel Evolution SDK
GLTransaction..::..IsReconciled Property
GLTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool IsReconciled { get; set; }
Visual Basic
Public Property IsReconciled As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

GLTransaction Class
GLTransaction Members


GLTransaction.IsSTGLDocLine Property

[image]

Pastel Evolution SDK
GLTransaction..::..IsSTGLDocLine Property
GLTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool IsSTGLDocLine { get; set; }
Visual Basic
Public Property IsSTGLDocLine As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

GLTransaction Class
GLTransaction Members


GLTransaction.JobCard Property

[image]

Pastel Evolution SDK
GLTransaction..::..JobCard Property
GLTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public JobCard JobCard { get; set; }
Visual Basic
Public Property JobCard As JobCard
    Get
    Set

Property Value

Type: JobCard

See Also

GLTransaction Class
GLTransaction Members


GLTransaction.JobCardID Property

[image]

Pastel Evolution SDK
GLTransaction..::..JobCardID Property
GLTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int JobCardID { get; set; }
Visual Basic
Public Property JobCardID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

GLTransaction Class
GLTransaction Members


GLTransaction.ModID Property

[image]

Pastel Evolution SDK
GLTransaction..::..ModID Property
GLTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override ModuleID ModID { get; set; }
Visual Basic
Public Overrides Property ModID As ModuleID
    Get
    Set

Property Value

Type: ModuleID

See Also

GLTransaction Class
GLTransaction Members


GLTransaction.Module Property

[image]

Pastel Evolution SDK
GLTransaction..::..Module Property
GLTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override Module Module { get; }
Visual Basic
Public Overrides ReadOnly Property Module As Module
    Get

Property Value

Type: Module

See Also

GLTransaction Class
GLTransaction Members


GLTransaction.OrderNo Property

[image]

Pastel Evolution SDK
GLTransaction..::..OrderNo Property
GLTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override string OrderNo { get; set; }
Visual Basic
Public Overrides Property OrderNo As String
    Get
    Set

Property Value

Type: String

See Also

GLTransaction Class
GLTransaction Members


GLTransaction.Project Property

[image]

Pastel Evolution SDK
GLTransaction..::..Project Property
GLTransaction Class See Also Send Feedback
Gets or sets the Project record associated with this transaction. When using Project Tracking, this field must be specified whereverapplicable.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override Project Project { get; set; }
Visual Basic
Public Overrides Property Project As Project
    Get
    Set

Property Value

Type: Project

See Also

GLTransaction Class
GLTransaction Members


GLTransaction.ProjectID Property

[image]

Pastel Evolution SDK
GLTransaction..::..ProjectID Property
GLTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ProjectID { get; set; }
Visual Basic
Public Overrides Property ProjectID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

GLTransaction Class
GLTransaction Members


GLTransaction.Reference Property

[image]

Pastel Evolution SDK
GLTransaction..::..Reference Property
GLTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override string Reference { get; set; }
Visual Basic
Public Overrides Property Reference As String
    Get
    Set

Property Value

Type: String

See Also

GLTransaction Class
GLTransaction Members


GLTransaction.Reference2 Property

[image]

Pastel Evolution SDK
GLTransaction..::..Reference2 Property
GLTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override string Reference2 { get; set; }
Visual Basic
Public Overrides Property Reference2 As String
    Get
    Set

Property Value

Type: String

See Also

GLTransaction Class
GLTransaction Members


GLTransaction.Tax Property

[image]

Pastel Evolution SDK
GLTransaction..::..Tax Property
GLTransaction Class See Also Send Feedback
Gets or sets the transaction tax amount (automatically rounded to 2 decimals and always posted positive).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override double Tax { get; set; }
Visual Basic
Public Overrides Property Tax As Double
    Get
    Set

Property Value

Type: Double

See Also

GLTransaction Class
GLTransaction Members


GLTransaction.TaxAccount Property

[image]

Pastel Evolution SDK
GLTransaction..::..TaxAccount Property
GLTransaction Class See Also Send Feedback
Gets or sets the Tax Account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLAccount TaxAccount { get; set; }
Visual Basic
Public Property TaxAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

See Also

GLTransaction Class
GLTransaction Members


GLTransaction.TaxAccountID Property

[image]

Pastel Evolution SDK
GLTransaction..::..TaxAccountID Property
GLTransaction Class See Also Send Feedback
Gets or sets the Tax Account ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int TaxAccountID { get; set; }
Visual Basic
Public Property TaxAccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

GLTransaction Class
GLTransaction Members


GLTransaction.TaxRate Property

[image]

Pastel Evolution SDK
GLTransaction..::..TaxRate Property
GLTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override TaxRate TaxRate { get; set; }
Visual Basic
Public Overrides Property TaxRate As TaxRate
    Get
    Set

Property Value

Type: TaxRate

See Also

GLTransaction Class
GLTransaction Members


GLTransaction.TaxRateID Property

[image]

Pastel Evolution SDK
GLTransaction..::..TaxRateID Property
GLTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int TaxRateID { get; set; }
Visual Basic
Public Overrides Property TaxRateID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

GLTransaction Class
GLTransaction Members


GLTransaction.TransactionCode Property

[image]

Pastel Evolution SDK
GLTransaction..::..TransactionCode Property
GLTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override TransactionCodeBase TransactionCode { get; set; }
Visual Basic
Public Overrides Property TransactionCode As TransactionCodeBase
    Get
    Set

Property Value

Type: TransactionCodeBase

See Also

GLTransaction Class
GLTransaction Members


GLTransaction.TransactionCodeID Property

[image]

Pastel Evolution SDK
GLTransaction..::..TransactionCodeID Property
GLTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int TransactionCodeID { get; set; }
Visual Basic
Public Overrides Property TransactionCodeID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

GLTransaction Class
GLTransaction Members


GLTransaction Events

[image] [image]

Pastel Evolution SDK
GLTransaction Events
GLTransaction Class See Also Send Feedback

The GLTransaction type exposes the following members.

Events

 | Name | Description
Public event | GLCreditPosting | (Inherited from TransactionBase.)
Public event | GLDebitPosting | (Inherited from TransactionBase.)
Public event | GLVatPosting | (Inherited from TransactionBase.)

See Also

GLTransaction Class


IBranched Interface

[image]

Pastel Evolution SDK
IBranched Interface
Members See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public interface IBranched
Visual Basic
Public Interface IBranched

See Also

IBranched Members


IBranched Members

[image] [image]

Pastel Evolution SDK
IBranched Members
IBranched Interface Properties See Also Send Feedback

The IBranched type exposes the following members.

Properties

 | Name | Description
Public property | Branch |
Public property | BranchID |

See Also

IBranched Interface


IBranched Properties

[image] [image]

Pastel Evolution SDK
IBranched Properties
IBranched Interface See Also Send Feedback

The IBranched type exposes the following members.

Properties

 | Name | Description
Public property | Branch |
Public property | BranchID |

See Also

IBranched Interface


IBranched.Branch Property

[image]

Pastel Evolution SDK
IBranched..::..Branch Property
IBranched Interface See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
Branch Branch { get; }
Visual Basic
ReadOnly Property Branch As Branch
    Get

Property Value

Type: Branch

See Also

IBranched Interface
IBranched Members


IBranched.BranchID Property

[image]

Pastel Evolution SDK
IBranched..::..BranchID Property
IBranched Interface See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
int BranchID { get; }
Visual Basic
ReadOnly Property BranchID As Integer
    Get

Property Value

Type: Int32

See Also

IBranched Interface
IBranched Members


Incident Class

[image]

Pastel Evolution SDK
Incident Class
Members See Also Send Feedback
Represents an Evolution Contact Management incident.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class Incident
Visual Basic
Public Class Incident

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..Incident

See Also

Incident Members


Incident Members

[image] [image]

Pastel Evolution SDK
Incident Members
Incident Class Constructors Methods Properties See Also Send Feedback

The Incident type exposes the following members.

Constructors

 | Name | Description
Public method | Incident()()()() | Creates a new instance of an incident.
Public method | Incident(Int32) | Creates a new instance of an incident.
Public method | Incident(String) | Creates a new instance of an incident.

Methods

 | Name | Description
 | _ListCurrentBranch(String) |
 | _ListCurrentBranch(String, Boolean) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List(String) |
 | List(String, Boolean) |
 | List(Customer, Boolean) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NewAction |
Public method | OnPost |
Public method | Post(IncidentLogEntry) | Posts an incident log entry.
Public method | Post(IncidentLogEntry, Boolean, Boolean) | Posts a incident log entry.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AgentGroupID | Gets the agent group's incident type id.
Public property | Branch |
Public property | Category | Gets or sets the incident's assigned category.
Public property | CategoryID | Gets or sets the incident's category id.
Public property | Contract | Gets or sets the sales opportunity linked to the incident.
Public property | ContractID |
Public property | CreatedDate | Gets the original creation date/time that the incident was created.
Public property | CurrentAgent | Gets the agent to whom the incident is currently assigned to. The current agent can only be changed by posting a re-assignment action.
Public property | CurrentAgentID |
Public property | Customer | Gets or sets the customer account linked to the incident.
Public property | CustomerReference | Gets or sets the customer's reference number.
Public property | DueBy | Gets or sets the incident's due date/time.
Public property | EscalationGroup | Gets or sets the incident's assigned escalation group. Note that while Evolution will automatically assign an agent if only an escalation group is supplier, the API requires that an agent be specified.
Public property | EscalationGroupID | Gets or sets the incident's escalation group id.
Public property | ID | Gets the internal record ID (0 for new, unsaved records).
Public property | IncidentType | Gets or sets the incident type.
Public property | IncidentTypeID | Gets or sets the incident's incident type id.
Public property | InventoryItem |
Public property | InventoryItemID |
Public property | JobCard | Gets or sets the job card linked to the incident.
Public property | JobCardID |
Public property | ModifiedDate | Gets the last date/time that the incident was modified.
Public property | Opportunity | Gets or sets the sales opportunity linked to the incident.
Public property | OpportunityID |
Public property | Outline | Gets or sets the incident's outline - the summary description.
Public property | Person | Gets or sets the person record related to the incident.
Public property | PersonID |
Public property | Priority | Gets or sets the incident's due date/time.
Public property | Project | Gets or sets the incident's assigned project.
Public property | ProjectID | Gets or sets the incident's project id.
Public property | Prospect | Gets or sets the prospective client related to the incident.
Public property | Reference | Gets or sets the internal incident reference.
Public property | RequireAcknowledgement | Gets or sets whether or not the incident requires acknowledgement.
Public property | Status | Gets or sets the incident's status.
Public property | Supplier | Gets or sets the supplier account linked to the incident.
Public property | UserFields |

See Also

Incident Class


Incident Constructor

[image] [image]

Pastel Evolution SDK
Incident Constructor
Incident Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Incident()()()() | Creates a new instance of an incident.
Public method | Incident(Int32) | Creates a new instance of an incident.
Public method | Incident(String) | Creates a new instance of an incident.

See Also

Incident Class
Incident Members


Incident Constructor

[image]

Pastel Evolution SDK
Incident Constructor
Incident Class See Also Send Feedback
Creates a new instance of an incident.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Incident()
Visual Basic
Public Sub New

See Also

Incident Class
Incident Members
Incident Overload


Incident Constructor (Int32)

[image]

Pastel Evolution SDK
Incident Constructor (Int32)
Incident Class See Also Send Feedback
Creates a new instance of an incident.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Incident(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32
Specifies the id of the existing record.

See Also

Incident Class
Incident Members
Incident Overload


Incident Constructor (String)

[image]

Pastel Evolution SDK
Incident Constructor (String)
Incident Class See Also Send Feedback
Creates a new instance of an incident.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Incident(
    string reference
)
Visual Basic
Public Sub New (
    reference As String
)

Parameters

reference
Type: System..::..String
Specifies the reference of the existing record.

See Also

Incident Class
Incident Members
Incident Overload


Incident Methods

[image] [image]

Pastel Evolution SDK
Incident Methods
Incident Class See Also Send Feedback

The Incident type exposes the following members.

Methods

 | Name | Description
 | _ListCurrentBranch(String) |
 | _ListCurrentBranch(String, Boolean) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List(String) |
 | List(String, Boolean) |
 | List(Customer, Boolean) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NewAction |
Public method | OnPost |
Public method | Post(IncidentLogEntry) | Posts an incident log entry.
Public method | Post(IncidentLogEntry, Boolean, Boolean) | Posts a incident log entry.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Incident Class


Incident._ListCurrentBranch Method

[image] [image]

Pastel Evolution SDK
Incident..::.._ListCurrentBranch Method
Incident Class See Also Send Feedback

Overload List

Name | Description
_ListCurrentBranch(String) |
_ListCurrentBranch(String, Boolean) |

See Also

Incident Class
Incident Members


Incident._ListCurrentBranch Method (String)

[image]

Pastel Evolution SDK
Incident..::.._ListCurrentBranch Method (String)
Incident Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable _ListCurrentBranch(
    string criteria
)
Visual Basic
Public Shared Function _ListCurrentBranch (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String

Return Value

Type: DataTable

See Also

Incident Class
Incident Members
_ListCurrentBranch Overload


Incident._ListCurrentBranch Method (String, Boolean)

[image]

Pastel Evolution SDK
Incident..::.._ListCurrentBranch Method (String, Boolean)
Incident Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable _ListCurrentBranch(
    string criteria,
    bool activeOnly
)
Visual Basic
Public Shared Function _ListCurrentBranch (
    criteria As String,
    activeOnly As Boolean
) As DataTable

Parameters

criteria
Type: System..::..String
activeOnly
Type: System..::..Boolean

Return Value

Type: DataTable

See Also

Incident Class
Incident Members
_ListCurrentBranch Overload


Incident.Find Method

[image]

Pastel Evolution SDK
Incident..::..Find Method
Incident Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String

Return Value

Type: Int32

See Also

Incident Class
Incident Members


Incident.List Method

[image] [image]

Pastel Evolution SDK
Incident..::..List Method
Incident Class See Also Send Feedback

Overload List

Name | Description
List(String) |
List(String, Boolean) |
List(Customer, Boolean) |

See Also

Incident Class
Incident Members


Incident.List Method (String)

[image]

Pastel Evolution SDK
Incident..::..List Method (String)
Incident Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria
)
Visual Basic
Public Shared Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String

Return Value

Type: DataTable

See Also

Incident Class
Incident Members
List Overload


Incident.List Method (String, Boolean)

[image]

Pastel Evolution SDK
Incident..::..List Method (String, Boolean)
Incident Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria,
    bool activeOnly
)
Visual Basic
Public Shared Function List (
    criteria As String,
    activeOnly As Boolean
) As DataTable

Parameters

criteria
Type: System..::..String
activeOnly
Type: System..::..Boolean

Return Value

Type: DataTable

See Also

Incident Class
Incident Members
List Overload


Incident.List Method (Customer, Boolean)

[image]

Pastel Evolution SDK
Incident..::..List Method (Customer, Boolean)
Incident Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    Customer account,
    bool activeOnly
)
Visual Basic
Public Shared Function List (
    account As Customer,
    activeOnly As Boolean
) As DataTable

Parameters

account
Type: Pastel.Evolution..::..Customer
activeOnly
Type: System..::..Boolean

Return Value

Type: DataTable

See Also

Incident Class
Incident Members
List Overload


Incident.NewAction Method

[image]

Pastel Evolution SDK
Incident..::..NewAction Method
Incident Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public IncidentLogEntry NewAction()
Visual Basic
Public Function NewAction As IncidentLogEntry

Return Value

Type: IncidentLogEntry

See Also

Incident Class
Incident Members


Incident.OnPost Method

[image]

Pastel Evolution SDK
Incident..::..OnPost Method
Incident Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void OnPost(
    IncidentLogEntry log,
    bool close,
    bool notify
)
Visual Basic
Public Sub OnPost (
    log As IncidentLogEntry,
    close As Boolean,
    notify As Boolean
)

Parameters

log
Type: Pastel.Evolution..::..IncidentLogEntry
close
Type: System..::..Boolean
notify
Type: System..::..Boolean

See Also

Incident Class
Incident Members


Incident.Post Method

[image] [image]

Pastel Evolution SDK
Incident..::..Post Method
Incident Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Post(IncidentLogEntry) | Posts an incident log entry.
Public method | Post(IncidentLogEntry, Boolean, Boolean) | Posts a incident log entry.

See Also

Incident Class
Incident Members


Incident.Post Method (IncidentLogEntry)

[image]

Pastel Evolution SDK
Incident..::..Post Method (IncidentLogEntry)
Incident Class See Also Send Feedback
Posts an incident log entry.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void Post(
    IncidentLogEntry log
)
Visual Basic
Public Sub Post (
    log As IncidentLogEntry
)

Parameters

log
Type: Pastel.Evolution..::..IncidentLogEntry
Specifies the log entry to post.

See Also

Incident Class
Incident Members
Post Overload


Incident.Post Method (IncidentLogEntry, Boolean, Boolean)

[image]

Pastel Evolution SDK
Incident..::..Post Method (IncidentLogEntry, Boolean, Boolean)
Incident Class See Also Send Feedback
Posts a incident log entry.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void Post(
    IncidentLogEntry log,
    bool close,
    bool notify
)
Visual Basic
Public Sub Post (
    log As IncidentLogEntry,
    close As Boolean,
    notify As Boolean
)

Parameters

log
Type: Pastel.Evolution..::..IncidentLogEntry
Specifies the log entry to post.
close
Type: System..::..Boolean
Specifies whether the incident is to be closed.
notify
Type: System..::..Boolean
Specifies whether or not notification is required.

See Also

Incident Class
Incident Members
Post Overload


Incident Properties

[image] [image]

Pastel Evolution SDK
Incident Properties
Incident Class See Also Send Feedback

The Incident type exposes the following members.

Properties

 | Name | Description
Public property | AgentGroupID | Gets the agent group's incident type id.
Public property | Branch |
Public property | Category | Gets or sets the incident's assigned category.
Public property | CategoryID | Gets or sets the incident's category id.
Public property | Contract | Gets or sets the sales opportunity linked to the incident.
Public property | ContractID |
Public property | CreatedDate | Gets the original creation date/time that the incident was created.
Public property | CurrentAgent | Gets the agent to whom the incident is currently assigned to. The current agent can only be changed by posting a re-assignment action.
Public property | CurrentAgentID |
Public property | Customer | Gets or sets the customer account linked to the incident.
Public property | CustomerReference | Gets or sets the customer's reference number.
Public property | DueBy | Gets or sets the incident's due date/time.
Public property | EscalationGroup | Gets or sets the incident's assigned escalation group. Note that while Evolution will automatically assign an agent if only an escalation group is supplier, the API requires that an agent be specified.
Public property | EscalationGroupID | Gets or sets the incident's escalation group id.
Public property | ID | Gets the internal record ID (0 for new, unsaved records).
Public property | IncidentType | Gets or sets the incident type.
Public property | IncidentTypeID | Gets or sets the incident's incident type id.
Public property | InventoryItem |
Public property | InventoryItemID |
Public property | JobCard | Gets or sets the job card linked to the incident.
Public property | JobCardID |
Public property | ModifiedDate | Gets the last date/time that the incident was modified.
Public property | Opportunity | Gets or sets the sales opportunity linked to the incident.
Public property | OpportunityID |
Public property | Outline | Gets or sets the incident's outline - the summary description.
Public property | Person | Gets or sets the person record related to the incident.
Public property | PersonID |
Public property | Priority | Gets or sets the incident's due date/time.
Public property | Project | Gets or sets the incident's assigned project.
Public property | ProjectID | Gets or sets the incident's project id.
Public property | Prospect | Gets or sets the prospective client related to the incident.
Public property | Reference | Gets or sets the internal incident reference.
Public property | RequireAcknowledgement | Gets or sets whether or not the incident requires acknowledgement.
Public property | Status | Gets or sets the incident's status.
Public property | Supplier | Gets or sets the supplier account linked to the incident.
Public property | UserFields |

See Also

Incident Class


Incident.AgentGroupID Property

[image]

Pastel Evolution SDK
Incident..::..AgentGroupID Property
Incident Class See Also Send Feedback
Gets the agent group's incident type id.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int AgentGroupID { get; internal set; }
Visual Basic
Public Property AgentGroupID As Integer
    Get
    Friend Set

Property Value

Type: Int32

See Also

Incident Class
Incident Members


Incident.Branch Property

[image]

Pastel Evolution SDK
Incident..::..Branch Property
Incident Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Branch Branch { get; }
Visual Basic
Public ReadOnly Property Branch As Branch
    Get

Property Value

Type: Branch

See Also

Incident Class
Incident Members


Incident.Category Property

[image]

Pastel Evolution SDK
Incident..::..Category Property
Incident Class See Also Send Feedback
Gets or sets the incident's assigned category.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public IncidentCategory Category { get; set; }
Visual Basic
Public Property Category As IncidentCategory
    Get
    Set

Property Value

Type: IncidentCategory

See Also

Incident Class
Incident Members


Incident.CategoryID Property

[image]

Pastel Evolution SDK
Incident..::..CategoryID Property
Incident Class See Also Send Feedback
Gets or sets the incident's category id.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int CategoryID { get; set; }
Visual Basic
Public Property CategoryID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

Incident Class
Incident Members


Incident.Contract Property

[image]

Pastel Evolution SDK
Incident..::..Contract Property
Incident Class See Also Send Feedback
Gets or sets the sales opportunity linked to the incident.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Contract Contract { get; set; }
Visual Basic
Public Property Contract As Contract
    Get
    Set

Property Value

Type: Contract

See Also

Incident Class
Incident Members


Incident.ContractID Property

[image]

Pastel Evolution SDK
Incident..::..ContractID Property
Incident Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int ContractID { get; set; }
Visual Basic
Public Property ContractID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

Incident Class
Incident Members


Incident.CreatedDate Property

[image]

Pastel Evolution SDK
Incident..::..CreatedDate Property
Incident Class See Also Send Feedback
Gets the original creation date/time that the incident was created.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DateTime CreatedDate { get; }
Visual Basic
Public ReadOnly Property CreatedDate As DateTime
    Get

Property Value

Type: DateTime

See Also

Incident Class
Incident Members


Incident.CurrentAgent Property

[image]

Pastel Evolution SDK
Incident..::..CurrentAgent Property
Incident Class See Also Send Feedback
Gets the agent to whom the incident is currently assigned to. The current agent can only be changed by posting a re-assignment action.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Agent CurrentAgent { get; }
Visual Basic
Public ReadOnly Property CurrentAgent As Agent
    Get

Property Value

Type: Agent

See Also

Incident Class
Incident Members


Incident.CurrentAgentID Property

[image]

Pastel Evolution SDK
Incident..::..CurrentAgentID Property
Incident Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int CurrentAgentID { get; set; }
Visual Basic
Public Property CurrentAgentID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

Incident Class
Incident Members


Incident.Customer Property

[image]

Pastel Evolution SDK
Incident..::..Customer Property
Incident Class See Also Send Feedback
Gets or sets the customer account linked to the incident.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Customer Customer { get; set; }
Visual Basic
Public Property Customer As Customer
    Get
    Set

Property Value

Type: Customer

See Also

Incident Class
Incident Members


Incident.CustomerReference Property

[image]

Pastel Evolution SDK
Incident..::..CustomerReference Property
Incident Class See Also Send Feedback
Gets or sets the customer's reference number.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string CustomerReference { get; set; }
Visual Basic
Public Property CustomerReference As String
    Get
    Set

Property Value

Type: String

See Also

Incident Class
Incident Members


Incident.DueBy Property

[image]

Pastel Evolution SDK
Incident..::..DueBy Property
Incident Class See Also Send Feedback
Gets or sets the incident's due date/time.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DateTime DueBy { get; set; }
Visual Basic
Public Property DueBy As DateTime
    Get
    Set

Property Value

Type: DateTime

See Also

Incident Class
Incident Members


Incident.EscalationGroup Property

[image]

Pastel Evolution SDK
Incident..::..EscalationGroup Property
Incident Class See Also Send Feedback
Gets or sets the incident's assigned escalation group. Note that while Evolution will automatically assign an agent if only an escalation group is supplier, the API requires that an agent be specified.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public EscalationGroup EscalationGroup { get; set; }
Visual Basic
Public Property EscalationGroup As EscalationGroup
    Get
    Set

Property Value

Type: EscalationGroup

See Also

Incident Class
Incident Members


Incident.EscalationGroupID Property

[image]

Pastel Evolution SDK
Incident..::..EscalationGroupID Property
Incident Class See Also Send Feedback
Gets or sets the incident's escalation group id.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int EscalationGroupID { get; set; }
Visual Basic
Public Property EscalationGroupID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

Incident Class
Incident Members


Incident.ID Property

[image]

Pastel Evolution SDK
Incident..::..ID Property
Incident Class See Also Send Feedback
Gets the internal record ID (0 for new, unsaved records).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int ID { get; }
Visual Basic
Public ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

See Also

Incident Class
Incident Members


Incident.IncidentType Property

[image]

Pastel Evolution SDK
Incident..::..IncidentType Property
Incident Class See Also Send Feedback
Gets or sets the incident type.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public IncidentType IncidentType { get; set; }
Visual Basic
Public Property IncidentType As IncidentType
    Get
    Set

Property Value

Type: IncidentType

See Also

Incident Class
Incident Members


Incident.IncidentTypeID Property

[image]

Pastel Evolution SDK
Incident..::..IncidentTypeID Property
Incident Class See Also Send Feedback
Gets or sets the incident's incident type id.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int IncidentTypeID { get; set; }
Visual Basic
Public Property IncidentTypeID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

Incident Class
Incident Members


Incident.InventoryItem Property

[image]

Pastel Evolution SDK
Incident..::..InventoryItem Property
Incident Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public InventoryItem InventoryItem { get; set; }
Visual Basic
Public Property InventoryItem As InventoryItem
    Get
    Set

Property Value

Type: InventoryItem

See Also

Incident Class
Incident Members


Incident.InventoryItemID Property

[image]

Pastel Evolution SDK
Incident..::..InventoryItemID Property
Incident Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int InventoryItemID { get; set; }
Visual Basic
Public Property InventoryItemID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

Incident Class
Incident Members


Incident.JobCard Property

[image]

Pastel Evolution SDK
Incident..::..JobCard Property
Incident Class See Also Send Feedback
Gets or sets the job card linked to the incident.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public JobCard JobCard { get; set; }
Visual Basic
Public Property JobCard As JobCard
    Get
    Set

Property Value

Type: JobCard

See Also

Incident Class
Incident Members


Incident.JobCardID Property

[image]

Pastel Evolution SDK
Incident..::..JobCardID Property
Incident Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int JobCardID { get; set; }
Visual Basic
Public Property JobCardID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

Incident Class
Incident Members


Incident.ModifiedDate Property

[image]

Pastel Evolution SDK
Incident..::..ModifiedDate Property
Incident Class See Also Send Feedback
Gets the last date/time that the incident was modified.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DateTime ModifiedDate { get; }
Visual Basic
Public ReadOnly Property ModifiedDate As DateTime
    Get

Property Value

Type: DateTime

See Also

Incident Class
Incident Members


Incident.Opportunity Property

[image]

Pastel Evolution SDK
Incident..::..Opportunity Property
Incident Class See Also Send Feedback
Gets or sets the sales opportunity linked to the incident.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Opportunity Opportunity { get; set; }
Visual Basic
Public Property Opportunity As Opportunity
    Get
    Set

Property Value

Type: Opportunity

See Also

Incident Class
Incident Members


Incident.OpportunityID Property

[image]

Pastel Evolution SDK
Incident..::..OpportunityID Property
Incident Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int OpportunityID { get; set; }
Visual Basic
Public Property OpportunityID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

Incident Class
Incident Members


Incident.Outline Property

[image]

Pastel Evolution SDK
Incident..::..Outline Property
Incident Class See Also Send Feedback
Gets or sets the incident's outline - the summary description.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Outline { get; set; }
Visual Basic
Public Property Outline As String
    Get
    Set

Property Value

Type: String

See Also

Incident Class
Incident Members


Incident.Person Property

[image]

Pastel Evolution SDK
Incident..::..Person Property
Incident Class See Also Send Feedback
Gets or sets the person record related to the incident.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Person Person { get; set; }
Visual Basic
Public Property Person As Person
    Get
    Set

Property Value

Type: Person

See Also

Incident Class
Incident Members


Incident.PersonID Property

[image]

Pastel Evolution SDK
Incident..::..PersonID Property
Incident Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int PersonID { get; set; }
Visual Basic
Public Property PersonID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

Incident Class
Incident Members


Incident.Priority Property

[image]

Pastel Evolution SDK
Incident..::..Priority Property
Incident Class See Also Send Feedback
Gets or sets the incident's due date/time.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Priority Priority { get; set; }
Visual Basic
Public Property Priority As Priority
    Get
    Set

Property Value

Type: Priority

See Also

Incident Class
Incident Members


Incident.Project Property

[image]

Pastel Evolution SDK
Incident..::..Project Property
Incident Class See Also Send Feedback
Gets or sets the incident's assigned project.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Project Project { get; set; }
Visual Basic
Public Property Project As Project
    Get
    Set

Property Value

Type: Project

See Also

Incident Class
Incident Members


Incident.ProjectID Property

[image]

Pastel Evolution SDK
Incident..::..ProjectID Property
Incident Class See Also Send Feedback
Gets or sets the incident's project id.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int ProjectID { get; set; }
Visual Basic
Public Property ProjectID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

Incident Class
Incident Members


Incident.Prospect Property

[image]

Pastel Evolution SDK
Incident..::..Prospect Property
Incident Class See Also Send Feedback
Gets or sets the prospective client related to the incident.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Prospect Prospect { get; set; }
Visual Basic
Public Property Prospect As Prospect
    Get
    Set

Property Value

Type: Prospect

See Also

Incident Class
Incident Members


Incident.Reference Property

[image]

Pastel Evolution SDK
Incident..::..Reference Property
Incident Class See Also Send Feedback
Gets or sets the internal incident reference.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Reference { get; set; }
Visual Basic
Public Property Reference As String
    Get
    Set

Property Value

Type: String

Remarks

If no reference is set at the time of posting the incident, one will be generated. If number generationis not configured, an exception will be thrown since each incident must have a reference.

See Also

Incident Class
Incident Members


Incident.RequireAcknowledgement Property

[image]

Pastel Evolution SDK
Incident..::..RequireAcknowledgement Property
Incident Class See Also Send Feedback
Gets or sets whether or not the incident requires acknowledgement.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool RequireAcknowledgement { get; set; }
Visual Basic
Public Property RequireAcknowledgement As Boolean
    Get
    Set

Property Value

Type: Boolean

Remarks

When set to true, new incident logs posted will create a notification for the creator of the incident.

See Also

Incident Class
Incident Members


Incident.Status Property

[image]

Pastel Evolution SDK
Incident..::..Status Property
Incident Class See Also Send Feedback
Gets or sets the incident's status.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Incident..::..IncidentStatus Status { get; internal set; }
Visual Basic
Public Property Status As Incident..::..IncidentStatus
    Get
    Friend Set

Property Value

Type: Incident..::..IncidentStatus

See Also

Incident Class
Incident Members


Incident.Supplier Property

[image]

Pastel Evolution SDK
Incident..::..Supplier Property
Incident Class See Also Send Feedback
Gets or sets the supplier account linked to the incident.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Supplier Supplier { get; set; }
Visual Basic
Public Property Supplier As Supplier
    Get
    Set

Property Value

Type: Supplier

See Also

Incident Class
Incident Members


Incident.UserFields Property

[image]

Pastel Evolution SDK
Incident..::..UserFields Property
Incident Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public FieldCollection UserFields { get; }
Visual Basic
Public ReadOnly Property UserFields As FieldCollection
    Get

Property Value

Type: FieldCollection

See Also

Incident Class
Incident Members


Incident.IncidentStatus Enumeration

[image]

Pastel Evolution SDK
Incident..::..IncidentStatus Enumeration
Incident Class See Also Send Feedback
Describes the status of the incident.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public enum IncidentStatus
Visual Basic
Public Enumeration IncidentStatus

Members

Member name | Value | Description
NotStarted | 1 | The incident has been logged but not yet actioned.
InProgress | 2 | The indicent has been actioned by not yet closed.
Complete | 3 | The incident has been closed.

See Also

Pastel.Evolution Namespace


IncidentCategory Class

[image]

Pastel Evolution SDK
IncidentCategory Class
Members See Also Send Feedback
Represents an incident category.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class IncidentCategory : BranchedRecordBase
Visual Basic
Public Class IncidentCategory
    Inherits BranchedRecordBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..IncidentCategory

See Also

IncidentCategory Members


IncidentCategory Members

[image] [image]

Pastel Evolution SDK
IncidentCategory Members
IncidentCategory Class Constructors Methods Fields Properties See Also Send Feedback

The IncidentCategory type exposes the following members.

Constructors

 | Name | Description
Public method | IncidentCategory(Int32) | Initializes a new instance of the IncidentCategory class
Public method | IncidentCategory(String) | Initializes a new instance of the IncidentCategory class

Methods

 | Name | Description
 | _ListCurrentBranch |
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find |
 | FindByDescription |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Description | Gets or sets the record description.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)

See Also

IncidentCategory Class


IncidentCategory Constructor

[image] [image]

Pastel Evolution SDK
IncidentCategory Constructor
IncidentCategory Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IncidentCategory(Int32) | Initializes a new instance of the IncidentCategory class
Public method | IncidentCategory(String) | Initializes a new instance of the IncidentCategory class

See Also

IncidentCategory Class
IncidentCategory Members


IncidentCategory Constructor (Int32)

[image]

Pastel Evolution SDK
IncidentCategory Constructor (Int32)
IncidentCategory Class See Also Send Feedback
Initializes a new instance of the IncidentCategory class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public IncidentCategory(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32

See Also

IncidentCategory Class
IncidentCategory Members
IncidentCategory Overload


IncidentCategory Constructor (String)

[image]

Pastel Evolution SDK
IncidentCategory Constructor (String)
IncidentCategory Class See Also Send Feedback
Initializes a new instance of the IncidentCategory class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public IncidentCategory(
    string description
)
Visual Basic
Public Sub New (
    description As String
)

Parameters

description
Type: System..::..String

See Also

IncidentCategory Class
IncidentCategory Members
IncidentCategory Overload


IncidentCategory Fields

[image] [image]

Pastel Evolution SDK
IncidentCategory Fields
IncidentCategory Class See Also Send Feedback

The IncidentCategory type exposes the following members.

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

IncidentCategory Class


IncidentCategory Methods

[image] [image]

Pastel Evolution SDK
IncidentCategory Methods
IncidentCategory Class See Also Send Feedback

The IncidentCategory type exposes the following members.

Methods

 | Name | Description
 | _ListCurrentBranch |
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find |
 | FindByDescription |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

IncidentCategory Class


IncidentCategory._ListCurrentBranch Method

[image]

Pastel Evolution SDK
IncidentCategory..::.._ListCurrentBranch Method
IncidentCategory Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable _ListCurrentBranch(
    string criteria
)
Visual Basic
Public Shared Function _ListCurrentBranch (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String

Return Value

Type: DataTable

See Also

IncidentCategory Class
IncidentCategory Members


IncidentCategory.Find Method

[image]

Pastel Evolution SDK
IncidentCategory..::..Find Method
IncidentCategory Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String

Return Value

Type: Int32

See Also

IncidentCategory Class
IncidentCategory Members


IncidentCategory.FindByDescription Method

[image]

Pastel Evolution SDK
IncidentCategory..::..FindByDescription Method
IncidentCategory Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int FindByDescription(
    string description
)
Visual Basic
Public Shared Function FindByDescription (
    description As String
) As Integer

Parameters

description
Type: System..::..String

Return Value

Type: Int32

See Also

IncidentCategory Class
IncidentCategory Members


IncidentCategory.List Method

[image]

Pastel Evolution SDK
IncidentCategory..::..List Method
IncidentCategory Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria
)
Visual Basic
Public Shared Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String

Return Value

Type: DataTable

See Also

IncidentCategory Class
IncidentCategory Members


IncidentCategory.OnDelete Method

[image]

Pastel Evolution SDK
IncidentCategory..::..OnDelete Method
IncidentCategory Class See Also Send Feedback
Removes the record from the database, provided it is not referenced by other records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

Exceptions

Exception | Condition
IntegrityViolationException |

See Also

IncidentCategory Class
IncidentCategory Members


IncidentCategory.OnSave Method

[image]

Pastel Evolution SDK
IncidentCategory..::..OnSave Method
IncidentCategory Class See Also Send Feedback
Persists the record to the database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

IncidentCategory Class
IncidentCategory Members


IncidentCategory Properties

[image] [image]

Pastel Evolution SDK
IncidentCategory Properties
IncidentCategory Class See Also Send Feedback

The IncidentCategory type exposes the following members.

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Description | Gets or sets the record description.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)

See Also

IncidentCategory Class


IncidentCategory.Description Property

[image]

Pastel Evolution SDK
IncidentCategory..::..Description Property
IncidentCategory Class See Also Send Feedback
Gets or sets the record description.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Description { get; }
Visual Basic
Public ReadOnly Property Description As String
    Get

Property Value

Type: String

See Also

IncidentCategory Class
IncidentCategory Members


IncidentCategory.ID Property

[image]

Pastel Evolution SDK
IncidentCategory..::..ID Property
IncidentCategory Class See Also Send Feedback
Gets the internal record ID (0 for new, unsaved records).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

See Also

IncidentCategory Class
IncidentCategory Members


IncidentCategory.LongID Property

[image]

Pastel Evolution SDK
IncidentCategory..::..LongID Property
IncidentCategory Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

IncidentCategory Class
IncidentCategory Members


IncidentLogAction Enumeration

[image]

Pastel Evolution SDK
IncidentLogAction Enumeration
See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public enum IncidentLogAction
Visual Basic
Public Enumeration IncidentLogAction

Members

Member name | Value | Description
Assign | 1 |
Action | 2 |
Acknowledge | 3 |
Close | 4 |
ReRoute | 5 |
ReOpen | 6 |
Escalate | 7 |
Email | 8 |
Approve | 9 |
Reject | 10 |

See Also

Pastel.Evolution Namespace


IncidentLogEntry Class

[image]

Pastel Evolution SDK
IncidentLogEntry Class
Members See Also Send Feedback
Represents an incident log entry.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class IncidentLogEntry
Visual Basic
Public Class IncidentLogEntry

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..IncidentLogEntry

See Also

IncidentLogEntry Members


IncidentLogEntry Members

[image] [image]

Pastel Evolution SDK
IncidentLogEntry Members
IncidentLogEntry Class Constructors Methods Properties See Also Send Feedback

The IncidentLogEntry type exposes the following members.

Constructors

 | Name | Description
Public method | IncidentLogEntry | Initializes a new instance of the IncidentLogEntry class

Methods

 | Name | Description
 | _Select |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List(String) |
 | List(String, String) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Action | Gets the log entry action.
Public property | Agent |
Public property | ID |
Public property | Incident |
Public property | IncidentID |
Public property | NewAgent |
Public property | Proxy |
Public property | RawFieldData |
Public property | Resolution |
Public property | UserFields |

See Also

IncidentLogEntry Class


IncidentLogEntry Constructor

[image]

Pastel Evolution SDK
IncidentLogEntry Constructor
IncidentLogEntry Class See Also Send Feedback
Initializes a new instance of the IncidentLogEntry class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public IncidentLogEntry(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32

See Also

IncidentLogEntry Class
IncidentLogEntry Members


IncidentLogEntry Methods

[image] [image]

Pastel Evolution SDK
IncidentLogEntry Methods
IncidentLogEntry Class See Also Send Feedback

The IncidentLogEntry type exposes the following members.

Methods

 | Name | Description
 | _Select |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List(String) |
 | List(String, String) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IncidentLogEntry Class


IncidentLogEntry._Select Method

[image]

Pastel Evolution SDK
IncidentLogEntry..::.._Select Method
IncidentLogEntry Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static IncidentLogEntry[] _Select(
    string criteria,
    string sortOrder
)
Visual Basic
Public Shared Function _Select (
    criteria As String,
    sortOrder As String
) As IncidentLogEntry()

Parameters

criteria
Type: System..::..String
sortOrder
Type: System..::..String

Return Value

Type: array< IncidentLogEntry >[]()[][]

See Also

IncidentLogEntry Class
IncidentLogEntry Members


IncidentLogEntry.Find Method

[image]

Pastel Evolution SDK
IncidentLogEntry..::..Find Method
IncidentLogEntry Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String

Return Value

Type: Int32

See Also

IncidentLogEntry Class
IncidentLogEntry Members


IncidentLogEntry.List Method

[image] [image]

Pastel Evolution SDK
IncidentLogEntry..::..List Method
IncidentLogEntry Class See Also Send Feedback

Overload List

Name | Description
List(String) |
List(String, String) |

See Also

IncidentLogEntry Class
IncidentLogEntry Members


IncidentLogEntry.List Method (String)

[image]

Pastel Evolution SDK
IncidentLogEntry..::..List Method (String)
IncidentLogEntry Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria
)
Visual Basic
Public Shared Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String

Return Value

Type: DataTable

See Also

IncidentLogEntry Class
IncidentLogEntry Members
List Overload


IncidentLogEntry.List Method (String, String)

[image]

Pastel Evolution SDK
IncidentLogEntry..::..List Method (String, String)
IncidentLogEntry Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria,
    string sortOrder
)
Visual Basic
Public Shared Function List (
    criteria As String,
    sortOrder As String
) As DataTable

Parameters

criteria
Type: System..::..String
sortOrder
Type: System..::..String

Return Value

Type: DataTable

See Also

IncidentLogEntry Class
IncidentLogEntry Members
List Overload


IncidentLogEntry Properties

[image] [image]

Pastel Evolution SDK
IncidentLogEntry Properties
IncidentLogEntry Class See Also Send Feedback

The IncidentLogEntry type exposes the following members.

Properties

 | Name | Description
Public property | Action | Gets the log entry action.
Public property | Agent |
Public property | ID |
Public property | Incident |
Public property | IncidentID |
Public property | NewAgent |
Public property | Proxy |
Public property | RawFieldData |
Public property | Resolution |
Public property | UserFields |

See Also

IncidentLogEntry Class


IncidentLogEntry.Action Property

[image]

Pastel Evolution SDK
IncidentLogEntry..::..Action Property
IncidentLogEntry Class See Also Send Feedback
Gets the log entry action.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public IncidentLogAction Action { get; internal set; }
Visual Basic
Public Property Action As IncidentLogAction
    Get
    Friend Set

Property Value

Type: IncidentLogAction

See Also

IncidentLogEntry Class
IncidentLogEntry Members


IncidentLogEntry.Agent Property

[image]

Pastel Evolution SDK
IncidentLogEntry..::..Agent Property
IncidentLogEntry Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Agent Agent { get; set; }
Visual Basic
Public Property Agent As Agent
    Get
    Set

Property Value

Type: Agent

See Also

IncidentLogEntry Class
IncidentLogEntry Members


IncidentLogEntry.ID Property

[image]

Pastel Evolution SDK
IncidentLogEntry..::..ID Property
IncidentLogEntry Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int ID { get; }
Visual Basic
Public ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

See Also

IncidentLogEntry Class
IncidentLogEntry Members


IncidentLogEntry.Incident Property

[image]

Pastel Evolution SDK
IncidentLogEntry..::..Incident Property
IncidentLogEntry Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Incident Incident { get; }
Visual Basic
Public ReadOnly Property Incident As Incident
    Get

Property Value

Type: Incident

See Also

IncidentLogEntry Class
IncidentLogEntry Members


IncidentLogEntry.IncidentID Property

[image]

Pastel Evolution SDK
IncidentLogEntry..::..IncidentID Property
IncidentLogEntry Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int IncidentID { get; }
Visual Basic
Public ReadOnly Property IncidentID As Integer
    Get

Property Value

Type: Int32

See Also

IncidentLogEntry Class
IncidentLogEntry Members


IncidentLogEntry.NewAgent Property

[image]

Pastel Evolution SDK
IncidentLogEntry..::..NewAgent Property
IncidentLogEntry Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Agent NewAgent { get; set; }
Visual Basic
Public Property NewAgent As Agent
    Get
    Set

Property Value

Type: Agent

See Also

IncidentLogEntry Class
IncidentLogEntry Members


IncidentLogEntry.Proxy Property

[image]

Pastel Evolution SDK
IncidentLogEntry..::..Proxy Property
IncidentLogEntry Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool Proxy { get; internal set; }
Visual Basic
Public Property Proxy As Boolean
    Get
    Friend Set

Property Value

Type: Boolean

See Also

IncidentLogEntry Class
IncidentLogEntry Members


IncidentLogEntry.RawFieldData Property

[image]

Pastel Evolution SDK
IncidentLogEntry..::..RawFieldData Property
IncidentLogEntry Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public FieldCollection RawFieldData { get; }
Visual Basic
Public ReadOnly Property RawFieldData As FieldCollection
    Get

Property Value

Type: FieldCollection

See Also

IncidentLogEntry Class
IncidentLogEntry Members


IncidentLogEntry.Resolution Property

[image]

Pastel Evolution SDK
IncidentLogEntry..::..Resolution Property
IncidentLogEntry Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Resolution { get; set; }
Visual Basic
Public Property Resolution As String
    Get
    Set

Property Value

Type: String

See Also

IncidentLogEntry Class
IncidentLogEntry Members


IncidentLogEntry.UserFields Property

[image]

Pastel Evolution SDK
IncidentLogEntry..::..UserFields Property
IncidentLogEntry Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public FieldCollection UserFields { get; }
Visual Basic
Public ReadOnly Property UserFields As FieldCollection
    Get

Property Value

Type: FieldCollection

See Also

IncidentLogEntry Class
IncidentLogEntry Members


IncidentLogNotification Class

[image]

Pastel Evolution SDK
IncidentLogNotification Class
Members See Also Send Feedback
Represents an incident notification. These appear in My Desktop\Notifications.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class IncidentLogNotification
Visual Basic
Public Class IncidentLogNotification

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..IncidentLogNotification

See Also

IncidentLogNotification Members


IncidentLogNotification Members

[image] [image]

Pastel Evolution SDK
IncidentLogNotification Members
IncidentLogNotification Class Constructors Methods See Also Send Feedback

The IncidentLogNotification type exposes the following members.

Constructors

 | Name | Description
Public method | IncidentLogNotification(Int32) | Initializes a new instance of the IncidentLogNotification class
Public method | IncidentLogNotification(IncidentLogEntry) | Initializes a new instance of the IncidentLogNotification class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IncidentLogNotification Class


IncidentLogNotification Constructor

[image] [image]

Pastel Evolution SDK
IncidentLogNotification Constructor
IncidentLogNotification Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IncidentLogNotification(Int32) | Initializes a new instance of the IncidentLogNotification class
Public method | IncidentLogNotification(IncidentLogEntry) | Initializes a new instance of the IncidentLogNotification class

See Also

IncidentLogNotification Class
IncidentLogNotification Members


IncidentLogNotification Constructor (Int32)

[image]

Pastel Evolution SDK
IncidentLogNotification Constructor (Int32)
IncidentLogNotification Class See Also Send Feedback
Initializes a new instance of the IncidentLogNotification class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public IncidentLogNotification(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32

See Also

IncidentLogNotification Class
IncidentLogNotification Members
IncidentLogNotification Overload


IncidentLogNotification Constructor (IncidentLogEntry)

[image]

Pastel Evolution SDK
IncidentLogNotification Constructor (IncidentLogEntry)
IncidentLogNotification Class See Also Send Feedback
Initializes a new instance of the IncidentLogNotification class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public IncidentLogNotification(
    IncidentLogEntry logEntry
)
Visual Basic
Public Sub New (
    logEntry As IncidentLogEntry
)

Parameters

logEntry
Type: Pastel.Evolution..::..IncidentLogEntry

See Also

IncidentLogNotification Class
IncidentLogNotification Members
IncidentLogNotification Overload


IncidentLogNotification Methods

[image] [image]

Pastel Evolution SDK
IncidentLogNotification Methods
IncidentLogNotification Class See Also Send Feedback

The IncidentLogNotification type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IncidentLogNotification Class


IncidentLogNotification.Find Method

[image]

Pastel Evolution SDK
IncidentLogNotification..::..Find Method
IncidentLogNotification Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String

Return Value

Type: Int32

See Also

IncidentLogNotification Class
IncidentLogNotification Members


IncidentType Class

[image]

Pastel Evolution SDK
IncidentType Class
Members See Also Send Feedback
Represents an incident type.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class IncidentType : BranchedRecordBase
Visual Basic
Public Class IncidentType
    Inherits BranchedRecordBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..IncidentType

See Also

IncidentType Members


IncidentType Members

[image] [image]

Pastel Evolution SDK
IncidentType Members
IncidentType Class Constructors Methods Fields Properties See Also Send Feedback

The IncidentType type exposes the following members.

Constructors

 | Name | Description
Public method | IncidentType(Int32) | Initializes a new instance of the IncidentType class
Public method | IncidentType(String) | Initializes a new instance of the IncidentType class

Methods

 | Name | Description
 | _ListCurrentBranch |
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Description | Gets or sets the record description.
Public property | EscalationGroupID | Gets or sets the record description.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | IncidentTypeGroupID |
Public property | LongID | (Overrides RecordBase..::..LongID.)

See Also

IncidentType Class


IncidentType Constructor

[image] [image]

Pastel Evolution SDK
IncidentType Constructor
IncidentType Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IncidentType(Int32) | Initializes a new instance of the IncidentType class
Public method | IncidentType(String) | Initializes a new instance of the IncidentType class

See Also

IncidentType Class
IncidentType Members


IncidentType Constructor (Int32)

[image]

Pastel Evolution SDK
IncidentType Constructor (Int32)
IncidentType Class See Also Send Feedback
Initializes a new instance of the IncidentType class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public IncidentType(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32

See Also

IncidentType Class
IncidentType Members
IncidentType Overload


IncidentType Constructor (String)

[image]

Pastel Evolution SDK
IncidentType Constructor (String)
IncidentType Class See Also Send Feedback
Initializes a new instance of the IncidentType class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public IncidentType(
    string description
)
Visual Basic
Public Sub New (
    description As String
)

Parameters

description
Type: System..::..String

See Also

IncidentType Class
IncidentType Members
IncidentType Overload


IncidentType Fields

[image] [image]

Pastel Evolution SDK
IncidentType Fields
IncidentType Class See Also Send Feedback

The IncidentType type exposes the following members.

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

IncidentType Class


IncidentType Methods

[image] [image]

Pastel Evolution SDK
IncidentType Methods
IncidentType Class See Also Send Feedback

The IncidentType type exposes the following members.

Methods

 | Name | Description
 | _ListCurrentBranch |
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

IncidentType Class


IncidentType._ListCurrentBranch Method

[image]

Pastel Evolution SDK
IncidentType..::.._ListCurrentBranch Method
IncidentType Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable _ListCurrentBranch(
    string criteria
)
Visual Basic
Public Shared Function _ListCurrentBranch (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String

Return Value

Type: DataTable

See Also

IncidentType Class
IncidentType Members


IncidentType.List Method

[image]

Pastel Evolution SDK
IncidentType..::..List Method
IncidentType Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria
)
Visual Basic
Public Shared Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String

Return Value

Type: DataTable

See Also

IncidentType Class
IncidentType Members


IncidentType.OnDelete Method

[image]

Pastel Evolution SDK
IncidentType..::..OnDelete Method
IncidentType Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

See Also

IncidentType Class
IncidentType Members


IncidentType.OnSave Method

[image]

Pastel Evolution SDK
IncidentType..::..OnSave Method
IncidentType Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

IncidentType Class
IncidentType Members


IncidentType Properties

[image] [image]

Pastel Evolution SDK
IncidentType Properties
IncidentType Class See Also Send Feedback

The IncidentType type exposes the following members.

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Description | Gets or sets the record description.
Public property | EscalationGroupID | Gets or sets the record description.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | IncidentTypeGroupID |
Public property | LongID | (Overrides RecordBase..::..LongID.)

See Also

IncidentType Class


IncidentType.Description Property

[image]

Pastel Evolution SDK
IncidentType..::..Description Property
IncidentType Class See Also Send Feedback
Gets or sets the record description.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Description { get; }
Visual Basic
Public ReadOnly Property Description As String
    Get

Property Value

Type: String

See Also

IncidentType Class
IncidentType Members


IncidentType.EscalationGroupID Property

[image]

Pastel Evolution SDK
IncidentType..::..EscalationGroupID Property
IncidentType Class See Also Send Feedback
Gets or sets the record description.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int EscalationGroupID { get; }
Visual Basic
Public ReadOnly Property EscalationGroupID As Integer
    Get

Property Value

Type: Int32

See Also

IncidentType Class
IncidentType Members


IncidentType.ID Property

[image]

Pastel Evolution SDK
IncidentType..::..ID Property
IncidentType Class See Also Send Feedback
Gets the internal record ID (0 for new, unsaved records).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

See Also

IncidentType Class
IncidentType Members


IncidentType.IncidentTypeGroupID Property

[image]

Pastel Evolution SDK
IncidentType..::..IncidentTypeGroupID Property
IncidentType Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int IncidentTypeGroupID { get; }
Visual Basic
Public ReadOnly Property IncidentTypeGroupID As Integer
    Get

Property Value

Type: Int32

See Also

IncidentType Class
IncidentType Members


IncidentType.LongID Property

[image]

Pastel Evolution SDK
IncidentType..::..LongID Property
IncidentType Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

IncidentType Class
IncidentType Members


InventoryBin Class

[image]

Pastel Evolution SDK
InventoryBin Class
Members See Also Send Feedback
Represents an inventory bin.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class InventoryBin : BranchedRecordBase
Visual Basic
Public Class InventoryBin
    Inherits BranchedRecordBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..InventoryBin

See Also

InventoryBin Members


InventoryBin Members

[image] [image]

Pastel Evolution SDK
InventoryBin Members
InventoryBin Class Constructors Methods Fields Properties See Also Send Feedback

The InventoryBin type exposes the following members.

Constructors

 | Name | Description
Public method | InventoryBin()()()() | Creates a new instance of a bin.
Public method | InventoryBin(Int32) | Creates a new instance of a bin.
Public method | InventoryBin(String) | Creates a new instance of a bin.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds a record's database ID.
 | FindByName | Finds a record's database ID.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | List | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | Name | Gets or sets the bin's name.

See Also

InventoryBin Class


InventoryBin Constructor

[image] [image]

Pastel Evolution SDK
InventoryBin Constructor
InventoryBin Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InventoryBin()()()() | Creates a new instance of a bin.
Public method | InventoryBin(Int32) | Creates a new instance of a bin.
Public method | InventoryBin(String) | Creates a new instance of a bin.

See Also

InventoryBin Class
InventoryBin Members


InventoryBin Constructor

[image]

Pastel Evolution SDK
InventoryBin Constructor
InventoryBin Class See Also Send Feedback
Creates a new instance of a bin.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public InventoryBin()
Visual Basic
Public Sub New

See Also

InventoryBin Class
InventoryBin Members
InventoryBin Overload


InventoryBin Constructor (Int32)

[image]

Pastel Evolution SDK
InventoryBin Constructor (Int32)
InventoryBin Class See Also Send Feedback
Creates a new instance of a bin.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public InventoryBin(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32
Specifies the id of the existing record.

See Also

InventoryBin Class
InventoryBin Members
InventoryBin Overload


InventoryBin Constructor (String)

[image]

Pastel Evolution SDK
InventoryBin Constructor (String)
InventoryBin Class See Also Send Feedback
Creates a new instance of a bin.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public InventoryBin(
    string name
)
Visual Basic
Public Sub New (
    name As String
)

Parameters

name
Type: System..::..String
Specifies the name of the existing record.

See Also

InventoryBin Class
InventoryBin Members
InventoryBin Overload


InventoryBin Fields

[image] [image]

Pastel Evolution SDK
InventoryBin Fields
InventoryBin Class See Also Send Feedback

The InventoryBin type exposes the following members.

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

InventoryBin Class


InventoryBin Methods

[image] [image]

Pastel Evolution SDK
InventoryBin Methods
InventoryBin Class See Also Send Feedback

The InventoryBin type exposes the following members.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds a record's database ID.
 | FindByName | Finds a record's database ID.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | List | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

InventoryBin Class


InventoryBin.Find Method

[image]

Pastel Evolution SDK
InventoryBin..::..Find Method
InventoryBin Class See Also Send Feedback
Finds a record's database ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.

Return Value

Type: Int32
The ID of the first record found; -1 if not record was found.

See Also

InventoryBin Class
InventoryBin Members


InventoryBin.FindByName Method

[image]

Pastel Evolution SDK
InventoryBin..::..FindByName Method
InventoryBin Class See Also Send Feedback
Finds a record's database ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int FindByName(
    string name
)
Visual Basic
Public Shared Function FindByName (
    name As String
) As Integer

Parameters

name
Type: System..::..String
Specifies the bin's name.

Return Value

Type: Int32
The ID of the first record found; -1 if not record was found.

See Also

InventoryBin Class
InventoryBin Members


InventoryBin.List Method

[image]

Pastel Evolution SDK
InventoryBin..::..List Method
InventoryBin Class See Also Send Feedback
Gets a list of database records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DataTable List(
    string criteria
)
Visual Basic
Public Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.

Return Value

Type: DataTable
Table containing selected records.

See Also

InventoryBin Class
InventoryBin Members


InventoryBin.OnDelete Method

[image]

Pastel Evolution SDK
InventoryBin..::..OnDelete Method
InventoryBin Class See Also Send Feedback
Removes the record from the database, provided it is not referenced by other records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

See Also

InventoryBin Class
InventoryBin Members


InventoryBin.OnSave Method

[image]

Pastel Evolution SDK
InventoryBin..::..OnSave Method
InventoryBin Class See Also Send Feedback
Persists the record to the database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

InventoryBin Class
InventoryBin Members


InventoryBin Properties

[image] [image]

Pastel Evolution SDK
InventoryBin Properties
InventoryBin Class See Also Send Feedback

The InventoryBin type exposes the following members.

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | Name | Gets or sets the bin's name.

See Also

InventoryBin Class


InventoryBin.ID Property

[image]

Pastel Evolution SDK
InventoryBin..::..ID Property
InventoryBin Class See Also Send Feedback
Gets the internal record ID (0 for new, unsaved records).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

Remarks

Once saved, the ID will reflect the record's internal database identifier.

See Also

InventoryBin Class
InventoryBin Members


InventoryBin.LongID Property

[image]

Pastel Evolution SDK
InventoryBin..::..LongID Property
InventoryBin Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

InventoryBin Class
InventoryBin Members


InventoryBin.Name Property

[image]

Pastel Evolution SDK
InventoryBin..::..Name Property
InventoryBin Class See Also Send Feedback
Gets or sets the bin's name.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

Property Value

Type: String

See Also

InventoryBin Class
InventoryBin Members


InventoryCostingMethod Enumeration

[image]

Pastel Evolution SDK
InventoryCostingMethod Enumeration
See Also Send Feedback
Inventory costing method.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public enum InventoryCostingMethod
Visual Basic
Public Enumeration InventoryCostingMethod

Members

Member name | Value | Description
WeightedAverage | 0 |
Latest | 1 |
Lowest | 2 |
Highest | 3 |
Standard | 4 |

See Also

Pastel.Evolution Namespace


InventoryGroup Class

[image]

Pastel Evolution SDK
InventoryGroup Class
Members See Also Send Feedback
Represents an inventory group.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class InventoryGroup : BranchedRecordBase
Visual Basic
Public Class InventoryGroup
    Inherits BranchedRecordBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..InventoryGroup

See Also

InventoryGroup Members


InventoryGroup Members

[image] [image]

Pastel Evolution SDK
InventoryGroup Members
InventoryGroup Class Constructors Methods Fields Properties See Also Send Feedback

The InventoryGroup type exposes the following members.

Constructors

 | Name | Description
Public method | InventoryGroup()()()() | Creates a new instance of a group.
Public method | InventoryGroup(Int32) | Creates a new instance of a group.
Public method | InventoryGroup(String) | Creates a new instance of a group.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds an inventory group ID.
 | FindByCode | Attempts to find an inventory group by using its code and returns its ID.
 | Get | Returns the [first] group object with the code specified; otherwise, returns null.
 | GetByCode | Returns a group object corresponding to the code specified; otherwise, returns null.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | List | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | (Overrides Object..::..ToString()()()().)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | AdjustmentAccount | Gets or sets the group's overriding adjustment GL account.
Public property | AdjustmentAccountID | Gets or sets the group's overriding adjustment GL account id.
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Code | Gets or sets the group's code.
Public property | CostOfSalesAccount | Gets or sets the group's overriding cost of sales GL account.
Public property | CostOfSalesAccountID | Gets or sets the group's overriding cost of sales GL account id.
Public property | CostVarianceAccount | Gets or sets the group's overriding cost variance GL account.
Public property | CostVarianceAccountID | Gets or sets the group's overriding cost variance GL account id.
Public property | Description | Gets or sets the group's description.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | MinimumGPPercent |
Public property | PurchasesAccount | Gets or sets the group's overriding purchases GL account.
Public property | PurchasesAccountID | Gets or sets the group's overriding purchases GL account id.
Public property | PurchasesCostVarianceAccount | Gets or sets the group's overriding purchases cost variance GL account.
Public property | PurchasesCostVarianceAccountID | Gets or sets the group's overriding purchases cost variance GL account ID.
Public property | SalesAccount | Gets or sets the group's overriding sales GL account.
Public property | SalesAccountID | Gets or sets the group's overriding sales GL account id.
Public property | StockAccount | Gets or sets the group's overriding stock GL account.
Public property | StockAccountID | Gets or sets the group's overriding stock GL account id.
Public property | WipAccount | Gets or sets the group's overriding work-in-progress GL account.
Public property | WipAccountID | Gets or sets the group's overriding work-in-progress GL account id.

See Also

InventoryGroup Class


InventoryGroup Constructor

[image] [image]

Pastel Evolution SDK
InventoryGroup Constructor
InventoryGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InventoryGroup()()()() | Creates a new instance of a group.
Public method | InventoryGroup(Int32) | Creates a new instance of a group.
Public method | InventoryGroup(String) | Creates a new instance of a group.

See Also

InventoryGroup Class
InventoryGroup Members


InventoryGroup Constructor

[image]

Pastel Evolution SDK
InventoryGroup Constructor
InventoryGroup Class See Also Send Feedback
Creates a new instance of a group.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public InventoryGroup()
Visual Basic
Public Sub New

See Also

InventoryGroup Class
InventoryGroup Members
InventoryGroup Overload


InventoryGroup Constructor (Int32)

[image]

Pastel Evolution SDK
InventoryGroup Constructor (Int32)
InventoryGroup Class See Also Send Feedback
Creates a new instance of a group.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public InventoryGroup(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32
Specifies the id of the existing record.

See Also

InventoryGroup Class
InventoryGroup Members
InventoryGroup Overload


InventoryGroup Constructor (String)

[image]

Pastel Evolution SDK
InventoryGroup Constructor (String)
InventoryGroup Class See Also Send Feedback
Creates a new instance of a group.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public InventoryGroup(
    string code
)
Visual Basic
Public Sub New (
    code As String
)

Parameters

code
Type: System..::..String
Specifies the code of the existing record.

See Also

InventoryGroup Class
InventoryGroup Members
InventoryGroup Overload


InventoryGroup Fields

[image] [image]

Pastel Evolution SDK
InventoryGroup Fields
InventoryGroup Class See Also Send Feedback

The InventoryGroup type exposes the following members.

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

InventoryGroup Class


InventoryGroup Methods

[image] [image]

Pastel Evolution SDK
InventoryGroup Methods
InventoryGroup Class See Also Send Feedback

The InventoryGroup type exposes the following members.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds an inventory group ID.
 | FindByCode | Attempts to find an inventory group by using its code and returns its ID.
 | Get | Returns the [first] group object with the code specified; otherwise, returns null.
 | GetByCode | Returns a group object corresponding to the code specified; otherwise, returns null.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | List | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | (Overrides Object..::..ToString()()()().)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

InventoryGroup Class


InventoryGroup.Find Method

[image]

Pastel Evolution SDK
InventoryGroup..::..Find Method
InventoryGroup Class See Also Send Feedback
Finds an inventory group ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String
The criteria passed to the SQL query. Eg. StGroup = 'INT001' or Description like '%Internal%'

Return Value

Type: Int32
The ID of the first record found; -1 if not record was found.

See Also

InventoryGroup Class
InventoryGroup Members


InventoryGroup.FindByCode Method

[image]

Pastel Evolution SDK
InventoryGroup..::..FindByCode Method
InventoryGroup Class See Also Send Feedback
Attempts to find an inventory group by using its code and returns its ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int FindByCode(
    string code
)
Visual Basic
Public Shared Function FindByCode (
    code As String
) As Integer

Parameters

code
Type: System..::..String
The code used to lookup the group.

Return Value

Type: Int32
-1 if no record was found, else the id of the first record matching the criteria supplied.

See Also

InventoryGroup Class
InventoryGroup Members
Pastel.Evolution Namespace
InventoryGroup..::..Find(String)


InventoryGroup.Get Method

[image]

Pastel Evolution SDK
InventoryGroup..::..Get Method
InventoryGroup Class See Also Send Feedback
Returns the [first] group object with the code specified; otherwise, returns null.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static InventoryGroup Get(
    string criteria
)
Visual Basic
Public Shared Function Get (
    criteria As String
) As InventoryGroup

Parameters

criteria
Type: System..::..String
Eg. Code like '1_B%'

Return Value

Type: InventoryGroup

See Also

InventoryGroup Class
InventoryGroup Members
Pastel.Evolution Namespace
InventoryGroup..::..Find(String)


InventoryGroup.GetByCode Method

[image]

Pastel Evolution SDK
InventoryGroup..::..GetByCode Method
InventoryGroup Class See Also Send Feedback
Returns a group object corresponding to the code specified; otherwise, returns null.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static InventoryGroup GetByCode(
    string code
)
Visual Basic
Public Shared Function GetByCode (
    code As String
) As InventoryGroup

Parameters

code
Type: System..::..String

Return Value

Type: InventoryGroup

See Also

InventoryGroup Class
InventoryGroup Members


InventoryGroup.List Method

[image]

Pastel Evolution SDK
InventoryGroup..::..List Method
InventoryGroup Class See Also Send Feedback
Gets a list of database records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DataTable List(
    string criteria
)
Visual Basic
Public Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.

Return Value

Type: DataTable
Table containing selected records.

See Also

InventoryGroup Class
InventoryGroup Members


InventoryGroup.OnDelete Method

[image]

Pastel Evolution SDK
InventoryGroup..::..OnDelete Method
InventoryGroup Class See Also Send Feedback
Removes the record from the database, provided it is not referenced by other records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

See Also

InventoryGroup Class
InventoryGroup Members


InventoryGroup.OnSave Method

[image]

Pastel Evolution SDK
InventoryGroup..::..OnSave Method
InventoryGroup Class See Also Send Feedback
Persists the record to the database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

InventoryGroup Class
InventoryGroup Members


InventoryGroup.ToString Method

[image]

Pastel Evolution SDK
InventoryGroup..::..ToString Method
InventoryGroup Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String

See Also

InventoryGroup Class
InventoryGroup Members


InventoryGroup Properties

[image] [image]

Pastel Evolution SDK
InventoryGroup Properties
InventoryGroup Class See Also Send Feedback

The InventoryGroup type exposes the following members.

Properties

 | Name | Description
Public property | AdjustmentAccount | Gets or sets the group's overriding adjustment GL account.
Public property | AdjustmentAccountID | Gets or sets the group's overriding adjustment GL account id.
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Code | Gets or sets the group's code.
Public property | CostOfSalesAccount | Gets or sets the group's overriding cost of sales GL account.
Public property | CostOfSalesAccountID | Gets or sets the group's overriding cost of sales GL account id.
Public property | CostVarianceAccount | Gets or sets the group's overriding cost variance GL account.
Public property | CostVarianceAccountID | Gets or sets the group's overriding cost variance GL account id.
Public property | Description | Gets or sets the group's description.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | MinimumGPPercent |
Public property | PurchasesAccount | Gets or sets the group's overriding purchases GL account.
Public property | PurchasesAccountID | Gets or sets the group's overriding purchases GL account id.
Public property | PurchasesCostVarianceAccount | Gets or sets the group's overriding purchases cost variance GL account.
Public property | PurchasesCostVarianceAccountID | Gets or sets the group's overriding purchases cost variance GL account ID.
Public property | SalesAccount | Gets or sets the group's overriding sales GL account.
Public property | SalesAccountID | Gets or sets the group's overriding sales GL account id.
Public property | StockAccount | Gets or sets the group's overriding stock GL account.
Public property | StockAccountID | Gets or sets the group's overriding stock GL account id.
Public property | WipAccount | Gets or sets the group's overriding work-in-progress GL account.
Public property | WipAccountID | Gets or sets the group's overriding work-in-progress GL account id.

See Also

InventoryGroup Class


InventoryGroup.AdjustmentAccount Property

[image]

Pastel Evolution SDK
InventoryGroup..::..AdjustmentAccount Property
InventoryGroup Class See Also Send Feedback
Gets or sets the group's overriding adjustment GL account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLAccount AdjustmentAccount { get; set; }
Visual Basic
Public Property AdjustmentAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

See Also

InventoryGroup Class
InventoryGroup Members


InventoryGroup.AdjustmentAccountID Property

[image]

Pastel Evolution SDK
InventoryGroup..::..AdjustmentAccountID Property
InventoryGroup Class See Also Send Feedback
Gets or sets the group's overriding adjustment GL account id.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int AdjustmentAccountID { get; set; }
Visual Basic
Public Property AdjustmentAccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

InventoryGroup Class
InventoryGroup Members


InventoryGroup.Code Property

[image]

Pastel Evolution SDK
InventoryGroup..::..Code Property
InventoryGroup Class See Also Send Feedback
Gets or sets the group's code.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Code { get; set; }
Visual Basic
Public Property Code As String
    Get
    Set

Property Value

Type: String

See Also

InventoryGroup Class
InventoryGroup Members


InventoryGroup.CostOfSalesAccount Property

[image]

Pastel Evolution SDK
InventoryGroup..::..CostOfSalesAccount Property
InventoryGroup Class See Also Send Feedback
Gets or sets the group's overriding cost of sales GL account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLAccount CostOfSalesAccount { get; set; }
Visual Basic
Public Property CostOfSalesAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

See Also

InventoryGroup Class
InventoryGroup Members


InventoryGroup.CostOfSalesAccountID Property

[image]

Pastel Evolution SDK
InventoryGroup..::..CostOfSalesAccountID Property
InventoryGroup Class See Also Send Feedback
Gets or sets the group's overriding cost of sales GL account id.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int CostOfSalesAccountID { get; set; }
Visual Basic
Public Property CostOfSalesAccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

InventoryGroup Class
InventoryGroup Members


InventoryGroup.CostVarianceAccount Property

[image]

Pastel Evolution SDK
InventoryGroup..::..CostVarianceAccount Property
InventoryGroup Class See Also Send Feedback
Gets or sets the group's overriding cost variance GL account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLAccount CostVarianceAccount { get; set; }
Visual Basic
Public Property CostVarianceAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

Remarks

In contrast to purchases cost variance, this account is used to account for variances encountered in latest or standard cost calculations. Warehouse transfer cost variations are posted to the overriding adjusment account or the credit ledger account on the warehouse transfer transaction code.

See Also

InventoryGroup Class
InventoryGroup Members


InventoryGroup.CostVarianceAccountID Property

[image]

Pastel Evolution SDK
InventoryGroup..::..CostVarianceAccountID Property
InventoryGroup Class See Also Send Feedback
Gets or sets the group's overriding cost variance GL account id.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int CostVarianceAccountID { get; set; }
Visual Basic
Public Property CostVarianceAccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

InventoryGroup Class
InventoryGroup Members


InventoryGroup.Description Property

[image]

Pastel Evolution SDK
InventoryGroup..::..Description Property
InventoryGroup Class See Also Send Feedback
Gets or sets the group's description.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set

Property Value

Type: String

See Also

InventoryGroup Class
InventoryGroup Members


InventoryGroup.ID Property

[image]

Pastel Evolution SDK
InventoryGroup..::..ID Property
InventoryGroup Class See Also Send Feedback
Gets the internal record ID (0 for new, unsaved records).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

Remarks

Once saved, the ID will reflect the record's internal database identifier.

See Also

InventoryGroup Class
InventoryGroup Members


InventoryGroup.LongID Property

[image]

Pastel Evolution SDK
InventoryGroup..::..LongID Property
InventoryGroup Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

InventoryGroup Class
InventoryGroup Members


InventoryGroup.MinimumGPPercent Property

[image]

Pastel Evolution SDK
InventoryGroup..::..MinimumGPPercent Property
InventoryGroup Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double MinimumGPPercent { get; set; }
Visual Basic
Public Property MinimumGPPercent As Double
    Get
    Set

Property Value

Type: Double

See Also

InventoryGroup Class
InventoryGroup Members


InventoryGroup.PurchasesAccount Property

[image]

Pastel Evolution SDK
InventoryGroup..::..PurchasesAccount Property
InventoryGroup Class See Also Send Feedback
Gets or sets the group's overriding purchases GL account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLAccount PurchasesAccount { get; set; }
Visual Basic
Public Property PurchasesAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

See Also

InventoryGroup Class
InventoryGroup Members


InventoryGroup.PurchasesAccountID Property

[image]

Pastel Evolution SDK
InventoryGroup..::..PurchasesAccountID Property
InventoryGroup Class See Also Send Feedback
Gets or sets the group's overriding purchases GL account id.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int PurchasesAccountID { get; set; }
Visual Basic
Public Property PurchasesAccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

InventoryGroup Class
InventoryGroup Members


InventoryGroup.PurchasesCostVarianceAccount Property

[image]

Pastel Evolution SDK
InventoryGroup..::..PurchasesCostVarianceAccount Property
InventoryGroup Class See Also Send Feedback
Gets or sets the group's overriding purchases cost variance GL account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLAccount PurchasesCostVarianceAccount { get; set; }
Visual Basic
Public Property PurchasesCostVarianceAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

Remarks

In contrast to the cost variance account, the purchases cost variance account is used only to account for variances between GRV and supplier invoice cost prices.

See Also

InventoryGroup Class
InventoryGroup Members


InventoryGroup.PurchasesCostVarianceAccountID Property

[image]

Pastel Evolution SDK
InventoryGroup..::..PurchasesCostVarianceAccountID Property
InventoryGroup Class See Also Send Feedback
Gets or sets the group's overriding purchases cost variance GL account ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int PurchasesCostVarianceAccountID { get; set; }
Visual Basic
Public Property PurchasesCostVarianceAccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

InventoryGroup Class
InventoryGroup Members


InventoryGroup.SalesAccount Property

[image]

Pastel Evolution SDK
InventoryGroup..::..SalesAccount Property
InventoryGroup Class See Also Send Feedback
Gets or sets the group's overriding sales GL account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLAccount SalesAccount { get; set; }
Visual Basic
Public Property SalesAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

See Also

InventoryGroup Class
InventoryGroup Members


InventoryGroup.SalesAccountID Property

[image]

Pastel Evolution SDK
InventoryGroup..::..SalesAccountID Property
InventoryGroup Class See Also Send Feedback
Gets or sets the group's overriding sales GL account id.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int SalesAccountID { get; set; }
Visual Basic
Public Property SalesAccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

InventoryGroup Class
InventoryGroup Members


InventoryGroup.StockAccount Property

[image]

Pastel Evolution SDK
InventoryGroup..::..StockAccount Property
InventoryGroup Class See Also Send Feedback
Gets or sets the group's overriding stock GL account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLAccount StockAccount { get; set; }
Visual Basic
Public Property StockAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

See Also

InventoryGroup Class
InventoryGroup Members


InventoryGroup.StockAccountID Property

[image]

Pastel Evolution SDK
InventoryGroup..::..StockAccountID Property
InventoryGroup Class See Also Send Feedback
Gets or sets the group's overriding stock GL account id.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int StockAccountID { get; set; }
Visual Basic
Public Property StockAccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

InventoryGroup Class
InventoryGroup Members


InventoryGroup.WipAccount Property

[image]

Pastel Evolution SDK
InventoryGroup..::..WipAccount Property
InventoryGroup Class See Also Send Feedback
Gets or sets the group's overriding work-in-progress GL account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLAccount WipAccount { get; set; }
Visual Basic
Public Property WipAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

See Also

InventoryGroup Class
InventoryGroup Members


InventoryGroup.WipAccountID Property

[image]

Pastel Evolution SDK
InventoryGroup..::..WipAccountID Property
InventoryGroup Class See Also Send Feedback
Gets or sets the group's overriding work-in-progress GL account id.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int WipAccountID { get; set; }
Visual Basic
Public Property WipAccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

InventoryGroup Class
InventoryGroup Members


InventoryIntegrationMethod Enumeration

[image]

Pastel Evolution SDK
InventoryIntegrationMethod Enumeration
See Also Send Feedback
Inventory costing method.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public enum InventoryIntegrationMethod
Visual Basic
Public Enumeration InventoryIntegrationMethod

Members

Member name | Value | Description
Perpetual | 0 |
Periodic | 1 |

See Also

Pastel.Evolution Namespace


InventoryItem Class

[image]

Pastel Evolution SDK
InventoryItem Class
Members See Also Send Feedback
Respresents an inventory item, typically products sold or services rendered.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class InventoryItem : AccountBase
Visual Basic
Public Class InventoryItem
    Inherits AccountBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..AccountBase
Pastel.Evolution..::..InventoryItem

See Also

InventoryItem Members


InventoryItem Members

[image] [image]

Pastel Evolution SDK
InventoryItem Members
InventoryItem Class Constructors Methods Fields Properties See Also Send Feedback

The InventoryItem type exposes the following members.

Constructors

 | Name | Description
Public method | InventoryItem()()()() | Creates a new instance of a stock item.
Public method | InventoryItem(Int32) | Creates a new instance of a stock item.
Public method | InventoryItem(String) | Creates a new instance of a stock item.

Methods

 | Name | Description
 | _Exists | Experimental method.
Public method | _GenerateAccountCode |
 | _ListCurrentBranch |
Public method | _Refresh | Experimental method.
 | _Select(String) | Experimental Method
 | _Select(String, String) |
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds a stock item ID.
 | FindByCode | Attempts to find an inventory item by its code and returns its ID.
 | Get | Returns an instance of the first record satisfying the criteria specified; otherwise, returns null.
 | GetByCode | Returns a inventory item object corresponding to the code specified; otherwise, returns null.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List(String) | Lists stock items for the supplied criteria.
 | List(String, String) | Lists stock items for the supplied criteria.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | (Overrides AccountBase..::..OnDelete()()()().)
Protected method | OnSave | (Overrides AccountBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | (Overrides AccountBase..::..ToString()()()().)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | _LotsExpire | Gets or sets whether or not the stock item is tracked in lots.
Public property | Active | Gets or sets the record's operational state. Inactive items cannot be used in further transactions. (Overrides AccountBase..::..Active.)
Public property | AllowDuplicateSerialNumber | Gets or sets whether the serial number item allows for duplicate serial numbers.
Public property | AllowNegativeStock | Whether or not the item allows for negative stock.
Public property | AverageUnitCost | Gets the stock item's average unit cost.
Public property | BarCode | Gets or sets the stock item's bar code.
Public property | BinCode | Gets or sets the stock item's bin.
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Code | Gets or sets the item code. When segmented, the full item code is returned; however, when setting the code, be sure to only set the item's short code. (Overrides AccountBase..::..Code.)
Public property | CostingMethod | Gets the unit cost according to chosen costing method set in inventory preferences.
Public property | DefaultCreditNoteTaxType | Gets or sets the stock item's default credit note tax type.
Public property | DefaultGoodsReceivedTaxType | Gets or sets the stock item's default tax type for goods received notes.
Public property | DefaultInvoicingTaxType | Gets or sets the stock item's default invoicing tax type.
Public property | DefaultPurchaseUnit |
Public property | DefaultPurchaseUnitID |
Public property | DefaultReturnToSupplierTaxType | Gets or sets the stock item's default tax type used on returns to supplier .
Public property | DefaultSellingPrice | Gets the stock item's default exclusive selling price (belonging to the default price list).
Public property | DefaultSellingUnit |
Public property | DefaultSellingUnitID |
Public property | Description | Gets or sets the stock item's description. (Overrides AccountBase..::..Description.)
Public property | Description_2 | Gets or sets the stock item's 2nd description.
Public property | Description_3 | Gets or sets the stock item's 3rd description.
Public property | Group | Gets or sets the stock item's group.
Public property | HighestUnitCost | Gets the stock item's highest unit cost.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | InitialLotStatus |
Public property | InitialLotStatusID |
Public property | IsCommissionable | Gets or sets whether or not the stock item is commissionable.
Public property | IsLotTracked | Gets or sets whether or not the stock item is tracked in lots.
Public property | IsSegmented | Whether or not the item is made up of segments.
Public property | IsSerialTracked | Gets or sets whether or not the stock item is tracked by serial numbers.
Public property | IsServiceItem | Gets or sets whether or not the item is a service item.
Public property | IsStrictSerialTracked | Gets or sets whether or not the stock item is serial-tracked using the "strict" method.
Public property | IsWarehouseTracked | Gets or sets whether or not the item is tracked in warehouses.
Public property | Item |
Public property | LatestUnitCost | Gets the stock item's latest unit cost.
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | LowestUnitCost | Gets the stock item's lowest unit cost.
Public property | MininumGPPercentage |
Public property | Module | Gets the stock item's Evolution module. (Overrides AccountBase..::..Module.)
Public property | PackCode | Gets or sets the stock item's pack code.
Public property | QtyFree | Gets the stock item's free quantity.
Public property | QtyOnHand | Gets the stock item's quantity on hand.
Public property | QtyOnPurchaseOrder | Gets the stock item's quantity on purchase order.
Public property | QtyOnSalesOrder | Gets the stock item's quantity on sales order.
Public property | QtyReserved | Gets the stock item's reserved quantity.
Public property | QtyWIP | Gets the quantity of stock on active jobs (work in progress).
Public property | RawFieldData | Obsolete.
Public property | Segments | Gets the stock item's segment collection.
Public property | SellingPrice1 | Gets or sets the exclusive selling price belonging to the "first" price list in the system (default: "Price List 1").
Public property | SellingPrice2 | Gets or sets the exclusive selling price belonging to the "second" price list in the system (default: "Price List 2").
Public property | SellingPrice3 | Gets or sets the exclusive selling price belonging to the "third" price list in the system (default: "Price List 3").
Public property | SellingPrices | Gets the stock item's selling price collection.
Public property | ShortCode | Gets the stock item's short code.
Public property | StandardUnitCost | Gets the stock item's standard unit cost.
Public property | StockingUnit |
Public property | UnitCost | Gets the unit cost according to chosen costing method set in inventory preferences.
Public property | UserFields |
Public property | WarehouseContexts | Gets the stock item's warehouse context collection.

See Also

InventoryItem Class


InventoryItem Constructor

[image] [image]

Pastel Evolution SDK
InventoryItem Constructor
InventoryItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InventoryItem()()()() | Creates a new instance of a stock item.
Public method | InventoryItem(Int32) | Creates a new instance of a stock item.
Public method | InventoryItem(String) | Creates a new instance of a stock item.

See Also

InventoryItem Class
InventoryItem Members


InventoryItem Constructor

[image]

Pastel Evolution SDK
InventoryItem Constructor
InventoryItem Class See Also Send Feedback
Creates a new instance of a stock item.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public InventoryItem()
Visual Basic
Public Sub New

See Also

InventoryItem Class
InventoryItem Members
InventoryItem Overload


InventoryItem Constructor (Int32)

[image]

Pastel Evolution SDK
InventoryItem Constructor (Int32)
InventoryItem Class See Also Send Feedback
Creates a new instance of a stock item.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public InventoryItem(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32
Specifies the id of the existing record.

See Also

InventoryItem Class
InventoryItem Members
InventoryItem Overload


InventoryItem Constructor (String)

[image]

Pastel Evolution SDK
InventoryItem Constructor (String)
InventoryItem Class See Also Send Feedback
Creates a new instance of a stock item.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public InventoryItem(
    string code
)
Visual Basic
Public Sub New (
    code As String
)

Parameters

code
Type: System..::..String
Specifies the code of the existing record.

See Also

InventoryItem Class
InventoryItem Members
InventoryItem Overload


InventoryItem Fields

[image] [image]

Pastel Evolution SDK
InventoryItem Fields
InventoryItem Class See Also Send Feedback

The InventoryItem type exposes the following members.

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

InventoryItem Class


InventoryItem Methods

[image] [image]

Pastel Evolution SDK
InventoryItem Methods
InventoryItem Class See Also Send Feedback

The InventoryItem type exposes the following members.

Methods

 | Name | Description
 | _Exists | Experimental method.
Public method | _GenerateAccountCode |
 | _ListCurrentBranch |
Public method | _Refresh | Experimental method.
 | _Select(String) | Experimental Method
 | _Select(String, String) |
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds a stock item ID.
 | FindByCode | Attempts to find an inventory item by its code and returns its ID.
 | Get | Returns an instance of the first record satisfying the criteria specified; otherwise, returns null.
 | GetByCode | Returns a inventory item object corresponding to the code specified; otherwise, returns null.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List(String) | Lists stock items for the supplied criteria.
 | List(String, String) | Lists stock items for the supplied criteria.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | (Overrides AccountBase..::..OnDelete()()()().)
Protected method | OnSave | (Overrides AccountBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | (Overrides AccountBase..::..ToString()()()().)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

InventoryItem Class


InventoryItem._Exists Method

[image]

Pastel Evolution SDK
InventoryItem..::.._Exists Method
InventoryItem Class See Also Send Feedback
Experimental method.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static bool _Exists(
    string code
)
Visual Basic
Public Shared Function _Exists (
    code As String
) As Boolean

Parameters

code
Type: System..::..String

Return Value

Type: Boolean

See Also

InventoryItem Class
InventoryItem Members


InventoryItem._GenerateAccountCode Method

[image]

Pastel Evolution SDK
InventoryItem..::.._GenerateAccountCode Method
InventoryItem Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string _GenerateAccountCode(
    string seed
)
Visual Basic
Public Function _GenerateAccountCode (
    seed As String
) As String

Parameters

seed
Type: System..::..String

Return Value

Type: String

See Also

InventoryItem Class
InventoryItem Members


InventoryItem._ListCurrentBranch Method

[image]

Pastel Evolution SDK
InventoryItem..::.._ListCurrentBranch Method
InventoryItem Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable _ListCurrentBranch(
    string criteria
)
Visual Basic
Public Shared Function _ListCurrentBranch (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String

Return Value

Type: DataTable

See Also

InventoryItem Class
InventoryItem Members


InventoryItem._Refresh Method

[image]

Pastel Evolution SDK
InventoryItem..::.._Refresh Method
InventoryItem Class See Also Send Feedback
Experimental method.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void _Refresh()
Visual Basic
Public Sub _Refresh

See Also

InventoryItem Class
InventoryItem Members


InventoryItem._Select Method

[image] [image]

Pastel Evolution SDK
InventoryItem..::.._Select Method
InventoryItem Class See Also Send Feedback

Overload List

Name | Description
_Select(String) | Experimental Method
_Select(String, String) |

See Also

InventoryItem Class
InventoryItem Members


InventoryItem._Select Method (String)

[image]

Pastel Evolution SDK
InventoryItem..::.._Select Method (String)
InventoryItem Class See Also Send Feedback
Experimental Method

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static InventoryItem[] _Select(
    string criteria
)
Visual Basic
Public Shared Function _Select (
    criteria As String
) As InventoryItem()

Parameters

criteria
Type: System..::..String

Return Value

Type: array< InventoryItem >[]()[][]

See Also

InventoryItem Class
InventoryItem Members
_Select Overload


InventoryItem._Select Method (String, String)

[image]

Pastel Evolution SDK
InventoryItem..::.._Select Method (String, String)
InventoryItem Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static InventoryItem[] _Select(
    string criteria,
    string sortOrder
)
Visual Basic
Public Shared Function _Select (
    criteria As String,
    sortOrder As String
) As InventoryItem()

Parameters

criteria
Type: System..::..String
sortOrder
Type: System..::..String

Return Value

Type: array< InventoryItem >[]()[][]

See Also

InventoryItem Class
InventoryItem Members
_Select Overload


InventoryItem.Find Method

[image]

Pastel Evolution SDK
InventoryItem..::..Find Method
InventoryItem Class See Also Send Feedback
Finds a stock item ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String
The SQL criteria to apply to the search, e.g. Code = 'ABC00112' or Description_1 like '%MOLD%'

Return Value

Type: Int32
The ID of the first record found; -1 if not record was foun.

See Also

InventoryItem Class
InventoryItem Members


InventoryItem.FindByCode Method

[image]

Pastel Evolution SDK
InventoryItem..::..FindByCode Method
InventoryItem Class See Also Send Feedback
Attempts to find an inventory item by its code and returns its ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int FindByCode(
    string code
)
Visual Basic
Public Shared Function FindByCode (
    code As String
) As Integer

Parameters

code
Type: System..::..String
The code used to lookup the account.

Return Value

Type: Int32
-1 if no record was found, else the id of the first account matching the criteria supplied.

See Also

InventoryItem Class
InventoryItem Members
Pastel.Evolution Namespace
InventoryItem..::..Find(String)


InventoryItem.Get Method

[image]

Pastel Evolution SDK
InventoryItem..::..Get Method
InventoryItem Class See Also Send Feedback
Returns an instance of the first record satisfying the criteria specified; otherwise, returns null.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static InventoryItem Get(
    string criteria
)
Visual Basic
Public Shared Function Get (
    criteria As String
) As InventoryItem

Parameters

criteria
Type: System..::..String
Eg. Code = 'STO0021' or Description like '%Stone%'

Return Value

Type: InventoryItem
The record found; otherwise null

See Also

InventoryItem Class
InventoryItem Members
Pastel.Evolution Namespace
InventoryItem..::..Find(String)


InventoryItem.GetByCode Method

[image]

Pastel Evolution SDK
InventoryItem..::..GetByCode Method
InventoryItem Class See Also Send Feedback
Returns a inventory item object corresponding to the code specified; otherwise, returns null.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static InventoryItem GetByCode(
    string code
)
Visual Basic
Public Shared Function GetByCode (
    code As String
) As InventoryItem

Parameters

code
Type: System..::..String
Specifies the code.

Return Value

Type: InventoryItem
The record found; otherwise null

See Also

InventoryItem Class
InventoryItem Members


InventoryItem.List Method

[image] [image]

Pastel Evolution SDK
InventoryItem..::..List Method
InventoryItem Class See Also Send Feedback

Overload List

Name | Description
List(String) | Lists stock items for the supplied criteria.
List(String, String) | Lists stock items for the supplied criteria.

See Also

InventoryItem Class
InventoryItem Members


InventoryItem.List Method (String)

[image]

Pastel Evolution SDK
InventoryItem..::..List Method (String)
InventoryItem Class See Also Send Feedback
Lists stock items for the supplied criteria.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria
)
Visual Basic
Public Shared Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String

Return Value

Type: DataTable

See Also

InventoryItem Class
InventoryItem Members
List Overload


InventoryItem.List Method (String, String)

[image]

Pastel Evolution SDK
InventoryItem..::..List Method (String, String)
InventoryItem Class See Also Send Feedback
Lists stock items for the supplied criteria.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria,
    string sortOrder
)
Visual Basic
Public Shared Function List (
    criteria As String,
    sortOrder As String
) As DataTable

Parameters

criteria
Type: System..::..String
The SQL criteria used to locate the record, e.g. Code like '1___'
sortOrder
Type: System..::..String
The SQL order by clause to use, e.g. ItemActive desc, Code

Return Value

Type: DataTable

Remarks

Table aliases to be used in criteria: Core, Bin

See Also

InventoryItem Class
InventoryItem Members
List Overload


InventoryItem.OnDelete Method

[image]

Pastel Evolution SDK
InventoryItem..::..OnDelete Method
InventoryItem Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

See Also

InventoryItem Class
InventoryItem Members


InventoryItem.OnSave Method

[image]

Pastel Evolution SDK
InventoryItem..::..OnSave Method
InventoryItem Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

InventoryItem Class
InventoryItem Members


InventoryItem.ToString Method

[image]

Pastel Evolution SDK
InventoryItem..::..ToString Method
InventoryItem Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String

See Also

InventoryItem Class
InventoryItem Members


InventoryItem Properties

[image] [image]

Pastel Evolution SDK
InventoryItem Properties
InventoryItem Class See Also Send Feedback

The InventoryItem type exposes the following members.

Properties

 | Name | Description
Public property | _LotsExpire | Gets or sets whether or not the stock item is tracked in lots.
Public property | Active | Gets or sets the record's operational state. Inactive items cannot be used in further transactions. (Overrides AccountBase..::..Active.)
Public property | AllowDuplicateSerialNumber | Gets or sets whether the serial number item allows for duplicate serial numbers.
Public property | AllowNegativeStock | Whether or not the item allows for negative stock.
Public property | AverageUnitCost | Gets the stock item's average unit cost.
Public property | BarCode | Gets or sets the stock item's bar code.
Public property | BinCode | Gets or sets the stock item's bin.
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Code | Gets or sets the item code. When segmented, the full item code is returned; however, when setting the code, be sure to only set the item's short code. (Overrides AccountBase..::..Code.)
Public property | CostingMethod | Gets the unit cost according to chosen costing method set in inventory preferences.
Public property | DefaultCreditNoteTaxType | Gets or sets the stock item's default credit note tax type.
Public property | DefaultGoodsReceivedTaxType | Gets or sets the stock item's default tax type for goods received notes.
Public property | DefaultInvoicingTaxType | Gets or sets the stock item's default invoicing tax type.
Public property | DefaultPurchaseUnit |
Public property | DefaultPurchaseUnitID |
Public property | DefaultReturnToSupplierTaxType | Gets or sets the stock item's default tax type used on returns to supplier .
Public property | DefaultSellingPrice | Gets the stock item's default exclusive selling price (belonging to the default price list).
Public property | DefaultSellingUnit |
Public property | DefaultSellingUnitID |
Public property | Description | Gets or sets the stock item's description. (Overrides AccountBase..::..Description.)
Public property | Description_2 | Gets or sets the stock item's 2nd description.
Public property | Description_3 | Gets or sets the stock item's 3rd description.
Public property | Group | Gets or sets the stock item's group.
Public property | HighestUnitCost | Gets the stock item's highest unit cost.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | InitialLotStatus |
Public property | InitialLotStatusID |
Public property | IsCommissionable | Gets or sets whether or not the stock item is commissionable.
Public property | IsLotTracked | Gets or sets whether or not the stock item is tracked in lots.
Public property | IsSegmented | Whether or not the item is made up of segments.
Public property | IsSerialTracked | Gets or sets whether or not the stock item is tracked by serial numbers.
Public property | IsServiceItem | Gets or sets whether or not the item is a service item.
Public property | IsStrictSerialTracked | Gets or sets whether or not the stock item is serial-tracked using the "strict" method.
Public property | IsWarehouseTracked | Gets or sets whether or not the item is tracked in warehouses.
Public property | Item |
Public property | LatestUnitCost | Gets the stock item's latest unit cost.
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | LowestUnitCost | Gets the stock item's lowest unit cost.
Public property | MininumGPPercentage |
Public property | Module | Gets the stock item's Evolution module. (Overrides AccountBase..::..Module.)
Public property | PackCode | Gets or sets the stock item's pack code.
Public property | QtyFree | Gets the stock item's free quantity.
Public property | QtyOnHand | Gets the stock item's quantity on hand.
Public property | QtyOnPurchaseOrder | Gets the stock item's quantity on purchase order.
Public property | QtyOnSalesOrder | Gets the stock item's quantity on sales order.
Public property | QtyReserved | Gets the stock item's reserved quantity.
Public property | QtyWIP | Gets the quantity of stock on active jobs (work in progress).
Public property | RawFieldData | Obsolete.
Public property | Segments | Gets the stock item's segment collection.
Public property | SellingPrice1 | Gets or sets the exclusive selling price belonging to the "first" price list in the system (default: "Price List 1").
Public property | SellingPrice2 | Gets or sets the exclusive selling price belonging to the "second" price list in the system (default: "Price List 2").
Public property | SellingPrice3 | Gets or sets the exclusive selling price belonging to the "third" price list in the system (default: "Price List 3").
Public property | SellingPrices | Gets the stock item's selling price collection.
Public property | ShortCode | Gets the stock item's short code.
Public property | StandardUnitCost | Gets the stock item's standard unit cost.
Public property | StockingUnit |
Public property | UnitCost | Gets the unit cost according to chosen costing method set in inventory preferences.
Public property | UserFields |
Public property | WarehouseContexts | Gets the stock item's warehouse context collection.

See Also

InventoryItem Class


InventoryItem._LotsExpire Property

[image]

Pastel Evolution SDK
InventoryItem..::.._LotsExpire Property
InventoryItem Class See Also Send Feedback
Gets or sets whether or not the stock item is tracked in lots.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool _LotsExpire { get; set; }
Visual Basic
Public Property _LotsExpire As Boolean
    Get
    Set

Property Value

Type: Boolean

Exceptions

Exception | Condition
Pastel.Evolution..::..EvolutionException | An existing item's lot tracking status may not be altered.

See Also

InventoryItem Class
InventoryItem Members


InventoryItem.Active Property

[image]

Pastel Evolution SDK
InventoryItem..::..Active Property
InventoryItem Class See Also Send Feedback
Gets or sets the record's operational state. Inactive items cannot be used in further transactions.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override bool Active { get; set; }
Visual Basic
Public Overrides Property Active As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

InventoryItem Class
InventoryItem Members


InventoryItem.AllowDuplicateSerialNumber Property

[image]

Pastel Evolution SDK
InventoryItem..::..AllowDuplicateSerialNumber Property
InventoryItem Class See Also Send Feedback
Gets or sets whether the serial number item allows for duplicate serial numbers.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool AllowDuplicateSerialNumber { get; set; }
Visual Basic
Public Property AllowDuplicateSerialNumber As Boolean
    Get
    Set

Property Value

Type: Boolean

Remarks

Item needs to be set as a non-strict serial number item to allow for duplicate serial numbers.

Exceptions

Exception | Condition
Pastel.Evolution..::..EvolutionException | An existing item's serial tracking status may not be altered.

See Also

InventoryItem Class
InventoryItem Members
Pastel.Evolution Namespace
InventoryItem..::..IsStrictSerialTracked


InventoryItem.AllowNegativeStock Property

[image]

Pastel Evolution SDK
InventoryItem..::..AllowNegativeStock Property
InventoryItem Class See Also Send Feedback
Whether or not the item allows for negative stock.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool AllowNegativeStock { get; }
Visual Basic
Public ReadOnly Property AllowNegativeStock As Boolean
    Get

Property Value

Type: Boolean

See Also

InventoryItem Class
InventoryItem Members
Pastel.Evolution Namespace
InventoryItem..::..Segments


InventoryItem.AverageUnitCost Property

[image]

Pastel Evolution SDK
InventoryItem..::..AverageUnitCost Property
InventoryItem Class See Also Send Feedback
Gets the stock item's average unit cost.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double AverageUnitCost { get; internal set; }
Visual Basic
Public Property AverageUnitCost As Double
    Get
    Friend Set

Property Value

Type: Double

See Also

InventoryItem Class
InventoryItem Members


InventoryItem.BarCode Property

[image]

Pastel Evolution SDK
InventoryItem..::..BarCode Property
InventoryItem Class See Also Send Feedback
Gets or sets the stock item's bar code.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string BarCode { get; set; }
Visual Basic
Public Property BarCode As String
    Get
    Set

Property Value

Type: String

See Also

InventoryItem Class
InventoryItem Members


InventoryItem.BinCode Property

[image]

Pastel Evolution SDK
InventoryItem..::..BinCode Property
InventoryItem Class See Also Send Feedback
Gets or sets the stock item's bin.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public InventoryBin BinCode { get; set; }
Visual Basic
Public Property BinCode As InventoryBin
    Get
    Set

Property Value

Type: InventoryBin

See Also

InventoryItem Class
InventoryItem Members


InventoryItem.Code Property

[image]

Pastel Evolution SDK
InventoryItem..::..Code Property
InventoryItem Class See Also Send Feedback
Gets or sets the item code. When segmented, the full item code is returned; however, when setting the code, be sure to only set the item's short code.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override string Code { get; set; }
Visual Basic
Public Overrides Property Code As String
    Get
    Set

Property Value

Type: String

See Also

InventoryItem Class
InventoryItem Members


InventoryItem.CostingMethod Property

[image]

Pastel Evolution SDK
InventoryItem..::..CostingMethod Property
InventoryItem Class See Also Send Feedback
Gets the unit cost according to chosen costing method set in inventory preferences.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public InventoryCostingMethod CostingMethod { get; set; }
Visual Basic
Public Property CostingMethod As InventoryCostingMethod
    Get
    Set

Property Value

Type: InventoryCostingMethod

See Also

InventoryItem Class
InventoryItem Members


InventoryItem.DefaultCreditNoteTaxType Property

[image]

Pastel Evolution SDK
InventoryItem..::..DefaultCreditNoteTaxType Property
InventoryItem Class See Also Send Feedback
Gets or sets the stock item's default credit note tax type.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public TaxRate DefaultCreditNoteTaxType { get; set; }
Visual Basic
Public Property DefaultCreditNoteTaxType As TaxRate
    Get
    Set

Property Value

Type: TaxRate

Remarks

If not supplied, a default tax rate will be set on saving.

See Also

InventoryItem Class
InventoryItem Members


InventoryItem.DefaultGoodsReceivedTaxType Property

[image]

Pastel Evolution SDK
InventoryItem..::..DefaultGoodsReceivedTaxType Property
InventoryItem Class See Also Send Feedback
Gets or sets the stock item's default tax type for goods received notes.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public TaxRate DefaultGoodsReceivedTaxType { get; set; }
Visual Basic
Public Property DefaultGoodsReceivedTaxType As TaxRate
    Get
    Set

Property Value

Type: TaxRate

Remarks

If not supplied, a default tax rate will be set on saving.

See Also

InventoryItem Class
InventoryItem Members


InventoryItem.DefaultInvoicingTaxType Property

[image]

Pastel Evolution SDK
InventoryItem..::..DefaultInvoicingTaxType Property
InventoryItem Class See Also Send Feedback
Gets or sets the stock item's default invoicing tax type.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public TaxRate DefaultInvoicingTaxType { get; set; }
Visual Basic
Public Property DefaultInvoicingTaxType As TaxRate
    Get
    Set

Property Value

Type: TaxRate

Remarks

If not supplied, a default tax rate will be set on saving.

See Also

InventoryItem Class
InventoryItem Members


InventoryItem.DefaultPurchaseUnit Property

[image]

Pastel Evolution SDK
InventoryItem..::..DefaultPurchaseUnit Property
InventoryItem Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Unit DefaultPurchaseUnit { get; set; }
Visual Basic
Public Property DefaultPurchaseUnit As Unit
    Get
    Set

Property Value

Type: Unit

See Also

InventoryItem Class
InventoryItem Members


InventoryItem.DefaultPurchaseUnitID Property

[image]

Pastel Evolution SDK
InventoryItem..::..DefaultPurchaseUnitID Property
InventoryItem Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int DefaultPurchaseUnitID { get; set; }
Visual Basic
Public Property DefaultPurchaseUnitID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

InventoryItem Class
InventoryItem Members


InventoryItem.DefaultReturnToSupplierTaxType Property

[image]

Pastel Evolution SDK
InventoryItem..::..DefaultReturnToSupplierTaxType Property
InventoryItem Class See Also Send Feedback
Gets or sets the stock item's default tax type used on returns to supplier .

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public TaxRate DefaultReturnToSupplierTaxType { get; set; }
Visual Basic
Public Property DefaultReturnToSupplierTaxType As TaxRate
    Get
    Set

Property Value

Type: TaxRate

Remarks

If not supplied, a default tax rate will be set on saving.

See Also

InventoryItem Class
InventoryItem Members


InventoryItem.DefaultSellingPrice Property

[image]

Pastel Evolution SDK
InventoryItem..::..DefaultSellingPrice Property
InventoryItem Class See Also Send Feedback
Gets the stock item's default exclusive selling price (belonging to the default price list).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double DefaultSellingPrice { get; }
Visual Basic
Public ReadOnly Property DefaultSellingPrice As Double
    Get

Property Value

Type: Double

See Also

InventoryItem Class
InventoryItem Members


InventoryItem.DefaultSellingUnit Property

[image]

Pastel Evolution SDK
InventoryItem..::..DefaultSellingUnit Property
InventoryItem Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Unit DefaultSellingUnit { get; set; }
Visual Basic
Public Property DefaultSellingUnit As Unit
    Get
    Set

Property Value

Type: Unit

See Also

InventoryItem Class
InventoryItem Members


InventoryItem.DefaultSellingUnitID Property

[image]

Pastel Evolution SDK
InventoryItem..::..DefaultSellingUnitID Property
InventoryItem Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int DefaultSellingUnitID { get; set; }
Visual Basic
Public Property DefaultSellingUnitID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

InventoryItem Class
InventoryItem Members


InventoryItem.Description Property

[image]

Pastel Evolution SDK
InventoryItem..::..Description Property
InventoryItem Class See Also Send Feedback
Gets or sets the stock item's description.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override string Description { get; set; }
Visual Basic
Public Overrides Property Description As String
    Get
    Set

Property Value

Type: String

See Also

InventoryItem Class
InventoryItem Members


InventoryItem.Description_2 Property

[image]

Pastel Evolution SDK
InventoryItem..::..Description_2 Property
InventoryItem Class See Also Send Feedback
Gets or sets the stock item's 2nd description.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Description_2 { get; set; }
Visual Basic
Public Property Description_2 As String
    Get
    Set

Property Value

Type: String

See Also

InventoryItem Class
InventoryItem Members


InventoryItem.Description_3 Property

[image]

Pastel Evolution SDK
InventoryItem..::..Description_3 Property
InventoryItem Class See Also Send Feedback
Gets or sets the stock item's 3rd description.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Description_3 { get; set; }
Visual Basic
Public Property Description_3 As String
    Get
    Set

Property Value

Type: String

See Also

InventoryItem Class
InventoryItem Members


InventoryItem.Group Property

[image]

Pastel Evolution SDK
InventoryItem..::..Group Property
InventoryItem Class See Also Send Feedback
Gets or sets the stock item's group.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public InventoryGroup Group { get; set; }
Visual Basic
Public Property Group As InventoryGroup
    Get
    Set

Property Value

Type: InventoryGroup

See Also

InventoryItem Class
InventoryItem Members


InventoryItem.HighestUnitCost Property

[image]

Pastel Evolution SDK
InventoryItem..::..HighestUnitCost Property
InventoryItem Class See Also Send Feedback
Gets the stock item's highest unit cost.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double HighestUnitCost { get; internal set; }
Visual Basic
Public Property HighestUnitCost As Double
    Get
    Friend Set

Property Value

Type: Double

See Also

InventoryItem Class
InventoryItem Members


InventoryItem.ID Property

[image]

Pastel Evolution SDK
InventoryItem..::..ID Property
InventoryItem Class See Also Send Feedback
Gets the internal record ID (0 for new, unsaved records).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

Remarks

Once saved, the ID will reflect the record's internal database identifier.

See Also

InventoryItem Class
InventoryItem Members


InventoryItem.InitialLotStatus Property

[image]

Pastel Evolution SDK
InventoryItem..::..InitialLotStatus Property
InventoryItem Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public LotStatus InitialLotStatus { get; set; }
Visual Basic
Public Property InitialLotStatus As LotStatus
    Get
    Set

Property Value

Type: LotStatus

See Also

InventoryItem Class
InventoryItem Members


InventoryItem.InitialLotStatusID Property

[image]

Pastel Evolution SDK
InventoryItem..::..InitialLotStatusID Property
InventoryItem Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int InitialLotStatusID { get; set; }
Visual Basic
Public Property InitialLotStatusID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

InventoryItem Class
InventoryItem Members


InventoryItem.IsCommissionable Property

[image]

Pastel Evolution SDK
InventoryItem..::..IsCommissionable Property
InventoryItem Class See Also Send Feedback
Gets or sets whether or not the stock item is commissionable.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool IsCommissionable { get; set; }
Visual Basic
Public Property IsCommissionable As Boolean
    Get
    Set

Property Value

Type: Boolean

Remarks

Commissionable items contribute sales & profit values to the sales representative report.

See Also

InventoryItem Class
InventoryItem Members


InventoryItem.IsLotTracked Property

[image]

Pastel Evolution SDK
InventoryItem..::..IsLotTracked Property
InventoryItem Class See Also Send Feedback
Gets or sets whether or not the stock item is tracked in lots.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool IsLotTracked { get; set; }
Visual Basic
Public Property IsLotTracked As Boolean
    Get
    Set

Property Value

Type: Boolean

Exceptions

Exception | Condition
Pastel.Evolution..::..EvolutionException | An existing item's lot tracking status may not be altered.

See Also

InventoryItem Class
InventoryItem Members


InventoryItem.IsSegmented Property

[image]

Pastel Evolution SDK
InventoryItem..::..IsSegmented Property
InventoryItem Class See Also Send Feedback
Whether or not the item is made up of segments.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool IsSegmented { get; }
Visual Basic
Public ReadOnly Property IsSegmented As Boolean
    Get

Property Value

Type: Boolean

See Also

InventoryItem Class
InventoryItem Members
Pastel.Evolution Namespace
InventoryItem..::..Segments


InventoryItem.IsSerialTracked Property

[image]

Pastel Evolution SDK
InventoryItem..::..IsSerialTracked Property
InventoryItem Class See Also Send Feedback
Gets or sets whether or not the stock item is tracked by serial numbers.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool IsSerialTracked { get; set; }
Visual Basic
Public Property IsSerialTracked As Boolean
    Get
    Set

Property Value

Type: Boolean

Remarks

When set true, IsStrictSerialTracked also defaults to true.

Exceptions

Exception | Condition
Pastel.Evolution..::..EvolutionException | An existing item's serial tracking status may not be altered.

See Also

InventoryItem Class
InventoryItem Members
Pastel.Evolution Namespace
InventoryItem..::..IsStrictSerialTracked


InventoryItem.IsServiceItem Property

[image]

Pastel Evolution SDK
InventoryItem..::..IsServiceItem Property
InventoryItem Class See Also Send Feedback
Gets or sets whether or not the item is a service item.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool IsServiceItem { get; set; }
Visual Basic
Public Property IsServiceItem As Boolean
    Get
    Set

Property Value

Type: Boolean

Remarks

Service items are sold or purchased without regard for a quantity on hand.

See Also

InventoryItem Class
InventoryItem Members


InventoryItem.IsStrictSerialTracked Property

[image]

Pastel Evolution SDK
InventoryItem..::..IsStrictSerialTracked Property
InventoryItem Class See Also Send Feedback
Gets or sets whether or not the stock item is serial-tracked using the "strict" method.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool IsStrictSerialTracked { get; set; }
Visual Basic
Public Property IsStrictSerialTracked As Boolean
    Get
    Set

Property Value

Type: Boolean

Remarks

Strict serial number tracking means that for every unit moved, a serial number must be supplied.

Exceptions

Exception | Condition
Pastel.Evolution..::..EvolutionException | An existing item's serial tracking configuration may not be altered.

See Also

InventoryItem Class
InventoryItem Members


InventoryItem.IsWarehouseTracked Property

[image]

Pastel Evolution SDK
InventoryItem..::..IsWarehouseTracked Property
InventoryItem Class See Also Send Feedback
Gets or sets whether or not the item is tracked in warehouses.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool IsWarehouseTracked { get; set; }
Visual Basic
Public Property IsWarehouseTracked As Boolean
    Get
    Set

Property Value

Type: Boolean

Remarks

If set true, and no warehouses are explicitly added to the WarehouseContexts collection, the item will get linked to the default warehouses.

Exceptions

Exception | Condition
Pastel.Evolution..::..EvolutionException | An existing item's warehouse status may not be altered.

See Also

InventoryItem Class
InventoryItem Members
Pastel.Evolution Namespace
Pastel.Evolution..::..WarehouseContext


InventoryItem.Item Property

[image]

Pastel Evolution SDK
InventoryItem..::..Item Property
InventoryItem Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public InventoryItem this[
    string code
] { get; }
Visual Basic
Public ReadOnly Default Property Item (
    code As String
) As InventoryItem
    Get

Parameters

code
Type: System..::..String

Property Value

Type: InventoryItem

See Also

InventoryItem Class
InventoryItem Members


InventoryItem.LatestUnitCost Property

[image]

Pastel Evolution SDK
InventoryItem..::..LatestUnitCost Property
InventoryItem Class See Also Send Feedback
Gets the stock item's latest unit cost.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double LatestUnitCost { get; internal set; }
Visual Basic
Public Property LatestUnitCost As Double
    Get
    Friend Set

Property Value

Type: Double

See Also

InventoryItem Class
InventoryItem Members


InventoryItem.LongID Property

[image]

Pastel Evolution SDK
InventoryItem..::..LongID Property
InventoryItem Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

InventoryItem Class
InventoryItem Members


InventoryItem.LowestUnitCost Property

[image]

Pastel Evolution SDK
InventoryItem..::..LowestUnitCost Property
InventoryItem Class See Also Send Feedback
Gets the stock item's lowest unit cost.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double LowestUnitCost { get; internal set; }
Visual Basic
Public Property LowestUnitCost As Double
    Get
    Friend Set

Property Value

Type: Double

See Also

InventoryItem Class
InventoryItem Members


InventoryItem.MininumGPPercentage Property

[image]

Pastel Evolution SDK
InventoryItem..::..MininumGPPercentage Property
InventoryItem Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double MininumGPPercentage { get; set; }
Visual Basic
Public Property MininumGPPercentage As Double
    Get
    Set

Property Value

Type: Double

See Also

InventoryItem Class
InventoryItem Members


InventoryItem.Module Property

[image]

Pastel Evolution SDK
InventoryItem..::..Module Property
InventoryItem Class See Also Send Feedback
Gets the stock item's Evolution module.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override Module Module { get; }
Visual Basic
Public Overrides ReadOnly Property Module As Module
    Get

Property Value

Type: Module

See Also

InventoryItem Class
InventoryItem Members


InventoryItem.PackCode Property

[image]

Pastel Evolution SDK
InventoryItem..::..PackCode Property
InventoryItem Class See Also Send Feedback
Gets or sets the stock item's pack code.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public PackCode PackCode { get; set; }
Visual Basic
Public Property PackCode As PackCode
    Get
    Set

Property Value

Type: PackCode

See Also

InventoryItem Class
InventoryItem Members


InventoryItem.QtyFree Property

[image]

Pastel Evolution SDK
InventoryItem..::..QtyFree Property
InventoryItem Class See Also Send Feedback
Gets the stock item's free quantity.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double QtyFree { get; }
Visual Basic
Public ReadOnly Property QtyFree As Double
    Get

Property Value

Type: Double

Remarks

Calculation: QtyOnHand - QtyReserved - QtyWIP

See Also

InventoryItem Class
InventoryItem Members
Pastel.Evolution Namespace
InventoryItem..::..QtyWIP
InventoryItem..::..QtyReserved


InventoryItem.QtyOnHand Property

[image]

Pastel Evolution SDK
InventoryItem..::..QtyOnHand Property
InventoryItem Class See Also Send Feedback
Gets the stock item's quantity on hand.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double QtyOnHand { get; }
Visual Basic
Public ReadOnly Property QtyOnHand As Double
    Get

Property Value

Type: Double

See Also

InventoryItem Class
InventoryItem Members


InventoryItem.QtyOnPurchaseOrder Property

[image]

Pastel Evolution SDK
InventoryItem..::..QtyOnPurchaseOrder Property
InventoryItem Class See Also Send Feedback
Gets the stock item's quantity on purchase order.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double QtyOnPurchaseOrder { get; }
Visual Basic
Public ReadOnly Property QtyOnPurchaseOrder As Double
    Get

Property Value

Type: Double

See Also

InventoryItem Class
InventoryItem Members


InventoryItem.QtyOnSalesOrder Property

[image]

Pastel Evolution SDK
InventoryItem..::..QtyOnSalesOrder Property
InventoryItem Class See Also Send Feedback
Gets the stock item's quantity on sales order.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double QtyOnSalesOrder { get; }
Visual Basic
Public ReadOnly Property QtyOnSalesOrder As Double
    Get

Property Value

Type: Double

See Also

InventoryItem Class
InventoryItem Members


InventoryItem.QtyReserved Property

[image]

Pastel Evolution SDK
InventoryItem..::..QtyReserved Property
InventoryItem Class See Also Send Feedback
Gets the stock item's reserved quantity.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double QtyReserved { get; }
Visual Basic
Public ReadOnly Property QtyReserved As Double
    Get

Property Value

Type: Double

See Also

InventoryItem Class
InventoryItem Members


InventoryItem.QtyWIP Property

[image]

Pastel Evolution SDK
InventoryItem..::..QtyWIP Property
InventoryItem Class See Also Send Feedback
Gets the quantity of stock on active jobs (work in progress).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double QtyWIP { get; internal set; }
Visual Basic
Public Property QtyWIP As Double
    Get
    Friend Set

Property Value

Type: Double

See Also

InventoryItem Class
InventoryItem Members


InventoryItem.RawFieldData Property

[image]

Pastel Evolution SDK
InventoryItem..::..RawFieldData Property
InventoryItem Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
[ObsoleteAttribute("Use UserFields instead.")]
public FieldCollection RawFieldData { get; }
Visual Basic
<ObsoleteAttribute("Use UserFields instead.")>
Public ReadOnly Property RawFieldData As FieldCollection
    Get

Property Value

Type: FieldCollection

See Also

InventoryItem Class
InventoryItem Members


InventoryItem.Segments Property

[image]

Pastel Evolution SDK
InventoryItem..::..Segments Property
InventoryItem Class See Also Send Feedback
Gets the stock item's segment collection.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public InventorySegmentCollection Segments { get; }
Visual Basic
Public ReadOnly Property Segments As InventorySegmentCollection
    Get

Property Value

Type: InventorySegmentCollection

See Also

InventoryItem Class
InventoryItem Members


InventoryItem.SellingPrice1 Property

[image]

Pastel Evolution SDK
InventoryItem..::..SellingPrice1 Property
InventoryItem Class See Also Send Feedback
Gets or sets the exclusive selling price belonging to the "first" price list in the system (default: "Price List 1").

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double SellingPrice1 { get; set; }
Visual Basic
Public Property SellingPrice1 As Double
    Get
    Set

Property Value

Type: Double

See Also

InventoryItem Class
InventoryItem Members


InventoryItem.SellingPrice2 Property

[image]

Pastel Evolution SDK
InventoryItem..::..SellingPrice2 Property
InventoryItem Class See Also Send Feedback
Gets or sets the exclusive selling price belonging to the "second" price list in the system (default: "Price List 2").

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double SellingPrice2 { get; set; }
Visual Basic
Public Property SellingPrice2 As Double
    Get
    Set

Property Value

Type: Double

See Also

InventoryItem Class
InventoryItem Members


InventoryItem.SellingPrice3 Property

[image]

Pastel Evolution SDK
InventoryItem..::..SellingPrice3 Property
InventoryItem Class See Also Send Feedback
Gets or sets the exclusive selling price belonging to the "third" price list in the system (default: "Price List 3").

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double SellingPrice3 { get; set; }
Visual Basic
Public Property SellingPrice3 As Double
    Get
    Set

Property Value

Type: Double

See Also

InventoryItem Class
InventoryItem Members


InventoryItem.SellingPrices Property

[image]

Pastel Evolution SDK
InventoryItem..::..SellingPrices Property
InventoryItem Class See Also Send Feedback
Gets the stock item's selling price collection.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public SellingPriceCollection SellingPrices { get; }
Visual Basic
Public ReadOnly Property SellingPrices As SellingPriceCollection
    Get

Property Value

Type: SellingPriceCollection

See Also

InventoryItem Class
InventoryItem Members


InventoryItem.ShortCode Property

[image]

Pastel Evolution SDK
InventoryItem..::..ShortCode Property
InventoryItem Class See Also Send Feedback
Gets the stock item's short code.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string ShortCode { get; }
Visual Basic
Public ReadOnly Property ShortCode As String
    Get

Property Value

Type: String

Remarks

When segmented, this value will represent the item code without any segmented suffices.

See Also

InventoryItem Class
InventoryItem Members


InventoryItem.StandardUnitCost Property

[image]

Pastel Evolution SDK
InventoryItem..::..StandardUnitCost Property
InventoryItem Class See Also Send Feedback
Gets the stock item's standard unit cost.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double StandardUnitCost { get; internal set; }
Visual Basic
Public Property StandardUnitCost As Double
    Get
    Friend Set

Property Value

Type: Double

See Also

InventoryItem Class
InventoryItem Members


InventoryItem.StockingUnit Property

[image]

Pastel Evolution SDK
InventoryItem..::..StockingUnit Property
InventoryItem Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Unit StockingUnit { get; set; }
Visual Basic
Public Property StockingUnit As Unit
    Get
    Set

Property Value

Type: Unit

See Also

InventoryItem Class
InventoryItem Members


InventoryItem.UnitCost Property

[image]

Pastel Evolution SDK
InventoryItem..::..UnitCost Property
InventoryItem Class See Also Send Feedback
Gets the unit cost according to chosen costing method set in inventory preferences.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double UnitCost { get; internal set; }
Visual Basic
Public Property UnitCost As Double
    Get
    Friend Set

Property Value

Type: Double

See Also

InventoryItem Class
InventoryItem Members
Pastel.Evolution Namespace
InventoryItem..::..AverageUnitCost
InventoryItem..::..LatestUnitCost


InventoryItem.UserFields Property

[image]

Pastel Evolution SDK
InventoryItem..::..UserFields Property
InventoryItem Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public FieldCollection UserFields { get; }
Visual Basic
Public ReadOnly Property UserFields As FieldCollection
    Get

Property Value

Type: FieldCollection

See Also

InventoryItem Class
InventoryItem Members


InventoryItem.WarehouseContexts Property

[image]

Pastel Evolution SDK
InventoryItem..::..WarehouseContexts Property
InventoryItem Class See Also Send Feedback
Gets the stock item's warehouse context collection.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public WarehouseContextCollection WarehouseContexts { get; }
Visual Basic
Public ReadOnly Property WarehouseContexts As WarehouseContextCollection
    Get

Property Value

Type: WarehouseContextCollection

Remarks

Items are selectively linked to one or more warehouses. These links form a context of stock holding in the sense that each warehouse contains a certain quantity of stock and more or more customised attributes. When moving stock, a warehouse context needs to be supplied.

See Also

InventoryItem Class
InventoryItem Members


InventoryOperation Enumeration

[image]

Pastel Evolution SDK
InventoryOperation Enumeration
See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public enum InventoryOperation
Visual Basic
Public Enumeration InventoryOperation

Members

Member name | Value | Description
Decrease | 0 |
Increase | 1 |
CostAdjustment | 2 |

See Also

Pastel.Evolution Namespace


InventorySegmentCollection Class

[image]

Pastel Evolution SDK
InventorySegmentCollection Class
Members See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class InventorySegmentCollection : IEnumerable
Visual Basic
Public Class InventorySegmentCollection
    Implements IEnumerable

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..InventorySegmentCollection

See Also

InventorySegmentCollection Members


InventorySegmentCollection Members

[image] [image]

Pastel Evolution SDK
InventorySegmentCollection Members
InventorySegmentCollection Class Methods Fields Properties See Also Send Feedback

The InventorySegmentCollection type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | InnerList |

Properties

 | Name | Description
Public property | Item[([( Int32])]) | Gets a selling price in the item's price collection.
Public property | Item[([( String])]) |
Public property | Item[([( InventorySegmentType])]) |

See Also

InventorySegmentCollection Class


InventorySegmentCollection Fields

[image] [image]

Pastel Evolution SDK
InventorySegmentCollection Fields
InventorySegmentCollection Class See Also Send Feedback

The InventorySegmentCollection type exposes the following members.

Fields

 | Name | Description
Protected field | InnerList |

See Also

InventorySegmentCollection Class


InventorySegmentCollection.InnerList Field

[image]

Pastel Evolution SDK
InventorySegmentCollection..::..InnerList Field
InventorySegmentCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected ArrayList InnerList
Visual Basic
Protected InnerList As ArrayList

Field Value

Type: ArrayList

See Also

InventorySegmentCollection Class
InventorySegmentCollection Members


InventorySegmentCollection Methods

[image] [image]

Pastel Evolution SDK
InventorySegmentCollection Methods
InventorySegmentCollection Class See Also Send Feedback

The InventorySegmentCollection type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InventorySegmentCollection Class


InventorySegmentCollection.GetEnumerator Method

[image]

Pastel Evolution SDK
InventorySegmentCollection..::..GetEnumerator Method
InventorySegmentCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public IEnumerator GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

InventorySegmentCollection Class
InventorySegmentCollection Members


InventorySegmentCollection Properties

[image] [image]

Pastel Evolution SDK
InventorySegmentCollection Properties
InventorySegmentCollection Class See Also Send Feedback

Properties

 | Name | Description
Public property | Item[([( Int32])]) | Gets a selling price in the item's price collection.
Public property | Item[([( String])]) |
Public property | Item[([( InventorySegmentType])]) |

See Also

InventorySegmentCollection Class


InventorySegmentCollection.Item Property

[image] [image]

Pastel Evolution SDK
InventorySegmentCollection..::..Item Property
InventorySegmentCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public property | Item[([( Int32])]) | Gets a selling price in the item's price collection.
Public property | Item[([( String])]) |
Public property | Item[([( InventorySegmentType])]) |

See Also

InventorySegmentCollection Class
InventorySegmentCollection Members


InventorySegmentCollection.Item Property (Int32)

[image]

Pastel Evolution SDK
InventorySegmentCollection..::..Item Property (Int32)
InventorySegmentCollection Class See Also Send Feedback
Gets a selling price in the item's price collection.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public InventorySegmentValue this[
    int index
] { get; }
Visual Basic
Public ReadOnly Default Property Item (
    index As Integer
) As InventorySegmentValue
    Get

Parameters

index
Type: System..::..Int32
The 0-based item index. When loading an item, the prices will be in sequence according to the Price List IDs, but when populating prices, the sequence will be logical and not numeric.

Return Value

Type: InventorySegmentValue

See Also

InventorySegmentCollection Class
InventorySegmentCollection Members
Item Overload


InventorySegmentCollection.Item Property (String)

[image]

Pastel Evolution SDK
InventorySegmentCollection..::..Item Property (String)
InventorySegmentCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public InventorySegmentValue this[
    string segmentTypeDescription
] { get; set; }
Visual Basic
Public Default Property Item (
    segmentTypeDescription As String
) As InventorySegmentValue
    Get
    Set

Parameters

segmentTypeDescription
Type: System..::..String

Property Value

Type: InventorySegmentValue

See Also

InventorySegmentCollection Class
InventorySegmentCollection Members
Item Overload


InventorySegmentCollection.Item Property (InventorySegmentType)

[image]

Pastel Evolution SDK
InventorySegmentCollection..::..Item Property (InventorySegmentType)
InventorySegmentCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public InventorySegmentValue this[
    InventorySegmentType segType
] { get; set; }
Visual Basic
Public Default Property Item (
    segType As InventorySegmentType
) As InventorySegmentValue
    Get
    Set

Parameters

segType
Type: Pastel.Evolution..::..InventorySegmentType

Property Value

Type: InventorySegmentValue

See Also

InventorySegmentCollection Class
InventorySegmentCollection Members
Item Overload


InventorySegmentGroup Class

[image]

Pastel Evolution SDK
InventorySegmentGroup Class
Members See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class InventorySegmentGroup
Visual Basic
Public Class InventorySegmentGroup

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..InventorySegmentGroup

See Also

InventorySegmentGroup Members


InventorySegmentGroup Members

[image] [image]

Pastel Evolution SDK
InventorySegmentGroup Members
InventorySegmentGroup Class Methods Properties See Also Send Feedback

The InventorySegmentGroup type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ID | Gets the internal record ID (0 for new, unsaved records).
Public property | SegmentType | Gets the segment group's segment type.

See Also

InventorySegmentGroup Class


InventorySegmentGroup Methods

[image] [image]

Pastel Evolution SDK
InventorySegmentGroup Methods
InventorySegmentGroup Class See Also Send Feedback

The InventorySegmentGroup type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InventorySegmentGroup Class


InventorySegmentGroup.List Method

[image]

Pastel Evolution SDK
InventorySegmentGroup..::..List Method
InventorySegmentGroup Class See Also Send Feedback
Gets a list of database records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria
)
Visual Basic
Public Shared Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.

Return Value

Type: DataTable
Table containing selected records.

See Also

InventorySegmentGroup Class
InventorySegmentGroup Members


InventorySegmentGroup Properties

[image] [image]

Pastel Evolution SDK
InventorySegmentGroup Properties
InventorySegmentGroup Class See Also Send Feedback

The InventorySegmentGroup type exposes the following members.

Properties

 | Name | Description
Public property | ID | Gets the internal record ID (0 for new, unsaved records).
Public property | SegmentType | Gets the segment group's segment type.

See Also

InventorySegmentGroup Class


InventorySegmentGroup.ID Property

[image]

Pastel Evolution SDK
InventorySegmentGroup..::..ID Property
InventorySegmentGroup Class See Also Send Feedback
Gets the internal record ID (0 for new, unsaved records).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int ID { get; }
Visual Basic
Public ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

Remarks

Once saved, the ID will reflect the record's internal database identifier.

See Also

InventorySegmentGroup Class
InventorySegmentGroup Members


InventorySegmentGroup.SegmentType Property

[image]

Pastel Evolution SDK
InventorySegmentGroup..::..SegmentType Property
InventorySegmentGroup Class See Also Send Feedback
Gets the segment group's segment type.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public InventorySegmentType SegmentType { get; }
Visual Basic
Public ReadOnly Property SegmentType As InventorySegmentType
    Get

Property Value

Type: InventorySegmentType

See Also

InventorySegmentGroup Class
InventorySegmentGroup Members


InventorySegmentType Class

[image]

Pastel Evolution SDK
InventorySegmentType Class
Members See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class InventorySegmentType
Visual Basic
Public Class InventorySegmentType

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..InventorySegmentType

See Also

InventorySegmentType Members


InventorySegmentType Members

[image] [image]

Pastel Evolution SDK
InventorySegmentType Members
InventorySegmentType Class Methods Properties See Also Send Feedback

The InventorySegmentType type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds a record's database ID.
 | FindByDescription |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Description | Gets the segment type's description.
Public property | ID | Gets the internal record ID (0 for new, unsaved records).

See Also

InventorySegmentType Class


InventorySegmentType Methods

[image] [image]

Pastel Evolution SDK
InventorySegmentType Methods
InventorySegmentType Class See Also Send Feedback

The InventorySegmentType type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds a record's database ID.
 | FindByDescription |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InventorySegmentType Class


InventorySegmentType.Find Method

[image]

Pastel Evolution SDK
InventorySegmentType..::..Find Method
InventorySegmentType Class See Also Send Feedback
Finds a record's database ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.

Return Value

Type: Int32
The ID of the first record found; -1 if not record was found.

See Also

InventorySegmentType Class
InventorySegmentType Members


InventorySegmentType.FindByDescription Method

[image]

Pastel Evolution SDK
InventorySegmentType..::..FindByDescription Method
InventorySegmentType Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int FindByDescription(
    string description
)
Visual Basic
Public Shared Function FindByDescription (
    description As String
) As Integer

Parameters

description
Type: System..::..String

Return Value

Type: Int32

See Also

InventorySegmentType Class
InventorySegmentType Members


InventorySegmentType.List Method

[image]

Pastel Evolution SDK
InventorySegmentType..::..List Method
InventorySegmentType Class See Also Send Feedback
Gets a list of database records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria
)
Visual Basic
Public Shared Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.

Return Value

Type: DataTable
Table containing selected records.

See Also

InventorySegmentType Class
InventorySegmentType Members


InventorySegmentType Properties

[image] [image]

Pastel Evolution SDK
InventorySegmentType Properties
InventorySegmentType Class See Also Send Feedback

The InventorySegmentType type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gets the segment type's description.
Public property | ID | Gets the internal record ID (0 for new, unsaved records).

See Also

InventorySegmentType Class


InventorySegmentType.Description Property

[image]

Pastel Evolution SDK
InventorySegmentType..::..Description Property
InventorySegmentType Class See Also Send Feedback
Gets the segment type's description.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Description { get; }
Visual Basic
Public ReadOnly Property Description As String
    Get

Property Value

Type: String

See Also

InventorySegmentType Class
InventorySegmentType Members


InventorySegmentType.ID Property

[image]

Pastel Evolution SDK
InventorySegmentType..::..ID Property
InventorySegmentType Class See Also Send Feedback
Gets the internal record ID (0 for new, unsaved records).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int ID { get; }
Visual Basic
Public ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

Remarks

Once saved, the ID will reflect the record's internal database identifier.

See Also

InventorySegmentType Class
InventorySegmentType Members


InventorySegmentValue Class

[image]

Pastel Evolution SDK
InventorySegmentValue Class
Members See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class InventorySegmentValue
Visual Basic
Public Class InventorySegmentValue

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..InventorySegmentValue

See Also

InventorySegmentValue Members


InventorySegmentValue Members

[image] [image]

Pastel Evolution SDK
InventorySegmentValue Members
InventorySegmentValue Class Constructors Methods Properties See Also Send Feedback

The InventorySegmentValue type exposes the following members.

Constructors

 | Name | Description
Public method | InventorySegmentValue(String, String) | Initializes a new instance of the InventorySegmentValue class
Public method | InventorySegmentValue(InventorySegmentType, String) | Initializes a new instance of the InventorySegmentValue class
Public method | InventorySegmentValue(String, InventorySegmentGroup, String) | Initializes a new instance of the InventorySegmentValue class
Public method | InventorySegmentValue(InventorySegmentType, InventorySegmentGroup, String) | Initializes a new instance of the InventorySegmentValue class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds a customer account ID.
 | FindByCode | Attempts to find an AR account by its account code and returns its ID.
 | Get | Returns the [first] customer object with the account code specified; otherwise, returns null.
 | GetByCode(String, String) |
 | GetByCode(InventorySegmentType, String) | Returns a customer object corresponding to the code specified; otherwise, returns null.
 | GetByCode(String, InventorySegmentGroup, String) |
 | GetByCode(InventorySegmentType, InventorySegmentGroup, String) |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List |
 | ListBySegmentGroupID |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Description |
Public property | ID |
Public property | SegmentGroup |
Public property | Value |

See Also

InventorySegmentValue Class


InventorySegmentValue Constructor

[image] [image]

Pastel Evolution SDK
InventorySegmentValue Constructor
InventorySegmentValue Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InventorySegmentValue(String, String) | Initializes a new instance of the InventorySegmentValue class
Public method | InventorySegmentValue(InventorySegmentType, String) | Initializes a new instance of the InventorySegmentValue class
Public method | InventorySegmentValue(String, InventorySegmentGroup, String) | Initializes a new instance of the InventorySegmentValue class
Public method | InventorySegmentValue(InventorySegmentType, InventorySegmentGroup, String) | Initializes a new instance of the InventorySegmentValue class

See Also

InventorySegmentValue Class
InventorySegmentValue Members


InventorySegmentValue Constructor (String, String)

[image]

Pastel Evolution SDK
InventorySegmentValue Constructor (String, String)
InventorySegmentValue Class See Also Send Feedback
Initializes a new instance of the InventorySegmentValue class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public InventorySegmentValue(
    string segmentType,
    string value
)
Visual Basic
Public Sub New (
    segmentType As String,
    value As String
)

Parameters

segmentType
Type: System..::..String
value
Type: System..::..String

See Also

InventorySegmentValue Class
InventorySegmentValue Members
InventorySegmentValue Overload


InventorySegmentValue Constructor (InventorySegmentType, String)

[image]

Pastel Evolution SDK
InventorySegmentValue Constructor (InventorySegmentType, String)
InventorySegmentValue Class See Also Send Feedback
Initializes a new instance of the InventorySegmentValue class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public InventorySegmentValue(
    InventorySegmentType type,
    string value
)
Visual Basic
Public Sub New (
    type As InventorySegmentType,
    value As String
)

Parameters

type
Type: Pastel.Evolution..::..InventorySegmentType
value
Type: System..::..String

See Also

InventorySegmentValue Class
InventorySegmentValue Members
InventorySegmentValue Overload


InventorySegmentValue Constructor (String, InventorySegmentGroup, String)

[image]

Pastel Evolution SDK
InventorySegmentValue Constructor (String, InventorySegmentGroup, String)
InventorySegmentValue Class See Also Send Feedback
Initializes a new instance of the InventorySegmentValue class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public InventorySegmentValue(
    string segmentType,
    InventorySegmentGroup group,
    string value
)
Visual Basic
Public Sub New (
    segmentType As String,
    group As InventorySegmentGroup,
    value As String
)

Parameters

segmentType
Type: System..::..String
group
Type: Pastel.Evolution..::..InventorySegmentGroup
value
Type: System..::..String

See Also

InventorySegmentValue Class
InventorySegmentValue Members
InventorySegmentValue Overload


InventorySegmentValue Constructor (InventorySegmentType, InventorySegmentGroup, String)

[image]

Pastel Evolution SDK
InventorySegmentValue Constructor (InventorySegmentType, InventorySegmentGroup, String)
InventorySegmentValue Class See Also Send Feedback
Initializes a new instance of the InventorySegmentValue class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public InventorySegmentValue(
    InventorySegmentType type,
    InventorySegmentGroup group,
    string value
)
Visual Basic
Public Sub New (
    type As InventorySegmentType,
    group As InventorySegmentGroup,
    value As String
)

Parameters

type
Type: Pastel.Evolution..::..InventorySegmentType
group
Type: Pastel.Evolution..::..InventorySegmentGroup
value
Type: System..::..String

See Also

InventorySegmentValue Class
InventorySegmentValue Members
InventorySegmentValue Overload


InventorySegmentValue Methods

[image] [image]

Pastel Evolution SDK
InventorySegmentValue Methods
InventorySegmentValue Class See Also Send Feedback

The InventorySegmentValue type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds a customer account ID.
 | FindByCode | Attempts to find an AR account by its account code and returns its ID.
 | Get | Returns the [first] customer object with the account code specified; otherwise, returns null.
 | GetByCode(String, String) |
 | GetByCode(InventorySegmentType, String) | Returns a customer object corresponding to the code specified; otherwise, returns null.
 | GetByCode(String, InventorySegmentGroup, String) |
 | GetByCode(InventorySegmentType, InventorySegmentGroup, String) |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List |
 | ListBySegmentGroupID |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InventorySegmentValue Class


InventorySegmentValue.Find Method

[image]

Pastel Evolution SDK
InventorySegmentValue..::..Find Method
InventorySegmentValue Class See Also Send Feedback
Finds a customer account ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String
The criteria passed to the SQL query. Eg. Account = 'CASH001' or Name like '%CASH%'

Return Value

Type: Int32

See Also

InventorySegmentValue Class
InventorySegmentValue Members


InventorySegmentValue.FindByCode Method

[image]

Pastel Evolution SDK
InventorySegmentValue..::..FindByCode Method
InventorySegmentValue Class See Also Send Feedback
Attempts to find an AR account by its account code and returns its ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int FindByCode(
    string code
)
Visual Basic
Public Shared Function FindByCode (
    code As String
) As Integer

Parameters

code
Type: System..::..String
The account code used to lookup the account.

Return Value

Type: Int32
-1 if no record was found, else the id of the first account matching the criteria supplied.

See Also

InventorySegmentValue Class
InventorySegmentValue Members
Pastel.Evolution Namespace
InventorySegmentValue..::..Find(String)


InventorySegmentValue.Get Method

[image]

Pastel Evolution SDK
InventorySegmentValue..::..Get Method
InventorySegmentValue Class See Also Send Feedback
Returns the [first] customer object with the account code specified; otherwise, returns null.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static InventorySegmentValue Get(
    string criteria
)
Visual Basic
Public Shared Function Get (
    criteria As String
) As InventorySegmentValue

Parameters

criteria
Type: System..::..String
Eg. Account = 'CASH001' or Name like '%CASH%'

Return Value

Type: InventorySegmentValue

See Also

InventorySegmentValue Class
InventorySegmentValue Members
Pastel.Evolution Namespace
InventorySegmentValue..::..Find(String)


InventorySegmentValue.GetByCode Method

[image] [image]

Pastel Evolution SDK
InventorySegmentValue..::..GetByCode Method
InventorySegmentValue Class See Also Send Feedback

Overload List

Name | Description
GetByCode(String, String) |
GetByCode(InventorySegmentType, String) | Returns a customer object corresponding to the code specified; otherwise, returns null.
GetByCode(String, InventorySegmentGroup, String) |
GetByCode(InventorySegmentType, InventorySegmentGroup, String) |

See Also

InventorySegmentValue Class
InventorySegmentValue Members


InventorySegmentValue.GetByCode Method (String, String)

[image]

Pastel Evolution SDK
InventorySegmentValue..::..GetByCode Method (String, String)
InventorySegmentValue Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static InventorySegmentValue GetByCode(
    string type,
    string code
)
Visual Basic
Public Shared Function GetByCode (
    type As String,
    code As String
) As InventorySegmentValue

Parameters

type
Type: System..::..String
code
Type: System..::..String

Return Value

Type: InventorySegmentValue

See Also

InventorySegmentValue Class
InventorySegmentValue Members
GetByCode Overload


InventorySegmentValue.GetByCode Method (InventorySegmentType, String)

[image]

Pastel Evolution SDK
InventorySegmentValue..::..GetByCode Method (InventorySegmentType, String)
InventorySegmentValue Class See Also Send Feedback
Returns a customer object corresponding to the code specified; otherwise, returns null.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static InventorySegmentValue GetByCode(
    InventorySegmentType type,
    string code
)
Visual Basic
Public Shared Function GetByCode (
    type As InventorySegmentType,
    code As String
) As InventorySegmentValue

Parameters

type
Type: Pastel.Evolution..::..InventorySegmentType
The segment type.
code
Type: System..::..String
The segment code.

Return Value

Type: InventorySegmentValue

See Also

InventorySegmentValue Class
InventorySegmentValue Members
GetByCode Overload


InventorySegmentValue.GetByCode Method (String, InventorySegmentGroup, String)

[image]

Pastel Evolution SDK
InventorySegmentValue..::..GetByCode Method (String, InventorySegmentGroup, String)
InventorySegmentValue Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static InventorySegmentValue GetByCode(
    string segmentType,
    InventorySegmentGroup group,
    string code
)
Visual Basic
Public Shared Function GetByCode (
    segmentType As String,
    group As InventorySegmentGroup,
    code As String
) As InventorySegmentValue

Parameters

segmentType
Type: System..::..String
group
Type: Pastel.Evolution..::..InventorySegmentGroup
code
Type: System..::..String

Return Value

Type: InventorySegmentValue

See Also

InventorySegmentValue Class
InventorySegmentValue Members
GetByCode Overload


InventorySegmentValue.GetByCode Method (InventorySegmentType, InventorySegmentGroup, String)

[image]

Pastel Evolution SDK
InventorySegmentValue..::..GetByCode Method (InventorySegmentType, InventorySegmentGroup, String)
InventorySegmentValue Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static InventorySegmentValue GetByCode(
    InventorySegmentType type,
    InventorySegmentGroup group,
    string code
)
Visual Basic
Public Shared Function GetByCode (
    type As InventorySegmentType,
    group As InventorySegmentGroup,
    code As String
) As InventorySegmentValue

Parameters

type
Type: Pastel.Evolution..::..InventorySegmentType
group
Type: Pastel.Evolution..::..InventorySegmentGroup
code
Type: System..::..String

Return Value

Type: InventorySegmentValue

See Also

InventorySegmentValue Class
InventorySegmentValue Members
GetByCode Overload


InventorySegmentValue.List Method

[image]

Pastel Evolution SDK
InventorySegmentValue..::..List Method
InventorySegmentValue Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria
)
Visual Basic
Public Shared Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String

Return Value

Type: DataTable

See Also

InventorySegmentValue Class
InventorySegmentValue Members


InventorySegmentValue.ListBySegmentGroupID Method

[image]

Pastel Evolution SDK
InventorySegmentValue..::..ListBySegmentGroupID Method
InventorySegmentValue Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable ListBySegmentGroupID(
    int id
)
Visual Basic
Public Shared Function ListBySegmentGroupID (
    id As Integer
) As DataTable

Parameters

id
Type: System..::..Int32

Return Value

Type: DataTable

See Also

InventorySegmentValue Class
InventorySegmentValue Members


InventorySegmentValue Properties

[image] [image]

Pastel Evolution SDK
InventorySegmentValue Properties
InventorySegmentValue Class See Also Send Feedback

The InventorySegmentValue type exposes the following members.

Properties

 | Name | Description
Public property | Description |
Public property | ID |
Public property | SegmentGroup |
Public property | Value |

See Also

InventorySegmentValue Class


InventorySegmentValue.Description Property

[image]

Pastel Evolution SDK
InventorySegmentValue..::..Description Property
InventorySegmentValue Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set

Property Value

Type: String

See Also

InventorySegmentValue Class
InventorySegmentValue Members


InventorySegmentValue.ID Property

[image]

Pastel Evolution SDK
InventorySegmentValue..::..ID Property
InventorySegmentValue Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int ID { get; }
Visual Basic
Public ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

See Also

InventorySegmentValue Class
InventorySegmentValue Members


InventorySegmentValue.SegmentGroup Property

[image]

Pastel Evolution SDK
InventorySegmentValue..::..SegmentGroup Property
InventorySegmentValue Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public InventorySegmentGroup SegmentGroup { get; }
Visual Basic
Public ReadOnly Property SegmentGroup As InventorySegmentGroup
    Get

Property Value

Type: InventorySegmentGroup

See Also

InventorySegmentValue Class
InventorySegmentValue Members


InventorySegmentValue.Value Property

[image]

Pastel Evolution SDK
InventorySegmentValue..::..Value Property
InventorySegmentValue Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Value { get; set; }
Visual Basic
Public Property Value As String
    Get
    Set

Property Value

Type: String

See Also

InventorySegmentValue Class
InventorySegmentValue Members


InventoryTransaction Class

[image]

Pastel Evolution SDK
InventoryTransaction Class
Members See Also Send Feedback
Represents an inventory transaction.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class InventoryTransaction : TransactionBase,
    ICloneable
Visual Basic
Public Class InventoryTransaction
    Inherits TransactionBase
    Implements ICloneable

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..TransactionBase
Pastel.Evolution..::..InventoryTransaction

See Also

InventoryTransaction Members


InventoryTransaction Members

[image] [image]

Pastel Evolution SDK
InventoryTransaction Members
InventoryTransaction Class Constructors Methods Fields Properties Events See Also Send Feedback

The InventoryTransaction type exposes the following members.

Constructors

 | Name | Description
Public method | InventoryTransaction | Creates a new instance of a transaction.

Methods

 | Name | Description
Protected method | beforePost |
Public method | Clone |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds a transaction ID.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List | Returns a System.Data.DataTable object containing the database records from the PostST table matching the supplied criteria.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAllowBlockedPosting | (Overrides TransactionBase..::..OnAllowBlockedPosting()()()().)
Protected method | OnPost | (Overrides TransactionBase..::..OnPost()()()().)
Protected method | onPostingGLCostVarianceCredit |
Protected method | onPostingGLCostVarianceDebit |
Protected method | onPostingGLCredit | (Inherited from TransactionBase.)
Protected method | onPostingGLDebit | (Inherited from TransactionBase.)
Protected method | onPostingGLVat | (Inherited from TransactionBase.)
Public method | Post | Posts the transaction to appropriate ledgers. (Inherited from TransactionBase.)
Protected method | RejectTransactionBranchAssignment | (Inherited from TransactionBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Validate | Validates the transaction. (Overrides TransactionBase..::..Validate()()()().)

Fields

 | Name | Description
Protected field | foreignOriginalTax | (Inherited from TransactionBase.)
Protected field | isDebitTrans | (Inherited from TransactionBase.)
Protected field | originalTax | (Inherited from TransactionBase.)
Protected field | readOnly | (Inherited from TransactionBase.)

Properties

 | Name | Description
Public property | Account | Gets or sets the transaction's account. (Overrides TransactionBase..::..Account.)
Public property | AccountID | Gets or sets the transaction's account id. (Overrides TransactionBase..::..AccountID.)
Public property | Audit | Gets the transaction's audit number. (Overrides TransactionBase..::..Audit.)
Public property | Branch | (Overrides TransactionBase..::..Branch.)
Public property | BranchID | (Overrides TransactionBase..::..BranchID.)
Public property | Credit | Gets the credit value posted by the transaction. (Overrides TransactionBase..::..Credit.)
Public property | CurrencyID | Gets or sets the account's currency id. 0 indicates local currency.
Public property | Date | Gets or sets the transaction date. (Overrides TransactionBase..::..Date.)
Public property | Debit | Gets the debit value posted by the transaction. (Overrides TransactionBase..::..Debit.)
Public property | Description | Gets or sets the transaction's description. (Overrides TransactionBase..::..Description.)
Public property | ExtOrderNo | Gets or sets the transaction's external order number. (Overrides TransactionBase..::..ExtOrderNo.)
Public property | ForeignTax |
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides TransactionBase..::..ID.)
Public property | InventoryItem | Gets or sets the transaction's stock item.
Public property | JobCard | Gets or sets the JobCard associated with this transaction.
Public property | JobCardID | Gets the JobCard ID.
Public property | Lot | Gets the transaction's assigned lot.
Public property | ModID | Gets or sets the transaction's module identifier. (Overrides TransactionBase..::..ModID.)
Public property | Module | Gets the transaction's Evolution module. (Overrides TransactionBase..::..Module.)
Public property | Operation | Gets or sets the transaction operation.
Public property | OrderNo | Gets or sets the transaction's order number. (Overrides TransactionBase..::..OrderNo.)
Public property | OverrideCreditAccount | Gets or sets the GL account to use when posting the transaction's credit leg, overriding the credit account configured in the transaction type.
Public property | OverrideDebitAccount | Gets or sets the GL account to use when posting the transaction's debit leg, overriding the debit account configured in the transaction type.
Public property | PostToGL | Enables or disables posting to the general ledger.
Public property | Project | Gets or sets the transaction's project. (Overrides TransactionBase..::..Project.)
Public property | ProjectID | Gets or sets the transaction's project id. (Overrides TransactionBase..::..ProjectID.)
Public property | Quantity | Gets or sets the transaction quantity.
Public property | Reference | Gets or sets the transaction's reference. (Overrides TransactionBase..::..Reference.)
Public property | Reference2 | Gets or sets the transaction's 2nd reference. (Overrides TransactionBase..::..Reference2.)
Public property | Representative | Gets or sets the sales representative
Public property | RepresentativeID | Gets or sets the sales representative ID.
Public property | SerialNumbers | Gets the transaction's serial number collection.
Public property | StockingUnitQuantity | Gets or sets the transaction quantity.
Public property | Tax | Gets or sets the transaction tax amount (automatically rounded to 2 decimals and always posted positive). (Overrides TransactionBase..::..Tax.)
Public property | TaxRate | Gets or sets the transaction's tax type. (Overrides TransactionBase..::..TaxRate.)
Public property | TaxRateID | Gets or sets the transaction's tax type id. (Overrides TransactionBase..::..TaxRateID.)
Public property | TransactionCode | Gets or sets the transaction code . (Overrides TransactionBase..::..TransactionCode.)
Public property | TransactionCodeID | Gets or sets the transaction code id. (Overrides TransactionBase..::..TransactionCodeID.)
Public property | Unit | Gets or sets the inventory unit om measure to use on this transaction. Note that this is not kept in the database, on recalling a transaction, this will always be null.
Public property | UnitCost | Gets or sets the transaction's unit cost.
Public property | UnitID |
Public property | Warehouse | Gets or sets the transaction's warehouse.
Public property | WarehouseContext |
Public property | WarehouseID | Gets or sets the transaction's warehouse id.

Events

 | Name | Description
Public event | BeforePost |
Public event | GLCostVarianceCreditPosting |
Public event | GLCostVarianceDebitPosting |
Public event | GLCreditPosting | (Inherited from TransactionBase.)
Public event | GLDebitPosting | (Inherited from TransactionBase.)
Public event | GLVatPosting | (Inherited from TransactionBase.)

See Also

InventoryTransaction Class


InventoryTransaction Constructor

[image]

Pastel Evolution SDK
InventoryTransaction Constructor
InventoryTransaction Class See Also Send Feedback
Creates a new instance of a transaction.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public InventoryTransaction()
Visual Basic
Public Sub New

See Also

InventoryTransaction Class
InventoryTransaction Members


InventoryTransaction Fields

[image] [image]

Pastel Evolution SDK
InventoryTransaction Fields
InventoryTransaction Class See Also Send Feedback

The InventoryTransaction type exposes the following members.

Fields

 | Name | Description
Protected field | foreignOriginalTax | (Inherited from TransactionBase.)
Protected field | isDebitTrans | (Inherited from TransactionBase.)
Protected field | originalTax | (Inherited from TransactionBase.)
Protected field | readOnly | (Inherited from TransactionBase.)

See Also

InventoryTransaction Class


InventoryTransaction Methods

[image] [image]

Pastel Evolution SDK
InventoryTransaction Methods
InventoryTransaction Class See Also Send Feedback

The InventoryTransaction type exposes the following members.

Methods

 | Name | Description
Protected method | beforePost |
Public method | Clone |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds a transaction ID.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List | Returns a System.Data.DataTable object containing the database records from the PostST table matching the supplied criteria.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAllowBlockedPosting | (Overrides TransactionBase..::..OnAllowBlockedPosting()()()().)
Protected method | OnPost | (Overrides TransactionBase..::..OnPost()()()().)
Protected method | onPostingGLCostVarianceCredit |
Protected method | onPostingGLCostVarianceDebit |
Protected method | onPostingGLCredit | (Inherited from TransactionBase.)
Protected method | onPostingGLDebit | (Inherited from TransactionBase.)
Protected method | onPostingGLVat | (Inherited from TransactionBase.)
Public method | Post | Posts the transaction to appropriate ledgers. (Inherited from TransactionBase.)
Protected method | RejectTransactionBranchAssignment | (Inherited from TransactionBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Validate | Validates the transaction. (Overrides TransactionBase..::..Validate()()()().)

See Also

InventoryTransaction Class


InventoryTransaction.beforePost Method

[image]

Pastel Evolution SDK
InventoryTransaction..::..beforePost Method
InventoryTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected void beforePost()
Visual Basic
Protected Sub beforePost

See Also

InventoryTransaction Class
InventoryTransaction Members


InventoryTransaction.Clone Method

[image]

Pastel Evolution SDK
InventoryTransaction..::..Clone Method
InventoryTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Object Clone()
Visual Basic
Public Function Clone As Object

Return Value

Type: Object

Implements

ICloneable..::..Clone()()()()

See Also

InventoryTransaction Class
InventoryTransaction Members


InventoryTransaction.Find Method

[image]

Pastel Evolution SDK
InventoryTransaction..::..Find Method
InventoryTransaction Class See Also Send Feedback
Finds a transaction ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static long Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Long

Parameters

criteria
Type: System..::..String
The criteria passed to the SQL query. Eg. Reference = 'INV001' or Description like '%Invoice%'

Return Value

Type: Int64

See Also

InventoryTransaction Class
InventoryTransaction Members


InventoryTransaction.List Method

[image]

Pastel Evolution SDK
InventoryTransaction..::..List Method
InventoryTransaction Class See Also Send Feedback
Returns a System.Data.DataTable object containing the database records from the PostST table matching the supplied criteria.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria
)
Visual Basic
Public Shared Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String
The SQL criteria used to locate the record, e.g. Reference like '1___' and Audit_No = 10.0005

Return Value

Type: DataTable
A System.Data.DataTable object containing matching records.

Remarks

The criteria is passed to an SQL query so use the appropriate syntax. Remember to includethe single quotes around string literals and append additional criteria with and.

See Also

InventoryTransaction Class
InventoryTransaction Members


InventoryTransaction.OnAllowBlockedPosting Method

[image]

Pastel Evolution SDK
InventoryTransaction..::..OnAllowBlockedPosting Method
InventoryTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override bool OnAllowBlockedPosting()
Visual Basic
Protected Friend Overrides Function OnAllowBlockedPosting As Boolean

Return Value

Type: Boolean

See Also

InventoryTransaction Class
InventoryTransaction Members


InventoryTransaction.OnPost Method

[image]

Pastel Evolution SDK
InventoryTransaction..::..OnPost Method
InventoryTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected override bool OnPost()
Visual Basic
Protected Overrides Function OnPost As Boolean

Return Value

Type: Boolean

See Also

InventoryTransaction Class
InventoryTransaction Members


InventoryTransaction.onPostingGLCostVarianceCredit Method

[image]

Pastel Evolution SDK
InventoryTransaction..::..onPostingGLCostVarianceCredit Method
InventoryTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected bool onPostingGLCostVarianceCredit(
    GLTransaction tran
)
Visual Basic
Protected Function onPostingGLCostVarianceCredit (
    tran As GLTransaction
) As Boolean

Parameters

tran
Type: Pastel.Evolution..::..GLTransaction

Return Value

Type: Boolean
Returns a value indicating whether the transaction has been handled already

See Also

InventoryTransaction Class
InventoryTransaction Members


InventoryTransaction.onPostingGLCostVarianceDebit Method

[image]

Pastel Evolution SDK
InventoryTransaction..::..onPostingGLCostVarianceDebit Method
InventoryTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected bool onPostingGLCostVarianceDebit(
    GLTransaction tran
)
Visual Basic
Protected Function onPostingGLCostVarianceDebit (
    tran As GLTransaction
) As Boolean

Parameters

tran
Type: Pastel.Evolution..::..GLTransaction

Return Value

Type: Boolean
Returns a value indicating whether the transaction has been handled already

See Also

InventoryTransaction Class
InventoryTransaction Members


InventoryTransaction.Validate Method

[image]

Pastel Evolution SDK
InventoryTransaction..::..Validate Method
InventoryTransaction Class See Also Send Feedback
Validates the transaction.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override bool Validate()
Visual Basic
Public Overrides Function Validate As Boolean

Return Value

Type: Boolean

See Also

InventoryTransaction Class
InventoryTransaction Members


InventoryTransaction Properties

[image] [image]

Pastel Evolution SDK
InventoryTransaction Properties
InventoryTransaction Class See Also Send Feedback

The InventoryTransaction type exposes the following members.

Properties

 | Name | Description
Public property | Account | Gets or sets the transaction's account. (Overrides TransactionBase..::..Account.)
Public property | AccountID | Gets or sets the transaction's account id. (Overrides TransactionBase..::..AccountID.)
Public property | Audit | Gets the transaction's audit number. (Overrides TransactionBase..::..Audit.)
Public property | Branch | (Overrides TransactionBase..::..Branch.)
Public property | BranchID | (Overrides TransactionBase..::..BranchID.)
Public property | Credit | Gets the credit value posted by the transaction. (Overrides TransactionBase..::..Credit.)
Public property | CurrencyID | Gets or sets the account's currency id. 0 indicates local currency.
Public property | Date | Gets or sets the transaction date. (Overrides TransactionBase..::..Date.)
Public property | Debit | Gets the debit value posted by the transaction. (Overrides TransactionBase..::..Debit.)
Public property | Description | Gets or sets the transaction's description. (Overrides TransactionBase..::..Description.)
Public property | ExtOrderNo | Gets or sets the transaction's external order number. (Overrides TransactionBase..::..ExtOrderNo.)
Public property | ForeignTax |
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides TransactionBase..::..ID.)
Public property | InventoryItem | Gets or sets the transaction's stock item.
Public property | JobCard | Gets or sets the JobCard associated with this transaction.
Public property | JobCardID | Gets the JobCard ID.
Public property | Lot | Gets the transaction's assigned lot.
Public property | ModID | Gets or sets the transaction's module identifier. (Overrides TransactionBase..::..ModID.)
Public property | Module | Gets the transaction's Evolution module. (Overrides TransactionBase..::..Module.)
Public property | Operation | Gets or sets the transaction operation.
Public property | OrderNo | Gets or sets the transaction's order number. (Overrides TransactionBase..::..OrderNo.)
Public property | OverrideCreditAccount | Gets or sets the GL account to use when posting the transaction's credit leg, overriding the credit account configured in the transaction type.
Public property | OverrideDebitAccount | Gets or sets the GL account to use when posting the transaction's debit leg, overriding the debit account configured in the transaction type.
Public property | PostToGL | Enables or disables posting to the general ledger.
Public property | Project | Gets or sets the transaction's project. (Overrides TransactionBase..::..Project.)
Public property | ProjectID | Gets or sets the transaction's project id. (Overrides TransactionBase..::..ProjectID.)
Public property | Quantity | Gets or sets the transaction quantity.
Public property | Reference | Gets or sets the transaction's reference. (Overrides TransactionBase..::..Reference.)
Public property | Reference2 | Gets or sets the transaction's 2nd reference. (Overrides TransactionBase..::..Reference2.)
Public property | Representative | Gets or sets the sales representative
Public property | RepresentativeID | Gets or sets the sales representative ID.
Public property | SerialNumbers | Gets the transaction's serial number collection.
Public property | StockingUnitQuantity | Gets or sets the transaction quantity.
Public property | Tax | Gets or sets the transaction tax amount (automatically rounded to 2 decimals and always posted positive). (Overrides TransactionBase..::..Tax.)
Public property | TaxRate | Gets or sets the transaction's tax type. (Overrides TransactionBase..::..TaxRate.)
Public property | TaxRateID | Gets or sets the transaction's tax type id. (Overrides TransactionBase..::..TaxRateID.)
Public property | TransactionCode | Gets or sets the transaction code . (Overrides TransactionBase..::..TransactionCode.)
Public property | TransactionCodeID | Gets or sets the transaction code id. (Overrides TransactionBase..::..TransactionCodeID.)
Public property | Unit | Gets or sets the inventory unit om measure to use on this transaction. Note that this is not kept in the database, on recalling a transaction, this will always be null.
Public property | UnitCost | Gets or sets the transaction's unit cost.
Public property | UnitID |
Public property | Warehouse | Gets or sets the transaction's warehouse.
Public property | WarehouseContext |
Public property | WarehouseID | Gets or sets the transaction's warehouse id.

See Also

InventoryTransaction Class


InventoryTransaction.Account Property

[image]

Pastel Evolution SDK
InventoryTransaction..::..Account Property
InventoryTransaction Class See Also Send Feedback
Gets or sets the transaction's account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override AccountBase Account { get; set; }
Visual Basic
Public Overrides Property Account As AccountBase
    Get
    Set

Property Value

Type: AccountBase

Remarks

The Account and InventoryItem properties may be used interchangeably.

See Also

InventoryTransaction Class
InventoryTransaction Members
Pastel.Evolution Namespace
InventoryTransaction..::..AccountID
InventoryTransaction..::..InventoryItem


InventoryTransaction.AccountID Property

[image]

Pastel Evolution SDK
InventoryTransaction..::..AccountID Property
InventoryTransaction Class See Also Send Feedback
Gets or sets the transaction's account id.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int AccountID { get; set; }
Visual Basic
Public Overrides Property AccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

InventoryTransaction Class
InventoryTransaction Members


InventoryTransaction.Audit Property

[image]

Pastel Evolution SDK
InventoryTransaction..::..Audit Property
InventoryTransaction Class See Also Send Feedback
Gets the transaction's audit number.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override string Audit { get; }
Visual Basic
Public Overrides ReadOnly Property Audit As String
    Get

Property Value

Type: String

Remarks

The audit number is 0 when unposted. After posting, it will reflect the transaction's posted audit number.

See Also

InventoryTransaction Class
InventoryTransaction Members


InventoryTransaction.Branch Property

[image]

Pastel Evolution SDK
InventoryTransaction..::..Branch Property
InventoryTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override Branch Branch { get; set; }
Visual Basic
Public Overrides Property Branch As Branch
    Get
    Set

Property Value

Type: Branch

Implements

IBranched..::..Branch

See Also

InventoryTransaction Class
InventoryTransaction Members


InventoryTransaction.BranchID Property

[image]

Pastel Evolution SDK
InventoryTransaction..::..BranchID Property
InventoryTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int BranchID { get; internal set; }
Visual Basic
Public Overrides Property BranchID As Integer
    Get
    Friend Set

Property Value

Type: Int32

Implements

IBranched..::..BranchID

See Also

InventoryTransaction Class
InventoryTransaction Members


InventoryTransaction.Credit Property

[image]

Pastel Evolution SDK
InventoryTransaction..::..Credit Property
InventoryTransaction Class See Also Send Feedback
Gets the credit value posted by the transaction.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override double Credit { get; set; }
Visual Basic
Public Overrides Property Credit As Double
    Get
    Set

Property Value

Type: Double

See Also

InventoryTransaction Class
InventoryTransaction Members


InventoryTransaction.CurrencyID Property

[image]

Pastel Evolution SDK
InventoryTransaction..::..CurrencyID Property
InventoryTransaction Class See Also Send Feedback
Gets or sets the account's currency id. 0 indicates local currency.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int CurrencyID { get; set; }
Visual Basic
Public Property CurrencyID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

InventoryTransaction Class
InventoryTransaction Members


InventoryTransaction.Date Property

[image]

Pastel Evolution SDK
InventoryTransaction..::..Date Property
InventoryTransaction Class See Also Send Feedback
Gets or sets the transaction date.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override DateTime Date { get; set; }
Visual Basic
Public Overrides Property Date As DateTime
    Get
    Set

Property Value

Type: DateTime

See Also

InventoryTransaction Class
InventoryTransaction Members


InventoryTransaction.Debit Property

[image]

Pastel Evolution SDK
InventoryTransaction..::..Debit Property
InventoryTransaction Class See Also Send Feedback
Gets the debit value posted by the transaction.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override double Debit { get; set; }
Visual Basic
Public Overrides Property Debit As Double
    Get
    Set

Property Value

Type: Double

See Also

InventoryTransaction Class
InventoryTransaction Members


InventoryTransaction.Description Property

[image]

Pastel Evolution SDK
InventoryTransaction..::..Description Property
InventoryTransaction Class See Also Send Feedback
Gets or sets the transaction's description.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override string Description { get; set; }
Visual Basic
Public Overrides Property Description As String
    Get
    Set

Property Value

Type: String

See Also

InventoryTransaction Class
InventoryTransaction Members


InventoryTransaction.ExtOrderNo Property

[image]

Pastel Evolution SDK
InventoryTransaction..::..ExtOrderNo Property
InventoryTransaction Class See Also Send Feedback
Gets or sets the transaction's external order number.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override string ExtOrderNo { get; set; }
Visual Basic
Public Overrides Property ExtOrderNo As String
    Get
    Set

Property Value

Type: String

See Also

InventoryTransaction Class
InventoryTransaction Members


InventoryTransaction.ForeignTax Property

[image]

Pastel Evolution SDK
InventoryTransaction..::..ForeignTax Property
InventoryTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double ForeignTax { get; set; }
Visual Basic
Public Property ForeignTax As Double
    Get
    Set

Property Value

Type: Double

See Also

InventoryTransaction Class
InventoryTransaction Members


InventoryTransaction.ID Property

[image]

Pastel Evolution SDK
InventoryTransaction..::..ID Property
InventoryTransaction Class See Also Send Feedback
Gets the internal record ID (0 for new, unsaved records).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Long
    Get

Property Value

Type: Int64

Remarks

Once saved, the ID will reflect the record's internal database identifier.

See Also

InventoryTransaction Class
InventoryTransaction Members


InventoryTransaction.InventoryItem Property

[image]

Pastel Evolution SDK
InventoryTransaction..::..InventoryItem Property
InventoryTransaction Class See Also Send Feedback
Gets or sets the transaction's stock item.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public InventoryItem InventoryItem { get; set; }
Visual Basic
Public Property InventoryItem As InventoryItem
    Get
    Set

Property Value

Type: InventoryItem

Remarks

The InventoryItem and Account properties may be used interchangeably.

See Also

InventoryTransaction Class
InventoryTransaction Members
Pastel.Evolution Namespace
InventoryTransaction..::..Account
InventoryTransaction..::..AccountID


InventoryTransaction.JobCard Property

[image]

Pastel Evolution SDK
InventoryTransaction..::..JobCard Property
InventoryTransaction Class See Also Send Feedback
Gets or sets the JobCard associated with this transaction.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public JobCard JobCard { get; internal set; }
Visual Basic
Public Property JobCard As JobCard
    Get
    Friend Set

Property Value

Type: JobCard

See Also

InventoryTransaction Class
InventoryTransaction Members


InventoryTransaction.JobCardID Property

[image]

Pastel Evolution SDK
InventoryTransaction..::..JobCardID Property
InventoryTransaction Class See Also Send Feedback
Gets the JobCard ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public long JobCardID { get; internal set; }
Visual Basic
Public Property JobCardID As Long
    Get
    Friend Set

Property Value

Type: Int64

See Also

InventoryTransaction Class
InventoryTransaction Members


InventoryTransaction.Lot Property

[image]

Pastel Evolution SDK
InventoryTransaction..::..Lot Property
InventoryTransaction Class See Also Send Feedback
Gets the transaction's assigned lot.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Lot Lot { get; set; }
Visual Basic
Public Property Lot As Lot
    Get
    Set

Property Value

Type: Lot

See Also

InventoryTransaction Class
InventoryTransaction Members
Pastel.Evolution Namespace
InventoryItem..::..IsLotTracked


InventoryTransaction.ModID Property

[image]

Pastel Evolution SDK
InventoryTransaction..::..ModID Property
InventoryTransaction Class See Also Send Feedback
Gets or sets the transaction's module identifier.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override ModuleID ModID { get; set; }
Visual Basic
Public Overrides Property ModID As ModuleID
    Get
    Set

Property Value

Type: ModuleID

Remarks

Used internally by Evolution to distinguish transaction origin.

See Also

InventoryTransaction Class
InventoryTransaction Members


InventoryTransaction.Module Property

[image]

Pastel Evolution SDK
InventoryTransaction..::..Module Property
InventoryTransaction Class See Also Send Feedback
Gets the transaction's Evolution module.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override Module Module { get; }
Visual Basic
Public Overrides ReadOnly Property Module As Module
    Get

Property Value

Type: Module

See Also

InventoryTransaction Class
InventoryTransaction Members


InventoryTransaction.Operation Property

[image]

Pastel Evolution SDK
InventoryTransaction..::..Operation Property
InventoryTransaction Class See Also Send Feedback
Gets or sets the transaction operation.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public InventoryOperation Operation { get; set; }
Visual Basic
Public Property Operation As InventoryOperation
    Get
    Set

Property Value

Type: InventoryOperation

See Also

InventoryTransaction Class
InventoryTransaction Members
Pastel.Evolution Namespace
InventoryTransaction..::..Quantity
InventoryTransaction..::..UnitCost


InventoryTransaction.OrderNo Property

[image]

Pastel Evolution SDK
InventoryTransaction..::..OrderNo Property
InventoryTransaction Class See Also Send Feedback
Gets or sets the transaction's order number.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override string OrderNo { get; set; }
Visual Basic
Public Overrides Property OrderNo As String
    Get
    Set

Property Value

Type: String

See Also

InventoryTransaction Class
InventoryTransaction Members


InventoryTransaction.OverrideCreditAccount Property

[image]

Pastel Evolution SDK
InventoryTransaction..::..OverrideCreditAccount Property
InventoryTransaction Class See Also Send Feedback
Gets or sets the GL account to use when posting the transaction's credit leg, overriding the credit account configured in the transaction type.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLAccount OverrideCreditAccount { get; set; }
Visual Basic
Public Property OverrideCreditAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

Remarks

When posting a negative quantity or cost, the credit account will actually be debited.

See Also

InventoryTransaction Class
InventoryTransaction Members


InventoryTransaction.OverrideDebitAccount Property

[image]

Pastel Evolution SDK
InventoryTransaction..::..OverrideDebitAccount Property
InventoryTransaction Class See Also Send Feedback
Gets or sets the GL account to use when posting the transaction's debit leg, overriding the debit account configured in the transaction type.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLAccount OverrideDebitAccount { get; set; }
Visual Basic
Public Property OverrideDebitAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

Remarks

When posting a negative quantity or cost, the debit account will actually be credited; I.e. this represents the inventory account.

See Also

InventoryTransaction Class
InventoryTransaction Members


InventoryTransaction.PostToGL Property

[image]

Pastel Evolution SDK
InventoryTransaction..::..PostToGL Property
InventoryTransaction Class See Also Send Feedback
Enables or disables posting to the general ledger.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool PostToGL { get; set; }
Visual Basic
Public Property PostToGL As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

InventoryTransaction Class
InventoryTransaction Members


InventoryTransaction.Project Property

[image]

Pastel Evolution SDK
InventoryTransaction..::..Project Property
InventoryTransaction Class See Also Send Feedback
Gets or sets the transaction's project.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override Project Project { get; set; }
Visual Basic
Public Overrides Property Project As Project
    Get
    Set

Property Value

Type: Project

See Also

InventoryTransaction Class
InventoryTransaction Members


InventoryTransaction.ProjectID Property

[image]

Pastel Evolution SDK
InventoryTransaction..::..ProjectID Property
InventoryTransaction Class See Also Send Feedback
Gets or sets the transaction's project id.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ProjectID { get; set; }
Visual Basic
Public Overrides Property ProjectID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

InventoryTransaction Class
InventoryTransaction Members


InventoryTransaction.Quantity Property

[image]

Pastel Evolution SDK
InventoryTransaction..::..Quantity Property
InventoryTransaction Class See Also Send Feedback
Gets or sets the transaction quantity.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double Quantity { get; set; }
Visual Basic
Public Property Quantity As Double
    Get
    Set

Property Value

Type: Double

See Also

InventoryTransaction Class
InventoryTransaction Members


InventoryTransaction.Reference Property

[image]

Pastel Evolution SDK
InventoryTransaction..::..Reference Property
InventoryTransaction Class See Also Send Feedback
Gets or sets the transaction's reference.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override string Reference { get; set; }
Visual Basic
Public Overrides Property Reference As String
    Get
    Set

Property Value

Type: String

Remarks

This is a required field.

See Also

InventoryTransaction Class
InventoryTransaction Members


InventoryTransaction.Reference2 Property

[image]

Pastel Evolution SDK
InventoryTransaction..::..Reference2 Property
InventoryTransaction Class See Also Send Feedback
Gets or sets the transaction's 2nd reference.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override string Reference2 { get; set; }
Visual Basic
Public Overrides Property Reference2 As String
    Get
    Set

Property Value

Type: String

Remarks

This field is optional.

See Also

InventoryTransaction Class
InventoryTransaction Members


InventoryTransaction.Representative Property

[image]

Pastel Evolution SDK
InventoryTransaction..::..Representative Property
InventoryTransaction Class See Also Send Feedback
Gets or sets the sales representative

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public SalesRepresentative Representative { get; set; }
Visual Basic
Public Property Representative As SalesRepresentative
    Get
    Set

Property Value

Type: SalesRepresentative

See Also

InventoryTransaction Class
InventoryTransaction Members


InventoryTransaction.RepresentativeID Property

[image]

Pastel Evolution SDK
InventoryTransaction..::..RepresentativeID Property
InventoryTransaction Class See Also Send Feedback
Gets or sets the sales representative ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int RepresentativeID { get; set; }
Visual Basic
Public Property RepresentativeID As Integer
    Get
    Set

Property Value

Type: Int32

Remarks

Use this method if the representative ID is readily available to gain a slight performance benefit.

See Also

InventoryTransaction Class
InventoryTransaction Members


InventoryTransaction.SerialNumbers Property

[image]

Pastel Evolution SDK
InventoryTransaction..::..SerialNumbers Property
InventoryTransaction Class See Also Send Feedback
Gets the transaction's serial number collection.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public SerialNumberCollection SerialNumbers { get; internal set; }
Visual Basic
Public Property SerialNumbers As SerialNumberCollection
    Get
    Friend Set

Property Value

Type: SerialNumberCollection

See Also

InventoryTransaction Class
InventoryTransaction Members
Pastel.Evolution Namespace
InventoryItem..::..IsSerialTracked


InventoryTransaction.StockingUnitQuantity Property

[image]

Pastel Evolution SDK
InventoryTransaction..::..StockingUnitQuantity Property
InventoryTransaction Class See Also Send Feedback
Gets or sets the transaction quantity.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double StockingUnitQuantity { get; set; }
Visual Basic
Public Property StockingUnitQuantity As Double
    Get
    Set

Property Value

Type: Double

See Also

InventoryTransaction Class
InventoryTransaction Members


InventoryTransaction.Tax Property

[image]

Pastel Evolution SDK
InventoryTransaction..::..Tax Property
InventoryTransaction Class See Also Send Feedback
Gets or sets the transaction tax amount (automatically rounded to 2 decimals and always posted positive).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override double Tax { get; set; }
Visual Basic
Public Overrides Property Tax As Double
    Get
    Set

Property Value

Type: Double

Remarks

There typically won't be tax on an inventory adjustment.

See Also

InventoryTransaction Class
InventoryTransaction Members


InventoryTransaction.TaxRate Property

[image]

Pastel Evolution SDK
InventoryTransaction..::..TaxRate Property
InventoryTransaction Class See Also Send Feedback
Gets or sets the transaction's tax type.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override TaxRate TaxRate { get; set; }
Visual Basic
Public Overrides Property TaxRate As TaxRate
    Get
    Set

Property Value

Type: TaxRate

See Also

InventoryTransaction Class
InventoryTransaction Members


InventoryTransaction.TaxRateID Property

[image]

Pastel Evolution SDK
InventoryTransaction..::..TaxRateID Property
InventoryTransaction Class See Also Send Feedback
Gets or sets the transaction's tax type id.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int TaxRateID { get; set; }
Visual Basic
Public Overrides Property TaxRateID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

InventoryTransaction Class
InventoryTransaction Members


InventoryTransaction.TransactionCode Property

[image]

Pastel Evolution SDK
InventoryTransaction..::..TransactionCode Property
InventoryTransaction Class See Also Send Feedback
Gets or sets the transaction code .

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override TransactionCodeBase TransactionCode { get; set; }
Visual Basic
Public Overrides Property TransactionCode As TransactionCodeBase
    Get
    Set

Property Value

Type: TransactionCodeBase

See Also

InventoryTransaction Class
InventoryTransaction Members


InventoryTransaction.TransactionCodeID Property

[image]

Pastel Evolution SDK
InventoryTransaction..::..TransactionCodeID Property
InventoryTransaction Class See Also Send Feedback
Gets or sets the transaction code id.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int TransactionCodeID { get; set; }
Visual Basic
Public Overrides Property TransactionCodeID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

InventoryTransaction Class
InventoryTransaction Members


InventoryTransaction.Unit Property

[image]

Pastel Evolution SDK
InventoryTransaction..::..Unit Property
InventoryTransaction Class See Also Send Feedback
Gets or sets the inventory unit om measure to use on this transaction. Note that this is not kept in the database, on recalling a transaction, this will always be null.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Unit Unit { get; set; }
Visual Basic
Public Property Unit As Unit
    Get
    Set

Property Value

Type: Unit

See Also

InventoryTransaction Class
InventoryTransaction Members


InventoryTransaction.UnitCost Property

[image]

Pastel Evolution SDK
InventoryTransaction..::..UnitCost Property
InventoryTransaction Class See Also Send Feedback
Gets or sets the transaction's unit cost.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double UnitCost { get; set; }
Visual Basic
Public Property UnitCost As Double
    Get
    Set

Property Value

Type: Double

See Also

InventoryTransaction Class
InventoryTransaction Members


InventoryTransaction.UnitID Property

[image]

Pastel Evolution SDK
InventoryTransaction..::..UnitID Property
InventoryTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int UnitID { get; set; }
Visual Basic
Public Property UnitID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

InventoryTransaction Class
InventoryTransaction Members


InventoryTransaction.Warehouse Property

[image]

Pastel Evolution SDK
InventoryTransaction..::..Warehouse Property
InventoryTransaction Class See Also Send Feedback
Gets or sets the transaction's warehouse.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Warehouse Warehouse { get; set; }
Visual Basic
Public Property Warehouse As Warehouse
    Get
    Set

Property Value

Type: Warehouse

See Also

InventoryTransaction Class
InventoryTransaction Members


InventoryTransaction.WarehouseContext Property

[image]

Pastel Evolution SDK
InventoryTransaction..::..WarehouseContext Property
InventoryTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public WarehouseContext WarehouseContext { get; set; }
Visual Basic
Public Property WarehouseContext As WarehouseContext
    Get
    Set

Property Value

Type: WarehouseContext

See Also

InventoryTransaction Class
InventoryTransaction Members


InventoryTransaction.WarehouseID Property

[image]

Pastel Evolution SDK
InventoryTransaction..::..WarehouseID Property
InventoryTransaction Class See Also Send Feedback
Gets or sets the transaction's warehouse id.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int WarehouseID { get; set; }
Visual Basic
Public Property WarehouseID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

InventoryTransaction Class
InventoryTransaction Members


InventoryTransaction Events

[image] [image]

Pastel Evolution SDK
InventoryTransaction Events
InventoryTransaction Class See Also Send Feedback

The InventoryTransaction type exposes the following members.

Events

 | Name | Description
Public event | BeforePost |
Public event | GLCostVarianceCreditPosting |
Public event | GLCostVarianceDebitPosting |
Public event | GLCreditPosting | (Inherited from TransactionBase.)
Public event | GLDebitPosting | (Inherited from TransactionBase.)
Public event | GLVatPosting | (Inherited from TransactionBase.)

See Also

InventoryTransaction Class


InventoryTransaction.BeforePost Event

[image]

Pastel Evolution SDK
InventoryTransaction..::..BeforePost Event
InventoryTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public event EventHandler BeforePost
Visual Basic
Public Event BeforePost As EventHandler

Value

Type: System..::..EventHandler

See Also

InventoryTransaction Class
InventoryTransaction Members


InventoryTransaction.GLCostVarianceCreditPosting Event

[image]

Pastel Evolution SDK
InventoryTransaction..::..GLCostVarianceCreditPosting Event
InventoryTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public event TransactionBase..::..GLPostingEventHandler GLCostVarianceCreditPosting
Visual Basic
Public Event GLCostVarianceCreditPosting As TransactionBase..::..GLPostingEventHandler

Value

Type: Pastel.Evolution..::..TransactionBase..::..GLPostingEventHandler

See Also

InventoryTransaction Class
InventoryTransaction Members


InventoryTransaction.GLCostVarianceDebitPosting Event

[image]

Pastel Evolution SDK
InventoryTransaction..::..GLCostVarianceDebitPosting Event
InventoryTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public event TransactionBase..::..GLPostingEventHandler GLCostVarianceDebitPosting
Visual Basic
Public Event GLCostVarianceDebitPosting As TransactionBase..::..GLPostingEventHandler

Value

Type: Pastel.Evolution..::..TransactionBase..::..GLPostingEventHandler

See Also

InventoryTransaction Class
InventoryTransaction Members


JobCard Class

[image]

Pastel Evolution SDK
JobCard Class
Members See Also Send Feedback
Represents an Evolution job card.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class JobCard : AccountBase
Visual Basic
Public Class JobCard
    Inherits AccountBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..AccountBase
Pastel.Evolution..::..JobCard

See Also

JobCard Members


JobCard Members

[image] [image]

Pastel Evolution SDK
JobCard Members
JobCard Class Constructors Methods Fields Properties See Also Send Feedback

The JobCard type exposes the following members.

Constructors

 | Name | Description
Public method | JobCard()()()() | Initializes a new instance of the JobCard class
Public method | JobCard(Int32) | Initializes a new instance of the JobCard class
Public method | JobCard(String) | Initializes a new instance of the JobCard class

Methods

 | Name | Description
 | _ListCurrentBranch(String) |
 | _ListCurrentBranch(Int32, JobCard..::..JobStatus) |
Protected method | cascadeProject |
Protected method | cascadeSalesReps |
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find |
 | FindByCode | Attempts to find an inventory item by its code and returns its ID.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | hasPostedLines |
 | List(String) |
 | List(Int32, JobCard..::..JobStatus) |
 | List(Customer, JobCard..::..JobStatus) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides AccountBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides AccountBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | (Inherited from AccountBase.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | deliverTo |
Protected field | detail |
Protected field | invoiceTo |
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | Account |
Public property | Active | (Overrides AccountBase..::..Active.)
Public property | Audit | Gets the audit number of the last transaction processed by this document. This value defaults to 0, and will not be available on recalled documents.
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | ClosingDate |
Public property | Code | (Overrides AccountBase..::..Code.)
Public property | CompletionDate |
Public property | DeliverTo |
Public property | DeliveryDate |
Public property | Description | (Overrides AccountBase..::..Description.)
Public property | Detail | Gets the job detail collection to which detail lines can be added and from which lines can be deleted
Public property | ExtOrderNo |
Public property | FinalInvoice |
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | InvoiceTo |
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | Module | (Overrides AccountBase..::..Module.)
Public property | Narration |
Public property | OverrideCOSGLAccount | Gets or sets the Job Card override COS GL Account.
Public property | OverrideRecoveryGLAccount | Gets or sets the Job Card override Recovery GL Account.
Public property | OverrideSalesGLAccount | Gets or sets the Job Card override Sales GL Account.
Public property | OverrideWIPGLAccount | Gets or sets the Job Card override WIP GL Account.
Public property | PostingMethod |
Public property | Project |
Public property | ProjectID |
Public property | QuoteAmount | Gets or sets the Job Card Quote Amount.
Public property | RawFieldData | Obsolete.
Public property | SalesRepresentative |
Public property | SalesRepresentativeID |
Public property | Started |
Public property | Status |
Public property | UserFields |

See Also

JobCard Class


JobCard Constructor

[image] [image]

Pastel Evolution SDK
JobCard Constructor
JobCard Class See Also Send Feedback

Overload List

 | Name | Description
Public method | JobCard()()()() | Initializes a new instance of the JobCard class
Public method | JobCard(Int32) | Initializes a new instance of the JobCard class
Public method | JobCard(String) | Initializes a new instance of the JobCard class

See Also

JobCard Class
JobCard Members


JobCard Constructor

[image]

Pastel Evolution SDK
JobCard Constructor
JobCard Class See Also Send Feedback
Initializes a new instance of the JobCard class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public JobCard()
Visual Basic
Public Sub New

See Also

JobCard Class
JobCard Members
JobCard Overload


JobCard Constructor (Int32)

[image]

Pastel Evolution SDK
JobCard Constructor (Int32)
JobCard Class See Also Send Feedback
Initializes a new instance of the JobCard class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public JobCard(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32

See Also

JobCard Class
JobCard Members
JobCard Overload


JobCard Constructor (String)

[image]

Pastel Evolution SDK
JobCard Constructor (String)
JobCard Class See Also Send Feedback
Initializes a new instance of the JobCard class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public JobCard(
    string jobCode
)
Visual Basic
Public Sub New (
    jobCode As String
)

Parameters

jobCode
Type: System..::..String

See Also

JobCard Class
JobCard Members
JobCard Overload


JobCard Fields

[image] [image]

Pastel Evolution SDK
JobCard Fields
JobCard Class See Also Send Feedback

The JobCard type exposes the following members.

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | deliverTo |
Protected field | detail |
Protected field | invoiceTo |
Protected field | wrapper | (Inherited from RecordBase.)

See Also

JobCard Class


JobCard.deliverTo Field

[image]

Pastel Evolution SDK
JobCard..::..deliverTo Field
JobCard Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected Address deliverTo
Visual Basic
Protected deliverTo As Address

Field Value

Type: Address

See Also

JobCard Class
JobCard Members


JobCard.detail Field

[image]

Pastel Evolution SDK
JobCard..::..detail Field
JobCard Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected JobDetailCollection detail
Visual Basic
Protected detail As JobDetailCollection

Field Value

Type: JobDetailCollection

See Also

JobCard Class
JobCard Members


JobCard.invoiceTo Field

[image]

Pastel Evolution SDK
JobCard..::..invoiceTo Field
JobCard Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected Address invoiceTo
Visual Basic
Protected invoiceTo As Address

Field Value

Type: Address

See Also

JobCard Class
JobCard Members


JobCard Methods

[image] [image]

Pastel Evolution SDK
JobCard Methods
JobCard Class See Also Send Feedback

The JobCard type exposes the following members.

Methods

 | Name | Description
 | _ListCurrentBranch(String) |
 | _ListCurrentBranch(Int32, JobCard..::..JobStatus) |
Protected method | cascadeProject |
Protected method | cascadeSalesReps |
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find |
 | FindByCode | Attempts to find an inventory item by its code and returns its ID.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | hasPostedLines |
 | List(String) |
 | List(Int32, JobCard..::..JobStatus) |
 | List(Customer, JobCard..::..JobStatus) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides AccountBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides AccountBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | (Inherited from AccountBase.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

JobCard Class


JobCard._ListCurrentBranch Method

[image] [image]

Pastel Evolution SDK
JobCard..::.._ListCurrentBranch Method
JobCard Class See Also Send Feedback

Overload List

Name | Description
_ListCurrentBranch(String) |
_ListCurrentBranch(Int32, JobCard..::..JobStatus) |

See Also

JobCard Class
JobCard Members


JobCard._ListCurrentBranch Method (String)

[image]

Pastel Evolution SDK
JobCard..::.._ListCurrentBranch Method (String)
JobCard Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable _ListCurrentBranch(
    string criteria
)
Visual Basic
Public Shared Function _ListCurrentBranch (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String

Return Value

Type: DataTable

See Also

JobCard Class
JobCard Members
_ListCurrentBranch Overload


JobCard._ListCurrentBranch Method (Int32, JobCard.JobStatus)

[image]

Pastel Evolution SDK
JobCard..::.._ListCurrentBranch Method (Int32, JobCard..::..JobStatus)
JobCard Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable _ListCurrentBranch(
    int accountID,
    JobCard..::..JobStatus status
)
Visual Basic
Public Shared Function _ListCurrentBranch (
    accountID As Integer,
    status As JobCard..::..JobStatus
) As DataTable

Parameters

accountID
Type: System..::..Int32
status
Type: Pastel.Evolution..::..JobCard..::..JobStatus

Return Value

Type: DataTable

See Also

JobCard Class
JobCard Members
_ListCurrentBranch Overload


JobCard.cascadeProject Method

[image]

Pastel Evolution SDK
JobCard..::..cascadeProject Method
JobCard Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal void cascadeProject()
Visual Basic
Protected Friend Sub cascadeProject

See Also

JobCard Class
JobCard Members


JobCard.cascadeSalesReps Method

[image]

Pastel Evolution SDK
JobCard..::..cascadeSalesReps Method
JobCard Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal void cascadeSalesReps()
Visual Basic
Protected Friend Sub cascadeSalesReps

See Also

JobCard Class
JobCard Members


JobCard.Find Method

[image]

Pastel Evolution SDK
JobCard..::..Find Method
JobCard Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String

Return Value

Type: Int32

See Also

JobCard Class
JobCard Members


JobCard.FindByCode Method

[image]

Pastel Evolution SDK
JobCard..::..FindByCode Method
JobCard Class See Also Send Feedback
Attempts to find an inventory item by its code and returns its ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int FindByCode(
    string code
)
Visual Basic
Public Shared Function FindByCode (
    code As String
) As Integer

Parameters

code
Type: System..::..String
The code used to lookup the account.

Return Value

Type: Int32
-1 if no record was found, else the id of the first account matching the criteria supplied.

See Also

JobCard Class
JobCard Members
Pastel.Evolution Namespace
JobCard..::..Find(String)


JobCard.hasPostedLines Method

[image]

Pastel Evolution SDK
JobCard..::..hasPostedLines Method
JobCard Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal bool hasPostedLines()
Visual Basic
Protected Friend Function hasPostedLines As Boolean

Return Value

Type: Boolean

See Also

JobCard Class
JobCard Members


JobCard.List Method

[image] [image]

Pastel Evolution SDK
JobCard..::..List Method
JobCard Class See Also Send Feedback

Overload List

Name | Description
List(String) |
List(Int32, JobCard..::..JobStatus) |
List(Customer, JobCard..::..JobStatus) |

See Also

JobCard Class
JobCard Members


JobCard.List Method (String)

[image]

Pastel Evolution SDK
JobCard..::..List Method (String)
JobCard Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria
)
Visual Basic
Public Shared Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String

Return Value

Type: DataTable

See Also

JobCard Class
JobCard Members
List Overload


JobCard.List Method (Int32, JobCard.JobStatus)

[image]

Pastel Evolution SDK
JobCard..::..List Method (Int32, JobCard..::..JobStatus)
JobCard Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    int accountID,
    JobCard..::..JobStatus status
)
Visual Basic
Public Shared Function List (
    accountID As Integer,
    status As JobCard..::..JobStatus
) As DataTable

Parameters

accountID
Type: System..::..Int32
status
Type: Pastel.Evolution..::..JobCard..::..JobStatus

Return Value

Type: DataTable

See Also

JobCard Class
JobCard Members
List Overload


JobCard.List Method (Customer, JobCard.JobStatus)

[image]

Pastel Evolution SDK
JobCard..::..List Method (Customer, JobCard..::..JobStatus)
JobCard Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    Customer account,
    JobCard..::..JobStatus status
)
Visual Basic
Public Shared Function List (
    account As Customer,
    status As JobCard..::..JobStatus
) As DataTable

Parameters

account
Type: Pastel.Evolution..::..Customer
status
Type: Pastel.Evolution..::..JobCard..::..JobStatus

Return Value

Type: DataTable

See Also

JobCard Class
JobCard Members
List Overload


JobCard.OnDelete Method

[image]

Pastel Evolution SDK
JobCard..::..OnDelete Method
JobCard Class See Also Send Feedback
Removes the record from the database, provided it is not referenced by other records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

Exceptions

Exception | Condition
IntegrityViolationException |

See Also

JobCard Class
JobCard Members


JobCard.OnSave Method

[image]

Pastel Evolution SDK
JobCard..::..OnSave Method
JobCard Class See Also Send Feedback
Persists the record to the database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

JobCard Class
JobCard Members


JobCard Properties

[image] [image]

Pastel Evolution SDK
JobCard Properties
JobCard Class See Also Send Feedback

The JobCard type exposes the following members.

Properties

 | Name | Description
Public property | Account |
Public property | Active | (Overrides AccountBase..::..Active.)
Public property | Audit | Gets the audit number of the last transaction processed by this document. This value defaults to 0, and will not be available on recalled documents.
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | ClosingDate |
Public property | Code | (Overrides AccountBase..::..Code.)
Public property | CompletionDate |
Public property | DeliverTo |
Public property | DeliveryDate |
Public property | Description | (Overrides AccountBase..::..Description.)
Public property | Detail | Gets the job detail collection to which detail lines can be added and from which lines can be deleted
Public property | ExtOrderNo |
Public property | FinalInvoice |
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | InvoiceTo |
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | Module | (Overrides AccountBase..::..Module.)
Public property | Narration |
Public property | OverrideCOSGLAccount | Gets or sets the Job Card override COS GL Account.
Public property | OverrideRecoveryGLAccount | Gets or sets the Job Card override Recovery GL Account.
Public property | OverrideSalesGLAccount | Gets or sets the Job Card override Sales GL Account.
Public property | OverrideWIPGLAccount | Gets or sets the Job Card override WIP GL Account.
Public property | PostingMethod |
Public property | Project |
Public property | ProjectID |
Public property | QuoteAmount | Gets or sets the Job Card Quote Amount.
Public property | RawFieldData | Obsolete.
Public property | SalesRepresentative |
Public property | SalesRepresentativeID |
Public property | Started |
Public property | Status |
Public property | UserFields |

See Also

JobCard Class


JobCard.Account Property

[image]

Pastel Evolution SDK
JobCard..::..Account Property
JobCard Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Customer Account { get; set; }
Visual Basic
Public Property Account As Customer
    Get
    Set

Property Value

Type: Customer

See Also

JobCard Class
JobCard Members


JobCard.Active Property

[image]

Pastel Evolution SDK
JobCard..::..Active Property
JobCard Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override bool Active { get; set; }
Visual Basic
Public Overrides Property Active As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

JobCard Class
JobCard Members


JobCard.Audit Property

[image]

Pastel Evolution SDK
JobCard..::..Audit Property
JobCard Class See Also Send Feedback
Gets the audit number of the last transaction processed by this document. This value defaults to 0, and will not be available on recalled documents.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Audit { get; }
Visual Basic
Public ReadOnly Property Audit As String
    Get

Property Value

Type: String

See Also

JobCard Class
JobCard Members


JobCard.ClosingDate Property

[image]

Pastel Evolution SDK
JobCard..::..ClosingDate Property
JobCard Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DateTime ClosingDate { get; set; }
Visual Basic
Public Property ClosingDate As DateTime
    Get
    Set

Property Value

Type: DateTime

See Also

JobCard Class
JobCard Members


JobCard.Code Property

[image]

Pastel Evolution SDK
JobCard..::..Code Property
JobCard Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override string Code { get; set; }
Visual Basic
Public Overrides Property Code As String
    Get
    Set

Property Value

Type: String

See Also

JobCard Class
JobCard Members


JobCard.CompletionDate Property

[image]

Pastel Evolution SDK
JobCard..::..CompletionDate Property
JobCard Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DateTime CompletionDate { get; set; }
Visual Basic
Public Property CompletionDate As DateTime
    Get
    Set

Property Value

Type: DateTime

See Also

JobCard Class
JobCard Members


JobCard.DeliverTo Property

[image]

Pastel Evolution SDK
JobCard..::..DeliverTo Property
JobCard Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Address DeliverTo { get; set; }
Visual Basic
Public Property DeliverTo As Address
    Get
    Set

Property Value

Type: Address

See Also

JobCard Class
JobCard Members


JobCard.DeliveryDate Property

[image]

Pastel Evolution SDK
JobCard..::..DeliveryDate Property
JobCard Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DateTime DeliveryDate { get; set; }
Visual Basic
Public Property DeliveryDate As DateTime
    Get
    Set

Property Value

Type: DateTime

See Also

JobCard Class
JobCard Members


JobCard.Description Property

[image]

Pastel Evolution SDK
JobCard..::..Description Property
JobCard Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override string Description { get; set; }
Visual Basic
Public Overrides Property Description As String
    Get
    Set

Property Value

Type: String

See Also

JobCard Class
JobCard Members


JobCard.Detail Property

[image]

Pastel Evolution SDK
JobCard..::..Detail Property
JobCard Class See Also Send Feedback
Gets the job detail collection to which detail lines can be added and from which lines can be deleted

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public JobDetailCollection Detail { get; }
Visual Basic
Public ReadOnly Property Detail As JobDetailCollection
    Get

Property Value

Type: JobDetailCollection

See Also

JobCard Class
JobCard Members


JobCard.ExtOrderNo Property

[image]

Pastel Evolution SDK
JobCard..::..ExtOrderNo Property
JobCard Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string ExtOrderNo { get; set; }
Visual Basic
Public Property ExtOrderNo As String
    Get
    Set

Property Value

Type: String

See Also

JobCard Class
JobCard Members


JobCard.FinalInvoice Property

[image]

Pastel Evolution SDK
JobCard..::..FinalInvoice Property
JobCard Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool FinalInvoice { get; set; }
Visual Basic
Public Property FinalInvoice As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

JobCard Class
JobCard Members


JobCard.ID Property

[image]

Pastel Evolution SDK
JobCard..::..ID Property
JobCard Class See Also Send Feedback
Gets the internal record ID (0 for new, unsaved records).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

See Also

JobCard Class
JobCard Members


JobCard.InvoiceTo Property

[image]

Pastel Evolution SDK
JobCard..::..InvoiceTo Property
JobCard Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Address InvoiceTo { get; set; }
Visual Basic
Public Property InvoiceTo As Address
    Get
    Set

Property Value

Type: Address

See Also

JobCard Class
JobCard Members


JobCard.LongID Property

[image]

Pastel Evolution SDK
JobCard..::..LongID Property
JobCard Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

JobCard Class
JobCard Members


JobCard.Module Property

[image]

Pastel Evolution SDK
JobCard..::..Module Property
JobCard Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override Module Module { get; }
Visual Basic
Public Overrides ReadOnly Property Module As Module
    Get

Property Value

Type: Module

See Also

JobCard Class
JobCard Members


JobCard.Narration Property

[image]

Pastel Evolution SDK
JobCard..::..Narration Property
JobCard Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Narration { get; set; }
Visual Basic
Public Property Narration As String
    Get
    Set

Property Value

Type: String

See Also

JobCard Class
JobCard Members


JobCard.OverrideCOSGLAccount Property

[image]

Pastel Evolution SDK
JobCard..::..OverrideCOSGLAccount Property
JobCard Class See Also Send Feedback
Gets or sets the Job Card override COS GL Account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLAccount OverrideCOSGLAccount { get; set; }
Visual Basic
Public Property OverrideCOSGLAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

See Also

JobCard Class
JobCard Members


JobCard.OverrideRecoveryGLAccount Property

[image]

Pastel Evolution SDK
JobCard..::..OverrideRecoveryGLAccount Property
JobCard Class See Also Send Feedback
Gets or sets the Job Card override Recovery GL Account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLAccount OverrideRecoveryGLAccount { get; set; }
Visual Basic
Public Property OverrideRecoveryGLAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

See Also

JobCard Class
JobCard Members


JobCard.OverrideSalesGLAccount Property

[image]

Pastel Evolution SDK
JobCard..::..OverrideSalesGLAccount Property
JobCard Class See Also Send Feedback
Gets or sets the Job Card override Sales GL Account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLAccount OverrideSalesGLAccount { get; set; }
Visual Basic
Public Property OverrideSalesGLAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

See Also

JobCard Class
JobCard Members


JobCard.OverrideWIPGLAccount Property

[image]

Pastel Evolution SDK
JobCard..::..OverrideWIPGLAccount Property
JobCard Class See Also Send Feedback
Gets or sets the Job Card override WIP GL Account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLAccount OverrideWIPGLAccount { get; set; }
Visual Basic
Public Property OverrideWIPGLAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

See Also

JobCard Class
JobCard Members


JobCard.PostingMethod Property

[image]

Pastel Evolution SDK
JobCard..::..PostingMethod Property
JobCard Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public JobPostingMethod PostingMethod { get; set; }
Visual Basic
Public Property PostingMethod As JobPostingMethod
    Get
    Set

Property Value

Type: JobPostingMethod

See Also

JobCard Class
JobCard Members


JobCard.Project Property

[image]

Pastel Evolution SDK
JobCard..::..Project Property
JobCard Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Project Project { get; set; }
Visual Basic
Public Property Project As Project
    Get
    Set

Property Value

Type: Project

See Also

JobCard Class
JobCard Members


JobCard.ProjectID Property

[image]

Pastel Evolution SDK
JobCard..::..ProjectID Property
JobCard Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int ProjectID { get; set; }
Visual Basic
Public Property ProjectID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

JobCard Class
JobCard Members


JobCard.QuoteAmount Property

[image]

Pastel Evolution SDK
JobCard..::..QuoteAmount Property
JobCard Class See Also Send Feedback
Gets or sets the Job Card Quote Amount.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double QuoteAmount { get; set; }
Visual Basic
Public Property QuoteAmount As Double
    Get
    Set

Property Value

Type: Double

See Also

JobCard Class
JobCard Members


JobCard.RawFieldData Property

[image]

Pastel Evolution SDK
JobCard..::..RawFieldData Property
JobCard Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
[ObsoleteAttribute("Use UserFields instead.")]
public FieldCollection RawFieldData { get; }
Visual Basic
<ObsoleteAttribute("Use UserFields instead.")>
Public ReadOnly Property RawFieldData As FieldCollection
    Get

Property Value

Type: FieldCollection

See Also

JobCard Class
JobCard Members


JobCard.SalesRepresentative Property

[image]

Pastel Evolution SDK
JobCard..::..SalesRepresentative Property
JobCard Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public SalesRepresentative SalesRepresentative { get; set; }
Visual Basic
Public Property SalesRepresentative As SalesRepresentative
    Get
    Set

Property Value

Type: SalesRepresentative

See Also

JobCard Class
JobCard Members


JobCard.SalesRepresentativeID Property

[image]

Pastel Evolution SDK
JobCard..::..SalesRepresentativeID Property
JobCard Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int SalesRepresentativeID { get; set; }
Visual Basic
Public Property SalesRepresentativeID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

JobCard Class
JobCard Members


JobCard.Started Property

[image]

Pastel Evolution SDK
JobCard..::..Started Property
JobCard Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DateTime Started { get; set; }
Visual Basic
Public Property Started As DateTime
    Get
    Set

Property Value

Type: DateTime

See Also

JobCard Class
JobCard Members


JobCard.Status Property

[image]

Pastel Evolution SDK
JobCard..::..Status Property
JobCard Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public JobCard..::..JobStatus Status { get; set; }
Visual Basic
Public Property Status As JobCard..::..JobStatus
    Get
    Set

Property Value

Type: JobCard..::..JobStatus

See Also

JobCard Class
JobCard Members


JobCard.UserFields Property

[image]

Pastel Evolution SDK
JobCard..::..UserFields Property
JobCard Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public FieldCollection UserFields { get; }
Visual Basic
Public ReadOnly Property UserFields As FieldCollection
    Get

Property Value

Type: FieldCollection

See Also

JobCard Class
JobCard Members


JobCard.JobStatus Enumeration

[image]

Pastel Evolution SDK
JobCard..::..JobStatus Enumeration
JobCard Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public enum JobStatus
Visual Basic
Public Enumeration JobStatus

Members

Member name | Value | Description
Quote | 0 |
Active | 1 |
Complete | 2 |

See Also

Pastel.Evolution Namespace


JobDetail Class

[image]

Pastel Evolution SDK
JobDetail Class
Members See Also Send Feedback
Represents a job transaction.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class JobDetail
Visual Basic
Public Class JobDetail

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..JobDetail

See Also

JobDetail Members


JobDetail Members

[image] [image]

Pastel Evolution SDK
JobDetail Members
JobDetail Class Constructors Methods Properties See Also Send Feedback

The JobDetail type exposes the following members.

Constructors

 | Name | Description
Public method | JobDetail()()()() | Initializes a new instance of the JobDetail class
Public method | JobDetail(Int32) | Initializes a new instance of the JobDetail class
Public method | JobDetail(Int64) | Initializes a new instance of the JobDetail class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Account |
Public property | BudgetPurchasesTotalTax | Gets the calculated line total.
Public property | BudgetSalesTotalExcl | Gets the calculated line total
Public property | BudgetSalesTotalIncl | Gets the calculated line total
Public property | BudgetSalesTotalTax | Gets the calculated line total.
Public property | BudgetTotalCost |
Public property | BudgetUnitCostPrice |
Public property | BudgetUnitSellingPrice |
Public property | Description |
Public property | Discount | Gets or sets the total line discount value (applies to tax excl. value)
Public property | DiscountPercent | Gets or sets the line discount percentage: 5% = 5, as opposed to 0.05
Public property | EndDate |
Public property | ID | Gets the internal record ID (0 for new, unsaved records).
Public property | Index | Gets the line number (1-based)
Public property | InventoryItem | Gets or sets the line's inventory item. Maps directly to the Account property but null if invalid.
Public property | InventoryItemID | Gets or sets the stock item id.
Public property | Kind |
Public property | LongID | Transitional accessor.
Public property | Lot |
Public property | LotID |
Public property | Project |
Public property | ProjectID |
Public property | PurchasesTaxRate |
Public property | PurchasesTotalTax | Gets the calculated line total tax.
Public property | Quantity |
Public property | QuantityWIP | Gets the work in progress quantity held by given detail record. This value gets increased when saving a new active inventory line and decreased by adding negative lines (-Quantity).
Public property | Reference |
Public property | SalesRepresentative |
Public property | SalesRepresentativeID |
Public property | SalesTaxRate | Sales tax type
Public property | SalesTotalExcl | Gets the calculated line total
Public property | SalesTotalIncl | Gets the calculated line total
Public property | SalesTotalTax | Gets the calculated line total
Public property | SerialNumbers |
Public property | Source | Gets the transaction source, decided by the Account.
Public property | StartDate |
Public property | Status |
Public property | StockingUnitQuantity |
Public property | StockingUnitQuantityWIP |
Public property | TotalCost |
Public property | TransactionCode | Gets or sets the job costing transaction type associate with the detail record. When setting the transaction type, the cost and sales tax types will default to those set on the transaction type.
Public property | Unit |
Public property | UnitCostPrice | Gets or sets the tax exclusive unit cost price. For new records, setting this value will also set BudgetUnitCostPrice.
Public property | UnitID |
Public property | UnitSellingPrice | Gets or sets the tax exclusive unit selling price. For new records, setting this value will also set BudgetUnitSellingPrice.
Public property | UserFields |
Public property | Warehouse | Gets or sets the warehouse relevant to this detail record. Set the warehouse only after setting the inventory item. The Warehouse and WarehouseContext properties are mapped to one another.
Public property | WarehouseContext | Gets or sets the warehouse link of the stock item specified.
Public property | WarehouseData | Obsolete.
Public property | WarehouseID | Gets the ID of the assigned warehouse (0 if N/A).
Public property | Worker | Gets or sets the line's worker. Maps directly to the Account property but null if invalid.
Public property | WorkerID | Gets or sets the worker id.

See Also

JobDetail Class


JobDetail Constructor

[image] [image]

Pastel Evolution SDK
JobDetail Constructor
JobDetail Class See Also Send Feedback

Overload List

 | Name | Description
Public method | JobDetail()()()() | Initializes a new instance of the JobDetail class
Public method | JobDetail(Int32) | Initializes a new instance of the JobDetail class
Public method | JobDetail(Int64) | Initializes a new instance of the JobDetail class

See Also

JobDetail Class
JobDetail Members


JobDetail Constructor

[image]

Pastel Evolution SDK
JobDetail Constructor
JobDetail Class See Also Send Feedback
Initializes a new instance of the JobDetail class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public JobDetail()
Visual Basic
Public Sub New

See Also

JobDetail Class
JobDetail Members
JobDetail Overload


JobDetail Constructor (Int32)

[image]

Pastel Evolution SDK
JobDetail Constructor (Int32)
JobDetail Class See Also Send Feedback
Initializes a new instance of the JobDetail class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public JobDetail(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32

See Also

JobDetail Class
JobDetail Members
JobDetail Overload


JobDetail Constructor (Int64)

[image]

Pastel Evolution SDK
JobDetail Constructor (Int64)
JobDetail Class See Also Send Feedback
Initializes a new instance of the JobDetail class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public JobDetail(
    long id
)
Visual Basic
Public Sub New (
    id As Long
)

Parameters

id
Type: System..::..Int64

See Also

JobDetail Class
JobDetail Members
JobDetail Overload


JobDetail Methods

[image] [image]

Pastel Evolution SDK
JobDetail Methods
JobDetail Class See Also Send Feedback

The JobDetail type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

JobDetail Class


JobDetail.Find Method

[image]

Pastel Evolution SDK
JobDetail..::..Find Method
JobDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static long Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Long

Parameters

criteria
Type: System..::..String

Return Value

Type: Int64

See Also

JobDetail Class
JobDetail Members


JobDetail.List Method

[image]

Pastel Evolution SDK
JobDetail..::..List Method
JobDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria
)
Visual Basic
Public Shared Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String

Return Value

Type: DataTable

See Also

JobDetail Class
JobDetail Members


JobDetail Properties

[image] [image]

Pastel Evolution SDK
JobDetail Properties
JobDetail Class See Also Send Feedback

The JobDetail type exposes the following members.

Properties

 | Name | Description
Public property | Account |
Public property | BudgetPurchasesTotalTax | Gets the calculated line total.
Public property | BudgetSalesTotalExcl | Gets the calculated line total
Public property | BudgetSalesTotalIncl | Gets the calculated line total
Public property | BudgetSalesTotalTax | Gets the calculated line total.
Public property | BudgetTotalCost |
Public property | BudgetUnitCostPrice |
Public property | BudgetUnitSellingPrice |
Public property | Description |
Public property | Discount | Gets or sets the total line discount value (applies to tax excl. value)
Public property | DiscountPercent | Gets or sets the line discount percentage: 5% = 5, as opposed to 0.05
Public property | EndDate |
Public property | ID | Gets the internal record ID (0 for new, unsaved records).
Public property | Index | Gets the line number (1-based)
Public property | InventoryItem | Gets or sets the line's inventory item. Maps directly to the Account property but null if invalid.
Public property | InventoryItemID | Gets or sets the stock item id.
Public property | Kind |
Public property | LongID | Transitional accessor.
Public property | Lot |
Public property | LotID |
Public property | Project |
Public property | ProjectID |
Public property | PurchasesTaxRate |
Public property | PurchasesTotalTax | Gets the calculated line total tax.
Public property | Quantity |
Public property | QuantityWIP | Gets the work in progress quantity held by given detail record. This value gets increased when saving a new active inventory line and decreased by adding negative lines (-Quantity).
Public property | Reference |
Public property | SalesRepresentative |
Public property | SalesRepresentativeID |
Public property | SalesTaxRate | Sales tax type
Public property | SalesTotalExcl | Gets the calculated line total
Public property | SalesTotalIncl | Gets the calculated line total
Public property | SalesTotalTax | Gets the calculated line total
Public property | SerialNumbers |
Public property | Source | Gets the transaction source, decided by the Account.
Public property | StartDate |
Public property | Status |
Public property | StockingUnitQuantity |
Public property | StockingUnitQuantityWIP |
Public property | TotalCost |
Public property | TransactionCode | Gets or sets the job costing transaction type associate with the detail record. When setting the transaction type, the cost and sales tax types will default to those set on the transaction type.
Public property | Unit |
Public property | UnitCostPrice | Gets or sets the tax exclusive unit cost price. For new records, setting this value will also set BudgetUnitCostPrice.
Public property | UnitID |
Public property | UnitSellingPrice | Gets or sets the tax exclusive unit selling price. For new records, setting this value will also set BudgetUnitSellingPrice.
Public property | UserFields |
Public property | Warehouse | Gets or sets the warehouse relevant to this detail record. Set the warehouse only after setting the inventory item. The Warehouse and WarehouseContext properties are mapped to one another.
Public property | WarehouseContext | Gets or sets the warehouse link of the stock item specified.
Public property | WarehouseData | Obsolete.
Public property | WarehouseID | Gets the ID of the assigned warehouse (0 if N/A).
Public property | Worker | Gets or sets the line's worker. Maps directly to the Account property but null if invalid.
Public property | WorkerID | Gets or sets the worker id.

See Also

JobDetail Class


JobDetail.Account Property

[image]

Pastel Evolution SDK
JobDetail..::..Account Property
JobDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public AccountBase Account { get; set; }
Visual Basic
Public Property Account As AccountBase
    Get
    Set

Property Value

Type: AccountBase

See Also

JobDetail Class
JobDetail Members


JobDetail.BudgetPurchasesTotalTax Property

[image]

Pastel Evolution SDK
JobDetail..::..BudgetPurchasesTotalTax Property
JobDetail Class See Also Send Feedback
Gets the calculated line total.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double BudgetPurchasesTotalTax { get; }
Visual Basic
Public ReadOnly Property BudgetPurchasesTotalTax As Double
    Get

Property Value

Type: Double

See Also

JobDetail Class
JobDetail Members


JobDetail.BudgetSalesTotalExcl Property

[image]

Pastel Evolution SDK
JobDetail..::..BudgetSalesTotalExcl Property
JobDetail Class See Also Send Feedback
Gets the calculated line total

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double BudgetSalesTotalExcl { get; }
Visual Basic
Public ReadOnly Property BudgetSalesTotalExcl As Double
    Get

Property Value

Type: Double

See Also

JobDetail Class
JobDetail Members


JobDetail.BudgetSalesTotalIncl Property

[image]

Pastel Evolution SDK
JobDetail..::..BudgetSalesTotalIncl Property
JobDetail Class See Also Send Feedback
Gets the calculated line total

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double BudgetSalesTotalIncl { get; }
Visual Basic
Public ReadOnly Property BudgetSalesTotalIncl As Double
    Get

Property Value

Type: Double

See Also

JobDetail Class
JobDetail Members


JobDetail.BudgetSalesTotalTax Property

[image]

Pastel Evolution SDK
JobDetail..::..BudgetSalesTotalTax Property
JobDetail Class See Also Send Feedback
Gets the calculated line total.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double BudgetSalesTotalTax { get; }
Visual Basic
Public ReadOnly Property BudgetSalesTotalTax As Double
    Get

Property Value

Type: Double

See Also

JobDetail Class
JobDetail Members


JobDetail.BudgetTotalCost Property

[image]

Pastel Evolution SDK
JobDetail..::..BudgetTotalCost Property
JobDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double BudgetTotalCost { get; }
Visual Basic
Public ReadOnly Property BudgetTotalCost As Double
    Get

Property Value

Type: Double

See Also

JobDetail Class
JobDetail Members


JobDetail.BudgetUnitCostPrice Property

[image]

Pastel Evolution SDK
JobDetail..::..BudgetUnitCostPrice Property
JobDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double BudgetUnitCostPrice { get; set; }
Visual Basic
Public Property BudgetUnitCostPrice As Double
    Get
    Set

Property Value

Type: Double

See Also

JobDetail Class
JobDetail Members


JobDetail.BudgetUnitSellingPrice Property

[image]

Pastel Evolution SDK
JobDetail..::..BudgetUnitSellingPrice Property
JobDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double BudgetUnitSellingPrice { get; set; }
Visual Basic
Public Property BudgetUnitSellingPrice As Double
    Get
    Set

Property Value

Type: Double

See Also

JobDetail Class
JobDetail Members


JobDetail.Description Property

[image]

Pastel Evolution SDK
JobDetail..::..Description Property
JobDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set

Property Value

Type: String

See Also

JobDetail Class
JobDetail Members


JobDetail.Discount Property

[image]

Pastel Evolution SDK
JobDetail..::..Discount Property
JobDetail Class See Also Send Feedback
Gets or sets the total line discount value (applies to tax excl. value)

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double Discount { get; set; }
Visual Basic
Public Property Discount As Double
    Get
    Set

Property Value

Type: Double

See Also

JobDetail Class
JobDetail Members


JobDetail.DiscountPercent Property

[image]

Pastel Evolution SDK
JobDetail..::..DiscountPercent Property
JobDetail Class See Also Send Feedback
Gets or sets the line discount percentage: 5% = 5, as opposed to 0.05

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double DiscountPercent { get; set; }
Visual Basic
Public Property DiscountPercent As Double
    Get
    Set

Property Value

Type: Double

See Also

JobDetail Class
JobDetail Members


JobDetail.EndDate Property

[image]

Pastel Evolution SDK
JobDetail..::..EndDate Property
JobDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DateTime EndDate { get; set; }
Visual Basic
Public Property EndDate As DateTime
    Get
    Set

Property Value

Type: DateTime

See Also

JobDetail Class
JobDetail Members


JobDetail.ID Property

[image]

Pastel Evolution SDK
JobDetail..::..ID Property
JobDetail Class See Also Send Feedback
Gets the internal record ID (0 for new, unsaved records).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int ID { get; }
Visual Basic
Public ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

See Also

JobDetail Class
JobDetail Members


JobDetail.Index Property

[image]

Pastel Evolution SDK
JobDetail..::..Index Property
JobDetail Class See Also Send Feedback
Gets the line number (1-based)

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int Index { get; internal set; }
Visual Basic
Public Property Index As Integer
    Get
    Friend Set

Property Value

Type: Int32

See Also

JobDetail Class
JobDetail Members


JobDetail.InventoryItem Property

[image]

Pastel Evolution SDK
JobDetail..::..InventoryItem Property
JobDetail Class See Also Send Feedback
Gets or sets the line's inventory item. Maps directly to the Account property but null if invalid.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public InventoryItem InventoryItem { get; set; }
Visual Basic
Public Property InventoryItem As InventoryItem
    Get
    Set

Property Value

Type: InventoryItem

See Also

JobDetail Class
JobDetail Members


JobDetail.InventoryItemID Property

[image]

Pastel Evolution SDK
JobDetail..::..InventoryItemID Property
JobDetail Class See Also Send Feedback
Gets or sets the stock item id.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int InventoryItemID { get; set; }
Visual Basic
Public Property InventoryItemID As Integer
    Get
    Set

Property Value

Type: Int32

Remarks

See Also

JobDetail Class
JobDetail Members
Pastel.Evolution Namespace
JobDetail..::..InventoryItem


JobDetail.Kind Property

[image]

Pastel Evolution SDK
JobDetail..::..Kind Property
JobDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public JobDetail..::..TransactionKind Kind { get; }
Visual Basic
Public ReadOnly Property Kind As JobDetail..::..TransactionKind
    Get

Property Value

Type: JobDetail..::..TransactionKind

See Also

JobDetail Class
JobDetail Members


JobDetail.LongID Property

[image]

Pastel Evolution SDK
JobDetail..::..LongID Property
JobDetail Class See Also Send Feedback
Transitional accessor.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public long LongID { get; }
Visual Basic
Public ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

JobDetail Class
JobDetail Members


JobDetail.Lot Property

[image]

Pastel Evolution SDK
JobDetail..::..Lot Property
JobDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Lot Lot { get; set; }
Visual Basic
Public Property Lot As Lot
    Get
    Set

Property Value

Type: Lot

See Also

JobDetail Class
JobDetail Members


JobDetail.LotID Property

[image]

Pastel Evolution SDK
JobDetail..::..LotID Property
JobDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int LotID { get; set; }
Visual Basic
Public Property LotID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

JobDetail Class
JobDetail Members


JobDetail.Project Property

[image]

Pastel Evolution SDK
JobDetail..::..Project Property
JobDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Project Project { get; set; }
Visual Basic
Public Property Project As Project
    Get
    Set

Property Value

Type: Project

See Also

JobDetail Class
JobDetail Members


JobDetail.ProjectID Property

[image]

Pastel Evolution SDK
JobDetail..::..ProjectID Property
JobDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int ProjectID { get; set; }
Visual Basic
Public Property ProjectID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

JobDetail Class
JobDetail Members


JobDetail.PurchasesTaxRate Property

[image]

Pastel Evolution SDK
JobDetail..::..PurchasesTaxRate Property
JobDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public TaxRate PurchasesTaxRate { get; set; }
Visual Basic
Public Property PurchasesTaxRate As TaxRate
    Get
    Set

Property Value

Type: TaxRate

See Also

JobDetail Class
JobDetail Members


JobDetail.PurchasesTotalTax Property

[image]

Pastel Evolution SDK
JobDetail..::..PurchasesTotalTax Property
JobDetail Class See Also Send Feedback
Gets the calculated line total tax.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double PurchasesTotalTax { get; }
Visual Basic
Public ReadOnly Property PurchasesTotalTax As Double
    Get

Property Value

Type: Double

See Also

JobDetail Class
JobDetail Members


JobDetail.Quantity Property

[image]

Pastel Evolution SDK
JobDetail..::..Quantity Property
JobDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double Quantity { get; set; }
Visual Basic
Public Property Quantity As Double
    Get
    Set

Property Value

Type: Double

See Also

JobDetail Class
JobDetail Members


JobDetail.QuantityWIP Property

[image]

Pastel Evolution SDK
JobDetail..::..QuantityWIP Property
JobDetail Class See Also Send Feedback
Gets the work in progress quantity held by given detail record. This value gets increased when saving a new active inventory line and decreased by adding negative lines (-Quantity).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double QuantityWIP { get; private set; }
Visual Basic
Public Property QuantityWIP As Double
    Get
    Private Set

Property Value

Type: Double

See Also

JobDetail Class
JobDetail Members


JobDetail.Reference Property

[image]

Pastel Evolution SDK
JobDetail..::..Reference Property
JobDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Reference { get; set; }
Visual Basic
Public Property Reference As String
    Get
    Set

Property Value

Type: String

See Also

JobDetail Class
JobDetail Members


JobDetail.SalesRepresentative Property

[image]

Pastel Evolution SDK
JobDetail..::..SalesRepresentative Property
JobDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public SalesRepresentative SalesRepresentative { get; set; }
Visual Basic
Public Property SalesRepresentative As SalesRepresentative
    Get
    Set

Property Value

Type: SalesRepresentative

See Also

JobDetail Class
JobDetail Members


JobDetail.SalesRepresentativeID Property

[image]

Pastel Evolution SDK
JobDetail..::..SalesRepresentativeID Property
JobDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int SalesRepresentativeID { get; set; }
Visual Basic
Public Property SalesRepresentativeID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

JobDetail Class
JobDetail Members


JobDetail.SalesTaxRate Property

[image]

Pastel Evolution SDK
JobDetail..::..SalesTaxRate Property
JobDetail Class See Also Send Feedback
Sales tax type

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public TaxRate SalesTaxRate { get; set; }
Visual Basic
Public Property SalesTaxRate As TaxRate
    Get
    Set

Property Value

Type: TaxRate

See Also

JobDetail Class
JobDetail Members


JobDetail.SalesTotalExcl Property

[image]

Pastel Evolution SDK
JobDetail..::..SalesTotalExcl Property
JobDetail Class See Also Send Feedback
Gets the calculated line total

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double SalesTotalExcl { get; }
Visual Basic
Public ReadOnly Property SalesTotalExcl As Double
    Get

Property Value

Type: Double

See Also

JobDetail Class
JobDetail Members


JobDetail.SalesTotalIncl Property

[image]

Pastel Evolution SDK
JobDetail..::..SalesTotalIncl Property
JobDetail Class See Also Send Feedback
Gets the calculated line total

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double SalesTotalIncl { get; }
Visual Basic
Public ReadOnly Property SalesTotalIncl As Double
    Get

Property Value

Type: Double

See Also

JobDetail Class
JobDetail Members


JobDetail.SalesTotalTax Property

[image]

Pastel Evolution SDK
JobDetail..::..SalesTotalTax Property
JobDetail Class See Also Send Feedback
Gets the calculated line total

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double SalesTotalTax { get; }
Visual Basic
Public ReadOnly Property SalesTotalTax As Double
    Get

Property Value

Type: Double

See Also

JobDetail Class
JobDetail Members


JobDetail.SerialNumbers Property

[image]

Pastel Evolution SDK
JobDetail..::..SerialNumbers Property
JobDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public SerialNumberCollection SerialNumbers { get; }
Visual Basic
Public ReadOnly Property SerialNumbers As SerialNumberCollection
    Get

Property Value

Type: SerialNumberCollection

See Also

JobDetail Class
JobDetail Members


JobDetail.Source Property

[image]

Pastel Evolution SDK
JobDetail..::..Source Property
JobDetail Class See Also Send Feedback
Gets the transaction source, decided by the Account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public JobDetail..::..TransactionSource Source { get; internal set; }
Visual Basic
Public Property Source As JobDetail..::..TransactionSource
    Get
    Friend Set

Property Value

Type: JobDetail..::..TransactionSource

See Also

JobDetail Class
JobDetail Members


JobDetail.StartDate Property

[image]

Pastel Evolution SDK
JobDetail..::..StartDate Property
JobDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DateTime StartDate { get; set; }
Visual Basic
Public Property StartDate As DateTime
    Get
    Set

Property Value

Type: DateTime

See Also

JobDetail Class
JobDetail Members


JobDetail.Status Property

[image]

Pastel Evolution SDK
JobDetail..::..Status Property
JobDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public JobCard..::..JobStatus Status { get; set; }
Visual Basic
Public Property Status As JobCard..::..JobStatus
    Get
    Set

Property Value

Type: JobCard..::..JobStatus

See Also

JobDetail Class
JobDetail Members


JobDetail.StockingUnitQuantity Property

[image]

Pastel Evolution SDK
JobDetail..::..StockingUnitQuantity Property
JobDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double StockingUnitQuantity { get; set; }
Visual Basic
Public Property StockingUnitQuantity As Double
    Get
    Set

Property Value

Type: Double

See Also

JobDetail Class
JobDetail Members


JobDetail.StockingUnitQuantityWIP Property

[image]

Pastel Evolution SDK
JobDetail..::..StockingUnitQuantityWIP Property
JobDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double StockingUnitQuantityWIP { get; private set; }
Visual Basic
Public Property StockingUnitQuantityWIP As Double
    Get
    Private Set

Property Value

Type: Double

See Also

JobDetail Class
JobDetail Members


JobDetail.TotalCost Property

[image]

Pastel Evolution SDK
JobDetail..::..TotalCost Property
JobDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalCost { get; }
Visual Basic
Public ReadOnly Property TotalCost As Double
    Get

Property Value

Type: Double

See Also

JobDetail Class
JobDetail Members


JobDetail.TransactionCode Property

[image]

Pastel Evolution SDK
JobDetail..::..TransactionCode Property
JobDetail Class See Also Send Feedback
Gets or sets the job costing transaction type associate with the detail record. When setting the transaction type, the cost and sales tax types will default to those set on the transaction type.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public JobTransactionCode TransactionCode { get; set; }
Visual Basic
Public Property TransactionCode As JobTransactionCode
    Get
    Set

Property Value

Type: JobTransactionCode

See Also

JobDetail Class
JobDetail Members


JobDetail.Unit Property

[image]

Pastel Evolution SDK
JobDetail..::..Unit Property
JobDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Unit Unit { get; set; }
Visual Basic
Public Property Unit As Unit
    Get
    Set

Property Value

Type: Unit

See Also

JobDetail Class
JobDetail Members


JobDetail.UnitCostPrice Property

[image]

Pastel Evolution SDK
JobDetail..::..UnitCostPrice Property
JobDetail Class See Also Send Feedback
Gets or sets the tax exclusive unit cost price. For new records, setting this value will also set BudgetUnitCostPrice.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double UnitCostPrice { get; set; }
Visual Basic
Public Property UnitCostPrice As Double
    Get
    Set

Property Value

Type: Double

Remarks

Set positive, even for negative quantities.

See Also

JobDetail Class
JobDetail Members


JobDetail.UnitID Property

[image]

Pastel Evolution SDK
JobDetail..::..UnitID Property
JobDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int UnitID { get; set; }
Visual Basic
Public Property UnitID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

JobDetail Class
JobDetail Members


JobDetail.UnitSellingPrice Property

[image]

Pastel Evolution SDK
JobDetail..::..UnitSellingPrice Property
JobDetail Class See Also Send Feedback
Gets or sets the tax exclusive unit selling price. For new records, setting this value will also set BudgetUnitSellingPrice.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double UnitSellingPrice { get; set; }
Visual Basic
Public Property UnitSellingPrice As Double
    Get
    Set

Property Value

Type: Double

See Also

JobDetail Class
JobDetail Members


JobDetail.UserFields Property

[image]

Pastel Evolution SDK
JobDetail..::..UserFields Property
JobDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public FieldCollection UserFields { get; }
Visual Basic
Public ReadOnly Property UserFields As FieldCollection
    Get

Property Value

Type: FieldCollection

See Also

JobDetail Class
JobDetail Members


JobDetail.Warehouse Property

[image]

Pastel Evolution SDK
JobDetail..::..Warehouse Property
JobDetail Class See Also Send Feedback
Gets or sets the warehouse relevant to this detail record. Set the warehouse only after setting the inventory item. The Warehouse and WarehouseContext properties are mapped to one another.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Warehouse Warehouse { get; set; }
Visual Basic
Public Property Warehouse As Warehouse
    Get
    Set

Property Value

Type: Warehouse

See Also

JobDetail Class
JobDetail Members


JobDetail.WarehouseContext Property

[image]

Pastel Evolution SDK
JobDetail..::..WarehouseContext Property
JobDetail Class See Also Send Feedback
Gets or sets the warehouse link of the stock item specified.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public WarehouseContext WarehouseContext { get; set; }
Visual Basic
Public Property WarehouseContext As WarehouseContext
    Get
    Set

Property Value

Type: WarehouseContext

See Also

JobDetail Class
JobDetail Members


JobDetail.WarehouseData Property

[image]

Pastel Evolution SDK
JobDetail..::..WarehouseData Property
JobDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
[ObsoleteAttribute("Use WarehouseContext instead.")]
public WarehouseContext WarehouseData { get; set; }
Visual Basic
<ObsoleteAttribute("Use WarehouseContext instead.")>
Public Property WarehouseData As WarehouseContext
    Get
    Set

Property Value

Type: WarehouseContext

See Also

JobDetail Class
JobDetail Members


JobDetail.WarehouseID Property

[image]

Pastel Evolution SDK
JobDetail..::..WarehouseID Property
JobDetail Class See Also Send Feedback
Gets the ID of the assigned warehouse (0 if N/A).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int WarehouseID { get; }
Visual Basic
Public ReadOnly Property WarehouseID As Integer
    Get

Property Value

Type: Int32

See Also

JobDetail Class
JobDetail Members


JobDetail.Worker Property

[image]

Pastel Evolution SDK
JobDetail..::..Worker Property
JobDetail Class See Also Send Feedback
Gets or sets the line's worker. Maps directly to the Account property but null if invalid.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Worker Worker { get; set; }
Visual Basic
Public Property Worker As Worker
    Get
    Set

Property Value

Type: Worker

See Also

JobDetail Class
JobDetail Members


JobDetail.WorkerID Property

[image]

Pastel Evolution SDK
JobDetail..::..WorkerID Property
JobDetail Class See Also Send Feedback
Gets or sets the worker id.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int WorkerID { get; set; }
Visual Basic
Public Property WorkerID As Integer
    Get
    Set

Property Value

Type: Int32

Remarks

See Also

JobDetail Class
JobDetail Members
Pastel.Evolution Namespace
JobDetail..::..InventoryItem


JobDetail.TransactionKind Enumeration

[image]

Pastel Evolution SDK
JobDetail..::..TransactionKind Enumeration
JobDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public enum TransactionKind
Visual Basic
Public Enumeration TransactionKind

Members

Member name | Value | Description
Removal | 0 |
Addition | 1 |

See Also

Pastel.Evolution Namespace


JobDetail.TransactionSource Enumeration

[image]

Pastel Evolution SDK
JobDetail..::..TransactionSource Enumeration
JobDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public enum TransactionSource
Visual Basic
Public Enumeration TransactionSource

Members

Member name | Value | Description
Inventory | 0 |
Payables | 1 |
Ledger | 2 |
Payroll | 3 |

See Also

Pastel.Evolution Namespace


JobDetailCollection Class

[image]

Pastel Evolution SDK
JobDetailCollection Class
Members See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class JobDetailCollection : CollectionBase
Visual Basic
Public Class JobDetailCollection
    Inherits CollectionBase

Inheritance Hierarchy

System..::..Object
System.Collections..::..CollectionBase
Pastel.Evolution..::..JobDetailCollection

See Also

JobDetailCollection Members


JobDetailCollection Members

[image] [image]

Pastel Evolution SDK
JobDetailCollection Members
JobDetailCollection Class Constructors Methods Properties Events See Also Send Feedback

The JobDetailCollection type exposes the following members.

Constructors

 | Name | Description
Public method | JobDetailCollection | Initializes a new instance of the JobDetailCollection class

Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Public method | OnCollectionChanged |
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove |
Public method | RemoveAt |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item |
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

Events

 | Name | Description
Public event | CollectionChanged | Occurs when detail records are added or deleted.

See Also

JobDetailCollection Class


JobDetailCollection Constructor

[image]

Pastel Evolution SDK
JobDetailCollection Constructor
JobDetailCollection Class See Also Send Feedback
Initializes a new instance of the JobDetailCollection class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public JobDetailCollection(
    JobCard parentDocument
)
Visual Basic
Public Sub New (
    parentDocument As JobCard
)

Parameters

parentDocument
Type: Pastel.Evolution..::..JobCard

See Also

JobDetailCollection Class
JobDetailCollection Members


JobDetailCollection Methods

[image] [image]

Pastel Evolution SDK
JobDetailCollection Methods
JobDetailCollection Class See Also Send Feedback

The JobDetailCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Public method | OnCollectionChanged |
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove |
Public method | RemoveAt |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

JobDetailCollection Class


JobDetailCollection.Add Method

[image]

Pastel Evolution SDK
JobDetailCollection..::..Add Method
JobDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void Add(
    JobDetail detailRecord
)
Visual Basic
Public Sub Add (
    detailRecord As JobDetail
)

Parameters

detailRecord
Type: Pastel.Evolution..::..JobDetail

See Also

JobDetailCollection Class
JobDetailCollection Members


JobDetailCollection.OnCollectionChanged Method

[image]

Pastel Evolution SDK
JobDetailCollection..::..OnCollectionChanged Method
JobDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void OnCollectionChanged(
    JobDetailCollection..::..JobDetailCollectionChangedEventArgs e
)
Visual Basic
Public Sub OnCollectionChanged (
    e As JobDetailCollection..::..JobDetailCollectionChangedEventArgs
)

Parameters

e
Type: Pastel.Evolution..::..JobDetailCollection..::..JobDetailCollectionChangedEventArgs

See Also

JobDetailCollection Class
JobDetailCollection Members


JobDetailCollection.Remove Method

[image]

Pastel Evolution SDK
JobDetailCollection..::..Remove Method
JobDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void Remove(
    JobDetail detailRecord
)
Visual Basic
Public Sub Remove (
    detailRecord As JobDetail
)

Parameters

detailRecord
Type: Pastel.Evolution..::..JobDetail

See Also

JobDetailCollection Class
JobDetailCollection Members


JobDetailCollection.RemoveAt Method

[image]

Pastel Evolution SDK
JobDetailCollection..::..RemoveAt Method
JobDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void RemoveAt(
    int index
)
Visual Basic
Public Sub RemoveAt (
    index As Integer
)

Parameters

index
Type: System..::..Int32

See Also

JobDetailCollection Class
JobDetailCollection Members


JobDetailCollection Properties

[image] [image]

Pastel Evolution SDK
JobDetailCollection Properties
JobDetailCollection Class See Also Send Feedback

The JobDetailCollection type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item |
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

JobDetailCollection Class


JobDetailCollection.Item Property

[image]

Pastel Evolution SDK
JobDetailCollection..::..Item Property
JobDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public JobDetail this[
    int index
] { get; set; }
Visual Basic
Public Default Property Item (
    index As Integer
) As JobDetail
    Get
    Set

Parameters

index
Type: System..::..Int32

Property Value

Type: JobDetail

See Also

JobDetailCollection Class
JobDetailCollection Members


JobDetailCollection Events

[image] [image]

Pastel Evolution SDK
JobDetailCollection Events
JobDetailCollection Class See Also Send Feedback

The JobDetailCollection type exposes the following members.

Events

 | Name | Description
Public event | CollectionChanged | Occurs when detail records are added or deleted.

See Also

JobDetailCollection Class


JobDetailCollection.CollectionChanged Event

[image]

Pastel Evolution SDK
JobDetailCollection..::..CollectionChanged Event
JobDetailCollection Class See Also Send Feedback
Occurs when detail records are added or deleted.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public event JobDetailCollection..::..JobDetailChangedEventHandler CollectionChanged
Visual Basic
Public Event CollectionChanged As JobDetailCollection..::..JobDetailChangedEventHandler

Value

Type: Pastel.Evolution..::..JobDetailCollection..::..JobDetailChangedEventHandler

See Also

JobDetailCollection Class
JobDetailCollection Members


JobDetailCollection.JobDetailChangeAction Enumeration

[image]

Pastel Evolution SDK
JobDetailCollection..::..JobDetailChangeAction Enumeration
JobDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public enum JobDetailChangeAction
Visual Basic
Public Enumeration JobDetailChangeAction

Members

Member name | Value | Description
Added | 0 |
Deleted | 1 |

See Also

Pastel.Evolution Namespace


JobDetailCollection.JobDetailChangedEventHandler Delegate

[image]

Pastel Evolution SDK
JobDetailCollection..::..JobDetailChangedEventHandler Delegate
JobDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public delegate void JobDetailChangedEventHandler(
    Object sender,
    JobDetailCollection..::..JobDetailCollectionChangedEventArgs e
)
Visual Basic
Public Delegate Sub JobDetailChangedEventHandler (
    sender As Object,
    e As JobDetailCollection..::..JobDetailCollectionChangedEventArgs
)

Parameters

sender
Type: System..::..Object
e
Type: Pastel.Evolution..::..JobDetailCollection..::..JobDetailCollectionChangedEventArgs

See Also

Pastel.Evolution Namespace


JobDetailCollection.JobDetailCollectionChangedEventArgs Class

[image]

Pastel Evolution SDK
JobDetailCollection..::..JobDetailCollectionChangedEventArgs Class
JobDetailCollection Class Members See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class JobDetailCollectionChangedEventArgs : EventArgs
Visual Basic
Public Class JobDetailCollectionChangedEventArgs
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Pastel.Evolution..::..JobDetailCollection..::..JobDetailCollectionChangedEventArgs

See Also

JobDetailCollection..::..JobDetailCollectionChangedEventArgs Members


JobDetailCollection.JobDetailCollectionChangedEventArgs Members

[image] [image]

Pastel Evolution SDK
JobDetailCollection..::..JobDetailCollectionChangedEventArgs Members
JobDetailCollection..::..JobDetailCollectionChangedEventArgs Class Constructors Methods Fields See Also Send Feedback

The JobDetailCollection..::..JobDetailCollectionChangedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | JobDetailCollection..::..JobDetailCollectionChangedEventArgs | Initializes a new instance of the JobDetailCollection..::..JobDetailCollectionChangedEventArgs class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | Action |
Public field | DetailRecord |

See Also

JobDetailCollection..::..JobDetailCollectionChangedEventArgs Class


JobDetailCollection.JobDetailCollectionChangedEventArgs Constructor

[image]

Pastel Evolution SDK
JobDetailCollection..::..JobDetailCollectionChangedEventArgs Constructor
JobDetailCollection..::..JobDetailCollectionChangedEventArgs Class See Also Send Feedback
Initializes a new instance of the JobDetailCollection..::..JobDetailCollectionChangedEventArgs class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public JobDetailCollectionChangedEventArgs(
    JobDetail detailRecord,
    JobDetailCollection..::..JobDetailChangeAction action
)
Visual Basic
Public Sub New (
    detailRecord As JobDetail,
    action As JobDetailCollection..::..JobDetailChangeAction
)

Parameters

detailRecord
Type: Pastel.Evolution..::..JobDetail
action
Type: Pastel.Evolution..::..JobDetailCollection..::..JobDetailChangeAction

See Also

JobDetailCollection..::..JobDetailCollectionChangedEventArgs Class
JobDetailCollection..::..JobDetailCollectionChangedEventArgs Members


JobDetailCollection.JobDetailCollectionChangedEventArgs Fields

[image] [image]

Pastel Evolution SDK
JobDetailCollection..::..JobDetailCollectionChangedEventArgs Fields
JobDetailCollection..::..JobDetailCollectionChangedEventArgs Class See Also Send Feedback

The JobDetailCollection..::..JobDetailCollectionChangedEventArgs type exposes the following members.

Fields

 | Name | Description
Public field | Action |
Public field | DetailRecord |

See Also

JobDetailCollection..::..JobDetailCollectionChangedEventArgs Class


JobDetailCollection.JobDetailCollectionChangedEventArgs.Action Field

[image]

Pastel Evolution SDK
JobDetailCollection..::..JobDetailCollectionChangedEventArgs..::..Action Field
JobDetailCollection..::..JobDetailCollectionChangedEventArgs Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public JobDetailCollection..::..JobDetailChangeAction Action
Visual Basic
Public Action As JobDetailCollection..::..JobDetailChangeAction

Field Value

Type: JobDetailCollection..::..JobDetailChangeAction

See Also

JobDetailCollection..::..JobDetailCollectionChangedEventArgs Class
JobDetailCollection..::..JobDetailCollectionChangedEventArgs Members


JobDetailCollection.JobDetailCollectionChangedEventArgs.DetailRecord Field

[image]

Pastel Evolution SDK
JobDetailCollection..::..JobDetailCollectionChangedEventArgs..::..DetailRecord Field
JobDetailCollection..::..JobDetailCollectionChangedEventArgs Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public JobDetail DetailRecord
Visual Basic
Public DetailRecord As JobDetail

Field Value

Type: JobDetail

See Also

JobDetailCollection..::..JobDetailCollectionChangedEventArgs Class
JobDetailCollection..::..JobDetailCollectionChangedEventArgs Members


JobDetailCollection.JobDetailCollectionChangedEventArgs Methods

[image] [image]

Pastel Evolution SDK
JobDetailCollection..::..JobDetailCollectionChangedEventArgs Methods
JobDetailCollection..::..JobDetailCollectionChangedEventArgs Class See Also Send Feedback

The JobDetailCollection..::..JobDetailCollectionChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

JobDetailCollection..::..JobDetailCollectionChangedEventArgs Class


JobPostingMethod Enumeration

[image]

Pastel Evolution SDK
JobPostingMethod Enumeration
See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public enum JobPostingMethod
Visual Basic
Public Enumeration JobPostingMethod

Members

Member name | Value | Description
CompletedContract | 0 |
PercentageCompletion | 1 |

See Also

Pastel.Evolution Namespace


JobPostingMethodGLContext Class

[image]

Pastel Evolution SDK
JobPostingMethodGLContext Class
Members See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class JobPostingMethodGLContext
Visual Basic
Public Class JobPostingMethodGLContext

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..JobPostingMethodGLContext

See Also

JobPostingMethodGLContext Members


JobPostingMethodGLContext Members

[image] [image]

Pastel Evolution SDK
JobPostingMethodGLContext Members
JobPostingMethodGLContext Class Constructors Methods Properties See Also Send Feedback

The JobPostingMethodGLContext type exposes the following members.

Constructors

 | Name | Description
Public method | JobPostingMethodGLContext | Initializes a new instance of the JobPostingMethodGLContext class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CostOfSalesGLAccount | Gets the job card posting method's cost of sales general ledger account.
Public property | CustomerControlGLAccount | Gets the job card posting method's customer control general ledger account.
Public property | RecoveryGLAccount | Gets the job card posting method's recovery general ledger account.
Public property | SalesGLAccount | Gets the job card posting method's sales general ledger account.
Public property | StockGLAccount | Gets the job card posting method's stock general ledger account.
Public property | SupplierControlGLAccount | Gets the job card posting method's supplier control general ledger account.
Public property | TaxGLAccount | Gets the job card posting method's tax general ledger account.
Public property | WipGLAccount | Gets the job card posting method's work in progress general ledger account.

See Also

JobPostingMethodGLContext Class


JobPostingMethodGLContext Constructor

[image]

Pastel Evolution SDK
JobPostingMethodGLContext Constructor
JobPostingMethodGLContext Class See Also Send Feedback
Initializes a new instance of the JobPostingMethodGLContext class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public JobPostingMethodGLContext(
    JobPostingMethod PostingMethod,
    int WipGLAccountID,
    int RecoveryGLAccountID,
    int TaxGLAccountID,
    int StockGLAccountID,
    int CreditorGLAccountID,
    int SalesGLAccountID,
    int CosGLAccountID,
    int DebtorGLAccountID
)
Visual Basic
Public Sub New (
    PostingMethod As JobPostingMethod,
    WipGLAccountID As Integer,
    RecoveryGLAccountID As Integer,
    TaxGLAccountID As Integer,
    StockGLAccountID As Integer,
    CreditorGLAccountID As Integer,
    SalesGLAccountID As Integer,
    CosGLAccountID As Integer,
    DebtorGLAccountID As Integer
)

Parameters

PostingMethod
Type: Pastel.Evolution..::..JobPostingMethod
WipGLAccountID
Type: System..::..Int32
RecoveryGLAccountID
Type: System..::..Int32
TaxGLAccountID
Type: System..::..Int32
StockGLAccountID
Type: System..::..Int32
CreditorGLAccountID
Type: System..::..Int32
SalesGLAccountID
Type: System..::..Int32
CosGLAccountID
Type: System..::..Int32
DebtorGLAccountID
Type: System..::..Int32

See Also

JobPostingMethodGLContext Class
JobPostingMethodGLContext Members


JobPostingMethodGLContext Methods

[image] [image]

Pastel Evolution SDK
JobPostingMethodGLContext Methods
JobPostingMethodGLContext Class See Also Send Feedback

The JobPostingMethodGLContext type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

JobPostingMethodGLContext Class


JobPostingMethodGLContext Properties

[image] [image]

Pastel Evolution SDK
JobPostingMethodGLContext Properties
JobPostingMethodGLContext Class See Also Send Feedback

The JobPostingMethodGLContext type exposes the following members.

Properties

 | Name | Description
Public property | CostOfSalesGLAccount | Gets the job card posting method's cost of sales general ledger account.
Public property | CustomerControlGLAccount | Gets the job card posting method's customer control general ledger account.
Public property | RecoveryGLAccount | Gets the job card posting method's recovery general ledger account.
Public property | SalesGLAccount | Gets the job card posting method's sales general ledger account.
Public property | StockGLAccount | Gets the job card posting method's stock general ledger account.
Public property | SupplierControlGLAccount | Gets the job card posting method's supplier control general ledger account.
Public property | TaxGLAccount | Gets the job card posting method's tax general ledger account.
Public property | WipGLAccount | Gets the job card posting method's work in progress general ledger account.

See Also

JobPostingMethodGLContext Class


JobPostingMethodGLContext.CostOfSalesGLAccount Property

[image]

Pastel Evolution SDK
JobPostingMethodGLContext..::..CostOfSalesGLAccount Property
JobPostingMethodGLContext Class See Also Send Feedback
Gets the job card posting method's cost of sales general ledger account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLAccount CostOfSalesGLAccount { get; }
Visual Basic
Public ReadOnly Property CostOfSalesGLAccount As GLAccount
    Get

Return Value

Type: GLAccount
GLAccount

See Also

JobPostingMethodGLContext Class
JobPostingMethodGLContext Members


JobPostingMethodGLContext.CustomerControlGLAccount Property

[image]

Pastel Evolution SDK
JobPostingMethodGLContext..::..CustomerControlGLAccount Property
JobPostingMethodGLContext Class See Also Send Feedback
Gets the job card posting method's customer control general ledger account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLAccount CustomerControlGLAccount { get; }
Visual Basic
Public ReadOnly Property CustomerControlGLAccount As GLAccount
    Get

Return Value

Type: GLAccount
GLAccount

See Also

JobPostingMethodGLContext Class
JobPostingMethodGLContext Members


JobPostingMethodGLContext.RecoveryGLAccount Property

[image]

Pastel Evolution SDK
JobPostingMethodGLContext..::..RecoveryGLAccount Property
JobPostingMethodGLContext Class See Also Send Feedback
Gets the job card posting method's recovery general ledger account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLAccount RecoveryGLAccount { get; }
Visual Basic
Public ReadOnly Property RecoveryGLAccount As GLAccount
    Get

Return Value

Type: GLAccount
GLAccount

See Also

JobPostingMethodGLContext Class
JobPostingMethodGLContext Members


JobPostingMethodGLContext.SalesGLAccount Property

[image]

Pastel Evolution SDK
JobPostingMethodGLContext..::..SalesGLAccount Property
JobPostingMethodGLContext Class See Also Send Feedback
Gets the job card posting method's sales general ledger account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLAccount SalesGLAccount { get; }
Visual Basic
Public ReadOnly Property SalesGLAccount As GLAccount
    Get

Return Value

Type: GLAccount
GLAccount

See Also

JobPostingMethodGLContext Class
JobPostingMethodGLContext Members


JobPostingMethodGLContext.StockGLAccount Property

[image]

Pastel Evolution SDK
JobPostingMethodGLContext..::..StockGLAccount Property
JobPostingMethodGLContext Class See Also Send Feedback
Gets the job card posting method's stock general ledger account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLAccount StockGLAccount { get; }
Visual Basic
Public ReadOnly Property StockGLAccount As GLAccount
    Get

Return Value

Type: GLAccount
GLAccount

See Also

JobPostingMethodGLContext Class
JobPostingMethodGLContext Members


JobPostingMethodGLContext.SupplierControlGLAccount Property

[image]

Pastel Evolution SDK
JobPostingMethodGLContext..::..SupplierControlGLAccount Property
JobPostingMethodGLContext Class See Also Send Feedback
Gets the job card posting method's supplier control general ledger account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLAccount SupplierControlGLAccount { get; }
Visual Basic
Public ReadOnly Property SupplierControlGLAccount As GLAccount
    Get

Return Value

Type: GLAccount
GLAccount

See Also

JobPostingMethodGLContext Class
JobPostingMethodGLContext Members


JobPostingMethodGLContext.TaxGLAccount Property

[image]

Pastel Evolution SDK
JobPostingMethodGLContext..::..TaxGLAccount Property
JobPostingMethodGLContext Class See Also Send Feedback
Gets the job card posting method's tax general ledger account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLAccount TaxGLAccount { get; }
Visual Basic
Public ReadOnly Property TaxGLAccount As GLAccount
    Get

Return Value

Type: GLAccount
GLAccount

See Also

JobPostingMethodGLContext Class
JobPostingMethodGLContext Members


JobPostingMethodGLContext.WipGLAccount Property

[image]

Pastel Evolution SDK
JobPostingMethodGLContext..::..WipGLAccount Property
JobPostingMethodGLContext Class See Also Send Feedback
Gets the job card posting method's work in progress general ledger account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLAccount WipGLAccount { get; }
Visual Basic
Public ReadOnly Property WipGLAccount As GLAccount
    Get

Return Value

Type: GLAccount
GLAccount

See Also

JobPostingMethodGLContext Class
JobPostingMethodGLContext Members


JobPostingMethodGLContextCollection Class

[image]

Pastel Evolution SDK
JobPostingMethodGLContextCollection Class
Members See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class JobPostingMethodGLContextCollection : CollectionBase
Visual Basic
Public Class JobPostingMethodGLContextCollection
    Inherits CollectionBase

Inheritance Hierarchy

System..::..Object
System.Collections..::..CollectionBase
Pastel.Evolution..::..JobPostingMethodGLContextCollection

See Also

JobPostingMethodGLContextCollection Members


JobPostingMethodGLContextCollection Members

[image] [image]

Pastel Evolution SDK
JobPostingMethodGLContextCollection Members
JobPostingMethodGLContextCollection Class Constructors Methods Properties See Also Send Feedback

The JobPostingMethodGLContextCollection type exposes the following members.

Constructors

 | Name | Description
Public method | JobPostingMethodGLContextCollection | Initializes a new instance of the JobPostingMethodGLContextCollection class

Methods

 | Name | Description
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | Gets the job card posting method context object for the posting method supplied.
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

JobPostingMethodGLContextCollection Class


JobPostingMethodGLContextCollection Constructor

[image]

Pastel Evolution SDK
JobPostingMethodGLContextCollection Constructor
JobPostingMethodGLContextCollection Class See Also Send Feedback
Initializes a new instance of the JobPostingMethodGLContextCollection class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public JobPostingMethodGLContextCollection()
Visual Basic
Public Sub New

See Also

JobPostingMethodGLContextCollection Class
JobPostingMethodGLContextCollection Members


JobPostingMethodGLContextCollection Methods

[image] [image]

Pastel Evolution SDK
JobPostingMethodGLContextCollection Methods
JobPostingMethodGLContextCollection Class See Also Send Feedback

The JobPostingMethodGLContextCollection type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

JobPostingMethodGLContextCollection Class


JobPostingMethodGLContextCollection Properties

[image] [image]

Pastel Evolution SDK
JobPostingMethodGLContextCollection Properties
JobPostingMethodGLContextCollection Class See Also Send Feedback

The JobPostingMethodGLContextCollection type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | Gets the job card posting method context object for the posting method supplied.
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

JobPostingMethodGLContextCollection Class


JobPostingMethodGLContextCollection.Item Property

[image]

Pastel Evolution SDK
JobPostingMethodGLContextCollection..::..Item Property
JobPostingMethodGLContextCollection Class See Also Send Feedback
Gets the job card posting method context object for the posting method supplied.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public JobPostingMethodGLContext this[
    JobPostingMethod jobPostingMethod
] { get; }
Visual Basic
Public ReadOnly Default Property Item (
    jobPostingMethod As JobPostingMethod
) As JobPostingMethodGLContext
    Get

Parameters

jobPostingMethod
Type: Pastel.Evolution..::..JobPostingMethod

Return Value

Type: JobPostingMethodGLContext

See Also

JobPostingMethodGLContextCollection Class
JobPostingMethodGLContextCollection Members


JobStatus Enumeration

[image]

Pastel Evolution SDK
JobStatus Enumeration
See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public enum JobStatus
Visual Basic
Public Enumeration JobStatus

Members

Member name | Value | Description
Quote | 0 |
Active | 1 |
Completed | 2 |

See Also

Pastel.Evolution Namespace


JobTransactionCode Class

[image]

Pastel Evolution SDK
JobTransactionCode Class
Members See Also Send Feedback
Represents a job costing transaction code.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class JobTransactionCode : TransactionCodeBase
Visual Basic
Public Class JobTransactionCode
    Inherits TransactionCodeBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..TransactionCodeBase
Pastel.Evolution..::..JobTransactionCode

See Also

JobTransactionCode Members


JobTransactionCode Members

[image] [image]

Pastel Evolution SDK
JobTransactionCode Members
JobTransactionCode Class Constructors Methods Fields Properties See Also Send Feedback

The JobTransactionCode type exposes the following members.

Constructors

 | Name | Description
Public method | JobTransactionCode()()()() | Initializes a new instance of the JobTransactionCode class
Public method | JobTransactionCode(Int32) | Initializes a new instance of the JobTransactionCode class
Public method | JobTransactionCode(JobDetail..::..TransactionSource, String) | Initializes a new instance of the JobTransactionCode class

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find |
 | FindByCode(String) | Attempts to find a record by its code and returns its ID.
 | FindByCode(JobDetail..::..TransactionSource, String) | Attempts to find a record by its code and returns its ID.
 | Get | Returns the [first] inventory item object with the criteria specified; otherwise, returns null.
 | GetByCode | Returns a transaction type object corresponding to the code and transaction source specified; otherwise, returns null.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | reversed | (Inherited from TransactionCodeBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | APControlAccount |
Public property | APControlAccountID |
Public property | ARControlAccount |
Public property | ARControlAccountID |
Public property | AsTransactionCode | Gets the basic transaction code object (of type TransactionCodeBase), cast as a proper TransactionCode object. (Inherited from TransactionCodeBase.)
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Code | (Overrides TransactionCodeBase..::..Code.)
Public property | CosAccount |
Public property | CostingTaxType |
Public property | CostingTaxTypeID |
Public property | Description | (Overrides TransactionCodeBase..::..Description.)
Public property | GLAccounts |
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | RecoveryAccount |
Protected property | Reversed | (Inherited from TransactionCodeBase.)
Public property | SalesTaxTypeID |
Public property | SellingTaxType |
Public property | Source |
Public property | StockAccount |
Public property | StockAccountID |
Public property | TaxAccount |
Public property | WIPAccount |
Public property | WIPAccountID |

See Also

JobTransactionCode Class


JobTransactionCode Constructor

[image] [image]

Pastel Evolution SDK
JobTransactionCode Constructor
JobTransactionCode Class See Also Send Feedback

Overload List

 | Name | Description
Public method | JobTransactionCode()()()() | Initializes a new instance of the JobTransactionCode class
Public method | JobTransactionCode(Int32) | Initializes a new instance of the JobTransactionCode class
Public method | JobTransactionCode(JobDetail..::..TransactionSource, String) | Initializes a new instance of the JobTransactionCode class

See Also

JobTransactionCode Class
JobTransactionCode Members


JobTransactionCode Constructor

[image]

Pastel Evolution SDK
JobTransactionCode Constructor
JobTransactionCode Class See Also Send Feedback
Initializes a new instance of the JobTransactionCode class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public JobTransactionCode()
Visual Basic
Public Sub New

See Also

JobTransactionCode Class
JobTransactionCode Members
JobTransactionCode Overload


JobTransactionCode Constructor (Int32)

[image]

Pastel Evolution SDK
JobTransactionCode Constructor (Int32)
JobTransactionCode Class See Also Send Feedback
Initializes a new instance of the JobTransactionCode class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public JobTransactionCode(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32

See Also

JobTransactionCode Class
JobTransactionCode Members
JobTransactionCode Overload


JobTransactionCode Constructor (JobDetail.TransactionSource, String)

[image]

Pastel Evolution SDK
JobTransactionCode Constructor (JobDetail..::..TransactionSource, String)
JobTransactionCode Class See Also Send Feedback
Initializes a new instance of the JobTransactionCode class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public JobTransactionCode(
    JobDetail..::..TransactionSource source,
    string code
)
Visual Basic
Public Sub New (
    source As JobDetail..::..TransactionSource,
    code As String
)

Parameters

source
Type: Pastel.Evolution..::..JobDetail..::..TransactionSource
code
Type: System..::..String

See Also

JobTransactionCode Class
JobTransactionCode Members
JobTransactionCode Overload


JobTransactionCode Fields

[image] [image]

Pastel Evolution SDK
JobTransactionCode Fields
JobTransactionCode Class See Also Send Feedback

The JobTransactionCode type exposes the following members.

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | reversed | (Inherited from TransactionCodeBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

JobTransactionCode Class


JobTransactionCode Methods

[image] [image]

Pastel Evolution SDK
JobTransactionCode Methods
JobTransactionCode Class See Also Send Feedback

The JobTransactionCode type exposes the following members.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find |
 | FindByCode(String) | Attempts to find a record by its code and returns its ID.
 | FindByCode(JobDetail..::..TransactionSource, String) | Attempts to find a record by its code and returns its ID.
 | Get | Returns the [first] inventory item object with the criteria specified; otherwise, returns null.
 | GetByCode | Returns a transaction type object corresponding to the code and transaction source specified; otherwise, returns null.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

JobTransactionCode Class


JobTransactionCode.Find Method

[image]

Pastel Evolution SDK
JobTransactionCode..::..Find Method
JobTransactionCode Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String

Return Value

Type: Int32

See Also

JobTransactionCode Class
JobTransactionCode Members


JobTransactionCode.FindByCode Method

[image] [image]

Pastel Evolution SDK
JobTransactionCode..::..FindByCode Method
JobTransactionCode Class See Also Send Feedback

Overload List

Name | Description
FindByCode(String) | Attempts to find a record by its code and returns its ID.
FindByCode(JobDetail..::..TransactionSource, String) | Attempts to find a record by its code and returns its ID.

See Also

JobTransactionCode Class
JobTransactionCode Members


JobTransactionCode.FindByCode Method (String)

[image]

Pastel Evolution SDK
JobTransactionCode..::..FindByCode Method (String)
JobTransactionCode Class See Also Send Feedback
Attempts to find a record by its code and returns its ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int FindByCode(
    string code
)
Visual Basic
Public Shared Function FindByCode (
    code As String
) As Integer

Parameters

code
Type: System..::..String
The code used to lookup the record.

Return Value

Type: Int32
-1 if no record was found, else the id of the first record matching the criteria supplied.

See Also

JobTransactionCode Class
JobTransactionCode Members
FindByCode Overload
Pastel.Evolution Namespace
JobTransactionCode..::..Find(String)


JobTransactionCode.FindByCode Method (JobDetail.TransactionSource, String)

[image]

Pastel Evolution SDK
JobTransactionCode..::..FindByCode Method (JobDetail..::..TransactionSource, String)
JobTransactionCode Class See Also Send Feedback
Attempts to find a record by its code and returns its ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int FindByCode(
    JobDetail..::..TransactionSource source,
    string code
)
Visual Basic
Public Shared Function FindByCode (
    source As JobDetail..::..TransactionSource,
    code As String
) As Integer

Parameters

source
Type: Pastel.Evolution..::..JobDetail..::..TransactionSource
The transaction source by which to filter the transaction listing.
code
Type: System..::..String
The code used to lookup the record.

Return Value

Type: Int32
-1 if no record was found, else the id of the first record matching the criteria supplied.

See Also

JobTransactionCode Class
JobTransactionCode Members
FindByCode Overload
Pastel.Evolution Namespace
JobTransactionCode..::..Find(String)


JobTransactionCode.Get Method

[image]

Pastel Evolution SDK
JobTransactionCode..::..Get Method
JobTransactionCode Class See Also Send Feedback
Returns the [first] inventory item object with the criteria specified; otherwise, returns null.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static JobTransactionCode Get(
    string criteria
)
Visual Basic
Public Shared Function Get (
    criteria As String
) As JobTransactionCode

Parameters

criteria
Type: System..::..String
Eg. Code = 'STO0021' or Description like '%Stone%'

Return Value

Type: JobTransactionCode

See Also

JobTransactionCode Class
JobTransactionCode Members
Pastel.Evolution Namespace
JobTransactionCode..::..Find(String)


JobTransactionCode.GetByCode Method

[image]

Pastel Evolution SDK
JobTransactionCode..::..GetByCode Method
JobTransactionCode Class See Also Send Feedback
Returns a transaction type object corresponding to the code and transaction source specified; otherwise, returns null.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static JobTransactionCode GetByCode(
    JobDetail..::..TransactionSource source,
    string code
)
Visual Basic
Public Shared Function GetByCode (
    source As JobDetail..::..TransactionSource,
    code As String
) As JobTransactionCode

Parameters

source
Type: Pastel.Evolution..::..JobDetail..::..TransactionSource
The transaction source by which to limit code search.
code
Type: System..::..String
The transaction code.

Return Value

Type: JobTransactionCode

See Also

JobTransactionCode Class
JobTransactionCode Members


JobTransactionCode.List Method

[image]

Pastel Evolution SDK
JobTransactionCode..::..List Method
JobTransactionCode Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria
)
Visual Basic
Public Shared Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String

Return Value

Type: DataTable

See Also

JobTransactionCode Class
JobTransactionCode Members


JobTransactionCode.OnDelete Method

[image]

Pastel Evolution SDK
JobTransactionCode..::..OnDelete Method
JobTransactionCode Class See Also Send Feedback
Removes the record from the database, provided it is not referenced by other records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

Exceptions

Exception | Condition
IntegrityViolationException |

See Also

JobTransactionCode Class
JobTransactionCode Members


JobTransactionCode.OnSave Method

[image]

Pastel Evolution SDK
JobTransactionCode..::..OnSave Method
JobTransactionCode Class See Also Send Feedback
Persists the record to the database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

JobTransactionCode Class
JobTransactionCode Members


JobTransactionCode Properties

[image] [image]

Pastel Evolution SDK
JobTransactionCode Properties
JobTransactionCode Class See Also Send Feedback

The JobTransactionCode type exposes the following members.

Properties

 | Name | Description
Public property | APControlAccount |
Public property | APControlAccountID |
Public property | ARControlAccount |
Public property | ARControlAccountID |
Public property | AsTransactionCode | Gets the basic transaction code object (of type TransactionCodeBase), cast as a proper TransactionCode object. (Inherited from TransactionCodeBase.)
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Code | (Overrides TransactionCodeBase..::..Code.)
Public property | CosAccount |
Public property | CostingTaxType |
Public property | CostingTaxTypeID |
Public property | Description | (Overrides TransactionCodeBase..::..Description.)
Public property | GLAccounts |
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | RecoveryAccount |
Protected property | Reversed | (Inherited from TransactionCodeBase.)
Public property | SalesTaxTypeID |
Public property | SellingTaxType |
Public property | Source |
Public property | StockAccount |
Public property | StockAccountID |
Public property | TaxAccount |
Public property | WIPAccount |
Public property | WIPAccountID |

See Also

JobTransactionCode Class


JobTransactionCode.APControlAccount Property

[image]

Pastel Evolution SDK
JobTransactionCode..::..APControlAccount Property
JobTransactionCode Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLAccount APControlAccount { get; set; }
Visual Basic
Public Property APControlAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

See Also

JobTransactionCode Class
JobTransactionCode Members


JobTransactionCode.APControlAccountID Property

[image]

Pastel Evolution SDK
JobTransactionCode..::..APControlAccountID Property
JobTransactionCode Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int APControlAccountID { get; set; }
Visual Basic
Public Property APControlAccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

JobTransactionCode Class
JobTransactionCode Members


JobTransactionCode.ARControlAccount Property

[image]

Pastel Evolution SDK
JobTransactionCode..::..ARControlAccount Property
JobTransactionCode Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLAccount ARControlAccount { get; set; }
Visual Basic
Public Property ARControlAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

See Also

JobTransactionCode Class
JobTransactionCode Members


JobTransactionCode.ARControlAccountID Property

[image]

Pastel Evolution SDK
JobTransactionCode..::..ARControlAccountID Property
JobTransactionCode Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int ARControlAccountID { get; set; }
Visual Basic
Public Property ARControlAccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

JobTransactionCode Class
JobTransactionCode Members


JobTransactionCode.Code Property

[image]

Pastel Evolution SDK
JobTransactionCode..::..Code Property
JobTransactionCode Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override string Code { get; set; }
Visual Basic
Public Overrides Property Code As String
    Get
    Set

Property Value

Type: String

See Also

JobTransactionCode Class
JobTransactionCode Members


JobTransactionCode.CosAccount Property

[image]

Pastel Evolution SDK
JobTransactionCode..::..CosAccount Property
JobTransactionCode Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLAccount CosAccount { get; set; }
Visual Basic
Public Property CosAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

See Also

JobTransactionCode Class
JobTransactionCode Members


JobTransactionCode.CostingTaxType Property

[image]

Pastel Evolution SDK
JobTransactionCode..::..CostingTaxType Property
JobTransactionCode Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public TaxRate CostingTaxType { get; set; }
Visual Basic
Public Property CostingTaxType As TaxRate
    Get
    Set

Property Value

Type: TaxRate

See Also

JobTransactionCode Class
JobTransactionCode Members


JobTransactionCode.CostingTaxTypeID Property

[image]

Pastel Evolution SDK
JobTransactionCode..::..CostingTaxTypeID Property
JobTransactionCode Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int CostingTaxTypeID { get; set; }
Visual Basic
Public Property CostingTaxTypeID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

JobTransactionCode Class
JobTransactionCode Members


JobTransactionCode.Description Property

[image]

Pastel Evolution SDK
JobTransactionCode..::..Description Property
JobTransactionCode Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override string Description { get; set; }
Visual Basic
Public Overrides Property Description As String
    Get
    Set

Property Value

Type: String

See Also

JobTransactionCode Class
JobTransactionCode Members


JobTransactionCode.GLAccounts Property

[image]

Pastel Evolution SDK
JobTransactionCode..::..GLAccounts Property
JobTransactionCode Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public TransactionTypePostingMethodGLContextCollection GLAccounts { get; }
Visual Basic
Public ReadOnly Property GLAccounts As TransactionTypePostingMethodGLContextCollection
    Get

Property Value

Type: TransactionTypePostingMethodGLContextCollection

See Also

JobTransactionCode Class
JobTransactionCode Members


JobTransactionCode.ID Property

[image]

Pastel Evolution SDK
JobTransactionCode..::..ID Property
JobTransactionCode Class See Also Send Feedback
Gets the internal record ID (0 for new, unsaved records).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

See Also

JobTransactionCode Class
JobTransactionCode Members


JobTransactionCode.LongID Property

[image]

Pastel Evolution SDK
JobTransactionCode..::..LongID Property
JobTransactionCode Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

JobTransactionCode Class
JobTransactionCode Members


JobTransactionCode.RecoveryAccount Property

[image]

Pastel Evolution SDK
JobTransactionCode..::..RecoveryAccount Property
JobTransactionCode Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLAccount RecoveryAccount { get; set; }
Visual Basic
Public Property RecoveryAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

See Also

JobTransactionCode Class
JobTransactionCode Members


JobTransactionCode.SalesTaxTypeID Property

[image]

Pastel Evolution SDK
JobTransactionCode..::..SalesTaxTypeID Property
JobTransactionCode Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int SalesTaxTypeID { get; set; }
Visual Basic
Public Property SalesTaxTypeID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

JobTransactionCode Class
JobTransactionCode Members


JobTransactionCode.SellingTaxType Property

[image]

Pastel Evolution SDK
JobTransactionCode..::..SellingTaxType Property
JobTransactionCode Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public TaxRate SellingTaxType { get; set; }
Visual Basic
Public Property SellingTaxType As TaxRate
    Get
    Set

Property Value

Type: TaxRate

See Also

JobTransactionCode Class
JobTransactionCode Members


JobTransactionCode.Source Property

[image]

Pastel Evolution SDK
JobTransactionCode..::..Source Property
JobTransactionCode Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public JobDetail..::..TransactionSource Source { get; set; }
Visual Basic
Public Property Source As JobDetail..::..TransactionSource
    Get
    Set

Property Value

Type: JobDetail..::..TransactionSource

See Also

JobTransactionCode Class
JobTransactionCode Members


JobTransactionCode.StockAccount Property

[image]

Pastel Evolution SDK
JobTransactionCode..::..StockAccount Property
JobTransactionCode Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLAccount StockAccount { get; set; }
Visual Basic
Public Property StockAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

See Also

JobTransactionCode Class
JobTransactionCode Members


JobTransactionCode.StockAccountID Property

[image]

Pastel Evolution SDK
JobTransactionCode..::..StockAccountID Property
JobTransactionCode Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int StockAccountID { get; set; }
Visual Basic
Public Property StockAccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

JobTransactionCode Class
JobTransactionCode Members


JobTransactionCode.TaxAccount Property

[image]

Pastel Evolution SDK
JobTransactionCode..::..TaxAccount Property
JobTransactionCode Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLAccount TaxAccount { get; set; }
Visual Basic
Public Property TaxAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

See Also

JobTransactionCode Class
JobTransactionCode Members


JobTransactionCode.WIPAccount Property

[image]

Pastel Evolution SDK
JobTransactionCode..::..WIPAccount Property
JobTransactionCode Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLAccount WIPAccount { get; set; }
Visual Basic
Public Property WIPAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

See Also

JobTransactionCode Class
JobTransactionCode Members


JobTransactionCode.WIPAccountID Property

[image]

Pastel Evolution SDK
JobTransactionCode..::..WIPAccountID Property
JobTransactionCode Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int WIPAccountID { get; set; }
Visual Basic
Public Property WIPAccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

JobTransactionCode Class
JobTransactionCode Members


JournalBatch Class

[image]

Pastel Evolution SDK
JournalBatch Class
Members See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class JournalBatch : BranchedRecordBase
Visual Basic
Public Class JournalBatch
    Inherits BranchedRecordBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..JournalBatch

See Also

JournalBatch Members


JournalBatch Members

[image] [image]

Pastel Evolution SDK
JournalBatch Members
JournalBatch Class Constructors Methods Fields Properties See Also Send Feedback

The JournalBatch type exposes the following members.

Constructors

 | Name | Description
Public method | JournalBatch()()()() | Creates a new instance of a general ledger journal batch.
Public method | JournalBatch(Int32) | Creates a new instance of a general ledger journal batch.
Public method | JournalBatch(String) | Creates a new instance of a general ledger journal batch.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find |
 | FindByCode |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List(String) |
 | List(String, String) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Code |
Public property | DefaultDescription |
Public property | Description |
Public property | Detail |
Public property | DoClearAfterPost |
Public property | ID | (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | Owner | Gets or sets the batch owner.
Public property | OwnerID | Gets or sets the Agent ID of the batch owner.
Public property | ProcessedCount |
Public property | Reference |
Public property | RepeatLimit |
Public property | TransactionCode |
Public property | TransactionCodeID |

See Also

JournalBatch Class


JournalBatch Constructor

[image] [image]

Pastel Evolution SDK
JournalBatch Constructor
JournalBatch Class See Also Send Feedback

Overload List

 | Name | Description
Public method | JournalBatch()()()() | Creates a new instance of a general ledger journal batch.
Public method | JournalBatch(Int32) | Creates a new instance of a general ledger journal batch.
Public method | JournalBatch(String) | Creates a new instance of a general ledger journal batch.

See Also

JournalBatch Class
JournalBatch Members


JournalBatch Constructor

[image]

Pastel Evolution SDK
JournalBatch Constructor
JournalBatch Class See Also Send Feedback
Creates a new instance of a general ledger journal batch.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public JournalBatch()
Visual Basic
Public Sub New

See Also

JournalBatch Class
JournalBatch Members
JournalBatch Overload


JournalBatch Constructor (Int32)

[image]

Pastel Evolution SDK
JournalBatch Constructor (Int32)
JournalBatch Class See Also Send Feedback
Creates a new instance of a general ledger journal batch.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public JournalBatch(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32
Specifies the ID of the existing record.

See Also

JournalBatch Class
JournalBatch Members
JournalBatch Overload


JournalBatch Constructor (String)

[image]

Pastel Evolution SDK
JournalBatch Constructor (String)
JournalBatch Class See Also Send Feedback
Creates a new instance of a general ledger journal batch.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public JournalBatch(
    string code
)
Visual Basic
Public Sub New (
    code As String
)

Parameters

code
Type: System..::..String

See Also

JournalBatch Class
JournalBatch Members
JournalBatch Overload


JournalBatch Fields

[image] [image]

Pastel Evolution SDK
JournalBatch Fields
JournalBatch Class See Also Send Feedback

The JournalBatch type exposes the following members.

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

JournalBatch Class


JournalBatch Methods

[image] [image]

Pastel Evolution SDK
JournalBatch Methods
JournalBatch Class See Also Send Feedback

The JournalBatch type exposes the following members.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find |
 | FindByCode |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List(String) |
 | List(String, String) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

JournalBatch Class


JournalBatch.Find Method

[image]

Pastel Evolution SDK
JournalBatch..::..Find Method
JournalBatch Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String

Return Value

Type: Int32

See Also

JournalBatch Class
JournalBatch Members


JournalBatch.FindByCode Method

[image]

Pastel Evolution SDK
JournalBatch..::..FindByCode Method
JournalBatch Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int FindByCode(
    string code
)
Visual Basic
Public Shared Function FindByCode (
    code As String
) As Integer

Parameters

code
Type: System..::..String

Return Value

Type: Int32

See Also

JournalBatch Class
JournalBatch Members


JournalBatch.List Method

[image] [image]

Pastel Evolution SDK
JournalBatch..::..List Method
JournalBatch Class See Also Send Feedback

Overload List

Name | Description
List(String) |
List(String, String) |

See Also

JournalBatch Class
JournalBatch Members


JournalBatch.List Method (String)

[image]

Pastel Evolution SDK
JournalBatch..::..List Method (String)
JournalBatch Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria
)
Visual Basic
Public Shared Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String

Return Value

Type: DataTable

See Also

JournalBatch Class
JournalBatch Members
List Overload


JournalBatch.List Method (String, String)

[image]

Pastel Evolution SDK
JournalBatch..::..List Method (String, String)
JournalBatch Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria,
    string sortOrder
)
Visual Basic
Public Shared Function List (
    criteria As String,
    sortOrder As String
) As DataTable

Parameters

criteria
Type: System..::..String
sortOrder
Type: System..::..String

Return Value

Type: DataTable

See Also

JournalBatch Class
JournalBatch Members
List Overload


JournalBatch.OnDelete Method

[image]

Pastel Evolution SDK
JournalBatch..::..OnDelete Method
JournalBatch Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

See Also

JournalBatch Class
JournalBatch Members


JournalBatch.OnSave Method

[image]

Pastel Evolution SDK
JournalBatch..::..OnSave Method
JournalBatch Class See Also Send Feedback
Persists the record to the database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

JournalBatch Class
JournalBatch Members


JournalBatch Properties

[image] [image]

Pastel Evolution SDK
JournalBatch Properties
JournalBatch Class See Also Send Feedback

The JournalBatch type exposes the following members.

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Code |
Public property | DefaultDescription |
Public property | Description |
Public property | Detail |
Public property | DoClearAfterPost |
Public property | ID | (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | Owner | Gets or sets the batch owner.
Public property | OwnerID | Gets or sets the Agent ID of the batch owner.
Public property | ProcessedCount |
Public property | Reference |
Public property | RepeatLimit |
Public property | TransactionCode |
Public property | TransactionCodeID |

See Also

JournalBatch Class


JournalBatch.Code Property

[image]

Pastel Evolution SDK
JournalBatch..::..Code Property
JournalBatch Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Code { get; set; }
Visual Basic
Public Property Code As String
    Get
    Set

Property Value

Type: String

See Also

JournalBatch Class
JournalBatch Members


JournalBatch.DefaultDescription Property

[image]

Pastel Evolution SDK
JournalBatch..::..DefaultDescription Property
JournalBatch Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string DefaultDescription { get; set; }
Visual Basic
Public Property DefaultDescription As String
    Get
    Set

Property Value

Type: String

See Also

JournalBatch Class
JournalBatch Members


JournalBatch.Description Property

[image]

Pastel Evolution SDK
JournalBatch..::..Description Property
JournalBatch Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set

Property Value

Type: String

See Also

JournalBatch Class
JournalBatch Members


JournalBatch.Detail Property

[image]

Pastel Evolution SDK
JournalBatch..::..Detail Property
JournalBatch Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public JournalBatchDetailCollection Detail { get; }
Visual Basic
Public ReadOnly Property Detail As JournalBatchDetailCollection
    Get

Property Value

Type: JournalBatchDetailCollection

See Also

JournalBatch Class
JournalBatch Members


JournalBatch.DoClearAfterPost Property

[image]

Pastel Evolution SDK
JournalBatch..::..DoClearAfterPost Property
JournalBatch Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool DoClearAfterPost { get; set; }
Visual Basic
Public Property DoClearAfterPost As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

JournalBatch Class
JournalBatch Members


JournalBatch.ID Property

[image]

Pastel Evolution SDK
JournalBatch..::..ID Property
JournalBatch Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

See Also

JournalBatch Class
JournalBatch Members


JournalBatch.LongID Property

[image]

Pastel Evolution SDK
JournalBatch..::..LongID Property
JournalBatch Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

JournalBatch Class
JournalBatch Members


JournalBatch.Owner Property

[image]

Pastel Evolution SDK
JournalBatch..::..Owner Property
JournalBatch Class See Also Send Feedback
Gets or sets the batch owner.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Agent Owner { get; set; }
Visual Basic
Public Property Owner As Agent
    Get
    Set

Property Value

Type: Agent

See Also

JournalBatch Class
JournalBatch Members


JournalBatch.OwnerID Property

[image]

Pastel Evolution SDK
JournalBatch..::..OwnerID Property
JournalBatch Class See Also Send Feedback
Gets or sets the Agent ID of the batch owner.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int OwnerID { get; set; }
Visual Basic
Public Property OwnerID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

JournalBatch Class
JournalBatch Members


JournalBatch.ProcessedCount Property

[image]

Pastel Evolution SDK
JournalBatch..::..ProcessedCount Property
JournalBatch Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int ProcessedCount { get; }
Visual Basic
Public ReadOnly Property ProcessedCount As Integer
    Get

Property Value

Type: Int32

See Also

JournalBatch Class
JournalBatch Members


JournalBatch.Reference Property

[image]

Pastel Evolution SDK
JournalBatch..::..Reference Property
JournalBatch Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Reference { get; internal set; }
Visual Basic
Public Property Reference As String
    Get
    Friend Set

Property Value

Type: String

See Also

JournalBatch Class
JournalBatch Members


JournalBatch.RepeatLimit Property

[image]

Pastel Evolution SDK
JournalBatch..::..RepeatLimit Property
JournalBatch Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int RepeatLimit { get; set; }
Visual Basic
Public Property RepeatLimit As Integer
    Get
    Set

Property Value

Type: Int32

See Also

JournalBatch Class
JournalBatch Members


JournalBatch.TransactionCode Property

[image]

Pastel Evolution SDK
JournalBatch..::..TransactionCode Property
JournalBatch Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public TransactionCode TransactionCode { get; set; }
Visual Basic
Public Property TransactionCode As TransactionCode
    Get
    Set

Property Value

Type: TransactionCode

See Also

JournalBatch Class
JournalBatch Members


JournalBatch.TransactionCodeID Property

[image]

Pastel Evolution SDK
JournalBatch..::..TransactionCodeID Property
JournalBatch Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int TransactionCodeID { get; set; }
Visual Basic
Public Property TransactionCodeID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

JournalBatch Class
JournalBatch Members


JournalBatchDetail Class

[image]

Pastel Evolution SDK
JournalBatchDetail Class
Members See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class JournalBatchDetail : BranchedRecordBase
Visual Basic
Public Class JournalBatchDetail
    Inherits BranchedRecordBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..JournalBatchDetail

See Also

JournalBatchDetail Members


JournalBatchDetail Members

[image] [image]

Pastel Evolution SDK
JournalBatchDetail Members
JournalBatchDetail Class Constructors Methods Fields Properties See Also Send Feedback

The JournalBatchDetail type exposes the following members.

Constructors

 | Name | Description
Public method | JournalBatchDetail()()()() | Creates a new instance of a journal batch detail record.
Public method | JournalBatchDetail(Int32) | Creates a new instance of a journal batch detail record.

Methods

 | Name | Description
Public method | Clone |
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | Account | Gets or sets the Account.
Public property | AccountID | Gets or sets the Account ID.
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Credit |
Public property | Date |
Public property | Debit | Sets the transaction debit amount.
Public property | Description | Gets or sets the record description.
Public property | EffectiveCredit |
Public property | EffectiveDebit |
Public property | GLAccountID | Gets or sets the GLAccount ID.
Public property | ID | (Overrides RecordBase..::..ID.)
Public property | IsLoading |
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | Project | Gets or sets the Project.
Public property | ProjectID | Gets or sets the Project ID.
Public property | Reference |
Public property | Tax | Gets or sets the transaction tax amount (automatically rounded to 2 decimals and always posted positive).
Public property | TaxAccount | Gets or sets the tax account.
Public property | TaxRate | Gets or sets the TaxRate.
Public property | TaxRateID | Gets or sets the TaxRate ID.

See Also

JournalBatchDetail Class


JournalBatchDetail Constructor

[image] [image]

Pastel Evolution SDK
JournalBatchDetail Constructor
JournalBatchDetail Class See Also Send Feedback

Overload List

 | Name | Description
Public method | JournalBatchDetail()()()() | Creates a new instance of a journal batch detail record.
Public method | JournalBatchDetail(Int32) | Creates a new instance of a journal batch detail record.

See Also

JournalBatchDetail Class
JournalBatchDetail Members


JournalBatchDetail Constructor

[image]

Pastel Evolution SDK
JournalBatchDetail Constructor
JournalBatchDetail Class See Also Send Feedback
Creates a new instance of a journal batch detail record.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public JournalBatchDetail()
Visual Basic
Public Sub New

See Also

JournalBatchDetail Class
JournalBatchDetail Members
JournalBatchDetail Overload


JournalBatchDetail Constructor (Int32)

[image]

Pastel Evolution SDK
JournalBatchDetail Constructor (Int32)
JournalBatchDetail Class See Also Send Feedback
Creates a new instance of a journal batch detail record.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public JournalBatchDetail(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32
Specifies the id of the existing record.

See Also

JournalBatchDetail Class
JournalBatchDetail Members
JournalBatchDetail Overload


JournalBatchDetail Fields

[image] [image]

Pastel Evolution SDK
JournalBatchDetail Fields
JournalBatchDetail Class See Also Send Feedback

The JournalBatchDetail type exposes the following members.

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

JournalBatchDetail Class


JournalBatchDetail Methods

[image] [image]

Pastel Evolution SDK
JournalBatchDetail Methods
JournalBatchDetail Class See Also Send Feedback

The JournalBatchDetail type exposes the following members.

Methods

 | Name | Description
Public method | Clone |
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

JournalBatchDetail Class


JournalBatchDetail.Clone Method

[image]

Pastel Evolution SDK
JournalBatchDetail..::..Clone Method
JournalBatchDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public JournalBatchDetail Clone()
Visual Basic
Public Function Clone As JournalBatchDetail

Return Value

Type: JournalBatchDetail

See Also

JournalBatchDetail Class
JournalBatchDetail Members


JournalBatchDetail.Find Method

[image]

Pastel Evolution SDK
JournalBatchDetail..::..Find Method
JournalBatchDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String

Return Value

Type: Int32

See Also

JournalBatchDetail Class
JournalBatchDetail Members


JournalBatchDetail.List Method

[image]

Pastel Evolution SDK
JournalBatchDetail..::..List Method
JournalBatchDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria
)
Visual Basic
Public Shared Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String

Return Value

Type: DataTable

See Also

JournalBatchDetail Class
JournalBatchDetail Members


JournalBatchDetail.OnDelete Method

[image]

Pastel Evolution SDK
JournalBatchDetail..::..OnDelete Method
JournalBatchDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

See Also

JournalBatchDetail Class
JournalBatchDetail Members


JournalBatchDetail.OnSave Method

[image]

Pastel Evolution SDK
JournalBatchDetail..::..OnSave Method
JournalBatchDetail Class See Also Send Feedback
Persists the record to the database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

JournalBatchDetail Class
JournalBatchDetail Members


JournalBatchDetail Properties

[image] [image]

Pastel Evolution SDK
JournalBatchDetail Properties
JournalBatchDetail Class See Also Send Feedback

The JournalBatchDetail type exposes the following members.

Properties

 | Name | Description
Public property | Account | Gets or sets the Account.
Public property | AccountID | Gets or sets the Account ID.
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Credit |
Public property | Date |
Public property | Debit | Sets the transaction debit amount.
Public property | Description | Gets or sets the record description.
Public property | EffectiveCredit |
Public property | EffectiveDebit |
Public property | GLAccountID | Gets or sets the GLAccount ID.
Public property | ID | (Overrides RecordBase..::..ID.)
Public property | IsLoading |
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | Project | Gets or sets the Project.
Public property | ProjectID | Gets or sets the Project ID.
Public property | Reference |
Public property | Tax | Gets or sets the transaction tax amount (automatically rounded to 2 decimals and always posted positive).
Public property | TaxAccount | Gets or sets the tax account.
Public property | TaxRate | Gets or sets the TaxRate.
Public property | TaxRateID | Gets or sets the TaxRate ID.

See Also

JournalBatchDetail Class


JournalBatchDetail.Account Property

[image]

Pastel Evolution SDK
JournalBatchDetail..::..Account Property
JournalBatchDetail Class See Also Send Feedback
Gets or sets the Account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLAccount Account { get; set; }
Visual Basic
Public Property Account As GLAccount
    Get
    Set

Property Value

Type: GLAccount

See Also

JournalBatchDetail Class
JournalBatchDetail Members


JournalBatchDetail.AccountID Property

[image]

Pastel Evolution SDK
JournalBatchDetail..::..AccountID Property
JournalBatchDetail Class See Also Send Feedback
Gets or sets the Account ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int AccountID { get; set; }
Visual Basic
Public Property AccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

JournalBatchDetail Class
JournalBatchDetail Members


JournalBatchDetail.Credit Property

[image]

Pastel Evolution SDK
JournalBatchDetail..::..Credit Property
JournalBatchDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double Credit { get; set; }
Visual Basic
Public Property Credit As Double
    Get
    Set

Property Value

Type: Double

See Also

JournalBatchDetail Class
JournalBatchDetail Members


JournalBatchDetail.Date Property

[image]

Pastel Evolution SDK
JournalBatchDetail..::..Date Property
JournalBatchDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DateTime Date { get; set; }
Visual Basic
Public Property Date As DateTime
    Get
    Set

Property Value

Type: DateTime

See Also

JournalBatchDetail Class
JournalBatchDetail Members


JournalBatchDetail.Debit Property

[image]

Pastel Evolution SDK
JournalBatchDetail..::..Debit Property
JournalBatchDetail Class See Also Send Feedback
Sets the transaction debit amount.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double Debit { get; set; }
Visual Basic
Public Property Debit As Double
    Get
    Set

Property Value

Type: Double

Remarks

Be careful when setting both debit and credit values. When setting debit to a negative value, debit will immediately become 0 and credit will immediately be set to the reverse of the value. If then setting credit to 0, the transaction amount will be cancelled.

See Also

JournalBatchDetail Class
JournalBatchDetail Members


JournalBatchDetail.Description Property

[image]

Pastel Evolution SDK
JournalBatchDetail..::..Description Property
JournalBatchDetail Class See Also Send Feedback
Gets or sets the record description.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set

Property Value

Type: String

See Also

JournalBatchDetail Class
JournalBatchDetail Members


JournalBatchDetail.EffectiveCredit Property

[image]

Pastel Evolution SDK
JournalBatchDetail..::..EffectiveCredit Property
JournalBatchDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double EffectiveCredit { get; set; }
Visual Basic
Public Property EffectiveCredit As Double
    Get
    Set

Property Value

Type: Double

See Also

JournalBatchDetail Class
JournalBatchDetail Members


JournalBatchDetail.EffectiveDebit Property

[image]

Pastel Evolution SDK
JournalBatchDetail..::..EffectiveDebit Property
JournalBatchDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double EffectiveDebit { get; set; }
Visual Basic
Public Property EffectiveDebit As Double
    Get
    Set

Property Value

Type: Double

See Also

JournalBatchDetail Class
JournalBatchDetail Members


JournalBatchDetail.GLAccountID Property

[image]

Pastel Evolution SDK
JournalBatchDetail..::..GLAccountID Property
JournalBatchDetail Class See Also Send Feedback
Gets or sets the GLAccount ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int GLAccountID { get; set; }
Visual Basic
Public Property GLAccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

JournalBatchDetail Class
JournalBatchDetail Members


JournalBatchDetail.ID Property

[image]

Pastel Evolution SDK
JournalBatchDetail..::..ID Property
JournalBatchDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

See Also

JournalBatchDetail Class
JournalBatchDetail Members


JournalBatchDetail.IsLoading Property

[image]

Pastel Evolution SDK
JournalBatchDetail..::..IsLoading Property
JournalBatchDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool IsLoading { get; set; }
Visual Basic
Public Property IsLoading As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

JournalBatchDetail Class
JournalBatchDetail Members


JournalBatchDetail.LongID Property

[image]

Pastel Evolution SDK
JournalBatchDetail..::..LongID Property
JournalBatchDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

JournalBatchDetail Class
JournalBatchDetail Members


JournalBatchDetail.Project Property

[image]

Pastel Evolution SDK
JournalBatchDetail..::..Project Property
JournalBatchDetail Class See Also Send Feedback
Gets or sets the Project.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Project Project { get; set; }
Visual Basic
Public Property Project As Project
    Get
    Set

Property Value

Type: Project

See Also

JournalBatchDetail Class
JournalBatchDetail Members


JournalBatchDetail.ProjectID Property

[image]

Pastel Evolution SDK
JournalBatchDetail..::..ProjectID Property
JournalBatchDetail Class See Also Send Feedback
Gets or sets the Project ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int ProjectID { get; set; }
Visual Basic
Public Property ProjectID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

JournalBatchDetail Class
JournalBatchDetail Members


JournalBatchDetail.Reference Property

[image]

Pastel Evolution SDK
JournalBatchDetail..::..Reference Property
JournalBatchDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Reference { get; set; }
Visual Basic
Public Property Reference As String
    Get
    Set

Property Value

Type: String

See Also

JournalBatchDetail Class
JournalBatchDetail Members


JournalBatchDetail.Tax Property

[image]

Pastel Evolution SDK
JournalBatchDetail..::..Tax Property
JournalBatchDetail Class See Also Send Feedback
Gets or sets the transaction tax amount (automatically rounded to 2 decimals and always posted positive).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double Tax { get; set; }
Visual Basic
Public Property Tax As Double
    Get
    Set

Property Value

Type: Double

See Also

JournalBatchDetail Class
JournalBatchDetail Members


JournalBatchDetail.TaxAccount Property

[image]

Pastel Evolution SDK
JournalBatchDetail..::..TaxAccount Property
JournalBatchDetail Class See Also Send Feedback
Gets or sets the tax account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLAccount TaxAccount { get; set; }
Visual Basic
Public Property TaxAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

See Also

JournalBatchDetail Class
JournalBatchDetail Members


JournalBatchDetail.TaxRate Property

[image]

Pastel Evolution SDK
JournalBatchDetail..::..TaxRate Property
JournalBatchDetail Class See Also Send Feedback
Gets or sets the TaxRate.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public TaxRate TaxRate { get; set; }
Visual Basic
Public Property TaxRate As TaxRate
    Get
    Set

Property Value

Type: TaxRate

See Also

JournalBatchDetail Class
JournalBatchDetail Members


JournalBatchDetail.TaxRateID Property

[image]

Pastel Evolution SDK
JournalBatchDetail..::..TaxRateID Property
JournalBatchDetail Class See Also Send Feedback
Gets or sets the TaxRate ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int TaxRateID { get; set; }
Visual Basic
Public Property TaxRateID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

JournalBatchDetail Class
JournalBatchDetail Members


JournalBatchDetailCollection Class

[image]

Pastel Evolution SDK
JournalBatchDetailCollection Class
Members See Also Send Feedback
Represents a collection of batch detail items, typically owned by a given inventory document record.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class JournalBatchDetailCollection : CollectionBase
Visual Basic
Public Class JournalBatchDetailCollection
    Inherits CollectionBase

Inheritance Hierarchy

System..::..Object
System.Collections..::..CollectionBase
Pastel.Evolution..::..JournalBatchDetailCollection

See Also

JournalBatchDetailCollection Members


JournalBatchDetailCollection Members

[image] [image]

Pastel Evolution SDK
JournalBatchDetailCollection Members
JournalBatchDetailCollection Class Methods Properties Events See Also Send Feedback

The JournalBatchDetailCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Appends a batch detail object to the batch.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Public method | OnCollectionChanged |
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove | Removes the specified order detail line from the collection
Public method | RemoveAt | Removes a detail record using its zero-based index.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | Gets a batch detail object by its zero-based index.
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

Events

 | Name | Description
Public event | CollectionChanged | Occurs when detail records are added or deleted.

See Also

JournalBatchDetailCollection Class


JournalBatchDetailCollection Methods

[image] [image]

Pastel Evolution SDK
JournalBatchDetailCollection Methods
JournalBatchDetailCollection Class See Also Send Feedback

The JournalBatchDetailCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Appends a batch detail object to the batch.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Public method | OnCollectionChanged |
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove | Removes the specified order detail line from the collection
Public method | RemoveAt | Removes a detail record using its zero-based index.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

JournalBatchDetailCollection Class


JournalBatchDetailCollection.Add Method

[image]

Pastel Evolution SDK
JournalBatchDetailCollection..::..Add Method
JournalBatchDetailCollection Class See Also Send Feedback
Appends a batch detail object to the batch.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void Add(
    JournalBatchDetail detailRecord
)
Visual Basic
Public Sub Add (
    detailRecord As JournalBatchDetail
)

Parameters

detailRecord
Type: Pastel.Evolution..::..JournalBatchDetail

Remarks

Take note that upon being added to a document, the detail record will assume the document's sales representative and project.

See Also

JournalBatchDetailCollection Class
JournalBatchDetailCollection Members


JournalBatchDetailCollection.OnCollectionChanged Method

[image]

Pastel Evolution SDK
JournalBatchDetailCollection..::..OnCollectionChanged Method
JournalBatchDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void OnCollectionChanged(
    JournalBatchDetailCollection..::..JournalBatchDetailCollectionChangedEventArgs e
)
Visual Basic
Public Sub OnCollectionChanged (
    e As JournalBatchDetailCollection..::..JournalBatchDetailCollectionChangedEventArgs
)

Parameters

e
Type: Pastel.Evolution..::..JournalBatchDetailCollection..::..JournalBatchDetailCollectionChangedEventArgs

See Also

JournalBatchDetailCollection Class
JournalBatchDetailCollection Members


JournalBatchDetailCollection.Remove Method

[image]

Pastel Evolution SDK
JournalBatchDetailCollection..::..Remove Method
JournalBatchDetailCollection Class See Also Send Feedback
Removes the specified order detail line from the collection

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void Remove(
    JournalBatchDetail detailRecord
)
Visual Basic
Public Sub Remove (
    detailRecord As JournalBatchDetail
)

Parameters

detailRecord
Type: Pastel.Evolution..::..JournalBatchDetail

See Also

JournalBatchDetailCollection Class
JournalBatchDetailCollection Members


JournalBatchDetailCollection.RemoveAt Method

[image]

Pastel Evolution SDK
JournalBatchDetailCollection..::..RemoveAt Method
JournalBatchDetailCollection Class See Also Send Feedback
Removes a detail record using its zero-based index.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void RemoveAt(
    int index
)
Visual Basic
Public Sub RemoveAt (
    index As Integer
)

Parameters

index
Type: System..::..Int32

See Also

JournalBatchDetailCollection Class
JournalBatchDetailCollection Members


JournalBatchDetailCollection Properties

[image] [image]

Pastel Evolution SDK
JournalBatchDetailCollection Properties
JournalBatchDetailCollection Class See Also Send Feedback

The JournalBatchDetailCollection type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | Gets a batch detail object by its zero-based index.
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

JournalBatchDetailCollection Class


JournalBatchDetailCollection.Item Property

[image]

Pastel Evolution SDK
JournalBatchDetailCollection..::..Item Property
JournalBatchDetailCollection Class See Also Send Feedback
Gets a batch detail object by its zero-based index.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public JournalBatchDetail this[
    int index
] { get; set; }
Visual Basic
Public Default Property Item (
    index As Integer
) As JournalBatchDetail
    Get
    Set

Parameters

index
Type: System..::..Int32

Return Value

Type: JournalBatchDetail

See Also

JournalBatchDetailCollection Class
JournalBatchDetailCollection Members


JournalBatchDetailCollection Events

[image] [image]

Pastel Evolution SDK
JournalBatchDetailCollection Events
JournalBatchDetailCollection Class See Also Send Feedback

The JournalBatchDetailCollection type exposes the following members.

Events

 | Name | Description
Public event | CollectionChanged | Occurs when detail records are added or deleted.

See Also

JournalBatchDetailCollection Class


JournalBatchDetailCollection.CollectionChanged Event

[image]

Pastel Evolution SDK
JournalBatchDetailCollection..::..CollectionChanged Event
JournalBatchDetailCollection Class See Also Send Feedback
Occurs when detail records are added or deleted.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public event JournalBatchDetailCollection..::..JournalBatchDetailChangedEventHandler CollectionChanged
Visual Basic
Public Event CollectionChanged As JournalBatchDetailCollection..::..JournalBatchDetailChangedEventHandler

Value

Type: Pastel.Evolution..::..JournalBatchDetailCollection..::..JournalBatchDetailChangedEventHandler

See Also

JournalBatchDetailCollection Class
JournalBatchDetailCollection Members


JournalBatchDetailCollection.JournalBatchDetailChangeAction Enumeration

[image]

Pastel Evolution SDK
JournalBatchDetailCollection..::..JournalBatchDetailChangeAction Enumeration
JournalBatchDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public enum JournalBatchDetailChangeAction
Visual Basic
Public Enumeration JournalBatchDetailChangeAction

Members

Member name | Value | Description
Added | 0 |
Deleted | 1 |

See Also

Pastel.Evolution Namespace


JournalBatchDetailCollection.JournalBatchDetailChangedEventHandler Delegate

[image]

Pastel Evolution SDK
JournalBatchDetailCollection..::..JournalBatchDetailChangedEventHandler Delegate
JournalBatchDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public delegate void JournalBatchDetailChangedEventHandler(
    Object sender,
    JournalBatchDetailCollection..::..JournalBatchDetailCollectionChangedEventArgs e
)
Visual Basic
Public Delegate Sub JournalBatchDetailChangedEventHandler (
    sender As Object,
    e As JournalBatchDetailCollection..::..JournalBatchDetailCollectionChangedEventArgs
)

Parameters

sender
Type: System..::..Object
e
Type: Pastel.Evolution..::..JournalBatchDetailCollection..::..JournalBatchDetailCollectionChangedEventArgs

See Also

Pastel.Evolution Namespace


JournalBatchDetailCollection.JournalBatchDetailCollectionChangedEventArgs Class

[image]

Pastel Evolution SDK
JournalBatchDetailCollection..::..JournalBatchDetailCollectionChangedEventArgs Class
JournalBatchDetailCollection Class Members See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class JournalBatchDetailCollectionChangedEventArgs : EventArgs
Visual Basic
Public Class JournalBatchDetailCollectionChangedEventArgs
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Pastel.Evolution..::..JournalBatchDetailCollection..::..JournalBatchDetailCollectionChangedEventArgs

See Also

JournalBatchDetailCollection..::..JournalBatchDetailCollectionChangedEventArgs Members


JournalBatchDetailCollection.JournalBatchDetailCollectionChangedEventArgs Members

[image] [image]

Pastel Evolution SDK
JournalBatchDetailCollection..::..JournalBatchDetailCollectionChangedEventArgs Members
JournalBatchDetailCollection..::..JournalBatchDetailCollectionChangedEventArgs Class Constructors Methods Fields See Also Send Feedback

The JournalBatchDetailCollection..::..JournalBatchDetailCollectionChangedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | JournalBatchDetailCollection..::..JournalBatchDetailCollectionChangedEventArgs | Initializes a new instance of the JournalBatchDetailCollection..::..JournalBatchDetailCollectionChangedEventArgs class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | Action |
Public field | DetailRecord |

See Also

JournalBatchDetailCollection..::..JournalBatchDetailCollectionChangedEventArgs Class


JournalBatchDetailCollection.JournalBatchDetailCollectionChangedEventArgs Constructor

[image]

Pastel Evolution SDK
JournalBatchDetailCollection..::..JournalBatchDetailCollectionChangedEventArgs Constructor
JournalBatchDetailCollection..::..JournalBatchDetailCollectionChangedEventArgs Class See Also Send Feedback
Initializes a new instance of the JournalBatchDetailCollection..::..JournalBatchDetailCollectionChangedEventArgs class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public JournalBatchDetailCollectionChangedEventArgs(
    JournalBatchDetail detailRecord,
    JournalBatchDetailCollection..::..JournalBatchDetailChangeAction action
)
Visual Basic
Public Sub New (
    detailRecord As JournalBatchDetail,
    action As JournalBatchDetailCollection..::..JournalBatchDetailChangeAction
)

Parameters

detailRecord
Type: Pastel.Evolution..::..JournalBatchDetail
action
Type: Pastel.Evolution..::..JournalBatchDetailCollection..::..JournalBatchDetailChangeAction

See Also

JournalBatchDetailCollection..::..JournalBatchDetailCollectionChangedEventArgs Class
JournalBatchDetailCollection..::..JournalBatchDetailCollectionChangedEventArgs Members


JournalBatchDetailCollection.JournalBatchDetailCollectionChangedEventArgs Fields

[image] [image]

Pastel Evolution SDK
JournalBatchDetailCollection..::..JournalBatchDetailCollectionChangedEventArgs Fields
JournalBatchDetailCollection..::..JournalBatchDetailCollectionChangedEventArgs Class See Also Send Feedback

The JournalBatchDetailCollection..::..JournalBatchDetailCollectionChangedEventArgs type exposes the following members.

Fields

 | Name | Description
Public field | Action |
Public field | DetailRecord |

See Also

JournalBatchDetailCollection..::..JournalBatchDetailCollectionChangedEventArgs Class


JournalBatchDetailCollection.JournalBatchDetailCollectionChangedEventArgs.Action Field

[image]

Pastel Evolution SDK
JournalBatchDetailCollection..::..JournalBatchDetailCollectionChangedEventArgs..::..Action Field
JournalBatchDetailCollection..::..JournalBatchDetailCollectionChangedEventArgs Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public JournalBatchDetailCollection..::..JournalBatchDetailChangeAction Action
Visual Basic
Public Action As JournalBatchDetailCollection..::..JournalBatchDetailChangeAction

Field Value

Type: JournalBatchDetailCollection..::..JournalBatchDetailChangeAction

See Also

JournalBatchDetailCollection..::..JournalBatchDetailCollectionChangedEventArgs Class
JournalBatchDetailCollection..::..JournalBatchDetailCollectionChangedEventArgs Members


JournalBatchDetailCollection.JournalBatchDetailCollectionChangedEventArgs.DetailRecord Field

[image]

Pastel Evolution SDK
JournalBatchDetailCollection..::..JournalBatchDetailCollectionChangedEventArgs..::..DetailRecord Field
JournalBatchDetailCollection..::..JournalBatchDetailCollectionChangedEventArgs Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public JournalBatchDetail DetailRecord
Visual Basic
Public DetailRecord As JournalBatchDetail

Field Value

Type: JournalBatchDetail

See Also

JournalBatchDetailCollection..::..JournalBatchDetailCollectionChangedEventArgs Class
JournalBatchDetailCollection..::..JournalBatchDetailCollectionChangedEventArgs Members


JournalBatchDetailCollection.JournalBatchDetailCollectionChangedEventArgs Methods

[image] [image]

Pastel Evolution SDK
JournalBatchDetailCollection..::..JournalBatchDetailCollectionChangedEventArgs Methods
JournalBatchDetailCollection..::..JournalBatchDetailCollectionChangedEventArgs Class See Also Send Feedback

The JournalBatchDetailCollection..::..JournalBatchDetailCollectionChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

JournalBatchDetailCollection..::..JournalBatchDetailCollectionChangedEventArgs Class


Lot Class

[image]

Pastel Evolution SDK
Lot Class
Members See Also Send Feedback
Represents a distinct inventory lot.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class Lot : BranchedRecordBase
Visual Basic
Public Class Lot
    Inherits BranchedRecordBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..Lot

See Also

Lot Members


Lot Members

[image] [image]

Pastel Evolution SDK
Lot Members
Lot Class Constructors Methods Fields Properties See Also Send Feedback

The Lot type exposes the following members.

Constructors

 | Name | Description
Public method | Lot()()()() | Initializes a new instance of the Lot class
Public method | Lot(Int32) | Initializes a new instance of the Lot class
Public method | Lot(String) | Initializes a new instance of the Lot class
Public method | Lot(String, InventoryItem) | Initializes a new instance of the Lot class
Public method | Lot(String, Int32) | Initializes a new instance of the Lot class

Methods

 | Name | Description
Public method | _Refresh | Experimental method.
 | _Select(String) | Experimental Method
 | _Select(Int32, String) |
 | _Select(String, String) |
 | _Select(InventoryItem, String) |
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find(String) | Finds the first record matching the criteria supplied
 | Find(Int32, String) |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List(String) |
 | List(InventoryItem) |
 | List(String, String) | Returns a datatable containing the matching rows.
 | List(InventoryItem, LotStatus) | Returns a datatable containing the matching rows.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | (Overrides RecordBase..::..OnSave()()()().)
Public method | Save()()()() | Persists the record to the database. (Inherited from RecordBase.)
Public method | Save(String, DateTime) | Saves modifications to the lot record, notably the status and expiry date, if applicable. When changing a lot's status, a transaction gets posted. The supplied parameters are used in that transaction.
Public method | ToString | (Overrides Object..::..ToString()()()().)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Code |
Public property | ExpiryDate | Gets or sets the lot's expiry date. If not set, DateTime.MaxValue is returned. Set to Defaults.NullDate to cancel.
Public property | ID | (Overrides RecordBase..::..ID.)
Public property | InventoryItem |
Public property | InventoryItemID |
Public property | IsDirty |
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | QtyFree | Gets the lot's free quantity.
Public property | QtyOnHand |
Public property | QtyReserved |
Public property | QtyWIP | Gets the quantity of stock on active jobs and in manufacturing (work in progress).
Public property | Status | Gets or sets the lot's status. Note that new lots will always default to the receiving lot configured on the item.
Public property | StatusID |
Public property | WarehouseContexts | Gets the Lot's warehouse context collection. Bear in mind that unless has actually been used in a given warehouse, there will be no warehouse context for it and null will be returned.

See Also

Lot Class


Lot Constructor

[image] [image]

Pastel Evolution SDK
Lot Constructor
Lot Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Lot()()()() | Initializes a new instance of the Lot class
Public method | Lot(Int32) | Initializes a new instance of the Lot class
Public method | Lot(String) | Initializes a new instance of the Lot class
Public method | Lot(String, InventoryItem) | Initializes a new instance of the Lot class
Public method | Lot(String, Int32) | Initializes a new instance of the Lot class

See Also

Lot Class
Lot Members


Lot Constructor

[image]

Pastel Evolution SDK
Lot Constructor
Lot Class See Also Send Feedback
Initializes a new instance of the Lot class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Lot()
Visual Basic
Public Sub New

See Also

Lot Class
Lot Members
Lot Overload


Lot Constructor (Int32)

[image]

Pastel Evolution SDK
Lot Constructor (Int32)
Lot Class See Also Send Feedback
Initializes a new instance of the Lot class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Lot(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32

See Also

Lot Class
Lot Members
Lot Overload


Lot Constructor (String)

[image]

Pastel Evolution SDK
Lot Constructor (String)
Lot Class See Also Send Feedback
Initializes a new instance of the Lot class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Lot(
    string code
)
Visual Basic
Public Sub New (
    code As String
)

Parameters

code
Type: System..::..String

See Also

Lot Class
Lot Members
Lot Overload


Lot Constructor (String, InventoryItem)

[image]

Pastel Evolution SDK
Lot Constructor (String, InventoryItem)
Lot Class See Also Send Feedback
Initializes a new instance of the Lot class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Lot(
    string code,
    InventoryItem stockItem
)
Visual Basic
Public Sub New (
    code As String,
    stockItem As InventoryItem
)

Parameters

code
Type: System..::..String
stockItem
Type: Pastel.Evolution..::..InventoryItem

See Also

Lot Class
Lot Members
Lot Overload


Lot Constructor (String, Int32)

[image]

Pastel Evolution SDK
Lot Constructor (String, Int32)
Lot Class See Also Send Feedback
Initializes a new instance of the Lot class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Lot(
    string code,
    int stockID
)
Visual Basic
Public Sub New (
    code As String,
    stockID As Integer
)

Parameters

code
Type: System..::..String
stockID
Type: System..::..Int32

See Also

Lot Class
Lot Members
Lot Overload


Lot Fields

[image] [image]

Pastel Evolution SDK
Lot Fields
Lot Class See Also Send Feedback

The Lot type exposes the following members.

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

Lot Class


Lot Methods

[image] [image]

Pastel Evolution SDK
Lot Methods
Lot Class See Also Send Feedback

The Lot type exposes the following members.

Methods

 | Name | Description
Public method | _Refresh | Experimental method.
 | _Select(String) | Experimental Method
 | _Select(Int32, String) |
 | _Select(String, String) |
 | _Select(InventoryItem, String) |
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find(String) | Finds the first record matching the criteria supplied
 | Find(Int32, String) |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List(String) |
 | List(InventoryItem) |
 | List(String, String) | Returns a datatable containing the matching rows.
 | List(InventoryItem, LotStatus) | Returns a datatable containing the matching rows.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | (Overrides RecordBase..::..OnSave()()()().)
Public method | Save()()()() | Persists the record to the database. (Inherited from RecordBase.)
Public method | Save(String, DateTime) | Saves modifications to the lot record, notably the status and expiry date, if applicable. When changing a lot's status, a transaction gets posted. The supplied parameters are used in that transaction.
Public method | ToString | (Overrides Object..::..ToString()()()().)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

Lot Class


Lot._Refresh Method

[image]

Pastel Evolution SDK
Lot..::.._Refresh Method
Lot Class See Also Send Feedback
Experimental method.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void _Refresh()
Visual Basic
Public Sub _Refresh

See Also

Lot Class
Lot Members


Lot._Select Method

[image] [image]

Pastel Evolution SDK
Lot..::.._Select Method
Lot Class See Also Send Feedback

Overload List

Name | Description
_Select(String) | Experimental Method
_Select(Int32, String) |
_Select(String, String) |
_Select(InventoryItem, String) |

See Also

Lot Class
Lot Members


Lot._Select Method (String)

[image]

Pastel Evolution SDK
Lot..::.._Select Method (String)
Lot Class See Also Send Feedback
Experimental Method

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static Lot[] _Select(
    string criteria
)
Visual Basic
Public Shared Function _Select (
    criteria As String
) As Lot()

Parameters

criteria
Type: System..::..String

Return Value

Type: array< Lot >[]()[][]

See Also

Lot Class
Lot Members
_Select Overload


Lot._Select Method (Int32, String)

[image]

Pastel Evolution SDK
Lot..::.._Select Method (Int32, String)
Lot Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static Lot[] _Select(
    int itemID,
    string sortOrder
)
Visual Basic
Public Shared Function _Select (
    itemID As Integer,
    sortOrder As String
) As Lot()

Parameters

itemID
Type: System..::..Int32
sortOrder
Type: System..::..String

Return Value

Type: array< Lot >[]()[][]

See Also

Lot Class
Lot Members
_Select Overload


Lot._Select Method (String, String)

[image]

Pastel Evolution SDK
Lot..::.._Select Method (String, String)
Lot Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static Lot[] _Select(
    string criteria,
    string sortOrder
)
Visual Basic
Public Shared Function _Select (
    criteria As String,
    sortOrder As String
) As Lot()

Parameters

criteria
Type: System..::..String
sortOrder
Type: System..::..String

Return Value

Type: array< Lot >[]()[][]

See Also

Lot Class
Lot Members
_Select Overload


Lot._Select Method (InventoryItem, String)

[image]

Pastel Evolution SDK
Lot..::.._Select Method (InventoryItem, String)
Lot Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static Lot[] _Select(
    InventoryItem item,
    string sortOrder
)
Visual Basic
Public Shared Function _Select (
    item As InventoryItem,
    sortOrder As String
) As Lot()

Parameters

item
Type: Pastel.Evolution..::..InventoryItem
sortOrder
Type: System..::..String

Return Value

Type: array< Lot >[]()[][]

See Also

Lot Class
Lot Members
_Select Overload


Lot.Find Method

[image] [image]

Pastel Evolution SDK
Lot..::..Find Method
Lot Class See Also Send Feedback

Overload List

Name | Description
Find(String) | Finds the first record matching the criteria supplied
Find(Int32, String) |

See Also

Lot Class
Lot Members


Lot.Find Method (String)

[image]

Pastel Evolution SDK
Lot..::..Find Method (String)
Lot Class See Also Send Feedback
Finds the first record matching the criteria supplied

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String
E.g. Code = 'abc'

Return Value

Type: Int32
The id of the record

See Also

Lot Class
Lot Members
Find Overload


Lot.Find Method (Int32, String)

[image]

Pastel Evolution SDK
Lot..::..Find Method (Int32, String)
Lot Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    int inventoryID,
    string code
)
Visual Basic
Public Shared Function Find (
    inventoryID As Integer,
    code As String
) As Integer

Parameters

inventoryID
Type: System..::..Int32
code
Type: System..::..String

Return Value

Type: Int32

See Also

Lot Class
Lot Members
Find Overload


Lot.List Method

[image] [image]

Pastel Evolution SDK
Lot..::..List Method
Lot Class See Also Send Feedback

Overload List

Name | Description
List(String) |
List(InventoryItem) |
List(String, String) | Returns a datatable containing the matching rows.
List(InventoryItem, LotStatus) | Returns a datatable containing the matching rows.

See Also

Lot Class
Lot Members


Lot.List Method (String)

[image]

Pastel Evolution SDK
Lot..::..List Method (String)
Lot Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria
)
Visual Basic
Public Shared Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String

Return Value

Type: DataTable

See Also

Lot Class
Lot Members
List Overload


Lot.List Method (InventoryItem)

[image]

Pastel Evolution SDK
Lot..::..List Method (InventoryItem)
Lot Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    InventoryItem item
)
Visual Basic
Public Shared Function List (
    item As InventoryItem
) As DataTable

Parameters

item
Type: Pastel.Evolution..::..InventoryItem

Return Value

Type: DataTable

See Also

Lot Class
Lot Members
List Overload


Lot.List Method (String, String)

[image]

Pastel Evolution SDK
Lot..::..List Method (String, String)
Lot Class See Also Send Feedback
Returns a datatable containing the matching rows.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria,
    string sortOrder
)
Visual Basic
Public Shared Function List (
    criteria As String,
    sortOrder As String
) As DataTable

Parameters

criteria
Type: System..::..String
e.g. SNStockLink = 100 and CurrentLoc = (int)SerialNumberLocation.InStock
sortOrder
Type: System..::..String
The SQL order by clause.

Return Value

Type: DataTable

See Also

Lot Class
Lot Members
List Overload


Lot.List Method (InventoryItem, LotStatus)

[image]

Pastel Evolution SDK
Lot..::..List Method (InventoryItem, LotStatus)
Lot Class See Also Send Feedback
Returns a datatable containing the matching rows.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    InventoryItem item,
    LotStatus status
)
Visual Basic
Public Shared Function List (
    item As InventoryItem,
    status As LotStatus
) As DataTable

Parameters

item
Type: Pastel.Evolution..::..InventoryItem
The inventory item to which the serial numbers belong.
status
Type: Pastel.Evolution..::..LotStatus
The current status of the lot on which to filter.

Return Value

Type: DataTable

See Also

Lot Class
Lot Members
List Overload


Lot.OnDelete Method

[image]

Pastel Evolution SDK
Lot..::..OnDelete Method
Lot Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

See Also

Lot Class
Lot Members


Lot.OnSave Method

[image]

Pastel Evolution SDK
Lot..::..OnSave Method
Lot Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

Lot Class
Lot Members


Lot.Save Method

[image] [image]

Pastel Evolution SDK
Lot..::..Save Method
Lot Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Save()()()() | Persists the record to the database. (Inherited from RecordBase.)
Public method | Save(String, DateTime) | Saves modifications to the lot record, notably the status and expiry date, if applicable. When changing a lot's status, a transaction gets posted. The supplied parameters are used in that transaction.

See Also

Lot Class
Lot Members


Lot.Save Method (String, DateTime)

[image]

Pastel Evolution SDK
Lot..::..Save Method (String, DateTime)
Lot Class See Also Send Feedback
Saves modifications to the lot record, notably the status and expiry date, if applicable. When changing a lot's status, a transaction gets posted. The supplied parameters are used in that transaction.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void Save(
    string statusTransferRef,
    DateTime statusTransferDate
)
Visual Basic
Public Sub Save (
    statusTransferRef As String,
    statusTransferDate As DateTime
)

Parameters

statusTransferRef
Type: System..::..String
The reference to post to the lot status transfer. Defaults to an empty string.
statusTransferDate
Type: System..::..DateTime
The date at which to post the lot status transfer. Defaults to the current date (date at which the lot is instantiated).

See Also

Lot Class
Lot Members
Save Overload


Lot.ToString Method

[image]

Pastel Evolution SDK
Lot..::..ToString Method
Lot Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String

See Also

Lot Class
Lot Members


Lot Properties

[image] [image]

Pastel Evolution SDK
Lot Properties
Lot Class See Also Send Feedback

The Lot type exposes the following members.

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Code |
Public property | ExpiryDate | Gets or sets the lot's expiry date. If not set, DateTime.MaxValue is returned. Set to Defaults.NullDate to cancel.
Public property | ID | (Overrides RecordBase..::..ID.)
Public property | InventoryItem |
Public property | InventoryItemID |
Public property | IsDirty |
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | QtyFree | Gets the lot's free quantity.
Public property | QtyOnHand |
Public property | QtyReserved |
Public property | QtyWIP | Gets the quantity of stock on active jobs and in manufacturing (work in progress).
Public property | Status | Gets or sets the lot's status. Note that new lots will always default to the receiving lot configured on the item.
Public property | StatusID |
Public property | WarehouseContexts | Gets the Lot's warehouse context collection. Bear in mind that unless has actually been used in a given warehouse, there will be no warehouse context for it and null will be returned.

See Also

Lot Class


Lot.Code Property

[image]

Pastel Evolution SDK
Lot..::..Code Property
Lot Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Code { get; set; }
Visual Basic
Public Property Code As String
    Get
    Set

Property Value

Type: String

See Also

Lot Class
Lot Members


Lot.ExpiryDate Property

[image]

Pastel Evolution SDK
Lot..::..ExpiryDate Property
Lot Class See Also Send Feedback
Gets or sets the lot's expiry date. If not set, DateTime.MaxValue is returned. Set to Defaults.NullDate to cancel.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DateTime ExpiryDate { get; set; }
Visual Basic
Public Property ExpiryDate As DateTime
    Get
    Set

Property Value

Type: DateTime

See Also

Lot Class
Lot Members


Lot.ID Property

[image]

Pastel Evolution SDK
Lot..::..ID Property
Lot Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

See Also

Lot Class
Lot Members


Lot.InventoryItem Property

[image]

Pastel Evolution SDK
Lot..::..InventoryItem Property
Lot Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public InventoryItem InventoryItem { get; set; }
Visual Basic
Public Property InventoryItem As InventoryItem
    Get
    Set

Property Value

Type: InventoryItem

See Also

Lot Class
Lot Members


Lot.InventoryItemID Property

[image]

Pastel Evolution SDK
Lot..::..InventoryItemID Property
Lot Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int InventoryItemID { get; set; }
Visual Basic
Public Property InventoryItemID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

Lot Class
Lot Members


Lot.IsDirty Property

[image]

Pastel Evolution SDK
Lot..::..IsDirty Property
Lot Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool IsDirty { get; }
Visual Basic
Public ReadOnly Property IsDirty As Boolean
    Get

Property Value

Type: Boolean

See Also

Lot Class
Lot Members


Lot.LongID Property

[image]

Pastel Evolution SDK
Lot..::..LongID Property
Lot Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

Lot Class
Lot Members


Lot.QtyFree Property

[image]

Pastel Evolution SDK
Lot..::..QtyFree Property
Lot Class See Also Send Feedback
Gets the lot's free quantity.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double QtyFree { get; }
Visual Basic
Public ReadOnly Property QtyFree As Double
    Get

Property Value

Type: Double

Remarks

Calculation: QtyOnHand - QtyReserved - QtyWIP

Remarks

Service items will always report int.MaxValue.

See Also

Lot Class
Lot Members
Pastel.Evolution Namespace
Lot..::..QtyWIP
Lot..::..QtyReserved


Lot.QtyOnHand Property

[image]

Pastel Evolution SDK
Lot..::..QtyOnHand Property
Lot Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double QtyOnHand { get; }
Visual Basic
Public ReadOnly Property QtyOnHand As Double
    Get

Property Value

Type: Double

See Also

Lot Class
Lot Members


Lot.QtyReserved Property

[image]

Pastel Evolution SDK
Lot..::..QtyReserved Property
Lot Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double QtyReserved { get; }
Visual Basic
Public ReadOnly Property QtyReserved As Double
    Get

Property Value

Type: Double

See Also

Lot Class
Lot Members


Lot.QtyWIP Property

[image]

Pastel Evolution SDK
Lot..::..QtyWIP Property
Lot Class See Also Send Feedback
Gets the quantity of stock on active jobs and in manufacturing (work in progress).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double QtyWIP { get; }
Visual Basic
Public ReadOnly Property QtyWIP As Double
    Get

Property Value

Type: Double

See Also

Lot Class
Lot Members


Lot.Status Property

[image]

Pastel Evolution SDK
Lot..::..Status Property
Lot Class See Also Send Feedback
Gets or sets the lot's status. Note that new lots will always default to the receiving lot configured on the item.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public LotStatus Status { get; set; }
Visual Basic
Public Property Status As LotStatus
    Get
    Set

Property Value

Type: LotStatus

See Also

Lot Class
Lot Members


Lot.StatusID Property

[image]

Pastel Evolution SDK
Lot..::..StatusID Property
Lot Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int StatusID { get; set; }
Visual Basic
Public Property StatusID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

Lot Class
Lot Members


Lot.WarehouseContexts Property

[image]

Pastel Evolution SDK
Lot..::..WarehouseContexts Property
Lot Class See Also Send Feedback
Gets the Lot's warehouse context collection. Bear in mind that unless has actually been used in a given warehouse, there will be no warehouse context for it and null will be returned.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public LotContext..::..LotContextCollection WarehouseContexts { get; }
Visual Basic
Public ReadOnly Property WarehouseContexts As LotContext..::..LotContextCollection
    Get

Property Value

Type: LotContext..::..LotContextCollection

See Also

Lot Class
Lot Members


LotContext Class

[image]

Pastel Evolution SDK
LotContext Class
Members See Also Send Feedback
Represents a distinct inventory lot.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class LotContext
Visual Basic
Public Class LotContext

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..LotContext

See Also

LotContext Members


LotContext Members

[image] [image]

Pastel Evolution SDK
LotContext Members
LotContext Class Methods Properties See Also Send Feedback

The LotContext type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ID |
Public property | Lot |
Public property | QtyAdjustedIn |
Public property | QtyAdjustedOut |
Public property | QtyFree | Gets the lot's free quantity.
Public property | QtyNetPurchased | Net quantity purchased: purchased - returned
Public property | QtyNetSold | Net quantity sold: sold - credited
Public property | QtyOnHand |
Public property | QtyReserved |
Public property | QtyWIP | Gets the quantity of stock on active jobs and in manufacturing (work in progress).
Public property | Warehouse |
Public property | WarehouseID |

See Also

LotContext Class


LotContext Methods

[image] [image]

Pastel Evolution SDK
LotContext Methods
LotContext Class See Also Send Feedback

The LotContext type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LotContext Class


LotContext Properties

[image] [image]

Pastel Evolution SDK
LotContext Properties
LotContext Class See Also Send Feedback

The LotContext type exposes the following members.

Properties

 | Name | Description
Public property | ID |
Public property | Lot |
Public property | QtyAdjustedIn |
Public property | QtyAdjustedOut |
Public property | QtyFree | Gets the lot's free quantity.
Public property | QtyNetPurchased | Net quantity purchased: purchased - returned
Public property | QtyNetSold | Net quantity sold: sold - credited
Public property | QtyOnHand |
Public property | QtyReserved |
Public property | QtyWIP | Gets the quantity of stock on active jobs and in manufacturing (work in progress).
Public property | Warehouse |
Public property | WarehouseID |

See Also

LotContext Class


LotContext.ID Property

[image]

Pastel Evolution SDK
LotContext..::..ID Property
LotContext Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int ID { get; }
Visual Basic
Public ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

See Also

LotContext Class
LotContext Members


LotContext.Lot Property

[image]

Pastel Evolution SDK
LotContext..::..Lot Property
LotContext Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Lot Lot { get; }
Visual Basic
Public ReadOnly Property Lot As Lot
    Get

Property Value

Type: Lot

See Also

LotContext Class
LotContext Members


LotContext.QtyAdjustedIn Property

[image]

Pastel Evolution SDK
LotContext..::..QtyAdjustedIn Property
LotContext Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double QtyAdjustedIn { get; }
Visual Basic
Public ReadOnly Property QtyAdjustedIn As Double
    Get

Property Value

Type: Double

See Also

LotContext Class
LotContext Members


LotContext.QtyAdjustedOut Property

[image]

Pastel Evolution SDK
LotContext..::..QtyAdjustedOut Property
LotContext Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double QtyAdjustedOut { get; }
Visual Basic
Public ReadOnly Property QtyAdjustedOut As Double
    Get

Property Value

Type: Double

See Also

LotContext Class
LotContext Members


LotContext.QtyFree Property

[image]

Pastel Evolution SDK
LotContext..::..QtyFree Property
LotContext Class See Also Send Feedback
Gets the lot's free quantity.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double QtyFree { get; }
Visual Basic
Public ReadOnly Property QtyFree As Double
    Get

Property Value

Type: Double

Remarks

Calculation: QtyOnHand - QtyReserved - QtyWIP

Remarks

Service items will always report int.MaxValue.

See Also

LotContext Class
LotContext Members
Pastel.Evolution Namespace
LotContext..::..QtyWIP
LotContext..::..QtyReserved


LotContext.QtyNetPurchased Property

[image]

Pastel Evolution SDK
LotContext..::..QtyNetPurchased Property
LotContext Class See Also Send Feedback
Net quantity purchased: purchased - returned

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double QtyNetPurchased { get; }
Visual Basic
Public ReadOnly Property QtyNetPurchased As Double
    Get

Property Value

Type: Double

See Also

LotContext Class
LotContext Members


LotContext.QtyNetSold Property

[image]

Pastel Evolution SDK
LotContext..::..QtyNetSold Property
LotContext Class See Also Send Feedback
Net quantity sold: sold - credited

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double QtyNetSold { get; }
Visual Basic
Public ReadOnly Property QtyNetSold As Double
    Get

Property Value

Type: Double

See Also

LotContext Class
LotContext Members


LotContext.QtyOnHand Property

[image]

Pastel Evolution SDK
LotContext..::..QtyOnHand Property
LotContext Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double QtyOnHand { get; }
Visual Basic
Public ReadOnly Property QtyOnHand As Double
    Get

Property Value

Type: Double

See Also

LotContext Class
LotContext Members


LotContext.QtyReserved Property

[image]

Pastel Evolution SDK
LotContext..::..QtyReserved Property
LotContext Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double QtyReserved { get; }
Visual Basic
Public ReadOnly Property QtyReserved As Double
    Get

Property Value

Type: Double

See Also

LotContext Class
LotContext Members


LotContext.QtyWIP Property

[image]

Pastel Evolution SDK
LotContext..::..QtyWIP Property
LotContext Class See Also Send Feedback
Gets the quantity of stock on active jobs and in manufacturing (work in progress).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double QtyWIP { get; }
Visual Basic
Public ReadOnly Property QtyWIP As Double
    Get

Property Value

Type: Double

See Also

LotContext Class
LotContext Members


LotContext.Warehouse Property

[image]

Pastel Evolution SDK
LotContext..::..Warehouse Property
LotContext Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Warehouse Warehouse { get; }
Visual Basic
Public ReadOnly Property Warehouse As Warehouse
    Get

Property Value

Type: Warehouse

See Also

LotContext Class
LotContext Members


LotContext.WarehouseID Property

[image]

Pastel Evolution SDK
LotContext..::..WarehouseID Property
LotContext Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int WarehouseID { get; }
Visual Basic
Public ReadOnly Property WarehouseID As Integer
    Get

Property Value

Type: Int32

See Also

LotContext Class
LotContext Members


LotContext.LotContextCollection Class

[image]

Pastel Evolution SDK
LotContext..::..LotContextCollection Class
LotContext Class Members See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class LotContextCollection : CollectionBase
Visual Basic
Public Class LotContextCollection
    Inherits CollectionBase

Inheritance Hierarchy

System..::..Object
System.Collections..::..CollectionBase
Pastel.Evolution..::..LotContext..::..LotContextCollection

See Also

LotContext..::..LotContextCollection Members


LotContext.LotContextCollection Members

[image] [image]

Pastel Evolution SDK
LotContext..::..LotContextCollection Members
LotContext..::..LotContextCollection Class Methods Properties See Also Send Feedback

The LotContext..::..LotContextCollection type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item[([( Int32])]) | Gets a lot context by warehouse ID, not by index.
Public property | Item[([( String])]) |
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

LotContext..::..LotContextCollection Class


LotContext.LotContextCollection Methods

[image] [image]

Pastel Evolution SDK
LotContext..::..LotContextCollection Methods
LotContext..::..LotContextCollection Class See Also Send Feedback

The LotContext..::..LotContextCollection type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LotContext..::..LotContextCollection Class


LotContext.LotContextCollection Properties

[image] [image]

Pastel Evolution SDK
LotContext..::..LotContextCollection Properties
LotContext..::..LotContextCollection Class See Also Send Feedback

The LotContext..::..LotContextCollection type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item[([( Int32])]) | Gets a lot context by warehouse ID, not by index.
Public property | Item[([( String])]) |
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

LotContext..::..LotContextCollection Class


LotContext.LotContextCollection.Item Property

[image] [image]

Pastel Evolution SDK
LotContext..::..LotContextCollection..::..Item Property
LotContext..::..LotContextCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public property | Item[([( Int32])]) | Gets a lot context by warehouse ID, not by index.
Public property | Item[([( String])]) |

See Also

LotContext..::..LotContextCollection Class
LotContext..::..LotContextCollection Members


LotContext.LotContextCollection.Item Property (Int32)

[image]

Pastel Evolution SDK
LotContext..::..LotContextCollection..::..Item Property (Int32)
LotContext..::..LotContextCollection Class See Also Send Feedback
Gets a lot context by warehouse ID, not by index.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public LotContext this[
    int warehouseID
] { get; }
Visual Basic
Public ReadOnly Default Property Item (
    warehouseID As Integer
) As LotContext
    Get

Parameters

warehouseID
Type: System..::..Int32

Return Value

Type: LotContext

See Also

LotContext..::..LotContextCollection Class
LotContext..::..LotContextCollection Members
Item Overload


LotContext.LotContextCollection.Item Property (String)

[image]

Pastel Evolution SDK
LotContext..::..LotContextCollection..::..Item Property (String)
LotContext..::..LotContextCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public LotContext this[
    string whseCode
] { get; }
Visual Basic
Public ReadOnly Default Property Item (
    whseCode As String
) As LotContext
    Get

Parameters

whseCode
Type: System..::..String

Property Value

Type: LotContext

See Also

LotContext..::..LotContextCollection Class
LotContext..::..LotContextCollection Members
Item Overload


LotStatus Class

[image]

Pastel Evolution SDK
LotStatus Class
Members See Also Send Feedback
Represents a lot status indicator.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class LotStatus : BranchedRecordBase
Visual Basic
Public Class LotStatus
    Inherits BranchedRecordBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..LotStatus

See Also

LotStatus Members


LotStatus Members

[image] [image]

Pastel Evolution SDK
LotStatus Members
LotStatus Class Constructors Methods Fields Properties See Also Send Feedback

The LotStatus type exposes the following members.

Constructors

 | Name | Description
Public method | LotStatus()()()() | Initializes a new instance of the LotStatus class
Public method | LotStatus(Int32) | Initializes a new instance of the LotStatus class
Public method | LotStatus(String) | Initializes a new instance of the LotStatus class

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds the first record matching the criteria supplied
 | FindByDescription |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List | Returns a datatable containing the matching rows.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | (Overrides Object..::..ToString()()()().)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | AllowPurchases |
Public property | AllowSales |
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Description |
Public property | ID | (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)

See Also

LotStatus Class


LotStatus Constructor

[image] [image]

Pastel Evolution SDK
LotStatus Constructor
LotStatus Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LotStatus()()()() | Initializes a new instance of the LotStatus class
Public method | LotStatus(Int32) | Initializes a new instance of the LotStatus class
Public method | LotStatus(String) | Initializes a new instance of the LotStatus class

See Also

LotStatus Class
LotStatus Members


LotStatus Constructor

[image]

Pastel Evolution SDK
LotStatus Constructor
LotStatus Class See Also Send Feedback
Initializes a new instance of the LotStatus class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public LotStatus()
Visual Basic
Public Sub New

See Also

LotStatus Class
LotStatus Members
LotStatus Overload


LotStatus Constructor (Int32)

[image]

Pastel Evolution SDK
LotStatus Constructor (Int32)
LotStatus Class See Also Send Feedback
Initializes a new instance of the LotStatus class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public LotStatus(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32

See Also

LotStatus Class
LotStatus Members
LotStatus Overload


LotStatus Constructor (String)

[image]

Pastel Evolution SDK
LotStatus Constructor (String)
LotStatus Class See Also Send Feedback
Initializes a new instance of the LotStatus class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public LotStatus(
    string description
)
Visual Basic
Public Sub New (
    description As String
)

Parameters

description
Type: System..::..String

See Also

LotStatus Class
LotStatus Members
LotStatus Overload


LotStatus Fields

[image] [image]

Pastel Evolution SDK
LotStatus Fields
LotStatus Class See Also Send Feedback

The LotStatus type exposes the following members.

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

LotStatus Class


LotStatus Methods

[image] [image]

Pastel Evolution SDK
LotStatus Methods
LotStatus Class See Also Send Feedback

The LotStatus type exposes the following members.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds the first record matching the criteria supplied
 | FindByDescription |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List | Returns a datatable containing the matching rows.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | (Overrides Object..::..ToString()()()().)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

LotStatus Class


LotStatus.Find Method

[image]

Pastel Evolution SDK
LotStatus..::..Find Method
LotStatus Class See Also Send Feedback
Finds the first record matching the criteria supplied

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String
E.g. Code = 'abc'

Return Value

Type: Int32
The id of the record

See Also

LotStatus Class
LotStatus Members


LotStatus.FindByDescription Method

[image]

Pastel Evolution SDK
LotStatus..::..FindByDescription Method
LotStatus Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int FindByDescription(
    string description
)
Visual Basic
Public Shared Function FindByDescription (
    description As String
) As Integer

Parameters

description
Type: System..::..String

Return Value

Type: Int32

See Also

LotStatus Class
LotStatus Members


LotStatus.List Method

[image]

Pastel Evolution SDK
LotStatus..::..List Method
LotStatus Class See Also Send Feedback
Returns a datatable containing the matching rows.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria
)
Visual Basic
Public Shared Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String
e.g. SNStockLink = 100 and CurrentLoc = (int)SerialNumberLocation.InStock

Return Value

Type: DataTable

See Also

LotStatus Class
LotStatus Members


LotStatus.OnDelete Method

[image]

Pastel Evolution SDK
LotStatus..::..OnDelete Method
LotStatus Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

See Also

LotStatus Class
LotStatus Members


LotStatus.OnSave Method

[image]

Pastel Evolution SDK
LotStatus..::..OnSave Method
LotStatus Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

LotStatus Class
LotStatus Members


LotStatus.ToString Method

[image]

Pastel Evolution SDK
LotStatus..::..ToString Method
LotStatus Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String

See Also

LotStatus Class
LotStatus Members


LotStatus Properties

[image] [image]

Pastel Evolution SDK
LotStatus Properties
LotStatus Class See Also Send Feedback

The LotStatus type exposes the following members.

Properties

 | Name | Description
Public property | AllowPurchases |
Public property | AllowSales |
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Description |
Public property | ID | (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)

See Also

LotStatus Class


LotStatus.AllowPurchases Property

[image]

Pastel Evolution SDK
LotStatus..::..AllowPurchases Property
LotStatus Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool AllowPurchases { get; set; }
Visual Basic
Public Property AllowPurchases As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

LotStatus Class
LotStatus Members


LotStatus.AllowSales Property

[image]

Pastel Evolution SDK
LotStatus..::..AllowSales Property
LotStatus Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool AllowSales { get; set; }
Visual Basic
Public Property AllowSales As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

LotStatus Class
LotStatus Members


LotStatus.Description Property

[image]

Pastel Evolution SDK
LotStatus..::..Description Property
LotStatus Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set

Property Value

Type: String

See Also

LotStatus Class
LotStatus Members


LotStatus.ID Property

[image]

Pastel Evolution SDK
LotStatus..::..ID Property
LotStatus Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

See Also

LotStatus Class
LotStatus Members


LotStatus.LongID Property

[image]

Pastel Evolution SDK
LotStatus..::..LongID Property
LotStatus Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

LotStatus Class
LotStatus Members


Module Enumeration

[image]

Pastel Evolution SDK
Module Enumeration
See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public enum Module
Visual Basic
Public Enumeration Module

Members

Member name | Value | Description
Unknown | 127 |
GL | 4 |
AR | 5 |
AP | 6 |
Inventory | 11 |
JobCosting | 99 |

See Also

Pastel.Evolution Namespace


ModuleID Enumeration

[image]

Pastel Evolution SDK
ModuleID Enumeration
See Also Send Feedback
Evolution module ID as it appears in the posting tables. Mainly used internally.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public enum ModuleID
Visual Basic
Public Enumeration ModuleID

Members

Member name | Value | Description
Tax | 0 |
TaxAR | 1 |
TaxAP | 2 |
Bnk | 3 |
Oth | 4 |
JL | 5 |
CB | 6 |
CBAR | 7 |
CBAP | 8 |
SADJ | 9 |
IJr | 10 |
AcPrf | 11 |
Inv | 12 |
Crn | 13 |
Grv | 14 |
Rts | 15 |
APTx | 16 |
ARTx | 17 |
OInv | 18 |
OGrv | 19 |
BOM | 20 |
WTrf | 21 |
WIBTI | 22 |
WIBTR | 23 |
JCI | 24 |
JCS | 25 |
JCG | 26 |
JCM | 27 |
POS | 28 |
POSI | 29 |
POSC | 30 |
MFDR | 31 |
MFRT | 32 |
MFMF | 33 |
MFWA | 34 |
MFR4MF | 35 |
MFBP | 36 |
MFRP | 37 |
MFUM | 38 |
MFVAI | 39 |
MFVAO | 40 |
MFR4UNMF | 41 |
BtAR | 42 |
BtAP | 43 |
RPOS | 44 |
PURGE | 45 |

See Also

Pastel.Evolution Namespace


NatureOfTransaction Class

[image]

Pastel Evolution SDK
NatureOfTransaction Class
Members See Also Send Feedback
Represents an EU Nature of Transaction code.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class NatureOfTransaction : BranchedRecordBase
Visual Basic
Public Class NatureOfTransaction
    Inherits BranchedRecordBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..NatureOfTransaction

See Also

NatureOfTransaction Members


NatureOfTransaction Members

[image] [image]

Pastel Evolution SDK
NatureOfTransaction Members
NatureOfTransaction Class Constructors Methods Fields Properties See Also Send Feedback

The NatureOfTransaction type exposes the following members.

Constructors

 | Name | Description
Public method | NatureOfTransaction()()()() | Creates a new nature of transaction code.
Public method | NatureOfTransaction(Int32) | Creates a new instance of a nature of transaction code.
Public method | NatureOfTransaction(String) | Creates a new instance of a nature of transaction code.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds a project account ID.
 | FindByCode | Attempts to find a project by its code and returns its ID.
 | Get | Returns an instance of the first record satisfying the criteria specified; otherwise, returns null.
 | GetByCode | Returns an instance of the first record with the code specified; otherwise, returns null.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | List | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Code | Gets or sets the nature of transaction code.
Public property | Description | Gets or sets the project description.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)

See Also

NatureOfTransaction Class


NatureOfTransaction Constructor

[image] [image]

Pastel Evolution SDK
NatureOfTransaction Constructor
NatureOfTransaction Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NatureOfTransaction()()()() | Creates a new nature of transaction code.
Public method | NatureOfTransaction(Int32) | Creates a new instance of a nature of transaction code.
Public method | NatureOfTransaction(String) | Creates a new instance of a nature of transaction code.

See Also

NatureOfTransaction Class
NatureOfTransaction Members


NatureOfTransaction Constructor

[image]

Pastel Evolution SDK
NatureOfTransaction Constructor
NatureOfTransaction Class See Also Send Feedback
Creates a new nature of transaction code.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public NatureOfTransaction()
Visual Basic
Public Sub New

See Also

NatureOfTransaction Class
NatureOfTransaction Members
NatureOfTransaction Overload


NatureOfTransaction Constructor (Int32)

[image]

Pastel Evolution SDK
NatureOfTransaction Constructor (Int32)
NatureOfTransaction Class See Also Send Feedback
Creates a new instance of a nature of transaction code.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public NatureOfTransaction(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32
Specifies the id of the existing record.

See Also

NatureOfTransaction Class
NatureOfTransaction Members
NatureOfTransaction Overload


NatureOfTransaction Constructor (String)

[image]

Pastel Evolution SDK
NatureOfTransaction Constructor (String)
NatureOfTransaction Class See Also Send Feedback
Creates a new instance of a nature of transaction code.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public NatureOfTransaction(
    string code
)
Visual Basic
Public Sub New (
    code As String
)

Parameters

code
Type: System..::..String
Specifies the code of the existing record.

See Also

NatureOfTransaction Class
NatureOfTransaction Members
NatureOfTransaction Overload


NatureOfTransaction Fields

[image] [image]

Pastel Evolution SDK
NatureOfTransaction Fields
NatureOfTransaction Class See Also Send Feedback

The NatureOfTransaction type exposes the following members.

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

NatureOfTransaction Class


NatureOfTransaction Methods

[image] [image]

Pastel Evolution SDK
NatureOfTransaction Methods
NatureOfTransaction Class See Also Send Feedback

The NatureOfTransaction type exposes the following members.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds a project account ID.
 | FindByCode | Attempts to find a project by its code and returns its ID.
 | Get | Returns an instance of the first record satisfying the criteria specified; otherwise, returns null.
 | GetByCode | Returns an instance of the first record with the code specified; otherwise, returns null.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | List | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

NatureOfTransaction Class


NatureOfTransaction.Find Method

[image]

Pastel Evolution SDK
NatureOfTransaction..::..Find Method
NatureOfTransaction Class See Also Send Feedback
Finds a project account ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String
The criteria passed to the SQL query. Eg. ProjectCode = 'INT001' or ProjectName like '%Internal%'

Return Value

Type: Int32
The ID of the first record found; -1 if not record was found.

See Also

NatureOfTransaction Class
NatureOfTransaction Members


NatureOfTransaction.FindByCode Method

[image]

Pastel Evolution SDK
NatureOfTransaction..::..FindByCode Method
NatureOfTransaction Class See Also Send Feedback
Attempts to find a project by its code and returns its ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int FindByCode(
    string code
)
Visual Basic
Public Shared Function FindByCode (
    code As String
) As Integer

Parameters

code
Type: System..::..String
The code used to lookup the project.

Return Value

Type: Int32
-1 if no record was found, else the id of the first account matching the criteria supplied.

See Also

NatureOfTransaction Class
NatureOfTransaction Members
Pastel.Evolution Namespace
NatureOfTransaction..::..Find(String)


NatureOfTransaction.Get Method

[image]

Pastel Evolution SDK
NatureOfTransaction..::..Get Method
NatureOfTransaction Class See Also Send Feedback
Returns an instance of the first record satisfying the criteria specified; otherwise, returns null.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static Project Get(
    string criteria
)
Visual Basic
Public Shared Function Get (
    criteria As String
) As Project

Parameters

criteria
Type: System..::..String
The criteria passed to the SQL query. Eg. ProjectCode = 'INT001' or ProjectName like '%Internal%'

Return Value

Type: Project
The record found; otherwise null

See Also

NatureOfTransaction Class
NatureOfTransaction Members
Pastel.Evolution Namespace
NatureOfTransaction..::..Find(String)
Project..::..Project(String)
NatureOfTransaction..::..GetByCode(String)


NatureOfTransaction.GetByCode Method

[image]

Pastel Evolution SDK
NatureOfTransaction..::..GetByCode Method
NatureOfTransaction Class See Also Send Feedback
Returns an instance of the first record with the code specified; otherwise, returns null.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static Project GetByCode(
    string code
)
Visual Basic
Public Shared Function GetByCode (
    code As String
) As Project

Parameters

code
Type: System..::..String
Specifies the code.

Return Value

Type: Project
The record found; otherwise null

See Also

NatureOfTransaction Class
NatureOfTransaction Members
Pastel.Evolution Namespace
NatureOfTransaction..::..Get(String)
Project..::..Project(String)
NatureOfTransaction..::..Find(String)


NatureOfTransaction.List Method

[image]

Pastel Evolution SDK
NatureOfTransaction..::..List Method
NatureOfTransaction Class See Also Send Feedback
Gets a list of database records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DataTable List(
    string criteria
)
Visual Basic
Public Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.

Return Value

Type: DataTable
Table containing selected records.

See Also

NatureOfTransaction Class
NatureOfTransaction Members


NatureOfTransaction.OnDelete Method

[image]

Pastel Evolution SDK
NatureOfTransaction..::..OnDelete Method
NatureOfTransaction Class See Also Send Feedback
Removes the record from the database, provided it is not referenced by other records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

See Also

NatureOfTransaction Class
NatureOfTransaction Members


NatureOfTransaction.OnSave Method

[image]

Pastel Evolution SDK
NatureOfTransaction..::..OnSave Method
NatureOfTransaction Class See Also Send Feedback
Persists the record to the database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

NatureOfTransaction Class
NatureOfTransaction Members


NatureOfTransaction Properties

[image] [image]

Pastel Evolution SDK
NatureOfTransaction Properties
NatureOfTransaction Class See Also Send Feedback

The NatureOfTransaction type exposes the following members.

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Code | Gets or sets the nature of transaction code.
Public property | Description | Gets or sets the project description.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)

See Also

NatureOfTransaction Class


NatureOfTransaction.Code Property

[image]

Pastel Evolution SDK
NatureOfTransaction..::..Code Property
NatureOfTransaction Class See Also Send Feedback
Gets or sets the nature of transaction code.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Code { get; set; }
Visual Basic
Public Property Code As String
    Get
    Set

Property Value

Type: String

See Also

NatureOfTransaction Class
NatureOfTransaction Members


NatureOfTransaction.Description Property

[image]

Pastel Evolution SDK
NatureOfTransaction..::..Description Property
NatureOfTransaction Class See Also Send Feedback
Gets or sets the project description.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set

Property Value

Type: String

See Also

NatureOfTransaction Class
NatureOfTransaction Members


NatureOfTransaction.ID Property

[image]

Pastel Evolution SDK
NatureOfTransaction..::..ID Property
NatureOfTransaction Class See Also Send Feedback
Gets the internal record ID (0 for new, unsaved records).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

Remarks

Once saved, the ID will reflect the record's internal database identifier.

See Also

NatureOfTransaction Class
NatureOfTransaction Members


NatureOfTransaction.LongID Property

[image]

Pastel Evolution SDK
NatureOfTransaction..::..LongID Property
NatureOfTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

NatureOfTransaction Class
NatureOfTransaction Members


Opportunity Class

[image]

Pastel Evolution SDK
Opportunity Class
Members See Also Send Feedback
Represents a Contact Management sales opportunity.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class Opportunity : BranchedRecordBase
Visual Basic
Public Class Opportunity
    Inherits BranchedRecordBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..Opportunity

See Also

Opportunity Members


Opportunity Members

[image] [image]

Pastel Evolution SDK
Opportunity Members
Opportunity Class Constructors Methods Fields Properties See Also Send Feedback

The Opportunity type exposes the following members.

Constructors

 | Name | Description
Public method | Opportunity()()()() | Creates a new instance of an opportunity.
Public method | Opportunity(Int32) | Creates a new instance of an opportunity.

Methods

 | Name | Description
 | _ListCurrentBranch |
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find |
 | FindByCode |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | Account |
Public property | AccountManager |
Public property | ActiveQuote |
Public property | ActiveQuoteID |
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Description |
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | IsPublic | Gets or sets whether or not the prospect is visible to agents other than the assigned agent.
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | Module |
Public property | Person | Gets or sets the person record related to the opportunity.
Public property | PersonID |
Public property | Probability |
Public property | Project |
Public property | Reference |
Public property | Stage |
Public property | StageID |
Public property | State | Gets the opportunity's status. WARNING: this may be renamed to status in future.
Public property | StateID |
Public property | UserFields |

See Also

Opportunity Class


Opportunity Constructor

[image] [image]

Pastel Evolution SDK
Opportunity Constructor
Opportunity Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Opportunity()()()() | Creates a new instance of an opportunity.
Public method | Opportunity(Int32) | Creates a new instance of an opportunity.

See Also

Opportunity Class
Opportunity Members


Opportunity Constructor

[image]

Pastel Evolution SDK
Opportunity Constructor
Opportunity Class See Also Send Feedback
Creates a new instance of an opportunity.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Opportunity()
Visual Basic
Public Sub New

See Also

Opportunity Class
Opportunity Members
Opportunity Overload


Opportunity Constructor (Int32)

[image]

Pastel Evolution SDK
Opportunity Constructor (Int32)
Opportunity Class See Also Send Feedback
Creates a new instance of an opportunity.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Opportunity(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32
Specifies the id of the existing record.

See Also

Opportunity Class
Opportunity Members
Opportunity Overload


Opportunity Fields

[image] [image]

Pastel Evolution SDK
Opportunity Fields
Opportunity Class See Also Send Feedback

The Opportunity type exposes the following members.

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

Opportunity Class


Opportunity Methods

[image] [image]

Pastel Evolution SDK
Opportunity Methods
Opportunity Class See Also Send Feedback

The Opportunity type exposes the following members.

Methods

 | Name | Description
 | _ListCurrentBranch |
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find |
 | FindByCode |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

Opportunity Class


Opportunity._ListCurrentBranch Method

[image]

Pastel Evolution SDK
Opportunity..::.._ListCurrentBranch Method
Opportunity Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable _ListCurrentBranch(
    string criteria
)
Visual Basic
Public Shared Function _ListCurrentBranch (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String

Return Value

Type: DataTable

See Also

Opportunity Class
Opportunity Members


Opportunity.Find Method

[image]

Pastel Evolution SDK
Opportunity..::..Find Method
Opportunity Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String

Return Value

Type: Int32

See Also

Opportunity Class
Opportunity Members


Opportunity.FindByCode Method

[image]

Pastel Evolution SDK
Opportunity..::..FindByCode Method
Opportunity Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int FindByCode(
    string reference
)
Visual Basic
Public Shared Function FindByCode (
    reference As String
) As Integer

Parameters

reference
Type: System..::..String

Return Value

Type: Int32

See Also

Opportunity Class
Opportunity Members


Opportunity.List Method

[image]

Pastel Evolution SDK
Opportunity..::..List Method
Opportunity Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria
)
Visual Basic
Public Shared Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String

Return Value

Type: DataTable

See Also

Opportunity Class
Opportunity Members


Opportunity.OnDelete Method

[image]

Pastel Evolution SDK
Opportunity..::..OnDelete Method
Opportunity Class See Also Send Feedback
Removes the record from the database, provided it is not referenced by other records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

Exceptions

Exception | Condition
IntegrityViolationException |

See Also

Opportunity Class
Opportunity Members


Opportunity.OnSave Method

[image]

Pastel Evolution SDK
Opportunity..::..OnSave Method
Opportunity Class See Also Send Feedback
Persists the record to the database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

Opportunity Class
Opportunity Members


Opportunity Properties

[image] [image]

Pastel Evolution SDK
Opportunity Properties
Opportunity Class See Also Send Feedback

The Opportunity type exposes the following members.

Properties

 | Name | Description
Public property | Account |
Public property | AccountManager |
Public property | ActiveQuote |
Public property | ActiveQuoteID |
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Description |
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | IsPublic | Gets or sets whether or not the prospect is visible to agents other than the assigned agent.
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | Module |
Public property | Person | Gets or sets the person record related to the opportunity.
Public property | PersonID |
Public property | Probability |
Public property | Project |
Public property | Reference |
Public property | Stage |
Public property | StageID |
Public property | State | Gets the opportunity's status. WARNING: this may be renamed to status in future.
Public property | StateID |
Public property | UserFields |

See Also

Opportunity Class


Opportunity.Account Property

[image]

Pastel Evolution SDK
Opportunity..::..Account Property
Opportunity Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public BranchedRecordBase Account { get; set; }
Visual Basic
Public Property Account As BranchedRecordBase
    Get
    Set

Property Value

Type: BranchedRecordBase

See Also

Opportunity Class
Opportunity Members


Opportunity.AccountManager Property

[image]

Pastel Evolution SDK
Opportunity..::..AccountManager Property
Opportunity Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Agent AccountManager { get; set; }
Visual Basic
Public Property AccountManager As Agent
    Get
    Set

Property Value

Type: Agent

See Also

Opportunity Class
Opportunity Members


Opportunity.ActiveQuote Property

[image]

Pastel Evolution SDK
Opportunity..::..ActiveQuote Property
Opportunity Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public SalesOrderQuotation ActiveQuote { get; set; }
Visual Basic
Public Property ActiveQuote As SalesOrderQuotation
    Get
    Set

Property Value

Type: SalesOrderQuotation

See Also

Opportunity Class
Opportunity Members


Opportunity.ActiveQuoteID Property

[image]

Pastel Evolution SDK
Opportunity..::..ActiveQuoteID Property
Opportunity Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int ActiveQuoteID { get; set; }
Visual Basic
Public Property ActiveQuoteID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

Opportunity Class
Opportunity Members


Opportunity.Description Property

[image]

Pastel Evolution SDK
Opportunity..::..Description Property
Opportunity Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set

Property Value

Type: String

See Also

Opportunity Class
Opportunity Members


Opportunity.ID Property

[image]

Pastel Evolution SDK
Opportunity..::..ID Property
Opportunity Class See Also Send Feedback
Gets the internal record ID (0 for new, unsaved records).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

See Also

Opportunity Class
Opportunity Members


Opportunity.IsPublic Property

[image]

Pastel Evolution SDK
Opportunity..::..IsPublic Property
Opportunity Class See Also Send Feedback
Gets or sets whether or not the prospect is visible to agents other than the assigned agent.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool IsPublic { get; set; }
Visual Basic
Public Property IsPublic As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

Opportunity Class
Opportunity Members


Opportunity.LongID Property

[image]

Pastel Evolution SDK
Opportunity..::..LongID Property
Opportunity Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

Opportunity Class
Opportunity Members


Opportunity.Module Property

[image]

Pastel Evolution SDK
Opportunity..::..Module Property
Opportunity Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Module Module { get; }
Visual Basic
Public ReadOnly Property Module As Module
    Get

Property Value

Type: Module

See Also

Opportunity Class
Opportunity Members


Opportunity.Person Property

[image]

Pastel Evolution SDK
Opportunity..::..Person Property
Opportunity Class See Also Send Feedback
Gets or sets the person record related to the opportunity.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Person Person { get; set; }
Visual Basic
Public Property Person As Person
    Get
    Set

Property Value

Type: Person

See Also

Opportunity Class
Opportunity Members


Opportunity.PersonID Property

[image]

Pastel Evolution SDK
Opportunity..::..PersonID Property
Opportunity Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int PersonID { get; }
Visual Basic
Public ReadOnly Property PersonID As Integer
    Get

Property Value

Type: Int32

See Also

Opportunity Class
Opportunity Members


Opportunity.Probability Property

[image]

Pastel Evolution SDK
Opportunity..::..Probability Property
Opportunity Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double Probability { get; set; }
Visual Basic
Public Property Probability As Double
    Get
    Set

Property Value

Type: Double

See Also

Opportunity Class
Opportunity Members


Opportunity.Project Property

[image]

Pastel Evolution SDK
Opportunity..::..Project Property
Opportunity Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Project Project { get; set; }
Visual Basic
Public Property Project As Project
    Get
    Set

Property Value

Type: Project

See Also

Opportunity Class
Opportunity Members


Opportunity.Reference Property

[image]

Pastel Evolution SDK
Opportunity..::..Reference Property
Opportunity Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Reference { get; set; }
Visual Basic
Public Property Reference As String
    Get
    Set

Property Value

Type: String

See Also

Opportunity Class
Opportunity Members


Opportunity.Stage Property

[image]

Pastel Evolution SDK
Opportunity..::..Stage Property
Opportunity Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public OpportunityStage Stage { get; set; }
Visual Basic
Public Property Stage As OpportunityStage
    Get
    Set

Property Value

Type: OpportunityStage

See Also

Opportunity Class
Opportunity Members


Opportunity.StageID Property

[image]

Pastel Evolution SDK
Opportunity..::..StageID Property
Opportunity Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int StageID { get; set; }
Visual Basic
Public Property StageID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

Opportunity Class
Opportunity Members


Opportunity.State Property

[image]

Pastel Evolution SDK
Opportunity..::..State Property
Opportunity Class See Also Send Feedback
Gets the opportunity's status. WARNING: this may be renamed to status in future.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public OpportunityState State { get; set; }
Visual Basic
Public Property State As OpportunityState
    Get
    Set

Property Value

Type: OpportunityState

See Also

Opportunity Class
Opportunity Members


Opportunity.StateID Property

[image]

Pastel Evolution SDK
Opportunity..::..StateID Property
Opportunity Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int StateID { get; set; }
Visual Basic
Public Property StateID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

Opportunity Class
Opportunity Members


Opportunity.UserFields Property

[image]

Pastel Evolution SDK
Opportunity..::..UserFields Property
Opportunity Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public FieldCollection UserFields { get; }
Visual Basic
Public ReadOnly Property UserFields As FieldCollection
    Get

Property Value

Type: FieldCollection

See Also

Opportunity Class
Opportunity Members


OpportunityStage Class

[image]

Pastel Evolution SDK
OpportunityStage Class
Members See Also Send Feedback
Represents a Contact Management sales opportunity stage.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class OpportunityStage : BranchedRecordBase
Visual Basic
Public Class OpportunityStage
    Inherits BranchedRecordBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..OpportunityStage

See Also

OpportunityStage Members


OpportunityStage Members

[image] [image]

Pastel Evolution SDK
OpportunityStage Members
OpportunityStage Class Constructors Methods Fields Properties See Also Send Feedback

The OpportunityStage type exposes the following members.

Constructors

 | Name | Description
Public method | OpportunityStage()()()() | Creates a new instance of an opportunity.
Public method | OpportunityStage(Int32) | Creates a new instance of a prospect.

Methods

 | Name | Description
 | _ListCurrentBranch |
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find |
 | FindByName |
 | GetByName |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Description |
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | Module |
Public property | Name |

See Also

OpportunityStage Class


OpportunityStage Constructor

[image] [image]

Pastel Evolution SDK
OpportunityStage Constructor
OpportunityStage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | OpportunityStage()()()() | Creates a new instance of an opportunity.
Public method | OpportunityStage(Int32) | Creates a new instance of a prospect.

See Also

OpportunityStage Class
OpportunityStage Members


OpportunityStage Constructor

[image]

Pastel Evolution SDK
OpportunityStage Constructor
OpportunityStage Class See Also Send Feedback
Creates a new instance of an opportunity.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public OpportunityStage()
Visual Basic
Public Sub New

See Also

OpportunityStage Class
OpportunityStage Members
OpportunityStage Overload


OpportunityStage Constructor (Int32)

[image]

Pastel Evolution SDK
OpportunityStage Constructor (Int32)
OpportunityStage Class See Also Send Feedback
Creates a new instance of a prospect.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public OpportunityStage(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32
Specifies the id of the existing record.

See Also

OpportunityStage Class
OpportunityStage Members
OpportunityStage Overload


OpportunityStage Fields

[image] [image]

Pastel Evolution SDK
OpportunityStage Fields
OpportunityStage Class See Also Send Feedback

The OpportunityStage type exposes the following members.

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

OpportunityStage Class


OpportunityStage Methods

[image] [image]

Pastel Evolution SDK
OpportunityStage Methods
OpportunityStage Class See Also Send Feedback

The OpportunityStage type exposes the following members.

Methods

 | Name | Description
 | _ListCurrentBranch |
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find |
 | FindByName |
 | GetByName |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

OpportunityStage Class


OpportunityStage._ListCurrentBranch Method

[image]

Pastel Evolution SDK
OpportunityStage..::.._ListCurrentBranch Method
OpportunityStage Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable _ListCurrentBranch(
    string criteria
)
Visual Basic
Public Shared Function _ListCurrentBranch (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String

Return Value

Type: DataTable

See Also

OpportunityStage Class
OpportunityStage Members


OpportunityStage.Find Method

[image]

Pastel Evolution SDK
OpportunityStage..::..Find Method
OpportunityStage Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String

Return Value

Type: Int32

See Also

OpportunityStage Class
OpportunityStage Members


OpportunityStage.FindByName Method

[image]

Pastel Evolution SDK
OpportunityStage..::..FindByName Method
OpportunityStage Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int FindByName(
    string name
)
Visual Basic
Public Shared Function FindByName (
    name As String
) As Integer

Parameters

name
Type: System..::..String

Return Value

Type: Int32

See Also

OpportunityStage Class
OpportunityStage Members


OpportunityStage.GetByName Method

[image]

Pastel Evolution SDK
OpportunityStage..::..GetByName Method
OpportunityStage Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static OpportunityStage GetByName(
    string name
)
Visual Basic
Public Shared Function GetByName (
    name As String
) As OpportunityStage

Parameters

name
Type: System..::..String

Return Value

Type: OpportunityStage

See Also

OpportunityStage Class
OpportunityStage Members


OpportunityStage.List Method

[image]

Pastel Evolution SDK
OpportunityStage..::..List Method
OpportunityStage Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria
)
Visual Basic
Public Shared Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String

Return Value

Type: DataTable

See Also

OpportunityStage Class
OpportunityStage Members


OpportunityStage.OnDelete Method

[image]

Pastel Evolution SDK
OpportunityStage..::..OnDelete Method
OpportunityStage Class See Also Send Feedback
Removes the record from the database, provided it is not referenced by other records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

Exceptions

Exception | Condition
IntegrityViolationException |

See Also

OpportunityStage Class
OpportunityStage Members


OpportunityStage.OnSave Method

[image]

Pastel Evolution SDK
OpportunityStage..::..OnSave Method
OpportunityStage Class See Also Send Feedback
Persists the record to the database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

OpportunityStage Class
OpportunityStage Members


OpportunityStage Properties

[image] [image]

Pastel Evolution SDK
OpportunityStage Properties
OpportunityStage Class See Also Send Feedback

The OpportunityStage type exposes the following members.

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Description |
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | Module |
Public property | Name |

See Also

OpportunityStage Class


OpportunityStage.Description Property

[image]

Pastel Evolution SDK
OpportunityStage..::..Description Property
OpportunityStage Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set

Property Value

Type: String

See Also

OpportunityStage Class
OpportunityStage Members


OpportunityStage.ID Property

[image]

Pastel Evolution SDK
OpportunityStage..::..ID Property
OpportunityStage Class See Also Send Feedback
Gets the internal record ID (0 for new, unsaved records).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

See Also

OpportunityStage Class
OpportunityStage Members


OpportunityStage.LongID Property

[image]

Pastel Evolution SDK
OpportunityStage..::..LongID Property
OpportunityStage Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

OpportunityStage Class
OpportunityStage Members


OpportunityStage.Module Property

[image]

Pastel Evolution SDK
OpportunityStage..::..Module Property
OpportunityStage Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Module Module { get; }
Visual Basic
Public ReadOnly Property Module As Module
    Get

Property Value

Type: Module

See Also

OpportunityStage Class
OpportunityStage Members


OpportunityStage.Name Property

[image]

Pastel Evolution SDK
OpportunityStage..::..Name Property
OpportunityStage Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

Property Value

Type: String

See Also

OpportunityStage Class
OpportunityStage Members


OpportunityState Class

[image]

Pastel Evolution SDK
OpportunityState Class
Members See Also Send Feedback
Represents a Contact Management opportunity status.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class OpportunityState : BranchedRecordBase
Visual Basic
Public Class OpportunityState
    Inherits BranchedRecordBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..OpportunityState

See Also

OpportunityState Members


OpportunityState Members

[image] [image]

Pastel Evolution SDK
OpportunityState Members
OpportunityState Class Constructors Methods Fields Properties See Also Send Feedback

The OpportunityState type exposes the following members.

Constructors

 | Name | Description
Public method | OpportunityState()()()() | Creates a new instance of an opportunity.
Public method | OpportunityState(Int32) | Creates a new instance of a prospect.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | IsFinal | Gets or sets whether or not this state terminates an opportunity.
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | Name |

See Also

OpportunityState Class


OpportunityState Constructor

[image] [image]

Pastel Evolution SDK
OpportunityState Constructor
OpportunityState Class See Also Send Feedback

Overload List

 | Name | Description
Public method | OpportunityState()()()() | Creates a new instance of an opportunity.
Public method | OpportunityState(Int32) | Creates a new instance of a prospect.

See Also

OpportunityState Class
OpportunityState Members


OpportunityState Constructor

[image]

Pastel Evolution SDK
OpportunityState Constructor
OpportunityState Class See Also Send Feedback
Creates a new instance of an opportunity.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public OpportunityState()
Visual Basic
Public Sub New

See Also

OpportunityState Class
OpportunityState Members
OpportunityState Overload


OpportunityState Constructor (Int32)

[image]

Pastel Evolution SDK
OpportunityState Constructor (Int32)
OpportunityState Class See Also Send Feedback
Creates a new instance of a prospect.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public OpportunityState(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32
Specifies the id of the existing record.

See Also

OpportunityState Class
OpportunityState Members
OpportunityState Overload


OpportunityState Fields

[image] [image]

Pastel Evolution SDK
OpportunityState Fields
OpportunityState Class See Also Send Feedback

The OpportunityState type exposes the following members.

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

OpportunityState Class


OpportunityState Methods

[image] [image]

Pastel Evolution SDK
OpportunityState Methods
OpportunityState Class See Also Send Feedback

The OpportunityState type exposes the following members.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

OpportunityState Class


OpportunityState.Find Method

[image]

Pastel Evolution SDK
OpportunityState..::..Find Method
OpportunityState Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String

Return Value

Type: Int32

See Also

OpportunityState Class
OpportunityState Members


OpportunityState.List Method

[image]

Pastel Evolution SDK
OpportunityState..::..List Method
OpportunityState Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria
)
Visual Basic
Public Shared Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String

Return Value

Type: DataTable

See Also

OpportunityState Class
OpportunityState Members


OpportunityState.OnDelete Method

[image]

Pastel Evolution SDK
OpportunityState..::..OnDelete Method
OpportunityState Class See Also Send Feedback
Removes the record from the database, provided it is not referenced by other records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

Exceptions

Exception | Condition
IntegrityViolationException |

See Also

OpportunityState Class
OpportunityState Members


OpportunityState.OnSave Method

[image]

Pastel Evolution SDK
OpportunityState..::..OnSave Method
OpportunityState Class See Also Send Feedback
Persists the record to the database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

OpportunityState Class
OpportunityState Members


OpportunityState Properties

[image] [image]

Pastel Evolution SDK
OpportunityState Properties
OpportunityState Class See Also Send Feedback

The OpportunityState type exposes the following members.

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | IsFinal | Gets or sets whether or not this state terminates an opportunity.
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | Name |

See Also

OpportunityState Class


OpportunityState.ID Property

[image]

Pastel Evolution SDK
OpportunityState..::..ID Property
OpportunityState Class See Also Send Feedback
Gets the internal record ID (0 for new, unsaved records).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

See Also

OpportunityState Class
OpportunityState Members


OpportunityState.IsFinal Property

[image]

Pastel Evolution SDK
OpportunityState..::..IsFinal Property
OpportunityState Class See Also Send Feedback
Gets or sets whether or not this state terminates an opportunity.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool IsFinal { get; set; }
Visual Basic
Public Property IsFinal As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

OpportunityState Class
OpportunityState Members


OpportunityState.LongID Property

[image]

Pastel Evolution SDK
OpportunityState..::..LongID Property
OpportunityState Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

OpportunityState Class
OpportunityState Members


OpportunityState.Name Property

[image]

Pastel Evolution SDK
OpportunityState..::..Name Property
OpportunityState Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

Property Value

Type: String

See Also

OpportunityState Class
OpportunityState Members


OrderBase Class

[image]

Pastel Evolution SDK
OrderBase Class
Members See Also Send Feedback
Includes functionality that is common to all inventory documents. Must be inherited.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract class OrderBase : BranchedRecordBase
Visual Basic
Public MustInherit Class OrderBase
    Inherits BranchedRecordBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..OrderBase
Pastel.Evolution..::..PurchasesDocumentBase
Pastel.Evolution..::..SalesDocumentBase

See Also

OrderBase Members


OrderBase Members

[image] [image]

Pastel Evolution SDK
OrderBase Members
OrderBase Class Constructors Methods Fields Properties See Also Send Feedback

The OrderBase type exposes the following members.

Constructors

 | Name | Description
Protected method | OrderBase()()()() | Initializes a new instance of the OrderBase class
Protected method | OrderBase(Int32) | Initializes a new instance of the OrderBase class
Protected method | OrderBase(String, DocumentType) | Initializes a new instance of the OrderBase class
Protected method | OrderBase(String, DocumentType, String, Int32) | Initializes a new instance of the OrderBase class

Methods

 | Name | Description
Public method | _SetFullQtyToProcess |
Protected method | BeforePostGLBatch |
Protected method | BeforePostInventory |
Protected method | BeforePostLedger |
Protected method | BeforeSave |
Protected method | cascadeForeignValues |
Protected method | cascadeProject |
Protected method | cascadeTaxRate |
Public method | Complete()()()() | Processes (invoices) all outstanding quantities on the order. The entire invoice fails if one or more detail lines do not have sufficient stock available. The CompleteMax method (SalesOrder only) is a variation on this method and attempts to confirm as much of the ordered stock as is available.
Public method | Complete(String) | Process (invoice) all outstanding quantities on the order. The entire invoice fails if one or more detail lines do not have sufficient stock available. The method is a variation on this method and attempts to confirm as much of the ordered stock as is available.
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Protected method | Detach |
Protected method | detailRemainsOutstanding |
Protected method | detailToProcess |
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds a record's database ID.
Protected method | fullQtySelected |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | glCreditPosting |
Protected method | glDebitPosting |
Protected method | initialise | Reverts the order to an unsaved, version 0 (see remarks) state.
 | List | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Not supported. Use the delete facility from inside Evolution. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | (Overrides RecordBase..::..OnSave()()()().)
Public method | Process()()()() | Posts the document to the various accounts and ledgers applicable.
Public method | Process(String) | Posts the document to the various accounts and ledgers applicable.
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | account |
Protected field | archID |
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | currency |
Protected field | dcTran |
Protected field | deliverTo |
Protected field | deliveryMethod |
Protected field | detail |
Protected field | glBatch |
Protected field | invoiceTo |
Protected field | orderPriority |
Protected field | orderStatus |
Protected field | originalDocument |
Protected field | processingAdditionalCosts |
Protected field | processLedger | Should the document process to AR or AP ledger?
Protected field | processStock |
Protected field | project |
Protected field | prospect |
Protected field | settlementTerms |
Protected field | taxType |
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | Account | Gets or sets the AR or AP account associated with the order.
Public property | AccountID | Gets or sets the ID of the AR or AP account associated with the order.
Public property | AllowInvoiceRounding |
Public property | ApplyTaxPerLine | Gets or sets whether tax per line should be applied.
Public property | Audit | Gets the audit number of the last transaction processed by this document. This value defaults to 0, and will not be available on recalled documents.
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Currency | Gets or sets the currency.
Public property | CurrencyID | Gets or sets the document's currency ID.
 | DefaultTaxMode | Gets the global default tax mode.
Public property | DeliverTo | Gets or sets the delivery address.
Public property | DeliveryDate | Gets or sets the delivery date.
Public property | DeliveryMethod | Gets or sets the delivery method.
Public property | DeliveryMethodID | Gets or sets the delivery method ID.
Public property | Description | Gets or sets the document description. This will also be the description on any transactions posted.
Public property | Detail | Gets the order detail collection representing the body of the document.
Public property | Discount | Gets or sets the document discount amount (applicable to tax excl. total),
Public property | DiscountForeign | Gets or sets the document foreign discount amount (applicable to tax excl. total),
Public property | DiscountLastProcessed | Gets the document discount amount last processed.
Public property | DiscountPercent | Gets or sets the document discount percentage.
Public property | DiscountToProcess | Gets the document discount amount about to be processed (applicable to tax excl. total).
Public property | DueDate | Gets or sets the due date.
Public property | ExchangeRate | Gets or sets the exchange rate.
Public property | ExternalOrderNo | Gets or sets the external order number.
Protected property | grossLastProcessTotal |
Protected property | grossLastProcessTotalForeign |
Protected property | grossOutstTotal |
Protected property | grossOutstTotalForeign |
Protected property | grossToProcessTotal |
Protected property | grossToProcessTotalForeign |
Protected property | grossTotal |
Protected property | grossTotalForeign |
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | InvoiceDate | Gets or sets the invoice date.
Public property | InvoiceTo | Gets or sets the invoice address.
Public property | IsLoading | Will be true while the order is busy loading detail.
Public property | IsPartialProcessingAllowed |
Public property | IsProcessing | Will be true while the order is busy processing transactions.
Public property | LedgerTransaction | Gets the last ledger transaction (AR/AP Transaction) posted.
Protected property | lineAdditionalCostTotal |
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | MessageLine1 | Gets or sets the 1st message line.
Public property | MessageLine2 | Gets or sets the 2nd message line.
Public property | MessageLine3 | Gets or sets the 3rd message line.
Protected property | nettLastProcessTotal |
Protected property | nettLastProcessTotalForeign |
Protected property | nettOutstTotal |
Protected property | nettOutstTotalForeign |
Protected property | nettToProcessTotal |
Protected property | nettToProcessTotalForeign |
Public property | OrderDate | Gets or sets the order date.
Public property | OrderNo | Gets or sets the order number.
Public property | OrderPriority | Gets or sets the order priority.
Public property | OrderPriorityID | Gets or sets the order priority ID.
Public property | OrderStatus | Gets or sets the document's order status.
Public property | OrderStatusID | Gets or sets the order status ID.
Public property | OriginalDocument | Gets the original document.
Public property | PrintCount | Gets or sets the print count.
Public property | Project | Gets or sets the project.
Public property | ProjectID | Gets or sets the project ID.
Public property | Prospect |
Public property | ProspectID |
Public property | RawFieldData | Obsolete.
Public property | Reference | Gets or sets the document reference (InvNumber).
Public property | Reference2 | Gets the 2nd document reference.
Public property | SettlementTerms |
Public property | SettlementTermsID |
Public property | State | Gets the document state.
Protected property | taxLastProcessTotal |
Protected property | taxLastProcessTotalForeign |
Public property | TaxMode | Gets or sets the tax mode.
Public property | TaxNumber | Gets or sets the cash account's tax number.
Protected property | taxOutstTotal |
Protected property | taxOutstTotalForeign |
Protected property | taxToProcessTotal |
Protected property | taxToProcessTotalForeign |
Protected property | taxTotal |
Protected property | taxTotalForeign |
Public property | TaxType |
Public property | TotalDiscountAdjusted | Gets the total discount adjusted amount.
Public property | TotalDiscountAdjustedForeign | Gets the total discount adjusted foreign amount.
Public property | TotalExcl | Gets the total excl amount.
Public property | TotalExclForeign | Gets the total excl amount.
Public property | TotalIncl | Gets the total incl amount.
Public property | TotalInclForeign | Gets the total incl amount.
Public property | TotalInclForeignBeforeInvoiceRounding | Gets the total incl amount before Invoice Rounding.
Public property | TotalLastProcessExcl | Gets the total last process excl.
Public property | TotalLastProcessExclForeign | Gets the total last process excl.
Public property | TotalLastProcessIncl | Gets the total last process incl.
Public property | TotalLastProcessInclForeign | Gets the total last process incl.
Public property | TotalLastProcessTax | Gets the total last process tax.
Public property | TotalLastProcessTaxForeign | Gets the total last process tax.
Public property | TotalOutstandingExcl | Gets the total outstanding excl.
Public property | TotalOutstandingExclForeign | Gets the total outstanding excl.
Public property | TotalOutstandingIncl | Gets the total outstanding incl.
Public property | TotalOutstandingInclForeign | Gets the total outstanding incl.
Public property | TotalOutstandingTax | Gets the total outstanding tax.
Public property | TotalOutstandingTaxForeign | Gets the total outstanding tax.
Public property | TotalTax | Gets the total tax amount.
Public property | TotalTaxForeign | Gets the total tax amount.
Public property | TotalToProcessExcl | Gets the total amount to process excl.
Public property | TotalToProcessExclForeign | Gets the total amount to process excl.
Public property | TotalToProcessIncl | Gets the total to process incl.
Public property | TotalToProcessInclForeign | Gets the total to process incl.
Public property | TotalToProcessTax | Gets the total to process tax.
Public property | TotalToProcessTaxForeign | Gets the total to process tax.
Public property | Type | Gets the order's document type.
Public property | UserFields | Gets access to the collection of user-defined fields on the record. Note that the field name is case-sensitive.
Public property | Version | Gets the current version of the order, incremented on every save.

See Also

OrderBase Class


OrderBase Constructor

[image] [image]

Pastel Evolution SDK
OrderBase Constructor
OrderBase Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | OrderBase()()()() | Initializes a new instance of the OrderBase class
Protected method | OrderBase(Int32) | Initializes a new instance of the OrderBase class
Protected method | OrderBase(String, DocumentType) | Initializes a new instance of the OrderBase class
Protected method | OrderBase(String, DocumentType, String, Int32) | Initializes a new instance of the OrderBase class

See Also

OrderBase Class
OrderBase Members


OrderBase Constructor

[image]

Pastel Evolution SDK
OrderBase Constructor
OrderBase Class See Also Send Feedback
Initializes a new instance of the OrderBase class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal OrderBase()
Visual Basic
Protected Friend Sub New

See Also

OrderBase Class
OrderBase Members
OrderBase Overload


OrderBase Constructor (Int32)

[image]

Pastel Evolution SDK
OrderBase Constructor (Int32)
OrderBase Class See Also Send Feedback
Initializes a new instance of the OrderBase class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal OrderBase(
    int id
)
Visual Basic
Protected Friend Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32

See Also

OrderBase Class
OrderBase Members
OrderBase Overload


OrderBase Constructor (String, DocumentType)

[image]

Pastel Evolution SDK
OrderBase Constructor (String, DocumentType)
OrderBase Class See Also Send Feedback
Initializes a new instance of the OrderBase class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal OrderBase(
    string orderNumber,
    DocumentType documentType
)
Visual Basic
Protected Friend Sub New (
    orderNumber As String,
    documentType As DocumentType
)

Parameters

orderNumber
Type: System..::..String
documentType
Type: Pastel.Evolution..::..DocumentType

See Also

OrderBase Class
OrderBase Members
OrderBase Overload


OrderBase Constructor (String, DocumentType, String, Int32)

[image]

Pastel Evolution SDK
OrderBase Constructor (String, DocumentType, String, Int32)
OrderBase Class See Also Send Feedback
Initializes a new instance of the OrderBase class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal OrderBase(
    string orderNumber,
    DocumentType documentType,
    string orderNumber2,
    int documentFlag
)
Visual Basic
Protected Friend Sub New (
    orderNumber As String,
    documentType As DocumentType,
    orderNumber2 As String,
    documentFlag As Integer
)

Parameters

orderNumber
Type: System..::..String
documentType
Type: Pastel.Evolution..::..DocumentType
orderNumber2
Type: System..::..String
documentFlag
Type: System..::..Int32

See Also

OrderBase Class
OrderBase Members
OrderBase Overload


OrderBase Fields

[image] [image]

Pastel Evolution SDK
OrderBase Fields
OrderBase Class See Also Send Feedback

The OrderBase type exposes the following members.

Fields

 | Name | Description
Protected field | account |
Protected field | archID |
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | currency |
Protected field | dcTran |
Protected field | deliverTo |
Protected field | deliveryMethod |
Protected field | detail |
Protected field | glBatch |
Protected field | invoiceTo |
Protected field | orderPriority |
Protected field | orderStatus |
Protected field | originalDocument |
Protected field | processingAdditionalCosts |
Protected field | processLedger | Should the document process to AR or AP ledger?
Protected field | processStock |
Protected field | project |
Protected field | prospect |
Protected field | settlementTerms |
Protected field | taxType |
Protected field | wrapper | (Inherited from RecordBase.)

See Also

OrderBase Class


OrderBase.account Field

[image]

Pastel Evolution SDK
OrderBase..::..account Field
OrderBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected DrCrAccount account
Visual Basic
Protected account As DrCrAccount

Field Value

Type: DrCrAccount

See Also

OrderBase Class
OrderBase Members


OrderBase.archID Field

[image]

Pastel Evolution SDK
OrderBase..::..archID Field
OrderBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected int archID
Visual Basic
Protected archID As Integer

Field Value

Type: Int32

See Also

OrderBase Class
OrderBase Members


OrderBase.currency Field

[image]

Pastel Evolution SDK
OrderBase..::..currency Field
OrderBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected Currency currency
Visual Basic
Protected currency As Currency

Field Value

Type: Currency

See Also

OrderBase Class
OrderBase Members


OrderBase.dcTran Field

[image]

Pastel Evolution SDK
OrderBase..::..dcTran Field
OrderBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected DrCrTransaction dcTran
Visual Basic
Protected dcTran As DrCrTransaction

Field Value

Type: DrCrTransaction

See Also

OrderBase Class
OrderBase Members


OrderBase.deliverTo Field

[image]

Pastel Evolution SDK
OrderBase..::..deliverTo Field
OrderBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected Address deliverTo
Visual Basic
Protected deliverTo As Address

Field Value

Type: Address

See Also

OrderBase Class
OrderBase Members


OrderBase.deliveryMethod Field

[image]

Pastel Evolution SDK
OrderBase..::..deliveryMethod Field
OrderBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected DeliveryMethod deliveryMethod
Visual Basic
Protected deliveryMethod As DeliveryMethod

Field Value

Type: DeliveryMethod

See Also

OrderBase Class
OrderBase Members


OrderBase.detail Field

[image]

Pastel Evolution SDK
OrderBase..::..detail Field
OrderBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected OrderDetailCollection detail
Visual Basic
Protected detail As OrderDetailCollection

Field Value

Type: OrderDetailCollection

See Also

OrderBase Class
OrderBase Members


OrderBase.glBatch Field

[image]

Pastel Evolution SDK
OrderBase..::..glBatch Field
OrderBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal GLBatch glBatch
Visual Basic
Protected Friend glBatch As GLBatch

Field Value

Type: GLBatch

See Also

OrderBase Class
OrderBase Members


OrderBase.invoiceTo Field

[image]

Pastel Evolution SDK
OrderBase..::..invoiceTo Field
OrderBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected Address invoiceTo
Visual Basic
Protected invoiceTo As Address

Field Value

Type: Address

See Also

OrderBase Class
OrderBase Members


OrderBase.orderPriority Field

[image]

Pastel Evolution SDK
OrderBase..::..orderPriority Field
OrderBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected Priority orderPriority
Visual Basic
Protected orderPriority As Priority

Field Value

Type: Priority

See Also

OrderBase Class
OrderBase Members


OrderBase.orderStatus Field

[image]

Pastel Evolution SDK
OrderBase..::..orderStatus Field
OrderBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected OrderStatus orderStatus
Visual Basic
Protected orderStatus As OrderStatus

Field Value

Type: OrderStatus

See Also

OrderBase Class
OrderBase Members


OrderBase.originalDocument Field

[image]

Pastel Evolution SDK
OrderBase..::..originalDocument Field
OrderBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected OrderBase originalDocument
Visual Basic
Protected originalDocument As OrderBase

Field Value

Type: OrderBase

See Also

OrderBase Class
OrderBase Members


OrderBase.processingAdditionalCosts Field

[image]

Pastel Evolution SDK
OrderBase..::..processingAdditionalCosts Field
OrderBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal bool processingAdditionalCosts
Visual Basic
Protected Friend processingAdditionalCosts As Boolean

Field Value

Type: Boolean

See Also

OrderBase Class
OrderBase Members


OrderBase.processLedger Field

[image]

Pastel Evolution SDK
OrderBase..::..processLedger Field
OrderBase Class See Also Send Feedback
Should the document process to AR or AP ledger?

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal bool processLedger
Visual Basic
Protected Friend processLedger As Boolean

Field Value

Type: Boolean

See Also

OrderBase Class
OrderBase Members


OrderBase.processStock Field

[image]

Pastel Evolution SDK
OrderBase..::..processStock Field
OrderBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal bool processStock
Visual Basic
Protected Friend processStock As Boolean

Field Value

Type: Boolean

See Also

OrderBase Class
OrderBase Members


OrderBase.project Field

[image]

Pastel Evolution SDK
OrderBase..::..project Field
OrderBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected Project project
Visual Basic
Protected project As Project

Field Value

Type: Project

See Also

OrderBase Class
OrderBase Members


OrderBase.prospect Field

[image]

Pastel Evolution SDK
OrderBase..::..prospect Field
OrderBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected Prospect prospect
Visual Basic
Protected prospect As Prospect

Field Value

Type: Prospect

See Also

OrderBase Class
OrderBase Members


OrderBase.settlementTerms Field

[image]

Pastel Evolution SDK
OrderBase..::..settlementTerms Field
OrderBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected SettlementTerms settlementTerms
Visual Basic
Protected settlementTerms As SettlementTerms

Field Value

Type: SettlementTerms

See Also

OrderBase Class
OrderBase Members


OrderBase.taxType Field

[image]

Pastel Evolution SDK
OrderBase..::..taxType Field
OrderBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected TaxRate taxType
Visual Basic
Protected taxType As TaxRate

Field Value

Type: TaxRate

See Also

OrderBase Class
OrderBase Members


OrderBase Methods

[image] [image]

Pastel Evolution SDK
OrderBase Methods
OrderBase Class See Also Send Feedback

The OrderBase type exposes the following members.

Methods

 | Name | Description
Public method | _SetFullQtyToProcess |
Protected method | BeforePostGLBatch |
Protected method | BeforePostInventory |
Protected method | BeforePostLedger |
Protected method | BeforeSave |
Protected method | cascadeForeignValues |
Protected method | cascadeProject |
Protected method | cascadeTaxRate |
Public method | Complete()()()() | Processes (invoices) all outstanding quantities on the order. The entire invoice fails if one or more detail lines do not have sufficient stock available. The CompleteMax method (SalesOrder only) is a variation on this method and attempts to confirm as much of the ordered stock as is available.
Public method | Complete(String) | Process (invoice) all outstanding quantities on the order. The entire invoice fails if one or more detail lines do not have sufficient stock available. The method is a variation on this method and attempts to confirm as much of the ordered stock as is available.
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Protected method | Detach |
Protected method | detailRemainsOutstanding |
Protected method | detailToProcess |
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds a record's database ID.
Protected method | fullQtySelected |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | glCreditPosting |
Protected method | glDebitPosting |
Protected method | initialise | Reverts the order to an unsaved, version 0 (see remarks) state.
 | List | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Not supported. Use the delete facility from inside Evolution. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | (Overrides RecordBase..::..OnSave()()()().)
Public method | Process()()()() | Posts the document to the various accounts and ledgers applicable.
Public method | Process(String) | Posts the document to the various accounts and ledgers applicable.
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

OrderBase Class


OrderBase._SetFullQtyToProcess Method

[image]

Pastel Evolution SDK
OrderBase..::.._SetFullQtyToProcess Method
OrderBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void _SetFullQtyToProcess()
Visual Basic
Public Sub _SetFullQtyToProcess

See Also

OrderBase Class
OrderBase Members


OrderBase.BeforePostGLBatch Method

[image]

Pastel Evolution SDK
OrderBase..::..BeforePostGLBatch Method
OrderBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected virtual void BeforePostGLBatch(
    OrderBase orderBase,
    CancelEventArgs e
)
Visual Basic
Protected Overridable Sub BeforePostGLBatch (
    orderBase As OrderBase,
    e As CancelEventArgs
)

Parameters

orderBase
Type: Pastel.Evolution..::..OrderBase
e
Type: System.ComponentModel..::..CancelEventArgs

See Also

OrderBase Class
OrderBase Members


OrderBase.BeforePostInventory Method

[image]

Pastel Evolution SDK
OrderBase..::..BeforePostInventory Method
OrderBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected virtual void BeforePostInventory(
    OrderBase orderBase,
    CancelEventArgs e
)
Visual Basic
Protected Overridable Sub BeforePostInventory (
    orderBase As OrderBase,
    e As CancelEventArgs
)

Parameters

orderBase
Type: Pastel.Evolution..::..OrderBase
e
Type: System.ComponentModel..::..CancelEventArgs

See Also

OrderBase Class
OrderBase Members


OrderBase.BeforePostLedger Method

[image]

Pastel Evolution SDK
OrderBase..::..BeforePostLedger Method
OrderBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected virtual void BeforePostLedger(
    OrderBase orderBase,
    CancelEventArgs e
)
Visual Basic
Protected Overridable Sub BeforePostLedger (
    orderBase As OrderBase,
    e As CancelEventArgs
)

Parameters

orderBase
Type: Pastel.Evolution..::..OrderBase
e
Type: System.ComponentModel..::..CancelEventArgs

See Also

OrderBase Class
OrderBase Members


OrderBase.BeforeSave Method

[image]

Pastel Evolution SDK
OrderBase..::..BeforeSave Method
OrderBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal virtual void BeforeSave()
Visual Basic
Protected Friend Overridable Sub BeforeSave

See Also

OrderBase Class
OrderBase Members


OrderBase.cascadeForeignValues Method

[image]

Pastel Evolution SDK
OrderBase..::..cascadeForeignValues Method
OrderBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal void cascadeForeignValues()
Visual Basic
Protected Friend Sub cascadeForeignValues

See Also

OrderBase Class
OrderBase Members


OrderBase.cascadeProject Method

[image]

Pastel Evolution SDK
OrderBase..::..cascadeProject Method
OrderBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal void cascadeProject()
Visual Basic
Protected Friend Sub cascadeProject

See Also

OrderBase Class
OrderBase Members


OrderBase.cascadeTaxRate Method

[image]

Pastel Evolution SDK
OrderBase..::..cascadeTaxRate Method
OrderBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal void cascadeTaxRate()
Visual Basic
Protected Friend Sub cascadeTaxRate

See Also

OrderBase Class
OrderBase Members


OrderBase.Complete Method

[image] [image]

Pastel Evolution SDK
OrderBase..::..Complete Method
OrderBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Complete()()()() | Processes (invoices) all outstanding quantities on the order. The entire invoice fails if one or more detail lines do not have sufficient stock available. The CompleteMax method (SalesOrder only) is a variation on this method and attempts to confirm as much of the ordered stock as is available.
Public method | Complete(String) | Process (invoice) all outstanding quantities on the order. The entire invoice fails if one or more detail lines do not have sufficient stock available. The method is a variation on this method and attempts to confirm as much of the ordered stock as is available.

See Also

OrderBase Class
OrderBase Members


OrderBase.Complete Method

[image]

Pastel Evolution SDK
OrderBase..::..Complete Method
OrderBase Class See Also Send Feedback
Processes (invoices) all outstanding quantities on the order. The entire invoice fails if one or more detail lines do not have sufficient stock available. The CompleteMax method (SalesOrder only) is a variation on this method and attempts to confirm as much of the ordered stock as is available.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Complete()
Visual Basic
Public Function Complete As String

Return Value

Type: String
The generated reference number.

See Also

OrderBase Class
OrderBase Members
Complete Overload
Pastel.Evolution Namespace
SalesOrder..::..CompleteMax()()()()
OrderBase..::..Process()()()()
OrderBase..::..Process(String)


OrderBase.Complete Method (String)

[image]

Pastel Evolution SDK
OrderBase..::..Complete Method (String)
OrderBase Class See Also Send Feedback
Process (invoice) all outstanding quantities on the order. The entire invoice fails if one or more detail lines do not have sufficient stock available. The method is a variation on this method and attempts to confirm as much of the ordered stock as is available.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Complete(
    string reference
)
Visual Basic
Public Function Complete (
    reference As String
) As String

Parameters

reference
Type: System..::..String
Specifies the transaction reference to use. No duplication checking is performed

Return Value

Type: String
The supplied reference number.

See Also

OrderBase Class
OrderBase Members
Complete Overload
Pastel.Evolution Namespace
SalesOrder..::..CompleteMax()()()()


OrderBase.Detach Method

[image]

Pastel Evolution SDK
OrderBase..::..Detach Method
OrderBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected virtual void Detach()
Visual Basic
Protected Overridable Sub Detach

See Also

OrderBase Class
OrderBase Members


OrderBase.detailRemainsOutstanding Method

[image]

Pastel Evolution SDK
OrderBase..::..detailRemainsOutstanding Method
OrderBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected bool detailRemainsOutstanding()
Visual Basic
Protected Function detailRemainsOutstanding As Boolean

Return Value

Type: Boolean

See Also

OrderBase Class
OrderBase Members


OrderBase.detailToProcess Method

[image]

Pastel Evolution SDK
OrderBase..::..detailToProcess Method
OrderBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected bool detailToProcess()
Visual Basic
Protected Function detailToProcess As Boolean

Return Value

Type: Boolean

See Also

OrderBase Class
OrderBase Members


OrderBase.Find Method

[image]

Pastel Evolution SDK
OrderBase..::..Find Method
OrderBase Class See Also Send Feedback
Finds a record's database ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.

Return Value

Type: Int32
The ID of the first record found; -1 if not record was found.

See Also

OrderBase Class
OrderBase Members


OrderBase.fullQtySelected Method

[image]

Pastel Evolution SDK
OrderBase..::..fullQtySelected Method
OrderBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected bool fullQtySelected()
Visual Basic
Protected Function fullQtySelected As Boolean

Return Value

Type: Boolean

See Also

OrderBase Class
OrderBase Members


OrderBase.glCreditPosting Method

[image]

Pastel Evolution SDK
OrderBase..::..glCreditPosting Method
OrderBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected abstract void glCreditPosting(
    TransactionBase sender,
    TransactionBase..::..GLPostingEventArgs e
)
Visual Basic
Protected MustOverride Sub glCreditPosting (
    sender As TransactionBase,
    e As TransactionBase..::..GLPostingEventArgs
)

Parameters

sender
Type: Pastel.Evolution..::..TransactionBase
e
Type: Pastel.Evolution..::..TransactionBase..::..GLPostingEventArgs

See Also

OrderBase Class
OrderBase Members


OrderBase.glDebitPosting Method

[image]

Pastel Evolution SDK
OrderBase..::..glDebitPosting Method
OrderBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected abstract void glDebitPosting(
    TransactionBase sender,
    TransactionBase..::..GLPostingEventArgs e
)
Visual Basic
Protected MustOverride Sub glDebitPosting (
    sender As TransactionBase,
    e As TransactionBase..::..GLPostingEventArgs
)

Parameters

sender
Type: Pastel.Evolution..::..TransactionBase
e
Type: Pastel.Evolution..::..TransactionBase..::..GLPostingEventArgs

See Also

OrderBase Class
OrderBase Members


OrderBase.initialise Method

[image]

Pastel Evolution SDK
OrderBase..::..initialise Method
OrderBase Class See Also Send Feedback
Reverts the order to an unsaved, version 0 (see remarks) state.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal virtual void initialise()
Visual Basic
Protected Friend Overridable Sub initialise

Remarks

Version 0: When using the Revert method, the order is set to an unsaved state, allowing it to be saved as another order. It does not; however, revert back to the last saved state, but rather assumes the current state as far as order detail is concerned.

See Also

OrderBase Class
OrderBase Members


OrderBase.List Method

[image]

Pastel Evolution SDK
OrderBase..::..List Method
OrderBase Class See Also Send Feedback
Gets a list of database records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria
)
Visual Basic
Public Shared Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.

Return Value

Type: DataTable
Table containing selected records.

See Also

OrderBase Class
OrderBase Members


OrderBase.OnDelete Method

[image]

Pastel Evolution SDK
OrderBase..::..OnDelete Method
OrderBase Class See Also Send Feedback
Not supported. Use the delete facility from inside Evolution.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

See Also

OrderBase Class
OrderBase Members


OrderBase.OnSave Method

[image]

Pastel Evolution SDK
OrderBase..::..OnSave Method
OrderBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

OrderBase Class
OrderBase Members


OrderBase.Process Method

[image] [image]

Pastel Evolution SDK
OrderBase..::..Process Method
OrderBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Process()()()() | Posts the document to the various accounts and ledgers applicable.
Public method | Process(String) | Posts the document to the various accounts and ledgers applicable.

See Also

OrderBase Class
OrderBase Members


OrderBase.Process Method

[image]

Pastel Evolution SDK
OrderBase..::..Process Method
OrderBase Class See Also Send Feedback
Posts the document to the various accounts and ledgers applicable.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public virtual string Process()
Visual Basic
Public Overridable Function Process As String

Return Value

Type: String
The generated reference number.

See Also

OrderBase Class
OrderBase Members
Process Overload


OrderBase.Process Method (String)

[image]

Pastel Evolution SDK
OrderBase..::..Process Method (String)
OrderBase Class See Also Send Feedback
Posts the document to the various accounts and ledgers applicable.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public virtual string Process(
    string reference
)
Visual Basic
Public Overridable Function Process (
    reference As String
) As String

Parameters

reference
Type: System..::..String
Specifies the transaction reference to use. No duplication checking is performed.

Return Value

Type: String
The reference number supplied.

Remarks

Use this method when a document reference has already been generated outside the Evolution system.

See Also

OrderBase Class
OrderBase Members
Process Overload
Pastel.Evolution Namespace
OrderBase..::..Process()()()()


OrderBase Properties

[image] [image]

Pastel Evolution SDK
OrderBase Properties
OrderBase Class See Also Send Feedback

The OrderBase type exposes the following members.

Properties

 | Name | Description
Public property | Account | Gets or sets the AR or AP account associated with the order.
Public property | AccountID | Gets or sets the ID of the AR or AP account associated with the order.
Public property | AllowInvoiceRounding |
Public property | ApplyTaxPerLine | Gets or sets whether tax per line should be applied.
Public property | Audit | Gets the audit number of the last transaction processed by this document. This value defaults to 0, and will not be available on recalled documents.
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Currency | Gets or sets the currency.
Public property | CurrencyID | Gets or sets the document's currency ID.
 | DefaultTaxMode | Gets the global default tax mode.
Public property | DeliverTo | Gets or sets the delivery address.
Public property | DeliveryDate | Gets or sets the delivery date.
Public property | DeliveryMethod | Gets or sets the delivery method.
Public property | DeliveryMethodID | Gets or sets the delivery method ID.
Public property | Description | Gets or sets the document description. This will also be the description on any transactions posted.
Public property | Detail | Gets the order detail collection representing the body of the document.
Public property | Discount | Gets or sets the document discount amount (applicable to tax excl. total),
Public property | DiscountForeign | Gets or sets the document foreign discount amount (applicable to tax excl. total),
Public property | DiscountLastProcessed | Gets the document discount amount last processed.
Public property | DiscountPercent | Gets or sets the document discount percentage.
Public property | DiscountToProcess | Gets the document discount amount about to be processed (applicable to tax excl. total).
Public property | DueDate | Gets or sets the due date.
Public property | ExchangeRate | Gets or sets the exchange rate.
Public property | ExternalOrderNo | Gets or sets the external order number.
Protected property | grossLastProcessTotal |
Protected property | grossLastProcessTotalForeign |
Protected property | grossOutstTotal |
Protected property | grossOutstTotalForeign |
Protected property | grossToProcessTotal |
Protected property | grossToProcessTotalForeign |
Protected property | grossTotal |
Protected property | grossTotalForeign |
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | InvoiceDate | Gets or sets the invoice date.
Public property | InvoiceTo | Gets or sets the invoice address.
Public property | IsLoading | Will be true while the order is busy loading detail.
Public property | IsPartialProcessingAllowed |
Public property | IsProcessing | Will be true while the order is busy processing transactions.
Public property | LedgerTransaction | Gets the last ledger transaction (AR/AP Transaction) posted.
Protected property | lineAdditionalCostTotal |
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | MessageLine1 | Gets or sets the 1st message line.
Public property | MessageLine2 | Gets or sets the 2nd message line.
Public property | MessageLine3 | Gets or sets the 3rd message line.
Protected property | nettLastProcessTotal |
Protected property | nettLastProcessTotalForeign |
Protected property | nettOutstTotal |
Protected property | nettOutstTotalForeign |
Protected property | nettToProcessTotal |
Protected property | nettToProcessTotalForeign |
Public property | OrderDate | Gets or sets the order date.
Public property | OrderNo | Gets or sets the order number.
Public property | OrderPriority | Gets or sets the order priority.
Public property | OrderPriorityID | Gets or sets the order priority ID.
Public property | OrderStatus | Gets or sets the document's order status.
Public property | OrderStatusID | Gets or sets the order status ID.
Public property | OriginalDocument | Gets the original document.
Public property | PrintCount | Gets or sets the print count.
Public property | Project | Gets or sets the project.
Public property | ProjectID | Gets or sets the project ID.
Public property | Prospect |
Public property | ProspectID |
Public property | RawFieldData | Obsolete.
Public property | Reference | Gets or sets the document reference (InvNumber).
Public property | Reference2 | Gets the 2nd document reference.
Public property | SettlementTerms |
Public property | SettlementTermsID |
Public property | State | Gets the document state.
Protected property | taxLastProcessTotal |
Protected property | taxLastProcessTotalForeign |
Public property | TaxMode | Gets or sets the tax mode.
Public property | TaxNumber | Gets or sets the cash account's tax number.
Protected property | taxOutstTotal |
Protected property | taxOutstTotalForeign |
Protected property | taxToProcessTotal |
Protected property | taxToProcessTotalForeign |
Protected property | taxTotal |
Protected property | taxTotalForeign |
Public property | TaxType |
Public property | TotalDiscountAdjusted | Gets the total discount adjusted amount.
Public property | TotalDiscountAdjustedForeign | Gets the total discount adjusted foreign amount.
Public property | TotalExcl | Gets the total excl amount.
Public property | TotalExclForeign | Gets the total excl amount.
Public property | TotalIncl | Gets the total incl amount.
Public property | TotalInclForeign | Gets the total incl amount.
Public property | TotalInclForeignBeforeInvoiceRounding | Gets the total incl amount before Invoice Rounding.
Public property | TotalLastProcessExcl | Gets the total last process excl.
Public property | TotalLastProcessExclForeign | Gets the total last process excl.
Public property | TotalLastProcessIncl | Gets the total last process incl.
Public property | TotalLastProcessInclForeign | Gets the total last process incl.
Public property | TotalLastProcessTax | Gets the total last process tax.
Public property | TotalLastProcessTaxForeign | Gets the total last process tax.
Public property | TotalOutstandingExcl | Gets the total outstanding excl.
Public property | TotalOutstandingExclForeign | Gets the total outstanding excl.
Public property | TotalOutstandingIncl | Gets the total outstanding incl.
Public property | TotalOutstandingInclForeign | Gets the total outstanding incl.
Public property | TotalOutstandingTax | Gets the total outstanding tax.
Public property | TotalOutstandingTaxForeign | Gets the total outstanding tax.
Public property | TotalTax | Gets the total tax amount.
Public property | TotalTaxForeign | Gets the total tax amount.
Public property | TotalToProcessExcl | Gets the total amount to process excl.
Public property | TotalToProcessExclForeign | Gets the total amount to process excl.
Public property | TotalToProcessIncl | Gets the total to process incl.
Public property | TotalToProcessInclForeign | Gets the total to process incl.
Public property | TotalToProcessTax | Gets the total to process tax.
Public property | TotalToProcessTaxForeign | Gets the total to process tax.
Public property | Type | Gets the order's document type.
Public property | UserFields | Gets access to the collection of user-defined fields on the record. Note that the field name is case-sensitive.
Public property | Version | Gets the current version of the order, incremented on every save.

See Also

OrderBase Class


OrderBase.Account Property

[image]

Pastel Evolution SDK
OrderBase..::..Account Property
OrderBase Class See Also Send Feedback
Gets or sets the AR or AP account associated with the order.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DrCrAccount Account { get; set; }
Visual Basic
Public Property Account As DrCrAccount
    Get
    Set

Property Value

Type: DrCrAccount

See Also

OrderBase Class
OrderBase Members
Pastel.Evolution Namespace
Pastel.Evolution..::..Supplier
Pastel.Evolution..::..Customer


OrderBase.AccountID Property

[image]

Pastel Evolution SDK
OrderBase..::..AccountID Property
OrderBase Class See Also Send Feedback
Gets or sets the ID of the AR or AP account associated with the order.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int AccountID { get; set; }
Visual Basic
Public Property AccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

OrderBase Class
OrderBase Members


OrderBase.AllowInvoiceRounding Property

[image]

Pastel Evolution SDK
OrderBase..::..AllowInvoiceRounding Property
OrderBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool AllowInvoiceRounding { get; set; }
Visual Basic
Public Property AllowInvoiceRounding As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

OrderBase Class
OrderBase Members


OrderBase.ApplyTaxPerLine Property

[image]

Pastel Evolution SDK
OrderBase..::..ApplyTaxPerLine Property
OrderBase Class See Also Send Feedback
Gets or sets whether tax per line should be applied.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool ApplyTaxPerLine { get; set; }
Visual Basic
Public Property ApplyTaxPerLine As Boolean
    Get
    Set

Property Value

Type: Boolean

Remarks

When tax per line is false the Tax amount will be calculated on the Total Order Exclusive amount, instead of each Line's Exclusive amount.

See Also

OrderBase Class
OrderBase Members


OrderBase.Audit Property

[image]

Pastel Evolution SDK
OrderBase..::..Audit Property
OrderBase Class See Also Send Feedback
Gets the audit number of the last transaction processed by this document. This value defaults to 0, and will not be available on recalled documents.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Audit { get; }
Visual Basic
Public ReadOnly Property Audit As String
    Get

Property Value

Type: String

See Also

OrderBase Class
OrderBase Members


OrderBase.Currency Property

[image]

Pastel Evolution SDK
OrderBase..::..Currency Property
OrderBase Class See Also Send Feedback
Gets or sets the currency.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Currency Currency { get; internal set; }
Visual Basic
Public Property Currency As Currency
    Get
    Friend Set

Property Value

Type: Currency

See Also

OrderBase Class
OrderBase Members


OrderBase.CurrencyID Property

[image]

Pastel Evolution SDK
OrderBase..::..CurrencyID Property
OrderBase Class See Also Send Feedback
Gets or sets the document's currency ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int CurrencyID { get; }
Visual Basic
Public ReadOnly Property CurrencyID As Integer
    Get

Property Value

Type: Int32

See Also

OrderBase Class
OrderBase Members


OrderBase.DefaultTaxMode Property

[image]

Pastel Evolution SDK
OrderBase..::..DefaultTaxMode Property
OrderBase Class See Also Send Feedback
Gets the global default tax mode.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static TaxMode DefaultTaxMode { get; }
Visual Basic
Public Shared ReadOnly Property DefaultTaxMode As TaxMode
    Get

Property Value

Type: TaxMode

Remarks

The default tax mode is Exclusive. This is to provide backward compatibility with earlier implementations of the SDK.

See Also

OrderBase Class
OrderBase Members


OrderBase.DeliverTo Property

[image]

Pastel Evolution SDK
OrderBase..::..DeliverTo Property
OrderBase Class See Also Send Feedback
Gets or sets the delivery address.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Address DeliverTo { get; set; }
Visual Basic
Public Property DeliverTo As Address
    Get
    Set

Property Value

Type: Address

See Also

OrderBase Class
OrderBase Members


OrderBase.DeliveryDate Property

[image]

Pastel Evolution SDK
OrderBase..::..DeliveryDate Property
OrderBase Class See Also Send Feedback
Gets or sets the delivery date.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DateTime DeliveryDate { get; set; }
Visual Basic
Public Property DeliveryDate As DateTime
    Get
    Set

Property Value

Type: DateTime

See Also

OrderBase Class
OrderBase Members


OrderBase.DeliveryMethod Property

[image]

Pastel Evolution SDK
OrderBase..::..DeliveryMethod Property
OrderBase Class See Also Send Feedback
Gets or sets the delivery method.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DeliveryMethod DeliveryMethod { get; set; }
Visual Basic
Public Property DeliveryMethod As DeliveryMethod
    Get
    Set

Property Value

Type: DeliveryMethod

See Also

OrderBase Class
OrderBase Members


OrderBase.DeliveryMethodID Property

[image]

Pastel Evolution SDK
OrderBase..::..DeliveryMethodID Property
OrderBase Class See Also Send Feedback
Gets or sets the delivery method ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int DeliveryMethodID { get; set; }
Visual Basic
Public Property DeliveryMethodID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

OrderBase Class
OrderBase Members


OrderBase.Description Property

[image]

Pastel Evolution SDK
OrderBase..::..Description Property
OrderBase Class See Also Send Feedback
Gets or sets the document description. This will also be the description on any transactions posted.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set

Property Value

Type: String

See Also

OrderBase Class
OrderBase Members


OrderBase.Detail Property

[image]

Pastel Evolution SDK
OrderBase..::..Detail Property
OrderBase Class See Also Send Feedback
Gets the order detail collection representing the body of the document.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public OrderDetailCollection Detail { get; }
Visual Basic
Public ReadOnly Property Detail As OrderDetailCollection
    Get

Property Value

Type: OrderDetailCollection

See Also

OrderBase Class
OrderBase Members
Pastel.Evolution Namespace
Pastel.Evolution..::..OrderDetail


OrderBase.Discount Property

[image]

Pastel Evolution SDK
OrderBase..::..Discount Property
OrderBase Class See Also Send Feedback
Gets or sets the document discount amount (applicable to tax excl. total),

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double Discount { get; set; }
Visual Basic
Public Property Discount As Double
    Get
    Set

Property Value

Type: Double

Remarks

Document discount is applied after line discount.

See Also

OrderBase Class
OrderBase Members


OrderBase.DiscountForeign Property

[image]

Pastel Evolution SDK
OrderBase..::..DiscountForeign Property
OrderBase Class See Also Send Feedback
Gets or sets the document foreign discount amount (applicable to tax excl. total),

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double DiscountForeign { get; set; }
Visual Basic
Public Property DiscountForeign As Double
    Get
    Set

Property Value

Type: Double

Remarks

Document foreign discount is applied after line discount.

See Also

OrderBase Class
OrderBase Members


OrderBase.DiscountLastProcessed Property

[image]

Pastel Evolution SDK
OrderBase..::..DiscountLastProcessed Property
OrderBase Class See Also Send Feedback
Gets the document discount amount last processed.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double DiscountLastProcessed { get; }
Visual Basic
Public ReadOnly Property DiscountLastProcessed As Double
    Get

Property Value

Type: Double

Remarks

Document discount is applied after line discount.

See Also

OrderBase Class
OrderBase Members


OrderBase.DiscountPercent Property

[image]

Pastel Evolution SDK
OrderBase..::..DiscountPercent Property
OrderBase Class See Also Send Feedback
Gets or sets the document discount percentage.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double DiscountPercent { get; set; }
Visual Basic
Public Property DiscountPercent As Double
    Get
    Set

Property Value

Type: Double

Remarks

Document discount is applied after line discount.

See Also

OrderBase Class
OrderBase Members


OrderBase.DiscountToProcess Property

[image]

Pastel Evolution SDK
OrderBase..::..DiscountToProcess Property
OrderBase Class See Also Send Feedback
Gets the document discount amount about to be processed (applicable to tax excl. total).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double DiscountToProcess { get; }
Visual Basic
Public ReadOnly Property DiscountToProcess As Double
    Get

Property Value

Type: Double

Remarks

Document discount is applied after line discount.

See Also

OrderBase Class
OrderBase Members


OrderBase.DueDate Property

[image]

Pastel Evolution SDK
OrderBase..::..DueDate Property
OrderBase Class See Also Send Feedback
Gets or sets the due date.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DateTime DueDate { get; set; }
Visual Basic
Public Property DueDate As DateTime
    Get
    Set

Property Value

Type: DateTime

See Also

OrderBase Class
OrderBase Members


OrderBase.ExchangeRate Property

[image]

Pastel Evolution SDK
OrderBase..::..ExchangeRate Property
OrderBase Class See Also Send Feedback
Gets or sets the exchange rate.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double ExchangeRate { get; set; }
Visual Basic
Public Property ExchangeRate As Double
    Get
    Set

Property Value

Type: Double

See Also

OrderBase Class
OrderBase Members


OrderBase.ExternalOrderNo Property

[image]

Pastel Evolution SDK
OrderBase..::..ExternalOrderNo Property
OrderBase Class See Also Send Feedback
Gets or sets the external order number.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string ExternalOrderNo { get; set; }
Visual Basic
Public Property ExternalOrderNo As String
    Get
    Set

Property Value

Type: String

See Also

OrderBase Class
OrderBase Members


OrderBase.grossLastProcessTotal Property

[image]

Pastel Evolution SDK
OrderBase..::..grossLastProcessTotal Property
OrderBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected double grossLastProcessTotal { get; }
Visual Basic
Protected ReadOnly Property grossLastProcessTotal As Double
    Get

Property Value

Type: Double

See Also

OrderBase Class
OrderBase Members


OrderBase.grossLastProcessTotalForeign Property

[image]

Pastel Evolution SDK
OrderBase..::..grossLastProcessTotalForeign Property
OrderBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected double grossLastProcessTotalForeign { get; }
Visual Basic
Protected ReadOnly Property grossLastProcessTotalForeign As Double
    Get

Property Value

Type: Double

See Also

OrderBase Class
OrderBase Members


OrderBase.grossOutstTotal Property

[image]

Pastel Evolution SDK
OrderBase..::..grossOutstTotal Property
OrderBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected double grossOutstTotal { get; }
Visual Basic
Protected ReadOnly Property grossOutstTotal As Double
    Get

Property Value

Type: Double

See Also

OrderBase Class
OrderBase Members


OrderBase.grossOutstTotalForeign Property

[image]

Pastel Evolution SDK
OrderBase..::..grossOutstTotalForeign Property
OrderBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected double grossOutstTotalForeign { get; }
Visual Basic
Protected ReadOnly Property grossOutstTotalForeign As Double
    Get

Property Value

Type: Double

See Also

OrderBase Class
OrderBase Members


OrderBase.grossToProcessTotal Property

[image]

Pastel Evolution SDK
OrderBase..::..grossToProcessTotal Property
OrderBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected double grossToProcessTotal { get; }
Visual Basic
Protected ReadOnly Property grossToProcessTotal As Double
    Get

Property Value

Type: Double

See Also

OrderBase Class
OrderBase Members


OrderBase.grossToProcessTotalForeign Property

[image]

Pastel Evolution SDK
OrderBase..::..grossToProcessTotalForeign Property
OrderBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected double grossToProcessTotalForeign { get; }
Visual Basic
Protected ReadOnly Property grossToProcessTotalForeign As Double
    Get

Property Value

Type: Double

See Also

OrderBase Class
OrderBase Members


OrderBase.grossTotal Property

[image]

Pastel Evolution SDK
OrderBase..::..grossTotal Property
OrderBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected double grossTotal { get; }
Visual Basic
Protected ReadOnly Property grossTotal As Double
    Get

Property Value

Type: Double

See Also

OrderBase Class
OrderBase Members


OrderBase.grossTotalForeign Property

[image]

Pastel Evolution SDK
OrderBase..::..grossTotalForeign Property
OrderBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected double grossTotalForeign { get; }
Visual Basic
Protected ReadOnly Property grossTotalForeign As Double
    Get

Property Value

Type: Double

See Also

OrderBase Class
OrderBase Members


OrderBase.ID Property

[image]

Pastel Evolution SDK
OrderBase..::..ID Property
OrderBase Class See Also Send Feedback
Gets the internal record ID (0 for new, unsaved records).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

See Also

OrderBase Class
OrderBase Members


OrderBase.InvoiceDate Property

[image]

Pastel Evolution SDK
OrderBase..::..InvoiceDate Property
OrderBase Class See Also Send Feedback
Gets or sets the invoice date.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DateTime InvoiceDate { get; set; }
Visual Basic
Public Property InvoiceDate As DateTime
    Get
    Set

Property Value

Type: DateTime

Remarks

The invoice date will determine the transaction date when posting the document.

See Also

OrderBase Class
OrderBase Members


OrderBase.InvoiceTo Property

[image]

Pastel Evolution SDK
OrderBase..::..InvoiceTo Property
OrderBase Class See Also Send Feedback
Gets or sets the invoice address.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Address InvoiceTo { get; set; }
Visual Basic
Public Property InvoiceTo As Address
    Get
    Set

Property Value

Type: Address

See Also

OrderBase Class
OrderBase Members


OrderBase.IsLoading Property

[image]

Pastel Evolution SDK
OrderBase..::..IsLoading Property
OrderBase Class See Also Send Feedback
Will be true while the order is busy loading detail.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool IsLoading { get; internal set; }
Visual Basic
Public Property IsLoading As Boolean
    Get
    Friend Set

Property Value

Type: Boolean

See Also

OrderBase Class
OrderBase Members


OrderBase.IsPartialProcessingAllowed Property

[image]

Pastel Evolution SDK
OrderBase..::..IsPartialProcessingAllowed Property
OrderBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public virtual bool IsPartialProcessingAllowed { get; }
Visual Basic
Public Overridable ReadOnly Property IsPartialProcessingAllowed As Boolean
    Get

Property Value

Type: Boolean

See Also

OrderBase Class
OrderBase Members


OrderBase.IsProcessing Property

[image]

Pastel Evolution SDK
OrderBase..::..IsProcessing Property
OrderBase Class See Also Send Feedback
Will be true while the order is busy processing transactions.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool IsProcessing { get; internal set; }
Visual Basic
Public Property IsProcessing As Boolean
    Get
    Friend Set

Property Value

Type: Boolean

See Also

OrderBase Class
OrderBase Members


OrderBase.LedgerTransaction Property

[image]

Pastel Evolution SDK
OrderBase..::..LedgerTransaction Property
OrderBase Class See Also Send Feedback
Gets the last ledger transaction (AR/AP Transaction) posted.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DrCrTransaction LedgerTransaction { get; }
Visual Basic
Public ReadOnly Property LedgerTransaction As DrCrTransaction
    Get

Property Value

Type: DrCrTransaction

Remarks

This transaction reference is only available immediately after processing the document.

See Also

OrderBase Class
OrderBase Members


OrderBase.lineAdditionalCostTotal Property

[image]

Pastel Evolution SDK
OrderBase..::..lineAdditionalCostTotal Property
OrderBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected double lineAdditionalCostTotal { get; }
Visual Basic
Protected ReadOnly Property lineAdditionalCostTotal As Double
    Get

Property Value

Type: Double

See Also

OrderBase Class
OrderBase Members


OrderBase.LongID Property

[image]

Pastel Evolution SDK
OrderBase..::..LongID Property
OrderBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

OrderBase Class
OrderBase Members


OrderBase.MessageLine1 Property

[image]

Pastel Evolution SDK
OrderBase..::..MessageLine1 Property
OrderBase Class See Also Send Feedback
Gets or sets the 1st message line.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string MessageLine1 { get; set; }
Visual Basic
Public Property MessageLine1 As String
    Get
    Set

Property Value

Type: String

See Also

OrderBase Class
OrderBase Members


OrderBase.MessageLine2 Property

[image]

Pastel Evolution SDK
OrderBase..::..MessageLine2 Property
OrderBase Class See Also Send Feedback
Gets or sets the 2nd message line.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string MessageLine2 { get; set; }
Visual Basic
Public Property MessageLine2 As String
    Get
    Set

Property Value

Type: String

See Also

OrderBase Class
OrderBase Members


OrderBase.MessageLine3 Property

[image]

Pastel Evolution SDK
OrderBase..::..MessageLine3 Property
OrderBase Class See Also Send Feedback
Gets or sets the 3rd message line.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string MessageLine3 { get; set; }
Visual Basic
Public Property MessageLine3 As String
    Get
    Set

Property Value

Type: String

See Also

OrderBase Class
OrderBase Members


OrderBase.nettLastProcessTotal Property

[image]

Pastel Evolution SDK
OrderBase..::..nettLastProcessTotal Property
OrderBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected double nettLastProcessTotal { get; }
Visual Basic
Protected ReadOnly Property nettLastProcessTotal As Double
    Get

Property Value

Type: Double

See Also

OrderBase Class
OrderBase Members


OrderBase.nettLastProcessTotalForeign Property

[image]

Pastel Evolution SDK
OrderBase..::..nettLastProcessTotalForeign Property
OrderBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected double nettLastProcessTotalForeign { get; }
Visual Basic
Protected ReadOnly Property nettLastProcessTotalForeign As Double
    Get

Property Value

Type: Double

See Also

OrderBase Class
OrderBase Members


OrderBase.nettOutstTotal Property

[image]

Pastel Evolution SDK
OrderBase..::..nettOutstTotal Property
OrderBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected double nettOutstTotal { get; }
Visual Basic
Protected ReadOnly Property nettOutstTotal As Double
    Get

Property Value

Type: Double

See Also

OrderBase Class
OrderBase Members


OrderBase.nettOutstTotalForeign Property

[image]

Pastel Evolution SDK
OrderBase..::..nettOutstTotalForeign Property
OrderBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected double nettOutstTotalForeign { get; }
Visual Basic
Protected ReadOnly Property nettOutstTotalForeign As Double
    Get

Property Value

Type: Double

See Also

OrderBase Class
OrderBase Members


OrderBase.nettToProcessTotal Property

[image]

Pastel Evolution SDK
OrderBase..::..nettToProcessTotal Property
OrderBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected double nettToProcessTotal { get; }
Visual Basic
Protected ReadOnly Property nettToProcessTotal As Double
    Get

Property Value

Type: Double

See Also

OrderBase Class
OrderBase Members


OrderBase.nettToProcessTotalForeign Property

[image]

Pastel Evolution SDK
OrderBase..::..nettToProcessTotalForeign Property
OrderBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected double nettToProcessTotalForeign { get; }
Visual Basic
Protected ReadOnly Property nettToProcessTotalForeign As Double
    Get

Property Value

Type: Double

See Also

OrderBase Class
OrderBase Members


OrderBase.OrderDate Property

[image]

Pastel Evolution SDK
OrderBase..::..OrderDate Property
OrderBase Class See Also Send Feedback
Gets or sets the order date.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DateTime OrderDate { get; set; }
Visual Basic
Public Property OrderDate As DateTime
    Get
    Set

Property Value

Type: DateTime

See Also

OrderBase Class
OrderBase Members


OrderBase.OrderNo Property

[image]

Pastel Evolution SDK
OrderBase..::..OrderNo Property
OrderBase Class See Also Send Feedback
Gets or sets the order number.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string OrderNo { get; set; }
Visual Basic
Public Property OrderNo As String
    Get
    Set

Property Value

Type: String

See Also

OrderBase Class
OrderBase Members


OrderBase.OrderPriority Property

[image]

Pastel Evolution SDK
OrderBase..::..OrderPriority Property
OrderBase Class See Also Send Feedback
Gets or sets the order priority.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Priority OrderPriority { get; set; }
Visual Basic
Public Property OrderPriority As Priority
    Get
    Set

Property Value

Type: Priority

See Also

OrderBase Class
OrderBase Members


OrderBase.OrderPriorityID Property

[image]

Pastel Evolution SDK
OrderBase..::..OrderPriorityID Property
OrderBase Class See Also Send Feedback
Gets or sets the order priority ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int OrderPriorityID { get; set; }
Visual Basic
Public Property OrderPriorityID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

OrderBase Class
OrderBase Members


OrderBase.OrderStatus Property

[image]

Pastel Evolution SDK
OrderBase..::..OrderStatus Property
OrderBase Class See Also Send Feedback
Gets or sets the document's order status.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public OrderStatus OrderStatus { get; set; }
Visual Basic
Public Property OrderStatus As OrderStatus
    Get
    Set

Property Value

Type: OrderStatus

See Also

OrderBase Class
OrderBase Members


OrderBase.OrderStatusID Property

[image]

Pastel Evolution SDK
OrderBase..::..OrderStatusID Property
OrderBase Class See Also Send Feedback
Gets or sets the order status ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int OrderStatusID { get; set; }
Visual Basic
Public Property OrderStatusID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

OrderBase Class
OrderBase Members


OrderBase.OriginalDocument Property

[image]

Pastel Evolution SDK
OrderBase..::..OriginalDocument Property
OrderBase Class See Also Send Feedback
Gets the original document.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract OrderBase OriginalDocument { get; }
Visual Basic
Public MustOverride ReadOnly Property OriginalDocument As OrderBase
    Get

Property Value

Type: OrderBase

See Also

OrderBase Class
OrderBase Members


OrderBase.PrintCount Property

[image]

Pastel Evolution SDK
OrderBase..::..PrintCount Property
OrderBase Class See Also Send Feedback
Gets or sets the print count.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int PrintCount { get; set; }
Visual Basic
Public Property PrintCount As Integer
    Get
    Set

Property Value

Type: Int32

See Also

OrderBase Class
OrderBase Members


OrderBase.Project Property

[image]

Pastel Evolution SDK
OrderBase..::..Project Property
OrderBase Class See Also Send Feedback
Gets or sets the project.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Project Project { get; set; }
Visual Basic
Public Property Project As Project
    Get
    Set

Property Value

Type: Project

See Also

OrderBase Class
OrderBase Members


OrderBase.ProjectID Property

[image]

Pastel Evolution SDK
OrderBase..::..ProjectID Property
OrderBase Class See Also Send Feedback
Gets or sets the project ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int ProjectID { get; set; }
Visual Basic
Public Property ProjectID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

OrderBase Class
OrderBase Members


OrderBase.Prospect Property

[image]

Pastel Evolution SDK
OrderBase..::..Prospect Property
OrderBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Prospect Prospect { get; set; }
Visual Basic
Public Property Prospect As Prospect
    Get
    Set

Property Value

Type: Prospect

See Also

OrderBase Class
OrderBase Members


OrderBase.ProspectID Property

[image]

Pastel Evolution SDK
OrderBase..::..ProspectID Property
OrderBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int ProspectID { get; set; }
Visual Basic
Public Property ProspectID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

OrderBase Class
OrderBase Members


OrderBase.RawFieldData Property

[image]

Pastel Evolution SDK
OrderBase..::..RawFieldData Property
OrderBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
[ObsoleteAttribute("Use UserFields instead.")]
public FieldCollection RawFieldData { get; }
Visual Basic
<ObsoleteAttribute("Use UserFields instead.")>
Public ReadOnly Property RawFieldData As FieldCollection
    Get

Property Value

Type: FieldCollection

See Also

OrderBase Class
OrderBase Members


OrderBase.Reference Property

[image]

Pastel Evolution SDK
OrderBase..::..Reference Property
OrderBase Class See Also Send Feedback
Gets or sets the document reference (InvNumber).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Reference { get; }
Visual Basic
Public ReadOnly Property Reference As String
    Get

Property Value

Type: String

See Also

OrderBase Class
OrderBase Members


OrderBase.Reference2 Property

[image]

Pastel Evolution SDK
OrderBase..::..Reference2 Property
OrderBase Class See Also Send Feedback
Gets the 2nd document reference.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Reference2 { get; }
Visual Basic
Public ReadOnly Property Reference2 As String
    Get

Property Value

Type: String

See Also

OrderBase Class
OrderBase Members


OrderBase.SettlementTerms Property

[image]

Pastel Evolution SDK
OrderBase..::..SettlementTerms Property
OrderBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public SettlementTerms SettlementTerms { get; set; }
Visual Basic
Public Property SettlementTerms As SettlementTerms
    Get
    Set

Property Value

Type: SettlementTerms

See Also

OrderBase Class
OrderBase Members


OrderBase.SettlementTermsID Property

[image]

Pastel Evolution SDK
OrderBase..::..SettlementTermsID Property
OrderBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int SettlementTermsID { get; set; }
Visual Basic
Public Property SettlementTermsID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

OrderBase Class
OrderBase Members


OrderBase.State Property

[image]

Pastel Evolution SDK
OrderBase..::..State Property
OrderBase Class See Also Send Feedback
Gets the document state.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DocumentState State { get; internal set; }
Visual Basic
Public Property State As DocumentState
    Get
    Friend Set

Property Value

Type: DocumentState

See Also

OrderBase Class
OrderBase Members


OrderBase.taxLastProcessTotal Property

[image]

Pastel Evolution SDK
OrderBase..::..taxLastProcessTotal Property
OrderBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected double taxLastProcessTotal { get; }
Visual Basic
Protected ReadOnly Property taxLastProcessTotal As Double
    Get

Property Value

Type: Double

See Also

OrderBase Class
OrderBase Members


OrderBase.taxLastProcessTotalForeign Property

[image]

Pastel Evolution SDK
OrderBase..::..taxLastProcessTotalForeign Property
OrderBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected double taxLastProcessTotalForeign { get; }
Visual Basic
Protected ReadOnly Property taxLastProcessTotalForeign As Double
    Get

Property Value

Type: Double

See Also

OrderBase Class
OrderBase Members


OrderBase.TaxMode Property

[image]

Pastel Evolution SDK
OrderBase..::..TaxMode Property
OrderBase Class See Also Send Feedback
Gets or sets the tax mode.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public TaxMode TaxMode { get; set; }
Visual Basic
Public Property TaxMode As TaxMode
    Get
    Set

Property Value

Type: TaxMode

See Also

OrderBase Class
OrderBase Members


OrderBase.TaxNumber Property

[image]

Pastel Evolution SDK
OrderBase..::..TaxNumber Property
OrderBase Class See Also Send Feedback
Gets or sets the cash account's tax number.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string TaxNumber { get; set; }
Visual Basic
Public Property TaxNumber As String
    Get
    Set

Property Value

Type: String

See Also

OrderBase Class
OrderBase Members


OrderBase.taxOutstTotal Property

[image]

Pastel Evolution SDK
OrderBase..::..taxOutstTotal Property
OrderBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected double taxOutstTotal { get; }
Visual Basic
Protected ReadOnly Property taxOutstTotal As Double
    Get

Property Value

Type: Double

See Also

OrderBase Class
OrderBase Members


OrderBase.taxOutstTotalForeign Property

[image]

Pastel Evolution SDK
OrderBase..::..taxOutstTotalForeign Property
OrderBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected double taxOutstTotalForeign { get; }
Visual Basic
Protected ReadOnly Property taxOutstTotalForeign As Double
    Get

Property Value

Type: Double

See Also

OrderBase Class
OrderBase Members


OrderBase.taxToProcessTotal Property

[image]

Pastel Evolution SDK
OrderBase..::..taxToProcessTotal Property
OrderBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected double taxToProcessTotal { get; }
Visual Basic
Protected ReadOnly Property taxToProcessTotal As Double
    Get

Property Value

Type: Double

See Also

OrderBase Class
OrderBase Members


OrderBase.taxToProcessTotalForeign Property

[image]

Pastel Evolution SDK
OrderBase..::..taxToProcessTotalForeign Property
OrderBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected double taxToProcessTotalForeign { get; }
Visual Basic
Protected ReadOnly Property taxToProcessTotalForeign As Double
    Get

Property Value

Type: Double

See Also

OrderBase Class
OrderBase Members


OrderBase.taxTotal Property

[image]

Pastel Evolution SDK
OrderBase..::..taxTotal Property
OrderBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected double taxTotal { get; }
Visual Basic
Protected ReadOnly Property taxTotal As Double
    Get

Property Value

Type: Double

See Also

OrderBase Class
OrderBase Members


OrderBase.taxTotalForeign Property

[image]

Pastel Evolution SDK
OrderBase..::..taxTotalForeign Property
OrderBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected double taxTotalForeign { get; }
Visual Basic
Protected ReadOnly Property taxTotalForeign As Double
    Get

Property Value

Type: Double

See Also

OrderBase Class
OrderBase Members


OrderBase.TaxType Property

[image]

Pastel Evolution SDK
OrderBase..::..TaxType Property
OrderBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public TaxRate TaxType { get; set; }
Visual Basic
Public Property TaxType As TaxRate
    Get
    Set

Property Value

Type: TaxRate

See Also

OrderBase Class
OrderBase Members


OrderBase.TotalDiscountAdjusted Property

[image]

Pastel Evolution SDK
OrderBase..::..TotalDiscountAdjusted Property
OrderBase Class See Also Send Feedback
Gets the total discount adjusted amount.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalDiscountAdjusted { get; }
Visual Basic
Public ReadOnly Property TotalDiscountAdjusted As Double
    Get

Property Value

Type: Double

See Also

OrderBase Class
OrderBase Members


OrderBase.TotalDiscountAdjustedForeign Property

[image]

Pastel Evolution SDK
OrderBase..::..TotalDiscountAdjustedForeign Property
OrderBase Class See Also Send Feedback
Gets the total discount adjusted foreign amount.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalDiscountAdjustedForeign { get; }
Visual Basic
Public ReadOnly Property TotalDiscountAdjustedForeign As Double
    Get

Property Value

Type: Double

See Also

OrderBase Class
OrderBase Members


OrderBase.TotalExcl Property

[image]

Pastel Evolution SDK
OrderBase..::..TotalExcl Property
OrderBase Class See Also Send Feedback
Gets the total excl amount.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalExcl { get; }
Visual Basic
Public ReadOnly Property TotalExcl As Double
    Get

Property Value

Type: Double

See Also

OrderBase Class
OrderBase Members


OrderBase.TotalExclForeign Property

[image]

Pastel Evolution SDK
OrderBase..::..TotalExclForeign Property
OrderBase Class See Also Send Feedback
Gets the total excl amount.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalExclForeign { get; }
Visual Basic
Public ReadOnly Property TotalExclForeign As Double
    Get

Property Value

Type: Double

See Also

OrderBase Class
OrderBase Members


OrderBase.TotalIncl Property

[image]

Pastel Evolution SDK
OrderBase..::..TotalIncl Property
OrderBase Class See Also Send Feedback
Gets the total incl amount.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalIncl { get; }
Visual Basic
Public ReadOnly Property TotalIncl As Double
    Get

Property Value

Type: Double

See Also

OrderBase Class
OrderBase Members


OrderBase.TotalInclForeign Property

[image]

Pastel Evolution SDK
OrderBase..::..TotalInclForeign Property
OrderBase Class See Also Send Feedback
Gets the total incl amount.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalInclForeign { get; }
Visual Basic
Public ReadOnly Property TotalInclForeign As Double
    Get

Property Value

Type: Double

See Also

OrderBase Class
OrderBase Members


OrderBase.TotalInclForeignBeforeInvoiceRounding Property

[image]

Pastel Evolution SDK
OrderBase..::..TotalInclForeignBeforeInvoiceRounding Property
OrderBase Class See Also Send Feedback
Gets the total incl amount before Invoice Rounding.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalInclForeignBeforeInvoiceRounding { get; }
Visual Basic
Public ReadOnly Property TotalInclForeignBeforeInvoiceRounding As Double
    Get

Property Value

Type: Double

See Also

OrderBase Class
OrderBase Members


OrderBase.TotalLastProcessExcl Property

[image]

Pastel Evolution SDK
OrderBase..::..TotalLastProcessExcl Property
OrderBase Class See Also Send Feedback
Gets the total last process excl.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalLastProcessExcl { get; }
Visual Basic
Public ReadOnly Property TotalLastProcessExcl As Double
    Get

Property Value

Type: Double

See Also

OrderBase Class
OrderBase Members


OrderBase.TotalLastProcessExclForeign Property

[image]

Pastel Evolution SDK
OrderBase..::..TotalLastProcessExclForeign Property
OrderBase Class See Also Send Feedback
Gets the total last process excl.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalLastProcessExclForeign { get; }
Visual Basic
Public ReadOnly Property TotalLastProcessExclForeign As Double
    Get

Property Value

Type: Double

See Also

OrderBase Class
OrderBase Members


OrderBase.TotalLastProcessIncl Property

[image]

Pastel Evolution SDK
OrderBase..::..TotalLastProcessIncl Property
OrderBase Class See Also Send Feedback
Gets the total last process incl.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalLastProcessIncl { get; }
Visual Basic
Public ReadOnly Property TotalLastProcessIncl As Double
    Get

Property Value

Type: Double

See Also

OrderBase Class
OrderBase Members


OrderBase.TotalLastProcessInclForeign Property

[image]

Pastel Evolution SDK
OrderBase..::..TotalLastProcessInclForeign Property
OrderBase Class See Also Send Feedback
Gets the total last process incl.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalLastProcessInclForeign { get; }
Visual Basic
Public ReadOnly Property TotalLastProcessInclForeign As Double
    Get

Property Value

Type: Double

See Also

OrderBase Class
OrderBase Members


OrderBase.TotalLastProcessTax Property

[image]

Pastel Evolution SDK
OrderBase..::..TotalLastProcessTax Property
OrderBase Class See Also Send Feedback
Gets the total last process tax.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalLastProcessTax { get; }
Visual Basic
Public ReadOnly Property TotalLastProcessTax As Double
    Get

Property Value

Type: Double

See Also

OrderBase Class
OrderBase Members


OrderBase.TotalLastProcessTaxForeign Property

[image]

Pastel Evolution SDK
OrderBase..::..TotalLastProcessTaxForeign Property
OrderBase Class See Also Send Feedback
Gets the total last process tax.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalLastProcessTaxForeign { get; }
Visual Basic
Public ReadOnly Property TotalLastProcessTaxForeign As Double
    Get

Property Value

Type: Double

See Also

OrderBase Class
OrderBase Members


OrderBase.TotalOutstandingExcl Property

[image]

Pastel Evolution SDK
OrderBase..::..TotalOutstandingExcl Property
OrderBase Class See Also Send Feedback
Gets the total outstanding excl.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalOutstandingExcl { get; }
Visual Basic
Public ReadOnly Property TotalOutstandingExcl As Double
    Get

Property Value

Type: Double

See Also

OrderBase Class
OrderBase Members


OrderBase.TotalOutstandingExclForeign Property

[image]

Pastel Evolution SDK
OrderBase..::..TotalOutstandingExclForeign Property
OrderBase Class See Also Send Feedback
Gets the total outstanding excl.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalOutstandingExclForeign { get; }
Visual Basic
Public ReadOnly Property TotalOutstandingExclForeign As Double
    Get

Property Value

Type: Double

See Also

OrderBase Class
OrderBase Members


OrderBase.TotalOutstandingIncl Property

[image]

Pastel Evolution SDK
OrderBase..::..TotalOutstandingIncl Property
OrderBase Class See Also Send Feedback
Gets the total outstanding incl.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalOutstandingIncl { get; }
Visual Basic
Public ReadOnly Property TotalOutstandingIncl As Double
    Get

Property Value

Type: Double

See Also

OrderBase Class
OrderBase Members


OrderBase.TotalOutstandingInclForeign Property

[image]

Pastel Evolution SDK
OrderBase..::..TotalOutstandingInclForeign Property
OrderBase Class See Also Send Feedback
Gets the total outstanding incl.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalOutstandingInclForeign { get; }
Visual Basic
Public ReadOnly Property TotalOutstandingInclForeign As Double
    Get

Property Value

Type: Double

See Also

OrderBase Class
OrderBase Members


OrderBase.TotalOutstandingTax Property

[image]

Pastel Evolution SDK
OrderBase..::..TotalOutstandingTax Property
OrderBase Class See Also Send Feedback
Gets the total outstanding tax.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalOutstandingTax { get; }
Visual Basic
Public ReadOnly Property TotalOutstandingTax As Double
    Get

Property Value

Type: Double

See Also

OrderBase Class
OrderBase Members


OrderBase.TotalOutstandingTaxForeign Property

[image]

Pastel Evolution SDK
OrderBase..::..TotalOutstandingTaxForeign Property
OrderBase Class See Also Send Feedback
Gets the total outstanding tax.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalOutstandingTaxForeign { get; }
Visual Basic
Public ReadOnly Property TotalOutstandingTaxForeign As Double
    Get

Property Value

Type: Double

See Also

OrderBase Class
OrderBase Members


OrderBase.TotalTax Property

[image]

Pastel Evolution SDK
OrderBase..::..TotalTax Property
OrderBase Class See Also Send Feedback
Gets the total tax amount.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalTax { get; }
Visual Basic
Public ReadOnly Property TotalTax As Double
    Get

Property Value

Type: Double

See Also

OrderBase Class
OrderBase Members


OrderBase.TotalTaxForeign Property

[image]

Pastel Evolution SDK
OrderBase..::..TotalTaxForeign Property
OrderBase Class See Also Send Feedback
Gets the total tax amount.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalTaxForeign { get; }
Visual Basic
Public ReadOnly Property TotalTaxForeign As Double
    Get

Property Value

Type: Double

See Also

OrderBase Class
OrderBase Members


OrderBase.TotalToProcessExcl Property

[image]

Pastel Evolution SDK
OrderBase..::..TotalToProcessExcl Property
OrderBase Class See Also Send Feedback
Gets the total amount to process excl.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalToProcessExcl { get; }
Visual Basic
Public ReadOnly Property TotalToProcessExcl As Double
    Get

Property Value

Type: Double

See Also

OrderBase Class
OrderBase Members


OrderBase.TotalToProcessExclForeign Property

[image]

Pastel Evolution SDK
OrderBase..::..TotalToProcessExclForeign Property
OrderBase Class See Also Send Feedback
Gets the total amount to process excl.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalToProcessExclForeign { get; }
Visual Basic
Public ReadOnly Property TotalToProcessExclForeign As Double
    Get

Property Value

Type: Double

See Also

OrderBase Class
OrderBase Members


OrderBase.TotalToProcessIncl Property

[image]

Pastel Evolution SDK
OrderBase..::..TotalToProcessIncl Property
OrderBase Class See Also Send Feedback
Gets the total to process incl.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalToProcessIncl { get; }
Visual Basic
Public ReadOnly Property TotalToProcessIncl As Double
    Get

Property Value

Type: Double

See Also

OrderBase Class
OrderBase Members


OrderBase.TotalToProcessInclForeign Property

[image]

Pastel Evolution SDK
OrderBase..::..TotalToProcessInclForeign Property
OrderBase Class See Also Send Feedback
Gets the total to process incl.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalToProcessInclForeign { get; }
Visual Basic
Public ReadOnly Property TotalToProcessInclForeign As Double
    Get

Property Value

Type: Double

See Also

OrderBase Class
OrderBase Members


OrderBase.TotalToProcessTax Property

[image]

Pastel Evolution SDK
OrderBase..::..TotalToProcessTax Property
OrderBase Class See Also Send Feedback
Gets the total to process tax.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalToProcessTax { get; }
Visual Basic
Public ReadOnly Property TotalToProcessTax As Double
    Get

Property Value

Type: Double

See Also

OrderBase Class
OrderBase Members


OrderBase.TotalToProcessTaxForeign Property

[image]

Pastel Evolution SDK
OrderBase..::..TotalToProcessTaxForeign Property
OrderBase Class See Also Send Feedback
Gets the total to process tax.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalToProcessTaxForeign { get; }
Visual Basic
Public ReadOnly Property TotalToProcessTaxForeign As Double
    Get

Property Value

Type: Double

See Also

OrderBase Class
OrderBase Members


OrderBase.Type Property

[image]

Pastel Evolution SDK
OrderBase..::..Type Property
OrderBase Class See Also Send Feedback
Gets the order's document type.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DocumentType Type { get; }
Visual Basic
Public ReadOnly Property Type As DocumentType
    Get

Property Value

Type: DocumentType

See Also

OrderBase Class
OrderBase Members


OrderBase.UserFields Property

[image]

Pastel Evolution SDK
OrderBase..::..UserFields Property
OrderBase Class See Also Send Feedback
Gets access to the collection of user-defined fields on the record. Note that the field name is case-sensitive.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public FieldCollection UserFields { get; }
Visual Basic
Public ReadOnly Property UserFields As FieldCollection
    Get

Property Value

Type: FieldCollection

See Also

OrderBase Class
OrderBase Members


OrderBase.Version Property

[image]

Pastel Evolution SDK
OrderBase..::..Version Property
OrderBase Class See Also Send Feedback
Gets the current version of the order, incremented on every save.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int Version { get; }
Visual Basic
Public ReadOnly Property Version As Integer
    Get

Property Value

Type: Int32

See Also

OrderBase Class
OrderBase Members


OrderDetail Class

[image]

Pastel Evolution SDK
OrderDetail Class
Members See Also Send Feedback
Represents an inventory document detail record.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class OrderDetail : BranchedRecordBase
Visual Basic
Public Class OrderDetail
    Inherits BranchedRecordBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..OrderDetail

See Also

OrderDetail Members


OrderDetail Members

[image] [image]

Pastel Evolution SDK
OrderDetail Members
OrderDetail Class Constructors Methods Fields Properties See Also Send Feedback

The OrderDetail type exposes the following members.

Constructors

 | Name | Description
Public method | OrderDetail()()()() | Creates a new instance of a order detail record.
Public method | OrderDetail(Int64) | Creates a new instance of an order detail record.
Public method | OrderDetail(String, Double, Double) | Creates a new instance of an order detail record.
Public method | OrderDetail(InventoryItem, Double, Double) | Creates a new instance of an order detail record.
Public method | OrderDetail(InventoryItem, Double, Double, TaxMode) | Creates a new instance of an order detail record.
Public method | OrderDetail(InventoryItem, String, Double, Double) | Creates a new instance of an order detail record.
Public method | OrderDetail(InventoryItem, String, Double, Double, TaxMode) | Creates a new instance of an order detail record.

Methods

 | Name | Description
Public method | _Copy | Experimental Method
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds a record's database ID.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | List | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the detail record from the order document only, not from the database. Save the order after calling Delete to delete the line from the database. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Protected method | SetDocument |
Public method | ToString | (Overrides Object..::..ToString()()()().)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | Account | Gets or sets the line's account (inventory item or GL account [in near future]).
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Description | Gets or sets the line description.
Public property | Discount | Gets or sets the total line discount value (applies to tax excl. value)
Public property | DiscountPercent | Gets or sets the line discount percentage as an integer value: 5% = 5, as opposed to 0.05
Public property | Document | Gets the document to which the detail record belongs.
Public property | GLAccount | Gets or sets the line's GLAccount.
Public property | GLAccountID | Gets or sets the GLAccount item id.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | Index | Gets the line number (1-based)
Public property | InventoryItem | Gets or sets the line's inventory item.
Public property | InventoryItemID | Gets or sets the stock item id.
Public property | JobID | Gets or sets the order detail record's job id.
Public property | LastProcess | Gets the stock quantity moved during the last processing action.
Public property | LongID | Transitional accessor. (Overrides RecordBase..::..LongID.)
Public property | Lot |
Public property | LotID |
Public property | Module | Indicates the Evolution module of the Order Detail line.
Public property | Note | Gets or sets the line note text.
Public property | Outstanding | Gets the quantity of stock that remains to be processed.
Public property | OverrideCostOfSalesAccount | Specifies the GL account to use when processing the document's cost of goods sold transaction.
Public property | OverridePurchaseAccount | Specifies the purchases GL account to use when processing the document's GL transactions. Currently this is merely an alias for
Public property | OverrideSalesAccount | Specifies the GL account to use when processing the document's sales transaction.
Public property | OverrideStockAccount | Specifies the GL account to use when processing the document's GL stock transaction.
Public property | PriceListNameID | Gets or sets the line pricelistID.
Public property | Processed | Gets the quantity of stock processed on this line up until this document.
Public property | Project | Gets or sets the line's project.
Public property | ProjectID | Gets or sets the line's project id.
Public property | Quantity | Gets or sets the quantity of product on order.
Public property | Representative | Gets or sets the sales representative on the order line. This only applies to sales transactions. When not set, the representative will default to the rep specified (if any) on the order document.
Public property | RepresentativeID | Gets or sets the representative id.
Public property | Reserved | Gets or sets the quantity of stock to reserve for an order (only applies to sales orders).
Public property | SerialNumbers | Gets the collection of serial numbers pertaining to the order detail record.
Public property | TaxMode | Gets or sets the line's tax mode.
Public property | TaxType |
Public property | ToProcess | Gets or sets the quantity of stock to move when calling the Process method.
Public property | TotalAdditionalCost | Gets or sets the additional cost allocated to the line.
Public property | TotalExcl | Gets the calculated, rounded line total exclusive amount, after discount.
Public property | TotalExclBeforeDiscount |
Public property | TotalExclBeforeDiscountForeign |
Public property | TotalExclBeforeDiscountForeignRaw |
Public property | TotalExclBeforeDiscountRaw |
Public property | TotalExclForeign |
Public property | TotalExclRaw |
Public property | TotalIncl | Gets the calculated line total inclusive amount, after discount.
Public property | TotalInclBeforeDiscount |
Public property | TotalInclBeforeDiscountForeign |
Public property | TotalInclForeign |
Public property | TotalLastProcessExcl |
Public property | TotalLastProcessExclAfterDocumentDiscount |
Public property | TotalLastProcessExclForeign |
Public property | TotalLastProcessExclForeignAfterDocumentDiscount |
Public property | TotalLastProcessIncl |
Public property | TotalLastProcessInclForeign |
Public property | TotalLastProcessTax |
Public property | TotalLastProcessTaxAfterDocumentDiscount |
Public property | TotalLastProcessTaxForeign |
Public property | TotalLastProcessTaxForeignAfterDocumentDiscount |
Public property | TotalOutstandingExcl |
Public property | TotalOutstandingExclForeign |
Public property | TotalOutstandingIncl |
Public property | TotalOutstandingInclForeign |
Public property | TotalOutstandingTax |
Public property | TotalOutstandingTaxForeign |
Public property | TotalProcessedExcl |
Public property | TotalProcessedExclForeign |
Public property | TotalProcessedIncl |
Public property | TotalProcessedInclForeign |
Public property | TotalProcessedTax |
Public property | TotalProcessedTaxForeign |
Public property | TotalSalesCost | Gets the line total cost of sale; i.e. current unit cost * quantity
Public property | TotalTax | Gets or sets the line total tax amount. Set this value as late as possible as it gets recalculated on setting Quantity, UnitSellingPrice, DiscountPercent, Discount, TaxType, as well as when adding the order detail record to the orders's Detail collection. IMPORTANT: Be sure to only use the Process() method and not one of the Complete* methods if you wish to override the tax amount. Setting TotalTax also does not affect TotalToProcessTax.
Public property | TotalTaxBeforeDiscount | Gets the tax amount before discount was applied. If discount is 100% and the total tax amount is 0, the tax rate is used to calculate a default tax amount.
Public property | TotalTaxBeforeDiscountForeign |
Public property | TotalTaxForeign |
Public property | TotalToProcessExcl |
Public property | TotalToProcessExclBeforeDiscount |
Public property | TotalToProcessExclBeforeDiscountForeign |
Public property | TotalToProcessExclForeign |
Public property | TotalToProcessIncl |
Public property | TotalToProcessInclBeforeDiscount |
Public property | TotalToProcessInclBeforeDiscountForeign |
Public property | TotalToProcessInclForeign |
Public property | TotalToProcessTax | Gets or sets the line total tax amount for the following invoice. Set this value as late as possible as it gets recalculated on setting ToProcess, UnitSellingPrice, DiscountPercent, Discount, TaxType, as well as when adding the order detail record to the orders's Detail collection. IMPORTANT: Be sure to only use the Process() method and not one of the Complete* methods only if you wish to override the tax amount.
Public property | TotalToProcessTaxAfterDocumentDiscount |
Public property | TotalToProcessTaxBeforeDiscount |
Public property | TotalToProcessTaxBeforeDiscountForeign |
Public property | TotalToProcessTaxForeign |
Public property | TotalToProcessTaxForeignAfterDocumentDiscount |
Public property | Unit |
Public property | UnitCostPrice | Gets or sets the unit cost price (used by credit notes only).
Public property | UnitID |
Public property | UnitSellingPrice | Gets or sets the unit selling or purchase price.
Public property | UnitSellingPriceAfterDiscount | Gets the line's unit selling price after discount.
Public property | UnitSellingPriceAfterDocumentDiscountExcl | Gets the order detail's unit selling price excl after line and document discount (unrounded).
Public property | UnitSellingPriceExclAfterLineDiscount | Gets the order detail's unit selling price excl after line discount (unrounded).
Public property | UnitSellingPriceForeign | Gets or sets the foreign unit selling price - on sales orders this will be the product selling price as expected, but on purchase orders, it is the supplier's selling price.
Public property | UserFields |
Public property | Warehouse | Gets or sets the warehouse relevant to this detail record. Set the warehouse only after setting the inventory item. The Warehouse and WarehouseContext properties are mapped to one another.
Public property | WarehouseContext | Gets or sets the warehouse context of the inventory item specified. Set the warehouse only after setting the inventory item. The Warehouse and WarehouseContext properties are mapped to one another.
Public property | WarehouseID | Gets the ID of the assigned warehouse (0 if N/A).

See Also

OrderDetail Class


OrderDetail Constructor

[image] [image]

Pastel Evolution SDK
OrderDetail Constructor
OrderDetail Class See Also Send Feedback

Overload List

 | Name | Description
Public method | OrderDetail()()()() | Creates a new instance of a order detail record.
Public method | OrderDetail(Int64) | Creates a new instance of an order detail record.
Public method | OrderDetail(String, Double, Double) | Creates a new instance of an order detail record.
Public method | OrderDetail(InventoryItem, Double, Double) | Creates a new instance of an order detail record.
Public method | OrderDetail(InventoryItem, Double, Double, TaxMode) | Creates a new instance of an order detail record.
Public method | OrderDetail(InventoryItem, String, Double, Double) | Creates a new instance of an order detail record.
Public method | OrderDetail(InventoryItem, String, Double, Double, TaxMode) | Creates a new instance of an order detail record.

See Also

OrderDetail Class
OrderDetail Members


OrderDetail Constructor

[image]

Pastel Evolution SDK
OrderDetail Constructor
OrderDetail Class See Also Send Feedback
Creates a new instance of a order detail record.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public OrderDetail()
Visual Basic
Public Sub New

See Also

OrderDetail Class
OrderDetail Members
OrderDetail Overload


OrderDetail Constructor (Int64)

[image]

Pastel Evolution SDK
OrderDetail Constructor (Int64)
OrderDetail Class See Also Send Feedback
Creates a new instance of an order detail record.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public OrderDetail(
    long id
)
Visual Basic
Public Sub New (
    id As Long
)

Parameters

id
Type: System..::..Int64
Specifies the id of the existing record.

See Also

OrderDetail Class
OrderDetail Members
OrderDetail Overload


OrderDetail Constructor (String, Double, Double)

[image]

Pastel Evolution SDK
OrderDetail Constructor (String, Double, Double)
OrderDetail Class See Also Send Feedback
Creates a new instance of an order detail record.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public OrderDetail(
    string itemCode,
    double quantity,
    double price
)
Visual Basic
Public Sub New (
    itemCode As String,
    quantity As Double,
    price As Double
)

Parameters

itemCode
Type: System..::..String
Specifies the item code.
quantity
Type: System..::..Double
Specifies the quantity.
price
Type: System..::..Double
Specifies the price.

See Also

OrderDetail Class
OrderDetail Members
OrderDetail Overload


OrderDetail Constructor (InventoryItem, Double, Double)

[image]

Pastel Evolution SDK
OrderDetail Constructor (InventoryItem, Double, Double)
OrderDetail Class See Also Send Feedback
Creates a new instance of an order detail record.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public OrderDetail(
    InventoryItem item,
    double quantity,
    double price
)
Visual Basic
Public Sub New (
    item As InventoryItem,
    quantity As Double,
    price As Double
)

Parameters

item
Type: Pastel.Evolution..::..InventoryItem
Specifies the item.
quantity
Type: System..::..Double
Specifies the quantity.
price
Type: System..::..Double
Specifies the price.

See Also

OrderDetail Class
OrderDetail Members
OrderDetail Overload


OrderDetail Constructor (InventoryItem, Double, Double, TaxMode)

[image]

Pastel Evolution SDK
OrderDetail Constructor (InventoryItem, Double, Double, TaxMode)
OrderDetail Class See Also Send Feedback
Creates a new instance of an order detail record.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public OrderDetail(
    InventoryItem item,
    double quantity,
    double price,
    TaxMode taxMode
)
Visual Basic
Public Sub New (
    item As InventoryItem,
    quantity As Double,
    price As Double,
    taxMode As TaxMode
)

Parameters

item
Type: Pastel.Evolution..::..InventoryItem
Specifies the item.
quantity
Type: System..::..Double
Specifies the quantity.
price
Type: System..::..Double
Specifies the exclusive unit price.
taxMode
Type: Pastel.Evolution..::..TaxMode
Specifies the tax mode.

See Also

OrderDetail Class
OrderDetail Members
OrderDetail Overload


OrderDetail Constructor (InventoryItem, String, Double, Double)

[image]

Pastel Evolution SDK
OrderDetail Constructor (InventoryItem, String, Double, Double)
OrderDetail Class See Also Send Feedback
Creates a new instance of an order detail record.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public OrderDetail(
    InventoryItem item,
    string warehouseCode,
    double quantity,
    double price
)
Visual Basic
Public Sub New (
    item As InventoryItem,
    warehouseCode As String,
    quantity As Double,
    price As Double
)

Parameters

item
Type: Pastel.Evolution..::..InventoryItem
Specifies the item.
warehouseCode
Type: System..::..String
Specifies the warehouse code.
quantity
Type: System..::..Double
Specifies the quantity.
price
Type: System..::..Double
Specifies the exclusive unit price.

See Also

OrderDetail Class
OrderDetail Members
OrderDetail Overload


OrderDetail Constructor (InventoryItem, String, Double, Double, TaxMode)

[image]

Pastel Evolution SDK
OrderDetail Constructor (InventoryItem, String, Double, Double, TaxMode)
OrderDetail Class See Also Send Feedback
Creates a new instance of an order detail record.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public OrderDetail(
    InventoryItem item,
    string warehouseCode,
    double quantity,
    double price,
    TaxMode taxMode
)
Visual Basic
Public Sub New (
    item As InventoryItem,
    warehouseCode As String,
    quantity As Double,
    price As Double,
    taxMode As TaxMode
)

Parameters

item
Type: Pastel.Evolution..::..InventoryItem
Specifies the inventory item.
warehouseCode
Type: System..::..String
Specifies the warehouse code.
quantity
Type: System..::..Double
Specifies the quantity.
price
Type: System..::..Double
Specifies the exclusive unit price.
taxMode
Type: Pastel.Evolution..::..TaxMode
Specifies the tax mode.

See Also

OrderDetail Class
OrderDetail Members
OrderDetail Overload
Pastel.Evolution Namespace
OrderDetail..::..UnitSellingPrice
OrderDetail..::..TaxMode
OrderDetail..::..InventoryItem


OrderDetail Fields

[image] [image]

Pastel Evolution SDK
OrderDetail Fields
OrderDetail Class See Also Send Feedback

The OrderDetail type exposes the following members.

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

OrderDetail Class


OrderDetail Methods

[image] [image]

Pastel Evolution SDK
OrderDetail Methods
OrderDetail Class See Also Send Feedback

The OrderDetail type exposes the following members.

Methods

 | Name | Description
Public method | _Copy | Experimental Method
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds a record's database ID.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | List | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the detail record from the order document only, not from the database. Save the order after calling Delete to delete the line from the database. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Protected method | SetDocument |
Public method | ToString | (Overrides Object..::..ToString()()()().)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

OrderDetail Class


OrderDetail._Copy Method

[image]

Pastel Evolution SDK
OrderDetail..::.._Copy Method
OrderDetail Class See Also Send Feedback
Experimental Method

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public OrderDetail _Copy()
Visual Basic
Public Function _Copy As OrderDetail

Return Value

Type: OrderDetail

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.Find Method

[image]

Pastel Evolution SDK
OrderDetail..::..Find Method
OrderDetail Class See Also Send Feedback
Finds a record's database ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.

Return Value

Type: Int32
The ID of the first record found; -1 if not record was found.

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.List Method

[image]

Pastel Evolution SDK
OrderDetail..::..List Method
OrderDetail Class See Also Send Feedback
Gets a list of database records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DataTable List(
    string criteria
)
Visual Basic
Public Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.

Return Value

Type: DataTable
Table containing selected records.

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.OnDelete Method

[image]

Pastel Evolution SDK
OrderDetail..::..OnDelete Method
OrderDetail Class See Also Send Feedback
Removes the detail record from the order document only, not from the database. Save the order after calling Delete to delete the line from the database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.OnSave Method

[image]

Pastel Evolution SDK
OrderDetail..::..OnSave Method
OrderDetail Class See Also Send Feedback
Persists the record to the database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.SetDocument Method

[image]

Pastel Evolution SDK
OrderDetail..::..SetDocument Method
OrderDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal void SetDocument(
    OrderBase document
)
Visual Basic
Protected Friend Sub SetDocument (
    document As OrderBase
)

Parameters

document
Type: Pastel.Evolution..::..OrderBase

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.ToString Method

[image]

Pastel Evolution SDK
OrderDetail..::..ToString Method
OrderDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String

See Also

OrderDetail Class
OrderDetail Members


OrderDetail Properties

[image] [image]

Pastel Evolution SDK
OrderDetail Properties
OrderDetail Class See Also Send Feedback

The OrderDetail type exposes the following members.

Properties

 | Name | Description
Public property | Account | Gets or sets the line's account (inventory item or GL account [in near future]).
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Description | Gets or sets the line description.
Public property | Discount | Gets or sets the total line discount value (applies to tax excl. value)
Public property | DiscountPercent | Gets or sets the line discount percentage as an integer value: 5% = 5, as opposed to 0.05
Public property | Document | Gets the document to which the detail record belongs.
Public property | GLAccount | Gets or sets the line's GLAccount.
Public property | GLAccountID | Gets or sets the GLAccount item id.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | Index | Gets the line number (1-based)
Public property | InventoryItem | Gets or sets the line's inventory item.
Public property | InventoryItemID | Gets or sets the stock item id.
Public property | JobID | Gets or sets the order detail record's job id.
Public property | LastProcess | Gets the stock quantity moved during the last processing action.
Public property | LongID | Transitional accessor. (Overrides RecordBase..::..LongID.)
Public property | Lot |
Public property | LotID |
Public property | Module | Indicates the Evolution module of the Order Detail line.
Public property | Note | Gets or sets the line note text.
Public property | Outstanding | Gets the quantity of stock that remains to be processed.
Public property | OverrideCostOfSalesAccount | Specifies the GL account to use when processing the document's cost of goods sold transaction.
Public property | OverridePurchaseAccount | Specifies the purchases GL account to use when processing the document's GL transactions. Currently this is merely an alias for
Public property | OverrideSalesAccount | Specifies the GL account to use when processing the document's sales transaction.
Public property | OverrideStockAccount | Specifies the GL account to use when processing the document's GL stock transaction.
Public property | PriceListNameID | Gets or sets the line pricelistID.
Public property | Processed | Gets the quantity of stock processed on this line up until this document.
Public property | Project | Gets or sets the line's project.
Public property | ProjectID | Gets or sets the line's project id.
Public property | Quantity | Gets or sets the quantity of product on order.
Public property | Representative | Gets or sets the sales representative on the order line. This only applies to sales transactions. When not set, the representative will default to the rep specified (if any) on the order document.
Public property | RepresentativeID | Gets or sets the representative id.
Public property | Reserved | Gets or sets the quantity of stock to reserve for an order (only applies to sales orders).
Public property | SerialNumbers | Gets the collection of serial numbers pertaining to the order detail record.
Public property | TaxMode | Gets or sets the line's tax mode.
Public property | TaxType |
Public property | ToProcess | Gets or sets the quantity of stock to move when calling the Process method.
Public property | TotalAdditionalCost | Gets or sets the additional cost allocated to the line.
Public property | TotalExcl | Gets the calculated, rounded line total exclusive amount, after discount.
Public property | TotalExclBeforeDiscount |
Public property | TotalExclBeforeDiscountForeign |
Public property | TotalExclBeforeDiscountForeignRaw |
Public property | TotalExclBeforeDiscountRaw |
Public property | TotalExclForeign |
Public property | TotalExclRaw |
Public property | TotalIncl | Gets the calculated line total inclusive amount, after discount.
Public property | TotalInclBeforeDiscount |
Public property | TotalInclBeforeDiscountForeign |
Public property | TotalInclForeign |
Public property | TotalLastProcessExcl |
Public property | TotalLastProcessExclAfterDocumentDiscount |
Public property | TotalLastProcessExclForeign |
Public property | TotalLastProcessExclForeignAfterDocumentDiscount |
Public property | TotalLastProcessIncl |
Public property | TotalLastProcessInclForeign |
Public property | TotalLastProcessTax |
Public property | TotalLastProcessTaxAfterDocumentDiscount |
Public property | TotalLastProcessTaxForeign |
Public property | TotalLastProcessTaxForeignAfterDocumentDiscount |
Public property | TotalOutstandingExcl |
Public property | TotalOutstandingExclForeign |
Public property | TotalOutstandingIncl |
Public property | TotalOutstandingInclForeign |
Public property | TotalOutstandingTax |
Public property | TotalOutstandingTaxForeign |
Public property | TotalProcessedExcl |
Public property | TotalProcessedExclForeign |
Public property | TotalProcessedIncl |
Public property | TotalProcessedInclForeign |
Public property | TotalProcessedTax |
Public property | TotalProcessedTaxForeign |
Public property | TotalSalesCost | Gets the line total cost of sale; i.e. current unit cost * quantity
Public property | TotalTax | Gets or sets the line total tax amount. Set this value as late as possible as it gets recalculated on setting Quantity, UnitSellingPrice, DiscountPercent, Discount, TaxType, as well as when adding the order detail record to the orders's Detail collection. IMPORTANT: Be sure to only use the Process() method and not one of the Complete* methods if you wish to override the tax amount. Setting TotalTax also does not affect TotalToProcessTax.
Public property | TotalTaxBeforeDiscount | Gets the tax amount before discount was applied. If discount is 100% and the total tax amount is 0, the tax rate is used to calculate a default tax amount.
Public property | TotalTaxBeforeDiscountForeign |
Public property | TotalTaxForeign |
Public property | TotalToProcessExcl |
Public property | TotalToProcessExclBeforeDiscount |
Public property | TotalToProcessExclBeforeDiscountForeign |
Public property | TotalToProcessExclForeign |
Public property | TotalToProcessIncl |
Public property | TotalToProcessInclBeforeDiscount |
Public property | TotalToProcessInclBeforeDiscountForeign |
Public property | TotalToProcessInclForeign |
Public property | TotalToProcessTax | Gets or sets the line total tax amount for the following invoice. Set this value as late as possible as it gets recalculated on setting ToProcess, UnitSellingPrice, DiscountPercent, Discount, TaxType, as well as when adding the order detail record to the orders's Detail collection. IMPORTANT: Be sure to only use the Process() method and not one of the Complete* methods only if you wish to override the tax amount.
Public property | TotalToProcessTaxAfterDocumentDiscount |
Public property | TotalToProcessTaxBeforeDiscount |
Public property | TotalToProcessTaxBeforeDiscountForeign |
Public property | TotalToProcessTaxForeign |
Public property | TotalToProcessTaxForeignAfterDocumentDiscount |
Public property | Unit |
Public property | UnitCostPrice | Gets or sets the unit cost price (used by credit notes only).
Public property | UnitID |
Public property | UnitSellingPrice | Gets or sets the unit selling or purchase price.
Public property | UnitSellingPriceAfterDiscount | Gets the line's unit selling price after discount.
Public property | UnitSellingPriceAfterDocumentDiscountExcl | Gets the order detail's unit selling price excl after line and document discount (unrounded).
Public property | UnitSellingPriceExclAfterLineDiscount | Gets the order detail's unit selling price excl after line discount (unrounded).
Public property | UnitSellingPriceForeign | Gets or sets the foreign unit selling price - on sales orders this will be the product selling price as expected, but on purchase orders, it is the supplier's selling price.
Public property | UserFields |
Public property | Warehouse | Gets or sets the warehouse relevant to this detail record. Set the warehouse only after setting the inventory item. The Warehouse and WarehouseContext properties are mapped to one another.
Public property | WarehouseContext | Gets or sets the warehouse context of the inventory item specified. Set the warehouse only after setting the inventory item. The Warehouse and WarehouseContext properties are mapped to one another.
Public property | WarehouseID | Gets the ID of the assigned warehouse (0 if N/A).

See Also

OrderDetail Class


OrderDetail.Account Property

[image]

Pastel Evolution SDK
OrderDetail..::..Account Property
OrderDetail Class See Also Send Feedback
Gets or sets the line's account (inventory item or GL account [in near future]).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public AccountBase Account { get; set; }
Visual Basic
Public Property Account As AccountBase
    Get
    Set

Property Value

Type: AccountBase

Remarks

When setting the item, the unit cost price is also set.

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.Description Property

[image]

Pastel Evolution SDK
OrderDetail..::..Description Property
OrderDetail Class See Also Send Feedback
Gets or sets the line description.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set

Property Value

Type: String

Remarks

If the description field is blank on assignment of the property, it will default to the inventory item description.

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.Discount Property

[image]

Pastel Evolution SDK
OrderDetail..::..Discount Property
OrderDetail Class See Also Send Feedback
Gets or sets the total line discount value (applies to tax excl. value)

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double Discount { get; set; }
Visual Basic
Public Property Discount As Double
    Get
    Set

Property Value

Type: Double

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.DiscountPercent Property

[image]

Pastel Evolution SDK
OrderDetail..::..DiscountPercent Property
OrderDetail Class See Also Send Feedback
Gets or sets the line discount percentage as an integer value: 5% = 5, as opposed to 0.05

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double DiscountPercent { get; set; }
Visual Basic
Public Property DiscountPercent As Double
    Get
    Set

Property Value

Type: Double

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.Document Property

[image]

Pastel Evolution SDK
OrderDetail..::..Document Property
OrderDetail Class See Also Send Feedback
Gets the document to which the detail record belongs.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public OrderBase Document { get; }
Visual Basic
Public ReadOnly Property Document As OrderBase
    Get

Property Value

Type: OrderBase

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.GLAccount Property

[image]

Pastel Evolution SDK
OrderDetail..::..GLAccount Property
OrderDetail Class See Also Send Feedback
Gets or sets the line's GLAccount.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLAccount GLAccount { get; set; }
Visual Basic
Public Property GLAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

Remarks

Setting this value will in effect set the Account.

See Also

OrderDetail Class
OrderDetail Members
Pastel.Evolution Namespace
OrderDetail..::..Account


OrderDetail.GLAccountID Property

[image]

Pastel Evolution SDK
OrderDetail..::..GLAccountID Property
OrderDetail Class See Also Send Feedback
Gets or sets the GLAccount item id.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int GLAccountID { get; set; }
Visual Basic
Public Property GLAccountID As Integer
    Get
    Set

Property Value

Type: Int32

Remarks

See Also

OrderDetail Class
OrderDetail Members
Pastel.Evolution Namespace
OrderDetail..::..GLAccount


OrderDetail.ID Property

[image]

Pastel Evolution SDK
OrderDetail..::..ID Property
OrderDetail Class See Also Send Feedback
Gets the internal record ID (0 for new, unsaved records).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.Index Property

[image]

Pastel Evolution SDK
OrderDetail..::..Index Property
OrderDetail Class See Also Send Feedback
Gets the line number (1-based)

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int Index { get; internal set; }
Visual Basic
Public Property Index As Integer
    Get
    Friend Set

Property Value

Type: Int32

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.InventoryItem Property

[image]

Pastel Evolution SDK
OrderDetail..::..InventoryItem Property
OrderDetail Class See Also Send Feedback
Gets or sets the line's inventory item.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public InventoryItem InventoryItem { get; set; }
Visual Basic
Public Property InventoryItem As InventoryItem
    Get
    Set

Property Value

Type: InventoryItem

Remarks

Setting this value will in effect set the Account. When setting the item, the unit cost price is also set.

See Also

OrderDetail Class
OrderDetail Members
Pastel.Evolution Namespace
OrderDetail..::..Account


OrderDetail.InventoryItemID Property

[image]

Pastel Evolution SDK
OrderDetail..::..InventoryItemID Property
OrderDetail Class See Also Send Feedback
Gets or sets the stock item id.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int InventoryItemID { get; set; }
Visual Basic
Public Property InventoryItemID As Integer
    Get
    Set

Property Value

Type: Int32

Remarks

See Also

OrderDetail Class
OrderDetail Members
Pastel.Evolution Namespace
OrderDetail..::..InventoryItem


OrderDetail.JobID Property

[image]

Pastel Evolution SDK
OrderDetail..::..JobID Property
OrderDetail Class See Also Send Feedback
Gets or sets the order detail record's job id.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int JobID { get; set; }
Visual Basic
Public Property JobID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.LastProcess Property

[image]

Pastel Evolution SDK
OrderDetail..::..LastProcess Property
OrderDetail Class See Also Send Feedback
Gets the stock quantity moved during the last processing action.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double LastProcess { get; }
Visual Basic
Public ReadOnly Property LastProcess As Double
    Get

Property Value

Type: Double

See Also

OrderDetail Class
OrderDetail Members
Pastel.Evolution Namespace
OrderDetail..::..ToProcess
OrderDetail..::..Processed


OrderDetail.LongID Property

[image]

Pastel Evolution SDK
OrderDetail..::..LongID Property
OrderDetail Class See Also Send Feedback
Transitional accessor.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.Lot Property

[image]

Pastel Evolution SDK
OrderDetail..::..Lot Property
OrderDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Lot Lot { get; set; }
Visual Basic
Public Property Lot As Lot
    Get
    Set

Property Value

Type: Lot

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.LotID Property

[image]

Pastel Evolution SDK
OrderDetail..::..LotID Property
OrderDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int LotID { get; set; }
Visual Basic
Public Property LotID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.Module Property

[image]

Pastel Evolution SDK
OrderDetail..::..Module Property
OrderDetail Class See Also Send Feedback
Indicates the Evolution module of the Order Detail line.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Module Module { get; }
Visual Basic
Public ReadOnly Property Module As Module
    Get

Property Value

Type: Module

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.Note Property

[image]

Pastel Evolution SDK
OrderDetail..::..Note Property
OrderDetail Class See Also Send Feedback
Gets or sets the line note text.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Note { get; set; }
Visual Basic
Public Property Note As String
    Get
    Set

Property Value

Type: String

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.Outstanding Property

[image]

Pastel Evolution SDK
OrderDetail..::..Outstanding Property
OrderDetail Class See Also Send Feedback
Gets the quantity of stock that remains to be processed.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double Outstanding { get; }
Visual Basic
Public ReadOnly Property Outstanding As Double
    Get

Property Value

Type: Double

Remarks

The calculation is Quantity - Processed.

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.OverrideCostOfSalesAccount Property

[image]

Pastel Evolution SDK
OrderDetail..::..OverrideCostOfSalesAccount Property
OrderDetail Class See Also Send Feedback
Specifies the GL account to use when processing the document's cost of goods sold transaction.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLAccount OverrideCostOfSalesAccount { get; set; }
Visual Basic
Public Property OverrideCostOfSalesAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

Remarks

The cost of sales account only applies to sales transactions (Sales order invoices and credit notes) and overrides "account 1" on the"issue stock" and "receive stock" transaction types. The GL account specified here also overrides the COS account defined on the item group or warehouse-specific group. No COS transaction is posted when using the period GL integration method as set in Inventory Defaults. Note that this value does not get saved with unprocessed documents. When set to null (as is the case when assigning a non-existing account via the GL Account's Get* methods), the default account will still be used.

See Also

OrderDetail Class
OrderDetail Members
Pastel.Evolution Namespace
OrderDetail..::..GLAccount
Pastel.Evolution..::..SalesOrder
Pastel.Evolution..::..CreditNote


OrderDetail.OverridePurchaseAccount Property

[image]

Pastel Evolution SDK
OrderDetail..::..OverridePurchaseAccount Property
OrderDetail Class See Also Send Feedback
Specifies the purchases GL account to use when processing the document's GL transactions. Currently this is merely an alias for

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLAccount OverridePurchaseAccount { get; set; }
Visual Basic
Public Property OverridePurchaseAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

Remarks

The purchases account only applies to purchases transactions (Purchase order invoices and returns) and overrides the contra account set on the"supplier invoice" and "return to supplier" transaction types. The GL account specified here also overrides the purchaes account defined on the item group or warehouse-specific group. Note that this value does not get saved with unprocessed documents. When set to null (as is the case when assigning a non-existing account via the GL Account's Get* methods), the default account will still be used.

See Also

OrderDetail Class
OrderDetail Members
Pastel.Evolution Namespace
OrderDetail..::..GLAccount
Pastel.Evolution..::..SalesOrder
Pastel.Evolution..::..CreditNote


OrderDetail.OverrideSalesAccount Property

[image]

Pastel Evolution SDK
OrderDetail..::..OverrideSalesAccount Property
OrderDetail Class See Also Send Feedback
Specifies the GL account to use when processing the document's sales transaction.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLAccount OverrideSalesAccount { get; set; }
Visual Basic
Public Property OverrideSalesAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

Remarks

The sales account only applies to sales transactions (Sales order invoices and credit notes) and overrides the contra account on theinvoice and credit note transaction types. The GL account specified here also overrides the account defined on the item group or warehouse-specific group. Note that this value does not get saved with unprocessed documents. When set to null (as is the case when assigning a non-existing account via the GL Account's Get* methods), the default account will still be used.

See Also

OrderDetail Class
OrderDetail Members
Pastel.Evolution Namespace
OrderDetail..::..GLAccount
Pastel.Evolution..::..SalesOrder
Pastel.Evolution..::..CreditNote


OrderDetail.OverrideStockAccount Property

[image]

Pastel Evolution SDK
OrderDetail..::..OverrideStockAccount Property
OrderDetail Class See Also Send Feedback
Specifies the GL account to use when processing the document's GL stock transaction.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLAccount OverrideStockAccount { get; set; }
Visual Basic
Public Property OverrideStockAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

Remarks

The stock account only applies to sales transactions (Sales order invoices and credit notes) and overrides "account 2" on the"issue stock" and "receive stock" transaction types. The GL account specified here also overrides the stock account defined on the item group or warehouse-specific group. No stock transaction is posted when using the periodic GL integration method as set in Inventory Defaults. Note that this value does not get saved with unprocessed documents. When set to null (as is the case when assigning a non-existing account via the GL Account's Get* methods), the default account will still be used. If this property is not set and during posting the stock account is overridden, it will reflect the overriding account after posting.

See Also

OrderDetail Class
OrderDetail Members
Pastel.Evolution Namespace
OrderDetail..::..GLAccount
Pastel.Evolution..::..SalesOrder
Pastel.Evolution..::..CreditNote


OrderDetail.PriceListNameID Property

[image]

Pastel Evolution SDK
OrderDetail..::..PriceListNameID Property
OrderDetail Class See Also Send Feedback
Gets or sets the line pricelistID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int PriceListNameID { get; set; }
Visual Basic
Public Property PriceListNameID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.Processed Property

[image]

Pastel Evolution SDK
OrderDetail..::..Processed Property
OrderDetail Class See Also Send Feedback
Gets the quantity of stock processed on this line up until this document.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double Processed { get; }
Visual Basic
Public ReadOnly Property Processed As Double
    Get

Property Value

Type: Double

See Also

OrderDetail Class
OrderDetail Members
Pastel.Evolution Namespace
OrderDetail..::..ToProcess


OrderDetail.Project Property

[image]

Pastel Evolution SDK
OrderDetail..::..Project Property
OrderDetail Class See Also Send Feedback
Gets or sets the line's project.
Gets or sets the project.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Project Project { get; set; }
Visual Basic
Public Property Project As Project
    Get
    Set

Property Value

Type: Project

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.ProjectID Property

[image]

Pastel Evolution SDK
OrderDetail..::..ProjectID Property
OrderDetail Class See Also Send Feedback
Gets or sets the line's project id.
Gets or sets the project id.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int ProjectID { get; set; }
Visual Basic
Public Property ProjectID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.Quantity Property

[image]

Pastel Evolution SDK
OrderDetail..::..Quantity Property
OrderDetail Class See Also Send Feedback
Gets or sets the quantity of product on order.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double Quantity { get; set; }
Visual Basic
Public Property Quantity As Double
    Get
    Set

Property Value

Type: Double

Remarks

In an order scenario, this is the quantity of product expected to be moved. This quantity gets rounded according to the rounding configuration set in inventory defaults.

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.Representative Property

[image]

Pastel Evolution SDK
OrderDetail..::..Representative Property
OrderDetail Class See Also Send Feedback
Gets or sets the sales representative on the order line. This only applies to sales transactions. When not set, the representative will default to the rep specified (if any) on the order document.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public SalesRepresentative Representative { get; set; }
Visual Basic
Public Property Representative As SalesRepresentative
    Get
    Set

Property Value

Type: SalesRepresentative

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.RepresentativeID Property

[image]

Pastel Evolution SDK
OrderDetail..::..RepresentativeID Property
OrderDetail Class See Also Send Feedback
Gets or sets the representative id.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int RepresentativeID { get; set; }
Visual Basic
Public Property RepresentativeID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

OrderDetail Class
OrderDetail Members
Pastel.Evolution Namespace
OrderDetail..::..Representative


OrderDetail.Reserved Property

[image]

Pastel Evolution SDK
OrderDetail..::..Reserved Property
OrderDetail Class See Also Send Feedback
Gets or sets the quantity of stock to reserve for an order (only applies to sales orders).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double Reserved { get; set; }
Visual Basic
Public Property Reserved As Double
    Get
    Set

Property Value

Type: Double

Remarks

Reserving stock ensures that items are not shipped on other orders. Only stock on hand can be reserved, i.e. stock that is on purchase order cannot be reserved in advance.

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.SerialNumbers Property

[image]

Pastel Evolution SDK
OrderDetail..::..SerialNumbers Property
OrderDetail Class See Also Send Feedback
Gets the collection of serial numbers pertaining to the order detail record.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public SerialNumberCollection SerialNumbers { get; }
Visual Basic
Public ReadOnly Property SerialNumbers As SerialNumberCollection
    Get

Property Value

Type: SerialNumberCollection

See Also

OrderDetail Class
OrderDetail Members
Pastel.Evolution Namespace
Pastel.Evolution..::..SerialNumber


OrderDetail.TaxMode Property

[image]

Pastel Evolution SDK
OrderDetail..::..TaxMode Property
OrderDetail Class See Also Send Feedback
Gets or sets the line's tax mode.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public TaxMode TaxMode { get; set; }
Visual Basic
Public Property TaxMode As TaxMode
    Get
    Set

Property Value

Type: TaxMode

Remarks

When attaching a detail record to an order with a differrent tax mode, the line's tax mode will automatically switch and the price be recalculated. New detail records default to tax exclusive mode and not to the mode set in inventory defaults. This was done for backward compatibility with earlier implementations of the SDK. Use the appropriate constructor for specifying the tax mode.

Exceptions

Exception | Condition
Pastel.Evolution..::..EvolutionException | The tax mode of a record linked to an order cannot be changed.

See Also

OrderDetail Class
OrderDetail Members
Pastel.Evolution Namespace
OrderDetail..::..OrderDetail(InventoryItem, Double, Double, TaxMode)


OrderDetail.TaxType Property

[image]

Pastel Evolution SDK
OrderDetail..::..TaxType Property
OrderDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public TaxRate TaxType { get; set; }
Visual Basic
Public Property TaxType As TaxRate
    Get
    Set

Property Value

Type: TaxRate

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.ToProcess Property

[image]

Pastel Evolution SDK
OrderDetail..::..ToProcess Property
OrderDetail Class See Also Send Feedback
Gets or sets the quantity of stock to move when calling the Process method.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double ToProcess { get; set; }
Visual Basic
Public Property ToProcess As Double
    Get
    Set

Property Value

Type: Double

Remarks

This cannot exceed the outstanding quantity.

Remarks

This value also has to effect on credit notes and returns to suppliers.

Exceptions

Exception | Condition
Pastel.Evolution..::..EvolutionException | The quantity ToProcess exceeds the Quantity property value. Increase the order quantity first.

See Also

OrderDetail Class
OrderDetail Members
Pastel.Evolution Namespace
OrderBase..::..Process(String)


OrderDetail.TotalAdditionalCost Property

[image]

Pastel Evolution SDK
OrderDetail..::..TotalAdditionalCost Property
OrderDetail Class See Also Send Feedback
Gets or sets the additional cost allocated to the line.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalAdditionalCost { get; set; }
Visual Basic
Public Property TotalAdditionalCost As Double
    Get
    Set

Property Value

Type: Double

Remarks

When processing, the total costs allocated to lines needs to match the document additional cost allocation.

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.TotalExcl Property

[image]

Pastel Evolution SDK
OrderDetail..::..TotalExcl Property
OrderDetail Class See Also Send Feedback
Gets the calculated, rounded line total exclusive amount, after discount.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalExcl { get; }
Visual Basic
Public ReadOnly Property TotalExcl As Double
    Get

Property Value

Type: Double

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.TotalExclBeforeDiscount Property

[image]

Pastel Evolution SDK
OrderDetail..::..TotalExclBeforeDiscount Property
OrderDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalExclBeforeDiscount { get; }
Visual Basic
Public ReadOnly Property TotalExclBeforeDiscount As Double
    Get

Property Value

Type: Double

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.TotalExclBeforeDiscountForeign Property

[image]

Pastel Evolution SDK
OrderDetail..::..TotalExclBeforeDiscountForeign Property
OrderDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalExclBeforeDiscountForeign { get; }
Visual Basic
Public ReadOnly Property TotalExclBeforeDiscountForeign As Double
    Get

Property Value

Type: Double

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.TotalExclBeforeDiscountForeignRaw Property

[image]

Pastel Evolution SDK
OrderDetail..::..TotalExclBeforeDiscountForeignRaw Property
OrderDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalExclBeforeDiscountForeignRaw { get; }
Visual Basic
Public ReadOnly Property TotalExclBeforeDiscountForeignRaw As Double
    Get

Property Value

Type: Double

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.TotalExclBeforeDiscountRaw Property

[image]

Pastel Evolution SDK
OrderDetail..::..TotalExclBeforeDiscountRaw Property
OrderDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalExclBeforeDiscountRaw { get; }
Visual Basic
Public ReadOnly Property TotalExclBeforeDiscountRaw As Double
    Get

Property Value

Type: Double

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.TotalExclForeign Property

[image]

Pastel Evolution SDK
OrderDetail..::..TotalExclForeign Property
OrderDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalExclForeign { get; }
Visual Basic
Public ReadOnly Property TotalExclForeign As Double
    Get

Property Value

Type: Double

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.TotalExclRaw Property

[image]

Pastel Evolution SDK
OrderDetail..::..TotalExclRaw Property
OrderDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalExclRaw { get; }
Visual Basic
Public ReadOnly Property TotalExclRaw As Double
    Get

Property Value

Type: Double

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.TotalIncl Property

[image]

Pastel Evolution SDK
OrderDetail..::..TotalIncl Property
OrderDetail Class See Also Send Feedback
Gets the calculated line total inclusive amount, after discount.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalIncl { get; }
Visual Basic
Public ReadOnly Property TotalIncl As Double
    Get

Property Value

Type: Double

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.TotalInclBeforeDiscount Property

[image]

Pastel Evolution SDK
OrderDetail..::..TotalInclBeforeDiscount Property
OrderDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalInclBeforeDiscount { get; }
Visual Basic
Public ReadOnly Property TotalInclBeforeDiscount As Double
    Get

Property Value

Type: Double

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.TotalInclBeforeDiscountForeign Property

[image]

Pastel Evolution SDK
OrderDetail..::..TotalInclBeforeDiscountForeign Property
OrderDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalInclBeforeDiscountForeign { get; }
Visual Basic
Public ReadOnly Property TotalInclBeforeDiscountForeign As Double
    Get

Property Value

Type: Double

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.TotalInclForeign Property

[image]

Pastel Evolution SDK
OrderDetail..::..TotalInclForeign Property
OrderDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalInclForeign { get; }
Visual Basic
Public ReadOnly Property TotalInclForeign As Double
    Get

Property Value

Type: Double

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.TotalLastProcessExcl Property

[image]

Pastel Evolution SDK
OrderDetail..::..TotalLastProcessExcl Property
OrderDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalLastProcessExcl { get; }
Visual Basic
Public ReadOnly Property TotalLastProcessExcl As Double
    Get

Property Value

Type: Double

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.TotalLastProcessExclAfterDocumentDiscount Property

[image]

Pastel Evolution SDK
OrderDetail..::..TotalLastProcessExclAfterDocumentDiscount Property
OrderDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalLastProcessExclAfterDocumentDiscount { get; }
Visual Basic
Public ReadOnly Property TotalLastProcessExclAfterDocumentDiscount As Double
    Get

Property Value

Type: Double

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.TotalLastProcessExclForeign Property

[image]

Pastel Evolution SDK
OrderDetail..::..TotalLastProcessExclForeign Property
OrderDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalLastProcessExclForeign { get; }
Visual Basic
Public ReadOnly Property TotalLastProcessExclForeign As Double
    Get

Property Value

Type: Double

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.TotalLastProcessExclForeignAfterDocumentDiscount Property

[image]

Pastel Evolution SDK
OrderDetail..::..TotalLastProcessExclForeignAfterDocumentDiscount Property
OrderDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalLastProcessExclForeignAfterDocumentDiscount { get; }
Visual Basic
Public ReadOnly Property TotalLastProcessExclForeignAfterDocumentDiscount As Double
    Get

Property Value

Type: Double

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.TotalLastProcessIncl Property

[image]

Pastel Evolution SDK
OrderDetail..::..TotalLastProcessIncl Property
OrderDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalLastProcessIncl { get; }
Visual Basic
Public ReadOnly Property TotalLastProcessIncl As Double
    Get

Property Value

Type: Double

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.TotalLastProcessInclForeign Property

[image]

Pastel Evolution SDK
OrderDetail..::..TotalLastProcessInclForeign Property
OrderDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalLastProcessInclForeign { get; }
Visual Basic
Public ReadOnly Property TotalLastProcessInclForeign As Double
    Get

Property Value

Type: Double

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.TotalLastProcessTax Property

[image]

Pastel Evolution SDK
OrderDetail..::..TotalLastProcessTax Property
OrderDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalLastProcessTax { get; }
Visual Basic
Public ReadOnly Property TotalLastProcessTax As Double
    Get

Property Value

Type: Double

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.TotalLastProcessTaxAfterDocumentDiscount Property

[image]

Pastel Evolution SDK
OrderDetail..::..TotalLastProcessTaxAfterDocumentDiscount Property
OrderDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalLastProcessTaxAfterDocumentDiscount { get; }
Visual Basic
Public ReadOnly Property TotalLastProcessTaxAfterDocumentDiscount As Double
    Get

Property Value

Type: Double

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.TotalLastProcessTaxForeign Property

[image]

Pastel Evolution SDK
OrderDetail..::..TotalLastProcessTaxForeign Property
OrderDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalLastProcessTaxForeign { get; }
Visual Basic
Public ReadOnly Property TotalLastProcessTaxForeign As Double
    Get

Property Value

Type: Double

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.TotalLastProcessTaxForeignAfterDocumentDiscount Property

[image]

Pastel Evolution SDK
OrderDetail..::..TotalLastProcessTaxForeignAfterDocumentDiscount Property
OrderDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalLastProcessTaxForeignAfterDocumentDiscount { get; }
Visual Basic
Public ReadOnly Property TotalLastProcessTaxForeignAfterDocumentDiscount As Double
    Get

Property Value

Type: Double

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.TotalOutstandingExcl Property

[image]

Pastel Evolution SDK
OrderDetail..::..TotalOutstandingExcl Property
OrderDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalOutstandingExcl { get; }
Visual Basic
Public ReadOnly Property TotalOutstandingExcl As Double
    Get

Property Value

Type: Double

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.TotalOutstandingExclForeign Property

[image]

Pastel Evolution SDK
OrderDetail..::..TotalOutstandingExclForeign Property
OrderDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalOutstandingExclForeign { get; }
Visual Basic
Public ReadOnly Property TotalOutstandingExclForeign As Double
    Get

Property Value

Type: Double

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.TotalOutstandingIncl Property

[image]

Pastel Evolution SDK
OrderDetail..::..TotalOutstandingIncl Property
OrderDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalOutstandingIncl { get; }
Visual Basic
Public ReadOnly Property TotalOutstandingIncl As Double
    Get

Property Value

Type: Double

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.TotalOutstandingInclForeign Property

[image]

Pastel Evolution SDK
OrderDetail..::..TotalOutstandingInclForeign Property
OrderDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalOutstandingInclForeign { get; }
Visual Basic
Public ReadOnly Property TotalOutstandingInclForeign As Double
    Get

Property Value

Type: Double

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.TotalOutstandingTax Property

[image]

Pastel Evolution SDK
OrderDetail..::..TotalOutstandingTax Property
OrderDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalOutstandingTax { get; }
Visual Basic
Public ReadOnly Property TotalOutstandingTax As Double
    Get

Property Value

Type: Double

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.TotalOutstandingTaxForeign Property

[image]

Pastel Evolution SDK
OrderDetail..::..TotalOutstandingTaxForeign Property
OrderDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalOutstandingTaxForeign { get; }
Visual Basic
Public ReadOnly Property TotalOutstandingTaxForeign As Double
    Get

Property Value

Type: Double

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.TotalProcessedExcl Property

[image]

Pastel Evolution SDK
OrderDetail..::..TotalProcessedExcl Property
OrderDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalProcessedExcl { get; }
Visual Basic
Public ReadOnly Property TotalProcessedExcl As Double
    Get

Property Value

Type: Double

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.TotalProcessedExclForeign Property

[image]

Pastel Evolution SDK
OrderDetail..::..TotalProcessedExclForeign Property
OrderDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalProcessedExclForeign { get; }
Visual Basic
Public ReadOnly Property TotalProcessedExclForeign As Double
    Get

Property Value

Type: Double

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.TotalProcessedIncl Property

[image]

Pastel Evolution SDK
OrderDetail..::..TotalProcessedIncl Property
OrderDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalProcessedIncl { get; }
Visual Basic
Public ReadOnly Property TotalProcessedIncl As Double
    Get

Property Value

Type: Double

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.TotalProcessedInclForeign Property

[image]

Pastel Evolution SDK
OrderDetail..::..TotalProcessedInclForeign Property
OrderDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalProcessedInclForeign { get; }
Visual Basic
Public ReadOnly Property TotalProcessedInclForeign As Double
    Get

Property Value

Type: Double

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.TotalProcessedTax Property

[image]

Pastel Evolution SDK
OrderDetail..::..TotalProcessedTax Property
OrderDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalProcessedTax { get; }
Visual Basic
Public ReadOnly Property TotalProcessedTax As Double
    Get

Property Value

Type: Double

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.TotalProcessedTaxForeign Property

[image]

Pastel Evolution SDK
OrderDetail..::..TotalProcessedTaxForeign Property
OrderDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalProcessedTaxForeign { get; }
Visual Basic
Public ReadOnly Property TotalProcessedTaxForeign As Double
    Get

Property Value

Type: Double

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.TotalSalesCost Property

[image]

Pastel Evolution SDK
OrderDetail..::..TotalSalesCost Property
OrderDetail Class See Also Send Feedback
Gets the line total cost of sale; i.e. current unit cost * quantity

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalSalesCost { get; }
Visual Basic
Public ReadOnly Property TotalSalesCost As Double
    Get

Property Value

Type: Double

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.TotalTax Property

[image]

Pastel Evolution SDK
OrderDetail..::..TotalTax Property
OrderDetail Class See Also Send Feedback
Gets or sets the line total tax amount. Set this value as late as possible as it gets recalculated on setting Quantity, UnitSellingPrice, DiscountPercent, Discount, TaxType, as well as when adding the order detail record to the orders's Detail collection. IMPORTANT: Be sure to only use the Process() method and not one of the Complete* methods if you wish to override the tax amount. Setting TotalTax also does not affect TotalToProcessTax.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalTax { get; set; }
Visual Basic
Public Property TotalTax As Double
    Get
    Set

Property Value

Type: Double

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.TotalTaxBeforeDiscount Property

[image]

Pastel Evolution SDK
OrderDetail..::..TotalTaxBeforeDiscount Property
OrderDetail Class See Also Send Feedback
Gets the tax amount before discount was applied. If discount is 100% and the total tax amount is 0, the tax rate is used to calculate a default tax amount.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalTaxBeforeDiscount { get; }
Visual Basic
Public ReadOnly Property TotalTaxBeforeDiscount As Double
    Get

Property Value

Type: Double

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.TotalTaxBeforeDiscountForeign Property

[image]

Pastel Evolution SDK
OrderDetail..::..TotalTaxBeforeDiscountForeign Property
OrderDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalTaxBeforeDiscountForeign { get; }
Visual Basic
Public ReadOnly Property TotalTaxBeforeDiscountForeign As Double
    Get

Property Value

Type: Double

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.TotalTaxForeign Property

[image]

Pastel Evolution SDK
OrderDetail..::..TotalTaxForeign Property
OrderDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalTaxForeign { get; set; }
Visual Basic
Public Property TotalTaxForeign As Double
    Get
    Set

Property Value

Type: Double

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.TotalToProcessExcl Property

[image]

Pastel Evolution SDK
OrderDetail..::..TotalToProcessExcl Property
OrderDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalToProcessExcl { get; }
Visual Basic
Public ReadOnly Property TotalToProcessExcl As Double
    Get

Property Value

Type: Double

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.TotalToProcessExclBeforeDiscount Property

[image]

Pastel Evolution SDK
OrderDetail..::..TotalToProcessExclBeforeDiscount Property
OrderDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalToProcessExclBeforeDiscount { get; }
Visual Basic
Public ReadOnly Property TotalToProcessExclBeforeDiscount As Double
    Get

Property Value

Type: Double

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.TotalToProcessExclBeforeDiscountForeign Property

[image]

Pastel Evolution SDK
OrderDetail..::..TotalToProcessExclBeforeDiscountForeign Property
OrderDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalToProcessExclBeforeDiscountForeign { get; }
Visual Basic
Public ReadOnly Property TotalToProcessExclBeforeDiscountForeign As Double
    Get

Property Value

Type: Double

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.TotalToProcessExclForeign Property

[image]

Pastel Evolution SDK
OrderDetail..::..TotalToProcessExclForeign Property
OrderDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalToProcessExclForeign { get; }
Visual Basic
Public ReadOnly Property TotalToProcessExclForeign As Double
    Get

Property Value

Type: Double

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.TotalToProcessIncl Property

[image]

Pastel Evolution SDK
OrderDetail..::..TotalToProcessIncl Property
OrderDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalToProcessIncl { get; }
Visual Basic
Public ReadOnly Property TotalToProcessIncl As Double
    Get

Property Value

Type: Double

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.TotalToProcessInclBeforeDiscount Property

[image]

Pastel Evolution SDK
OrderDetail..::..TotalToProcessInclBeforeDiscount Property
OrderDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalToProcessInclBeforeDiscount { get; }
Visual Basic
Public ReadOnly Property TotalToProcessInclBeforeDiscount As Double
    Get

Property Value

Type: Double

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.TotalToProcessInclBeforeDiscountForeign Property

[image]

Pastel Evolution SDK
OrderDetail..::..TotalToProcessInclBeforeDiscountForeign Property
OrderDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalToProcessInclBeforeDiscountForeign { get; }
Visual Basic
Public ReadOnly Property TotalToProcessInclBeforeDiscountForeign As Double
    Get

Property Value

Type: Double

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.TotalToProcessInclForeign Property

[image]

Pastel Evolution SDK
OrderDetail..::..TotalToProcessInclForeign Property
OrderDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalToProcessInclForeign { get; }
Visual Basic
Public ReadOnly Property TotalToProcessInclForeign As Double
    Get

Property Value

Type: Double

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.TotalToProcessTax Property

[image]

Pastel Evolution SDK
OrderDetail..::..TotalToProcessTax Property
OrderDetail Class See Also Send Feedback
Gets or sets the line total tax amount for the following invoice. Set this value as late as possible as it gets recalculated on setting ToProcess, UnitSellingPrice, DiscountPercent, Discount, TaxType, as well as when adding the order detail record to the orders's Detail collection. IMPORTANT: Be sure to only use the Process() method and not one of the Complete* methods only if you wish to override the tax amount.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalToProcessTax { get; set; }
Visual Basic
Public Property TotalToProcessTax As Double
    Get
    Set

Property Value

Type: Double

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.TotalToProcessTaxAfterDocumentDiscount Property

[image]

Pastel Evolution SDK
OrderDetail..::..TotalToProcessTaxAfterDocumentDiscount Property
OrderDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalToProcessTaxAfterDocumentDiscount { get; }
Visual Basic
Public ReadOnly Property TotalToProcessTaxAfterDocumentDiscount As Double
    Get

Property Value

Type: Double

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.TotalToProcessTaxBeforeDiscount Property

[image]

Pastel Evolution SDK
OrderDetail..::..TotalToProcessTaxBeforeDiscount Property
OrderDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalToProcessTaxBeforeDiscount { get; }
Visual Basic
Public ReadOnly Property TotalToProcessTaxBeforeDiscount As Double
    Get

Property Value

Type: Double

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.TotalToProcessTaxBeforeDiscountForeign Property

[image]

Pastel Evolution SDK
OrderDetail..::..TotalToProcessTaxBeforeDiscountForeign Property
OrderDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalToProcessTaxBeforeDiscountForeign { get; }
Visual Basic
Public ReadOnly Property TotalToProcessTaxBeforeDiscountForeign As Double
    Get

Property Value

Type: Double

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.TotalToProcessTaxForeign Property

[image]

Pastel Evolution SDK
OrderDetail..::..TotalToProcessTaxForeign Property
OrderDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalToProcessTaxForeign { get; set; }
Visual Basic
Public Property TotalToProcessTaxForeign As Double
    Get
    Set

Property Value

Type: Double

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.TotalToProcessTaxForeignAfterDocumentDiscount Property

[image]

Pastel Evolution SDK
OrderDetail..::..TotalToProcessTaxForeignAfterDocumentDiscount Property
OrderDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalToProcessTaxForeignAfterDocumentDiscount { get; }
Visual Basic
Public ReadOnly Property TotalToProcessTaxForeignAfterDocumentDiscount As Double
    Get

Property Value

Type: Double

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.Unit Property

[image]

Pastel Evolution SDK
OrderDetail..::..Unit Property
OrderDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Unit Unit { get; set; }
Visual Basic
Public Property Unit As Unit
    Get
    Set

Property Value

Type: Unit

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.UnitCostPrice Property

[image]

Pastel Evolution SDK
OrderDetail..::..UnitCostPrice Property
OrderDetail Class See Also Send Feedback
Gets or sets the unit cost price (used by credit notes only).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double UnitCostPrice { get; set; }
Visual Basic
Public Property UnitCostPrice As Double
    Get
    Set

Property Value

Type: Double

Remarks

The unit cost price defaults to the current item cost price in the system but can be overridden if required. Override only after setting the inventory item and warehouse.

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.UnitID Property

[image]

Pastel Evolution SDK
OrderDetail..::..UnitID Property
OrderDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int UnitID { get; set; }
Visual Basic
Public Property UnitID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.UnitSellingPrice Property

[image]

Pastel Evolution SDK
OrderDetail..::..UnitSellingPrice Property
OrderDetail Class See Also Send Feedback
Gets or sets the unit selling or purchase price.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double UnitSellingPrice { get; set; }
Visual Basic
Public Property UnitSellingPrice As Double
    Get
    Set

Property Value

Type: Double

See Also

OrderDetail Class
OrderDetail Members
Pastel.Evolution Namespace
OrderBase..::..TaxMode


OrderDetail.UnitSellingPriceAfterDiscount Property

[image]

Pastel Evolution SDK
OrderDetail..::..UnitSellingPriceAfterDiscount Property
OrderDetail Class See Also Send Feedback
Gets the line's unit selling price after discount.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double UnitSellingPriceAfterDiscount { get; }
Visual Basic
Public ReadOnly Property UnitSellingPriceAfterDiscount As Double
    Get

Property Value

Type: Double

Remarks

Unlike UnitSellingPriceExclAfterDiscount, this value is based on the tax mode.

See Also

OrderDetail Class
OrderDetail Members
Pastel.Evolution Namespace
OrderDetail..::..UnitSellingPriceExclAfterLineDiscount
OrderDetail..::..TaxMode


OrderDetail.UnitSellingPriceAfterDocumentDiscountExcl Property

[image]

Pastel Evolution SDK
OrderDetail..::..UnitSellingPriceAfterDocumentDiscountExcl Property
OrderDetail Class See Also Send Feedback
Gets the order detail's unit selling price excl after line and document discount (unrounded).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double UnitSellingPriceAfterDocumentDiscountExcl { get; }
Visual Basic
Public ReadOnly Property UnitSellingPriceAfterDocumentDiscountExcl As Double
    Get

Property Value

Type: Double

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.UnitSellingPriceExclAfterLineDiscount Property

[image]

Pastel Evolution SDK
OrderDetail..::..UnitSellingPriceExclAfterLineDiscount Property
OrderDetail Class See Also Send Feedback
Gets the order detail's unit selling price excl after line discount (unrounded).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double UnitSellingPriceExclAfterLineDiscount { get; }
Visual Basic
Public ReadOnly Property UnitSellingPriceExclAfterLineDiscount As Double
    Get

Property Value

Type: Double

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.UnitSellingPriceForeign Property

[image]

Pastel Evolution SDK
OrderDetail..::..UnitSellingPriceForeign Property
OrderDetail Class See Also Send Feedback
Gets or sets the foreign unit selling price - on sales orders this will be the product selling price as expected, but on purchase orders, it is the supplier's selling price.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double UnitSellingPriceForeign { get; set; }
Visual Basic
Public Property UnitSellingPriceForeign As Double
    Get
    Set

Property Value

Type: Double

See Also

OrderDetail Class
OrderDetail Members
Pastel.Evolution Namespace
OrderBase..::..TaxMode


OrderDetail.UserFields Property

[image]

Pastel Evolution SDK
OrderDetail..::..UserFields Property
OrderDetail Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public FieldCollection UserFields { get; }
Visual Basic
Public ReadOnly Property UserFields As FieldCollection
    Get

Property Value

Type: FieldCollection

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.Warehouse Property

[image]

Pastel Evolution SDK
OrderDetail..::..Warehouse Property
OrderDetail Class See Also Send Feedback
Gets or sets the warehouse relevant to this detail record. Set the warehouse only after setting the inventory item. The Warehouse and WarehouseContext properties are mapped to one another.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Warehouse Warehouse { get; set; }
Visual Basic
Public Property Warehouse As Warehouse
    Get
    Set

Property Value

Type: Warehouse

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.WarehouseContext Property

[image]

Pastel Evolution SDK
OrderDetail..::..WarehouseContext Property
OrderDetail Class See Also Send Feedback
Gets or sets the warehouse context of the inventory item specified. Set the warehouse only after setting the inventory item. The Warehouse and WarehouseContext properties are mapped to one another.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public WarehouseContext WarehouseContext { get; set; }
Visual Basic
Public Property WarehouseContext As WarehouseContext
    Get
    Set

Property Value

Type: WarehouseContext

See Also

OrderDetail Class
OrderDetail Members


OrderDetail.WarehouseID Property

[image]

Pastel Evolution SDK
OrderDetail..::..WarehouseID Property
OrderDetail Class See Also Send Feedback
Gets the ID of the assigned warehouse (0 if N/A).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int WarehouseID { get; }
Visual Basic
Public ReadOnly Property WarehouseID As Integer
    Get

Property Value

Type: Int32

See Also

OrderDetail Class
OrderDetail Members


OrderDetailCollection Class

[image]

Pastel Evolution SDK
OrderDetailCollection Class
Members See Also Send Feedback
Represents a collection of order detail items, typically owned by a given inventory document record.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class OrderDetailCollection : CollectionBase,
    ICloneable
Visual Basic
Public Class OrderDetailCollection
    Inherits CollectionBase
    Implements ICloneable

Inheritance Hierarchy

System..::..Object
System.Collections..::..CollectionBase
Pastel.Evolution..::..OrderDetailCollection

See Also

OrderDetailCollection Members


OrderDetailCollection Members

[image] [image]

Pastel Evolution SDK
OrderDetailCollection Members
OrderDetailCollection Class Methods Properties Events See Also Send Feedback

The OrderDetailCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add(OrderDetail) | Appends an order detail object to the order.
Public method | Add(String, Double, Double) | Appends a detail line to the order.
Public method | Add(InventoryItem, Double, Double) | Appends a detail line to the order.
Public method | Add(String, String, Double, Double) | Appends a detail line to the order.
Public method | Add(InventoryItem, String, Double, Double) | Appends a detail line to the order.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Clone |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | (Overrides CollectionBase..::..OnClear()()()().)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Public method | OnCollectionChanged |
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Process | Calls the Process method on each detail record
Public method | Remove | Removes the specified order detail line from the collection
Public method | RemoveAt | Removes an order detail line using its zero-based index.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item[([( Int32])]) | Gets an order detail object by its zero-based index.
Public property | Item[([( DocumentState, Int32])]) |
Public property | LastProcessCount |
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | OutstandingCount |
Public property | ToProcessCount |
Public property | TotalAdditionalCost |
Public property | TotalExcl |
Public property | TotalExclBeforeDiscount |
Public property | TotalExclBeforeDiscountForeign |
Public property | TotalExclForeign |
Public property | TotalIncl |
Public property | TotalInclForeign |
Public property | TotalLastProcessExcl |
Public property | TotalLastProcessExclForeign |
Public property | TotalLastProcessIncl |
Public property | TotalLastProcessInclForeign |
Public property | TotalLastProcessQuantity |
Public property | TotalLastProcessTax |
Public property | TotalLastProcessTaxAfterDocumentDiscount |
Public property | TotalLastProcessTaxAfterDocumentDiscountForeign |
Public property | TotalLastProcessTaxForeign |
Public property | TotalOutstandingExcl |
Public property | TotalOutstandingExclAfterDocumentDiscount |
Public property | TotalOutstandingExclAfterDocumentDiscountForeign |
Public property | TotalOutstandingExclForeign |
Public property | TotalOutstandingIncl |
Public property | TotalOutstandingInclForeign |
Public property | TotalOutstandingQuantity |
Public property | TotalOutstandingTax |
Public property | TotalOutstandingTaxAfterDocumentDiscount |
Public property | TotalOutstandingTaxAfterDocumentDiscountForeign |
Public property | TotalOutstandingTaxForeign |
Public property | TotalQuantity |
Public property | TotalSalesCost | Gets the total cost of sale; i.e. current unit cost * quantity
Public property | TotalTax |
Public property | TotalTaxAfterDocumentDiscount |
Public property | TotalTaxAfterDocumentDiscountForeign |
Public property | TotalTaxForeign |
Public property | TotalToProcessExcl |
Public property | TotalToProcessExclAfterDocumentDiscount |
Public property | TotalToProcessExclForeign |
Public property | TotalToProcessExclForeignAfterDocumentDiscount |
Public property | TotalToProcessIncl |
Public property | TotalToProcessInclAfterDocumentDiscount |
Public property | TotalToProcessInclAfterDocumentDiscountForeign |
Public property | TotalToProcessInclForeign |
Public property | TotalToProcessTax |
Public property | TotalToProcessTaxAfterDocumentDiscount |
Public property | TotalToProcessTaxForeign |
Public property | TotalToProcessTaxForeignAfterDocumentDiscount |

Events

 | Name | Description
Public event | CollectionChanged | Occurs when detail records are added or deleted.

See Also

OrderDetailCollection Class


OrderDetailCollection Methods

[image] [image]

Pastel Evolution SDK
OrderDetailCollection Methods
OrderDetailCollection Class See Also Send Feedback

The OrderDetailCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add(OrderDetail) | Appends an order detail object to the order.
Public method | Add(String, Double, Double) | Appends a detail line to the order.
Public method | Add(InventoryItem, Double, Double) | Appends a detail line to the order.
Public method | Add(String, String, Double, Double) | Appends a detail line to the order.
Public method | Add(InventoryItem, String, Double, Double) | Appends a detail line to the order.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Clone |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | (Overrides CollectionBase..::..OnClear()()()().)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Public method | OnCollectionChanged |
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Process | Calls the Process method on each detail record
Public method | Remove | Removes the specified order detail line from the collection
Public method | RemoveAt | Removes an order detail line using its zero-based index.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OrderDetailCollection Class


OrderDetailCollection.Add Method

[image] [image]

Pastel Evolution SDK
OrderDetailCollection..::..Add Method
OrderDetailCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Add(OrderDetail) | Appends an order detail object to the order.
Public method | Add(String, Double, Double) | Appends a detail line to the order.
Public method | Add(InventoryItem, Double, Double) | Appends a detail line to the order.
Public method | Add(String, String, Double, Double) | Appends a detail line to the order.
Public method | Add(InventoryItem, String, Double, Double) | Appends a detail line to the order.

See Also

OrderDetailCollection Class
OrderDetailCollection Members


OrderDetailCollection.Add Method (OrderDetail)

[image]

Pastel Evolution SDK
OrderDetailCollection..::..Add Method (OrderDetail)
OrderDetailCollection Class See Also Send Feedback
Appends an order detail object to the order.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void Add(
    OrderDetail detailRecord
)
Visual Basic
Public Sub Add (
    detailRecord As OrderDetail
)

Parameters

detailRecord
Type: Pastel.Evolution..::..OrderDetail

Remarks

Take note that upon being added to a document, the detail record will assume the document's sales representative and project.

See Also

OrderDetailCollection Class
OrderDetailCollection Members
Add Overload


OrderDetailCollection.Add Method (String, Double, Double)

[image]

Pastel Evolution SDK
OrderDetailCollection..::..Add Method (String, Double, Double)
OrderDetailCollection Class See Also Send Feedback
Appends a detail line to the order.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public OrderDetail Add(
    string itemCode,
    double quantity,
    double price
)
Visual Basic
Public Function Add (
    itemCode As String,
    quantity As Double,
    price As Double
) As OrderDetail

Parameters

itemCode
Type: System..::..String
The code of the stock item
quantity
Type: System..::..Double
The quantity to order
price
Type: System..::..Double
The exclusive unit price

Return Value

Type: OrderDetail
The newly created detail record.

See Also

OrderDetailCollection Class
OrderDetailCollection Members
Add Overload


OrderDetailCollection.Add Method (InventoryItem, Double, Double)

[image]

Pastel Evolution SDK
OrderDetailCollection..::..Add Method (InventoryItem, Double, Double)
OrderDetailCollection Class See Also Send Feedback
Appends a detail line to the order.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public OrderDetail Add(
    InventoryItem item,
    double quantity,
    double price
)
Visual Basic
Public Function Add (
    item As InventoryItem,
    quantity As Double,
    price As Double
) As OrderDetail

Parameters

item
Type: Pastel.Evolution..::..InventoryItem
The stock item object.
quantity
Type: System..::..Double
The quantity to order.
price
Type: System..::..Double
The unit price.

Return Value

Type: OrderDetail
The newly created detail record.

See Also

OrderDetailCollection Class
OrderDetailCollection Members
Add Overload


OrderDetailCollection.Add Method (String, String, Double, Double)

[image]

Pastel Evolution SDK
OrderDetailCollection..::..Add Method (String, String, Double, Double)
OrderDetailCollection Class See Also Send Feedback
Appends a detail line to the order.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public OrderDetail Add(
    string itemCode,
    string warehouseCode,
    double quantity,
    double price
)
Visual Basic
Public Function Add (
    itemCode As String,
    warehouseCode As String,
    quantity As Double,
    price As Double
) As OrderDetail

Parameters

itemCode
Type: System..::..String
The code of the stock item
warehouseCode
Type: System..::..String
The code of the warehouse to use on this record.
quantity
Type: System..::..Double
The quantity to order
price
Type: System..::..Double
The exclusive unit price

Return Value

Type: OrderDetail
The newly created detail record.

See Also

OrderDetailCollection Class
OrderDetailCollection Members
Add Overload


OrderDetailCollection.Add Method (InventoryItem, String, Double, Double)

[image]

Pastel Evolution SDK
OrderDetailCollection..::..Add Method (InventoryItem, String, Double, Double)
OrderDetailCollection Class See Also Send Feedback
Appends a detail line to the order.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public OrderDetail Add(
    InventoryItem item,
    string warehouseCode,
    double quantity,
    double price
)
Visual Basic
Public Function Add (
    item As InventoryItem,
    warehouseCode As String,
    quantity As Double,
    price As Double
) As OrderDetail

Parameters

item
Type: Pastel.Evolution..::..InventoryItem
The code of the stock item.
warehouseCode
Type: System..::..String
The code of the warehouse to use on this record.
quantity
Type: System..::..Double
The quantity to order.
price
Type: System..::..Double
The exclusive unit price.

Return Value

Type: OrderDetail
The newly created detail record.

See Also

OrderDetailCollection Class
OrderDetailCollection Members
Add Overload


OrderDetailCollection.Clone Method

[image]

Pastel Evolution SDK
OrderDetailCollection..::..Clone Method
OrderDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Object Clone()
Visual Basic
Public Function Clone As Object

Return Value

Type: Object

Implements

ICloneable..::..Clone()()()()

See Also

OrderDetailCollection Class
OrderDetailCollection Members


OrderDetailCollection.OnClear Method

[image]

Pastel Evolution SDK
OrderDetailCollection..::..OnClear Method
OrderDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected override void OnClear()
Visual Basic
Protected Overrides Sub OnClear

See Also

OrderDetailCollection Class
OrderDetailCollection Members


OrderDetailCollection.OnCollectionChanged Method

[image]

Pastel Evolution SDK
OrderDetailCollection..::..OnCollectionChanged Method
OrderDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void OnCollectionChanged(
    OrderDetailCollection..::..OrderDetailCollectionChangedEventArgs e
)
Visual Basic
Public Sub OnCollectionChanged (
    e As OrderDetailCollection..::..OrderDetailCollectionChangedEventArgs
)

Parameters

e
Type: Pastel.Evolution..::..OrderDetailCollection..::..OrderDetailCollectionChangedEventArgs

See Also

OrderDetailCollection Class
OrderDetailCollection Members


OrderDetailCollection.Process Method

[image]

Pastel Evolution SDK
OrderDetailCollection..::..Process Method
OrderDetailCollection Class See Also Send Feedback
Calls the Process method on each detail record

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void Process(
    int archID
)
Visual Basic
Public Sub Process (
    archID As Integer
)

Parameters

archID
Type: System..::..Int32

See Also

OrderDetailCollection Class
OrderDetailCollection Members


OrderDetailCollection.Remove Method

[image]

Pastel Evolution SDK
OrderDetailCollection..::..Remove Method
OrderDetailCollection Class See Also Send Feedback
Removes the specified order detail line from the collection

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void Remove(
    OrderDetail detailRecord
)
Visual Basic
Public Sub Remove (
    detailRecord As OrderDetail
)

Parameters

detailRecord
Type: Pastel.Evolution..::..OrderDetail

See Also

OrderDetailCollection Class
OrderDetailCollection Members


OrderDetailCollection.RemoveAt Method

[image]

Pastel Evolution SDK
OrderDetailCollection..::..RemoveAt Method
OrderDetailCollection Class See Also Send Feedback
Removes an order detail line using its zero-based index.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void RemoveAt(
    int index
)
Visual Basic
Public Sub RemoveAt (
    index As Integer
)

Parameters

index
Type: System..::..Int32

See Also

OrderDetailCollection Class
OrderDetailCollection Members


OrderDetailCollection Properties

[image] [image]

Pastel Evolution SDK
OrderDetailCollection Properties
OrderDetailCollection Class See Also Send Feedback

The OrderDetailCollection type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item[([( Int32])]) | Gets an order detail object by its zero-based index.
Public property | Item[([( DocumentState, Int32])]) |
Public property | LastProcessCount |
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | OutstandingCount |
Public property | ToProcessCount |
Public property | TotalAdditionalCost |
Public property | TotalExcl |
Public property | TotalExclBeforeDiscount |
Public property | TotalExclBeforeDiscountForeign |
Public property | TotalExclForeign |
Public property | TotalIncl |
Public property | TotalInclForeign |
Public property | TotalLastProcessExcl |
Public property | TotalLastProcessExclForeign |
Public property | TotalLastProcessIncl |
Public property | TotalLastProcessInclForeign |
Public property | TotalLastProcessQuantity |
Public property | TotalLastProcessTax |
Public property | TotalLastProcessTaxAfterDocumentDiscount |
Public property | TotalLastProcessTaxAfterDocumentDiscountForeign |
Public property | TotalLastProcessTaxForeign |
Public property | TotalOutstandingExcl |
Public property | TotalOutstandingExclAfterDocumentDiscount |
Public property | TotalOutstandingExclAfterDocumentDiscountForeign |
Public property | TotalOutstandingExclForeign |
Public property | TotalOutstandingIncl |
Public property | TotalOutstandingInclForeign |
Public property | TotalOutstandingQuantity |
Public property | TotalOutstandingTax |
Public property | TotalOutstandingTaxAfterDocumentDiscount |
Public property | TotalOutstandingTaxAfterDocumentDiscountForeign |
Public property | TotalOutstandingTaxForeign |
Public property | TotalQuantity |
Public property | TotalSalesCost | Gets the total cost of sale; i.e. current unit cost * quantity
Public property | TotalTax |
Public property | TotalTaxAfterDocumentDiscount |
Public property | TotalTaxAfterDocumentDiscountForeign |
Public property | TotalTaxForeign |
Public property | TotalToProcessExcl |
Public property | TotalToProcessExclAfterDocumentDiscount |
Public property | TotalToProcessExclForeign |
Public property | TotalToProcessExclForeignAfterDocumentDiscount |
Public property | TotalToProcessIncl |
Public property | TotalToProcessInclAfterDocumentDiscount |
Public property | TotalToProcessInclAfterDocumentDiscountForeign |
Public property | TotalToProcessInclForeign |
Public property | TotalToProcessTax |
Public property | TotalToProcessTaxAfterDocumentDiscount |
Public property | TotalToProcessTaxForeign |
Public property | TotalToProcessTaxForeignAfterDocumentDiscount |

See Also

OrderDetailCollection Class


OrderDetailCollection.Item Property

[image] [image]

Pastel Evolution SDK
OrderDetailCollection..::..Item Property
OrderDetailCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public property | Item[([( Int32])]) | Gets an order detail object by its zero-based index.
Public property | Item[([( DocumentState, Int32])]) |

See Also

OrderDetailCollection Class
OrderDetailCollection Members


OrderDetailCollection.Item Property (Int32)

[image]

Pastel Evolution SDK
OrderDetailCollection..::..Item Property (Int32)
OrderDetailCollection Class See Also Send Feedback
Gets an order detail object by its zero-based index.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public OrderDetail this[
    int index
] { get; set; }
Visual Basic
Public Default Property Item (
    index As Integer
) As OrderDetail
    Get
    Set

Parameters

index
Type: System..::..Int32

Return Value

Type: OrderDetail

See Also

OrderDetailCollection Class
OrderDetailCollection Members
Item Overload


OrderDetailCollection.Item Property (DocumentState, Int32)

[image]

Pastel Evolution SDK
OrderDetailCollection..::..Item Property (DocumentState, Int32)
OrderDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public OrderDetail this[
    DocumentState state,
    int index
] { get; }
Visual Basic
Public ReadOnly Default Property Item (
    state As DocumentState,
    index As Integer
) As OrderDetail
    Get

Parameters

state
Type: Pastel.Evolution..::..DocumentState
index
Type: System..::..Int32

Property Value

Type: OrderDetail

See Also

OrderDetailCollection Class
OrderDetailCollection Members
Item Overload


OrderDetailCollection.LastProcessCount Property

[image]

Pastel Evolution SDK
OrderDetailCollection..::..LastProcessCount Property
OrderDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int LastProcessCount { get; }
Visual Basic
Public ReadOnly Property LastProcessCount As Integer
    Get

Property Value

Type: Int32

See Also

OrderDetailCollection Class
OrderDetailCollection Members


OrderDetailCollection.OutstandingCount Property

[image]

Pastel Evolution SDK
OrderDetailCollection..::..OutstandingCount Property
OrderDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int OutstandingCount { get; }
Visual Basic
Public ReadOnly Property OutstandingCount As Integer
    Get

Property Value

Type: Int32

See Also

OrderDetailCollection Class
OrderDetailCollection Members


OrderDetailCollection.ToProcessCount Property

[image]

Pastel Evolution SDK
OrderDetailCollection..::..ToProcessCount Property
OrderDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int ToProcessCount { get; }
Visual Basic
Public ReadOnly Property ToProcessCount As Integer
    Get

Property Value

Type: Int32

See Also

OrderDetailCollection Class
OrderDetailCollection Members


OrderDetailCollection.TotalAdditionalCost Property

[image]

Pastel Evolution SDK
OrderDetailCollection..::..TotalAdditionalCost Property
OrderDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalAdditionalCost { get; }
Visual Basic
Public ReadOnly Property TotalAdditionalCost As Double
    Get

Property Value

Type: Double

See Also

OrderDetailCollection Class
OrderDetailCollection Members


OrderDetailCollection.TotalExcl Property

[image]

Pastel Evolution SDK
OrderDetailCollection..::..TotalExcl Property
OrderDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalExcl { get; }
Visual Basic
Public ReadOnly Property TotalExcl As Double
    Get

Property Value

Type: Double

See Also

OrderDetailCollection Class
OrderDetailCollection Members


OrderDetailCollection.TotalExclBeforeDiscount Property

[image]

Pastel Evolution SDK
OrderDetailCollection..::..TotalExclBeforeDiscount Property
OrderDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalExclBeforeDiscount { get; }
Visual Basic
Public ReadOnly Property TotalExclBeforeDiscount As Double
    Get

Property Value

Type: Double

See Also

OrderDetailCollection Class
OrderDetailCollection Members


OrderDetailCollection.TotalExclBeforeDiscountForeign Property

[image]

Pastel Evolution SDK
OrderDetailCollection..::..TotalExclBeforeDiscountForeign Property
OrderDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalExclBeforeDiscountForeign { get; }
Visual Basic
Public ReadOnly Property TotalExclBeforeDiscountForeign As Double
    Get

Property Value

Type: Double

See Also

OrderDetailCollection Class
OrderDetailCollection Members


OrderDetailCollection.TotalExclForeign Property

[image]

Pastel Evolution SDK
OrderDetailCollection..::..TotalExclForeign Property
OrderDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalExclForeign { get; }
Visual Basic
Public ReadOnly Property TotalExclForeign As Double
    Get

Property Value

Type: Double

See Also

OrderDetailCollection Class
OrderDetailCollection Members


OrderDetailCollection.TotalIncl Property

[image]

Pastel Evolution SDK
OrderDetailCollection..::..TotalIncl Property
OrderDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalIncl { get; }
Visual Basic
Public ReadOnly Property TotalIncl As Double
    Get

Property Value

Type: Double

See Also

OrderDetailCollection Class
OrderDetailCollection Members


OrderDetailCollection.TotalInclForeign Property

[image]

Pastel Evolution SDK
OrderDetailCollection..::..TotalInclForeign Property
OrderDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalInclForeign { get; }
Visual Basic
Public ReadOnly Property TotalInclForeign As Double
    Get

Property Value

Type: Double

See Also

OrderDetailCollection Class
OrderDetailCollection Members


OrderDetailCollection.TotalLastProcessExcl Property

[image]

Pastel Evolution SDK
OrderDetailCollection..::..TotalLastProcessExcl Property
OrderDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalLastProcessExcl { get; }
Visual Basic
Public ReadOnly Property TotalLastProcessExcl As Double
    Get

Property Value

Type: Double

See Also

OrderDetailCollection Class
OrderDetailCollection Members


OrderDetailCollection.TotalLastProcessExclForeign Property

[image]

Pastel Evolution SDK
OrderDetailCollection..::..TotalLastProcessExclForeign Property
OrderDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalLastProcessExclForeign { get; }
Visual Basic
Public ReadOnly Property TotalLastProcessExclForeign As Double
    Get

Property Value

Type: Double

See Also

OrderDetailCollection Class
OrderDetailCollection Members


OrderDetailCollection.TotalLastProcessIncl Property

[image]

Pastel Evolution SDK
OrderDetailCollection..::..TotalLastProcessIncl Property
OrderDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalLastProcessIncl { get; }
Visual Basic
Public ReadOnly Property TotalLastProcessIncl As Double
    Get

Property Value

Type: Double

See Also

OrderDetailCollection Class
OrderDetailCollection Members


OrderDetailCollection.TotalLastProcessInclForeign Property

[image]

Pastel Evolution SDK
OrderDetailCollection..::..TotalLastProcessInclForeign Property
OrderDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalLastProcessInclForeign { get; }
Visual Basic
Public ReadOnly Property TotalLastProcessInclForeign As Double
    Get

Property Value

Type: Double

See Also

OrderDetailCollection Class
OrderDetailCollection Members


OrderDetailCollection.TotalLastProcessQuantity Property

[image]

Pastel Evolution SDK
OrderDetailCollection..::..TotalLastProcessQuantity Property
OrderDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalLastProcessQuantity { get; }
Visual Basic
Public ReadOnly Property TotalLastProcessQuantity As Double
    Get

Property Value

Type: Double

See Also

OrderDetailCollection Class
OrderDetailCollection Members


OrderDetailCollection.TotalLastProcessTax Property

[image]

Pastel Evolution SDK
OrderDetailCollection..::..TotalLastProcessTax Property
OrderDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalLastProcessTax { get; }
Visual Basic
Public ReadOnly Property TotalLastProcessTax As Double
    Get

Property Value

Type: Double

See Also

OrderDetailCollection Class
OrderDetailCollection Members


OrderDetailCollection.TotalLastProcessTaxAfterDocumentDiscount Property

[image]

Pastel Evolution SDK
OrderDetailCollection..::..TotalLastProcessTaxAfterDocumentDiscount Property
OrderDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalLastProcessTaxAfterDocumentDiscount { get; }
Visual Basic
Public ReadOnly Property TotalLastProcessTaxAfterDocumentDiscount As Double
    Get

Property Value

Type: Double

See Also

OrderDetailCollection Class
OrderDetailCollection Members


OrderDetailCollection.TotalLastProcessTaxAfterDocumentDiscountForeign Property

[image]

Pastel Evolution SDK
OrderDetailCollection..::..TotalLastProcessTaxAfterDocumentDiscountForeign Property
OrderDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalLastProcessTaxAfterDocumentDiscountForeign { get; }
Visual Basic
Public ReadOnly Property TotalLastProcessTaxAfterDocumentDiscountForeign As Double
    Get

Property Value

Type: Double

See Also

OrderDetailCollection Class
OrderDetailCollection Members


OrderDetailCollection.TotalLastProcessTaxForeign Property

[image]

Pastel Evolution SDK
OrderDetailCollection..::..TotalLastProcessTaxForeign Property
OrderDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalLastProcessTaxForeign { get; }
Visual Basic
Public ReadOnly Property TotalLastProcessTaxForeign As Double
    Get

Property Value

Type: Double

See Also

OrderDetailCollection Class
OrderDetailCollection Members


OrderDetailCollection.TotalOutstandingExcl Property

[image]

Pastel Evolution SDK
OrderDetailCollection..::..TotalOutstandingExcl Property
OrderDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalOutstandingExcl { get; }
Visual Basic
Public ReadOnly Property TotalOutstandingExcl As Double
    Get

Property Value

Type: Double

See Also

OrderDetailCollection Class
OrderDetailCollection Members


OrderDetailCollection.TotalOutstandingExclAfterDocumentDiscount Property

[image]

Pastel Evolution SDK
OrderDetailCollection..::..TotalOutstandingExclAfterDocumentDiscount Property
OrderDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalOutstandingExclAfterDocumentDiscount { get; }
Visual Basic
Public ReadOnly Property TotalOutstandingExclAfterDocumentDiscount As Double
    Get

Property Value

Type: Double

See Also

OrderDetailCollection Class
OrderDetailCollection Members


OrderDetailCollection.TotalOutstandingExclAfterDocumentDiscountForeign Property

[image]

Pastel Evolution SDK
OrderDetailCollection..::..TotalOutstandingExclAfterDocumentDiscountForeign Property
OrderDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalOutstandingExclAfterDocumentDiscountForeign { get; }
Visual Basic
Public ReadOnly Property TotalOutstandingExclAfterDocumentDiscountForeign As Double
    Get

Property Value

Type: Double

See Also

OrderDetailCollection Class
OrderDetailCollection Members


OrderDetailCollection.TotalOutstandingExclForeign Property

[image]

Pastel Evolution SDK
OrderDetailCollection..::..TotalOutstandingExclForeign Property
OrderDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalOutstandingExclForeign { get; }
Visual Basic
Public ReadOnly Property TotalOutstandingExclForeign As Double
    Get

Property Value

Type: Double

See Also

OrderDetailCollection Class
OrderDetailCollection Members


OrderDetailCollection.TotalOutstandingIncl Property

[image]

Pastel Evolution SDK
OrderDetailCollection..::..TotalOutstandingIncl Property
OrderDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalOutstandingIncl { get; }
Visual Basic
Public ReadOnly Property TotalOutstandingIncl As Double
    Get

Property Value

Type: Double

See Also

OrderDetailCollection Class
OrderDetailCollection Members


OrderDetailCollection.TotalOutstandingInclForeign Property

[image]

Pastel Evolution SDK
OrderDetailCollection..::..TotalOutstandingInclForeign Property
OrderDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalOutstandingInclForeign { get; }
Visual Basic
Public ReadOnly Property TotalOutstandingInclForeign As Double
    Get

Property Value

Type: Double

See Also

OrderDetailCollection Class
OrderDetailCollection Members


OrderDetailCollection.TotalOutstandingQuantity Property

[image]

Pastel Evolution SDK
OrderDetailCollection..::..TotalOutstandingQuantity Property
OrderDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalOutstandingQuantity { get; }
Visual Basic
Public ReadOnly Property TotalOutstandingQuantity As Double
    Get

Property Value

Type: Double

See Also

OrderDetailCollection Class
OrderDetailCollection Members


OrderDetailCollection.TotalOutstandingTax Property

[image]

Pastel Evolution SDK
OrderDetailCollection..::..TotalOutstandingTax Property
OrderDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalOutstandingTax { get; }
Visual Basic
Public ReadOnly Property TotalOutstandingTax As Double
    Get

Property Value

Type: Double

See Also

OrderDetailCollection Class
OrderDetailCollection Members


OrderDetailCollection.TotalOutstandingTaxAfterDocumentDiscount Property

[image]

Pastel Evolution SDK
OrderDetailCollection..::..TotalOutstandingTaxAfterDocumentDiscount Property
OrderDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalOutstandingTaxAfterDocumentDiscount { get; }
Visual Basic
Public ReadOnly Property TotalOutstandingTaxAfterDocumentDiscount As Double
    Get

Property Value

Type: Double

See Also

OrderDetailCollection Class
OrderDetailCollection Members


OrderDetailCollection.TotalOutstandingTaxAfterDocumentDiscountForeign Property

[image]

Pastel Evolution SDK
OrderDetailCollection..::..TotalOutstandingTaxAfterDocumentDiscountForeign Property
OrderDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalOutstandingTaxAfterDocumentDiscountForeign { get; }
Visual Basic
Public ReadOnly Property TotalOutstandingTaxAfterDocumentDiscountForeign As Double
    Get

Property Value

Type: Double

See Also

OrderDetailCollection Class
OrderDetailCollection Members


OrderDetailCollection.TotalOutstandingTaxForeign Property

[image]

Pastel Evolution SDK
OrderDetailCollection..::..TotalOutstandingTaxForeign Property
OrderDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalOutstandingTaxForeign { get; }
Visual Basic
Public ReadOnly Property TotalOutstandingTaxForeign As Double
    Get

Property Value

Type: Double

See Also

OrderDetailCollection Class
OrderDetailCollection Members


OrderDetailCollection.TotalQuantity Property

[image]

Pastel Evolution SDK
OrderDetailCollection..::..TotalQuantity Property
OrderDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalQuantity { get; }
Visual Basic
Public ReadOnly Property TotalQuantity As Double
    Get

Property Value

Type: Double

See Also

OrderDetailCollection Class
OrderDetailCollection Members


OrderDetailCollection.TotalSalesCost Property

[image]

Pastel Evolution SDK
OrderDetailCollection..::..TotalSalesCost Property
OrderDetailCollection Class See Also Send Feedback
Gets the total cost of sale; i.e. current unit cost * quantity

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalSalesCost { get; }
Visual Basic
Public ReadOnly Property TotalSalesCost As Double
    Get

Property Value

Type: Double

See Also

OrderDetailCollection Class
OrderDetailCollection Members


OrderDetailCollection.TotalTax Property

[image]

Pastel Evolution SDK
OrderDetailCollection..::..TotalTax Property
OrderDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalTax { get; }
Visual Basic
Public ReadOnly Property TotalTax As Double
    Get

Property Value

Type: Double

See Also

OrderDetailCollection Class
OrderDetailCollection Members


OrderDetailCollection.TotalTaxAfterDocumentDiscount Property

[image]

Pastel Evolution SDK
OrderDetailCollection..::..TotalTaxAfterDocumentDiscount Property
OrderDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalTaxAfterDocumentDiscount { get; }
Visual Basic
Public ReadOnly Property TotalTaxAfterDocumentDiscount As Double
    Get

Property Value

Type: Double

See Also

OrderDetailCollection Class
OrderDetailCollection Members


OrderDetailCollection.TotalTaxAfterDocumentDiscountForeign Property

[image]

Pastel Evolution SDK
OrderDetailCollection..::..TotalTaxAfterDocumentDiscountForeign Property
OrderDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalTaxAfterDocumentDiscountForeign { get; }
Visual Basic
Public ReadOnly Property TotalTaxAfterDocumentDiscountForeign As Double
    Get

Property Value

Type: Double

See Also

OrderDetailCollection Class
OrderDetailCollection Members


OrderDetailCollection.TotalTaxForeign Property

[image]

Pastel Evolution SDK
OrderDetailCollection..::..TotalTaxForeign Property
OrderDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalTaxForeign { get; }
Visual Basic
Public ReadOnly Property TotalTaxForeign As Double
    Get

Property Value

Type: Double

See Also

OrderDetailCollection Class
OrderDetailCollection Members


OrderDetailCollection.TotalToProcessExcl Property

[image]

Pastel Evolution SDK
OrderDetailCollection..::..TotalToProcessExcl Property
OrderDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalToProcessExcl { get; }
Visual Basic
Public ReadOnly Property TotalToProcessExcl As Double
    Get

Property Value

Type: Double

See Also

OrderDetailCollection Class
OrderDetailCollection Members


OrderDetailCollection.TotalToProcessExclAfterDocumentDiscount Property

[image]

Pastel Evolution SDK
OrderDetailCollection..::..TotalToProcessExclAfterDocumentDiscount Property
OrderDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalToProcessExclAfterDocumentDiscount { get; }
Visual Basic
Public ReadOnly Property TotalToProcessExclAfterDocumentDiscount As Double
    Get

Property Value

Type: Double

See Also

OrderDetailCollection Class
OrderDetailCollection Members


OrderDetailCollection.TotalToProcessExclForeign Property

[image]

Pastel Evolution SDK
OrderDetailCollection..::..TotalToProcessExclForeign Property
OrderDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalToProcessExclForeign { get; }
Visual Basic
Public ReadOnly Property TotalToProcessExclForeign As Double
    Get

Property Value

Type: Double

See Also

OrderDetailCollection Class
OrderDetailCollection Members


OrderDetailCollection.TotalToProcessExclForeignAfterDocumentDiscount Property

[image]

Pastel Evolution SDK
OrderDetailCollection..::..TotalToProcessExclForeignAfterDocumentDiscount Property
OrderDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalToProcessExclForeignAfterDocumentDiscount { get; }
Visual Basic
Public ReadOnly Property TotalToProcessExclForeignAfterDocumentDiscount As Double
    Get

Property Value

Type: Double

See Also

OrderDetailCollection Class
OrderDetailCollection Members


OrderDetailCollection.TotalToProcessIncl Property

[image]

Pastel Evolution SDK
OrderDetailCollection..::..TotalToProcessIncl Property
OrderDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalToProcessIncl { get; }
Visual Basic
Public ReadOnly Property TotalToProcessIncl As Double
    Get

Property Value

Type: Double

See Also

OrderDetailCollection Class
OrderDetailCollection Members


OrderDetailCollection.TotalToProcessInclAfterDocumentDiscount Property

[image]

Pastel Evolution SDK
OrderDetailCollection..::..TotalToProcessInclAfterDocumentDiscount Property
OrderDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalToProcessInclAfterDocumentDiscount { get; }
Visual Basic
Public ReadOnly Property TotalToProcessInclAfterDocumentDiscount As Double
    Get

Property Value

Type: Double

See Also

OrderDetailCollection Class
OrderDetailCollection Members


OrderDetailCollection.TotalToProcessInclAfterDocumentDiscountForeign Property

[image]

Pastel Evolution SDK
OrderDetailCollection..::..TotalToProcessInclAfterDocumentDiscountForeign Property
OrderDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalToProcessInclAfterDocumentDiscountForeign { get; }
Visual Basic
Public ReadOnly Property TotalToProcessInclAfterDocumentDiscountForeign As Double
    Get

Property Value

Type: Double

See Also

OrderDetailCollection Class
OrderDetailCollection Members


OrderDetailCollection.TotalToProcessInclForeign Property

[image]

Pastel Evolution SDK
OrderDetailCollection..::..TotalToProcessInclForeign Property
OrderDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalToProcessInclForeign { get; }
Visual Basic
Public ReadOnly Property TotalToProcessInclForeign As Double
    Get

Property Value

Type: Double

See Also

OrderDetailCollection Class
OrderDetailCollection Members


OrderDetailCollection.TotalToProcessTax Property

[image]

Pastel Evolution SDK
OrderDetailCollection..::..TotalToProcessTax Property
OrderDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalToProcessTax { get; }
Visual Basic
Public ReadOnly Property TotalToProcessTax As Double
    Get

Property Value

Type: Double

See Also

OrderDetailCollection Class
OrderDetailCollection Members


OrderDetailCollection.TotalToProcessTaxAfterDocumentDiscount Property

[image]

Pastel Evolution SDK
OrderDetailCollection..::..TotalToProcessTaxAfterDocumentDiscount Property
OrderDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalToProcessTaxAfterDocumentDiscount { get; }
Visual Basic
Public ReadOnly Property TotalToProcessTaxAfterDocumentDiscount As Double
    Get

Property Value

Type: Double

See Also

OrderDetailCollection Class
OrderDetailCollection Members


OrderDetailCollection.TotalToProcessTaxForeign Property

[image]

Pastel Evolution SDK
OrderDetailCollection..::..TotalToProcessTaxForeign Property
OrderDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalToProcessTaxForeign { get; }
Visual Basic
Public ReadOnly Property TotalToProcessTaxForeign As Double
    Get

Property Value

Type: Double

See Also

OrderDetailCollection Class
OrderDetailCollection Members


OrderDetailCollection.TotalToProcessTaxForeignAfterDocumentDiscount Property

[image]

Pastel Evolution SDK
OrderDetailCollection..::..TotalToProcessTaxForeignAfterDocumentDiscount Property
OrderDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double TotalToProcessTaxForeignAfterDocumentDiscount { get; }
Visual Basic
Public ReadOnly Property TotalToProcessTaxForeignAfterDocumentDiscount As Double
    Get

Property Value

Type: Double

See Also

OrderDetailCollection Class
OrderDetailCollection Members


OrderDetailCollection Events

[image] [image]

Pastel Evolution SDK
OrderDetailCollection Events
OrderDetailCollection Class See Also Send Feedback

The OrderDetailCollection type exposes the following members.

Events

 | Name | Description
Public event | CollectionChanged | Occurs when detail records are added or deleted.

See Also

OrderDetailCollection Class


OrderDetailCollection.CollectionChanged Event

[image]

Pastel Evolution SDK
OrderDetailCollection..::..CollectionChanged Event
OrderDetailCollection Class See Also Send Feedback
Occurs when detail records are added or deleted.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public event OrderDetailCollection..::..OrderDetailChangedEventHandler CollectionChanged
Visual Basic
Public Event CollectionChanged As OrderDetailCollection..::..OrderDetailChangedEventHandler

Value

Type: Pastel.Evolution..::..OrderDetailCollection..::..OrderDetailChangedEventHandler

See Also

OrderDetailCollection Class
OrderDetailCollection Members


OrderDetailCollection.OrderDetailChangeAction Enumeration

[image]

Pastel Evolution SDK
OrderDetailCollection..::..OrderDetailChangeAction Enumeration
OrderDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public enum OrderDetailChangeAction
Visual Basic
Public Enumeration OrderDetailChangeAction

Members

Member name | Value | Description
Added | 0 |
Deleted | 1 |

See Also

Pastel.Evolution Namespace


OrderDetailCollection.OrderDetailChangedEventHandler Delegate

[image]

Pastel Evolution SDK
OrderDetailCollection..::..OrderDetailChangedEventHandler Delegate
OrderDetailCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public delegate void OrderDetailChangedEventHandler(
    Object sender,
    OrderDetailCollection..::..OrderDetailCollectionChangedEventArgs e
)
Visual Basic
Public Delegate Sub OrderDetailChangedEventHandler (
    sender As Object,
    e As OrderDetailCollection..::..OrderDetailCollectionChangedEventArgs
)

Parameters

sender
Type: System..::..Object
e
Type: Pastel.Evolution..::..OrderDetailCollection..::..OrderDetailCollectionChangedEventArgs

See Also

Pastel.Evolution Namespace


OrderDetailCollection.OrderDetailCollectionChangedEventArgs Class

[image]

Pastel Evolution SDK
OrderDetailCollection..::..OrderDetailCollectionChangedEventArgs Class
OrderDetailCollection Class Members See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class OrderDetailCollectionChangedEventArgs : EventArgs
Visual Basic
Public Class OrderDetailCollectionChangedEventArgs
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Pastel.Evolution..::..OrderDetailCollection..::..OrderDetailCollectionChangedEventArgs

See Also

OrderDetailCollection..::..OrderDetailCollectionChangedEventArgs Members


OrderDetailCollection.OrderDetailCollectionChangedEventArgs Members

[image] [image]

Pastel Evolution SDK
OrderDetailCollection..::..OrderDetailCollectionChangedEventArgs Members
OrderDetailCollection..::..OrderDetailCollectionChangedEventArgs Class Constructors Methods Fields See Also Send Feedback

The OrderDetailCollection..::..OrderDetailCollectionChangedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | OrderDetailCollection..::..OrderDetailCollectionChangedEventArgs | Initializes a new instance of the OrderDetailCollection..::..OrderDetailCollectionChangedEventArgs class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | Action |
Public field | DetailRecord |

See Also

OrderDetailCollection..::..OrderDetailCollectionChangedEventArgs Class


OrderDetailCollection.OrderDetailCollectionChangedEventArgs Constructor

[image]

Pastel Evolution SDK
OrderDetailCollection..::..OrderDetailCollectionChangedEventArgs Constructor
OrderDetailCollection..::..OrderDetailCollectionChangedEventArgs Class See Also Send Feedback
Initializes a new instance of the OrderDetailCollection..::..OrderDetailCollectionChangedEventArgs class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public OrderDetailCollectionChangedEventArgs(
    OrderDetail detailRecord,
    OrderDetailCollection..::..OrderDetailChangeAction action
)
Visual Basic
Public Sub New (
    detailRecord As OrderDetail,
    action As OrderDetailCollection..::..OrderDetailChangeAction
)

Parameters

detailRecord
Type: Pastel.Evolution..::..OrderDetail
action
Type: Pastel.Evolution..::..OrderDetailCollection..::..OrderDetailChangeAction

See Also

OrderDetailCollection..::..OrderDetailCollectionChangedEventArgs Class
OrderDetailCollection..::..OrderDetailCollectionChangedEventArgs Members


OrderDetailCollection.OrderDetailCollectionChangedEventArgs Fields

[image] [image]

Pastel Evolution SDK
OrderDetailCollection..::..OrderDetailCollectionChangedEventArgs Fields
OrderDetailCollection..::..OrderDetailCollectionChangedEventArgs Class See Also Send Feedback

The OrderDetailCollection..::..OrderDetailCollectionChangedEventArgs type exposes the following members.

Fields

 | Name | Description
Public field | Action |
Public field | DetailRecord |

See Also

OrderDetailCollection..::..OrderDetailCollectionChangedEventArgs Class


OrderDetailCollection.OrderDetailCollectionChangedEventArgs.Action Field

[image]

Pastel Evolution SDK
OrderDetailCollection..::..OrderDetailCollectionChangedEventArgs..::..Action Field
OrderDetailCollection..::..OrderDetailCollectionChangedEventArgs Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public OrderDetailCollection..::..OrderDetailChangeAction Action
Visual Basic
Public Action As OrderDetailCollection..::..OrderDetailChangeAction

Field Value

Type: OrderDetailCollection..::..OrderDetailChangeAction

See Also

OrderDetailCollection..::..OrderDetailCollectionChangedEventArgs Class
OrderDetailCollection..::..OrderDetailCollectionChangedEventArgs Members


OrderDetailCollection.OrderDetailCollectionChangedEventArgs.DetailRecord Field

[image]

Pastel Evolution SDK
OrderDetailCollection..::..OrderDetailCollectionChangedEventArgs..::..DetailRecord Field
OrderDetailCollection..::..OrderDetailCollectionChangedEventArgs Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public OrderDetail DetailRecord
Visual Basic
Public DetailRecord As OrderDetail

Field Value

Type: OrderDetail

See Also

OrderDetailCollection..::..OrderDetailCollectionChangedEventArgs Class
OrderDetailCollection..::..OrderDetailCollectionChangedEventArgs Members


OrderDetailCollection.OrderDetailCollectionChangedEventArgs Methods

[image] [image]

Pastel Evolution SDK
OrderDetailCollection..::..OrderDetailCollectionChangedEventArgs Methods
OrderDetailCollection..::..OrderDetailCollectionChangedEventArgs Class See Also Send Feedback

The OrderDetailCollection..::..OrderDetailCollectionChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OrderDetailCollection..::..OrderDetailCollectionChangedEventArgs Class


OrderStatus Class

[image]

Pastel Evolution SDK
OrderStatus Class
Members See Also Send Feedback
Represents a user-definable inventory document status.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class OrderStatus : BranchedRecordBase
Visual Basic
Public Class OrderStatus
    Inherits BranchedRecordBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..OrderStatus

See Also

OrderStatus Members


OrderStatus Members

[image] [image]

Pastel Evolution SDK
OrderStatus Members
OrderStatus Class Constructors Methods Fields Properties See Also Send Feedback

The OrderStatus type exposes the following members.

Constructors

 | Name | Description
Public method | OrderStatus()()()() | Creates a new instance of an order status.
Public method | OrderStatus(Int32) | Creates a new instance of an order status.
Public method | OrderStatus(String) | Creates a new instance of an order status.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds a record's database ID.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | List | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Description | Gets or sets the record description.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)

See Also

OrderStatus Class


OrderStatus Constructor

[image] [image]

Pastel Evolution SDK
OrderStatus Constructor
OrderStatus Class See Also Send Feedback

Overload List

 | Name | Description
Public method | OrderStatus()()()() | Creates a new instance of an order status.
Public method | OrderStatus(Int32) | Creates a new instance of an order status.
Public method | OrderStatus(String) | Creates a new instance of an order status.

See Also

OrderStatus Class
OrderStatus Members


OrderStatus Constructor

[image]

Pastel Evolution SDK
OrderStatus Constructor
OrderStatus Class See Also Send Feedback
Creates a new instance of an order status.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public OrderStatus()
Visual Basic
Public Sub New

See Also

OrderStatus Class
OrderStatus Members
OrderStatus Overload


OrderStatus Constructor (Int32)

[image]

Pastel Evolution SDK
OrderStatus Constructor (Int32)
OrderStatus Class See Also Send Feedback
Creates a new instance of an order status.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public OrderStatus(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32
Specifies the id of the existing record.

See Also

OrderStatus Class
OrderStatus Members
OrderStatus Overload


OrderStatus Constructor (String)

[image]

Pastel Evolution SDK
OrderStatus Constructor (String)
OrderStatus Class See Also Send Feedback
Creates a new instance of an order status.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public OrderStatus(
    string code
)
Visual Basic
Public Sub New (
    code As String
)

Parameters

code
Type: System..::..String
Specifies the code of the existing record.

See Also

OrderStatus Class
OrderStatus Members
OrderStatus Overload


OrderStatus Fields

[image] [image]

Pastel Evolution SDK
OrderStatus Fields
OrderStatus Class See Also Send Feedback

The OrderStatus type exposes the following members.

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

OrderStatus Class


OrderStatus Methods

[image] [image]

Pastel Evolution SDK
OrderStatus Methods
OrderStatus Class See Also Send Feedback

The OrderStatus type exposes the following members.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds a record's database ID.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | List | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

OrderStatus Class


OrderStatus.Find Method

[image]

Pastel Evolution SDK
OrderStatus..::..Find Method
OrderStatus Class See Also Send Feedback
Finds a record's database ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.

Return Value

Type: Int32
The ID of the first record found; -1 if not record was found.

See Also

OrderStatus Class
OrderStatus Members


OrderStatus.List Method

[image]

Pastel Evolution SDK
OrderStatus..::..List Method
OrderStatus Class See Also Send Feedback
Gets a list of database records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DataTable List(
    string criteria
)
Visual Basic
Public Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.

Return Value

Type: DataTable
Table containing selected records.

See Also

OrderStatus Class
OrderStatus Members


OrderStatus.OnDelete Method

[image]

Pastel Evolution SDK
OrderStatus..::..OnDelete Method
OrderStatus Class See Also Send Feedback
Removes the record from the database, provided it is not referenced by other records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

Exceptions

Exception | Condition
IntegrityViolationException |

See Also

OrderStatus Class
OrderStatus Members


OrderStatus.OnSave Method

[image]

Pastel Evolution SDK
OrderStatus..::..OnSave Method
OrderStatus Class See Also Send Feedback
Persists the record to the database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

OrderStatus Class
OrderStatus Members


OrderStatus Properties

[image] [image]

Pastel Evolution SDK
OrderStatus Properties
OrderStatus Class See Also Send Feedback

The OrderStatus type exposes the following members.

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Description | Gets or sets the record description.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)

See Also

OrderStatus Class


OrderStatus.Description Property

[image]

Pastel Evolution SDK
OrderStatus..::..Description Property
OrderStatus Class See Also Send Feedback
Gets or sets the record description.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set

Property Value

Type: String

See Also

OrderStatus Class
OrderStatus Members


OrderStatus.ID Property

[image]

Pastel Evolution SDK
OrderStatus..::..ID Property
OrderStatus Class See Also Send Feedback
Gets the internal record ID (0 for new, unsaved records).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

See Also

OrderStatus Class
OrderStatus Members


OrderStatus.LongID Property

[image]

Pastel Evolution SDK
OrderStatus..::..LongID Property
OrderStatus Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

OrderStatus Class
OrderStatus Members


PackCode Class

[image]

Pastel Evolution SDK
PackCode Class
Members See Also Send Feedback
Represents an inventory item pack code.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class PackCode : BranchedRecordBase
Visual Basic
Public Class PackCode
    Inherits BranchedRecordBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..PackCode

See Also

PackCode Members


PackCode Members

[image] [image]

Pastel Evolution SDK
PackCode Members
PackCode Class Constructors Methods Fields Properties See Also Send Feedback

The PackCode type exposes the following members.

Constructors

 | Name | Description
Public method | PackCode()()()() | Creates a new instance of a pack code.
Public method | PackCode(Int32) | Creates a new instance of a pack code.
Public method | PackCode(String) | Creates a new instance of a pack code.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds a record's database ID.
 | FindByCode | Attempts to find a PackCode by its code and returns its ID.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | List | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Code | Gets or sets the pack code's code.
Public property | Description | Gets or sets the pack code's description.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | Size | Gets or sets the pack code's size.

See Also

PackCode Class


PackCode Constructor

[image] [image]

Pastel Evolution SDK
PackCode Constructor
PackCode Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PackCode()()()() | Creates a new instance of a pack code.
Public method | PackCode(Int32) | Creates a new instance of a pack code.
Public method | PackCode(String) | Creates a new instance of a pack code.

See Also

PackCode Class
PackCode Members


PackCode Constructor

[image]

Pastel Evolution SDK
PackCode Constructor
PackCode Class See Also Send Feedback
Creates a new instance of a pack code.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public PackCode()
Visual Basic
Public Sub New

See Also

PackCode Class
PackCode Members
PackCode Overload


PackCode Constructor (Int32)

[image]

Pastel Evolution SDK
PackCode Constructor (Int32)
PackCode Class See Also Send Feedback
Creates a new instance of a pack code.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public PackCode(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32
Specifies the id of the existing record.

See Also

PackCode Class
PackCode Members
PackCode Overload


PackCode Constructor (String)

[image]

Pastel Evolution SDK
PackCode Constructor (String)
PackCode Class See Also Send Feedback
Creates a new instance of a pack code.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public PackCode(
    string code
)
Visual Basic
Public Sub New (
    code As String
)

Parameters

code
Type: System..::..String
Specifies the code of the existing record.

See Also

PackCode Class
PackCode Members
PackCode Overload


PackCode Fields

[image] [image]

Pastel Evolution SDK
PackCode Fields
PackCode Class See Also Send Feedback

The PackCode type exposes the following members.

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

PackCode Class


PackCode Methods

[image] [image]

Pastel Evolution SDK
PackCode Methods
PackCode Class See Also Send Feedback

The PackCode type exposes the following members.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds a record's database ID.
 | FindByCode | Attempts to find a PackCode by its code and returns its ID.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | List | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

PackCode Class


PackCode.Find Method

[image]

Pastel Evolution SDK
PackCode..::..Find Method
PackCode Class See Also Send Feedback
Finds a record's database ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.

Return Value

Type: Int32
The ID of the first record found; -1 if not record was found.

See Also

PackCode Class
PackCode Members


PackCode.FindByCode Method

[image]

Pastel Evolution SDK
PackCode..::..FindByCode Method
PackCode Class See Also Send Feedback
Attempts to find a PackCode by its code and returns its ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int FindByCode(
    string code
)
Visual Basic
Public Shared Function FindByCode (
    code As String
) As Integer

Parameters

code
Type: System..::..String
The code used to lookup the packcode.

Return Value

Type: Int32
-1 if no record was found, else the id of the first packcode matching the criteria supplied.

See Also

PackCode Class
PackCode Members
Pastel.Evolution Namespace
PackCode..::..Find(String)


PackCode.List Method

[image]

Pastel Evolution SDK
PackCode..::..List Method
PackCode Class See Also Send Feedback
Gets a list of database records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DataTable List(
    string criteria
)
Visual Basic
Public Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.

Return Value

Type: DataTable
Table containing selected records.

See Also

PackCode Class
PackCode Members


PackCode.OnDelete Method

[image]

Pastel Evolution SDK
PackCode..::..OnDelete Method
PackCode Class See Also Send Feedback
Removes the record from the database, provided it is not referenced by other records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

See Also

PackCode Class
PackCode Members


PackCode.OnSave Method

[image]

Pastel Evolution SDK
PackCode..::..OnSave Method
PackCode Class See Also Send Feedback
Persists the record to the database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

PackCode Class
PackCode Members


PackCode Properties

[image] [image]

Pastel Evolution SDK
PackCode Properties
PackCode Class See Also Send Feedback

The PackCode type exposes the following members.

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Code | Gets or sets the pack code's code.
Public property | Description | Gets or sets the pack code's description.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | Size | Gets or sets the pack code's size.

See Also

PackCode Class


PackCode.Code Property

[image]

Pastel Evolution SDK
PackCode..::..Code Property
PackCode Class See Also Send Feedback
Gets or sets the pack code's code.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Code { get; set; }
Visual Basic
Public Property Code As String
    Get
    Set

Property Value

Type: String

See Also

PackCode Class
PackCode Members


PackCode.Description Property

[image]

Pastel Evolution SDK
PackCode..::..Description Property
PackCode Class See Also Send Feedback
Gets or sets the pack code's description.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set

Property Value

Type: String

See Also

PackCode Class
PackCode Members


PackCode.ID Property

[image]

Pastel Evolution SDK
PackCode..::..ID Property
PackCode Class See Also Send Feedback
Gets the internal record ID (0 for new, unsaved records).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

Remarks

Once saved, the ID will reflect the record's internal database identifier.

See Also

PackCode Class
PackCode Members


PackCode.LongID Property

[image]

Pastel Evolution SDK
PackCode..::..LongID Property
PackCode Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

PackCode Class
PackCode Members


PackCode.Size Property

[image]

Pastel Evolution SDK
PackCode..::..Size Property
PackCode Class See Also Send Feedback
Gets or sets the pack code's size.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double Size { get; set; }
Visual Basic
Public Property Size As Double
    Get
    Set

Property Value

Type: Double

See Also

PackCode Class
PackCode Members


PercentageOfCompletedContractPostingMethodGLContext Class

[image]

Pastel Evolution SDK
PercentageOfCompletedContractPostingMethodGLContext Class
Members See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class PercentageOfCompletedContractPostingMethodGLContext : TransactionTypePostingMethodGLContextBase
Visual Basic
Public Class PercentageOfCompletedContractPostingMethodGLContext
    Inherits TransactionTypePostingMethodGLContextBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..TransactionTypePostingMethodGLContextBase
Pastel.Evolution..::..PercentageOfCompletedContractPostingMethodGLContext

See Also

PercentageOfCompletedContractPostingMethodGLContext Members


PercentageOfCompletedContractPostingMethodGLContext Members

[image] [image]

Pastel Evolution SDK
PercentageOfCompletedContractPostingMethodGLContext Members
PercentageOfCompletedContractPostingMethodGLContext Class Methods Properties See Also Send Feedback

The PercentageOfCompletedContractPostingMethodGLContext type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | COSAccount | Gets or sets the Transaction Code's COS GL Account. (Overrides TransactionTypePostingMethodGLContextBase..::..COSAccount.)
Public property | COSAccountID | (Overrides TransactionTypePostingMethodGLContextBase..::..COSAccountID.)
Public property | CustomerControlAccount | Gets or sets the Transaction Code's Customer Control GL Account. (Overrides TransactionTypePostingMethodGLContextBase..::..CustomerControlAccount.)
Public property | CustomerControlAccountID | (Overrides TransactionTypePostingMethodGLContextBase..::..CustomerControlAccountID.)
Public property | RecoveryAccount | Gets or sets the Transaction Code's Recovery GL Account. (Overrides TransactionTypePostingMethodGLContextBase..::..RecoveryAccount.)
Public property | RecoveryAccountID | (Overrides TransactionTypePostingMethodGLContextBase..::..RecoveryAccountID.)
Public property | SalesAccount | Gets or sets the Transaction Code's Sales GL Account. (Overrides TransactionTypePostingMethodGLContextBase..::..SalesAccount.)
Public property | SalesAccountID | (Overrides TransactionTypePostingMethodGLContextBase..::..SalesAccountID.)
Public property | StockAccount | Gets or sets the Transaction Code's Stock GL Account. (Overrides TransactionTypePostingMethodGLContextBase..::..StockAccount.)
Public property | StockAccountID | (Overrides TransactionTypePostingMethodGLContextBase..::..StockAccountID.)
Public property | SupplierControlAccount | Gets or sets the Transaction Code's Supplier Control GL Account. (Overrides TransactionTypePostingMethodGLContextBase..::..SupplierControlAccount.)
Public property | SupplierControlAccountID | (Overrides TransactionTypePostingMethodGLContextBase..::..SupplierControlAccountID.)
Public property | TaxAccount | Gets or sets the Transaction Code's Tax GL Account. (Overrides TransactionTypePostingMethodGLContextBase..::..TaxAccount.)
Public property | TaxAccountID | (Overrides TransactionTypePostingMethodGLContextBase..::..TaxAccountID.)
Public property | WIPAccount | Gets or sets the Transaction Code's WIP GL Account. (Overrides TransactionTypePostingMethodGLContextBase..::..WIPAccount.)
Public property | WIPAccountID | (Overrides TransactionTypePostingMethodGLContextBase..::..WIPAccountID.)

See Also

PercentageOfCompletedContractPostingMethodGLContext Class


PercentageOfCompletedContractPostingMethodGLContext Methods

[image] [image]

Pastel Evolution SDK
PercentageOfCompletedContractPostingMethodGLContext Methods
PercentageOfCompletedContractPostingMethodGLContext Class See Also Send Feedback

The PercentageOfCompletedContractPostingMethodGLContext type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PercentageOfCompletedContractPostingMethodGLContext Class


PercentageOfCompletedContractPostingMethodGLContext Properties

[image] [image]

Pastel Evolution SDK
PercentageOfCompletedContractPostingMethodGLContext Properties
PercentageOfCompletedContractPostingMethodGLContext Class See Also Send Feedback

The PercentageOfCompletedContractPostingMethodGLContext type exposes the following members.

Properties

 | Name | Description
Public property | COSAccount | Gets or sets the Transaction Code's COS GL Account. (Overrides TransactionTypePostingMethodGLContextBase..::..COSAccount.)
Public property | COSAccountID | (Overrides TransactionTypePostingMethodGLContextBase..::..COSAccountID.)
Public property | CustomerControlAccount | Gets or sets the Transaction Code's Customer Control GL Account. (Overrides TransactionTypePostingMethodGLContextBase..::..CustomerControlAccount.)
Public property | CustomerControlAccountID | (Overrides TransactionTypePostingMethodGLContextBase..::..CustomerControlAccountID.)
Public property | RecoveryAccount | Gets or sets the Transaction Code's Recovery GL Account. (Overrides TransactionTypePostingMethodGLContextBase..::..RecoveryAccount.)
Public property | RecoveryAccountID | (Overrides TransactionTypePostingMethodGLContextBase..::..RecoveryAccountID.)
Public property | SalesAccount | Gets or sets the Transaction Code's Sales GL Account. (Overrides TransactionTypePostingMethodGLContextBase..::..SalesAccount.)
Public property | SalesAccountID | (Overrides TransactionTypePostingMethodGLContextBase..::..SalesAccountID.)
Public property | StockAccount | Gets or sets the Transaction Code's Stock GL Account. (Overrides TransactionTypePostingMethodGLContextBase..::..StockAccount.)
Public property | StockAccountID | (Overrides TransactionTypePostingMethodGLContextBase..::..StockAccountID.)
Public property | SupplierControlAccount | Gets or sets the Transaction Code's Supplier Control GL Account. (Overrides TransactionTypePostingMethodGLContextBase..::..SupplierControlAccount.)
Public property | SupplierControlAccountID | (Overrides TransactionTypePostingMethodGLContextBase..::..SupplierControlAccountID.)
Public property | TaxAccount | Gets or sets the Transaction Code's Tax GL Account. (Overrides TransactionTypePostingMethodGLContextBase..::..TaxAccount.)
Public property | TaxAccountID | (Overrides TransactionTypePostingMethodGLContextBase..::..TaxAccountID.)
Public property | WIPAccount | Gets or sets the Transaction Code's WIP GL Account. (Overrides TransactionTypePostingMethodGLContextBase..::..WIPAccount.)
Public property | WIPAccountID | (Overrides TransactionTypePostingMethodGLContextBase..::..WIPAccountID.)

See Also

PercentageOfCompletedContractPostingMethodGLContext Class


PercentageOfCompletedContractPostingMethodGLContext.COSAccount Property

[image]

Pastel Evolution SDK
PercentageOfCompletedContractPostingMethodGLContext..::..COSAccount Property
PercentageOfCompletedContractPostingMethodGLContext Class See Also Send Feedback
Gets or sets the Transaction Code's COS GL Account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override GLAccount COSAccount { get; set; }
Visual Basic
Public Overrides Property COSAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

See Also

PercentageOfCompletedContractPostingMethodGLContext Class
PercentageOfCompletedContractPostingMethodGLContext Members


PercentageOfCompletedContractPostingMethodGLContext.COSAccountID Property

[image]

Pastel Evolution SDK
PercentageOfCompletedContractPostingMethodGLContext..::..COSAccountID Property
PercentageOfCompletedContractPostingMethodGLContext Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int COSAccountID { get; set; }
Visual Basic
Public Overrides Property COSAccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

PercentageOfCompletedContractPostingMethodGLContext Class
PercentageOfCompletedContractPostingMethodGLContext Members


PercentageOfCompletedContractPostingMethodGLContext.CustomerControlAccount Property

[image]

Pastel Evolution SDK
PercentageOfCompletedContractPostingMethodGLContext..::..CustomerControlAccount Property
PercentageOfCompletedContractPostingMethodGLContext Class See Also Send Feedback
Gets or sets the Transaction Code's Customer Control GL Account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override GLAccount CustomerControlAccount { get; set; }
Visual Basic
Public Overrides Property CustomerControlAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

See Also

PercentageOfCompletedContractPostingMethodGLContext Class
PercentageOfCompletedContractPostingMethodGLContext Members


PercentageOfCompletedContractPostingMethodGLContext.CustomerControlAccountID Property

[image]

Pastel Evolution SDK
PercentageOfCompletedContractPostingMethodGLContext..::..CustomerControlAccountID Property
PercentageOfCompletedContractPostingMethodGLContext Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int CustomerControlAccountID { get; set; }
Visual Basic
Public Overrides Property CustomerControlAccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

PercentageOfCompletedContractPostingMethodGLContext Class
PercentageOfCompletedContractPostingMethodGLContext Members


PercentageOfCompletedContractPostingMethodGLContext.RecoveryAccount Property

[image]

Pastel Evolution SDK
PercentageOfCompletedContractPostingMethodGLContext..::..RecoveryAccount Property
PercentageOfCompletedContractPostingMethodGLContext Class See Also Send Feedback
Gets or sets the Transaction Code's Recovery GL Account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override GLAccount RecoveryAccount { get; set; }
Visual Basic
Public Overrides Property RecoveryAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

See Also

PercentageOfCompletedContractPostingMethodGLContext Class
PercentageOfCompletedContractPostingMethodGLContext Members


PercentageOfCompletedContractPostingMethodGLContext.RecoveryAccountID Property

[image]

Pastel Evolution SDK
PercentageOfCompletedContractPostingMethodGLContext..::..RecoveryAccountID Property
PercentageOfCompletedContractPostingMethodGLContext Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int RecoveryAccountID { get; set; }
Visual Basic
Public Overrides Property RecoveryAccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

PercentageOfCompletedContractPostingMethodGLContext Class
PercentageOfCompletedContractPostingMethodGLContext Members


PercentageOfCompletedContractPostingMethodGLContext.SalesAccount Property

[image]

Pastel Evolution SDK
PercentageOfCompletedContractPostingMethodGLContext..::..SalesAccount Property
PercentageOfCompletedContractPostingMethodGLContext Class See Also Send Feedback
Gets or sets the Transaction Code's Sales GL Account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override GLAccount SalesAccount { get; set; }
Visual Basic
Public Overrides Property SalesAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

See Also

PercentageOfCompletedContractPostingMethodGLContext Class
PercentageOfCompletedContractPostingMethodGLContext Members


PercentageOfCompletedContractPostingMethodGLContext.SalesAccountID Property

[image]

Pastel Evolution SDK
PercentageOfCompletedContractPostingMethodGLContext..::..SalesAccountID Property
PercentageOfCompletedContractPostingMethodGLContext Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int SalesAccountID { get; set; }
Visual Basic
Public Overrides Property SalesAccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

PercentageOfCompletedContractPostingMethodGLContext Class
PercentageOfCompletedContractPostingMethodGLContext Members


PercentageOfCompletedContractPostingMethodGLContext.StockAccount Property

[image]

Pastel Evolution SDK
PercentageOfCompletedContractPostingMethodGLContext..::..StockAccount Property
PercentageOfCompletedContractPostingMethodGLContext Class See Also Send Feedback
Gets or sets the Transaction Code's Stock GL Account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override GLAccount StockAccount { get; set; }
Visual Basic
Public Overrides Property StockAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

See Also

PercentageOfCompletedContractPostingMethodGLContext Class
PercentageOfCompletedContractPostingMethodGLContext Members


PercentageOfCompletedContractPostingMethodGLContext.StockAccountID Property

[image]

Pastel Evolution SDK
PercentageOfCompletedContractPostingMethodGLContext..::..StockAccountID Property
PercentageOfCompletedContractPostingMethodGLContext Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int StockAccountID { get; set; }
Visual Basic
Public Overrides Property StockAccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

PercentageOfCompletedContractPostingMethodGLContext Class
PercentageOfCompletedContractPostingMethodGLContext Members


PercentageOfCompletedContractPostingMethodGLContext.SupplierControlAccount Property

[image]

Pastel Evolution SDK
PercentageOfCompletedContractPostingMethodGLContext..::..SupplierControlAccount Property
PercentageOfCompletedContractPostingMethodGLContext Class See Also Send Feedback
Gets or sets the Transaction Code's Supplier Control GL Account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override GLAccount SupplierControlAccount { get; set; }
Visual Basic
Public Overrides Property SupplierControlAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

See Also

PercentageOfCompletedContractPostingMethodGLContext Class
PercentageOfCompletedContractPostingMethodGLContext Members


PercentageOfCompletedContractPostingMethodGLContext.SupplierControlAccountID Property

[image]

Pastel Evolution SDK
PercentageOfCompletedContractPostingMethodGLContext..::..SupplierControlAccountID Property
PercentageOfCompletedContractPostingMethodGLContext Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int SupplierControlAccountID { get; set; }
Visual Basic
Public Overrides Property SupplierControlAccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

PercentageOfCompletedContractPostingMethodGLContext Class
PercentageOfCompletedContractPostingMethodGLContext Members


PercentageOfCompletedContractPostingMethodGLContext.TaxAccount Property

[image]

Pastel Evolution SDK
PercentageOfCompletedContractPostingMethodGLContext..::..TaxAccount Property
PercentageOfCompletedContractPostingMethodGLContext Class See Also Send Feedback
Gets or sets the Transaction Code's Tax GL Account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override GLAccount TaxAccount { get; set; }
Visual Basic
Public Overrides Property TaxAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

See Also

PercentageOfCompletedContractPostingMethodGLContext Class
PercentageOfCompletedContractPostingMethodGLContext Members


PercentageOfCompletedContractPostingMethodGLContext.TaxAccountID Property

[image]

Pastel Evolution SDK
PercentageOfCompletedContractPostingMethodGLContext..::..TaxAccountID Property
PercentageOfCompletedContractPostingMethodGLContext Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int TaxAccountID { get; set; }
Visual Basic
Public Overrides Property TaxAccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

PercentageOfCompletedContractPostingMethodGLContext Class
PercentageOfCompletedContractPostingMethodGLContext Members


PercentageOfCompletedContractPostingMethodGLContext.WIPAccount Property

[image]

Pastel Evolution SDK
PercentageOfCompletedContractPostingMethodGLContext..::..WIPAccount Property
PercentageOfCompletedContractPostingMethodGLContext Class See Also Send Feedback
Gets or sets the Transaction Code's WIP GL Account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override GLAccount WIPAccount { get; set; }
Visual Basic
Public Overrides Property WIPAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

See Also

PercentageOfCompletedContractPostingMethodGLContext Class
PercentageOfCompletedContractPostingMethodGLContext Members


PercentageOfCompletedContractPostingMethodGLContext.WIPAccountID Property

[image]

Pastel Evolution SDK
PercentageOfCompletedContractPostingMethodGLContext..::..WIPAccountID Property
PercentageOfCompletedContractPostingMethodGLContext Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int WIPAccountID { get; set; }
Visual Basic
Public Overrides Property WIPAccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

PercentageOfCompletedContractPostingMethodGLContext Class
PercentageOfCompletedContractPostingMethodGLContext Members


Person Class

[image]

Pastel Evolution SDK
Person Class
Members See Also Send Feedback
Represents a person record.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class Person : BranchedRecordBase
Visual Basic
Public Class Person
    Inherits BranchedRecordBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..Person

See Also

Person Members


Person Members

[image] [image]

Pastel Evolution SDK
Person Members
Person Class Constructors Methods Fields Properties See Also Send Feedback

The Person type exposes the following members.

Constructors

 | Name | Description
Public method | Person()()()() | Creates a new instance of a person.
Public method | Person(Int32) | Creates a new instance of a person.

Methods

 | Name | Description
Public method | _CreateLink | Temporary method for linking a person to either a customer, supplier, or prospective customer record. This will most likely become obsolete in future.
 | _ListCurrentBranch |
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find(String) | Finds a record's database ID.
 | Find(String, array<Object>[]()[][]) | Finds a record's database ID.
Public method | GenerateFullName |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List | Returns a System.Data.DataTable object containing the database records from the Client table matching the supplied criteria.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | Address |
Public property | BirthDate |
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Comments | Gets or sets comments for this person.
Public property | Department |
Public property | DepartmentID |
Public property | Description |
Public property | Designation |
Public property | DesignationID |
Public property | EmailAddress | Gets or sets the person's email address.
Public property | Fax |
Public property | FirstName | Gets or sets the person's first name.
Public property | FullName | Gets or sets the person's full name. (a.k.a. display name)
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | Initials |
Public property | LastName | Gets or sets the person's last name.
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | PostalAddress |
Public property | TelHome |
Public property | TelMobile |
Public property | TelWork |
Public property | Title |
Public property | UserFields |
Public property | WebPage |

See Also

Person Class


Person Constructor

[image] [image]

Pastel Evolution SDK
Person Constructor
Person Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Person()()()() | Creates a new instance of a person.
Public method | Person(Int32) | Creates a new instance of a person.

See Also

Person Class
Person Members


Person Constructor

[image]

Pastel Evolution SDK
Person Constructor
Person Class See Also Send Feedback
Creates a new instance of a person.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Person()
Visual Basic
Public Sub New

See Also

Person Class
Person Members
Person Overload


Person Constructor (Int32)

[image]

Pastel Evolution SDK
Person Constructor (Int32)
Person Class See Also Send Feedback
Creates a new instance of a person.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Person(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32
Specifies the id of the existing record.

See Also

Person Class
Person Members
Person Overload


Person Fields

[image] [image]

Pastel Evolution SDK
Person Fields
Person Class See Also Send Feedback

The Person type exposes the following members.

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

Person Class


Person Methods

[image] [image]

Pastel Evolution SDK
Person Methods
Person Class See Also Send Feedback

The Person type exposes the following members.

Methods

 | Name | Description
Public method | _CreateLink | Temporary method for linking a person to either a customer, supplier, or prospective customer record. This will most likely become obsolete in future.
 | _ListCurrentBranch |
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find(String) | Finds a record's database ID.
 | Find(String, array<Object>[]()[][]) | Finds a record's database ID.
Public method | GenerateFullName |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List | Returns a System.Data.DataTable object containing the database records from the Client table matching the supplied criteria.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

Person Class


Person._CreateLink Method

[image]

Pastel Evolution SDK
Person..::.._CreateLink Method
Person Class See Also Send Feedback
Temporary method for linking a person to either a customer, supplier, or prospective customer record. This will most likely become obsolete in future.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void _CreateLink(
    BranchedRecordBase record
)
Visual Basic
Public Sub _CreateLink (
    record As BranchedRecordBase
)

Parameters

record
Type: Pastel.Evolution..::..BranchedRecordBase

See Also

Person Class
Person Members


Person._ListCurrentBranch Method

[image]

Pastel Evolution SDK
Person..::.._ListCurrentBranch Method
Person Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable _ListCurrentBranch(
    string criteria
)
Visual Basic
Public Shared Function _ListCurrentBranch (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String

Return Value

Type: DataTable

See Also

Person Class
Person Members


Person.Find Method

[image] [image]

Pastel Evolution SDK
Person..::..Find Method
Person Class See Also Send Feedback

Overload List

Name | Description
Find(String) | Finds a record's database ID.
Find(String, array<Object>[]()[][]) | Finds a record's database ID.

See Also

Person Class
Person Members


Person.Find Method (String)

[image]

Pastel Evolution SDK
Person..::..Find Method (String)
Person Class See Also Send Feedback
Finds a record's database ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.

Return Value

Type: Int32
The ID of the first record found; -1 if not record was found.

See Also

Person Class
Person Members
Find Overload


Person.Find Method (String, Object[])

[image]

Pastel Evolution SDK
Person..::..Find Method (String, array<Object>[]()[][])
Person Class See Also Send Feedback
Finds a record's database ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria,
    Object[] args
)
Visual Basic
Public Shared Function Find (
    criteria As String,
    args As Object()
) As Integer

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause containing zero or more format items.
args
Type: array< System..::..Object >[]()[][]
The arguments to pass to the String.Format function for replacing parameters in the criteria string.

Return Value

Type: Int32
The ID of the first record found; -1 if not record was found.

See Also

Person Class
Person Members
Find Overload


Person.GenerateFullName Method

[image]

Pastel Evolution SDK
Person..::..GenerateFullName Method
Person Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void GenerateFullName()
Visual Basic
Public Sub GenerateFullName

See Also

Person Class
Person Members


Person.List Method

[image]

Pastel Evolution SDK
Person..::..List Method
Person Class See Also Send Feedback
Returns a System.Data.DataTable object containing the database records from the Client table matching the supplied criteria.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria
)
Visual Basic
Public Shared Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String
The SQL criteria used to locate the record, e.g. Account like '1___'

Return Value

Type: DataTable
A System.Data.DataTable object containing matching records.

Remarks

The criteria is passed to an SQL query so use the appropriate syntax. Remember to include the single quotes around string literals and append additional criteria with and.

See Also

Person Class
Person Members


Person.OnDelete Method

[image]

Pastel Evolution SDK
Person..::..OnDelete Method
Person Class See Also Send Feedback
Removes the record from the database, provided it is not referenced by other records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

Exceptions

Exception | Condition
IntegrityViolationException |

See Also

Person Class
Person Members


Person.OnSave Method

[image]

Pastel Evolution SDK
Person..::..OnSave Method
Person Class See Also Send Feedback
Persists the record to the database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

Person Class
Person Members


Person Properties

[image] [image]

Pastel Evolution SDK
Person Properties
Person Class See Also Send Feedback

The Person type exposes the following members.

Properties

 | Name | Description
Public property | Address |
Public property | BirthDate |
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Comments | Gets or sets comments for this person.
Public property | Department |
Public property | DepartmentID |
Public property | Description |
Public property | Designation |
Public property | DesignationID |
Public property | EmailAddress | Gets or sets the person's email address.
Public property | Fax |
Public property | FirstName | Gets or sets the person's first name.
Public property | FullName | Gets or sets the person's full name. (a.k.a. display name)
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | Initials |
Public property | LastName | Gets or sets the person's last name.
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | PostalAddress |
Public property | TelHome |
Public property | TelMobile |
Public property | TelWork |
Public property | Title |
Public property | UserFields |
Public property | WebPage |

See Also

Person Class


Person.Address Property

[image]

Pastel Evolution SDK
Person..::..Address Property
Person Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Address Address { get; set; }
Visual Basic
Public Property Address As Address
    Get
    Set

Property Value

Type: Address

See Also

Person Class
Person Members


Person.BirthDate Property

[image]

Pastel Evolution SDK
Person..::..BirthDate Property
Person Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DateTime BirthDate { get; set; }
Visual Basic
Public Property BirthDate As DateTime
    Get
    Set

Property Value

Type: DateTime

See Also

Person Class
Person Members


Person.Comments Property

[image]

Pastel Evolution SDK
Person..::..Comments Property
Person Class See Also Send Feedback
Gets or sets comments for this person.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Comments { get; set; }
Visual Basic
Public Property Comments As String
    Get
    Set

Property Value

Type: String

See Also

Person Class
Person Members


Person.Department Property

[image]

Pastel Evolution SDK
Person..::..Department Property
Person Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Department Department { get; set; }
Visual Basic
Public Property Department As Department
    Get
    Set

Property Value

Type: Department

See Also

Person Class
Person Members


Person.DepartmentID Property

[image]

Pastel Evolution SDK
Person..::..DepartmentID Property
Person Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int DepartmentID { get; set; }
Visual Basic
Public Property DepartmentID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

Person Class
Person Members


Person.Description Property

[image]

Pastel Evolution SDK
Person..::..Description Property
Person Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set

Property Value

Type: String

See Also

Person Class
Person Members


Person.Designation Property

[image]

Pastel Evolution SDK
Person..::..Designation Property
Person Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Designation Designation { get; set; }
Visual Basic
Public Property Designation As Designation
    Get
    Set

Property Value

Type: Designation

See Also

Person Class
Person Members


Person.DesignationID Property

[image]

Pastel Evolution SDK
Person..::..DesignationID Property
Person Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int DesignationID { get; set; }
Visual Basic
Public Property DesignationID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

Person Class
Person Members


Person.EmailAddress Property

[image]

Pastel Evolution SDK
Person..::..EmailAddress Property
Person Class See Also Send Feedback
Gets or sets the person's email address.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string EmailAddress { get; set; }
Visual Basic
Public Property EmailAddress As String
    Get
    Set

Property Value

Type: String

See Also

Person Class
Person Members


Person.Fax Property

[image]

Pastel Evolution SDK
Person..::..Fax Property
Person Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Fax { get; set; }
Visual Basic
Public Property Fax As String
    Get
    Set

Property Value

Type: String

See Also

Person Class
Person Members


Person.FirstName Property

[image]

Pastel Evolution SDK
Person..::..FirstName Property
Person Class See Also Send Feedback
Gets or sets the person's first name.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string FirstName { get; set; }
Visual Basic
Public Property FirstName As String
    Get
    Set

Property Value

Type: String

See Also

Person Class
Person Members


Person.FullName Property

[image]

Pastel Evolution SDK
Person..::..FullName Property
Person Class See Also Send Feedback
Gets or sets the person's full name. (a.k.a. display name)

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string FullName { get; set; }
Visual Basic
Public Property FullName As String
    Get
    Set

Property Value

Type: String

See Also

Person Class
Person Members


Person.ID Property

[image]

Pastel Evolution SDK
Person..::..ID Property
Person Class See Also Send Feedback
Gets the internal record ID (0 for new, unsaved records).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

See Also

Person Class
Person Members


Person.Initials Property

[image]

Pastel Evolution SDK
Person..::..Initials Property
Person Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Initials { get; set; }
Visual Basic
Public Property Initials As String
    Get
    Set

Property Value

Type: String

See Also

Person Class
Person Members


Person.LastName Property

[image]

Pastel Evolution SDK
Person..::..LastName Property
Person Class See Also Send Feedback
Gets or sets the person's last name.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string LastName { get; set; }
Visual Basic
Public Property LastName As String
    Get
    Set

Property Value

Type: String

See Also

Person Class
Person Members


Person.LongID Property

[image]

Pastel Evolution SDK
Person..::..LongID Property
Person Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

Person Class
Person Members


Person.PostalAddress Property

[image]

Pastel Evolution SDK
Person..::..PostalAddress Property
Person Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Address PostalAddress { get; set; }
Visual Basic
Public Property PostalAddress As Address
    Get
    Set

Property Value

Type: Address

See Also

Person Class
Person Members


Person.TelHome Property

[image]

Pastel Evolution SDK
Person..::..TelHome Property
Person Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string TelHome { get; set; }
Visual Basic
Public Property TelHome As String
    Get
    Set

Property Value

Type: String

See Also

Person Class
Person Members


Person.TelMobile Property

[image]

Pastel Evolution SDK
Person..::..TelMobile Property
Person Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string TelMobile { get; set; }
Visual Basic
Public Property TelMobile As String
    Get
    Set

Property Value

Type: String

See Also

Person Class
Person Members


Person.TelWork Property

[image]

Pastel Evolution SDK
Person..::..TelWork Property
Person Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string TelWork { get; set; }
Visual Basic
Public Property TelWork As String
    Get
    Set

Property Value

Type: String

See Also

Person Class
Person Members


Person.Title Property

[image]

Pastel Evolution SDK
Person..::..Title Property
Person Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Title { get; set; }
Visual Basic
Public Property Title As String
    Get
    Set

Property Value

Type: String

See Also

Person Class
Person Members


Person.UserFields Property

[image]

Pastel Evolution SDK
Person..::..UserFields Property
Person Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public FieldCollection UserFields { get; }
Visual Basic
Public ReadOnly Property UserFields As FieldCollection
    Get

Property Value

Type: FieldCollection

See Also

Person Class
Person Members


Person.WebPage Property

[image]

Pastel Evolution SDK
Person..::..WebPage Property
Person Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string WebPage { get; set; }
Visual Basic
Public Property WebPage As String
    Get
    Set

Property Value

Type: String

See Also

Person Class
Person Members


PostDatedCheque Class

[image]

Pastel Evolution SDK
PostDatedCheque Class
Members See Also Send Feedback
Represents a post dated transaction.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class PostDatedCheque : BranchedRecordBase
Visual Basic
Public Class PostDatedCheque
    Inherits BranchedRecordBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..PostDatedCheque

See Also

PostDatedCheque Members


PostDatedCheque Members

[image] [image]

Pastel Evolution SDK
PostDatedCheque Members
PostDatedCheque Class Constructors Methods Fields Properties See Also Send Feedback

The PostDatedCheque type exposes the following members.

Constructors

 | Name | Description
Public method | PostDatedCheque()()()() | Initializes a new instance of the PostDatedCheque class
Public method | PostDatedCheque(Int32) | Initializes a new instance of the PostDatedCheque class

Methods

 | Name | Description
 | _ListCurrentBranch |
Protected method | calcAmounts |
Protected method | calcDiscountAmounts |
Protected method | calcDiscountTaxValues |
Protected method | calcTaxValues |
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds a post dated Cheque ID.
 | Get | Returns the [first] post dated cheque object matching the criteria specified; otherwise, returns null.
Protected method | getExchangeRate |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List(String) | Returns a System.Data.DataTable object containing the database records from the _etblPostDatedCheques table matching the supplied criteria.
 | List(String, String) | Returns a System.Data.DataTable object containing the database records from the _etblPostDatedCheques table matching the supplied criteria.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Protected method | setExchangeRate |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | Validate |
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | amount |
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | discountAmount |
Protected field | discountForeignAmount |
Protected field | discountForeignTax |
Protected field | discountTax |
Protected field | fcDiscountQueue |
Protected field | fcQueue |
Protected field | foreignAmount |
Protected field | foreignOriginalDiscountTax |
Protected field | foreignOriginalTax |
Protected field | foreignTax |
Protected field | originalDiscountTax |
Protected field | originalTax |
Protected field | tax |
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | Amount | Gets or sets the (gross) transaction value. Negative values are allowed and will result in inverted debits and credits.
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Cancelled | Gets or sets whether the Post Dated Cheque is Cancelled.
Public property | CancelledReason | Gets or sets the Post Dated Cheque Cancelled Reason.
Public property | ContraGLAccount | Gets or sets the Contra General Ledger.
Public property | ContraGLAccountID | Gets or sets the Contra General Ledger's ID.
Public property | Currency |
Public property | Customer | Gets or sets the Customer.
Public property | CustomerID | Gets or sets the Customer's ID.
Public property | Date | Gets or sets the Transaction's Date.
Public property | Description | Gets or sets the Transaction Description.
Public property | DiscountAmount | Gets or sets the discount value.
Public property | DiscountForeignTax | Gets or sets the post dated cheque discount foreign tax amount (automatically rounded to 2 decimals).
Public property | DiscountTax | Gets or sets the post dated cheque discount tax amount (automatically rounded to 2 decimals).
Public property | DiscountTaxRateID | Gets or sets the Discount TaxRate's ID.
Public property | DiscountTaxType | Gets or sets the Discount TaxRate.
Public property | ExchangeRate | Gets or sets the applicable exchange rate, expressed as [home currency]/[foreign currency]. Defaults to applicable exchange rate for the transaction date.
Public property | ForeignAmount | Gets or sets the foreign transaction value.
Public property | ForeignDiscountAmount | Gets or sets the foreign discount value.
Public property | ForeignTax | Gets or sets the post dated cheque foreign tax amount (automatically rounded to 2 decimals).
Public property | ID | (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | OrderNumber | Gets or sets the Transaction Order Number.
Public property | Project | Gets or sets the Project.
Public property | ProjectID | Gets or sets the Project's ID.
Public property | Reference | Gets or sets the Transaction Reference.
Public property | Reference2 | Gets or sets the Transaction Reference 2.
Public property | SalesRep | Gets or sets the Sales Rep.
Public property | SalesRepID | Gets or sets the Sales Rep's ID.
Public property | Tax | Gets or sets the post dated cheque tax amount (automatically rounded to 2 decimals).
Public property | TaxType | Gets or sets the TaxRate.
Public property | TaxTypeID | Gets or sets the TaxRate's ID.
Public property | TransactionCode | Gets or sets the Transaction Code.
Public property | TransactionCodeID | Gets or sets the Transaction Code's ID.

See Also

PostDatedCheque Class


PostDatedCheque Constructor

[image] [image]

Pastel Evolution SDK
PostDatedCheque Constructor
PostDatedCheque Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PostDatedCheque()()()() | Initializes a new instance of the PostDatedCheque class
Public method | PostDatedCheque(Int32) | Initializes a new instance of the PostDatedCheque class

See Also

PostDatedCheque Class
PostDatedCheque Members


PostDatedCheque Constructor

[image]

Pastel Evolution SDK
PostDatedCheque Constructor
PostDatedCheque Class See Also Send Feedback
Initializes a new instance of the PostDatedCheque class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public PostDatedCheque()
Visual Basic
Public Sub New

See Also

PostDatedCheque Class
PostDatedCheque Members
PostDatedCheque Overload


PostDatedCheque Constructor (Int32)

[image]

Pastel Evolution SDK
PostDatedCheque Constructor (Int32)
PostDatedCheque Class See Also Send Feedback
Initializes a new instance of the PostDatedCheque class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public PostDatedCheque(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32

See Also

PostDatedCheque Class
PostDatedCheque Members
PostDatedCheque Overload


PostDatedCheque Fields

[image] [image]

Pastel Evolution SDK
PostDatedCheque Fields
PostDatedCheque Class See Also Send Feedback

The PostDatedCheque type exposes the following members.

Fields

 | Name | Description
Protected field | amount |
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | discountAmount |
Protected field | discountForeignAmount |
Protected field | discountForeignTax |
Protected field | discountTax |
Protected field | fcDiscountQueue |
Protected field | fcQueue |
Protected field | foreignAmount |
Protected field | foreignOriginalDiscountTax |
Protected field | foreignOriginalTax |
Protected field | foreignTax |
Protected field | originalDiscountTax |
Protected field | originalTax |
Protected field | tax |
Protected field | wrapper | (Inherited from RecordBase.)

See Also

PostDatedCheque Class


PostDatedCheque.amount Field

[image]

Pastel Evolution SDK
PostDatedCheque..::..amount Field
PostDatedCheque Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected double amount
Visual Basic
Protected amount As Double

Field Value

Type: Double

See Also

PostDatedCheque Class
PostDatedCheque Members


PostDatedCheque.discountAmount Field

[image]

Pastel Evolution SDK
PostDatedCheque..::..discountAmount Field
PostDatedCheque Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected double discountAmount
Visual Basic
Protected discountAmount As Double

Field Value

Type: Double

See Also

PostDatedCheque Class
PostDatedCheque Members


PostDatedCheque.discountForeignAmount Field

[image]

Pastel Evolution SDK
PostDatedCheque..::..discountForeignAmount Field
PostDatedCheque Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected double discountForeignAmount
Visual Basic
Protected discountForeignAmount As Double

Field Value

Type: Double

See Also

PostDatedCheque Class
PostDatedCheque Members


PostDatedCheque.discountForeignTax Field

[image]

Pastel Evolution SDK
PostDatedCheque..::..discountForeignTax Field
PostDatedCheque Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected double discountForeignTax
Visual Basic
Protected discountForeignTax As Double

Field Value

Type: Double

See Also

PostDatedCheque Class
PostDatedCheque Members


PostDatedCheque.discountTax Field

[image]

Pastel Evolution SDK
PostDatedCheque..::..discountTax Field
PostDatedCheque Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected double discountTax
Visual Basic
Protected discountTax As Double

Field Value

Type: Double

See Also

PostDatedCheque Class
PostDatedCheque Members


PostDatedCheque.fcDiscountQueue Field

[image]

Pastel Evolution SDK
PostDatedCheque..::..fcDiscountQueue Field
PostDatedCheque Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal Utils..::..LimitedQueue fcDiscountQueue
Visual Basic
Protected Friend fcDiscountQueue As Utils..::..LimitedQueue

Field Value

Type: Utils..::..LimitedQueue

See Also

PostDatedCheque Class
PostDatedCheque Members


PostDatedCheque.fcQueue Field

[image]

Pastel Evolution SDK
PostDatedCheque..::..fcQueue Field
PostDatedCheque Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal Utils..::..LimitedQueue fcQueue
Visual Basic
Protected Friend fcQueue As Utils..::..LimitedQueue

Field Value

Type: Utils..::..LimitedQueue

See Also

PostDatedCheque Class
PostDatedCheque Members


PostDatedCheque.foreignAmount Field

[image]

Pastel Evolution SDK
PostDatedCheque..::..foreignAmount Field
PostDatedCheque Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected double foreignAmount
Visual Basic
Protected foreignAmount As Double

Field Value

Type: Double

See Also

PostDatedCheque Class
PostDatedCheque Members


PostDatedCheque.foreignOriginalDiscountTax Field

[image]

Pastel Evolution SDK
PostDatedCheque..::..foreignOriginalDiscountTax Field
PostDatedCheque Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected double foreignOriginalDiscountTax
Visual Basic
Protected foreignOriginalDiscountTax As Double

Field Value

Type: Double

See Also

PostDatedCheque Class
PostDatedCheque Members


PostDatedCheque.foreignOriginalTax Field

[image]

Pastel Evolution SDK
PostDatedCheque..::..foreignOriginalTax Field
PostDatedCheque Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected double foreignOriginalTax
Visual Basic
Protected foreignOriginalTax As Double

Field Value

Type: Double

See Also

PostDatedCheque Class
PostDatedCheque Members


PostDatedCheque.foreignTax Field

[image]

Pastel Evolution SDK
PostDatedCheque..::..foreignTax Field
PostDatedCheque Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected double foreignTax
Visual Basic
Protected foreignTax As Double

Field Value

Type: Double

See Also

PostDatedCheque Class
PostDatedCheque Members


PostDatedCheque.originalDiscountTax Field

[image]

Pastel Evolution SDK
PostDatedCheque..::..originalDiscountTax Field
PostDatedCheque Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected double originalDiscountTax
Visual Basic
Protected originalDiscountTax As Double

Field Value

Type: Double

See Also

PostDatedCheque Class
PostDatedCheque Members


PostDatedCheque.originalTax Field

[image]

Pastel Evolution SDK
PostDatedCheque..::..originalTax Field
PostDatedCheque Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected double originalTax
Visual Basic
Protected originalTax As Double

Field Value

Type: Double

See Also

PostDatedCheque Class
PostDatedCheque Members


PostDatedCheque.tax Field

[image]

Pastel Evolution SDK
PostDatedCheque..::..tax Field
PostDatedCheque Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected double tax
Visual Basic
Protected tax As Double

Field Value

Type: Double

See Also

PostDatedCheque Class
PostDatedCheque Members


PostDatedCheque Methods

[image] [image]

Pastel Evolution SDK
PostDatedCheque Methods
PostDatedCheque Class See Also Send Feedback

The PostDatedCheque type exposes the following members.

Methods

 | Name | Description
 | _ListCurrentBranch |
Protected method | calcAmounts |
Protected method | calcDiscountAmounts |
Protected method | calcDiscountTaxValues |
Protected method | calcTaxValues |
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds a post dated Cheque ID.
 | Get | Returns the [first] post dated cheque object matching the criteria specified; otherwise, returns null.
Protected method | getExchangeRate |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List(String) | Returns a System.Data.DataTable object containing the database records from the _etblPostDatedCheques table matching the supplied criteria.
 | List(String, String) | Returns a System.Data.DataTable object containing the database records from the _etblPostDatedCheques table matching the supplied criteria.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Protected method | setExchangeRate |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | Validate |
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

PostDatedCheque Class


PostDatedCheque._ListCurrentBranch Method

[image]

Pastel Evolution SDK
PostDatedCheque..::.._ListCurrentBranch Method
PostDatedCheque Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable _ListCurrentBranch(
    string criteria
)
Visual Basic
Public Shared Function _ListCurrentBranch (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String

Return Value

Type: DataTable

See Also

PostDatedCheque Class
PostDatedCheque Members


PostDatedCheque.calcAmounts Method

[image]

Pastel Evolution SDK
PostDatedCheque..::..calcAmounts Method
PostDatedCheque Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected void calcAmounts()
Visual Basic
Protected Sub calcAmounts

See Also

PostDatedCheque Class
PostDatedCheque Members


PostDatedCheque.calcDiscountAmounts Method

[image]

Pastel Evolution SDK
PostDatedCheque..::..calcDiscountAmounts Method
PostDatedCheque Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected void calcDiscountAmounts()
Visual Basic
Protected Sub calcDiscountAmounts

See Also

PostDatedCheque Class
PostDatedCheque Members


PostDatedCheque.calcDiscountTaxValues Method

[image]

Pastel Evolution SDK
PostDatedCheque..::..calcDiscountTaxValues Method
PostDatedCheque Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected void calcDiscountTaxValues()
Visual Basic
Protected Sub calcDiscountTaxValues

See Also

PostDatedCheque Class
PostDatedCheque Members


PostDatedCheque.calcTaxValues Method

[image]

Pastel Evolution SDK
PostDatedCheque..::..calcTaxValues Method
PostDatedCheque Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected void calcTaxValues()
Visual Basic
Protected Sub calcTaxValues

See Also

PostDatedCheque Class
PostDatedCheque Members


PostDatedCheque.Find Method

[image]

Pastel Evolution SDK
PostDatedCheque..::..Find Method
PostDatedCheque Class See Also Send Feedback
Finds a post dated Cheque ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String
The criteria passed to the SQL query. Eg. cpdcReference = 'CH001'

Return Value

Type: Int32

See Also

PostDatedCheque Class
PostDatedCheque Members


PostDatedCheque.Get Method

[image]

Pastel Evolution SDK
PostDatedCheque..::..Get Method
PostDatedCheque Class See Also Send Feedback
Returns the [first] post dated cheque object matching the criteria specified; otherwise, returns null.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static PostDatedCheque Get(
    string criteria
)
Visual Basic
Public Shared Function Get (
    criteria As String
) As PostDatedCheque

Parameters

criteria
Type: System..::..String
Eg. cpdcReference = 'CH001'

Return Value

Type: PostDatedCheque

See Also

PostDatedCheque Class
PostDatedCheque Members
Pastel.Evolution Namespace
PostDatedCheque..::..Find(String)


PostDatedCheque.getExchangeRate Method

[image]

Pastel Evolution SDK
PostDatedCheque..::..getExchangeRate Method
PostDatedCheque Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected double getExchangeRate()
Visual Basic
Protected Function getExchangeRate As Double

Return Value

Type: Double

See Also

PostDatedCheque Class
PostDatedCheque Members


PostDatedCheque.List Method

[image] [image]

Pastel Evolution SDK
PostDatedCheque..::..List Method
PostDatedCheque Class See Also Send Feedback

Overload List

Name | Description
List(String) | Returns a System.Data.DataTable object containing the database records from the _etblPostDatedCheques table matching the supplied criteria.
List(String, String) | Returns a System.Data.DataTable object containing the database records from the _etblPostDatedCheques table matching the supplied criteria.

See Also

PostDatedCheque Class
PostDatedCheque Members


PostDatedCheque.List Method (String)

[image]

Pastel Evolution SDK
PostDatedCheque..::..List Method (String)
PostDatedCheque Class See Also Send Feedback
Returns a System.Data.DataTable object containing the database records from the _etblPostDatedCheques table matching the supplied criteria.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria
)
Visual Basic
Public Shared Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String
The SQL criteria used to locate the record, e.g. cpdcReference like '1___'

Return Value

Type: DataTable
A System.Data.DataTable object containing matching records.

Remarks

The criteria is passed to an SQL query so use the appropriate syntax. Remember to includethe single quotes around string literals and append additional criteria with and.

See Also

PostDatedCheque Class
PostDatedCheque Members
List Overload


PostDatedCheque.List Method (String, String)

[image]

Pastel Evolution SDK
PostDatedCheque..::..List Method (String, String)
PostDatedCheque Class See Also Send Feedback
Returns a System.Data.DataTable object containing the database records from the _etblPostDatedCheques table matching the supplied criteria.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria,
    string sortOrder
)
Visual Basic
Public Shared Function List (
    criteria As String,
    sortOrder As String
) As DataTable

Parameters

criteria
Type: System..::..String
The SQL criteria used to locate the record, e.g. cpdcReference like '1___'
sortOrder
Type: System..::..String
The SQL order by clause to use, e.g. cpdcReference, etc

Return Value

Type: DataTable
A System.Data.DataTable object containing matching records.

Remarks

The criteria is passed to an SQL query so use the appropriate syntax. Remember to includethe single quotes around string literals and append additional criteria with and.

See Also

PostDatedCheque Class
PostDatedCheque Members
List Overload


PostDatedCheque.OnDelete Method

[image]

Pastel Evolution SDK
PostDatedCheque..::..OnDelete Method
PostDatedCheque Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

See Also

PostDatedCheque Class
PostDatedCheque Members


PostDatedCheque.OnSave Method

[image]

Pastel Evolution SDK
PostDatedCheque..::..OnSave Method
PostDatedCheque Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

PostDatedCheque Class
PostDatedCheque Members


PostDatedCheque.setExchangeRate Method

[image]

Pastel Evolution SDK
PostDatedCheque..::..setExchangeRate Method
PostDatedCheque Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected void setExchangeRate(
    double value
)
Visual Basic
Protected Sub setExchangeRate (
    value As Double
)

Parameters

value
Type: System..::..Double

See Also

PostDatedCheque Class
PostDatedCheque Members


PostDatedCheque.Validate Method

[image]

Pastel Evolution SDK
PostDatedCheque..::..Validate Method
PostDatedCheque Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected bool Validate()
Visual Basic
Protected Function Validate As Boolean

Return Value

Type: Boolean

See Also

PostDatedCheque Class
PostDatedCheque Members


PostDatedCheque Properties

[image] [image]

Pastel Evolution SDK
PostDatedCheque Properties
PostDatedCheque Class See Also Send Feedback

The PostDatedCheque type exposes the following members.

Properties

 | Name | Description
Public property | Amount | Gets or sets the (gross) transaction value. Negative values are allowed and will result in inverted debits and credits.
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Cancelled | Gets or sets whether the Post Dated Cheque is Cancelled.
Public property | CancelledReason | Gets or sets the Post Dated Cheque Cancelled Reason.
Public property | ContraGLAccount | Gets or sets the Contra General Ledger.
Public property | ContraGLAccountID | Gets or sets the Contra General Ledger's ID.
Public property | Currency |
Public property | Customer | Gets or sets the Customer.
Public property | CustomerID | Gets or sets the Customer's ID.
Public property | Date | Gets or sets the Transaction's Date.
Public property | Description | Gets or sets the Transaction Description.
Public property | DiscountAmount | Gets or sets the discount value.
Public property | DiscountForeignTax | Gets or sets the post dated cheque discount foreign tax amount (automatically rounded to 2 decimals).
Public property | DiscountTax | Gets or sets the post dated cheque discount tax amount (automatically rounded to 2 decimals).
Public property | DiscountTaxRateID | Gets or sets the Discount TaxRate's ID.
Public property | DiscountTaxType | Gets or sets the Discount TaxRate.
Public property | ExchangeRate | Gets or sets the applicable exchange rate, expressed as [home currency]/[foreign currency]. Defaults to applicable exchange rate for the transaction date.
Public property | ForeignAmount | Gets or sets the foreign transaction value.
Public property | ForeignDiscountAmount | Gets or sets the foreign discount value.
Public property | ForeignTax | Gets or sets the post dated cheque foreign tax amount (automatically rounded to 2 decimals).
Public property | ID | (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | OrderNumber | Gets or sets the Transaction Order Number.
Public property | Project | Gets or sets the Project.
Public property | ProjectID | Gets or sets the Project's ID.
Public property | Reference | Gets or sets the Transaction Reference.
Public property | Reference2 | Gets or sets the Transaction Reference 2.
Public property | SalesRep | Gets or sets the Sales Rep.
Public property | SalesRepID | Gets or sets the Sales Rep's ID.
Public property | Tax | Gets or sets the post dated cheque tax amount (automatically rounded to 2 decimals).
Public property | TaxType | Gets or sets the TaxRate.
Public property | TaxTypeID | Gets or sets the TaxRate's ID.
Public property | TransactionCode | Gets or sets the Transaction Code.
Public property | TransactionCodeID | Gets or sets the Transaction Code's ID.

See Also

PostDatedCheque Class


PostDatedCheque.Amount Property

[image]

Pastel Evolution SDK
PostDatedCheque..::..Amount Property
PostDatedCheque Class See Also Send Feedback
Gets or sets the (gross) transaction value. Negative values are allowed and will result in inverted debits and credits.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double Amount { get; set; }
Visual Basic
Public Property Amount As Double
    Get
    Set

Property Value

Type: Double

See Also

PostDatedCheque Class
PostDatedCheque Members


PostDatedCheque.Cancelled Property

[image]

Pastel Evolution SDK
PostDatedCheque..::..Cancelled Property
PostDatedCheque Class See Also Send Feedback
Gets or sets whether the Post Dated Cheque is Cancelled.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool Cancelled { get; set; }
Visual Basic
Public Property Cancelled As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

PostDatedCheque Class
PostDatedCheque Members


PostDatedCheque.CancelledReason Property

[image]

Pastel Evolution SDK
PostDatedCheque..::..CancelledReason Property
PostDatedCheque Class See Also Send Feedback
Gets or sets the Post Dated Cheque Cancelled Reason.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string CancelledReason { get; set; }
Visual Basic
Public Property CancelledReason As String
    Get
    Set

Property Value

Type: String

See Also

PostDatedCheque Class
PostDatedCheque Members


PostDatedCheque.ContraGLAccount Property

[image]

Pastel Evolution SDK
PostDatedCheque..::..ContraGLAccount Property
PostDatedCheque Class See Also Send Feedback
Gets or sets the Contra General Ledger.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLAccount ContraGLAccount { get; set; }
Visual Basic
Public Property ContraGLAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

See Also

PostDatedCheque Class
PostDatedCheque Members


PostDatedCheque.ContraGLAccountID Property

[image]

Pastel Evolution SDK
PostDatedCheque..::..ContraGLAccountID Property
PostDatedCheque Class See Also Send Feedback
Gets or sets the Contra General Ledger's ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int ContraGLAccountID { get; set; }
Visual Basic
Public Property ContraGLAccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

PostDatedCheque Class
PostDatedCheque Members


PostDatedCheque.Currency Property

[image]

Pastel Evolution SDK
PostDatedCheque..::..Currency Property
PostDatedCheque Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Currency Currency { get; }
Visual Basic
Public ReadOnly Property Currency As Currency
    Get

Property Value

Type: Currency

See Also

PostDatedCheque Class
PostDatedCheque Members


PostDatedCheque.Customer Property

[image]

Pastel Evolution SDK
PostDatedCheque..::..Customer Property
PostDatedCheque Class See Also Send Feedback
Gets or sets the Customer.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Customer Customer { get; set; }
Visual Basic
Public Property Customer As Customer
    Get
    Set

Property Value

Type: Customer

See Also

PostDatedCheque Class
PostDatedCheque Members


PostDatedCheque.CustomerID Property

[image]

Pastel Evolution SDK
PostDatedCheque..::..CustomerID Property
PostDatedCheque Class See Also Send Feedback
Gets or sets the Customer's ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int CustomerID { get; set; }
Visual Basic
Public Property CustomerID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

PostDatedCheque Class
PostDatedCheque Members


PostDatedCheque.Date Property

[image]

Pastel Evolution SDK
PostDatedCheque..::..Date Property
PostDatedCheque Class See Also Send Feedback
Gets or sets the Transaction's Date.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DateTime Date { get; set; }
Visual Basic
Public Property Date As DateTime
    Get
    Set

Property Value

Type: DateTime

See Also

PostDatedCheque Class
PostDatedCheque Members


PostDatedCheque.Description Property

[image]

Pastel Evolution SDK
PostDatedCheque..::..Description Property
PostDatedCheque Class See Also Send Feedback
Gets or sets the Transaction Description.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set

Property Value

Type: String

See Also

PostDatedCheque Class
PostDatedCheque Members


PostDatedCheque.DiscountAmount Property

[image]

Pastel Evolution SDK
PostDatedCheque..::..DiscountAmount Property
PostDatedCheque Class See Also Send Feedback
Gets or sets the discount value.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double DiscountAmount { get; set; }
Visual Basic
Public Property DiscountAmount As Double
    Get
    Set

Property Value

Type: Double

See Also

PostDatedCheque Class
PostDatedCheque Members


PostDatedCheque.DiscountForeignTax Property

[image]

Pastel Evolution SDK
PostDatedCheque..::..DiscountForeignTax Property
PostDatedCheque Class See Also Send Feedback
Gets or sets the post dated cheque discount foreign tax amount (automatically rounded to 2 decimals).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double DiscountForeignTax { get; set; }
Visual Basic
Public Property DiscountForeignTax As Double
    Get
    Set

Property Value

Type: Double

See Also

PostDatedCheque Class
PostDatedCheque Members


PostDatedCheque.DiscountTax Property

[image]

Pastel Evolution SDK
PostDatedCheque..::..DiscountTax Property
PostDatedCheque Class See Also Send Feedback
Gets or sets the post dated cheque discount tax amount (automatically rounded to 2 decimals).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double DiscountTax { get; set; }
Visual Basic
Public Property DiscountTax As Double
    Get
    Set

Property Value

Type: Double

See Also

PostDatedCheque Class
PostDatedCheque Members


PostDatedCheque.DiscountTaxRateID Property

[image]

Pastel Evolution SDK
PostDatedCheque..::..DiscountTaxRateID Property
PostDatedCheque Class See Also Send Feedback
Gets or sets the Discount TaxRate's ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int DiscountTaxRateID { get; set; }
Visual Basic
Public Property DiscountTaxRateID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

PostDatedCheque Class
PostDatedCheque Members


PostDatedCheque.DiscountTaxType Property

[image]

Pastel Evolution SDK
PostDatedCheque..::..DiscountTaxType Property
PostDatedCheque Class See Also Send Feedback
Gets or sets the Discount TaxRate.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public TaxRate DiscountTaxType { get; set; }
Visual Basic
Public Property DiscountTaxType As TaxRate
    Get
    Set

Property Value

Type: TaxRate

See Also

PostDatedCheque Class
PostDatedCheque Members


PostDatedCheque.ExchangeRate Property

[image]

Pastel Evolution SDK
PostDatedCheque..::..ExchangeRate Property
PostDatedCheque Class See Also Send Feedback
Gets or sets the applicable exchange rate, expressed as [home currency]/[foreign currency]. Defaults to applicable exchange rate for the transaction date.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double ExchangeRate { get; set; }
Visual Basic
Public Property ExchangeRate As Double
    Get
    Set

Property Value

Type: Double

See Also

PostDatedCheque Class
PostDatedCheque Members


PostDatedCheque.ForeignAmount Property

[image]

Pastel Evolution SDK
PostDatedCheque..::..ForeignAmount Property
PostDatedCheque Class See Also Send Feedback
Gets or sets the foreign transaction value.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double ForeignAmount { get; set; }
Visual Basic
Public Property ForeignAmount As Double
    Get
    Set

Property Value

Type: Double

See Also

PostDatedCheque Class
PostDatedCheque Members


PostDatedCheque.ForeignDiscountAmount Property

[image]

Pastel Evolution SDK
PostDatedCheque..::..ForeignDiscountAmount Property
PostDatedCheque Class See Also Send Feedback
Gets or sets the foreign discount value.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double ForeignDiscountAmount { get; set; }
Visual Basic
Public Property ForeignDiscountAmount As Double
    Get
    Set

Property Value

Type: Double

See Also

PostDatedCheque Class
PostDatedCheque Members


PostDatedCheque.ForeignTax Property

[image]

Pastel Evolution SDK
PostDatedCheque..::..ForeignTax Property
PostDatedCheque Class See Also Send Feedback
Gets or sets the post dated cheque foreign tax amount (automatically rounded to 2 decimals).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double ForeignTax { get; set; }
Visual Basic
Public Property ForeignTax As Double
    Get
    Set

Property Value

Type: Double

See Also

PostDatedCheque Class
PostDatedCheque Members


PostDatedCheque.ID Property

[image]

Pastel Evolution SDK
PostDatedCheque..::..ID Property
PostDatedCheque Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

See Also

PostDatedCheque Class
PostDatedCheque Members


PostDatedCheque.LongID Property

[image]

Pastel Evolution SDK
PostDatedCheque..::..LongID Property
PostDatedCheque Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

PostDatedCheque Class
PostDatedCheque Members


PostDatedCheque.OrderNumber Property

[image]

Pastel Evolution SDK
PostDatedCheque..::..OrderNumber Property
PostDatedCheque Class See Also Send Feedback
Gets or sets the Transaction Order Number.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string OrderNumber { get; set; }
Visual Basic
Public Property OrderNumber As String
    Get
    Set

Property Value

Type: String

See Also

PostDatedCheque Class
PostDatedCheque Members


PostDatedCheque.Project Property

[image]

Pastel Evolution SDK
PostDatedCheque..::..Project Property
PostDatedCheque Class See Also Send Feedback
Gets or sets the Project.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Project Project { get; set; }
Visual Basic
Public Property Project As Project
    Get
    Set

Property Value

Type: Project

See Also

PostDatedCheque Class
PostDatedCheque Members


PostDatedCheque.ProjectID Property

[image]

Pastel Evolution SDK
PostDatedCheque..::..ProjectID Property
PostDatedCheque Class See Also Send Feedback
Gets or sets the Project's ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int ProjectID { get; set; }
Visual Basic
Public Property ProjectID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

PostDatedCheque Class
PostDatedCheque Members


PostDatedCheque.Reference Property

[image]

Pastel Evolution SDK
PostDatedCheque..::..Reference Property
PostDatedCheque Class See Also Send Feedback
Gets or sets the Transaction Reference.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Reference { get; set; }
Visual Basic
Public Property Reference As String
    Get
    Set

Property Value

Type: String

See Also

PostDatedCheque Class
PostDatedCheque Members


PostDatedCheque.Reference2 Property

[image]

Pastel Evolution SDK
PostDatedCheque..::..Reference2 Property
PostDatedCheque Class See Also Send Feedback
Gets or sets the Transaction Reference 2.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Reference2 { get; set; }
Visual Basic
Public Property Reference2 As String
    Get
    Set

Property Value

Type: String

See Also

PostDatedCheque Class
PostDatedCheque Members


PostDatedCheque.SalesRep Property

[image]

Pastel Evolution SDK
PostDatedCheque..::..SalesRep Property
PostDatedCheque Class See Also Send Feedback
Gets or sets the Sales Rep.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public SalesRepresentative SalesRep { get; set; }
Visual Basic
Public Property SalesRep As SalesRepresentative
    Get
    Set

Property Value

Type: SalesRepresentative

See Also

PostDatedCheque Class
PostDatedCheque Members


PostDatedCheque.SalesRepID Property

[image]

Pastel Evolution SDK
PostDatedCheque..::..SalesRepID Property
PostDatedCheque Class See Also Send Feedback
Gets or sets the Sales Rep's ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int SalesRepID { get; set; }
Visual Basic
Public Property SalesRepID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

PostDatedCheque Class
PostDatedCheque Members


PostDatedCheque.Tax Property

[image]

Pastel Evolution SDK
PostDatedCheque..::..Tax Property
PostDatedCheque Class See Also Send Feedback
Gets or sets the post dated cheque tax amount (automatically rounded to 2 decimals).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double Tax { get; set; }
Visual Basic
Public Property Tax As Double
    Get
    Set

Property Value

Type: Double

See Also

PostDatedCheque Class
PostDatedCheque Members


PostDatedCheque.TaxType Property

[image]

Pastel Evolution SDK
PostDatedCheque..::..TaxType Property
PostDatedCheque Class See Also Send Feedback
Gets or sets the TaxRate.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public TaxRate TaxType { get; set; }
Visual Basic
Public Property TaxType As TaxRate
    Get
    Set

Property Value

Type: TaxRate

See Also

PostDatedCheque Class
PostDatedCheque Members


PostDatedCheque.TaxTypeID Property

[image]

Pastel Evolution SDK
PostDatedCheque..::..TaxTypeID Property
PostDatedCheque Class See Also Send Feedback
Gets or sets the TaxRate's ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int TaxTypeID { get; set; }
Visual Basic
Public Property TaxTypeID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

PostDatedCheque Class
PostDatedCheque Members


PostDatedCheque.TransactionCode Property

[image]

Pastel Evolution SDK
PostDatedCheque..::..TransactionCode Property
PostDatedCheque Class See Also Send Feedback
Gets or sets the Transaction Code.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public TransactionCodeBase TransactionCode { get; set; }
Visual Basic
Public Property TransactionCode As TransactionCodeBase
    Get
    Set

Property Value

Type: TransactionCodeBase

See Also

PostDatedCheque Class
PostDatedCheque Members


PostDatedCheque.TransactionCodeID Property

[image]

Pastel Evolution SDK
PostDatedCheque..::..TransactionCodeID Property
PostDatedCheque Class See Also Send Feedback
Gets or sets the Transaction Code's ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int TransactionCodeID { get; set; }
Visual Basic
Public Property TransactionCodeID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

PostDatedCheque Class
PostDatedCheque Members


PriceList Class

[image]

Pastel Evolution SDK
PriceList Class
Members See Also Send Feedback
Represents an inventory price list.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class PriceList : BranchedRecordBase
Visual Basic
Public Class PriceList
    Inherits BranchedRecordBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..PriceList

See Also

PriceList Members


PriceList Members

[image] [image]

Pastel Evolution SDK
PriceList Members
PriceList Class Constructors Methods Fields Properties See Also Send Feedback

The PriceList type exposes the following members.

Constructors

 | Name | Description
Public method | PriceList()()()() | Creates a new instance of a price list.
Public method | PriceList(Int32) | Creates a new instance of a price list.
Public method | PriceList(String) | Creates a new instance of a price list.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds a record's database ID.
 | FindByName | Executes the FindByName method.
 | Get | Returns an instance of the first record satisfying the criteria specified; otherwise, returns null.
 | GetByName | Gets the by name.
 | GetDefault | Gets the default price list.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Description | Gets or sets the price list's description.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | Name | Gets or sets the price list's name.

See Also

PriceList Class


PriceList Constructor

[image] [image]

Pastel Evolution SDK
PriceList Constructor
PriceList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PriceList()()()() | Creates a new instance of a price list.
Public method | PriceList(Int32) | Creates a new instance of a price list.
Public method | PriceList(String) | Creates a new instance of a price list.

See Also

PriceList Class
PriceList Members


PriceList Constructor

[image]

Pastel Evolution SDK
PriceList Constructor
PriceList Class See Also Send Feedback
Creates a new instance of a price list.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public PriceList()
Visual Basic
Public Sub New

See Also

PriceList Class
PriceList Members
PriceList Overload


PriceList Constructor (Int32)

[image]

Pastel Evolution SDK
PriceList Constructor (Int32)
PriceList Class See Also Send Feedback
Creates a new instance of a price list.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public PriceList(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32
Specifies the id of the existing record.

See Also

PriceList Class
PriceList Members
PriceList Overload


PriceList Constructor (String)

[image]

Pastel Evolution SDK
PriceList Constructor (String)
PriceList Class See Also Send Feedback
Creates a new instance of a price list.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public PriceList(
    string name
)
Visual Basic
Public Sub New (
    name As String
)

Parameters

name
Type: System..::..String
Specifies the name of the existing record.

See Also

PriceList Class
PriceList Members
PriceList Overload


PriceList Fields

[image] [image]

Pastel Evolution SDK
PriceList Fields
PriceList Class See Also Send Feedback

The PriceList type exposes the following members.

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

PriceList Class


PriceList Methods

[image] [image]

Pastel Evolution SDK
PriceList Methods
PriceList Class See Also Send Feedback

The PriceList type exposes the following members.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds a record's database ID.
 | FindByName | Executes the FindByName method.
 | Get | Returns an instance of the first record satisfying the criteria specified; otherwise, returns null.
 | GetByName | Gets the by name.
 | GetDefault | Gets the default price list.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

PriceList Class


PriceList.Find Method

[image]

Pastel Evolution SDK
PriceList..::..Find Method
PriceList Class See Also Send Feedback
Finds a record's database ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.

Return Value

Type: Int32
The ID of the first record found; -1 if not record was found.

See Also

PriceList Class
PriceList Members


PriceList.FindByName Method

[image]

Pastel Evolution SDK
PriceList..::..FindByName Method
PriceList Class See Also Send Feedback
Executes the FindByName method.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int FindByName(
    string name
)
Visual Basic
Public Shared Function FindByName (
    name As String
) As Integer

Parameters

name
Type: System..::..String
Specifies the name.

Return Value

Type: Int32
The FindByName.

See Also

PriceList Class
PriceList Members


PriceList.Get Method

[image]

Pastel Evolution SDK
PriceList..::..Get Method
PriceList Class See Also Send Feedback
Returns an instance of the first record satisfying the criteria specified; otherwise, returns null.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static PriceList Get(
    string criteria
)
Visual Basic
Public Shared Function Get (
    criteria As String
) As PriceList

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.

Return Value

Type: PriceList
The record found; otherwise null

See Also

PriceList Class
PriceList Members


PriceList.GetByName Method

[image]

Pastel Evolution SDK
PriceList..::..GetByName Method
PriceList Class See Also Send Feedback
Gets the by name.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static PriceList GetByName(
    string name
)
Visual Basic
Public Shared Function GetByName (
    name As String
) As PriceList

Parameters

name
Type: System..::..String
Specifies the name.

Return Value

Type: PriceList
The ByName.

See Also

PriceList Class
PriceList Members


PriceList.GetDefault Method

[image]

Pastel Evolution SDK
PriceList..::..GetDefault Method
PriceList Class See Also Send Feedback
Gets the default price list.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static PriceList GetDefault()
Visual Basic
Public Shared Function GetDefault As PriceList

Return Value

Type: PriceList
The Default.

See Also

PriceList Class
PriceList Members


PriceList.List Method

[image]

Pastel Evolution SDK
PriceList..::..List Method
PriceList Class See Also Send Feedback
Gets a list of database records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria
)
Visual Basic
Public Shared Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.

Return Value

Type: DataTable
Table containing selected records.

See Also

PriceList Class
PriceList Members


PriceList.OnDelete Method

[image]

Pastel Evolution SDK
PriceList..::..OnDelete Method
PriceList Class See Also Send Feedback
Removes the record from the database, provided it is not referenced by other records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

Exceptions

Exception | Condition
IntegrityViolationException |

See Also

PriceList Class
PriceList Members


PriceList.OnSave Method

[image]

Pastel Evolution SDK
PriceList..::..OnSave Method
PriceList Class See Also Send Feedback
Persists the record to the database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

PriceList Class
PriceList Members


PriceList Properties

[image] [image]

Pastel Evolution SDK
PriceList Properties
PriceList Class See Also Send Feedback

The PriceList type exposes the following members.

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Description | Gets or sets the price list's description.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | Name | Gets or sets the price list's name.

See Also

PriceList Class


PriceList.Description Property

[image]

Pastel Evolution SDK
PriceList..::..Description Property
PriceList Class See Also Send Feedback
Gets or sets the price list's description.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set

Property Value

Type: String

See Also

PriceList Class
PriceList Members


PriceList.ID Property

[image]

Pastel Evolution SDK
PriceList..::..ID Property
PriceList Class See Also Send Feedback
Gets the internal record ID (0 for new, unsaved records).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

See Also

PriceList Class
PriceList Members


PriceList.LongID Property

[image]

Pastel Evolution SDK
PriceList..::..LongID Property
PriceList Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

PriceList Class
PriceList Members


PriceList.Name Property

[image]

Pastel Evolution SDK
PriceList..::..Name Property
PriceList Class See Also Send Feedback
Gets or sets the price list's name.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

Property Value

Type: String

See Also

PriceList Class
PriceList Members


PrintGroup Class

[image]

Pastel Evolution SDK
PrintGroup Class
Members See Also Send Feedback
Represents a print group, which is a collection of inventory documents enabling batch printing.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class PrintGroup : BranchedRecordBase
Visual Basic
Public Class PrintGroup
    Inherits BranchedRecordBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..PrintGroup

See Also

PrintGroup Members


PrintGroup Members

[image] [image]

Pastel Evolution SDK
PrintGroup Members
PrintGroup Class Constructors Methods Fields Properties See Also Send Feedback

The PrintGroup type exposes the following members.

Constructors

 | Name | Description
Public method | PrintGroup(Int32) | Creates a new instance of a print group.
Public method | PrintGroup(String, DocumentType) | Creates a new instance of a print group.

Methods

 | Name | Description
Public method | AddDocument | Appends a document to the print group.
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds a record's database ID.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | List | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Not supported. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | RemoveDocument | Removes a document from the print group.
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Description | Gets or sets the record description.
Public property | DocumentIDs | Gets the print group's ArrayList of document ID's.
Public property | DocumentType | Gets the print group's document type.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)

See Also

PrintGroup Class


PrintGroup Constructor

[image] [image]

Pastel Evolution SDK
PrintGroup Constructor
PrintGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PrintGroup(Int32) | Creates a new instance of a print group.
Public method | PrintGroup(String, DocumentType) | Creates a new instance of a print group.

See Also

PrintGroup Class
PrintGroup Members


PrintGroup Constructor (Int32)

[image]

Pastel Evolution SDK
PrintGroup Constructor (Int32)
PrintGroup Class See Also Send Feedback
Creates a new instance of a print group.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public PrintGroup(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32
Specifies the id of the existing record.

See Also

PrintGroup Class
PrintGroup Members
PrintGroup Overload


PrintGroup Constructor (String, DocumentType)

[image]

Pastel Evolution SDK
PrintGroup Constructor (String, DocumentType)
PrintGroup Class See Also Send Feedback
Creates a new instance of a print group.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public PrintGroup(
    string description,
    DocumentType documentType
)
Visual Basic
Public Sub New (
    description As String,
    documentType As DocumentType
)

Parameters

description
Type: System..::..String
Specifies the description of the existing record.
documentType
Type: Pastel.Evolution..::..DocumentType
Specifies the document type of the existing record.

See Also

PrintGroup Class
PrintGroup Members
PrintGroup Overload


PrintGroup Fields

[image] [image]

Pastel Evolution SDK
PrintGroup Fields
PrintGroup Class See Also Send Feedback

The PrintGroup type exposes the following members.

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

PrintGroup Class


PrintGroup Methods

[image] [image]

Pastel Evolution SDK
PrintGroup Methods
PrintGroup Class See Also Send Feedback

The PrintGroup type exposes the following members.

Methods

 | Name | Description
Public method | AddDocument | Appends a document to the print group.
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds a record's database ID.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | List | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Not supported. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | RemoveDocument | Removes a document from the print group.
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

PrintGroup Class


PrintGroup.AddDocument Method

[image]

Pastel Evolution SDK
PrintGroup..::..AddDocument Method
PrintGroup Class See Also Send Feedback
Appends a document to the print group.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void AddDocument(
    OrderBase document
)
Visual Basic
Public Sub AddDocument (
    document As OrderBase
)

Parameters

document
Type: Pastel.Evolution..::..OrderBase
Specifies the document.

See Also

PrintGroup Class
PrintGroup Members


PrintGroup.Find Method

[image]

Pastel Evolution SDK
PrintGroup..::..Find Method
PrintGroup Class See Also Send Feedback
Finds a record's database ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String
Specifies the criteria.

Return Value

Type: Int32
The ID of the first record found; -1 if not record was found.

See Also

PrintGroup Class
PrintGroup Members


PrintGroup.List Method

[image]

Pastel Evolution SDK
PrintGroup..::..List Method
PrintGroup Class See Also Send Feedback
Gets a list of database records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DataTable List(
    string criteria
)
Visual Basic
Public Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.

Return Value

Type: DataTable
Table containing selected records.

See Also

PrintGroup Class
PrintGroup Members


PrintGroup.OnDelete Method

[image]

Pastel Evolution SDK
PrintGroup..::..OnDelete Method
PrintGroup Class See Also Send Feedback
Not supported.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

See Also

PrintGroup Class
PrintGroup Members


PrintGroup.OnSave Method

[image]

Pastel Evolution SDK
PrintGroup..::..OnSave Method
PrintGroup Class See Also Send Feedback
Persists the record to the database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

PrintGroup Class
PrintGroup Members


PrintGroup.RemoveDocument Method

[image]

Pastel Evolution SDK
PrintGroup..::..RemoveDocument Method
PrintGroup Class See Also Send Feedback
Removes a document from the print group.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void RemoveDocument(
    OrderBase document
)
Visual Basic
Public Sub RemoveDocument (
    document As OrderBase
)

Parameters

document
Type: Pastel.Evolution..::..OrderBase

See Also

PrintGroup Class
PrintGroup Members


PrintGroup Properties

[image] [image]

Pastel Evolution SDK
PrintGroup Properties
PrintGroup Class See Also Send Feedback

The PrintGroup type exposes the following members.

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Description | Gets or sets the record description.
Public property | DocumentIDs | Gets the print group's ArrayList of document ID's.
Public property | DocumentType | Gets the print group's document type.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)

See Also

PrintGroup Class


PrintGroup.Description Property

[image]

Pastel Evolution SDK
PrintGroup..::..Description Property
PrintGroup Class See Also Send Feedback
Gets or sets the record description.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set

Property Value

Type: String

See Also

PrintGroup Class
PrintGroup Members


PrintGroup.DocumentIDs Property

[image]

Pastel Evolution SDK
PrintGroup..::..DocumentIDs Property
PrintGroup Class See Also Send Feedback
Gets the print group's ArrayList of document ID's.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public ArrayList DocumentIDs { get; }
Visual Basic
Public ReadOnly Property DocumentIDs As ArrayList
    Get

Property Value

Type: ArrayList

Remarks

This list is updated by AddDocument and RemoveDocument.

See Also

PrintGroup Class
PrintGroup Members
Pastel.Evolution Namespace
PrintGroup..::..AddDocument(OrderBase)
PrintGroup..::..RemoveDocument(OrderBase)


PrintGroup.DocumentType Property

[image]

Pastel Evolution SDK
PrintGroup..::..DocumentType Property
PrintGroup Class See Also Send Feedback
Gets the print group's document type.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DocumentType DocumentType { get; }
Visual Basic
Public ReadOnly Property DocumentType As DocumentType
    Get

Property Value

Type: DocumentType

Remarks

Only documents with a matching document type can be added to the print group.

See Also

PrintGroup Class
PrintGroup Members


PrintGroup.ID Property

[image]

Pastel Evolution SDK
PrintGroup..::..ID Property
PrintGroup Class See Also Send Feedback
Gets the internal record ID (0 for new, unsaved records).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

See Also

PrintGroup Class
PrintGroup Members


PrintGroup.LongID Property

[image]

Pastel Evolution SDK
PrintGroup..::..LongID Property
PrintGroup Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

PrintGroup Class
PrintGroup Members


Priority Class

[image]

Pastel Evolution SDK
Priority Class
Members See Also Send Feedback
Represents an incident priority.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class Priority : BranchedRecordBase
Visual Basic
Public Class Priority
    Inherits BranchedRecordBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..Priority

See Also

Priority Members


Priority Members

[image] [image]

Pastel Evolution SDK
Priority Members
Priority Class Constructors Methods Fields Properties See Also Send Feedback

The Priority type exposes the following members.

Constructors

 | Name | Description
Public method | Priority()()()() | Creates a new instance of a priority.
Public method | Priority(Int32) | Creates a new instance of a priority.
Public method | Priority(String) | Creates a new instance of a priority.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds a record's database ID.
Public method | GetDefault |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | List | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Colour | Gets or sets the priority's colour.
Public property | Description | Gets or sets the record description.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | IsDefault | Gets whether or not the priority is the default priority.
Public property | LongID | (Overrides RecordBase..::..LongID.)

See Also

Priority Class


Priority Constructor

[image] [image]

Pastel Evolution SDK
Priority Constructor
Priority Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Priority()()()() | Creates a new instance of a priority.
Public method | Priority(Int32) | Creates a new instance of a priority.
Public method | Priority(String) | Creates a new instance of a priority.

See Also

Priority Class
Priority Members


Priority Constructor

[image]

Pastel Evolution SDK
Priority Constructor
Priority Class See Also Send Feedback
Creates a new instance of a priority.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Priority()
Visual Basic
Public Sub New

See Also

Priority Class
Priority Members
Priority Overload


Priority Constructor (Int32)

[image]

Pastel Evolution SDK
Priority Constructor (Int32)
Priority Class See Also Send Feedback
Creates a new instance of a priority.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Priority(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32
Specifies the id of the existing record.

See Also

Priority Class
Priority Members
Priority Overload


Priority Constructor (String)

[image]

Pastel Evolution SDK
Priority Constructor (String)
Priority Class See Also Send Feedback
Creates a new instance of a priority.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Priority(
    string description
)
Visual Basic
Public Sub New (
    description As String
)

Parameters

description
Type: System..::..String
Specifies the description of the existing record.

See Also

Priority Class
Priority Members
Priority Overload


Priority Fields

[image] [image]

Pastel Evolution SDK
Priority Fields
Priority Class See Also Send Feedback

The Priority type exposes the following members.

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

Priority Class


Priority Methods

[image] [image]

Pastel Evolution SDK
Priority Methods
Priority Class See Also Send Feedback

The Priority type exposes the following members.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds a record's database ID.
Public method | GetDefault |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | List | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

Priority Class


Priority.Find Method

[image]

Pastel Evolution SDK
Priority..::..Find Method
Priority Class See Also Send Feedback
Finds a record's database ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.

Return Value

Type: Int32
The ID of the first record found; -1 if not record was found.

See Also

Priority Class
Priority Members


Priority.GetDefault Method

[image]

Pastel Evolution SDK
Priority..::..GetDefault Method
Priority Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Priority GetDefault()
Visual Basic
Public Function GetDefault As Priority

Return Value

Type: Priority

See Also

Priority Class
Priority Members


Priority.List Method

[image]

Pastel Evolution SDK
Priority..::..List Method
Priority Class See Also Send Feedback
Gets a list of database records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DataTable List(
    string criteria
)
Visual Basic
Public Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.

Return Value

Type: DataTable
Table containing selected records.

See Also

Priority Class
Priority Members


Priority.OnDelete Method

[image]

Pastel Evolution SDK
Priority..::..OnDelete Method
Priority Class See Also Send Feedback
Removes the record from the database, provided it is not referenced by other records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

See Also

Priority Class
Priority Members


Priority.OnSave Method

[image]

Pastel Evolution SDK
Priority..::..OnSave Method
Priority Class See Also Send Feedback
Persists the record to the database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

Priority Class
Priority Members


Priority Properties

[image] [image]

Pastel Evolution SDK
Priority Properties
Priority Class See Also Send Feedback

The Priority type exposes the following members.

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Colour | Gets or sets the priority's colour.
Public property | Description | Gets or sets the record description.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | IsDefault | Gets whether or not the priority is the default priority.
Public property | LongID | (Overrides RecordBase..::..LongID.)

See Also

Priority Class


Priority.Colour Property

[image]

Pastel Evolution SDK
Priority..::..Colour Property
Priority Class See Also Send Feedback
Gets or sets the priority's colour.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int Colour { get; set; }
Visual Basic
Public Property Colour As Integer
    Get
    Set

Property Value

Type: Int32

Remarks

Accepts a value between 0 and 255.

See Also

Priority Class
Priority Members


Priority.Description Property

[image]

Pastel Evolution SDK
Priority..::..Description Property
Priority Class See Also Send Feedback
Gets or sets the record description.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set

Property Value

Type: String

See Also

Priority Class
Priority Members


Priority.ID Property

[image]

Pastel Evolution SDK
Priority..::..ID Property
Priority Class See Also Send Feedback
Gets the internal record ID (0 for new, unsaved records).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

Remarks

Once saved, the ID will reflect the record's internal database identifier.

See Also

Priority Class
Priority Members


Priority.IsDefault Property

[image]

Pastel Evolution SDK
Priority..::..IsDefault Property
Priority Class See Also Send Feedback
Gets whether or not the priority is the default priority.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool IsDefault { get; }
Visual Basic
Public ReadOnly Property IsDefault As Boolean
    Get

Property Value

Type: Boolean

See Also

Priority Class
Priority Members


Priority.LongID Property

[image]

Pastel Evolution SDK
Priority..::..LongID Property
Priority Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

Priority Class
Priority Members


Project Class

[image]

Pastel Evolution SDK
Project Class
Members See Also Send Feedback
Represents a project.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class Project : BranchedRecordBase
Visual Basic
Public Class Project
    Inherits BranchedRecordBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..Project

See Also

Project Members


Project Members

[image] [image]

Pastel Evolution SDK
Project Members
Project Class Constructors Methods Fields Properties See Also Send Feedback

The Project type exposes the following members.

Constructors

 | Name | Description
Public method | Project()()()() | Creates a new instance of a project.
Public method | Project(Int32) | Creates a new instance of a project.
Public method | Project(String) | Creates a new instance of a project.

Methods

 | Name | Description
 | _ListCurrentBranch |
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds a project ID.
 | FindByCode | Attempts to find a project by its code and returns its ID.
 | Get | Returns an instance of the first record satisfying the criteria specified; otherwise, returns null.
 | GetByCode | Returns an instance of the first record with the code specified; otherwise, returns null.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | Active | Gets or sets the record's operational state.
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Code | Gets or sets the project code.
Public property | Description | Gets or sets the project description (name, in this case).
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | ProjectDescription | Gets or sets the project's description.

See Also

Project Class


Project Constructor

[image] [image]

Pastel Evolution SDK
Project Constructor
Project Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Project()()()() | Creates a new instance of a project.
Public method | Project(Int32) | Creates a new instance of a project.
Public method | Project(String) | Creates a new instance of a project.

See Also

Project Class
Project Members


Project Constructor

[image]

Pastel Evolution SDK
Project Constructor
Project Class See Also Send Feedback
Creates a new instance of a project.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Project()
Visual Basic
Public Sub New

See Also

Project Class
Project Members
Project Overload


Project Constructor (Int32)

[image]

Pastel Evolution SDK
Project Constructor (Int32)
Project Class See Also Send Feedback
Creates a new instance of a project.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Project(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32
Specifies the id of the existing record.

See Also

Project Class
Project Members
Project Overload


Project Constructor (String)

[image]

Pastel Evolution SDK
Project Constructor (String)
Project Class See Also Send Feedback
Creates a new instance of a project.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Project(
    string code
)
Visual Basic
Public Sub New (
    code As String
)

Parameters

code
Type: System..::..String
Specifies the code of the existing record.

See Also

Project Class
Project Members
Project Overload


Project Fields

[image] [image]

Pastel Evolution SDK
Project Fields
Project Class See Also Send Feedback

The Project type exposes the following members.

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

Project Class


Project Methods

[image] [image]

Pastel Evolution SDK
Project Methods
Project Class See Also Send Feedback

The Project type exposes the following members.

Methods

 | Name | Description
 | _ListCurrentBranch |
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds a project ID.
 | FindByCode | Attempts to find a project by its code and returns its ID.
 | Get | Returns an instance of the first record satisfying the criteria specified; otherwise, returns null.
 | GetByCode | Returns an instance of the first record with the code specified; otherwise, returns null.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

Project Class


Project._ListCurrentBranch Method

[image]

Pastel Evolution SDK
Project..::.._ListCurrentBranch Method
Project Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable _ListCurrentBranch(
    string criteria
)
Visual Basic
Public Shared Function _ListCurrentBranch (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String

Return Value

Type: DataTable

See Also

Project Class
Project Members


Project.Find Method

[image]

Pastel Evolution SDK
Project..::..Find Method
Project Class See Also Send Feedback
Finds a project ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String
The criteria passed to the SQL query. Eg. ProjectCode = 'INT001' or ProjectName like '%Internal%'

Return Value

Type: Int32
The ID of the first record found; -1 if not record was found.

See Also

Project Class
Project Members


Project.FindByCode Method

[image]

Pastel Evolution SDK
Project..::..FindByCode Method
Project Class See Also Send Feedback
Attempts to find a project by its code and returns its ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int FindByCode(
    string code
)
Visual Basic
Public Shared Function FindByCode (
    code As String
) As Integer

Parameters

code
Type: System..::..String
The code used to lookup the project.

Return Value

Type: Int32
-1 if no record was found, else the id of the first record matching the criteria supplied.

See Also

Project Class
Project Members
Pastel.Evolution Namespace
Project..::..Find(String)


Project.Get Method

[image]

Pastel Evolution SDK
Project..::..Get Method
Project Class See Also Send Feedback
Returns an instance of the first record satisfying the criteria specified; otherwise, returns null.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static Project Get(
    string criteria
)
Visual Basic
Public Shared Function Get (
    criteria As String
) As Project

Parameters

criteria
Type: System..::..String
The criteria passed to the SQL query. Eg. ProjectCode = 'INT001' or ProjectName like '%Internal%'

Return Value

Type: Project
The record found; otherwise null

See Also

Project Class
Project Members
Pastel.Evolution Namespace
Project..::..Find(String)
Project..::..Project(String)
Project..::..GetByCode(String)


Project.GetByCode Method

[image]

Pastel Evolution SDK
Project..::..GetByCode Method
Project Class See Also Send Feedback
Returns an instance of the first record with the code specified; otherwise, returns null.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static Project GetByCode(
    string code
)
Visual Basic
Public Shared Function GetByCode (
    code As String
) As Project

Parameters

code
Type: System..::..String
Specifies the code.

Return Value

Type: Project
The record found; otherwise null

See Also

Project Class
Project Members
Pastel.Evolution Namespace
Project..::..Get(String)
Project..::..Project(String)
Project..::..Find(String)


Project.List Method

[image]

Pastel Evolution SDK
Project..::..List Method
Project Class See Also Send Feedback
Gets a list of database records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria
)
Visual Basic
Public Shared Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.

Return Value

Type: DataTable
Table containing selected records.

See Also

Project Class
Project Members


Project.OnDelete Method

[image]

Pastel Evolution SDK
Project..::..OnDelete Method
Project Class See Also Send Feedback
Removes the record from the database, provided it is not referenced by other records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

See Also

Project Class
Project Members


Project.OnSave Method

[image]

Pastel Evolution SDK
Project..::..OnSave Method
Project Class See Also Send Feedback
Persists the record to the database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

Project Class
Project Members


Project Properties

[image] [image]

Pastel Evolution SDK
Project Properties
Project Class See Also Send Feedback

The Project type exposes the following members.

Properties

 | Name | Description
Public property | Active | Gets or sets the record's operational state.
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Code | Gets or sets the project code.
Public property | Description | Gets or sets the project description (name, in this case).
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | ProjectDescription | Gets or sets the project's description.

See Also

Project Class


Project.Active Property

[image]

Pastel Evolution SDK
Project..::..Active Property
Project Class See Also Send Feedback
Gets or sets the record's operational state.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool Active { get; set; }
Visual Basic
Public Property Active As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

Project Class
Project Members


Project.Code Property

[image]

Pastel Evolution SDK
Project..::..Code Property
Project Class See Also Send Feedback
Gets or sets the project code.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Code { get; set; }
Visual Basic
Public Property Code As String
    Get
    Set

Property Value

Type: String

See Also

Project Class
Project Members


Project.Description Property

[image]

Pastel Evolution SDK
Project..::..Description Property
Project Class See Also Send Feedback
Gets or sets the project description (name, in this case).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set

Property Value

Type: String

See Also

Project Class
Project Members


Project.ID Property

[image]

Pastel Evolution SDK
Project..::..ID Property
Project Class See Also Send Feedback
Gets the internal record ID (0 for new, unsaved records).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

Remarks

Once saved, the ID will reflect the record's internal database identifier.

See Also

Project Class
Project Members


Project.LongID Property

[image]

Pastel Evolution SDK
Project..::..LongID Property
Project Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

Project Class
Project Members


Project.ProjectDescription Property

[image]

Pastel Evolution SDK
Project..::..ProjectDescription Property
Project Class See Also Send Feedback
Gets or sets the project's description.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string ProjectDescription { get; set; }
Visual Basic
Public Property ProjectDescription As String
    Get
    Set

Property Value

Type: String

See Also

Project Class
Project Members


PropertyDirection Enumeration

[image]

Pastel Evolution SDK
PropertyDirection Enumeration
See Also Send Feedback
Describes whether a Property's Direction is a Value or Percentage.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public enum PropertyDirection
Visual Basic
Public Enumeration PropertyDirection

Members

Member name | Value | Description
Value | 0 |
Percentage | 1 |

See Also

Pastel.Evolution Namespace


Prospect Class

[image]

Pastel Evolution SDK
Prospect Class
Members See Also Send Feedback
Represents a Contact Management prospective customer.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class Prospect : BranchedRecordBase
Visual Basic
Public Class Prospect
    Inherits BranchedRecordBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..Prospect

See Also

Prospect Members


Prospect Members

[image] [image]

Pastel Evolution SDK
Prospect Members
Prospect Class Constructors Methods Fields Properties See Also Send Feedback

The Prospect type exposes the following members.

Constructors

 | Name | Description
Public method | Prospect()()()() | Creates a new instance of a prospect.
Public method | Prospect(Int32) | Creates a new instance of a prospect.
Public method | Prospect(String) | Creates a new instance of a prospect.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find |
 | FindByCompanyName | Attempts to find a Prospect by its Company Name and returns its ID.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | Agent | Gets or sets the agent to whom the prospect belongs. Prospects can be hidden from other agents by setting IsPublic to false.
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | ChargeTax | Gets or sets whether the account is taxed (on quotations etc.)
Public property | CompanyName |
Public property | Description |
Public property | EmailAddress |
Public property | Fax |
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | IsPublic | Gets or sets whether or not the prospect is visible to agents other than the assigned agent.
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | Module |
Public property | PhysicalAddress | Gets or sets the account's physical address.
Public property | PostalAddress | Gets or sets the account's postal address.
Public property | Representative | Gets or sets the Sales Representative.
Public property | RepresentativeID | Gets or sets the Sales Representative ID.
Public property | Telephone |
Public property | UserFields |
Public property | Webpage |

See Also

Prospect Class


Prospect Constructor

[image] [image]

Pastel Evolution SDK
Prospect Constructor
Prospect Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Prospect()()()() | Creates a new instance of a prospect.
Public method | Prospect(Int32) | Creates a new instance of a prospect.
Public method | Prospect(String) | Creates a new instance of a prospect.

See Also

Prospect Class
Prospect Members


Prospect Constructor

[image]

Pastel Evolution SDK
Prospect Constructor
Prospect Class See Also Send Feedback
Creates a new instance of a prospect.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Prospect()
Visual Basic
Public Sub New

See Also

Prospect Class
Prospect Members
Prospect Overload


Prospect Constructor (Int32)

[image]

Pastel Evolution SDK
Prospect Constructor (Int32)
Prospect Class See Also Send Feedback
Creates a new instance of a prospect.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Prospect(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32
Specifies the id of the existing record.

See Also

Prospect Class
Prospect Members
Prospect Overload


Prospect Constructor (String)

[image]

Pastel Evolution SDK
Prospect Constructor (String)
Prospect Class See Also Send Feedback
Creates a new instance of a prospect.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Prospect(
    string companyName
)
Visual Basic
Public Sub New (
    companyName As String
)

Parameters

companyName
Type: System..::..String
Specifies the companyName of the existing record.

See Also

Prospect Class
Prospect Members
Prospect Overload


Prospect Fields

[image] [image]

Pastel Evolution SDK
Prospect Fields
Prospect Class See Also Send Feedback

The Prospect type exposes the following members.

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

Prospect Class


Prospect Methods

[image] [image]

Pastel Evolution SDK
Prospect Methods
Prospect Class See Also Send Feedback

The Prospect type exposes the following members.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find |
 | FindByCompanyName | Attempts to find a Prospect by its Company Name and returns its ID.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

Prospect Class


Prospect.Find Method

[image]

Pastel Evolution SDK
Prospect..::..Find Method
Prospect Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String

Return Value

Type: Int32

See Also

Prospect Class
Prospect Members


Prospect.FindByCompanyName Method

[image]

Pastel Evolution SDK
Prospect..::..FindByCompanyName Method
Prospect Class See Also Send Feedback
Attempts to find a Prospect by its Company Name and returns its ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int FindByCompanyName(
    string companyName
)
Visual Basic
Public Shared Function FindByCompanyName (
    companyName As String
) As Integer

Parameters

companyName
Type: System..::..String
The Company Name used to lookup the prospect.

Return Value

Type: Int32
-1 if no record was found, else the id of the first account matching the criteria supplied.

See Also

Prospect Class
Prospect Members
Pastel.Evolution Namespace
Prospect..::..Find(String)


Prospect.List Method

[image]

Pastel Evolution SDK
Prospect..::..List Method
Prospect Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria
)
Visual Basic
Public Shared Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String

Return Value

Type: DataTable

See Also

Prospect Class
Prospect Members


Prospect.OnDelete Method

[image]

Pastel Evolution SDK
Prospect..::..OnDelete Method
Prospect Class See Also Send Feedback
Removes the record from the database, provided it is not referenced by other records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

Exceptions

Exception | Condition
IntegrityViolationException |

See Also

Prospect Class
Prospect Members


Prospect.OnSave Method

[image]

Pastel Evolution SDK
Prospect..::..OnSave Method
Prospect Class See Also Send Feedback
Persists the record to the database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

Prospect Class
Prospect Members


Prospect Properties

[image] [image]

Pastel Evolution SDK
Prospect Properties
Prospect Class See Also Send Feedback

The Prospect type exposes the following members.

Properties

 | Name | Description
Public property | Agent | Gets or sets the agent to whom the prospect belongs. Prospects can be hidden from other agents by setting IsPublic to false.
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | ChargeTax | Gets or sets whether the account is taxed (on quotations etc.)
Public property | CompanyName |
Public property | Description |
Public property | EmailAddress |
Public property | Fax |
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | IsPublic | Gets or sets whether or not the prospect is visible to agents other than the assigned agent.
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | Module |
Public property | PhysicalAddress | Gets or sets the account's physical address.
Public property | PostalAddress | Gets or sets the account's postal address.
Public property | Representative | Gets or sets the Sales Representative.
Public property | RepresentativeID | Gets or sets the Sales Representative ID.
Public property | Telephone |
Public property | UserFields |
Public property | Webpage |

See Also

Prospect Class


Prospect.Agent Property

[image]

Pastel Evolution SDK
Prospect..::..Agent Property
Prospect Class See Also Send Feedback
Gets or sets the agent to whom the prospect belongs. Prospects can be hidden from other agents by setting IsPublic to false.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Agent Agent { get; set; }
Visual Basic
Public Property Agent As Agent
    Get
    Set

Property Value

Type: Agent

See Also

Prospect Class
Prospect Members


Prospect.ChargeTax Property

[image]

Pastel Evolution SDK
Prospect..::..ChargeTax Property
Prospect Class See Also Send Feedback
Gets or sets whether the account is taxed (on quotations etc.)

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool ChargeTax { get; set; }
Visual Basic
Public Property ChargeTax As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

Prospect Class
Prospect Members


Prospect.CompanyName Property

[image]

Pastel Evolution SDK
Prospect..::..CompanyName Property
Prospect Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string CompanyName { get; set; }
Visual Basic
Public Property CompanyName As String
    Get
    Set

Property Value

Type: String

See Also

Prospect Class
Prospect Members


Prospect.Description Property

[image]

Pastel Evolution SDK
Prospect..::..Description Property
Prospect Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set

Property Value

Type: String

See Also

Prospect Class
Prospect Members


Prospect.EmailAddress Property

[image]

Pastel Evolution SDK
Prospect..::..EmailAddress Property
Prospect Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string EmailAddress { get; set; }
Visual Basic
Public Property EmailAddress As String
    Get
    Set

Property Value

Type: String

See Also

Prospect Class
Prospect Members


Prospect.Fax Property

[image]

Pastel Evolution SDK
Prospect..::..Fax Property
Prospect Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Fax { get; set; }
Visual Basic
Public Property Fax As String
    Get
    Set

Property Value

Type: String

See Also

Prospect Class
Prospect Members


Prospect.ID Property

[image]

Pastel Evolution SDK
Prospect..::..ID Property
Prospect Class See Also Send Feedback
Gets the internal record ID (0 for new, unsaved records).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

See Also

Prospect Class
Prospect Members


Prospect.IsPublic Property

[image]

Pastel Evolution SDK
Prospect..::..IsPublic Property
Prospect Class See Also Send Feedback
Gets or sets whether or not the prospect is visible to agents other than the assigned agent.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool IsPublic { get; set; }
Visual Basic
Public Property IsPublic As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

Prospect Class
Prospect Members


Prospect.LongID Property

[image]

Pastel Evolution SDK
Prospect..::..LongID Property
Prospect Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

Prospect Class
Prospect Members


Prospect.Module Property

[image]

Pastel Evolution SDK
Prospect..::..Module Property
Prospect Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Module Module { get; }
Visual Basic
Public ReadOnly Property Module As Module
    Get

Property Value

Type: Module

See Also

Prospect Class
Prospect Members


Prospect.PhysicalAddress Property

[image]

Pastel Evolution SDK
Prospect..::..PhysicalAddress Property
Prospect Class See Also Send Feedback
Gets or sets the account's physical address.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Address PhysicalAddress { get; set; }
Visual Basic
Public Property PhysicalAddress As Address
    Get
    Set

Property Value

Type: Address

See Also

Prospect Class
Prospect Members


Prospect.PostalAddress Property

[image]

Pastel Evolution SDK
Prospect..::..PostalAddress Property
Prospect Class See Also Send Feedback
Gets or sets the account's postal address.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Address PostalAddress { get; set; }
Visual Basic
Public Property PostalAddress As Address
    Get
    Set

Property Value

Type: Address

See Also

Prospect Class
Prospect Members


Prospect.Representative Property

[image]

Pastel Evolution SDK
Prospect..::..Representative Property
Prospect Class See Also Send Feedback
Gets or sets the Sales Representative.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public SalesRepresentative Representative { get; set; }
Visual Basic
Public Property Representative As SalesRepresentative
    Get
    Set

Property Value

Type: SalesRepresentative

See Also

Prospect Class
Prospect Members


Prospect.RepresentativeID Property

[image]

Pastel Evolution SDK
Prospect..::..RepresentativeID Property
Prospect Class See Also Send Feedback
Gets or sets the Sales Representative ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int RepresentativeID { get; set; }
Visual Basic
Public Property RepresentativeID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

Prospect Class
Prospect Members


Prospect.Telephone Property

[image]

Pastel Evolution SDK
Prospect..::..Telephone Property
Prospect Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Telephone { get; set; }
Visual Basic
Public Property Telephone As String
    Get
    Set

Property Value

Type: String

See Also

Prospect Class
Prospect Members


Prospect.UserFields Property

[image]

Pastel Evolution SDK
Prospect..::..UserFields Property
Prospect Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public FieldCollection UserFields { get; }
Visual Basic
Public ReadOnly Property UserFields As FieldCollection
    Get

Property Value

Type: FieldCollection

See Also

Prospect Class
Prospect Members


Prospect.Webpage Property

[image]

Pastel Evolution SDK
Prospect..::..Webpage Property
Prospect Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Webpage { get; set; }
Visual Basic
Public Property Webpage As String
    Get
    Set

Property Value

Type: String

See Also

Prospect Class
Prospect Members


PurchaseOrder Class

[image]

Pastel Evolution SDK
PurchaseOrder Class
Members See Also Send Feedback
Representation a Purchase Order document.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class PurchaseOrder : PurchasesDocumentBase
Visual Basic
Public Class PurchaseOrder
    Inherits PurchasesDocumentBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..OrderBase
Pastel.Evolution..::..PurchasesDocumentBase
Pastel.Evolution..::..PurchaseOrder

See Also

PurchaseOrder Members


PurchaseOrder Members

[image] [image]

Pastel Evolution SDK
PurchaseOrder Members
PurchaseOrder Class Constructors Methods Fields Properties See Also Send Feedback

The PurchaseOrder type exposes the following members.

Constructors

 | Name | Description
Public method | PurchaseOrder()()()() | Creates a new instance of a purchase order.
Public method | PurchaseOrder(Int32) | Creates a new instance of a purchase order.
Public method | PurchaseOrder(String) | Creates a new instance of an existing purchase order.
Public method | PurchaseOrder(String, String) | Creates an instance of an existing unprocessed supplier invoice having the given purchase order and grv numbers.

Methods

 | Name | Description
Public method | _SetFullQtyToProcess | (Inherited from OrderBase.)
Protected method | BeforePostGLBatch | (Overrides OrderBase..::..BeforePostGLBatch(OrderBase, CancelEventArgs).)
Protected method | BeforePostInventory | (Overrides OrderBase..::..BeforePostInventory(OrderBase, CancelEventArgs).)
Protected method | BeforePostLedger | (Overrides OrderBase..::..BeforePostLedger(OrderBase, CancelEventArgs).)
Protected method | BeforeSave | (Inherited from OrderBase.)
Protected method | cascadeForeignValues | (Inherited from OrderBase.)
Protected method | cascadeProject | (Inherited from OrderBase.)
Protected method | cascadeTaxRate | (Inherited from OrderBase.)
Public method | Complete()()()() | Processes (invoices) all outstanding quantities on the order. The entire invoice fails if one or more detail lines do not have sufficient stock available. The CompleteMax method (SalesOrder only) is a variation on this method and attempts to confirm as much of the ordered stock as is available. (Inherited from OrderBase.)
Public method | Complete(String) | Process (invoice) all outstanding quantities on the order. The entire invoice fails if one or more detail lines do not have sufficient stock available. The method is a variation on this method and attempts to confirm as much of the ordered stock as is available. (Inherited from OrderBase.)
Public method | CompleteStock()()()() | Processes a stock receipt (maximum quantity) without posting a supplier invoice. Only allowed when supplier invoice/GRV separation is enabled in purchase order defaults.
Public method | CompleteStock(String) | Processes a stock receipt (maximum quantity) without posting a supplier invoice. Only allowed when supplier invoice/GRV separation is enabled in purchase order defaults.
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Protected method | Detach | (Overrides OrderBase..::..Detach()()()().)
Protected method | detailRemainsOutstanding | (Inherited from OrderBase.)
Protected method | detailToProcess | (Inherited from OrderBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds and returns the id of the first order matching the supplied criteria. E.g. OrderNum = 'PO0001'
Protected method | fullQtySelected | (Inherited from OrderBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | glCreditPosting | (Overrides OrderBase..::..glCreditPosting(TransactionBase, TransactionBase..::..GLPostingEventArgs).)
Protected method | glDebitPosting | (Overrides OrderBase..::..glDebitPosting(TransactionBase, TransactionBase..::..GLPostingEventArgs).)
Protected method | initialise | (Overrides OrderBase..::..initialise()()()().)
 | List | Lists outstanding orders for the supplied criteria.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Not supported. Use the delete facility from inside Evolution. (Inherited from OrderBase.)
Protected method | OnSave | (Overrides PurchasesDocumentBase..::..OnSave()()()().)
Public method | Process()()()() | Posts the document to the various accounts and ledgers applicable. (Inherited from OrderBase.)
Public method | Process(String) | Posts the document to the various accounts and ledgers applicable. (Overrides OrderBase..::..Process(String).)
Public method | ProcessStock()()()() | Processes a stock receipt without posting a supplier invoice. Only allowed when supplier invoice/GRV separation is enabled in purchase order defaults.
Public method | ProcessStock(String) | Processes a stock receipt without posting a supplier invoice. Only allowed when supplier invoice/GRV separation is enabled in purchase order defaults.
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | account | (Inherited from OrderBase.)
Protected field | archID | (Inherited from OrderBase.)
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | currency | (Inherited from OrderBase.)
Protected field | dcTran | (Inherited from OrderBase.)
Protected field | deliverTo | (Inherited from OrderBase.)
Protected field | deliveryMethod | (Inherited from OrderBase.)
Protected field | detail | (Inherited from OrderBase.)
Protected field | glBatch | (Inherited from OrderBase.)
Protected field | invoiceTo | (Inherited from OrderBase.)
Protected field | orderPriority | (Inherited from OrderBase.)
Protected field | orderStatus | (Inherited from OrderBase.)
Protected field | originalDocument | (Inherited from OrderBase.)
Protected field | processingAdditionalCosts | (Inherited from OrderBase.)
Protected field | processLedger | Should the document process to AR or AP ledger? (Inherited from OrderBase.)
Protected field | processStock | (Inherited from OrderBase.)
Protected field | project | (Inherited from OrderBase.)
Protected field | prospect | (Inherited from OrderBase.)
Protected field | settlementTerms | (Inherited from OrderBase.)
Protected field | taxType | (Inherited from OrderBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | Account | Gets or sets the AR or AP account associated with the order. (Inherited from OrderBase.)
Public property | AccountID | Gets or sets the ID of the AR or AP account associated with the order. (Inherited from OrderBase.)
Public property | AdditionalCosts | (Inherited from PurchasesDocumentBase.)
Public property | AllowInvoiceRounding | (Inherited from OrderBase.)
Public property | ApplyTaxPerLine | Gets or sets whether tax per line should be applied. (Inherited from OrderBase.)
Public property | Audit | Gets the audit number of the last transaction processed by this document. This value defaults to 0, and will not be available on recalled documents. (Inherited from OrderBase.)
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Currency | Gets or sets the currency. (Inherited from OrderBase.)
Public property | CurrencyID | Gets or sets the document's currency ID. (Inherited from OrderBase.)
Public property | DeliverTo | Gets or sets the delivery address. (Inherited from OrderBase.)
Public property | DeliveryDate | Gets or sets the delivery date. (Inherited from OrderBase.)
Public property | DeliveryMethod | Gets or sets the delivery method. (Inherited from OrderBase.)
Public property | DeliveryMethodID | Gets or sets the delivery method ID. (Inherited from OrderBase.)
Public property | Description | Gets or sets the document description. This will also be the description on any transactions posted. (Inherited from OrderBase.)
Public property | Detail | Gets the order detail collection representing the body of the document. (Inherited from OrderBase.)
Public property | Discount | Gets or sets the document discount amount (applicable to tax excl. total), (Inherited from OrderBase.)
Public property | DiscountForeign | Gets or sets the document foreign discount amount (applicable to tax excl. total), (Inherited from OrderBase.)
Public property | DiscountLastProcessed | Gets the document discount amount last processed. (Inherited from OrderBase.)
Public property | DiscountPercent | Gets or sets the document discount percentage. (Inherited from OrderBase.)
Public property | DiscountToProcess | Gets the document discount amount about to be processed (applicable to tax excl. total). (Inherited from OrderBase.)
Public property | DueDate | Gets or sets the due date. (Inherited from OrderBase.)
Public property | ExchangeRate | Gets or sets the exchange rate. (Inherited from OrderBase.)
Public property | ExternalOrderNo | Gets or sets the external order number. (Inherited from OrderBase.)
Protected property | grossLastProcessTotal | (Inherited from OrderBase.)
Protected property | grossLastProcessTotalForeign | (Inherited from OrderBase.)
Protected property | grossOutstTotal | (Inherited from OrderBase.)
Protected property | grossOutstTotalForeign | (Inherited from OrderBase.)
Protected property | grossToProcessTotal | (Inherited from OrderBase.)
Protected property | grossToProcessTotalForeign | (Inherited from OrderBase.)
Protected property | grossTotal | (Inherited from OrderBase.)
Protected property | grossTotalForeign | (Inherited from OrderBase.)
Public property | GrvState | Gets the phase of this goods receiving document, either a goods received note or a supplier invoice.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Inherited from OrderBase.)
Public property | InvoiceDate | Gets or sets the invoice date. (Inherited from OrderBase.)
Public property | InvoiceTo | Gets or sets the invoice address. (Inherited from OrderBase.)
Public property | IsLoading | Will be true while the order is busy loading detail. (Inherited from OrderBase.)
Public property | IsPartialProcessingAllowed | (Inherited from OrderBase.)
Public property | IsProcessing | Will be true while the order is busy processing transactions. (Inherited from OrderBase.)
Public property | LedgerTransaction | Gets the last ledger transaction (AR/AP Transaction) posted. (Inherited from OrderBase.)
Protected property | lineAdditionalCostTotal | (Inherited from OrderBase.)
Public property | LongID | (Inherited from OrderBase.)
Public property | MessageLine1 | Gets or sets the 1st message line. (Inherited from OrderBase.)
Public property | MessageLine2 | Gets or sets the 2nd message line. (Inherited from OrderBase.)
Public property | MessageLine3 | Gets or sets the 3rd message line. (Inherited from OrderBase.)
Protected property | nettLastProcessTotal | (Inherited from OrderBase.)
Protected property | nettLastProcessTotalForeign | (Inherited from OrderBase.)
Protected property | nettOutstTotal | (Inherited from OrderBase.)
Protected property | nettOutstTotalForeign | (Inherited from OrderBase.)
Protected property | nettToProcessTotal | (Inherited from OrderBase.)
Protected property | nettToProcessTotalForeign | (Inherited from OrderBase.)
Public property | OrderDate | Gets or sets the order date. (Inherited from OrderBase.)
Public property | OrderNo | Gets or sets the order number. (Inherited from OrderBase.)
Public property | OrderPriority | Gets or sets the order priority. (Inherited from OrderBase.)
Public property | OrderPriorityID | Gets or sets the order priority ID. (Inherited from OrderBase.)
Public property | OrderStatus | Gets or sets the document's order status. (Inherited from OrderBase.)
Public property | OrderStatusID | Gets or sets the order status ID. (Inherited from OrderBase.)
Public property | OriginalDocument | (Overrides OrderBase..::..OriginalDocument.)
Public property | PrintCount | Gets or sets the print count. (Inherited from OrderBase.)
Public property | Project | Gets or sets the project. (Inherited from OrderBase.)
Public property | ProjectID | Gets or sets the project ID. (Inherited from OrderBase.)
Public property | Prospect | (Inherited from OrderBase.)
Public property | ProspectID | (Inherited from OrderBase.)
Public property | RawFieldData | Obsolete. (Inherited from OrderBase.)
Public property | Reference | Gets or sets the document reference (InvNumber). (Inherited from OrderBase.)
Public property | Reference2 | Gets the 2nd document reference. (Inherited from OrderBase.)
Public property | SettlementTerms | (Inherited from OrderBase.)
Public property | SettlementTermsID | (Inherited from OrderBase.)
Public property | State | Gets the document state. (Inherited from OrderBase.)
Public property | Supplier | Gets or sets the order's supplier account (maps directly to Account).
Public property | SupplierInvoiceNo | Gets or sets the document supplier invoice number.
Protected property | taxLastProcessTotal | (Inherited from OrderBase.)
Protected property | taxLastProcessTotalForeign | (Inherited from OrderBase.)
Public property | TaxMode | Gets or sets the tax mode. (Inherited from OrderBase.)
Public property | TaxNumber | Gets or sets the cash account's tax number. (Inherited from OrderBase.)
Protected property | taxOutstTotal | (Inherited from OrderBase.)
Protected property | taxOutstTotalForeign | (Inherited from OrderBase.)
Protected property | taxToProcessTotal | (Inherited from OrderBase.)
Protected property | taxToProcessTotalForeign | (Inherited from OrderBase.)
Protected property | taxTotal | (Inherited from OrderBase.)
Protected property | taxTotalForeign | (Inherited from OrderBase.)
Public property | TaxType | (Inherited from OrderBase.)
Public property | TotalDiscountAdjusted | Gets the total discount adjusted amount. (Inherited from OrderBase.)
Public property | TotalDiscountAdjustedForeign | Gets the total discount adjusted foreign amount. (Inherited from OrderBase.)
Public property | TotalExcl | Gets the total excl amount. (Inherited from OrderBase.)
Public property | TotalExclForeign | Gets the total excl amount. (Inherited from OrderBase.)
Public property | TotalIncl | Gets the total incl amount. (Inherited from OrderBase.)
Public property | TotalInclForeign | Gets the total incl amount. (Inherited from OrderBase.)
Public property | TotalInclForeignBeforeInvoiceRounding | Gets the total incl amount before Invoice Rounding. (Inherited from OrderBase.)
Public property | TotalLastProcessExcl | Gets the total last process excl. (Inherited from OrderBase.)
Public property | TotalLastProcessExclForeign | Gets the total last process excl. (Inherited from OrderBase.)
Public property | TotalLastProcessIncl | Gets the total last process incl. (Inherited from OrderBase.)
Public property | TotalLastProcessInclForeign | Gets the total last process incl. (Inherited from OrderBase.)
Public property | TotalLastProcessTax | Gets the total last process tax. (Inherited from OrderBase.)
Public property | TotalLastProcessTaxForeign | Gets the total last process tax. (Inherited from OrderBase.)
Public property | TotalOutstandingExcl | Gets the total outstanding excl. (Inherited from OrderBase.)
Public property | TotalOutstandingExclForeign | Gets the total outstanding excl. (Inherited from OrderBase.)
Public property | TotalOutstandingIncl | Gets the total outstanding incl. (Inherited from OrderBase.)
Public property | TotalOutstandingInclForeign | Gets the total outstanding incl. (Inherited from OrderBase.)
Public property | TotalOutstandingTax | Gets the total outstanding tax. (Inherited from OrderBase.)
Public property | TotalOutstandingTaxForeign | Gets the total outstanding tax. (Inherited from OrderBase.)
Public property | TotalTax | Gets the total tax amount. (Inherited from OrderBase.)
Public property | TotalTaxForeign | Gets the total tax amount. (Inherited from OrderBase.)
Public property | TotalToProcessExcl | Gets the total amount to process excl. (Inherited from OrderBase.)
Public property | TotalToProcessExclForeign | Gets the total amount to process excl. (Inherited from OrderBase.)
Public property | TotalToProcessIncl | Gets the total to process incl. (Inherited from OrderBase.)
Public property | TotalToProcessInclForeign | Gets the total to process incl. (Inherited from OrderBase.)
Public property | TotalToProcessTax | Gets the total to process tax. (Inherited from OrderBase.)
Public property | TotalToProcessTaxForeign | Gets the total to process tax. (Inherited from OrderBase.)
Public property | Type | Gets the order's document type. (Inherited from OrderBase.)
Public property | UserFields | Gets access to the collection of user-defined fields on the record. Note that the field name is case-sensitive. (Inherited from OrderBase.)
Public property | Version | Gets the current version of the order, incremented on every save. (Inherited from OrderBase.)

See Also

PurchaseOrder Class


PurchaseOrder Constructor

[image] [image]

Pastel Evolution SDK
PurchaseOrder Constructor
PurchaseOrder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PurchaseOrder()()()() | Creates a new instance of a purchase order.
Public method | PurchaseOrder(Int32) | Creates a new instance of a purchase order.
Public method | PurchaseOrder(String) | Creates a new instance of an existing purchase order.
Public method | PurchaseOrder(String, String) | Creates an instance of an existing unprocessed supplier invoice having the given purchase order and grv numbers.

See Also

PurchaseOrder Class
PurchaseOrder Members


PurchaseOrder Constructor

[image]

Pastel Evolution SDK
PurchaseOrder Constructor
PurchaseOrder Class See Also Send Feedback
Creates a new instance of a purchase order.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public PurchaseOrder()
Visual Basic
Public Sub New

See Also

PurchaseOrder Class
PurchaseOrder Members
PurchaseOrder Overload


PurchaseOrder Constructor (Int32)

[image]

Pastel Evolution SDK
PurchaseOrder Constructor (Int32)
PurchaseOrder Class See Also Send Feedback
Creates a new instance of a purchase order.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public PurchaseOrder(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32
Specifies the id of the existing record.

See Also

PurchaseOrder Class
PurchaseOrder Members
PurchaseOrder Overload


PurchaseOrder Constructor (String)

[image]

Pastel Evolution SDK
PurchaseOrder Constructor (String)
PurchaseOrder Class See Also Send Feedback
Creates a new instance of an existing purchase order.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public PurchaseOrder(
    string orderNo
)
Visual Basic
Public Sub New (
    orderNo As String
)

Parameters

orderNo
Type: System..::..String
Specifies the order number of the existing record.

See Also

PurchaseOrder Class
PurchaseOrder Members
PurchaseOrder Overload


PurchaseOrder Constructor (String, String)

[image]

Pastel Evolution SDK
PurchaseOrder Constructor (String, String)
PurchaseOrder Class See Also Send Feedback
Creates an instance of an existing unprocessed supplier invoice having the given purchase order and grv numbers.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public PurchaseOrder(
    string orderNumber,
    string grvNumber
)
Visual Basic
Public Sub New (
    orderNumber As String,
    grvNumber As String
)

Parameters

orderNumber
Type: System..::..String
The purchase order number.
grvNumber
Type: System..::..String
The GRV number with which this supplier invoice is associated.

See Also

PurchaseOrder Class
PurchaseOrder Members
PurchaseOrder Overload


PurchaseOrder Fields

[image] [image]

Pastel Evolution SDK
PurchaseOrder Fields
PurchaseOrder Class See Also Send Feedback

The PurchaseOrder type exposes the following members.

Fields

 | Name | Description
Protected field | account | (Inherited from OrderBase.)
Protected field | archID | (Inherited from OrderBase.)
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | currency | (Inherited from OrderBase.)
Protected field | dcTran | (Inherited from OrderBase.)
Protected field | deliverTo | (Inherited from OrderBase.)
Protected field | deliveryMethod | (Inherited from OrderBase.)
Protected field | detail | (Inherited from OrderBase.)
Protected field | glBatch | (Inherited from OrderBase.)
Protected field | invoiceTo | (Inherited from OrderBase.)
Protected field | orderPriority | (Inherited from OrderBase.)
Protected field | orderStatus | (Inherited from OrderBase.)
Protected field | originalDocument | (Inherited from OrderBase.)
Protected field | processingAdditionalCosts | (Inherited from OrderBase.)
Protected field | processLedger | Should the document process to AR or AP ledger? (Inherited from OrderBase.)
Protected field | processStock | (Inherited from OrderBase.)
Protected field | project | (Inherited from OrderBase.)
Protected field | prospect | (Inherited from OrderBase.)
Protected field | settlementTerms | (Inherited from OrderBase.)
Protected field | taxType | (Inherited from OrderBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

PurchaseOrder Class


PurchaseOrder Methods

[image] [image]

Pastel Evolution SDK
PurchaseOrder Methods
PurchaseOrder Class See Also Send Feedback

The PurchaseOrder type exposes the following members.

Methods

 | Name | Description
Public method | _SetFullQtyToProcess | (Inherited from OrderBase.)
Protected method | BeforePostGLBatch | (Overrides OrderBase..::..BeforePostGLBatch(OrderBase, CancelEventArgs).)
Protected method | BeforePostInventory | (Overrides OrderBase..::..BeforePostInventory(OrderBase, CancelEventArgs).)
Protected method | BeforePostLedger | (Overrides OrderBase..::..BeforePostLedger(OrderBase, CancelEventArgs).)
Protected method | BeforeSave | (Inherited from OrderBase.)
Protected method | cascadeForeignValues | (Inherited from OrderBase.)
Protected method | cascadeProject | (Inherited from OrderBase.)
Protected method | cascadeTaxRate | (Inherited from OrderBase.)
Public method | Complete()()()() | Processes (invoices) all outstanding quantities on the order. The entire invoice fails if one or more detail lines do not have sufficient stock available. The CompleteMax method (SalesOrder only) is a variation on this method and attempts to confirm as much of the ordered stock as is available. (Inherited from OrderBase.)
Public method | Complete(String) | Process (invoice) all outstanding quantities on the order. The entire invoice fails if one or more detail lines do not have sufficient stock available. The method is a variation on this method and attempts to confirm as much of the ordered stock as is available. (Inherited from OrderBase.)
Public method | CompleteStock()()()() | Processes a stock receipt (maximum quantity) without posting a supplier invoice. Only allowed when supplier invoice/GRV separation is enabled in purchase order defaults.
Public method | CompleteStock(String) | Processes a stock receipt (maximum quantity) without posting a supplier invoice. Only allowed when supplier invoice/GRV separation is enabled in purchase order defaults.
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Protected method | Detach | (Overrides OrderBase..::..Detach()()()().)
Protected method | detailRemainsOutstanding | (Inherited from OrderBase.)
Protected method | detailToProcess | (Inherited from OrderBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds and returns the id of the first order matching the supplied criteria. E.g. OrderNum = 'PO0001'
Protected method | fullQtySelected | (Inherited from OrderBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | glCreditPosting | (Overrides OrderBase..::..glCreditPosting(TransactionBase, TransactionBase..::..GLPostingEventArgs).)
Protected method | glDebitPosting | (Overrides OrderBase..::..glDebitPosting(TransactionBase, TransactionBase..::..GLPostingEventArgs).)
Protected method | initialise | (Overrides OrderBase..::..initialise()()()().)
 | List | Lists outstanding orders for the supplied criteria.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Not supported. Use the delete facility from inside Evolution. (Inherited from OrderBase.)
Protected method | OnSave | (Overrides PurchasesDocumentBase..::..OnSave()()()().)
Public method | Process()()()() | Posts the document to the various accounts and ledgers applicable. (Inherited from OrderBase.)
Public method | Process(String) | Posts the document to the various accounts and ledgers applicable. (Overrides OrderBase..::..Process(String).)
Public method | ProcessStock()()()() | Processes a stock receipt without posting a supplier invoice. Only allowed when supplier invoice/GRV separation is enabled in purchase order defaults.
Public method | ProcessStock(String) | Processes a stock receipt without posting a supplier invoice. Only allowed when supplier invoice/GRV separation is enabled in purchase order defaults.
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

PurchaseOrder Class


PurchaseOrder.BeforePostGLBatch Method

[image]

Pastel Evolution SDK
PurchaseOrder..::..BeforePostGLBatch Method
PurchaseOrder Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected override void BeforePostGLBatch(
    OrderBase orderBase,
    CancelEventArgs e
)
Visual Basic
Protected Overrides Sub BeforePostGLBatch (
    orderBase As OrderBase,
    e As CancelEventArgs
)

Parameters

orderBase
Type: Pastel.Evolution..::..OrderBase
e
Type: System.ComponentModel..::..CancelEventArgs

See Also

PurchaseOrder Class
PurchaseOrder Members


PurchaseOrder.BeforePostInventory Method

[image]

Pastel Evolution SDK
PurchaseOrder..::..BeforePostInventory Method
PurchaseOrder Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected override void BeforePostInventory(
    OrderBase orderBase,
    CancelEventArgs e
)
Visual Basic
Protected Overrides Sub BeforePostInventory (
    orderBase As OrderBase,
    e As CancelEventArgs
)

Parameters

orderBase
Type: Pastel.Evolution..::..OrderBase
e
Type: System.ComponentModel..::..CancelEventArgs

See Also

PurchaseOrder Class
PurchaseOrder Members


PurchaseOrder.BeforePostLedger Method

[image]

Pastel Evolution SDK
PurchaseOrder..::..BeforePostLedger Method
PurchaseOrder Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected override void BeforePostLedger(
    OrderBase orderBase,
    CancelEventArgs e
)
Visual Basic
Protected Overrides Sub BeforePostLedger (
    orderBase As OrderBase,
    e As CancelEventArgs
)

Parameters

orderBase
Type: Pastel.Evolution..::..OrderBase
e
Type: System.ComponentModel..::..CancelEventArgs

See Also

PurchaseOrder Class
PurchaseOrder Members


PurchaseOrder.CompleteStock Method

[image] [image]

Pastel Evolution SDK
PurchaseOrder..::..CompleteStock Method
PurchaseOrder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CompleteStock()()()() | Processes a stock receipt (maximum quantity) without posting a supplier invoice. Only allowed when supplier invoice/GRV separation is enabled in purchase order defaults.
Public method | CompleteStock(String) | Processes a stock receipt (maximum quantity) without posting a supplier invoice. Only allowed when supplier invoice/GRV separation is enabled in purchase order defaults.

See Also

PurchaseOrder Class
PurchaseOrder Members


PurchaseOrder.CompleteStock Method

[image]

Pastel Evolution SDK
PurchaseOrder..::..CompleteStock Method
PurchaseOrder Class See Also Send Feedback
Processes a stock receipt (maximum quantity) without posting a supplier invoice. Only allowed when supplier invoice/GRV separation is enabled in purchase order defaults.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string CompleteStock()
Visual Basic
Public Function CompleteStock As String

Return Value

Type: String
The generated GRV number.

See Also

PurchaseOrder Class
PurchaseOrder Members
CompleteStock Overload
Pastel.Evolution Namespace
PurchaseOrder..::..ProcessStock()()()()


PurchaseOrder.CompleteStock Method (String)

[image]

Pastel Evolution SDK
PurchaseOrder..::..CompleteStock Method (String)
PurchaseOrder Class See Also Send Feedback
Processes a stock receipt (maximum quantity) without posting a supplier invoice. Only allowed when supplier invoice/GRV separation is enabled in purchase order defaults.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string CompleteStock(
    string reference
)
Visual Basic
Public Function CompleteStock (
    reference As String
) As String

Parameters

reference
Type: System..::..String
Specifies the GRV number to post.

Return Value

Type: String
The supplied GRV number.

See Also

PurchaseOrder Class
PurchaseOrder Members
CompleteStock Overload
Pastel.Evolution Namespace
PurchaseOrder..::..CompleteStock()()()()


PurchaseOrder.Detach Method

[image]

Pastel Evolution SDK
PurchaseOrder..::..Detach Method
PurchaseOrder Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected override void Detach()
Visual Basic
Protected Overrides Sub Detach

See Also

PurchaseOrder Class
PurchaseOrder Members


PurchaseOrder.Find Method

[image]

Pastel Evolution SDK
PurchaseOrder..::..Find Method
PurchaseOrder Class See Also Send Feedback
Finds and returns the id of the first order matching the supplied criteria. E.g. OrderNum = 'PO0001'

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.

Return Value

Type: Int32
The ID of the first record found; -1 if not record was found.

See Also

PurchaseOrder Class
PurchaseOrder Members


PurchaseOrder.glCreditPosting Method

[image]

Pastel Evolution SDK
PurchaseOrder..::..glCreditPosting Method
PurchaseOrder Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected override void glCreditPosting(
    TransactionBase sender,
    TransactionBase..::..GLPostingEventArgs e
)
Visual Basic
Protected Overrides Sub glCreditPosting (
    sender As TransactionBase,
    e As TransactionBase..::..GLPostingEventArgs
)

Parameters

sender
Type: Pastel.Evolution..::..TransactionBase
e
Type: Pastel.Evolution..::..TransactionBase..::..GLPostingEventArgs

See Also

PurchaseOrder Class
PurchaseOrder Members


PurchaseOrder.glDebitPosting Method

[image]

Pastel Evolution SDK
PurchaseOrder..::..glDebitPosting Method
PurchaseOrder Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected override void glDebitPosting(
    TransactionBase sender,
    TransactionBase..::..GLPostingEventArgs e
)
Visual Basic
Protected Overrides Sub glDebitPosting (
    sender As TransactionBase,
    e As TransactionBase..::..GLPostingEventArgs
)

Parameters

sender
Type: Pastel.Evolution..::..TransactionBase
e
Type: Pastel.Evolution..::..TransactionBase..::..GLPostingEventArgs

See Also

PurchaseOrder Class
PurchaseOrder Members


PurchaseOrder.initialise Method

[image]

Pastel Evolution SDK
PurchaseOrder..::..initialise Method
PurchaseOrder Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void initialise()
Visual Basic
Protected Friend Overrides Sub initialise

See Also

PurchaseOrder Class
PurchaseOrder Members


PurchaseOrder.List Method

[image]

Pastel Evolution SDK
PurchaseOrder..::..List Method
PurchaseOrder Class See Also Send Feedback
Lists outstanding orders for the supplied criteria.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria
)
Visual Basic
Public Shared Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String
E.g. Supplier.Account = 'SUPP001' and (OrderNum = 'PO209302')

Return Value

Type: DataTable

Remarks

Table aliases: Core, Supplier

See Also

PurchaseOrder Class
PurchaseOrder Members


PurchaseOrder.OnSave Method

[image]

Pastel Evolution SDK
PurchaseOrder..::..OnSave Method
PurchaseOrder Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

PurchaseOrder Class
PurchaseOrder Members


PurchaseOrder.Process Method

[image] [image]

Pastel Evolution SDK
PurchaseOrder..::..Process Method
PurchaseOrder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Process()()()() | Posts the document to the various accounts and ledgers applicable. (Inherited from OrderBase.)
Public method | Process(String) | Posts the document to the various accounts and ledgers applicable. (Overrides OrderBase..::..Process(String).)

See Also

PurchaseOrder Class
PurchaseOrder Members


PurchaseOrder.Process Method (String)

[image]

Pastel Evolution SDK
PurchaseOrder..::..Process Method (String)
PurchaseOrder Class See Also Send Feedback
Posts the document to the various accounts and ledgers applicable.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override string Process(
    string reference
)
Visual Basic
Public Overrides Function Process (
    reference As String
) As String

Parameters

reference
Type: System..::..String
Specifies the GRV Number to post. If specified, no number will be generated. Note that no duplication checking is performed. When processing an unprocessed supplier invoice document, the reference parameter is ignored.

Return Value

Type: String

See Also

PurchaseOrder Class
PurchaseOrder Members
Process Overload
Pastel.Evolution Namespace
PurchaseOrder..::..ProcessStock()()()()


PurchaseOrder.ProcessStock Method

[image] [image]

Pastel Evolution SDK
PurchaseOrder..::..ProcessStock Method
PurchaseOrder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ProcessStock()()()() | Processes a stock receipt without posting a supplier invoice. Only allowed when supplier invoice/GRV separation is enabled in purchase order defaults.
Public method | ProcessStock(String) | Processes a stock receipt without posting a supplier invoice. Only allowed when supplier invoice/GRV separation is enabled in purchase order defaults.

See Also

PurchaseOrder Class
PurchaseOrder Members


PurchaseOrder.ProcessStock Method

[image]

Pastel Evolution SDK
PurchaseOrder..::..ProcessStock Method
PurchaseOrder Class See Also Send Feedback
Processes a stock receipt without posting a supplier invoice. Only allowed when supplier invoice/GRV separation is enabled in purchase order defaults.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string ProcessStock()
Visual Basic
Public Function ProcessStock As String

Return Value

Type: String
The generated GRV number.

See Also

PurchaseOrder Class
PurchaseOrder Members
ProcessStock Overload
Pastel.Evolution Namespace
PurchaseOrder..::..Process(String)
PurchaseOrder..::..Process(String)


PurchaseOrder.ProcessStock Method (String)

[image]

Pastel Evolution SDK
PurchaseOrder..::..ProcessStock Method (String)
PurchaseOrder Class See Also Send Feedback
Processes a stock receipt without posting a supplier invoice. Only allowed when supplier invoice/GRV separation is enabled in purchase order defaults.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string ProcessStock(
    string reference
)
Visual Basic
Public Function ProcessStock (
    reference As String
) As String

Parameters

reference
Type: System..::..String
Custom GRV number.

Return Value

Type: String
The GRV number passed in; the generated GRV number if an empty string is supplied.

Remarks

Receiving stock results in an archived GRV document and an unprocessed supplier invoice document.

See Also

PurchaseOrder Class
PurchaseOrder Members
ProcessStock Overload


PurchaseOrder Properties

[image] [image]

Pastel Evolution SDK
PurchaseOrder Properties
PurchaseOrder Class See Also Send Feedback

The PurchaseOrder type exposes the following members.

Properties

 | Name | Description
Public property | Account | Gets or sets the AR or AP account associated with the order. (Inherited from OrderBase.)
Public property | AccountID | Gets or sets the ID of the AR or AP account associated with the order. (Inherited from OrderBase.)
Public property | AdditionalCosts | (Inherited from PurchasesDocumentBase.)
Public property | AllowInvoiceRounding | (Inherited from OrderBase.)
Public property | ApplyTaxPerLine | Gets or sets whether tax per line should be applied. (Inherited from OrderBase.)
Public property | Audit | Gets the audit number of the last transaction processed by this document. This value defaults to 0, and will not be available on recalled documents. (Inherited from OrderBase.)
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Currency | Gets or sets the currency. (Inherited from OrderBase.)
Public property | CurrencyID | Gets or sets the document's currency ID. (Inherited from OrderBase.)
Public property | DeliverTo | Gets or sets the delivery address. (Inherited from OrderBase.)
Public property | DeliveryDate | Gets or sets the delivery date. (Inherited from OrderBase.)
Public property | DeliveryMethod | Gets or sets the delivery method. (Inherited from OrderBase.)
Public property | DeliveryMethodID | Gets or sets the delivery method ID. (Inherited from OrderBase.)
Public property | Description | Gets or sets the document description. This will also be the description on any transactions posted. (Inherited from OrderBase.)
Public property | Detail | Gets the order detail collection representing the body of the document. (Inherited from OrderBase.)
Public property | Discount | Gets or sets the document discount amount (applicable to tax excl. total), (Inherited from OrderBase.)
Public property | DiscountForeign | Gets or sets the document foreign discount amount (applicable to tax excl. total), (Inherited from OrderBase.)
Public property | DiscountLastProcessed | Gets the document discount amount last processed. (Inherited from OrderBase.)
Public property | DiscountPercent | Gets or sets the document discount percentage. (Inherited from OrderBase.)
Public property | DiscountToProcess | Gets the document discount amount about to be processed (applicable to tax excl. total). (Inherited from OrderBase.)
Public property | DueDate | Gets or sets the due date. (Inherited from OrderBase.)
Public property | ExchangeRate | Gets or sets the exchange rate. (Inherited from OrderBase.)
Public property | ExternalOrderNo | Gets or sets the external order number. (Inherited from OrderBase.)
Protected property | grossLastProcessTotal | (Inherited from OrderBase.)
Protected property | grossLastProcessTotalForeign | (Inherited from OrderBase.)
Protected property | grossOutstTotal | (Inherited from OrderBase.)
Protected property | grossOutstTotalForeign | (Inherited from OrderBase.)
Protected property | grossToProcessTotal | (Inherited from OrderBase.)
Protected property | grossToProcessTotalForeign | (Inherited from OrderBase.)
Protected property | grossTotal | (Inherited from OrderBase.)
Protected property | grossTotalForeign | (Inherited from OrderBase.)
Public property | GrvState | Gets the phase of this goods receiving document, either a goods received note or a supplier invoice.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Inherited from OrderBase.)
Public property | InvoiceDate | Gets or sets the invoice date. (Inherited from OrderBase.)
Public property | InvoiceTo | Gets or sets the invoice address. (Inherited from OrderBase.)
Public property | IsLoading | Will be true while the order is busy loading detail. (Inherited from OrderBase.)
Public property | IsPartialProcessingAllowed | (Inherited from OrderBase.)
Public property | IsProcessing | Will be true while the order is busy processing transactions. (Inherited from OrderBase.)
Public property | LedgerTransaction | Gets the last ledger transaction (AR/AP Transaction) posted. (Inherited from OrderBase.)
Protected property | lineAdditionalCostTotal | (Inherited from OrderBase.)
Public property | LongID | (Inherited from OrderBase.)
Public property | MessageLine1 | Gets or sets the 1st message line. (Inherited from OrderBase.)
Public property | MessageLine2 | Gets or sets the 2nd message line. (Inherited from OrderBase.)
Public property | MessageLine3 | Gets or sets the 3rd message line. (Inherited from OrderBase.)
Protected property | nettLastProcessTotal | (Inherited from OrderBase.)
Protected property | nettLastProcessTotalForeign | (Inherited from OrderBase.)
Protected property | nettOutstTotal | (Inherited from OrderBase.)
Protected property | nettOutstTotalForeign | (Inherited from OrderBase.)
Protected property | nettToProcessTotal | (Inherited from OrderBase.)
Protected property | nettToProcessTotalForeign | (Inherited from OrderBase.)
Public property | OrderDate | Gets or sets the order date. (Inherited from OrderBase.)
Public property | OrderNo | Gets or sets the order number. (Inherited from OrderBase.)
Public property | OrderPriority | Gets or sets the order priority. (Inherited from OrderBase.)
Public property | OrderPriorityID | Gets or sets the order priority ID. (Inherited from OrderBase.)
Public property | OrderStatus | Gets or sets the document's order status. (Inherited from OrderBase.)
Public property | OrderStatusID | Gets or sets the order status ID. (Inherited from OrderBase.)
Public property | OriginalDocument | (Overrides OrderBase..::..OriginalDocument.)
Public property | PrintCount | Gets or sets the print count. (Inherited from OrderBase.)
Public property | Project | Gets or sets the project. (Inherited from OrderBase.)
Public property | ProjectID | Gets or sets the project ID. (Inherited from OrderBase.)
Public property | Prospect | (Inherited from OrderBase.)
Public property | ProspectID | (Inherited from OrderBase.)
Public property | RawFieldData | Obsolete. (Inherited from OrderBase.)
Public property | Reference | Gets or sets the document reference (InvNumber). (Inherited from OrderBase.)
Public property | Reference2 | Gets the 2nd document reference. (Inherited from OrderBase.)
Public property | SettlementTerms | (Inherited from OrderBase.)
Public property | SettlementTermsID | (Inherited from OrderBase.)
Public property | State | Gets the document state. (Inherited from OrderBase.)
Public property | Supplier | Gets or sets the order's supplier account (maps directly to Account).
Public property | SupplierInvoiceNo | Gets or sets the document supplier invoice number.
Protected property | taxLastProcessTotal | (Inherited from OrderBase.)
Protected property | taxLastProcessTotalForeign | (Inherited from OrderBase.)
Public property | TaxMode | Gets or sets the tax mode. (Inherited from OrderBase.)
Public property | TaxNumber | Gets or sets the cash account's tax number. (Inherited from OrderBase.)
Protected property | taxOutstTotal | (Inherited from OrderBase.)
Protected property | taxOutstTotalForeign | (Inherited from OrderBase.)
Protected property | taxToProcessTotal | (Inherited from OrderBase.)
Protected property | taxToProcessTotalForeign | (Inherited from OrderBase.)
Protected property | taxTotal | (Inherited from OrderBase.)
Protected property | taxTotalForeign | (Inherited from OrderBase.)
Public property | TaxType | (Inherited from OrderBase.)
Public property | TotalDiscountAdjusted | Gets the total discount adjusted amount. (Inherited from OrderBase.)
Public property | TotalDiscountAdjustedForeign | Gets the total discount adjusted foreign amount. (Inherited from OrderBase.)
Public property | TotalExcl | Gets the total excl amount. (Inherited from OrderBase.)
Public property | TotalExclForeign | Gets the total excl amount. (Inherited from OrderBase.)
Public property | TotalIncl | Gets the total incl amount. (Inherited from OrderBase.)
Public property | TotalInclForeign | Gets the total incl amount. (Inherited from OrderBase.)
Public property | TotalInclForeignBeforeInvoiceRounding | Gets the total incl amount before Invoice Rounding. (Inherited from OrderBase.)
Public property | TotalLastProcessExcl | Gets the total last process excl. (Inherited from OrderBase.)
Public property | TotalLastProcessExclForeign | Gets the total last process excl. (Inherited from OrderBase.)
Public property | TotalLastProcessIncl | Gets the total last process incl. (Inherited from OrderBase.)
Public property | TotalLastProcessInclForeign | Gets the total last process incl. (Inherited from OrderBase.)
Public property | TotalLastProcessTax | Gets the total last process tax. (Inherited from OrderBase.)
Public property | TotalLastProcessTaxForeign | Gets the total last process tax. (Inherited from OrderBase.)
Public property | TotalOutstandingExcl | Gets the total outstanding excl. (Inherited from OrderBase.)
Public property | TotalOutstandingExclForeign | Gets the total outstanding excl. (Inherited from OrderBase.)
Public property | TotalOutstandingIncl | Gets the total outstanding incl. (Inherited from OrderBase.)
Public property | TotalOutstandingInclForeign | Gets the total outstanding incl. (Inherited from OrderBase.)
Public property | TotalOutstandingTax | Gets the total outstanding tax. (Inherited from OrderBase.)
Public property | TotalOutstandingTaxForeign | Gets the total outstanding tax. (Inherited from OrderBase.)
Public property | TotalTax | Gets the total tax amount. (Inherited from OrderBase.)
Public property | TotalTaxForeign | Gets the total tax amount. (Inherited from OrderBase.)
Public property | TotalToProcessExcl | Gets the total amount to process excl. (Inherited from OrderBase.)
Public property | TotalToProcessExclForeign | Gets the total amount to process excl. (Inherited from OrderBase.)
Public property | TotalToProcessIncl | Gets the total to process incl. (Inherited from OrderBase.)
Public property | TotalToProcessInclForeign | Gets the total to process incl. (Inherited from OrderBase.)
Public property | TotalToProcessTax | Gets the total to process tax. (Inherited from OrderBase.)
Public property | TotalToProcessTaxForeign | Gets the total to process tax. (Inherited from OrderBase.)
Public property | Type | Gets the order's document type. (Inherited from OrderBase.)
Public property | UserFields | Gets access to the collection of user-defined fields on the record. Note that the field name is case-sensitive. (Inherited from OrderBase.)
Public property | Version | Gets the current version of the order, incremented on every save. (Inherited from OrderBase.)

See Also

PurchaseOrder Class


PurchaseOrder.GrvState Property

[image]

Pastel Evolution SDK
PurchaseOrder..::..GrvState Property
PurchaseOrder Class See Also Send Feedback
Gets the phase of this goods receiving document, either a goods received note or a supplier invoice.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public PurchaseOrder..::..GrvPhase GrvState { get; internal set; }
Visual Basic
Public Property GrvState As PurchaseOrder..::..GrvPhase
    Get
    Friend Set

Property Value

Type: PurchaseOrder..::..GrvPhase

See Also

PurchaseOrder Class
PurchaseOrder Members


PurchaseOrder.OriginalDocument Property

[image]

Pastel Evolution SDK
PurchaseOrder..::..OriginalDocument Property
PurchaseOrder Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override OrderBase OriginalDocument { get; }
Visual Basic
Public Overrides ReadOnly Property OriginalDocument As OrderBase
    Get

Property Value

Type: OrderBase

See Also

PurchaseOrder Class
PurchaseOrder Members


PurchaseOrder.Supplier Property

[image]

Pastel Evolution SDK
PurchaseOrder..::..Supplier Property
PurchaseOrder Class See Also Send Feedback
Gets or sets the order's supplier account (maps directly to Account).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Supplier Supplier { get; set; }
Visual Basic
Public Property Supplier As Supplier
    Get
    Set

Property Value

Type: Supplier

See Also

PurchaseOrder Class
PurchaseOrder Members


PurchaseOrder.SupplierInvoiceNo Property

[image]

Pastel Evolution SDK
PurchaseOrder..::..SupplierInvoiceNo Property
PurchaseOrder Class See Also Send Feedback
Gets or sets the document supplier invoice number.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string SupplierInvoiceNo { get; set; }
Visual Basic
Public Property SupplierInvoiceNo As String
    Get
    Set

Property Value

Type: String

See Also

PurchaseOrder Class
PurchaseOrder Members


PurchaseOrder.GrvPhase Enumeration

[image]

Pastel Evolution SDK
PurchaseOrder..::..GrvPhase Enumeration
PurchaseOrder Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public enum GrvPhase
Visual Basic
Public Enumeration GrvPhase

Members

Member name | Value | Description
GRV | 1 |
SupplierInvoice | 2 |

See Also

Pastel.Evolution Namespace


PurchasesDocumentBase Class

[image]

Pastel Evolution SDK
PurchasesDocumentBase Class
Members See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract class PurchasesDocumentBase : OrderBase
Visual Basic
Public MustInherit Class PurchasesDocumentBase
    Inherits OrderBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..OrderBase
Pastel.Evolution..::..PurchasesDocumentBase
Pastel.Evolution..::..PurchaseOrder
Pastel.Evolution..::..ReturnToSupplier

See Also

PurchasesDocumentBase Members


PurchasesDocumentBase Members

[image] [image]

Pastel Evolution SDK
PurchasesDocumentBase Members
PurchasesDocumentBase Class Constructors Methods Fields Properties See Also Send Feedback

The PurchasesDocumentBase type exposes the following members.

Constructors

 | Name | Description
Protected method | PurchasesDocumentBase()()()() | Initializes a new instance of the PurchasesDocumentBase class
Protected method | PurchasesDocumentBase(Int32) | Initializes a new instance of the PurchasesDocumentBase class
Protected method | PurchasesDocumentBase(String, DocumentType) | Initializes a new instance of the PurchasesDocumentBase class
Protected method | PurchasesDocumentBase(String, DocumentType, String, Int32) | Initializes a new instance of the PurchasesDocumentBase class

Methods

 | Name | Description
Public method | _SetFullQtyToProcess | (Inherited from OrderBase.)
Protected method | BeforePostGLBatch | (Inherited from OrderBase.)
Protected method | BeforePostInventory | (Inherited from OrderBase.)
Protected method | BeforePostLedger | (Inherited from OrderBase.)
Protected method | BeforeSave | (Inherited from OrderBase.)
Protected method | cascadeForeignValues | (Inherited from OrderBase.)
Protected method | cascadeProject | (Inherited from OrderBase.)
Protected method | cascadeTaxRate | (Inherited from OrderBase.)
Public method | Complete()()()() | Processes (invoices) all outstanding quantities on the order. The entire invoice fails if one or more detail lines do not have sufficient stock available. The CompleteMax method (SalesOrder only) is a variation on this method and attempts to confirm as much of the ordered stock as is available. (Inherited from OrderBase.)
Public method | Complete(String) | Process (invoice) all outstanding quantities on the order. The entire invoice fails if one or more detail lines do not have sufficient stock available. The method is a variation on this method and attempts to confirm as much of the ordered stock as is available. (Inherited from OrderBase.)
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Protected method | Detach | (Inherited from OrderBase.)
Protected method | detailRemainsOutstanding | (Inherited from OrderBase.)
Protected method | detailToProcess | (Inherited from OrderBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | fullQtySelected | (Inherited from OrderBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | glCreditPosting | (Inherited from OrderBase.)
Protected method | glDebitPosting | (Inherited from OrderBase.)
Protected method | initialise | Reverts the order to an unsaved, version 0 (see remarks) state. (Inherited from OrderBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Not supported. Use the delete facility from inside Evolution. (Inherited from OrderBase.)
Protected method | OnSave | (Overrides OrderBase..::..OnSave()()()().)
Public method | Process()()()() | Posts the document to the various accounts and ledgers applicable. (Inherited from OrderBase.)
Public method | Process(String) | Posts the document to the various accounts and ledgers applicable. (Inherited from OrderBase.)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | account | (Inherited from OrderBase.)
Protected field | archID | (Inherited from OrderBase.)
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | currency | (Inherited from OrderBase.)
Protected field | dcTran | (Inherited from OrderBase.)
Protected field | deliverTo | (Inherited from OrderBase.)
Protected field | deliveryMethod | (Inherited from OrderBase.)
Protected field | detail | (Inherited from OrderBase.)
Protected field | glBatch | (Inherited from OrderBase.)
Protected field | invoiceTo | (Inherited from OrderBase.)
Protected field | orderPriority | (Inherited from OrderBase.)
Protected field | orderStatus | (Inherited from OrderBase.)
Protected field | originalDocument | (Inherited from OrderBase.)
Protected field | processingAdditionalCosts | (Inherited from OrderBase.)
Protected field | processLedger | Should the document process to AR or AP ledger? (Inherited from OrderBase.)
Protected field | processStock | (Inherited from OrderBase.)
Protected field | project | (Inherited from OrderBase.)
Protected field | prospect | (Inherited from OrderBase.)
Protected field | settlementTerms | (Inherited from OrderBase.)
Protected field | taxType | (Inherited from OrderBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | Account | Gets or sets the AR or AP account associated with the order. (Inherited from OrderBase.)
Public property | AccountID | Gets or sets the ID of the AR or AP account associated with the order. (Inherited from OrderBase.)
Public property | AdditionalCosts |
Public property | AllowInvoiceRounding | (Inherited from OrderBase.)
Public property | ApplyTaxPerLine | Gets or sets whether tax per line should be applied. (Inherited from OrderBase.)
Public property | Audit | Gets the audit number of the last transaction processed by this document. This value defaults to 0, and will not be available on recalled documents. (Inherited from OrderBase.)
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Currency | Gets or sets the currency. (Inherited from OrderBase.)
Public property | CurrencyID | Gets or sets the document's currency ID. (Inherited from OrderBase.)
Public property | DeliverTo | Gets or sets the delivery address. (Inherited from OrderBase.)
Public property | DeliveryDate | Gets or sets the delivery date. (Inherited from OrderBase.)
Public property | DeliveryMethod | Gets or sets the delivery method. (Inherited from OrderBase.)
Public property | DeliveryMethodID | Gets or sets the delivery method ID. (Inherited from OrderBase.)
Public property | Description | Gets or sets the document description. This will also be the description on any transactions posted. (Inherited from OrderBase.)
Public property | Detail | Gets the order detail collection representing the body of the document. (Inherited from OrderBase.)
Public property | Discount | Gets or sets the document discount amount (applicable to tax excl. total), (Inherited from OrderBase.)
Public property | DiscountForeign | Gets or sets the document foreign discount amount (applicable to tax excl. total), (Inherited from OrderBase.)
Public property | DiscountLastProcessed | Gets the document discount amount last processed. (Inherited from OrderBase.)
Public property | DiscountPercent | Gets or sets the document discount percentage. (Inherited from OrderBase.)
Public property | DiscountToProcess | Gets the document discount amount about to be processed (applicable to tax excl. total). (Inherited from OrderBase.)
Public property | DueDate | Gets or sets the due date. (Inherited from OrderBase.)
Public property | ExchangeRate | Gets or sets the exchange rate. (Inherited from OrderBase.)
Public property | ExternalOrderNo | Gets or sets the external order number. (Inherited from OrderBase.)
Protected property | grossLastProcessTotal | (Inherited from OrderBase.)
Protected property | grossLastProcessTotalForeign | (Inherited from OrderBase.)
Protected property | grossOutstTotal | (Inherited from OrderBase.)
Protected property | grossOutstTotalForeign | (Inherited from OrderBase.)
Protected property | grossToProcessTotal | (Inherited from OrderBase.)
Protected property | grossToProcessTotalForeign | (Inherited from OrderBase.)
Protected property | grossTotal | (Inherited from OrderBase.)
Protected property | grossTotalForeign | (Inherited from OrderBase.)
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Inherited from OrderBase.)
Public property | InvoiceDate | Gets or sets the invoice date. (Inherited from OrderBase.)
Public property | InvoiceTo | Gets or sets the invoice address. (Inherited from OrderBase.)
Public property | IsLoading | Will be true while the order is busy loading detail. (Inherited from OrderBase.)
Public property | IsPartialProcessingAllowed | (Inherited from OrderBase.)
Public property | IsProcessing | Will be true while the order is busy processing transactions. (Inherited from OrderBase.)
Public property | LedgerTransaction | Gets the last ledger transaction (AR/AP Transaction) posted. (Inherited from OrderBase.)
Protected property | lineAdditionalCostTotal | (Inherited from OrderBase.)
Public property | LongID | (Inherited from OrderBase.)
Public property | MessageLine1 | Gets or sets the 1st message line. (Inherited from OrderBase.)
Public property | MessageLine2 | Gets or sets the 2nd message line. (Inherited from OrderBase.)
Public property | MessageLine3 | Gets or sets the 3rd message line. (Inherited from OrderBase.)
Protected property | nettLastProcessTotal | (Inherited from OrderBase.)
Protected property | nettLastProcessTotalForeign | (Inherited from OrderBase.)
Protected property | nettOutstTotal | (Inherited from OrderBase.)
Protected property | nettOutstTotalForeign | (Inherited from OrderBase.)
Protected property | nettToProcessTotal | (Inherited from OrderBase.)
Protected property | nettToProcessTotalForeign | (Inherited from OrderBase.)
Public property | OrderDate | Gets or sets the order date. (Inherited from OrderBase.)
Public property | OrderNo | Gets or sets the order number. (Inherited from OrderBase.)
Public property | OrderPriority | Gets or sets the order priority. (Inherited from OrderBase.)
Public property | OrderPriorityID | Gets or sets the order priority ID. (Inherited from OrderBase.)
Public property | OrderStatus | Gets or sets the document's order status. (Inherited from OrderBase.)
Public property | OrderStatusID | Gets or sets the order status ID. (Inherited from OrderBase.)
Public property | OriginalDocument | Gets the original document. (Inherited from OrderBase.)
Public property | PrintCount | Gets or sets the print count. (Inherited from OrderBase.)
Public property | Project | Gets or sets the project. (Inherited from OrderBase.)
Public property | ProjectID | Gets or sets the project ID. (Inherited from OrderBase.)
Public property | Prospect | (Inherited from OrderBase.)
Public property | ProspectID | (Inherited from OrderBase.)
Public property | RawFieldData | Obsolete. (Inherited from OrderBase.)
Public property | Reference | Gets or sets the document reference (InvNumber). (Inherited from OrderBase.)
Public property | Reference2 | Gets the 2nd document reference. (Inherited from OrderBase.)
Public property | SettlementTerms | (Inherited from OrderBase.)
Public property | SettlementTermsID | (Inherited from OrderBase.)
Public property | State | Gets the document state. (Inherited from OrderBase.)
Protected property | taxLastProcessTotal | (Inherited from OrderBase.)
Protected property | taxLastProcessTotalForeign | (Inherited from OrderBase.)
Public property | TaxMode | Gets or sets the tax mode. (Inherited from OrderBase.)
Public property | TaxNumber | Gets or sets the cash account's tax number. (Inherited from OrderBase.)
Protected property | taxOutstTotal | (Inherited from OrderBase.)
Protected property | taxOutstTotalForeign | (Inherited from OrderBase.)
Protected property | taxToProcessTotal | (Inherited from OrderBase.)
Protected property | taxToProcessTotalForeign | (Inherited from OrderBase.)
Protected property | taxTotal | (Inherited from OrderBase.)
Protected property | taxTotalForeign | (Inherited from OrderBase.)
Public property | TaxType | (Inherited from OrderBase.)
Public property | TotalDiscountAdjusted | Gets the total discount adjusted amount. (Inherited from OrderBase.)
Public property | TotalDiscountAdjustedForeign | Gets the total discount adjusted foreign amount. (Inherited from OrderBase.)
Public property | TotalExcl | Gets the total excl amount. (Inherited from OrderBase.)
Public property | TotalExclForeign | Gets the total excl amount. (Inherited from OrderBase.)
Public property | TotalIncl | Gets the total incl amount. (Inherited from OrderBase.)
Public property | TotalInclForeign | Gets the total incl amount. (Inherited from OrderBase.)
Public property | TotalInclForeignBeforeInvoiceRounding | Gets the total incl amount before Invoice Rounding. (Inherited from OrderBase.)
Public property | TotalLastProcessExcl | Gets the total last process excl. (Inherited from OrderBase.)
Public property | TotalLastProcessExclForeign | Gets the total last process excl. (Inherited from OrderBase.)
Public property | TotalLastProcessIncl | Gets the total last process incl. (Inherited from OrderBase.)
Public property | TotalLastProcessInclForeign | Gets the total last process incl. (Inherited from OrderBase.)
Public property | TotalLastProcessTax | Gets the total last process tax. (Inherited from OrderBase.)
Public property | TotalLastProcessTaxForeign | Gets the total last process tax. (Inherited from OrderBase.)
Public property | TotalOutstandingExcl | Gets the total outstanding excl. (Inherited from OrderBase.)
Public property | TotalOutstandingExclForeign | Gets the total outstanding excl. (Inherited from OrderBase.)
Public property | TotalOutstandingIncl | Gets the total outstanding incl. (Inherited from OrderBase.)
Public property | TotalOutstandingInclForeign | Gets the total outstanding incl. (Inherited from OrderBase.)
Public property | TotalOutstandingTax | Gets the total outstanding tax. (Inherited from OrderBase.)
Public property | TotalOutstandingTaxForeign | Gets the total outstanding tax. (Inherited from OrderBase.)
Public property | TotalTax | Gets the total tax amount. (Inherited from OrderBase.)
Public property | TotalTaxForeign | Gets the total tax amount. (Inherited from OrderBase.)
Public property | TotalToProcessExcl | Gets the total amount to process excl. (Inherited from OrderBase.)
Public property | TotalToProcessExclForeign | Gets the total amount to process excl. (Inherited from OrderBase.)
Public property | TotalToProcessIncl | Gets the total to process incl. (Inherited from OrderBase.)
Public property | TotalToProcessInclForeign | Gets the total to process incl. (Inherited from OrderBase.)
Public property | TotalToProcessTax | Gets the total to process tax. (Inherited from OrderBase.)
Public property | TotalToProcessTaxForeign | Gets the total to process tax. (Inherited from OrderBase.)
Public property | Type | Gets the order's document type. (Inherited from OrderBase.)
Public property | UserFields | Gets access to the collection of user-defined fields on the record. Note that the field name is case-sensitive. (Inherited from OrderBase.)
Public property | Version | Gets the current version of the order, incremented on every save. (Inherited from OrderBase.)

See Also

PurchasesDocumentBase Class


PurchasesDocumentBase Constructor

[image] [image]

Pastel Evolution SDK
PurchasesDocumentBase Constructor
PurchasesDocumentBase Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | PurchasesDocumentBase()()()() | Initializes a new instance of the PurchasesDocumentBase class
Protected method | PurchasesDocumentBase(Int32) | Initializes a new instance of the PurchasesDocumentBase class
Protected method | PurchasesDocumentBase(String, DocumentType) | Initializes a new instance of the PurchasesDocumentBase class
Protected method | PurchasesDocumentBase(String, DocumentType, String, Int32) | Initializes a new instance of the PurchasesDocumentBase class

See Also

PurchasesDocumentBase Class
PurchasesDocumentBase Members


PurchasesDocumentBase Constructor

[image]

Pastel Evolution SDK
PurchasesDocumentBase Constructor
PurchasesDocumentBase Class See Also Send Feedback
Initializes a new instance of the PurchasesDocumentBase class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal PurchasesDocumentBase()
Visual Basic
Protected Friend Sub New

See Also

PurchasesDocumentBase Class
PurchasesDocumentBase Members
PurchasesDocumentBase Overload


PurchasesDocumentBase Constructor (Int32)

[image]

Pastel Evolution SDK
PurchasesDocumentBase Constructor (Int32)
PurchasesDocumentBase Class See Also Send Feedback
Initializes a new instance of the PurchasesDocumentBase class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal PurchasesDocumentBase(
    int id
)
Visual Basic
Protected Friend Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32

See Also

PurchasesDocumentBase Class
PurchasesDocumentBase Members
PurchasesDocumentBase Overload


PurchasesDocumentBase Constructor (String, DocumentType)

[image]

Pastel Evolution SDK
PurchasesDocumentBase Constructor (String, DocumentType)
PurchasesDocumentBase Class See Also Send Feedback
Initializes a new instance of the PurchasesDocumentBase class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal PurchasesDocumentBase(
    string orderNumber,
    DocumentType documentType
)
Visual Basic
Protected Friend Sub New (
    orderNumber As String,
    documentType As DocumentType
)

Parameters

orderNumber
Type: System..::..String
documentType
Type: Pastel.Evolution..::..DocumentType

See Also

PurchasesDocumentBase Class
PurchasesDocumentBase Members
PurchasesDocumentBase Overload


PurchasesDocumentBase Constructor (String, DocumentType, String, Int32)

[image]

Pastel Evolution SDK
PurchasesDocumentBase Constructor (String, DocumentType, String, Int32)
PurchasesDocumentBase Class See Also Send Feedback
Initializes a new instance of the PurchasesDocumentBase class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal PurchasesDocumentBase(
    string orderNumber,
    DocumentType documentType,
    string orderNumber2,
    int documentFlag
)
Visual Basic
Protected Friend Sub New (
    orderNumber As String,
    documentType As DocumentType,
    orderNumber2 As String,
    documentFlag As Integer
)

Parameters

orderNumber
Type: System..::..String
documentType
Type: Pastel.Evolution..::..DocumentType
orderNumber2
Type: System..::..String
documentFlag
Type: System..::..Int32

See Also

PurchasesDocumentBase Class
PurchasesDocumentBase Members
PurchasesDocumentBase Overload


PurchasesDocumentBase Fields

[image] [image]

Pastel Evolution SDK
PurchasesDocumentBase Fields
PurchasesDocumentBase Class See Also Send Feedback

The PurchasesDocumentBase type exposes the following members.

Fields

 | Name | Description
Protected field | account | (Inherited from OrderBase.)
Protected field | archID | (Inherited from OrderBase.)
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | currency | (Inherited from OrderBase.)
Protected field | dcTran | (Inherited from OrderBase.)
Protected field | deliverTo | (Inherited from OrderBase.)
Protected field | deliveryMethod | (Inherited from OrderBase.)
Protected field | detail | (Inherited from OrderBase.)
Protected field | glBatch | (Inherited from OrderBase.)
Protected field | invoiceTo | (Inherited from OrderBase.)
Protected field | orderPriority | (Inherited from OrderBase.)
Protected field | orderStatus | (Inherited from OrderBase.)
Protected field | originalDocument | (Inherited from OrderBase.)
Protected field | processingAdditionalCosts | (Inherited from OrderBase.)
Protected field | processLedger | Should the document process to AR or AP ledger? (Inherited from OrderBase.)
Protected field | processStock | (Inherited from OrderBase.)
Protected field | project | (Inherited from OrderBase.)
Protected field | prospect | (Inherited from OrderBase.)
Protected field | settlementTerms | (Inherited from OrderBase.)
Protected field | taxType | (Inherited from OrderBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

PurchasesDocumentBase Class


PurchasesDocumentBase Methods

[image] [image]

Pastel Evolution SDK
PurchasesDocumentBase Methods
PurchasesDocumentBase Class See Also Send Feedback

The PurchasesDocumentBase type exposes the following members.

Methods

 | Name | Description
Public method | _SetFullQtyToProcess | (Inherited from OrderBase.)
Protected method | BeforePostGLBatch | (Inherited from OrderBase.)
Protected method | BeforePostInventory | (Inherited from OrderBase.)
Protected method | BeforePostLedger | (Inherited from OrderBase.)
Protected method | BeforeSave | (Inherited from OrderBase.)
Protected method | cascadeForeignValues | (Inherited from OrderBase.)
Protected method | cascadeProject | (Inherited from OrderBase.)
Protected method | cascadeTaxRate | (Inherited from OrderBase.)
Public method | Complete()()()() | Processes (invoices) all outstanding quantities on the order. The entire invoice fails if one or more detail lines do not have sufficient stock available. The CompleteMax method (SalesOrder only) is a variation on this method and attempts to confirm as much of the ordered stock as is available. (Inherited from OrderBase.)
Public method | Complete(String) | Process (invoice) all outstanding quantities on the order. The entire invoice fails if one or more detail lines do not have sufficient stock available. The method is a variation on this method and attempts to confirm as much of the ordered stock as is available. (Inherited from OrderBase.)
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Protected method | Detach | (Inherited from OrderBase.)
Protected method | detailRemainsOutstanding | (Inherited from OrderBase.)
Protected method | detailToProcess | (Inherited from OrderBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | fullQtySelected | (Inherited from OrderBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | glCreditPosting | (Inherited from OrderBase.)
Protected method | glDebitPosting | (Inherited from OrderBase.)
Protected method | initialise | Reverts the order to an unsaved, version 0 (see remarks) state. (Inherited from OrderBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Not supported. Use the delete facility from inside Evolution. (Inherited from OrderBase.)
Protected method | OnSave | (Overrides OrderBase..::..OnSave()()()().)
Public method | Process()()()() | Posts the document to the various accounts and ledgers applicable. (Inherited from OrderBase.)
Public method | Process(String) | Posts the document to the various accounts and ledgers applicable. (Inherited from OrderBase.)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

PurchasesDocumentBase Class


PurchasesDocumentBase.OnSave Method

[image]

Pastel Evolution SDK
PurchasesDocumentBase..::..OnSave Method
PurchasesDocumentBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

PurchasesDocumentBase Class
PurchasesDocumentBase Members


PurchasesDocumentBase Properties

[image] [image]

Pastel Evolution SDK
PurchasesDocumentBase Properties
PurchasesDocumentBase Class See Also Send Feedback

The PurchasesDocumentBase type exposes the following members.

Properties

 | Name | Description
Public property | Account | Gets or sets the AR or AP account associated with the order. (Inherited from OrderBase.)
Public property | AccountID | Gets or sets the ID of the AR or AP account associated with the order. (Inherited from OrderBase.)
Public property | AdditionalCosts |
Public property | AllowInvoiceRounding | (Inherited from OrderBase.)
Public property | ApplyTaxPerLine | Gets or sets whether tax per line should be applied. (Inherited from OrderBase.)
Public property | Audit | Gets the audit number of the last transaction processed by this document. This value defaults to 0, and will not be available on recalled documents. (Inherited from OrderBase.)
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Currency | Gets or sets the currency. (Inherited from OrderBase.)
Public property | CurrencyID | Gets or sets the document's currency ID. (Inherited from OrderBase.)
Public property | DeliverTo | Gets or sets the delivery address. (Inherited from OrderBase.)
Public property | DeliveryDate | Gets or sets the delivery date. (Inherited from OrderBase.)
Public property | DeliveryMethod | Gets or sets the delivery method. (Inherited from OrderBase.)
Public property | DeliveryMethodID | Gets or sets the delivery method ID. (Inherited from OrderBase.)
Public property | Description | Gets or sets the document description. This will also be the description on any transactions posted. (Inherited from OrderBase.)
Public property | Detail | Gets the order detail collection representing the body of the document. (Inherited from OrderBase.)
Public property | Discount | Gets or sets the document discount amount (applicable to tax excl. total), (Inherited from OrderBase.)
Public property | DiscountForeign | Gets or sets the document foreign discount amount (applicable to tax excl. total), (Inherited from OrderBase.)
Public property | DiscountLastProcessed | Gets the document discount amount last processed. (Inherited from OrderBase.)
Public property | DiscountPercent | Gets or sets the document discount percentage. (Inherited from OrderBase.)
Public property | DiscountToProcess | Gets the document discount amount about to be processed (applicable to tax excl. total). (Inherited from OrderBase.)
Public property | DueDate | Gets or sets the due date. (Inherited from OrderBase.)
Public property | ExchangeRate | Gets or sets the exchange rate. (Inherited from OrderBase.)
Public property | ExternalOrderNo | Gets or sets the external order number. (Inherited from OrderBase.)
Protected property | grossLastProcessTotal | (Inherited from OrderBase.)
Protected property | grossLastProcessTotalForeign | (Inherited from OrderBase.)
Protected property | grossOutstTotal | (Inherited from OrderBase.)
Protected property | grossOutstTotalForeign | (Inherited from OrderBase.)
Protected property | grossToProcessTotal | (Inherited from OrderBase.)
Protected property | grossToProcessTotalForeign | (Inherited from OrderBase.)
Protected property | grossTotal | (Inherited from OrderBase.)
Protected property | grossTotalForeign | (Inherited from OrderBase.)
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Inherited from OrderBase.)
Public property | InvoiceDate | Gets or sets the invoice date. (Inherited from OrderBase.)
Public property | InvoiceTo | Gets or sets the invoice address. (Inherited from OrderBase.)
Public property | IsLoading | Will be true while the order is busy loading detail. (Inherited from OrderBase.)
Public property | IsPartialProcessingAllowed | (Inherited from OrderBase.)
Public property | IsProcessing | Will be true while the order is busy processing transactions. (Inherited from OrderBase.)
Public property | LedgerTransaction | Gets the last ledger transaction (AR/AP Transaction) posted. (Inherited from OrderBase.)
Protected property | lineAdditionalCostTotal | (Inherited from OrderBase.)
Public property | LongID | (Inherited from OrderBase.)
Public property | MessageLine1 | Gets or sets the 1st message line. (Inherited from OrderBase.)
Public property | MessageLine2 | Gets or sets the 2nd message line. (Inherited from OrderBase.)
Public property | MessageLine3 | Gets or sets the 3rd message line. (Inherited from OrderBase.)
Protected property | nettLastProcessTotal | (Inherited from OrderBase.)
Protected property | nettLastProcessTotalForeign | (Inherited from OrderBase.)
Protected property | nettOutstTotal | (Inherited from OrderBase.)
Protected property | nettOutstTotalForeign | (Inherited from OrderBase.)
Protected property | nettToProcessTotal | (Inherited from OrderBase.)
Protected property | nettToProcessTotalForeign | (Inherited from OrderBase.)
Public property | OrderDate | Gets or sets the order date. (Inherited from OrderBase.)
Public property | OrderNo | Gets or sets the order number. (Inherited from OrderBase.)
Public property | OrderPriority | Gets or sets the order priority. (Inherited from OrderBase.)
Public property | OrderPriorityID | Gets or sets the order priority ID. (Inherited from OrderBase.)
Public property | OrderStatus | Gets or sets the document's order status. (Inherited from OrderBase.)
Public property | OrderStatusID | Gets or sets the order status ID. (Inherited from OrderBase.)
Public property | OriginalDocument | Gets the original document. (Inherited from OrderBase.)
Public property | PrintCount | Gets or sets the print count. (Inherited from OrderBase.)
Public property | Project | Gets or sets the project. (Inherited from OrderBase.)
Public property | ProjectID | Gets or sets the project ID. (Inherited from OrderBase.)
Public property | Prospect | (Inherited from OrderBase.)
Public property | ProspectID | (Inherited from OrderBase.)
Public property | RawFieldData | Obsolete. (Inherited from OrderBase.)
Public property | Reference | Gets or sets the document reference (InvNumber). (Inherited from OrderBase.)
Public property | Reference2 | Gets the 2nd document reference. (Inherited from OrderBase.)
Public property | SettlementTerms | (Inherited from OrderBase.)
Public property | SettlementTermsID | (Inherited from OrderBase.)
Public property | State | Gets the document state. (Inherited from OrderBase.)
Protected property | taxLastProcessTotal | (Inherited from OrderBase.)
Protected property | taxLastProcessTotalForeign | (Inherited from OrderBase.)
Public property | TaxMode | Gets or sets the tax mode. (Inherited from OrderBase.)
Public property | TaxNumber | Gets or sets the cash account's tax number. (Inherited from OrderBase.)
Protected property | taxOutstTotal | (Inherited from OrderBase.)
Protected property | taxOutstTotalForeign | (Inherited from OrderBase.)
Protected property | taxToProcessTotal | (Inherited from OrderBase.)
Protected property | taxToProcessTotalForeign | (Inherited from OrderBase.)
Protected property | taxTotal | (Inherited from OrderBase.)
Protected property | taxTotalForeign | (Inherited from OrderBase.)
Public property | TaxType | (Inherited from OrderBase.)
Public property | TotalDiscountAdjusted | Gets the total discount adjusted amount. (Inherited from OrderBase.)
Public property | TotalDiscountAdjustedForeign | Gets the total discount adjusted foreign amount. (Inherited from OrderBase.)
Public property | TotalExcl | Gets the total excl amount. (Inherited from OrderBase.)
Public property | TotalExclForeign | Gets the total excl amount. (Inherited from OrderBase.)
Public property | TotalIncl | Gets the total incl amount. (Inherited from OrderBase.)
Public property | TotalInclForeign | Gets the total incl amount. (Inherited from OrderBase.)
Public property | TotalInclForeignBeforeInvoiceRounding | Gets the total incl amount before Invoice Rounding. (Inherited from OrderBase.)
Public property | TotalLastProcessExcl | Gets the total last process excl. (Inherited from OrderBase.)
Public property | TotalLastProcessExclForeign | Gets the total last process excl. (Inherited from OrderBase.)
Public property | TotalLastProcessIncl | Gets the total last process incl. (Inherited from OrderBase.)
Public property | TotalLastProcessInclForeign | Gets the total last process incl. (Inherited from OrderBase.)
Public property | TotalLastProcessTax | Gets the total last process tax. (Inherited from OrderBase.)
Public property | TotalLastProcessTaxForeign | Gets the total last process tax. (Inherited from OrderBase.)
Public property | TotalOutstandingExcl | Gets the total outstanding excl. (Inherited from OrderBase.)
Public property | TotalOutstandingExclForeign | Gets the total outstanding excl. (Inherited from OrderBase.)
Public property | TotalOutstandingIncl | Gets the total outstanding incl. (Inherited from OrderBase.)
Public property | TotalOutstandingInclForeign | Gets the total outstanding incl. (Inherited from OrderBase.)
Public property | TotalOutstandingTax | Gets the total outstanding tax. (Inherited from OrderBase.)
Public property | TotalOutstandingTaxForeign | Gets the total outstanding tax. (Inherited from OrderBase.)
Public property | TotalTax | Gets the total tax amount. (Inherited from OrderBase.)
Public property | TotalTaxForeign | Gets the total tax amount. (Inherited from OrderBase.)
Public property | TotalToProcessExcl | Gets the total amount to process excl. (Inherited from OrderBase.)
Public property | TotalToProcessExclForeign | Gets the total amount to process excl. (Inherited from OrderBase.)
Public property | TotalToProcessIncl | Gets the total to process incl. (Inherited from OrderBase.)
Public property | TotalToProcessInclForeign | Gets the total to process incl. (Inherited from OrderBase.)
Public property | TotalToProcessTax | Gets the total to process tax. (Inherited from OrderBase.)
Public property | TotalToProcessTaxForeign | Gets the total to process tax. (Inherited from OrderBase.)
Public property | Type | Gets the order's document type. (Inherited from OrderBase.)
Public property | UserFields | Gets access to the collection of user-defined fields on the record. Note that the field name is case-sensitive. (Inherited from OrderBase.)
Public property | Version | Gets the current version of the order, incremented on every save. (Inherited from OrderBase.)

See Also

PurchasesDocumentBase Class


PurchasesDocumentBase.AdditionalCosts Property

[image]

Pastel Evolution SDK
PurchasesDocumentBase..::..AdditionalCosts Property
PurchasesDocumentBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public CostAllocationCollection AdditionalCosts { get; }
Visual Basic
Public ReadOnly Property AdditionalCosts As CostAllocationCollection
    Get

Property Value

Type: CostAllocationCollection

See Also

PurchasesDocumentBase Class
PurchasesDocumentBase Members


RecordBase Class

[image]

Pastel Evolution SDK
RecordBase Class
Members See Also Send Feedback
Embodies a common Evolution record, such as an account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract class RecordBase
Visual Basic
Public MustInherit Class RecordBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..Branch
Pastel.Evolution..::..BranchedRecordBase

See Also

RecordBase Members


RecordBase Members

[image] [image]

Pastel Evolution SDK
RecordBase Members
RecordBase Class Constructors Methods Fields Properties See Also Send Feedback

The RecordBase type exposes the following members.

Constructors

 | Name | Description
Protected method | RecordBase | Initializes a new instance of the RecordBase class

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) |
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete |
Protected method | OnSave |
Public method | Save | Persists the record to the database.
 | TestRange |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | wrapper |

Properties

 | Name | Description
Public property | ID | Gets the internal record ID (0 for new, unsaved records).
Public property | LongID | Gets the internal record ID (0 for new, unsaved records).

See Also

RecordBase Class


RecordBase Constructor

[image]

Pastel Evolution SDK
RecordBase Constructor
RecordBase Class See Also Send Feedback
Initializes a new instance of the RecordBase class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected RecordBase()
Visual Basic
Protected Sub New

See Also

RecordBase Class
RecordBase Members


RecordBase Fields

[image] [image]

Pastel Evolution SDK
RecordBase Fields
RecordBase Class See Also Send Feedback

The RecordBase type exposes the following members.

Fields

 | Name | Description
Protected field | wrapper |

See Also

RecordBase Class


RecordBase.wrapper Field

[image]

Pastel Evolution SDK
RecordBase..::..wrapper Field
RecordBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal RecordWrapperBase wrapper
Visual Basic
Protected Friend wrapper As RecordWrapperBase

Field Value

Type: RecordWrapperBase

See Also

RecordBase Class
RecordBase Members


RecordBase Methods

[image] [image]

Pastel Evolution SDK
RecordBase Methods
RecordBase Class See Also Send Feedback

The RecordBase type exposes the following members.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) |
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete |
Protected method | OnSave |
Public method | Save | Persists the record to the database.
 | TestRange |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RecordBase Class


RecordBase.Delete Method

[image]

Pastel Evolution SDK
RecordBase..::..Delete Method
RecordBase Class See Also Send Feedback
Removes the record from the database, provided it is not referenced by other records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void Delete()
Visual Basic
Public Sub Delete

See Also

RecordBase Class
RecordBase Members


RecordBase.Equals Method

[image] [image]

Pastel Evolution SDK
RecordBase..::..Equals Method
RecordBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) |

See Also

RecordBase Class
RecordBase Members


RecordBase.Equals Method (RecordBase)

[image]

Pastel Evolution SDK
RecordBase..::..Equals Method (RecordBase)
RecordBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool Equals(
    RecordBase obj
)
Visual Basic
Public Function Equals (
    obj As RecordBase
) As Boolean

Parameters

obj
Type: Pastel.Evolution..::..RecordBase

Return Value

Type: Boolean

See Also

RecordBase Class
RecordBase Members
Equals Overload


RecordBase.OnDelete Method

[image]

Pastel Evolution SDK
RecordBase..::..OnDelete Method
RecordBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal abstract void OnDelete()
Visual Basic
Protected Friend MustOverride Sub OnDelete

See Also

RecordBase Class
RecordBase Members


RecordBase.OnSave Method

[image]

Pastel Evolution SDK
RecordBase..::..OnSave Method
RecordBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal abstract void OnSave()
Visual Basic
Protected Friend MustOverride Sub OnSave

See Also

RecordBase Class
RecordBase Members


RecordBase.Save Method

[image]

Pastel Evolution SDK
RecordBase..::..Save Method
RecordBase Class See Also Send Feedback
Persists the record to the database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void Save()
Visual Basic
Public Sub Save

See Also

RecordBase Class
RecordBase Members


RecordBase.TestRange Method

[image]

Pastel Evolution SDK
RecordBase..::..TestRange Method
RecordBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected static void TestRange(
    double value,
    double minValue,
    double maxValue,
    string valueDescription
)
Visual Basic
Protected Shared Sub TestRange (
    value As Double,
    minValue As Double,
    maxValue As Double,
    valueDescription As String
)

Parameters

value
Type: System..::..Double
minValue
Type: System..::..Double
maxValue
Type: System..::..Double
valueDescription
Type: System..::..String

See Also

RecordBase Class
RecordBase Members


RecordBase Properties

[image] [image]

Pastel Evolution SDK
RecordBase Properties
RecordBase Class See Also Send Feedback

The RecordBase type exposes the following members.

Properties

 | Name | Description
Public property | ID | Gets the internal record ID (0 for new, unsaved records).
Public property | LongID | Gets the internal record ID (0 for new, unsaved records).

See Also

RecordBase Class


RecordBase.ID Property

[image]

Pastel Evolution SDK
RecordBase..::..ID Property
RecordBase Class See Also Send Feedback
Gets the internal record ID (0 for new, unsaved records).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract int ID { get; }
Visual Basic
Public MustOverride ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

Remarks

Once saved, the ID will reflect the record's internal database identifier.

See Also

RecordBase Class
RecordBase Members


RecordBase.LongID Property

[image]

Pastel Evolution SDK
RecordBase..::..LongID Property
RecordBase Class See Also Send Feedback
Gets the internal record ID (0 for new, unsaved records).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract long LongID { get; }
Visual Basic
Public MustOverride ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

Remarks

Once saved, the ID will reflect the record's internal database identifier.

See Also

RecordBase Class
RecordBase Members


ReturnToSupplier Class

[image]

Pastel Evolution SDK
ReturnToSupplier Class
Members See Also Send Feedback
Represents a return to supplier document.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class ReturnToSupplier : PurchasesDocumentBase
Visual Basic
Public Class ReturnToSupplier
    Inherits PurchasesDocumentBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..OrderBase
Pastel.Evolution..::..PurchasesDocumentBase
Pastel.Evolution..::..ReturnToSupplier

See Also

ReturnToSupplier Members


ReturnToSupplier Members

[image] [image]

Pastel Evolution SDK
ReturnToSupplier Members
ReturnToSupplier Class Constructors Methods Fields Properties See Also Send Feedback

The ReturnToSupplier type exposes the following members.

Constructors

 | Name | Description
Public method | ReturnToSupplier()()()() | Initializes a new instance of the ReturnToSupplier class
Public method | ReturnToSupplier(Int32) | Initializes a new instance of the ReturnToSupplier class
Public method | ReturnToSupplier(String) | Initializes a new instance of the ReturnToSupplier class

Methods

 | Name | Description
Public method | _SetFullQtyToProcess | (Inherited from OrderBase.)
Protected method | BeforePostGLBatch | (Overrides OrderBase..::..BeforePostGLBatch(OrderBase, CancelEventArgs).)
Protected method | BeforePostInventory | (Overrides OrderBase..::..BeforePostInventory(OrderBase, CancelEventArgs).)
Protected method | BeforePostLedger | (Overrides OrderBase..::..BeforePostLedger(OrderBase, CancelEventArgs).)
Protected method | BeforeSave | (Inherited from OrderBase.)
Protected method | cascadeForeignValues | (Inherited from OrderBase.)
Protected method | cascadeProject | (Inherited from OrderBase.)
Protected method | cascadeTaxRate | (Inherited from OrderBase.)
Public method | Complete()()()() | Processes (invoices) all outstanding quantities on the order. The entire invoice fails if one or more detail lines do not have sufficient stock available. The CompleteMax method (SalesOrder only) is a variation on this method and attempts to confirm as much of the ordered stock as is available. (Inherited from OrderBase.)
Public method | Complete(String) | Process (invoice) all outstanding quantities on the order. The entire invoice fails if one or more detail lines do not have sufficient stock available. The method is a variation on this method and attempts to confirm as much of the ordered stock as is available. (Inherited from OrderBase.)
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Protected method | Detach | (Inherited from OrderBase.)
Protected method | detailRemainsOutstanding | (Inherited from OrderBase.)
Protected method | detailToProcess | (Inherited from OrderBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds and returns the id of the first order matching the supplied criteria. E.g. OrderNum = 'PO0001'
Protected method | fullQtySelected | (Inherited from OrderBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | glCreditPosting | (Overrides OrderBase..::..glCreditPosting(TransactionBase, TransactionBase..::..GLPostingEventArgs).)
Protected method | glDebitPosting | (Overrides OrderBase..::..glDebitPosting(TransactionBase, TransactionBase..::..GLPostingEventArgs).)
Protected method | initialise | (Overrides OrderBase..::..initialise()()()().)
 | List | Lists documents for the supplied criteria.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Not supported. Use the delete facility from inside Evolution. (Inherited from OrderBase.)
Protected method | OnSave | (Inherited from PurchasesDocumentBase.)
Public method | Process()()()() | Posts the document to the various accounts and ledgers applicable. (Inherited from OrderBase.)
Public method | Process(String) | Posts the document to the various accounts and ledgers applicable. (Inherited from OrderBase.)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | account | (Inherited from OrderBase.)
Protected field | archID | (Inherited from OrderBase.)
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | currency | (Inherited from OrderBase.)
Protected field | dcTran | (Inherited from OrderBase.)
Protected field | deliverTo | (Inherited from OrderBase.)
Protected field | deliveryMethod | (Inherited from OrderBase.)
Protected field | detail | (Inherited from OrderBase.)
Protected field | glBatch | (Inherited from OrderBase.)
Protected field | invoiceTo | (Inherited from OrderBase.)
Protected field | orderPriority | (Inherited from OrderBase.)
Protected field | orderStatus | (Inherited from OrderBase.)
Protected field | originalDocument | (Inherited from OrderBase.)
Protected field | processingAdditionalCosts | (Inherited from OrderBase.)
Protected field | processLedger | Should the document process to AR or AP ledger? (Inherited from OrderBase.)
Protected field | processStock | (Inherited from OrderBase.)
Protected field | project | (Inherited from OrderBase.)
Protected field | prospect | (Inherited from OrderBase.)
Protected field | settlementTerms | (Inherited from OrderBase.)
Protected field | taxType | (Inherited from OrderBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | Account | Gets or sets the AR or AP account associated with the order. (Inherited from OrderBase.)
Public property | AccountID | Gets or sets the ID of the AR or AP account associated with the order. (Inherited from OrderBase.)
Public property | AdditionalCosts | (Inherited from PurchasesDocumentBase.)
Public property | AllowInvoiceRounding | (Inherited from OrderBase.)
Public property | ApplyTaxPerLine | Gets or sets whether tax per line should be applied. (Inherited from OrderBase.)
Public property | Audit | Gets the audit number of the last transaction processed by this document. This value defaults to 0, and will not be available on recalled documents. (Inherited from OrderBase.)
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Currency | Gets or sets the currency. (Inherited from OrderBase.)
Public property | CurrencyID | Gets or sets the document's currency ID. (Inherited from OrderBase.)
Public property | DeliverTo | Gets or sets the delivery address. (Inherited from OrderBase.)
Public property | DeliveryDate | Gets or sets the delivery date. (Inherited from OrderBase.)
Public property | DeliveryMethod | Gets or sets the delivery method. (Inherited from OrderBase.)
Public property | DeliveryMethodID | Gets or sets the delivery method ID. (Inherited from OrderBase.)
Public property | Description | Gets or sets the document description. This will also be the description on any transactions posted. (Inherited from OrderBase.)
Public property | Detail | Gets the order detail collection representing the body of the document. (Inherited from OrderBase.)
Public property | Discount | Gets or sets the document discount amount (applicable to tax excl. total), (Inherited from OrderBase.)
Public property | DiscountForeign | Gets or sets the document foreign discount amount (applicable to tax excl. total), (Inherited from OrderBase.)
Public property | DiscountLastProcessed | Gets the document discount amount last processed. (Inherited from OrderBase.)
Public property | DiscountPercent | Gets or sets the document discount percentage. (Inherited from OrderBase.)
Public property | DiscountToProcess | Gets the document discount amount about to be processed (applicable to tax excl. total). (Inherited from OrderBase.)
Public property | DueDate | Gets or sets the due date. (Inherited from OrderBase.)
Public property | ExchangeRate | Gets or sets the exchange rate. (Inherited from OrderBase.)
Public property | ExternalOrderNo | Gets or sets the external order number. (Inherited from OrderBase.)
Protected property | grossLastProcessTotal | (Inherited from OrderBase.)
Protected property | grossLastProcessTotalForeign | (Inherited from OrderBase.)
Protected property | grossOutstTotal | (Inherited from OrderBase.)
Protected property | grossOutstTotalForeign | (Inherited from OrderBase.)
Protected property | grossToProcessTotal | (Inherited from OrderBase.)
Protected property | grossToProcessTotalForeign | (Inherited from OrderBase.)
Protected property | grossTotal | (Inherited from OrderBase.)
Protected property | grossTotalForeign | (Inherited from OrderBase.)
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Inherited from OrderBase.)
Public property | InvoiceDate | Gets or sets the invoice date. (Inherited from OrderBase.)
Public property | InvoiceNumber |
Public property | InvoiceTo | Gets or sets the invoice address. (Inherited from OrderBase.)
Public property | IsLoading | Will be true while the order is busy loading detail. (Inherited from OrderBase.)
Public property | IsPartialProcessingAllowed | (Overrides OrderBase..::..IsPartialProcessingAllowed.)
Public property | IsProcessing | Will be true while the order is busy processing transactions. (Inherited from OrderBase.)
Public property | LedgerTransaction | Gets the last ledger transaction (AR/AP Transaction) posted. (Inherited from OrderBase.)
Protected property | lineAdditionalCostTotal | (Inherited from OrderBase.)
Public property | LongID | (Inherited from OrderBase.)
Public property | MessageLine1 | Gets or sets the 1st message line. (Inherited from OrderBase.)
Public property | MessageLine2 | Gets or sets the 2nd message line. (Inherited from OrderBase.)
Public property | MessageLine3 | Gets or sets the 3rd message line. (Inherited from OrderBase.)
Protected property | nettLastProcessTotal | (Inherited from OrderBase.)
Protected property | nettLastProcessTotalForeign | (Inherited from OrderBase.)
Protected property | nettOutstTotal | (Inherited from OrderBase.)
Protected property | nettOutstTotalForeign | (Inherited from OrderBase.)
Protected property | nettToProcessTotal | (Inherited from OrderBase.)
Protected property | nettToProcessTotalForeign | (Inherited from OrderBase.)
Public property | OrderDate | Gets or sets the order date. (Inherited from OrderBase.)
Public property | OrderNo | Gets or sets the order number. (Inherited from OrderBase.)
Public property | OrderPriority | Gets or sets the order priority. (Inherited from OrderBase.)
Public property | OrderPriorityID | Gets or sets the order priority ID. (Inherited from OrderBase.)
Public property | OrderStatus | Gets or sets the document's order status. (Inherited from OrderBase.)
Public property | OrderStatusID | Gets or sets the order status ID. (Inherited from OrderBase.)
Public property | OriginalDocument | (Overrides OrderBase..::..OriginalDocument.)
Public property | PrintCount | Gets or sets the print count. (Inherited from OrderBase.)
Public property | Project | Gets or sets the project. (Inherited from OrderBase.)
Public property | ProjectID | Gets or sets the project ID. (Inherited from OrderBase.)
Public property | Prospect | (Inherited from OrderBase.)
Public property | ProspectID | (Inherited from OrderBase.)
Public property | RawFieldData | Obsolete. (Inherited from OrderBase.)
Public property | Reference | Gets or sets the document reference (InvNumber). (Inherited from OrderBase.)
Public property | Reference2 | Gets the 2nd document reference. (Inherited from OrderBase.)
Public property | SettlementTerms | (Inherited from OrderBase.)
Public property | SettlementTermsID | (Inherited from OrderBase.)
Public property | State | Gets the document state. (Inherited from OrderBase.)
Public property | Supplier |
Protected property | taxLastProcessTotal | (Inherited from OrderBase.)
Protected property | taxLastProcessTotalForeign | (Inherited from OrderBase.)
Public property | TaxMode | Gets or sets the tax mode. (Inherited from OrderBase.)
Public property | TaxNumber | Gets or sets the cash account's tax number. (Inherited from OrderBase.)
Protected property | taxOutstTotal | (Inherited from OrderBase.)
Protected property | taxOutstTotalForeign | (Inherited from OrderBase.)
Protected property | taxToProcessTotal | (Inherited from OrderBase.)
Protected property | taxToProcessTotalForeign | (Inherited from OrderBase.)
Protected property | taxTotal | (Inherited from OrderBase.)
Protected property | taxTotalForeign | (Inherited from OrderBase.)
Public property | TaxType | (Inherited from OrderBase.)
Public property | TotalDiscountAdjusted | Gets the total discount adjusted amount. (Inherited from OrderBase.)
Public property | TotalDiscountAdjustedForeign | Gets the total discount adjusted foreign amount. (Inherited from OrderBase.)
Public property | TotalExcl | Gets the total excl amount. (Inherited from OrderBase.)
Public property | TotalExclForeign | Gets the total excl amount. (Inherited from OrderBase.)
Public property | TotalIncl | Gets the total incl amount. (Inherited from OrderBase.)
Public property | TotalInclForeign | Gets the total incl amount. (Inherited from OrderBase.)
Public property | TotalInclForeignBeforeInvoiceRounding | Gets the total incl amount before Invoice Rounding. (Inherited from OrderBase.)
Public property | TotalLastProcessExcl | Gets the total last process excl. (Inherited from OrderBase.)
Public property | TotalLastProcessExclForeign | Gets the total last process excl. (Inherited from OrderBase.)
Public property | TotalLastProcessIncl | Gets the total last process incl. (Inherited from OrderBase.)
Public property | TotalLastProcessInclForeign | Gets the total last process incl. (Inherited from OrderBase.)
Public property | TotalLastProcessTax | Gets the total last process tax. (Inherited from OrderBase.)
Public property | TotalLastProcessTaxForeign | Gets the total last process tax. (Inherited from OrderBase.)
Public property | TotalOutstandingExcl | Gets the total outstanding excl. (Inherited from OrderBase.)
Public property | TotalOutstandingExclForeign | Gets the total outstanding excl. (Inherited from OrderBase.)
Public property | TotalOutstandingIncl | Gets the total outstanding incl. (Inherited from OrderBase.)
Public property | TotalOutstandingInclForeign | Gets the total outstanding incl. (Inherited from OrderBase.)
Public property | TotalOutstandingTax | Gets the total outstanding tax. (Inherited from OrderBase.)
Public property | TotalOutstandingTaxForeign | Gets the total outstanding tax. (Inherited from OrderBase.)
Public property | TotalTax | Gets the total tax amount. (Inherited from OrderBase.)
Public property | TotalTaxForeign | Gets the total tax amount. (Inherited from OrderBase.)
Public property | TotalToProcessExcl | Gets the total amount to process excl. (Inherited from OrderBase.)
Public property | TotalToProcessExclForeign | Gets the total amount to process excl. (Inherited from OrderBase.)
Public property | TotalToProcessIncl | Gets the total to process incl. (Inherited from OrderBase.)
Public property | TotalToProcessInclForeign | Gets the total to process incl. (Inherited from OrderBase.)
Public property | TotalToProcessTax | Gets the total to process tax. (Inherited from OrderBase.)
Public property | TotalToProcessTaxForeign | Gets the total to process tax. (Inherited from OrderBase.)
Public property | Type | Gets the order's document type. (Inherited from OrderBase.)
Public property | UserFields | Gets access to the collection of user-defined fields on the record. Note that the field name is case-sensitive. (Inherited from OrderBase.)
Public property | Version | Gets the current version of the order, incremented on every save. (Inherited from OrderBase.)

See Also

ReturnToSupplier Class


ReturnToSupplier Constructor

[image] [image]

Pastel Evolution SDK
ReturnToSupplier Constructor
ReturnToSupplier Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ReturnToSupplier()()()() | Initializes a new instance of the ReturnToSupplier class
Public method | ReturnToSupplier(Int32) | Initializes a new instance of the ReturnToSupplier class
Public method | ReturnToSupplier(String) | Initializes a new instance of the ReturnToSupplier class

See Also

ReturnToSupplier Class
ReturnToSupplier Members


ReturnToSupplier Constructor

[image]

Pastel Evolution SDK
ReturnToSupplier Constructor
ReturnToSupplier Class See Also Send Feedback
Initializes a new instance of the ReturnToSupplier class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public ReturnToSupplier()
Visual Basic
Public Sub New

See Also

ReturnToSupplier Class
ReturnToSupplier Members
ReturnToSupplier Overload


ReturnToSupplier Constructor (Int32)

[image]

Pastel Evolution SDK
ReturnToSupplier Constructor (Int32)
ReturnToSupplier Class See Also Send Feedback
Initializes a new instance of the ReturnToSupplier class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public ReturnToSupplier(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32

See Also

ReturnToSupplier Class
ReturnToSupplier Members
ReturnToSupplier Overload


ReturnToSupplier Constructor (String)

[image]

Pastel Evolution SDK
ReturnToSupplier Constructor (String)
ReturnToSupplier Class See Also Send Feedback
Initializes a new instance of the ReturnToSupplier class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public ReturnToSupplier(
    string reference
)
Visual Basic
Public Sub New (
    reference As String
)

Parameters

reference
Type: System..::..String

See Also

ReturnToSupplier Class
ReturnToSupplier Members
ReturnToSupplier Overload


ReturnToSupplier Fields

[image] [image]

Pastel Evolution SDK
ReturnToSupplier Fields
ReturnToSupplier Class See Also Send Feedback

The ReturnToSupplier type exposes the following members.

Fields

 | Name | Description
Protected field | account | (Inherited from OrderBase.)
Protected field | archID | (Inherited from OrderBase.)
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | currency | (Inherited from OrderBase.)
Protected field | dcTran | (Inherited from OrderBase.)
Protected field | deliverTo | (Inherited from OrderBase.)
Protected field | deliveryMethod | (Inherited from OrderBase.)
Protected field | detail | (Inherited from OrderBase.)
Protected field | glBatch | (Inherited from OrderBase.)
Protected field | invoiceTo | (Inherited from OrderBase.)
Protected field | orderPriority | (Inherited from OrderBase.)
Protected field | orderStatus | (Inherited from OrderBase.)
Protected field | originalDocument | (Inherited from OrderBase.)
Protected field | processingAdditionalCosts | (Inherited from OrderBase.)
Protected field | processLedger | Should the document process to AR or AP ledger? (Inherited from OrderBase.)
Protected field | processStock | (Inherited from OrderBase.)
Protected field | project | (Inherited from OrderBase.)
Protected field | prospect | (Inherited from OrderBase.)
Protected field | settlementTerms | (Inherited from OrderBase.)
Protected field | taxType | (Inherited from OrderBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

ReturnToSupplier Class


ReturnToSupplier Methods

[image] [image]

Pastel Evolution SDK
ReturnToSupplier Methods
ReturnToSupplier Class See Also Send Feedback

The ReturnToSupplier type exposes the following members.

Methods

 | Name | Description
Public method | _SetFullQtyToProcess | (Inherited from OrderBase.)
Protected method | BeforePostGLBatch | (Overrides OrderBase..::..BeforePostGLBatch(OrderBase, CancelEventArgs).)
Protected method | BeforePostInventory | (Overrides OrderBase..::..BeforePostInventory(OrderBase, CancelEventArgs).)
Protected method | BeforePostLedger | (Overrides OrderBase..::..BeforePostLedger(OrderBase, CancelEventArgs).)
Protected method | BeforeSave | (Inherited from OrderBase.)
Protected method | cascadeForeignValues | (Inherited from OrderBase.)
Protected method | cascadeProject | (Inherited from OrderBase.)
Protected method | cascadeTaxRate | (Inherited from OrderBase.)
Public method | Complete()()()() | Processes (invoices) all outstanding quantities on the order. The entire invoice fails if one or more detail lines do not have sufficient stock available. The CompleteMax method (SalesOrder only) is a variation on this method and attempts to confirm as much of the ordered stock as is available. (Inherited from OrderBase.)
Public method | Complete(String) | Process (invoice) all outstanding quantities on the order. The entire invoice fails if one or more detail lines do not have sufficient stock available. The method is a variation on this method and attempts to confirm as much of the ordered stock as is available. (Inherited from OrderBase.)
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Protected method | Detach | (Inherited from OrderBase.)
Protected method | detailRemainsOutstanding | (Inherited from OrderBase.)
Protected method | detailToProcess | (Inherited from OrderBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds and returns the id of the first order matching the supplied criteria. E.g. OrderNum = 'PO0001'
Protected method | fullQtySelected | (Inherited from OrderBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | glCreditPosting | (Overrides OrderBase..::..glCreditPosting(TransactionBase, TransactionBase..::..GLPostingEventArgs).)
Protected method | glDebitPosting | (Overrides OrderBase..::..glDebitPosting(TransactionBase, TransactionBase..::..GLPostingEventArgs).)
Protected method | initialise | (Overrides OrderBase..::..initialise()()()().)
 | List | Lists documents for the supplied criteria.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Not supported. Use the delete facility from inside Evolution. (Inherited from OrderBase.)
Protected method | OnSave | (Inherited from PurchasesDocumentBase.)
Public method | Process()()()() | Posts the document to the various accounts and ledgers applicable. (Inherited from OrderBase.)
Public method | Process(String) | Posts the document to the various accounts and ledgers applicable. (Inherited from OrderBase.)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

ReturnToSupplier Class


ReturnToSupplier.BeforePostGLBatch Method

[image]

Pastel Evolution SDK
ReturnToSupplier..::..BeforePostGLBatch Method
ReturnToSupplier Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected override void BeforePostGLBatch(
    OrderBase orderBase,
    CancelEventArgs e
)
Visual Basic
Protected Overrides Sub BeforePostGLBatch (
    orderBase As OrderBase,
    e As CancelEventArgs
)

Parameters

orderBase
Type: Pastel.Evolution..::..OrderBase
e
Type: System.ComponentModel..::..CancelEventArgs

See Also

ReturnToSupplier Class
ReturnToSupplier Members


ReturnToSupplier.BeforePostInventory Method

[image]

Pastel Evolution SDK
ReturnToSupplier..::..BeforePostInventory Method
ReturnToSupplier Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected override void BeforePostInventory(
    OrderBase orderBase,
    CancelEventArgs e
)
Visual Basic
Protected Overrides Sub BeforePostInventory (
    orderBase As OrderBase,
    e As CancelEventArgs
)

Parameters

orderBase
Type: Pastel.Evolution..::..OrderBase
e
Type: System.ComponentModel..::..CancelEventArgs

See Also

ReturnToSupplier Class
ReturnToSupplier Members


ReturnToSupplier.BeforePostLedger Method

[image]

Pastel Evolution SDK
ReturnToSupplier..::..BeforePostLedger Method
ReturnToSupplier Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected override void BeforePostLedger(
    OrderBase orderBase,
    CancelEventArgs e
)
Visual Basic
Protected Overrides Sub BeforePostLedger (
    orderBase As OrderBase,
    e As CancelEventArgs
)

Parameters

orderBase
Type: Pastel.Evolution..::..OrderBase
e
Type: System.ComponentModel..::..CancelEventArgs

See Also

ReturnToSupplier Class
ReturnToSupplier Members


ReturnToSupplier.Find Method

[image]

Pastel Evolution SDK
ReturnToSupplier..::..Find Method
ReturnToSupplier Class See Also Send Feedback
Finds and returns the id of the first order matching the supplied criteria. E.g. OrderNum = 'PO0001'

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.

Return Value

Type: Int32
The ID of the first record found; -1 if not record was found.

See Also

ReturnToSupplier Class
ReturnToSupplier Members


ReturnToSupplier.glCreditPosting Method

[image]

Pastel Evolution SDK
ReturnToSupplier..::..glCreditPosting Method
ReturnToSupplier Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected override void glCreditPosting(
    TransactionBase sender,
    TransactionBase..::..GLPostingEventArgs e
)
Visual Basic
Protected Overrides Sub glCreditPosting (
    sender As TransactionBase,
    e As TransactionBase..::..GLPostingEventArgs
)

Parameters

sender
Type: Pastel.Evolution..::..TransactionBase
e
Type: Pastel.Evolution..::..TransactionBase..::..GLPostingEventArgs

See Also

ReturnToSupplier Class
ReturnToSupplier Members


ReturnToSupplier.glDebitPosting Method

[image]

Pastel Evolution SDK
ReturnToSupplier..::..glDebitPosting Method
ReturnToSupplier Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected override void glDebitPosting(
    TransactionBase sender,
    TransactionBase..::..GLPostingEventArgs e
)
Visual Basic
Protected Overrides Sub glDebitPosting (
    sender As TransactionBase,
    e As TransactionBase..::..GLPostingEventArgs
)

Parameters

sender
Type: Pastel.Evolution..::..TransactionBase
e
Type: Pastel.Evolution..::..TransactionBase..::..GLPostingEventArgs

See Also

ReturnToSupplier Class
ReturnToSupplier Members


ReturnToSupplier.initialise Method

[image]

Pastel Evolution SDK
ReturnToSupplier..::..initialise Method
ReturnToSupplier Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void initialise()
Visual Basic
Protected Friend Overrides Sub initialise

See Also

ReturnToSupplier Class
ReturnToSupplier Members


ReturnToSupplier.List Method

[image]

Pastel Evolution SDK
ReturnToSupplier..::..List Method
ReturnToSupplier Class See Also Send Feedback
Lists documents for the supplied criteria.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria
)
Visual Basic
Public Shared Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String
E.g. Supplier.Account = 'SUPP001' and (OrderNum = 'PO209302')

Return Value

Type: DataTable

Remarks

Table aliases: Core, Supplier

See Also

ReturnToSupplier Class
ReturnToSupplier Members


ReturnToSupplier Properties

[image] [image]

Pastel Evolution SDK
ReturnToSupplier Properties
ReturnToSupplier Class See Also Send Feedback

The ReturnToSupplier type exposes the following members.

Properties

 | Name | Description
Public property | Account | Gets or sets the AR or AP account associated with the order. (Inherited from OrderBase.)
Public property | AccountID | Gets or sets the ID of the AR or AP account associated with the order. (Inherited from OrderBase.)
Public property | AdditionalCosts | (Inherited from PurchasesDocumentBase.)
Public property | AllowInvoiceRounding | (Inherited from OrderBase.)
Public property | ApplyTaxPerLine | Gets or sets whether tax per line should be applied. (Inherited from OrderBase.)
Public property | Audit | Gets the audit number of the last transaction processed by this document. This value defaults to 0, and will not be available on recalled documents. (Inherited from OrderBase.)
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Currency | Gets or sets the currency. (Inherited from OrderBase.)
Public property | CurrencyID | Gets or sets the document's currency ID. (Inherited from OrderBase.)
Public property | DeliverTo | Gets or sets the delivery address. (Inherited from OrderBase.)
Public property | DeliveryDate | Gets or sets the delivery date. (Inherited from OrderBase.)
Public property | DeliveryMethod | Gets or sets the delivery method. (Inherited from OrderBase.)
Public property | DeliveryMethodID | Gets or sets the delivery method ID. (Inherited from OrderBase.)
Public property | Description | Gets or sets the document description. This will also be the description on any transactions posted. (Inherited from OrderBase.)
Public property | Detail | Gets the order detail collection representing the body of the document. (Inherited from OrderBase.)
Public property | Discount | Gets or sets the document discount amount (applicable to tax excl. total), (Inherited from OrderBase.)
Public property | DiscountForeign | Gets or sets the document foreign discount amount (applicable to tax excl. total), (Inherited from OrderBase.)
Public property | DiscountLastProcessed | Gets the document discount amount last processed. (Inherited from OrderBase.)
Public property | DiscountPercent | Gets or sets the document discount percentage. (Inherited from OrderBase.)
Public property | DiscountToProcess | Gets the document discount amount about to be processed (applicable to tax excl. total). (Inherited from OrderBase.)
Public property | DueDate | Gets or sets the due date. (Inherited from OrderBase.)
Public property | ExchangeRate | Gets or sets the exchange rate. (Inherited from OrderBase.)
Public property | ExternalOrderNo | Gets or sets the external order number. (Inherited from OrderBase.)
Protected property | grossLastProcessTotal | (Inherited from OrderBase.)
Protected property | grossLastProcessTotalForeign | (Inherited from OrderBase.)
Protected property | grossOutstTotal | (Inherited from OrderBase.)
Protected property | grossOutstTotalForeign | (Inherited from OrderBase.)
Protected property | grossToProcessTotal | (Inherited from OrderBase.)
Protected property | grossToProcessTotalForeign | (Inherited from OrderBase.)
Protected property | grossTotal | (Inherited from OrderBase.)
Protected property | grossTotalForeign | (Inherited from OrderBase.)
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Inherited from OrderBase.)
Public property | InvoiceDate | Gets or sets the invoice date. (Inherited from OrderBase.)
Public property | InvoiceNumber |
Public property | InvoiceTo | Gets or sets the invoice address. (Inherited from OrderBase.)
Public property | IsLoading | Will be true while the order is busy loading detail. (Inherited from OrderBase.)
Public property | IsPartialProcessingAllowed | (Overrides OrderBase..::..IsPartialProcessingAllowed.)
Public property | IsProcessing | Will be true while the order is busy processing transactions. (Inherited from OrderBase.)
Public property | LedgerTransaction | Gets the last ledger transaction (AR/AP Transaction) posted. (Inherited from OrderBase.)
Protected property | lineAdditionalCostTotal | (Inherited from OrderBase.)
Public property | LongID | (Inherited from OrderBase.)
Public property | MessageLine1 | Gets or sets the 1st message line. (Inherited from OrderBase.)
Public property | MessageLine2 | Gets or sets the 2nd message line. (Inherited from OrderBase.)
Public property | MessageLine3 | Gets or sets the 3rd message line. (Inherited from OrderBase.)
Protected property | nettLastProcessTotal | (Inherited from OrderBase.)
Protected property | nettLastProcessTotalForeign | (Inherited from OrderBase.)
Protected property | nettOutstTotal | (Inherited from OrderBase.)
Protected property | nettOutstTotalForeign | (Inherited from OrderBase.)
Protected property | nettToProcessTotal | (Inherited from OrderBase.)
Protected property | nettToProcessTotalForeign | (Inherited from OrderBase.)
Public property | OrderDate | Gets or sets the order date. (Inherited from OrderBase.)
Public property | OrderNo | Gets or sets the order number. (Inherited from OrderBase.)
Public property | OrderPriority | Gets or sets the order priority. (Inherited from OrderBase.)
Public property | OrderPriorityID | Gets or sets the order priority ID. (Inherited from OrderBase.)
Public property | OrderStatus | Gets or sets the document's order status. (Inherited from OrderBase.)
Public property | OrderStatusID | Gets or sets the order status ID. (Inherited from OrderBase.)
Public property | OriginalDocument | (Overrides OrderBase..::..OriginalDocument.)
Public property | PrintCount | Gets or sets the print count. (Inherited from OrderBase.)
Public property | Project | Gets or sets the project. (Inherited from OrderBase.)
Public property | ProjectID | Gets or sets the project ID. (Inherited from OrderBase.)
Public property | Prospect | (Inherited from OrderBase.)
Public property | ProspectID | (Inherited from OrderBase.)
Public property | RawFieldData | Obsolete. (Inherited from OrderBase.)
Public property | Reference | Gets or sets the document reference (InvNumber). (Inherited from OrderBase.)
Public property | Reference2 | Gets the 2nd document reference. (Inherited from OrderBase.)
Public property | SettlementTerms | (Inherited from OrderBase.)
Public property | SettlementTermsID | (Inherited from OrderBase.)
Public property | State | Gets the document state. (Inherited from OrderBase.)
Public property | Supplier |
Protected property | taxLastProcessTotal | (Inherited from OrderBase.)
Protected property | taxLastProcessTotalForeign | (Inherited from OrderBase.)
Public property | TaxMode | Gets or sets the tax mode. (Inherited from OrderBase.)
Public property | TaxNumber | Gets or sets the cash account's tax number. (Inherited from OrderBase.)
Protected property | taxOutstTotal | (Inherited from OrderBase.)
Protected property | taxOutstTotalForeign | (Inherited from OrderBase.)
Protected property | taxToProcessTotal | (Inherited from OrderBase.)
Protected property | taxToProcessTotalForeign | (Inherited from OrderBase.)
Protected property | taxTotal | (Inherited from OrderBase.)
Protected property | taxTotalForeign | (Inherited from OrderBase.)
Public property | TaxType | (Inherited from OrderBase.)
Public property | TotalDiscountAdjusted | Gets the total discount adjusted amount. (Inherited from OrderBase.)
Public property | TotalDiscountAdjustedForeign | Gets the total discount adjusted foreign amount. (Inherited from OrderBase.)
Public property | TotalExcl | Gets the total excl amount. (Inherited from OrderBase.)
Public property | TotalExclForeign | Gets the total excl amount. (Inherited from OrderBase.)
Public property | TotalIncl | Gets the total incl amount. (Inherited from OrderBase.)
Public property | TotalInclForeign | Gets the total incl amount. (Inherited from OrderBase.)
Public property | TotalInclForeignBeforeInvoiceRounding | Gets the total incl amount before Invoice Rounding. (Inherited from OrderBase.)
Public property | TotalLastProcessExcl | Gets the total last process excl. (Inherited from OrderBase.)
Public property | TotalLastProcessExclForeign | Gets the total last process excl. (Inherited from OrderBase.)
Public property | TotalLastProcessIncl | Gets the total last process incl. (Inherited from OrderBase.)
Public property | TotalLastProcessInclForeign | Gets the total last process incl. (Inherited from OrderBase.)
Public property | TotalLastProcessTax | Gets the total last process tax. (Inherited from OrderBase.)
Public property | TotalLastProcessTaxForeign | Gets the total last process tax. (Inherited from OrderBase.)
Public property | TotalOutstandingExcl | Gets the total outstanding excl. (Inherited from OrderBase.)
Public property | TotalOutstandingExclForeign | Gets the total outstanding excl. (Inherited from OrderBase.)
Public property | TotalOutstandingIncl | Gets the total outstanding incl. (Inherited from OrderBase.)
Public property | TotalOutstandingInclForeign | Gets the total outstanding incl. (Inherited from OrderBase.)
Public property | TotalOutstandingTax | Gets the total outstanding tax. (Inherited from OrderBase.)
Public property | TotalOutstandingTaxForeign | Gets the total outstanding tax. (Inherited from OrderBase.)
Public property | TotalTax | Gets the total tax amount. (Inherited from OrderBase.)
Public property | TotalTaxForeign | Gets the total tax amount. (Inherited from OrderBase.)
Public property | TotalToProcessExcl | Gets the total amount to process excl. (Inherited from OrderBase.)
Public property | TotalToProcessExclForeign | Gets the total amount to process excl. (Inherited from OrderBase.)
Public property | TotalToProcessIncl | Gets the total to process incl. (Inherited from OrderBase.)
Public property | TotalToProcessInclForeign | Gets the total to process incl. (Inherited from OrderBase.)
Public property | TotalToProcessTax | Gets the total to process tax. (Inherited from OrderBase.)
Public property | TotalToProcessTaxForeign | Gets the total to process tax. (Inherited from OrderBase.)
Public property | Type | Gets the order's document type. (Inherited from OrderBase.)
Public property | UserFields | Gets access to the collection of user-defined fields on the record. Note that the field name is case-sensitive. (Inherited from OrderBase.)
Public property | Version | Gets the current version of the order, incremented on every save. (Inherited from OrderBase.)

See Also

ReturnToSupplier Class


ReturnToSupplier.InvoiceNumber Property

[image]

Pastel Evolution SDK
ReturnToSupplier..::..InvoiceNumber Property
ReturnToSupplier Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string InvoiceNumber { get; set; }
Visual Basic
Public Property InvoiceNumber As String
    Get
    Set

Property Value

Type: String

See Also

ReturnToSupplier Class
ReturnToSupplier Members


ReturnToSupplier.IsPartialProcessingAllowed Property

[image]

Pastel Evolution SDK
ReturnToSupplier..::..IsPartialProcessingAllowed Property
ReturnToSupplier Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override bool IsPartialProcessingAllowed { get; }
Visual Basic
Public Overrides ReadOnly Property IsPartialProcessingAllowed As Boolean
    Get

Property Value

Type: Boolean

See Also

ReturnToSupplier Class
ReturnToSupplier Members


ReturnToSupplier.OriginalDocument Property

[image]

Pastel Evolution SDK
ReturnToSupplier..::..OriginalDocument Property
ReturnToSupplier Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override OrderBase OriginalDocument { get; }
Visual Basic
Public Overrides ReadOnly Property OriginalDocument As OrderBase
    Get

Property Value

Type: OrderBase

See Also

ReturnToSupplier Class
ReturnToSupplier Members


ReturnToSupplier.Supplier Property

[image]

Pastel Evolution SDK
ReturnToSupplier..::..Supplier Property
ReturnToSupplier Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Supplier Supplier { get; set; }
Visual Basic
Public Property Supplier As Supplier
    Get
    Set

Property Value

Type: Supplier

See Also

ReturnToSupplier Class
ReturnToSupplier Members


SalesDocumentBase Class

[image]

Pastel Evolution SDK
SalesDocumentBase Class
Members See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract class SalesDocumentBase : OrderBase
Visual Basic
Public MustInherit Class SalesDocumentBase
    Inherits OrderBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..OrderBase
Pastel.Evolution..::..SalesDocumentBase
Pastel.Evolution..::..CreditNote
Pastel.Evolution..::..SalesOrder

See Also

SalesDocumentBase Members


SalesDocumentBase Members

[image] [image]

Pastel Evolution SDK
SalesDocumentBase Members
SalesDocumentBase Class Constructors Methods Fields Properties See Also Send Feedback

The SalesDocumentBase type exposes the following members.

Constructors

 | Name | Description
Protected method | SalesDocumentBase()()()() | Initializes a new instance of the SalesDocumentBase class
Protected method | SalesDocumentBase(Int32) | Initializes a new instance of the SalesDocumentBase class
Protected method | SalesDocumentBase(String, DocumentType) | Initializes a new instance of the SalesDocumentBase class

Methods

 | Name | Description
Public method | _SetFullQtyToProcess | (Inherited from OrderBase.)
Protected method | BeforePostGLBatch | (Inherited from OrderBase.)
Protected method | BeforePostInventory | (Inherited from OrderBase.)
Protected method | BeforePostLedger | (Inherited from OrderBase.)
Protected method | BeforeSave | (Inherited from OrderBase.)
Public method | CalcRounding |
Protected method | cascadeForeignValues | (Inherited from OrderBase.)
Protected method | cascadeProject | (Inherited from OrderBase.)
Protected method | cascadeRepresentative |
Protected method | cascadeTaxRate | (Inherited from OrderBase.)
Public method | Complete()()()() | Processes (invoices) all outstanding quantities on the order. The entire invoice fails if one or more detail lines do not have sufficient stock available. The CompleteMax method (SalesOrder only) is a variation on this method and attempts to confirm as much of the ordered stock as is available. (Inherited from OrderBase.)
Public method | Complete(String) | Process (invoice) all outstanding quantities on the order. The entire invoice fails if one or more detail lines do not have sufficient stock available. The method is a variation on this method and attempts to confirm as much of the ordered stock as is available. (Inherited from OrderBase.)
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Protected method | Detach | (Inherited from OrderBase.)
Protected method | detailRemainsOutstanding | (Inherited from OrderBase.)
Protected method | detailToProcess | (Inherited from OrderBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | fullQtySelected | (Inherited from OrderBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | glCreditPosting | (Inherited from OrderBase.)
Protected method | glDebitPosting | (Inherited from OrderBase.)
Protected method | initialise | Reverts the order to an unsaved, version 0 (see remarks) state. (Inherited from OrderBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Not supported. Use the delete facility from inside Evolution. (Inherited from OrderBase.)
Protected method | OnSave | (Inherited from OrderBase.)
Public method | Process()()()() | Posts the document to the various accounts and ledgers applicable. (Inherited from OrderBase.)
Public method | Process(String) | Posts the document to the various accounts and ledgers applicable. (Inherited from OrderBase.)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | account | (Inherited from OrderBase.)
Protected field | archID | (Inherited from OrderBase.)
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | currency | (Inherited from OrderBase.)
Protected field | dcTran | (Inherited from OrderBase.)
Protected field | deliverTo | (Inherited from OrderBase.)
Protected field | deliveryMethod | (Inherited from OrderBase.)
Protected field | detail | (Inherited from OrderBase.)
Protected field | glBatch | (Inherited from OrderBase.)
Protected field | invoiceTo | (Inherited from OrderBase.)
Protected field | orderPriority | (Inherited from OrderBase.)
Protected field | orderStatus | (Inherited from OrderBase.)
Protected field | originalDocument | (Inherited from OrderBase.)
Protected field | processingAdditionalCosts | (Inherited from OrderBase.)
Protected field | processLedger | Should the document process to AR or AP ledger? (Inherited from OrderBase.)
Protected field | processStock | (Inherited from OrderBase.)
Protected field | project | (Inherited from OrderBase.)
Protected field | prospect | (Inherited from OrderBase.)
Protected field | salesOpp |
Protected field | salesRep |
Protected field | settlementTerms | (Inherited from OrderBase.)
Protected field | taxType | (Inherited from OrderBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | Account | Gets or sets the AR or AP account associated with the order. (Inherited from OrderBase.)
Public property | AccountID | Gets or sets the ID of the AR or AP account associated with the order. (Inherited from OrderBase.)
Public property | AllowInvoiceRounding | (Inherited from OrderBase.)
Public property | ApplyTaxPerLine | Gets or sets whether tax per line should be applied. (Inherited from OrderBase.)
Public property | Audit | Gets the audit number of the last transaction processed by this document. This value defaults to 0, and will not be available on recalled documents. (Inherited from OrderBase.)
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Currency | Gets or sets the currency. (Inherited from OrderBase.)
Public property | CurrencyID | Gets or sets the document's currency ID. (Inherited from OrderBase.)
Public property | Customer | Gets or sets the document's customer account (maps directly to Account).
Public property | DeliverTo | Gets or sets the delivery address. (Inherited from OrderBase.)
Public property | DeliveryDate | Gets or sets the delivery date. (Inherited from OrderBase.)
Public property | DeliveryMethod | Gets or sets the delivery method. (Inherited from OrderBase.)
Public property | DeliveryMethodID | Gets or sets the delivery method ID. (Inherited from OrderBase.)
Public property | Description | Gets or sets the document description. This will also be the description on any transactions posted. (Inherited from OrderBase.)
Public property | Detail | Gets the order detail collection representing the body of the document. (Inherited from OrderBase.)
Public property | Discount | Gets or sets the document discount amount (applicable to tax excl. total), (Inherited from OrderBase.)
Public property | DiscountForeign | Gets or sets the document foreign discount amount (applicable to tax excl. total), (Inherited from OrderBase.)
Public property | DiscountLastProcessed | Gets the document discount amount last processed. (Inherited from OrderBase.)
Public property | DiscountPercent | Gets or sets the document discount percentage. (Inherited from OrderBase.)
Public property | DiscountToProcess | Gets the document discount amount about to be processed (applicable to tax excl. total). (Inherited from OrderBase.)
Public property | DueDate | Gets or sets the due date. (Inherited from OrderBase.)
Public property | ExchangeRate | Gets or sets the exchange rate. (Inherited from OrderBase.)
Public property | ExternalOrderNo | Gets or sets the external order number. (Inherited from OrderBase.)
Protected property | grossLastProcessTotal | (Inherited from OrderBase.)
Protected property | grossLastProcessTotalForeign | (Inherited from OrderBase.)
Protected property | grossOutstTotal | (Inherited from OrderBase.)
Protected property | grossOutstTotalForeign | (Inherited from OrderBase.)
Protected property | grossToProcessTotal | (Inherited from OrderBase.)
Protected property | grossToProcessTotalForeign | (Inherited from OrderBase.)
Protected property | grossTotal | (Inherited from OrderBase.)
Protected property | grossTotalForeign | (Inherited from OrderBase.)
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Inherited from OrderBase.)
Public property | InvoiceDate | Gets or sets the invoice date. (Inherited from OrderBase.)
Public property | InvoiceTo | Gets or sets the invoice address. (Inherited from OrderBase.)
Public property | IsLoading | Will be true while the order is busy loading detail. (Inherited from OrderBase.)
Public property | IsPartialProcessingAllowed | (Inherited from OrderBase.)
Public property | IsProcessing | Will be true while the order is busy processing transactions. (Inherited from OrderBase.)
Public property | LedgerTransaction | Gets the last ledger transaction (AR/AP Transaction) posted. (Inherited from OrderBase.)
Protected property | lineAdditionalCostTotal | (Inherited from OrderBase.)
Public property | LongID | (Inherited from OrderBase.)
Public property | MessageLine1 | Gets or sets the 1st message line. (Inherited from OrderBase.)
Public property | MessageLine2 | Gets or sets the 2nd message line. (Inherited from OrderBase.)
Public property | MessageLine3 | Gets or sets the 3rd message line. (Inherited from OrderBase.)
Protected property | nettLastProcessTotal | (Inherited from OrderBase.)
Protected property | nettLastProcessTotalForeign | (Inherited from OrderBase.)
Protected property | nettOutstTotal | (Inherited from OrderBase.)
Protected property | nettOutstTotalForeign | (Inherited from OrderBase.)
Protected property | nettToProcessTotal | (Inherited from OrderBase.)
Protected property | nettToProcessTotalForeign | (Inherited from OrderBase.)
Public property | OrderDate | Gets or sets the order date. (Inherited from OrderBase.)
Public property | OrderNo | Gets or sets the order number. (Inherited from OrderBase.)
Public property | OrderPriority | Gets or sets the order priority. (Inherited from OrderBase.)
Public property | OrderPriorityID | Gets or sets the order priority ID. (Inherited from OrderBase.)
Public property | OrderStatus | Gets or sets the document's order status. (Inherited from OrderBase.)
Public property | OrderStatusID | Gets or sets the order status ID. (Inherited from OrderBase.)
Public property | OriginalDocument | Gets the original document. (Inherited from OrderBase.)
Public property | PrintCount | Gets or sets the print count. (Inherited from OrderBase.)
Public property | Project | Gets or sets the project. (Inherited from OrderBase.)
Public property | ProjectID | Gets or sets the project ID. (Inherited from OrderBase.)
Public property | Prospect | (Inherited from OrderBase.)
Public property | ProspectID | (Inherited from OrderBase.)
Public property | RawFieldData | Obsolete. (Inherited from OrderBase.)
Public property | Reference | Gets or sets the document reference (InvNumber). (Inherited from OrderBase.)
Public property | Reference2 | Gets the 2nd document reference. (Inherited from OrderBase.)
Public property | Representative | Gets or sets the document sales representative.
Public property | RepresentativeID | Gets or sets the sales representative ID.
Public property | SalesOpportunity |
Public property | SettlementTerms | (Inherited from OrderBase.)
Public property | SettlementTermsID | (Inherited from OrderBase.)
Public property | State | Gets the document state. (Inherited from OrderBase.)
Protected property | taxLastProcessTotal | (Inherited from OrderBase.)
Protected property | taxLastProcessTotalForeign | (Inherited from OrderBase.)
Public property | TaxMode | Gets or sets the tax mode. (Inherited from OrderBase.)
Public property | TaxNumber | Gets or sets the cash account's tax number. (Inherited from OrderBase.)
Protected property | taxOutstTotal | (Inherited from OrderBase.)
Protected property | taxOutstTotalForeign | (Inherited from OrderBase.)
Protected property | taxToProcessTotal | (Inherited from OrderBase.)
Protected property | taxToProcessTotalForeign | (Inherited from OrderBase.)
Protected property | taxTotal | (Inherited from OrderBase.)
Protected property | taxTotalForeign | (Inherited from OrderBase.)
Public property | TaxType | (Inherited from OrderBase.)
Public property | TotalDiscountAdjusted | Gets the total discount adjusted amount. (Inherited from OrderBase.)
Public property | TotalDiscountAdjustedForeign | Gets the total discount adjusted foreign amount. (Inherited from OrderBase.)
Public property | TotalExcl | Gets the total excl amount. (Inherited from OrderBase.)
Public property | TotalExclForeign | Gets the total excl amount. (Inherited from OrderBase.)
Public property | TotalIncl | Gets the total incl amount. (Inherited from OrderBase.)
Public property | TotalInclForeign | Gets the total incl amount. (Inherited from OrderBase.)
Public property | TotalInclForeignBeforeInvoiceRounding | Gets the total incl amount before Invoice Rounding. (Inherited from OrderBase.)
Public property | TotalLastProcessExcl | Gets the total last process excl. (Inherited from OrderBase.)
Public property | TotalLastProcessExclForeign | Gets the total last process excl. (Inherited from OrderBase.)
Public property | TotalLastProcessIncl | Gets the total last process incl. (Inherited from OrderBase.)
Public property | TotalLastProcessInclForeign | Gets the total last process incl. (Inherited from OrderBase.)
Public property | TotalLastProcessTax | Gets the total last process tax. (Inherited from OrderBase.)
Public property | TotalLastProcessTaxForeign | Gets the total last process tax. (Inherited from OrderBase.)
Public property | TotalOutstandingExcl | Gets the total outstanding excl. (Inherited from OrderBase.)
Public property | TotalOutstandingExclForeign | Gets the total outstanding excl. (Inherited from OrderBase.)
Public property | TotalOutstandingIncl | Gets the total outstanding incl. (Inherited from OrderBase.)
Public property | TotalOutstandingInclForeign | Gets the total outstanding incl. (Inherited from OrderBase.)
Public property | TotalOutstandingTax | Gets the total outstanding tax. (Inherited from OrderBase.)
Public property | TotalOutstandingTaxForeign | Gets the total outstanding tax. (Inherited from OrderBase.)
Public property | TotalTax | Gets the total tax amount. (Inherited from OrderBase.)
Public property | TotalTaxForeign | Gets the total tax amount. (Inherited from OrderBase.)
Public property | TotalToProcessExcl | Gets the total amount to process excl. (Inherited from OrderBase.)
Public property | TotalToProcessExclForeign | Gets the total amount to process excl. (Inherited from OrderBase.)
Public property | TotalToProcessIncl | Gets the total to process incl. (Inherited from OrderBase.)
Public property | TotalToProcessInclForeign | Gets the total to process incl. (Inherited from OrderBase.)
Public property | TotalToProcessTax | Gets the total to process tax. (Inherited from OrderBase.)
Public property | TotalToProcessTaxForeign | Gets the total to process tax. (Inherited from OrderBase.)
Public property | Type | Gets the order's document type. (Inherited from OrderBase.)
Public property | UserFields | Gets access to the collection of user-defined fields on the record. Note that the field name is case-sensitive. (Inherited from OrderBase.)
Public property | Version | Gets the current version of the order, incremented on every save. (Inherited from OrderBase.)

See Also

SalesDocumentBase Class


SalesDocumentBase Constructor

[image] [image]

Pastel Evolution SDK
SalesDocumentBase Constructor
SalesDocumentBase Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | SalesDocumentBase()()()() | Initializes a new instance of the SalesDocumentBase class
Protected method | SalesDocumentBase(Int32) | Initializes a new instance of the SalesDocumentBase class
Protected method | SalesDocumentBase(String, DocumentType) | Initializes a new instance of the SalesDocumentBase class

See Also

SalesDocumentBase Class
SalesDocumentBase Members


SalesDocumentBase Constructor

[image]

Pastel Evolution SDK
SalesDocumentBase Constructor
SalesDocumentBase Class See Also Send Feedback
Initializes a new instance of the SalesDocumentBase class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal SalesDocumentBase()
Visual Basic
Protected Friend Sub New

See Also

SalesDocumentBase Class
SalesDocumentBase Members
SalesDocumentBase Overload


SalesDocumentBase Constructor (Int32)

[image]

Pastel Evolution SDK
SalesDocumentBase Constructor (Int32)
SalesDocumentBase Class See Also Send Feedback
Initializes a new instance of the SalesDocumentBase class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal SalesDocumentBase(
    int id
)
Visual Basic
Protected Friend Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32

See Also

SalesDocumentBase Class
SalesDocumentBase Members
SalesDocumentBase Overload


SalesDocumentBase Constructor (String, DocumentType)

[image]

Pastel Evolution SDK
SalesDocumentBase Constructor (String, DocumentType)
SalesDocumentBase Class See Also Send Feedback
Initializes a new instance of the SalesDocumentBase class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal SalesDocumentBase(
    string orderNumber,
    DocumentType documentType
)
Visual Basic
Protected Friend Sub New (
    orderNumber As String,
    documentType As DocumentType
)

Parameters

orderNumber
Type: System..::..String
documentType
Type: Pastel.Evolution..::..DocumentType

See Also

SalesDocumentBase Class
SalesDocumentBase Members
SalesDocumentBase Overload


SalesDocumentBase Fields

[image] [image]

Pastel Evolution SDK
SalesDocumentBase Fields
SalesDocumentBase Class See Also Send Feedback

The SalesDocumentBase type exposes the following members.

Fields

 | Name | Description
Protected field | account | (Inherited from OrderBase.)
Protected field | archID | (Inherited from OrderBase.)
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | currency | (Inherited from OrderBase.)
Protected field | dcTran | (Inherited from OrderBase.)
Protected field | deliverTo | (Inherited from OrderBase.)
Protected field | deliveryMethod | (Inherited from OrderBase.)
Protected field | detail | (Inherited from OrderBase.)
Protected field | glBatch | (Inherited from OrderBase.)
Protected field | invoiceTo | (Inherited from OrderBase.)
Protected field | orderPriority | (Inherited from OrderBase.)
Protected field | orderStatus | (Inherited from OrderBase.)
Protected field | originalDocument | (Inherited from OrderBase.)
Protected field | processingAdditionalCosts | (Inherited from OrderBase.)
Protected field | processLedger | Should the document process to AR or AP ledger? (Inherited from OrderBase.)
Protected field | processStock | (Inherited from OrderBase.)
Protected field | project | (Inherited from OrderBase.)
Protected field | prospect | (Inherited from OrderBase.)
Protected field | salesOpp |
Protected field | salesRep |
Protected field | settlementTerms | (Inherited from OrderBase.)
Protected field | taxType | (Inherited from OrderBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

SalesDocumentBase Class


SalesDocumentBase.salesOpp Field

[image]

Pastel Evolution SDK
SalesDocumentBase..::..salesOpp Field
SalesDocumentBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected Opportunity salesOpp
Visual Basic
Protected salesOpp As Opportunity

Field Value

Type: Opportunity

See Also

SalesDocumentBase Class
SalesDocumentBase Members


SalesDocumentBase.salesRep Field

[image]

Pastel Evolution SDK
SalesDocumentBase..::..salesRep Field
SalesDocumentBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected SalesRepresentative salesRep
Visual Basic
Protected salesRep As SalesRepresentative

Field Value

Type: SalesRepresentative

See Also

SalesDocumentBase Class
SalesDocumentBase Members


SalesDocumentBase Methods

[image] [image]

Pastel Evolution SDK
SalesDocumentBase Methods
SalesDocumentBase Class See Also Send Feedback

The SalesDocumentBase type exposes the following members.

Methods

 | Name | Description
Public method | _SetFullQtyToProcess | (Inherited from OrderBase.)
Protected method | BeforePostGLBatch | (Inherited from OrderBase.)
Protected method | BeforePostInventory | (Inherited from OrderBase.)
Protected method | BeforePostLedger | (Inherited from OrderBase.)
Protected method | BeforeSave | (Inherited from OrderBase.)
Public method | CalcRounding |
Protected method | cascadeForeignValues | (Inherited from OrderBase.)
Protected method | cascadeProject | (Inherited from OrderBase.)
Protected method | cascadeRepresentative |
Protected method | cascadeTaxRate | (Inherited from OrderBase.)
Public method | Complete()()()() | Processes (invoices) all outstanding quantities on the order. The entire invoice fails if one or more detail lines do not have sufficient stock available. The CompleteMax method (SalesOrder only) is a variation on this method and attempts to confirm as much of the ordered stock as is available. (Inherited from OrderBase.)
Public method | Complete(String) | Process (invoice) all outstanding quantities on the order. The entire invoice fails if one or more detail lines do not have sufficient stock available. The method is a variation on this method and attempts to confirm as much of the ordered stock as is available. (Inherited from OrderBase.)
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Protected method | Detach | (Inherited from OrderBase.)
Protected method | detailRemainsOutstanding | (Inherited from OrderBase.)
Protected method | detailToProcess | (Inherited from OrderBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | fullQtySelected | (Inherited from OrderBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | glCreditPosting | (Inherited from OrderBase.)
Protected method | glDebitPosting | (Inherited from OrderBase.)
Protected method | initialise | Reverts the order to an unsaved, version 0 (see remarks) state. (Inherited from OrderBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Not supported. Use the delete facility from inside Evolution. (Inherited from OrderBase.)
Protected method | OnSave | (Inherited from OrderBase.)
Public method | Process()()()() | Posts the document to the various accounts and ledgers applicable. (Inherited from OrderBase.)
Public method | Process(String) | Posts the document to the various accounts and ledgers applicable. (Inherited from OrderBase.)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

SalesDocumentBase Class


SalesDocumentBase.CalcRounding Method

[image]

Pastel Evolution SDK
SalesDocumentBase..::..CalcRounding Method
SalesDocumentBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double CalcRounding(
    double docTotal,
    double denom,
    int rndOpt
)
Visual Basic
Public Function CalcRounding (
    docTotal As Double,
    denom As Double,
    rndOpt As Integer
) As Double

Parameters

docTotal
Type: System..::..Double
denom
Type: System..::..Double
rndOpt
Type: System..::..Int32

Return Value

Type: Double

See Also

SalesDocumentBase Class
SalesDocumentBase Members


SalesDocumentBase.cascadeRepresentative Method

[image]

Pastel Evolution SDK
SalesDocumentBase..::..cascadeRepresentative Method
SalesDocumentBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal void cascadeRepresentative()
Visual Basic
Protected Friend Sub cascadeRepresentative

See Also

SalesDocumentBase Class
SalesDocumentBase Members


SalesDocumentBase Properties

[image] [image]

Pastel Evolution SDK
SalesDocumentBase Properties
SalesDocumentBase Class See Also Send Feedback

The SalesDocumentBase type exposes the following members.

Properties

 | Name | Description
Public property | Account | Gets or sets the AR or AP account associated with the order. (Inherited from OrderBase.)
Public property | AccountID | Gets or sets the ID of the AR or AP account associated with the order. (Inherited from OrderBase.)
Public property | AllowInvoiceRounding | (Inherited from OrderBase.)
Public property | ApplyTaxPerLine | Gets or sets whether tax per line should be applied. (Inherited from OrderBase.)
Public property | Audit | Gets the audit number of the last transaction processed by this document. This value defaults to 0, and will not be available on recalled documents. (Inherited from OrderBase.)
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Currency | Gets or sets the currency. (Inherited from OrderBase.)
Public property | CurrencyID | Gets or sets the document's currency ID. (Inherited from OrderBase.)
Public property | Customer | Gets or sets the document's customer account (maps directly to Account).
Public property | DeliverTo | Gets or sets the delivery address. (Inherited from OrderBase.)
Public property | DeliveryDate | Gets or sets the delivery date. (Inherited from OrderBase.)
Public property | DeliveryMethod | Gets or sets the delivery method. (Inherited from OrderBase.)
Public property | DeliveryMethodID | Gets or sets the delivery method ID. (Inherited from OrderBase.)
Public property | Description | Gets or sets the document description. This will also be the description on any transactions posted. (Inherited from OrderBase.)
Public property | Detail | Gets the order detail collection representing the body of the document. (Inherited from OrderBase.)
Public property | Discount | Gets or sets the document discount amount (applicable to tax excl. total), (Inherited from OrderBase.)
Public property | DiscountForeign | Gets or sets the document foreign discount amount (applicable to tax excl. total), (Inherited from OrderBase.)
Public property | DiscountLastProcessed | Gets the document discount amount last processed. (Inherited from OrderBase.)
Public property | DiscountPercent | Gets or sets the document discount percentage. (Inherited from OrderBase.)
Public property | DiscountToProcess | Gets the document discount amount about to be processed (applicable to tax excl. total). (Inherited from OrderBase.)
Public property | DueDate | Gets or sets the due date. (Inherited from OrderBase.)
Public property | ExchangeRate | Gets or sets the exchange rate. (Inherited from OrderBase.)
Public property | ExternalOrderNo | Gets or sets the external order number. (Inherited from OrderBase.)
Protected property | grossLastProcessTotal | (Inherited from OrderBase.)
Protected property | grossLastProcessTotalForeign | (Inherited from OrderBase.)
Protected property | grossOutstTotal | (Inherited from OrderBase.)
Protected property | grossOutstTotalForeign | (Inherited from OrderBase.)
Protected property | grossToProcessTotal | (Inherited from OrderBase.)
Protected property | grossToProcessTotalForeign | (Inherited from OrderBase.)
Protected property | grossTotal | (Inherited from OrderBase.)
Protected property | grossTotalForeign | (Inherited from OrderBase.)
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Inherited from OrderBase.)
Public property | InvoiceDate | Gets or sets the invoice date. (Inherited from OrderBase.)
Public property | InvoiceTo | Gets or sets the invoice address. (Inherited from OrderBase.)
Public property | IsLoading | Will be true while the order is busy loading detail. (Inherited from OrderBase.)
Public property | IsPartialProcessingAllowed | (Inherited from OrderBase.)
Public property | IsProcessing | Will be true while the order is busy processing transactions. (Inherited from OrderBase.)
Public property | LedgerTransaction | Gets the last ledger transaction (AR/AP Transaction) posted. (Inherited from OrderBase.)
Protected property | lineAdditionalCostTotal | (Inherited from OrderBase.)
Public property | LongID | (Inherited from OrderBase.)
Public property | MessageLine1 | Gets or sets the 1st message line. (Inherited from OrderBase.)
Public property | MessageLine2 | Gets or sets the 2nd message line. (Inherited from OrderBase.)
Public property | MessageLine3 | Gets or sets the 3rd message line. (Inherited from OrderBase.)
Protected property | nettLastProcessTotal | (Inherited from OrderBase.)
Protected property | nettLastProcessTotalForeign | (Inherited from OrderBase.)
Protected property | nettOutstTotal | (Inherited from OrderBase.)
Protected property | nettOutstTotalForeign | (Inherited from OrderBase.)
Protected property | nettToProcessTotal | (Inherited from OrderBase.)
Protected property | nettToProcessTotalForeign | (Inherited from OrderBase.)
Public property | OrderDate | Gets or sets the order date. (Inherited from OrderBase.)
Public property | OrderNo | Gets or sets the order number. (Inherited from OrderBase.)
Public property | OrderPriority | Gets or sets the order priority. (Inherited from OrderBase.)
Public property | OrderPriorityID | Gets or sets the order priority ID. (Inherited from OrderBase.)
Public property | OrderStatus | Gets or sets the document's order status. (Inherited from OrderBase.)
Public property | OrderStatusID | Gets or sets the order status ID. (Inherited from OrderBase.)
Public property | OriginalDocument | Gets the original document. (Inherited from OrderBase.)
Public property | PrintCount | Gets or sets the print count. (Inherited from OrderBase.)
Public property | Project | Gets or sets the project. (Inherited from OrderBase.)
Public property | ProjectID | Gets or sets the project ID. (Inherited from OrderBase.)
Public property | Prospect | (Inherited from OrderBase.)
Public property | ProspectID | (Inherited from OrderBase.)
Public property | RawFieldData | Obsolete. (Inherited from OrderBase.)
Public property | Reference | Gets or sets the document reference (InvNumber). (Inherited from OrderBase.)
Public property | Reference2 | Gets the 2nd document reference. (Inherited from OrderBase.)
Public property | Representative | Gets or sets the document sales representative.
Public property | RepresentativeID | Gets or sets the sales representative ID.
Public property | SalesOpportunity |
Public property | SettlementTerms | (Inherited from OrderBase.)
Public property | SettlementTermsID | (Inherited from OrderBase.)
Public property | State | Gets the document state. (Inherited from OrderBase.)
Protected property | taxLastProcessTotal | (Inherited from OrderBase.)
Protected property | taxLastProcessTotalForeign | (Inherited from OrderBase.)
Public property | TaxMode | Gets or sets the tax mode. (Inherited from OrderBase.)
Public property | TaxNumber | Gets or sets the cash account's tax number. (Inherited from OrderBase.)
Protected property | taxOutstTotal | (Inherited from OrderBase.)
Protected property | taxOutstTotalForeign | (Inherited from OrderBase.)
Protected property | taxToProcessTotal | (Inherited from OrderBase.)
Protected property | taxToProcessTotalForeign | (Inherited from OrderBase.)
Protected property | taxTotal | (Inherited from OrderBase.)
Protected property | taxTotalForeign | (Inherited from OrderBase.)
Public property | TaxType | (Inherited from OrderBase.)
Public property | TotalDiscountAdjusted | Gets the total discount adjusted amount. (Inherited from OrderBase.)
Public property | TotalDiscountAdjustedForeign | Gets the total discount adjusted foreign amount. (Inherited from OrderBase.)
Public property | TotalExcl | Gets the total excl amount. (Inherited from OrderBase.)
Public property | TotalExclForeign | Gets the total excl amount. (Inherited from OrderBase.)
Public property | TotalIncl | Gets the total incl amount. (Inherited from OrderBase.)
Public property | TotalInclForeign | Gets the total incl amount. (Inherited from OrderBase.)
Public property | TotalInclForeignBeforeInvoiceRounding | Gets the total incl amount before Invoice Rounding. (Inherited from OrderBase.)
Public property | TotalLastProcessExcl | Gets the total last process excl. (Inherited from OrderBase.)
Public property | TotalLastProcessExclForeign | Gets the total last process excl. (Inherited from OrderBase.)
Public property | TotalLastProcessIncl | Gets the total last process incl. (Inherited from OrderBase.)
Public property | TotalLastProcessInclForeign | Gets the total last process incl. (Inherited from OrderBase.)
Public property | TotalLastProcessTax | Gets the total last process tax. (Inherited from OrderBase.)
Public property | TotalLastProcessTaxForeign | Gets the total last process tax. (Inherited from OrderBase.)
Public property | TotalOutstandingExcl | Gets the total outstanding excl. (Inherited from OrderBase.)
Public property | TotalOutstandingExclForeign | Gets the total outstanding excl. (Inherited from OrderBase.)
Public property | TotalOutstandingIncl | Gets the total outstanding incl. (Inherited from OrderBase.)
Public property | TotalOutstandingInclForeign | Gets the total outstanding incl. (Inherited from OrderBase.)
Public property | TotalOutstandingTax | Gets the total outstanding tax. (Inherited from OrderBase.)
Public property | TotalOutstandingTaxForeign | Gets the total outstanding tax. (Inherited from OrderBase.)
Public property | TotalTax | Gets the total tax amount. (Inherited from OrderBase.)
Public property | TotalTaxForeign | Gets the total tax amount. (Inherited from OrderBase.)
Public property | TotalToProcessExcl | Gets the total amount to process excl. (Inherited from OrderBase.)
Public property | TotalToProcessExclForeign | Gets the total amount to process excl. (Inherited from OrderBase.)
Public property | TotalToProcessIncl | Gets the total to process incl. (Inherited from OrderBase.)
Public property | TotalToProcessInclForeign | Gets the total to process incl. (Inherited from OrderBase.)
Public property | TotalToProcessTax | Gets the total to process tax. (Inherited from OrderBase.)
Public property | TotalToProcessTaxForeign | Gets the total to process tax. (Inherited from OrderBase.)
Public property | Type | Gets the order's document type. (Inherited from OrderBase.)
Public property | UserFields | Gets access to the collection of user-defined fields on the record. Note that the field name is case-sensitive. (Inherited from OrderBase.)
Public property | Version | Gets the current version of the order, incremented on every save. (Inherited from OrderBase.)

See Also

SalesDocumentBase Class


SalesDocumentBase.Customer Property

[image]

Pastel Evolution SDK
SalesDocumentBase..::..Customer Property
SalesDocumentBase Class See Also Send Feedback
Gets or sets the document's customer account (maps directly to Account).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Customer Customer { get; set; }
Visual Basic
Public Property Customer As Customer
    Get
    Set

Property Value

Type: Customer

See Also

SalesDocumentBase Class
SalesDocumentBase Members


SalesDocumentBase.Representative Property

[image]

Pastel Evolution SDK
SalesDocumentBase..::..Representative Property
SalesDocumentBase Class See Also Send Feedback
Gets or sets the document sales representative.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public SalesRepresentative Representative { get; set; }
Visual Basic
Public Property Representative As SalesRepresentative
    Get
    Set

Property Value

Type: SalesRepresentative

Remarks

Be sure to set the document representative before adding detail records. This will ensure the sales rep is set on the detail records. Alternatively, the sales rep can be specified for each detail record, or even overridden after adding the detail record to the document. Warning: when "Post sales rep per line" inventory option is disabled, the representative on all detail records will be replaced when setting the document representative.

See Also

SalesDocumentBase Class
SalesDocumentBase Members


SalesDocumentBase.RepresentativeID Property

[image]

Pastel Evolution SDK
SalesDocumentBase..::..RepresentativeID Property
SalesDocumentBase Class See Also Send Feedback
Gets or sets the sales representative ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int RepresentativeID { get; set; }
Visual Basic
Public Property RepresentativeID As Integer
    Get
    Set

Property Value

Type: Int32

Remarks

Use this property if the representative ID is readily available to gain a slight performance benefit.

See Also

SalesDocumentBase Class
SalesDocumentBase Members


SalesDocumentBase.SalesOpportunity Property

[image]

Pastel Evolution SDK
SalesDocumentBase..::..SalesOpportunity Property
SalesDocumentBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Opportunity SalesOpportunity { get; set; }
Visual Basic
Public Property SalesOpportunity As Opportunity
    Get
    Set

Property Value

Type: Opportunity

See Also

SalesDocumentBase Class
SalesDocumentBase Members


SalesOrder Class

[image]

Pastel Evolution SDK
SalesOrder Class
Members See Also Send Feedback
An object representation of an Evolution Sales Order.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class SalesOrder : SalesDocumentBase
Visual Basic
Public Class SalesOrder
    Inherits SalesDocumentBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..OrderBase
Pastel.Evolution..::..SalesDocumentBase
Pastel.Evolution..::..SalesOrder
Pastel.Evolution..::..SalesOrderQuotation

See Also

SalesOrder Members


SalesOrder Members

[image] [image]

Pastel Evolution SDK
SalesOrder Members
SalesOrder Class Constructors Methods Fields Properties See Also Send Feedback

The SalesOrder type exposes the following members.

Constructors

 | Name | Description
Public method | SalesOrder()()()() | Creates a new instance of a sales order.
Public method | SalesOrder(Int32) | Creates a new instance of a sales order.
Public method | SalesOrder(String) | Creates a new instance of a sales order.

Methods

 | Name | Description
Public method | _SetFullQtyToProcess | (Inherited from OrderBase.)
Public method | _SetMaxQtyToProcess | Experimental method
Protected method | BeforePostGLBatch | (Overrides OrderBase..::..BeforePostGLBatch(OrderBase, CancelEventArgs).)
Protected method | BeforePostInventory | (Overrides OrderBase..::..BeforePostInventory(OrderBase, CancelEventArgs).)
Protected method | BeforePostLedger | (Overrides OrderBase..::..BeforePostLedger(OrderBase, CancelEventArgs).)
Protected method | BeforeSave | (Inherited from OrderBase.)
Public method | CalcRounding | (Inherited from SalesDocumentBase.)
Protected method | cascadeForeignValues | (Inherited from OrderBase.)
Protected method | cascadeProject | (Inherited from OrderBase.)
Protected method | cascadeRepresentative | (Inherited from SalesDocumentBase.)
Protected method | cascadeTaxRate | (Inherited from OrderBase.)
Public method | Complete()()()() | Processes (invoices) all outstanding quantities on the order. The entire invoice fails if one or more detail lines do not have sufficient stock available. The CompleteMax method (SalesOrder only) is a variation on this method and attempts to confirm as much of the ordered stock as is available. (Inherited from OrderBase.)
Public method | Complete(String) | Process (invoice) all outstanding quantities on the order. The entire invoice fails if one or more detail lines do not have sufficient stock available. The method is a variation on this method and attempts to confirm as much of the ordered stock as is available. (Inherited from OrderBase.)
Public method | CompleteMax | Processes as much of the ordered stock as is available. If an "all or nothing" approach is required, use the method instead.
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Protected method | Detach | (Inherited from OrderBase.)
Protected method | detailRemainsOutstanding | (Inherited from OrderBase.)
Protected method | detailToProcess | (Inherited from OrderBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds and returns the id of the first order matching the supplied criteria. E.g. OrderNum = 'SO0001'
Protected method | fullQtySelected | (Inherited from OrderBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | glCreditPosting | (Overrides OrderBase..::..glCreditPosting(TransactionBase, TransactionBase..::..GLPostingEventArgs).)
Protected method | glDebitPosting | (Overrides OrderBase..::..glDebitPosting(TransactionBase, TransactionBase..::..GLPostingEventArgs).)
Protected method | initialise | (Overrides OrderBase..::..initialise()()()().)
 | List | Lists outstanding orders for the supplied criteria.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Not supported. Use the delete facility from inside Evolution. (Inherited from OrderBase.)
Protected method | OnSave | (Inherited from OrderBase.)
Public method | Process()()()() | Posts the document to the various accounts and ledgers applicable. (Inherited from OrderBase.)
Public method | Process(String) | Posts the document to the various accounts and ledgers applicable. (Inherited from OrderBase.)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | account | (Inherited from OrderBase.)
Protected field | archID | (Inherited from OrderBase.)
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | currency | (Inherited from OrderBase.)
Protected field | dcTran | (Inherited from OrderBase.)
Protected field | deliverTo | (Inherited from OrderBase.)
Protected field | deliveryMethod | (Inherited from OrderBase.)
Protected field | detail | (Inherited from OrderBase.)
Protected field | glBatch | (Inherited from OrderBase.)
Protected field | invoiceTo | (Inherited from OrderBase.)
Protected field | orderPriority | (Inherited from OrderBase.)
Protected field | orderStatus | (Inherited from OrderBase.)
Protected field | originalDocument | (Inherited from OrderBase.)
Protected field | processingAdditionalCosts | (Inherited from OrderBase.)
Protected field | processLedger | Should the document process to AR or AP ledger? (Inherited from OrderBase.)
Protected field | processStock | (Inherited from OrderBase.)
Protected field | project | (Inherited from OrderBase.)
Protected field | prospect | (Inherited from OrderBase.)
Protected field | salesOpp | (Inherited from SalesDocumentBase.)
Protected field | salesRep | (Inherited from SalesDocumentBase.)
Protected field | settlementTerms | (Inherited from OrderBase.)
Protected field | taxType | (Inherited from OrderBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | Account | Gets or sets the AR or AP account associated with the order. (Inherited from OrderBase.)
Public property | AccountID | Gets or sets the ID of the AR or AP account associated with the order. (Inherited from OrderBase.)
Public property | AllowInvoiceRounding | (Inherited from OrderBase.)
Public property | ApplyTaxPerLine | Gets or sets whether tax per line should be applied. (Inherited from OrderBase.)
Public property | Audit | Gets the audit number of the last transaction processed by this document. This value defaults to 0, and will not be available on recalled documents. (Inherited from OrderBase.)
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Currency | Gets or sets the currency. (Inherited from OrderBase.)
Public property | CurrencyID | Gets or sets the document's currency ID. (Inherited from OrderBase.)
Public property | Customer | Gets or sets the document's customer account (maps directly to Account). (Inherited from SalesDocumentBase.)
Public property | DeliverTo | Gets or sets the delivery address. (Inherited from OrderBase.)
Public property | DeliveryDate | Gets or sets the delivery date. (Inherited from OrderBase.)
Public property | DeliveryMethod | Gets or sets the delivery method. (Inherited from OrderBase.)
Public property | DeliveryMethodID | Gets or sets the delivery method ID. (Inherited from OrderBase.)
Public property | DeliveryNote | Gets or sets the document delivery note number
Public property | Description | Gets or sets the document description. This will also be the description on any transactions posted. (Inherited from OrderBase.)
Public property | Detail | Gets the order detail collection representing the body of the document. (Inherited from OrderBase.)
Public property | Discount | Gets or sets the document discount amount (applicable to tax excl. total), (Inherited from OrderBase.)
Public property | DiscountForeign | Gets or sets the document foreign discount amount (applicable to tax excl. total), (Inherited from OrderBase.)
Public property | DiscountLastProcessed | Gets the document discount amount last processed. (Inherited from OrderBase.)
Public property | DiscountPercent | Gets or sets the document discount percentage. (Inherited from OrderBase.)
Public property | DiscountToProcess | Gets the document discount amount about to be processed (applicable to tax excl. total). (Inherited from OrderBase.)
Public property | DueDate | Gets or sets the due date. (Inherited from OrderBase.)
Public property | ExchangeRate | Gets or sets the exchange rate. (Inherited from OrderBase.)
Public property | ExternalOrderNo | Gets or sets the external order number. (Inherited from OrderBase.)
Protected property | grossLastProcessTotal | (Inherited from OrderBase.)
Protected property | grossLastProcessTotalForeign | (Inherited from OrderBase.)
Protected property | grossOutstTotal | (Inherited from OrderBase.)
Protected property | grossOutstTotalForeign | (Inherited from OrderBase.)
Protected property | grossToProcessTotal | (Inherited from OrderBase.)
Protected property | grossToProcessTotalForeign | (Inherited from OrderBase.)
Protected property | grossTotal | (Inherited from OrderBase.)
Protected property | grossTotalForeign | (Inherited from OrderBase.)
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Inherited from OrderBase.)
Public property | InvoiceDate | Gets or sets the invoice date. (Inherited from OrderBase.)
Public property | InvoiceTo | Gets or sets the invoice address. (Inherited from OrderBase.)
Public property | IsLoading | Will be true while the order is busy loading detail. (Inherited from OrderBase.)
Public property | IsPartialProcessingAllowed | (Inherited from OrderBase.)
Public property | IsProcessing | Will be true while the order is busy processing transactions. (Inherited from OrderBase.)
Public property | LedgerTransaction | Gets the last ledger transaction (AR/AP Transaction) posted. (Inherited from OrderBase.)
Protected property | lineAdditionalCostTotal | (Inherited from OrderBase.)
Public property | LongID | (Inherited from OrderBase.)
Public property | MessageLine1 | Gets or sets the 1st message line. (Inherited from OrderBase.)
Public property | MessageLine2 | Gets or sets the 2nd message line. (Inherited from OrderBase.)
Public property | MessageLine3 | Gets or sets the 3rd message line. (Inherited from OrderBase.)
Protected property | nettLastProcessTotal | (Inherited from OrderBase.)
Protected property | nettLastProcessTotalForeign | (Inherited from OrderBase.)
Protected property | nettOutstTotal | (Inherited from OrderBase.)
Protected property | nettOutstTotalForeign | (Inherited from OrderBase.)
Protected property | nettToProcessTotal | (Inherited from OrderBase.)
Protected property | nettToProcessTotalForeign | (Inherited from OrderBase.)
Public property | OrderDate | Gets or sets the order date. (Inherited from OrderBase.)
Public property | OrderNo | Gets or sets the order number. (Inherited from OrderBase.)
Public property | OrderPriority | Gets or sets the order priority. (Inherited from OrderBase.)
Public property | OrderPriorityID | Gets or sets the order priority ID. (Inherited from OrderBase.)
Public property | OrderStatus | Gets or sets the document's order status. (Inherited from OrderBase.)
Public property | OrderStatusID | Gets or sets the order status ID. (Inherited from OrderBase.)
Public property | OriginalDocument | Gets the order's original document. (Overrides OrderBase..::..OriginalDocument.)
Public property | PrintCount | Gets or sets the print count. (Inherited from OrderBase.)
Public property | Project | Gets or sets the project. (Inherited from OrderBase.)
Public property | ProjectID | Gets or sets the project ID. (Inherited from OrderBase.)
Public property | Prospect | (Inherited from OrderBase.)
Public property | ProspectID | (Inherited from OrderBase.)
Public property | RawFieldData | Obsolete. (Inherited from OrderBase.)
Public property | Reference | Gets or sets the document reference (InvNumber). (Inherited from OrderBase.)
Public property | Reference2 | Gets the 2nd document reference. (Inherited from OrderBase.)
Public property | Representative | Gets or sets the document sales representative. (Inherited from SalesDocumentBase.)
Public property | RepresentativeID | Gets or sets the sales representative ID. (Inherited from SalesDocumentBase.)
Public property | SalesOpportunity | (Inherited from SalesDocumentBase.)
Public property | SettlementTerms | (Inherited from OrderBase.)
Public property | SettlementTermsID | (Inherited from OrderBase.)
Public property | State | Gets the document state. (Inherited from OrderBase.)
Protected property | taxLastProcessTotal | (Inherited from OrderBase.)
Protected property | taxLastProcessTotalForeign | (Inherited from OrderBase.)
Public property | TaxMode | Gets or sets the tax mode. (Inherited from OrderBase.)
Public property | TaxNumber | Gets or sets the cash account's tax number. (Inherited from OrderBase.)
Protected property | taxOutstTotal | (Inherited from OrderBase.)
Protected property | taxOutstTotalForeign | (Inherited from OrderBase.)
Protected property | taxToProcessTotal | (Inherited from OrderBase.)
Protected property | taxToProcessTotalForeign | (Inherited from OrderBase.)
Protected property | taxTotal | (Inherited from OrderBase.)
Protected property | taxTotalForeign | (Inherited from OrderBase.)
Public property | TaxType | (Inherited from OrderBase.)
Public property | TotalDiscountAdjusted | Gets the total discount adjusted amount. (Inherited from OrderBase.)
Public property | TotalDiscountAdjustedForeign | Gets the total discount adjusted foreign amount. (Inherited from OrderBase.)
Public property | TotalExcl | Gets the total excl amount. (Inherited from OrderBase.)
Public property | TotalExclForeign | Gets the total excl amount. (Inherited from OrderBase.)
Public property | TotalIncl | Gets the total incl amount. (Inherited from OrderBase.)
Public property | TotalInclForeign | Gets the total incl amount. (Inherited from OrderBase.)
Public property | TotalInclForeignBeforeInvoiceRounding | Gets the total incl amount before Invoice Rounding. (Inherited from OrderBase.)
Public property | TotalLastProcessExcl | Gets the total last process excl. (Inherited from OrderBase.)
Public property | TotalLastProcessExclForeign | Gets the total last process excl. (Inherited from OrderBase.)
Public property | TotalLastProcessIncl | Gets the total last process incl. (Inherited from OrderBase.)
Public property | TotalLastProcessInclForeign | Gets the total last process incl. (Inherited from OrderBase.)
Public property | TotalLastProcessTax | Gets the total last process tax. (Inherited from OrderBase.)
Public property | TotalLastProcessTaxForeign | Gets the total last process tax. (Inherited from OrderBase.)
Public property | TotalOutstandingExcl | Gets the total outstanding excl. (Inherited from OrderBase.)
Public property | TotalOutstandingExclForeign | Gets the total outstanding excl. (Inherited from OrderBase.)
Public property | TotalOutstandingIncl | Gets the total outstanding incl. (Inherited from OrderBase.)
Public property | TotalOutstandingInclForeign | Gets the total outstanding incl. (Inherited from OrderBase.)
Public property | TotalOutstandingTax | Gets the total outstanding tax. (Inherited from OrderBase.)
Public property | TotalOutstandingTaxForeign | Gets the total outstanding tax. (Inherited from OrderBase.)
Public property | TotalTax | Gets the total tax amount. (Inherited from OrderBase.)
Public property | TotalTaxForeign | Gets the total tax amount. (Inherited from OrderBase.)
Public property | TotalToProcessExcl | Gets the total amount to process excl. (Inherited from OrderBase.)
Public property | TotalToProcessExclForeign | Gets the total amount to process excl. (Inherited from OrderBase.)
Public property | TotalToProcessIncl | Gets the total to process incl. (Inherited from OrderBase.)
Public property | TotalToProcessInclForeign | Gets the total to process incl. (Inherited from OrderBase.)
Public property | TotalToProcessTax | Gets the total to process tax. (Inherited from OrderBase.)
Public property | TotalToProcessTaxForeign | Gets the total to process tax. (Inherited from OrderBase.)
Public property | Type | Gets the order's document type. (Inherited from OrderBase.)
Public property | UserFields | Gets access to the collection of user-defined fields on the record. Note that the field name is case-sensitive. (Inherited from OrderBase.)
Public property | Version | Gets the current version of the order, incremented on every save. (Inherited from OrderBase.)

See Also

SalesOrder Class


SalesOrder Constructor

[image] [image]

Pastel Evolution SDK
SalesOrder Constructor
SalesOrder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SalesOrder()()()() | Creates a new instance of a sales order.
Public method | SalesOrder(Int32) | Creates a new instance of a sales order.
Public method | SalesOrder(String) | Creates a new instance of a sales order.

See Also

SalesOrder Class
SalesOrder Members


SalesOrder Constructor

[image]

Pastel Evolution SDK
SalesOrder Constructor
SalesOrder Class See Also Send Feedback
Creates a new instance of a sales order.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public SalesOrder()
Visual Basic
Public Sub New

See Also

SalesOrder Class
SalesOrder Members
SalesOrder Overload


SalesOrder Constructor (Int32)

[image]

Pastel Evolution SDK
SalesOrder Constructor (Int32)
SalesOrder Class See Also Send Feedback
Creates a new instance of a sales order.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public SalesOrder(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32
Specifies the id of the existing record.

See Also

SalesOrder Class
SalesOrder Members
SalesOrder Overload


SalesOrder Constructor (String)

[image]

Pastel Evolution SDK
SalesOrder Constructor (String)
SalesOrder Class See Also Send Feedback
Creates a new instance of a sales order.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public SalesOrder(
    string orderNumber
)
Visual Basic
Public Sub New (
    orderNumber As String
)

Parameters

orderNumber
Type: System..::..String
Specifies the order number of the existing record.

See Also

SalesOrder Class
SalesOrder Members
SalesOrder Overload


SalesOrder Fields

[image] [image]

Pastel Evolution SDK
SalesOrder Fields
SalesOrder Class See Also Send Feedback

The SalesOrder type exposes the following members.

Fields

 | Name | Description
Protected field | account | (Inherited from OrderBase.)
Protected field | archID | (Inherited from OrderBase.)
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | currency | (Inherited from OrderBase.)
Protected field | dcTran | (Inherited from OrderBase.)
Protected field | deliverTo | (Inherited from OrderBase.)
Protected field | deliveryMethod | (Inherited from OrderBase.)
Protected field | detail | (Inherited from OrderBase.)
Protected field | glBatch | (Inherited from OrderBase.)
Protected field | invoiceTo | (Inherited from OrderBase.)
Protected field | orderPriority | (Inherited from OrderBase.)
Protected field | orderStatus | (Inherited from OrderBase.)
Protected field | originalDocument | (Inherited from OrderBase.)
Protected field | processingAdditionalCosts | (Inherited from OrderBase.)
Protected field | processLedger | Should the document process to AR or AP ledger? (Inherited from OrderBase.)
Protected field | processStock | (Inherited from OrderBase.)
Protected field | project | (Inherited from OrderBase.)
Protected field | prospect | (Inherited from OrderBase.)
Protected field | salesOpp | (Inherited from SalesDocumentBase.)
Protected field | salesRep | (Inherited from SalesDocumentBase.)
Protected field | settlementTerms | (Inherited from OrderBase.)
Protected field | taxType | (Inherited from OrderBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

SalesOrder Class


SalesOrder Methods

[image] [image]

Pastel Evolution SDK
SalesOrder Methods
SalesOrder Class See Also Send Feedback

The SalesOrder type exposes the following members.

Methods

 | Name | Description
Public method | _SetFullQtyToProcess | (Inherited from OrderBase.)
Public method | _SetMaxQtyToProcess | Experimental method
Protected method | BeforePostGLBatch | (Overrides OrderBase..::..BeforePostGLBatch(OrderBase, CancelEventArgs).)
Protected method | BeforePostInventory | (Overrides OrderBase..::..BeforePostInventory(OrderBase, CancelEventArgs).)
Protected method | BeforePostLedger | (Overrides OrderBase..::..BeforePostLedger(OrderBase, CancelEventArgs).)
Protected method | BeforeSave | (Inherited from OrderBase.)
Public method | CalcRounding | (Inherited from SalesDocumentBase.)
Protected method | cascadeForeignValues | (Inherited from OrderBase.)
Protected method | cascadeProject | (Inherited from OrderBase.)
Protected method | cascadeRepresentative | (Inherited from SalesDocumentBase.)
Protected method | cascadeTaxRate | (Inherited from OrderBase.)
Public method | Complete()()()() | Processes (invoices) all outstanding quantities on the order. The entire invoice fails if one or more detail lines do not have sufficient stock available. The CompleteMax method (SalesOrder only) is a variation on this method and attempts to confirm as much of the ordered stock as is available. (Inherited from OrderBase.)
Public method | Complete(String) | Process (invoice) all outstanding quantities on the order. The entire invoice fails if one or more detail lines do not have sufficient stock available. The method is a variation on this method and attempts to confirm as much of the ordered stock as is available. (Inherited from OrderBase.)
Public method | CompleteMax | Processes as much of the ordered stock as is available. If an "all or nothing" approach is required, use the method instead.
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Protected method | Detach | (Inherited from OrderBase.)
Protected method | detailRemainsOutstanding | (Inherited from OrderBase.)
Protected method | detailToProcess | (Inherited from OrderBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds and returns the id of the first order matching the supplied criteria. E.g. OrderNum = 'SO0001'
Protected method | fullQtySelected | (Inherited from OrderBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | glCreditPosting | (Overrides OrderBase..::..glCreditPosting(TransactionBase, TransactionBase..::..GLPostingEventArgs).)
Protected method | glDebitPosting | (Overrides OrderBase..::..glDebitPosting(TransactionBase, TransactionBase..::..GLPostingEventArgs).)
Protected method | initialise | (Overrides OrderBase..::..initialise()()()().)
 | List | Lists outstanding orders for the supplied criteria.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Not supported. Use the delete facility from inside Evolution. (Inherited from OrderBase.)
Protected method | OnSave | (Inherited from OrderBase.)
Public method | Process()()()() | Posts the document to the various accounts and ledgers applicable. (Inherited from OrderBase.)
Public method | Process(String) | Posts the document to the various accounts and ledgers applicable. (Inherited from OrderBase.)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

SalesOrder Class


SalesOrder._SetMaxQtyToProcess Method

[image]

Pastel Evolution SDK
SalesOrder..::.._SetMaxQtyToProcess Method
SalesOrder Class See Also Send Feedback
Experimental method

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void _SetMaxQtyToProcess()
Visual Basic
Public Sub _SetMaxQtyToProcess

See Also

SalesOrder Class
SalesOrder Members


SalesOrder.BeforePostGLBatch Method

[image]

Pastel Evolution SDK
SalesOrder..::..BeforePostGLBatch Method
SalesOrder Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected override void BeforePostGLBatch(
    OrderBase orderBase,
    CancelEventArgs e
)
Visual Basic
Protected Overrides Sub BeforePostGLBatch (
    orderBase As OrderBase,
    e As CancelEventArgs
)

Parameters

orderBase
Type: Pastel.Evolution..::..OrderBase
e
Type: System.ComponentModel..::..CancelEventArgs

See Also

SalesOrder Class
SalesOrder Members


SalesOrder.BeforePostInventory Method

[image]

Pastel Evolution SDK
SalesOrder..::..BeforePostInventory Method
SalesOrder Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected override void BeforePostInventory(
    OrderBase orderBase,
    CancelEventArgs e
)
Visual Basic
Protected Overrides Sub BeforePostInventory (
    orderBase As OrderBase,
    e As CancelEventArgs
)

Parameters

orderBase
Type: Pastel.Evolution..::..OrderBase
e
Type: System.ComponentModel..::..CancelEventArgs

See Also

SalesOrder Class
SalesOrder Members


SalesOrder.BeforePostLedger Method

[image]

Pastel Evolution SDK
SalesOrder..::..BeforePostLedger Method
SalesOrder Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected override void BeforePostLedger(
    OrderBase orderBase,
    CancelEventArgs e
)
Visual Basic
Protected Overrides Sub BeforePostLedger (
    orderBase As OrderBase,
    e As CancelEventArgs
)

Parameters

orderBase
Type: Pastel.Evolution..::..OrderBase
e
Type: System.ComponentModel..::..CancelEventArgs

See Also

SalesOrder Class
SalesOrder Members


SalesOrder.CompleteMax Method

[image]

Pastel Evolution SDK
SalesOrder..::..CompleteMax Method
SalesOrder Class See Also Send Feedback
Processes as much of the ordered stock as is available. If an "all or nothing" approach is required, use the method instead.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string CompleteMax()
Visual Basic
Public Function CompleteMax As String

Return Value

Type: String
Invoice number

See Also

SalesOrder Class
SalesOrder Members
Pastel.Evolution Namespace
OrderDetail..::..ToProcess
OrderBase..::..Complete()()()()


SalesOrder.Find Method

[image]

Pastel Evolution SDK
SalesOrder..::..Find Method
SalesOrder Class See Also Send Feedback
Finds and returns the id of the first order matching the supplied criteria. E.g. OrderNum = 'SO0001'

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.

Return Value

Type: Int32
The ID of the first record found; -1 if not record was found.

See Also

SalesOrder Class
SalesOrder Members


SalesOrder.glCreditPosting Method

[image]

Pastel Evolution SDK
SalesOrder..::..glCreditPosting Method
SalesOrder Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected override void glCreditPosting(
    TransactionBase sender,
    TransactionBase..::..GLPostingEventArgs e
)
Visual Basic
Protected Overrides Sub glCreditPosting (
    sender As TransactionBase,
    e As TransactionBase..::..GLPostingEventArgs
)

Parameters

sender
Type: Pastel.Evolution..::..TransactionBase
e
Type: Pastel.Evolution..::..TransactionBase..::..GLPostingEventArgs

See Also

SalesOrder Class
SalesOrder Members


SalesOrder.glDebitPosting Method

[image]

Pastel Evolution SDK
SalesOrder..::..glDebitPosting Method
SalesOrder Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected override void glDebitPosting(
    TransactionBase sender,
    TransactionBase..::..GLPostingEventArgs e
)
Visual Basic
Protected Overrides Sub glDebitPosting (
    sender As TransactionBase,
    e As TransactionBase..::..GLPostingEventArgs
)

Parameters

sender
Type: Pastel.Evolution..::..TransactionBase
e
Type: Pastel.Evolution..::..TransactionBase..::..GLPostingEventArgs

See Also

SalesOrder Class
SalesOrder Members


SalesOrder.initialise Method

[image]

Pastel Evolution SDK
SalesOrder..::..initialise Method
SalesOrder Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void initialise()
Visual Basic
Protected Friend Overrides Sub initialise

See Also

SalesOrder Class
SalesOrder Members


SalesOrder.List Method

[image]

Pastel Evolution SDK
SalesOrder..::..List Method
SalesOrder Class See Also Send Feedback
Lists outstanding orders for the supplied criteria.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria
)
Visual Basic
Public Shared Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String
E.g. Customer.Account = 'CASH001' and (OrderNum = 'SO209302')

Return Value

Type: DataTable

Remarks

Pseudo-tables: Core, Customer

See Also

SalesOrder Class
SalesOrder Members


SalesOrder Properties

[image] [image]

Pastel Evolution SDK
SalesOrder Properties
SalesOrder Class See Also Send Feedback

The SalesOrder type exposes the following members.

Properties

 | Name | Description
Public property | Account | Gets or sets the AR or AP account associated with the order. (Inherited from OrderBase.)
Public property | AccountID | Gets or sets the ID of the AR or AP account associated with the order. (Inherited from OrderBase.)
Public property | AllowInvoiceRounding | (Inherited from OrderBase.)
Public property | ApplyTaxPerLine | Gets or sets whether tax per line should be applied. (Inherited from OrderBase.)
Public property | Audit | Gets the audit number of the last transaction processed by this document. This value defaults to 0, and will not be available on recalled documents. (Inherited from OrderBase.)
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Currency | Gets or sets the currency. (Inherited from OrderBase.)
Public property | CurrencyID | Gets or sets the document's currency ID. (Inherited from OrderBase.)
Public property | Customer | Gets or sets the document's customer account (maps directly to Account). (Inherited from SalesDocumentBase.)
Public property | DeliverTo | Gets or sets the delivery address. (Inherited from OrderBase.)
Public property | DeliveryDate | Gets or sets the delivery date. (Inherited from OrderBase.)
Public property | DeliveryMethod | Gets or sets the delivery method. (Inherited from OrderBase.)
Public property | DeliveryMethodID | Gets or sets the delivery method ID. (Inherited from OrderBase.)
Public property | DeliveryNote | Gets or sets the document delivery note number
Public property | Description | Gets or sets the document description. This will also be the description on any transactions posted. (Inherited from OrderBase.)
Public property | Detail | Gets the order detail collection representing the body of the document. (Inherited from OrderBase.)
Public property | Discount | Gets or sets the document discount amount (applicable to tax excl. total), (Inherited from OrderBase.)
Public property | DiscountForeign | Gets or sets the document foreign discount amount (applicable to tax excl. total), (Inherited from OrderBase.)
Public property | DiscountLastProcessed | Gets the document discount amount last processed. (Inherited from OrderBase.)
Public property | DiscountPercent | Gets or sets the document discount percentage. (Inherited from OrderBase.)
Public property | DiscountToProcess | Gets the document discount amount about to be processed (applicable to tax excl. total). (Inherited from OrderBase.)
Public property | DueDate | Gets or sets the due date. (Inherited from OrderBase.)
Public property | ExchangeRate | Gets or sets the exchange rate. (Inherited from OrderBase.)
Public property | ExternalOrderNo | Gets or sets the external order number. (Inherited from OrderBase.)
Protected property | grossLastProcessTotal | (Inherited from OrderBase.)
Protected property | grossLastProcessTotalForeign | (Inherited from OrderBase.)
Protected property | grossOutstTotal | (Inherited from OrderBase.)
Protected property | grossOutstTotalForeign | (Inherited from OrderBase.)
Protected property | grossToProcessTotal | (Inherited from OrderBase.)
Protected property | grossToProcessTotalForeign | (Inherited from OrderBase.)
Protected property | grossTotal | (Inherited from OrderBase.)
Protected property | grossTotalForeign | (Inherited from OrderBase.)
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Inherited from OrderBase.)
Public property | InvoiceDate | Gets or sets the invoice date. (Inherited from OrderBase.)
Public property | InvoiceTo | Gets or sets the invoice address. (Inherited from OrderBase.)
Public property | IsLoading | Will be true while the order is busy loading detail. (Inherited from OrderBase.)
Public property | IsPartialProcessingAllowed | (Inherited from OrderBase.)
Public property | IsProcessing | Will be true while the order is busy processing transactions. (Inherited from OrderBase.)
Public property | LedgerTransaction | Gets the last ledger transaction (AR/AP Transaction) posted. (Inherited from OrderBase.)
Protected property | lineAdditionalCostTotal | (Inherited from OrderBase.)
Public property | LongID | (Inherited from OrderBase.)
Public property | MessageLine1 | Gets or sets the 1st message line. (Inherited from OrderBase.)
Public property | MessageLine2 | Gets or sets the 2nd message line. (Inherited from OrderBase.)
Public property | MessageLine3 | Gets or sets the 3rd message line. (Inherited from OrderBase.)
Protected property | nettLastProcessTotal | (Inherited from OrderBase.)
Protected property | nettLastProcessTotalForeign | (Inherited from OrderBase.)
Protected property | nettOutstTotal | (Inherited from OrderBase.)
Protected property | nettOutstTotalForeign | (Inherited from OrderBase.)
Protected property | nettToProcessTotal | (Inherited from OrderBase.)
Protected property | nettToProcessTotalForeign | (Inherited from OrderBase.)
Public property | OrderDate | Gets or sets the order date. (Inherited from OrderBase.)
Public property | OrderNo | Gets or sets the order number. (Inherited from OrderBase.)
Public property | OrderPriority | Gets or sets the order priority. (Inherited from OrderBase.)
Public property | OrderPriorityID | Gets or sets the order priority ID. (Inherited from OrderBase.)
Public property | OrderStatus | Gets or sets the document's order status. (Inherited from OrderBase.)
Public property | OrderStatusID | Gets or sets the order status ID. (Inherited from OrderBase.)
Public property | OriginalDocument | Gets the order's original document. (Overrides OrderBase..::..OriginalDocument.)
Public property | PrintCount | Gets or sets the print count. (Inherited from OrderBase.)
Public property | Project | Gets or sets the project. (Inherited from OrderBase.)
Public property | ProjectID | Gets or sets the project ID. (Inherited from OrderBase.)
Public property | Prospect | (Inherited from OrderBase.)
Public property | ProspectID | (Inherited from OrderBase.)
Public property | RawFieldData | Obsolete. (Inherited from OrderBase.)
Public property | Reference | Gets or sets the document reference (InvNumber). (Inherited from OrderBase.)
Public property | Reference2 | Gets the 2nd document reference. (Inherited from OrderBase.)
Public property | Representative | Gets or sets the document sales representative. (Inherited from SalesDocumentBase.)
Public property | RepresentativeID | Gets or sets the sales representative ID. (Inherited from SalesDocumentBase.)
Public property | SalesOpportunity | (Inherited from SalesDocumentBase.)
Public property | SettlementTerms | (Inherited from OrderBase.)
Public property | SettlementTermsID | (Inherited from OrderBase.)
Public property | State | Gets the document state. (Inherited from OrderBase.)
Protected property | taxLastProcessTotal | (Inherited from OrderBase.)
Protected property | taxLastProcessTotalForeign | (Inherited from OrderBase.)
Public property | TaxMode | Gets or sets the tax mode. (Inherited from OrderBase.)
Public property | TaxNumber | Gets or sets the cash account's tax number. (Inherited from OrderBase.)
Protected property | taxOutstTotal | (Inherited from OrderBase.)
Protected property | taxOutstTotalForeign | (Inherited from OrderBase.)
Protected property | taxToProcessTotal | (Inherited from OrderBase.)
Protected property | taxToProcessTotalForeign | (Inherited from OrderBase.)
Protected property | taxTotal | (Inherited from OrderBase.)
Protected property | taxTotalForeign | (Inherited from OrderBase.)
Public property | TaxType | (Inherited from OrderBase.)
Public property | TotalDiscountAdjusted | Gets the total discount adjusted amount. (Inherited from OrderBase.)
Public property | TotalDiscountAdjustedForeign | Gets the total discount adjusted foreign amount. (Inherited from OrderBase.)
Public property | TotalExcl | Gets the total excl amount. (Inherited from OrderBase.)
Public property | TotalExclForeign | Gets the total excl amount. (Inherited from OrderBase.)
Public property | TotalIncl | Gets the total incl amount. (Inherited from OrderBase.)
Public property | TotalInclForeign | Gets the total incl amount. (Inherited from OrderBase.)
Public property | TotalInclForeignBeforeInvoiceRounding | Gets the total incl amount before Invoice Rounding. (Inherited from OrderBase.)
Public property | TotalLastProcessExcl | Gets the total last process excl. (Inherited from OrderBase.)
Public property | TotalLastProcessExclForeign | Gets the total last process excl. (Inherited from OrderBase.)
Public property | TotalLastProcessIncl | Gets the total last process incl. (Inherited from OrderBase.)
Public property | TotalLastProcessInclForeign | Gets the total last process incl. (Inherited from OrderBase.)
Public property | TotalLastProcessTax | Gets the total last process tax. (Inherited from OrderBase.)
Public property | TotalLastProcessTaxForeign | Gets the total last process tax. (Inherited from OrderBase.)
Public property | TotalOutstandingExcl | Gets the total outstanding excl. (Inherited from OrderBase.)
Public property | TotalOutstandingExclForeign | Gets the total outstanding excl. (Inherited from OrderBase.)
Public property | TotalOutstandingIncl | Gets the total outstanding incl. (Inherited from OrderBase.)
Public property | TotalOutstandingInclForeign | Gets the total outstanding incl. (Inherited from OrderBase.)
Public property | TotalOutstandingTax | Gets the total outstanding tax. (Inherited from OrderBase.)
Public property | TotalOutstandingTaxForeign | Gets the total outstanding tax. (Inherited from OrderBase.)
Public property | TotalTax | Gets the total tax amount. (Inherited from OrderBase.)
Public property | TotalTaxForeign | Gets the total tax amount. (Inherited from OrderBase.)
Public property | TotalToProcessExcl | Gets the total amount to process excl. (Inherited from OrderBase.)
Public property | TotalToProcessExclForeign | Gets the total amount to process excl. (Inherited from OrderBase.)
Public property | TotalToProcessIncl | Gets the total to process incl. (Inherited from OrderBase.)
Public property | TotalToProcessInclForeign | Gets the total to process incl. (Inherited from OrderBase.)
Public property | TotalToProcessTax | Gets the total to process tax. (Inherited from OrderBase.)
Public property | TotalToProcessTaxForeign | Gets the total to process tax. (Inherited from OrderBase.)
Public property | Type | Gets the order's document type. (Inherited from OrderBase.)
Public property | UserFields | Gets access to the collection of user-defined fields on the record. Note that the field name is case-sensitive. (Inherited from OrderBase.)
Public property | Version | Gets the current version of the order, incremented on every save. (Inherited from OrderBase.)

See Also

SalesOrder Class


SalesOrder.DeliveryNote Property

[image]

Pastel Evolution SDK
SalesOrder..::..DeliveryNote Property
SalesOrder Class See Also Send Feedback
Gets or sets the document delivery note number

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string DeliveryNote { get; set; }
Visual Basic
Public Property DeliveryNote As String
    Get
    Set

Property Value

Type: String

See Also

SalesOrder Class
SalesOrder Members


SalesOrder.OriginalDocument Property

[image]

Pastel Evolution SDK
SalesOrder..::..OriginalDocument Property
SalesOrder Class See Also Send Feedback
Gets the order's original document.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override OrderBase OriginalDocument { get; }
Visual Basic
Public Overrides ReadOnly Property OriginalDocument As OrderBase
    Get

Property Value

Type: OrderBase

See Also

SalesOrder Class
SalesOrder Members


SalesOrderQuotation Class

[image]

Pastel Evolution SDK
SalesOrderQuotation Class
Members See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class SalesOrderQuotation : SalesOrder
Visual Basic
Public Class SalesOrderQuotation
    Inherits SalesOrder

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..OrderBase
Pastel.Evolution..::..SalesDocumentBase
Pastel.Evolution..::..SalesOrder
Pastel.Evolution..::..SalesOrderQuotation

See Also

SalesOrderQuotation Members


SalesOrderQuotation Members

[image] [image]

Pastel Evolution SDK
SalesOrderQuotation Members
SalesOrderQuotation Class Constructors Methods Fields Properties See Also Send Feedback

The SalesOrderQuotation type exposes the following members.

Constructors

 | Name | Description
Public method | SalesOrderQuotation()()()() | Initializes a new instance of the SalesOrderQuotation class
Public method | SalesOrderQuotation(Int32) | Initializes a new instance of the SalesOrderQuotation class
Public method | SalesOrderQuotation(String) | Initializes a new instance of the SalesOrderQuotation class

Methods

 | Name | Description
Public method | _SetFullQtyToProcess | (Inherited from OrderBase.)
Public method | _SetMaxQtyToProcess | Experimental method (Inherited from SalesOrder.)
Protected method | BeforePostGLBatch | (Inherited from SalesOrder.)
Protected method | BeforePostInventory | (Inherited from SalesOrder.)
Protected method | BeforePostLedger | (Inherited from SalesOrder.)
Protected method | BeforeSave | (Overrides OrderBase..::..BeforeSave()()()().)
Public method | CalcRounding | (Inherited from SalesDocumentBase.)
Protected method | cascadeForeignValues | (Inherited from OrderBase.)
Protected method | cascadeProject | (Inherited from OrderBase.)
Protected method | cascadeRepresentative | (Inherited from SalesDocumentBase.)
Protected method | cascadeTaxRate | (Inherited from OrderBase.)
Public method | Complete()()()() | Processes (invoices) all outstanding quantities on the order. The entire invoice fails if one or more detail lines do not have sufficient stock available. The CompleteMax method (SalesOrder only) is a variation on this method and attempts to confirm as much of the ordered stock as is available. (Inherited from OrderBase.)
Public method | Complete(String) | Process (invoice) all outstanding quantities on the order. The entire invoice fails if one or more detail lines do not have sufficient stock available. The method is a variation on this method and attempts to confirm as much of the ordered stock as is available. (Inherited from OrderBase.)
Public method | CompleteMax | Processes as much of the ordered stock as is available. If an "all or nothing" approach is required, use the method instead. (Inherited from SalesOrder.)
Public method | ConvertToOrder | Converts a quotation into an unprocessed sales order. If automatic numbering is enabled and immediate processing required, this step may be omitted. Otherwise, convert the quote, then set the order number and finally, process.
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Protected method | Detach | (Inherited from OrderBase.)
Protected method | detailRemainsOutstanding | (Inherited from OrderBase.)
Protected method | detailToProcess | (Inherited from OrderBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds and returns the id of the first order matching the supplied criteria. E.g. OrderNum = 'SO0001'
Protected method | fullQtySelected | (Inherited from OrderBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | glCreditPosting | (Inherited from SalesOrder.)
Protected method | glDebitPosting | (Inherited from SalesOrder.)
Protected method | initialise | (Inherited from SalesOrder.)
 | List | Lists quotations for the supplied criteria.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Not supported. Use the delete facility from inside Evolution. (Inherited from OrderBase.)
Protected method | OnSave | (Inherited from OrderBase.)
Public method | Process()()()() | Posts the document to the various accounts and ledgers applicable. (Inherited from OrderBase.)
Public method | Process(String) | Posts the document to the various accounts and ledgers applicable. (Inherited from OrderBase.)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | account | (Inherited from OrderBase.)
Protected field | archID | (Inherited from OrderBase.)
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | currency | (Inherited from OrderBase.)
Protected field | dcTran | (Inherited from OrderBase.)
Protected field | deliverTo | (Inherited from OrderBase.)
Protected field | deliveryMethod | (Inherited from OrderBase.)
Protected field | detail | (Inherited from OrderBase.)
Protected field | glBatch | (Inherited from OrderBase.)
Protected field | invoiceTo | (Inherited from OrderBase.)
Protected field | orderPriority | (Inherited from OrderBase.)
Protected field | orderStatus | (Inherited from OrderBase.)
Protected field | originalDocument | (Inherited from OrderBase.)
Protected field | processingAdditionalCosts | (Inherited from OrderBase.)
Protected field | processLedger | Should the document process to AR or AP ledger? (Inherited from OrderBase.)
Protected field | processStock | (Inherited from OrderBase.)
Protected field | project | (Inherited from OrderBase.)
Protected field | prospect | (Inherited from OrderBase.)
Protected field | salesOpp | (Inherited from SalesDocumentBase.)
Protected field | salesRep | (Inherited from SalesDocumentBase.)
Protected field | settlementTerms | (Inherited from OrderBase.)
Protected field | taxType | (Inherited from OrderBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | Account | Gets or sets the AR or AP account associated with the order. (Inherited from OrderBase.)
Public property | AccountID | Gets or sets the ID of the AR or AP account associated with the order. (Inherited from OrderBase.)
Public property | AllowInvoiceRounding | (Inherited from OrderBase.)
Public property | ApplyTaxPerLine | Gets or sets whether tax per line should be applied. (Inherited from OrderBase.)
Public property | Audit | Gets the audit number of the last transaction processed by this document. This value defaults to 0, and will not be available on recalled documents. (Inherited from OrderBase.)
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Currency | Gets or sets the currency. (Inherited from OrderBase.)
Public property | CurrencyID | Gets or sets the document's currency ID. (Inherited from OrderBase.)
Public property | Customer | Gets or sets the document's customer account (maps directly to Account). (Inherited from SalesDocumentBase.)
Public property | DeliverTo | Gets or sets the delivery address. (Inherited from OrderBase.)
Public property | DeliveryDate | Gets or sets the delivery date. (Inherited from OrderBase.)
Public property | DeliveryMethod | Gets or sets the delivery method. (Inherited from OrderBase.)
Public property | DeliveryMethodID | Gets or sets the delivery method ID. (Inherited from OrderBase.)
Public property | DeliveryNote | Gets or sets the document delivery note number (Inherited from SalesOrder.)
Public property | Description | Gets or sets the document description. This will also be the description on any transactions posted. (Inherited from OrderBase.)
Public property | Detail | Gets the order detail collection representing the body of the document. (Inherited from OrderBase.)
Public property | Discount | Gets or sets the document discount amount (applicable to tax excl. total), (Inherited from OrderBase.)
Public property | DiscountForeign | Gets or sets the document foreign discount amount (applicable to tax excl. total), (Inherited from OrderBase.)
Public property | DiscountLastProcessed | Gets the document discount amount last processed. (Inherited from OrderBase.)
Public property | DiscountPercent | Gets or sets the document discount percentage. (Inherited from OrderBase.)
Public property | DiscountToProcess | Gets the document discount amount about to be processed (applicable to tax excl. total). (Inherited from OrderBase.)
Public property | DueDate | Gets or sets the due date. (Inherited from OrderBase.)
Public property | ExchangeRate | Gets or sets the exchange rate. (Inherited from OrderBase.)
Public property | ExternalOrderNo | Gets or sets the external order number. (Inherited from OrderBase.)
Protected property | grossLastProcessTotal | (Inherited from OrderBase.)
Protected property | grossLastProcessTotalForeign | (Inherited from OrderBase.)
Protected property | grossOutstTotal | (Inherited from OrderBase.)
Protected property | grossOutstTotalForeign | (Inherited from OrderBase.)
Protected property | grossToProcessTotal | (Inherited from OrderBase.)
Protected property | grossToProcessTotalForeign | (Inherited from OrderBase.)
Protected property | grossTotal | (Inherited from OrderBase.)
Protected property | grossTotalForeign | (Inherited from OrderBase.)
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Inherited from OrderBase.)
Public property | InvoiceDate | Gets or sets the invoice date. (Inherited from OrderBase.)
Public property | InvoiceTo | Gets or sets the invoice address. (Inherited from OrderBase.)
Public property | IsLoading | Will be true while the order is busy loading detail. (Inherited from OrderBase.)
Public property | IsPartialProcessingAllowed | (Inherited from OrderBase.)
Public property | IsProcessing | Will be true while the order is busy processing transactions. (Inherited from OrderBase.)
Public property | LedgerTransaction | Gets the last ledger transaction (AR/AP Transaction) posted. (Inherited from OrderBase.)
Protected property | lineAdditionalCostTotal | (Inherited from OrderBase.)
Public property | LongID | (Inherited from OrderBase.)
Public property | MessageLine1 | Gets or sets the 1st message line. (Inherited from OrderBase.)
Public property | MessageLine2 | Gets or sets the 2nd message line. (Inherited from OrderBase.)
Public property | MessageLine3 | Gets or sets the 3rd message line. (Inherited from OrderBase.)
Protected property | nettLastProcessTotal | (Inherited from OrderBase.)
Protected property | nettLastProcessTotalForeign | (Inherited from OrderBase.)
Protected property | nettOutstTotal | (Inherited from OrderBase.)
Protected property | nettOutstTotalForeign | (Inherited from OrderBase.)
Protected property | nettToProcessTotal | (Inherited from OrderBase.)
Protected property | nettToProcessTotalForeign | (Inherited from OrderBase.)
Public property | OrderDate | Gets or sets the order date. (Inherited from OrderBase.)
Public property | OrderNo | Gets or sets the order number. (Inherited from OrderBase.)
Public property | OrderPriority | Gets or sets the order priority. (Inherited from OrderBase.)
Public property | OrderPriorityID | Gets or sets the order priority ID. (Inherited from OrderBase.)
Public property | OrderStatus | Gets or sets the document's order status. (Inherited from OrderBase.)
Public property | OrderStatusID | Gets or sets the order status ID. (Inherited from OrderBase.)
Public property | OriginalDocument | Gets the order's original document. (Inherited from SalesOrder.)
Public property | PrintCount | Gets or sets the print count. (Inherited from OrderBase.)
Public property | Project | Gets or sets the project. (Inherited from OrderBase.)
Public property | ProjectID | Gets or sets the project ID. (Inherited from OrderBase.)
Public property | Prospect | (Inherited from OrderBase.)
Public property | ProspectID | (Inherited from OrderBase.)
Public property | QuoteNo |
Public property | RawFieldData | Obsolete. (Inherited from OrderBase.)
Public property | Reference | Gets or sets the document reference (InvNumber). (Inherited from OrderBase.)
Public property | Reference2 | Gets the 2nd document reference. (Inherited from OrderBase.)
Public property | Representative | Gets or sets the document sales representative. (Inherited from SalesDocumentBase.)
Public property | RepresentativeID | Gets or sets the sales representative ID. (Inherited from SalesDocumentBase.)
Public property | SalesOpportunity | (Inherited from SalesDocumentBase.)
Public property | SettlementTerms | (Inherited from OrderBase.)
Public property | SettlementTermsID | (Inherited from OrderBase.)
Public property | State | Gets the document state. (Inherited from OrderBase.)
Protected property | taxLastProcessTotal | (Inherited from OrderBase.)
Protected property | taxLastProcessTotalForeign | (Inherited from OrderBase.)
Public property | TaxMode | Gets or sets the tax mode. (Inherited from OrderBase.)
Public property | TaxNumber | Gets or sets the cash account's tax number. (Inherited from OrderBase.)
Protected property | taxOutstTotal | (Inherited from OrderBase.)
Protected property | taxOutstTotalForeign | (Inherited from OrderBase.)
Protected property | taxToProcessTotal | (Inherited from OrderBase.)
Protected property | taxToProcessTotalForeign | (Inherited from OrderBase.)
Protected property | taxTotal | (Inherited from OrderBase.)
Protected property | taxTotalForeign | (Inherited from OrderBase.)
Public property | TaxType | (Inherited from OrderBase.)
Public property | TotalDiscountAdjusted | Gets the total discount adjusted amount. (Inherited from OrderBase.)
Public property | TotalDiscountAdjustedForeign | Gets the total discount adjusted foreign amount. (Inherited from OrderBase.)
Public property | TotalExcl | Gets the total excl amount. (Inherited from OrderBase.)
Public property | TotalExclForeign | Gets the total excl amount. (Inherited from OrderBase.)
Public property | TotalIncl | Gets the total incl amount. (Inherited from OrderBase.)
Public property | TotalInclForeign | Gets the total incl amount. (Inherited from OrderBase.)
Public property | TotalInclForeignBeforeInvoiceRounding | Gets the total incl amount before Invoice Rounding. (Inherited from OrderBase.)
Public property | TotalLastProcessExcl | Gets the total last process excl. (Inherited from OrderBase.)
Public property | TotalLastProcessExclForeign | Gets the total last process excl. (Inherited from OrderBase.)
Public property | TotalLastProcessIncl | Gets the total last process incl. (Inherited from OrderBase.)
Public property | TotalLastProcessInclForeign | Gets the total last process incl. (Inherited from OrderBase.)
Public property | TotalLastProcessTax | Gets the total last process tax. (Inherited from OrderBase.)
Public property | TotalLastProcessTaxForeign | Gets the total last process tax. (Inherited from OrderBase.)
Public property | TotalOutstandingExcl | Gets the total outstanding excl. (Inherited from OrderBase.)
Public property | TotalOutstandingExclForeign | Gets the total outstanding excl. (Inherited from OrderBase.)
Public property | TotalOutstandingIncl | Gets the total outstanding incl. (Inherited from OrderBase.)
Public property | TotalOutstandingInclForeign | Gets the total outstanding incl. (Inherited from OrderBase.)
Public property | TotalOutstandingTax | Gets the total outstanding tax. (Inherited from OrderBase.)
Public property | TotalOutstandingTaxForeign | Gets the total outstanding tax. (Inherited from OrderBase.)
Public property | TotalTax | Gets the total tax amount. (Inherited from OrderBase.)
Public property | TotalTaxForeign | Gets the total tax amount. (Inherited from OrderBase.)
Public property | TotalToProcessExcl | Gets the total amount to process excl. (Inherited from OrderBase.)
Public property | TotalToProcessExclForeign | Gets the total amount to process excl. (Inherited from OrderBase.)
Public property | TotalToProcessIncl | Gets the total to process incl. (Inherited from OrderBase.)
Public property | TotalToProcessInclForeign | Gets the total to process incl. (Inherited from OrderBase.)
Public property | TotalToProcessTax | Gets the total to process tax. (Inherited from OrderBase.)
Public property | TotalToProcessTaxForeign | Gets the total to process tax. (Inherited from OrderBase.)
Public property | Type | Gets the order's document type. (Inherited from OrderBase.)
Public property | UserFields | Gets access to the collection of user-defined fields on the record. Note that the field name is case-sensitive. (Inherited from OrderBase.)
Public property | Version | Gets the current version of the order, incremented on every save. (Inherited from OrderBase.)

See Also

SalesOrderQuotation Class


SalesOrderQuotation Constructor

[image] [image]

Pastel Evolution SDK
SalesOrderQuotation Constructor
SalesOrderQuotation Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SalesOrderQuotation()()()() | Initializes a new instance of the SalesOrderQuotation class
Public method | SalesOrderQuotation(Int32) | Initializes a new instance of the SalesOrderQuotation class
Public method | SalesOrderQuotation(String) | Initializes a new instance of the SalesOrderQuotation class

See Also

SalesOrderQuotation Class
SalesOrderQuotation Members


SalesOrderQuotation Constructor

[image]

Pastel Evolution SDK
SalesOrderQuotation Constructor
SalesOrderQuotation Class See Also Send Feedback
Initializes a new instance of the SalesOrderQuotation class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public SalesOrderQuotation()
Visual Basic
Public Sub New

See Also

SalesOrderQuotation Class
SalesOrderQuotation Members
SalesOrderQuotation Overload


SalesOrderQuotation Constructor (Int32)

[image]

Pastel Evolution SDK
SalesOrderQuotation Constructor (Int32)
SalesOrderQuotation Class See Also Send Feedback
Initializes a new instance of the SalesOrderQuotation class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public SalesOrderQuotation(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32

See Also

SalesOrderQuotation Class
SalesOrderQuotation Members
SalesOrderQuotation Overload


SalesOrderQuotation Constructor (String)

[image]

Pastel Evolution SDK
SalesOrderQuotation Constructor (String)
SalesOrderQuotation Class See Also Send Feedback
Initializes a new instance of the SalesOrderQuotation class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public SalesOrderQuotation(
    string quoteReference
)
Visual Basic
Public Sub New (
    quoteReference As String
)

Parameters

quoteReference
Type: System..::..String

See Also

SalesOrderQuotation Class
SalesOrderQuotation Members
SalesOrderQuotation Overload


SalesOrderQuotation Fields

[image] [image]

Pastel Evolution SDK
SalesOrderQuotation Fields
SalesOrderQuotation Class See Also Send Feedback

The SalesOrderQuotation type exposes the following members.

Fields

 | Name | Description
Protected field | account | (Inherited from OrderBase.)
Protected field | archID | (Inherited from OrderBase.)
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | currency | (Inherited from OrderBase.)
Protected field | dcTran | (Inherited from OrderBase.)
Protected field | deliverTo | (Inherited from OrderBase.)
Protected field | deliveryMethod | (Inherited from OrderBase.)
Protected field | detail | (Inherited from OrderBase.)
Protected field | glBatch | (Inherited from OrderBase.)
Protected field | invoiceTo | (Inherited from OrderBase.)
Protected field | orderPriority | (Inherited from OrderBase.)
Protected field | orderStatus | (Inherited from OrderBase.)
Protected field | originalDocument | (Inherited from OrderBase.)
Protected field | processingAdditionalCosts | (Inherited from OrderBase.)
Protected field | processLedger | Should the document process to AR or AP ledger? (Inherited from OrderBase.)
Protected field | processStock | (Inherited from OrderBase.)
Protected field | project | (Inherited from OrderBase.)
Protected field | prospect | (Inherited from OrderBase.)
Protected field | salesOpp | (Inherited from SalesDocumentBase.)
Protected field | salesRep | (Inherited from SalesDocumentBase.)
Protected field | settlementTerms | (Inherited from OrderBase.)
Protected field | taxType | (Inherited from OrderBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

SalesOrderQuotation Class


SalesOrderQuotation Methods

[image] [image]

Pastel Evolution SDK
SalesOrderQuotation Methods
SalesOrderQuotation Class See Also Send Feedback

The SalesOrderQuotation type exposes the following members.

Methods

 | Name | Description
Public method | _SetFullQtyToProcess | (Inherited from OrderBase.)
Public method | _SetMaxQtyToProcess | Experimental method (Inherited from SalesOrder.)
Protected method | BeforePostGLBatch | (Inherited from SalesOrder.)
Protected method | BeforePostInventory | (Inherited from SalesOrder.)
Protected method | BeforePostLedger | (Inherited from SalesOrder.)
Protected method | BeforeSave | (Overrides OrderBase..::..BeforeSave()()()().)
Public method | CalcRounding | (Inherited from SalesDocumentBase.)
Protected method | cascadeForeignValues | (Inherited from OrderBase.)
Protected method | cascadeProject | (Inherited from OrderBase.)
Protected method | cascadeRepresentative | (Inherited from SalesDocumentBase.)
Protected method | cascadeTaxRate | (Inherited from OrderBase.)
Public method | Complete()()()() | Processes (invoices) all outstanding quantities on the order. The entire invoice fails if one or more detail lines do not have sufficient stock available. The CompleteMax method (SalesOrder only) is a variation on this method and attempts to confirm as much of the ordered stock as is available. (Inherited from OrderBase.)
Public method | Complete(String) | Process (invoice) all outstanding quantities on the order. The entire invoice fails if one or more detail lines do not have sufficient stock available. The method is a variation on this method and attempts to confirm as much of the ordered stock as is available. (Inherited from OrderBase.)
Public method | CompleteMax | Processes as much of the ordered stock as is available. If an "all or nothing" approach is required, use the method instead. (Inherited from SalesOrder.)
Public method | ConvertToOrder | Converts a quotation into an unprocessed sales order. If automatic numbering is enabled and immediate processing required, this step may be omitted. Otherwise, convert the quote, then set the order number and finally, process.
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Protected method | Detach | (Inherited from OrderBase.)
Protected method | detailRemainsOutstanding | (Inherited from OrderBase.)
Protected method | detailToProcess | (Inherited from OrderBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds and returns the id of the first order matching the supplied criteria. E.g. OrderNum = 'SO0001'
Protected method | fullQtySelected | (Inherited from OrderBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | glCreditPosting | (Inherited from SalesOrder.)
Protected method | glDebitPosting | (Inherited from SalesOrder.)
Protected method | initialise | (Inherited from SalesOrder.)
 | List | Lists quotations for the supplied criteria.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Not supported. Use the delete facility from inside Evolution. (Inherited from OrderBase.)
Protected method | OnSave | (Inherited from OrderBase.)
Public method | Process()()()() | Posts the document to the various accounts and ledgers applicable. (Inherited from OrderBase.)
Public method | Process(String) | Posts the document to the various accounts and ledgers applicable. (Inherited from OrderBase.)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

SalesOrderQuotation Class


SalesOrderQuotation.BeforeSave Method

[image]

Pastel Evolution SDK
SalesOrderQuotation..::..BeforeSave Method
SalesOrderQuotation Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void BeforeSave()
Visual Basic
Protected Friend Overrides Sub BeforeSave

See Also

SalesOrderQuotation Class
SalesOrderQuotation Members


SalesOrderQuotation.ConvertToOrder Method

[image]

Pastel Evolution SDK
SalesOrderQuotation..::..ConvertToOrder Method
SalesOrderQuotation Class See Also Send Feedback
Converts a quotation into an unprocessed sales order. If automatic numbering is enabled and immediate processing required, this step may be omitted. Otherwise, convert the quote, then set the order number and finally, process.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public SalesOrder ConvertToOrder()
Visual Basic
Public Function ConvertToOrder As SalesOrder

Return Value

Type: SalesOrder

See Also

SalesOrderQuotation Class
SalesOrderQuotation Members


SalesOrderQuotation.Find Method

[image]

Pastel Evolution SDK
SalesOrderQuotation..::..Find Method
SalesOrderQuotation Class See Also Send Feedback
Finds and returns the id of the first order matching the supplied criteria. E.g. OrderNum = 'SO0001'

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.

Return Value

Type: Int32
The ID of the first record found; -1 if not record was found.

See Also

SalesOrderQuotation Class
SalesOrderQuotation Members


SalesOrderQuotation.List Method

[image]

Pastel Evolution SDK
SalesOrderQuotation..::..List Method
SalesOrderQuotation Class See Also Send Feedback
Lists quotations for the supplied criteria.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria
)
Visual Basic
Public Shared Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String
E.g. Customer.Account = 'CASH001' and (OrderNum = 'SO209302')

Return Value

Type: DataTable

Remarks

Pseudo-tables: Core, Customer

See Also

SalesOrderQuotation Class
SalesOrderQuotation Members


SalesOrderQuotation Properties

[image] [image]

Pastel Evolution SDK
SalesOrderQuotation Properties
SalesOrderQuotation Class See Also Send Feedback

The SalesOrderQuotation type exposes the following members.

Properties

 | Name | Description
Public property | Account | Gets or sets the AR or AP account associated with the order. (Inherited from OrderBase.)
Public property | AccountID | Gets or sets the ID of the AR or AP account associated with the order. (Inherited from OrderBase.)
Public property | AllowInvoiceRounding | (Inherited from OrderBase.)
Public property | ApplyTaxPerLine | Gets or sets whether tax per line should be applied. (Inherited from OrderBase.)
Public property | Audit | Gets the audit number of the last transaction processed by this document. This value defaults to 0, and will not be available on recalled documents. (Inherited from OrderBase.)
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Currency | Gets or sets the currency. (Inherited from OrderBase.)
Public property | CurrencyID | Gets or sets the document's currency ID. (Inherited from OrderBase.)
Public property | Customer | Gets or sets the document's customer account (maps directly to Account). (Inherited from SalesDocumentBase.)
Public property | DeliverTo | Gets or sets the delivery address. (Inherited from OrderBase.)
Public property | DeliveryDate | Gets or sets the delivery date. (Inherited from OrderBase.)
Public property | DeliveryMethod | Gets or sets the delivery method. (Inherited from OrderBase.)
Public property | DeliveryMethodID | Gets or sets the delivery method ID. (Inherited from OrderBase.)
Public property | DeliveryNote | Gets or sets the document delivery note number (Inherited from SalesOrder.)
Public property | Description | Gets or sets the document description. This will also be the description on any transactions posted. (Inherited from OrderBase.)
Public property | Detail | Gets the order detail collection representing the body of the document. (Inherited from OrderBase.)
Public property | Discount | Gets or sets the document discount amount (applicable to tax excl. total), (Inherited from OrderBase.)
Public property | DiscountForeign | Gets or sets the document foreign discount amount (applicable to tax excl. total), (Inherited from OrderBase.)
Public property | DiscountLastProcessed | Gets the document discount amount last processed. (Inherited from OrderBase.)
Public property | DiscountPercent | Gets or sets the document discount percentage. (Inherited from OrderBase.)
Public property | DiscountToProcess | Gets the document discount amount about to be processed (applicable to tax excl. total). (Inherited from OrderBase.)
Public property | DueDate | Gets or sets the due date. (Inherited from OrderBase.)
Public property | ExchangeRate | Gets or sets the exchange rate. (Inherited from OrderBase.)
Public property | ExternalOrderNo | Gets or sets the external order number. (Inherited from OrderBase.)
Protected property | grossLastProcessTotal | (Inherited from OrderBase.)
Protected property | grossLastProcessTotalForeign | (Inherited from OrderBase.)
Protected property | grossOutstTotal | (Inherited from OrderBase.)
Protected property | grossOutstTotalForeign | (Inherited from OrderBase.)
Protected property | grossToProcessTotal | (Inherited from OrderBase.)
Protected property | grossToProcessTotalForeign | (Inherited from OrderBase.)
Protected property | grossTotal | (Inherited from OrderBase.)
Protected property | grossTotalForeign | (Inherited from OrderBase.)
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Inherited from OrderBase.)
Public property | InvoiceDate | Gets or sets the invoice date. (Inherited from OrderBase.)
Public property | InvoiceTo | Gets or sets the invoice address. (Inherited from OrderBase.)
Public property | IsLoading | Will be true while the order is busy loading detail. (Inherited from OrderBase.)
Public property | IsPartialProcessingAllowed | (Inherited from OrderBase.)
Public property | IsProcessing | Will be true while the order is busy processing transactions. (Inherited from OrderBase.)
Public property | LedgerTransaction | Gets the last ledger transaction (AR/AP Transaction) posted. (Inherited from OrderBase.)
Protected property | lineAdditionalCostTotal | (Inherited from OrderBase.)
Public property | LongID | (Inherited from OrderBase.)
Public property | MessageLine1 | Gets or sets the 1st message line. (Inherited from OrderBase.)
Public property | MessageLine2 | Gets or sets the 2nd message line. (Inherited from OrderBase.)
Public property | MessageLine3 | Gets or sets the 3rd message line. (Inherited from OrderBase.)
Protected property | nettLastProcessTotal | (Inherited from OrderBase.)
Protected property | nettLastProcessTotalForeign | (Inherited from OrderBase.)
Protected property | nettOutstTotal | (Inherited from OrderBase.)
Protected property | nettOutstTotalForeign | (Inherited from OrderBase.)
Protected property | nettToProcessTotal | (Inherited from OrderBase.)
Protected property | nettToProcessTotalForeign | (Inherited from OrderBase.)
Public property | OrderDate | Gets or sets the order date. (Inherited from OrderBase.)
Public property | OrderNo | Gets or sets the order number. (Inherited from OrderBase.)
Public property | OrderPriority | Gets or sets the order priority. (Inherited from OrderBase.)
Public property | OrderPriorityID | Gets or sets the order priority ID. (Inherited from OrderBase.)
Public property | OrderStatus | Gets or sets the document's order status. (Inherited from OrderBase.)
Public property | OrderStatusID | Gets or sets the order status ID. (Inherited from OrderBase.)
Public property | OriginalDocument | Gets the order's original document. (Inherited from SalesOrder.)
Public property | PrintCount | Gets or sets the print count. (Inherited from OrderBase.)
Public property | Project | Gets or sets the project. (Inherited from OrderBase.)
Public property | ProjectID | Gets or sets the project ID. (Inherited from OrderBase.)
Public property | Prospect | (Inherited from OrderBase.)
Public property | ProspectID | (Inherited from OrderBase.)
Public property | QuoteNo |
Public property | RawFieldData | Obsolete. (Inherited from OrderBase.)
Public property | Reference | Gets or sets the document reference (InvNumber). (Inherited from OrderBase.)
Public property | Reference2 | Gets the 2nd document reference. (Inherited from OrderBase.)
Public property | Representative | Gets or sets the document sales representative. (Inherited from SalesDocumentBase.)
Public property | RepresentativeID | Gets or sets the sales representative ID. (Inherited from SalesDocumentBase.)
Public property | SalesOpportunity | (Inherited from SalesDocumentBase.)
Public property | SettlementTerms | (Inherited from OrderBase.)
Public property | SettlementTermsID | (Inherited from OrderBase.)
Public property | State | Gets the document state. (Inherited from OrderBase.)
Protected property | taxLastProcessTotal | (Inherited from OrderBase.)
Protected property | taxLastProcessTotalForeign | (Inherited from OrderBase.)
Public property | TaxMode | Gets or sets the tax mode. (Inherited from OrderBase.)
Public property | TaxNumber | Gets or sets the cash account's tax number. (Inherited from OrderBase.)
Protected property | taxOutstTotal | (Inherited from OrderBase.)
Protected property | taxOutstTotalForeign | (Inherited from OrderBase.)
Protected property | taxToProcessTotal | (Inherited from OrderBase.)
Protected property | taxToProcessTotalForeign | (Inherited from OrderBase.)
Protected property | taxTotal | (Inherited from OrderBase.)
Protected property | taxTotalForeign | (Inherited from OrderBase.)
Public property | TaxType | (Inherited from OrderBase.)
Public property | TotalDiscountAdjusted | Gets the total discount adjusted amount. (Inherited from OrderBase.)
Public property | TotalDiscountAdjustedForeign | Gets the total discount adjusted foreign amount. (Inherited from OrderBase.)
Public property | TotalExcl | Gets the total excl amount. (Inherited from OrderBase.)
Public property | TotalExclForeign | Gets the total excl amount. (Inherited from OrderBase.)
Public property | TotalIncl | Gets the total incl amount. (Inherited from OrderBase.)
Public property | TotalInclForeign | Gets the total incl amount. (Inherited from OrderBase.)
Public property | TotalInclForeignBeforeInvoiceRounding | Gets the total incl amount before Invoice Rounding. (Inherited from OrderBase.)
Public property | TotalLastProcessExcl | Gets the total last process excl. (Inherited from OrderBase.)
Public property | TotalLastProcessExclForeign | Gets the total last process excl. (Inherited from OrderBase.)
Public property | TotalLastProcessIncl | Gets the total last process incl. (Inherited from OrderBase.)
Public property | TotalLastProcessInclForeign | Gets the total last process incl. (Inherited from OrderBase.)
Public property | TotalLastProcessTax | Gets the total last process tax. (Inherited from OrderBase.)
Public property | TotalLastProcessTaxForeign | Gets the total last process tax. (Inherited from OrderBase.)
Public property | TotalOutstandingExcl | Gets the total outstanding excl. (Inherited from OrderBase.)
Public property | TotalOutstandingExclForeign | Gets the total outstanding excl. (Inherited from OrderBase.)
Public property | TotalOutstandingIncl | Gets the total outstanding incl. (Inherited from OrderBase.)
Public property | TotalOutstandingInclForeign | Gets the total outstanding incl. (Inherited from OrderBase.)
Public property | TotalOutstandingTax | Gets the total outstanding tax. (Inherited from OrderBase.)
Public property | TotalOutstandingTaxForeign | Gets the total outstanding tax. (Inherited from OrderBase.)
Public property | TotalTax | Gets the total tax amount. (Inherited from OrderBase.)
Public property | TotalTaxForeign | Gets the total tax amount. (Inherited from OrderBase.)
Public property | TotalToProcessExcl | Gets the total amount to process excl. (Inherited from OrderBase.)
Public property | TotalToProcessExclForeign | Gets the total amount to process excl. (Inherited from OrderBase.)
Public property | TotalToProcessIncl | Gets the total to process incl. (Inherited from OrderBase.)
Public property | TotalToProcessInclForeign | Gets the total to process incl. (Inherited from OrderBase.)
Public property | TotalToProcessTax | Gets the total to process tax. (Inherited from OrderBase.)
Public property | TotalToProcessTaxForeign | Gets the total to process tax. (Inherited from OrderBase.)
Public property | Type | Gets the order's document type. (Inherited from OrderBase.)
Public property | UserFields | Gets access to the collection of user-defined fields on the record. Note that the field name is case-sensitive. (Inherited from OrderBase.)
Public property | Version | Gets the current version of the order, incremented on every save. (Inherited from OrderBase.)

See Also

SalesOrderQuotation Class


SalesOrderQuotation.QuoteNo Property

[image]

Pastel Evolution SDK
SalesOrderQuotation..::..QuoteNo Property
SalesOrderQuotation Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string QuoteNo { get; set; }
Visual Basic
Public Property QuoteNo As String
    Get
    Set

Property Value

Type: String

See Also

SalesOrderQuotation Class
SalesOrderQuotation Members


SalesRepresentative Class

[image]

Pastel Evolution SDK
SalesRepresentative Class
Members See Also Send Feedback
Represents an Evolution sales representative.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class SalesRepresentative : BranchedRecordBase
Visual Basic
Public Class SalesRepresentative
    Inherits BranchedRecordBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..SalesRepresentative

See Also

SalesRepresentative Members


SalesRepresentative Members

[image] [image]

Pastel Evolution SDK
SalesRepresentative Members
SalesRepresentative Class Constructors Methods Fields Properties See Also Send Feedback

The SalesRepresentative type exposes the following members.

Constructors

 | Name | Description
Public method | SalesRepresentative()()()() | Creates a new instance of a representative.
Public method | SalesRepresentative(Int32) | Creates a new instance of a representative.
Public method | SalesRepresentative(String) | Creates a new instance of a representative.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds a record's database ID.
 | FindByCode | Attempts to find a representative by its code and returns its ID.
 | Get | Returns the [first] group object with the code specified; otherwise, returns null.
 | GetByCode | Returns a representative object corresponding to the code specified; otherwise, returns null.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | Address1 | Gets or sets the representative's address line 1.
Public property | Address2 | Gets or sets the representative's address2.
Public property | Address3 | Gets or sets the representative's address3.
Public property | Address4 | Gets or sets the representative's address4.
Public property | Bank | Gets or sets the representative's bank.
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Code | Gets or sets the representative's code.
Public property | Comment1 | Gets or sets the representative's comment1.
Public property | Comment2 | Gets or sets the representative's comment2.
Public property | Description | Gets or sets the representative's name.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | OnHold | Gets or sets the representative's status.

See Also

SalesRepresentative Class


SalesRepresentative Constructor

[image] [image]

Pastel Evolution SDK
SalesRepresentative Constructor
SalesRepresentative Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SalesRepresentative()()()() | Creates a new instance of a representative.
Public method | SalesRepresentative(Int32) | Creates a new instance of a representative.
Public method | SalesRepresentative(String) | Creates a new instance of a representative.

See Also

SalesRepresentative Class
SalesRepresentative Members


SalesRepresentative Constructor

[image]

Pastel Evolution SDK
SalesRepresentative Constructor
SalesRepresentative Class See Also Send Feedback
Creates a new instance of a representative.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public SalesRepresentative()
Visual Basic
Public Sub New

See Also

SalesRepresentative Class
SalesRepresentative Members
SalesRepresentative Overload


SalesRepresentative Constructor (Int32)

[image]

Pastel Evolution SDK
SalesRepresentative Constructor (Int32)
SalesRepresentative Class See Also Send Feedback
Creates a new instance of a representative.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public SalesRepresentative(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32
Specifies the id of the existing record.

See Also

SalesRepresentative Class
SalesRepresentative Members
SalesRepresentative Overload


SalesRepresentative Constructor (String)

[image]

Pastel Evolution SDK
SalesRepresentative Constructor (String)
SalesRepresentative Class See Also Send Feedback
Creates a new instance of a representative.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public SalesRepresentative(
    string code
)
Visual Basic
Public Sub New (
    code As String
)

Parameters

code
Type: System..::..String
Specifies the code of the existing record.

See Also

SalesRepresentative Class
SalesRepresentative Members
SalesRepresentative Overload


SalesRepresentative Fields

[image] [image]

Pastel Evolution SDK
SalesRepresentative Fields
SalesRepresentative Class See Also Send Feedback

The SalesRepresentative type exposes the following members.

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

SalesRepresentative Class


SalesRepresentative Methods

[image] [image]

Pastel Evolution SDK
SalesRepresentative Methods
SalesRepresentative Class See Also Send Feedback

The SalesRepresentative type exposes the following members.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds a record's database ID.
 | FindByCode | Attempts to find a representative by its code and returns its ID.
 | Get | Returns the [first] group object with the code specified; otherwise, returns null.
 | GetByCode | Returns a representative object corresponding to the code specified; otherwise, returns null.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

SalesRepresentative Class


SalesRepresentative.Find Method

[image]

Pastel Evolution SDK
SalesRepresentative..::..Find Method
SalesRepresentative Class See Also Send Feedback
Finds a record's database ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.

Return Value

Type: Int32
The ID of the first record found; -1 if not record was found.

See Also

SalesRepresentative Class
SalesRepresentative Members


SalesRepresentative.FindByCode Method

[image]

Pastel Evolution SDK
SalesRepresentative..::..FindByCode Method
SalesRepresentative Class See Also Send Feedback
Attempts to find a representative by its code and returns its ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int FindByCode(
    string code
)
Visual Basic
Public Shared Function FindByCode (
    code As String
) As Integer

Parameters

code
Type: System..::..String
The code used to lookup the record.

Return Value

Type: Int32
-1 if no record was found, else the id of the first record matching the criteria supplied.

See Also

SalesRepresentative Class
SalesRepresentative Members
Pastel.Evolution Namespace
SalesRepresentative..::..Find(String)


SalesRepresentative.Get Method

[image]

Pastel Evolution SDK
SalesRepresentative..::..Get Method
SalesRepresentative Class See Also Send Feedback
Returns the [first] group object with the code specified; otherwise, returns null.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static SalesRepresentative Get(
    string criteria
)
Visual Basic
Public Shared Function Get (
    criteria As String
) As SalesRepresentative

Parameters

criteria
Type: System..::..String
Eg. Code like '1_B%'

Return Value

Type: SalesRepresentative
The record found; otherwise null

See Also

SalesRepresentative Class
SalesRepresentative Members
Pastel.Evolution Namespace
SalesRepresentative..::..Find(String)


SalesRepresentative.GetByCode Method

[image]

Pastel Evolution SDK
SalesRepresentative..::..GetByCode Method
SalesRepresentative Class See Also Send Feedback
Returns a representative object corresponding to the code specified; otherwise, returns null.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static SalesRepresentative GetByCode(
    string code
)
Visual Basic
Public Shared Function GetByCode (
    code As String
) As SalesRepresentative

Parameters

code
Type: System..::..String
Specifies the code.

Return Value

Type: SalesRepresentative
The record found; otherwise null

See Also

SalesRepresentative Class
SalesRepresentative Members


SalesRepresentative.List Method

[image]

Pastel Evolution SDK
SalesRepresentative..::..List Method
SalesRepresentative Class See Also Send Feedback
Gets a list of database records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria
)
Visual Basic
Public Shared Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.

Return Value

Type: DataTable
Table containing selected records.

See Also

SalesRepresentative Class
SalesRepresentative Members


SalesRepresentative.OnDelete Method

[image]

Pastel Evolution SDK
SalesRepresentative..::..OnDelete Method
SalesRepresentative Class See Also Send Feedback
Removes the record from the database, provided it is not referenced by other records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

Exceptions

Exception | Condition
IntegrityViolationException |

See Also

SalesRepresentative Class
SalesRepresentative Members


SalesRepresentative.OnSave Method

[image]

Pastel Evolution SDK
SalesRepresentative..::..OnSave Method
SalesRepresentative Class See Also Send Feedback
Persists the record to the database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

SalesRepresentative Class
SalesRepresentative Members


SalesRepresentative Properties

[image] [image]

Pastel Evolution SDK
SalesRepresentative Properties
SalesRepresentative Class See Also Send Feedback

The SalesRepresentative type exposes the following members.

Properties

 | Name | Description
Public property | Address1 | Gets or sets the representative's address line 1.
Public property | Address2 | Gets or sets the representative's address2.
Public property | Address3 | Gets or sets the representative's address3.
Public property | Address4 | Gets or sets the representative's address4.
Public property | Bank | Gets or sets the representative's bank.
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Code | Gets or sets the representative's code.
Public property | Comment1 | Gets or sets the representative's comment1.
Public property | Comment2 | Gets or sets the representative's comment2.
Public property | Description | Gets or sets the representative's name.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | OnHold | Gets or sets the representative's status.

See Also

SalesRepresentative Class


SalesRepresentative.Address1 Property

[image]

Pastel Evolution SDK
SalesRepresentative..::..Address1 Property
SalesRepresentative Class See Also Send Feedback
Gets or sets the representative's address line 1.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Address1 { get; set; }
Visual Basic
Public Property Address1 As String
    Get
    Set

Property Value

Type: String

See Also

SalesRepresentative Class
SalesRepresentative Members


SalesRepresentative.Address2 Property

[image]

Pastel Evolution SDK
SalesRepresentative..::..Address2 Property
SalesRepresentative Class See Also Send Feedback
Gets or sets the representative's address2.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Address2 { get; set; }
Visual Basic
Public Property Address2 As String
    Get
    Set

Property Value

Type: String

See Also

SalesRepresentative Class
SalesRepresentative Members


SalesRepresentative.Address3 Property

[image]

Pastel Evolution SDK
SalesRepresentative..::..Address3 Property
SalesRepresentative Class See Also Send Feedback
Gets or sets the representative's address3.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Address3 { get; set; }
Visual Basic
Public Property Address3 As String
    Get
    Set

Property Value

Type: String

See Also

SalesRepresentative Class
SalesRepresentative Members


SalesRepresentative.Address4 Property

[image]

Pastel Evolution SDK
SalesRepresentative..::..Address4 Property
SalesRepresentative Class See Also Send Feedback
Gets or sets the representative's address4.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Address4 { get; set; }
Visual Basic
Public Property Address4 As String
    Get
    Set

Property Value

Type: String

See Also

SalesRepresentative Class
SalesRepresentative Members


SalesRepresentative.Bank Property

[image]

Pastel Evolution SDK
SalesRepresentative..::..Bank Property
SalesRepresentative Class See Also Send Feedback
Gets or sets the representative's bank.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Bank { get; set; }
Visual Basic
Public Property Bank As String
    Get
    Set

Property Value

Type: String

See Also

SalesRepresentative Class
SalesRepresentative Members


SalesRepresentative.Code Property

[image]

Pastel Evolution SDK
SalesRepresentative..::..Code Property
SalesRepresentative Class See Also Send Feedback
Gets or sets the representative's code.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Code { get; set; }
Visual Basic
Public Property Code As String
    Get
    Set

Property Value

Type: String

See Also

SalesRepresentative Class
SalesRepresentative Members


SalesRepresentative.Comment1 Property

[image]

Pastel Evolution SDK
SalesRepresentative..::..Comment1 Property
SalesRepresentative Class See Also Send Feedback
Gets or sets the representative's comment1.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Comment1 { get; set; }
Visual Basic
Public Property Comment1 As String
    Get
    Set

Property Value

Type: String

See Also

SalesRepresentative Class
SalesRepresentative Members


SalesRepresentative.Comment2 Property

[image]

Pastel Evolution SDK
SalesRepresentative..::..Comment2 Property
SalesRepresentative Class See Also Send Feedback
Gets or sets the representative's comment2.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Comment2 { get; set; }
Visual Basic
Public Property Comment2 As String
    Get
    Set

Property Value

Type: String

See Also

SalesRepresentative Class
SalesRepresentative Members


SalesRepresentative.Description Property

[image]

Pastel Evolution SDK
SalesRepresentative..::..Description Property
SalesRepresentative Class See Also Send Feedback
Gets or sets the representative's name.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set

Property Value

Type: String

See Also

SalesRepresentative Class
SalesRepresentative Members


SalesRepresentative.ID Property

[image]

Pastel Evolution SDK
SalesRepresentative..::..ID Property
SalesRepresentative Class See Also Send Feedback
Gets the internal record ID (0 for new, unsaved records).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

Remarks

Once saved, the ID will reflect the record's internal database identifier.

See Also

SalesRepresentative Class
SalesRepresentative Members


SalesRepresentative.LongID Property

[image]

Pastel Evolution SDK
SalesRepresentative..::..LongID Property
SalesRepresentative Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

SalesRepresentative Class
SalesRepresentative Members


SalesRepresentative.OnHold Property

[image]

Pastel Evolution SDK
SalesRepresentative..::..OnHold Property
SalesRepresentative Class See Also Send Feedback
Gets or sets the representative's status.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool OnHold { get; set; }
Visual Basic
Public Property OnHold As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

SalesRepresentative Class
SalesRepresentative Members


SellingPrice Class

[image]

Pastel Evolution SDK
SellingPrice Class
Members See Also Send Feedback
Represents a collection of inventory selling prices.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class SellingPrice
Visual Basic
Public Class SellingPrice

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..SellingPrice

See Also

SellingPrice Members
Pastel.Evolution Namespace
Pastel.Evolution..::..SellingPriceCollection


SellingPrice Members

[image] [image]

Pastel Evolution SDK
SellingPrice Members
SellingPrice Class Methods Properties See Also Send Feedback

The SellingPrice type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List | Gets a list of database records.
 | ListByPriceListID | Gets a list of selling prices by price list ID.
 | ListByStockItemAndWarehouseID | Gets a list of selling prices by stock item ID and Warehouse ID.
 | ListByStockItemID | Gets a list of selling prices by stock item ID.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save | Saves the individual selling price. Note that saving the inventory item automatically saves the entire selling price collection.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ID | Gets the record ID.
Public property | LongID | Transitional accessor.
Public property | MarkupCostingMethod |
Public property | MarkupPercentage | Gets or sets the markup percentage to be used in calculating this selling price. One can either specify a markup percentage,or specify fixed prices, but not both.
Public property | PriceExcl | Gets or sets the vat-exclusive unit price. Setting a value will automatically calculate the inclusive price using thedefault invoicing tax code on the inveotory item, and also cancel the effect of any markup percentage set.
Public property | PriceIncl | Gets or sets the vat-inclusive unit price. Setting a value will automatically calculate the exclusive price using thedefault invoicing tax code on the inveotory item, and also cancel the effect of any markup percentage set.
Public property | PriceList | Gets the price list this selling price belongs to.
Public property | StockItem | Gets the stock item this selling price belongs to.

See Also

SellingPrice Class


SellingPrice Methods

[image] [image]

Pastel Evolution SDK
SellingPrice Methods
SellingPrice Class See Also Send Feedback

The SellingPrice type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List | Gets a list of database records.
 | ListByPriceListID | Gets a list of selling prices by price list ID.
 | ListByStockItemAndWarehouseID | Gets a list of selling prices by stock item ID and Warehouse ID.
 | ListByStockItemID | Gets a list of selling prices by stock item ID.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save | Saves the individual selling price. Note that saving the inventory item automatically saves the entire selling price collection.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SellingPrice Class


SellingPrice.List Method

[image]

Pastel Evolution SDK
SellingPrice..::..List Method
SellingPrice Class See Also Send Feedback
Gets a list of database records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria
)
Visual Basic
Public Shared Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.

Return Value

Type: DataTable
Table containing selected records.

See Also

SellingPrice Class
SellingPrice Members


SellingPrice.ListByPriceListID Method

[image]

Pastel Evolution SDK
SellingPrice..::..ListByPriceListID Method
SellingPrice Class See Also Send Feedback
Gets a list of selling prices by price list ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable ListByPriceListID(
    int id
)
Visual Basic
Public Shared Function ListByPriceListID (
    id As Integer
) As DataTable

Parameters

id
Type: System..::..Int32
Specifies the price list id.

Return Value

Type: DataTable
The ListByPriceListID.

See Also

SellingPrice Class
SellingPrice Members


SellingPrice.ListByStockItemAndWarehouseID Method

[image]

Pastel Evolution SDK
SellingPrice..::..ListByStockItemAndWarehouseID Method
SellingPrice Class See Also Send Feedback
Gets a list of selling prices by stock item ID and Warehouse ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable ListByStockItemAndWarehouseID(
    int stockID,
    int warehouseID
)
Visual Basic
Public Shared Function ListByStockItemAndWarehouseID (
    stockID As Integer,
    warehouseID As Integer
) As DataTable

Parameters

stockID
Type: System..::..Int32
Specifies the stock item id.
warehouseID
Type: System..::..Int32
Specifies the warehouse id.

Return Value

Type: DataTable
The ListByStockItemAndWarehouseID.

See Also

SellingPrice Class
SellingPrice Members


SellingPrice.ListByStockItemID Method

[image]

Pastel Evolution SDK
SellingPrice..::..ListByStockItemID Method
SellingPrice Class See Also Send Feedback
Gets a list of selling prices by stock item ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable ListByStockItemID(
    int id
)
Visual Basic
Public Shared Function ListByStockItemID (
    id As Integer
) As DataTable

Parameters

id
Type: System..::..Int32
Specifies the stock item id.

Return Value

Type: DataTable
The ListByStockItemID.

See Also

SellingPrice Class
SellingPrice Members


SellingPrice.Save Method

[image]

Pastel Evolution SDK
SellingPrice..::..Save Method
SellingPrice Class See Also Send Feedback
Saves the individual selling price. Note that saving the inventory item automatically saves the entire selling price collection.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void Save()
Visual Basic
Public Sub Save

See Also

SellingPrice Class
SellingPrice Members


SellingPrice Properties

[image] [image]

Pastel Evolution SDK
SellingPrice Properties
SellingPrice Class See Also Send Feedback

The SellingPrice type exposes the following members.

Properties

 | Name | Description
Public property | ID | Gets the record ID.
Public property | LongID | Transitional accessor.
Public property | MarkupCostingMethod |
Public property | MarkupPercentage | Gets or sets the markup percentage to be used in calculating this selling price. One can either specify a markup percentage,or specify fixed prices, but not both.
Public property | PriceExcl | Gets or sets the vat-exclusive unit price. Setting a value will automatically calculate the inclusive price using thedefault invoicing tax code on the inveotory item, and also cancel the effect of any markup percentage set.
Public property | PriceIncl | Gets or sets the vat-inclusive unit price. Setting a value will automatically calculate the exclusive price using thedefault invoicing tax code on the inveotory item, and also cancel the effect of any markup percentage set.
Public property | PriceList | Gets the price list this selling price belongs to.
Public property | StockItem | Gets the stock item this selling price belongs to.

See Also

SellingPrice Class


SellingPrice.ID Property

[image]

Pastel Evolution SDK
SellingPrice..::..ID Property
SellingPrice Class See Also Send Feedback
Gets the record ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int ID { get; }
Visual Basic
Public ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

See Also

SellingPrice Class
SellingPrice Members


SellingPrice.LongID Property

[image]

Pastel Evolution SDK
SellingPrice..::..LongID Property
SellingPrice Class See Also Send Feedback
Transitional accessor.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public long LongID { get; }
Visual Basic
Public ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

SellingPrice Class
SellingPrice Members


SellingPrice.MarkupCostingMethod Property

[image]

Pastel Evolution SDK
SellingPrice..::..MarkupCostingMethod Property
SellingPrice Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public InventoryCostingMethod MarkupCostingMethod { get; set; }
Visual Basic
Public Property MarkupCostingMethod As InventoryCostingMethod
    Get
    Set

Property Value

Type: InventoryCostingMethod

See Also

SellingPrice Class
SellingPrice Members


SellingPrice.MarkupPercentage Property

[image]

Pastel Evolution SDK
SellingPrice..::..MarkupPercentage Property
SellingPrice Class See Also Send Feedback
Gets or sets the markup percentage to be used in calculating this selling price. One can either specify a markup percentage,or specify fixed prices, but not both.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double MarkupPercentage { get; set; }
Visual Basic
Public Property MarkupPercentage As Double
    Get
    Set

Property Value

Type: Double

See Also

SellingPrice Class
SellingPrice Members


SellingPrice.PriceExcl Property

[image]

Pastel Evolution SDK
SellingPrice..::..PriceExcl Property
SellingPrice Class See Also Send Feedback
Gets or sets the vat-exclusive unit price. Setting a value will automatically calculate the inclusive price using thedefault invoicing tax code on the inveotory item, and also cancel the effect of any markup percentage set.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double PriceExcl { get; set; }
Visual Basic
Public Property PriceExcl As Double
    Get
    Set

Property Value

Type: Double

See Also

SellingPrice Class
SellingPrice Members


SellingPrice.PriceIncl Property

[image]

Pastel Evolution SDK
SellingPrice..::..PriceIncl Property
SellingPrice Class See Also Send Feedback
Gets or sets the vat-inclusive unit price. Setting a value will automatically calculate the exclusive price using thedefault invoicing tax code on the inveotory item, and also cancel the effect of any markup percentage set.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double PriceIncl { get; set; }
Visual Basic
Public Property PriceIncl As Double
    Get
    Set

Property Value

Type: Double

See Also

SellingPrice Class
SellingPrice Members


SellingPrice.PriceList Property

[image]

Pastel Evolution SDK
SellingPrice..::..PriceList Property
SellingPrice Class See Also Send Feedback
Gets the price list this selling price belongs to.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public PriceList PriceList { get; }
Visual Basic
Public ReadOnly Property PriceList As PriceList
    Get

Property Value

Type: PriceList

See Also

SellingPrice Class
SellingPrice Members


SellingPrice.StockItem Property

[image]

Pastel Evolution SDK
SellingPrice..::..StockItem Property
SellingPrice Class See Also Send Feedback
Gets the stock item this selling price belongs to.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public InventoryItem StockItem { get; }
Visual Basic
Public ReadOnly Property StockItem As InventoryItem
    Get

Property Value

Type: InventoryItem

See Also

SellingPrice Class
SellingPrice Members


SellingPriceCollection Class

[image]

Pastel Evolution SDK
SellingPriceCollection Class
Members See Also Send Feedback
Represents an inventory selling price collection.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class SellingPriceCollection : CollectionBase
Visual Basic
Public Class SellingPriceCollection
    Inherits CollectionBase

Inheritance Hierarchy

System..::..Object
System.Collections..::..CollectionBase
Pastel.Evolution..::..SellingPriceCollection

See Also

SellingPriceCollection Members


SellingPriceCollection Members

[image] [image]

Pastel Evolution SDK
SellingPriceCollection Members
SellingPriceCollection Class Methods Properties See Also Send Feedback

The SellingPriceCollection type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | (Overrides CollectionBase..::..OnRemove(Int32, Object).)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | Save |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item[([( Int32])]) | Gets a selling price in the item's price collection.
Public property | Item[([( String])]) |
Public property | Item[([( PriceList])]) |
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

SellingPriceCollection Class


SellingPriceCollection Methods

[image] [image]

Pastel Evolution SDK
SellingPriceCollection Methods
SellingPriceCollection Class See Also Send Feedback

The SellingPriceCollection type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | (Overrides CollectionBase..::..OnRemove(Int32, Object).)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | Save |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SellingPriceCollection Class


SellingPriceCollection.OnRemove Method

[image]

Pastel Evolution SDK
SellingPriceCollection..::..OnRemove Method
SellingPriceCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected override void OnRemove(
    int index,
    Object value
)
Visual Basic
Protected Overrides Sub OnRemove (
    index As Integer,
    value As Object
)

Parameters

index
Type: System..::..Int32
value
Type: System..::..Object

See Also

SellingPriceCollection Class
SellingPriceCollection Members


SellingPriceCollection.Save Method

[image]

Pastel Evolution SDK
SellingPriceCollection..::..Save Method
SellingPriceCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void Save()
Visual Basic
Public Sub Save

See Also

SellingPriceCollection Class
SellingPriceCollection Members


SellingPriceCollection Properties

[image] [image]

Pastel Evolution SDK
SellingPriceCollection Properties
SellingPriceCollection Class See Also Send Feedback

The SellingPriceCollection type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item[([( Int32])]) | Gets a selling price in the item's price collection.
Public property | Item[([( String])]) |
Public property | Item[([( PriceList])]) |
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

SellingPriceCollection Class


SellingPriceCollection.Item Property

[image] [image]

Pastel Evolution SDK
SellingPriceCollection..::..Item Property
SellingPriceCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public property | Item[([( Int32])]) | Gets a selling price in the item's price collection.
Public property | Item[([( String])]) |
Public property | Item[([( PriceList])]) |

See Also

SellingPriceCollection Class
SellingPriceCollection Members


SellingPriceCollection.Item Property (Int32)

[image]

Pastel Evolution SDK
SellingPriceCollection..::..Item Property (Int32)
SellingPriceCollection Class See Also Send Feedback
Gets a selling price in the item's price collection.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public SellingPrice this[
    int index
] { get; }
Visual Basic
Public ReadOnly Default Property Item (
    index As Integer
) As SellingPrice
    Get

Parameters

index
Type: System..::..Int32
The 0-based item index. When loading an item, the prices will be in sequence according to the Price List IDs, but when populating prices, the sequence will be logical and not numeric.

Return Value

Type: SellingPrice

See Also

SellingPriceCollection Class
SellingPriceCollection Members
Item Overload


SellingPriceCollection.Item Property (String)

[image]

Pastel Evolution SDK
SellingPriceCollection..::..Item Property (String)
SellingPriceCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public SellingPrice this[
    string priceListName
] { get; }
Visual Basic
Public ReadOnly Default Property Item (
    priceListName As String
) As SellingPrice
    Get

Parameters

priceListName
Type: System..::..String

Property Value

Type: SellingPrice

See Also

SellingPriceCollection Class
SellingPriceCollection Members
Item Overload


SellingPriceCollection.Item Property (PriceList)

[image]

Pastel Evolution SDK
SellingPriceCollection..::..Item Property (PriceList)
SellingPriceCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public SellingPrice this[
    PriceList priceList
] { get; }
Visual Basic
Public ReadOnly Default Property Item (
    priceList As PriceList
) As SellingPrice
    Get

Parameters

priceList
Type: Pastel.Evolution..::..PriceList

Property Value

Type: SellingPrice

See Also

SellingPriceCollection Class
SellingPriceCollection Members
Item Overload


Serialiser Class

[image]

Pastel Evolution SDK
Serialiser Class
Members See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class Serialiser
Visual Basic
Public Class Serialiser

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..Serialiser

See Also

Serialiser Members


Serialiser Members

[image] [image]

Pastel Evolution SDK
Serialiser Members
Serialiser Class Constructors Methods See Also Send Feedback

The Serialiser type exposes the following members.

Constructors

 | Name | Description
Public method | Serialiser | Initializes a new instance of the Serialiser class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PersistToFile |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Serialiser Class


Serialiser Constructor

[image]

Pastel Evolution SDK
Serialiser Constructor
Serialiser Class See Also Send Feedback
Initializes a new instance of the Serialiser class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Serialiser()
Visual Basic
Public Sub New

See Also

Serialiser Class
Serialiser Members


Serialiser Methods

[image] [image]

Pastel Evolution SDK
Serialiser Methods
Serialiser Class See Also Send Feedback

The Serialiser type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PersistToFile |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Serialiser Class


Serialiser.PersistToFile Method

[image]

Pastel Evolution SDK
Serialiser..::..PersistToFile Method
Serialiser Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static void PersistToFile(
    Object rec,
    string path
)
Visual Basic
Public Shared Sub PersistToFile (
    rec As Object,
    path As String
)

Parameters

rec
Type: System..::..Object
path
Type: System..::..String

See Also

Serialiser Class
Serialiser Members


SerialNumber Class

[image]

Pastel Evolution SDK
SerialNumber Class
Members See Also Send Feedback
Represents a distinct serial number.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class SerialNumber : BranchedRecordBase
Visual Basic
Public Class SerialNumber
    Inherits BranchedRecordBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..SerialNumber

See Also

SerialNumber Members


SerialNumber Members

[image] [image]

Pastel Evolution SDK
SerialNumber Members
SerialNumber Class Constructors Methods Fields Properties See Also Send Feedback

The SerialNumber type exposes the following members.

Constructors

 | Name | Description
Public method | SerialNumber()()()() | Initializes a new instance of the SerialNumber class
Public method | SerialNumber(Int32) | Initializes a new instance of the SerialNumber class
Public method | SerialNumber(String, InventoryItem) | Initializes a new instance of the SerialNumber class
Public method | SerialNumber(String, Int32) | Initializes a new instance of the SerialNumber class
Public method | SerialNumber(String, Int32, SerialNumberLocation) | Initializes a new instance of the SerialNumber class

Methods

 | Name | Description
 | _Select(String) | Experimental Method
 | _Select(String, String) | Experimental Method
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds the first record matching the criteria supplied
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List(String) | Returns a datatable containing the matching rows.
 | List(String, String) |
 | List(InventoryItem, SerialNumberLocation) | Returns a datatable containing the matching rows.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | (Overrides Object..::..ToString()()()().)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Code |
Public property | CurrentAccount |
Public property | CurrentLocation |
Public property | ID | (Overrides RecordBase..::..ID.)
Public property | LastMovement |
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | LotID |
Public property | StockItem |
Public property | StockItemID |

See Also

SerialNumber Class


SerialNumber Constructor

[image] [image]

Pastel Evolution SDK
SerialNumber Constructor
SerialNumber Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SerialNumber()()()() | Initializes a new instance of the SerialNumber class
Public method | SerialNumber(Int32) | Initializes a new instance of the SerialNumber class
Public method | SerialNumber(String, InventoryItem) | Initializes a new instance of the SerialNumber class
Public method | SerialNumber(String, Int32) | Initializes a new instance of the SerialNumber class
Public method | SerialNumber(String, Int32, SerialNumberLocation) | Initializes a new instance of the SerialNumber class

See Also

SerialNumber Class
SerialNumber Members


SerialNumber Constructor

[image]

Pastel Evolution SDK
SerialNumber Constructor
SerialNumber Class See Also Send Feedback
Initializes a new instance of the SerialNumber class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public SerialNumber()
Visual Basic
Public Sub New

See Also

SerialNumber Class
SerialNumber Members
SerialNumber Overload


SerialNumber Constructor (Int32)

[image]

Pastel Evolution SDK
SerialNumber Constructor (Int32)
SerialNumber Class See Also Send Feedback
Initializes a new instance of the SerialNumber class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public SerialNumber(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32

See Also

SerialNumber Class
SerialNumber Members
SerialNumber Overload


SerialNumber Constructor (String, InventoryItem)

[image]

Pastel Evolution SDK
SerialNumber Constructor (String, InventoryItem)
SerialNumber Class See Also Send Feedback
Initializes a new instance of the SerialNumber class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public SerialNumber(
    string code,
    InventoryItem stockItem
)
Visual Basic
Public Sub New (
    code As String,
    stockItem As InventoryItem
)

Parameters

code
Type: System..::..String
stockItem
Type: Pastel.Evolution..::..InventoryItem

See Also

SerialNumber Class
SerialNumber Members
SerialNumber Overload


SerialNumber Constructor (String, Int32)

[image]

Pastel Evolution SDK
SerialNumber Constructor (String, Int32)
SerialNumber Class See Also Send Feedback
Initializes a new instance of the SerialNumber class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public SerialNumber(
    string code,
    int stockID
)
Visual Basic
Public Sub New (
    code As String,
    stockID As Integer
)

Parameters

code
Type: System..::..String
stockID
Type: System..::..Int32

See Also

SerialNumber Class
SerialNumber Members
SerialNumber Overload


SerialNumber Constructor (String, Int32, SerialNumberLocation)

[image]

Pastel Evolution SDK
SerialNumber Constructor (String, Int32, SerialNumberLocation)
SerialNumber Class See Also Send Feedback
Initializes a new instance of the SerialNumber class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public SerialNumber(
    string code,
    int stockID,
    SerialNumberLocation location
)
Visual Basic
Public Sub New (
    code As String,
    stockID As Integer,
    location As SerialNumberLocation
)

Parameters

code
Type: System..::..String
stockID
Type: System..::..Int32
location
Type: Pastel.Evolution..::..SerialNumberLocation

See Also

SerialNumber Class
SerialNumber Members
SerialNumber Overload


SerialNumber Fields

[image] [image]

Pastel Evolution SDK
SerialNumber Fields
SerialNumber Class See Also Send Feedback

The SerialNumber type exposes the following members.

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

SerialNumber Class


SerialNumber Methods

[image] [image]

Pastel Evolution SDK
SerialNumber Methods
SerialNumber Class See Also Send Feedback

The SerialNumber type exposes the following members.

Methods

 | Name | Description
 | _Select(String) | Experimental Method
 | _Select(String, String) | Experimental Method
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds the first record matching the criteria supplied
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List(String) | Returns a datatable containing the matching rows.
 | List(String, String) |
 | List(InventoryItem, SerialNumberLocation) | Returns a datatable containing the matching rows.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | (Overrides Object..::..ToString()()()().)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

SerialNumber Class


SerialNumber._Select Method

[image] [image]

Pastel Evolution SDK
SerialNumber..::.._Select Method
SerialNumber Class See Also Send Feedback

Overload List

Name | Description
_Select(String) | Experimental Method
_Select(String, String) | Experimental Method

See Also

SerialNumber Class
SerialNumber Members


SerialNumber._Select Method (String)

[image]

Pastel Evolution SDK
SerialNumber..::.._Select Method (String)
SerialNumber Class See Also Send Feedback
Experimental Method

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static SerialNumber[] _Select(
    string criteria
)
Visual Basic
Public Shared Function _Select (
    criteria As String
) As SerialNumber()

Parameters

criteria
Type: System..::..String

Return Value

Type: array< SerialNumber >[]()[][]

See Also

SerialNumber Class
SerialNumber Members
_Select Overload


SerialNumber._Select Method (String, String)

[image]

Pastel Evolution SDK
SerialNumber..::.._Select Method (String, String)
SerialNumber Class See Also Send Feedback
Experimental Method

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static SerialNumber[] _Select(
    string criteria,
    string sortOrder
)
Visual Basic
Public Shared Function _Select (
    criteria As String,
    sortOrder As String
) As SerialNumber()

Parameters

criteria
Type: System..::..String
sortOrder
Type: System..::..String

Return Value

Type: array< SerialNumber >[]()[][]

See Also

SerialNumber Class
SerialNumber Members
_Select Overload


SerialNumber.Find Method

[image]

Pastel Evolution SDK
SerialNumber..::..Find Method
SerialNumber Class See Also Send Feedback
Finds the first record matching the criteria supplied

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String
E.g. Code = 'abc'

Return Value

Type: Int32
The id of the record

See Also

SerialNumber Class
SerialNumber Members


SerialNumber.List Method

[image] [image]

Pastel Evolution SDK
SerialNumber..::..List Method
SerialNumber Class See Also Send Feedback

Overload List

Name | Description
List(String) | Returns a datatable containing the matching rows.
List(String, String) |
List(InventoryItem, SerialNumberLocation) | Returns a datatable containing the matching rows.

See Also

SerialNumber Class
SerialNumber Members


SerialNumber.List Method (String)

[image]

Pastel Evolution SDK
SerialNumber..::..List Method (String)
SerialNumber Class See Also Send Feedback
Returns a datatable containing the matching rows.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria
)
Visual Basic
Public Shared Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String
e.g. SNStockLink = 100 and CurrentLoc = (int)SerialNumberLocation.InStock

Return Value

Type: DataTable

See Also

SerialNumber Class
SerialNumber Members
List Overload


SerialNumber.List Method (String, String)

[image]

Pastel Evolution SDK
SerialNumber..::..List Method (String, String)
SerialNumber Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria,
    string sortOrder
)
Visual Basic
Public Shared Function List (
    criteria As String,
    sortOrder As String
) As DataTable

Parameters

criteria
Type: System..::..String
sortOrder
Type: System..::..String

Return Value

Type: DataTable

See Also

SerialNumber Class
SerialNumber Members
List Overload


SerialNumber.List Method (InventoryItem, SerialNumberLocation)

[image]

Pastel Evolution SDK
SerialNumber..::..List Method (InventoryItem, SerialNumberLocation)
SerialNumber Class See Also Send Feedback
Returns a datatable containing the matching rows.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    InventoryItem item,
    SerialNumberLocation currentLocation
)
Visual Basic
Public Shared Function List (
    item As InventoryItem,
    currentLocation As SerialNumberLocation
) As DataTable

Parameters

item
Type: Pastel.Evolution..::..InventoryItem
The inventory item to which the serial numbers belong.
currentLocation
Type: Pastel.Evolution..::..SerialNumberLocation
The current location of the serial numbers.

Return Value

Type: DataTable

See Also

SerialNumber Class
SerialNumber Members
List Overload


SerialNumber.OnDelete Method

[image]

Pastel Evolution SDK
SerialNumber..::..OnDelete Method
SerialNumber Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

See Also

SerialNumber Class
SerialNumber Members


SerialNumber.OnSave Method

[image]

Pastel Evolution SDK
SerialNumber..::..OnSave Method
SerialNumber Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

SerialNumber Class
SerialNumber Members


SerialNumber.ToString Method

[image]

Pastel Evolution SDK
SerialNumber..::..ToString Method
SerialNumber Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String

See Also

SerialNumber Class
SerialNumber Members


SerialNumber Properties

[image] [image]

Pastel Evolution SDK
SerialNumber Properties
SerialNumber Class See Also Send Feedback

The SerialNumber type exposes the following members.

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Code |
Public property | CurrentAccount |
Public property | CurrentLocation |
Public property | ID | (Overrides RecordBase..::..ID.)
Public property | LastMovement |
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | LotID |
Public property | StockItem |
Public property | StockItemID |

See Also

SerialNumber Class


SerialNumber.Code Property

[image]

Pastel Evolution SDK
SerialNumber..::..Code Property
SerialNumber Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Code { get; set; }
Visual Basic
Public Property Code As String
    Get
    Set

Property Value

Type: String

See Also

SerialNumber Class
SerialNumber Members


SerialNumber.CurrentAccount Property

[image]

Pastel Evolution SDK
SerialNumber..::..CurrentAccount Property
SerialNumber Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public AccountBase CurrentAccount { get; internal set; }
Visual Basic
Public Property CurrentAccount As AccountBase
    Get
    Friend Set

Property Value

Type: AccountBase

See Also

SerialNumber Class
SerialNumber Members


SerialNumber.CurrentLocation Property

[image]

Pastel Evolution SDK
SerialNumber..::..CurrentLocation Property
SerialNumber Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public SerialNumberLocation CurrentLocation { get; internal set; }
Visual Basic
Public Property CurrentLocation As SerialNumberLocation
    Get
    Friend Set

Property Value

Type: SerialNumberLocation

See Also

SerialNumber Class
SerialNumber Members


SerialNumber.ID Property

[image]

Pastel Evolution SDK
SerialNumber..::..ID Property
SerialNumber Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

See Also

SerialNumber Class
SerialNumber Members


SerialNumber.LastMovement Property

[image]

Pastel Evolution SDK
SerialNumber..::..LastMovement Property
SerialNumber Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DateTime LastMovement { get; }
Visual Basic
Public ReadOnly Property LastMovement As DateTime
    Get

Property Value

Type: DateTime

See Also

SerialNumber Class
SerialNumber Members


SerialNumber.LongID Property

[image]

Pastel Evolution SDK
SerialNumber..::..LongID Property
SerialNumber Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

SerialNumber Class
SerialNumber Members


SerialNumber.LotID Property

[image]

Pastel Evolution SDK
SerialNumber..::..LotID Property
SerialNumber Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int LotID { get; set; }
Visual Basic
Public Property LotID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

SerialNumber Class
SerialNumber Members


SerialNumber.StockItem Property

[image]

Pastel Evolution SDK
SerialNumber..::..StockItem Property
SerialNumber Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public InventoryItem StockItem { get; set; }
Visual Basic
Public Property StockItem As InventoryItem
    Get
    Set

Property Value

Type: InventoryItem

See Also

SerialNumber Class
SerialNumber Members


SerialNumber.StockItemID Property

[image]

Pastel Evolution SDK
SerialNumber..::..StockItemID Property
SerialNumber Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int StockItemID { get; set; }
Visual Basic
Public Property StockItemID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

SerialNumber Class
SerialNumber Members


SerialNumberCollection Class

[image]

Pastel Evolution SDK
SerialNumberCollection Class
Members See Also Send Feedback
Represents a collection of serial numbers, typically linked to a transaction or inventory document detail record.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class SerialNumberCollection : CollectionBase
Visual Basic
Public Class SerialNumberCollection
    Inherits CollectionBase

Inheritance Hierarchy

System..::..Object
System.Collections..::..CollectionBase
Pastel.Evolution..::..SerialNumberCollection

See Also

SerialNumberCollection Members


SerialNumberCollection Members

[image] [image]

Pastel Evolution SDK
SerialNumberCollection Members
SerialNumberCollection Class Constructors Methods Properties See Also Send Feedback

The SerialNumberCollection type exposes the following members.

Constructors

 | Name | Description
Public method | SerialNumberCollection()()()() | Initializes a new instance of the SerialNumberCollection class
Public method | SerialNumberCollection(OrderDetail) | Initializes a new instance of the SerialNumberCollection class

Methods

 | Name | Description
Public method | Add(String) | Adds a serial number for the code specified. If the serial number does not exist, it will be initalised as a new serial number record. The stock item needs to be assigned in this case.
Public method | Add(array<String>[]()[][]) | Adds a collection of serial numbers for the code specified. If a serial number does not exist, it will be initalised as a new serial number record. The stock item needs to be assigned to the owner of the collection in this case.
Public method | Add(SerialNumber) |
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Delete |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove |
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | Save()()()() |
Public method | Save(OrderDetail) |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | InventoryItem |
Public property | Item[([( Int32])]) |
Public property | Item[([( String])]) |
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | MovementParameters |

See Also

SerialNumberCollection Class


SerialNumberCollection Constructor

[image] [image]

Pastel Evolution SDK
SerialNumberCollection Constructor
SerialNumberCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SerialNumberCollection()()()() | Initializes a new instance of the SerialNumberCollection class
Public method | SerialNumberCollection(OrderDetail) | Initializes a new instance of the SerialNumberCollection class

See Also

SerialNumberCollection Class
SerialNumberCollection Members


SerialNumberCollection Constructor

[image]

Pastel Evolution SDK
SerialNumberCollection Constructor
SerialNumberCollection Class See Also Send Feedback
Initializes a new instance of the SerialNumberCollection class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public SerialNumberCollection()
Visual Basic
Public Sub New

See Also

SerialNumberCollection Class
SerialNumberCollection Members
SerialNumberCollection Overload


SerialNumberCollection Constructor (OrderDetail)

[image]

Pastel Evolution SDK
SerialNumberCollection Constructor (OrderDetail)
SerialNumberCollection Class See Also Send Feedback
Initializes a new instance of the SerialNumberCollection class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public SerialNumberCollection(
    OrderDetail orderDetail
)
Visual Basic
Public Sub New (
    orderDetail As OrderDetail
)

Parameters

orderDetail
Type: Pastel.Evolution..::..OrderDetail

See Also

SerialNumberCollection Class
SerialNumberCollection Members
SerialNumberCollection Overload


SerialNumberCollection Methods

[image] [image]

Pastel Evolution SDK
SerialNumberCollection Methods
SerialNumberCollection Class See Also Send Feedback

The SerialNumberCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add(String) | Adds a serial number for the code specified. If the serial number does not exist, it will be initalised as a new serial number record. The stock item needs to be assigned in this case.
Public method | Add(array<String>[]()[][]) | Adds a collection of serial numbers for the code specified. If a serial number does not exist, it will be initalised as a new serial number record. The stock item needs to be assigned to the owner of the collection in this case.
Public method | Add(SerialNumber) |
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Delete |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove |
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | Save()()()() |
Public method | Save(OrderDetail) |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SerialNumberCollection Class


SerialNumberCollection.Add Method

[image] [image]

Pastel Evolution SDK
SerialNumberCollection..::..Add Method
SerialNumberCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Add(String) | Adds a serial number for the code specified. If the serial number does not exist, it will be initalised as a new serial number record. The stock item needs to be assigned in this case.
Public method | Add(array<String>[]()[][]) | Adds a collection of serial numbers for the code specified. If a serial number does not exist, it will be initalised as a new serial number record. The stock item needs to be assigned to the owner of the collection in this case.
Public method | Add(SerialNumber) |

See Also

SerialNumberCollection Class
SerialNumberCollection Members


SerialNumberCollection.Add Method (String)

[image]

Pastel Evolution SDK
SerialNumberCollection..::..Add Method (String)
SerialNumberCollection Class See Also Send Feedback
Adds a serial number for the code specified. If the serial number does not exist, it will be initalised as a new serial number record. The stock item needs to be assigned in this case.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void Add(
    string sn
)
Visual Basic
Public Sub Add (
    sn As String
)

Parameters

sn
Type: System..::..String

See Also

SerialNumberCollection Class
SerialNumberCollection Members
Add Overload


SerialNumberCollection.Add Method (String[])

[image]

Pastel Evolution SDK
SerialNumberCollection..::..Add Method (array<String>[]()[][])
SerialNumberCollection Class See Also Send Feedback
Adds a collection of serial numbers for the code specified. If a serial number does not exist, it will be initalised as a new serial number record. The stock item needs to be assigned to the owner of the collection in this case.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void Add(
    params string[] serialNos
)
Visual Basic
Public Sub Add (
    ParamArray serialNos As String()
)

Parameters

serialNos
Type: array< System..::..String >[]()[][]
The string array of serial numbers.

See Also

SerialNumberCollection Class
SerialNumberCollection Members
Add Overload


SerialNumberCollection.Add Method (SerialNumber)

[image]

Pastel Evolution SDK
SerialNumberCollection..::..Add Method (SerialNumber)
SerialNumberCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void Add(
    SerialNumber sn
)
Visual Basic
Public Sub Add (
    sn As SerialNumber
)

Parameters

sn
Type: Pastel.Evolution..::..SerialNumber

See Also

SerialNumberCollection Class
SerialNumberCollection Members
Add Overload


SerialNumberCollection.Delete Method

[image]

Pastel Evolution SDK
SerialNumberCollection..::..Delete Method
SerialNumberCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void Delete()
Visual Basic
Public Sub Delete

See Also

SerialNumberCollection Class
SerialNumberCollection Members


SerialNumberCollection.Load Method

[image]

Pastel Evolution SDK
SerialNumberCollection..::..Load Method
SerialNumberCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void Load()
Visual Basic
Public Sub Load

See Also

SerialNumberCollection Class
SerialNumberCollection Members


SerialNumberCollection.Remove Method

[image]

Pastel Evolution SDK
SerialNumberCollection..::..Remove Method
SerialNumberCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void Remove(
    SerialNumber sn
)
Visual Basic
Public Sub Remove (
    sn As SerialNumber
)

Parameters

sn
Type: Pastel.Evolution..::..SerialNumber

See Also

SerialNumberCollection Class
SerialNumberCollection Members


SerialNumberCollection.Save Method

[image] [image]

Pastel Evolution SDK
SerialNumberCollection..::..Save Method
SerialNumberCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Save()()()() |
Public method | Save(OrderDetail) |

See Also

SerialNumberCollection Class
SerialNumberCollection Members


SerialNumberCollection.Save Method

[image]

Pastel Evolution SDK
SerialNumberCollection..::..Save Method
SerialNumberCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void Save()
Visual Basic
Public Sub Save

See Also

SerialNumberCollection Class
SerialNumberCollection Members
Save Overload


SerialNumberCollection.Save Method (OrderDetail)

[image]

Pastel Evolution SDK
SerialNumberCollection..::..Save Method (OrderDetail)
SerialNumberCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void Save(
    OrderDetail orderDetail
)
Visual Basic
Public Sub Save (
    orderDetail As OrderDetail
)

Parameters

orderDetail
Type: Pastel.Evolution..::..OrderDetail

See Also

SerialNumberCollection Class
SerialNumberCollection Members
Save Overload


SerialNumberCollection Properties

[image] [image]

Pastel Evolution SDK
SerialNumberCollection Properties
SerialNumberCollection Class See Also Send Feedback

The SerialNumberCollection type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | InventoryItem |
Public property | Item[([( Int32])]) |
Public property | Item[([( String])]) |
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | MovementParameters |

See Also

SerialNumberCollection Class


SerialNumberCollection.InventoryItem Property

[image]

Pastel Evolution SDK
SerialNumberCollection..::..InventoryItem Property
SerialNumberCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public InventoryItem InventoryItem { get; set; }
Visual Basic
Public Property InventoryItem As InventoryItem
    Get
    Set

Property Value

Type: InventoryItem

See Also

SerialNumberCollection Class
SerialNumberCollection Members


SerialNumberCollection.Item Property

[image] [image]

Pastel Evolution SDK
SerialNumberCollection..::..Item Property
SerialNumberCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public property | Item[([( Int32])]) |
Public property | Item[([( String])]) |

See Also

SerialNumberCollection Class
SerialNumberCollection Members


SerialNumberCollection.Item Property (Int32)

[image]

Pastel Evolution SDK
SerialNumberCollection..::..Item Property (Int32)
SerialNumberCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public SerialNumber this[
    int index
] { get; }
Visual Basic
Public ReadOnly Default Property Item (
    index As Integer
) As SerialNumber
    Get

Parameters

index
Type: System..::..Int32

Property Value

Type: SerialNumber

See Also

SerialNumberCollection Class
SerialNumberCollection Members
Item Overload


SerialNumberCollection.Item Property (String)

[image]

Pastel Evolution SDK
SerialNumberCollection..::..Item Property (String)
SerialNumberCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public SerialNumber this[
    string serialNumber
] { get; }
Visual Basic
Public ReadOnly Default Property Item (
    serialNumber As String
) As SerialNumber
    Get

Parameters

serialNumber
Type: System..::..String

Property Value

Type: SerialNumber

See Also

SerialNumberCollection Class
SerialNumberCollection Members
Item Overload


SerialNumberCollection.MovementParameters Property

[image]

Pastel Evolution SDK
SerialNumberCollection..::..MovementParameters Property
SerialNumberCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public SerialNumberTransaction..::..MovementParameters MovementParameters { get; set; }
Visual Basic
Public Property MovementParameters As SerialNumberTransaction..::..MovementParameters
    Get
    Set

Property Value

Type: SerialNumberTransaction..::..MovementParameters

See Also

SerialNumberCollection Class
SerialNumberCollection Members


SerialNumberLocation Enumeration

[image]

Pastel Evolution SDK
SerialNumberLocation Enumeration
See Also Send Feedback
Describes an inventory number's location.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public enum SerialNumberLocation
Visual Basic
Public Enumeration SerialNumberLocation

Members

Member name | Value | Description
Supplier | 0 |
InStock | 1 |
Customer | 2 |
OutOfStock | 3 | Lost (Adjusted out)
BoM | 4 |
JobWIP | 6 |
Unknown | 9 |

See Also

Pastel.Evolution Namespace


SerialNumberTransaction Class

[image]

Pastel Evolution SDK
SerialNumberTransaction Class
Members See Also Send Feedback
Summary description for Transaction.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class SerialNumberTransaction
Visual Basic
Public Class SerialNumberTransaction

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..SerialNumberTransaction

See Also

SerialNumberTransaction Members


SerialNumberTransaction Members

[image] [image]

Pastel Evolution SDK
SerialNumberTransaction Members
SerialNumberTransaction Class Methods Properties See Also Send Feedback

The SerialNumberTransaction type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Validate |

Properties

 | Name | Description
Public property | Account |
Public property | AccountID |
Public property | Audit |
Public property | Date |
Public property | ID |
Public property | JobCardID |
Public property | Module |
Public property | Owner |
Public property | Project |
Public property | ProjectID |
Public property | Reference |
Public property | Reference2 |
Public property | TranCode |
Public property | TranCodeID |
Public property | Type |
Public property | Warehouse |
Public property | WarehouseID |

See Also

SerialNumberTransaction Class


SerialNumberTransaction Methods

[image] [image]

Pastel Evolution SDK
SerialNumberTransaction Methods
SerialNumberTransaction Class See Also Send Feedback

The SerialNumberTransaction type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Validate |

See Also

SerialNumberTransaction Class


SerialNumberTransaction.Validate Method

[image]

Pastel Evolution SDK
SerialNumberTransaction..::..Validate Method
SerialNumberTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool Validate()
Visual Basic
Public Function Validate As Boolean

Return Value

Type: Boolean

See Also

SerialNumberTransaction Class
SerialNumberTransaction Members


SerialNumberTransaction Properties

[image] [image]

Pastel Evolution SDK
SerialNumberTransaction Properties
SerialNumberTransaction Class See Also Send Feedback

The SerialNumberTransaction type exposes the following members.

Properties

 | Name | Description
Public property | Account |
Public property | AccountID |
Public property | Audit |
Public property | Date |
Public property | ID |
Public property | JobCardID |
Public property | Module |
Public property | Owner |
Public property | Project |
Public property | ProjectID |
Public property | Reference |
Public property | Reference2 |
Public property | TranCode |
Public property | TranCodeID |
Public property | Type |
Public property | Warehouse |
Public property | WarehouseID |

See Also

SerialNumberTransaction Class


SerialNumberTransaction.Account Property

[image]

Pastel Evolution SDK
SerialNumberTransaction..::..Account Property
SerialNumberTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public SerialNumber Account { get; set; }
Visual Basic
Public Property Account As SerialNumber
    Get
    Set

Property Value

Type: SerialNumber

See Also

SerialNumberTransaction Class
SerialNumberTransaction Members


SerialNumberTransaction.AccountID Property

[image]

Pastel Evolution SDK
SerialNumberTransaction..::..AccountID Property
SerialNumberTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public long AccountID { get; set; }
Visual Basic
Public Property AccountID As Long
    Get
    Set

Property Value

Type: Int64

See Also

SerialNumberTransaction Class
SerialNumberTransaction Members


SerialNumberTransaction.Audit Property

[image]

Pastel Evolution SDK
SerialNumberTransaction..::..Audit Property
SerialNumberTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Audit { get; }
Visual Basic
Public ReadOnly Property Audit As String
    Get

Property Value

Type: String

See Also

SerialNumberTransaction Class
SerialNumberTransaction Members


SerialNumberTransaction.Date Property

[image]

Pastel Evolution SDK
SerialNumberTransaction..::..Date Property
SerialNumberTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DateTime Date { get; set; }
Visual Basic
Public Property Date As DateTime
    Get
    Set

Property Value

Type: DateTime

See Also

SerialNumberTransaction Class
SerialNumberTransaction Members


SerialNumberTransaction.ID Property

[image]

Pastel Evolution SDK
SerialNumberTransaction..::..ID Property
SerialNumberTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int ID { get; }
Visual Basic
Public ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

See Also

SerialNumberTransaction Class
SerialNumberTransaction Members


SerialNumberTransaction.JobCardID Property

[image]

Pastel Evolution SDK
SerialNumberTransaction..::..JobCardID Property
SerialNumberTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public long JobCardID { get; set; }
Visual Basic
Public Property JobCardID As Long
    Get
    Set

Property Value

Type: Int64

See Also

SerialNumberTransaction Class
SerialNumberTransaction Members


SerialNumberTransaction.Module Property

[image]

Pastel Evolution SDK
SerialNumberTransaction..::..Module Property
SerialNumberTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Module Module { get; }
Visual Basic
Public ReadOnly Property Module As Module
    Get

Property Value

Type: Module

See Also

SerialNumberTransaction Class
SerialNumberTransaction Members


SerialNumberTransaction.Owner Property

[image]

Pastel Evolution SDK
SerialNumberTransaction..::..Owner Property
SerialNumberTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public AccountBase Owner { get; set; }
Visual Basic
Public Property Owner As AccountBase
    Get
    Set

Property Value

Type: AccountBase

See Also

SerialNumberTransaction Class
SerialNumberTransaction Members


SerialNumberTransaction.Project Property

[image]

Pastel Evolution SDK
SerialNumberTransaction..::..Project Property
SerialNumberTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Project Project { set; }
Visual Basic
Public WriteOnly Property Project As Project
    Set

Property Value

Type: Project

See Also

SerialNumberTransaction Class
SerialNumberTransaction Members


SerialNumberTransaction.ProjectID Property

[image]

Pastel Evolution SDK
SerialNumberTransaction..::..ProjectID Property
SerialNumberTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int ProjectID { get; set; }
Visual Basic
Public Property ProjectID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

SerialNumberTransaction Class
SerialNumberTransaction Members


SerialNumberTransaction.Reference Property

[image]

Pastel Evolution SDK
SerialNumberTransaction..::..Reference Property
SerialNumberTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Reference { get; set; }
Visual Basic
Public Property Reference As String
    Get
    Set

Property Value

Type: String

See Also

SerialNumberTransaction Class
SerialNumberTransaction Members


SerialNumberTransaction.Reference2 Property

[image]

Pastel Evolution SDK
SerialNumberTransaction..::..Reference2 Property
SerialNumberTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Reference2 { get; set; }
Visual Basic
Public Property Reference2 As String
    Get
    Set

Property Value

Type: String

See Also

SerialNumberTransaction Class
SerialNumberTransaction Members


SerialNumberTransaction.TranCode Property

[image]

Pastel Evolution SDK
SerialNumberTransaction..::..TranCode Property
SerialNumberTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public TransactionCodeBase TranCode { get; set; }
Visual Basic
Public Property TranCode As TransactionCodeBase
    Get
    Set

Property Value

Type: TransactionCodeBase

See Also

SerialNumberTransaction Class
SerialNumberTransaction Members


SerialNumberTransaction.TranCodeID Property

[image]

Pastel Evolution SDK
SerialNumberTransaction..::..TranCodeID Property
SerialNumberTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int TranCodeID { get; set; }
Visual Basic
Public Property TranCodeID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

SerialNumberTransaction Class
SerialNumberTransaction Members


SerialNumberTransaction.Type Property

[image]

Pastel Evolution SDK
SerialNumberTransaction..::..Type Property
SerialNumberTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public SerialNumberTransaction..::..SerialNumberMovement Type { get; set; }
Visual Basic
Public Property Type As SerialNumberTransaction..::..SerialNumberMovement
    Get
    Set

Property Value

Type: SerialNumberTransaction..::..SerialNumberMovement

See Also

SerialNumberTransaction Class
SerialNumberTransaction Members


SerialNumberTransaction.Warehouse Property

[image]

Pastel Evolution SDK
SerialNumberTransaction..::..Warehouse Property
SerialNumberTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Warehouse Warehouse { get; set; }
Visual Basic
Public Property Warehouse As Warehouse
    Get
    Set

Property Value

Type: Warehouse

See Also

SerialNumberTransaction Class
SerialNumberTransaction Members


SerialNumberTransaction.WarehouseID Property

[image]

Pastel Evolution SDK
SerialNumberTransaction..::..WarehouseID Property
SerialNumberTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int WarehouseID { get; set; }
Visual Basic
Public Property WarehouseID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

SerialNumberTransaction Class
SerialNumberTransaction Members


SerialNumberTransaction.MovementParameters Class

[image]

Pastel Evolution SDK
SerialNumberTransaction..::..MovementParameters Class
SerialNumberTransaction Class Members See Also Send Feedback
Represents a set of parameters used by a serial number collection when relocating serial numbers.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class MovementParameters
Visual Basic
Public Class MovementParameters

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..SerialNumberTransaction..::..MovementParameters

See Also

SerialNumberTransaction..::..MovementParameters Members


SerialNumberTransaction.MovementParameters Members

[image] [image]

Pastel Evolution SDK
SerialNumberTransaction..::..MovementParameters Members
SerialNumberTransaction..::..MovementParameters Class Constructors Methods Properties See Also Send Feedback

The SerialNumberTransaction..::..MovementParameters type exposes the following members.

Constructors

 | Name | Description
Public method | SerialNumberTransaction..::..MovementParameters | Initializes a new instance of the SerialNumberTransaction..::..MovementParameters class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Movement |
Public property | NewAccount |
Public property | Transaction |

See Also

SerialNumberTransaction..::..MovementParameters Class


SerialNumberTransaction.MovementParameters Constructor

[image]

Pastel Evolution SDK
SerialNumberTransaction..::..MovementParameters Constructor
SerialNumberTransaction..::..MovementParameters Class See Also Send Feedback
Initializes a new instance of the SerialNumberTransaction..::..MovementParameters class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public MovementParameters()
Visual Basic
Public Sub New

See Also

SerialNumberTransaction..::..MovementParameters Class
SerialNumberTransaction..::..MovementParameters Members


SerialNumberTransaction.MovementParameters Methods

[image] [image]

Pastel Evolution SDK
SerialNumberTransaction..::..MovementParameters Methods
SerialNumberTransaction..::..MovementParameters Class See Also Send Feedback

The SerialNumberTransaction..::..MovementParameters type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SerialNumberTransaction..::..MovementParameters Class


SerialNumberTransaction.MovementParameters Properties

[image] [image]

Pastel Evolution SDK
SerialNumberTransaction..::..MovementParameters Properties
SerialNumberTransaction..::..MovementParameters Class See Also Send Feedback

The SerialNumberTransaction..::..MovementParameters type exposes the following members.

Properties

 | Name | Description
Public property | Movement |
Public property | NewAccount |
Public property | Transaction |

See Also

SerialNumberTransaction..::..MovementParameters Class


SerialNumberTransaction.MovementParameters.Movement Property

[image]

Pastel Evolution SDK
SerialNumberTransaction..::..MovementParameters..::..Movement Property
SerialNumberTransaction..::..MovementParameters Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public SerialNumberTransaction..::..SerialNumberMovement Movement { get; set; }
Visual Basic
Public Property Movement As SerialNumberTransaction..::..SerialNumberMovement
    Get
    Set

Property Value

Type: SerialNumberTransaction..::..SerialNumberMovement

See Also

SerialNumberTransaction..::..MovementParameters Class
SerialNumberTransaction..::..MovementParameters Members


SerialNumberTransaction.MovementParameters.NewAccount Property

[image]

Pastel Evolution SDK
SerialNumberTransaction..::..MovementParameters..::..NewAccount Property
SerialNumberTransaction..::..MovementParameters Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public AccountBase NewAccount { get; set; }
Visual Basic
Public Property NewAccount As AccountBase
    Get
    Set

Property Value

Type: AccountBase

See Also

SerialNumberTransaction..::..MovementParameters Class
SerialNumberTransaction..::..MovementParameters Members


SerialNumberTransaction.MovementParameters.Transaction Property

[image]

Pastel Evolution SDK
SerialNumberTransaction..::..MovementParameters..::..Transaction Property
SerialNumberTransaction..::..MovementParameters Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public InventoryTransaction Transaction { get; set; }
Visual Basic
Public Property Transaction As InventoryTransaction
    Get
    Set

Property Value

Type: InventoryTransaction

See Also

SerialNumberTransaction..::..MovementParameters Class
SerialNumberTransaction..::..MovementParameters Members


SerialNumberTransaction.SerialNumberMovement Enumeration

[image]

Pastel Evolution SDK
SerialNumberTransaction..::..SerialNumberMovement Enumeration
SerialNumberTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public enum SerialNumberMovement
Visual Basic
Public Enumeration SerialNumberMovement

Members

Member name | Value | Description
Purchased | 8 | Takes place during a supplier invoice.
Returned | 3 | Takes place during a return to supplier
Sold | 7 | Takes place during a customer invoice
Credited | 1 | Takes place during a customer credit note.
Gained | 4 |
Lost | 5 |
IssuedWarehouseTransfer | 9 |
ReceivedWarehouseTransfer | 10 |
Manufactured | 11 |
Dismantled | 12 |
Unknown | 15 |
ReturnedWIP | 16 |
IssuedWIP | 17 |

See Also

Pastel.Evolution Namespace


SettlementTerms Class

[image]

Pastel Evolution SDK
SettlementTerms Class
Members See Also Send Feedback
Represents settlement terms.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class SettlementTerms : BranchedRecordBase
Visual Basic
Public Class SettlementTerms
    Inherits BranchedRecordBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..SettlementTerms

See Also

SettlementTerms Members


SettlementTerms Members

[image] [image]

Pastel Evolution SDK
SettlementTerms Members
SettlementTerms Class Constructors Methods Fields Properties See Also Send Feedback

The SettlementTerms type exposes the following members.

Constructors

 | Name | Description
Public method | SettlementTerms()()()() | Creates a new instance of settlement terms.
Public method | SettlementTerms(Int32) | Creates a new instance of settlement terms.
Public method | SettlementTerms(String) | Creates a new instance of settlement terms.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds a settlement terms record ID.
 | FindByCode | Attempts to find settlement terms by its code and returns its ID.
 | Get | Returns an instance of the first record satisfying the criteria specified; otherwise, returns null.
 | GetByCode | Returns an instance of the first record with the code specified; otherwise, returns null.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | List | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | Base |
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Code | Gets or sets the SettlementTerms code.
Public property | Days |
Public property | Description | Gets or sets the settlement terms' description.
Public property | DiscountPercentage | Gets or sets the applicable discount as a value between 0 and 100.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)

See Also

SettlementTerms Class


SettlementTerms Constructor

[image] [image]

Pastel Evolution SDK
SettlementTerms Constructor
SettlementTerms Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SettlementTerms()()()() | Creates a new instance of settlement terms.
Public method | SettlementTerms(Int32) | Creates a new instance of settlement terms.
Public method | SettlementTerms(String) | Creates a new instance of settlement terms.

See Also

SettlementTerms Class
SettlementTerms Members


SettlementTerms Constructor

[image]

Pastel Evolution SDK
SettlementTerms Constructor
SettlementTerms Class See Also Send Feedback
Creates a new instance of settlement terms.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public SettlementTerms()
Visual Basic
Public Sub New

See Also

SettlementTerms Class
SettlementTerms Members
SettlementTerms Overload


SettlementTerms Constructor (Int32)

[image]

Pastel Evolution SDK
SettlementTerms Constructor (Int32)
SettlementTerms Class See Also Send Feedback
Creates a new instance of settlement terms.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public SettlementTerms(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32
Specifies the id of the existing record.

See Also

SettlementTerms Class
SettlementTerms Members
SettlementTerms Overload


SettlementTerms Constructor (String)

[image]

Pastel Evolution SDK
SettlementTerms Constructor (String)
SettlementTerms Class See Also Send Feedback
Creates a new instance of settlement terms.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public SettlementTerms(
    string code
)
Visual Basic
Public Sub New (
    code As String
)

Parameters

code
Type: System..::..String
Specifies the code of the existing record.

See Also

SettlementTerms Class
SettlementTerms Members
SettlementTerms Overload


SettlementTerms Fields

[image] [image]

Pastel Evolution SDK
SettlementTerms Fields
SettlementTerms Class See Also Send Feedback

The SettlementTerms type exposes the following members.

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

SettlementTerms Class


SettlementTerms Methods

[image] [image]

Pastel Evolution SDK
SettlementTerms Methods
SettlementTerms Class See Also Send Feedback

The SettlementTerms type exposes the following members.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds a settlement terms record ID.
 | FindByCode | Attempts to find settlement terms by its code and returns its ID.
 | Get | Returns an instance of the first record satisfying the criteria specified; otherwise, returns null.
 | GetByCode | Returns an instance of the first record with the code specified; otherwise, returns null.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | List | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

SettlementTerms Class


SettlementTerms.Find Method

[image]

Pastel Evolution SDK
SettlementTerms..::..Find Method
SettlementTerms Class See Also Send Feedback
Finds a settlement terms record ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String
The criteria passed to the SQL query. Eg. cSettlementCode = 'INT001' or cSettlementDescription like '%Internal%'

Return Value

Type: Int32
The ID of the first record found; -1 if not record was found.

See Also

SettlementTerms Class
SettlementTerms Members


SettlementTerms.FindByCode Method

[image]

Pastel Evolution SDK
SettlementTerms..::..FindByCode Method
SettlementTerms Class See Also Send Feedback
Attempts to find settlement terms by its code and returns its ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int FindByCode(
    string code
)
Visual Basic
Public Shared Function FindByCode (
    code As String
) As Integer

Parameters

code
Type: System..::..String
The code used to lookup the settlement terms.

Return Value

Type: Int32
-1 if no record was found, else the id of the first account matching the criteria supplied.

See Also

SettlementTerms Class
SettlementTerms Members
Pastel.Evolution Namespace
SettlementTerms..::..Find(String)


SettlementTerms.Get Method

[image]

Pastel Evolution SDK
SettlementTerms..::..Get Method
SettlementTerms Class See Also Send Feedback
Returns an instance of the first record satisfying the criteria specified; otherwise, returns null.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static SettlementTerms Get(
    string criteria
)
Visual Basic
Public Shared Function Get (
    criteria As String
) As SettlementTerms

Parameters

criteria
Type: System..::..String
The criteria passed to the SQL query. Eg. cSettlementCode = 'INT001' or cSettlementDescription like '%Internal%'

Return Value

Type: SettlementTerms
The record found; otherwise null

See Also

SettlementTerms Class
SettlementTerms Members
Pastel.Evolution Namespace
SettlementTerms..::..Find(String)
SettlementTerms..::..SettlementTerms(String)
SettlementTerms..::..GetByCode(String)


SettlementTerms.GetByCode Method

[image]

Pastel Evolution SDK
SettlementTerms..::..GetByCode Method
SettlementTerms Class See Also Send Feedback
Returns an instance of the first record with the code specified; otherwise, returns null.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static SettlementTerms GetByCode(
    string code
)
Visual Basic
Public Shared Function GetByCode (
    code As String
) As SettlementTerms

Parameters

code
Type: System..::..String
Specifies the code.

Return Value

Type: SettlementTerms
The record found; otherwise null

See Also

SettlementTerms Class
SettlementTerms Members
Pastel.Evolution Namespace
SettlementTerms..::..Get(String)
SettlementTerms..::..SettlementTerms(String)
SettlementTerms..::..Find(String)


SettlementTerms.List Method

[image]

Pastel Evolution SDK
SettlementTerms..::..List Method
SettlementTerms Class See Also Send Feedback
Gets a list of database records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DataTable List(
    string criteria
)
Visual Basic
Public Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.

Return Value

Type: DataTable
Table containing selected records.

See Also

SettlementTerms Class
SettlementTerms Members


SettlementTerms.OnDelete Method

[image]

Pastel Evolution SDK
SettlementTerms..::..OnDelete Method
SettlementTerms Class See Also Send Feedback
Removes the record from the database, provided it is not referenced by other records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

See Also

SettlementTerms Class
SettlementTerms Members


SettlementTerms.OnSave Method

[image]

Pastel Evolution SDK
SettlementTerms..::..OnSave Method
SettlementTerms Class See Also Send Feedback
Persists the record to the database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

SettlementTerms Class
SettlementTerms Members


SettlementTerms Properties

[image] [image]

Pastel Evolution SDK
SettlementTerms Properties
SettlementTerms Class See Also Send Feedback

The SettlementTerms type exposes the following members.

Properties

 | Name | Description
Public property | Base |
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Code | Gets or sets the SettlementTerms code.
Public property | Days |
Public property | Description | Gets or sets the settlement terms' description.
Public property | DiscountPercentage | Gets or sets the applicable discount as a value between 0 and 100.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)

See Also

SettlementTerms Class


SettlementTerms.Base Property

[image]

Pastel Evolution SDK
SettlementTerms..::..Base Property
SettlementTerms Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public AgeingDate Base { get; set; }
Visual Basic
Public Property Base As AgeingDate
    Get
    Set

Property Value

Type: AgeingDate

See Also

SettlementTerms Class
SettlementTerms Members


SettlementTerms.Code Property

[image]

Pastel Evolution SDK
SettlementTerms..::..Code Property
SettlementTerms Class See Also Send Feedback
Gets or sets the SettlementTerms code.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Code { get; set; }
Visual Basic
Public Property Code As String
    Get
    Set

Property Value

Type: String

See Also

SettlementTerms Class
SettlementTerms Members


SettlementTerms.Days Property

[image]

Pastel Evolution SDK
SettlementTerms..::..Days Property
SettlementTerms Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int Days { get; set; }
Visual Basic
Public Property Days As Integer
    Get
    Set

Property Value

Type: Int32

See Also

SettlementTerms Class
SettlementTerms Members


SettlementTerms.Description Property

[image]

Pastel Evolution SDK
SettlementTerms..::..Description Property
SettlementTerms Class See Also Send Feedback
Gets or sets the settlement terms' description.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set

Property Value

Type: String

See Also

SettlementTerms Class
SettlementTerms Members


SettlementTerms.DiscountPercentage Property

[image]

Pastel Evolution SDK
SettlementTerms..::..DiscountPercentage Property
SettlementTerms Class See Also Send Feedback
Gets or sets the applicable discount as a value between 0 and 100.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double DiscountPercentage { get; set; }
Visual Basic
Public Property DiscountPercentage As Double
    Get
    Set

Property Value

Type: Double

See Also

SettlementTerms Class
SettlementTerms Members


SettlementTerms.ID Property

[image]

Pastel Evolution SDK
SettlementTerms..::..ID Property
SettlementTerms Class See Also Send Feedback
Gets the internal record ID (0 for new, unsaved records).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

Remarks

Once saved, the ID will reflect the record's internal database identifier.

See Also

SettlementTerms Class
SettlementTerms Members


SettlementTerms.LongID Property

[image]

Pastel Evolution SDK
SettlementTerms..::..LongID Property
SettlementTerms Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

SettlementTerms Class
SettlementTerms Members


SplitAllocation Class

[image]

Pastel Evolution SDK
SplitAllocation Class
Members See Also Send Feedback
Describes a transaction split allocation used when splitting a transaction's contra entry.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class SplitAllocation
Visual Basic
Public Class SplitAllocation

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..SplitAllocation
Pastel.Evolution..::..TransactionBase..::..SplitAllocation

See Also

SplitAllocation Members


SplitAllocation Members

[image] [image]

Pastel Evolution SDK
SplitAllocation Members
SplitAllocation Class Constructors Methods Properties See Also Send Feedback

The SplitAllocation type exposes the following members.

Constructors

 | Name | Description
Public method | SplitAllocation()()()() | Initializes a new instance of the SplitAllocation class
Public method | SplitAllocation(GLAccount, Double) | Creates a new instance of a transaction split allocation entry.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Account | Gets or sets the GL account to post to.
Public property | Amount | Gets or sets the value of this split allocation. Note that the Amount and Foreign amount properties are mutually exclusive. Setting one value will zero the other.
Public property | Description |
Public property | ForeignAmount | Gets or sets the foreign value of this split allocation. Note that the Amount and Foreign amount properties are mutually exclusive. Setting one value will zero the other.
Public property | Project |

See Also

SplitAllocation Class


SplitAllocation Constructor

[image] [image]

Pastel Evolution SDK
SplitAllocation Constructor
SplitAllocation Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SplitAllocation()()()() | Initializes a new instance of the SplitAllocation class
Public method | SplitAllocation(GLAccount, Double) | Creates a new instance of a transaction split allocation entry.

See Also

SplitAllocation Class
SplitAllocation Members


SplitAllocation Constructor

[image]

Pastel Evolution SDK
SplitAllocation Constructor
SplitAllocation Class See Also Send Feedback
Initializes a new instance of the SplitAllocation class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public SplitAllocation()
Visual Basic
Public Sub New

See Also

SplitAllocation Class
SplitAllocation Members
SplitAllocation Overload


SplitAllocation Constructor (GLAccount, Double)

[image]

Pastel Evolution SDK
SplitAllocation Constructor (GLAccount, Double)
SplitAllocation Class See Also Send Feedback
Creates a new instance of a transaction split allocation entry.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public SplitAllocation(
    GLAccount account,
    double amount
)
Visual Basic
Public Sub New (
    account As GLAccount,
    amount As Double
)

Parameters

account
Type: Pastel.Evolution..::..GLAccount
The GL account to use.
amount
Type: System..::..Double

See Also

SplitAllocation Class
SplitAllocation Members
SplitAllocation Overload


SplitAllocation Methods

[image] [image]

Pastel Evolution SDK
SplitAllocation Methods
SplitAllocation Class See Also Send Feedback

The SplitAllocation type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SplitAllocation Class


SplitAllocation Properties

[image] [image]

Pastel Evolution SDK
SplitAllocation Properties
SplitAllocation Class See Also Send Feedback

The SplitAllocation type exposes the following members.

Properties

 | Name | Description
Public property | Account | Gets or sets the GL account to post to.
Public property | Amount | Gets or sets the value of this split allocation. Note that the Amount and Foreign amount properties are mutually exclusive. Setting one value will zero the other.
Public property | Description |
Public property | ForeignAmount | Gets or sets the foreign value of this split allocation. Note that the Amount and Foreign amount properties are mutually exclusive. Setting one value will zero the other.
Public property | Project |

See Also

SplitAllocation Class


SplitAllocation.Account Property

[image]

Pastel Evolution SDK
SplitAllocation..::..Account Property
SplitAllocation Class See Also Send Feedback
Gets or sets the GL account to post to.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLAccount Account { get; set; }
Visual Basic
Public Property Account As GLAccount
    Get
    Set

Property Value

Type: GLAccount

See Also

SplitAllocation Class
SplitAllocation Members


SplitAllocation.Amount Property

[image]

Pastel Evolution SDK
SplitAllocation..::..Amount Property
SplitAllocation Class See Also Send Feedback
Gets or sets the value of this split allocation. Note that the Amount and Foreign amount properties are mutually exclusive. Setting one value will zero the other.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double Amount { get; set; }
Visual Basic
Public Property Amount As Double
    Get
    Set

Property Value

Type: Double

See Also

SplitAllocation Class
SplitAllocation Members


SplitAllocation.Description Property

[image]

Pastel Evolution SDK
SplitAllocation..::..Description Property
SplitAllocation Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set

Property Value

Type: String

See Also

SplitAllocation Class
SplitAllocation Members


SplitAllocation.ForeignAmount Property

[image]

Pastel Evolution SDK
SplitAllocation..::..ForeignAmount Property
SplitAllocation Class See Also Send Feedback
Gets or sets the foreign value of this split allocation. Note that the Amount and Foreign amount properties are mutually exclusive. Setting one value will zero the other.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double ForeignAmount { get; set; }
Visual Basic
Public Property ForeignAmount As Double
    Get
    Set

Property Value

Type: Double

See Also

SplitAllocation Class
SplitAllocation Members


SplitAllocation.Project Property

[image]

Pastel Evolution SDK
SplitAllocation..::..Project Property
SplitAllocation Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Project Project { get; set; }
Visual Basic
Public Property Project As Project
    Get
    Set

Property Value

Type: Project

See Also

SplitAllocation Class
SplitAllocation Members


SplitAllocationCollection Class

[image]

Pastel Evolution SDK
SplitAllocationCollection Class
Members See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class SplitAllocationCollection : CollectionBase
Visual Basic
Public Class SplitAllocationCollection
    Inherits CollectionBase

Inheritance Hierarchy

System..::..Object
System.Collections..::..CollectionBase
Pastel.Evolution..::..SplitAllocationCollection

See Also

SplitAllocationCollection Members


SplitAllocationCollection Members

[image] [image]

Pastel Evolution SDK
SplitAllocationCollection Members
SplitAllocationCollection Class Constructors Methods Properties Events See Also Send Feedback

The SplitAllocationCollection type exposes the following members.

Constructors

 | Name | Description
Public method | SplitAllocationCollection | Initializes a new instance of the SplitAllocationCollection class

Methods

 | Name | Description
Public method | Add(SplitAllocation) |
Public method | Add(String, Double) |
Public method | Add(GLAccount, Double) |
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Public method | OnCollectionChanged |
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove |
Public method | RemoveAt |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item |
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

Events

 | Name | Description
Public event | CollectionChanged | Occurs when detail records are added or deleted.

See Also

SplitAllocationCollection Class


SplitAllocationCollection Constructor

[image]

Pastel Evolution SDK
SplitAllocationCollection Constructor
SplitAllocationCollection Class See Also Send Feedback
Initializes a new instance of the SplitAllocationCollection class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public SplitAllocationCollection()
Visual Basic
Public Sub New

See Also

SplitAllocationCollection Class
SplitAllocationCollection Members


SplitAllocationCollection Methods

[image] [image]

Pastel Evolution SDK
SplitAllocationCollection Methods
SplitAllocationCollection Class See Also Send Feedback

The SplitAllocationCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add(SplitAllocation) |
Public method | Add(String, Double) |
Public method | Add(GLAccount, Double) |
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Public method | OnCollectionChanged |
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove |
Public method | RemoveAt |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SplitAllocationCollection Class


SplitAllocationCollection.Add Method

[image] [image]

Pastel Evolution SDK
SplitAllocationCollection..::..Add Method
SplitAllocationCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Add(SplitAllocation) |
Public method | Add(String, Double) |
Public method | Add(GLAccount, Double) |

See Also

SplitAllocationCollection Class
SplitAllocationCollection Members


SplitAllocationCollection.Add Method (SplitAllocation)

[image]

Pastel Evolution SDK
SplitAllocationCollection..::..Add Method (SplitAllocation)
SplitAllocationCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void Add(
    SplitAllocation splitEntry
)
Visual Basic
Public Sub Add (
    splitEntry As SplitAllocation
)

Parameters

splitEntry
Type: Pastel.Evolution..::..SplitAllocation

See Also

SplitAllocationCollection Class
SplitAllocationCollection Members
Add Overload


SplitAllocationCollection.Add Method (String, Double)

[image]

Pastel Evolution SDK
SplitAllocationCollection..::..Add Method (String, Double)
SplitAllocationCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public SplitAllocation Add(
    string accountCode,
    double amount
)
Visual Basic
Public Function Add (
    accountCode As String,
    amount As Double
) As SplitAllocation

Parameters

accountCode
Type: System..::..String
amount
Type: System..::..Double

Return Value

Type: SplitAllocation

See Also

SplitAllocationCollection Class
SplitAllocationCollection Members
Add Overload


SplitAllocationCollection.Add Method (GLAccount, Double)

[image]

Pastel Evolution SDK
SplitAllocationCollection..::..Add Method (GLAccount, Double)
SplitAllocationCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public SplitAllocation Add(
    GLAccount account,
    double amount
)
Visual Basic
Public Function Add (
    account As GLAccount,
    amount As Double
) As SplitAllocation

Parameters

account
Type: Pastel.Evolution..::..GLAccount
amount
Type: System..::..Double

Return Value

Type: SplitAllocation

See Also

SplitAllocationCollection Class
SplitAllocationCollection Members
Add Overload


SplitAllocationCollection.OnCollectionChanged Method

[image]

Pastel Evolution SDK
SplitAllocationCollection..::..OnCollectionChanged Method
SplitAllocationCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void OnCollectionChanged(
    SplitAllocationCollection..::..OrderDetailCollectionChangedEventArgs e
)
Visual Basic
Public Sub OnCollectionChanged (
    e As SplitAllocationCollection..::..OrderDetailCollectionChangedEventArgs
)

Parameters

e
Type: Pastel.Evolution..::..SplitAllocationCollection..::..OrderDetailCollectionChangedEventArgs

See Also

SplitAllocationCollection Class
SplitAllocationCollection Members


SplitAllocationCollection.Remove Method

[image]

Pastel Evolution SDK
SplitAllocationCollection..::..Remove Method
SplitAllocationCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void Remove(
    SplitAllocation splitEntry
)
Visual Basic
Public Sub Remove (
    splitEntry As SplitAllocation
)

Parameters

splitEntry
Type: Pastel.Evolution..::..SplitAllocation

See Also

SplitAllocationCollection Class
SplitAllocationCollection Members


SplitAllocationCollection.RemoveAt Method

[image]

Pastel Evolution SDK
SplitAllocationCollection..::..RemoveAt Method
SplitAllocationCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void RemoveAt(
    int index
)
Visual Basic
Public Sub RemoveAt (
    index As Integer
)

Parameters

index
Type: System..::..Int32

See Also

SplitAllocationCollection Class
SplitAllocationCollection Members


SplitAllocationCollection Properties

[image] [image]

Pastel Evolution SDK
SplitAllocationCollection Properties
SplitAllocationCollection Class See Also Send Feedback

The SplitAllocationCollection type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item |
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

SplitAllocationCollection Class


SplitAllocationCollection.Item Property

[image]

Pastel Evolution SDK
SplitAllocationCollection..::..Item Property
SplitAllocationCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public SplitAllocation this[
    int index
] { get; set; }
Visual Basic
Public Default Property Item (
    index As Integer
) As SplitAllocation
    Get
    Set

Parameters

index
Type: System..::..Int32

Property Value

Type: SplitAllocation

See Also

SplitAllocationCollection Class
SplitAllocationCollection Members


SplitAllocationCollection Events

[image] [image]

Pastel Evolution SDK
SplitAllocationCollection Events
SplitAllocationCollection Class See Also Send Feedback

The SplitAllocationCollection type exposes the following members.

Events

 | Name | Description
Public event | CollectionChanged | Occurs when detail records are added or deleted.

See Also

SplitAllocationCollection Class


SplitAllocationCollection.CollectionChanged Event

[image]

Pastel Evolution SDK
SplitAllocationCollection..::..CollectionChanged Event
SplitAllocationCollection Class See Also Send Feedback
Occurs when detail records are added or deleted.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public event SplitAllocationCollection..::..OrderDetailChangedEventHandler CollectionChanged
Visual Basic
Public Event CollectionChanged As SplitAllocationCollection..::..OrderDetailChangedEventHandler

Value

Type: Pastel.Evolution..::..SplitAllocationCollection..::..OrderDetailChangedEventHandler

See Also

SplitAllocationCollection Class
SplitAllocationCollection Members


SplitAllocationCollection.OrderDetailChangeAction Enumeration

[image]

Pastel Evolution SDK
SplitAllocationCollection..::..OrderDetailChangeAction Enumeration
SplitAllocationCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public enum OrderDetailChangeAction
Visual Basic
Public Enumeration OrderDetailChangeAction

Members

Member name | Value | Description
Added | 0 |
Deleted | 1 |

See Also

Pastel.Evolution Namespace


SplitAllocationCollection.OrderDetailChangedEventHandler Delegate

[image]

Pastel Evolution SDK
SplitAllocationCollection..::..OrderDetailChangedEventHandler Delegate
SplitAllocationCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public delegate void OrderDetailChangedEventHandler(
    Object sender,
    SplitAllocationCollection..::..OrderDetailCollectionChangedEventArgs e
)
Visual Basic
Public Delegate Sub OrderDetailChangedEventHandler (
    sender As Object,
    e As SplitAllocationCollection..::..OrderDetailCollectionChangedEventArgs
)

Parameters

sender
Type: System..::..Object
e
Type: Pastel.Evolution..::..SplitAllocationCollection..::..OrderDetailCollectionChangedEventArgs

See Also

Pastel.Evolution Namespace


SplitAllocationCollection.OrderDetailCollectionChangedEventArgs Class

[image]

Pastel Evolution SDK
SplitAllocationCollection..::..OrderDetailCollectionChangedEventArgs Class
SplitAllocationCollection Class Members See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class OrderDetailCollectionChangedEventArgs : EventArgs
Visual Basic
Public Class OrderDetailCollectionChangedEventArgs
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Pastel.Evolution..::..SplitAllocationCollection..::..OrderDetailCollectionChangedEventArgs

See Also

SplitAllocationCollection..::..OrderDetailCollectionChangedEventArgs Members


SplitAllocationCollection.OrderDetailCollectionChangedEventArgs Members

[image] [image]

Pastel Evolution SDK
SplitAllocationCollection..::..OrderDetailCollectionChangedEventArgs Members
SplitAllocationCollection..::..OrderDetailCollectionChangedEventArgs Class Constructors Methods Fields See Also Send Feedback

The SplitAllocationCollection..::..OrderDetailCollectionChangedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | SplitAllocationCollection..::..OrderDetailCollectionChangedEventArgs | Initializes a new instance of the SplitAllocationCollection..::..OrderDetailCollectionChangedEventArgs class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | Action |
Public field | DetailRecord |

See Also

SplitAllocationCollection..::..OrderDetailCollectionChangedEventArgs Class


SplitAllocationCollection.OrderDetailCollectionChangedEventArgs Constructor

[image]

Pastel Evolution SDK
SplitAllocationCollection..::..OrderDetailCollectionChangedEventArgs Constructor
SplitAllocationCollection..::..OrderDetailCollectionChangedEventArgs Class See Also Send Feedback
Initializes a new instance of the SplitAllocationCollection..::..OrderDetailCollectionChangedEventArgs class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public OrderDetailCollectionChangedEventArgs(
    OrderDetail detailRecord,
    SplitAllocationCollection..::..OrderDetailChangeAction action
)
Visual Basic
Public Sub New (
    detailRecord As OrderDetail,
    action As SplitAllocationCollection..::..OrderDetailChangeAction
)

Parameters

detailRecord
Type: Pastel.Evolution..::..OrderDetail
action
Type: Pastel.Evolution..::..SplitAllocationCollection..::..OrderDetailChangeAction

See Also

SplitAllocationCollection..::..OrderDetailCollectionChangedEventArgs Class
SplitAllocationCollection..::..OrderDetailCollectionChangedEventArgs Members


SplitAllocationCollection.OrderDetailCollectionChangedEventArgs Fields

[image] [image]

Pastel Evolution SDK
SplitAllocationCollection..::..OrderDetailCollectionChangedEventArgs Fields
SplitAllocationCollection..::..OrderDetailCollectionChangedEventArgs Class See Also Send Feedback

The SplitAllocationCollection..::..OrderDetailCollectionChangedEventArgs type exposes the following members.

Fields

 | Name | Description
Public field | Action |
Public field | DetailRecord |

See Also

SplitAllocationCollection..::..OrderDetailCollectionChangedEventArgs Class


SplitAllocationCollection.OrderDetailCollectionChangedEventArgs.Action Field

[image]

Pastel Evolution SDK
SplitAllocationCollection..::..OrderDetailCollectionChangedEventArgs..::..Action Field
SplitAllocationCollection..::..OrderDetailCollectionChangedEventArgs Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public SplitAllocationCollection..::..OrderDetailChangeAction Action
Visual Basic
Public Action As SplitAllocationCollection..::..OrderDetailChangeAction

Field Value

Type: SplitAllocationCollection..::..OrderDetailChangeAction

See Also

SplitAllocationCollection..::..OrderDetailCollectionChangedEventArgs Class
SplitAllocationCollection..::..OrderDetailCollectionChangedEventArgs Members


SplitAllocationCollection.OrderDetailCollectionChangedEventArgs.DetailRecord Field

[image]

Pastel Evolution SDK
SplitAllocationCollection..::..OrderDetailCollectionChangedEventArgs..::..DetailRecord Field
SplitAllocationCollection..::..OrderDetailCollectionChangedEventArgs Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public OrderDetail DetailRecord
Visual Basic
Public DetailRecord As OrderDetail

Field Value

Type: OrderDetail

See Also

SplitAllocationCollection..::..OrderDetailCollectionChangedEventArgs Class
SplitAllocationCollection..::..OrderDetailCollectionChangedEventArgs Members


SplitAllocationCollection.OrderDetailCollectionChangedEventArgs Methods

[image] [image]

Pastel Evolution SDK
SplitAllocationCollection..::..OrderDetailCollectionChangedEventArgs Methods
SplitAllocationCollection..::..OrderDetailCollectionChangedEventArgs Class See Also Send Feedback

The SplitAllocationCollection..::..OrderDetailCollectionChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SplitAllocationCollection..::..OrderDetailCollectionChangedEventArgs Class


Supplier Class

[image]

Pastel Evolution SDK
Supplier Class
Members See Also Send Feedback
Represents a supplier account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class Supplier : DrCrAccount
Visual Basic
Public Class Supplier
    Inherits DrCrAccount

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..AccountBase
Pastel.Evolution..::..DrCrAccount
Pastel.Evolution..::..Supplier

See Also

Supplier Members


Supplier Members

[image] [image]

Pastel Evolution SDK
Supplier Members
Supplier Class Constructors Methods Fields Properties See Also Send Feedback

The Supplier type exposes the following members.

Constructors

 | Name | Description
Public method | Supplier()()()() | Creates a new instance of a supplier account.
Public method | Supplier(Int32) | Creates a new instance of a supplier account.
Public method | Supplier(String) | Creates a new instance of a supplier account.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds a record's database ID.
 | FindByCode | Finds the database ID of a record matching the specified code.
 | Get | Returns an instance of the first record satisfying the criteria specified; otherwise, returns null.
 | GetByCode | Returns an instance of the first record with the code specified; otherwise, returns null.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides AccountBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides AccountBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | (Inherited from AccountBase.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | AccountBalance | Gets the account's current balance. (Overrides DrCrAccount..::..AccountBalance.)
Public property | AccountDescription | Gets or sets the account's account description.
Public property | AccountTerms | Gets or sets the account terms.
Public property | Active | Gets or sets the record's operational state. (Overrides AccountBase..::..Active.)
Public property | Addressee | Gets or sets the account's addressee.
Public property | Areas | Gets or sets the account's area.
Public property | AreasID | Gets or sets the account's area id.
Public property | AutomaticDiscount | Gets or sets the account's automatic discount percentage.
Public property | AutoPaymentMethod | Gets or sets the account's automatic payment method.
Public property | BalanceBroughtForward |
Public property | Bank | Gets or sets the account's bank.
Public property | BankAccountNo | Gets or sets the account's bank account number.
Public property | BankAccountType | Gets or sets the account's bank account type.
Public property | BankBranchCode | Gets or sets the account's bank branch code.
Public property | BankID | Gets or sets the account's bank id.
Public property | BankReferenceNo | Gets or sets the account's bank reference number.
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | BusinessClass | Gets or sets the account's business class.
Public property | BusinessClassID | Gets or sets the account's business class id.
Public property | BusinessType | Gets or sets the account's business type.
Public property | BusinessTypeID | Gets or sets the account's business type id.
Public property | ChargeTax | Gets or sets the account's taxable status. (Overrides DrCrAccount..::..ChargeTax.)
Public property | CheckTerms | Gets or sets whether or not the account's terms will be checked before posting a transaction.
Public property | Code | Gets or sets the account's code. (Overrides AccountBase..::..Code.)
Public property | ContactPerson | Gets or sets the account's contact person.
Public property | Country | Gets or sets the account's country.
Public property | CountryID | Gets or sets the account's country id.
Public property | CreditLimit | Gets or sets the credit limit.
Public property | Currency | Gets or sets the account's currency. null indicates home currency. (Overrides DrCrAccount..::..Currency.)
Public property | CurrencyID | Gets or sets the account's currency id. 0 indicates local currency. (Overrides DrCrAccount..::..CurrencyID.)
Public property | DefaultSettlementTerms | (Overrides DrCrAccount..::..DefaultSettlementTerms.)
Public property | DefaultTaxRate | Gets or sets the account's default tax rate.
Public property | DefaultTaxRateID | Gets or sets the account's default tax rate id.
Public property | DeliverTo | Gets or sets the account's addressee.
Public property | Description | Gets or sets the account's description. (Overrides AccountBase..::..Description.)
Public property | DiscountMatrixRow | Gets or sets the account's discount matrix row.
Public property | EmailAddress | Gets or sets the account's email address.
Public property | EmailRemittance | Gets or sets the whether or not the account requires an emailed statement.
Public property | Fax1 | Gets or sets the fax number.
Public property | Fax2 | Gets or sets the 2nd fax number.
Public property | ForeignAccountBalance | Gets the account's foreign account balance. (Overrides DrCrAccount..::..ForeignAccountBalance.)
Public property | Group | Gets or sets the account's group.
Public property | GroupID | Gets or sets the account's group id.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | Initials | Gets or sets the account's initials.
Public property | InterestRate | Gets or sets the account's interest rate.
Public property | IsForeignCurrencyAccount | Whether or not the account is a foreign currency account. (Overrides DrCrAccount..::..IsForeignCurrencyAccount.)
Public property | IsOnHold | Gets or sets whether or not the account is on hold.
Public property | Item |
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | Module | Gets the account's Evolution module. (Overrides AccountBase..::..Module.)
Public property | PhysicalAddress | Gets or sets the account's physical address.
Public property | PostalAddress | Gets or sets the account's postal address.
Public property | PrintRemittance | Gets or sets the whether or not the account requires a printed statement.
Public property | RawFieldData | Obsolete.
Public property | Registration | Gets or sets the registration number.
Public property | SettlementDiscountPercent | Gets or sets the account's settlement discount percentage.
Public property | StatementZipPassword | Gets or sets the account's emailed statement's zip password.
Public property | TaxNumber | Gets or sets the tax number.
Public property | Telephone | Gets or sets the telephone number.
Public property | Telephone2 | Gets or sets the 2nd telephone number.
Public property | Timestamp | Gets the account's timestamp.
Public property | Title | Gets or sets the account's title.
Public property | UseEmail | Gets or sets the account's use email.
Public property | UserFields |
Public property | Webpage | Gets or sets the account's website address.

See Also

Supplier Class


Supplier Constructor

[image] [image]

Pastel Evolution SDK
Supplier Constructor
Supplier Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Supplier()()()() | Creates a new instance of a supplier account.
Public method | Supplier(Int32) | Creates a new instance of a supplier account.
Public method | Supplier(String) | Creates a new instance of a supplier account.

See Also

Supplier Class
Supplier Members


Supplier Constructor

[image]

Pastel Evolution SDK
Supplier Constructor
Supplier Class See Also Send Feedback
Creates a new instance of a supplier account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Supplier()
Visual Basic
Public Sub New

See Also

Supplier Class
Supplier Members
Supplier Overload


Supplier Constructor (Int32)

[image]

Pastel Evolution SDK
Supplier Constructor (Int32)
Supplier Class See Also Send Feedback
Creates a new instance of a supplier account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Supplier(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32
Specifies the id of the existing record.

See Also

Supplier Class
Supplier Members
Supplier Overload


Supplier Constructor (String)

[image]

Pastel Evolution SDK
Supplier Constructor (String)
Supplier Class See Also Send Feedback
Creates a new instance of a supplier account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Supplier(
    string code
)
Visual Basic
Public Sub New (
    code As String
)

Parameters

code
Type: System..::..String
Specifies the code of the existing record.

See Also

Supplier Class
Supplier Members
Supplier Overload


Supplier Fields

[image] [image]

Pastel Evolution SDK
Supplier Fields
Supplier Class See Also Send Feedback

The Supplier type exposes the following members.

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

Supplier Class


Supplier Methods

[image] [image]

Pastel Evolution SDK
Supplier Methods
Supplier Class See Also Send Feedback

The Supplier type exposes the following members.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds a record's database ID.
 | FindByCode | Finds the database ID of a record matching the specified code.
 | Get | Returns an instance of the first record satisfying the criteria specified; otherwise, returns null.
 | GetByCode | Returns an instance of the first record with the code specified; otherwise, returns null.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides AccountBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides AccountBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | (Inherited from AccountBase.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

Supplier Class


Supplier.Find Method

[image]

Pastel Evolution SDK
Supplier..::..Find Method
Supplier Class See Also Send Feedback
Finds a record's database ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String
Eg. Account = 'CASH001' or Name like '%CASH%'

Return Value

Type: Int32
The ID of the first record found; -1 if not record was found.

See Also

Supplier Class
Supplier Members


Supplier.FindByCode Method

[image]

Pastel Evolution SDK
Supplier..::..FindByCode Method
Supplier Class See Also Send Feedback
Finds the database ID of a record matching the specified code.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int FindByCode(
    string code
)
Visual Basic
Public Shared Function FindByCode (
    code As String
) As Integer

Parameters

code
Type: System..::..String
Specifies the code.

Return Value

Type: Int32
The ID of the first record found; -1 if not record was found.

See Also

Supplier Class
Supplier Members


Supplier.Get Method

[image]

Pastel Evolution SDK
Supplier..::..Get Method
Supplier Class See Also Send Feedback
Returns an instance of the first record satisfying the criteria specified; otherwise, returns null.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static Supplier Get(
    string criteria
)
Visual Basic
Public Shared Function Get (
    criteria As String
) As Supplier

Parameters

criteria
Type: System..::..String
Eg. Account = 'CASH001' or Name like '%CASH%'

Return Value

Type: Supplier
The record found; otherwise null

See Also

Supplier Class
Supplier Members
Pastel.Evolution Namespace
Supplier..::..Find(String)


Supplier.GetByCode Method

[image]

Pastel Evolution SDK
Supplier..::..GetByCode Method
Supplier Class See Also Send Feedback
Returns an instance of the first record with the code specified; otherwise, returns null.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static Supplier GetByCode(
    string code
)
Visual Basic
Public Shared Function GetByCode (
    code As String
) As Supplier

Parameters

code
Type: System..::..String
Specifies the code.

Return Value

Type: Supplier
The record found; otherwise null

See Also

Supplier Class
Supplier Members


Supplier.List Method

[image]

Pastel Evolution SDK
Supplier..::..List Method
Supplier Class See Also Send Feedback
Gets a list of database records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria
)
Visual Basic
Public Shared Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.

Return Value

Type: DataTable
Table containing selected records.

See Also

Supplier Class
Supplier Members


Supplier.OnDelete Method

[image]

Pastel Evolution SDK
Supplier..::..OnDelete Method
Supplier Class See Also Send Feedback
Removes the record from the database, provided it is not referenced by other records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

Exceptions

Exception | Condition
IntegrityViolationException |

See Also

Supplier Class
Supplier Members


Supplier.OnSave Method

[image]

Pastel Evolution SDK
Supplier..::..OnSave Method
Supplier Class See Also Send Feedback
Persists the record to the database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

Supplier Class
Supplier Members


Supplier Properties

[image] [image]

Pastel Evolution SDK
Supplier Properties
Supplier Class See Also Send Feedback

The Supplier type exposes the following members.

Properties

 | Name | Description
Public property | AccountBalance | Gets the account's current balance. (Overrides DrCrAccount..::..AccountBalance.)
Public property | AccountDescription | Gets or sets the account's account description.
Public property | AccountTerms | Gets or sets the account terms.
Public property | Active | Gets or sets the record's operational state. (Overrides AccountBase..::..Active.)
Public property | Addressee | Gets or sets the account's addressee.
Public property | Areas | Gets or sets the account's area.
Public property | AreasID | Gets or sets the account's area id.
Public property | AutomaticDiscount | Gets or sets the account's automatic discount percentage.
Public property | AutoPaymentMethod | Gets or sets the account's automatic payment method.
Public property | BalanceBroughtForward |
Public property | Bank | Gets or sets the account's bank.
Public property | BankAccountNo | Gets or sets the account's bank account number.
Public property | BankAccountType | Gets or sets the account's bank account type.
Public property | BankBranchCode | Gets or sets the account's bank branch code.
Public property | BankID | Gets or sets the account's bank id.
Public property | BankReferenceNo | Gets or sets the account's bank reference number.
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | BusinessClass | Gets or sets the account's business class.
Public property | BusinessClassID | Gets or sets the account's business class id.
Public property | BusinessType | Gets or sets the account's business type.
Public property | BusinessTypeID | Gets or sets the account's business type id.
Public property | ChargeTax | Gets or sets the account's taxable status. (Overrides DrCrAccount..::..ChargeTax.)
Public property | CheckTerms | Gets or sets whether or not the account's terms will be checked before posting a transaction.
Public property | Code | Gets or sets the account's code. (Overrides AccountBase..::..Code.)
Public property | ContactPerson | Gets or sets the account's contact person.
Public property | Country | Gets or sets the account's country.
Public property | CountryID | Gets or sets the account's country id.
Public property | CreditLimit | Gets or sets the credit limit.
Public property | Currency | Gets or sets the account's currency. null indicates home currency. (Overrides DrCrAccount..::..Currency.)
Public property | CurrencyID | Gets or sets the account's currency id. 0 indicates local currency. (Overrides DrCrAccount..::..CurrencyID.)
Public property | DefaultSettlementTerms | (Overrides DrCrAccount..::..DefaultSettlementTerms.)
Public property | DefaultTaxRate | Gets or sets the account's default tax rate.
Public property | DefaultTaxRateID | Gets or sets the account's default tax rate id.
Public property | DeliverTo | Gets or sets the account's addressee.
Public property | Description | Gets or sets the account's description. (Overrides AccountBase..::..Description.)
Public property | DiscountMatrixRow | Gets or sets the account's discount matrix row.
Public property | EmailAddress | Gets or sets the account's email address.
Public property | EmailRemittance | Gets or sets the whether or not the account requires an emailed statement.
Public property | Fax1 | Gets or sets the fax number.
Public property | Fax2 | Gets or sets the 2nd fax number.
Public property | ForeignAccountBalance | Gets the account's foreign account balance. (Overrides DrCrAccount..::..ForeignAccountBalance.)
Public property | Group | Gets or sets the account's group.
Public property | GroupID | Gets or sets the account's group id.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | Initials | Gets or sets the account's initials.
Public property | InterestRate | Gets or sets the account's interest rate.
Public property | IsForeignCurrencyAccount | Whether or not the account is a foreign currency account. (Overrides DrCrAccount..::..IsForeignCurrencyAccount.)
Public property | IsOnHold | Gets or sets whether or not the account is on hold.
Public property | Item |
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | Module | Gets the account's Evolution module. (Overrides AccountBase..::..Module.)
Public property | PhysicalAddress | Gets or sets the account's physical address.
Public property | PostalAddress | Gets or sets the account's postal address.
Public property | PrintRemittance | Gets or sets the whether or not the account requires a printed statement.
Public property | RawFieldData | Obsolete.
Public property | Registration | Gets or sets the registration number.
Public property | SettlementDiscountPercent | Gets or sets the account's settlement discount percentage.
Public property | StatementZipPassword | Gets or sets the account's emailed statement's zip password.
Public property | TaxNumber | Gets or sets the tax number.
Public property | Telephone | Gets or sets the telephone number.
Public property | Telephone2 | Gets or sets the 2nd telephone number.
Public property | Timestamp | Gets the account's timestamp.
Public property | Title | Gets or sets the account's title.
Public property | UseEmail | Gets or sets the account's use email.
Public property | UserFields |
Public property | Webpage | Gets or sets the account's website address.

See Also

Supplier Class


Supplier.AccountBalance Property

[image]

Pastel Evolution SDK
Supplier..::..AccountBalance Property
Supplier Class See Also Send Feedback
Gets the account's current balance.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override double AccountBalance { get; }
Visual Basic
Public Overrides ReadOnly Property AccountBalance As Double
    Get

Property Value

Type: Double

See Also

Supplier Class
Supplier Members


Supplier.AccountDescription Property

[image]

Pastel Evolution SDK
Supplier..::..AccountDescription Property
Supplier Class See Also Send Feedback
Gets or sets the account's account description.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string AccountDescription { get; set; }
Visual Basic
Public Property AccountDescription As String
    Get
    Set

Property Value

Type: String

See Also

Supplier Class
Supplier Members


Supplier.AccountTerms Property

[image]

Pastel Evolution SDK
Supplier..::..AccountTerms Property
Supplier Class See Also Send Feedback
Gets or sets the account terms.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int AccountTerms { get; set; }
Visual Basic
Public Property AccountTerms As Integer
    Get
    Set

Property Value

Type: Int32

See Also

Supplier Class
Supplier Members


Supplier.Active Property

[image]

Pastel Evolution SDK
Supplier..::..Active Property
Supplier Class See Also Send Feedback
Gets or sets the record's operational state.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override bool Active { get; set; }
Visual Basic
Public Overrides Property Active As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

Supplier Class
Supplier Members


Supplier.Addressee Property

[image]

Pastel Evolution SDK
Supplier..::..Addressee Property
Supplier Class See Also Send Feedback
Gets or sets the account's addressee.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Addressee { get; set; }
Visual Basic
Public Property Addressee As String
    Get
    Set

Property Value

Type: String

Remarks

This would generally be the same as the account description,except where the company name will not be useful in locating the recipient when shipping letters/statements.

See Also

Supplier Class
Supplier Members
Pastel.Evolution Namespace
Supplier..::..DeliverTo


Supplier.Areas Property

[image]

Pastel Evolution SDK
Supplier..::..Areas Property
Supplier Class See Also Send Feedback
Gets or sets the account's area.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Area Areas { get; set; }
Visual Basic
Public Property Areas As Area
    Get
    Set

Property Value

Type: Area

See Also

Supplier Class
Supplier Members


Supplier.AreasID Property

[image]

Pastel Evolution SDK
Supplier..::..AreasID Property
Supplier Class See Also Send Feedback
Gets or sets the account's area id.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int AreasID { get; set; }
Visual Basic
Public Property AreasID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

Supplier Class
Supplier Members


Supplier.AutomaticDiscount Property

[image]

Pastel Evolution SDK
Supplier..::..AutomaticDiscount Property
Supplier Class See Also Send Feedback
Gets or sets the account's automatic discount percentage.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double AutomaticDiscount { get; set; }
Visual Basic
Public Property AutomaticDiscount As Double
    Get
    Set

Property Value

Type: Double

Remarks

Acceptable values : 0 - 100.

See Also

Supplier Class
Supplier Members


Supplier.AutoPaymentMethod Property

[image]

Pastel Evolution SDK
Supplier..::..AutoPaymentMethod Property
Supplier Class See Also Send Feedback
Gets or sets the account's automatic payment method.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public AutoPaymentMethod AutoPaymentMethod { get; set; }
Visual Basic
Public Property AutoPaymentMethod As AutoPaymentMethod
    Get
    Set

Property Value

Type: AutoPaymentMethod

See Also

Supplier Class
Supplier Members


Supplier.BalanceBroughtForward Property

[image]

Pastel Evolution SDK
Supplier..::..BalanceBroughtForward Property
Supplier Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int BalanceBroughtForward { get; set; }
Visual Basic
Public Property BalanceBroughtForward As Integer
    Get
    Set

Property Value

Type: Int32

See Also

Supplier Class
Supplier Members


Supplier.Bank Property

[image]

Pastel Evolution SDK
Supplier..::..Bank Property
Supplier Class See Also Send Feedback
Gets or sets the account's bank.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Bank Bank { get; set; }
Visual Basic
Public Property Bank As Bank
    Get
    Set

Property Value

Type: Bank

See Also

Supplier Class
Supplier Members


Supplier.BankAccountNo Property

[image]

Pastel Evolution SDK
Supplier..::..BankAccountNo Property
Supplier Class See Also Send Feedback
Gets or sets the account's bank account number.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string BankAccountNo { get; set; }
Visual Basic
Public Property BankAccountNo As String
    Get
    Set

Property Value

Type: String

See Also

Supplier Class
Supplier Members


Supplier.BankAccountType Property

[image]

Pastel Evolution SDK
Supplier..::..BankAccountType Property
Supplier Class See Also Send Feedback
Gets or sets the account's bank account type.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Bank..::..AccountType BankAccountType { get; set; }
Visual Basic
Public Property BankAccountType As Bank..::..AccountType
    Get
    Set

Property Value

Type: Bank..::..AccountType

See Also

Supplier Class
Supplier Members


Supplier.BankBranchCode Property

[image]

Pastel Evolution SDK
Supplier..::..BankBranchCode Property
Supplier Class See Also Send Feedback
Gets or sets the account's bank branch code.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string BankBranchCode { get; set; }
Visual Basic
Public Property BankBranchCode As String
    Get
    Set

Property Value

Type: String

See Also

Supplier Class
Supplier Members


Supplier.BankID Property

[image]

Pastel Evolution SDK
Supplier..::..BankID Property
Supplier Class See Also Send Feedback
Gets or sets the account's bank id.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int BankID { get; set; }
Visual Basic
Public Property BankID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

Supplier Class
Supplier Members


Supplier.BankReferenceNo Property

[image]

Pastel Evolution SDK
Supplier..::..BankReferenceNo Property
Supplier Class See Also Send Feedback
Gets or sets the account's bank reference number.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string BankReferenceNo { get; set; }
Visual Basic
Public Property BankReferenceNo As String
    Get
    Set

Property Value

Type: String

See Also

Supplier Class
Supplier Members


Supplier.BusinessClass Property

[image]

Pastel Evolution SDK
Supplier..::..BusinessClass Property
Supplier Class See Also Send Feedback
Gets or sets the account's business class.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public BusinessClass BusinessClass { get; set; }
Visual Basic
Public Property BusinessClass As BusinessClass
    Get
    Set

Property Value

Type: BusinessClass

See Also

Supplier Class
Supplier Members


Supplier.BusinessClassID Property

[image]

Pastel Evolution SDK
Supplier..::..BusinessClassID Property
Supplier Class See Also Send Feedback
Gets or sets the account's business class id.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int BusinessClassID { get; set; }
Visual Basic
Public Property BusinessClassID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

Supplier Class
Supplier Members


Supplier.BusinessType Property

[image]

Pastel Evolution SDK
Supplier..::..BusinessType Property
Supplier Class See Also Send Feedback
Gets or sets the account's business type.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public BusinessType BusinessType { get; set; }
Visual Basic
Public Property BusinessType As BusinessType
    Get
    Set

Property Value

Type: BusinessType

See Also

Supplier Class
Supplier Members


Supplier.BusinessTypeID Property

[image]

Pastel Evolution SDK
Supplier..::..BusinessTypeID Property
Supplier Class See Also Send Feedback
Gets or sets the account's business type id.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int BusinessTypeID { get; set; }
Visual Basic
Public Property BusinessTypeID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

Supplier Class
Supplier Members


Supplier.ChargeTax Property

[image]

Pastel Evolution SDK
Supplier..::..ChargeTax Property
Supplier Class See Also Send Feedback
Gets or sets the account's taxable status.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override bool ChargeTax { get; set; }
Visual Basic
Public Overrides Property ChargeTax As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

Supplier Class
Supplier Members


Supplier.CheckTerms Property

[image]

Pastel Evolution SDK
Supplier..::..CheckTerms Property
Supplier Class See Also Send Feedback
Gets or sets whether or not the account's terms will be checked before posting a transaction.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool CheckTerms { get; set; }
Visual Basic
Public Property CheckTerms As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

Supplier Class
Supplier Members


Supplier.Code Property

[image]

Pastel Evolution SDK
Supplier..::..Code Property
Supplier Class See Also Send Feedback
Gets or sets the account's code.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override string Code { get; set; }
Visual Basic
Public Overrides Property Code As String
    Get
    Set

Property Value

Type: String

Remarks

This maps to the account field in Evolution.

See Also

Supplier Class
Supplier Members


Supplier.ContactPerson Property

[image]

Pastel Evolution SDK
Supplier..::..ContactPerson Property
Supplier Class See Also Send Feedback
Gets or sets the account's contact person.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string ContactPerson { get; set; }
Visual Basic
Public Property ContactPerson As String
    Get
    Set

Property Value

Type: String

See Also

Supplier Class
Supplier Members


Supplier.Country Property

[image]

Pastel Evolution SDK
Supplier..::..Country Property
Supplier Class See Also Send Feedback
Gets or sets the account's country.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Country Country { get; set; }
Visual Basic
Public Property Country As Country
    Get
    Set

Property Value

Type: Country

See Also

Supplier Class
Supplier Members


Supplier.CountryID Property

[image]

Pastel Evolution SDK
Supplier..::..CountryID Property
Supplier Class See Also Send Feedback
Gets or sets the account's country id.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int CountryID { get; set; }
Visual Basic
Public Property CountryID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

Supplier Class
Supplier Members


Supplier.CreditLimit Property

[image]

Pastel Evolution SDK
Supplier..::..CreditLimit Property
Supplier Class See Also Send Feedback
Gets or sets the credit limit.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double CreditLimit { get; set; }
Visual Basic
Public Property CreditLimit As Double
    Get
    Set

Property Value

Type: Double

See Also

Supplier Class
Supplier Members


Supplier.Currency Property

[image]

Pastel Evolution SDK
Supplier..::..Currency Property
Supplier Class See Also Send Feedback
Gets or sets the account's currency. null indicates home currency.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override Currency Currency { get; set; }
Visual Basic
Public Overrides Property Currency As Currency
    Get
    Set

Property Value

Type: Currency

See Also

Supplier Class
Supplier Members


Supplier.CurrencyID Property

[image]

Pastel Evolution SDK
Supplier..::..CurrencyID Property
Supplier Class See Also Send Feedback
Gets or sets the account's currency id. 0 indicates local currency.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int CurrencyID { get; set; }
Visual Basic
Public Overrides Property CurrencyID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

Supplier Class
Supplier Members


Supplier.DefaultSettlementTerms Property

[image]

Pastel Evolution SDK
Supplier..::..DefaultSettlementTerms Property
Supplier Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override SettlementTerms DefaultSettlementTerms { get; set; }
Visual Basic
Public Overrides Property DefaultSettlementTerms As SettlementTerms
    Get
    Set

Property Value

Type: SettlementTerms

See Also

Supplier Class
Supplier Members


Supplier.DefaultTaxRate Property

[image]

Pastel Evolution SDK
Supplier..::..DefaultTaxRate Property
Supplier Class See Also Send Feedback
Gets or sets the account's default tax rate.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public TaxRate DefaultTaxRate { get; set; }
Visual Basic
Public Property DefaultTaxRate As TaxRate
    Get
    Set

Property Value

Type: TaxRate

See Also

Supplier Class
Supplier Members


Supplier.DefaultTaxRateID Property

[image]

Pastel Evolution SDK
Supplier..::..DefaultTaxRateID Property
Supplier Class See Also Send Feedback
Gets or sets the account's default tax rate id.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int DefaultTaxRateID { get; set; }
Visual Basic
Public Property DefaultTaxRateID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

Supplier Class
Supplier Members


Supplier.DeliverTo Property

[image]

Pastel Evolution SDK
Supplier..::..DeliverTo Property
Supplier Class See Also Send Feedback
Gets or sets the account's addressee.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string DeliverTo { get; set; }
Visual Basic
Public Property DeliverTo As String
    Get
    Set

Property Value

Type: String

Remarks

This would generally be the same as the account description,except where the company name will not be useful in locating the recipientwhen shipping goods.

See Also

Supplier Class
Supplier Members
Pastel.Evolution Namespace
Supplier..::..Addressee


Supplier.Description Property

[image]

Pastel Evolution SDK
Supplier..::..Description Property
Supplier Class See Also Send Feedback
Gets or sets the account's description.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override string Description { get; set; }
Visual Basic
Public Overrides Property Description As String
    Get
    Set

Property Value

Type: String

Remarks

This maps to the account's name in Evolution.

See Also

Supplier Class
Supplier Members


Supplier.DiscountMatrixRow Property

[image]

Pastel Evolution SDK
Supplier..::..DiscountMatrixRow Property
Supplier Class See Also Send Feedback
Gets or sets the account's discount matrix row.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int DiscountMatrixRow { get; set; }
Visual Basic
Public Property DiscountMatrixRow As Integer
    Get
    Set

Property Value

Type: Int32

See Also

Supplier Class
Supplier Members


Supplier.EmailAddress Property

[image]

Pastel Evolution SDK
Supplier..::..EmailAddress Property
Supplier Class See Also Send Feedback
Gets or sets the account's email address.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string EmailAddress { get; set; }
Visual Basic
Public Property EmailAddress As String
    Get
    Set

Property Value

Type: String

See Also

Supplier Class
Supplier Members


Supplier.EmailRemittance Property

[image]

Pastel Evolution SDK
Supplier..::..EmailRemittance Property
Supplier Class See Also Send Feedback
Gets or sets the whether or not the account requires an emailed statement.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool EmailRemittance { get; set; }
Visual Basic
Public Property EmailRemittance As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

Supplier Class
Supplier Members


Supplier.Fax1 Property

[image]

Pastel Evolution SDK
Supplier..::..Fax1 Property
Supplier Class See Also Send Feedback
Gets or sets the fax number.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Fax1 { get; set; }
Visual Basic
Public Property Fax1 As String
    Get
    Set

Property Value

Type: String

See Also

Supplier Class
Supplier Members


Supplier.Fax2 Property

[image]

Pastel Evolution SDK
Supplier..::..Fax2 Property
Supplier Class See Also Send Feedback
Gets or sets the 2nd fax number.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Fax2 { get; set; }
Visual Basic
Public Property Fax2 As String
    Get
    Set

Property Value

Type: String

See Also

Supplier Class
Supplier Members


Supplier.ForeignAccountBalance Property

[image]

Pastel Evolution SDK
Supplier..::..ForeignAccountBalance Property
Supplier Class See Also Send Feedback
Gets the account's foreign account balance.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override double ForeignAccountBalance { get; }
Visual Basic
Public Overrides ReadOnly Property ForeignAccountBalance As Double
    Get

Property Value

Type: Double

See Also

Supplier Class
Supplier Members


Supplier.Group Property

[image]

Pastel Evolution SDK
Supplier..::..Group Property
Supplier Class See Also Send Feedback
Gets or sets the account's group.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public SupplierGroup Group { get; set; }
Visual Basic
Public Property Group As SupplierGroup
    Get
    Set

Property Value

Type: SupplierGroup

See Also

Supplier Class
Supplier Members


Supplier.GroupID Property

[image]

Pastel Evolution SDK
Supplier..::..GroupID Property
Supplier Class See Also Send Feedback
Gets or sets the account's group id.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int GroupID { get; set; }
Visual Basic
Public Property GroupID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

Supplier Class
Supplier Members


Supplier.ID Property

[image]

Pastel Evolution SDK
Supplier..::..ID Property
Supplier Class See Also Send Feedback
Gets the internal record ID (0 for new, unsaved records).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

Remarks

Once saved, the ID will reflect the record's internal database identifier.

See Also

Supplier Class
Supplier Members


Supplier.Initials Property

[image]

Pastel Evolution SDK
Supplier..::..Initials Property
Supplier Class See Also Send Feedback
Gets or sets the account's initials.
Gets or sets the initials.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Initials { get; set; }
Visual Basic
Public Property Initials As String
    Get
    Set

Property Value

Type: String

See Also

Supplier Class
Supplier Members


Supplier.InterestRate Property

[image]

Pastel Evolution SDK
Supplier..::..InterestRate Property
Supplier Class See Also Send Feedback
Gets or sets the account's interest rate.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double InterestRate { get; set; }
Visual Basic
Public Property InterestRate As Double
    Get
    Set

Property Value

Type: Double

See Also

Supplier Class
Supplier Members


Supplier.IsForeignCurrencyAccount Property

[image]

Pastel Evolution SDK
Supplier..::..IsForeignCurrencyAccount Property
Supplier Class See Also Send Feedback
Whether or not the account is a foreign currency account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override bool IsForeignCurrencyAccount { get; }
Visual Basic
Public Overrides ReadOnly Property IsForeignCurrencyAccount As Boolean
    Get

Property Value

Type: Boolean

See Also

Supplier Class
Supplier Members


Supplier.IsOnHold Property

[image]

Pastel Evolution SDK
Supplier..::..IsOnHold Property
Supplier Class See Also Send Feedback
Gets or sets whether or not the account is on hold.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool IsOnHold { get; set; }
Visual Basic
Public Property IsOnHold As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

Supplier Class
Supplier Members


Supplier.Item Property

[image]

Pastel Evolution SDK
Supplier..::..Item Property
Supplier Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Supplier this[
    string code
] { get; }
Visual Basic
Public ReadOnly Default Property Item (
    code As String
) As Supplier
    Get

Parameters

code
Type: System..::..String

Property Value

Type: Supplier

See Also

Supplier Class
Supplier Members


Supplier.LongID Property

[image]

Pastel Evolution SDK
Supplier..::..LongID Property
Supplier Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

Supplier Class
Supplier Members


Supplier.Module Property

[image]

Pastel Evolution SDK
Supplier..::..Module Property
Supplier Class See Also Send Feedback
Gets the account's Evolution module.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override Module Module { get; }
Visual Basic
Public Overrides ReadOnly Property Module As Module
    Get

Property Value

Type: Module

See Also

Supplier Class
Supplier Members


Supplier.PhysicalAddress Property

[image]

Pastel Evolution SDK
Supplier..::..PhysicalAddress Property
Supplier Class See Also Send Feedback
Gets or sets the account's physical address.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Address PhysicalAddress { get; set; }
Visual Basic
Public Property PhysicalAddress As Address
    Get
    Set

Property Value

Type: Address

See Also

Supplier Class
Supplier Members


Supplier.PostalAddress Property

[image]

Pastel Evolution SDK
Supplier..::..PostalAddress Property
Supplier Class See Also Send Feedback
Gets or sets the account's postal address.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Address PostalAddress { get; set; }
Visual Basic
Public Property PostalAddress As Address
    Get
    Set

Property Value

Type: Address

See Also

Supplier Class
Supplier Members


Supplier.PrintRemittance Property

[image]

Pastel Evolution SDK
Supplier..::..PrintRemittance Property
Supplier Class See Also Send Feedback
Gets or sets the whether or not the account requires a printed statement.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool PrintRemittance { get; set; }
Visual Basic
Public Property PrintRemittance As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

Supplier Class
Supplier Members


Supplier.RawFieldData Property

[image]

Pastel Evolution SDK
Supplier..::..RawFieldData Property
Supplier Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
[ObsoleteAttribute("Use UserFields instead.")]
public FieldCollection RawFieldData { get; }
Visual Basic
<ObsoleteAttribute("Use UserFields instead.")>
Public ReadOnly Property RawFieldData As FieldCollection
    Get

Property Value

Type: FieldCollection

See Also

Supplier Class
Supplier Members


Supplier.Registration Property

[image]

Pastel Evolution SDK
Supplier..::..Registration Property
Supplier Class See Also Send Feedback
Gets or sets the registration number.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Registration { get; set; }
Visual Basic
Public Property Registration As String
    Get
    Set

Property Value

Type: String

See Also

Supplier Class
Supplier Members


Supplier.SettlementDiscountPercent Property

[image]

Pastel Evolution SDK
Supplier..::..SettlementDiscountPercent Property
Supplier Class See Also Send Feedback
Gets or sets the account's settlement discount percentage.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double SettlementDiscountPercent { get; set; }
Visual Basic
Public Property SettlementDiscountPercent As Double
    Get
    Set

Property Value

Type: Double

See Also

Supplier Class
Supplier Members


Supplier.StatementZipPassword Property

[image]

Pastel Evolution SDK
Supplier..::..StatementZipPassword Property
Supplier Class See Also Send Feedback
Gets or sets the account's emailed statement's zip password.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string StatementZipPassword { get; set; }
Visual Basic
Public Property StatementZipPassword As String
    Get
    Set

Property Value

Type: String

See Also

Supplier Class
Supplier Members


Supplier.TaxNumber Property

[image]

Pastel Evolution SDK
Supplier..::..TaxNumber Property
Supplier Class See Also Send Feedback
Gets or sets the tax number.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string TaxNumber { get; set; }
Visual Basic
Public Property TaxNumber As String
    Get
    Set

Property Value

Type: String

See Also

Supplier Class
Supplier Members


Supplier.Telephone Property

[image]

Pastel Evolution SDK
Supplier..::..Telephone Property
Supplier Class See Also Send Feedback
Gets or sets the telephone number.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Telephone { get; set; }
Visual Basic
Public Property Telephone As String
    Get
    Set

Property Value

Type: String

See Also

Supplier Class
Supplier Members


Supplier.Telephone2 Property

[image]

Pastel Evolution SDK
Supplier..::..Telephone2 Property
Supplier Class See Also Send Feedback
Gets or sets the 2nd telephone number.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Telephone2 { get; set; }
Visual Basic
Public Property Telephone2 As String
    Get
    Set

Property Value

Type: String

See Also

Supplier Class
Supplier Members


Supplier.Timestamp Property

[image]

Pastel Evolution SDK
Supplier..::..Timestamp Property
Supplier Class See Also Send Feedback
Gets the account's timestamp.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DateTime Timestamp { get; }
Visual Basic
Public ReadOnly Property Timestamp As DateTime
    Get

Property Value

Type: DateTime

See Also

Supplier Class
Supplier Members


Supplier.Title Property

[image]

Pastel Evolution SDK
Supplier..::..Title Property
Supplier Class See Also Send Feedback
Gets or sets the account's title.
Gets or sets the account's title.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Title { get; set; }
Visual Basic
Public Property Title As String
    Get
    Set

Property Value

Type: String

See Also

Supplier Class
Supplier Members


Supplier.UseEmail Property

[image]

Pastel Evolution SDK
Supplier..::..UseEmail Property
Supplier Class See Also Send Feedback
Gets or sets the account's use email.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool UseEmail { get; set; }
Visual Basic
Public Property UseEmail As Boolean
    Get
    Set

Property Value

Type: Boolean

Remarks

This field's use is largely deprecated.

See Also

Supplier Class
Supplier Members
Pastel.Evolution Namespace
Supplier..::..EmailRemittance
Supplier..::..StatementZipPassword


Supplier.UserFields Property

[image]

Pastel Evolution SDK
Supplier..::..UserFields Property
Supplier Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public FieldCollection UserFields { get; }
Visual Basic
Public ReadOnly Property UserFields As FieldCollection
    Get

Property Value

Type: FieldCollection

See Also

Supplier Class
Supplier Members


Supplier.Webpage Property

[image]

Pastel Evolution SDK
Supplier..::..Webpage Property
Supplier Class See Also Send Feedback
Gets or sets the account's website address.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Webpage { get; set; }
Visual Basic
Public Property Webpage As String
    Get
    Set

Property Value

Type: String

See Also

Supplier Class
Supplier Members


SupplierGroup Class

[image]

Pastel Evolution SDK
SupplierGroup Class
Members See Also Send Feedback
Represents a supplier group.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class SupplierGroup : BranchedRecordBase
Visual Basic
Public Class SupplierGroup
    Inherits BranchedRecordBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..SupplierGroup

See Also

SupplierGroup Members


SupplierGroup Members

[image] [image]

Pastel Evolution SDK
SupplierGroup Members
SupplierGroup Class Constructors Methods Fields Properties See Also Send Feedback

The SupplierGroup type exposes the following members.

Constructors

 | Name | Description
Public method | SupplierGroup()()()() | Creates a new instance of a group.
Public method | SupplierGroup(Int32) | Creates a new instance of a group.
Public method | SupplierGroup(String) | Creates a new instance of a group.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds a record's database ID.
 | FindByCode | Attempts to find an AR group by its code and returns its ID.
 | Get | Returns the [first] group object with the account code specified; otherwise, returns null.
 | GetByCode | Returns a group object corresponding to the code specified; otherwise, returns null.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | List | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Code | Gets or sets the group's code.
Public property | ControlAccount | Gets or sets the group's override control account.
Public property | ControlAccountID | Gets or sets the group's override control account id.
Public property | Description | Gets or sets the group description.
Public property | DiscountMatrixRow | Gets or sets the group's discount matrix row.
Public property | ForeignLossAccountID | Gets or sets the group's foreign loss account id.
Public property | ForeignProfitAccountID | Gets or sets the group's foreign profit account id.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | TaxControlAccount | Gets or sets the group's override tax control account.
Public property | TaxControlAccountID | Gets or sets the group's override tax control account id.
Public property | TimeStamp | Gets or sets the group's modification timestamp.

See Also

SupplierGroup Class


SupplierGroup Constructor

[image] [image]

Pastel Evolution SDK
SupplierGroup Constructor
SupplierGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SupplierGroup()()()() | Creates a new instance of a group.
Public method | SupplierGroup(Int32) | Creates a new instance of a group.
Public method | SupplierGroup(String) | Creates a new instance of a group.

See Also

SupplierGroup Class
SupplierGroup Members


SupplierGroup Constructor

[image]

Pastel Evolution SDK
SupplierGroup Constructor
SupplierGroup Class See Also Send Feedback
Creates a new instance of a group.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public SupplierGroup()
Visual Basic
Public Sub New

See Also

SupplierGroup Class
SupplierGroup Members
SupplierGroup Overload


SupplierGroup Constructor (Int32)

[image]

Pastel Evolution SDK
SupplierGroup Constructor (Int32)
SupplierGroup Class See Also Send Feedback
Creates a new instance of a group.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public SupplierGroup(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32
The ID of the group in the database.

See Also

SupplierGroup Class
SupplierGroup Members
SupplierGroup Overload


SupplierGroup Constructor (String)

[image]

Pastel Evolution SDK
SupplierGroup Constructor (String)
SupplierGroup Class See Also Send Feedback
Creates a new instance of a group.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public SupplierGroup(
    string code
)
Visual Basic
Public Sub New (
    code As String
)

Parameters

code
Type: System..::..String
Specifies the code of the existing record.

See Also

SupplierGroup Class
SupplierGroup Members
SupplierGroup Overload


SupplierGroup Fields

[image] [image]

Pastel Evolution SDK
SupplierGroup Fields
SupplierGroup Class See Also Send Feedback

The SupplierGroup type exposes the following members.

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

SupplierGroup Class


SupplierGroup Methods

[image] [image]

Pastel Evolution SDK
SupplierGroup Methods
SupplierGroup Class See Also Send Feedback

The SupplierGroup type exposes the following members.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds a record's database ID.
 | FindByCode | Attempts to find an AR group by its code and returns its ID.
 | Get | Returns the [first] group object with the account code specified; otherwise, returns null.
 | GetByCode | Returns a group object corresponding to the code specified; otherwise, returns null.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | List | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

SupplierGroup Class


SupplierGroup.Find Method

[image]

Pastel Evolution SDK
SupplierGroup..::..Find Method
SupplierGroup Class See Also Send Feedback
Finds a record's database ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.

Return Value

Type: Int32
The ID of the first record found; -1 if not record was found.

See Also

SupplierGroup Class
SupplierGroup Members


SupplierGroup.FindByCode Method

[image]

Pastel Evolution SDK
SupplierGroup..::..FindByCode Method
SupplierGroup Class See Also Send Feedback
Attempts to find an AR group by its code and returns its ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int FindByCode(
    string code
)
Visual Basic
Public Shared Function FindByCode (
    code As String
) As Integer

Parameters

code
Type: System..::..String
The account code used to lookup the account.

Return Value

Type: Int32
-1 if no record was found, else the id of the first account matching the criteria supplied.

See Also

SupplierGroup Class
SupplierGroup Members
Pastel.Evolution Namespace
SupplierGroup..::..Find(String)


SupplierGroup.Get Method

[image]

Pastel Evolution SDK
SupplierGroup..::..Get Method
SupplierGroup Class See Also Send Feedback
Returns the [first] group object with the account code specified; otherwise, returns null.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static SupplierGroup Get(
    string criteria
)
Visual Basic
Public Shared Function Get (
    criteria As String
) As SupplierGroup

Parameters

criteria
Type: System..::..String
Eg. Code like '1_B%'

Return Value

Type: SupplierGroup
The record found; otherwise null

See Also

SupplierGroup Class
SupplierGroup Members
Pastel.Evolution Namespace
SupplierGroup..::..Find(String)


SupplierGroup.GetByCode Method

[image]

Pastel Evolution SDK
SupplierGroup..::..GetByCode Method
SupplierGroup Class See Also Send Feedback
Returns a group object corresponding to the code specified; otherwise, returns null.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static SupplierGroup GetByCode(
    string code
)
Visual Basic
Public Shared Function GetByCode (
    code As String
) As SupplierGroup

Parameters

code
Type: System..::..String
Specifies the code.

Return Value

Type: SupplierGroup
The record found; otherwise null

See Also

SupplierGroup Class
SupplierGroup Members


SupplierGroup.List Method

[image]

Pastel Evolution SDK
SupplierGroup..::..List Method
SupplierGroup Class See Also Send Feedback
Gets a list of database records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DataTable List(
    string criteria
)
Visual Basic
Public Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.

Return Value

Type: DataTable
Table containing selected records.

See Also

SupplierGroup Class
SupplierGroup Members


SupplierGroup.OnDelete Method

[image]

Pastel Evolution SDK
SupplierGroup..::..OnDelete Method
SupplierGroup Class See Also Send Feedback
Removes the record from the database, provided it is not referenced by other records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

Exceptions

Exception | Condition
IntegrityViolationException |

See Also

SupplierGroup Class
SupplierGroup Members


SupplierGroup.OnSave Method

[image]

Pastel Evolution SDK
SupplierGroup..::..OnSave Method
SupplierGroup Class See Also Send Feedback
Persists the record to the database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

SupplierGroup Class
SupplierGroup Members


SupplierGroup Properties

[image] [image]

Pastel Evolution SDK
SupplierGroup Properties
SupplierGroup Class See Also Send Feedback

The SupplierGroup type exposes the following members.

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Code | Gets or sets the group's code.
Public property | ControlAccount | Gets or sets the group's override control account.
Public property | ControlAccountID | Gets or sets the group's override control account id.
Public property | Description | Gets or sets the group description.
Public property | DiscountMatrixRow | Gets or sets the group's discount matrix row.
Public property | ForeignLossAccountID | Gets or sets the group's foreign loss account id.
Public property | ForeignProfitAccountID | Gets or sets the group's foreign profit account id.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | TaxControlAccount | Gets or sets the group's override tax control account.
Public property | TaxControlAccountID | Gets or sets the group's override tax control account id.
Public property | TimeStamp | Gets or sets the group's modification timestamp.

See Also

SupplierGroup Class


SupplierGroup.Code Property

[image]

Pastel Evolution SDK
SupplierGroup..::..Code Property
SupplierGroup Class See Also Send Feedback
Gets or sets the group's code.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Code { get; set; }
Visual Basic
Public Property Code As String
    Get
    Set

Property Value

Type: String

See Also

SupplierGroup Class
SupplierGroup Members


SupplierGroup.ControlAccount Property

[image]

Pastel Evolution SDK
SupplierGroup..::..ControlAccount Property
SupplierGroup Class See Also Send Feedback
Gets or sets the group's override control account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLAccount ControlAccount { get; set; }
Visual Basic
Public Property ControlAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

See Also

SupplierGroup Class
SupplierGroup Members


SupplierGroup.ControlAccountID Property

[image]

Pastel Evolution SDK
SupplierGroup..::..ControlAccountID Property
SupplierGroup Class See Also Send Feedback
Gets or sets the group's override control account id.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int ControlAccountID { get; set; }
Visual Basic
Public Property ControlAccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

SupplierGroup Class
SupplierGroup Members


SupplierGroup.Description Property

[image]

Pastel Evolution SDK
SupplierGroup..::..Description Property
SupplierGroup Class See Also Send Feedback
Gets or sets the group description.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set

Property Value

Type: String

See Also

SupplierGroup Class
SupplierGroup Members


SupplierGroup.DiscountMatrixRow Property

[image]

Pastel Evolution SDK
SupplierGroup..::..DiscountMatrixRow Property
SupplierGroup Class See Also Send Feedback
Gets or sets the group's discount matrix row.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int DiscountMatrixRow { get; set; }
Visual Basic
Public Property DiscountMatrixRow As Integer
    Get
    Set

Property Value

Type: Int32

See Also

SupplierGroup Class
SupplierGroup Members


SupplierGroup.ForeignLossAccountID Property

[image]

Pastel Evolution SDK
SupplierGroup..::..ForeignLossAccountID Property
SupplierGroup Class See Also Send Feedback
Gets or sets the group's foreign loss account id.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int ForeignLossAccountID { get; set; }
Visual Basic
Public Property ForeignLossAccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

SupplierGroup Class
SupplierGroup Members


SupplierGroup.ForeignProfitAccountID Property

[image]

Pastel Evolution SDK
SupplierGroup..::..ForeignProfitAccountID Property
SupplierGroup Class See Also Send Feedback
Gets or sets the group's foreign profit account id.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int ForeignProfitAccountID { get; set; }
Visual Basic
Public Property ForeignProfitAccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

SupplierGroup Class
SupplierGroup Members


SupplierGroup.ID Property

[image]

Pastel Evolution SDK
SupplierGroup..::..ID Property
SupplierGroup Class See Also Send Feedback
Gets the internal record ID (0 for new, unsaved records).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

See Also

SupplierGroup Class
SupplierGroup Members


SupplierGroup.LongID Property

[image]

Pastel Evolution SDK
SupplierGroup..::..LongID Property
SupplierGroup Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

SupplierGroup Class
SupplierGroup Members


SupplierGroup.TaxControlAccount Property

[image]

Pastel Evolution SDK
SupplierGroup..::..TaxControlAccount Property
SupplierGroup Class See Also Send Feedback
Gets or sets the group's override tax control account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLAccount TaxControlAccount { get; set; }
Visual Basic
Public Property TaxControlAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

See Also

SupplierGroup Class
SupplierGroup Members


SupplierGroup.TaxControlAccountID Property

[image]

Pastel Evolution SDK
SupplierGroup..::..TaxControlAccountID Property
SupplierGroup Class See Also Send Feedback
Gets or sets the group's override tax control account id.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int TaxControlAccountID { get; set; }
Visual Basic
Public Property TaxControlAccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

SupplierGroup Class
SupplierGroup Members


SupplierGroup.TimeStamp Property

[image]

Pastel Evolution SDK
SupplierGroup..::..TimeStamp Property
SupplierGroup Class See Also Send Feedback
Gets or sets the group's modification timestamp.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DateTime TimeStamp { get; set; }
Visual Basic
Public Property TimeStamp As DateTime
    Get
    Set

Property Value

Type: DateTime

See Also

SupplierGroup Class
SupplierGroup Members


SupplierTransaction Class

[image]

Pastel Evolution SDK
SupplierTransaction Class
Members See Also Send Feedback
Represents a supplier transaction.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class SupplierTransaction : DrCrTransaction,
    ICloneable
Visual Basic
Public Class SupplierTransaction
    Inherits DrCrTransaction
    Implements ICloneable

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..TransactionBase
Pastel.Evolution..::..DrCrTransaction
Pastel.Evolution..::..SupplierTransaction

See Also

SupplierTransaction Members


SupplierTransaction Members

[image] [image]

Pastel Evolution SDK
SupplierTransaction Members
SupplierTransaction Class Constructors Methods Fields Properties Events See Also Send Feedback

The SupplierTransaction type exposes the following members.

Constructors

 | Name | Description
Public method | SupplierTransaction()()()() | Creates a new instance of a supplier transaction.
Public method | SupplierTransaction(Int64) | Creates a new instance of a supplier transaction.

Methods

 | Name | Description
Protected method | calcAmounts | (Inherited from DrCrTransaction.)
Protected method | calcTaxValues |
Public method | CalculateTax | Calculates the tax amount on the transaction.
Public method | Clone | (Overrides DrCrTransaction..::..Clone()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find(String) | Finds a transaction ID.
 | Find(AccountBase, String) | Finds a transaction ID.
Protected method | getExchangeRate | (Overrides DrCrTransaction..::..getExchangeRate()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List(String) | Returns a System.Data.DataTable object containing the database records from the PostAR table matching the supplied criteria.
 | List(AccountBase, String) | Returns a System.Data.DataTable object containing the database records from the PostAR/PostAP table matching the supplied criteria and limited to the specified account.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAllowBlockedPosting | (Overrides TransactionBase..::..OnAllowBlockedPosting()()()().)
Protected method | OnOverrideControlAccount | (Overrides DrCrTransaction..::..OnOverrideControlAccount(GLTransaction).)
Protected method | OnOverrideTaxControlAccount | (Overrides DrCrTransaction..::..OnOverrideTaxControlAccount(TransactionCode, GLTransaction).)
Protected method | OnPost | (Overrides TransactionBase..::..OnPost()()()().)
Protected method | onPostingGLCredit | (Inherited from TransactionBase.)
Protected method | onPostingGLDebit | (Inherited from TransactionBase.)
Protected method | onPostingGLVat | (Inherited from TransactionBase.)
Public method | Post | Posts the transaction to appropriate ledgers. (Inherited from TransactionBase.)
Protected method | RejectTransactionBranchAssignment | (Inherited from TransactionBase.)
Protected method | setExchangeRate | (Overrides DrCrTransaction..::..setExchangeRate(Double).)
Public method | ToString | (Inherited from DrCrTransaction.)
Public method | Validate | (Overrides DrCrTransaction..::..Validate()()()().)

Fields

 | Name | Description
Protected field | allocations | (Inherited from DrCrTransaction.)
Protected field | amount | (Inherited from DrCrTransaction.)
Protected field | branch | (Inherited from DrCrTransaction.)
Protected field | currency | (Inherited from DrCrTransaction.)
Protected field | fcQueue | (Inherited from DrCrTransaction.)
Protected field | foreignAmount | (Inherited from DrCrTransaction.)
Protected field | foreignOriginalTax | (Inherited from TransactionBase.)
Protected field | foreignTax | (Inherited from DrCrTransaction.)
Protected field | glCredit | (Inherited from DrCrTransaction.)
Protected field | glDebit | (Inherited from DrCrTransaction.)
Protected field | glForeignCredit | (Inherited from DrCrTransaction.)
Protected field | glForeignDebit | (Inherited from DrCrTransaction.)
Protected field | isDebitTrans | (Inherited from TransactionBase.)
Protected field | originalTax | (Inherited from TransactionBase.)
Protected field | project | (Inherited from DrCrTransaction.)
Protected field | readOnly | (Inherited from TransactionBase.)
Protected field | settlementTerms | (Inherited from DrCrTransaction.)
Protected field | splitAllocations | (Inherited from DrCrTransaction.)
Protected field | tax | (Inherited from DrCrTransaction.)
Protected field | taxType | (Inherited from DrCrTransaction.)
Protected field | tranCode | (Inherited from DrCrTransaction.)

Properties

 | Name | Description
Public property | Account | Gets or sets the Account to which the transaction gets posted. This is a mandatory field. (Overrides TransactionBase..::..Account.)
Public property | AccountID | Gets or sets the ID of the Account to which the transaction gets posted. (Overrides TransactionBase..::..AccountID.)
Public property | Allocations | Gets the transaction's allocation collection. (Overrides DrCrTransaction..::..Allocations.)
Public property | Amount | Gets or sets the (gross) transaction value. Negative values are allowed and will result in inverted debits and credits. (Overrides DrCrTransaction..::..Amount.)
Public property | Audit | Gets the transaction's audit number. (Overrides TransactionBase..::..Audit.)
Public property | Branch | (Overrides DrCrTransaction..::..Branch.)
Public property | BranchID | (Overrides DrCrTransaction..::..BranchID.)
Public property | Credit | Gets the transaction's credit value, the value of which is determined by the Amount and TransactionCode properties. (Overrides TransactionBase..::..Credit.)
Public property | Currency | Gets the foreign currency in use on this transaction, determined by the specified account. A null value indicates local currency. (Overrides DrCrTransaction..::..Currency.)
Public property | CurrencyID | (Overrides DrCrTransaction..::..CurrencyID.)
Public property | Date | Gets or sets the date on which the transaction takes place. This often differs from the actual posting date but defaults to the current date. (Overrides TransactionBase..::..Date.)
Public property | Debit | Gets the transaction's debit value, the value of which is determined by the Amount and TransactionCode properties. (Overrides TransactionBase..::..Debit.)
Public property | Description | Gets or sets the transaction description that - togeter with the Reference - appears on the account's statement by default. This is a mandatory field. (Overrides TransactionBase..::..Description.)
Public property | ExchangeRate | Gets or sets the applicable exchange rate, expressed as [home currency]/[foreign currency]. Defaults to applicable exchange rate for the transaction date. (Inherited from DrCrTransaction.)
Public property | ExtOrderNo | Gets or sets the transaction's external order number. (Overrides TransactionBase..::..ExtOrderNo.)
Public property | ForeignAmount | Gets or sets the foreign transaction value. (Overrides DrCrTransaction..::..ForeignAmount.)
Public property | ForeignCredit | Gets the transaction's foreign credit value, which is determined by the ForeignAmount and TransactionCode properties. (Overrides DrCrTransaction..::..ForeignCredit.)
Public property | ForeignDebit | Gets the transaction's foreign debit value, which is determined by the ForeignAmount and TransactionCode properties. (Overrides DrCrTransaction..::..ForeignDebit.)
Public property | ForeignOutstanding | Gets the transaction's foreign outstanding amount. (Overrides DrCrTransaction..::..ForeignOutstanding.)
Public property | ForeignTax | Gets or sets the transaction foreign tax amount (automatically rounded to 2 decimals). Note that setting this will switch the entry mode to foreign and recalculate the Amount property. (Overrides DrCrTransaction..::..ForeignTax.)
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides TransactionBase..::..ID.)
Public property | IsDebit | Indicates whether the transaction is a debit (true) or credit(false) (Inherited from DrCrTransaction.)
Public property | IsDebitPositive | (Overrides DrCrTransaction..::..IsDebitPositive.)
Public property | MaxForeignOutstanding | Gets the maximum possible foreign outstanding value for the given transaction, based on the ForeignDebit or ForeignCredit value. (Inherited from DrCrTransaction.)
Public property | MaxOutstanding | Gets the maximum possible outstanding value for the given transaction, based on the Debit or Credit value. (Inherited from DrCrTransaction.)
Public property | ModID | Gets or sets the transaction's evolution module id. (Overrides TransactionBase..::..ModID.)
Public property | Module | Gets the Evolution module this record belongs to, used in internal validation. (Overrides TransactionBase..::..Module.)
Public property | OrderNo | Gets or sets the transaction order number. (Overrides TransactionBase..::..OrderNo.)
Public property | Outstanding | Gets the transaction's outstanding amount. (Overrides DrCrTransaction..::..Outstanding.)
Public property | Project | Gets or sets the Project record associated with this transaction. When using Project Tracking, this field must be specified whereverapplicable. (Overrides TransactionBase..::..Project.)
Public property | ProjectID | Gets or sets the ID of the Project record associated with this transaction. When using Project Tracking, this field must be specified wherever applicable. (Overrides TransactionBase..::..ProjectID.)
Public property | Reference | Gets or sets the transaction reference that - together with the Description - appears on the customer statement by default. This is a mandatory field. (Overrides TransactionBase..::..Reference.)
Public property | Reference2 | Gets or sets an additional transaction reference. (Overrides TransactionBase..::..Reference2.)
Public property | SettlementTerms | (Overrides DrCrTransaction..::..SettlementTerms.)
Public property | SettlementTermsID | (Overrides DrCrTransaction..::..SettlementTermsID.)
Public property | SplitAllocations | Gets the transaction's split allocation collection, used to split the contra account posting to various GL accounts. (Overrides DrCrTransaction..::..SplitAllocations.)
Public property | Supplier | Gets or sets the transaction's supplier account (maps directly to Account).
Public property | Tax | Gets or sets the transaction tax amount (automatically rounded to 2 decimals). (Overrides TransactionBase..::..Tax.)
Public property | TaxRate | Gets or sets the TaxRate record associated with this transaction. If a tax type is specified, a tax amount is automatically calculated, but can be overridden. (Overrides TransactionBase..::..TaxRate.)
Public property | TaxRateID | (Overrides TransactionBase..::..TaxRateID.)
Public property | TransactionCode | Gets or sets the TransactionCode record associated with this transaction, as maintained in Accounts Payable > Maintenance > Transaction Types. Transaction codes/types govern General Ledger integration. This is a mandatory field. (Overrides TransactionBase..::..TransactionCode.)
Public property | TransactionCodeID | Gets or sets the ID of the TransactionCode record associated with this transaction, which governs General Ledger integration. (Overrides TransactionBase..::..TransactionCodeID.)

Events

 | Name | Description
Public event | GLCreditPosting | (Inherited from TransactionBase.)
Public event | GLDebitPosting | (Inherited from TransactionBase.)
Public event | GLVatPosting | (Inherited from TransactionBase.)

See Also

SupplierTransaction Class


SupplierTransaction Constructor

[image] [image]

Pastel Evolution SDK
SupplierTransaction Constructor
SupplierTransaction Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SupplierTransaction()()()() | Creates a new instance of a supplier transaction.
Public method | SupplierTransaction(Int64) | Creates a new instance of a supplier transaction.

See Also

SupplierTransaction Class
SupplierTransaction Members


SupplierTransaction Constructor

[image]

Pastel Evolution SDK
SupplierTransaction Constructor
SupplierTransaction Class See Also Send Feedback
Creates a new instance of a supplier transaction.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public SupplierTransaction()
Visual Basic
Public Sub New

See Also

SupplierTransaction Class
SupplierTransaction Members
SupplierTransaction Overload


SupplierTransaction Constructor (Int64)

[image]

Pastel Evolution SDK
SupplierTransaction Constructor (Int64)
SupplierTransaction Class See Also Send Feedback
Creates a new instance of a supplier transaction.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public SupplierTransaction(
    long id
)
Visual Basic
Public Sub New (
    id As Long
)

Parameters

id
Type: System..::..Int64
Specifies the id of the existing record.

See Also

SupplierTransaction Class
SupplierTransaction Members
SupplierTransaction Overload


SupplierTransaction Fields

[image] [image]

Pastel Evolution SDK
SupplierTransaction Fields
SupplierTransaction Class See Also Send Feedback

The SupplierTransaction type exposes the following members.

Fields

 | Name | Description
Protected field | allocations | (Inherited from DrCrTransaction.)
Protected field | amount | (Inherited from DrCrTransaction.)
Protected field | branch | (Inherited from DrCrTransaction.)
Protected field | currency | (Inherited from DrCrTransaction.)
Protected field | fcQueue | (Inherited from DrCrTransaction.)
Protected field | foreignAmount | (Inherited from DrCrTransaction.)
Protected field | foreignOriginalTax | (Inherited from TransactionBase.)
Protected field | foreignTax | (Inherited from DrCrTransaction.)
Protected field | glCredit | (Inherited from DrCrTransaction.)
Protected field | glDebit | (Inherited from DrCrTransaction.)
Protected field | glForeignCredit | (Inherited from DrCrTransaction.)
Protected field | glForeignDebit | (Inherited from DrCrTransaction.)
Protected field | isDebitTrans | (Inherited from TransactionBase.)
Protected field | originalTax | (Inherited from TransactionBase.)
Protected field | project | (Inherited from DrCrTransaction.)
Protected field | readOnly | (Inherited from TransactionBase.)
Protected field | settlementTerms | (Inherited from DrCrTransaction.)
Protected field | splitAllocations | (Inherited from DrCrTransaction.)
Protected field | tax | (Inherited from DrCrTransaction.)
Protected field | taxType | (Inherited from DrCrTransaction.)
Protected field | tranCode | (Inherited from DrCrTransaction.)

See Also

SupplierTransaction Class


SupplierTransaction Methods

[image] [image]

Pastel Evolution SDK
SupplierTransaction Methods
SupplierTransaction Class See Also Send Feedback

The SupplierTransaction type exposes the following members.

Methods

 | Name | Description
Protected method | calcAmounts | (Inherited from DrCrTransaction.)
Protected method | calcTaxValues |
Public method | CalculateTax | Calculates the tax amount on the transaction.
Public method | Clone | (Overrides DrCrTransaction..::..Clone()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find(String) | Finds a transaction ID.
 | Find(AccountBase, String) | Finds a transaction ID.
Protected method | getExchangeRate | (Overrides DrCrTransaction..::..getExchangeRate()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List(String) | Returns a System.Data.DataTable object containing the database records from the PostAR table matching the supplied criteria.
 | List(AccountBase, String) | Returns a System.Data.DataTable object containing the database records from the PostAR/PostAP table matching the supplied criteria and limited to the specified account.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAllowBlockedPosting | (Overrides TransactionBase..::..OnAllowBlockedPosting()()()().)
Protected method | OnOverrideControlAccount | (Overrides DrCrTransaction..::..OnOverrideControlAccount(GLTransaction).)
Protected method | OnOverrideTaxControlAccount | (Overrides DrCrTransaction..::..OnOverrideTaxControlAccount(TransactionCode, GLTransaction).)
Protected method | OnPost | (Overrides TransactionBase..::..OnPost()()()().)
Protected method | onPostingGLCredit | (Inherited from TransactionBase.)
Protected method | onPostingGLDebit | (Inherited from TransactionBase.)
Protected method | onPostingGLVat | (Inherited from TransactionBase.)
Public method | Post | Posts the transaction to appropriate ledgers. (Inherited from TransactionBase.)
Protected method | RejectTransactionBranchAssignment | (Inherited from TransactionBase.)
Protected method | setExchangeRate | (Overrides DrCrTransaction..::..setExchangeRate(Double).)
Public method | ToString | (Inherited from DrCrTransaction.)
Public method | Validate | (Overrides DrCrTransaction..::..Validate()()()().)

See Also

SupplierTransaction Class


SupplierTransaction.calcTaxValues Method

[image]

Pastel Evolution SDK
SupplierTransaction..::..calcTaxValues Method
SupplierTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected void calcTaxValues()
Visual Basic
Protected Sub calcTaxValues

See Also

SupplierTransaction Class
SupplierTransaction Members


SupplierTransaction.CalculateTax Method

[image]

Pastel Evolution SDK
SupplierTransaction..::..CalculateTax Method
SupplierTransaction Class See Also Send Feedback
Calculates the tax amount on the transaction.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void CalculateTax()
Visual Basic
Public Sub CalculateTax

See Also

SupplierTransaction Class
SupplierTransaction Members


SupplierTransaction.Clone Method

[image]

Pastel Evolution SDK
SupplierTransaction..::..Clone Method
SupplierTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override Object Clone()
Visual Basic
Public Overrides Function Clone As Object

Return Value

Type: Object

Implements

ICloneable..::..Clone()()()()
ICloneable..::..Clone()()()()

See Also

SupplierTransaction Class
SupplierTransaction Members


SupplierTransaction.Find Method

[image] [image]

Pastel Evolution SDK
SupplierTransaction..::..Find Method
SupplierTransaction Class See Also Send Feedback

Overload List

Name | Description
Find(String) | Finds a transaction ID.
Find(AccountBase, String) | Finds a transaction ID.

See Also

SupplierTransaction Class
SupplierTransaction Members


SupplierTransaction.Find Method (String)

[image]

Pastel Evolution SDK
SupplierTransaction..::..Find Method (String)
SupplierTransaction Class See Also Send Feedback
Finds a transaction ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static long Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Long

Parameters

criteria
Type: System..::..String
The criteria passed to the SQL query. Eg. Reference = 'INV001' or Description like '%Invoice%'

Return Value

Type: Int64

See Also

SupplierTransaction Class
SupplierTransaction Members
Find Overload


SupplierTransaction.Find Method (AccountBase, String)

[image]

Pastel Evolution SDK
SupplierTransaction..::..Find Method (AccountBase, String)
SupplierTransaction Class See Also Send Feedback
Finds a transaction ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static long Find(
    AccountBase account,
    string criteria
)
Visual Basic
Public Shared Function Find (
    account As AccountBase,
    criteria As String
) As Long

Parameters

account
Type: Pastel.Evolution..::..AccountBase
The supplier account by which to filter the transaction list.
criteria
Type: System..::..String
The criteria passed to the SQL query. Eg. Reference = 'INV001' or Description like '%Invoice%'

Return Value

Type: Int64

See Also

SupplierTransaction Class
SupplierTransaction Members
Find Overload


SupplierTransaction.getExchangeRate Method

[image]

Pastel Evolution SDK
SupplierTransaction..::..getExchangeRate Method
SupplierTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected override double getExchangeRate()
Visual Basic
Protected Overrides Function getExchangeRate As Double

Return Value

Type: Double

See Also

SupplierTransaction Class
SupplierTransaction Members


SupplierTransaction.List Method

[image] [image]

Pastel Evolution SDK
SupplierTransaction..::..List Method
SupplierTransaction Class See Also Send Feedback

Overload List

Name | Description
List(String) | Returns a System.Data.DataTable object containing the database records from the PostAR table matching the supplied criteria.
List(AccountBase, String) | Returns a System.Data.DataTable object containing the database records from the PostAR/PostAP table matching the supplied criteria and limited to the specified account.

See Also

SupplierTransaction Class
SupplierTransaction Members


SupplierTransaction.List Method (String)

[image]

Pastel Evolution SDK
SupplierTransaction..::..List Method (String)
SupplierTransaction Class See Also Send Feedback
Returns a System.Data.DataTable object containing the database records from the PostAR table matching the supplied criteria.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria
)
Visual Basic
Public Shared Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String
The SQL criteria used to locate the record, e.g. Reference like '1___'

Return Value

Type: DataTable
A System.Data.DataTable object containing matching records.

Remarks

The criteria is passed to an SQL query so use the appropriate syntax. Remember to include the single quotes around string literals and append additional criteria with and.

See Also

SupplierTransaction Class
SupplierTransaction Members
List Overload


SupplierTransaction.List Method (AccountBase, String)

[image]

Pastel Evolution SDK
SupplierTransaction..::..List Method (AccountBase, String)
SupplierTransaction Class See Also Send Feedback
Returns a System.Data.DataTable object containing the database records from the PostAR/PostAP table matching the supplied criteria and limited to the specified account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    AccountBase account,
    string criteria
)
Visual Basic
Public Shared Function List (
    account As AccountBase,
    criteria As String
) As DataTable

Parameters

account
Type: Pastel.Evolution..::..AccountBase
The supplier account by which to filter the transaction list.
criteria
Type: System..::..String
The SQL criteria used to locate the record, e.g. Reference like '1___'

Return Value

Type: DataTable
A System.Data.DataTable object containing matching records.

Remarks

The criteria is passed to an SQL query so use the appropriate syntax. Remember to include the single quotes around string literals and append additional criteria with and.

See Also

SupplierTransaction Class
SupplierTransaction Members
List Overload


SupplierTransaction.OnAllowBlockedPosting Method

[image]

Pastel Evolution SDK
SupplierTransaction..::..OnAllowBlockedPosting Method
SupplierTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override bool OnAllowBlockedPosting()
Visual Basic
Protected Friend Overrides Function OnAllowBlockedPosting As Boolean

Return Value

Type: Boolean

See Also

SupplierTransaction Class
SupplierTransaction Members


SupplierTransaction.OnOverrideControlAccount Method

[image]

Pastel Evolution SDK
SupplierTransaction..::..OnOverrideControlAccount Method
SupplierTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnOverrideControlAccount(
    GLTransaction glTran
)
Visual Basic
Protected Friend Overrides Sub OnOverrideControlAccount (
    glTran As GLTransaction
)

Parameters

glTran
Type: Pastel.Evolution..::..GLTransaction

See Also

SupplierTransaction Class
SupplierTransaction Members


SupplierTransaction.OnOverrideTaxControlAccount Method

[image]

Pastel Evolution SDK
SupplierTransaction..::..OnOverrideTaxControlAccount Method
SupplierTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnOverrideTaxControlAccount(
    TransactionCode tranCode,
    GLTransaction glTran
)
Visual Basic
Protected Friend Overrides Sub OnOverrideTaxControlAccount (
    tranCode As TransactionCode,
    glTran As GLTransaction
)

Parameters

tranCode
Type: Pastel.Evolution..::..TransactionCode
glTran
Type: Pastel.Evolution..::..GLTransaction

See Also

SupplierTransaction Class
SupplierTransaction Members


SupplierTransaction.OnPost Method

[image]

Pastel Evolution SDK
SupplierTransaction..::..OnPost Method
SupplierTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected override bool OnPost()
Visual Basic
Protected Overrides Function OnPost As Boolean

Return Value

Type: Boolean

See Also

SupplierTransaction Class
SupplierTransaction Members


SupplierTransaction.setExchangeRate Method

[image]

Pastel Evolution SDK
SupplierTransaction..::..setExchangeRate Method
SupplierTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected override void setExchangeRate(
    double value
)
Visual Basic
Protected Overrides Sub setExchangeRate (
    value As Double
)

Parameters

value
Type: System..::..Double

See Also

SupplierTransaction Class
SupplierTransaction Members


SupplierTransaction.Validate Method

[image]

Pastel Evolution SDK
SupplierTransaction..::..Validate Method
SupplierTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override bool Validate()
Visual Basic
Public Overrides Function Validate As Boolean

Return Value

Type: Boolean

See Also

SupplierTransaction Class
SupplierTransaction Members


SupplierTransaction Properties

[image] [image]

Pastel Evolution SDK
SupplierTransaction Properties
SupplierTransaction Class See Also Send Feedback

The SupplierTransaction type exposes the following members.

Properties

 | Name | Description
Public property | Account | Gets or sets the Account to which the transaction gets posted. This is a mandatory field. (Overrides TransactionBase..::..Account.)
Public property | AccountID | Gets or sets the ID of the Account to which the transaction gets posted. (Overrides TransactionBase..::..AccountID.)
Public property | Allocations | Gets the transaction's allocation collection. (Overrides DrCrTransaction..::..Allocations.)
Public property | Amount | Gets or sets the (gross) transaction value. Negative values are allowed and will result in inverted debits and credits. (Overrides DrCrTransaction..::..Amount.)
Public property | Audit | Gets the transaction's audit number. (Overrides TransactionBase..::..Audit.)
Public property | Branch | (Overrides DrCrTransaction..::..Branch.)
Public property | BranchID | (Overrides DrCrTransaction..::..BranchID.)
Public property | Credit | Gets the transaction's credit value, the value of which is determined by the Amount and TransactionCode properties. (Overrides TransactionBase..::..Credit.)
Public property | Currency | Gets the foreign currency in use on this transaction, determined by the specified account. A null value indicates local currency. (Overrides DrCrTransaction..::..Currency.)
Public property | CurrencyID | (Overrides DrCrTransaction..::..CurrencyID.)
Public property | Date | Gets or sets the date on which the transaction takes place. This often differs from the actual posting date but defaults to the current date. (Overrides TransactionBase..::..Date.)
Public property | Debit | Gets the transaction's debit value, the value of which is determined by the Amount and TransactionCode properties. (Overrides TransactionBase..::..Debit.)
Public property | Description | Gets or sets the transaction description that - togeter with the Reference - appears on the account's statement by default. This is a mandatory field. (Overrides TransactionBase..::..Description.)
Public property | ExchangeRate | Gets or sets the applicable exchange rate, expressed as [home currency]/[foreign currency]. Defaults to applicable exchange rate for the transaction date. (Inherited from DrCrTransaction.)
Public property | ExtOrderNo | Gets or sets the transaction's external order number. (Overrides TransactionBase..::..ExtOrderNo.)
Public property | ForeignAmount | Gets or sets the foreign transaction value. (Overrides DrCrTransaction..::..ForeignAmount.)
Public property | ForeignCredit | Gets the transaction's foreign credit value, which is determined by the ForeignAmount and TransactionCode properties. (Overrides DrCrTransaction..::..ForeignCredit.)
Public property | ForeignDebit | Gets the transaction's foreign debit value, which is determined by the ForeignAmount and TransactionCode properties. (Overrides DrCrTransaction..::..ForeignDebit.)
Public property | ForeignOutstanding | Gets the transaction's foreign outstanding amount. (Overrides DrCrTransaction..::..ForeignOutstanding.)
Public property | ForeignTax | Gets or sets the transaction foreign tax amount (automatically rounded to 2 decimals). Note that setting this will switch the entry mode to foreign and recalculate the Amount property. (Overrides DrCrTransaction..::..ForeignTax.)
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides TransactionBase..::..ID.)
Public property | IsDebit | Indicates whether the transaction is a debit (true) or credit(false) (Inherited from DrCrTransaction.)
Public property | IsDebitPositive | (Overrides DrCrTransaction..::..IsDebitPositive.)
Public property | MaxForeignOutstanding | Gets the maximum possible foreign outstanding value for the given transaction, based on the ForeignDebit or ForeignCredit value. (Inherited from DrCrTransaction.)
Public property | MaxOutstanding | Gets the maximum possible outstanding value for the given transaction, based on the Debit or Credit value. (Inherited from DrCrTransaction.)
Public property | ModID | Gets or sets the transaction's evolution module id. (Overrides TransactionBase..::..ModID.)
Public property | Module | Gets the Evolution module this record belongs to, used in internal validation. (Overrides TransactionBase..::..Module.)
Public property | OrderNo | Gets or sets the transaction order number. (Overrides TransactionBase..::..OrderNo.)
Public property | Outstanding | Gets the transaction's outstanding amount. (Overrides DrCrTransaction..::..Outstanding.)
Public property | Project | Gets or sets the Project record associated with this transaction. When using Project Tracking, this field must be specified whereverapplicable. (Overrides TransactionBase..::..Project.)
Public property | ProjectID | Gets or sets the ID of the Project record associated with this transaction. When using Project Tracking, this field must be specified wherever applicable. (Overrides TransactionBase..::..ProjectID.)
Public property | Reference | Gets or sets the transaction reference that - together with the Description - appears on the customer statement by default. This is a mandatory field. (Overrides TransactionBase..::..Reference.)
Public property | Reference2 | Gets or sets an additional transaction reference. (Overrides TransactionBase..::..Reference2.)
Public property | SettlementTerms | (Overrides DrCrTransaction..::..SettlementTerms.)
Public property | SettlementTermsID | (Overrides DrCrTransaction..::..SettlementTermsID.)
Public property | SplitAllocations | Gets the transaction's split allocation collection, used to split the contra account posting to various GL accounts. (Overrides DrCrTransaction..::..SplitAllocations.)
Public property | Supplier | Gets or sets the transaction's supplier account (maps directly to Account).
Public property | Tax | Gets or sets the transaction tax amount (automatically rounded to 2 decimals). (Overrides TransactionBase..::..Tax.)
Public property | TaxRate | Gets or sets the TaxRate record associated with this transaction. If a tax type is specified, a tax amount is automatically calculated, but can be overridden. (Overrides TransactionBase..::..TaxRate.)
Public property | TaxRateID | (Overrides TransactionBase..::..TaxRateID.)
Public property | TransactionCode | Gets or sets the TransactionCode record associated with this transaction, as maintained in Accounts Payable > Maintenance > Transaction Types. Transaction codes/types govern General Ledger integration. This is a mandatory field. (Overrides TransactionBase..::..TransactionCode.)
Public property | TransactionCodeID | Gets or sets the ID of the TransactionCode record associated with this transaction, which governs General Ledger integration. (Overrides TransactionBase..::..TransactionCodeID.)

See Also

SupplierTransaction Class


SupplierTransaction.Account Property

[image]

Pastel Evolution SDK
SupplierTransaction..::..Account Property
SupplierTransaction Class See Also Send Feedback
Gets or sets the Account to which the transaction gets posted. This is a mandatory field.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override AccountBase Account { get; set; }
Visual Basic
Public Overrides Property Account As AccountBase
    Get
    Set

Property Value

Type: AccountBase

See Also

SupplierTransaction Class
SupplierTransaction Members
Pastel.Evolution Namespace
SupplierTransaction..::..Supplier


SupplierTransaction.AccountID Property

[image]

Pastel Evolution SDK
SupplierTransaction..::..AccountID Property
SupplierTransaction Class See Also Send Feedback
Gets or sets the ID of the Account to which the transaction gets posted.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int AccountID { get; set; }
Visual Basic
Public Overrides Property AccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

SupplierTransaction Class
SupplierTransaction Members
Pastel.Evolution Namespace
SupplierTransaction..::..Account


SupplierTransaction.Allocations Property

[image]

Pastel Evolution SDK
SupplierTransaction..::..Allocations Property
SupplierTransaction Class See Also Send Feedback
Gets the transaction's allocation collection.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override AllocationCollection Allocations { get; }
Visual Basic
Public Overrides ReadOnly Property Allocations As AllocationCollection
    Get

Property Value

Type: AllocationCollection

See Also

SupplierTransaction Class
SupplierTransaction Members


SupplierTransaction.Amount Property

[image]

Pastel Evolution SDK
SupplierTransaction..::..Amount Property
SupplierTransaction Class See Also Send Feedback
Gets or sets the (gross) transaction value. Negative values are allowed and will result in inverted debits and credits.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override double Amount { get; set; }
Visual Basic
Public Overrides Property Amount As Double
    Get
    Set

Property Value

Type: Double

See Also

SupplierTransaction Class
SupplierTransaction Members


SupplierTransaction.Audit Property

[image]

Pastel Evolution SDK
SupplierTransaction..::..Audit Property
SupplierTransaction Class See Also Send Feedback
Gets the transaction's audit number.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override string Audit { get; }
Visual Basic
Public Overrides ReadOnly Property Audit As String
    Get

Property Value

Type: String

Remarks

The audit number is 0 when unposted. After posting, it will reflect the transaction's posted audit number.

See Also

SupplierTransaction Class
SupplierTransaction Members


SupplierTransaction.Branch Property

[image]

Pastel Evolution SDK
SupplierTransaction..::..Branch Property
SupplierTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override Branch Branch { get; set; }
Visual Basic
Public Overrides Property Branch As Branch
    Get
    Set

Property Value

Type: Branch

Implements

IBranched..::..Branch

See Also

SupplierTransaction Class
SupplierTransaction Members


SupplierTransaction.BranchID Property

[image]

Pastel Evolution SDK
SupplierTransaction..::..BranchID Property
SupplierTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int BranchID { get; internal set; }
Visual Basic
Public Overrides Property BranchID As Integer
    Get
    Friend Set

Property Value

Type: Int32

Implements

IBranched..::..BranchID

See Also

SupplierTransaction Class
SupplierTransaction Members


SupplierTransaction.Credit Property

[image]

Pastel Evolution SDK
SupplierTransaction..::..Credit Property
SupplierTransaction Class See Also Send Feedback
Gets the transaction's credit value, the value of which is determined by the Amount and TransactionCode properties.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override double Credit { get; set; }
Visual Basic
Public Overrides Property Credit As Double
    Get
    Set

Property Value

Type: Double

See Also

SupplierTransaction Class
SupplierTransaction Members


SupplierTransaction.Currency Property

[image]

Pastel Evolution SDK
SupplierTransaction..::..Currency Property
SupplierTransaction Class See Also Send Feedback
Gets the foreign currency in use on this transaction, determined by the specified account. A null value indicates local currency.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override Currency Currency { get; internal set; }
Visual Basic
Public Overrides Property Currency As Currency
    Get
    Friend Set

Property Value

Type: Currency

See Also

SupplierTransaction Class
SupplierTransaction Members


SupplierTransaction.CurrencyID Property

[image]

Pastel Evolution SDK
SupplierTransaction..::..CurrencyID Property
SupplierTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int CurrencyID { get; internal set; }
Visual Basic
Public Overrides Property CurrencyID As Integer
    Get
    Friend Set

Property Value

Type: Int32

See Also

SupplierTransaction Class
SupplierTransaction Members


SupplierTransaction.Date Property

[image]

Pastel Evolution SDK
SupplierTransaction..::..Date Property
SupplierTransaction Class See Also Send Feedback
Gets or sets the date on which the transaction takes place. This often differs from the actual posting date but defaults to the current date.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override DateTime Date { get; set; }
Visual Basic
Public Overrides Property Date As DateTime
    Get
    Set

Property Value

Type: DateTime

See Also

SupplierTransaction Class
SupplierTransaction Members


SupplierTransaction.Debit Property

[image]

Pastel Evolution SDK
SupplierTransaction..::..Debit Property
SupplierTransaction Class See Also Send Feedback
Gets the transaction's debit value, the value of which is determined by the Amount and TransactionCode properties.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override double Debit { get; set; }
Visual Basic
Public Overrides Property Debit As Double
    Get
    Set

Property Value

Type: Double

See Also

SupplierTransaction Class
SupplierTransaction Members


SupplierTransaction.Description Property

[image]

Pastel Evolution SDK
SupplierTransaction..::..Description Property
SupplierTransaction Class See Also Send Feedback
Gets or sets the transaction description that - togeter with the Reference - appears on the account's statement by default. This is a mandatory field.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override string Description { get; set; }
Visual Basic
Public Overrides Property Description As String
    Get
    Set

Property Value

Type: String

Remarks

The Reference is usually a sequencial code whereas the description is more general, e.g. a transaction might have the reference "PMB128901" and the description "Payment - Thank You".

See Also

SupplierTransaction Class
SupplierTransaction Members


SupplierTransaction.ExtOrderNo Property

[image]

Pastel Evolution SDK
SupplierTransaction..::..ExtOrderNo Property
SupplierTransaction Class See Also Send Feedback
Gets or sets the transaction's external order number.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override string ExtOrderNo { get; set; }
Visual Basic
Public Overrides Property ExtOrderNo As String
    Get
    Set

Property Value

Type: String

See Also

SupplierTransaction Class
SupplierTransaction Members


SupplierTransaction.ForeignAmount Property

[image]

Pastel Evolution SDK
SupplierTransaction..::..ForeignAmount Property
SupplierTransaction Class See Also Send Feedback
Gets or sets the foreign transaction value.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override double ForeignAmount { get; set; }
Visual Basic
Public Overrides Property ForeignAmount As Double
    Get
    Set

Property Value

Type: Double

See Also

SupplierTransaction Class
SupplierTransaction Members


SupplierTransaction.ForeignCredit Property

[image]

Pastel Evolution SDK
SupplierTransaction..::..ForeignCredit Property
SupplierTransaction Class See Also Send Feedback
Gets the transaction's foreign credit value, which is determined by the ForeignAmount and TransactionCode properties.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override double ForeignCredit { get; }
Visual Basic
Public Overrides ReadOnly Property ForeignCredit As Double
    Get

Property Value

Type: Double

See Also

SupplierTransaction Class
SupplierTransaction Members


SupplierTransaction.ForeignDebit Property

[image]

Pastel Evolution SDK
SupplierTransaction..::..ForeignDebit Property
SupplierTransaction Class See Also Send Feedback
Gets the transaction's foreign debit value, which is determined by the ForeignAmount and TransactionCode properties.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override double ForeignDebit { get; }
Visual Basic
Public Overrides ReadOnly Property ForeignDebit As Double
    Get

Property Value

Type: Double

See Also

SupplierTransaction Class
SupplierTransaction Members


SupplierTransaction.ForeignOutstanding Property

[image]

Pastel Evolution SDK
SupplierTransaction..::..ForeignOutstanding Property
SupplierTransaction Class See Also Send Feedback
Gets the transaction's foreign outstanding amount.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override double ForeignOutstanding { get; internal set; }
Visual Basic
Public Overrides Property ForeignOutstanding As Double
    Get
    Friend Set

Property Value

Type: Double

See Also

SupplierTransaction Class
SupplierTransaction Members


SupplierTransaction.ForeignTax Property

[image]

Pastel Evolution SDK
SupplierTransaction..::..ForeignTax Property
SupplierTransaction Class See Also Send Feedback
Gets or sets the transaction foreign tax amount (automatically rounded to 2 decimals). Note that setting this will switch the entry mode to foreign and recalculate the Amount property.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override double ForeignTax { get; set; }
Visual Basic
Public Overrides Property ForeignTax As Double
    Get
    Set

Property Value

Type: Double

See Also

SupplierTransaction Class
SupplierTransaction Members


SupplierTransaction.ID Property

[image]

Pastel Evolution SDK
SupplierTransaction..::..ID Property
SupplierTransaction Class See Also Send Feedback
Gets the internal record ID (0 for new, unsaved records).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Long
    Get

Property Value

Type: Int64

See Also

SupplierTransaction Class
SupplierTransaction Members


SupplierTransaction.IsDebitPositive Property

[image]

Pastel Evolution SDK
SupplierTransaction..::..IsDebitPositive Property
SupplierTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override bool IsDebitPositive { get; }
Visual Basic
Public Overrides ReadOnly Property IsDebitPositive As Boolean
    Get

Property Value

Type: Boolean

See Also

SupplierTransaction Class
SupplierTransaction Members


SupplierTransaction.ModID Property

[image]

Pastel Evolution SDK
SupplierTransaction..::..ModID Property
SupplierTransaction Class See Also Send Feedback
Gets or sets the transaction's evolution module id.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override ModuleID ModID { get; set; }
Visual Basic
Public Overrides Property ModID As ModuleID
    Get
    Set

Property Value

Type: ModuleID

See Also

SupplierTransaction Class
SupplierTransaction Members


SupplierTransaction.Module Property

[image]

Pastel Evolution SDK
SupplierTransaction..::..Module Property
SupplierTransaction Class See Also Send Feedback
Gets the Evolution module this record belongs to, used in internal validation.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override Module Module { get; }
Visual Basic
Public Overrides ReadOnly Property Module As Module
    Get

Property Value

Type: Module

See Also

SupplierTransaction Class
SupplierTransaction Members


SupplierTransaction.OrderNo Property

[image]

Pastel Evolution SDK
SupplierTransaction..::..OrderNo Property
SupplierTransaction Class See Also Send Feedback
Gets or sets the transaction order number.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override string OrderNo { get; set; }
Visual Basic
Public Overrides Property OrderNo As String
    Get
    Set

Property Value

Type: String

See Also

SupplierTransaction Class
SupplierTransaction Members


SupplierTransaction.Outstanding Property

[image]

Pastel Evolution SDK
SupplierTransaction..::..Outstanding Property
SupplierTransaction Class See Also Send Feedback
Gets the transaction's outstanding amount.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override double Outstanding { get; internal set; }
Visual Basic
Public Overrides Property Outstanding As Double
    Get
    Friend Set

Property Value

Type: Double

See Also

SupplierTransaction Class
SupplierTransaction Members


SupplierTransaction.Project Property

[image]

Pastel Evolution SDK
SupplierTransaction..::..Project Property
SupplierTransaction Class See Also Send Feedback
Gets or sets the Project record associated with this transaction. When using Project Tracking, this field must be specified whereverapplicable.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override Project Project { get; set; }
Visual Basic
Public Overrides Property Project As Project
    Get
    Set

Property Value

Type: Project

See Also

SupplierTransaction Class
SupplierTransaction Members


SupplierTransaction.ProjectID Property

[image]

Pastel Evolution SDK
SupplierTransaction..::..ProjectID Property
SupplierTransaction Class See Also Send Feedback
Gets or sets the ID of the Project record associated with this transaction. When using Project Tracking, this field must be specified wherever applicable.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ProjectID { get; set; }
Visual Basic
Public Overrides Property ProjectID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

SupplierTransaction Class
SupplierTransaction Members


SupplierTransaction.Reference Property

[image]

Pastel Evolution SDK
SupplierTransaction..::..Reference Property
SupplierTransaction Class See Also Send Feedback
Gets or sets the transaction reference that - together with the Description - appears on the customer statement by default. This is a mandatory field.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override string Reference { get; set; }
Visual Basic
Public Overrides Property Reference As String
    Get
    Set

Property Value

Type: String

Remarks

The Reference is usually quite "cryptic" (numbered sequenceetc.) whereas the description is more friendly, e.g. a transaction might have thereference "PMB128901" and the description "Payment - Thank You".

See Also

SupplierTransaction Class
SupplierTransaction Members


SupplierTransaction.Reference2 Property

[image]

Pastel Evolution SDK
SupplierTransaction..::..Reference2 Property
SupplierTransaction Class See Also Send Feedback
Gets or sets an additional transaction reference.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override string Reference2 { get; set; }
Visual Basic
Public Overrides Property Reference2 As String
    Get
    Set

Property Value

Type: String

See Also

SupplierTransaction Class
SupplierTransaction Members


SupplierTransaction.SettlementTerms Property

[image]

Pastel Evolution SDK
SupplierTransaction..::..SettlementTerms Property
SupplierTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override SettlementTerms SettlementTerms { get; set; }
Visual Basic
Public Overrides Property SettlementTerms As SettlementTerms
    Get
    Set

Property Value

Type: SettlementTerms

See Also

SupplierTransaction Class
SupplierTransaction Members


SupplierTransaction.SettlementTermsID Property

[image]

Pastel Evolution SDK
SupplierTransaction..::..SettlementTermsID Property
SupplierTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int SettlementTermsID { get; set; }
Visual Basic
Public Overrides Property SettlementTermsID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

SupplierTransaction Class
SupplierTransaction Members


SupplierTransaction.SplitAllocations Property

[image]

Pastel Evolution SDK
SupplierTransaction..::..SplitAllocations Property
SupplierTransaction Class See Also Send Feedback
Gets the transaction's split allocation collection, used to split the contra account posting to various GL accounts.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override SplitAllocationCollection SplitAllocations { get; }
Visual Basic
Public Overrides ReadOnly Property SplitAllocations As SplitAllocationCollection
    Get

Property Value

Type: SplitAllocationCollection

See Also

SupplierTransaction Class
SupplierTransaction Members


SupplierTransaction.Supplier Property

[image]

Pastel Evolution SDK
SupplierTransaction..::..Supplier Property
SupplierTransaction Class See Also Send Feedback
Gets or sets the transaction's supplier account (maps directly to Account).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Supplier Supplier { get; set; }
Visual Basic
Public Property Supplier As Supplier
    Get
    Set

Property Value

Type: Supplier

See Also

SupplierTransaction Class
SupplierTransaction Members


SupplierTransaction.Tax Property

[image]

Pastel Evolution SDK
SupplierTransaction..::..Tax Property
SupplierTransaction Class See Also Send Feedback
Gets or sets the transaction tax amount (automatically rounded to 2 decimals).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override double Tax { get; set; }
Visual Basic
Public Overrides Property Tax As Double
    Get
    Set

Property Value

Type: Double

See Also

SupplierTransaction Class
SupplierTransaction Members


SupplierTransaction.TaxRate Property

[image]

Pastel Evolution SDK
SupplierTransaction..::..TaxRate Property
SupplierTransaction Class See Also Send Feedback
Gets or sets the TaxRate record associated with this transaction. If a tax type is specified, a tax amount is automatically calculated, but can be overridden.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override TaxRate TaxRate { get; set; }
Visual Basic
Public Overrides Property TaxRate As TaxRate
    Get
    Set

Property Value

Type: TaxRate

See Also

SupplierTransaction Class
SupplierTransaction Members


SupplierTransaction.TaxRateID Property

[image]

Pastel Evolution SDK
SupplierTransaction..::..TaxRateID Property
SupplierTransaction Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int TaxRateID { get; set; }
Visual Basic
Public Overrides Property TaxRateID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

SupplierTransaction Class
SupplierTransaction Members


SupplierTransaction.TransactionCode Property

[image]

Pastel Evolution SDK
SupplierTransaction..::..TransactionCode Property
SupplierTransaction Class See Also Send Feedback
Gets or sets the TransactionCode record associated with this transaction, as maintained in Accounts Payable > Maintenance > Transaction Types. Transaction codes/types govern General Ledger integration. This is a mandatory field.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override TransactionCodeBase TransactionCode { get; set; }
Visual Basic
Public Overrides Property TransactionCode As TransactionCodeBase
    Get
    Set

Property Value

Type: TransactionCodeBase

See Also

SupplierTransaction Class
SupplierTransaction Members


SupplierTransaction.TransactionCodeID Property

[image]

Pastel Evolution SDK
SupplierTransaction..::..TransactionCodeID Property
SupplierTransaction Class See Also Send Feedback
Gets or sets the ID of the TransactionCode record associated with this transaction, which governs General Ledger integration.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int TransactionCodeID { get; set; }
Visual Basic
Public Overrides Property TransactionCodeID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

SupplierTransaction Class
SupplierTransaction Members
Pastel.Evolution Namespace
SupplierTransaction..::..TransactionCode


SupplierTransaction Events

[image] [image]

Pastel Evolution SDK
SupplierTransaction Events
SupplierTransaction Class See Also Send Feedback

The SupplierTransaction type exposes the following members.

Events

 | Name | Description
Public event | GLCreditPosting | (Inherited from TransactionBase.)
Public event | GLDebitPosting | (Inherited from TransactionBase.)
Public event | GLVatPosting | (Inherited from TransactionBase.)

See Also

SupplierTransaction Class


TaxMode Enumeration

[image]

Pastel Evolution SDK
TaxMode Enumeration
See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public enum TaxMode
Visual Basic
Public Enumeration TaxMode

Members

Member name | Value | Description
Exclusive | 0 |
Inclusive | 1 |

See Also

Pastel.Evolution Namespace


TaxRate Class

[image]

Pastel Evolution SDK
TaxRate Class
Members See Also Send Feedback
Represents a tax rate.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class TaxRate : BranchedRecordBase
Visual Basic
Public Class TaxRate
    Inherits BranchedRecordBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..TaxRate

See Also

TaxRate Members


TaxRate Members

[image] [image]

Pastel Evolution SDK
TaxRate Members
TaxRate Class Constructors Methods Fields Properties See Also Send Feedback

The TaxRate type exposes the following members.

Constructors

 | Name | Description
Public method | TaxRate()()()() | Creates a new instance of a tax type.
Public method | TaxRate(Int32) | Creates a new instance of a tax type.
Public method | TaxRate(String) | Creates a new instance of a tax type.

Methods

 | Name | Description
 | _ListCurrentBranch |
 | _Select(String) | Experimental Method
 | _Select(String, String) |
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds a record's database ID.
 | FindByCode | Finds the database ID of a record matching the specified code.
 | Get | Returns an instance of the first record satisfying the criteria specified; otherwise, returns null.
 | GetByCode | Returns an instance of the first record with the code specified; otherwise, returns null.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List(String) | Returns a System.Data.DataTable object containing the database records from the Client table matching the supplied criteria.
 | List(String, String) | Returns a System.Data.DataTable object containing the database records from the Client table matching the supplied criteria.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Gets the record's string representation. (Overrides Object..::..ToString()()()().)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Code | Gets or sets the tax type's code.
Public property | Description | Gets or sets the tax type's description.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | Rate | Gets or sets the tax type's rate.

See Also

TaxRate Class


TaxRate Constructor

[image] [image]

Pastel Evolution SDK
TaxRate Constructor
TaxRate Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TaxRate()()()() | Creates a new instance of a tax type.
Public method | TaxRate(Int32) | Creates a new instance of a tax type.
Public method | TaxRate(String) | Creates a new instance of a tax type.

See Also

TaxRate Class
TaxRate Members


TaxRate Constructor

[image]

Pastel Evolution SDK
TaxRate Constructor
TaxRate Class See Also Send Feedback
Creates a new instance of a tax type.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public TaxRate()
Visual Basic
Public Sub New

See Also

TaxRate Class
TaxRate Members
TaxRate Overload


TaxRate Constructor (Int32)

[image]

Pastel Evolution SDK
TaxRate Constructor (Int32)
TaxRate Class See Also Send Feedback
Creates a new instance of a tax type.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public TaxRate(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32
Specifies the id of the existing record.

See Also

TaxRate Class
TaxRate Members
TaxRate Overload


TaxRate Constructor (String)

[image]

Pastel Evolution SDK
TaxRate Constructor (String)
TaxRate Class See Also Send Feedback
Creates a new instance of a tax type.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public TaxRate(
    string code
)
Visual Basic
Public Sub New (
    code As String
)

Parameters

code
Type: System..::..String
Specifies the code of the existing record.

See Also

TaxRate Class
TaxRate Members
TaxRate Overload


TaxRate Fields

[image] [image]

Pastel Evolution SDK
TaxRate Fields
TaxRate Class See Also Send Feedback

The TaxRate type exposes the following members.

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

TaxRate Class


TaxRate Methods

[image] [image]

Pastel Evolution SDK
TaxRate Methods
TaxRate Class See Also Send Feedback

The TaxRate type exposes the following members.

Methods

 | Name | Description
 | _ListCurrentBranch |
 | _Select(String) | Experimental Method
 | _Select(String, String) |
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds a record's database ID.
 | FindByCode | Finds the database ID of a record matching the specified code.
 | Get | Returns an instance of the first record satisfying the criteria specified; otherwise, returns null.
 | GetByCode | Returns an instance of the first record with the code specified; otherwise, returns null.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List(String) | Returns a System.Data.DataTable object containing the database records from the Client table matching the supplied criteria.
 | List(String, String) | Returns a System.Data.DataTable object containing the database records from the Client table matching the supplied criteria.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Gets the record's string representation. (Overrides Object..::..ToString()()()().)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

TaxRate Class


TaxRate._ListCurrentBranch Method

[image]

Pastel Evolution SDK
TaxRate..::.._ListCurrentBranch Method
TaxRate Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable _ListCurrentBranch(
    string criteria
)
Visual Basic
Public Shared Function _ListCurrentBranch (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String

Return Value

Type: DataTable

See Also

TaxRate Class
TaxRate Members


TaxRate._Select Method

[image] [image]

Pastel Evolution SDK
TaxRate..::.._Select Method
TaxRate Class See Also Send Feedback

Overload List

Name | Description
_Select(String) | Experimental Method
_Select(String, String) |

See Also

TaxRate Class
TaxRate Members


TaxRate._Select Method (String)

[image]

Pastel Evolution SDK
TaxRate..::.._Select Method (String)
TaxRate Class See Also Send Feedback
Experimental Method

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static TaxRate[] _Select(
    string criteria
)
Visual Basic
Public Shared Function _Select (
    criteria As String
) As TaxRate()

Parameters

criteria
Type: System..::..String

Return Value

Type: array< TaxRate >[]()[][]

See Also

TaxRate Class
TaxRate Members
_Select Overload


TaxRate._Select Method (String, String)

[image]

Pastel Evolution SDK
TaxRate..::.._Select Method (String, String)
TaxRate Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static TaxRate[] _Select(
    string criteria,
    string sortOrder
)
Visual Basic
Public Shared Function _Select (
    criteria As String,
    sortOrder As String
) As TaxRate()

Parameters

criteria
Type: System..::..String
sortOrder
Type: System..::..String

Return Value

Type: array< TaxRate >[]()[][]

See Also

TaxRate Class
TaxRate Members
_Select Overload


TaxRate.Find Method

[image]

Pastel Evolution SDK
TaxRate..::..Find Method
TaxRate Class See Also Send Feedback
Finds a record's database ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.

Return Value

Type: Int32
The ID of the first record found; -1 if not record was found.

See Also

TaxRate Class
TaxRate Members


TaxRate.FindByCode Method

[image]

Pastel Evolution SDK
TaxRate..::..FindByCode Method
TaxRate Class See Also Send Feedback
Finds the database ID of a record matching the specified code.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int FindByCode(
    string code
)
Visual Basic
Public Shared Function FindByCode (
    code As String
) As Integer

Parameters

code
Type: System..::..String
Specifies the code.

Return Value

Type: Int32
The ID of the first record found; -1 if not record was found.

See Also

TaxRate Class
TaxRate Members


TaxRate.Get Method

[image]

Pastel Evolution SDK
TaxRate..::..Get Method
TaxRate Class See Also Send Feedback
Returns an instance of the first record satisfying the criteria specified; otherwise, returns null.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static TaxRate Get(
    string criteria
)
Visual Basic
Public Shared Function Get (
    criteria As String
) As TaxRate

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.

Return Value

Type: TaxRate
The record found; otherwise null

See Also

TaxRate Class
TaxRate Members
Pastel.Evolution Namespace
TaxRate..::..Find(String)


TaxRate.GetByCode Method

[image]

Pastel Evolution SDK
TaxRate..::..GetByCode Method
TaxRate Class See Also Send Feedback
Returns an instance of the first record with the code specified; otherwise, returns null.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static TaxRate GetByCode(
    string code
)
Visual Basic
Public Shared Function GetByCode (
    code As String
) As TaxRate

Parameters

code
Type: System..::..String
Specifies the code.

Return Value

Type: TaxRate
The record found; otherwise null

See Also

TaxRate Class
TaxRate Members


TaxRate.List Method

[image] [image]

Pastel Evolution SDK
TaxRate..::..List Method
TaxRate Class See Also Send Feedback

Overload List

Name | Description
List(String) | Returns a System.Data.DataTable object containing the database records from the Client table matching the supplied criteria.
List(String, String) | Returns a System.Data.DataTable object containing the database records from the Client table matching the supplied criteria.

See Also

TaxRate Class
TaxRate Members


TaxRate.List Method (String)

[image]

Pastel Evolution SDK
TaxRate..::..List Method (String)
TaxRate Class See Also Send Feedback
Returns a System.Data.DataTable object containing the database records from the Client table matching the supplied criteria.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria
)
Visual Basic
Public Shared Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String
The SQL criteria used to locate the record, e.g. Account like '1___'

Return Value

Type: DataTable
A System.Data.DataTable object containing matching records.

Remarks

The criteria is passed to an SQL query so use the appropriate syntax. Remember to includethe single quotes around string literals and append additional criteria with and.

See Also

TaxRate Class
TaxRate Members
List Overload


TaxRate.List Method (String, String)

[image]

Pastel Evolution SDK
TaxRate..::..List Method (String, String)
TaxRate Class See Also Send Feedback
Returns a System.Data.DataTable object containing the database records from the Client table matching the supplied criteria.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria,
    string sortOrder
)
Visual Basic
Public Shared Function List (
    criteria As String,
    sortOrder As String
) As DataTable

Parameters

criteria
Type: System..::..String
The SQL criteria used to locate the record, e.g. Account like '1___'
sortOrder
Type: System..::..String
The SQL order by clause to use, e.g. DCBalance desc, Account

Return Value

Type: DataTable
A System.Data.DataTable object containing matching records.

Remarks

The criteria is passed to an SQL query so use the appropriate syntax. Remember to includethe single quotes around string literals and append additional criteria with and.

See Also

TaxRate Class
TaxRate Members
List Overload


TaxRate.OnDelete Method

[image]

Pastel Evolution SDK
TaxRate..::..OnDelete Method
TaxRate Class See Also Send Feedback
Removes the record from the database, provided it is not referenced by other records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

See Also

TaxRate Class
TaxRate Members


TaxRate.OnSave Method

[image]

Pastel Evolution SDK
TaxRate..::..OnSave Method
TaxRate Class See Also Send Feedback
Persists the record to the database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

TaxRate Class
TaxRate Members


TaxRate.ToString Method

[image]

Pastel Evolution SDK
TaxRate..::..ToString Method
TaxRate Class See Also Send Feedback
Gets the record's string representation.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String
The object's string representation.

Remarks

Useful while debugging.

See Also

TaxRate Class
TaxRate Members


TaxRate Properties

[image] [image]

Pastel Evolution SDK
TaxRate Properties
TaxRate Class See Also Send Feedback

The TaxRate type exposes the following members.

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Code | Gets or sets the tax type's code.
Public property | Description | Gets or sets the tax type's description.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | Rate | Gets or sets the tax type's rate.

See Also

TaxRate Class


TaxRate.Code Property

[image]

Pastel Evolution SDK
TaxRate..::..Code Property
TaxRate Class See Also Send Feedback
Gets or sets the tax type's code.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Code { get; set; }
Visual Basic
Public Property Code As String
    Get
    Set

Property Value

Type: String

See Also

TaxRate Class
TaxRate Members


TaxRate.Description Property

[image]

Pastel Evolution SDK
TaxRate..::..Description Property
TaxRate Class See Also Send Feedback
Gets or sets the tax type's description.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set

Property Value

Type: String

See Also

TaxRate Class
TaxRate Members


TaxRate.ID Property

[image]

Pastel Evolution SDK
TaxRate..::..ID Property
TaxRate Class See Also Send Feedback
Gets the internal record ID (0 for new, unsaved records).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

Remarks

Once saved, the ID will reflect the record's internal database identifier.

See Also

TaxRate Class
TaxRate Members


TaxRate.LongID Property

[image]

Pastel Evolution SDK
TaxRate..::..LongID Property
TaxRate Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

TaxRate Class
TaxRate Members


TaxRate.Rate Property

[image]

Pastel Evolution SDK
TaxRate..::..Rate Property
TaxRate Class See Also Send Feedback
Gets or sets the tax type's rate.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double Rate { get; set; }
Visual Basic
Public Property Rate As Double
    Get
    Set

Property Value

Type: Double

Remarks

Valid values 0-100

See Also

TaxRate Class
TaxRate Members


TransactionBase Class

[image]

Pastel Evolution SDK
TransactionBase Class
Members See Also Send Feedback
Embodies a common Evolution transaction.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract class TransactionBase : IBranched
Visual Basic
Public MustInherit Class TransactionBase
    Implements IBranched

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..TransactionBase
Pastel.Evolution..::..DrCrTransaction
Pastel.Evolution..::..GLTransaction
Pastel.Evolution..::..InventoryTransaction

See Also

TransactionBase Members


TransactionBase Members

[image] [image]

Pastel Evolution SDK
TransactionBase Members
TransactionBase Class Constructors Methods Fields Properties Events See Also Send Feedback

The TransactionBase type exposes the following members.

Constructors

 | Name | Description
Protected method | TransactionBase | Initializes a new instance of the TransactionBase class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAllowBlockedPosting |
Protected method | OnPost |
Protected method | onPostingGLCredit |
Protected method | onPostingGLDebit |
Protected method | onPostingGLVat |
Public method | Post | Posts the transaction to appropriate ledgers.
Protected method | RejectTransactionBranchAssignment |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Validate | Validates the transaction.

Fields

 | Name | Description
Protected field | foreignOriginalTax |
Protected field | isDebitTrans |
Protected field | originalTax |
Protected field | readOnly |

Properties

 | Name | Description
Public property | Account | Gets or sets the transaction's account.
Public property | AccountID | Gets or sets the transaction's account id.
Public property | Audit | Gets the transaction's audit number.
Public property | Branch |
Public property | BranchID |
Public property | Credit | Gets or sets the transaction's credit value.
Public property | Date | Gets or sets the transaction date.
Public property | Debit | Gets or sets the transaction's debit value.
Public property | Description | Gets or sets the transaction description.
Public property | ExtOrderNo | Gets or sets the transaction's external order number.
Public property | ID | Gets the transaction id.
Public property | ModID | Gets or sets the transaction's Evolution module ID.
Public property | Module | Gets the transaction's Evolution module.
Public property | OrderNo | Gets or sets the transaction's order number.
Public property | Project | Sets the transaction's project.
Public property | ProjectID | Gets or sets the transaction's project id.
Public property | Reference | Gets or sets the transaction reference.
Public property | Reference2 | Gets or sets the 2nd transaction reference.
Public property | Tax | Gets or sets the transaction tax amount.
Public property | TaxRate | Gets or sets the transaction's tax type.
Public property | TaxRateID | Gets or sets the transaction's tax type id.
Public property | TransactionCode | Gets or sets the transaction's transaction code.
Public property | TransactionCodeID | Gets or sets the transaction code id.

Events

 | Name | Description
Public event | GLCreditPosting |
Public event | GLDebitPosting |
Public event | GLVatPosting |

See Also

TransactionBase Class


TransactionBase Constructor

[image]

Pastel Evolution SDK
TransactionBase Constructor
TransactionBase Class See Also Send Feedback
Initializes a new instance of the TransactionBase class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected TransactionBase()
Visual Basic
Protected Sub New

See Also

TransactionBase Class
TransactionBase Members


TransactionBase Fields

[image] [image]

Pastel Evolution SDK
TransactionBase Fields
TransactionBase Class See Also Send Feedback

The TransactionBase type exposes the following members.

Fields

 | Name | Description
Protected field | foreignOriginalTax |
Protected field | isDebitTrans |
Protected field | originalTax |
Protected field | readOnly |

See Also

TransactionBase Class


TransactionBase.foreignOriginalTax Field

[image]

Pastel Evolution SDK
TransactionBase..::..foreignOriginalTax Field
TransactionBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected double foreignOriginalTax
Visual Basic
Protected foreignOriginalTax As Double

Field Value

Type: Double

See Also

TransactionBase Class
TransactionBase Members


TransactionBase.isDebitTrans Field

[image]

Pastel Evolution SDK
TransactionBase..::..isDebitTrans Field
TransactionBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected bool isDebitTrans
Visual Basic
Protected isDebitTrans As Boolean

Field Value

Type: Boolean

See Also

TransactionBase Class
TransactionBase Members


TransactionBase.originalTax Field

[image]

Pastel Evolution SDK
TransactionBase..::..originalTax Field
TransactionBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected double originalTax
Visual Basic
Protected originalTax As Double

Field Value

Type: Double

See Also

TransactionBase Class
TransactionBase Members


TransactionBase.readOnly Field

[image]

Pastel Evolution SDK
TransactionBase..::..readOnly Field
TransactionBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected bool readOnly
Visual Basic
Protected readOnly As Boolean

Field Value

Type: Boolean

See Also

TransactionBase Class
TransactionBase Members


TransactionBase Methods

[image] [image]

Pastel Evolution SDK
TransactionBase Methods
TransactionBase Class See Also Send Feedback

The TransactionBase type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAllowBlockedPosting |
Protected method | OnPost |
Protected method | onPostingGLCredit |
Protected method | onPostingGLDebit |
Protected method | onPostingGLVat |
Public method | Post | Posts the transaction to appropriate ledgers.
Protected method | RejectTransactionBranchAssignment |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Validate | Validates the transaction.

See Also

TransactionBase Class


TransactionBase.OnAllowBlockedPosting Method

[image]

Pastel Evolution SDK
TransactionBase..::..OnAllowBlockedPosting Method
TransactionBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal abstract bool OnAllowBlockedPosting()
Visual Basic
Protected Friend MustOverride Function OnAllowBlockedPosting As Boolean

Return Value

Type: Boolean

See Also

TransactionBase Class
TransactionBase Members


TransactionBase.OnPost Method

[image]

Pastel Evolution SDK
TransactionBase..::..OnPost Method
TransactionBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected abstract bool OnPost()
Visual Basic
Protected MustOverride Function OnPost As Boolean

Return Value

Type: Boolean

See Also

TransactionBase Class
TransactionBase Members


TransactionBase.onPostingGLCredit Method

[image]

Pastel Evolution SDK
TransactionBase..::..onPostingGLCredit Method
TransactionBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected bool onPostingGLCredit(
    GLTransaction tran
)
Visual Basic
Protected Function onPostingGLCredit (
    tran As GLTransaction
) As Boolean

Parameters

tran
Type: Pastel.Evolution..::..GLTransaction

Return Value

Type: Boolean
Returns true if the transaction has already been handled.

See Also

TransactionBase Class
TransactionBase Members


TransactionBase.onPostingGLDebit Method

[image]

Pastel Evolution SDK
TransactionBase..::..onPostingGLDebit Method
TransactionBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected bool onPostingGLDebit(
    GLTransaction tran
)
Visual Basic
Protected Function onPostingGLDebit (
    tran As GLTransaction
) As Boolean

Parameters

tran
Type: Pastel.Evolution..::..GLTransaction

Return Value

Type: Boolean
Returns true if the transaction has already been handled.

See Also

TransactionBase Class
TransactionBase Members


TransactionBase.onPostingGLVat Method

[image]

Pastel Evolution SDK
TransactionBase..::..onPostingGLVat Method
TransactionBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected bool onPostingGLVat(
    GLTransaction tran
)
Visual Basic
Protected Function onPostingGLVat (
    tran As GLTransaction
) As Boolean

Parameters

tran
Type: Pastel.Evolution..::..GLTransaction

Return Value

Type: Boolean

See Also

TransactionBase Class
TransactionBase Members


TransactionBase.Post Method

[image]

Pastel Evolution SDK
TransactionBase..::..Post Method
TransactionBase Class See Also Send Feedback
Posts the transaction to appropriate ledgers.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool Post()
Visual Basic
Public Function Post As Boolean

Return Value

Type: Boolean

See Also

TransactionBase Class
TransactionBase Members


TransactionBase.RejectTransactionBranchAssignment Method

[image]

Pastel Evolution SDK
TransactionBase..::..RejectTransactionBranchAssignment Method
TransactionBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected void RejectTransactionBranchAssignment()
Visual Basic
Protected Sub RejectTransactionBranchAssignment

See Also

TransactionBase Class
TransactionBase Members


TransactionBase.Validate Method

[image]

Pastel Evolution SDK
TransactionBase..::..Validate Method
TransactionBase Class See Also Send Feedback
Validates the transaction.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public virtual bool Validate()
Visual Basic
Public Overridable Function Validate As Boolean

Return Value

Type: Boolean
The Validate.

See Also

TransactionBase Class
TransactionBase Members


TransactionBase Properties

[image] [image]

Pastel Evolution SDK
TransactionBase Properties
TransactionBase Class See Also Send Feedback

The TransactionBase type exposes the following members.

Properties

 | Name | Description
Public property | Account | Gets or sets the transaction's account.
Public property | AccountID | Gets or sets the transaction's account id.
Public property | Audit | Gets the transaction's audit number.
Public property | Branch |
Public property | BranchID |
Public property | Credit | Gets or sets the transaction's credit value.
Public property | Date | Gets or sets the transaction date.
Public property | Debit | Gets or sets the transaction's debit value.
Public property | Description | Gets or sets the transaction description.
Public property | ExtOrderNo | Gets or sets the transaction's external order number.
Public property | ID | Gets the transaction id.
Public property | ModID | Gets or sets the transaction's Evolution module ID.
Public property | Module | Gets the transaction's Evolution module.
Public property | OrderNo | Gets or sets the transaction's order number.
Public property | Project | Sets the transaction's project.
Public property | ProjectID | Gets or sets the transaction's project id.
Public property | Reference | Gets or sets the transaction reference.
Public property | Reference2 | Gets or sets the 2nd transaction reference.
Public property | Tax | Gets or sets the transaction tax amount.
Public property | TaxRate | Gets or sets the transaction's tax type.
Public property | TaxRateID | Gets or sets the transaction's tax type id.
Public property | TransactionCode | Gets or sets the transaction's transaction code.
Public property | TransactionCodeID | Gets or sets the transaction code id.

See Also

TransactionBase Class


TransactionBase.Account Property

[image]

Pastel Evolution SDK
TransactionBase..::..Account Property
TransactionBase Class See Also Send Feedback
Gets or sets the transaction's account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract AccountBase Account { get; set; }
Visual Basic
Public MustOverride Property Account As AccountBase
    Get
    Set

Property Value

Type: AccountBase

See Also

TransactionBase Class
TransactionBase Members


TransactionBase.AccountID Property

[image]

Pastel Evolution SDK
TransactionBase..::..AccountID Property
TransactionBase Class See Also Send Feedback
Gets or sets the transaction's account id.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract int AccountID { get; set; }
Visual Basic
Public MustOverride Property AccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

TransactionBase Class
TransactionBase Members


TransactionBase.Audit Property

[image]

Pastel Evolution SDK
TransactionBase..::..Audit Property
TransactionBase Class See Also Send Feedback
Gets the transaction's audit number.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract string Audit { get; }
Visual Basic
Public MustOverride ReadOnly Property Audit As String
    Get

Property Value

Type: String

Remarks

The audit number is 0 when unposted. After posting, it will reflect the transaction's posted audit number.

See Also

TransactionBase Class
TransactionBase Members


TransactionBase.Branch Property

[image]

Pastel Evolution SDK
TransactionBase..::..Branch Property
TransactionBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract Branch Branch { get; set; }
Visual Basic
Public MustOverride Property Branch As Branch
    Get
    Set

Property Value

Type: Branch

Implements

IBranched..::..Branch

See Also

TransactionBase Class
TransactionBase Members


TransactionBase.BranchID Property

[image]

Pastel Evolution SDK
TransactionBase..::..BranchID Property
TransactionBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract int BranchID { get; internal set; }
Visual Basic
Public MustOverride Property BranchID As Integer
    Get
    Friend Set

Property Value

Type: Int32

Implements

IBranched..::..BranchID

See Also

TransactionBase Class
TransactionBase Members


TransactionBase.Credit Property

[image]

Pastel Evolution SDK
TransactionBase..::..Credit Property
TransactionBase Class See Also Send Feedback
Gets or sets the transaction's credit value.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract double Credit { get; set; }
Visual Basic
Public MustOverride Property Credit As Double
    Get
    Set

Property Value

Type: Double

See Also

TransactionBase Class
TransactionBase Members


TransactionBase.Date Property

[image]

Pastel Evolution SDK
TransactionBase..::..Date Property
TransactionBase Class See Also Send Feedback
Gets or sets the transaction date.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract DateTime Date { get; set; }
Visual Basic
Public MustOverride Property Date As DateTime
    Get
    Set

Property Value

Type: DateTime

See Also

TransactionBase Class
TransactionBase Members


TransactionBase.Debit Property

[image]

Pastel Evolution SDK
TransactionBase..::..Debit Property
TransactionBase Class See Also Send Feedback
Gets or sets the transaction's debit value.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract double Debit { get; set; }
Visual Basic
Public MustOverride Property Debit As Double
    Get
    Set

Property Value

Type: Double

See Also

TransactionBase Class
TransactionBase Members


TransactionBase.Description Property

[image]

Pastel Evolution SDK
TransactionBase..::..Description Property
TransactionBase Class See Also Send Feedback
Gets or sets the transaction description.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract string Description { get; set; }
Visual Basic
Public MustOverride Property Description As String
    Get
    Set

Property Value

Type: String

See Also

TransactionBase Class
TransactionBase Members


TransactionBase.ExtOrderNo Property

[image]

Pastel Evolution SDK
TransactionBase..::..ExtOrderNo Property
TransactionBase Class See Also Send Feedback
Gets or sets the transaction's external order number.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract string ExtOrderNo { get; set; }
Visual Basic
Public MustOverride Property ExtOrderNo As String
    Get
    Set

Property Value

Type: String

See Also

TransactionBase Class
TransactionBase Members


TransactionBase.ID Property

[image]

Pastel Evolution SDK
TransactionBase..::..ID Property
TransactionBase Class See Also Send Feedback
Gets the transaction id.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract long ID { get; }
Visual Basic
Public MustOverride ReadOnly Property ID As Long
    Get

Property Value

Type: Int64

Remarks

The ID is 0 when unposted; once posted, it will reflect the transaction's internal database ID.

See Also

TransactionBase Class
TransactionBase Members


TransactionBase.ModID Property

[image]

Pastel Evolution SDK
TransactionBase..::..ModID Property
TransactionBase Class See Also Send Feedback
Gets or sets the transaction's Evolution module ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract ModuleID ModID { get; set; }
Visual Basic
Public MustOverride Property ModID As ModuleID
    Get
    Set

Property Value

Type: ModuleID

See Also

TransactionBase Class
TransactionBase Members


TransactionBase.Module Property

[image]

Pastel Evolution SDK
TransactionBase..::..Module Property
TransactionBase Class See Also Send Feedback
Gets the transaction's Evolution module.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract Module Module { get; }
Visual Basic
Public MustOverride ReadOnly Property Module As Module
    Get

Property Value

Type: Module

See Also

TransactionBase Class
TransactionBase Members


TransactionBase.OrderNo Property

[image]

Pastel Evolution SDK
TransactionBase..::..OrderNo Property
TransactionBase Class See Also Send Feedback
Gets or sets the transaction's order number.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract string OrderNo { get; set; }
Visual Basic
Public MustOverride Property OrderNo As String
    Get
    Set

Property Value

Type: String

See Also

TransactionBase Class
TransactionBase Members


TransactionBase.Project Property

[image]

Pastel Evolution SDK
TransactionBase..::..Project Property
TransactionBase Class See Also Send Feedback
Sets the transaction's project.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract Project Project { get; set; }
Visual Basic
Public MustOverride Property Project As Project
    Get
    Set

Property Value

Type: Project

See Also

TransactionBase Class
TransactionBase Members


TransactionBase.ProjectID Property

[image]

Pastel Evolution SDK
TransactionBase..::..ProjectID Property
TransactionBase Class See Also Send Feedback
Gets or sets the transaction's project id.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract int ProjectID { get; set; }
Visual Basic
Public MustOverride Property ProjectID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

TransactionBase Class
TransactionBase Members


TransactionBase.Reference Property

[image]

Pastel Evolution SDK
TransactionBase..::..Reference Property
TransactionBase Class See Also Send Feedback
Gets or sets the transaction reference.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract string Reference { get; set; }
Visual Basic
Public MustOverride Property Reference As String
    Get
    Set

Property Value

Type: String

See Also

TransactionBase Class
TransactionBase Members


TransactionBase.Reference2 Property

[image]

Pastel Evolution SDK
TransactionBase..::..Reference2 Property
TransactionBase Class See Also Send Feedback
Gets or sets the 2nd transaction reference.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract string Reference2 { get; set; }
Visual Basic
Public MustOverride Property Reference2 As String
    Get
    Set

Property Value

Type: String

See Also

TransactionBase Class
TransactionBase Members


TransactionBase.Tax Property

[image]

Pastel Evolution SDK
TransactionBase..::..Tax Property
TransactionBase Class See Also Send Feedback
Gets or sets the transaction tax amount.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract double Tax { get; set; }
Visual Basic
Public MustOverride Property Tax As Double
    Get
    Set

Property Value

Type: Double

See Also

TransactionBase Class
TransactionBase Members


TransactionBase.TaxRate Property

[image]

Pastel Evolution SDK
TransactionBase..::..TaxRate Property
TransactionBase Class See Also Send Feedback
Gets or sets the transaction's tax type.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract TaxRate TaxRate { get; set; }
Visual Basic
Public MustOverride Property TaxRate As TaxRate
    Get
    Set

Property Value

Type: TaxRate

See Also

TransactionBase Class
TransactionBase Members


TransactionBase.TaxRateID Property

[image]

Pastel Evolution SDK
TransactionBase..::..TaxRateID Property
TransactionBase Class See Also Send Feedback
Gets or sets the transaction's tax type id.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract int TaxRateID { get; set; }
Visual Basic
Public MustOverride Property TaxRateID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

TransactionBase Class
TransactionBase Members


TransactionBase.TransactionCode Property

[image]

Pastel Evolution SDK
TransactionBase..::..TransactionCode Property
TransactionBase Class See Also Send Feedback
Gets or sets the transaction's transaction code.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract TransactionCodeBase TransactionCode { get; set; }
Visual Basic
Public MustOverride Property TransactionCode As TransactionCodeBase
    Get
    Set

Property Value

Type: TransactionCodeBase

See Also

TransactionBase Class
TransactionBase Members


TransactionBase.TransactionCodeID Property

[image]

Pastel Evolution SDK
TransactionBase..::..TransactionCodeID Property
TransactionBase Class See Also Send Feedback
Gets or sets the transaction code id.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract int TransactionCodeID { get; set; }
Visual Basic
Public MustOverride Property TransactionCodeID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

TransactionBase Class
TransactionBase Members


TransactionBase Events

[image] [image]

Pastel Evolution SDK
TransactionBase Events
TransactionBase Class See Also Send Feedback

The TransactionBase type exposes the following members.

Events

 | Name | Description
Public event | GLCreditPosting |
Public event | GLDebitPosting |
Public event | GLVatPosting |

See Also

TransactionBase Class


TransactionBase.GLCreditPosting Event

[image]

Pastel Evolution SDK
TransactionBase..::..GLCreditPosting Event
TransactionBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public event TransactionBase..::..GLPostingEventHandler GLCreditPosting
Visual Basic
Public Event GLCreditPosting As TransactionBase..::..GLPostingEventHandler

Value

Type: Pastel.Evolution..::..TransactionBase..::..GLPostingEventHandler

See Also

TransactionBase Class
TransactionBase Members


TransactionBase.GLDebitPosting Event

[image]

Pastel Evolution SDK
TransactionBase..::..GLDebitPosting Event
TransactionBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public event TransactionBase..::..GLPostingEventHandler GLDebitPosting
Visual Basic
Public Event GLDebitPosting As TransactionBase..::..GLPostingEventHandler

Value

Type: Pastel.Evolution..::..TransactionBase..::..GLPostingEventHandler

See Also

TransactionBase Class
TransactionBase Members


TransactionBase.GLVatPosting Event

[image]

Pastel Evolution SDK
TransactionBase..::..GLVatPosting Event
TransactionBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public event TransactionBase..::..GLPostingEventHandler GLVatPosting
Visual Basic
Public Event GLVatPosting As TransactionBase..::..GLPostingEventHandler

Value

Type: Pastel.Evolution..::..TransactionBase..::..GLPostingEventHandler

See Also

TransactionBase Class
TransactionBase Members


TransactionBase.AllocationEntry Class

[image]

Pastel Evolution SDK
TransactionBase..::..AllocationEntry Class
TransactionBase Class Members See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
[ObsoleteAttribute("Use Pastel.Evolution.AllocationEntry instead.")]
public class AllocationEntry : AllocationEntry
Visual Basic
<ObsoleteAttribute("Use Pastel.Evolution.AllocationEntry instead.")>
Public Class AllocationEntry
    Inherits AllocationEntry

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..AllocationEntry
Pastel.Evolution..::..TransactionBase..::..AllocationEntry

See Also

TransactionBase..::..AllocationEntry Members


TransactionBase.AllocationEntry Members

[image] [image]

Pastel Evolution SDK
TransactionBase..::..AllocationEntry Members
TransactionBase..::..AllocationEntry Class Constructors Methods Properties See Also Send Feedback

The TransactionBase..::..AllocationEntry type exposes the following members.

Constructors

 | Name | Description
Public method | TransactionBase..::..AllocationEntry | Initializes a new instance of the TransactionBase..::..AllocationEntry class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AllowRemove | (Inherited from AllocationEntry.)
Public property | Amount | Gets the allocation value. (Inherited from AllocationEntry.)
Public property | BalancingDescription | (Inherited from AllocationEntry.)
Public property | BalancingReference | (Inherited from AllocationEntry.)
Public property | BalancingTransaction | Represents the balancing transaction linked to this allocation. After saving of allocations, it will exist on whichever transaction it relates to and not necessarily the current allocation collection. (Inherited from AllocationEntry.)
Public property | BalancingTransactionID | Gets the ID of the balancing transaction. (Inherited from AllocationEntry.)
Public property | Date | Gets the allocation date. (Inherited from AllocationEntry.)
Public property | ForeignAmount | Gets the foreign allocation value. (Inherited from AllocationEntry.)
Public property | Transaction | Gets the allocated transaction. (Inherited from AllocationEntry.)
Public property | TransactionID | Gets the ID of the allocated transaction. (Inherited from AllocationEntry.)

See Also

TransactionBase..::..AllocationEntry Class


TransactionBase.AllocationEntry Constructor

[image]

Pastel Evolution SDK
TransactionBase..::..AllocationEntry Constructor
TransactionBase..::..AllocationEntry Class See Also Send Feedback
Initializes a new instance of the TransactionBase..::..AllocationEntry class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public AllocationEntry()
Visual Basic
Public Sub New

See Also

TransactionBase..::..AllocationEntry Class
TransactionBase..::..AllocationEntry Members


TransactionBase.AllocationEntry Methods

[image] [image]

Pastel Evolution SDK
TransactionBase..::..AllocationEntry Methods
TransactionBase..::..AllocationEntry Class See Also Send Feedback

The TransactionBase..::..AllocationEntry type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TransactionBase..::..AllocationEntry Class


TransactionBase.AllocationEntry Properties

[image] [image]

Pastel Evolution SDK
TransactionBase..::..AllocationEntry Properties
TransactionBase..::..AllocationEntry Class See Also Send Feedback

The TransactionBase..::..AllocationEntry type exposes the following members.

Properties

 | Name | Description
Public property | AllowRemove | (Inherited from AllocationEntry.)
Public property | Amount | Gets the allocation value. (Inherited from AllocationEntry.)
Public property | BalancingDescription | (Inherited from AllocationEntry.)
Public property | BalancingReference | (Inherited from AllocationEntry.)
Public property | BalancingTransaction | Represents the balancing transaction linked to this allocation. After saving of allocations, it will exist on whichever transaction it relates to and not necessarily the current allocation collection. (Inherited from AllocationEntry.)
Public property | BalancingTransactionID | Gets the ID of the balancing transaction. (Inherited from AllocationEntry.)
Public property | Date | Gets the allocation date. (Inherited from AllocationEntry.)
Public property | ForeignAmount | Gets the foreign allocation value. (Inherited from AllocationEntry.)
Public property | Transaction | Gets the allocated transaction. (Inherited from AllocationEntry.)
Public property | TransactionID | Gets the ID of the allocated transaction. (Inherited from AllocationEntry.)

See Also

TransactionBase..::..AllocationEntry Class


TransactionBase.GLPostingEventArgs Class

[image]

Pastel Evolution SDK
TransactionBase..::..GLPostingEventArgs Class
TransactionBase Class Members See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class GLPostingEventArgs : EventArgs
Visual Basic
Public Class GLPostingEventArgs
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Pastel.Evolution..::..TransactionBase..::..GLPostingEventArgs

See Also

TransactionBase..::..GLPostingEventArgs Members


TransactionBase.GLPostingEventArgs Members

[image] [image]

Pastel Evolution SDK
TransactionBase..::..GLPostingEventArgs Members
TransactionBase..::..GLPostingEventArgs Class Constructors Methods Properties See Also Send Feedback

The TransactionBase..::..GLPostingEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | TransactionBase..::..GLPostingEventArgs | Initializes a new instance of the TransactionBase..::..GLPostingEventArgs class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | GLTransaction |
Public property | Posted |

See Also

TransactionBase..::..GLPostingEventArgs Class


TransactionBase.GLPostingEventArgs Constructor

[image]

Pastel Evolution SDK
TransactionBase..::..GLPostingEventArgs Constructor
TransactionBase..::..GLPostingEventArgs Class See Also Send Feedback
Initializes a new instance of the TransactionBase..::..GLPostingEventArgs class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLPostingEventArgs(
    GLTransaction tran
)
Visual Basic
Public Sub New (
    tran As GLTransaction
)

Parameters

tran
Type: Pastel.Evolution..::..GLTransaction

See Also

TransactionBase..::..GLPostingEventArgs Class
TransactionBase..::..GLPostingEventArgs Members


TransactionBase.GLPostingEventArgs Methods

[image] [image]

Pastel Evolution SDK
TransactionBase..::..GLPostingEventArgs Methods
TransactionBase..::..GLPostingEventArgs Class See Also Send Feedback

The TransactionBase..::..GLPostingEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TransactionBase..::..GLPostingEventArgs Class


TransactionBase.GLPostingEventArgs Properties

[image] [image]

Pastel Evolution SDK
TransactionBase..::..GLPostingEventArgs Properties
TransactionBase..::..GLPostingEventArgs Class See Also Send Feedback

The TransactionBase..::..GLPostingEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | GLTransaction |
Public property | Posted |

See Also

TransactionBase..::..GLPostingEventArgs Class


TransactionBase.GLPostingEventArgs.GLTransaction Property

[image]

Pastel Evolution SDK
TransactionBase..::..GLPostingEventArgs..::..GLTransaction Property
TransactionBase..::..GLPostingEventArgs Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLTransaction GLTransaction { get; set; }
Visual Basic
Public Property GLTransaction As GLTransaction
    Get
    Set

Property Value

Type: GLTransaction

See Also

TransactionBase..::..GLPostingEventArgs Class
TransactionBase..::..GLPostingEventArgs Members


TransactionBase.GLPostingEventArgs.Posted Property

[image]

Pastel Evolution SDK
TransactionBase..::..GLPostingEventArgs..::..Posted Property
TransactionBase..::..GLPostingEventArgs Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool Posted { get; set; }
Visual Basic
Public Property Posted As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

TransactionBase..::..GLPostingEventArgs Class
TransactionBase..::..GLPostingEventArgs Members


TransactionBase.GLPostingEventHandler Delegate

[image]

Pastel Evolution SDK
TransactionBase..::..GLPostingEventHandler Delegate
TransactionBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public delegate void GLPostingEventHandler(
    TransactionBase sender,
    TransactionBase..::..GLPostingEventArgs e
)
Visual Basic
Public Delegate Sub GLPostingEventHandler (
    sender As TransactionBase,
    e As TransactionBase..::..GLPostingEventArgs
)

Parameters

sender
Type: Pastel.Evolution..::..TransactionBase
e
Type: Pastel.Evolution..::..TransactionBase..::..GLPostingEventArgs

See Also

Pastel.Evolution Namespace


TransactionBase.SplitAllocation Class

[image]

Pastel Evolution SDK
TransactionBase..::..SplitAllocation Class
TransactionBase Class Members See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
[ObsoleteAttribute("Use Pastel.Evolution.SplitAllocation instead.")]
public class SplitAllocation : SplitAllocation
Visual Basic
<ObsoleteAttribute("Use Pastel.Evolution.SplitAllocation instead.")>
Public Class SplitAllocation
    Inherits SplitAllocation

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..SplitAllocation
Pastel.Evolution..::..TransactionBase..::..SplitAllocation

See Also

TransactionBase..::..SplitAllocation Members


TransactionBase.SplitAllocation Members

[image] [image]

Pastel Evolution SDK
TransactionBase..::..SplitAllocation Members
TransactionBase..::..SplitAllocation Class Constructors Methods Properties See Also Send Feedback

The TransactionBase..::..SplitAllocation type exposes the following members.

Constructors

 | Name | Description
Public method | TransactionBase..::..SplitAllocation | Initializes a new instance of the TransactionBase..::..SplitAllocation class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Account | Gets or sets the GL account to post to. (Inherited from SplitAllocation.)
Public property | Amount | Gets or sets the value of this split allocation. Note that the Amount and Foreign amount properties are mutually exclusive. Setting one value will zero the other. (Inherited from SplitAllocation.)
Public property | Description | (Inherited from SplitAllocation.)
Public property | ForeignAmount | Gets or sets the foreign value of this split allocation. Note that the Amount and Foreign amount properties are mutually exclusive. Setting one value will zero the other. (Inherited from SplitAllocation.)
Public property | Project | (Inherited from SplitAllocation.)

See Also

TransactionBase..::..SplitAllocation Class


TransactionBase.SplitAllocation Constructor

[image]

Pastel Evolution SDK
TransactionBase..::..SplitAllocation Constructor
TransactionBase..::..SplitAllocation Class See Also Send Feedback
Initializes a new instance of the TransactionBase..::..SplitAllocation class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public SplitAllocation()
Visual Basic
Public Sub New

See Also

TransactionBase..::..SplitAllocation Class
TransactionBase..::..SplitAllocation Members


TransactionBase.SplitAllocation Methods

[image] [image]

Pastel Evolution SDK
TransactionBase..::..SplitAllocation Methods
TransactionBase..::..SplitAllocation Class See Also Send Feedback

The TransactionBase..::..SplitAllocation type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TransactionBase..::..SplitAllocation Class


TransactionBase.SplitAllocation Properties

[image] [image]

Pastel Evolution SDK
TransactionBase..::..SplitAllocation Properties
TransactionBase..::..SplitAllocation Class See Also Send Feedback

The TransactionBase..::..SplitAllocation type exposes the following members.

Properties

 | Name | Description
Public property | Account | Gets or sets the GL account to post to. (Inherited from SplitAllocation.)
Public property | Amount | Gets or sets the value of this split allocation. Note that the Amount and Foreign amount properties are mutually exclusive. Setting one value will zero the other. (Inherited from SplitAllocation.)
Public property | Description | (Inherited from SplitAllocation.)
Public property | ForeignAmount | Gets or sets the foreign value of this split allocation. Note that the Amount and Foreign amount properties are mutually exclusive. Setting one value will zero the other. (Inherited from SplitAllocation.)
Public property | Project | (Inherited from SplitAllocation.)

See Also

TransactionBase..::..SplitAllocation Class


TransactionCode Class

[image]

Pastel Evolution SDK
TransactionCode Class
Members See Also Send Feedback
Represents an Evolution transaction code. Transaction codes dictate the nature (debit/credit) of a transaction as well as the GL accounts to post to.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class TransactionCode : TransactionCodeBase
Visual Basic
Public Class TransactionCode
    Inherits TransactionCodeBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..TransactionCodeBase
Pastel.Evolution..::..TransactionCode

See Also

TransactionCode Members


TransactionCode Members

[image] [image]

Pastel Evolution SDK
TransactionCode Members
TransactionCode Class Constructors Methods Fields Properties See Also Send Feedback

The TransactionCode type exposes the following members.

Constructors

 | Name | Description
Public method | TransactionCode()()()() | Creates a new instance of a transaction code.
Public method | TransactionCode(Int32) | Creates a new instance of a transaction code.
Public method | TransactionCode(Module, String) | Creates a new instance of a transaction code.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find(String) | Finds a record's database ID.
 | Find(String, Module) | Finds a record's database ID.
Public method | Find(Module, String) | Executes the Find method.
 | FindByCode | Finds the database ID of a record matching the specified code.
 | Get | Returns an instance of the first record satisfying the criteria specified; otherwise, returns null.
 | GetByCode | Returns a transaction type object corresponding to the code specified; otherwise, returns null.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List(String) | Gets a list of database records.
 | List(String, Module) | Executes the List method.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records.Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | reversed | (Inherited from TransactionCodeBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | Account1ID | Gets or sets the transaction code's account1 id.
Public property | Account2ID | Gets or sets the transaction code's account2 id.
Public property | AllowSubAccTrans | Gets or sets whether transactions to sub accounts (linked debtor accounts) are allowed when using this transaction code.
Public property | AsTransactionCode | Gets the basic transaction code object (of type TransactionCodeBase), cast as a proper TransactionCode object. (Inherited from TransactionCodeBase.)
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Code | Gets or sets the transaction code's code. (Overrides TransactionCodeBase..::..Code.)
Public property | CreditAccount | Gets the transaction code's credit GL account.
Public property | CreditAccountID | Gets the transaction code's credit GL account id.
Public property | DebitAccount | Gets the transaction code's debit GL account.
Public property | DebitAccountID | Gets the transaction code's debit GL account id.
Public property | Description | Gets or sets the transaction code's description. (Overrides TransactionCodeBase..::..Description.)
Public property | GLPrompt | Gets or sets whether or not to prompt for a GL account.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | IsDebitTrans | Gets or sets whether this transaction code is a debit transaction type.
Public property | LinkedTrCode | Gets the transaction code's linked transaction code.
Public property | LinkedTrCodeID | Gets the transaction code's linked transaction code ID.
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | Module | Gets or sets the transaction code's Evolution module.
Public property | Rep | Gets or sets the transaction code's default representative.
Protected property | Reversed | (Overrides TransactionCodeBase..::..Reversed.)
Public property | SalesFilter | Gets or sets whether this transaction is a "sales" transaction code.
Public property | Taxable | Gets or sets the transaction code's taxable status.
Public property | TaxAccountID | Gets or sets the transaction code's tax account id.
Public property | TaxRateID | Gets or sets the transaction code's default tax type id.

See Also

TransactionCode Class


TransactionCode Constructor

[image] [image]

Pastel Evolution SDK
TransactionCode Constructor
TransactionCode Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TransactionCode()()()() | Creates a new instance of a transaction code.
Public method | TransactionCode(Int32) | Creates a new instance of a transaction code.
Public method | TransactionCode(Module, String) | Creates a new instance of a transaction code.

See Also

TransactionCode Class
TransactionCode Members


TransactionCode Constructor

[image]

Pastel Evolution SDK
TransactionCode Constructor
TransactionCode Class See Also Send Feedback
Creates a new instance of a transaction code.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public TransactionCode()
Visual Basic
Public Sub New

See Also

TransactionCode Class
TransactionCode Members
TransactionCode Overload


TransactionCode Constructor (Int32)

[image]

Pastel Evolution SDK
TransactionCode Constructor (Int32)
TransactionCode Class See Also Send Feedback
Creates a new instance of a transaction code.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public TransactionCode(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32
Specifies the id of the existing record.

See Also

TransactionCode Class
TransactionCode Members
TransactionCode Overload


TransactionCode Constructor (Module, String)

[image]

Pastel Evolution SDK
TransactionCode Constructor (Module, String)
TransactionCode Class See Also Send Feedback
Creates a new instance of a transaction code.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public TransactionCode(
    Module module,
    string code
)
Visual Basic
Public Sub New (
    module As Module,
    code As String
)

Parameters

module
Type: Pastel.Evolution..::..Module
Specifies the module of the existing record.
code
Type: System..::..String
Specifies the code of the existing record.

See Also

TransactionCode Class
TransactionCode Members
TransactionCode Overload


TransactionCode Fields

[image] [image]

Pastel Evolution SDK
TransactionCode Fields
TransactionCode Class See Also Send Feedback

The TransactionCode type exposes the following members.

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | reversed | (Inherited from TransactionCodeBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

TransactionCode Class


TransactionCode Methods

[image] [image]

Pastel Evolution SDK
TransactionCode Methods
TransactionCode Class See Also Send Feedback

The TransactionCode type exposes the following members.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find(String) | Finds a record's database ID.
 | Find(String, Module) | Finds a record's database ID.
Public method | Find(Module, String) | Executes the Find method.
 | FindByCode | Finds the database ID of a record matching the specified code.
 | Get | Returns an instance of the first record satisfying the criteria specified; otherwise, returns null.
 | GetByCode | Returns a transaction type object corresponding to the code specified; otherwise, returns null.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List(String) | Gets a list of database records.
 | List(String, Module) | Executes the List method.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records.Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

TransactionCode Class


TransactionCode.Find Method

[image] [image]

Pastel Evolution SDK
TransactionCode..::..Find Method
TransactionCode Class See Also Send Feedback

Overload List

 | Name | Description
 | Find(String) | Finds a record's database ID.
 | Find(String, Module) | Finds a record's database ID.
Public method | Find(Module, String) | Executes the Find method.

See Also

TransactionCode Class
TransactionCode Members


TransactionCode.Find Method (String)

[image]

Pastel Evolution SDK
TransactionCode..::..Find Method (String)
TransactionCode Class See Also Send Feedback
Finds a record's database ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.

Return Value

Type: Int32
The ID of the first record found; -1 if not record was found.

Remarks

WARNING: be sure to filter on both code andmodule when using this method since some transaction type codes are duplicated between modules. Using the alternative overloaded find method is highly recommended.

See Also

TransactionCode Class
TransactionCode Members
Find Overload
Pastel.Evolution Namespace
TransactionCode..::..Find(String, Module)


TransactionCode.Find Method (String, Module)

[image]

Pastel Evolution SDK
TransactionCode..::..Find Method (String, Module)
TransactionCode Class See Also Send Feedback
Finds a record's database ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria,
    Module module
)
Visual Basic
Public Shared Function Find (
    criteria As String,
    module As Module
) As Integer

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.
module
Type: Pastel.Evolution..::..Module
Specifies the module.

Return Value

Type: Int32
The Find.

See Also

TransactionCode Class
TransactionCode Members
Find Overload
Pastel.Evolution Namespace
TransactionCode..::..Find(String)


TransactionCode.Find Method (Module, String)

[image]

Pastel Evolution SDK
TransactionCode..::..Find Method (Module, String)
TransactionCode Class See Also Send Feedback
Executes the Find method.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int Find(
    Module module,
    string criteria
)
Visual Basic
Public Function Find (
    module As Module,
    criteria As String
) As Integer

Parameters

module
Type: Pastel.Evolution..::..Module
Specifies the module.
criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.

Return Value

Type: Int32
The Find.

See Also

TransactionCode Class
TransactionCode Members
Find Overload


TransactionCode.FindByCode Method

[image]

Pastel Evolution SDK
TransactionCode..::..FindByCode Method
TransactionCode Class See Also Send Feedback
Finds the database ID of a record matching the specified code.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int FindByCode(
    string code,
    Module module
)
Visual Basic
Public Shared Function FindByCode (
    code As String,
    module As Module
) As Integer

Parameters

code
Type: System..::..String
Specifies the code.
module
Type: Pastel.Evolution..::..Module
Specifies the module.

Return Value

Type: Int32
The ID of the first record found; -1 if not record was found.

See Also

TransactionCode Class
TransactionCode Members


TransactionCode.Get Method

[image]

Pastel Evolution SDK
TransactionCode..::..Get Method
TransactionCode Class See Also Send Feedback
Returns an instance of the first record satisfying the criteria specified; otherwise, returns null.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static TransactionCode Get(
    string criteria,
    Module module
)
Visual Basic
Public Shared Function Get (
    criteria As String,
    module As Module
) As TransactionCode

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.
module
Type: Pastel.Evolution..::..Module
Specifies the module.

Return Value

Type: TransactionCode
The record found; otherwise null

See Also

TransactionCode Class
TransactionCode Members
Pastel.Evolution Namespace
TransactionCode..::..Find(String)
TransactionCode..::..GetByCode(String, Module)


TransactionCode.GetByCode Method

[image]

Pastel Evolution SDK
TransactionCode..::..GetByCode Method
TransactionCode Class See Also Send Feedback
Returns a transaction type object corresponding to the code specified; otherwise, returns null.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static TransactionCode GetByCode(
    string code,
    Module module
)
Visual Basic
Public Shared Function GetByCode (
    code As String,
    module As Module
) As TransactionCode

Parameters

code
Type: System..::..String
Specifies the code.
module
Type: Pastel.Evolution..::..Module
Specifies the module.

Return Value

Type: TransactionCode
The ByCode.

See Also

TransactionCode Class
TransactionCode Members


TransactionCode.List Method

[image] [image]

Pastel Evolution SDK
TransactionCode..::..List Method
TransactionCode Class See Also Send Feedback

Overload List

Name | Description
List(String) | Gets a list of database records.
List(String, Module) | Executes the List method.

See Also

TransactionCode Class
TransactionCode Members


TransactionCode.List Method (String)

[image]

Pastel Evolution SDK
TransactionCode..::..List Method (String)
TransactionCode Class See Also Send Feedback
Gets a list of database records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria
)
Visual Basic
Public Shared Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.

Return Value

Type: DataTable
Table containing selected records.

See Also

TransactionCode Class
TransactionCode Members
List Overload


TransactionCode.List Method (String, Module)

[image]

Pastel Evolution SDK
TransactionCode..::..List Method (String, Module)
TransactionCode Class See Also Send Feedback
Executes the List method.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria,
    Module module
)
Visual Basic
Public Shared Function List (
    criteria As String,
    module As Module
) As DataTable

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.
module
Type: Pastel.Evolution..::..Module
Specifies the module.

Return Value

Type: DataTable
The List.

See Also

TransactionCode Class
TransactionCode Members
List Overload


TransactionCode.OnDelete Method

[image]

Pastel Evolution SDK
TransactionCode..::..OnDelete Method
TransactionCode Class See Also Send Feedback
Removes the record from the database, provided it is not referenced by other records.Removes the record from the database, provided it is not referenced by other records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

See Also

TransactionCode Class
TransactionCode Members


TransactionCode.OnSave Method

[image]

Pastel Evolution SDK
TransactionCode..::..OnSave Method
TransactionCode Class See Also Send Feedback
Persists the record to the database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

TransactionCode Class
TransactionCode Members


TransactionCode Properties

[image] [image]

Pastel Evolution SDK
TransactionCode Properties
TransactionCode Class See Also Send Feedback

The TransactionCode type exposes the following members.

Properties

 | Name | Description
Public property | Account1ID | Gets or sets the transaction code's account1 id.
Public property | Account2ID | Gets or sets the transaction code's account2 id.
Public property | AllowSubAccTrans | Gets or sets whether transactions to sub accounts (linked debtor accounts) are allowed when using this transaction code.
Public property | AsTransactionCode | Gets the basic transaction code object (of type TransactionCodeBase), cast as a proper TransactionCode object. (Inherited from TransactionCodeBase.)
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Code | Gets or sets the transaction code's code. (Overrides TransactionCodeBase..::..Code.)
Public property | CreditAccount | Gets the transaction code's credit GL account.
Public property | CreditAccountID | Gets the transaction code's credit GL account id.
Public property | DebitAccount | Gets the transaction code's debit GL account.
Public property | DebitAccountID | Gets the transaction code's debit GL account id.
Public property | Description | Gets or sets the transaction code's description. (Overrides TransactionCodeBase..::..Description.)
Public property | GLPrompt | Gets or sets whether or not to prompt for a GL account.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | IsDebitTrans | Gets or sets whether this transaction code is a debit transaction type.
Public property | LinkedTrCode | Gets the transaction code's linked transaction code.
Public property | LinkedTrCodeID | Gets the transaction code's linked transaction code ID.
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | Module | Gets or sets the transaction code's Evolution module.
Public property | Rep | Gets or sets the transaction code's default representative.
Protected property | Reversed | (Overrides TransactionCodeBase..::..Reversed.)
Public property | SalesFilter | Gets or sets whether this transaction is a "sales" transaction code.
Public property | Taxable | Gets or sets the transaction code's taxable status.
Public property | TaxAccountID | Gets or sets the transaction code's tax account id.
Public property | TaxRateID | Gets or sets the transaction code's default tax type id.

See Also

TransactionCode Class


TransactionCode.Account1ID Property

[image]

Pastel Evolution SDK
TransactionCode..::..Account1ID Property
TransactionCode Class See Also Send Feedback
Gets or sets the transaction code's account1 id.
Gets or sets the transaction code's account1 id.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int Account1ID { get; set; }
Visual Basic
Public Property Account1ID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

TransactionCode Class
TransactionCode Members


TransactionCode.Account2ID Property

[image]

Pastel Evolution SDK
TransactionCode..::..Account2ID Property
TransactionCode Class See Also Send Feedback
Gets or sets the transaction code's account2 id.
Gets or sets the transaction code's account2 id.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int Account2ID { get; set; }
Visual Basic
Public Property Account2ID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

TransactionCode Class
TransactionCode Members


TransactionCode.AllowSubAccTrans Property

[image]

Pastel Evolution SDK
TransactionCode..::..AllowSubAccTrans Property
TransactionCode Class See Also Send Feedback
Gets or sets whether transactions to sub accounts (linked debtor accounts) are allowed when using this transaction code.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool AllowSubAccTrans { get; set; }
Visual Basic
Public Property AllowSubAccTrans As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

TransactionCode Class
TransactionCode Members


TransactionCode.Code Property

[image]

Pastel Evolution SDK
TransactionCode..::..Code Property
TransactionCode Class See Also Send Feedback
Gets or sets the transaction code's code.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override string Code { get; set; }
Visual Basic
Public Overrides Property Code As String
    Get
    Set

Property Value

Type: String

See Also

TransactionCode Class
TransactionCode Members


TransactionCode.CreditAccount Property

[image]

Pastel Evolution SDK
TransactionCode..::..CreditAccount Property
TransactionCode Class See Also Send Feedback
Gets the transaction code's credit GL account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLAccount CreditAccount { get; }
Visual Basic
Public ReadOnly Property CreditAccount As GLAccount
    Get

Property Value

Type: GLAccount

See Also

TransactionCode Class
TransactionCode Members


TransactionCode.CreditAccountID Property

[image]

Pastel Evolution SDK
TransactionCode..::..CreditAccountID Property
TransactionCode Class See Also Send Feedback
Gets the transaction code's credit GL account id.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int CreditAccountID { get; set; }
Visual Basic
Public Property CreditAccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

TransactionCode Class
TransactionCode Members


TransactionCode.DebitAccount Property

[image]

Pastel Evolution SDK
TransactionCode..::..DebitAccount Property
TransactionCode Class See Also Send Feedback
Gets the transaction code's debit GL account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLAccount DebitAccount { get; }
Visual Basic
Public ReadOnly Property DebitAccount As GLAccount
    Get

Property Value

Type: GLAccount

See Also

TransactionCode Class
TransactionCode Members


TransactionCode.DebitAccountID Property

[image]

Pastel Evolution SDK
TransactionCode..::..DebitAccountID Property
TransactionCode Class See Also Send Feedback
Gets the transaction code's debit GL account id.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int DebitAccountID { get; set; }
Visual Basic
Public Property DebitAccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

TransactionCode Class
TransactionCode Members


TransactionCode.Description Property

[image]

Pastel Evolution SDK
TransactionCode..::..Description Property
TransactionCode Class See Also Send Feedback
Gets or sets the transaction code's description.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override string Description { get; set; }
Visual Basic
Public Overrides Property Description As String
    Get
    Set

Property Value

Type: String

See Also

TransactionCode Class
TransactionCode Members


TransactionCode.GLPrompt Property

[image]

Pastel Evolution SDK
TransactionCode..::..GLPrompt Property
TransactionCode Class See Also Send Feedback
Gets or sets whether or not to prompt for a GL account.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool GLPrompt { get; set; }
Visual Basic
Public Property GLPrompt As Boolean
    Get
    Set

Property Value

Type: Boolean

Remarks

Only relevant when transacting inside of Evolution.

See Also

TransactionCode Class
TransactionCode Members


TransactionCode.ID Property

[image]

Pastel Evolution SDK
TransactionCode..::..ID Property
TransactionCode Class See Also Send Feedback
Gets the internal record ID (0 for new, unsaved records).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

Remarks

Once saved, the ID will reflect the record's internal database identifier.

See Also

TransactionCode Class
TransactionCode Members


TransactionCode.IsDebitTrans Property

[image]

Pastel Evolution SDK
TransactionCode..::..IsDebitTrans Property
TransactionCode Class See Also Send Feedback
Gets or sets whether this transaction code is a debit transaction type.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool IsDebitTrans { get; set; }
Visual Basic
Public Property IsDebitTrans As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

TransactionCode Class
TransactionCode Members


TransactionCode.LinkedTrCode Property

[image]

Pastel Evolution SDK
TransactionCode..::..LinkedTrCode Property
TransactionCode Class See Also Send Feedback
Gets the transaction code's linked transaction code.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public TransactionCode LinkedTrCode { get; }
Visual Basic
Public ReadOnly Property LinkedTrCode As TransactionCode
    Get

Property Value

Type: TransactionCode

See Also

TransactionCode Class
TransactionCode Members


TransactionCode.LinkedTrCodeID Property

[image]

Pastel Evolution SDK
TransactionCode..::..LinkedTrCodeID Property
TransactionCode Class See Also Send Feedback
Gets the transaction code's linked transaction code ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int LinkedTrCodeID { get; }
Visual Basic
Public ReadOnly Property LinkedTrCodeID As Integer
    Get

Property Value

Type: Int32

Remarks

See the default INV transaction code for an example of how linked transactions are configured.

See Also

TransactionCode Class
TransactionCode Members


TransactionCode.LongID Property

[image]

Pastel Evolution SDK
TransactionCode..::..LongID Property
TransactionCode Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

TransactionCode Class
TransactionCode Members


TransactionCode.Module Property

[image]

Pastel Evolution SDK
TransactionCode..::..Module Property
TransactionCode Class See Also Send Feedback
Gets or sets the transaction code's Evolution module.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Module Module { get; set; }
Visual Basic
Public Property Module As Module
    Get
    Set

Property Value

Type: Module

Remarks

Transaction codes can be duplicated as long as they belong to distinct modules.

See Also

TransactionCode Class
TransactionCode Members


TransactionCode.Rep Property

[image]

Pastel Evolution SDK
TransactionCode..::..Rep Property
TransactionCode Class See Also Send Feedback
Gets or sets the transaction code's default representative.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool Rep { get; set; }
Visual Basic
Public Property Rep As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

TransactionCode Class
TransactionCode Members


TransactionCode.Reversed Property

[image]

Pastel Evolution SDK
TransactionCode..::..Reversed Property
TransactionCode Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override bool Reversed { get; set; }
Visual Basic
Protected Friend Overrides Property Reversed As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

TransactionCode Class
TransactionCode Members


TransactionCode.SalesFilter Property

[image]

Pastel Evolution SDK
TransactionCode..::..SalesFilter Property
TransactionCode Class See Also Send Feedback
Gets or sets whether this transaction is a "sales" transaction code.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool SalesFilter { get; set; }
Visual Basic
Public Property SalesFilter As Boolean
    Get
    Set

Property Value

Type: Boolean

Remarks

Used in debtors/inventory reporting.

See Also

TransactionCode Class
TransactionCode Members


TransactionCode.Taxable Property

[image]

Pastel Evolution SDK
TransactionCode..::..Taxable Property
TransactionCode Class See Also Send Feedback
Gets or sets the transaction code's taxable status.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool Taxable { get; set; }
Visual Basic
Public Property Taxable As Boolean
    Get
    Set

Property Value

Type: Boolean

Remarks

A taxable transaction codes must specify a tax account.

See Also

TransactionCode Class
TransactionCode Members
Pastel.Evolution Namespace
TransactionCode..::..TaxAccountID


TransactionCode.TaxAccountID Property

[image]

Pastel Evolution SDK
TransactionCode..::..TaxAccountID Property
TransactionCode Class See Also Send Feedback
Gets or sets the transaction code's tax account id.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int TaxAccountID { get; set; }
Visual Basic
Public Property TaxAccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

TransactionCode Class
TransactionCode Members
Pastel.Evolution Namespace
TransactionCode..::..Taxable


TransactionCode.TaxRateID Property

[image]

Pastel Evolution SDK
TransactionCode..::..TaxRateID Property
TransactionCode Class See Also Send Feedback
Gets or sets the transaction code's default tax type id.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int TaxRateID { get; set; }
Visual Basic
Public Property TaxRateID As Integer
    Get
    Set

Property Value

Type: Int32

Remarks

If a default type is not set, a tax type must be specified when posting a transaction.

See Also

TransactionCode Class
TransactionCode Members
Pastel.Evolution Namespace
TransactionBase..::..TaxRate


TransactionCodeBase Class

[image]

Pastel Evolution SDK
TransactionCodeBase Class
Members See Also Send Feedback
Embodies common Evolution transaction code functionality.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract class TransactionCodeBase : BranchedRecordBase
Visual Basic
Public MustInherit Class TransactionCodeBase
    Inherits BranchedRecordBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..TransactionCodeBase
Pastel.Evolution..::..JobTransactionCode
Pastel.Evolution..::..TransactionCode

See Also

TransactionCodeBase Members


TransactionCodeBase Members

[image] [image]

Pastel Evolution SDK
TransactionCodeBase Members
TransactionCodeBase Class Constructors Methods Fields Properties See Also Send Feedback

The TransactionCodeBase type exposes the following members.

Constructors

 | Name | Description
Protected method | TransactionCodeBase | Initializes a new instance of the TransactionCodeBase class

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | (Inherited from RecordBase.)
Protected method | OnSave | (Inherited from RecordBase.)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | reversed |
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | AsTransactionCode | Gets the basic transaction code object (of type TransactionCodeBase), cast as a proper TransactionCode object.
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Code | Gets or sets the transaction code's code.
Public property | Description | Gets or sets the transaction code's description.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Inherited from RecordBase.)
Public property | LongID | Gets the internal record ID (0 for new, unsaved records). (Inherited from RecordBase.)
Protected property | Reversed |

See Also

TransactionCodeBase Class


TransactionCodeBase Constructor

[image]

Pastel Evolution SDK
TransactionCodeBase Constructor
TransactionCodeBase Class See Also Send Feedback
Initializes a new instance of the TransactionCodeBase class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected TransactionCodeBase()
Visual Basic
Protected Sub New

See Also

TransactionCodeBase Class
TransactionCodeBase Members


TransactionCodeBase Fields

[image] [image]

Pastel Evolution SDK
TransactionCodeBase Fields
TransactionCodeBase Class See Also Send Feedback

The TransactionCodeBase type exposes the following members.

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | reversed |
Protected field | wrapper | (Inherited from RecordBase.)

See Also

TransactionCodeBase Class


TransactionCodeBase.reversed Field

[image]

Pastel Evolution SDK
TransactionCodeBase..::..reversed Field
TransactionCodeBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal bool reversed
Visual Basic
Protected Friend reversed As Boolean

Field Value

Type: Boolean

See Also

TransactionCodeBase Class
TransactionCodeBase Members


TransactionCodeBase Methods

[image] [image]

Pastel Evolution SDK
TransactionCodeBase Methods
TransactionCodeBase Class See Also Send Feedback

The TransactionCodeBase type exposes the following members.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | (Inherited from RecordBase.)
Protected method | OnSave | (Inherited from RecordBase.)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

TransactionCodeBase Class


TransactionCodeBase Properties

[image] [image]

Pastel Evolution SDK
TransactionCodeBase Properties
TransactionCodeBase Class See Also Send Feedback

The TransactionCodeBase type exposes the following members.

Properties

 | Name | Description
Public property | AsTransactionCode | Gets the basic transaction code object (of type TransactionCodeBase), cast as a proper TransactionCode object.
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Code | Gets or sets the transaction code's code.
Public property | Description | Gets or sets the transaction code's description.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Inherited from RecordBase.)
Public property | LongID | Gets the internal record ID (0 for new, unsaved records). (Inherited from RecordBase.)
Protected property | Reversed |

See Also

TransactionCodeBase Class


TransactionCodeBase.AsTransactionCode Property

[image]

Pastel Evolution SDK
TransactionCodeBase..::..AsTransactionCode Property
TransactionCodeBase Class See Also Send Feedback
Gets the basic transaction code object (of type TransactionCodeBase), cast as a proper TransactionCode object.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public TransactionCode AsTransactionCode { get; }
Visual Basic
Public ReadOnly Property AsTransactionCode As TransactionCode
    Get

Property Value

Type: TransactionCode

See Also

TransactionCodeBase Class
TransactionCodeBase Members


TransactionCodeBase.Code Property

[image]

Pastel Evolution SDK
TransactionCodeBase..::..Code Property
TransactionCodeBase Class See Also Send Feedback
Gets or sets the transaction code's code.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract string Code { get; set; }
Visual Basic
Public MustOverride Property Code As String
    Get
    Set

Property Value

Type: String

See Also

TransactionCodeBase Class
TransactionCodeBase Members


TransactionCodeBase.Description Property

[image]

Pastel Evolution SDK
TransactionCodeBase..::..Description Property
TransactionCodeBase Class See Also Send Feedback
Gets or sets the transaction code's description.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract string Description { get; set; }
Visual Basic
Public MustOverride Property Description As String
    Get
    Set

Property Value

Type: String

See Also

TransactionCodeBase Class
TransactionCodeBase Members


TransactionCodeBase.Reversed Property

[image]

Pastel Evolution SDK
TransactionCodeBase..::..Reversed Property
TransactionCodeBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal virtual bool Reversed { get; set; }
Visual Basic
Protected Friend Overridable Property Reversed As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

TransactionCodeBase Class
TransactionCodeBase Members


TransactionTypePostingMethodGLContextBase Class

[image]

Pastel Evolution SDK
TransactionTypePostingMethodGLContextBase Class
Members See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class TransactionTypePostingMethodGLContextBase
Visual Basic
Public Class TransactionTypePostingMethodGLContextBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..TransactionTypePostingMethodGLContextBase
Pastel.Evolution..::..CompletedContractPostingMethodGLContext
Pastel.Evolution..::..PercentageOfCompletedContractPostingMethodGLContext

See Also

TransactionTypePostingMethodGLContextBase Members


TransactionTypePostingMethodGLContextBase Members

[image] [image]

Pastel Evolution SDK
TransactionTypePostingMethodGLContextBase Members
TransactionTypePostingMethodGLContextBase Class Methods Properties See Also Send Feedback

The TransactionTypePostingMethodGLContextBase type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | COSAccount |
Public property | COSAccountID |
Public property | CustomerControlAccount |
Public property | CustomerControlAccountID |
Public property | RecoveryAccount |
Public property | RecoveryAccountID |
Public property | SalesAccount |
Public property | SalesAccountID |
Public property | StockAccount |
Public property | StockAccountID |
Public property | SupplierControlAccount |
Public property | SupplierControlAccountID |
Public property | TaxAccount |
Public property | TaxAccountID |
Public property | WIPAccount |
Public property | WIPAccountID |

See Also

TransactionTypePostingMethodGLContextBase Class


TransactionTypePostingMethodGLContextBase Methods

[image] [image]

Pastel Evolution SDK
TransactionTypePostingMethodGLContextBase Methods
TransactionTypePostingMethodGLContextBase Class See Also Send Feedback

The TransactionTypePostingMethodGLContextBase type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TransactionTypePostingMethodGLContextBase Class


TransactionTypePostingMethodGLContextBase Properties

[image] [image]

Pastel Evolution SDK
TransactionTypePostingMethodGLContextBase Properties
TransactionTypePostingMethodGLContextBase Class See Also Send Feedback

The TransactionTypePostingMethodGLContextBase type exposes the following members.

Properties

 | Name | Description
Public property | COSAccount |
Public property | COSAccountID |
Public property | CustomerControlAccount |
Public property | CustomerControlAccountID |
Public property | RecoveryAccount |
Public property | RecoveryAccountID |
Public property | SalesAccount |
Public property | SalesAccountID |
Public property | StockAccount |
Public property | StockAccountID |
Public property | SupplierControlAccount |
Public property | SupplierControlAccountID |
Public property | TaxAccount |
Public property | TaxAccountID |
Public property | WIPAccount |
Public property | WIPAccountID |

See Also

TransactionTypePostingMethodGLContextBase Class


TransactionTypePostingMethodGLContextBase.COSAccount Property

[image]

Pastel Evolution SDK
TransactionTypePostingMethodGLContextBase..::..COSAccount Property
TransactionTypePostingMethodGLContextBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public virtual GLAccount COSAccount { get; set; }
Visual Basic
Public Overridable Property COSAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

See Also

TransactionTypePostingMethodGLContextBase Class
TransactionTypePostingMethodGLContextBase Members


TransactionTypePostingMethodGLContextBase.COSAccountID Property

[image]

Pastel Evolution SDK
TransactionTypePostingMethodGLContextBase..::..COSAccountID Property
TransactionTypePostingMethodGLContextBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public virtual int COSAccountID { get; set; }
Visual Basic
Public Overridable Property COSAccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

TransactionTypePostingMethodGLContextBase Class
TransactionTypePostingMethodGLContextBase Members


TransactionTypePostingMethodGLContextBase.CustomerControlAccount Property

[image]

Pastel Evolution SDK
TransactionTypePostingMethodGLContextBase..::..CustomerControlAccount Property
TransactionTypePostingMethodGLContextBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public virtual GLAccount CustomerControlAccount { get; set; }
Visual Basic
Public Overridable Property CustomerControlAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

See Also

TransactionTypePostingMethodGLContextBase Class
TransactionTypePostingMethodGLContextBase Members


TransactionTypePostingMethodGLContextBase.CustomerControlAccountID Property

[image]

Pastel Evolution SDK
TransactionTypePostingMethodGLContextBase..::..CustomerControlAccountID Property
TransactionTypePostingMethodGLContextBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public virtual int CustomerControlAccountID { get; set; }
Visual Basic
Public Overridable Property CustomerControlAccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

TransactionTypePostingMethodGLContextBase Class
TransactionTypePostingMethodGLContextBase Members


TransactionTypePostingMethodGLContextBase.RecoveryAccount Property

[image]

Pastel Evolution SDK
TransactionTypePostingMethodGLContextBase..::..RecoveryAccount Property
TransactionTypePostingMethodGLContextBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public virtual GLAccount RecoveryAccount { get; set; }
Visual Basic
Public Overridable Property RecoveryAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

See Also

TransactionTypePostingMethodGLContextBase Class
TransactionTypePostingMethodGLContextBase Members


TransactionTypePostingMethodGLContextBase.RecoveryAccountID Property

[image]

Pastel Evolution SDK
TransactionTypePostingMethodGLContextBase..::..RecoveryAccountID Property
TransactionTypePostingMethodGLContextBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public virtual int RecoveryAccountID { get; set; }
Visual Basic
Public Overridable Property RecoveryAccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

TransactionTypePostingMethodGLContextBase Class
TransactionTypePostingMethodGLContextBase Members


TransactionTypePostingMethodGLContextBase.SalesAccount Property

[image]

Pastel Evolution SDK
TransactionTypePostingMethodGLContextBase..::..SalesAccount Property
TransactionTypePostingMethodGLContextBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public virtual GLAccount SalesAccount { get; set; }
Visual Basic
Public Overridable Property SalesAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

See Also

TransactionTypePostingMethodGLContextBase Class
TransactionTypePostingMethodGLContextBase Members


TransactionTypePostingMethodGLContextBase.SalesAccountID Property

[image]

Pastel Evolution SDK
TransactionTypePostingMethodGLContextBase..::..SalesAccountID Property
TransactionTypePostingMethodGLContextBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public virtual int SalesAccountID { get; set; }
Visual Basic
Public Overridable Property SalesAccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

TransactionTypePostingMethodGLContextBase Class
TransactionTypePostingMethodGLContextBase Members


TransactionTypePostingMethodGLContextBase.StockAccount Property

[image]

Pastel Evolution SDK
TransactionTypePostingMethodGLContextBase..::..StockAccount Property
TransactionTypePostingMethodGLContextBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public virtual GLAccount StockAccount { get; set; }
Visual Basic
Public Overridable Property StockAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

See Also

TransactionTypePostingMethodGLContextBase Class
TransactionTypePostingMethodGLContextBase Members


TransactionTypePostingMethodGLContextBase.StockAccountID Property

[image]

Pastel Evolution SDK
TransactionTypePostingMethodGLContextBase..::..StockAccountID Property
TransactionTypePostingMethodGLContextBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public virtual int StockAccountID { get; set; }
Visual Basic
Public Overridable Property StockAccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

TransactionTypePostingMethodGLContextBase Class
TransactionTypePostingMethodGLContextBase Members


TransactionTypePostingMethodGLContextBase.SupplierControlAccount Property

[image]

Pastel Evolution SDK
TransactionTypePostingMethodGLContextBase..::..SupplierControlAccount Property
TransactionTypePostingMethodGLContextBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public virtual GLAccount SupplierControlAccount { get; set; }
Visual Basic
Public Overridable Property SupplierControlAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

See Also

TransactionTypePostingMethodGLContextBase Class
TransactionTypePostingMethodGLContextBase Members


TransactionTypePostingMethodGLContextBase.SupplierControlAccountID Property

[image]

Pastel Evolution SDK
TransactionTypePostingMethodGLContextBase..::..SupplierControlAccountID Property
TransactionTypePostingMethodGLContextBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public virtual int SupplierControlAccountID { get; set; }
Visual Basic
Public Overridable Property SupplierControlAccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

TransactionTypePostingMethodGLContextBase Class
TransactionTypePostingMethodGLContextBase Members


TransactionTypePostingMethodGLContextBase.TaxAccount Property

[image]

Pastel Evolution SDK
TransactionTypePostingMethodGLContextBase..::..TaxAccount Property
TransactionTypePostingMethodGLContextBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public virtual GLAccount TaxAccount { get; set; }
Visual Basic
Public Overridable Property TaxAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

See Also

TransactionTypePostingMethodGLContextBase Class
TransactionTypePostingMethodGLContextBase Members


TransactionTypePostingMethodGLContextBase.TaxAccountID Property

[image]

Pastel Evolution SDK
TransactionTypePostingMethodGLContextBase..::..TaxAccountID Property
TransactionTypePostingMethodGLContextBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public virtual int TaxAccountID { get; set; }
Visual Basic
Public Overridable Property TaxAccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

TransactionTypePostingMethodGLContextBase Class
TransactionTypePostingMethodGLContextBase Members


TransactionTypePostingMethodGLContextBase.WIPAccount Property

[image]

Pastel Evolution SDK
TransactionTypePostingMethodGLContextBase..::..WIPAccount Property
TransactionTypePostingMethodGLContextBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public virtual GLAccount WIPAccount { get; set; }
Visual Basic
Public Overridable Property WIPAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

See Also

TransactionTypePostingMethodGLContextBase Class
TransactionTypePostingMethodGLContextBase Members


TransactionTypePostingMethodGLContextBase.WIPAccountID Property

[image]

Pastel Evolution SDK
TransactionTypePostingMethodGLContextBase..::..WIPAccountID Property
TransactionTypePostingMethodGLContextBase Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public virtual int WIPAccountID { get; set; }
Visual Basic
Public Overridable Property WIPAccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

TransactionTypePostingMethodGLContextBase Class
TransactionTypePostingMethodGLContextBase Members


TransactionTypePostingMethodGLContextCollection Class

[image]

Pastel Evolution SDK
TransactionTypePostingMethodGLContextCollection Class
Members See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class TransactionTypePostingMethodGLContextCollection : CollectionBase
Visual Basic
Public Class TransactionTypePostingMethodGLContextCollection
    Inherits CollectionBase

Inheritance Hierarchy

System..::..Object
System.Collections..::..CollectionBase
Pastel.Evolution..::..TransactionTypePostingMethodGLContextCollection

See Also

TransactionTypePostingMethodGLContextCollection Members


TransactionTypePostingMethodGLContextCollection Members

[image] [image]

Pastel Evolution SDK
TransactionTypePostingMethodGLContextCollection Members
TransactionTypePostingMethodGLContextCollection Class Methods Properties See Also Send Feedback

The TransactionTypePostingMethodGLContextCollection type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item |
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

TransactionTypePostingMethodGLContextCollection Class


TransactionTypePostingMethodGLContextCollection Methods

[image] [image]

Pastel Evolution SDK
TransactionTypePostingMethodGLContextCollection Methods
TransactionTypePostingMethodGLContextCollection Class See Also Send Feedback

The TransactionTypePostingMethodGLContextCollection type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TransactionTypePostingMethodGLContextCollection Class


TransactionTypePostingMethodGLContextCollection Properties

[image] [image]

Pastel Evolution SDK
TransactionTypePostingMethodGLContextCollection Properties
TransactionTypePostingMethodGLContextCollection Class See Also Send Feedback

The TransactionTypePostingMethodGLContextCollection type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item |
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

TransactionTypePostingMethodGLContextCollection Class


TransactionTypePostingMethodGLContextCollection.Item Property

[image]

Pastel Evolution SDK
TransactionTypePostingMethodGLContextCollection..::..Item Property
TransactionTypePostingMethodGLContextCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public TransactionTypePostingMethodGLContextBase this[
    JobPostingMethod jobPostingMethod
] { get; }
Visual Basic
Public ReadOnly Default Property Item (
    jobPostingMethod As JobPostingMethod
) As TransactionTypePostingMethodGLContextBase
    Get

Parameters

jobPostingMethod
Type: Pastel.Evolution..::..JobPostingMethod

Property Value

Type: TransactionTypePostingMethodGLContextBase

See Also

TransactionTypePostingMethodGLContextCollection Class
TransactionTypePostingMethodGLContextCollection Members


Unit Class

[image]

Pastel Evolution SDK
Unit Class
Members See Also Send Feedback
Represents an inventory unit.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class Unit : BranchedRecordBase
Visual Basic
Public Class Unit
    Inherits BranchedRecordBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..Unit

See Also

Unit Members


Unit Members

[image] [image]

Pastel Evolution SDK
Unit Members
Unit Class Constructors Methods Fields Properties See Also Send Feedback

The Unit type exposes the following members.

Constructors

 | Name | Description
Public method | Unit()()()() | Creates a new instance of a unit.
Public method | Unit(Int32) | Creates a new instance of an inventory unit.
Public method | Unit(String) | Creates a new instance of an inventory unit.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds an inventory unit ID.
 | FindByCode | Attempts to find an inventory unit by using its code and returns its ID.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | List | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | (Overrides Object..::..ToString()()()().)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Category |
Public property | CategoryID |
Public property | Code | Gets or sets the unit's code.
Public property | Conversions | Gets the inventory item's unit conversions, based on the stocking unit. If a StockingUnit is not set, UnitConversions will be null.
Public property | Description | Gets or sets the unit's description.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)

See Also

Unit Class


Unit Constructor

[image] [image]

Pastel Evolution SDK
Unit Constructor
Unit Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Unit()()()() | Creates a new instance of a unit.
Public method | Unit(Int32) | Creates a new instance of an inventory unit.
Public method | Unit(String) | Creates a new instance of an inventory unit.

See Also

Unit Class
Unit Members


Unit Constructor

[image]

Pastel Evolution SDK
Unit Constructor
Unit Class See Also Send Feedback
Creates a new instance of a unit.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Unit()
Visual Basic
Public Sub New

See Also

Unit Class
Unit Members
Unit Overload


Unit Constructor (Int32)

[image]

Pastel Evolution SDK
Unit Constructor (Int32)
Unit Class See Also Send Feedback
Creates a new instance of an inventory unit.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Unit(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32
Specifies the id of the existing record.

See Also

Unit Class
Unit Members
Unit Overload


Unit Constructor (String)

[image]

Pastel Evolution SDK
Unit Constructor (String)
Unit Class See Also Send Feedback
Creates a new instance of an inventory unit.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Unit(
    string code
)
Visual Basic
Public Sub New (
    code As String
)

Parameters

code
Type: System..::..String
Specifies the code of the existing record.

See Also

Unit Class
Unit Members
Unit Overload


Unit Fields

[image] [image]

Pastel Evolution SDK
Unit Fields
Unit Class See Also Send Feedback

The Unit type exposes the following members.

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

Unit Class


Unit Methods

[image] [image]

Pastel Evolution SDK
Unit Methods
Unit Class See Also Send Feedback

The Unit type exposes the following members.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds an inventory unit ID.
 | FindByCode | Attempts to find an inventory unit by using its code and returns its ID.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | List | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | (Overrides Object..::..ToString()()()().)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

Unit Class


Unit.Find Method

[image]

Pastel Evolution SDK
Unit..::..Find Method
Unit Class See Also Send Feedback
Finds an inventory unit ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String
The criteria passed to the SQL query. Eg. cUnitCode = '01'

Return Value

Type: Int32
The ID of the first record found; -1 if not record was found.

See Also

Unit Class
Unit Members


Unit.FindByCode Method

[image]

Pastel Evolution SDK
Unit..::..FindByCode Method
Unit Class See Also Send Feedback
Attempts to find an inventory unit by using its code and returns its ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int FindByCode(
    string code
)
Visual Basic
Public Shared Function FindByCode (
    code As String
) As Integer

Parameters

code
Type: System..::..String
The code used to lookup the unit.

Return Value

Type: Int32
-1 if no record was found, else the id of the first record matching the criteria supplied.

See Also

Unit Class
Unit Members
Pastel.Evolution Namespace
Unit..::..Find(String)


Unit.List Method

[image]

Pastel Evolution SDK
Unit..::..List Method
Unit Class See Also Send Feedback
Gets a list of database records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DataTable List(
    string criteria
)
Visual Basic
Public Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.

Return Value

Type: DataTable
Table containing selected records.

See Also

Unit Class
Unit Members


Unit.OnDelete Method

[image]

Pastel Evolution SDK
Unit..::..OnDelete Method
Unit Class See Also Send Feedback
Removes the record from the database, provided it is not referenced by other records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

See Also

Unit Class
Unit Members


Unit.OnSave Method

[image]

Pastel Evolution SDK
Unit..::..OnSave Method
Unit Class See Also Send Feedback
Persists the record to the database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

Unit Class
Unit Members


Unit.ToString Method

[image]

Pastel Evolution SDK
Unit..::..ToString Method
Unit Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String

See Also

Unit Class
Unit Members


Unit Properties

[image] [image]

Pastel Evolution SDK
Unit Properties
Unit Class See Also Send Feedback

The Unit type exposes the following members.

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Category |
Public property | CategoryID |
Public property | Code | Gets or sets the unit's code.
Public property | Conversions | Gets the inventory item's unit conversions, based on the stocking unit. If a StockingUnit is not set, UnitConversions will be null.
Public property | Description | Gets or sets the unit's description.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)

See Also

Unit Class


Unit.Category Property

[image]

Pastel Evolution SDK
Unit..::..Category Property
Unit Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public UnitCategory Category { get; set; }
Visual Basic
Public Property Category As UnitCategory
    Get
    Set

Property Value

Type: UnitCategory

See Also

Unit Class
Unit Members


Unit.CategoryID Property

[image]

Pastel Evolution SDK
Unit..::..CategoryID Property
Unit Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int CategoryID { get; set; }
Visual Basic
Public Property CategoryID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

Unit Class
Unit Members


Unit.Code Property

[image]

Pastel Evolution SDK
Unit..::..Code Property
Unit Class See Also Send Feedback
Gets or sets the unit's code.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Code { get; set; }
Visual Basic
Public Property Code As String
    Get
    Set

Property Value

Type: String

See Also

Unit Class
Unit Members


Unit.Conversions Property

[image]

Pastel Evolution SDK
Unit..::..Conversions Property
Unit Class See Also Send Feedback
Gets the inventory item's unit conversions, based on the stocking unit. If a StockingUnit is not set, UnitConversions will be null.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public UnitConversionCollection Conversions { get; }
Visual Basic
Public ReadOnly Property Conversions As UnitConversionCollection
    Get

Property Value

Type: UnitConversionCollection

See Also

Unit Class
Unit Members


Unit.Description Property

[image]

Pastel Evolution SDK
Unit..::..Description Property
Unit Class See Also Send Feedback
Gets or sets the unit's description.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set

Property Value

Type: String

See Also

Unit Class
Unit Members


Unit.ID Property

[image]

Pastel Evolution SDK
Unit..::..ID Property
Unit Class See Also Send Feedback
Gets the internal record ID (0 for new, unsaved records).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

Remarks

Once saved, the ID will reflect the record's internal database identifier.

See Also

Unit Class
Unit Members


Unit.LongID Property

[image]

Pastel Evolution SDK
Unit..::..LongID Property
Unit Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

Unit Class
Unit Members


UnitCategory Class

[image]

Pastel Evolution SDK
UnitCategory Class
Members See Also Send Feedback
Represents an inventory group.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class UnitCategory : BranchedRecordBase
Visual Basic
Public Class UnitCategory
    Inherits BranchedRecordBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..UnitCategory

See Also

UnitCategory Members


UnitCategory Members

[image] [image]

Pastel Evolution SDK
UnitCategory Members
UnitCategory Class Constructors Methods Fields Properties See Also Send Feedback

The UnitCategory type exposes the following members.

Constructors

 | Name | Description
Public method | UnitCategory()()()() | Creates a new instance of an inventory unit category.
Public method | UnitCategory(Int32) | Creates a new instance of an inventory category.
Public method | UnitCategory(String) | Creates a new instance of an inventory unit category.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds an inventory group ID.
 | FindByDescription | Attempts to find an inventory group by using its code and returns its ID.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | List | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | (Overrides Object..::..ToString()()()().)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Description | Gets or sets the category description.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)

See Also

UnitCategory Class


UnitCategory Constructor

[image] [image]

Pastel Evolution SDK
UnitCategory Constructor
UnitCategory Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UnitCategory()()()() | Creates a new instance of an inventory unit category.
Public method | UnitCategory(Int32) | Creates a new instance of an inventory category.
Public method | UnitCategory(String) | Creates a new instance of an inventory unit category.

See Also

UnitCategory Class
UnitCategory Members


UnitCategory Constructor

[image]

Pastel Evolution SDK
UnitCategory Constructor
UnitCategory Class See Also Send Feedback
Creates a new instance of an inventory unit category.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public UnitCategory()
Visual Basic
Public Sub New

See Also

UnitCategory Class
UnitCategory Members
UnitCategory Overload


UnitCategory Constructor (Int32)

[image]

Pastel Evolution SDK
UnitCategory Constructor (Int32)
UnitCategory Class See Also Send Feedback
Creates a new instance of an inventory category.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public UnitCategory(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32
Specifies the id of the existing record.

See Also

UnitCategory Class
UnitCategory Members
UnitCategory Overload


UnitCategory Constructor (String)

[image]

Pastel Evolution SDK
UnitCategory Constructor (String)
UnitCategory Class See Also Send Feedback
Creates a new instance of an inventory unit category.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public UnitCategory(
    string description
)
Visual Basic
Public Sub New (
    description As String
)

Parameters

description
Type: System..::..String
Specifies the description of the existing record.

See Also

UnitCategory Class
UnitCategory Members
UnitCategory Overload


UnitCategory Fields

[image] [image]

Pastel Evolution SDK
UnitCategory Fields
UnitCategory Class See Also Send Feedback

The UnitCategory type exposes the following members.

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

UnitCategory Class


UnitCategory Methods

[image] [image]

Pastel Evolution SDK
UnitCategory Methods
UnitCategory Class See Also Send Feedback

The UnitCategory type exposes the following members.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds an inventory group ID.
 | FindByDescription | Attempts to find an inventory group by using its code and returns its ID.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | List | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | (Overrides Object..::..ToString()()()().)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

UnitCategory Class


UnitCategory.Find Method

[image]

Pastel Evolution SDK
UnitCategory..::..Find Method
UnitCategory Class See Also Send Feedback
Finds an inventory group ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String
The criteria passed to the SQL query. Eg. cUnitCatDescription = 'Mass'

Return Value

Type: Int32
The ID of the first record found; -1 if not record was found.

See Also

UnitCategory Class
UnitCategory Members


UnitCategory.FindByDescription Method

[image]

Pastel Evolution SDK
UnitCategory..::..FindByDescription Method
UnitCategory Class See Also Send Feedback
Attempts to find an inventory group by using its code and returns its ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int FindByDescription(
    string code
)
Visual Basic
Public Shared Function FindByDescription (
    code As String
) As Integer

Parameters

code
Type: System..::..String
The code used to lookup the group.

Return Value

Type: Int32
-1 if no record was found, else the id of the first record matching the criteria supplied.

See Also

UnitCategory Class
UnitCategory Members
Pastel.Evolution Namespace
UnitCategory..::..Find(String)


UnitCategory.List Method

[image]

Pastel Evolution SDK
UnitCategory..::..List Method
UnitCategory Class See Also Send Feedback
Gets a list of database records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DataTable List(
    string criteria
)
Visual Basic
Public Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.

Return Value

Type: DataTable
Table containing selected records.

See Also

UnitCategory Class
UnitCategory Members


UnitCategory.OnDelete Method

[image]

Pastel Evolution SDK
UnitCategory..::..OnDelete Method
UnitCategory Class See Also Send Feedback
Removes the record from the database, provided it is not referenced by other records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

See Also

UnitCategory Class
UnitCategory Members


UnitCategory.OnSave Method

[image]

Pastel Evolution SDK
UnitCategory..::..OnSave Method
UnitCategory Class See Also Send Feedback
Persists the record to the database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

UnitCategory Class
UnitCategory Members


UnitCategory.ToString Method

[image]

Pastel Evolution SDK
UnitCategory..::..ToString Method
UnitCategory Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String

See Also

UnitCategory Class
UnitCategory Members


UnitCategory Properties

[image] [image]

Pastel Evolution SDK
UnitCategory Properties
UnitCategory Class See Also Send Feedback

The UnitCategory type exposes the following members.

Properties

 | Name | Description
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Description | Gets or sets the category description.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)

See Also

UnitCategory Class


UnitCategory.Description Property

[image]

Pastel Evolution SDK
UnitCategory..::..Description Property
UnitCategory Class See Also Send Feedback
Gets or sets the category description.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set

Property Value

Type: String

See Also

UnitCategory Class
UnitCategory Members


UnitCategory.ID Property

[image]

Pastel Evolution SDK
UnitCategory..::..ID Property
UnitCategory Class See Also Send Feedback
Gets the internal record ID (0 for new, unsaved records).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

Remarks

Once saved, the ID will reflect the record's internal database identifier.

See Also

UnitCategory Class
UnitCategory Members


UnitCategory.LongID Property

[image]

Pastel Evolution SDK
UnitCategory..::..LongID Property
UnitCategory Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

UnitCategory Class
UnitCategory Members


UnitConversion Class

[image]

Pastel Evolution SDK
UnitConversion Class
Members See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class UnitConversion : BranchedRecordBase
Visual Basic
Public Class UnitConversion
    Inherits BranchedRecordBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..UnitConversion

See Also

UnitConversion Members


UnitConversion Members

[image] [image]

Pastel Evolution SDK
UnitConversion Members
UnitConversion Class Constructors Methods Fields Properties See Also Send Feedback

The UnitConversion type exposes the following members.

Constructors

 | Name | Description
Public method | UnitConversion(Int32) | Creates a new instance of a unit conversion.
Public method | UnitConversion(Int32, Int32) | Creates a new instance of a unit conversion.

Methods

 | Name | Description
 | _Select(Int32) | Experimental Method
 | _Select(Unit) | Experimental Method
 | _Select(String, String) | Experimental Method
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find(String) |
 | Find(Int32, Int32) |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List(String) |
 | List(String, String) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | BaseQuantity |
Public property | BaseUnit | Gets the base unit in the conversion.
Public property | BaseUnitID |
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | ConversionQuantity |
Public property | ConversionUnit |
Public property | ConversionUnitID |
Public property | ID | (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)

See Also

UnitConversion Class


UnitConversion Constructor

[image] [image]

Pastel Evolution SDK
UnitConversion Constructor
UnitConversion Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UnitConversion(Int32) | Creates a new instance of a unit conversion.
Public method | UnitConversion(Int32, Int32) | Creates a new instance of a unit conversion.

See Also

UnitConversion Class
UnitConversion Members


UnitConversion Constructor (Int32)

[image]

Pastel Evolution SDK
UnitConversion Constructor (Int32)
UnitConversion Class See Also Send Feedback
Creates a new instance of a unit conversion.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public UnitConversion(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32
Specifies the id of the existing record.

See Also

UnitConversion Class
UnitConversion Members
UnitConversion Overload


UnitConversion Constructor (Int32, Int32)

[image]

Pastel Evolution SDK
UnitConversion Constructor (Int32, Int32)
UnitConversion Class See Also Send Feedback
Creates a new instance of a unit conversion.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public UnitConversion(
    int baseUnitID,
    int conversionUnitID
)
Visual Basic
Public Sub New (
    baseUnitID As Integer,
    conversionUnitID As Integer
)

Parameters

baseUnitID
Type: System..::..Int32
conversionUnitID
Type: System..::..Int32

See Also

UnitConversion Class
UnitConversion Members
UnitConversion Overload


UnitConversion Fields

[image] [image]

Pastel Evolution SDK
UnitConversion Fields
UnitConversion Class See Also Send Feedback

The UnitConversion type exposes the following members.

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

UnitConversion Class


UnitConversion Methods

[image] [image]

Pastel Evolution SDK
UnitConversion Methods
UnitConversion Class See Also Send Feedback

The UnitConversion type exposes the following members.

Methods

 | Name | Description
 | _Select(Int32) | Experimental Method
 | _Select(Unit) | Experimental Method
 | _Select(String, String) | Experimental Method
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find(String) |
 | Find(Int32, Int32) |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List(String) |
 | List(String, String) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

UnitConversion Class


UnitConversion._Select Method

[image] [image]

Pastel Evolution SDK
UnitConversion..::.._Select Method
UnitConversion Class See Also Send Feedback

Overload List

Name | Description
_Select(Int32) | Experimental Method
_Select(Unit) | Experimental Method
_Select(String, String) | Experimental Method

See Also

UnitConversion Class
UnitConversion Members


UnitConversion._Select Method (Int32)

[image]

Pastel Evolution SDK
UnitConversion..::.._Select Method (Int32)
UnitConversion Class See Also Send Feedback
Experimental Method

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static UnitConversion[] _Select(
    int baseUnitID
)
Visual Basic
Public Shared Function _Select (
    baseUnitID As Integer
) As UnitConversion()

Parameters

baseUnitID
Type: System..::..Int32

Return Value

Type: array< UnitConversion >[]()[][]

See Also

UnitConversion Class
UnitConversion Members
_Select Overload


UnitConversion._Select Method (Unit)

[image]

Pastel Evolution SDK
UnitConversion..::.._Select Method (Unit)
UnitConversion Class See Also Send Feedback
Experimental Method

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static UnitConversion[] _Select(
    Unit baseUnit
)
Visual Basic
Public Shared Function _Select (
    baseUnit As Unit
) As UnitConversion()

Parameters

baseUnit
Type: Pastel.Evolution..::..Unit

Return Value

Type: array< UnitConversion >[]()[][]

See Also

UnitConversion Class
UnitConversion Members
_Select Overload


UnitConversion._Select Method (String, String)

[image]

Pastel Evolution SDK
UnitConversion..::.._Select Method (String, String)
UnitConversion Class See Also Send Feedback
Experimental Method

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static UnitConversion[] _Select(
    string criteria,
    string sortOrder
)
Visual Basic
Public Shared Function _Select (
    criteria As String,
    sortOrder As String
) As UnitConversion()

Parameters

criteria
Type: System..::..String
sortOrder
Type: System..::..String

Return Value

Type: array< UnitConversion >[]()[][]

See Also

UnitConversion Class
UnitConversion Members
_Select Overload


UnitConversion.Find Method

[image] [image]

Pastel Evolution SDK
UnitConversion..::..Find Method
UnitConversion Class See Also Send Feedback

Overload List

Name | Description
Find(String) |
Find(Int32, Int32) |

See Also

UnitConversion Class
UnitConversion Members


UnitConversion.Find Method (String)

[image]

Pastel Evolution SDK
UnitConversion..::..Find Method (String)
UnitConversion Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String

Return Value

Type: Int32

See Also

UnitConversion Class
UnitConversion Members
Find Overload


UnitConversion.Find Method (Int32, Int32)

[image]

Pastel Evolution SDK
UnitConversion..::..Find Method (Int32, Int32)
UnitConversion Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    int baseUnitID,
    int conversionUnitID
)
Visual Basic
Public Shared Function Find (
    baseUnitID As Integer,
    conversionUnitID As Integer
) As Integer

Parameters

baseUnitID
Type: System..::..Int32
conversionUnitID
Type: System..::..Int32

Return Value

Type: Int32

See Also

UnitConversion Class
UnitConversion Members
Find Overload


UnitConversion.List Method

[image] [image]

Pastel Evolution SDK
UnitConversion..::..List Method
UnitConversion Class See Also Send Feedback

Overload List

Name | Description
List(String) |
List(String, String) |

See Also

UnitConversion Class
UnitConversion Members


UnitConversion.List Method (String)

[image]

Pastel Evolution SDK
UnitConversion..::..List Method (String)
UnitConversion Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria
)
Visual Basic
Public Shared Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String

Return Value

Type: DataTable

See Also

UnitConversion Class
UnitConversion Members
List Overload


UnitConversion.List Method (String, String)

[image]

Pastel Evolution SDK
UnitConversion..::..List Method (String, String)
UnitConversion Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria,
    string sortOrder
)
Visual Basic
Public Shared Function List (
    criteria As String,
    sortOrder As String
) As DataTable

Parameters

criteria
Type: System..::..String
sortOrder
Type: System..::..String

Return Value

Type: DataTable

See Also

UnitConversion Class
UnitConversion Members
List Overload


UnitConversion.OnDelete Method

[image]

Pastel Evolution SDK
UnitConversion..::..OnDelete Method
UnitConversion Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

See Also

UnitConversion Class
UnitConversion Members


UnitConversion.OnSave Method

[image]

Pastel Evolution SDK
UnitConversion..::..OnSave Method
UnitConversion Class See Also Send Feedback
Persists the record to the database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

UnitConversion Class
UnitConversion Members


UnitConversion Properties

[image] [image]

Pastel Evolution SDK
UnitConversion Properties
UnitConversion Class See Also Send Feedback

The UnitConversion type exposes the following members.

Properties

 | Name | Description
Public property | BaseQuantity |
Public property | BaseUnit | Gets the base unit in the conversion.
Public property | BaseUnitID |
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | ConversionQuantity |
Public property | ConversionUnit |
Public property | ConversionUnitID |
Public property | ID | (Overrides RecordBase..::..ID.)
Public property | LongID | (Overrides RecordBase..::..LongID.)

See Also

UnitConversion Class


UnitConversion.BaseQuantity Property

[image]

Pastel Evolution SDK
UnitConversion..::..BaseQuantity Property
UnitConversion Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double BaseQuantity { get; set; }
Visual Basic
Public Property BaseQuantity As Double
    Get
    Set

Property Value

Type: Double

See Also

UnitConversion Class
UnitConversion Members


UnitConversion.BaseUnit Property

[image]

Pastel Evolution SDK
UnitConversion..::..BaseUnit Property
UnitConversion Class See Also Send Feedback
Gets the base unit in the conversion.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Unit BaseUnit { get; internal set; }
Visual Basic
Public Property BaseUnit As Unit
    Get
    Friend Set

Property Value

Type: Unit

See Also

UnitConversion Class
UnitConversion Members


UnitConversion.BaseUnitID Property

[image]

Pastel Evolution SDK
UnitConversion..::..BaseUnitID Property
UnitConversion Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int BaseUnitID { get; set; }
Visual Basic
Public Property BaseUnitID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

UnitConversion Class
UnitConversion Members


UnitConversion.ConversionQuantity Property

[image]

Pastel Evolution SDK
UnitConversion..::..ConversionQuantity Property
UnitConversion Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double ConversionQuantity { get; set; }
Visual Basic
Public Property ConversionQuantity As Double
    Get
    Set

Property Value

Type: Double

See Also

UnitConversion Class
UnitConversion Members


UnitConversion.ConversionUnit Property

[image]

Pastel Evolution SDK
UnitConversion..::..ConversionUnit Property
UnitConversion Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Unit ConversionUnit { get; set; }
Visual Basic
Public Property ConversionUnit As Unit
    Get
    Set

Property Value

Type: Unit

See Also

UnitConversion Class
UnitConversion Members


UnitConversion.ConversionUnitID Property

[image]

Pastel Evolution SDK
UnitConversion..::..ConversionUnitID Property
UnitConversion Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int ConversionUnitID { get; set; }
Visual Basic
Public Property ConversionUnitID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

UnitConversion Class
UnitConversion Members


UnitConversion.ID Property

[image]

Pastel Evolution SDK
UnitConversion..::..ID Property
UnitConversion Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

See Also

UnitConversion Class
UnitConversion Members


UnitConversion.LongID Property

[image]

Pastel Evolution SDK
UnitConversion..::..LongID Property
UnitConversion Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

UnitConversion Class
UnitConversion Members


UnitConversionCollection Class

[image]

Pastel Evolution SDK
UnitConversionCollection Class
Members See Also Send Feedback
Represents a collection of warehouse context records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class UnitConversionCollection : CollectionBase
Visual Basic
Public Class UnitConversionCollection
    Inherits CollectionBase

Inheritance Hierarchy

System..::..Object
System.Collections..::..CollectionBase
Pastel.Evolution..::..UnitConversionCollection

See Also

UnitConversionCollection Members
Pastel.Evolution Namespace
Pastel.Evolution..::..DeliveryAddress


UnitConversionCollection Members

[image] [image]

Pastel Evolution SDK
UnitConversionCollection Members
UnitConversionCollection Class Methods Properties See Also Send Feedback

The UnitConversionCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add(Unit, Double) |
Public method | Add(Unit, Double, Double) |
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | ConversionExists(Unit) | Gets whether a conversion is configured between the current unit and the given unit.
Public method | ConversionExists(Int32, Int32) | Gets whether a conversion is configured for the given units. It does not matter which unit is specified as the base.
Public method | ConversionExists(Unit, Unit) | Gets whether a conversion is configured for the given units. It does not matter which unit is specified as the base.
Public method | ConvertFrom | Converts a specified quantity of specified unit to the base unit.
Public method | ConvertTo | Converts a specified quantity of base unit to the specified unit.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item[([( Int32])]) | Gets a delivery address by index.
Public property | Item[([( String])]) | Gets the unit conversion object relating to the current base unit and conversion unit code specified.
Public property | Item[([( Unit])]) |
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

UnitConversionCollection Class


UnitConversionCollection Methods

[image] [image]

Pastel Evolution SDK
UnitConversionCollection Methods
UnitConversionCollection Class See Also Send Feedback

The UnitConversionCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add(Unit, Double) |
Public method | Add(Unit, Double, Double) |
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | ConversionExists(Unit) | Gets whether a conversion is configured between the current unit and the given unit.
Public method | ConversionExists(Int32, Int32) | Gets whether a conversion is configured for the given units. It does not matter which unit is specified as the base.
Public method | ConversionExists(Unit, Unit) | Gets whether a conversion is configured for the given units. It does not matter which unit is specified as the base.
Public method | ConvertFrom | Converts a specified quantity of specified unit to the base unit.
Public method | ConvertTo | Converts a specified quantity of base unit to the specified unit.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UnitConversionCollection Class


UnitConversionCollection.Add Method

[image] [image]

Pastel Evolution SDK
UnitConversionCollection..::..Add Method
UnitConversionCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Add(Unit, Double) |
Public method | Add(Unit, Double, Double) |

See Also

UnitConversionCollection Class
UnitConversionCollection Members


UnitConversionCollection.Add Method (Unit, Double)

[image]

Pastel Evolution SDK
UnitConversionCollection..::..Add Method (Unit, Double)
UnitConversionCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void Add(
    Unit conversionUnit,
    double conversionQty
)
Visual Basic
Public Sub Add (
    conversionUnit As Unit,
    conversionQty As Double
)

Parameters

conversionUnit
Type: Pastel.Evolution..::..Unit
conversionQty
Type: System..::..Double

See Also

UnitConversionCollection Class
UnitConversionCollection Members
Add Overload


UnitConversionCollection.Add Method (Unit, Double, Double)

[image]

Pastel Evolution SDK
UnitConversionCollection..::..Add Method (Unit, Double, Double)
UnitConversionCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void Add(
    Unit conversionUnit,
    double baseQty,
    double conversionQty
)
Visual Basic
Public Sub Add (
    conversionUnit As Unit,
    baseQty As Double,
    conversionQty As Double
)

Parameters

conversionUnit
Type: Pastel.Evolution..::..Unit
baseQty
Type: System..::..Double
conversionQty
Type: System..::..Double

See Also

UnitConversionCollection Class
UnitConversionCollection Members
Add Overload


UnitConversionCollection.ConversionExists Method

[image] [image]

Pastel Evolution SDK
UnitConversionCollection..::..ConversionExists Method
UnitConversionCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ConversionExists(Unit) | Gets whether a conversion is configured between the current unit and the given unit.
Public method | ConversionExists(Int32, Int32) | Gets whether a conversion is configured for the given units. It does not matter which unit is specified as the base.
Public method | ConversionExists(Unit, Unit) | Gets whether a conversion is configured for the given units. It does not matter which unit is specified as the base.

See Also

UnitConversionCollection Class
UnitConversionCollection Members


UnitConversionCollection.ConversionExists Method (Unit)

[image]

Pastel Evolution SDK
UnitConversionCollection..::..ConversionExists Method (Unit)
UnitConversionCollection Class See Also Send Feedback
Gets whether a conversion is configured between the current unit and the given unit.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool ConversionExists(
    Unit conversionUnit
)
Visual Basic
Public Function ConversionExists (
    conversionUnit As Unit
) As Boolean

Parameters

conversionUnit
Type: Pastel.Evolution..::..Unit

Return Value

Type: Boolean

See Also

UnitConversionCollection Class
UnitConversionCollection Members
ConversionExists Overload


UnitConversionCollection.ConversionExists Method (Int32, Int32)

[image]

Pastel Evolution SDK
UnitConversionCollection..::..ConversionExists Method (Int32, Int32)
UnitConversionCollection Class See Also Send Feedback
Gets whether a conversion is configured for the given units. It does not matter which unit is specified as the base.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool ConversionExists(
    int baseUnitID,
    int conversionUnitID
)
Visual Basic
Public Function ConversionExists (
    baseUnitID As Integer,
    conversionUnitID As Integer
) As Boolean

Parameters

baseUnitID
Type: System..::..Int32
conversionUnitID
Type: System..::..Int32

Return Value

Type: Boolean

See Also

UnitConversionCollection Class
UnitConversionCollection Members
ConversionExists Overload


UnitConversionCollection.ConversionExists Method (Unit, Unit)

[image]

Pastel Evolution SDK
UnitConversionCollection..::..ConversionExists Method (Unit, Unit)
UnitConversionCollection Class See Also Send Feedback
Gets whether a conversion is configured for the given units. It does not matter which unit is specified as the base.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool ConversionExists(
    Unit baseUnit,
    Unit conversionUnit
)
Visual Basic
Public Function ConversionExists (
    baseUnit As Unit,
    conversionUnit As Unit
) As Boolean

Parameters

baseUnit
Type: Pastel.Evolution..::..Unit
conversionUnit
Type: Pastel.Evolution..::..Unit

Return Value

Type: Boolean

See Also

UnitConversionCollection Class
UnitConversionCollection Members
ConversionExists Overload


UnitConversionCollection.ConvertFrom Method

[image]

Pastel Evolution SDK
UnitConversionCollection..::..ConvertFrom Method
UnitConversionCollection Class See Also Send Feedback
Converts a specified quantity of specified unit to the base unit.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double ConvertFrom(
    Unit u,
    double quantity
)
Visual Basic
Public Function ConvertFrom (
    u As Unit,
    quantity As Double
) As Double

Parameters

u
Type: Pastel.Evolution..::..Unit
The source unit.
quantity
Type: System..::..Double
The quantity of source unit to convert.

Return Value

Type: Double

See Also

UnitConversionCollection Class
UnitConversionCollection Members


UnitConversionCollection.ConvertTo Method

[image]

Pastel Evolution SDK
UnitConversionCollection..::..ConvertTo Method
UnitConversionCollection Class See Also Send Feedback
Converts a specified quantity of base unit to the specified unit.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double ConvertTo(
    Unit u,
    double quantity
)
Visual Basic
Public Function ConvertTo (
    u As Unit,
    quantity As Double
) As Double

Parameters

u
Type: Pastel.Evolution..::..Unit
The target unit.
quantity
Type: System..::..Double
The quantity of base unit to convert.

Return Value

Type: Double

See Also

UnitConversionCollection Class
UnitConversionCollection Members


UnitConversionCollection Properties

[image] [image]

Pastel Evolution SDK
UnitConversionCollection Properties
UnitConversionCollection Class See Also Send Feedback

The UnitConversionCollection type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item[([( Int32])]) | Gets a delivery address by index.
Public property | Item[([( String])]) | Gets the unit conversion object relating to the current base unit and conversion unit code specified.
Public property | Item[([( Unit])]) |
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

UnitConversionCollection Class


UnitConversionCollection.Item Property

[image] [image]

Pastel Evolution SDK
UnitConversionCollection..::..Item Property
UnitConversionCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public property | Item[([( Int32])]) | Gets a delivery address by index.
Public property | Item[([( String])]) | Gets the unit conversion object relating to the current base unit and conversion unit code specified.
Public property | Item[([( Unit])]) |

See Also

UnitConversionCollection Class
UnitConversionCollection Members


UnitConversionCollection.Item Property (Int32)

[image]

Pastel Evolution SDK
UnitConversionCollection..::..Item Property (Int32)
UnitConversionCollection Class See Also Send Feedback
Gets a delivery address by index.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public UnitConversion this[
    int index
] { get; }
Visual Basic
Public ReadOnly Default Property Item (
    index As Integer
) As UnitConversion
    Get

Parameters

index
Type: System..::..Int32

Return Value

Type: UnitConversion

See Also

UnitConversionCollection Class
UnitConversionCollection Members
Item Overload


UnitConversionCollection.Item Property (String)

[image]

Pastel Evolution SDK
UnitConversionCollection..::..Item Property (String)
UnitConversionCollection Class See Also Send Feedback
Gets the unit conversion object relating to the current base unit and conversion unit code specified.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public UnitConversion this[
    string conversionUnitCode
] { get; }
Visual Basic
Public ReadOnly Default Property Item (
    conversionUnitCode As String
) As UnitConversion
    Get

Parameters

conversionUnitCode
Type: System..::..String
The unit code for which to retrieve the conversion.

Return Value

Type: UnitConversion

See Also

UnitConversionCollection Class
UnitConversionCollection Members
Item Overload


UnitConversionCollection.Item Property (Unit)

[image]

Pastel Evolution SDK
UnitConversionCollection..::..Item Property (Unit)
UnitConversionCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public UnitConversion this[
    Unit conversionUnit
] { get; }
Visual Basic
Public ReadOnly Default Property Item (
    conversionUnit As Unit
) As UnitConversion
    Get

Parameters

conversionUnit
Type: Pastel.Evolution..::..Unit

Property Value

Type: UnitConversion

See Also

UnitConversionCollection Class
UnitConversionCollection Members
Item Overload


Utils Class

[image]

Pastel Evolution SDK
Utils Class
Members See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static class Utils
Visual Basic
Public NotInheritable Class Utils

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..Utils

See Also

Utils Members


Utils Members

[image] [image]

Pastel Evolution SDK
Utils Members
Utils Class Methods See Also Send Feedback

The Utils type exposes the following members.

Methods

Name | Description
TrimString |

See Also

Utils Class


Utils Methods

[image] [image]

Pastel Evolution SDK
Utils Methods
Utils Class See Also Send Feedback

The Utils type exposes the following members.

Methods

Name | Description
TrimString |

See Also

Utils Class


Utils.TrimString Method

[image]

Pastel Evolution SDK
Utils..::..TrimString Method
Utils Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static string TrimString(
    string value,
    int maxlength,
    bool ellipses
)
Visual Basic
Public Shared Function TrimString (
    value As String,
    maxlength As Integer,
    ellipses As Boolean
) As String

Parameters

value
Type: System..::..String
maxlength
Type: System..::..Int32
ellipses
Type: System..::..Boolean

Return Value

Type: String

See Also

Utils Class
Utils Members


Utils.LimitedQueue Class

[image]

Pastel Evolution SDK
Utils..::..LimitedQueue Class
Utils Class Members See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class LimitedQueue : Queue
Visual Basic
Public Class LimitedQueue
    Inherits Queue

Inheritance Hierarchy

System..::..Object
System.Collections..::..Queue
Pastel.Evolution..::..Utils..::..LimitedQueue

See Also

Utils..::..LimitedQueue Members


Utils.LimitedQueue Members

[image] [image]

Pastel Evolution SDK
Utils..::..LimitedQueue Members
Utils..::..LimitedQueue Class Constructors Methods Properties See Also Send Feedback

The Utils..::..LimitedQueue type exposes the following members.

Constructors

 | Name | Description
Public method | Utils..::..LimitedQueue | Initializes a new instance of the Utils..::..LimitedQueue class

Methods

 | Name | Description
Public method | Clear | Removes all objects from the Queue. (Inherited from Queue.)
Public method | Clone | Creates a shallow copy of the Queue. (Inherited from Queue.)
Public method | Contains | Determines whether an element is in the Queue. (Inherited from Queue.)
Public method | CopyTo | Copies the Queue elements to an existing one-dimensional Array, starting at the specified array index. (Inherited from Queue.)
Public method | Dequeue | Removes and returns the object at the beginning of the Queue. (Inherited from Queue.)
Public method | Enqueue |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Queue. (Inherited from Queue.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Peek | Returns the object at the beginning of the Queue without removing it. (Inherited from Queue.)
Public method | ToArray | Copies the Queue elements to a new array. (Inherited from Queue.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TrimToSize | Sets the capacity to the actual number of elements in the Queue. (Inherited from Queue.)

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the Queue. (Inherited from Queue.)
Public property | IsSynchronized | Gets a value indicating whether access to the Queue is synchronized (thread safe). (Inherited from Queue.)
Public property | Limit |
Public property | SyncRoot | Gets an object that can be used to synchronize access to the Queue. (Inherited from Queue.)

See Also

Utils..::..LimitedQueue Class


Utils.LimitedQueue Constructor

[image]

Pastel Evolution SDK
Utils..::..LimitedQueue Constructor
Utils..::..LimitedQueue Class See Also Send Feedback
Initializes a new instance of the Utils..::..LimitedQueue class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public LimitedQueue(
    int limit
)
Visual Basic
Public Sub New (
    limit As Integer
)

Parameters

limit
Type: System..::..Int32

See Also

Utils..::..LimitedQueue Class
Utils..::..LimitedQueue Members


Utils.LimitedQueue Methods

[image] [image]

Pastel Evolution SDK
Utils..::..LimitedQueue Methods
Utils..::..LimitedQueue Class See Also Send Feedback

The Utils..::..LimitedQueue type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes all objects from the Queue. (Inherited from Queue.)
Public method | Clone | Creates a shallow copy of the Queue. (Inherited from Queue.)
Public method | Contains | Determines whether an element is in the Queue. (Inherited from Queue.)
Public method | CopyTo | Copies the Queue elements to an existing one-dimensional Array, starting at the specified array index. (Inherited from Queue.)
Public method | Dequeue | Removes and returns the object at the beginning of the Queue. (Inherited from Queue.)
Public method | Enqueue |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Queue. (Inherited from Queue.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Peek | Returns the object at the beginning of the Queue without removing it. (Inherited from Queue.)
Public method | ToArray | Copies the Queue elements to a new array. (Inherited from Queue.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TrimToSize | Sets the capacity to the actual number of elements in the Queue. (Inherited from Queue.)

See Also

Utils..::..LimitedQueue Class


Utils.LimitedQueue.Enqueue Method

[image]

Pastel Evolution SDK
Utils..::..LimitedQueue..::..Enqueue Method
Utils..::..LimitedQueue Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void Enqueue(
    Object item
)
Visual Basic
Public Sub Enqueue (
    item As Object
)

Parameters

item
Type: System..::..Object

See Also

Utils..::..LimitedQueue Class
Utils..::..LimitedQueue Members


Utils.LimitedQueue Properties

[image] [image]

Pastel Evolution SDK
Utils..::..LimitedQueue Properties
Utils..::..LimitedQueue Class See Also Send Feedback

The Utils..::..LimitedQueue type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the Queue. (Inherited from Queue.)
Public property | IsSynchronized | Gets a value indicating whether access to the Queue is synchronized (thread safe). (Inherited from Queue.)
Public property | Limit |
Public property | SyncRoot | Gets an object that can be used to synchronize access to the Queue. (Inherited from Queue.)

See Also

Utils..::..LimitedQueue Class


Utils.LimitedQueue.Limit Property

[image]

Pastel Evolution SDK
Utils..::..LimitedQueue..::..Limit Property
Utils..::..LimitedQueue Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int Limit { get; set; }
Visual Basic
Public Property Limit As Integer
    Get
    Set

Property Value

Type: Int32

See Also

Utils..::..LimitedQueue Class
Utils..::..LimitedQueue Members


Warehouse Class

[image]

Pastel Evolution SDK
Warehouse Class
Members See Also Send Feedback
Represents an inventory warehouse.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class Warehouse : AccountBase
Visual Basic
Public Class Warehouse
    Inherits AccountBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..AccountBase
Pastel.Evolution..::..Warehouse

See Also

Warehouse Members


Warehouse Members

[image] [image]

Pastel Evolution SDK
Warehouse Members
Warehouse Class Constructors Methods Fields Properties See Also Send Feedback

The Warehouse type exposes the following members.

Constructors

 | Name | Description
Public method | Warehouse()()()() | Creates a new instance of a warehouse.
Public method | Warehouse(Int32) | Creates a new instance of a warehouse.
Public method | Warehouse(String) | Creates a new instance of a warehouse.

Methods

 | Name | Description
 | _Exists | Experimental method.
 | _Select(String) | Experimental Method
 | _Select(String, String) |
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds and returns the ID of the first record matching the criteria supplied.
 | FindByCode | Attempts to find a warehouse by its code and returns its ID.
 | Get |
 | GetByCode | Returns a warehouse object corresponding to the code specified; otherwise, returns null.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMaster | Returns the master warehouse.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List(String) | Lists warehouses for the supplied criteria.
 | List(String, String) | Lists warehouses for the supplied criteria.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | (Overrides AccountBase..::..OnDelete()()()().)
Protected method | OnSave | (Overrides AccountBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | (Overrides AccountBase..::..ToString()()()().)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | Active | Gets or sets the record's operational state. (Overrides AccountBase..::..Active.)
Public property | AddNewStock | Gets or sets whether or not new items are automatically linked to this warehouse.
Public property | Address1 | Gets or sets the warehouse's address line 1.
Public property | Address2 | Gets or sets the warehouse's address line 2.
Public property | Address3 | Gets or sets the warehouse's address line 3.
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Code | Gets or sets the warehouse's code. (Overrides AccountBase..::..Code.)
Public property | DefaultWarehouse | Gets the warehouse's default status (true for the 'master' warehouse).
Public property | Description | Gets or sets the warehouse's description. (Overrides AccountBase..::..Description.)
Public property | EMailAddress | Gets or sets the warehouse's email address.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | KnownAs | Gets or sets the warehouse's common name.
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | Manager | Gets or sets the warehouse manager's name.
Public property | ModemTel | Gets or sets the warehouse's modem telephone number.
Public property | Module | Gets the Evolution module this record forms a part of. (Overrides AccountBase..::..Module.)
Public property | PostalCode | Gets or sets the warehouse's postal code.
Public property | Telephone | Gets or sets the warehouse's telephone number.

See Also

Warehouse Class


Warehouse Constructor

[image] [image]

Pastel Evolution SDK
Warehouse Constructor
Warehouse Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Warehouse()()()() | Creates a new instance of a warehouse.
Public method | Warehouse(Int32) | Creates a new instance of a warehouse.
Public method | Warehouse(String) | Creates a new instance of a warehouse.

See Also

Warehouse Class
Warehouse Members


Warehouse Constructor

[image]

Pastel Evolution SDK
Warehouse Constructor
Warehouse Class See Also Send Feedback
Creates a new instance of a warehouse.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Warehouse()
Visual Basic
Public Sub New

See Also

Warehouse Class
Warehouse Members
Warehouse Overload


Warehouse Constructor (Int32)

[image]

Pastel Evolution SDK
Warehouse Constructor (Int32)
Warehouse Class See Also Send Feedback
Creates a new instance of a warehouse.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Warehouse(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32
Specifies the id of the existing record.

See Also

Warehouse Class
Warehouse Members
Warehouse Overload


Warehouse Constructor (String)

[image]

Pastel Evolution SDK
Warehouse Constructor (String)
Warehouse Class See Also Send Feedback
Creates a new instance of a warehouse.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Warehouse(
    string code
)
Visual Basic
Public Sub New (
    code As String
)

Parameters

code
Type: System..::..String
Specifies the code of the existing record.

See Also

Warehouse Class
Warehouse Members
Warehouse Overload


Warehouse Fields

[image] [image]

Pastel Evolution SDK
Warehouse Fields
Warehouse Class See Also Send Feedback

The Warehouse type exposes the following members.

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

Warehouse Class


Warehouse Methods

[image] [image]

Pastel Evolution SDK
Warehouse Methods
Warehouse Class See Also Send Feedback

The Warehouse type exposes the following members.

Methods

 | Name | Description
 | _Exists | Experimental method.
 | _Select(String) | Experimental Method
 | _Select(String, String) |
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds and returns the ID of the first record matching the criteria supplied.
 | FindByCode | Attempts to find a warehouse by its code and returns its ID.
 | Get |
 | GetByCode | Returns a warehouse object corresponding to the code specified; otherwise, returns null.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMaster | Returns the master warehouse.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List(String) | Lists warehouses for the supplied criteria.
 | List(String, String) | Lists warehouses for the supplied criteria.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | (Overrides AccountBase..::..OnDelete()()()().)
Protected method | OnSave | (Overrides AccountBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | (Overrides AccountBase..::..ToString()()()().)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

Warehouse Class


Warehouse._Exists Method

[image]

Pastel Evolution SDK
Warehouse..::.._Exists Method
Warehouse Class See Also Send Feedback
Experimental method.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static bool _Exists(
    string code
)
Visual Basic
Public Shared Function _Exists (
    code As String
) As Boolean

Parameters

code
Type: System..::..String

Return Value

Type: Boolean

See Also

Warehouse Class
Warehouse Members


Warehouse._Select Method

[image] [image]

Pastel Evolution SDK
Warehouse..::.._Select Method
Warehouse Class See Also Send Feedback

Overload List

Name | Description
_Select(String) | Experimental Method
_Select(String, String) |

See Also

Warehouse Class
Warehouse Members


Warehouse._Select Method (String)

[image]

Pastel Evolution SDK
Warehouse..::.._Select Method (String)
Warehouse Class See Also Send Feedback
Experimental Method

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static Warehouse[] _Select(
    string criteria
)
Visual Basic
Public Shared Function _Select (
    criteria As String
) As Warehouse()

Parameters

criteria
Type: System..::..String

Return Value

Type: array< Warehouse >[]()[][]

See Also

Warehouse Class
Warehouse Members
_Select Overload


Warehouse._Select Method (String, String)

[image]

Pastel Evolution SDK
Warehouse..::.._Select Method (String, String)
Warehouse Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static Warehouse[] _Select(
    string criteria,
    string sortOrder
)
Visual Basic
Public Shared Function _Select (
    criteria As String,
    sortOrder As String
) As Warehouse()

Parameters

criteria
Type: System..::..String
sortOrder
Type: System..::..String

Return Value

Type: array< Warehouse >[]()[][]

See Also

Warehouse Class
Warehouse Members
_Select Overload


Warehouse.Find Method

[image]

Pastel Evolution SDK
Warehouse..::..Find Method
Warehouse Class See Also Send Feedback
Finds and returns the ID of the first record matching the criteria supplied.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String
E.g. Code = 'abc' or Name like '%MASTER%'

Return Value

Type: Int32
The id of the record

See Also

Warehouse Class
Warehouse Members


Warehouse.FindByCode Method

[image]

Pastel Evolution SDK
Warehouse..::..FindByCode Method
Warehouse Class See Also Send Feedback
Attempts to find a warehouse by its code and returns its ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int FindByCode(
    string code
)
Visual Basic
Public Shared Function FindByCode (
    code As String
) As Integer

Parameters

code
Type: System..::..String
The code used to lookup the warehouse.

Return Value

Type: Int32
-1 if no record was found, else the id of the first account matching the criteria supplied.

See Also

Warehouse Class
Warehouse Members
Pastel.Evolution Namespace
Warehouse..::..Find(String)


Warehouse.Get Method

[image]

Pastel Evolution SDK
Warehouse..::..Get Method
Warehouse Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static Warehouse Get(
    string criteria
)
Visual Basic
Public Shared Function Get (
    criteria As String
) As Warehouse

Parameters

criteria
Type: System..::..String
Eg. Code = 'STO0021' or Description like '%Stone%'

Return Value

Type: Warehouse

See Also

Warehouse Class
Warehouse Members
Pastel.Evolution Namespace
Warehouse..::..Find(String)


Warehouse.GetByCode Method

[image]

Pastel Evolution SDK
Warehouse..::..GetByCode Method
Warehouse Class See Also Send Feedback
Returns a warehouse object corresponding to the code specified; otherwise, returns null.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static Warehouse GetByCode(
    string code
)
Visual Basic
Public Shared Function GetByCode (
    code As String
) As Warehouse

Parameters

code
Type: System..::..String
Specifies the code.

Return Value

Type: Warehouse
The record found; otherwise null

See Also

Warehouse Class
Warehouse Members


Warehouse.GetMaster Method

[image]

Pastel Evolution SDK
Warehouse..::..GetMaster Method
Warehouse Class See Also Send Feedback
Returns the master warehouse.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static Warehouse GetMaster()
Visual Basic
Public Shared Function GetMaster As Warehouse

Return Value

Type: Warehouse

See Also

Warehouse Class
Warehouse Members


Warehouse.List Method

[image] [image]

Pastel Evolution SDK
Warehouse..::..List Method
Warehouse Class See Also Send Feedback

Overload List

Name | Description
List(String) | Lists warehouses for the supplied criteria.
List(String, String) | Lists warehouses for the supplied criteria.

See Also

Warehouse Class
Warehouse Members


Warehouse.List Method (String)

[image]

Pastel Evolution SDK
Warehouse..::..List Method (String)
Warehouse Class See Also Send Feedback
Lists warehouses for the supplied criteria.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria
)
Visual Basic
Public Shared Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String

Return Value

Type: DataTable

See Also

Warehouse Class
Warehouse Members
List Overload


Warehouse.List Method (String, String)

[image]

Pastel Evolution SDK
Warehouse..::..List Method (String, String)
Warehouse Class See Also Send Feedback
Lists warehouses for the supplied criteria.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria,
    string sortOrder
)
Visual Basic
Public Shared Function List (
    criteria As String,
    sortOrder As String
) As DataTable

Parameters

criteria
Type: System..::..String
The SQL criteria used to locate the record, e.g. Name like '1___'
sortOrder
Type: System..::..String
The SQL order by clause to use, e.g. Address1 desc, Name

Return Value

Type: DataTable

See Also

Warehouse Class
Warehouse Members
List Overload


Warehouse.OnDelete Method

[image]

Pastel Evolution SDK
Warehouse..::..OnDelete Method
Warehouse Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

See Also

Warehouse Class
Warehouse Members


Warehouse.OnSave Method

[image]

Pastel Evolution SDK
Warehouse..::..OnSave Method
Warehouse Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

Warehouse Class
Warehouse Members


Warehouse.ToString Method

[image]

Pastel Evolution SDK
Warehouse..::..ToString Method
Warehouse Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String

See Also

Warehouse Class
Warehouse Members


Warehouse Properties

[image] [image]

Pastel Evolution SDK
Warehouse Properties
Warehouse Class See Also Send Feedback

The Warehouse type exposes the following members.

Properties

 | Name | Description
Public property | Active | Gets or sets the record's operational state. (Overrides AccountBase..::..Active.)
Public property | AddNewStock | Gets or sets whether or not new items are automatically linked to this warehouse.
Public property | Address1 | Gets or sets the warehouse's address line 1.
Public property | Address2 | Gets or sets the warehouse's address line 2.
Public property | Address3 | Gets or sets the warehouse's address line 3.
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Code | Gets or sets the warehouse's code. (Overrides AccountBase..::..Code.)
Public property | DefaultWarehouse | Gets the warehouse's default status (true for the 'master' warehouse).
Public property | Description | Gets or sets the warehouse's description. (Overrides AccountBase..::..Description.)
Public property | EMailAddress | Gets or sets the warehouse's email address.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | KnownAs | Gets or sets the warehouse's common name.
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | Manager | Gets or sets the warehouse manager's name.
Public property | ModemTel | Gets or sets the warehouse's modem telephone number.
Public property | Module | Gets the Evolution module this record forms a part of. (Overrides AccountBase..::..Module.)
Public property | PostalCode | Gets or sets the warehouse's postal code.
Public property | Telephone | Gets or sets the warehouse's telephone number.

See Also

Warehouse Class


Warehouse.Active Property

[image]

Pastel Evolution SDK
Warehouse..::..Active Property
Warehouse Class See Also Send Feedback
Gets or sets the record's operational state.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override bool Active { get; set; }
Visual Basic
Public Overrides Property Active As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

Warehouse Class
Warehouse Members


Warehouse.AddNewStock Property

[image]

Pastel Evolution SDK
Warehouse..::..AddNewStock Property
Warehouse Class See Also Send Feedback
Gets or sets whether or not new items are automatically linked to this warehouse.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool AddNewStock { get; set; }
Visual Basic
Public Property AddNewStock As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

Warehouse Class
Warehouse Members


Warehouse.Address1 Property

[image]

Pastel Evolution SDK
Warehouse..::..Address1 Property
Warehouse Class See Also Send Feedback
Gets or sets the warehouse's address line 1.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Address1 { get; set; }
Visual Basic
Public Property Address1 As String
    Get
    Set

Property Value

Type: String

See Also

Warehouse Class
Warehouse Members


Warehouse.Address2 Property

[image]

Pastel Evolution SDK
Warehouse..::..Address2 Property
Warehouse Class See Also Send Feedback
Gets or sets the warehouse's address line 2.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Address2 { get; set; }
Visual Basic
Public Property Address2 As String
    Get
    Set

Property Value

Type: String

See Also

Warehouse Class
Warehouse Members


Warehouse.Address3 Property

[image]

Pastel Evolution SDK
Warehouse..::..Address3 Property
Warehouse Class See Also Send Feedback
Gets or sets the warehouse's address line 3.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Address3 { get; set; }
Visual Basic
Public Property Address3 As String
    Get
    Set

Property Value

Type: String

See Also

Warehouse Class
Warehouse Members


Warehouse.Code Property

[image]

Pastel Evolution SDK
Warehouse..::..Code Property
Warehouse Class See Also Send Feedback
Gets or sets the warehouse's code.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override string Code { get; set; }
Visual Basic
Public Overrides Property Code As String
    Get
    Set

Property Value

Type: String

See Also

Warehouse Class
Warehouse Members


Warehouse.DefaultWarehouse Property

[image]

Pastel Evolution SDK
Warehouse..::..DefaultWarehouse Property
Warehouse Class See Also Send Feedback
Gets the warehouse's default status (true for the 'master' warehouse).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool DefaultWarehouse { get; }
Visual Basic
Public ReadOnly Property DefaultWarehouse As Boolean
    Get

Property Value

Type: Boolean

See Also

Warehouse Class
Warehouse Members


Warehouse.Description Property

[image]

Pastel Evolution SDK
Warehouse..::..Description Property
Warehouse Class See Also Send Feedback
Gets or sets the warehouse's description.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override string Description { get; set; }
Visual Basic
Public Overrides Property Description As String
    Get
    Set

Property Value

Type: String

See Also

Warehouse Class
Warehouse Members


Warehouse.EMailAddress Property

[image]

Pastel Evolution SDK
Warehouse..::..EMailAddress Property
Warehouse Class See Also Send Feedback
Gets or sets the warehouse's email address.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string EMailAddress { get; set; }
Visual Basic
Public Property EMailAddress As String
    Get
    Set

Property Value

Type: String

See Also

Warehouse Class
Warehouse Members


Warehouse.ID Property

[image]

Pastel Evolution SDK
Warehouse..::..ID Property
Warehouse Class See Also Send Feedback
Gets the internal record ID (0 for new, unsaved records).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

Remarks

Once saved, the ID will reflect the record's internal database identifier.

See Also

Warehouse Class
Warehouse Members


Warehouse.KnownAs Property

[image]

Pastel Evolution SDK
Warehouse..::..KnownAs Property
Warehouse Class See Also Send Feedback
Gets or sets the warehouse's common name.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string KnownAs { get; set; }
Visual Basic
Public Property KnownAs As String
    Get
    Set

Property Value

Type: String

See Also

Warehouse Class
Warehouse Members


Warehouse.LongID Property

[image]

Pastel Evolution SDK
Warehouse..::..LongID Property
Warehouse Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

Warehouse Class
Warehouse Members


Warehouse.Manager Property

[image]

Pastel Evolution SDK
Warehouse..::..Manager Property
Warehouse Class See Also Send Feedback
Gets or sets the warehouse manager's name.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Manager { get; set; }
Visual Basic
Public Property Manager As String
    Get
    Set

Property Value

Type: String

See Also

Warehouse Class
Warehouse Members


Warehouse.ModemTel Property

[image]

Pastel Evolution SDK
Warehouse..::..ModemTel Property
Warehouse Class See Also Send Feedback
Gets or sets the warehouse's modem telephone number.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string ModemTel { get; set; }
Visual Basic
Public Property ModemTel As String
    Get
    Set

Property Value

Type: String

See Also

Warehouse Class
Warehouse Members


Warehouse.Module Property

[image]

Pastel Evolution SDK
Warehouse..::..Module Property
Warehouse Class See Also Send Feedback
Gets the Evolution module this record forms a part of.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override Module Module { get; }
Visual Basic
Public Overrides ReadOnly Property Module As Module
    Get

Property Value

Type: Module

See Also

Warehouse Class
Warehouse Members


Warehouse.PostalCode Property

[image]

Pastel Evolution SDK
Warehouse..::..PostalCode Property
Warehouse Class See Also Send Feedback
Gets or sets the warehouse's postal code.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string PostalCode { get; set; }
Visual Basic
Public Property PostalCode As String
    Get
    Set

Property Value

Type: String

See Also

Warehouse Class
Warehouse Members


Warehouse.Telephone Property

[image]

Pastel Evolution SDK
Warehouse..::..Telephone Property
Warehouse Class See Also Send Feedback
Gets or sets the warehouse's telephone number.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Telephone { get; set; }
Visual Basic
Public Property Telephone As String
    Get
    Set

Property Value

Type: String

See Also

Warehouse Class
Warehouse Members


WarehouseContext Class

[image]

Pastel Evolution SDK
WarehouseContext Class
Members See Also Send Feedback
Represents an inventory item's context within a give warehouse.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class WarehouseContext : BranchedRecordBase
Visual Basic
Public Class WarehouseContext
    Inherits BranchedRecordBase

Remarks

Inventory items are selectively linked to warehouses. The WarehouseContext class represents that link and provides access the item's quantities within the specific warehouse.

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..WarehouseContext

See Also

WarehouseContext Members


WarehouseContext Members

[image] [image]

Pastel Evolution SDK
WarehouseContext Members
WarehouseContext Class Constructors Methods Fields Properties See Also Send Feedback

The WarehouseContext type exposes the following members.

Constructors

 | Name | Description
Public method | WarehouseContext(InventoryItem, Warehouse) | Creates a new instance of a warehouse context record.
Public method | WarehouseContext(InventoryItem, Int32) | Creates a new instance of a warehouse context record.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds a record's database ID.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransferStock |
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | AllowNegativeQty | Gets or sets whether or not a negative stock level is allowed for the given item in the given warehouse.
Public property | AllowNegativeStock | Whether or not the item allows for negative stock.
Public property | AverageUnitCost | Gets the effective unit cost applicable to this item/warehouse combination. If warehouse costing is disabled, the item's global cost will be returned.
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Group | Gets the group in this warehouse.
Public property | HighestUnitCost | Gets the maximum reached unit cost applicable to this item/warehouse combination. If warehouse costing is disabled, the item's global cost will be returned.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | InventoryItem | Gets the object's stock item.
Public property | LatestUnitCost | Gets the latest unit cost applicable to this item/warehouse combination. If warehouse costing is disabled, the item's global cost will be returned.
Public property | LongID | Transitional accessor. (Overrides RecordBase..::..LongID.)
Public property | LowestUnitCost | Gets the minimum reached unit cost applicable to this item/warehouse combination. If warehouse costing is disabled, the item's global cost will be returned.
Public property | QtyFree | Gets the item's quantity free in this warehouse.
Public property | QtyOnHand | Gets the item's quantity on hand in this warehouse.
Public property | QtyOnPurchaseOrder | Gets the item's quantity on purchase order in this warehouse.
Public property | QtyOnSalesOrder | Gets the item's quantity on sales order in this warehouse.
Public property | QtyReserved | Gets the item's quantity reserved in this warehouse.
Public property | QtyWIP | Gets the item's work-in-progress quantity in this warehouse.
Public property | SellingPrices | Gets the Selling Prices for the Current Warehouse.
Public property | StandardUnitCost | Gets the standard unit cost applicable to this item/warehouse combination. If warehouse costing is disabled, the item's global cost will be returned.
Public property | UnitCost | Gets the effective unit cost applicable to this item/warehouse combination. If warehouse costing is disabled, the item's global cost will be returned.
Public property | UseItemDefaults | Gets or sets whether to apply the item's defaults to this warehouse context.
Public property | UseItemInformationDefaults | Gets or sets whether to apply the item's information defaults to this warehouse context.
Public property | UseItemOrderingLevels | Gets or sets whether to apply the item's ordering levels to this warehouse context.
Public property | UseItemPricing | Gets or sets whether to apply the item's pricing to this warehouse context.
Public property | UseItemSuppliers | Gets or sets whether to apply the item's suppliers to this warehouse context.
Public property | Warehouse | Gets the object's warehouse.

See Also

WarehouseContext Class


WarehouseContext Constructor

[image] [image]

Pastel Evolution SDK
WarehouseContext Constructor
WarehouseContext Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WarehouseContext(InventoryItem, Warehouse) | Creates a new instance of a warehouse context record.
Public method | WarehouseContext(InventoryItem, Int32) | Creates a new instance of a warehouse context record.

See Also

WarehouseContext Class
WarehouseContext Members


WarehouseContext Constructor (InventoryItem, Warehouse)

[image]

Pastel Evolution SDK
WarehouseContext Constructor (InventoryItem, Warehouse)
WarehouseContext Class See Also Send Feedback
Creates a new instance of a warehouse context record.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public WarehouseContext(
    InventoryItem item,
    Warehouse warehouse
)
Visual Basic
Public Sub New (
    item As InventoryItem,
    warehouse As Warehouse
)

Parameters

item
Type: Pastel.Evolution..::..InventoryItem
Specifies the inventory item.
warehouse
Type: Pastel.Evolution..::..Warehouse
Specifies the warehouse.

See Also

WarehouseContext Class
WarehouseContext Members
WarehouseContext Overload


WarehouseContext Constructor (InventoryItem, Int32)

[image]

Pastel Evolution SDK
WarehouseContext Constructor (InventoryItem, Int32)
WarehouseContext Class See Also Send Feedback
Creates a new instance of a warehouse context record.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public WarehouseContext(
    InventoryItem item,
    int warehouseID
)
Visual Basic
Public Sub New (
    item As InventoryItem,
    warehouseID As Integer
)

Parameters

item
Type: Pastel.Evolution..::..InventoryItem
Specifies the inventory item.
warehouseID
Type: System..::..Int32
Specifies the warehouse id.

See Also

WarehouseContext Class
WarehouseContext Members
WarehouseContext Overload


WarehouseContext Fields

[image] [image]

Pastel Evolution SDK
WarehouseContext Fields
WarehouseContext Class See Also Send Feedback

The WarehouseContext type exposes the following members.

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

WarehouseContext Class


WarehouseContext Methods

[image] [image]

Pastel Evolution SDK
WarehouseContext Methods
WarehouseContext Class See Also Send Feedback

The WarehouseContext type exposes the following members.

Methods

 | Name | Description
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds a record's database ID.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List | Gets a list of database records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides RecordBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides RecordBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransferStock |
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

WarehouseContext Class


WarehouseContext.Find Method

[image]

Pastel Evolution SDK
WarehouseContext..::..Find Method
WarehouseContext Class See Also Send Feedback
Finds a record's database ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.

Return Value

Type: Int32
The ID of the first record found; -1 if not record was found.

See Also

WarehouseContext Class
WarehouseContext Members


WarehouseContext.List Method

[image]

Pastel Evolution SDK
WarehouseContext..::..List Method
WarehouseContext Class See Also Send Feedback
Gets a list of database records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria
)
Visual Basic
Public Shared Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String
Specifies the criteria as a SQL where clause.

Return Value

Type: DataTable
Table containing selected records.

See Also

WarehouseContext Class
WarehouseContext Members


WarehouseContext.OnDelete Method

[image]

Pastel Evolution SDK
WarehouseContext..::..OnDelete Method
WarehouseContext Class See Also Send Feedback
Removes the record from the database, provided it is not referenced by other records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

See Also

WarehouseContext Class
WarehouseContext Members


WarehouseContext.OnSave Method

[image]

Pastel Evolution SDK
WarehouseContext..::..OnSave Method
WarehouseContext Class See Also Send Feedback
Persists the record to the database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

WarehouseContext Class
WarehouseContext Members


WarehouseContext.TransferStock Method

[image]

Pastel Evolution SDK
WarehouseContext..::..TransferStock Method
WarehouseContext Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void TransferStock()
Visual Basic
Public Sub TransferStock

See Also

WarehouseContext Class
WarehouseContext Members


WarehouseContext Properties

[image] [image]

Pastel Evolution SDK
WarehouseContext Properties
WarehouseContext Class See Also Send Feedback

The WarehouseContext type exposes the following members.

Properties

 | Name | Description
Public property | AllowNegativeQty | Gets or sets whether or not a negative stock level is allowed for the given item in the given warehouse.
Public property | AllowNegativeStock | Whether or not the item allows for negative stock.
Public property | AverageUnitCost | Gets the effective unit cost applicable to this item/warehouse combination. If warehouse costing is disabled, the item's global cost will be returned.
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Group | Gets the group in this warehouse.
Public property | HighestUnitCost | Gets the maximum reached unit cost applicable to this item/warehouse combination. If warehouse costing is disabled, the item's global cost will be returned.
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | InventoryItem | Gets the object's stock item.
Public property | LatestUnitCost | Gets the latest unit cost applicable to this item/warehouse combination. If warehouse costing is disabled, the item's global cost will be returned.
Public property | LongID | Transitional accessor. (Overrides RecordBase..::..LongID.)
Public property | LowestUnitCost | Gets the minimum reached unit cost applicable to this item/warehouse combination. If warehouse costing is disabled, the item's global cost will be returned.
Public property | QtyFree | Gets the item's quantity free in this warehouse.
Public property | QtyOnHand | Gets the item's quantity on hand in this warehouse.
Public property | QtyOnPurchaseOrder | Gets the item's quantity on purchase order in this warehouse.
Public property | QtyOnSalesOrder | Gets the item's quantity on sales order in this warehouse.
Public property | QtyReserved | Gets the item's quantity reserved in this warehouse.
Public property | QtyWIP | Gets the item's work-in-progress quantity in this warehouse.
Public property | SellingPrices | Gets the Selling Prices for the Current Warehouse.
Public property | StandardUnitCost | Gets the standard unit cost applicable to this item/warehouse combination. If warehouse costing is disabled, the item's global cost will be returned.
Public property | UnitCost | Gets the effective unit cost applicable to this item/warehouse combination. If warehouse costing is disabled, the item's global cost will be returned.
Public property | UseItemDefaults | Gets or sets whether to apply the item's defaults to this warehouse context.
Public property | UseItemInformationDefaults | Gets or sets whether to apply the item's information defaults to this warehouse context.
Public property | UseItemOrderingLevels | Gets or sets whether to apply the item's ordering levels to this warehouse context.
Public property | UseItemPricing | Gets or sets whether to apply the item's pricing to this warehouse context.
Public property | UseItemSuppliers | Gets or sets whether to apply the item's suppliers to this warehouse context.
Public property | Warehouse | Gets the object's warehouse.

See Also

WarehouseContext Class


WarehouseContext.AllowNegativeQty Property

[image]

Pastel Evolution SDK
WarehouseContext..::..AllowNegativeQty Property
WarehouseContext Class See Also Send Feedback
Gets or sets whether or not a negative stock level is allowed for the given item in the given warehouse.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool AllowNegativeQty { get; }
Visual Basic
Public ReadOnly Property AllowNegativeQty As Boolean
    Get

Property Value

Type: Boolean

See Also

WarehouseContext Class
WarehouseContext Members


WarehouseContext.AllowNegativeStock Property

[image]

Pastel Evolution SDK
WarehouseContext..::..AllowNegativeStock Property
WarehouseContext Class See Also Send Feedback
Whether or not the item allows for negative stock.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool AllowNegativeStock { get; }
Visual Basic
Public ReadOnly Property AllowNegativeStock As Boolean
    Get

Property Value

Type: Boolean

See Also

WarehouseContext Class
WarehouseContext Members
Pastel.Evolution Namespace
[!:Pastel.Evolution.InventoryItem.bAllowNegStock]


WarehouseContext.AverageUnitCost Property

[image]

Pastel Evolution SDK
WarehouseContext..::..AverageUnitCost Property
WarehouseContext Class See Also Send Feedback
Gets the effective unit cost applicable to this item/warehouse combination. If warehouse costing is disabled, the item's global cost will be returned.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double AverageUnitCost { get; }
Visual Basic
Public ReadOnly Property AverageUnitCost As Double
    Get

Property Value

Type: Double

See Also

WarehouseContext Class
WarehouseContext Members


WarehouseContext.Group Property

[image]

Pastel Evolution SDK
WarehouseContext..::..Group Property
WarehouseContext Class See Also Send Feedback
Gets the group in this warehouse.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public InventoryGroup Group { get; set; }
Visual Basic
Public Property Group As InventoryGroup
    Get
    Set

Property Value

Type: InventoryGroup

See Also

WarehouseContext Class
WarehouseContext Members


WarehouseContext.HighestUnitCost Property

[image]

Pastel Evolution SDK
WarehouseContext..::..HighestUnitCost Property
WarehouseContext Class See Also Send Feedback
Gets the maximum reached unit cost applicable to this item/warehouse combination. If warehouse costing is disabled, the item's global cost will be returned.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double HighestUnitCost { get; }
Visual Basic
Public ReadOnly Property HighestUnitCost As Double
    Get

Property Value

Type: Double

See Also

WarehouseContext Class
WarehouseContext Members


WarehouseContext.ID Property

[image]

Pastel Evolution SDK
WarehouseContext..::..ID Property
WarehouseContext Class See Also Send Feedback
Gets the internal record ID (0 for new, unsaved records).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

Remarks

Once saved, the ID will reflect the record's internal database identifier.

See Also

WarehouseContext Class
WarehouseContext Members


WarehouseContext.InventoryItem Property

[image]

Pastel Evolution SDK
WarehouseContext..::..InventoryItem Property
WarehouseContext Class See Also Send Feedback
Gets the object's stock item.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public InventoryItem InventoryItem { get; }
Visual Basic
Public ReadOnly Property InventoryItem As InventoryItem
    Get

Property Value

Type: InventoryItem

See Also

WarehouseContext Class
WarehouseContext Members


WarehouseContext.LatestUnitCost Property

[image]

Pastel Evolution SDK
WarehouseContext..::..LatestUnitCost Property
WarehouseContext Class See Also Send Feedback
Gets the latest unit cost applicable to this item/warehouse combination. If warehouse costing is disabled, the item's global cost will be returned.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double LatestUnitCost { get; }
Visual Basic
Public ReadOnly Property LatestUnitCost As Double
    Get

Property Value

Type: Double

See Also

WarehouseContext Class
WarehouseContext Members


WarehouseContext.LongID Property

[image]

Pastel Evolution SDK
WarehouseContext..::..LongID Property
WarehouseContext Class See Also Send Feedback
Transitional accessor.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

WarehouseContext Class
WarehouseContext Members


WarehouseContext.LowestUnitCost Property

[image]

Pastel Evolution SDK
WarehouseContext..::..LowestUnitCost Property
WarehouseContext Class See Also Send Feedback
Gets the minimum reached unit cost applicable to this item/warehouse combination. If warehouse costing is disabled, the item's global cost will be returned.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double LowestUnitCost { get; }
Visual Basic
Public ReadOnly Property LowestUnitCost As Double
    Get

Property Value

Type: Double

See Also

WarehouseContext Class
WarehouseContext Members


WarehouseContext.QtyFree Property

[image]

Pastel Evolution SDK
WarehouseContext..::..QtyFree Property
WarehouseContext Class See Also Send Feedback
Gets the item's quantity free in this warehouse.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double QtyFree { get; }
Visual Basic
Public ReadOnly Property QtyFree As Double
    Get

Property Value

Type: Double

See Also

WarehouseContext Class
WarehouseContext Members
Pastel.Evolution Namespace
InventoryItem..::..QtyFree


WarehouseContext.QtyOnHand Property

[image]

Pastel Evolution SDK
WarehouseContext..::..QtyOnHand Property
WarehouseContext Class See Also Send Feedback
Gets the item's quantity on hand in this warehouse.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double QtyOnHand { get; }
Visual Basic
Public ReadOnly Property QtyOnHand As Double
    Get

Property Value

Type: Double

See Also

WarehouseContext Class
WarehouseContext Members
Pastel.Evolution Namespace
InventoryItem..::..QtyOnHand


WarehouseContext.QtyOnPurchaseOrder Property

[image]

Pastel Evolution SDK
WarehouseContext..::..QtyOnPurchaseOrder Property
WarehouseContext Class See Also Send Feedback
Gets the item's quantity on purchase order in this warehouse.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double QtyOnPurchaseOrder { get; }
Visual Basic
Public ReadOnly Property QtyOnPurchaseOrder As Double
    Get

Property Value

Type: Double

See Also

WarehouseContext Class
WarehouseContext Members
Pastel.Evolution Namespace
InventoryItem..::..QtyOnPurchaseOrder


WarehouseContext.QtyOnSalesOrder Property

[image]

Pastel Evolution SDK
WarehouseContext..::..QtyOnSalesOrder Property
WarehouseContext Class See Also Send Feedback
Gets the item's quantity on sales order in this warehouse.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double QtyOnSalesOrder { get; }
Visual Basic
Public ReadOnly Property QtyOnSalesOrder As Double
    Get

Property Value

Type: Double

See Also

WarehouseContext Class
WarehouseContext Members
Pastel.Evolution Namespace
InventoryItem..::..QtyOnSalesOrder


WarehouseContext.QtyReserved Property

[image]

Pastel Evolution SDK
WarehouseContext..::..QtyReserved Property
WarehouseContext Class See Also Send Feedback
Gets the item's quantity reserved in this warehouse.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double QtyReserved { get; }
Visual Basic
Public ReadOnly Property QtyReserved As Double
    Get

Property Value

Type: Double

See Also

WarehouseContext Class
WarehouseContext Members
Pastel.Evolution Namespace
InventoryItem..::..QtyReserved


WarehouseContext.QtyWIP Property

[image]

Pastel Evolution SDK
WarehouseContext..::..QtyWIP Property
WarehouseContext Class See Also Send Feedback
Gets the item's work-in-progress quantity in this warehouse.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double QtyWIP { get; internal set; }
Visual Basic
Public Property QtyWIP As Double
    Get
    Friend Set

Property Value

Type: Double

See Also

WarehouseContext Class
WarehouseContext Members
Pastel.Evolution Namespace
InventoryItem..::..QtyWIP


WarehouseContext.SellingPrices Property

[image]

Pastel Evolution SDK
WarehouseContext..::..SellingPrices Property
WarehouseContext Class See Also Send Feedback
Gets the Selling Prices for the Current Warehouse.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public SellingPriceCollection SellingPrices { get; }
Visual Basic
Public ReadOnly Property SellingPrices As SellingPriceCollection
    Get

Property Value

Type: SellingPriceCollection

See Also

WarehouseContext Class
WarehouseContext Members


WarehouseContext.StandardUnitCost Property

[image]

Pastel Evolution SDK
WarehouseContext..::..StandardUnitCost Property
WarehouseContext Class See Also Send Feedback
Gets the standard unit cost applicable to this item/warehouse combination. If warehouse costing is disabled, the item's global cost will be returned.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double StandardUnitCost { get; }
Visual Basic
Public ReadOnly Property StandardUnitCost As Double
    Get

Property Value

Type: Double

See Also

WarehouseContext Class
WarehouseContext Members


WarehouseContext.UnitCost Property

[image]

Pastel Evolution SDK
WarehouseContext..::..UnitCost Property
WarehouseContext Class See Also Send Feedback
Gets the effective unit cost applicable to this item/warehouse combination. If warehouse costing is disabled, the item's global cost will be returned.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double UnitCost { get; }
Visual Basic
Public ReadOnly Property UnitCost As Double
    Get

Property Value

Type: Double

See Also

WarehouseContext Class
WarehouseContext Members


WarehouseContext.UseItemDefaults Property

[image]

Pastel Evolution SDK
WarehouseContext..::..UseItemDefaults Property
WarehouseContext Class See Also Send Feedback
Gets or sets whether to apply the item's defaults to this warehouse context.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool UseItemDefaults { get; internal set; }
Visual Basic
Public Property UseItemDefaults As Boolean
    Get
    Friend Set

Property Value

Type: Boolean

See Also

WarehouseContext Class
WarehouseContext Members


WarehouseContext.UseItemInformationDefaults Property

[image]

Pastel Evolution SDK
WarehouseContext..::..UseItemInformationDefaults Property
WarehouseContext Class See Also Send Feedback
Gets or sets whether to apply the item's information defaults to this warehouse context.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool UseItemInformationDefaults { get; internal set; }
Visual Basic
Public Property UseItemInformationDefaults As Boolean
    Get
    Friend Set

Property Value

Type: Boolean

See Also

WarehouseContext Class
WarehouseContext Members


WarehouseContext.UseItemOrderingLevels Property

[image]

Pastel Evolution SDK
WarehouseContext..::..UseItemOrderingLevels Property
WarehouseContext Class See Also Send Feedback
Gets or sets whether to apply the item's ordering levels to this warehouse context.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool UseItemOrderingLevels { get; internal set; }
Visual Basic
Public Property UseItemOrderingLevels As Boolean
    Get
    Friend Set

Property Value

Type: Boolean

See Also

WarehouseContext Class
WarehouseContext Members


WarehouseContext.UseItemPricing Property

[image]

Pastel Evolution SDK
WarehouseContext..::..UseItemPricing Property
WarehouseContext Class See Also Send Feedback
Gets or sets whether to apply the item's pricing to this warehouse context.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool UseItemPricing { get; internal set; }
Visual Basic
Public Property UseItemPricing As Boolean
    Get
    Friend Set

Property Value

Type: Boolean

See Also

WarehouseContext Class
WarehouseContext Members


WarehouseContext.UseItemSuppliers Property

[image]

Pastel Evolution SDK
WarehouseContext..::..UseItemSuppliers Property
WarehouseContext Class See Also Send Feedback
Gets or sets whether to apply the item's suppliers to this warehouse context.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool UseItemSuppliers { get; internal set; }
Visual Basic
Public Property UseItemSuppliers As Boolean
    Get
    Friend Set

Property Value

Type: Boolean

See Also

WarehouseContext Class
WarehouseContext Members


WarehouseContext.Warehouse Property

[image]

Pastel Evolution SDK
WarehouseContext..::..Warehouse Property
WarehouseContext Class See Also Send Feedback
Gets the object's warehouse.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Warehouse Warehouse { get; }
Visual Basic
Public ReadOnly Property Warehouse As Warehouse
    Get

Property Value

Type: Warehouse

See Also

WarehouseContext Class
WarehouseContext Members


WarehouseContextCollection Class

[image]

Pastel Evolution SDK
WarehouseContextCollection Class
Members See Also Send Feedback
Represents a collection of warehouse context records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class WarehouseContextCollection : CollectionBase
Visual Basic
Public Class WarehouseContextCollection
    Inherits CollectionBase

Inheritance Hierarchy

System..::..Object
System.Collections..::..CollectionBase
Pastel.Evolution..::..WarehouseContextCollection

See Also

WarehouseContextCollection Members
Pastel.Evolution Namespace
Pastel.Evolution..::..WarehouseContext


WarehouseContextCollection Members

[image] [image]

Pastel Evolution SDK
WarehouseContextCollection Members
WarehouseContextCollection Class Constructors Methods Properties See Also Send Feedback

The WarehouseContextCollection type exposes the following members.

Constructors

 | Name | Description
Public method | WarehouseContextCollection | Initializes a new instance of the WarehouseContextCollection class

Methods

 | Name | Description
Public method | Add(String) |
Public method | Add(Warehouse) |
Public method | Add(WarehouseContext) |
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item[([( Int32])]) | Gets a warehouse context by warehouse ID, not by index.
Public property | Item[([( String])]) | Gets the warehouse context object relating to the current item and the warehouse code specified.
Public property | Item[([( Warehouse])]) |
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

WarehouseContextCollection Class


WarehouseContextCollection Constructor

[image]

Pastel Evolution SDK
WarehouseContextCollection Constructor
WarehouseContextCollection Class See Also Send Feedback
Initializes a new instance of the WarehouseContextCollection class

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public WarehouseContextCollection(
    InventoryItem stockItem
)
Visual Basic
Public Sub New (
    stockItem As InventoryItem
)

Parameters

stockItem
Type: Pastel.Evolution..::..InventoryItem

See Also

WarehouseContextCollection Class
WarehouseContextCollection Members


WarehouseContextCollection Methods

[image] [image]

Pastel Evolution SDK
WarehouseContextCollection Methods
WarehouseContextCollection Class See Also Send Feedback

The WarehouseContextCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add(String) |
Public method | Add(Warehouse) |
Public method | Add(WarehouseContext) |
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WarehouseContextCollection Class


WarehouseContextCollection.Add Method

[image] [image]

Pastel Evolution SDK
WarehouseContextCollection..::..Add Method
WarehouseContextCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Add(String) |
Public method | Add(Warehouse) |
Public method | Add(WarehouseContext) |

See Also

WarehouseContextCollection Class
WarehouseContextCollection Members


WarehouseContextCollection.Add Method (String)

[image]

Pastel Evolution SDK
WarehouseContextCollection..::..Add Method (String)
WarehouseContextCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void Add(
    string whseCode
)
Visual Basic
Public Sub Add (
    whseCode As String
)

Parameters

whseCode
Type: System..::..String

See Also

WarehouseContextCollection Class
WarehouseContextCollection Members
Add Overload


WarehouseContextCollection.Add Method (Warehouse)

[image]

Pastel Evolution SDK
WarehouseContextCollection..::..Add Method (Warehouse)
WarehouseContextCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void Add(
    Warehouse whse
)
Visual Basic
Public Sub Add (
    whse As Warehouse
)

Parameters

whse
Type: Pastel.Evolution..::..Warehouse

See Also

WarehouseContextCollection Class
WarehouseContextCollection Members
Add Overload


WarehouseContextCollection.Add Method (WarehouseContext)

[image]

Pastel Evolution SDK
WarehouseContextCollection..::..Add Method (WarehouseContext)
WarehouseContextCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void Add(
    WarehouseContext data
)
Visual Basic
Public Sub Add (
    data As WarehouseContext
)

Parameters

data
Type: Pastel.Evolution..::..WarehouseContext

See Also

WarehouseContextCollection Class
WarehouseContextCollection Members
Add Overload


WarehouseContextCollection Properties

[image] [image]

Pastel Evolution SDK
WarehouseContextCollection Properties
WarehouseContextCollection Class See Also Send Feedback

The WarehouseContextCollection type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item[([( Int32])]) | Gets a warehouse context by warehouse ID, not by index.
Public property | Item[([( String])]) | Gets the warehouse context object relating to the current item and the warehouse code specified.
Public property | Item[([( Warehouse])]) |
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

WarehouseContextCollection Class


WarehouseContextCollection.Item Property

[image] [image]

Pastel Evolution SDK
WarehouseContextCollection..::..Item Property
WarehouseContextCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public property | Item[([( Int32])]) | Gets a warehouse context by warehouse ID, not by index.
Public property | Item[([( String])]) | Gets the warehouse context object relating to the current item and the warehouse code specified.
Public property | Item[([( Warehouse])]) |

See Also

WarehouseContextCollection Class
WarehouseContextCollection Members


WarehouseContextCollection.Item Property (Int32)

[image]

Pastel Evolution SDK
WarehouseContextCollection..::..Item Property (Int32)
WarehouseContextCollection Class See Also Send Feedback
Gets a warehouse context by warehouse ID, not by index.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public WarehouseContext this[
    int warehouseID
] { get; }
Visual Basic
Public ReadOnly Default Property Item (
    warehouseID As Integer
) As WarehouseContext
    Get

Parameters

warehouseID
Type: System..::..Int32

Return Value

Type: WarehouseContext

See Also

WarehouseContextCollection Class
WarehouseContextCollection Members
Item Overload


WarehouseContextCollection.Item Property (String)

[image]

Pastel Evolution SDK
WarehouseContextCollection..::..Item Property (String)
WarehouseContextCollection Class See Also Send Feedback
Gets the warehouse context object relating to the current item and the warehouse code specified.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public WarehouseContext this[
    string warehouseCode
] { get; }
Visual Basic
Public ReadOnly Default Property Item (
    warehouseCode As String
) As WarehouseContext
    Get

Parameters

warehouseCode
Type: System..::..String

Return Value

Type: WarehouseContext

See Also

WarehouseContextCollection Class
WarehouseContextCollection Members
Item Overload


WarehouseContextCollection.Item Property (Warehouse)

[image]

Pastel Evolution SDK
WarehouseContextCollection..::..Item Property (Warehouse)
WarehouseContextCollection Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public WarehouseContext this[
    Warehouse warehouse
] { get; }
Visual Basic
Public ReadOnly Default Property Item (
    warehouse As Warehouse
) As WarehouseContext
    Get

Parameters

warehouse
Type: Pastel.Evolution..::..Warehouse

Property Value

Type: WarehouseContext

See Also

WarehouseContextCollection Class
WarehouseContextCollection Members
Item Overload


WarehouseTransfer Class

[image]

Pastel Evolution SDK
WarehouseTransfer Class
Members See Also Send Feedback
Represents a warehouse transfer transaction.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class WarehouseTransfer
Visual Basic
Public Class WarehouseTransfer

Remarks

A warehouse transfer results in two independent inventory transactions, grouped into the same audit batch. You cannot retrieve

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..WarehouseTransfer

See Also

WarehouseTransfer Members


WarehouseTransfer Members

[image] [image]

Pastel Evolution SDK
WarehouseTransfer Members
WarehouseTransfer Class Constructors Methods Properties See Also Send Feedback

The WarehouseTransfer type exposes the following members.

Constructors

 | Name | Description
Public method | WarehouseTransfer | Creates a new instance of a warehouse transfer transaction.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Post | Processes the transfer.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Validate | Validates the transaction without attempting to post.

Properties

 | Name | Description
Public property | Account | Gets or sets the warehouse transfer's account (stock item).
Public property | AccountID | Gets or sets the warehouse transfer's account id.
Public property | Audit | Gets the transaction's audit number.
Public property | Date | Gets or sets the date on which the transfer takes place.
Public property | Description | Gets or sets the warehouse transfer description.
Public property | ExtOrderNo | Gets or sets the warehouse transfer's external order number, if relevant.
Public property | FromWarehouse | Gets or sets the warehouse from which goods will be transferred.
Public property | InventoryItem | Gets or sets the warehouse transfer's account (stock item).
Public property | Lot |
Public property | ModID | Gets or sets the transaction's module identifier.
Public property | Module | Gets the Evolution module this record forms a part of.
Public property | OrderNo | Gets or sets the warehouse transfer's order number, if relevant.
Public property | Project | Sets the warehouse transfer's project.
Public property | ProjectID | Gets or sets the warehouse transfer's project id.
Public property | Quantity | Gets or sets the quantity of stock to transfer.
Public property | Reference | Gets or sets the warehouse transfer's reference (compulsory).
Public property | Reference2 | Gets or sets the warehouse transfer's 2nd reference.
Public property | SerialNumbers | Gets the warehouse transfer's serial number collection.
Public property | ToWarehouse | Gets or sets the warehouse to which goods will be transferred.
Public property | TranCode | Sets the warehouse transfer's transaction code.
Public property | TranCodeID | Gets or sets the warehouse transfer's tran code id.
Public property | UnitCost | Gets or sets the unit cost at which the transfer takes place. This typically includes the item's value in addition to a calculated transfer value.

See Also

WarehouseTransfer Class


WarehouseTransfer Constructor

[image]

Pastel Evolution SDK
WarehouseTransfer Constructor
WarehouseTransfer Class See Also Send Feedback
Creates a new instance of a warehouse transfer transaction.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public WarehouseTransfer()
Visual Basic
Public Sub New

See Also

WarehouseTransfer Class
WarehouseTransfer Members


WarehouseTransfer Methods

[image] [image]

Pastel Evolution SDK
WarehouseTransfer Methods
WarehouseTransfer Class See Also Send Feedback

The WarehouseTransfer type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Post | Processes the transfer.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Validate | Validates the transaction without attempting to post.

See Also

WarehouseTransfer Class


WarehouseTransfer.Post Method

[image]

Pastel Evolution SDK
WarehouseTransfer..::..Post Method
WarehouseTransfer Class See Also Send Feedback
Processes the transfer.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool Post()
Visual Basic
Public Function Post As Boolean

Return Value

Type: Boolean

See Also

WarehouseTransfer Class
WarehouseTransfer Members


WarehouseTransfer.Validate Method

[image]

Pastel Evolution SDK
WarehouseTransfer..::..Validate Method
WarehouseTransfer Class See Also Send Feedback
Validates the transaction without attempting to post.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool Validate()
Visual Basic
Public Function Validate As Boolean

Return Value

Type: Boolean
The Validate.

See Also

WarehouseTransfer Class
WarehouseTransfer Members


WarehouseTransfer Properties

[image] [image]

Pastel Evolution SDK
WarehouseTransfer Properties
WarehouseTransfer Class See Also Send Feedback

The WarehouseTransfer type exposes the following members.

Properties

 | Name | Description
Public property | Account | Gets or sets the warehouse transfer's account (stock item).
Public property | AccountID | Gets or sets the warehouse transfer's account id.
Public property | Audit | Gets the transaction's audit number.
Public property | Date | Gets or sets the date on which the transfer takes place.
Public property | Description | Gets or sets the warehouse transfer description.
Public property | ExtOrderNo | Gets or sets the warehouse transfer's external order number, if relevant.
Public property | FromWarehouse | Gets or sets the warehouse from which goods will be transferred.
Public property | InventoryItem | Gets or sets the warehouse transfer's account (stock item).
Public property | Lot |
Public property | ModID | Gets or sets the transaction's module identifier.
Public property | Module | Gets the Evolution module this record forms a part of.
Public property | OrderNo | Gets or sets the warehouse transfer's order number, if relevant.
Public property | Project | Sets the warehouse transfer's project.
Public property | ProjectID | Gets or sets the warehouse transfer's project id.
Public property | Quantity | Gets or sets the quantity of stock to transfer.
Public property | Reference | Gets or sets the warehouse transfer's reference (compulsory).
Public property | Reference2 | Gets or sets the warehouse transfer's 2nd reference.
Public property | SerialNumbers | Gets the warehouse transfer's serial number collection.
Public property | ToWarehouse | Gets or sets the warehouse to which goods will be transferred.
Public property | TranCode | Sets the warehouse transfer's transaction code.
Public property | TranCodeID | Gets or sets the warehouse transfer's tran code id.
Public property | UnitCost | Gets or sets the unit cost at which the transfer takes place. This typically includes the item's value in addition to a calculated transfer value.

See Also

WarehouseTransfer Class


WarehouseTransfer.Account Property

[image]

Pastel Evolution SDK
WarehouseTransfer..::..Account Property
WarehouseTransfer Class See Also Send Feedback
Gets or sets the warehouse transfer's account (stock item).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public AccountBase Account { get; set; }
Visual Basic
Public Property Account As AccountBase
    Get
    Set

Property Value

Type: AccountBase

See Also

WarehouseTransfer Class
WarehouseTransfer Members


WarehouseTransfer.AccountID Property

[image]

Pastel Evolution SDK
WarehouseTransfer..::..AccountID Property
WarehouseTransfer Class See Also Send Feedback
Gets or sets the warehouse transfer's account id.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int AccountID { get; set; }
Visual Basic
Public Property AccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

WarehouseTransfer Class
WarehouseTransfer Members


WarehouseTransfer.Audit Property

[image]

Pastel Evolution SDK
WarehouseTransfer..::..Audit Property
WarehouseTransfer Class See Also Send Feedback
Gets the transaction's audit number.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Audit { get; }
Visual Basic
Public ReadOnly Property Audit As String
    Get

Property Value

Type: String

Remarks

The audit number is 0 when unposted. After posting, it will reflect the transaction's posted audit number.

See Also

WarehouseTransfer Class
WarehouseTransfer Members


WarehouseTransfer.Date Property

[image]

Pastel Evolution SDK
WarehouseTransfer..::..Date Property
WarehouseTransfer Class See Also Send Feedback
Gets or sets the date on which the transfer takes place.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public DateTime Date { get; set; }
Visual Basic
Public Property Date As DateTime
    Get
    Set

Property Value

Type: DateTime

See Also

WarehouseTransfer Class
WarehouseTransfer Members


WarehouseTransfer.Description Property

[image]

Pastel Evolution SDK
WarehouseTransfer..::..Description Property
WarehouseTransfer Class See Also Send Feedback
Gets or sets the warehouse transfer description.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set

Property Value

Type: String

See Also

WarehouseTransfer Class
WarehouseTransfer Members


WarehouseTransfer.ExtOrderNo Property

[image]

Pastel Evolution SDK
WarehouseTransfer..::..ExtOrderNo Property
WarehouseTransfer Class See Also Send Feedback
Gets or sets the warehouse transfer's external order number, if relevant.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string ExtOrderNo { get; set; }
Visual Basic
Public Property ExtOrderNo As String
    Get
    Set

Property Value

Type: String

See Also

WarehouseTransfer Class
WarehouseTransfer Members


WarehouseTransfer.FromWarehouse Property

[image]

Pastel Evolution SDK
WarehouseTransfer..::..FromWarehouse Property
WarehouseTransfer Class See Also Send Feedback
Gets or sets the warehouse from which goods will be transferred.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Warehouse FromWarehouse { get; set; }
Visual Basic
Public Property FromWarehouse As Warehouse
    Get
    Set

Property Value

Type: Warehouse

See Also

WarehouseTransfer Class
WarehouseTransfer Members


WarehouseTransfer.InventoryItem Property

[image]

Pastel Evolution SDK
WarehouseTransfer..::..InventoryItem Property
WarehouseTransfer Class See Also Send Feedback
Gets or sets the warehouse transfer's account (stock item).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public InventoryItem InventoryItem { get; set; }
Visual Basic
Public Property InventoryItem As InventoryItem
    Get
    Set

Property Value

Type: InventoryItem

See Also

WarehouseTransfer Class
WarehouseTransfer Members


WarehouseTransfer.Lot Property

[image]

Pastel Evolution SDK
WarehouseTransfer..::..Lot Property
WarehouseTransfer Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Lot Lot { get; set; }
Visual Basic
Public Property Lot As Lot
    Get
    Set

Property Value

Type: Lot

See Also

WarehouseTransfer Class
WarehouseTransfer Members


WarehouseTransfer.ModID Property

[image]

Pastel Evolution SDK
WarehouseTransfer..::..ModID Property
WarehouseTransfer Class See Also Send Feedback
Gets or sets the transaction's module identifier.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public ModuleID ModID { get; }
Visual Basic
Public ReadOnly Property ModID As ModuleID
    Get

Property Value

Type: ModuleID

Remarks

Used internally by Evolution to distinguish transaction origin.

See Also

WarehouseTransfer Class
WarehouseTransfer Members


WarehouseTransfer.Module Property

[image]

Pastel Evolution SDK
WarehouseTransfer..::..Module Property
WarehouseTransfer Class See Also Send Feedback
Gets the Evolution module this record forms a part of.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Module Module { get; }
Visual Basic
Public ReadOnly Property Module As Module
    Get

Property Value

Type: Module

See Also

WarehouseTransfer Class
WarehouseTransfer Members


WarehouseTransfer.OrderNo Property

[image]

Pastel Evolution SDK
WarehouseTransfer..::..OrderNo Property
WarehouseTransfer Class See Also Send Feedback
Gets or sets the warehouse transfer's order number, if relevant.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string OrderNo { get; set; }
Visual Basic
Public Property OrderNo As String
    Get
    Set

Property Value

Type: String

See Also

WarehouseTransfer Class
WarehouseTransfer Members


WarehouseTransfer.Project Property

[image]

Pastel Evolution SDK
WarehouseTransfer..::..Project Property
WarehouseTransfer Class See Also Send Feedback
Sets the warehouse transfer's project.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Project Project { set; }
Visual Basic
Public WriteOnly Property Project As Project
    Set

Property Value

Type: Project

See Also

WarehouseTransfer Class
WarehouseTransfer Members


WarehouseTransfer.ProjectID Property

[image]

Pastel Evolution SDK
WarehouseTransfer..::..ProjectID Property
WarehouseTransfer Class See Also Send Feedback
Gets or sets the warehouse transfer's project id.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int ProjectID { get; set; }
Visual Basic
Public Property ProjectID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

WarehouseTransfer Class
WarehouseTransfer Members


WarehouseTransfer.Quantity Property

[image]

Pastel Evolution SDK
WarehouseTransfer..::..Quantity Property
WarehouseTransfer Class See Also Send Feedback
Gets or sets the quantity of stock to transfer.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double Quantity { get; set; }
Visual Basic
Public Property Quantity As Double
    Get
    Set

Property Value

Type: Double

See Also

WarehouseTransfer Class
WarehouseTransfer Members


WarehouseTransfer.Reference Property

[image]

Pastel Evolution SDK
WarehouseTransfer..::..Reference Property
WarehouseTransfer Class See Also Send Feedback
Gets or sets the warehouse transfer's reference (compulsory).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Reference { get; set; }
Visual Basic
Public Property Reference As String
    Get
    Set

Property Value

Type: String

See Also

WarehouseTransfer Class
WarehouseTransfer Members


WarehouseTransfer.Reference2 Property

[image]

Pastel Evolution SDK
WarehouseTransfer..::..Reference2 Property
WarehouseTransfer Class See Also Send Feedback
Gets or sets the warehouse transfer's 2nd reference.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string Reference2 { get; set; }
Visual Basic
Public Property Reference2 As String
    Get
    Set

Property Value

Type: String

See Also

WarehouseTransfer Class
WarehouseTransfer Members


WarehouseTransfer.SerialNumbers Property

[image]

Pastel Evolution SDK
WarehouseTransfer..::..SerialNumbers Property
WarehouseTransfer Class See Also Send Feedback
Gets the warehouse transfer's serial number collection.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public SerialNumberCollection SerialNumbers { get; }
Visual Basic
Public ReadOnly Property SerialNumbers As SerialNumberCollection
    Get

Property Value

Type: SerialNumberCollection

See Also

WarehouseTransfer Class
WarehouseTransfer Members


WarehouseTransfer.ToWarehouse Property

[image]

Pastel Evolution SDK
WarehouseTransfer..::..ToWarehouse Property
WarehouseTransfer Class See Also Send Feedback
Gets or sets the warehouse to which goods will be transferred.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Warehouse ToWarehouse { get; set; }
Visual Basic
Public Property ToWarehouse As Warehouse
    Get
    Set

Property Value

Type: Warehouse

See Also

WarehouseTransfer Class
WarehouseTransfer Members


WarehouseTransfer.TranCode Property

[image]

Pastel Evolution SDK
WarehouseTransfer..::..TranCode Property
WarehouseTransfer Class See Also Send Feedback
Sets the warehouse transfer's transaction code.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public TransactionCode TranCode { get; set; }
Visual Basic
Public Property TranCode As TransactionCode
    Get
    Set

Property Value

Type: TransactionCode

Remarks

Defaults to the transaction code configured in Evolution's inventory defaults.

See Also

WarehouseTransfer Class
WarehouseTransfer Members


WarehouseTransfer.TranCodeID Property

[image]

Pastel Evolution SDK
WarehouseTransfer..::..TranCodeID Property
WarehouseTransfer Class See Also Send Feedback
Gets or sets the warehouse transfer's tran code id.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int TranCodeID { get; set; }
Visual Basic
Public Property TranCodeID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

WarehouseTransfer Class
WarehouseTransfer Members


WarehouseTransfer.UnitCost Property

[image]

Pastel Evolution SDK
WarehouseTransfer..::..UnitCost Property
WarehouseTransfer Class See Also Send Feedback
Gets or sets the unit cost at which the transfer takes place. This typically includes the item's value in addition to a calculated transfer value.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double UnitCost { get; set; }
Visual Basic
Public Property UnitCost As Double
    Get
    Set

Property Value

Type: Double

Remarks

The variance between the specified UnitCost and the item's true warehouse cost gets posted to the inventory cost variance account.

See Also

WarehouseTransfer Class
WarehouseTransfer Members


Worker Class

[image]

Pastel Evolution SDK
Worker Class
Members See Also Send Feedback
Represents a Worker.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class Worker : AccountBase
Visual Basic
Public Class Worker
    Inherits AccountBase

Inheritance Hierarchy

System..::..Object
Pastel.Evolution..::..RecordBase
Pastel.Evolution..::..BranchedRecordBase
Pastel.Evolution..::..AccountBase
Pastel.Evolution..::..Worker

See Also

Worker Members


Worker Members

[image] [image]

Pastel Evolution SDK
Worker Members
Worker Class Constructors Methods Fields Properties See Also Send Feedback

The Worker type exposes the following members.

Constructors

 | Name | Description
Public method | Worker()()()() | Creates a new instance of a Worker.
Public method | Worker(Int32) | Creates a new instance of a Worker.
Public method | Worker(String) | Creates a new instance of a Worker.

Methods

 | Name | Description
 | _ListCurrentBranch |
 | _Select(String) | Experimental Method
 | _Select(String, String) |
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds a worker ID.
 | FindByCode | Attempts to find a worker by its code and returns its ID.
 | Get | Returns the [first] worker object matching the criteria specified; otherwise, returns null.
 | GetByCode | Returns a worker object corresponding to the code specified; otherwise, returns null.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List(String) | Returns a System.Data.DataTable object containing the database records from the _etblWorkers table matching the supplied criteria.
 | List(String, String) | Returns a System.Data.DataTable object containing the database records from the _etblWorkers table matching the supplied criteria.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides AccountBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides AccountBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | (Inherited from AccountBase.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

Properties

 | Name | Description
Public property | Active | Gets or sets the worker's operational state. (Overrides AccountBase..::..Active.)
Public property | BillableRate | Gets or sets the worker's billable rate.
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Code | Gets or sets the worker's code. (Overrides AccountBase..::..Code.)
Public property | Description | Gets or sets the worker's name. (Overrides AccountBase..::..Description.)
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | Item | Gets a worker object possessing the given code.
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | Module | Gets the Evolution module this record belongs to, Used in internal validation. (Overrides AccountBase..::..Module.)
Public property | WorkerCost | Gets or sets the worker's cost.

See Also

Worker Class


Worker Constructor

[image] [image]

Pastel Evolution SDK
Worker Constructor
Worker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Worker()()()() | Creates a new instance of a Worker.
Public method | Worker(Int32) | Creates a new instance of a Worker.
Public method | Worker(String) | Creates a new instance of a Worker.

See Also

Worker Class
Worker Members


Worker Constructor

[image]

Pastel Evolution SDK
Worker Constructor
Worker Class See Also Send Feedback
Creates a new instance of a Worker.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Worker()
Visual Basic
Public Sub New

See Also

Worker Class
Worker Members
Worker Overload


Worker Constructor (Int32)

[image]

Pastel Evolution SDK
Worker Constructor (Int32)
Worker Class See Also Send Feedback
Creates a new instance of a Worker.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Worker(
    int id
)
Visual Basic
Public Sub New (
    id As Integer
)

Parameters

id
Type: System..::..Int32
Specifies the id of the existing record.

See Also

Worker Class
Worker Members
Worker Overload


Worker Constructor (String)

[image]

Pastel Evolution SDK
Worker Constructor (String)
Worker Class See Also Send Feedback
Creates a new instance of a Worker.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Worker(
    string code
)
Visual Basic
Public Sub New (
    code As String
)

Parameters

code
Type: System..::..String
Specifies the code of the existing record.

See Also

Worker Class
Worker Members
Worker Overload


Worker Fields

[image] [image]

Pastel Evolution SDK
Worker Fields
Worker Class See Also Send Feedback

The Worker type exposes the following members.

Fields

 | Name | Description
Protected field | branch | (Inherited from BranchedRecordBase.)
Protected field | wrapper | (Inherited from RecordBase.)

See Also

Worker Class


Worker Methods

[image] [image]

Pastel Evolution SDK
Worker Methods
Worker Class See Also Send Feedback

The Worker type exposes the following members.

Methods

 | Name | Description
 | _ListCurrentBranch |
 | _Select(String) | Experimental Method
 | _Select(String, String) |
Public method | Delete | Removes the record from the database, provided it is not referenced by other records. (Inherited from RecordBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(RecordBase) | (Inherited from RecordBase.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Finds a worker ID.
 | FindByCode | Attempts to find a worker by its code and returns its ID.
 | Get | Returns the [first] worker object matching the criteria specified; otherwise, returns null.
 | GetByCode | Returns a worker object corresponding to the code specified; otherwise, returns null.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | List(String) | Returns a System.Data.DataTable object containing the database records from the _etblWorkers table matching the supplied criteria.
 | List(String, String) | Returns a System.Data.DataTable object containing the database records from the _etblWorkers table matching the supplied criteria.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDelete | Removes the record from the database, provided it is not referenced by other records. (Overrides AccountBase..::..OnDelete()()()().)
Protected method | OnSave | Persists the record to the database. (Overrides AccountBase..::..OnSave()()()().)
Public method | Save | Persists the record to the database. (Inherited from RecordBase.)
Public method | ToString | (Inherited from AccountBase.)
Protected method | ValidateBranchRelation | (Inherited from BranchedRecordBase.)
Protected method | ValidateSetBranch | (Inherited from BranchedRecordBase.)

See Also

Worker Class


Worker._ListCurrentBranch Method

[image]

Pastel Evolution SDK
Worker..::.._ListCurrentBranch Method
Worker Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable _ListCurrentBranch(
    string criteria
)
Visual Basic
Public Shared Function _ListCurrentBranch (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String

Return Value

Type: DataTable

See Also

Worker Class
Worker Members


Worker._Select Method

[image] [image]

Pastel Evolution SDK
Worker..::.._Select Method
Worker Class See Also Send Feedback

Overload List

Name | Description
_Select(String) | Experimental Method
_Select(String, String) |

See Also

Worker Class
Worker Members


Worker._Select Method (String)

[image]

Pastel Evolution SDK
Worker..::.._Select Method (String)
Worker Class See Also Send Feedback
Experimental Method

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static Worker[] _Select(
    string criteria
)
Visual Basic
Public Shared Function _Select (
    criteria As String
) As Worker()

Parameters

criteria
Type: System..::..String

Return Value

Type: array< Worker >[]()[][]

See Also

Worker Class
Worker Members
_Select Overload


Worker._Select Method (String, String)

[image]

Pastel Evolution SDK
Worker..::.._Select Method (String, String)
Worker Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static Worker[] _Select(
    string criteria,
    string sortOrder
)
Visual Basic
Public Shared Function _Select (
    criteria As String,
    sortOrder As String
) As Worker()

Parameters

criteria
Type: System..::..String
sortOrder
Type: System..::..String

Return Value

Type: array< Worker >[]()[][]

See Also

Worker Class
Worker Members
_Select Overload


Worker.Find Method

[image]

Pastel Evolution SDK
Worker..::..Find Method
Worker Class See Also Send Feedback
Finds a worker ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int Find(
    string criteria
)
Visual Basic
Public Shared Function Find (
    criteria As String
) As Integer

Parameters

criteria
Type: System..::..String
The criteria passed to the SQL query. Eg. cWorkerCode = 'WORK001' or cWorkerName like '%Worker%'

Return Value

Type: Int32

See Also

Worker Class
Worker Members


Worker.FindByCode Method

[image]

Pastel Evolution SDK
Worker..::..FindByCode Method
Worker Class See Also Send Feedback
Attempts to find a worker by its code and returns its ID.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static int FindByCode(
    string code
)
Visual Basic
Public Shared Function FindByCode (
    code As String
) As Integer

Parameters

code
Type: System..::..String
The code used to lookup the worker.

Return Value

Type: Int32
-1 if no record was found, else the id of the first worker matching the criteria supplied.

See Also

Worker Class
Worker Members
Pastel.Evolution Namespace
Worker..::..Find(String)


Worker.Get Method

[image]

Pastel Evolution SDK
Worker..::..Get Method
Worker Class See Also Send Feedback
Returns the [first] worker object matching the criteria specified; otherwise, returns null.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static Worker Get(
    string criteria
)
Visual Basic
Public Shared Function Get (
    criteria As String
) As Worker

Parameters

criteria
Type: System..::..String
Eg. cWorkerCode = 'WORK001' or cWorkerName like '%Worker%'

Return Value

Type: Worker

See Also

Worker Class
Worker Members
Pastel.Evolution Namespace
Worker..::..Find(String)


Worker.GetByCode Method

[image]

Pastel Evolution SDK
Worker..::..GetByCode Method
Worker Class See Also Send Feedback
Returns a worker object corresponding to the code specified; otherwise, returns null.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static Worker GetByCode(
    string code
)
Visual Basic
Public Shared Function GetByCode (
    code As String
) As Worker

Parameters

code
Type: System..::..String

Return Value

Type: Worker

See Also

Worker Class
Worker Members


Worker.List Method

[image] [image]

Pastel Evolution SDK
Worker..::..List Method
Worker Class See Also Send Feedback

Overload List

Name | Description
List(String) | Returns a System.Data.DataTable object containing the database records from the _etblWorkers table matching the supplied criteria.
List(String, String) | Returns a System.Data.DataTable object containing the database records from the _etblWorkers table matching the supplied criteria.

See Also

Worker Class
Worker Members


Worker.List Method (String)

[image]

Pastel Evolution SDK
Worker..::..List Method (String)
Worker Class See Also Send Feedback
Returns a System.Data.DataTable object containing the database records from the _etblWorkers table matching the supplied criteria.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria
)
Visual Basic
Public Shared Function List (
    criteria As String
) As DataTable

Parameters

criteria
Type: System..::..String
The SQL criteria used to locate the record, e.g. cWorkerCode like '1___'

Return Value

Type: DataTable
A System.Data.DataTable object containing matching records.

Remarks

The criteria is passed to an SQL query so use the appropriate syntax. Remember to includethe single quotes around string literals and append additional criteria with and.

See Also

Worker Class
Worker Members
List Overload


Worker.List Method (String, String)

[image]

Pastel Evolution SDK
Worker..::..List Method (String, String)
Worker Class See Also Send Feedback
Returns a System.Data.DataTable object containing the database records from the _etblWorkers table matching the supplied criteria.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static DataTable List(
    string criteria,
    string sortOrder
)
Visual Basic
Public Shared Function List (
    criteria As String,
    sortOrder As String
) As DataTable

Parameters

criteria
Type: System..::..String
The SQL criteria used to locate the record, e.g. cWorkerCode like '1___'
sortOrder
Type: System..::..String
The SQL order by clause to use, e.g. cWorkerName, cWorkerCode

Return Value

Type: DataTable
A System.Data.DataTable object containing matching records.

Remarks

The criteria is passed to an SQL query so use the appropriate syntax. Remember to includethe single quotes around string literals and append additional criteria with and.

See Also

Worker Class
Worker Members
List Overload


Worker.OnDelete Method

[image]

Pastel Evolution SDK
Worker..::..OnDelete Method
Worker Class See Also Send Feedback
Removes the record from the database, provided it is not referenced by other records.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnDelete()
Visual Basic
Protected Friend Overrides Sub OnDelete

Exceptions

Exception | Condition
IntegrityViolationException |

See Also

Worker Class
Worker Members


Worker.OnSave Method

[image]

Pastel Evolution SDK
Worker..::..OnSave Method
Worker Class See Also Send Feedback
Persists the record to the database.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected internal override void OnSave()
Visual Basic
Protected Friend Overrides Sub OnSave

See Also

Worker Class
Worker Members


Worker Properties

[image] [image]

Pastel Evolution SDK
Worker Properties
Worker Class See Also Send Feedback

The Worker type exposes the following members.

Properties

 | Name | Description
Public property | Active | Gets or sets the worker's operational state. (Overrides AccountBase..::..Active.)
Public property | BillableRate | Gets or sets the worker's billable rate.
Public property | Branch | (Inherited from BranchedRecordBase.)
Public property | BranchID | Gets the record's branch ID. (Inherited from BranchedRecordBase.)
Public property | Code | Gets or sets the worker's code. (Overrides AccountBase..::..Code.)
Public property | Description | Gets or sets the worker's name. (Overrides AccountBase..::..Description.)
Public property | ID | Gets the internal record ID (0 for new, unsaved records). (Overrides RecordBase..::..ID.)
Public property | Item | Gets a worker object possessing the given code.
Public property | LongID | (Overrides RecordBase..::..LongID.)
Public property | Module | Gets the Evolution module this record belongs to, Used in internal validation. (Overrides AccountBase..::..Module.)
Public property | WorkerCost | Gets or sets the worker's cost.

See Also

Worker Class


Worker.Active Property

[image]

Pastel Evolution SDK
Worker..::..Active Property
Worker Class See Also Send Feedback
Gets or sets the worker's operational state.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override bool Active { get; set; }
Visual Basic
Public Overrides Property Active As Boolean
    Get
    Set

Property Value

Type: Boolean

Remarks

Inactive records cannot be used when posting transactions.

See Also

Worker Class
Worker Members


Worker.BillableRate Property

[image]

Pastel Evolution SDK
Worker..::..BillableRate Property
Worker Class See Also Send Feedback
Gets or sets the worker's billable rate.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double BillableRate { get; set; }
Visual Basic
Public Property BillableRate As Double
    Get
    Set

Property Value

Type: Double

See Also

Worker Class
Worker Members


Worker.Code Property

[image]

Pastel Evolution SDK
Worker..::..Code Property
Worker Class See Also Send Feedback
Gets or sets the worker's code.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override string Code { get; set; }
Visual Basic
Public Overrides Property Code As String
    Get
    Set

Property Value

Type: String

Remarks

This field maps to the cWorkerCode database field. This is a mandatory field.

See Also

Worker Class
Worker Members


Worker.Description Property

[image]

Pastel Evolution SDK
Worker..::..Description Property
Worker Class See Also Send Feedback
Gets or sets the worker's name.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override string Description { get; set; }
Visual Basic
Public Overrides Property Description As String
    Get
    Set

Property Value

Type: String

See Also

Worker Class
Worker Members


Worker.ID Property

[image]

Pastel Evolution SDK
Worker..::..ID Property
Worker Class See Also Send Feedback
Gets the internal record ID (0 for new, unsaved records).

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override int ID { get; }
Visual Basic
Public Overrides ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

Remarks

Once saved, the ID will reflect the record's internal database identifier.

See Also

Worker Class
Worker Members


Worker.Item Property

[image]

Pastel Evolution SDK
Worker..::..Item Property
Worker Class See Also Send Feedback
Gets a worker object possessing the given code.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public Worker this[
    string code
] { get; }
Visual Basic
Public ReadOnly Default Property Item (
    code As String
) As Worker
    Get

Parameters

code
Type: System..::..String

Return Value

Type: Worker
The worker matching the supplied code.

Exceptions

Exception | Condition
RecordNotExistsException |

See Also

Worker Class
Worker Members


Worker.LongID Property

[image]

Pastel Evolution SDK
Worker..::..LongID Property
Worker Class See Also Send Feedback

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override long LongID { get; }
Visual Basic
Public Overrides ReadOnly Property LongID As Long
    Get

Property Value

Type: Int64

See Also

Worker Class
Worker Members


Worker.Module Property

[image]

Pastel Evolution SDK
Worker..::..Module Property
Worker Class See Also Send Feedback
Gets the Evolution module this record belongs to, Used in internal validation.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public override Module Module { get; }
Visual Basic
Public Overrides ReadOnly Property Module As Module
    Get

Property Value

Type: Module

See Also

Worker Class
Worker Members


Worker.WorkerCost Property

[image]

Pastel Evolution SDK
Worker..::..WorkerCost Property
Worker Class See Also Send Feedback
Gets or sets the worker's cost.

Namespace: Pastel.Evolution
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public double WorkerCost { get; set; }
Visual Basic
Public Property WorkerCost As Double
    Get
    Set

Property Value

Type: Double

See Also

Worker Class
Worker Members


Pastel.Evolution.Internal Namespace

[image]

Pastel Evolution SDK
Pastel.Evolution.Internal Namespace
Send Feedback

Classes

 | Class | Description
Public class | APDefaults |
Public class | ARDefaults |
Public class | AutoNumberingScheme |
Public class | CashbookBatchDefaults |
Public class | ContactManagementDefaults |
Public class | GLDefaults |
Public class | InventoryDefaults |
Public class | JobDefaults |
Public class | JournalBatchDefaults |
Public class | ModuleRegistration |
Public class | RecordWrapperBase |

Structures

 | Structure | Description
Public structure | myToken |

Enumerations

 | Enumeration | Description
Public enumeration | ModuleRegistration..::..Module |


APDefaults Class

[image]

Pastel Evolution SDK
APDefaults Class
Members See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class APDefaults
Visual Basic
Public Class APDefaults

Inheritance Hierarchy

System..::..Object
Pastel.Evolution.Internal..::..APDefaults

See Also

APDefaults Members
Pastel.Evolution.Internal Namespace


APDefaults Members

[image] [image]

Pastel Evolution SDK
APDefaults Members
APDefaults Class Methods Properties See Also Send Feedback

The APDefaults type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AutoNumbering |
Public property | SupplierFilterStartLength |

See Also

APDefaults Class
Pastel.Evolution.Internal Namespace


APDefaults Methods

[image] [image]

Pastel Evolution SDK
APDefaults Methods
APDefaults Class See Also Send Feedback

The APDefaults type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

APDefaults Class
Pastel.Evolution.Internal Namespace


APDefaults Properties

[image] [image]

Pastel Evolution SDK
APDefaults Properties
APDefaults Class See Also Send Feedback

The APDefaults type exposes the following members.

Properties

 | Name | Description
Public property | AutoNumbering |
Public property | SupplierFilterStartLength |

See Also

APDefaults Class
Pastel.Evolution.Internal Namespace


APDefaults.AutoNumbering Property

[image]

Pastel Evolution SDK
APDefaults..::..AutoNumbering Property
APDefaults Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public AutoNumberingScheme AutoNumbering { get; }
Visual Basic
Public ReadOnly Property AutoNumbering As AutoNumberingScheme
    Get

Property Value

Type: AutoNumberingScheme

See Also

APDefaults Class
APDefaults Members
Pastel.Evolution.Internal Namespace


APDefaults.SupplierFilterStartLength Property

[image]

Pastel Evolution SDK
APDefaults..::..SupplierFilterStartLength Property
APDefaults Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int SupplierFilterStartLength { get; }
Visual Basic
Public ReadOnly Property SupplierFilterStartLength As Integer
    Get

Property Value

Type: Int32

See Also

APDefaults Class
APDefaults Members
Pastel.Evolution.Internal Namespace


ARDefaults Class

[image]

Pastel Evolution SDK
ARDefaults Class
Members See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class ARDefaults
Visual Basic
Public Class ARDefaults

Inheritance Hierarchy

System..::..Object
Pastel.Evolution.Internal..::..ARDefaults

See Also

ARDefaults Members
Pastel.Evolution.Internal Namespace


ARDefaults Members

[image] [image]

Pastel Evolution SDK
ARDefaults Members
ARDefaults Class Methods Properties See Also Send Feedback

The ARDefaults type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AutoNumbering |
Public property | CustomerFilterStartLength |

See Also

ARDefaults Class
Pastel.Evolution.Internal Namespace


ARDefaults Methods

[image] [image]

Pastel Evolution SDK
ARDefaults Methods
ARDefaults Class See Also Send Feedback

The ARDefaults type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ARDefaults Class
Pastel.Evolution.Internal Namespace


ARDefaults Properties

[image] [image]

Pastel Evolution SDK
ARDefaults Properties
ARDefaults Class See Also Send Feedback

The ARDefaults type exposes the following members.

Properties

 | Name | Description
Public property | AutoNumbering |
Public property | CustomerFilterStartLength |

See Also

ARDefaults Class
Pastel.Evolution.Internal Namespace


ARDefaults.AutoNumbering Property

[image]

Pastel Evolution SDK
ARDefaults..::..AutoNumbering Property
ARDefaults Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public AutoNumberingScheme AutoNumbering { get; }
Visual Basic
Public ReadOnly Property AutoNumbering As AutoNumberingScheme
    Get

Property Value

Type: AutoNumberingScheme

See Also

ARDefaults Class
ARDefaults Members
Pastel.Evolution.Internal Namespace


ARDefaults.CustomerFilterStartLength Property

[image]

Pastel Evolution SDK
ARDefaults..::..CustomerFilterStartLength Property
ARDefaults Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int CustomerFilterStartLength { get; }
Visual Basic
Public ReadOnly Property CustomerFilterStartLength As Integer
    Get

Property Value

Type: Int32

See Also

ARDefaults Class
ARDefaults Members
Pastel.Evolution.Internal Namespace


AutoNumberingScheme Class

[image]

Pastel Evolution SDK
AutoNumberingScheme Class
Members See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class AutoNumberingScheme
Visual Basic
Public Class AutoNumberingScheme

Inheritance Hierarchy

System..::..Object
Pastel.Evolution.Internal..::..AutoNumberingScheme

See Also

AutoNumberingScheme Members
Pastel.Evolution.Internal Namespace


AutoNumberingScheme Members

[image] [image]

Pastel Evolution SDK
AutoNumberingScheme Members
AutoNumberingScheme Class Constructors Methods Properties See Also Send Feedback

The AutoNumberingScheme type exposes the following members.

Constructors

 | Name | Description
Public method | AutoNumberingScheme | Initializes a new instance of the AutoNumberingScheme class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEnabled | Gets whether Automatic Numbering is on.
Public property | PadLength | Gets the Automatic Numbering pad length.
Public property | PrefixLength | Gets the Automatic Numbering prefix length.
Public property | UpperCaseOnly | Gets whether Automatic Numbering only allows Upper Case characters.

See Also

AutoNumberingScheme Class
Pastel.Evolution.Internal Namespace


AutoNumberingScheme Constructor

[image]

Pastel Evolution SDK
AutoNumberingScheme Constructor
AutoNumberingScheme Class See Also Send Feedback
Initializes a new instance of the AutoNumberingScheme class

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public AutoNumberingScheme(
    RecordWrapperBase defaults
)
Visual Basic
Public Sub New (
    defaults As RecordWrapperBase
)

Parameters

defaults
Type: Pastel.Evolution.Internal..::..RecordWrapperBase

See Also

AutoNumberingScheme Class
AutoNumberingScheme Members
Pastel.Evolution.Internal Namespace


AutoNumberingScheme Methods

[image] [image]

Pastel Evolution SDK
AutoNumberingScheme Methods
AutoNumberingScheme Class See Also Send Feedback

The AutoNumberingScheme type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AutoNumberingScheme Class
Pastel.Evolution.Internal Namespace


AutoNumberingScheme Properties

[image] [image]

Pastel Evolution SDK
AutoNumberingScheme Properties
AutoNumberingScheme Class See Also Send Feedback

The AutoNumberingScheme type exposes the following members.

Properties

 | Name | Description
Public property | IsEnabled | Gets whether Automatic Numbering is on.
Public property | PadLength | Gets the Automatic Numbering pad length.
Public property | PrefixLength | Gets the Automatic Numbering prefix length.
Public property | UpperCaseOnly | Gets whether Automatic Numbering only allows Upper Case characters.

See Also

AutoNumberingScheme Class
Pastel.Evolution.Internal Namespace


AutoNumberingScheme.IsEnabled Property

[image]

Pastel Evolution SDK
AutoNumberingScheme..::..IsEnabled Property
AutoNumberingScheme Class See Also Send Feedback
Gets whether Automatic Numbering is on.

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool IsEnabled { get; }
Visual Basic
Public ReadOnly Property IsEnabled As Boolean
    Get

Property Value

Type: Boolean

See Also

AutoNumberingScheme Class
AutoNumberingScheme Members
Pastel.Evolution.Internal Namespace


AutoNumberingScheme.PadLength Property

[image]

Pastel Evolution SDK
AutoNumberingScheme..::..PadLength Property
AutoNumberingScheme Class See Also Send Feedback
Gets the Automatic Numbering pad length.

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int PadLength { get; }
Visual Basic
Public ReadOnly Property PadLength As Integer
    Get

Property Value

Type: Int32

See Also

AutoNumberingScheme Class
AutoNumberingScheme Members
Pastel.Evolution.Internal Namespace


AutoNumberingScheme.PrefixLength Property

[image]

Pastel Evolution SDK
AutoNumberingScheme..::..PrefixLength Property
AutoNumberingScheme Class See Also Send Feedback
Gets the Automatic Numbering prefix length.

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int PrefixLength { get; }
Visual Basic
Public ReadOnly Property PrefixLength As Integer
    Get

Property Value

Type: Int32

See Also

AutoNumberingScheme Class
AutoNumberingScheme Members
Pastel.Evolution.Internal Namespace


AutoNumberingScheme.UpperCaseOnly Property

[image]

Pastel Evolution SDK
AutoNumberingScheme..::..UpperCaseOnly Property
AutoNumberingScheme Class See Also Send Feedback
Gets whether Automatic Numbering only allows Upper Case characters.

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool UpperCaseOnly { get; }
Visual Basic
Public ReadOnly Property UpperCaseOnly As Boolean
    Get

Property Value

Type: Boolean

See Also

AutoNumberingScheme Class
AutoNumberingScheme Members
Pastel.Evolution.Internal Namespace


CashbookBatchDefaults Class

[image]

Pastel Evolution SDK
CashbookBatchDefaults Class
Members See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class CashbookBatchDefaults
Visual Basic
Public Class CashbookBatchDefaults

Inheritance Hierarchy

System..::..Object
Pastel.Evolution.Internal..::..CashbookBatchDefaults

See Also

CashbookBatchDefaults Members
Pastel.Evolution.Internal Namespace


CashbookBatchDefaults Members

[image] [image]

Pastel Evolution SDK
CashbookBatchDefaults Members
CashbookBatchDefaults Class Methods Properties See Also Send Feedback

The CashbookBatchDefaults type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AccountsPayableAccount |
Public property | AccountsPayableAccountID |
Public property | AccountsReceivableAccount |
Public property | AccountsReceivableAccountID |
Public property | APDiscTransactionCode |
Public property | APDiscTransactionCodeID |
Public property | ARDiscTransactionCode |
Public property | ARDiscTransactionCodeID |
Public property | BankAccount |
Public property | BankAccountID |
Public property | InputTaxAccountID |
Public property | InputTaxRateID |
Public property | OutputTaxAccountID |
Public property | OutputTaxRateID |
Public property | TransactionCode |
Public property | TransactionCodeID |

See Also

CashbookBatchDefaults Class
Pastel.Evolution.Internal Namespace


CashbookBatchDefaults Methods

[image] [image]

Pastel Evolution SDK
CashbookBatchDefaults Methods
CashbookBatchDefaults Class See Also Send Feedback

The CashbookBatchDefaults type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CashbookBatchDefaults Class
Pastel.Evolution.Internal Namespace


CashbookBatchDefaults Properties

[image] [image]

Pastel Evolution SDK
CashbookBatchDefaults Properties
CashbookBatchDefaults Class See Also Send Feedback

The CashbookBatchDefaults type exposes the following members.

Properties

 | Name | Description
Public property | AccountsPayableAccount |
Public property | AccountsPayableAccountID |
Public property | AccountsReceivableAccount |
Public property | AccountsReceivableAccountID |
Public property | APDiscTransactionCode |
Public property | APDiscTransactionCodeID |
Public property | ARDiscTransactionCode |
Public property | ARDiscTransactionCodeID |
Public property | BankAccount |
Public property | BankAccountID |
Public property | InputTaxAccountID |
Public property | InputTaxRateID |
Public property | OutputTaxAccountID |
Public property | OutputTaxRateID |
Public property | TransactionCode |
Public property | TransactionCodeID |

See Also

CashbookBatchDefaults Class
Pastel.Evolution.Internal Namespace


CashbookBatchDefaults.AccountsPayableAccount Property

[image]

Pastel Evolution SDK
CashbookBatchDefaults..::..AccountsPayableAccount Property
CashbookBatchDefaults Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLAccount AccountsPayableAccount { get; set; }
Visual Basic
Public Property AccountsPayableAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

See Also

CashbookBatchDefaults Class
CashbookBatchDefaults Members
Pastel.Evolution.Internal Namespace


CashbookBatchDefaults.AccountsPayableAccountID Property

[image]

Pastel Evolution SDK
CashbookBatchDefaults..::..AccountsPayableAccountID Property
CashbookBatchDefaults Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int AccountsPayableAccountID { get; set; }
Visual Basic
Public Property AccountsPayableAccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CashbookBatchDefaults Class
CashbookBatchDefaults Members
Pastel.Evolution.Internal Namespace


CashbookBatchDefaults.AccountsReceivableAccount Property

[image]

Pastel Evolution SDK
CashbookBatchDefaults..::..AccountsReceivableAccount Property
CashbookBatchDefaults Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLAccount AccountsReceivableAccount { get; set; }
Visual Basic
Public Property AccountsReceivableAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

See Also

CashbookBatchDefaults Class
CashbookBatchDefaults Members
Pastel.Evolution.Internal Namespace


CashbookBatchDefaults.AccountsReceivableAccountID Property

[image]

Pastel Evolution SDK
CashbookBatchDefaults..::..AccountsReceivableAccountID Property
CashbookBatchDefaults Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int AccountsReceivableAccountID { get; set; }
Visual Basic
Public Property AccountsReceivableAccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CashbookBatchDefaults Class
CashbookBatchDefaults Members
Pastel.Evolution.Internal Namespace


CashbookBatchDefaults.APDiscTransactionCode Property

[image]

Pastel Evolution SDK
CashbookBatchDefaults..::..APDiscTransactionCode Property
CashbookBatchDefaults Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public TransactionCode APDiscTransactionCode { get; set; }
Visual Basic
Public Property APDiscTransactionCode As TransactionCode
    Get
    Set

Property Value

Type: TransactionCode

See Also

CashbookBatchDefaults Class
CashbookBatchDefaults Members
Pastel.Evolution.Internal Namespace


CashbookBatchDefaults.APDiscTransactionCodeID Property

[image]

Pastel Evolution SDK
CashbookBatchDefaults..::..APDiscTransactionCodeID Property
CashbookBatchDefaults Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int APDiscTransactionCodeID { get; set; }
Visual Basic
Public Property APDiscTransactionCodeID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CashbookBatchDefaults Class
CashbookBatchDefaults Members
Pastel.Evolution.Internal Namespace


CashbookBatchDefaults.ARDiscTransactionCode Property

[image]

Pastel Evolution SDK
CashbookBatchDefaults..::..ARDiscTransactionCode Property
CashbookBatchDefaults Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public TransactionCode ARDiscTransactionCode { get; set; }
Visual Basic
Public Property ARDiscTransactionCode As TransactionCode
    Get
    Set

Property Value

Type: TransactionCode

See Also

CashbookBatchDefaults Class
CashbookBatchDefaults Members
Pastel.Evolution.Internal Namespace


CashbookBatchDefaults.ARDiscTransactionCodeID Property

[image]

Pastel Evolution SDK
CashbookBatchDefaults..::..ARDiscTransactionCodeID Property
CashbookBatchDefaults Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int ARDiscTransactionCodeID { get; set; }
Visual Basic
Public Property ARDiscTransactionCodeID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CashbookBatchDefaults Class
CashbookBatchDefaults Members
Pastel.Evolution.Internal Namespace


CashbookBatchDefaults.BankAccount Property

[image]

Pastel Evolution SDK
CashbookBatchDefaults..::..BankAccount Property
CashbookBatchDefaults Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public GLAccount BankAccount { get; set; }
Visual Basic
Public Property BankAccount As GLAccount
    Get
    Set

Property Value

Type: GLAccount

See Also

CashbookBatchDefaults Class
CashbookBatchDefaults Members
Pastel.Evolution.Internal Namespace


CashbookBatchDefaults.BankAccountID Property

[image]

Pastel Evolution SDK
CashbookBatchDefaults..::..BankAccountID Property
CashbookBatchDefaults Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int BankAccountID { get; set; }
Visual Basic
Public Property BankAccountID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CashbookBatchDefaults Class
CashbookBatchDefaults Members
Pastel.Evolution.Internal Namespace


CashbookBatchDefaults.InputTaxAccountID Property

[image]

Pastel Evolution SDK
CashbookBatchDefaults..::..InputTaxAccountID Property
CashbookBatchDefaults Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int InputTaxAccountID { get; }
Visual Basic
Public ReadOnly Property InputTaxAccountID As Integer
    Get

Property Value

Type: Int32

See Also

CashbookBatchDefaults Class
CashbookBatchDefaults Members
Pastel.Evolution.Internal Namespace


CashbookBatchDefaults.InputTaxRateID Property

[image]

Pastel Evolution SDK
CashbookBatchDefaults..::..InputTaxRateID Property
CashbookBatchDefaults Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int InputTaxRateID { get; }
Visual Basic
Public ReadOnly Property InputTaxRateID As Integer
    Get

Property Value

Type: Int32

See Also

CashbookBatchDefaults Class
CashbookBatchDefaults Members
Pastel.Evolution.Internal Namespace


CashbookBatchDefaults.OutputTaxAccountID Property

[image]

Pastel Evolution SDK
CashbookBatchDefaults..::..OutputTaxAccountID Property
CashbookBatchDefaults Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int OutputTaxAccountID { get; }
Visual Basic
Public ReadOnly Property OutputTaxAccountID As Integer
    Get

Property Value

Type: Int32

See Also

CashbookBatchDefaults Class
CashbookBatchDefaults Members
Pastel.Evolution.Internal Namespace


CashbookBatchDefaults.OutputTaxRateID Property

[image]

Pastel Evolution SDK
CashbookBatchDefaults..::..OutputTaxRateID Property
CashbookBatchDefaults Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int OutputTaxRateID { get; }
Visual Basic
Public ReadOnly Property OutputTaxRateID As Integer
    Get

Property Value

Type: Int32

See Also

CashbookBatchDefaults Class
CashbookBatchDefaults Members
Pastel.Evolution.Internal Namespace


CashbookBatchDefaults.TransactionCode Property

[image]

Pastel Evolution SDK
CashbookBatchDefaults..::..TransactionCode Property
CashbookBatchDefaults Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public TransactionCode TransactionCode { get; set; }
Visual Basic
Public Property TransactionCode As TransactionCode
    Get
    Set

Property Value

Type: TransactionCode

See Also

CashbookBatchDefaults Class
CashbookBatchDefaults Members
Pastel.Evolution.Internal Namespace


CashbookBatchDefaults.TransactionCodeID Property

[image]

Pastel Evolution SDK
CashbookBatchDefaults..::..TransactionCodeID Property
CashbookBatchDefaults Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int TransactionCodeID { get; set; }
Visual Basic
Public Property TransactionCodeID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CashbookBatchDefaults Class
CashbookBatchDefaults Members
Pastel.Evolution.Internal Namespace


ContactManagementDefaults Class

[image]

Pastel Evolution SDK
ContactManagementDefaults Class
Members See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class ContactManagementDefaults
Visual Basic
Public Class ContactManagementDefaults

Inheritance Hierarchy

System..::..Object
Pastel.Evolution.Internal..::..ContactManagementDefaults

See Also

ContactManagementDefaults Members
Pastel.Evolution.Internal Namespace


ContactManagementDefaults Members

[image] [image]

Pastel Evolution SDK
ContactManagementDefaults Members
ContactManagementDefaults Class Methods Properties See Also Send Feedback

The ContactManagementDefaults type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ContactFilterStartLength |
Public property | DocumentStoragePath |
Public property | DueDateIncrement |
Public property | DueTimeIncrement |

See Also

ContactManagementDefaults Class
Pastel.Evolution.Internal Namespace


ContactManagementDefaults Methods

[image] [image]

Pastel Evolution SDK
ContactManagementDefaults Methods
ContactManagementDefaults Class See Also Send Feedback

The ContactManagementDefaults type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ContactManagementDefaults Class
Pastel.Evolution.Internal Namespace


ContactManagementDefaults Properties

[image] [image]

Pastel Evolution SDK
ContactManagementDefaults Properties
ContactManagementDefaults Class See Also Send Feedback

The ContactManagementDefaults type exposes the following members.

Properties

 | Name | Description
Public property | ContactFilterStartLength |
Public property | DocumentStoragePath |
Public property | DueDateIncrement |
Public property | DueTimeIncrement |

See Also

ContactManagementDefaults Class
Pastel.Evolution.Internal Namespace


ContactManagementDefaults.ContactFilterStartLength Property

[image]

Pastel Evolution SDK
ContactManagementDefaults..::..ContactFilterStartLength Property
ContactManagementDefaults Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int ContactFilterStartLength { get; }
Visual Basic
Public ReadOnly Property ContactFilterStartLength As Integer
    Get

Property Value

Type: Int32

See Also

ContactManagementDefaults Class
ContactManagementDefaults Members
Pastel.Evolution.Internal Namespace


ContactManagementDefaults.DocumentStoragePath Property

[image]

Pastel Evolution SDK
ContactManagementDefaults..::..DocumentStoragePath Property
ContactManagementDefaults Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string DocumentStoragePath { get; }
Visual Basic
Public ReadOnly Property DocumentStoragePath As String
    Get

Property Value

Type: String

See Also

ContactManagementDefaults Class
ContactManagementDefaults Members
Pastel.Evolution.Internal Namespace


ContactManagementDefaults.DueDateIncrement Property

[image]

Pastel Evolution SDK
ContactManagementDefaults..::..DueDateIncrement Property
ContactManagementDefaults Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int DueDateIncrement { get; }
Visual Basic
Public ReadOnly Property DueDateIncrement As Integer
    Get

Property Value

Type: Int32

See Also

ContactManagementDefaults Class
ContactManagementDefaults Members
Pastel.Evolution.Internal Namespace


ContactManagementDefaults.DueTimeIncrement Property

[image]

Pastel Evolution SDK
ContactManagementDefaults..::..DueTimeIncrement Property
ContactManagementDefaults Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int DueTimeIncrement { get; }
Visual Basic
Public ReadOnly Property DueTimeIncrement As Integer
    Get

Property Value

Type: Int32

See Also

ContactManagementDefaults Class
ContactManagementDefaults Members
Pastel.Evolution.Internal Namespace


GLDefaults Class

[image]

Pastel Evolution SDK
GLDefaults Class
Members See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class GLDefaults
Visual Basic
Public Class GLDefaults

Inheritance Hierarchy

System..::..Object
Pastel.Evolution.Internal..::..GLDefaults

See Also

GLDefaults Members
Pastel.Evolution.Internal Namespace


GLDefaults Members

[image] [image]

Pastel Evolution SDK
GLDefaults Members
GLDefaults Class Methods Properties See Also Send Feedback

The GLDefaults type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CashbookBatches |
Public property | JournalBatches |

See Also

GLDefaults Class
Pastel.Evolution.Internal Namespace


GLDefaults Methods

[image] [image]

Pastel Evolution SDK
GLDefaults Methods
GLDefaults Class See Also Send Feedback

The GLDefaults type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GLDefaults Class
Pastel.Evolution.Internal Namespace


GLDefaults Properties

[image] [image]

Pastel Evolution SDK
GLDefaults Properties
GLDefaults Class See Also Send Feedback

The GLDefaults type exposes the following members.

Properties

 | Name | Description
Public property | CashbookBatches |
Public property | JournalBatches |

See Also

GLDefaults Class
Pastel.Evolution.Internal Namespace


GLDefaults.CashbookBatches Property

[image]

Pastel Evolution SDK
GLDefaults..::..CashbookBatches Property
GLDefaults Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public CashbookBatchDefaults CashbookBatches { get; }
Visual Basic
Public ReadOnly Property CashbookBatches As CashbookBatchDefaults
    Get

Property Value

Type: CashbookBatchDefaults

See Also

GLDefaults Class
GLDefaults Members
Pastel.Evolution.Internal Namespace


GLDefaults.JournalBatches Property

[image]

Pastel Evolution SDK
GLDefaults..::..JournalBatches Property
GLDefaults Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public JournalBatchDefaults JournalBatches { get; }
Visual Basic
Public ReadOnly Property JournalBatches As JournalBatchDefaults
    Get

Property Value

Type: JournalBatchDefaults

See Also

GLDefaults Class
GLDefaults Members
Pastel.Evolution.Internal Namespace


InventoryDefaults Class

[image]

Pastel Evolution SDK
InventoryDefaults Class
Members See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class InventoryDefaults
Visual Basic
Public Class InventoryDefaults

Inheritance Hierarchy

System..::..Object
Pastel.Evolution.Internal..::..InventoryDefaults

See Also

InventoryDefaults Members
Pastel.Evolution.Internal Namespace


InventoryDefaults Members

[image] [image]

Pastel Evolution SDK
InventoryDefaults Members
InventoryDefaults Class Methods Properties See Also Send Feedback

The InventoryDefaults type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | _AdjustmentTransactionCode | Gets or sets the TransactionCode.
Public property | _AdjustmentTransactionCodeID | Gets or sets the TransactionCode ID.
Public property | AllowNegativeQty |
Public property | AllowNegStockDef |
Public property | AutoNumbering |
Public property | PostGLLineDescription |
Public property | PostInventoryLineDescription |

See Also

InventoryDefaults Class
Pastel.Evolution.Internal Namespace


InventoryDefaults Methods

[image] [image]

Pastel Evolution SDK
InventoryDefaults Methods
InventoryDefaults Class See Also Send Feedback

The InventoryDefaults type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InventoryDefaults Class
Pastel.Evolution.Internal Namespace


InventoryDefaults Properties

[image] [image]

Pastel Evolution SDK
InventoryDefaults Properties
InventoryDefaults Class See Also Send Feedback

The InventoryDefaults type exposes the following members.

Properties

 | Name | Description
Public property | _AdjustmentTransactionCode | Gets or sets the TransactionCode.
Public property | _AdjustmentTransactionCodeID | Gets or sets the TransactionCode ID.
Public property | AllowNegativeQty |
Public property | AllowNegStockDef |
Public property | AutoNumbering |
Public property | PostGLLineDescription |
Public property | PostInventoryLineDescription |

See Also

InventoryDefaults Class
Pastel.Evolution.Internal Namespace


InventoryDefaults._AdjustmentTransactionCode Property

[image]

Pastel Evolution SDK
InventoryDefaults..::.._AdjustmentTransactionCode Property
InventoryDefaults Class See Also Send Feedback
Gets or sets the TransactionCode.

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public TransactionCode _AdjustmentTransactionCode { get; }
Visual Basic
Public ReadOnly Property _AdjustmentTransactionCode As TransactionCode
    Get

Property Value

Type: TransactionCode

See Also

InventoryDefaults Class
InventoryDefaults Members
Pastel.Evolution.Internal Namespace


InventoryDefaults._AdjustmentTransactionCodeID Property

[image]

Pastel Evolution SDK
InventoryDefaults..::.._AdjustmentTransactionCodeID Property
InventoryDefaults Class See Also Send Feedback
Gets or sets the TransactionCode ID.

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int _AdjustmentTransactionCodeID { get; }
Visual Basic
Public ReadOnly Property _AdjustmentTransactionCodeID As Integer
    Get

Property Value

Type: Int32

See Also

InventoryDefaults Class
InventoryDefaults Members
Pastel.Evolution.Internal Namespace


InventoryDefaults.AllowNegativeQty Property

[image]

Pastel Evolution SDK
InventoryDefaults..::..AllowNegativeQty Property
InventoryDefaults Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool AllowNegativeQty { get; }
Visual Basic
Public ReadOnly Property AllowNegativeQty As Boolean
    Get

Property Value

Type: Boolean

See Also

InventoryDefaults Class
InventoryDefaults Members
Pastel.Evolution.Internal Namespace


InventoryDefaults.AllowNegStockDef Property

[image]

Pastel Evolution SDK
InventoryDefaults..::..AllowNegStockDef Property
InventoryDefaults Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool AllowNegStockDef { get; }
Visual Basic
Public ReadOnly Property AllowNegStockDef As Boolean
    Get

Property Value

Type: Boolean

See Also

InventoryDefaults Class
InventoryDefaults Members
Pastel.Evolution.Internal Namespace


InventoryDefaults.AutoNumbering Property

[image]

Pastel Evolution SDK
InventoryDefaults..::..AutoNumbering Property
InventoryDefaults Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public AutoNumberingScheme AutoNumbering { get; }
Visual Basic
Public ReadOnly Property AutoNumbering As AutoNumberingScheme
    Get

Property Value

Type: AutoNumberingScheme

See Also

InventoryDefaults Class
InventoryDefaults Members
Pastel.Evolution.Internal Namespace


InventoryDefaults.PostGLLineDescription Property

[image]

Pastel Evolution SDK
InventoryDefaults..::..PostGLLineDescription Property
InventoryDefaults Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool PostGLLineDescription { get; }
Visual Basic
Public ReadOnly Property PostGLLineDescription As Boolean
    Get

Property Value

Type: Boolean

See Also

InventoryDefaults Class
InventoryDefaults Members
Pastel.Evolution.Internal Namespace


InventoryDefaults.PostInventoryLineDescription Property

[image]

Pastel Evolution SDK
InventoryDefaults..::..PostInventoryLineDescription Property
InventoryDefaults Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public bool PostInventoryLineDescription { get; }
Visual Basic
Public ReadOnly Property PostInventoryLineDescription As Boolean
    Get

Property Value

Type: Boolean

See Also

InventoryDefaults Class
InventoryDefaults Members
Pastel.Evolution.Internal Namespace


JobDefaults Class

[image]

Pastel Evolution SDK
JobDefaults Class
Members See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class JobDefaults
Visual Basic
Public Class JobDefaults

Inheritance Hierarchy

System..::..Object
Pastel.Evolution.Internal..::..JobDefaults

See Also

JobDefaults Members
Pastel.Evolution.Internal Namespace


JobDefaults Members

[image] [image]

Pastel Evolution SDK
JobDefaults Members
JobDefaults Class Methods Properties See Also Send Feedback

The JobDefaults type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | JobPostingMethodGLAccounts |

See Also

JobDefaults Class
Pastel.Evolution.Internal Namespace


JobDefaults Methods

[image] [image]

Pastel Evolution SDK
JobDefaults Methods
JobDefaults Class See Also Send Feedback

The JobDefaults type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

JobDefaults Class
Pastel.Evolution.Internal Namespace


JobDefaults Properties

[image] [image]

Pastel Evolution SDK
JobDefaults Properties
JobDefaults Class See Also Send Feedback

The JobDefaults type exposes the following members.

Properties

 | Name | Description
Public property | JobPostingMethodGLAccounts |

See Also

JobDefaults Class
Pastel.Evolution.Internal Namespace


JobDefaults.JobPostingMethodGLAccounts Property

[image]

Pastel Evolution SDK
JobDefaults..::..JobPostingMethodGLAccounts Property
JobDefaults Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public JobPostingMethodGLContextCollection JobPostingMethodGLAccounts { get; }
Visual Basic
Public ReadOnly Property JobPostingMethodGLAccounts As JobPostingMethodGLContextCollection
    Get

Property Value

Type: JobPostingMethodGLContextCollection

See Also

JobDefaults Class
JobDefaults Members
Pastel.Evolution.Internal Namespace


JournalBatchDefaults Class

[image]

Pastel Evolution SDK
JournalBatchDefaults Class
Members See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public class JournalBatchDefaults
Visual Basic
Public Class JournalBatchDefaults

Inheritance Hierarchy

System..::..Object
Pastel.Evolution.Internal..::..JournalBatchDefaults

See Also

JournalBatchDefaults Members
Pastel.Evolution.Internal Namespace


JournalBatchDefaults Members

[image] [image]

Pastel Evolution SDK
JournalBatchDefaults Members
JournalBatchDefaults Class Methods Properties See Also Send Feedback

The JournalBatchDefaults type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | InputTaxAccountID |
Public property | InputTaxRateID |
Public property | OutputTaxAccountID |
Public property | OutputTaxRateID |
Public property | TransactionCode |
Public property | TransactionCodeID |

See Also

JournalBatchDefaults Class
Pastel.Evolution.Internal Namespace


JournalBatchDefaults Methods

[image] [image]

Pastel Evolution SDK
JournalBatchDefaults Methods
JournalBatchDefaults Class See Also Send Feedback

The JournalBatchDefaults type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

JournalBatchDefaults Class
Pastel.Evolution.Internal Namespace


JournalBatchDefaults Properties

[image] [image]

Pastel Evolution SDK
JournalBatchDefaults Properties
JournalBatchDefaults Class See Also Send Feedback

The JournalBatchDefaults type exposes the following members.

Properties

 | Name | Description
Public property | InputTaxAccountID |
Public property | InputTaxRateID |
Public property | OutputTaxAccountID |
Public property | OutputTaxRateID |
Public property | TransactionCode |
Public property | TransactionCodeID |

See Also

JournalBatchDefaults Class
Pastel.Evolution.Internal Namespace


JournalBatchDefaults.InputTaxAccountID Property

[image]

Pastel Evolution SDK
JournalBatchDefaults..::..InputTaxAccountID Property
JournalBatchDefaults Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int InputTaxAccountID { get; }
Visual Basic
Public ReadOnly Property InputTaxAccountID As Integer
    Get

Property Value

Type: Int32

See Also

JournalBatchDefaults Class
JournalBatchDefaults Members
Pastel.Evolution.Internal Namespace


JournalBatchDefaults.InputTaxRateID Property

[image]

Pastel Evolution SDK
JournalBatchDefaults..::..InputTaxRateID Property
JournalBatchDefaults Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int InputTaxRateID { get; }
Visual Basic
Public ReadOnly Property InputTaxRateID As Integer
    Get

Property Value

Type: Int32

See Also

JournalBatchDefaults Class
JournalBatchDefaults Members
Pastel.Evolution.Internal Namespace


JournalBatchDefaults.OutputTaxAccountID Property

[image]

Pastel Evolution SDK
JournalBatchDefaults..::..OutputTaxAccountID Property
JournalBatchDefaults Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int OutputTaxAccountID { get; }
Visual Basic
Public ReadOnly Property OutputTaxAccountID As Integer
    Get

Property Value

Type: Int32

See Also

JournalBatchDefaults Class
JournalBatchDefaults Members
Pastel.Evolution.Internal Namespace


JournalBatchDefaults.OutputTaxRateID Property

[image]

Pastel Evolution SDK
JournalBatchDefaults..::..OutputTaxRateID Property
JournalBatchDefaults Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int OutputTaxRateID { get; }
Visual Basic
Public ReadOnly Property OutputTaxRateID As Integer
    Get

Property Value

Type: Int32

See Also

JournalBatchDefaults Class
JournalBatchDefaults Members
Pastel.Evolution.Internal Namespace


JournalBatchDefaults.TransactionCode Property

[image]

Pastel Evolution SDK
JournalBatchDefaults..::..TransactionCode Property
JournalBatchDefaults Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public TransactionCode TransactionCode { get; set; }
Visual Basic
Public Property TransactionCode As TransactionCode
    Get
    Set

Property Value

Type: TransactionCode

See Also

JournalBatchDefaults Class
JournalBatchDefaults Members
Pastel.Evolution.Internal Namespace


JournalBatchDefaults.TransactionCodeID Property

[image]

Pastel Evolution SDK
JournalBatchDefaults..::..TransactionCodeID Property
JournalBatchDefaults Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int TransactionCodeID { get; set; }
Visual Basic
Public Property TransactionCodeID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

JournalBatchDefaults Class
JournalBatchDefaults Members
Pastel.Evolution.Internal Namespace


ModuleRegistration Class

[image]

Pastel Evolution SDK
ModuleRegistration Class
Members See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static class ModuleRegistration
Visual Basic
Public NotInheritable Class ModuleRegistration

Inheritance Hierarchy

System..::..Object
Pastel.Evolution.Internal..::..ModuleRegistration

See Also

ModuleRegistration Members
Pastel.Evolution.Internal Namespace


ModuleRegistration Members

[image] [image]

Pastel Evolution SDK
ModuleRegistration Members
ModuleRegistration Class Properties See Also Send Feedback

The ModuleRegistration type exposes the following members.

Properties

Name | Description
ActiveModuleNames |

See Also

ModuleRegistration Class
Pastel.Evolution.Internal Namespace


ModuleRegistration Properties

[image] [image]

Pastel Evolution SDK
ModuleRegistration Properties
ModuleRegistration Class See Also Send Feedback

The ModuleRegistration type exposes the following members.

Properties

Name | Description
ActiveModuleNames |

See Also

ModuleRegistration Class
Pastel.Evolution.Internal Namespace


ModuleRegistration.ActiveModuleNames Property

[image]

Pastel Evolution SDK
ModuleRegistration..::..ActiveModuleNames Property
ModuleRegistration Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public static string[] ActiveModuleNames { get; }
Visual Basic
Public Shared ReadOnly Property ActiveModuleNames As String()
    Get

Property Value

Type: array< String >[]()[][]

See Also

ModuleRegistration Class
ModuleRegistration Members
Pastel.Evolution.Internal Namespace


ModuleRegistration.Module Enumeration

[image]

Pastel Evolution SDK
ModuleRegistration..::..Module Enumeration
ModuleRegistration Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public enum Module
Visual Basic
Public Enumeration Module

Members

Member name | Value | Description
Unknown | 0 |
All | 1 |
System | 2 |
UserDefined | 3 |
GeneralLedger | 4 |
AccountsReceivable | 5 |
AccountsPayable | 6 |
LinkedAccounts | 7 |
RecurringRevenue | 8 |
CreditControl | 9 |
ContactManagement | 10 |
Inventory | 11 |
OrderEntry | 12 |
BillOfMaterials | 13 |
JobCosting | 14 |
PointOfSale | 15 |
Warehouse | 16 |
SerialNumbers | 17 |
DiscountMatrix | 18 |
FixedAssets | 19 |
SDKConnector | 20 |
ReportWriter | 21 |
TaxMan | 22 |
Resolve | 23 |
ManagementCentre | 24 |
GLMasterSubAccounts | 25 |
GLSegmentedAccounts | 26 |
QuoteAir | 27 |
DBitFixedAssets | 28 |
BankManager2 | 29 |
SegmentedIC | 30 |
ForeignCurrency | 31 |
BICSimple | 32 |
BICAdvanced | 33 |
LotTracking | 34 |
Manufacturing | 35 |
BICMunicipalBilling | 36 |
Procurement | 37 |
Unused1 | 38 |
BICOLAP | 39 |
BICWebReporting | 40 |
EvolutionStandard | 41 |
CashManager | 42 |
MunicipalBilling | 43 |
Retail | 44 |
BICGenie | 45 |
BranchAccounting | 46 |
AuditTool | 47 |
WinjitVoucherManagement | 48 |
WinjitGlobalTax | 49 |
WinjitDeliveryManagement | 50 |
BusinessGateway | 51 |
WinjitAdvancedProcurement | 52 |
WinjitMobility | 53 |
WinjitServiceManagement | 54 |
WinjitInventoryOptimisation | 55 |

See Also

Pastel.Evolution.Internal Namespace


myToken Structure

[image]

Pastel Evolution SDK
myToken Structure
Members See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public struct myToken
Visual Basic
Public Structure myToken

See Also

myToken Members
Pastel.Evolution.Internal Namespace


myToken Members

[image] [image]

Pastel Evolution SDK
myToken Members
myToken Structure Methods See Also Send Feedback

The myToken type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

myToken Structure
Pastel.Evolution.Internal Namespace


myToken Methods

[image] [image]

Pastel Evolution SDK
myToken Methods
myToken Structure See Also Send Feedback

The myToken type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

myToken Structure
Pastel.Evolution.Internal Namespace


RecordWrapperBase Class

[image]

Pastel Evolution SDK
RecordWrapperBase Class
Members See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public abstract class RecordWrapperBase : ICloneable
Visual Basic
Public MustInherit Class RecordWrapperBase
    Implements ICloneable

Inheritance Hierarchy

System..::..Object
Pastel.Evolution.Internal..::..RecordWrapperBase

See Also

RecordWrapperBase Members
Pastel.Evolution.Internal Namespace


RecordWrapperBase Members

[image] [image]

Pastel Evolution SDK
RecordWrapperBase Members
RecordWrapperBase Class Constructors Methods Fields Properties See Also Send Feedback

The RecordWrapperBase type exposes the following members.

Constructors

 | Name | Description
Public method | RecordWrapperBase | Initializes a new instance of the RecordWrapperBase class

Methods

 | Name | Description
Public method | Clone |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get(Int32) |
Public method | Get(Int64) |
Public method | Get(String) |
Public method | GetByBranch(Int32) |
Public method | GetByBranch(Int32, String) |
Public method | GetByBranch(Int32, String, Object) |
Public method | GetByBranch(Int32, String, Object, String, Object) |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | joinLists |
Protected method | mapFieldManager |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | readFields(DataRow) |
Protected method | readFields(SqlDataReader) |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | branchIDFieldName |
Protected field | fieldManager |
Protected field | fields |
Protected field | lockedRawFields |
Protected field | modifiedFields |
Protected field | rawFields |
Protected field | readOnlyFields |
Protected field | tableName |
Protected field | userFields |
Protected field | writableFields |

Properties

 | Name | Description
Public property | BranchID |
 | dbConn |
Public property | Fields |
Public property | TableName |
Public property | UserFields |

See Also

RecordWrapperBase Class
Pastel.Evolution.Internal Namespace


RecordWrapperBase Constructor

[image]

Pastel Evolution SDK
RecordWrapperBase Constructor
RecordWrapperBase Class See Also Send Feedback
Initializes a new instance of the RecordWrapperBase class

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public RecordWrapperBase()
Visual Basic
Public Sub New

See Also

RecordWrapperBase Class
RecordWrapperBase Members
Pastel.Evolution.Internal Namespace


RecordWrapperBase Fields

[image] [image]

Pastel Evolution SDK
RecordWrapperBase Fields
RecordWrapperBase Class See Also Send Feedback

The RecordWrapperBase type exposes the following members.

Fields

 | Name | Description
Protected field | branchIDFieldName |
Protected field | fieldManager |
Protected field | fields |
Protected field | lockedRawFields |
Protected field | modifiedFields |
Protected field | rawFields |
Protected field | readOnlyFields |
Protected field | tableName |
Protected field | userFields |
Protected field | writableFields |

See Also

RecordWrapperBase Class
Pastel.Evolution.Internal Namespace


RecordWrapperBase.branchIDFieldName Field

[image]

Pastel Evolution SDK
RecordWrapperBase..::..branchIDFieldName Field
RecordWrapperBase Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected string branchIDFieldName
Visual Basic
Protected branchIDFieldName As String

Field Value

Type: String

See Also

RecordWrapperBase Class
RecordWrapperBase Members
Pastel.Evolution.Internal Namespace


RecordWrapperBase.fieldManager Field

[image]

Pastel Evolution SDK
RecordWrapperBase..::..fieldManager Field
RecordWrapperBase Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected FieldCollectionManager fieldManager
Visual Basic
Protected fieldManager As FieldCollectionManager

Field Value

Type: FieldCollectionManager

See Also

RecordWrapperBase Class
RecordWrapperBase Members
Pastel.Evolution.Internal Namespace


RecordWrapperBase.fields Field

[image]

Pastel Evolution SDK
RecordWrapperBase..::..fields Field
RecordWrapperBase Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected FieldCollection fields
Visual Basic
Protected fields As FieldCollection

Field Value

Type: FieldCollection

See Also

RecordWrapperBase Class
RecordWrapperBase Members
Pastel.Evolution.Internal Namespace


RecordWrapperBase.lockedRawFields Field

[image]

Pastel Evolution SDK
RecordWrapperBase..::..lockedRawFields Field
RecordWrapperBase Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected FieldCollection lockedRawFields
Visual Basic
Protected lockedRawFields As FieldCollection

Field Value

Type: FieldCollection

See Also

RecordWrapperBase Class
RecordWrapperBase Members
Pastel.Evolution.Internal Namespace


RecordWrapperBase.modifiedFields Field

[image]

Pastel Evolution SDK
RecordWrapperBase..::..modifiedFields Field
RecordWrapperBase Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected FieldCollection modifiedFields
Visual Basic
Protected modifiedFields As FieldCollection

Field Value

Type: FieldCollection

See Also

RecordWrapperBase Class
RecordWrapperBase Members
Pastel.Evolution.Internal Namespace


RecordWrapperBase.rawFields Field

[image]

Pastel Evolution SDK
RecordWrapperBase..::..rawFields Field
RecordWrapperBase Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected FieldCollection rawFields
Visual Basic
Protected rawFields As FieldCollection

Field Value

Type: FieldCollection

See Also

RecordWrapperBase Class
RecordWrapperBase Members
Pastel.Evolution.Internal Namespace


RecordWrapperBase.readOnlyFields Field

[image]

Pastel Evolution SDK
RecordWrapperBase..::..readOnlyFields Field
RecordWrapperBase Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected FieldCollection readOnlyFields
Visual Basic
Protected readOnlyFields As FieldCollection

Field Value

Type: FieldCollection

See Also

RecordWrapperBase Class
RecordWrapperBase Members
Pastel.Evolution.Internal Namespace


RecordWrapperBase.tableName Field

[image]

Pastel Evolution SDK
RecordWrapperBase..::..tableName Field
RecordWrapperBase Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected string tableName
Visual Basic
Protected tableName As String

Field Value

Type: String

See Also

RecordWrapperBase Class
RecordWrapperBase Members
Pastel.Evolution.Internal Namespace


RecordWrapperBase.userFields Field

[image]

Pastel Evolution SDK
RecordWrapperBase..::..userFields Field
RecordWrapperBase Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected FieldCollection userFields
Visual Basic
Protected userFields As FieldCollection

Field Value

Type: FieldCollection

See Also

RecordWrapperBase Class
RecordWrapperBase Members
Pastel.Evolution.Internal Namespace


RecordWrapperBase.writableFields Field

[image]

Pastel Evolution SDK
RecordWrapperBase..::..writableFields Field
RecordWrapperBase Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected FieldCollection writableFields
Visual Basic
Protected writableFields As FieldCollection

Field Value

Type: FieldCollection

See Also

RecordWrapperBase Class
RecordWrapperBase Members
Pastel.Evolution.Internal Namespace


RecordWrapperBase Methods

[image] [image]

Pastel Evolution SDK
RecordWrapperBase Methods
RecordWrapperBase Class See Also Send Feedback

The RecordWrapperBase type exposes the following members.

Methods

 | Name | Description
Public method | Clone |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get(Int32) |
Public method | Get(Int64) |
Public method | Get(String) |
Public method | GetByBranch(Int32) |
Public method | GetByBranch(Int32, String) |
Public method | GetByBranch(Int32, String, Object) |
Public method | GetByBranch(Int32, String, Object, String, Object) |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | joinLists |
Protected method | mapFieldManager |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | readFields(DataRow) |
Protected method | readFields(SqlDataReader) |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RecordWrapperBase Class
Pastel.Evolution.Internal Namespace


RecordWrapperBase.Clone Method

[image]

Pastel Evolution SDK
RecordWrapperBase..::..Clone Method
RecordWrapperBase Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public virtual Object Clone()
Visual Basic
Public Overridable Function Clone As Object

Return Value

Type: Object

Implements

ICloneable..::..Clone()()()()

See Also

RecordWrapperBase Class
RecordWrapperBase Members
Pastel.Evolution.Internal Namespace


RecordWrapperBase.Get Method

[image] [image]

Pastel Evolution SDK
RecordWrapperBase..::..Get Method
RecordWrapperBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Get(Int32) |
Public method | Get(Int64) |
Public method | Get(String) |

See Also

RecordWrapperBase Class
RecordWrapperBase Members
Pastel.Evolution.Internal Namespace


RecordWrapperBase.Get Method (Int32)

[image]

Pastel Evolution SDK
RecordWrapperBase..::..Get Method (Int32)
RecordWrapperBase Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public virtual void Get(
    int ID
)
Visual Basic
Public Overridable Sub Get (
    ID As Integer
)

Parameters

ID
Type: System..::..Int32

See Also

RecordWrapperBase Class
RecordWrapperBase Members
Get Overload
Pastel.Evolution.Internal Namespace


RecordWrapperBase.Get Method (Int64)

[image]

Pastel Evolution SDK
RecordWrapperBase..::..Get Method (Int64)
RecordWrapperBase Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public virtual void Get(
    long ID
)
Visual Basic
Public Overridable Sub Get (
    ID As Long
)

Parameters

ID
Type: System..::..Int64

See Also

RecordWrapperBase Class
RecordWrapperBase Members
Get Overload
Pastel.Evolution.Internal Namespace


RecordWrapperBase.Get Method (String)

[image]

Pastel Evolution SDK
RecordWrapperBase..::..Get Method (String)
RecordWrapperBase Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public virtual void Get(
    string criteria
)
Visual Basic
Public Overridable Sub Get (
    criteria As String
)

Parameters

criteria
Type: System..::..String

See Also

RecordWrapperBase Class
RecordWrapperBase Members
Get Overload
Pastel.Evolution.Internal Namespace


RecordWrapperBase.GetByBranch Method

[image] [image]

Pastel Evolution SDK
RecordWrapperBase..::..GetByBranch Method
RecordWrapperBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetByBranch(Int32) |
Public method | GetByBranch(Int32, String) |
Public method | GetByBranch(Int32, String, Object) |
Public method | GetByBranch(Int32, String, Object, String, Object) |

See Also

RecordWrapperBase Class
RecordWrapperBase Members
Pastel.Evolution.Internal Namespace


RecordWrapperBase.GetByBranch Method (Int32)

[image]

Pastel Evolution SDK
RecordWrapperBase..::..GetByBranch Method (Int32)
RecordWrapperBase Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void GetByBranch(
    int branchID
)
Visual Basic
Public Sub GetByBranch (
    branchID As Integer
)

Parameters

branchID
Type: System..::..Int32

See Also

RecordWrapperBase Class
RecordWrapperBase Members
GetByBranch Overload
Pastel.Evolution.Internal Namespace


RecordWrapperBase.GetByBranch Method (Int32, String)

[image]

Pastel Evolution SDK
RecordWrapperBase..::..GetByBranch Method (Int32, String)
RecordWrapperBase Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void GetByBranch(
    int branchID,
    string criteria
)
Visual Basic
Public Sub GetByBranch (
    branchID As Integer,
    criteria As String
)

Parameters

branchID
Type: System..::..Int32
criteria
Type: System..::..String

See Also

RecordWrapperBase Class
RecordWrapperBase Members
GetByBranch Overload
Pastel.Evolution.Internal Namespace


RecordWrapperBase.GetByBranch Method (Int32, String, Object)

[image]

Pastel Evolution SDK
RecordWrapperBase..::..GetByBranch Method (Int32, String, Object)
RecordWrapperBase Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void GetByBranch(
    int branchID,
    string field0,
    Object value0
)
Visual Basic
Public Sub GetByBranch (
    branchID As Integer,
    field0 As String,
    value0 As Object
)

Parameters

branchID
Type: System..::..Int32
field0
Type: System..::..String
value0
Type: System..::..Object

See Also

RecordWrapperBase Class
RecordWrapperBase Members
GetByBranch Overload
Pastel.Evolution.Internal Namespace


RecordWrapperBase.GetByBranch Method (Int32, String, Object, String, Object)

[image]

Pastel Evolution SDK
RecordWrapperBase..::..GetByBranch Method (Int32, String, Object, String, Object)
RecordWrapperBase Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public void GetByBranch(
    int branchID,
    string field0,
    Object value0,
    string field1,
    Object value1
)
Visual Basic
Public Sub GetByBranch (
    branchID As Integer,
    field0 As String,
    value0 As Object,
    field1 As String,
    value1 As Object
)

Parameters

branchID
Type: System..::..Int32
field0
Type: System..::..String
value0
Type: System..::..Object
field1
Type: System..::..String
value1
Type: System..::..Object

See Also

RecordWrapperBase Class
RecordWrapperBase Members
GetByBranch Overload
Pastel.Evolution.Internal Namespace


RecordWrapperBase.joinLists Method

[image]

Pastel Evolution SDK
RecordWrapperBase..::..joinLists Method
RecordWrapperBase Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected List<string> joinLists(
    List<string> listA,
    List<string> listB
)
Visual Basic
Protected Function joinLists (
    listA As List(Of String),
    listB As List(Of String)
) As List(Of String)

Parameters

listA
Type: System.Collections.Generic..::..List <(Of <(<' String >)>)>
listB
Type: System.Collections.Generic..::..List <(Of <(<' String >)>)>

Return Value

Type: List <(Of <(<' String >)>)>

See Also

RecordWrapperBase Class
RecordWrapperBase Members
Pastel.Evolution.Internal Namespace


RecordWrapperBase.mapFieldManager Method

[image]

Pastel Evolution SDK
RecordWrapperBase..::..mapFieldManager Method
RecordWrapperBase Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected void mapFieldManager()
Visual Basic
Protected Sub mapFieldManager

See Also

RecordWrapperBase Class
RecordWrapperBase Members
Pastel.Evolution.Internal Namespace


RecordWrapperBase.readFields Method

[image] [image]

Pastel Evolution SDK
RecordWrapperBase..::..readFields Method
RecordWrapperBase Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | readFields(DataRow) |
Protected method | readFields(SqlDataReader) |

See Also

RecordWrapperBase Class
RecordWrapperBase Members
Pastel.Evolution.Internal Namespace


RecordWrapperBase.readFields Method (DataRow)

[image]

Pastel Evolution SDK
RecordWrapperBase..::..readFields Method (DataRow)
RecordWrapperBase Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected void readFields(
    DataRow row
)
Visual Basic
Protected Sub readFields (
    row As DataRow
)

Parameters

row
Type: System.Data..::..DataRow

See Also

RecordWrapperBase Class
RecordWrapperBase Members
readFields Overload
Pastel.Evolution.Internal Namespace


RecordWrapperBase.readFields Method (SqlDataReader)

[image]

Pastel Evolution SDK
RecordWrapperBase..::..readFields Method (SqlDataReader)
RecordWrapperBase Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected void readFields(
    SqlDataReader dr
)
Visual Basic
Protected Sub readFields (
    dr As SqlDataReader
)

Parameters

dr
Type: System.Data.SqlClient..::..SqlDataReader

See Also

RecordWrapperBase Class
RecordWrapperBase Members
readFields Overload
Pastel.Evolution.Internal Namespace


RecordWrapperBase Properties

[image] [image]

Pastel Evolution SDK
RecordWrapperBase Properties
RecordWrapperBase Class See Also Send Feedback

The RecordWrapperBase type exposes the following members.

Properties

 | Name | Description
Public property | BranchID |
 | dbConn |
Public property | Fields |
Public property | TableName |
Public property | UserFields |

See Also

RecordWrapperBase Class
Pastel.Evolution.Internal Namespace


RecordWrapperBase.BranchID Property

[image]

Pastel Evolution SDK
RecordWrapperBase..::..BranchID Property
RecordWrapperBase Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public int BranchID { get; set; }
Visual Basic
Public Property BranchID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

RecordWrapperBase Class
RecordWrapperBase Members
Pastel.Evolution.Internal Namespace


RecordWrapperBase.dbConn Property

[image]

Pastel Evolution SDK
RecordWrapperBase..::..dbConn Property
RecordWrapperBase Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
protected static SqlConnection dbConn { get; }
Visual Basic
Protected Shared ReadOnly Property dbConn As SqlConnection
    Get

Property Value

Type: SqlConnection

See Also

RecordWrapperBase Class
RecordWrapperBase Members
Pastel.Evolution.Internal Namespace


RecordWrapperBase.Fields Property

[image]

Pastel Evolution SDK
RecordWrapperBase..::..Fields Property
RecordWrapperBase Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public FieldCollection Fields { get; }
Visual Basic
Public ReadOnly Property Fields As FieldCollection
    Get

Property Value

Type: FieldCollection

See Also

RecordWrapperBase Class
RecordWrapperBase Members
Pastel.Evolution.Internal Namespace


RecordWrapperBase.TableName Property

[image]

Pastel Evolution SDK
RecordWrapperBase..::..TableName Property
RecordWrapperBase Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public string TableName { get; }
Visual Basic
Public ReadOnly Property TableName As String
    Get

Property Value

Type: String

See Also

RecordWrapperBase Class
RecordWrapperBase Members
Pastel.Evolution.Internal Namespace


RecordWrapperBase.UserFields Property

[image]

Pastel Evolution SDK
RecordWrapperBase..::..UserFields Property
RecordWrapperBase Class See Also Send Feedback

Namespace: Pastel.Evolution.Internal
Assembly: Pastel.Evolution (in Pastel.Evolution.dll) Version: 7.0.0.11

Syntax

C#
public FieldCollection UserFields { get; }
Visual Basic
Public ReadOnly Property UserFields As FieldCollection
    Get

Property Value

Type: FieldCollection

See Also

RecordWrapperBase Class
RecordWrapperBase Members
Pastel.Evolution.Internal Namespace